TextCSTemplateCompiler.EXPRESSION_ESCAPE Field

TextCSTemplateCompiler EXPRESSION_ESCAPE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXPRESSION_ESCAPE
public const string EXPRESSION_ESCAPE
Public Const EXPRESSION_ESCAPE As String
Public Const EXPRESSION_ESCAPE As String
public:
literal String^ EXPRESSION_ESCAPE
public:
literal String^ EXPRESSION_ESCAPE
static val mutable EXPRESSION_ESCAPE: string
static val mutable EXPRESSION_ESCAPE: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.LACONFIG_END Field

TextCSTemplateCompiler LACONFIG_END Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LACONFIG_END
public const string LACONFIG_END
Public Const LACONFIG_END As String
Public Const LACONFIG_END As String
public:
literal String^ LACONFIG_END
public:
literal String^ LACONFIG_END
static val mutable LACONFIG_END: string
static val mutable LACONFIG_END: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.LACONFIG_START Field

TextCSTemplateCompiler LACONFIG_START Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LACONFIG_START
public const string LACONFIG_START
Public Const LACONFIG_START As String
Public Const LACONFIG_START As String
public:
literal String^ LACONFIG_START
public:
literal String^ LACONFIG_START
static val mutable LACONFIG_START: string
static val mutable LACONFIG_START: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.OVERRIDE Field

TextCSTemplateCompiler OVERRIDE Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string OVERRIDE
public const string OVERRIDE
Public Const OVERRIDE As String
Public Const OVERRIDE As String
public:
literal String^ OVERRIDE
public:
literal String^ OVERRIDE
static val mutable OVERRIDE: string
static val mutable OVERRIDE: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.RENDER_AREA Field

TextCSTemplateCompiler RENDER_AREA Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string RENDER_AREA
public const string RENDER_AREA
Public Const RENDER_AREA As String
Public Const RENDER_AREA As String
public:
literal String^ RENDER_AREA
public:
literal String^ RENDER_AREA
static val mutable RENDER_AREA: string
static val mutable RENDER_AREA: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.SPAN_CLOSE Field

TextCSTemplateCompiler SPAN_CLOSE Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char SPAN_CLOSE
public const char SPAN_CLOSE
Public Const SPAN_CLOSE As Char
Public Const SPAN_CLOSE As Char
public:
literal wchar_t SPAN_CLOSE
public:
literal wchar_t SPAN_CLOSE
static val mutable SPAN_CLOSE: char
static val mutable SPAN_CLOSE: char

Field Value

Type: Online Char
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.SPAN_OPEN Field

TextCSTemplateCompiler SPAN_OPEN Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char SPAN_OPEN
public const char SPAN_OPEN
Public Const SPAN_OPEN As Char
Public Const SPAN_OPEN As Char
public:
literal wchar_t SPAN_OPEN
public:
literal wchar_t SPAN_OPEN
static val mutable SPAN_OPEN: char
static val mutable SPAN_OPEN: char

Field Value

Type: Online Char
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.STATEMENT Field

TextCSTemplateCompiler STATEMENT Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STATEMENT
public const string STATEMENT
Public Const STATEMENT As String
Public Const STATEMENT As String
public:
literal String^ STATEMENT
public:
literal String^ STATEMENT
static val mutable STATEMENT: string
static val mutable STATEMENT: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.STATEMENT_ESCAPE Field

TextCSTemplateCompiler STATEMENT_ESCAPE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STATEMENT_ESCAPE
public const string STATEMENT_ESCAPE
Public Const STATEMENT_ESCAPE As String
Public Const STATEMENT_ESCAPE As String
public:
literal String^ STATEMENT_ESCAPE
public:
literal String^ STATEMENT_ESCAPE
static val mutable STATEMENT_ESCAPE: string
static val mutable STATEMENT_ESCAPE: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.VERBATIM Field

TextCSTemplateCompiler VERBATIM Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VERBATIM
public const string VERBATIM
Public Const VERBATIM As String
Public Const VERBATIM As String
public:
literal String^ VERBATIM
public:
literal String^ VERBATIM
static val mutable VERBATIM: string
static val mutable VERBATIM: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.VIRTUAL Field

TextCSTemplateCompiler VIRTUAL Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VIRTUAL
public const string VIRTUAL
Public Const VIRTUAL As String
Public Const VIRTUAL As String
public:
literal String^ VIRTUAL
public:
literal String^ VIRTUAL
static val mutable VIRTUAL: string
static val mutable VIRTUAL: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler Methods

TextCSTemplateCompiler Methods NFX Class Library

The TextCSTemplateCompiler type exposes the following members.
Methods
 | Name | Description
Public method | Compile | Performs compilation if it has not already been performed (Inherited from TemplateCompiler.)
Public method | Configure | (Inherited from TemplateCompiler.)
Protected method | Destructor | (Inherited from TemplateCompiler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCompileCode | (Overrides TemplateCompiler DoCompileCode .)
Protected method | DoCompileTemplateSource | (Overrides TemplateCompiler DoCompileTemplateSource(CompileUnit).)
Protected method | DoConfigure | Override to perform custom configuration (Inherited from TemplateCompiler.)
Public method | EnsureNotCompiled | Throws an exception if this instance has already been compiled (Inherited from TemplateCompiler.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExcludeTemplateSource | Exclude template source from compilation (Inherited from TemplateCompiler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GenerateUniqueName | Generates unique identifier suitable for use in code per compiler instance (Inherited from TemplateCompiler.)
Public method | GetEnumerator | (Inherited from TemplateCompiler.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncludeTemplateSource | Includes template source into compilation (Inherited from TemplateCompiler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReferenceAssembly | References assembly by its name if it is already not referenced (Inherited from TemplateCompiler.)
Protected method | RegisterDefaultUsings | Override to provide default using clauses (Inherited from TemplateCompiler.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnReferenceAssembly | Removes assembly reference by its name if it was already referenced (Inherited from TemplateCompiler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from TemplateCompiler.)
Back to Top
See Also
TextCSTemplateCompiler Class
NFX.Templatization Namespace


TextCSTemplateCompiler.DoCompileCode Method

TextCSTemplateCompiler DoCompileCode Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoCompileCode()
protected override void DoCompileCode()
Protected Overrides Sub DoCompileCode
Protected Overrides Sub DoCompileCode
protected:
virtual void DoCompileCode() override
protected:
virtual void DoCompileCode() override
abstract DoCompileCode : unit -> unit
override DoCompileCode : unit -> unit
abstract DoCompileCode : unit -> unit
override DoCompileCode : unit -> unit
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.DoCompileTemplateSource Method

TextCSTemplateCompiler DoCompileTemplateSource Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoCompileTemplateSource(
    CompileUnit unit
)
protected override void DoCompileTemplateSource(
    CompileUnit unit
)
Protected Overrides Sub DoCompileTemplateSource (
    unit As CompileUnit
)
Protected Overrides Sub DoCompileTemplateSource (
    unit As CompileUnit
)
protected:
virtual void DoCompileTemplateSource(
    CompileUnit^ unit
) override
protected:
virtual void DoCompileTemplateSource(
    CompileUnit^ unit
) override
abstract DoCompileTemplateSource :
        unit : CompileUnit -> unit
override DoCompileTemplateSource :
        unit : CompileUnit -> unit
abstract DoCompileTemplateSource :
        unit : CompileUnit -> unit
override DoCompileTemplateSource :
        unit : CompileUnit -> unit

Parameters

unit
Type: NFX.Templatization CompileUnit
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler Properties

TextCSTemplateCompiler Properties NFX Class Library

The TextCSTemplateCompiler type exposes the following members.
Properties
 | Name | Description
Public property | Assembly | Returns compiled assembly or null if only source have been compiled when CompileCode=false; (Inherited from TemplateCompiler.)
Public property | AssemblyFileName | Gets/sets filename for assembly, if null then assembly is created in-memory only (Inherited from TemplateCompiler.)
Public property | BaseTypeName | Sets the name of base type that templates inherit from. This type must directly or indirectly inherit from Template (Inherited from TemplateCompiler.)
Public property | CodeCompilerErrors | Returns code compilation errors (Inherited from TemplateCompiler.)
Public property | CompileCode | Indicates whether language compilation should be performed and Assembly be built (Inherited from TemplateCompiler.)
Public property | Compiled | Indicates whether this instance was compiled (Inherited from TemplateCompiler.)
Public property | CompileUnitsWithErrors | Returns compile units that have errors (Inherited from TemplateCompiler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | HasErrors | Indicates whether some units have template compilation errors or code compiler errors exist (Inherited from TemplateCompiler.)
Public property | Item | Returns a compile unit by template source or throws if it does not exist (Inherited from TemplateCompiler.)
Public property | LanguageName | (Overrides TemplateCompiler LanguageName.)
Public property | LanguageSourceFileExtension | (Overrides TemplateCompiler LanguageSourceFileExtension.)
Public property | Namespace | Sets the name of namespace that classes compiled into (Inherited from TemplateCompiler.)
Public property | Options | Config options section used for compilation (Inherited from TemplateCompiler.)
Public property | ReferencedAssemblies | Returns referenced assemblies (Inherited from TemplateCompiler.)
Public property | ReferencedAssembliesSearchPath | Gets/sets path for referenced assemblies that do not have a path in their names (Inherited from TemplateCompiler.)
Back to Top
See Also
TextCSTemplateCompiler Class
NFX.Templatization Namespace


TextCSTemplateCompiler.LanguageName Property

TextCSTemplateCompiler LanguageName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string LanguageName { get; }
public override string LanguageName { get; }
Public Overrides ReadOnly Property LanguageName As String
    Get
Public Overrides ReadOnly Property LanguageName As String
    Get
public:
virtual property String^ LanguageName {
    String^ get () override;
}
public:
virtual property String^ LanguageName {
    String^ get () override;
}
abstract LanguageName : string with get
override LanguageName : string with get
abstract LanguageName : string with get
override LanguageName : string with get

Property Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.LanguageSourceFileExtension Property

TextCSTemplateCompiler LanguageSourceFileExtension Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string LanguageSourceFileExtension { get; }
public override string LanguageSourceFileExtension { get; }
Public Overrides ReadOnly Property LanguageSourceFileExtension As String
    Get
Public Overrides ReadOnly Property LanguageSourceFileExtension As String
    Get
public:
virtual property String^ LanguageSourceFileExtension {
    String^ get () override;
}
public:
virtual property String^ LanguageSourceFileExtension {
    String^ get () override;
}
abstract LanguageSourceFileExtension : string with get
override LanguageSourceFileExtension : string with get
abstract LanguageSourceFileExtension : string with get
override LanguageSourceFileExtension : string with get

Property Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


NFX.Throttling Namespace

NFX.Throttling Namespace NFX Class Library

Provides throttling functions like time-spacing rate limiters
Classes
 | Class | Description
Public class | NOPThrottle | No operation throttle
Public class | NOPThrottling | Represents throttling implementation that does nothing and always returns NOPThrottle
Public class | SlidingWindowThrottle | Efficiently calculates the throttling rate over a number of seconds. The algorithm implements a variation of token bucket algorithm that doesn't require to add tokens to the bucket on a timer but rather it maintains a cirtular buffer of tokens with resolution of 1/BucketsPerSec. The Add() function is used to add items to a bucket associated with the timestamp passed as the first argument to the function. The Sum() returns the total number of items over the given interval of seconds. The items automatically expire when the time moves on the successive invocations of the Add() method.
Public class | Throttle | Base class defining throttle interface
Public class | ThrottlingService | A service that maintains throttling components in an application and allows to turn on/off global throttling functionality
Public class | TimeSpacingThrottle | Throttle based on space reservation in time. It allows at most Limit calls of Try() function per Interval. The calls are assumed to be equally spaced within the Interval
Interfaces
 | Interface | Description
Public interface | IThrottle |
Public interface | IThrottling | Defines throttling interface to be implemented by the throttling service
Public interface | IThrottlingImplementation | Interface implementing configurable and disposable throttling functionaliry


IThrottle Interface

IThrottle Interface NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IThrottle : IApplicationComponent,
    IDisposable
public interface IThrottle : IApplicationComponent,
    IDisposable
Public Interface IThrottle
    Inherits IApplicationComponent, IDisposable
Public Interface IThrottle
    Inherits IApplicationComponent, IDisposable
public interface class IThrottle : IApplicationComponent,
    IDisposable
public interface class IThrottle : IApplicationComponent,
    IDisposable
type IThrottle =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
type IThrottle =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
See Also
IThrottle Members
NFX.Throttling Namespace


IThrottle Members

IThrottle Members NFX Class Library

The IThrottle type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | Register | Register this instance with throttling container
Public method | Reset | Reset the internal state of the throttle
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc.
Public method | Unregister | Unregister this instance from throttling container
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Name | Returns the unique name of this instance
Public property | Unit | Returns the name of unit of measurement for this instance
Back to Top
See Also
IThrottle Interface
NFX.Throttling Namespace


IThrottle Methods

IThrottle Methods NFX Class Library

The IThrottle type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | Register | Register this instance with throttling container
Public method | Reset | Reset the internal state of the throttle
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc.
Public method | Unregister | Unregister this instance from throttling container
Back to Top
See Also
IThrottle Interface
NFX.Throttling Namespace


IThrottle.Register Method

IThrottle Register Method NFX Class Library

Register this instance with throttling container

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Register(
    IThrottling throttling
)
void Register(
    IThrottling throttling
)
Sub Register (
    throttling As IThrottling
)
Sub Register (
    throttling As IThrottling
)
void Register(
    IThrottling^ throttling
)
void Register(
    IThrottling^ throttling
)
abstract Register :
        throttling : IThrottling -> unit
abstract Register :
        throttling : IThrottling -> unit

Parameters

throttling
Type: NFX.Throttling IThrottling
See Also
IThrottle Interface
IThrottle Members
NFX.Throttling Namespace


IThrottle.Reset Method

IThrottle Reset Method NFX Class Library

Reset the internal state of the throttle

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Reset()
void Reset()
Sub Reset
Sub Reset
void Reset()
void Reset()
abstract Reset : unit -> unit
abstract Reset : unit -> unit
See Also
IThrottle Interface
IThrottle Members
NFX.Throttling Namespace


IThrottle.Try Method

IThrottle Try Method NFX Class Library

Overload List
 | Name | Description
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc.
Back to Top
See Also
IThrottle Interface
IThrottle Members
NFX.Throttling Namespace


IThrottle.Try Method

IThrottle Try Method NFX Class Library

Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Try()
bool Try()
Function Try As Boolean
Function Try As Boolean
bool Try()
bool Try()
abstract Try : unit -> bool
abstract Try : unit -> bool

Return Value

Type: Online Boolean
See Also
IThrottle Interface
IThrottle Members
Try Overload
NFX.Throttling Namespace


IThrottle.Try Method (Double)

IThrottle Try Method (Double) NFX Class Library

Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc.

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Try(
    double value
)
bool Try(
    double value
)
Function Try (
    value As Double
) As Boolean
Function Try (
    value As Double
) As Boolean
bool Try(
    double value
)
bool Try(
    double value
)
abstract Try :
        value : float -> bool
abstract Try :
        value : float -> bool

Parameters

value
Type: Online System Double

Return Value

Type: Online Boolean
See Also
IThrottle Interface
IThrottle Members
Try Overload
NFX.Throttling Namespace


IThrottle.Unregister Method

IThrottle Unregister Method NFX Class Library

Unregister this instance from throttling container

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Unregister()
bool Unregister()
Function Unregister As Boolean
Function Unregister As Boolean
bool Unregister()
bool Unregister()
abstract Unregister : unit -> bool
abstract Unregister : unit -> bool

Return Value

Type: Online Boolean
See Also
IThrottle Interface
IThrottle Members
NFX.Throttling Namespace


IThrottle Properties

IThrottle Properties NFX Class Library

The IThrottle type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Name | Returns the unique name of this instance
Public property | Unit | Returns the name of unit of measurement for this instance
Back to Top
See Also
IThrottle Interface
NFX.Throttling Namespace


IThrottle.Name Property

IThrottle Name Property NFX Class Library

Returns the unique name of this instance

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Name { get; }
string Name { get; }
ReadOnly Property Name As String
    Get
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
property String^ Name {
    String^ get ();
}
abstract Name : string with get
abstract Name : string with get

Property Value

Type: Online String
See Also
IThrottle Interface
IThrottle Members
NFX.Throttling Namespace


IThrottle.Unit Property

IThrottle Unit Property NFX Class Library

Returns the name of unit of measurement for this instance

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Unit { get; }
string Unit { get; }
ReadOnly Property Unit As String
    Get
ReadOnly Property Unit As String
    Get
property String^ Unit {
    String^ get ();
}
property String^ Unit {
    String^ get ();
}
abstract Unit : string with get
abstract Unit : string with get

Property Value

Type: Online String
See Also
IThrottle Interface
IThrottle Members
NFX.Throttling Namespace


IThrottling Interface

IThrottling Interface NFX Class Library

Defines throttling interface to be implemented by the throttling service

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IThrottling : IApplicationComponent,
    IDisposable
public interface IThrottling : IApplicationComponent,
    IDisposable
Public Interface IThrottling
    Inherits IApplicationComponent, IDisposable
Public Interface IThrottling
    Inherits IApplicationComponent, IDisposable
public interface class IThrottling : IApplicationComponent,
    IDisposable
public interface class IThrottling : IApplicationComponent,
    IDisposable
type IThrottling =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
type IThrottling =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
See Also
IThrottling Members
NFX.Throttling Namespace


IThrottling Members

IThrottling Members NFX Class Library

The IThrottling type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | RegisterThrottle | Register a throttle with this throttling container
Public method | UnregisterThrottle | Unregister a throttle from this throttling container
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Enabled | Turns throttling functionality on/off
Public property | Item | Get a throttle by name
Back to Top
See Also
IThrottling Interface
NFX.Throttling Namespace


IThrottling Methods

IThrottling Methods NFX Class Library

The IThrottling type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | RegisterThrottle | Register a throttle with this throttling container
Public method | UnregisterThrottle | Unregister a throttle from this throttling container
Back to Top
See Also
IThrottling Interface
NFX.Throttling Namespace


IThrottling.RegisterThrottle Method

IThrottling RegisterThrottle Method NFX Class Library

Register a throttle with this throttling container

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RegisterThrottle(
    Throttle throttle
)
void RegisterThrottle(
    Throttle throttle
)
Sub RegisterThrottle (
    throttle As Throttle
)
Sub RegisterThrottle (
    throttle As Throttle
)
void RegisterThrottle(
    Throttle^ throttle
)
void RegisterThrottle(
    Throttle^ throttle
)
abstract RegisterThrottle :
        throttle : Throttle -> unit
abstract RegisterThrottle :
        throttle : Throttle -> unit

Parameters

throttle
Type: NFX.Throttling Throttle
See Also
IThrottling Interface
IThrottling Members
NFX.Throttling Namespace


IThrottling.UnregisterThrottle Method

IThrottling UnregisterThrottle Method NFX Class Library

Unregister a throttle from this throttling container

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool UnregisterThrottle(
    Throttle throttle
)
bool UnregisterThrottle(
    Throttle throttle
)
Function UnregisterThrottle (
    throttle As Throttle
) As Boolean
Function UnregisterThrottle (
    throttle As Throttle
) As Boolean
bool UnregisterThrottle(
    Throttle^ throttle
)
bool UnregisterThrottle(
    Throttle^ throttle
)
abstract UnregisterThrottle :
        throttle : Throttle -> bool
abstract UnregisterThrottle :
        throttle : Throttle -> bool

Parameters

throttle
Type: NFX.Throttling Throttle

Return Value

Type: Online Boolean
True if throttle was successfully unregistered
See Also
IThrottling Interface
IThrottling Members
NFX.Throttling Namespace


IThrottling Properties

IThrottling Properties NFX Class Library

The IThrottling type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Enabled | Turns throttling functionality on/off
Public property | Item | Get a throttle by name
Back to Top
See Also
IThrottling Interface
NFX.Throttling Namespace


IThrottling.Enabled Property

IThrottling Enabled Property NFX Class Library

Turns throttling functionality on/off

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Enabled { get; }
bool Enabled { get; }
ReadOnly Property Enabled As Boolean
    Get
ReadOnly Property Enabled As Boolean
    Get
property bool Enabled {
    bool get ();
}
property bool Enabled {
    bool get ();
}
abstract Enabled : bool with get
abstract Enabled : bool with get

Property Value

Type: Online Boolean
See Also
IThrottling Interface
IThrottling Members
NFX.Throttling Namespace


IThrottling.Item Property

IThrottling Item Property NFX Class Library

Get a throttle by name

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IThrottle this[
    string name
] { get; }
IThrottle this[
    string name
] { get; }
ReadOnly Default Property Item (
    name As String
) As IThrottle
    Get
ReadOnly Default Property Item (
    name As String
) As IThrottle
    Get
property IThrottle^ default[String^ name] {
    IThrottle^ get (String^ name);
}
property IThrottle^ default[String^ name] {
    IThrottle^ get (String^ name);
}
abstract Item : IThrottle with get
abstract Item : IThrottle with get

Parameters

name
Type: Online System String

Property Value

Type: IThrottle
See Also
IThrottling Interface
IThrottling Members
NFX.Throttling Namespace


IThrottlingImplementation Interface

IThrottlingImplementation Interface NFX Class Library

Interface implementing configurable and disposable throttling functionaliry

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IThrottlingImplementation : IThrottling,
    IApplicationComponent, IDisposable, IConfigurable
public interface IThrottlingImplementation : IThrottling,
    IApplicationComponent, IDisposable, IConfigurable
Public Interface IThrottlingImplementation
    Inherits IThrottling, IApplicationComponent, IDisposable, IConfigurable
Public Interface IThrottlingImplementation
    Inherits IThrottling, IApplicationComponent, IDisposable, IConfigurable
public interface class IThrottlingImplementation : IThrottling,
    IApplicationComponent, IDisposable, IConfigurable
public interface class IThrottlingImplementation : IThrottling,
    IApplicationComponent, IDisposable, IConfigurable
type IThrottlingImplementation =
    interface
        interface IThrottling
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
type IThrottlingImplementation =
    interface
        interface IThrottling
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
See Also
IThrottlingImplementation Members
NFX.Throttling Namespace


IThrottlingImplementation Members

IThrottlingImplementation Members NFX Class Library

The IThrottlingImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | RegisterThrottle | Register a throttle with this throttling container (Inherited from IThrottling.)
Public method | UnregisterThrottle | Unregister a throttle from this throttling container (Inherited from IThrottling.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Enabled | Turns throttling functionality on/off (Inherited from IThrottling.)
Public property | Item | Get a throttle by name (Inherited from IThrottling.)
Back to Top
See Also
IThrottlingImplementation Interface
NFX.Throttling Namespace


IThrottlingImplementation Methods

IThrottlingImplementation Methods NFX Class Library

The IThrottlingImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | RegisterThrottle | Register a throttle with this throttling container (Inherited from IThrottling.)
Public method | UnregisterThrottle | Unregister a throttle from this throttling container (Inherited from IThrottling.)
Back to Top
See Also
IThrottlingImplementation Interface
NFX.Throttling Namespace


IThrottlingImplementation Properties

IThrottlingImplementation Properties NFX Class Library

The IThrottlingImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Enabled | Turns throttling functionality on/off (Inherited from IThrottling.)
Public property | Item | Get a throttle by name (Inherited from IThrottling.)
Back to Top
See Also
IThrottlingImplementation Interface
NFX.Throttling Namespace


NOPThrottle Class

NOPThrottle Class NFX Class Library

No operation throttle
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Throttling Throttle
NFX.Throttling NOPThrottle

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NOPThrottle : Throttle
public sealed class NOPThrottle : Throttle
Public NotInheritable Class NOPThrottle
    Inherits Throttle
Public NotInheritable Class NOPThrottle
    Inherits Throttle
public ref class NOPThrottle sealed : public Throttle
public ref class NOPThrottle sealed : public Throttle
[<SealedAttribute>]
type NOPThrottle =
    class
        inherit Throttle
    end
[<SealedAttribute>]
type NOPThrottle =
    class
        inherit Throttle
    end
See Also
NOPThrottle Members
NFX.Throttling Namespace


NOPThrottle Members

NOPThrottle Members NFX Class Library

The NOPThrottle type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setThrottling | (Inherited from Throttle.)
Public method | Configure | (Inherited from Throttle.)
Protected method | Destructor | (Inherited from Throttle.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Inherited from Throttle.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Register this instance with throttling container (Inherited from Throttle.)
Public method | Reset | Reset the internal state of the throttle (Overrides Throttle Reset .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count (Overrides Throttle Try .)
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc. (Overrides Throttle Try(Double).)
Protected method | Try(DateTime, Double) | Update current throttle timestamp (Overrides Throttle Try(DateTime, Double).)
Public method | Unregister | Unregister this instance from throttling container (Inherited from Throttle.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
 | Instance | Returns a singlelton instance of the NOPThrottle
Public property | Name | Returns the unique name of this instance (Inherited from Throttle.)
Public property | Throttling | References the Throttling that this instance is registered with (Inherited from Throttle.)
Public property | Unit | Returns the name of unit of measurement for this instance (Inherited from Throttle.)
Back to Top
See Also
NOPThrottle Class
NFX.Throttling Namespace


NOPThrottle Methods

NOPThrottle Methods NFX Class Library

The NOPThrottle type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setThrottling | (Inherited from Throttle.)
Public method | Configure | (Inherited from Throttle.)
Protected method | Destructor | (Inherited from Throttle.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Inherited from Throttle.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Register this instance with throttling container (Inherited from Throttle.)
Public method | Reset | Reset the internal state of the throttle (Overrides Throttle Reset .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count (Overrides Throttle Try .)
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc. (Overrides Throttle Try(Double).)
Protected method | Try(DateTime, Double) | Update current throttle timestamp (Overrides Throttle Try(DateTime, Double).)
Public method | Unregister | Unregister this instance from throttling container (Inherited from Throttle.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPThrottle Class
NFX.Throttling Namespace


NOPThrottle.Reset Method

NOPThrottle Reset Method NFX Class Library

Reset the internal state of the throttle

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Reset()
public override void Reset()
Public Overrides Sub Reset
Public Overrides Sub Reset
public:
virtual void Reset() override
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IThrottle Reset
See Also
NOPThrottle Class
NOPThrottle Members
NFX.Throttling Namespace


NOPThrottle.Try Method

NOPThrottle Try Method NFX Class Library

Overload List
 | Name | Description
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count (Overrides Throttle Try .)
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc. (Overrides Throttle Try(Double).)
Protected method | Try(DateTime, Double) | Update current throttle timestamp (Overrides Throttle Try(DateTime, Double).)
Back to Top
See Also
NOPThrottle Class
NOPThrottle Members
NFX.Throttling Namespace


NOPThrottle.Try Method

NOPThrottle Try Method NFX Class Library

Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Try()
public override bool Try()
Public Overrides Function Try As Boolean
Public Overrides Function Try As Boolean
public:
virtual bool Try() override
public:
virtual bool Try() override
abstract Try : unit -> bool
override Try : unit -> bool
abstract Try : unit -> bool
override Try : unit -> bool

Return Value

Type: Online Boolean

Implements

IThrottle Try
See Also
NOPThrottle Class
NOPThrottle Members
Try Overload
NFX.Throttling Namespace


NOPThrottle.Try Method (Double)

NOPThrottle Try Method (Double) NFX Class Library

Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc.

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Try(
    double value
)
public override bool Try(
    double value
)
Public Overrides Function Try (
    value As Double
) As Boolean
Public Overrides Function Try (
    value As Double
) As Boolean
public:
virtual bool Try(
    double value
) override
public:
virtual bool Try(
    double value
) override
abstract Try :
        value : float -> bool
override Try :
        value : float -> bool
abstract Try :
        value : float -> bool
override Try :
        value : float -> bool

Parameters

value
Type: Online System Double

Return Value

Type: Online Boolean

Implements

IThrottle Try(Double)
See Also
NOPThrottle Class
NOPThrottle Members
Try Overload
NFX.Throttling Namespace


NOPThrottle.Try Method (DateTime, Double)

NOPThrottle Try Method (DateTime, Double) NFX Class Library

Update current throttle timestamp

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal override bool Try(
    DateTime time,
    double value
)
internal override bool Try(
    DateTime time,
    double value
)
Friend Overrides Function Try (
    time As DateTime,
    value As Double
) As Boolean
Friend Overrides Function Try (
    time As DateTime,
    value As Double
) As Boolean
internal:
virtual bool Try(
    DateTime time,
    double value
) override
internal:
virtual bool Try(
    DateTime time,
    double value
) override
internal abstract Try :
        time : DateTime *
        value : float -> bool
internal override Try :
        time : DateTime *
        value : float -> bool
internal abstract Try :
        time : DateTime *
        value : float -> bool
internal override Try :
        time : DateTime *
        value : float -> bool

Parameters

time
Type: Online System DateTime
value
Type: Online System Double

Return Value

Type: Online Boolean
See Also
NOPThrottle Class
NOPThrottle Members
Try Overload
NFX.Throttling Namespace


NOPThrottle Properties

NOPThrottle Properties NFX Class Library

The NOPThrottle type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
 | Instance | Returns a singlelton instance of the NOPThrottle
Public property | Name | Returns the unique name of this instance (Inherited from Throttle.)
Public property | Throttling | References the Throttling that this instance is registered with (Inherited from Throttle.)
Public property | Unit | Returns the name of unit of measurement for this instance (Inherited from Throttle.)
Back to Top
See Also
NOPThrottle Class
NFX.Throttling Namespace


NOPThrottle.Instance Property

NOPThrottle Instance Property NFX Class Library

Returns a singlelton instance of the NOPThrottle

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NOPThrottle Instance { get; }
public static NOPThrottle Instance { get; }
Public Shared ReadOnly Property Instance As NOPThrottle
    Get
Public Shared ReadOnly Property Instance As NOPThrottle
    Get
public:
static property NOPThrottle^ Instance {
    NOPThrottle^ get ();
}
public:
static property NOPThrottle^ Instance {
    NOPThrottle^ get ();
}
static member Instance : NOPThrottle with get
static member Instance : NOPThrottle with get

Property Value

Type: NOPThrottle
See Also
NOPThrottle Class
NOPThrottle Members
NFX.Throttling Namespace


NOPThrottling Class

NOPThrottling Class NFX Class Library

Represents throttling implementation that does nothing and always returns NOPThrottle
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Throttling NOPThrottling

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NOPThrottling : ApplicationComponent,
    IThrottlingImplementation, IThrottling, IApplicationComponent, IDisposable, IConfigurable
public class NOPThrottling : ApplicationComponent,
    IThrottlingImplementation, IThrottling, IApplicationComponent, IDisposable, IConfigurable
Public Class NOPThrottling
    Inherits ApplicationComponent
    Implements IThrottlingImplementation, IThrottling, IApplicationComponent, IDisposable,
    IConfigurable
Public Class NOPThrottling
    Inherits ApplicationComponent
    Implements IThrottlingImplementation, IThrottling, IApplicationComponent, IDisposable,
    IConfigurable
public ref class NOPThrottling : public ApplicationComponent,
    IThrottlingImplementation, IThrottling, IApplicationComponent, IDisposable, IConfigurable
public ref class NOPThrottling : public ApplicationComponent,
    IThrottlingImplementation, IThrottling, IApplicationComponent, IDisposable, IConfigurable
type NOPThrottling =
    class
        inherit ApplicationComponent
        interface IThrottlingImplementation
        interface IThrottling
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
type NOPThrottling =
    class
        inherit ApplicationComponent
        interface IThrottlingImplementation
        interface IThrottling
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
See Also
NOPThrottling Members
NFX.Throttling Namespace


NOPThrottling Members

NOPThrottling Members NFX Class Library

The NOPThrottling type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterThrottle |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnregisterThrottle |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled |
 | Instance |
Public property | Item |
Back to Top
See Also
NOPThrottling Class
NFX.Throttling Namespace


NOPThrottling Methods

NOPThrottling Methods NFX Class Library

The NOPThrottling type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterThrottle |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnregisterThrottle |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPThrottling Class
NFX.Throttling Namespace


NOPThrottling.Configure Method

NOPThrottling Configure Method NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
NOPThrottling Class
NOPThrottling Members
NFX.Throttling Namespace


NOPThrottling.RegisterThrottle Method

NOPThrottling RegisterThrottle Method NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RegisterThrottle(
    Throttle throttle
)
public void RegisterThrottle(
    Throttle throttle
)
Public Sub RegisterThrottle (
    throttle As Throttle
)
Public Sub RegisterThrottle (
    throttle As Throttle
)
public:
virtual void RegisterThrottle(
    Throttle^ throttle
) sealed
public:
virtual void RegisterThrottle(
    Throttle^ throttle
) sealed
abstract RegisterThrottle :
        throttle : Throttle -> unit
override RegisterThrottle :
        throttle : Throttle -> unit
abstract RegisterThrottle :
        throttle : Throttle -> unit
override RegisterThrottle :
        throttle : Throttle -> unit

Parameters

throttle
Type: NFX.Throttling Throttle

Implements

IThrottling RegisterThrottle(Throttle)
See Also
NOPThrottling Class
NOPThrottling Members
NFX.Throttling Namespace


NOPThrottling.UnregisterThrottle Method

NOPThrottling UnregisterThrottle Method NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnregisterThrottle(
    Throttle throttle
)
public bool UnregisterThrottle(
    Throttle throttle
)
Public Function UnregisterThrottle (
    throttle As Throttle
) As Boolean
Public Function UnregisterThrottle (
    throttle As Throttle
) As Boolean
public:
virtual bool UnregisterThrottle(
    Throttle^ throttle
) sealed
public:
virtual bool UnregisterThrottle(
    Throttle^ throttle
) sealed
abstract UnregisterThrottle :
        throttle : Throttle -> bool
override UnregisterThrottle :
        throttle : Throttle -> bool
abstract UnregisterThrottle :
        throttle : Throttle -> bool
override UnregisterThrottle :
        throttle : Throttle -> bool

Parameters

throttle
Type: NFX.Throttling Throttle

Return Value

Type: Online Boolean

Implements

IThrottling UnregisterThrottle(Throttle)
See Also
NOPThrottling Class
NOPThrottling Members
NFX.Throttling Namespace


NOPThrottling Properties

NOPThrottling Properties NFX Class Library

The NOPThrottling type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled |
 | Instance |
Public property | Item |
Back to Top
See Also
NOPThrottling Class
NFX.Throttling Namespace


NOPThrottling.Enabled Property

NOPThrottling Enabled Property NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Enabled { get; }
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
Public ReadOnly Property Enabled As Boolean
    Get
public:
virtual property bool Enabled {
    bool get () sealed;
}
public:
virtual property bool Enabled {
    bool get () sealed;
}
abstract Enabled : bool with get
override Enabled : bool with get
abstract Enabled : bool with get
override Enabled : bool with get

Property Value

Type: Online Boolean

Implements

IThrottling Enabled
See Also
NOPThrottling Class
NOPThrottling Members
NFX.Throttling Namespace


NOPThrottling.Instance Property

NOPThrottling Instance Property NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NOPThrottling Instance { get; }
public static NOPThrottling Instance { get; }
Public Shared ReadOnly Property Instance As NOPThrottling
    Get
Public Shared ReadOnly Property Instance As NOPThrottling
    Get
public:
static property NOPThrottling^ Instance {
    NOPThrottling^ get ();
}
public:
static property NOPThrottling^ Instance {
    NOPThrottling^ get ();
}
static member Instance : NOPThrottling with get
static member Instance : NOPThrottling with get

Property Value

Type: NOPThrottling
See Also
NOPThrottling Class
NOPThrottling Members
NFX.Throttling Namespace


NOPThrottling.Item Property

NOPThrottling Item Property NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IThrottle this[
    string name
] { get; }
public IThrottle this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As IThrottle
    Get
Public ReadOnly Default Property Item (
    name As String
) As IThrottle
    Get
public:
virtual property IThrottle^ default[String^ name] {
    IThrottle^ get (String^ name) sealed;
}
public:
virtual property IThrottle^ default[String^ name] {
    IThrottle^ get (String^ name) sealed;
}
abstract Item : IThrottle with get
override Item : IThrottle with get
abstract Item : IThrottle with get
override Item : IThrottle with get

Parameters

name
Type: Online System String

Property Value

Type: IThrottle

Implements

IThrottling Item String
See Also
NOPThrottling Class
NOPThrottling Members
NFX.Throttling Namespace


SlidingWindowThrottle Class

SlidingWindowThrottle Class NFX Class Library

Efficiently calculates the throttling rate over a number of seconds. The algorithm implements a variation of token bucket algorithm that doesn't require to add tokens to the bucket on a timer but rather it maintains a cirtular buffer of tokens with resolution of 1/BucketsPerSec. The Add() function is used to add items to a bucket associated with the timestamp passed as the first argument to the function. The Sum() returns the total number of items over the given interval of seconds. The items automatically expire when the time moves on the successive invocations of the Add() method.
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Throttling Throttle
NFX.Throttling SlidingWindowThrottle

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SlidingWindowThrottle : Throttle
public class SlidingWindowThrottle : Throttle
Public Class SlidingWindowThrottle
    Inherits Throttle
Public Class SlidingWindowThrottle
    Inherits Throttle
public ref class SlidingWindowThrottle : public Throttle
public ref class SlidingWindowThrottle : public Throttle
type SlidingWindowThrottle =
    class
        inherit Throttle
    end
type SlidingWindowThrottle =
    class
        inherit Throttle
    end
See Also
SlidingWindowThrottle Members
NFX.Throttling Namespace


SlidingWindowThrottle Members

SlidingWindowThrottle Members NFX Class Library

The SlidingWindowThrottle type exposes the following members.
Constructors
 | Name | Description
Public method | SlidingWindowThrottle | Initializes a new instance of the SlidingWindowThrottle class
Public method | SlidingWindowThrottle(String, Int32, Int32, Int32, String) | Constructor
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setThrottling | (Inherited from Throttle.)
Public method | Configure | (Inherited from Throttle.)
Protected method | Destructor | (Overrides Throttle Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Overrides Throttle DoConfigure(IConfigSectionNode).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Register this instance with throttling container (Inherited from Throttle.)
Public method | Reset | Reset the internal state of the throttling strategy (Overrides Throttle Reset .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | ToString(DateTime) | Dump the internal state to string
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count (Inherited from Throttle.)
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc. (Inherited from Throttle.)
Protected method | Try(DateTime, Double) | Add value to the bucket associated with time (Overrides Throttle Try(DateTime, Double).)
Public method | Unregister | Unregister this instance from throttling container (Inherited from Throttle.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Avg | Return current running average over the throttling interval
Public property | BucketsPerSec | Number of measurement buckets per second. The greater the number the more accurate throttle rate is calculated and the slower the calculation gets
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Interval | Return throttling interval in seconds
Public property | Limit | Return throttle limit over Interval
Public property | Name | Returns the unique name of this instance (Inherited from Throttle.)
Public property | Sum | Return current running sum over the throttling interval
Public property | Throttling | References the Throttling that this instance is registered with (Inherited from Throttle.)
Public property | Unit | Returns the name of unit of measurement for this instance (Inherited from Throttle.)
Back to Top
See Also
SlidingWindowThrottle Class
NFX.Throttling Namespace


SlidingWindowThrottle Constructor

SlidingWindowThrottle Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SlidingWindowThrottle | Initializes a new instance of the SlidingWindowThrottle class
Public method | SlidingWindowThrottle(String, Int32, Int32, Int32, String) | Constructor
Back to Top
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
NFX.Throttling Namespace


SlidingWindowThrottle Constructor

SlidingWindowThrottle Constructor NFX Class Library

Initializes a new instance of the SlidingWindowThrottle class

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlidingWindowThrottle()
public SlidingWindowThrottle()
Public Sub New
Public Sub New
public:
SlidingWindowThrottle()
public:
SlidingWindowThrottle()
new : unit -> SlidingWindowThrottle
new : unit -> SlidingWindowThrottle
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
SlidingWindowThrottle Overload
NFX.Throttling Namespace


SlidingWindowThrottle Constructor (String, Int32, Int32, Int32, String)

SlidingWindowThrottle Constructor (String, Int32, Int32, Int32, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlidingWindowThrottle(
    string name,
    int throttleLimit,
    int throttleInterval,
    int bucketsPerSecond = 5,
    string unit = null
)
public SlidingWindowThrottle(
    string name,
    int throttleLimit,
    int throttleInterval,
    int bucketsPerSecond = 5,
    string unit = null
)
Public Sub New (
    name As String,
    throttleLimit As Integer,
    throttleInterval As Integer,
    Optional bucketsPerSecond As Integer = 5,
    Optional unit As String = Nothing
)
Public Sub New (
    name As String,
    throttleLimit As Integer,
    throttleInterval As Integer,
    Optional bucketsPerSecond As Integer = 5,
    Optional unit As String = Nothing
)
public:
SlidingWindowThrottle(
    String^ name,
    int throttleLimit,
    int throttleInterval,
    int bucketsPerSecond = 5,
    String^ unit = nullptr
)
public:
SlidingWindowThrottle(
    String^ name,
    int throttleLimit,
    int throttleInterval,
    int bucketsPerSecond = 5,
    String^ unit = nullptr
)
new :
        name : string *
        throttleLimit : int *
        throttleInterval : int *
        ?bucketsPerSecond : int *
        ?unit : string
(* Defaults:
        let _bucketsPerSecond = defaultArg bucketsPerSecond 5
        let _unit = defaultArg unit null
*)
-> SlidingWindowThrottle
new :
        name : string *
        throttleLimit : int *
        throttleInterval : int *
        ?bucketsPerSecond : int *
        ?unit : string
(* Defaults:
        let _bucketsPerSecond = defaultArg bucketsPerSecond 5
        let _unit = defaultArg unit null
*)
-> SlidingWindowThrottle

Parameters

name
Type: Online System String
Name of this instance
throttleLimit
Type: Online System Int32
Throttling limit per throttleInterval
throttleInterval
Type: Online System Int32
Throttling interval in number of seconds
bucketsPerSecond (Optional)
Type: Online System Int32
Number of buckets per second to calculate internal running sum. The greater the value the more precise the avg calculation is and the longer it takes to calculate
unit (Optional)
Type: Online System String
Unit of measurement
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
SlidingWindowThrottle Overload
NFX.Throttling Namespace


SlidingWindowThrottle Methods

SlidingWindowThrottle Methods NFX Class Library

The SlidingWindowThrottle type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setThrottling | (Inherited from Throttle.)
Public method | Configure | (Inherited from Throttle.)
Protected method | Destructor | (Overrides Throttle Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Overrides Throttle DoConfigure(IConfigSectionNode).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Register this instance with throttling container (Inherited from Throttle.)
Public method | Reset | Reset the internal state of the throttling strategy (Overrides Throttle Reset .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | ToString(DateTime) | Dump the internal state to string
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count (Inherited from Throttle.)
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc. (Inherited from Throttle.)
Protected method | Try(DateTime, Double) | Add value to the bucket associated with time (Overrides Throttle Try(DateTime, Double).)
Public method | Unregister | Unregister this instance from throttling container (Inherited from Throttle.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SlidingWindowThrottle Class
NFX.Throttling Namespace


SlidingWindowThrottle.Destructor Method

SlidingWindowThrottle Destructor Method NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
NFX.Throttling Namespace


SlidingWindowThrottle.DoConfigure Method

SlidingWindowThrottle DoConfigure Method NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
NFX.Throttling Namespace


SlidingWindowThrottle.Reset Method

SlidingWindowThrottle Reset Method NFX Class Library

Reset the internal state of the throttling strategy

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Reset()
public override void Reset()
Public Overrides Sub Reset
Public Overrides Sub Reset
public:
virtual void Reset() override
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IThrottle Reset
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
NFX.Throttling Namespace


SlidingWindowThrottle.ToString Method

SlidingWindowThrottle ToString Method NFX Class Library

Overload List
 | Name | Description
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | ToString(DateTime) | Dump the internal state to string
Back to Top
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
NFX.Throttling Namespace


SlidingWindowThrottle.ToString Method (DateTime)

SlidingWindowThrottle ToString Method (DateTime) NFX Class Library

[This is preliminary documentation and is subject to change.]

Dump the internal state to string

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToString(
    DateTime time
)
public string ToString(
    DateTime time
)
Public Function ToString (
    time As DateTime
) As String
Public Function ToString (
    time As DateTime
) As String
public:
String^ ToString(
    DateTime time
)
public:
String^ ToString(
    DateTime time
)
member ToString :
        time : DateTime -> string
member ToString :
        time : DateTime -> string

Parameters

time
Type: Online System DateTime
Time for which to dump internal state to string

Return Value

Type: Online String
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
ToString Overload
NFX.Throttling Namespace


SlidingWindowThrottle.Try Method

SlidingWindowThrottle Try Method NFX Class Library

Overload List
 | Name | Description
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count (Inherited from Throttle.)
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc. (Inherited from Throttle.)
Protected method | Try(DateTime, Double) | Add value to the bucket associated with time (Overrides Throttle Try(DateTime, Double).)
Back to Top
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
NFX.Throttling Namespace


SlidingWindowThrottle.Try Method (DateTime, Double)

SlidingWindowThrottle Try Method (DateTime, Double) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add value to the bucket associated with time

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal override bool Try(
    DateTime time,
    double value
)
internal override bool Try(
    DateTime time,
    double value
)
Friend Overrides Function Try (
    time As DateTime,
    value As Double
) As Boolean
Friend Overrides Function Try (
    time As DateTime,
    value As Double
) As Boolean
internal:
virtual bool Try(
    DateTime time,
    double value
) override
internal:
virtual bool Try(
    DateTime time,
    double value
) override
internal abstract Try :
        time : DateTime *
        value : float -> bool
internal override Try :
        time : DateTime *
        value : float -> bool
internal abstract Try :
        time : DateTime *
        value : float -> bool
internal override Try :
        time : DateTime *
        value : float -> bool

Parameters

time
Type: Online System DateTime
Monotonically increasing time value
value
Type: Online System Double
The value to add to the bucket associated with time

Return Value

Type: Online Boolean
Current running sum
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
Try Overload
NFX.Throttling Namespace


SlidingWindowThrottle Properties

SlidingWindowThrottle Properties NFX Class Library

The SlidingWindowThrottle type exposes the following members.
Properties
 | Name | Description
Public property | Avg | Return current running average over the throttling interval
Public property | BucketsPerSec | Number of measurement buckets per second. The greater the number the more accurate throttle rate is calculated and the slower the calculation gets
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Interval | Return throttling interval in seconds
Public property | Limit | Return throttle limit over Interval
Public property | Name | Returns the unique name of this instance (Inherited from Throttle.)
Public property | Sum | Return current running sum over the throttling interval
Public property | Throttling | References the Throttling that this instance is registered with (Inherited from Throttle.)
Public property | Unit | Returns the name of unit of measurement for this instance (Inherited from Throttle.)
Back to Top
See Also
SlidingWindowThrottle Class
NFX.Throttling Namespace


SlidingWindowThrottle.Avg Property

SlidingWindowThrottle Avg Property NFX Class Library

Return current running average over the throttling interval

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Avg { get; }
public double Avg { get; }
Public ReadOnly Property Avg As Double
    Get
Public ReadOnly Property Avg As Double
    Get
public:
property double Avg {
    double get ();
}
public:
property double Avg {
    double get ();
}
member Avg : float with get
member Avg : float with get

Property Value

Type: Online Double
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
NFX.Throttling Namespace


SlidingWindowThrottle.BucketsPerSec Property

SlidingWindowThrottle BucketsPerSec Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Number of measurement buckets per second. The greater the number the more accurate throttle rate is calculated and the slower the calculation gets

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$buckets-per-sec", 8)]
public int BucketsPerSec { get; internal set; }
[ConfigAttribute("$buckets-per-sec", 8)]
public int BucketsPerSec { get; internal set; }
<ConfigAttribute("$buckets-per-sec", 8)>
Public Property BucketsPerSec As Integer
    Get
    Friend Set
<ConfigAttribute("$buckets-per-sec", 8)>
Public Property BucketsPerSec As Integer
    Get
    Friend Set
public:
[ConfigAttribute(L"$buckets-per-sec", 8)]
property int BucketsPerSec {
    int get ();
    internal: void set (int value);
}
public:
[ConfigAttribute(L"$buckets-per-sec", 8)]
property int BucketsPerSec {
    int get ();
    internal: void set (int value);
}
[<ConfigAttribute("$buckets-per-sec", 8)>]
member BucketsPerSec : int with get, internal set
[<ConfigAttribute("$buckets-per-sec", 8)>]
member BucketsPerSec : int with get, internal set

Property Value

Type: Online Int32
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
NFX.Throttling Namespace


SlidingWindowThrottle.Interval Property

SlidingWindowThrottle Interval Property NFX Class Library

Return throttling interval in seconds

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$interval")]
public int Interval { get; internal set; }
[ConfigAttribute("$interval")]
public int Interval { get; internal set; }
<ConfigAttribute("$interval")>
Public Property Interval As Integer
    Get
    Friend Set
<ConfigAttribute("$interval")>
Public Property Interval As Integer
    Get
    Friend Set
public:
[ConfigAttribute(L"$interval")]
property int Interval {
    int get ();
    internal: void set (int value);
}
public:
[ConfigAttribute(L"$interval")]
property int Interval {
    int get ();
    internal: void set (int value);
}
[<ConfigAttribute("$interval")>]
member Interval : int with get, internal set
[<ConfigAttribute("$interval")>]
member Interval : int with get, internal set

Property Value

Type: Online Int32
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
NFX.Throttling Namespace


SlidingWindowThrottle.Limit Property

SlidingWindowThrottle Limit Property NFX Class Library

Return throttle limit over Interval

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$limit")]
public double Limit { get; internal set; }
[ConfigAttribute("$limit")]
public double Limit { get; internal set; }
<ConfigAttribute("$limit")>
Public Property Limit As Double
    Get
    Friend Set
<ConfigAttribute("$limit")>
Public Property Limit As Double
    Get
    Friend Set
public:
[ConfigAttribute(L"$limit")]
property double Limit {
    double get ();
    internal: void set (double value);
}
public:
[ConfigAttribute(L"$limit")]
property double Limit {
    double get ();
    internal: void set (double value);
}
[<ConfigAttribute("$limit")>]
member Limit : float with get, internal set
[<ConfigAttribute("$limit")>]
member Limit : float with get, internal set

Property Value

Type: Online Double
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
NFX.Throttling Namespace


SlidingWindowThrottle.Sum Property

SlidingWindowThrottle Sum Property NFX Class Library

Return current running sum over the throttling interval

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Sum { get; }
public double Sum { get; }
Public ReadOnly Property Sum As Double
    Get
Public ReadOnly Property Sum As Double
    Get
public:
property double Sum {
    double get ();
}
public:
property double Sum {
    double get ();
}
member Sum : float with get
member Sum : float with get

Property Value

Type: Online Double
See Also
SlidingWindowThrottle Class
SlidingWindowThrottle Members
NFX.Throttling Namespace


Throttle Class

Throttle Class NFX Class Library

Base class defining throttle interface
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Throttling Throttle
NFX.Throttling NOPThrottle
NFX.Throttling SlidingWindowThrottle
NFX.Throttling TimeSpacingThrottle

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Throttle : ApplicationComponent,
    IConfigurable, IThrottle, IApplicationComponent, IDisposable
public abstract class Throttle : ApplicationComponent,
    IConfigurable, IThrottle, IApplicationComponent, IDisposable
Public MustInherit Class Throttle
    Inherits ApplicationComponent
    Implements IConfigurable, IThrottle, IApplicationComponent, IDisposable
Public MustInherit Class Throttle
    Inherits ApplicationComponent
    Implements IConfigurable, IThrottle, IApplicationComponent, IDisposable
public ref class Throttle abstract : public ApplicationComponent,
    IConfigurable, IThrottle, IApplicationComponent, IDisposable
public ref class Throttle abstract : public ApplicationComponent,
    IConfigurable, IThrottle, IApplicationComponent, IDisposable
[<AbstractClassAttribute>]
type Throttle =
    class
        inherit ApplicationComponent
        interface IConfigurable
        interface IThrottle
        interface IApplicationComponent
        interface IDisposable
    end
[<AbstractClassAttribute>]
type Throttle =
    class
        inherit ApplicationComponent
        interface IConfigurable
        interface IThrottle
        interface IApplicationComponent
        interface IDisposable
    end
See Also
Throttle Members
NFX.Throttling Namespace


Throttle Members

Throttle Members NFX Class Library

The Throttle type exposes the following members.
Constructors
 | Name | Description
Protected method | Throttle | Initializes a new instance of the Throttle class
Protected method | Throttle(String, String) | Constructor that identifies throttle by name, and optionally defines the unit of measurement for this throttle instance
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setThrottling |
Public method | Configure |
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Register this instance with throttling container
Public method | Reset | Reset the internal state of the throttle
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc.
Protected method | Try(DateTime, Double) | Update current throttle timestamp
Public method | Unregister | Unregister this instance from throttling container
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
DEFAULT_UNITS |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Name | Returns the unique name of this instance
Public property | Throttling | References the Throttling that this instance is registered with
Public property | Unit | Returns the name of unit of measurement for this instance
Back to Top
See Also
Throttle Class
NFX.Throttling Namespace


Throttle Constructor

Throttle Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | Throttle | Initializes a new instance of the Throttle class
Protected method | Throttle(String, String) | Constructor that identifies throttle by name, and optionally defines the unit of measurement for this throttle instance
Back to Top
See Also
Throttle Class
Throttle Members
NFX.Throttling Namespace


Throttle Constructor

Throttle Constructor NFX Class Library

Initializes a new instance of the Throttle class

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Throttle()
protected Throttle()
Protected Sub New
Protected Sub New
protected:
Throttle()
protected:
Throttle()
new : unit -> Throttle
new : unit -> Throttle
See Also
Throttle Class
Throttle Members
Throttle Overload
NFX.Throttling Namespace


Throttle Constructor (String, String)

Throttle Constructor (String, String) NFX Class Library

Constructor that identifies throttle by name, and optionally defines the unit of measurement for this throttle instance

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Throttle(
    string name,
    string unit = null
)
protected Throttle(
    string name,
    string unit = null
)
Protected Sub New (
    name As String,
    Optional unit As String = Nothing
)
Protected Sub New (
    name As String,
    Optional unit As String = Nothing
)
protected:
Throttle(
    String^ name,
    String^ unit = nullptr
)
protected:
Throttle(
    String^ name,
    String^ unit = nullptr
)
new :
        name : string *
        ?unit : string
(* Defaults:
        let _unit = defaultArg unit null
*)
-> Throttle
new :
        name : string *
        ?unit : string
(* Defaults:
        let _unit = defaultArg unit null
*)
-> Throttle

Parameters

name
Type: Online System String
unit (Optional)
Type: Online System String
See Also
Throttle Class
Throttle Members
Throttle Overload
NFX.Throttling Namespace


Throttle Fields

Throttle Fields NFX Class Library

The Throttle type exposes the following members.
Fields
Name | Description
DEFAULT_UNITS |
Back to Top
See Also
Throttle Class
NFX.Throttling Namespace


Throttle.DEFAULT_UNITS Field

Throttle DEFAULT_UNITS Field NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const string DEFAULT_UNITS
internal const string DEFAULT_UNITS
Friend Const DEFAULT_UNITS As String
Friend Const DEFAULT_UNITS As String
internal:
literal String^ DEFAULT_UNITS
internal:
literal String^ DEFAULT_UNITS
static val mutable internal DEFAULT_UNITS: string
static val mutable internal DEFAULT_UNITS: string

Field Value

Type: Online String
See Also
Throttle Class
Throttle Members
NFX.Throttling Namespace


Throttle Methods

Throttle Methods NFX Class Library

The Throttle type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setThrottling |
Public method | Configure |
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Register this instance with throttling container
Public method | Reset | Reset the internal state of the throttle
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc.
Protected method | Try(DateTime, Double) | Update current throttle timestamp
Public method | Unregister | Unregister this instance from throttling container
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Throttle Class
NFX.Throttling Namespace


Throttle.__setThrottling Method

Throttle __setThrottling Method NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void __setThrottling(
    IThrottlingImplementation ti
)
internal void __setThrottling(
    IThrottlingImplementation ti
)
Friend Sub __setThrottling (
    ti As IThrottlingImplementation
)
Friend Sub __setThrottling (
    ti As IThrottlingImplementation
)
internal:
void __setThrottling(
    IThrottlingImplementation^ ti
)
internal:
void __setThrottling(
    IThrottlingImplementation^ ti
)
internal member __setThrottling :
        ti : IThrottlingImplementation -> unit
internal member __setThrottling :
        ti : IThrottlingImplementation -> unit

Parameters

ti
Type: NFX.Throttling IThrottlingImplementation
See Also
Throttle Class
Throttle Members
NFX.Throttling Namespace


Throttle.Configure Method

Throttle Configure Method NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
Throttle Class
Throttle Members
NFX.Throttling Namespace


Throttle.Destructor Method

Throttle Destructor Method NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Throttle Class
Throttle Members
NFX.Throttling Namespace


Throttle.DoConfigure Method

Throttle DoConfigure Method NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoConfigure(
    IConfigSectionNode node
)
protected virtual void DoConfigure(
    IConfigSectionNode node
)
Protected Overridable Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overridable Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
)
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
Throttle Class
Throttle Members
NFX.Throttling Namespace


Throttle.Register Method

Throttle Register Method NFX Class Library

Register this instance with throttling container

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Register(
    IThrottling throttling
)
public void Register(
    IThrottling throttling
)
Public Sub Register (
    throttling As IThrottling
)
Public Sub Register (
    throttling As IThrottling
)
public:
virtual void Register(
    IThrottling^ throttling
) sealed
public:
virtual void Register(
    IThrottling^ throttling
) sealed
abstract Register :
        throttling : IThrottling -> unit
override Register :
        throttling : IThrottling -> unit
abstract Register :
        throttling : IThrottling -> unit
override Register :
        throttling : IThrottling -> unit

Parameters

throttling
Type: NFX.Throttling IThrottling

Implements

IThrottle Register(IThrottling)
See Also
Throttle Class
Throttle Members
NFX.Throttling Namespace


Throttle.Reset Method

Throttle Reset Method NFX Class Library

Reset the internal state of the throttle

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Reset()
public abstract void Reset()
Public MustOverride Sub Reset
Public MustOverride Sub Reset
public:
virtual void Reset() abstract
public:
virtual void Reset() abstract
abstract Reset : unit -> unit
abstract Reset : unit -> unit

Implements

IThrottle Reset
See Also
Throttle Class
Throttle Members
NFX.Throttling Namespace


Throttle.Try Method

Throttle Try Method NFX Class Library

Overload List
 | Name | Description
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc.
Protected method | Try(DateTime, Double) | Update current throttle timestamp
Back to Top
See Also
Throttle Class
Throttle Members
NFX.Throttling Namespace


Throttle.Try Method

Throttle Try Method NFX Class Library

Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Try()
public virtual bool Try()
Public Overridable Function Try As Boolean
Public Overridable Function Try As Boolean
public:
virtual bool Try()
public:
virtual bool Try()
abstract Try : unit -> bool
override Try : unit -> bool
abstract Try : unit -> bool
override Try : unit -> bool

Return Value

Type: Online Boolean

Implements

IThrottle Try
See Also
Throttle Class
Throttle Members
Try Overload
NFX.Throttling Namespace


Throttle.Try Method (Double)

Throttle Try Method (Double) NFX Class Library

Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc.

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Try(
    double value
)
public virtual bool Try(
    double value
)
Public Overridable Function Try (
    value As Double
) As Boolean
Public Overridable Function Try (
    value As Double
) As Boolean
public:
virtual bool Try(
    double value
)
public:
virtual bool Try(
    double value
)
abstract Try :
        value : float -> bool
override Try :
        value : float -> bool
abstract Try :
        value : float -> bool
override Try :
        value : float -> bool

Parameters

value
Type: Online System Double

Return Value

Type: Online Boolean

Implements

IThrottle Try(Double)
See Also
Throttle Class
Throttle Members
Try Overload
NFX.Throttling Namespace


Throttle.Try Method (DateTime, Double)

Throttle Try Method (DateTime, Double) NFX Class Library

Update current throttle timestamp

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal abstract bool Try(
    DateTime time,
    double value
)
internal abstract bool Try(
    DateTime time,
    double value
)
Friend MustOverride Function Try (
    time As DateTime,
    value As Double
) As Boolean
Friend MustOverride Function Try (
    time As DateTime,
    value As Double
) As Boolean
internal:
virtual bool Try(
    DateTime time,
    double value
) abstract
internal:
virtual bool Try(
    DateTime time,
    double value
) abstract
internal abstract Try :
        time : DateTime *
        value : float -> bool
internal abstract Try :
        time : DateTime *
        value : float -> bool

Parameters

time
Type: Online System DateTime
value
Type: Online System Double

Return Value

Type: Online Boolean
See Also
Throttle Class
Throttle Members
Try Overload
NFX.Throttling Namespace


Throttle.Unregister Method

Throttle Unregister Method NFX Class Library

Unregister this instance from throttling container

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Unregister()
public bool Unregister()
Public Function Unregister As Boolean
Public Function Unregister As Boolean
public:
virtual bool Unregister() sealed
public:
virtual bool Unregister() sealed
abstract Unregister : unit -> bool
override Unregister : unit -> bool
abstract Unregister : unit -> bool
override Unregister : unit -> bool

Return Value

Type: Online Boolean

Implements

IThrottle Unregister
See Also
Throttle Class
Throttle Members
NFX.Throttling Namespace


Throttle Properties

Throttle Properties NFX Class Library

The Throttle type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Name | Returns the unique name of this instance
Public property | Throttling | References the Throttling that this instance is registered with
Public property | Unit | Returns the name of unit of measurement for this instance
Back to Top
See Also
Throttle Class
NFX.Throttling Namespace


Throttle.Name Property

Throttle Name Property NFX Class Library

Returns the unique name of this instance

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

IThrottle Name
See Also
Throttle Class
Throttle Members
NFX.Throttling Namespace


Throttle.Throttling Property

Throttle Throttling Property NFX Class Library

References the Throttling that this instance is registered with

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IThrottling Throttling { get; }
public IThrottling Throttling { get; }
Public ReadOnly Property Throttling As IThrottling
    Get
Public ReadOnly Property Throttling As IThrottling
    Get
public:
property IThrottling^ Throttling {
    IThrottling^ get ();
}
public:
property IThrottling^ Throttling {
    IThrottling^ get ();
}
member Throttling : IThrottling with get
member Throttling : IThrottling with get

Property Value

Type: IThrottling
See Also
Throttle Class
Throttle Members
NFX.Throttling Namespace


Throttle.Unit Property

Throttle Unit Property NFX Class Library

Returns the name of unit of measurement for this instance

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Unit { get; }
public string Unit { get; }
Public ReadOnly Property Unit As String
    Get
Public ReadOnly Property Unit As String
    Get
public:
virtual property String^ Unit {
    String^ get () sealed;
}
public:
virtual property String^ Unit {
    String^ get () sealed;
}
abstract Unit : string with get
override Unit : string with get
abstract Unit : string with get
override Unit : string with get

Property Value

Type: Online String

Implements

IThrottle Unit
See Also
Throttle Class
Throttle Members
NFX.Throttling Namespace


ThrottlingService Class

ThrottlingService Class NFX Class Library

A service that maintains throttling components in an application and allows to turn on/off global throttling functionality
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.Throttling ThrottlingService

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigMacroContextAttribute]
public class ThrottlingService : Service,
    IThrottlingImplementation, IThrottling, IApplicationComponent, IDisposable, IConfigurable
[ConfigMacroContextAttribute]
public class ThrottlingService : Service,
    IThrottlingImplementation, IThrottling, IApplicationComponent, IDisposable, IConfigurable
<ConfigMacroContextAttribute>
Public Class ThrottlingService
    Inherits Service
    Implements IThrottlingImplementation, IThrottling, IApplicationComponent, IDisposable,
    IConfigurable
<ConfigMacroContextAttribute>
Public Class ThrottlingService
    Inherits Service
    Implements IThrottlingImplementation, IThrottling, IApplicationComponent, IDisposable,
    IConfigurable
[ConfigMacroContextAttribute]
public ref class ThrottlingService : public Service,
    IThrottlingImplementation, IThrottling, IApplicationComponent, IDisposable, IConfigurable
[ConfigMacroContextAttribute]
public ref class ThrottlingService : public Service,
    IThrottlingImplementation, IThrottling, IApplicationComponent, IDisposable, IConfigurable
[<ConfigMacroContextAttribute>]
type ThrottlingService =
    class
        inherit Service
        interface IThrottlingImplementation
        interface IThrottling
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
[<ConfigMacroContextAttribute>]
type ThrottlingService =
    class
        inherit Service
        interface IThrottlingImplementation
        interface IThrottling
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
See Also
ThrottlingService Members
NFX.Throttling Namespace


ThrottlingService Members

ThrottlingService Members NFX Class Library

The ThrottlingService type exposes the following members.
Constructors
 | Name | Description
Public method | ThrottlingService | Initializes a new instance of the ThrottlingService class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Get T | Resolve a typed throttle by name
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterThrottle | Register a throttle with this throttling container
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | UnregisterThrottle | Unregister a throttle from this throttling container
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_THROTTLE_SECTION |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled |
Public property | Item | Resolve a throttle instance by name
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
ThrottlingService Class
NFX.Throttling Namespace


ThrottlingService Constructor

ThrottlingService Constructor NFX Class Library

Initializes a new instance of the ThrottlingService class

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ThrottlingService()
public ThrottlingService()
Public Sub New
Public Sub New
public:
ThrottlingService()
public:
ThrottlingService()
new : unit -> ThrottlingService
new : unit -> ThrottlingService
See Also
ThrottlingService Class
ThrottlingService Members
NFX.Throttling Namespace


ThrottlingService Fields

ThrottlingService Fields NFX Class Library

The ThrottlingService type exposes the following members.
Fields
Name | Description
CONFIG_THROTTLE_SECTION |
Back to Top
See Also
ThrottlingService Class
NFX.Throttling Namespace


ThrottlingService.CONFIG_THROTTLE_SECTION Field

ThrottlingService CONFIG_THROTTLE_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_THROTTLE_SECTION
public const string CONFIG_THROTTLE_SECTION
Public Const CONFIG_THROTTLE_SECTION As String
Public Const CONFIG_THROTTLE_SECTION As String
public:
literal String^ CONFIG_THROTTLE_SECTION
public:
literal String^ CONFIG_THROTTLE_SECTION
static val mutable CONFIG_THROTTLE_SECTION: string
static val mutable CONFIG_THROTTLE_SECTION: string

Field Value

Type: Online String
See Also
ThrottlingService Class
ThrottlingService Members
NFX.Throttling Namespace


ThrottlingService Methods

ThrottlingService Methods NFX Class Library

The ThrottlingService type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Get T | Resolve a typed throttle by name
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterThrottle | Register a throttle with this throttling container
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | UnregisterThrottle | Unregister a throttle from this throttling container
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ThrottlingService Class
NFX.Throttling Namespace


ThrottlingService.Destructor Method

ThrottlingService Destructor Method NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
ThrottlingService Class
ThrottlingService Members
NFX.Throttling Namespace


ThrottlingService.DoConfigure Method

ThrottlingService DoConfigure Method NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
ThrottlingService Class
ThrottlingService Members
NFX.Throttling Namespace


ThrottlingService.DoStart Method

ThrottlingService DoStart Method NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
ThrottlingService Class
ThrottlingService Members
NFX.Throttling Namespace


ThrottlingService.Get(T) Method

ThrottlingService Get T Method NFX Class Library

Resolve a typed throttle by name

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Get<T>(
    string name
)
where T : Throttle
public T Get<T>(
    string name
)
where T : Throttle
Public Function Get(Of T As Throttle) (
    name As String
) As T
Public Function Get(Of T As Throttle) (
    name As String
) As T
public:
generic<typename T>
where T : Throttle
T Get(
    String^ name
)
public:
generic<typename T>
where T : Throttle
T Get(
    String^ name
)
member Get :
        name : string -> 'T  when 'T : Throttle
member Get :
        name : string -> 'T  when 'T : Throttle

Parameters

name
Type: Online System String
Type Parameters
T

Return Value

Type: T
See Also
ThrottlingService Class
ThrottlingService Members
NFX.Throttling Namespace


ThrottlingService.RegisterThrottle Method

ThrottlingService RegisterThrottle Method NFX Class Library

Register a throttle with this throttling container

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RegisterThrottle(
    Throttle throttle
)
public void RegisterThrottle(
    Throttle throttle
)
Public Sub RegisterThrottle (
    throttle As Throttle
)
Public Sub RegisterThrottle (
    throttle As Throttle
)
public:
virtual void RegisterThrottle(
    Throttle^ throttle
) sealed
public:
virtual void RegisterThrottle(
    Throttle^ throttle
) sealed
abstract RegisterThrottle :
        throttle : Throttle -> unit
override RegisterThrottle :
        throttle : Throttle -> unit
abstract RegisterThrottle :
        throttle : Throttle -> unit
override RegisterThrottle :
        throttle : Throttle -> unit

Parameters

throttle
Type: NFX.Throttling Throttle

Implements

IThrottling RegisterThrottle(Throttle)
See Also
ThrottlingService Class
ThrottlingService Members
NFX.Throttling Namespace


ThrottlingService.UnregisterThrottle Method

ThrottlingService UnregisterThrottle Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Unregister a throttle from this throttling container

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnregisterThrottle(
    Throttle throttle
)
public bool UnregisterThrottle(
    Throttle throttle
)
Public Function UnregisterThrottle (
    throttle As Throttle
) As Boolean
Public Function UnregisterThrottle (
    throttle As Throttle
) As Boolean
public:
virtual bool UnregisterThrottle(
    Throttle^ throttle
) sealed
public:
virtual bool UnregisterThrottle(
    Throttle^ throttle
) sealed
abstract UnregisterThrottle :
        throttle : Throttle -> bool
override UnregisterThrottle :
        throttle : Throttle -> bool
abstract UnregisterThrottle :
        throttle : Throttle -> bool
override UnregisterThrottle :
        throttle : Throttle -> bool

Parameters

throttle
Type: NFX.Throttling Throttle

Return Value

Type: Online Boolean
True if throttle was successfully unregistered

Implements

IThrottling UnregisterThrottle(Throttle)
See Also
ThrottlingService Class
ThrottlingService Members
NFX.Throttling Namespace


ThrottlingService Properties

ThrottlingService Properties NFX Class Library

The ThrottlingService type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled |
Public property | Item | Resolve a throttle instance by name
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
ThrottlingService Class
NFX.Throttling Namespace


ThrottlingService.ComponentCommonName Property

ThrottlingService ComponentCommonName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ComponentCommonName { get; }
public override string ComponentCommonName { get; }
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get

Property Value

Type: Online String

Implements

IApplicationComponent ComponentCommonName
IApplicationComponent ComponentCommonName
See Also
ThrottlingService Class
ThrottlingService Members
NFX.Throttling Namespace


ThrottlingService.Enabled Property

ThrottlingService Enabled Property NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Enabled { get; }
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
Public ReadOnly Property Enabled As Boolean
    Get
public:
virtual property bool Enabled {
    bool get () sealed;
}
public:
virtual property bool Enabled {
    bool get () sealed;
}
abstract Enabled : bool with get
override Enabled : bool with get
abstract Enabled : bool with get
override Enabled : bool with get

Property Value

Type: Online Boolean

Implements

IThrottling Enabled
See Also
ThrottlingService Class
ThrottlingService Members
NFX.Throttling Namespace


ThrottlingService.Item Property

ThrottlingService Item Property NFX Class Library

Resolve a throttle instance by name

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IThrottle this[
    string name
] { get; }
public IThrottle this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As IThrottle
    Get
Public ReadOnly Default Property Item (
    name As String
) As IThrottle
    Get
public:
virtual property IThrottle^ default[String^ name] {
    IThrottle^ get (String^ name) sealed;
}
public:
virtual property IThrottle^ default[String^ name] {
    IThrottle^ get (String^ name) sealed;
}
abstract Item : IThrottle with get
override Item : IThrottle with get
abstract Item : IThrottle with get
override Item : IThrottle with get

Parameters

name
Type: Online System String

Property Value

Type: IThrottle

Implements

IThrottling Item String
See Also
ThrottlingService Class
ThrottlingService Members
NFX.Throttling Namespace


TimeSpacingThrottle Class

TimeSpacingThrottle Class NFX Class Library

Throttle based on space reservation in time. It allows at most Limit calls of Try() function per Interval. The calls are assumed to be equally spaced within the Interval
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Throttling Throttle
NFX.Throttling TimeSpacingThrottle

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimeSpacingThrottle : Throttle
public class TimeSpacingThrottle : Throttle
Public Class TimeSpacingThrottle
    Inherits Throttle
Public Class TimeSpacingThrottle
    Inherits Throttle
public ref class TimeSpacingThrottle : public Throttle
public ref class TimeSpacingThrottle : public Throttle
type TimeSpacingThrottle =
    class
        inherit Throttle
    end
type TimeSpacingThrottle =
    class
        inherit Throttle
    end
See Also
TimeSpacingThrottle Members
NFX.Throttling Namespace


TimeSpacingThrottle Members

TimeSpacingThrottle Members NFX Class Library

The TimeSpacingThrottle type exposes the following members.
Constructors
 | Name | Description
Public method | TimeSpacingThrottle | Initializes a new instance of the TimeSpacingThrottle class
Public method | TimeSpacingThrottle(String, Int32, Int32, String) | Constructor
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setThrottling | (Inherited from Throttle.)
Public method | Configure | (Inherited from Throttle.)
Protected method | Destructor | (Overrides Throttle Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Overrides Throttle DoConfigure(IConfigSectionNode).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Register this instance with throttling container (Inherited from Throttle.)
Public method | Reset | Reset the internal state of the throttling strategy (Overrides Throttle Reset .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count (Inherited from Throttle.)
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc. (Inherited from Throttle.)
Protected method | Try(DateTime, Double) | Try to reserve a value of units assuming given time. (Overrides Throttle Try(DateTime, Double).)
Public method | Unregister | Unregister this instance from throttling container (Inherited from Throttle.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Interval | Return throttling interval in seconds
Public property | Limit | Return throttle limit over Interval
Public property | Name | Returns the unique name of this instance (Inherited from Throttle.)
Public property | Throttling | References the Throttling that this instance is registered with (Inherited from Throttle.)
Public property | Unit | Returns the name of unit of measurement for this instance (Inherited from Throttle.)
Back to Top
See Also
TimeSpacingThrottle Class
NFX.Throttling Namespace


TimeSpacingThrottle Constructor

TimeSpacingThrottle Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TimeSpacingThrottle | Initializes a new instance of the TimeSpacingThrottle class
Public method | TimeSpacingThrottle(String, Int32, Int32, String) | Constructor
Back to Top
See Also
TimeSpacingThrottle Class
TimeSpacingThrottle Members
NFX.Throttling Namespace


TimeSpacingThrottle Constructor

TimeSpacingThrottle Constructor NFX Class Library

Initializes a new instance of the TimeSpacingThrottle class

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpacingThrottle()
public TimeSpacingThrottle()
Public Sub New
Public Sub New
public:
TimeSpacingThrottle()
public:
TimeSpacingThrottle()
new : unit -> TimeSpacingThrottle
new : unit -> TimeSpacingThrottle
See Also
TimeSpacingThrottle Class
TimeSpacingThrottle Members
TimeSpacingThrottle Overload
NFX.Throttling Namespace


TimeSpacingThrottle Constructor (String, Int32, Int32, String)

TimeSpacingThrottle Constructor (String, Int32, Int32, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpacingThrottle(
    string name,
    int throttleLimit,
    int throttleInterval = 1,
    string unit = null
)
public TimeSpacingThrottle(
    string name,
    int throttleLimit,
    int throttleInterval = 1,
    string unit = null
)
Public Sub New (
    name As String,
    throttleLimit As Integer,
    Optional throttleInterval As Integer = 1,
    Optional unit As String = Nothing
)
Public Sub New (
    name As String,
    throttleLimit As Integer,
    Optional throttleInterval As Integer = 1,
    Optional unit As String = Nothing
)
public:
TimeSpacingThrottle(
    String^ name,
    int throttleLimit,
    int throttleInterval = 1,
    String^ unit = nullptr
)
public:
TimeSpacingThrottle(
    String^ name,
    int throttleLimit,
    int throttleInterval = 1,
    String^ unit = nullptr
)
new :
        name : string *
        throttleLimit : int *
        ?throttleInterval : int *
        ?unit : string
(* Defaults:
        let _throttleInterval = defaultArg throttleInterval 1
        let _unit = defaultArg unit null
*)
-> TimeSpacingThrottle
new :
        name : string *
        throttleLimit : int *
        ?throttleInterval : int *
        ?unit : string
(* Defaults:
        let _throttleInterval = defaultArg throttleInterval 1
        let _unit = defaultArg unit null
*)
-> TimeSpacingThrottle

Parameters

name
Type: Online System String
Name of this instance
throttleLimit
Type: Online System Int32
Throttling limit per throttleInterval
throttleInterval (Optional)
Type: Online System Int32
Throttling interval in number of seconds
unit (Optional)
Type: Online System String
Unit of measurement
See Also
TimeSpacingThrottle Class
TimeSpacingThrottle Members
TimeSpacingThrottle Overload
NFX.Throttling Namespace


TimeSpacingThrottle Methods

TimeSpacingThrottle Methods NFX Class Library

The TimeSpacingThrottle type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setThrottling | (Inherited from Throttle.)
Public method | Configure | (Inherited from Throttle.)
Protected method | Destructor | (Overrides Throttle Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Overrides Throttle DoConfigure(IConfigSectionNode).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Register this instance with throttling container (Inherited from Throttle.)
Public method | Reset | Reset the internal state of the throttling strategy (Overrides Throttle Reset .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count (Inherited from Throttle.)
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc. (Inherited from Throttle.)
Protected method | Try(DateTime, Double) | Try to reserve a value of units assuming given time. (Overrides Throttle Try(DateTime, Double).)
Public method | Unregister | Unregister this instance from throttling container (Inherited from Throttle.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TimeSpacingThrottle Class
NFX.Throttling Namespace


TimeSpacingThrottle.Destructor Method

TimeSpacingThrottle Destructor Method NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
TimeSpacingThrottle Class
TimeSpacingThrottle Members
NFX.Throttling Namespace


TimeSpacingThrottle.DoConfigure Method

TimeSpacingThrottle DoConfigure Method NFX Class Library

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
TimeSpacingThrottle Class
TimeSpacingThrottle Members
NFX.Throttling Namespace


TimeSpacingThrottle.Reset Method

TimeSpacingThrottle Reset Method NFX Class Library

Reset the internal state of the throttling strategy

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Reset()
public override void Reset()
Public Overrides Sub Reset
Public Overrides Sub Reset
public:
virtual void Reset() override
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IThrottle Reset
See Also
TimeSpacingThrottle Class
TimeSpacingThrottle Members
NFX.Throttling Namespace


TimeSpacingThrottle.Try Method

TimeSpacingThrottle Try Method NFX Class Library

Overload List
 | Name | Description
Public method | Try | Checks whether the current throttle rate limit has not been reached per one unit of measurement. This method is usually used to throttle based on pass count (Inherited from Throttle.)
Public method | Try(Double) | Checks whether the current throttle rate limit has not been reached for the provided value. This method is usually used to throttle based on values like financial amounts, data volumes, user counts, etc. (Inherited from Throttle.)
Protected method | Try(DateTime, Double) | Try to reserve a value of units assuming given time. (Overrides Throttle Try(DateTime, Double).)
Back to Top
See Also
TimeSpacingThrottle Class
TimeSpacingThrottle Members
NFX.Throttling Namespace


TimeSpacingThrottle.Try Method (DateTime, Double)

TimeSpacingThrottle Try Method (DateTime, Double) NFX Class Library

[This is preliminary documentation and is subject to change.]

Try to reserve a value of units assuming given time.

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal override bool Try(
    DateTime time,
    double value
)
internal override bool Try(
    DateTime time,
    double value
)
Friend Overrides Function Try (
    time As DateTime,
    value As Double
) As Boolean
Friend Overrides Function Try (
    time As DateTime,
    value As Double
) As Boolean
internal:
virtual bool Try(
    DateTime time,
    double value
) override
internal:
virtual bool Try(
    DateTime time,
    double value
) override
internal abstract Try :
        time : DateTime *
        value : float -> bool
internal override Try :
        time : DateTime *
        value : float -> bool
internal abstract Try :
        time : DateTime *
        value : float -> bool
internal override Try :
        time : DateTime *
        value : float -> bool

Parameters

time
Type: Online System DateTime
Monotonically increasing time value
value
Type: Online System Double
The value of timeslots needed to reserve

Return Value

Type: Online Boolean
True if reservation is successful
See Also
TimeSpacingThrottle Class
TimeSpacingThrottle Members
Try Overload
NFX.Throttling Namespace


TimeSpacingThrottle Properties

TimeSpacingThrottle Properties NFX Class Library

The TimeSpacingThrottle type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Interval | Return throttling interval in seconds
Public property | Limit | Return throttle limit over Interval
Public property | Name | Returns the unique name of this instance (Inherited from Throttle.)
Public property | Throttling | References the Throttling that this instance is registered with (Inherited from Throttle.)
Public property | Unit | Returns the name of unit of measurement for this instance (Inherited from Throttle.)
Back to Top
See Also
TimeSpacingThrottle Class
NFX.Throttling Namespace


TimeSpacingThrottle.Interval Property

TimeSpacingThrottle Interval Property NFX Class Library

Return throttling interval in seconds

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$interval")]
public int Interval { get; internal set; }
[ConfigAttribute("$interval")]
public int Interval { get; internal set; }
<ConfigAttribute("$interval")>
Public Property Interval As Integer
    Get
    Friend Set
<ConfigAttribute("$interval")>
Public Property Interval As Integer
    Get
    Friend Set
public:
[ConfigAttribute(L"$interval")]
property int Interval {
    int get ();
    internal: void set (int value);
}
public:
[ConfigAttribute(L"$interval")]
property int Interval {
    int get ();
    internal: void set (int value);
}
[<ConfigAttribute("$interval")>]
member Interval : int with get, internal set
[<ConfigAttribute("$interval")>]
member Interval : int with get, internal set

Property Value

Type: Online Int32
See Also
TimeSpacingThrottle Class
TimeSpacingThrottle Members
NFX.Throttling Namespace


TimeSpacingThrottle.Limit Property

TimeSpacingThrottle Limit Property NFX Class Library

Return throttle limit over Interval

Namespace: NFX.Throttling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$limit")]
public double Limit { get; internal set; }
[ConfigAttribute("$limit")]
public double Limit { get; internal set; }
<ConfigAttribute("$limit")>
Public Property Limit As Double
    Get
    Friend Set
<ConfigAttribute("$limit")>
Public Property Limit As Double
    Get
    Friend Set
public:
[ConfigAttribute(L"$limit")]
property double Limit {
    double get ();
    internal: void set (double value);
}
public:
[ConfigAttribute(L"$limit")]
property double Limit {
    double get ();
    internal: void set (double value);
}
[<ConfigAttribute("$limit")>]
member Limit : float with get, internal set
[<ConfigAttribute("$limit")>]
member Limit : float with get, internal set

Property Value

Type: Online Double
See Also
TimeSpacingThrottle Class
TimeSpacingThrottle Members
NFX.Throttling Namespace


NFX.Time Namespace

NFX.Time Namespace NFX Class Library

Facilittates working with time sources
Classes
 | Class | Description
Public class | DaysOfWeekUtils |
Public class | DefaultTimeSource | Provides default time source implementation which is build on DateTime local class
Public class | Event | Represents an event manageable by IEventTimer
Public class | EventTimer | Provides default implementation for IEventTimer
Public class | NOPEventTimer | Normally this class should never be used as the dafult EventTimer is always present instead of nop
Public class | TimeException | Base exception thrown by the Time framework
Public class | TimeLocation | Data about location where time is measured relative to UTC
Public class | WinApi |
Interfaces
 | Interface | Description
Public interface | IEventHandler | Represents an entity that can handle events. This type is used to implement event handlers that get injected via config
Public interface | IEventTimer | Denotes a contract for an app-global event timer - an entity that fires requested events
Public interface | IEventTimerImplementation | Denotes an implementation for an app-global event timer - an entity that fires requested events
Public interface | ILocalizedTimeProvider | Describes an entity that provides the localized time
Public interface | ITimeSource | Denotes app-global time source - an entity that supplies time in this application instance
Public interface | ITimeSourceImplementation | Denotes an implementation for an app-global time source - an entity that supplies time in this application instance
Delegates
 | Delegate | Description
Public delegate | TimerEvent | Delegate type for events that get called when timer fires
Public delegate | TimerEventDefinitionChange | Delegate type for events that get called when one of timer event definition parameters changes
Public delegate | TimerEventStatusChange | Delegate type for events that get called when timer event status changes
Enumerations
 | Enumeration | Description
Public enumeration | DaysOfWeek | Days of week bitmask enumeration
Public enumeration | EventBodyAsyncModel | Defines event body execution asynchrony model
Public enumeration | EventStatus | Denotes statuses that events get transitioned through


DaysOfWeek Enumeration

DaysOfWeek Enumeration NFX Class Library

Days of week bitmask enumeration

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum DaysOfWeek
[FlagsAttribute]
public enum DaysOfWeek
<FlagsAttribute>
Public Enumeration DaysOfWeek
<FlagsAttribute>
Public Enumeration DaysOfWeek
[FlagsAttribute]
public enum class DaysOfWeek
[FlagsAttribute]
public enum class DaysOfWeek
[<FlagsAttribute>]
type DaysOfWeek
[<FlagsAttribute>]
type DaysOfWeek
Members
Member name | Value | Description
None | 0 |
Sun | 1 |
Mon | 2 |
Tue | 4 |
Wed | 8 |
Thu | 16 |
Fri | 32 |
Sat | 64 |
Sunday | 1 |
Monday | 2 |
Tuesday | 4 |
Wednesday | 8 |
Thursday | 16 |
Friday | 32 |
Saturday | 64 |
All | 127 |
See Also
NFX.Time Namespace


DaysOfWeekUtils Class

DaysOfWeekUtils Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Time DaysOfWeekUtils

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class DaysOfWeekUtils
public static class DaysOfWeekUtils
<ExtensionAttribute>
Public NotInheritable Class DaysOfWeekUtils
<ExtensionAttribute>
Public NotInheritable Class DaysOfWeekUtils
[ExtensionAttribute]
public ref class DaysOfWeekUtils abstract sealed
[ExtensionAttribute]
public ref class DaysOfWeekUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DaysOfWeekUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DaysOfWeekUtils =  class end
See Also
DaysOfWeekUtils Members
NFX.Time Namespace


DaysOfWeekUtils Members

DaysOfWeekUtils Members NFX Class Library

The DaysOfWeekUtils type exposes the following members.
Methods
Name | Description
Contains |
Back to Top
See Also
DaysOfWeekUtils Class
NFX.Time Namespace


DaysOfWeekUtils Methods

DaysOfWeekUtils Methods NFX Class Library

The DaysOfWeekUtils type exposes the following members.
Methods
Name | Description
Contains |
Back to Top
See Also
DaysOfWeekUtils Class
NFX.Time Namespace


DaysOfWeekUtils.Contains Method

DaysOfWeekUtils Contains Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool Contains(
    this DaysOfWeek set,
    DayOfWeek day
)
public static bool Contains(
    this DaysOfWeek set,
    DayOfWeek day
)
<ExtensionAttribute>
Public Shared Function Contains (
    set As DaysOfWeek,
    day As DayOfWeek
) As Boolean
<ExtensionAttribute>
Public Shared Function Contains (
    set As DaysOfWeek,
    day As DayOfWeek
) As Boolean
public:
[ExtensionAttribute]
static bool Contains(
    DaysOfWeek set,
    DayOfWeek day
)
public:
[ExtensionAttribute]
static bool Contains(
    DaysOfWeek set,
    DayOfWeek day
)
static member Contains :
        set : DaysOfWeek *
        day : DayOfWeek -> bool
static member Contains :
        set : DaysOfWeek *
        day : DayOfWeek -> bool

Parameters

set
Type: NFX.Time DaysOfWeek
day
Type: Online System DayOfWeek

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DaysOfWeek. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
DaysOfWeekUtils Class
DaysOfWeekUtils Members
NFX.Time Namespace


DefaultTimeSource Class

DefaultTimeSource Class NFX Class Library

Provides default time source implementation which is build on DateTime local class
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Time DefaultTimeSource

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DefaultTimeSource : ApplicationComponent,
    ITimeSourceImplementation, ITimeSource, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable
public class DefaultTimeSource : ApplicationComponent,
    ITimeSourceImplementation, ITimeSource, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable
Public Class DefaultTimeSource
    Inherits ApplicationComponent
    Implements ITimeSourceImplementation, ITimeSource, IApplicationComponent, ILocalizedTimeProvider,
    IDisposable, IConfigurable
Public Class DefaultTimeSource
    Inherits ApplicationComponent
    Implements ITimeSourceImplementation, ITimeSource, IApplicationComponent, ILocalizedTimeProvider,
    IDisposable, IConfigurable
public ref class DefaultTimeSource : public ApplicationComponent,
    ITimeSourceImplementation, ITimeSource, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable
public ref class DefaultTimeSource : public ApplicationComponent,
    ITimeSourceImplementation, ITimeSource, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable
type DefaultTimeSource =
    class
        inherit ApplicationComponent
        interface ITimeSourceImplementation
        interface ITimeSource
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
    end
type DefaultTimeSource =
    class
        inherit ApplicationComponent
        interface ITimeSourceImplementation
        interface ITimeSource
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
    end
See Also
DefaultTimeSource Members
NFX.Time Namespace


DefaultTimeSource Members

DefaultTimeSource Members NFX Class Library

The DefaultTimeSource type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
 | Instance | Returns a singleton DefaultTimeSource instance
Public property | LocalizedTime | Returns current time localized per TimeLocation
Public property | Now |
Public property | TimeLocation |
Public property | UTCNow |
Back to Top
See Also
DefaultTimeSource Class
NFX.Time Namespace


DefaultTimeSource Methods

DefaultTimeSource Methods NFX Class Library

The DefaultTimeSource type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DefaultTimeSource Class
NFX.Time Namespace


DefaultTimeSource.Configure Method

DefaultTimeSource Configure Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
DefaultTimeSource Class
DefaultTimeSource Members
NFX.Time Namespace


DefaultTimeSource.LocalizedTimeToUniversalTime Method

DefaultTimeSource LocalizedTimeToUniversalTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts localized time to UTC time as of TimeLocation property

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime

Parameters

local
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTimeToUniversalTime(DateTime)
See Also
DefaultTimeSource Class
DefaultTimeSource Members
NFX.Time Namespace


DefaultTimeSource.UniversalTimeToLocalizedTime Method

DefaultTimeSource UniversalTimeToLocalizedTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts universal time to local time as of TimeLocation property

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime

Parameters

utc
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider UniversalTimeToLocalizedTime(DateTime)
See Also
DefaultTimeSource Class
DefaultTimeSource Members
NFX.Time Namespace


DefaultTimeSource Properties

DefaultTimeSource Properties NFX Class Library

The DefaultTimeSource type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
 | Instance | Returns a singleton DefaultTimeSource instance
Public property | LocalizedTime | Returns current time localized per TimeLocation
Public property | Now |
Public property | TimeLocation |
Public property | UTCNow |
Back to Top
See Also
DefaultTimeSource Class
NFX.Time Namespace


DefaultTimeSource.Instance Property

DefaultTimeSource Instance Property NFX Class Library

Returns a singleton DefaultTimeSource instance

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DefaultTimeSource Instance { get; }
public static DefaultTimeSource Instance { get; }
Public Shared ReadOnly Property Instance As DefaultTimeSource
    Get
Public Shared ReadOnly Property Instance As DefaultTimeSource
    Get
public:
static property DefaultTimeSource^ Instance {
    DefaultTimeSource^ get ();
}
public:
static property DefaultTimeSource^ Instance {
    DefaultTimeSource^ get ();
}
static member Instance : DefaultTimeSource with get
static member Instance : DefaultTimeSource with get

Property Value

Type: DefaultTimeSource
See Also
DefaultTimeSource Class
DefaultTimeSource Members
NFX.Time Namespace


DefaultTimeSource.LocalizedTime Property

DefaultTimeSource LocalizedTime Property NFX Class Library

Returns current time localized per TimeLocation

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTime { get; }
public DateTime LocalizedTime { get; }
Public ReadOnly Property LocalizedTime As DateTime
    Get
Public ReadOnly Property LocalizedTime As DateTime
    Get
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get

Property Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTime
See Also
DefaultTimeSource Class
DefaultTimeSource Members
NFX.Time Namespace


DefaultTimeSource.Now Property

DefaultTimeSource Now Property NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Now { get; }
public DateTime Now { get; }
Public ReadOnly Property Now As DateTime
    Get
Public ReadOnly Property Now As DateTime
    Get
public:
virtual property DateTime Now {
    DateTime get () sealed;
}
public:
virtual property DateTime Now {
    DateTime get () sealed;
}
abstract Now : DateTime with get
override Now : DateTime with get
abstract Now : DateTime with get
override Now : DateTime with get

Property Value

Type: Online DateTime

Implements

ITimeSource Now
See Also
DefaultTimeSource Class
DefaultTimeSource Members
NFX.Time Namespace


DefaultTimeSource.TimeLocation Property

DefaultTimeSource TimeLocation Property NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeLocation TimeLocation { get; }
public TimeLocation TimeLocation { get; }
Public ReadOnly Property TimeLocation As TimeLocation
    Get
Public ReadOnly Property TimeLocation As TimeLocation
    Get
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
}
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
}
abstract TimeLocation : TimeLocation with get
override TimeLocation : TimeLocation with get
abstract TimeLocation : TimeLocation with get
override TimeLocation : TimeLocation with get

Property Value

Type: TimeLocation

Implements

ILocalizedTimeProvider TimeLocation
See Also
DefaultTimeSource Class
DefaultTimeSource Members
NFX.Time Namespace


DefaultTimeSource.UTCNow Property

DefaultTimeSource UTCNow Property NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime UTCNow { get; }
public DateTime UTCNow { get; }
Public ReadOnly Property UTCNow As DateTime
    Get
Public ReadOnly Property UTCNow As DateTime
    Get
public:
virtual property DateTime UTCNow {
    DateTime get () sealed;
}
public:
virtual property DateTime UTCNow {
    DateTime get () sealed;
}
abstract UTCNow : DateTime with get
override UTCNow : DateTime with get
abstract UTCNow : DateTime with get
override UTCNow : DateTime with get

Property Value

Type: Online DateTime

Implements

ITimeSource UTCNow
See Also
DefaultTimeSource Class
DefaultTimeSource Members
NFX.Time Namespace


Event Class

Event Class NFX Class Library

Represents an event manageable by IEventTimer
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Time Event
NFX.IO.FileSystem DeleteFilesJob

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Event : ApplicationComponent, INamed,
    IExternallyParameterized, IConfigurable, ILocalizedTimeProvider
public class Event : ApplicationComponent, INamed,
    IExternallyParameterized, IConfigurable, ILocalizedTimeProvider
Public Class Event
    Inherits ApplicationComponent
    Implements INamed, IExternallyParameterized, IConfigurable, ILocalizedTimeProvider
Public Class Event
    Inherits ApplicationComponent
    Implements INamed, IExternallyParameterized, IConfigurable, ILocalizedTimeProvider
public ref class Event : public ApplicationComponent,
    INamed, IExternallyParameterized, IConfigurable, ILocalizedTimeProvider
public ref class Event : public ApplicationComponent,
    INamed, IExternallyParameterized, IConfigurable, ILocalizedTimeProvider
type Event =
    class
        inherit ApplicationComponent
        interface INamed
        interface IExternallyParameterized
        interface IConfigurable
        interface ILocalizedTimeProvider
    end
type Event =
    class
        inherit ApplicationComponent
        interface INamed
        interface IExternallyParameterized
        interface IConfigurable
        interface ILocalizedTimeProvider
    end
See Also
Event Members
NFX.Time Namespace


Event Members

Event Members NFX Class Library

The Event type exposes the following members.
Constructors
 | Name | Description
Public method | Event(IEventTimer, IConfigSectionNode) | Initializes a new instance of the Event class
Public method | Event(IEventTimer, String, TimerEvent, Nullable TimeSpan , IConfigSectionNode, EventBodyAsyncModel, Boolean) | Initializes a new instance of the Event class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AdjustDate | Adjusts date time Localized time
Public method | Configure |
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFire |
Protected method | DoHandleError |
Protected method | DoVisit | Override to perform extra status checks
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Fire | Calls event regardless of any constraints. Invokes a handler right away if syncInvoke is true or BodyAsyncModel is Sync, otherwise queues the task on a thread pool either as a regular or long-running task depending on BodyAsyncModel
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResetCallCount | Resets call count counter. If this event has expired it will eventually transition to Started state. Keep in mind that it may expire again if EndDate is set and past due
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property
Protected method | VisitAndCheck | Invoked by timer, checks all conditions and fires/expires event depending on the status. Returns true if event was fired, false otherwise
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_EVENT_SECTION |
 | CONFIG_HANDLER_SECTION |
Public field | EventHandler | References event handler that handles events. If it is null then only delegate events are called
Protected field | m_Lock |
Back to Top
Properties
 | Name | Description
Public property | BodyAsyncModel | Defines how event body should be invoked
Public property | CallCount | Returns how many times this event was called
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Context | Adds arbitrary context object to the event
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled | Specifies whether this event will fire/participate in timer loop
Public property | EndDate | Specifies when this event will stop firing in the local event time
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | Interval | Specifies how often event fires
Public property | LastCall | Returns when was this event called for the last time in the local event time
Public property | LastError | Returns the last exception thrown from event handler or nul if no error happened
Public property | LocalizedTime | Returns current time localized per TimeLocation
Public property | MaxCount | Specifies how many times this event can be called. If less or equal than zero then no limit is set
Public property | Name |
Public property | StartDate | Specifies when this event will start firing in the local event time
Public property | Status |
Public property | TimeLocation | Returns time location that this Event instance operates under.
Public property | Timer |
Back to Top
Events
 | Name | Description
Public event | Body | Event body that gets called when the event is due. The body is always invoked ASYNCHRONOUSLY unless Fire(syncronous=true) is called in which case it gets called on a thread that called Fire(true)
Public event | DefinitionChange | Invoked when one of timer event definition parameters changes. Always called synchronously on the same thread that made a change. Subscribers should not block for long
Public event | StatusChange | Invoked when timer event status changes. Always called synchronously by the timer thread. Subscribers should not block for long
Back to Top
See Also
Event Class
NFX.Time Namespace


Event Constructor

Event Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Event(IEventTimer, IConfigSectionNode) | Initializes a new instance of the Event class
Public method | Event(IEventTimer, String, TimerEvent, Nullable TimeSpan , IConfigSectionNode, EventBodyAsyncModel, Boolean) | Initializes a new instance of the Event class
Back to Top
See Also
Event Class
Event Members
NFX.Time Namespace


Event Constructor (IEventTimer, IConfigSectionNode)

Event Constructor (IEventTimer, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Event class

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Event(
    IEventTimer timer,
    IConfigSectionNode config
)
public Event(
    IEventTimer timer,
    IConfigSectionNode config
)
Public Sub New (
    timer As IEventTimer,
    config As IConfigSectionNode
)
Public Sub New (
    timer As IEventTimer,
    config As IConfigSectionNode
)
public:
Event(
    IEventTimer^ timer,
    IConfigSectionNode^ config
)
public:
Event(
    IEventTimer^ timer,
    IConfigSectionNode^ config
)
new :
        timer : IEventTimer *
        config : IConfigSectionNode -> Event
new :
        timer : IEventTimer *
        config : IConfigSectionNode -> Event

Parameters

timer
Type: NFX.Time IEventTimer
config
Type: NFX.Environment IConfigSectionNode
See Also
Event Class
Event Members
Event Overload
NFX.Time Namespace


Event Constructor (IEventTimer, String, TimerEvent, Nullable(TimeSpan), IConfigSectionNode, EventBodyAsyncModel, Boolean)

Event Constructor (IEventTimer, String, TimerEvent, Nullable TimeSpan , IConfigSectionNode, EventBodyAsyncModel, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Event class

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Event(
    IEventTimer timer,
    string name = null,
    TimerEvent body = null,
    Nullable<TimeSpan> interval = null,
    IConfigSectionNode config = null,
    EventBodyAsyncModel bodyAsyncModel = EventBodyAsyncModel.AsyncTask,
    bool enabled = true
)
public Event(
    IEventTimer timer,
    string name = null,
    TimerEvent body = null,
    Nullable<TimeSpan> interval = null,
    IConfigSectionNode config = null,
    EventBodyAsyncModel bodyAsyncModel = EventBodyAsyncModel.AsyncTask,
    bool enabled = true
)
Public Sub New (
    timer As IEventTimer,
    Optional name As String = Nothing,
    Optional body As TimerEvent = Nothing,
    Optional interval As Nullable(Of TimeSpan) = Nothing,
    Optional config As IConfigSectionNode = Nothing,
    Optional bodyAsyncModel As EventBodyAsyncModel = EventBodyAsyncModel.AsyncTask,
    Optional enabled As Boolean = true
)
Public Sub New (
    timer As IEventTimer,
    Optional name As String = Nothing,
    Optional body As TimerEvent = Nothing,
    Optional interval As Nullable(Of TimeSpan) = Nothing,
    Optional config As IConfigSectionNode = Nothing,
    Optional bodyAsyncModel As EventBodyAsyncModel = EventBodyAsyncModel.AsyncTask,
    Optional enabled As Boolean = true
)
public:
Event(
    IEventTimer^ timer,
    String^ name = nullptr,
    TimerEvent^ body = nullptr,
    Nullable<TimeSpan> interval = nullptr,
    IConfigSectionNode^ config = nullptr,
    EventBodyAsyncModel bodyAsyncModel = EventBodyAsyncModel::AsyncTask,
    bool enabled = true
)
public:
Event(
    IEventTimer^ timer,
    String^ name = nullptr,
    TimerEvent^ body = nullptr,
    Nullable<TimeSpan> interval = nullptr,
    IConfigSectionNode^ config = nullptr,
    EventBodyAsyncModel bodyAsyncModel = EventBodyAsyncModel::AsyncTask,
    bool enabled = true
)
new :
        timer : IEventTimer *
        ?name : string *
        ?body : TimerEvent *
        ?interval : Nullable<TimeSpan> *
        ?config : IConfigSectionNode *
        ?bodyAsyncModel : EventBodyAsyncModel *
        ?enabled : bool
(* Defaults:
        let _name = defaultArg name null
        let _body = defaultArg body null
        let _interval = defaultArg interval null
        let _config = defaultArg config null
        let _bodyAsyncModel = defaultArg bodyAsyncModel EventBodyAsyncModel.AsyncTask
        let _enabled = defaultArg enabled true
*)
-> Event
new :
        timer : IEventTimer *
        ?name : string *
        ?body : TimerEvent *
        ?interval : Nullable<TimeSpan> *
        ?config : IConfigSectionNode *
        ?bodyAsyncModel : EventBodyAsyncModel *
        ?enabled : bool
(* Defaults:
        let _name = defaultArg name null
        let _body = defaultArg body null
        let _interval = defaultArg interval null
        let _config = defaultArg config null
        let _bodyAsyncModel = defaultArg bodyAsyncModel EventBodyAsyncModel.AsyncTask
        let _enabled = defaultArg enabled true
*)
-> Event

Parameters

timer
Type: NFX.Time IEventTimer
name (Optional)
Type: Online System String
body (Optional)
Type: NFX.Time TimerEvent
interval (Optional)
Type: Online System Nullable Online TimeSpan
config (Optional)
Type: NFX.Environment IConfigSectionNode
bodyAsyncModel (Optional)
Type: NFX.Time EventBodyAsyncModel
enabled (Optional)
Type: Online System Boolean
See Also
Event Class
Event Members
Event Overload
NFX.Time Namespace


Event Fields

Event Fields NFX Class Library

The Event type exposes the following members.
Fields
 | Name | Description
 | CONFIG_EVENT_SECTION |
 | CONFIG_HANDLER_SECTION |
Public field | EventHandler | References event handler that handles events. If it is null then only delegate events are called
Protected field | m_Lock |
Back to Top
See Also
Event Class
NFX.Time Namespace


Event.CONFIG_EVENT_SECTION Field

Event CONFIG_EVENT_SECTION Field NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_EVENT_SECTION
public const string CONFIG_EVENT_SECTION
Public Const CONFIG_EVENT_SECTION As String
Public Const CONFIG_EVENT_SECTION As String
public:
literal String^ CONFIG_EVENT_SECTION
public:
literal String^ CONFIG_EVENT_SECTION
static val mutable CONFIG_EVENT_SECTION: string
static val mutable CONFIG_EVENT_SECTION: string

Field Value

Type: Online String
See Also
Event Class
Event Members
NFX.Time Namespace


Event.CONFIG_HANDLER_SECTION Field

Event CONFIG_HANDLER_SECTION Field NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_HANDLER_SECTION
public const string CONFIG_HANDLER_SECTION
Public Const CONFIG_HANDLER_SECTION As String
Public Const CONFIG_HANDLER_SECTION As String
public:
literal String^ CONFIG_HANDLER_SECTION
public:
literal String^ CONFIG_HANDLER_SECTION
static val mutable CONFIG_HANDLER_SECTION: string
static val mutable CONFIG_HANDLER_SECTION: string

Field Value

Type: Online String
See Also
Event Class
Event Members
NFX.Time Namespace


Event.EventHandler Field

Event EventHandler Field NFX Class Library

References event handler that handles events. If it is null then only delegate events are called

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEventHandler EventHandler
public IEventHandler EventHandler
Public EventHandler As IEventHandler
Public EventHandler As IEventHandler
public:
IEventHandler^ EventHandler
public:
IEventHandler^ EventHandler
val mutable EventHandler: IEventHandler
val mutable EventHandler: IEventHandler

Field Value

Type: IEventHandler
See Also
Event Class
Event Members
NFX.Time Namespace


Event.m_Lock Field

Event m_Lock Field NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly Object m_Lock
protected readonly Object m_Lock
Protected ReadOnly m_Lock As Object
Protected ReadOnly m_Lock As Object
protected:
initonly Object^ m_Lock
protected:
initonly Object^ m_Lock
val m_Lock: Object
val m_Lock: Object

Field Value

Type: Online Object
See Also
Event Class
Event Members
NFX.Time Namespace


Event Methods

Event Methods NFX Class Library

The Event type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AdjustDate | Adjusts date time Localized time
Public method | Configure |
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFire |
Protected method | DoHandleError |
Protected method | DoVisit | Override to perform extra status checks
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Fire | Calls event regardless of any constraints. Invokes a handler right away if syncInvoke is true or BodyAsyncModel is Sync, otherwise queues the task on a thread pool either as a regular or long-running task depending on BodyAsyncModel
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResetCallCount | Resets call count counter. If this event has expired it will eventually transition to Started state. Keep in mind that it may expire again if EndDate is set and past due
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property
Protected method | VisitAndCheck | Invoked by timer, checks all conditions and fires/expires event depending on the status. Returns true if event was fired, false otherwise
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Event Class
NFX.Time Namespace


Event.AdjustDate Method

Event AdjustDate Method NFX Class Library

Adjusts date time Localized time

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Nullable<DateTime> AdjustDate(
    Nullable<DateTime> date
)
protected Nullable<DateTime> AdjustDate(
    Nullable<DateTime> date
)
Protected Function AdjustDate (
    date As Nullable(Of DateTime)
) As Nullable(Of DateTime)
Protected Function AdjustDate (
    date As Nullable(Of DateTime)
) As Nullable(Of DateTime)
protected:
Nullable<DateTime> AdjustDate(
    Nullable<DateTime> date
)
protected:
Nullable<DateTime> AdjustDate(
    Nullable<DateTime> date
)
member AdjustDate :
        date : Nullable<DateTime> -> Nullable<DateTime>
member AdjustDate :
        date : Nullable<DateTime> -> Nullable<DateTime>

Parameters

date
Type: Online System Nullable Online DateTime

Return Value

Type: Online Nullable Online DateTime
See Also
Event Class
Event Members
NFX.Time Namespace


Event.Configure Method

Event Configure Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Configure(
    IConfigSectionNode config
)
public virtual void Configure(
    IConfigSectionNode config
)
Public Overridable Sub Configure (
    config As IConfigSectionNode
)
Public Overridable Sub Configure (
    config As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ config
)
public:
virtual void Configure(
    IConfigSectionNode^ config
)
abstract Configure :
        config : IConfigSectionNode -> unit
override Configure :
        config : IConfigSectionNode -> unit
abstract Configure :
        config : IConfigSectionNode -> unit
override Configure :
        config : IConfigSectionNode -> unit

Parameters

config
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
Event Class
Event Members
NFX.Time Namespace


Event.Destructor Method

Event Destructor Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Event Class
Event Members
NFX.Time Namespace


Event.DoFire Method

Event DoFire Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoFire()
protected virtual void DoFire()
Protected Overridable Sub DoFire
Protected Overridable Sub DoFire
protected:
virtual void DoFire()
protected:
virtual void DoFire()
abstract DoFire : unit -> unit
override DoFire : unit -> unit
abstract DoFire : unit -> unit
override DoFire : unit -> unit
See Also
Event Class
Event Members
NFX.Time Namespace


Event.DoHandleError Method

Event DoHandleError Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoHandleError(
    Exception error
)
protected virtual void DoHandleError(
    Exception error
)
Protected Overridable Sub DoHandleError (
    error As Exception
)
Protected Overridable Sub DoHandleError (
    error As Exception
)
protected:
virtual void DoHandleError(
    Exception^ error
)
protected:
virtual void DoHandleError(
    Exception^ error
)
abstract DoHandleError :
        error : Exception -> unit
override DoHandleError :
        error : Exception -> unit
abstract DoHandleError :
        error : Exception -> unit
override DoHandleError :
        error : Exception -> unit

Parameters

error
Type: Online System Exception
See Also
Event Class
Event Members
NFX.Time Namespace


Event.DoVisit Method

Event DoVisit Method NFX Class Library

Override to perform extra status checks

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool DoVisit(
    DateTime localNow
)
protected virtual bool DoVisit(
    DateTime localNow
)
Protected Overridable Function DoVisit (
    localNow As DateTime
) As Boolean
Protected Overridable Function DoVisit (
    localNow As DateTime
) As Boolean
protected:
virtual bool DoVisit(
    DateTime localNow
)
protected:
virtual bool DoVisit(
    DateTime localNow
)
abstract DoVisit :
        localNow : DateTime -> bool
override DoVisit :
        localNow : DateTime -> bool
abstract DoVisit :
        localNow : DateTime -> bool
override DoVisit :
        localNow : DateTime -> bool

Parameters

localNow
Type: Online System DateTime

Return Value

Type: Online Boolean
See Also
Event Class
Event Members
NFX.Time Namespace


Event.ExternalGetParameter Method

Event ExternalGetParameter Method NFX Class Library

Gets external parameter value returning true if parameter was found

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
Event Class
Event Members
NFX.Time Namespace


Event.ExternalParametersForGroups Method

Event ExternalParametersForGroups Method NFX Class Library

Returns named parameters that can be used to control this component

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
Event Class
Event Members
NFX.Time Namespace


Event.ExternalSetParameter Method

Event ExternalSetParameter Method NFX Class Library

Sets external parameter value returning true if parameter was found and set

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
Event Class
Event Members
NFX.Time Namespace


Event.Fire Method

Event Fire Method NFX Class Library

Calls event regardless of any constraints. Invokes a handler right away if syncInvoke is true or BodyAsyncModel is Sync, otherwise queues the task on a thread pool either as a regular or long-running task depending on BodyAsyncModel

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Fire(
    bool syncInvoke = false
)
public void Fire(
    bool syncInvoke = false
)
Public Sub Fire (
    Optional syncInvoke As Boolean = false
)
Public Sub Fire (
    Optional syncInvoke As Boolean = false
)
public:
void Fire(
    bool syncInvoke = false
)
public:
void Fire(
    bool syncInvoke = false
)
member Fire :
        ?syncInvoke : bool
(* Defaults:
        let _syncInvoke = defaultArg syncInvoke false
*)
-> unit
member Fire :
        ?syncInvoke : bool
(* Defaults:
        let _syncInvoke = defaultArg syncInvoke false
*)
-> unit

Parameters

syncInvoke (Optional)
Type: Online System Boolean
See Also
Event Class
Event Members
NFX.Time Namespace


Event.LocalizedTimeToUniversalTime Method

Event LocalizedTimeToUniversalTime Method NFX Class Library

Converts localized time to UTC time as of TimeLocation property

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime

Parameters

local
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTimeToUniversalTime(DateTime)
See Also
Event Class
Event Members
NFX.Time Namespace


Event.ResetCallCount Method

Event ResetCallCount Method NFX Class Library

Resets call count counter. If this event has expired it will eventually transition to Started state. Keep in mind that it may expire again if EndDate is set and past due

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ResetCallCount()
public void ResetCallCount()
Public Sub ResetCallCount
Public Sub ResetCallCount
public:
void ResetCallCount()
public:
void ResetCallCount()
member ResetCallCount : unit -> unit
member ResetCallCount : unit -> unit
See Also
Event Class
Event Members
NFX.Time Namespace


Event.UniversalTimeToLocalizedTime Method

Event UniversalTimeToLocalizedTime Method NFX Class Library

Converts universal time to local time as of TimeLocation property

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime

Parameters

utc
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider UniversalTimeToLocalizedTime(DateTime)
See Also
Event Class
Event Members
NFX.Time Namespace


Event.VisitAndCheck Method

Event VisitAndCheck Method NFX Class Library

Invoked by timer, checks all conditions and fires/expires event depending on the status. Returns true if event was fired, false otherwise

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal bool VisitAndCheck(
    DateTime utcNow
)
protected internal bool VisitAndCheck(
    DateTime utcNow
)
Protected Friend Function VisitAndCheck (
    utcNow As DateTime
) As Boolean
Protected Friend Function VisitAndCheck (
    utcNow As DateTime
) As Boolean
protected public:
bool VisitAndCheck(
    DateTime utcNow
)
protected public:
bool VisitAndCheck(
    DateTime utcNow
)
member VisitAndCheck :
        utcNow : DateTime -> bool
member VisitAndCheck :
        utcNow : DateTime -> bool

Parameters

utcNow
Type: Online System DateTime

Return Value

Type: Online Boolean
See Also
Event Class
Event Members
NFX.Time Namespace


Event Properties

Event Properties NFX Class Library

The Event type exposes the following members.
Properties
 | Name | Description
Public property | BodyAsyncModel | Defines how event body should be invoked
Public property | CallCount | Returns how many times this event was called
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Context | Adds arbitrary context object to the event
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled | Specifies whether this event will fire/participate in timer loop
Public property | EndDate | Specifies when this event will stop firing in the local event time
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | Interval | Specifies how often event fires
Public property | LastCall | Returns when was this event called for the last time in the local event time
Public property | LastError | Returns the last exception thrown from event handler or nul if no error happened
Public property | LocalizedTime | Returns current time localized per TimeLocation
Public property | MaxCount | Specifies how many times this event can be called. If less or equal than zero then no limit is set
Public property | Name |
Public property | StartDate | Specifies when this event will start firing in the local event time
Public property | Status |
Public property | TimeLocation | Returns time location that this Event instance operates under.
Public property | Timer |
Back to Top
See Also
Event Class
NFX.Time Namespace


Event.BodyAsyncModel Property

Event BodyAsyncModel Property NFX Class Library

Defines how event body should be invoked

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute]
public virtual EventBodyAsyncModel BodyAsyncModel { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute]
public virtual EventBodyAsyncModel BodyAsyncModel { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute>
Public Overridable Property BodyAsyncModel As EventBodyAsyncModel
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute>
Public Overridable Property BodyAsyncModel As EventBodyAsyncModel
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute]
virtual property EventBodyAsyncModel BodyAsyncModel {
    EventBodyAsyncModel get ();
    void set (EventBodyAsyncModel value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute]
virtual property EventBodyAsyncModel BodyAsyncModel {
    EventBodyAsyncModel get ();
    void set (EventBodyAsyncModel value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
abstract BodyAsyncModel : EventBodyAsyncModel with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
override BodyAsyncModel : EventBodyAsyncModel with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
abstract BodyAsyncModel : EventBodyAsyncModel with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
override BodyAsyncModel : EventBodyAsyncModel with get, set

Property Value

Type: EventBodyAsyncModel
See Also
Event Class
Event Members
NFX.Time Namespace


Event.CallCount Property

Event CallCount Property NFX Class Library

Returns how many times this event was called

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CallCount { get; }
public int CallCount { get; }
Public ReadOnly Property CallCount As Integer
    Get
Public ReadOnly Property CallCount As Integer
    Get
public:
property int CallCount {
    int get ();
}
public:
property int CallCount {
    int get ();
}
member CallCount : int with get
member CallCount : int with get

Property Value

Type: Online Int32
See Also
Event Class
Event Members
NFX.Time Namespace


Event.Context Property

Event Context Property NFX Class Library

Adds arbitrary context object to the event

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public Object Context { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public Object Context { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property Context As Object
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property Context As Object
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Object^ Context {
    Object^ get ();
    void set (Object^ value);
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Object^ Context {
    Object^ get ();
    void set (Object^ value);
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member Context : Object with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member Context : Object with get, set

Property Value

Type: Online Object
See Also
Event Class
Event Members
NFX.Time Namespace


Event.Enabled Property

Event Enabled Property NFX Class Library

Specifies whether this event will fire/participate in timer loop

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public bool Enabled { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public bool Enabled { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property Enabled As Boolean
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property Enabled As Boolean
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool Enabled {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member Enabled : bool with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member Enabled : bool with get, set

Property Value

Type: Online Boolean
See Also
Event Class
Event Members
NFX.Time Namespace


Event.EndDate Property

Event EndDate Property NFX Class Library

Specifies when this event will stop firing in the local event time

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<DateTime> EndDate { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<DateTime> EndDate { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property EndDate As Nullable(Of DateTime)
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property EndDate As Nullable(Of DateTime)
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<DateTime> EndDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<DateTime> EndDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member EndDate : Nullable<DateTime> with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member EndDate : Nullable<DateTime> with get, set

Property Value

Type: Online Nullable Online DateTime
See Also
Event Class
Event Members
NFX.Time Namespace


Event.ExternalParameters Property

Event ExternalParameters Property NFX Class Library

Returns named parameters that can be used to control this component

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
Event Class
Event Members
NFX.Time Namespace


Event.Interval Property

Event Interval Property NFX Class Library

Specifies how often event fires

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public TimeSpan Interval { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public TimeSpan Interval { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property Interval As TimeSpan
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property Interval As TimeSpan
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property TimeSpan Interval {
    TimeSpan get ();
    void set (TimeSpan value);
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property TimeSpan Interval {
    TimeSpan get ();
    void set (TimeSpan value);
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member Interval : TimeSpan with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member Interval : TimeSpan with get, set

Property Value

Type: Online TimeSpan
See Also
Event Class
Event Members
NFX.Time Namespace


Event.LastCall Property

Event LastCall Property NFX Class Library

Returns when was this event called for the last time in the local event time

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LastCall { get; }
public DateTime LastCall { get; }
Public ReadOnly Property LastCall As DateTime
    Get
Public ReadOnly Property LastCall As DateTime
    Get
public:
property DateTime LastCall {
    DateTime get ();
}
public:
property DateTime LastCall {
    DateTime get ();
}
member LastCall : DateTime with get
member LastCall : DateTime with get

Property Value

Type: Online DateTime
See Also
Event Class
Event Members
NFX.Time Namespace


Event.LastError Property

Event LastError Property NFX Class Library

Returns the last exception thrown from event handler or nul if no error happened

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception LastError { get; }
public Exception LastError { get; }
Public ReadOnly Property LastError As Exception
    Get
Public ReadOnly Property LastError As Exception
    Get
public:
property Exception^ LastError {
    Exception^ get ();
}
public:
property Exception^ LastError {
    Exception^ get ();
}
member LastError : Exception with get
member LastError : Exception with get

Property Value

Type: Online Exception
See Also
Event Class
Event Members
NFX.Time Namespace


Event.LocalizedTime Property

Event LocalizedTime Property NFX Class Library

Returns current time localized per TimeLocation

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTime { get; }
public DateTime LocalizedTime { get; }
Public ReadOnly Property LocalizedTime As DateTime
    Get
Public ReadOnly Property LocalizedTime As DateTime
    Get
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get

Property Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTime
See Also
Event Class
Event Members
NFX.Time Namespace


Event.MaxCount Property

Event MaxCount Property NFX Class Library

Specifies how many times this event can be called. If less or equal than zero then no limit is set

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public int MaxCount { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public int MaxCount { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property MaxCount As Integer
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property MaxCount As Integer
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int MaxCount {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int MaxCount {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member MaxCount : int with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member MaxCount : int with get, set

Property Value

Type: Online Int32
See Also
Event Class
Event Members
NFX.Time Namespace


Event.Name Property

Event Name Property NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Event Class
Event Members
NFX.Time Namespace


Event.StartDate Property

Event StartDate Property NFX Class Library

Specifies when this event will start firing in the local event time

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<DateTime> StartDate { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<DateTime> StartDate { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property StartDate As Nullable(Of DateTime)
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property StartDate As Nullable(Of DateTime)
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<DateTime> StartDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<DateTime> StartDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member StartDate : Nullable<DateTime> with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member StartDate : Nullable<DateTime> with get, set

Property Value

Type: Online Nullable Online DateTime
See Also
Event Class
Event Members
NFX.Time Namespace


Event.Status Property

Event Status Property NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventStatus Status { get; }
public EventStatus Status { get; }
Public ReadOnly Property Status As EventStatus
    Get
Public ReadOnly Property Status As EventStatus
    Get
public:
property EventStatus Status {
    EventStatus get ();
}
public:
property EventStatus Status {
    EventStatus get ();
}
member Status : EventStatus with get
member Status : EventStatus with get

Property Value

Type: EventStatus
See Also
Event Class
Event Members
NFX.Time Namespace


Event.TimeLocation Property

Event TimeLocation Property NFX Class Library

Returns time location that this Event instance operates under.

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeLocation TimeLocation { get; set; }
public TimeLocation TimeLocation { get; set; }
Public Property TimeLocation As TimeLocation
    Get
    Set
Public Property TimeLocation As TimeLocation
    Get
    Set
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
    void set (TimeLocation^ value) sealed;
}
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
    void set (TimeLocation^ value) sealed;
}
abstract TimeLocation : TimeLocation with get, set
override TimeLocation : TimeLocation with get, set
abstract TimeLocation : TimeLocation with get, set
override TimeLocation : TimeLocation with get, set

Property Value

Type: TimeLocation

Implements

ILocalizedTimeProvider TimeLocation
See Also
Event Class
Event Members
NFX.Time Namespace


Event.Timer Property

Event Timer Property NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEventTimer Timer { get; }
public IEventTimer Timer { get; }
Public ReadOnly Property Timer As IEventTimer
    Get
Public ReadOnly Property Timer As IEventTimer
    Get
public:
property IEventTimer^ Timer {
    IEventTimer^ get ();
}
public:
property IEventTimer^ Timer {
    IEventTimer^ get ();
}
member Timer : IEventTimer with get
member Timer : IEventTimer with get

Property Value

Type: IEventTimer
See Also
Event Class
Event Members
NFX.Time Namespace


Event Events

Event Events NFX Class Library

The Event type exposes the following members.
Events
 | Name | Description
Public event | Body | Event body that gets called when the event is due. The body is always invoked ASYNCHRONOUSLY unless Fire(syncronous=true) is called in which case it gets called on a thread that called Fire(true)
Public event | DefinitionChange | Invoked when one of timer event definition parameters changes. Always called synchronously on the same thread that made a change. Subscribers should not block for long
Public event | StatusChange | Invoked when timer event status changes. Always called synchronously by the timer thread. Subscribers should not block for long
Back to Top
See Also
Event Class
NFX.Time Namespace


Event.Body Event

Event Body Event NFX Class Library

Event body that gets called when the event is due. The body is always invoked ASYNCHRONOUSLY unless Fire(syncronous=true) is called in which case it gets called on a thread that called Fire(true)

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event TimerEvent Body
public event TimerEvent Body
Public Event Body As TimerEvent
Public Event Body As TimerEvent
public:
 event TimerEvent^ Body {
    void add (TimerEvent^ value);
    void remove (TimerEvent^ value);
}
public:
 event TimerEvent^ Body {
    void add (TimerEvent^ value);
    void remove (TimerEvent^ value);
}
member Body : IEvent<TimerEvent,
    EventArgs>
member Body : IEvent<TimerEvent,
    EventArgs>

Value

Type: NFX.Time TimerEvent
See Also
Event Class
Event Members
NFX.Time Namespace


Event.DefinitionChange Event

Event DefinitionChange Event NFX Class Library

Invoked when one of timer event definition parameters changes. Always called synchronously on the same thread that made a change. Subscribers should not block for long

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event TimerEventDefinitionChange DefinitionChange
public event TimerEventDefinitionChange DefinitionChange
Public Event DefinitionChange As TimerEventDefinitionChange
Public Event DefinitionChange As TimerEventDefinitionChange
public:
 event TimerEventDefinitionChange^ DefinitionChange {
    void add (TimerEventDefinitionChange^ value);
    void remove (TimerEventDefinitionChange^ value);
}
public:
 event TimerEventDefinitionChange^ DefinitionChange {
    void add (TimerEventDefinitionChange^ value);
    void remove (TimerEventDefinitionChange^ value);
}
member DefinitionChange : IEvent<TimerEventDefinitionChange,
    EventArgs>
member DefinitionChange : IEvent<TimerEventDefinitionChange,
    EventArgs>

Value

Type: NFX.Time TimerEventDefinitionChange
See Also
Event Class
Event Members
NFX.Time Namespace


Event.StatusChange Event

Event StatusChange Event NFX Class Library

Invoked when timer event status changes. Always called synchronously by the timer thread. Subscribers should not block for long

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event TimerEventStatusChange StatusChange
public event TimerEventStatusChange StatusChange
Public Event StatusChange As TimerEventStatusChange
Public Event StatusChange As TimerEventStatusChange
public:
 event TimerEventStatusChange^ StatusChange {
    void add (TimerEventStatusChange^ value);
    void remove (TimerEventStatusChange^ value);
}
public:
 event TimerEventStatusChange^ StatusChange {
    void add (TimerEventStatusChange^ value);
    void remove (TimerEventStatusChange^ value);
}
member StatusChange : IEvent<TimerEventStatusChange,
    EventArgs>
member StatusChange : IEvent<TimerEventStatusChange,
    EventArgs>

Value

Type: NFX.Time TimerEventStatusChange
See Also
Event Class
Event Members
NFX.Time Namespace


EventBodyAsyncModel Enumeration

EventBodyAsyncModel Enumeration NFX Class Library

Defines event body execution asynchrony model

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum EventBodyAsyncModel
public enum EventBodyAsyncModel
Public Enumeration EventBodyAsyncModel
Public Enumeration EventBodyAsyncModel
public enum class EventBodyAsyncModel
public enum class EventBodyAsyncModel
type EventBodyAsyncModel
type EventBodyAsyncModel
Members
Member name | Value | Description
AsyncTask | 0 | The body should be called as a short-lived (less than 1 sec) task
LongRunningAsyncTask | 1 | The body should be called as a long-runnig task. The system may dedicate it a thread. Use this ONLY for events that fire infrequently (i.e. once every X minutes+) and take long time to execute (seconds+)
Sync | 2 | ADVANCED FEATURE. Run task synchronously on the timer thread. Use this option ONLY if the task body is very short (less than 10 ms). In most cases do not use this option as event body blocks the whole global application timer thread
See Also
NFX.Time Namespace


EventStatus Enumeration

EventStatus Enumeration NFX Class Library

Denotes statuses that events get transitioned through

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum EventStatus
public enum EventStatus
Public Enumeration EventStatus
Public Enumeration EventStatus
public enum class EventStatus
public enum class EventStatus
type EventStatus
type EventStatus
Members
Member name | Value | Description
NotStarted | 0 |
Started | 1 |
Expired | 2 |
Invalid | 3 |
See Also
NFX.Time Namespace


EventTimer Class

EventTimer Class NFX Class Library

Provides default implementation for IEventTimer
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Online Object
NFX.ServiceModel ServiceWithInstrumentationBase Online Object
NFX.Time EventTimer

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class EventTimer : ServiceWithInstrumentationBase<Object>,
    IEventTimerImplementation, IEventTimer, IApplicationComponent, IInstrumentable, IExternallyParameterized,
    IDisposable, IConfigurable
public sealed class EventTimer : ServiceWithInstrumentationBase<Object>,
    IEventTimerImplementation, IEventTimer, IApplicationComponent, IInstrumentable, IExternallyParameterized,
    IDisposable, IConfigurable
Public NotInheritable Class EventTimer
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements IEventTimerImplementation, IEventTimer, IApplicationComponent, IInstrumentable,
    IExternallyParameterized, IDisposable, IConfigurable
Public NotInheritable Class EventTimer
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements IEventTimerImplementation, IEventTimer, IApplicationComponent, IInstrumentable,
    IExternallyParameterized, IDisposable, IConfigurable
public ref class EventTimer sealed : public ServiceWithInstrumentationBase<Object^>,
    IEventTimerImplementation, IEventTimer, IApplicationComponent, IInstrumentable, IExternallyParameterized,
    IDisposable, IConfigurable
public ref class EventTimer sealed : public ServiceWithInstrumentationBase<Object^>,
    IEventTimerImplementation, IEventTimer, IApplicationComponent, IInstrumentable, IExternallyParameterized,
    IDisposable, IConfigurable
[<SealedAttribute>]
type EventTimer =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface IEventTimerImplementation
        interface IEventTimer
        interface IApplicationComponent
        interface IInstrumentable
        interface IExternallyParameterized
        interface IDisposable
        interface IConfigurable
    end
[<SealedAttribute>]
type EventTimer =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface IEventTimerImplementation
        interface IEventTimer
        interface IApplicationComponent
        interface IInstrumentable
        interface IExternallyParameterized
        interface IDisposable
        interface IConfigurable
    end
See Also
EventTimer Members
NFX.Time Namespace


EventTimer Members

EventTimer Members NFX Class Library

The EventTimer type exposes the following members.
Constructors
 | Name | Description
Public method | EventTimer | Initializes a new instance of the EventTimer class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
DEFAULT_RESOLUTION_MS |
MAX_RESOLUTION_MS |
MIN_RESOLUTION_MS |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Events | Lists all events in the instance
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | ResolutionMs | Timer resolution in milliseconds
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEventTimerImplementation __InternalRegisterEvent |
Explicit interface implemetation | IEventTimerImplementation __InternalUnRegisterEvent |
Back to Top
See Also
EventTimer Class
NFX.Time Namespace


EventTimer Constructor

EventTimer Constructor NFX Class Library

Initializes a new instance of the EventTimer class

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventTimer()
public EventTimer()
Public Sub New
Public Sub New
public:
EventTimer()
public:
EventTimer()
new : unit -> EventTimer
new : unit -> EventTimer
See Also
EventTimer Class
EventTimer Members
NFX.Time Namespace


EventTimer Fields

EventTimer Fields NFX Class Library

The EventTimer type exposes the following members.
Fields
Name | Description
DEFAULT_RESOLUTION_MS |
MAX_RESOLUTION_MS |
MIN_RESOLUTION_MS |
Back to Top
See Also
EventTimer Class
NFX.Time Namespace


EventTimer.DEFAULT_RESOLUTION_MS Field

EventTimer DEFAULT_RESOLUTION_MS Field NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_RESOLUTION_MS
public const int DEFAULT_RESOLUTION_MS
Public Const DEFAULT_RESOLUTION_MS As Integer
Public Const DEFAULT_RESOLUTION_MS As Integer
public:
literal int DEFAULT_RESOLUTION_MS
public:
literal int DEFAULT_RESOLUTION_MS
static val mutable DEFAULT_RESOLUTION_MS: int
static val mutable DEFAULT_RESOLUTION_MS: int

Field Value

Type: Online Int32
See Also
EventTimer Class
EventTimer Members
NFX.Time Namespace


EventTimer.MAX_RESOLUTION_MS Field

EventTimer MAX_RESOLUTION_MS Field NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_RESOLUTION_MS
public const int MAX_RESOLUTION_MS
Public Const MAX_RESOLUTION_MS As Integer
Public Const MAX_RESOLUTION_MS As Integer
public:
literal int MAX_RESOLUTION_MS
public:
literal int MAX_RESOLUTION_MS
static val mutable MAX_RESOLUTION_MS: int
static val mutable MAX_RESOLUTION_MS: int

Field Value

Type: Online Int32
See Also
EventTimer Class
EventTimer Members
NFX.Time Namespace


EventTimer.MIN_RESOLUTION_MS Field

EventTimer MIN_RESOLUTION_MS Field NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MIN_RESOLUTION_MS
public const int MIN_RESOLUTION_MS
Public Const MIN_RESOLUTION_MS As Integer
Public Const MIN_RESOLUTION_MS As Integer
public:
literal int MIN_RESOLUTION_MS
public:
literal int MIN_RESOLUTION_MS
static val mutable MIN_RESOLUTION_MS: int
static val mutable MIN_RESOLUTION_MS: int

Field Value

Type: Online Int32
See Also
EventTimer Class
EventTimer Members
NFX.Time Namespace


EventTimer Methods

EventTimer Methods NFX Class Library

The EventTimer type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEventTimerImplementation __InternalRegisterEvent |
Explicit interface implemetation | IEventTimerImplementation __InternalUnRegisterEvent |
Back to Top
See Also
EventTimer Class
NFX.Time Namespace


EventTimer.DoConfigure Method

EventTimer DoConfigure Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
EventTimer Class
EventTimer Members
NFX.Time Namespace


EventTimer.DoStart Method

EventTimer DoStart Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
EventTimer Class
EventTimer Members
NFX.Time Namespace


EventTimer.DoWaitForCompleteStop Method

EventTimer DoWaitForCompleteStop Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
EventTimer Class
EventTimer Members
NFX.Time Namespace


EventTimer.IEventTimerImplementation.__InternalRegisterEvent Method

EventTimer IEventTimerImplementation __InternalRegisterEvent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IEventTimerImplementation.__InternalRegisterEvent(
    Event evt
)
void IEventTimerImplementation.__InternalRegisterEvent(
    Event evt
)
Private Sub __InternalRegisterEvent (
    evt As Event
) Implements IEventTimerImplementation.__InternalRegisterEvent
Private Sub __InternalRegisterEvent (
    evt As Event
) Implements IEventTimerImplementation.__InternalRegisterEvent
private:
virtual void __InternalRegisterEvent(
    Event^ evt
) sealed = IEventTimerImplementation::__InternalRegisterEvent
private:
virtual void __InternalRegisterEvent(
    Event^ evt
) sealed = IEventTimerImplementation::__InternalRegisterEvent
private abstract __InternalRegisterEvent :
        evt : Event -> unit
private override __InternalRegisterEvent :
        evt : Event -> unit
private abstract __InternalRegisterEvent :
        evt : Event -> unit
private override __InternalRegisterEvent :
        evt : Event -> unit

Parameters

evt
Type: NFX.Time Event

Implements

IEventTimerImplementation __InternalRegisterEvent(Event)
See Also
EventTimer Class
EventTimer Members
NFX.Time Namespace


EventTimer.IEventTimerImplementation.__InternalUnRegisterEvent Method

EventTimer IEventTimerImplementation __InternalUnRegisterEvent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IEventTimerImplementation.__InternalUnRegisterEvent(
    Event evt
)
void IEventTimerImplementation.__InternalUnRegisterEvent(
    Event evt
)
Private Sub __InternalUnRegisterEvent (
    evt As Event
) Implements IEventTimerImplementation.__InternalUnRegisterEvent
Private Sub __InternalUnRegisterEvent (
    evt As Event
) Implements IEventTimerImplementation.__InternalUnRegisterEvent
private:
virtual void __InternalUnRegisterEvent(
    Event^ evt
) sealed = IEventTimerImplementation::__InternalUnRegisterEvent
private:
virtual void __InternalUnRegisterEvent(
    Event^ evt
) sealed = IEventTimerImplementation::__InternalUnRegisterEvent
private abstract __InternalUnRegisterEvent :
        evt : Event -> unit
private override __InternalUnRegisterEvent :
        evt : Event -> unit
private abstract __InternalUnRegisterEvent :
        evt : Event -> unit
private override __InternalUnRegisterEvent :
        evt : Event -> unit

Parameters

evt
Type: NFX.Time Event

Implements

IEventTimerImplementation __InternalUnRegisterEvent(Event)
See Also
EventTimer Class
EventTimer Members
NFX.Time Namespace


EventTimer Properties

EventTimer Properties NFX Class Library

The EventTimer type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Events | Lists all events in the instance
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | ResolutionMs | Timer resolution in milliseconds
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
EventTimer Class
NFX.Time Namespace


EventTimer.Events Property

EventTimer Events Property NFX Class Library

Lists all events in the instance

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<Event> Events { get; }
public IRegistry<Event> Events { get; }
Public ReadOnly Property Events As IRegistry(Of Event)
    Get
Public ReadOnly Property Events As IRegistry(Of Event)
    Get
public:
virtual property IRegistry<Event^>^ Events {
    IRegistry<Event^>^ get () sealed;
}
public:
virtual property IRegistry<Event^>^ Events {
    IRegistry<Event^>^ get () sealed;
}
abstract Events : IRegistry<Event> with get
override Events : IRegistry<Event> with get
abstract Events : IRegistry<Event> with get
override Events : IRegistry<Event> with get

Property Value

Type: IRegistry Event

Implements

IEventTimer Events
See Also
EventTimer Class
EventTimer Members
NFX.Time Namespace


EventTimer.InstrumentationEnabled Property

EventTimer InstrumentationEnabled Property NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
IInstrumentable InstrumentationEnabled
See Also
EventTimer Class
EventTimer Members
NFX.Time Namespace


EventTimer.ResolutionMs Property

EventTimer ResolutionMs Property NFX Class Library

Timer resolution in milliseconds

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public int ResolutionMs { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public int ResolutionMs { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property ResolutionMs As Integer
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property ResolutionMs As Integer
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property int ResolutionMs {
    int get () sealed;
    void set (int value) sealed;
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property int ResolutionMs {
    int get () sealed;
    void set (int value) sealed;
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract ResolutionMs : int with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
override ResolutionMs : int with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract ResolutionMs : int with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
override ResolutionMs : int with get, set

Property Value

Type: Online Int32

Implements

IEventTimerImplementation ResolutionMs
IEventTimer ResolutionMs
See Also
EventTimer Class
EventTimer Members
NFX.Time Namespace


IEventHandler Interface

IEventHandler Interface NFX Class Library

Represents an entity that can handle events. This type is used to implement event handlers that get injected via config

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IEventHandler
public interface IEventHandler
Public Interface IEventHandler
Public Interface IEventHandler
public interface class IEventHandler
public interface class IEventHandler
type IEventHandler =  interface end
type IEventHandler =  interface end
See Also
IEventHandler Members
NFX.Time Namespace


IEventHandler Members

IEventHandler Members NFX Class Library

The IEventHandler type exposes the following members.
Methods
 | Name | Description
Public method | EventDefinitionChange |
Public method | EventHandlerBody |
Public method | EventStatusChange |
Back to Top
See Also
IEventHandler Interface
NFX.Time Namespace


IEventHandler Methods

IEventHandler Methods NFX Class Library

The IEventHandler type exposes the following members.
Methods
 | Name | Description
Public method | EventDefinitionChange |
Public method | EventHandlerBody |
Public method | EventStatusChange |
Back to Top
See Also
IEventHandler Interface
NFX.Time Namespace


IEventHandler.EventDefinitionChange Method

IEventHandler EventDefinitionChange Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void EventDefinitionChange(
    Event sender,
    string parameterName
)
void EventDefinitionChange(
    Event sender,
    string parameterName
)
Sub EventDefinitionChange (
    sender As Event,
    parameterName As String
)
Sub EventDefinitionChange (
    sender As Event,
    parameterName As String
)
void EventDefinitionChange(
    Event^ sender,
    String^ parameterName
)
void EventDefinitionChange(
    Event^ sender,
    String^ parameterName
)
abstract EventDefinitionChange :
        sender : Event *
        parameterName : string -> unit
abstract EventDefinitionChange :
        sender : Event *
        parameterName : string -> unit

Parameters

sender
Type: NFX.Time Event
parameterName
Type: Online System String
See Also
IEventHandler Interface
IEventHandler Members
NFX.Time Namespace


IEventHandler.EventHandlerBody Method

IEventHandler EventHandlerBody Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void EventHandlerBody(
    Event sender
)
void EventHandlerBody(
    Event sender
)
Sub EventHandlerBody (
    sender As Event
)
Sub EventHandlerBody (
    sender As Event
)
void EventHandlerBody(
    Event^ sender
)
void EventHandlerBody(
    Event^ sender
)
abstract EventHandlerBody :
        sender : Event -> unit
abstract EventHandlerBody :
        sender : Event -> unit

Parameters

sender
Type: NFX.Time Event
See Also
IEventHandler Interface
IEventHandler Members
NFX.Time Namespace


IEventHandler.EventStatusChange Method

IEventHandler EventStatusChange Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void EventStatusChange(
    Event sender,
    EventStatus priorStatus
)
void EventStatusChange(
    Event sender,
    EventStatus priorStatus
)
Sub EventStatusChange (
    sender As Event,
    priorStatus As EventStatus
)
Sub EventStatusChange (
    sender As Event,
    priorStatus As EventStatus
)
void EventStatusChange(
    Event^ sender,
    EventStatus priorStatus
)
void EventStatusChange(
    Event^ sender,
    EventStatus priorStatus
)
abstract EventStatusChange :
        sender : Event *
        priorStatus : EventStatus -> unit
abstract EventStatusChange :
        sender : Event *
        priorStatus : EventStatus -> unit

Parameters

sender
Type: NFX.Time Event
priorStatus
Type: NFX.Time EventStatus
See Also
IEventHandler Interface
IEventHandler Members
NFX.Time Namespace


IEventTimer Interface

IEventTimer Interface NFX Class Library

Denotes a contract for an app-global event timer - an entity that fires requested events

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IEventTimer : IApplicationComponent,
    IDisposable, IInstrumentable, IExternallyParameterized
public interface IEventTimer : IApplicationComponent,
    IDisposable, IInstrumentable, IExternallyParameterized
Public Interface IEventTimer
    Inherits IApplicationComponent, IDisposable, IInstrumentable, IExternallyParameterized
Public Interface IEventTimer
    Inherits IApplicationComponent, IDisposable, IInstrumentable, IExternallyParameterized
public interface class IEventTimer : IApplicationComponent,
    IDisposable, IInstrumentable, IExternallyParameterized
public interface class IEventTimer : IApplicationComponent,
    IDisposable, IInstrumentable, IExternallyParameterized
type IEventTimer =
    interface
        interface IApplicationComponent
        interface IDisposable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type IEventTimer =
    interface
        interface IApplicationComponent
        interface IDisposable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
IEventTimer Members
NFX.Time Namespace


IEventTimer Members

IEventTimer Members NFX Class Library

The IEventTimer type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Events | Lists all events in the instance
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | ResolutionMs | Gets the granularity of event firing resolution
Back to Top
See Also
IEventTimer Interface
NFX.Time Namespace


IEventTimer Methods

IEventTimer Methods NFX Class Library

The IEventTimer type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Back to Top
See Also
IEventTimer Interface
NFX.Time Namespace


IEventTimer Properties

IEventTimer Properties NFX Class Library

The IEventTimer type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Events | Lists all events in the instance
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | ResolutionMs | Gets the granularity of event firing resolution
Back to Top
See Also
IEventTimer Interface
NFX.Time Namespace


IEventTimer.Events Property

IEventTimer Events Property NFX Class Library

Lists all events in the instance

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IRegistry<Event> Events { get; }
IRegistry<Event> Events { get; }
ReadOnly Property Events As IRegistry(Of Event)
    Get
ReadOnly Property Events As IRegistry(Of Event)
    Get
property IRegistry<Event^>^ Events {
    IRegistry<Event^>^ get ();
}
property IRegistry<Event^>^ Events {
    IRegistry<Event^>^ get ();
}
abstract Events : IRegistry<Event> with get
abstract Events : IRegistry<Event> with get

Property Value

Type: IRegistry Event
See Also
IEventTimer Interface
IEventTimer Members
NFX.Time Namespace


IEventTimer.ResolutionMs Property

IEventTimer ResolutionMs Property NFX Class Library

Gets the granularity of event firing resolution

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ResolutionMs { get; }
int ResolutionMs { get; }
ReadOnly Property ResolutionMs As Integer
    Get
ReadOnly Property ResolutionMs As Integer
    Get
property int ResolutionMs {
    int get ();
}
property int ResolutionMs {
    int get ();
}
abstract ResolutionMs : int with get
abstract ResolutionMs : int with get

Property Value

Type: Online Int32
See Also
IEventTimer Interface
IEventTimer Members
NFX.Time Namespace


IEventTimerImplementation Interface

IEventTimerImplementation Interface NFX Class Library

Denotes an implementation for an app-global event timer - an entity that fires requested events

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IEventTimerImplementation : IEventTimer,
    IApplicationComponent, IInstrumentable, IExternallyParameterized, IDisposable, IConfigurable
public interface IEventTimerImplementation : IEventTimer,
    IApplicationComponent, IInstrumentable, IExternallyParameterized, IDisposable, IConfigurable
Public Interface IEventTimerImplementation
    Inherits IEventTimer, IApplicationComponent, IInstrumentable, IExternallyParameterized,
    IDisposable, IConfigurable
Public Interface IEventTimerImplementation
    Inherits IEventTimer, IApplicationComponent, IInstrumentable, IExternallyParameterized,
    IDisposable, IConfigurable
public interface class IEventTimerImplementation : IEventTimer,
    IApplicationComponent, IInstrumentable, IExternallyParameterized, IDisposable, IConfigurable
public interface class IEventTimerImplementation : IEventTimer,
    IApplicationComponent, IInstrumentable, IExternallyParameterized, IDisposable, IConfigurable
type IEventTimerImplementation =
    interface
        interface IEventTimer
        interface IApplicationComponent
        interface IInstrumentable
        interface IExternallyParameterized
        interface IDisposable
        interface IConfigurable
    end
type IEventTimerImplementation =
    interface
        interface IEventTimer
        interface IApplicationComponent
        interface IInstrumentable
        interface IExternallyParameterized
        interface IDisposable
        interface IConfigurable
    end
See Also
IEventTimerImplementation Members
NFX.Time Namespace


IEventTimerImplementation Members

IEventTimerImplementation Members NFX Class Library

The IEventTimerImplementation type exposes the following members.
Methods
 | Name | Description
Public method | __InternalRegisterEvent | Internall call, developers - do not call
Public method | __InternalUnRegisterEvent | Internall call, developers - do not call
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Events | Lists all events in the instance (Inherited from IEventTimer.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | ResolutionMs | Gets the granularity of event firing resolution (Inherited from IEventTimer.)
Public property | ResolutionMs |
Back to Top
See Also
IEventTimerImplementation Interface
NFX.Time Namespace


IEventTimerImplementation Methods

IEventTimerImplementation Methods NFX Class Library

The IEventTimerImplementation type exposes the following members.
Methods
 | Name | Description
Public method | __InternalRegisterEvent | Internall call, developers - do not call
Public method | __InternalUnRegisterEvent | Internall call, developers - do not call
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Back to Top
See Also
IEventTimerImplementation Interface
NFX.Time Namespace


IEventTimerImplementation.__InternalRegisterEvent Method

IEventTimerImplementation __InternalRegisterEvent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Internall call, developers - do not call

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void __InternalRegisterEvent(
    Event evt
)
void __InternalRegisterEvent(
    Event evt
)
Sub __InternalRegisterEvent (
    evt As Event
)
Sub __InternalRegisterEvent (
    evt As Event
)
void __InternalRegisterEvent(
    Event^ evt
)
void __InternalRegisterEvent(
    Event^ evt
)
abstract __InternalRegisterEvent :
        evt : Event -> unit
abstract __InternalRegisterEvent :
        evt : Event -> unit

Parameters

evt
Type: NFX.Time Event
See Also
IEventTimerImplementation Interface
IEventTimerImplementation Members
NFX.Time Namespace


IEventTimerImplementation.__InternalUnRegisterEvent Method

IEventTimerImplementation __InternalUnRegisterEvent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Internall call, developers - do not call

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void __InternalUnRegisterEvent(
    Event evt
)
void __InternalUnRegisterEvent(
    Event evt
)
Sub __InternalUnRegisterEvent (
    evt As Event
)
Sub __InternalUnRegisterEvent (
    evt As Event
)
void __InternalUnRegisterEvent(
    Event^ evt
)
void __InternalUnRegisterEvent(
    Event^ evt
)
abstract __InternalUnRegisterEvent :
        evt : Event -> unit
abstract __InternalUnRegisterEvent :
        evt : Event -> unit

Parameters

evt
Type: NFX.Time Event
See Also
IEventTimerImplementation Interface
IEventTimerImplementation Members
NFX.Time Namespace


IEventTimerImplementation Properties

IEventTimerImplementation Properties NFX Class Library

The IEventTimerImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Events | Lists all events in the instance (Inherited from IEventTimer.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | ResolutionMs | Gets the granularity of event firing resolution (Inherited from IEventTimer.)
Public property | ResolutionMs |
Back to Top
See Also
IEventTimerImplementation Interface
NFX.Time Namespace


IEventTimerImplementation.ResolutionMs Property

IEventTimerImplementation ResolutionMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public property | ResolutionMs | Gets the granularity of event firing resolution (Inherited from IEventTimer.)
Public property | ResolutionMs |
Back to Top
See Also
IEventTimerImplementation Interface
IEventTimerImplementation Members
NFX.Time Namespace


IEventTimerImplementation.ResolutionMs Property

IEventTimerImplementation ResolutionMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ResolutionMs { get; set; }
int ResolutionMs { get; set; }
Property ResolutionMs As Integer
    Get
    Set
Property ResolutionMs As Integer
    Get
    Set
property int ResolutionMs {
    int get ();
    void set (int value);
}
property int ResolutionMs {
    int get ();
    void set (int value);
}
abstract ResolutionMs : int with get, set
abstract ResolutionMs : int with get, set

Property Value

Type: Online Int32

Implements

IEventTimer ResolutionMs
See Also
IEventTimerImplementation Interface
IEventTimerImplementation Members
ResolutionMs Overload
NFX.Time Namespace


ILocalizedTimeProvider Interface

ILocalizedTimeProvider Interface NFX Class Library

Describes an entity that provides the localized time

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILocalizedTimeProvider
public interface ILocalizedTimeProvider
Public Interface ILocalizedTimeProvider
Public Interface ILocalizedTimeProvider
public interface class ILocalizedTimeProvider
public interface class ILocalizedTimeProvider
type ILocalizedTimeProvider =  interface end
type ILocalizedTimeProvider =  interface end
See Also
ILocalizedTimeProvider Members
NFX.Time Namespace


ILocalizedTimeProvider Members

ILocalizedTimeProvider Members NFX Class Library

The ILocalizedTimeProvider type exposes the following members.
Methods
 | Name | Description
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property
Back to Top
Properties
 | Name | Description
Public property | LocalizedTime | Returns current time localized per TimeLocation
Public property | TimeLocation | Returns the location
Back to Top
See Also
ILocalizedTimeProvider Interface
NFX.Time Namespace


ILocalizedTimeProvider Methods

ILocalizedTimeProvider Methods NFX Class Library

The ILocalizedTimeProvider type exposes the following members.
Methods
 | Name | Description
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property
Back to Top
See Also
ILocalizedTimeProvider Interface
NFX.Time Namespace


ILocalizedTimeProvider.LocalizedTimeToUniversalTime Method

ILocalizedTimeProvider LocalizedTimeToUniversalTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts localized time to UTC time as of TimeLocation property

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime

Parameters

local
Type: Online System DateTime

Return Value

Type: Online DateTime
See Also
ILocalizedTimeProvider Interface
ILocalizedTimeProvider Members
NFX.Time Namespace


ILocalizedTimeProvider.UniversalTimeToLocalizedTime Method

ILocalizedTimeProvider UniversalTimeToLocalizedTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts universal time to local time as of TimeLocation property

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime

Parameters

utc
Type: Online System DateTime

Return Value

Type: Online DateTime
See Also
ILocalizedTimeProvider Interface
ILocalizedTimeProvider Members
NFX.Time Namespace


ILocalizedTimeProvider Properties

ILocalizedTimeProvider Properties NFX Class Library

The ILocalizedTimeProvider type exposes the following members.
Properties
 | Name | Description
Public property | LocalizedTime | Returns current time localized per TimeLocation
Public property | TimeLocation | Returns the location
Back to Top
See Also
ILocalizedTimeProvider Interface
NFX.Time Namespace


ILocalizedTimeProvider.LocalizedTime Property

ILocalizedTimeProvider LocalizedTime Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns current time localized per TimeLocation

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
DateTime LocalizedTime { get; }
DateTime LocalizedTime { get; }
ReadOnly Property LocalizedTime As DateTime
    Get
ReadOnly Property LocalizedTime As DateTime
    Get
property DateTime LocalizedTime {
    DateTime get ();
}
property DateTime LocalizedTime {
    DateTime get ();
}
abstract LocalizedTime : DateTime with get
abstract LocalizedTime : DateTime with get

Property Value

Type: Online DateTime
See Also
ILocalizedTimeProvider Interface
ILocalizedTimeProvider Members
NFX.Time Namespace


ILocalizedTimeProvider.TimeLocation Property

ILocalizedTimeProvider TimeLocation Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the location

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TimeLocation TimeLocation { get; }
TimeLocation TimeLocation { get; }
ReadOnly Property TimeLocation As TimeLocation
    Get
ReadOnly Property TimeLocation As TimeLocation
    Get
property TimeLocation^ TimeLocation {
    TimeLocation^ get ();
}
property TimeLocation^ TimeLocation {
    TimeLocation^ get ();
}
abstract TimeLocation : TimeLocation with get
abstract TimeLocation : TimeLocation with get

Property Value

Type: TimeLocation
See Also
ILocalizedTimeProvider Interface
ILocalizedTimeProvider Members
NFX.Time Namespace


ITimeSource Interface

ITimeSource Interface NFX Class Library

Denotes app-global time source - an entity that supplies time in this application instance

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITimeSource : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
public interface ITimeSource : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
Public Interface ITimeSource
    Inherits IApplicationComponent, IDisposable, ILocalizedTimeProvider
Public Interface ITimeSource
    Inherits IApplicationComponent, IDisposable, ILocalizedTimeProvider
public interface class ITimeSource : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
public interface class ITimeSource : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
type ITimeSource =
    interface
        interface IApplicationComponent
        interface IDisposable
        interface ILocalizedTimeProvider
    end
type ITimeSource =
    interface
        interface IApplicationComponent
        interface IDisposable
        interface ILocalizedTimeProvider
    end
See Also
ITimeSource Members
NFX.Time Namespace


ITimeSource Members

ITimeSource Members NFX Class Library

The ITimeSource type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | Now | Returns local time stamp, Alias to this.LocalizedTime
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Public property | UTCNow | Returns current UTC time stamp
Back to Top
See Also
ITimeSource Interface
NFX.Time Namespace


ITimeSource Methods

ITimeSource Methods NFX Class Library

The ITimeSource type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
ITimeSource Interface
NFX.Time Namespace


ITimeSource Properties

ITimeSource Properties NFX Class Library

The ITimeSource type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | Now | Returns local time stamp, Alias to this.LocalizedTime
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Public property | UTCNow | Returns current UTC time stamp
Back to Top
See Also
ITimeSource Interface
NFX.Time Namespace


ITimeSource.Now Property

ITimeSource Now Property NFX Class Library

Returns local time stamp, Alias to this.LocalizedTime

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
DateTime Now { get; }
DateTime Now { get; }
ReadOnly Property Now As DateTime
    Get
ReadOnly Property Now As DateTime
    Get
property DateTime Now {
    DateTime get ();
}
property DateTime Now {
    DateTime get ();
}
abstract Now : DateTime with get
abstract Now : DateTime with get

Property Value

Type: Online DateTime
See Also
ITimeSource Interface
ITimeSource Members
NFX.Time Namespace


ITimeSource.UTCNow Property

ITimeSource UTCNow Property NFX Class Library

Returns current UTC time stamp

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
DateTime UTCNow { get; }
DateTime UTCNow { get; }
ReadOnly Property UTCNow As DateTime
    Get
ReadOnly Property UTCNow As DateTime
    Get
property DateTime UTCNow {
    DateTime get ();
}
property DateTime UTCNow {
    DateTime get ();
}
abstract UTCNow : DateTime with get
abstract UTCNow : DateTime with get

Property Value

Type: Online DateTime
See Also
ITimeSource Interface
ITimeSource Members
NFX.Time Namespace


ITimeSourceImplementation Interface

ITimeSourceImplementation Interface NFX Class Library

Denotes an implementation for an app-global time source - an entity that supplies time in this application instance

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITimeSourceImplementation : ITimeSource,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable
public interface ITimeSourceImplementation : ITimeSource,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable
Public Interface ITimeSourceImplementation
    Inherits ITimeSource, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable
Public Interface ITimeSourceImplementation
    Inherits ITimeSource, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable
public interface class ITimeSourceImplementation : ITimeSource,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable
public interface class ITimeSourceImplementation : ITimeSource,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable
type ITimeSourceImplementation =
    interface
        interface ITimeSource
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
    end
type ITimeSourceImplementation =
    interface
        interface ITimeSource
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
    end
See Also
ITimeSourceImplementation Members
NFX.Time Namespace


ITimeSourceImplementation Members

ITimeSourceImplementation Members NFX Class Library

The ITimeSourceImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | Now | Returns local time stamp, Alias to this.LocalizedTime (Inherited from ITimeSource.)
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Public property | UTCNow | Returns current UTC time stamp (Inherited from ITimeSource.)
Back to Top
See Also
ITimeSourceImplementation Interface
NFX.Time Namespace


ITimeSourceImplementation Methods

ITimeSourceImplementation Methods NFX Class Library

The ITimeSourceImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
ITimeSourceImplementation Interface
NFX.Time Namespace


ITimeSourceImplementation Properties

ITimeSourceImplementation Properties NFX Class Library

The ITimeSourceImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | Now | Returns local time stamp, Alias to this.LocalizedTime (Inherited from ITimeSource.)
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Public property | UTCNow | Returns current UTC time stamp (Inherited from ITimeSource.)
Back to Top
See Also
ITimeSourceImplementation Interface
NFX.Time Namespace


NOPEventTimer Class

NOPEventTimer Class NFX Class Library

Normally this class should never be used as the dafult EventTimer is always present instead of nop
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Time NOPEventTimer

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NOPEventTimer : ApplicationComponent,
    IEventTimerImplementation, IEventTimer, IApplicationComponent, IInstrumentable, IExternallyParameterized,
    IDisposable, IConfigurable
public sealed class NOPEventTimer : ApplicationComponent,
    IEventTimerImplementation, IEventTimer, IApplicationComponent, IInstrumentable, IExternallyParameterized,
    IDisposable, IConfigurable
Public NotInheritable Class NOPEventTimer
    Inherits ApplicationComponent
    Implements IEventTimerImplementation, IEventTimer, IApplicationComponent, IInstrumentable,
    IExternallyParameterized, IDisposable, IConfigurable
Public NotInheritable Class NOPEventTimer
    Inherits ApplicationComponent
    Implements IEventTimerImplementation, IEventTimer, IApplicationComponent, IInstrumentable,
    IExternallyParameterized, IDisposable, IConfigurable
public ref class NOPEventTimer sealed : public ApplicationComponent,
    IEventTimerImplementation, IEventTimer, IApplicationComponent, IInstrumentable, IExternallyParameterized,
    IDisposable, IConfigurable
public ref class NOPEventTimer sealed : public ApplicationComponent,
    IEventTimerImplementation, IEventTimer, IApplicationComponent, IInstrumentable, IExternallyParameterized,
    IDisposable, IConfigurable
[<SealedAttribute>]
type NOPEventTimer =
    class
        inherit ApplicationComponent
        interface IEventTimerImplementation
        interface IEventTimer
        interface IApplicationComponent
        interface IInstrumentable
        interface IExternallyParameterized
        interface IDisposable
        interface IConfigurable
    end
[<SealedAttribute>]
type NOPEventTimer =
    class
        inherit ApplicationComponent
        interface IEventTimerImplementation
        interface IEventTimer
        interface IApplicationComponent
        interface IInstrumentable
        interface IExternallyParameterized
        interface IDisposable
        interface IConfigurable
    end
See Also
NOPEventTimer Members
NFX.Time Namespace


NOPEventTimer Members

NOPEventTimer Members NFX Class Library

The NOPEventTimer type exposes the following members.
Constructors
 | Name | Description
Public method | NOPEventTimer | Initializes a new instance of the NOPEventTimer class
Back to Top
Methods
 | Name | Description
Public method | __InternalRegisterEvent |
Public method | __InternalUnRegisterEvent |
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter |
Public method | ExternalParametersForGroups |
Public method | ExternalSetParameter |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Events |
Public property | ExternalParameters |
 | Instance |
Public property | InstrumentationEnabled |
Public property | ResolutionMs |
Back to Top
See Also
NOPEventTimer Class
NFX.Time Namespace


NOPEventTimer Constructor

NOPEventTimer Constructor NFX Class Library

Initializes a new instance of the NOPEventTimer class

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NOPEventTimer()
public NOPEventTimer()
Public Sub New
Public Sub New
public:
NOPEventTimer()
public:
NOPEventTimer()
new : unit -> NOPEventTimer
new : unit -> NOPEventTimer
See Also
NOPEventTimer Class
NOPEventTimer Members
NFX.Time Namespace


NOPEventTimer Methods

NOPEventTimer Methods NFX Class Library

The NOPEventTimer type exposes the following members.
Methods
 | Name | Description
Public method | __InternalRegisterEvent |
Public method | __InternalUnRegisterEvent |
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter |
Public method | ExternalParametersForGroups |
Public method | ExternalSetParameter |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPEventTimer Class
NFX.Time Namespace


NOPEventTimer.__InternalRegisterEvent Method

NOPEventTimer __InternalRegisterEvent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void __InternalRegisterEvent(
    Event evt
)
public void __InternalRegisterEvent(
    Event evt
)
Public Sub __InternalRegisterEvent (
    evt As Event
)
Public Sub __InternalRegisterEvent (
    evt As Event
)
public:
virtual void __InternalRegisterEvent(
    Event^ evt
) sealed
public:
virtual void __InternalRegisterEvent(
    Event^ evt
) sealed
abstract __InternalRegisterEvent :
        evt : Event -> unit
override __InternalRegisterEvent :
        evt : Event -> unit
abstract __InternalRegisterEvent :
        evt : Event -> unit
override __InternalRegisterEvent :
        evt : Event -> unit

Parameters

evt
Type: NFX.Time Event

Implements

IEventTimerImplementation __InternalRegisterEvent(Event)
See Also
NOPEventTimer Class
NOPEventTimer Members
NFX.Time Namespace


NOPEventTimer.__InternalUnRegisterEvent Method

NOPEventTimer __InternalUnRegisterEvent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void __InternalUnRegisterEvent(
    Event evt
)
public void __InternalUnRegisterEvent(
    Event evt
)
Public Sub __InternalUnRegisterEvent (
    evt As Event
)
Public Sub __InternalUnRegisterEvent (
    evt As Event
)
public:
virtual void __InternalUnRegisterEvent(
    Event^ evt
) sealed
public:
virtual void __InternalUnRegisterEvent(
    Event^ evt
) sealed
abstract __InternalUnRegisterEvent :
        evt : Event -> unit
override __InternalUnRegisterEvent :
        evt : Event -> unit
abstract __InternalUnRegisterEvent :
        evt : Event -> unit
override __InternalUnRegisterEvent :
        evt : Event -> unit

Parameters

evt
Type: NFX.Time Event

Implements

IEventTimerImplementation __InternalUnRegisterEvent(Event)
See Also
NOPEventTimer Class
NOPEventTimer Members
NFX.Time Namespace


NOPEventTimer.Configure Method

NOPEventTimer Configure Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
NOPEventTimer Class
NOPEventTimer Members
NFX.Time Namespace


NOPEventTimer.ExternalGetParameter Method

NOPEventTimer ExternalGetParameter Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
NOPEventTimer Class
NOPEventTimer Members
NFX.Time Namespace


NOPEventTimer.ExternalParametersForGroups Method

NOPEventTimer ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
NOPEventTimer Class
NOPEventTimer Members
NFX.Time Namespace


NOPEventTimer.ExternalSetParameter Method

NOPEventTimer ExternalSetParameter Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
NOPEventTimer Class
NOPEventTimer Members
NFX.Time Namespace


NOPEventTimer Properties

NOPEventTimer Properties NFX Class Library

The NOPEventTimer type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Events |
Public property | ExternalParameters |
 | Instance |
Public property | InstrumentationEnabled |
Public property | ResolutionMs |
Back to Top
See Also
NOPEventTimer Class
NFX.Time Namespace


NOPEventTimer.Events Property

NOPEventTimer Events Property NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<Event> Events { get; }
public IRegistry<Event> Events { get; }
Public ReadOnly Property Events As IRegistry(Of Event)
    Get
Public ReadOnly Property Events As IRegistry(Of Event)
    Get
public:
virtual property IRegistry<Event^>^ Events {
    IRegistry<Event^>^ get () sealed;
}
public:
virtual property IRegistry<Event^>^ Events {
    IRegistry<Event^>^ get () sealed;
}
abstract Events : IRegistry<Event> with get
override Events : IRegistry<Event> with get
abstract Events : IRegistry<Event> with get
override Events : IRegistry<Event> with get

Property Value

Type: IRegistry Event

Implements

IEventTimer Events
See Also
NOPEventTimer Class
NOPEventTimer Members
NFX.Time Namespace


NOPEventTimer.ExternalParameters Property

NOPEventTimer ExternalParameters Property NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
NOPEventTimer Class
NOPEventTimer Members
NFX.Time Namespace


NOPEventTimer.Instance Property

NOPEventTimer Instance Property NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NOPEventTimer Instance { get; }
public static NOPEventTimer Instance { get; }
Public Shared ReadOnly Property Instance As NOPEventTimer
    Get
Public Shared ReadOnly Property Instance As NOPEventTimer
    Get
public:
static property NOPEventTimer^ Instance {
    NOPEventTimer^ get ();
}
public:
static property NOPEventTimer^ Instance {
    NOPEventTimer^ get ();
}
static member Instance : NOPEventTimer with get
static member Instance : NOPEventTimer with get

Property Value

Type: NOPEventTimer
See Also
NOPEventTimer Class
NOPEventTimer Members
NFX.Time Namespace


NOPEventTimer.InstrumentationEnabled Property

NOPEventTimer InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool InstrumentationEnabled { get; set; }
public bool InstrumentationEnabled { get; set; }
Public Property InstrumentationEnabled As Boolean
    Get
    Set
Public Property InstrumentationEnabled As Boolean
    Get
    Set
public:
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract InstrumentationEnabled : bool with get, set
override InstrumentationEnabled : bool with get, set
abstract InstrumentationEnabled : bool with get, set
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
NOPEventTimer Class
NOPEventTimer Members
NFX.Time Namespace


NOPEventTimer.ResolutionMs Property

NOPEventTimer ResolutionMs Property NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ResolutionMs { get; set; }
public int ResolutionMs { get; set; }
Public Property ResolutionMs As Integer
    Get
    Set
Public Property ResolutionMs As Integer
    Get
    Set
public:
virtual property int ResolutionMs {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int ResolutionMs {
    int get () sealed;
    void set (int value) sealed;
}
abstract ResolutionMs : int with get, set
override ResolutionMs : int with get, set
abstract ResolutionMs : int with get, set
override ResolutionMs : int with get, set

Property Value

Type: Online Int32

Implements

IEventTimerImplementation ResolutionMs
IEventTimer ResolutionMs
See Also
NOPEventTimer Class
NOPEventTimer Members
NFX.Time Namespace


TimeException Class

TimeException Class NFX Class Library

Base exception thrown by the Time framework
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Time TimeException

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TimeException : NFXException
[SerializableAttribute]
public class TimeException : NFXException
<SerializableAttribute>
Public Class TimeException
    Inherits NFXException
<SerializableAttribute>
Public Class TimeException
    Inherits NFXException
[SerializableAttribute]
public ref class TimeException : public NFXException
[SerializableAttribute]
public ref class TimeException : public NFXException
[<SerializableAttribute>]
type TimeException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type TimeException =
    class
        inherit NFXException
    end
See Also
TimeException Members
NFX.Time Namespace


TimeException Members

TimeException Members NFX Class Library

The TimeException type exposes the following members.
Constructors
 | Name | Description
Public method | TimeException | Initializes a new instance of the TimeException class
Public method | TimeException(String) | Initializes a new instance of the TimeException class
Protected method | TimeException(SerializationInfo, StreamingContext) | Initializes a new instance of the TimeException class
Public method | TimeException(String, Exception) | Initializes a new instance of the TimeException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
TimeException Class
NFX.Time Namespace


TimeException Constructor

TimeException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TimeException | Initializes a new instance of the TimeException class
Public method | TimeException(String) | Initializes a new instance of the TimeException class
Protected method | TimeException(SerializationInfo, StreamingContext) | Initializes a new instance of the TimeException class
Public method | TimeException(String, Exception) | Initializes a new instance of the TimeException class
Back to Top
See Also
TimeException Class
TimeException Members
NFX.Time Namespace


TimeException Constructor

TimeException Constructor NFX Class Library

Initializes a new instance of the TimeException class

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeException()
public TimeException()
Public Sub New
Public Sub New
public:
TimeException()
public:
TimeException()
new : unit -> TimeException
new : unit -> TimeException
See Also
TimeException Class
TimeException Members
TimeException Overload
NFX.Time Namespace


TimeException Constructor (String)

TimeException Constructor (String) NFX Class Library

Initializes a new instance of the TimeException class

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeException(
    string message
)
public TimeException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
TimeException(
    String^ message
)
public:
TimeException(
    String^ message
)
new :
        message : string -> TimeException
new :
        message : string -> TimeException

Parameters

message
Type: Online System String
See Also
TimeException Class
TimeException Members
TimeException Overload
NFX.Time Namespace


TimeException Constructor (SerializationInfo, StreamingContext)

TimeException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeException class

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TimeException(
    SerializationInfo info,
    StreamingContext context
)
protected TimeException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
TimeException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
TimeException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> TimeException
new :
        info : SerializationInfo *
        context : StreamingContext -> TimeException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
TimeException Class
TimeException Members
TimeException Overload
NFX.Time Namespace


TimeException Constructor (String, Exception)

TimeException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeException class

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeException(
    string message,
    Exception inner
)
public TimeException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
TimeException(
    String^ message,
    Exception^ inner
)
public:
TimeException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> TimeException
new :
        message : string *
        inner : Exception -> TimeException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
TimeException Class
TimeException Members
TimeException Overload
NFX.Time Namespace


TimeException Methods

TimeException Methods NFX Class Library

The TimeException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
TimeException Class
NFX.Time Namespace


TimeException Properties

TimeException Properties NFX Class Library

The TimeException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
TimeException Class
NFX.Time Namespace


TimeException Events

TimeException Events NFX Class Library

The TimeException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
TimeException Class
NFX.Time Namespace


TimeLocation Class

TimeLocation Class NFX Class Library

Data about location where time is measured relative to UTC
Inheritance Hierarchy
Online System Object
NFX.Time TimeLocation

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TimeLocation : IConfigurable
public sealed class TimeLocation : IConfigurable
Public NotInheritable Class TimeLocation
    Implements IConfigurable
Public NotInheritable Class TimeLocation
    Implements IConfigurable
public ref class TimeLocation sealed : IConfigurable
public ref class TimeLocation sealed : IConfigurable
[<SealedAttribute>]
type TimeLocation =
    class
        interface IConfigurable
    end
[<SealedAttribute>]
type TimeLocation =
    class
        interface IConfigurable
    end
See Also
TimeLocation Members
NFX.Time Namespace


TimeLocation Members

TimeLocation Members NFX Class Library

The TimeLocation type exposes the following members.
Constructors
 | Name | Description
Public method | TimeLocation(Boolean) | Creates instance that uses entity's parent settings. May use TimeLocation.Parent static instance instead
Public method | TimeLocation(TimeSpan, String, Boolean) | Initializes a new instance of the TimeLocation class
Back to Top
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_TIMELOCATION_SECTION |
Back to Top
Properties
 | Name | Description
Public property | Description | Location description
Public property | Immutable | Returns true to indicate that the instance can not be mutated with Configure() or property sets
 | Parent | Returns a singleton instance of timelocation which uses parent setting
Public property | UseParentSetting | Returns true when entity's parent settings should be used
 | UTC | Returns a singleton instance of UTC timelocation (zero offset from UTC)
Public property | UTCOffset | Returns UTC offset
Back to Top
See Also
TimeLocation Class
NFX.Time Namespace


TimeLocation Constructor

TimeLocation Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TimeLocation(Boolean) | Creates instance that uses entity's parent settings. May use TimeLocation.Parent static instance instead
Public method | TimeLocation(TimeSpan, String, Boolean) | Initializes a new instance of the TimeLocation class
Back to Top
See Also
TimeLocation Class
TimeLocation Members
NFX.Time Namespace


TimeLocation Constructor (Boolean)

TimeLocation Constructor (Boolean) NFX Class Library

Creates instance that uses entity's parent settings. May use TimeLocation.Parent static instance instead

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeLocation(
    bool immutable = false
)
public TimeLocation(
    bool immutable = false
)
Public Sub New (
    Optional immutable As Boolean = false
)
Public Sub New (
    Optional immutable As Boolean = false
)
public:
TimeLocation(
    bool immutable = false
)
public:
TimeLocation(
    bool immutable = false
)
new :
        ?immutable : bool
(* Defaults:
        let _immutable = defaultArg immutable false
*)
-> TimeLocation
new :
        ?immutable : bool
(* Defaults:
        let _immutable = defaultArg immutable false
*)
-> TimeLocation

Parameters

immutable (Optional)
Type: Online System Boolean
See Also
TimeLocation Class
TimeLocation Members
TimeLocation Overload
NFX.Time Namespace


TimeLocation Constructor (TimeSpan, String, Boolean)

TimeLocation Constructor (TimeSpan, String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeLocation class

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeLocation(
    TimeSpan utcOffset,
    string description,
    bool immutable = false
)
public TimeLocation(
    TimeSpan utcOffset,
    string description,
    bool immutable = false
)
Public Sub New (
    utcOffset As TimeSpan,
    description As String,
    Optional immutable As Boolean = false
)
Public Sub New (
    utcOffset As TimeSpan,
    description As String,
    Optional immutable As Boolean = false
)
public:
TimeLocation(
    TimeSpan utcOffset,
    String^ description,
    bool immutable = false
)
public:
TimeLocation(
    TimeSpan utcOffset,
    String^ description,
    bool immutable = false
)
new :
        utcOffset : TimeSpan *
        description : string *
        ?immutable : bool
(* Defaults:
        let _immutable = defaultArg immutable false
*)
-> TimeLocation
new :
        utcOffset : TimeSpan *
        description : string *
        ?immutable : bool
(* Defaults:
        let _immutable = defaultArg immutable false
*)
-> TimeLocation

Parameters

utcOffset
Type: Online System TimeSpan
description
Type: Online System String
immutable (Optional)
Type: Online System Boolean
See Also
TimeLocation Class
TimeLocation Members
TimeLocation Overload
NFX.Time Namespace


TimeLocation Fields

TimeLocation Fields NFX Class Library

The TimeLocation type exposes the following members.
Fields
Name | Description
CONFIG_TIMELOCATION_SECTION |
Back to Top
See Also
TimeLocation Class
NFX.Time Namespace


TimeLocation.CONFIG_TIMELOCATION_SECTION Field

TimeLocation CONFIG_TIMELOCATION_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TIMELOCATION_SECTION
public const string CONFIG_TIMELOCATION_SECTION
Public Const CONFIG_TIMELOCATION_SECTION As String
Public Const CONFIG_TIMELOCATION_SECTION As String
public:
literal String^ CONFIG_TIMELOCATION_SECTION
public:
literal String^ CONFIG_TIMELOCATION_SECTION
static val mutable CONFIG_TIMELOCATION_SECTION: string
static val mutable CONFIG_TIMELOCATION_SECTION: string

Field Value

Type: Online String
See Also
TimeLocation Class
TimeLocation Members
NFX.Time Namespace


TimeLocation Methods

TimeLocation Methods NFX Class Library

The TimeLocation type exposes the following members.
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TimeLocation Class
NFX.Time Namespace


TimeLocation.Configure Method

TimeLocation Configure Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
TimeLocation Class
TimeLocation Members
NFX.Time Namespace


TimeLocation.ToString Method

TimeLocation ToString Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
TimeLocation Class
TimeLocation Members
NFX.Time Namespace


TimeLocation Properties

TimeLocation Properties NFX Class Library

The TimeLocation type exposes the following members.
Properties
 | Name | Description
Public property | Description | Location description
Public property | Immutable | Returns true to indicate that the instance can not be mutated with Configure() or property sets
 | Parent | Returns a singleton instance of timelocation which uses parent setting
Public property | UseParentSetting | Returns true when entity's parent settings should be used
 | UTC | Returns a singleton instance of UTC timelocation (zero offset from UTC)
Public property | UTCOffset | Returns UTC offset
Back to Top
See Also
TimeLocation Class
NFX.Time Namespace


TimeLocation.Description Property

TimeLocation Description Property NFX Class Library

Location description

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
Public Property Description As String
    Get
    Set
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set
member Description : string with get, set

Property Value

Type: Online String
See Also
TimeLocation Class
TimeLocation Members
NFX.Time Namespace


TimeLocation.Immutable Property

TimeLocation Immutable Property NFX Class Library

Returns true to indicate that the instance can not be mutated with Configure() or property sets

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Immutable { get; }
public bool Immutable { get; }
Public ReadOnly Property Immutable As Boolean
    Get
Public ReadOnly Property Immutable As Boolean
    Get
public:
property bool Immutable {
    bool get ();
}
public:
property bool Immutable {
    bool get ();
}
member Immutable : bool with get
member Immutable : bool with get

Property Value

Type: Online Boolean
See Also
TimeLocation Class
TimeLocation Members
NFX.Time Namespace


TimeLocation.Parent Property

TimeLocation Parent Property NFX Class Library

Returns a singleton instance of timelocation which uses parent setting

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TimeLocation Parent { get; }
public static TimeLocation Parent { get; }
Public Shared ReadOnly Property Parent As TimeLocation
    Get
Public Shared ReadOnly Property Parent As TimeLocation
    Get
public:
static property TimeLocation^ Parent {
    TimeLocation^ get ();
}
public:
static property TimeLocation^ Parent {
    TimeLocation^ get ();
}
static member Parent : TimeLocation with get
static member Parent : TimeLocation with get

Property Value

Type: TimeLocation
See Also
TimeLocation Class
TimeLocation Members
NFX.Time Namespace


TimeLocation.UseParentSetting Property

TimeLocation UseParentSetting Property NFX Class Library

Returns true when entity's parent settings should be used

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UseParentSetting { get; }
public bool UseParentSetting { get; }
Public ReadOnly Property UseParentSetting As Boolean
    Get
Public ReadOnly Property UseParentSetting As Boolean
    Get
public:
property bool UseParentSetting {
    bool get ();
}
public:
property bool UseParentSetting {
    bool get ();
}
member UseParentSetting : bool with get
member UseParentSetting : bool with get

Property Value

Type: Online Boolean
See Also
TimeLocation Class
TimeLocation Members
NFX.Time Namespace


TimeLocation.UTC Property

TimeLocation UTC Property NFX Class Library

Returns a singleton instance of UTC timelocation (zero offset from UTC)

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TimeLocation UTC { get; }
public static TimeLocation UTC { get; }
Public Shared ReadOnly Property UTC As TimeLocation
    Get
Public Shared ReadOnly Property UTC As TimeLocation
    Get
public:
static property TimeLocation^ UTC {
    TimeLocation^ get ();
}
public:
static property TimeLocation^ UTC {
    TimeLocation^ get ();
}
static member UTC : TimeLocation with get
static member UTC : TimeLocation with get

Property Value

Type: TimeLocation
See Also
TimeLocation Class
TimeLocation Members
NFX.Time Namespace


TimeLocation.UTCOffset Property

TimeLocation UTCOffset Property NFX Class Library

Returns UTC offset

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan UTCOffset { get; set; }
public TimeSpan UTCOffset { get; set; }
Public Property UTCOffset As TimeSpan
    Get
    Set
Public Property UTCOffset As TimeSpan
    Get
    Set
public:
property TimeSpan UTCOffset {
    TimeSpan get ();
    void set (TimeSpan value);
}
public:
property TimeSpan UTCOffset {
    TimeSpan get ();
    void set (TimeSpan value);
}
member UTCOffset : TimeSpan with get, set
member UTCOffset : TimeSpan with get, set

Property Value

Type: Online TimeSpan
See Also
TimeLocation Class
TimeLocation Members
NFX.Time Namespace


TimerEvent Delegate

TimerEvent Delegate NFX Class Library

Delegate type for events that get called when timer fires

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void TimerEvent(
    Event sender
)
public delegate void TimerEvent(
    Event sender
)
Public Delegate Sub TimerEvent (
    sender As Event
)
Public Delegate Sub TimerEvent (
    sender As Event
)
public delegate void TimerEvent(
    Event^ sender
)
public delegate void TimerEvent(
    Event^ sender
)
type TimerEvent =
    delegate of
        sender : Event -> unit
type TimerEvent =
    delegate of
        sender : Event -> unit

Parameters

sender
Type: NFX.Time Event
See Also
NFX.Time Namespace


TimerEventDefinitionChange Delegate

TimerEventDefinitionChange Delegate NFX Class Library

Delegate type for events that get called when one of timer event definition parameters changes

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void TimerEventDefinitionChange(
    Event sender,
    string parameterName
)
public delegate void TimerEventDefinitionChange(
    Event sender,
    string parameterName
)
Public Delegate Sub TimerEventDefinitionChange (
    sender As Event,
    parameterName As String
)
Public Delegate Sub TimerEventDefinitionChange (
    sender As Event,
    parameterName As String
)
public delegate void TimerEventDefinitionChange(
    Event^ sender,
    String^ parameterName
)
public delegate void TimerEventDefinitionChange(
    Event^ sender,
    String^ parameterName
)
type TimerEventDefinitionChange =
    delegate of
        sender : Event *
        parameterName : string -> unit
type TimerEventDefinitionChange =
    delegate of
        sender : Event *
        parameterName : string -> unit

Parameters

sender
Type: NFX.Time Event
parameterName
Type: Online System String
See Also
NFX.Time Namespace


TimerEventStatusChange Delegate

TimerEventStatusChange Delegate NFX Class Library

Delegate type for events that get called when timer event status changes

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void TimerEventStatusChange(
    Event sender,
    EventStatus priorStatus
)
public delegate void TimerEventStatusChange(
    Event sender,
    EventStatus priorStatus
)
Public Delegate Sub TimerEventStatusChange (
    sender As Event,
    priorStatus As EventStatus
)
Public Delegate Sub TimerEventStatusChange (
    sender As Event,
    priorStatus As EventStatus
)
public delegate void TimerEventStatusChange(
    Event^ sender,
    EventStatus priorStatus
)
public delegate void TimerEventStatusChange(
    Event^ sender,
    EventStatus priorStatus
)
type TimerEventStatusChange =
    delegate of
        sender : Event *
        priorStatus : EventStatus -> unit
type TimerEventStatusChange =
    delegate of
        sender : Event *
        priorStatus : EventStatus -> unit

Parameters

sender
Type: NFX.Time Event
priorStatus
Type: NFX.Time EventStatus
See Also
NFX.Time Namespace


WinApi Class

WinApi Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Time WinApi

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class WinApi
public static class WinApi
Public NotInheritable Class WinApi
Public NotInheritable Class WinApi
public ref class WinApi abstract sealed
public ref class WinApi abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WinApi =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WinApi =  class end
See Also
WinApi Members
NFX.Time Namespace


WinApi Members

WinApi Members NFX Class Library

The WinApi type exposes the following members.
Methods
Name | Description
QueryPerformanceCounter |
QueryPerformanceFrequency |
Back to Top
See Also
WinApi Class
NFX.Time Namespace


WinApi Methods

WinApi Methods NFX Class Library

The WinApi type exposes the following members.
Methods
Name | Description
QueryPerformanceCounter |
QueryPerformanceFrequency |
Back to Top
See Also
WinApi Class
NFX.Time Namespace


WinApi.QueryPerformanceCounter Method

WinApi QueryPerformanceCounter Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool QueryPerformanceCounter(
    out long lpPerformanceCount
)
public static bool QueryPerformanceCounter(
    out long lpPerformanceCount
)
Public Shared Function QueryPerformanceCounter (
    <OutAttribute> ByRef lpPerformanceCount As Long
) As Boolean
Public Shared Function QueryPerformanceCounter (
    <OutAttribute> ByRef lpPerformanceCount As Long
) As Boolean
public:
static bool QueryPerformanceCounter(
    [OutAttribute] long long% lpPerformanceCount
)
public:
static bool QueryPerformanceCounter(
    [OutAttribute] long long% lpPerformanceCount
)
static member QueryPerformanceCounter :
        lpPerformanceCount : int64 byref -> bool
static member QueryPerformanceCounter :
        lpPerformanceCount : int64 byref -> bool

Parameters

lpPerformanceCount
Type: Online System Int64

Return Value

Type: Online Boolean
See Also
WinApi Class
WinApi Members
NFX.Time Namespace


WinApi.QueryPerformanceFrequency Method

WinApi QueryPerformanceFrequency Method NFX Class Library

Namespace: NFX.Time
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool QueryPerformanceFrequency(
    out long lpFrequency
)
public static bool QueryPerformanceFrequency(
    out long lpFrequency
)
Public Shared Function QueryPerformanceFrequency (
    <OutAttribute> ByRef lpFrequency As Long
) As Boolean
Public Shared Function QueryPerformanceFrequency (
    <OutAttribute> ByRef lpFrequency As Long
) As Boolean
public:
static bool QueryPerformanceFrequency(
    [OutAttribute] long long% lpFrequency
)
public:
static bool QueryPerformanceFrequency(
    [OutAttribute] long long% lpFrequency
)
static member QueryPerformanceFrequency :
        lpFrequency : int64 byref -> bool
static member QueryPerformanceFrequency :
        lpFrequency : int64 byref -> bool

Parameters

lpFrequency
Type: Online System Int64

Return Value

Type: Online Boolean
See Also
WinApi Class
WinApi Members
NFX.Time Namespace


NFX.Time.Instrumentation Namespace

NFX.Time.Instrumentation Namespace NFX Class Library

Classes
 | Class | Description
Public class | EventCount |
Public class | FiredEventCount |
Public class | TimeInstrumentationLongGauge |


EventCount Class

EventCount Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Time.Instrumentation TimeInstrumentationLongGauge
NFX.Time.Instrumentation EventCount

Namespace: NFX.Time.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class EventCount : TimeInstrumentationLongGauge
[SerializableAttribute]
public class EventCount : TimeInstrumentationLongGauge
<SerializableAttribute>
Public Class EventCount
    Inherits TimeInstrumentationLongGauge
<SerializableAttribute>
Public Class EventCount
    Inherits TimeInstrumentationLongGauge
[SerializableAttribute]
public ref class EventCount : public TimeInstrumentationLongGauge
[SerializableAttribute]
public ref class EventCount : public TimeInstrumentationLongGauge
[<SerializableAttribute>]
type EventCount =
    class
        inherit TimeInstrumentationLongGauge
    end
[<SerializableAttribute>]
type EventCount =
    class
        inherit TimeInstrumentationLongGauge
    end
See Also
EventCount Members
NFX.Time.Instrumentation Namespace


EventCount Members

EventCount Members NFX Class Library

The EventCount type exposes the following members.
Constructors
 | Name | Description
Protected method | EventCount | Initializes a new instance of the EventCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
EventCount Class
NFX.Time.Instrumentation Namespace


EventCount Constructor

EventCount Constructor NFX Class Library

Initializes a new instance of the EventCount class

Namespace: NFX.Time.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected EventCount(
    long value
)
protected EventCount(
    long value
)
Protected Sub New (
    value As Long
)
Protected Sub New (
    value As Long
)
protected:
EventCount(
    long long value
)
protected:
EventCount(
    long long value
)
new :
        value : int64 -> EventCount
new :
        value : int64 -> EventCount

Parameters

value
Type: Online System Int64
See Also
EventCount Class
EventCount Members
NFX.Time.Instrumentation Namespace


EventCount Fields

EventCount Fields NFX Class Library

The EventCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
EventCount Class
NFX.Time.Instrumentation Namespace


EventCount Methods

EventCount Methods NFX Class Library

The EventCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
EventCount Class
NFX.Time.Instrumentation Namespace


EventCount.MakeAggregateInstance Method

EventCount MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Time.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
EventCount Class
EventCount Members
NFX.Time.Instrumentation Namespace


EventCount.Record Method

EventCount Record Method NFX Class Library

Namespace: NFX.Time.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    long value
)
public static void Record(
    long value
)
Public Shared Sub Record (
    value As Long
)
Public Shared Sub Record (
    value As Long
)
public:
static void Record(
    long long value
)
public:
static void Record(
    long long value
)
static member Record :
        value : int64 -> unit
static member Record :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
EventCount Class
EventCount Members
NFX.Time.Instrumentation Namespace


EventCount Properties

EventCount Properties NFX Class Library

The EventCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
EventCount Class
NFX.Time.Instrumentation Namespace


EventCount.Description Property

EventCount Description Property NFX Class Library

Namespace: NFX.Time.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
EventCount Class
EventCount Members
NFX.Time.Instrumentation Namespace


EventCount.ValueUnitName Property

EventCount ValueUnitName Property NFX Class Library

Namespace: NFX.Time.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
EventCount Class
EventCount Members
NFX.Time.Instrumentation Namespace


FiredEventCount Class

FiredEventCount Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Time.Instrumentation TimeInstrumentationLongGauge
NFX.Time.Instrumentation FiredEventCount

Namespace: NFX.Time.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FiredEventCount : TimeInstrumentationLongGauge
[SerializableAttribute]
public class FiredEventCount : TimeInstrumentationLongGauge
<SerializableAttribute>
Public Class FiredEventCount
    Inherits TimeInstrumentationLongGauge
<SerializableAttribute>
Public Class FiredEventCount
    Inherits TimeInstrumentationLongGauge
[SerializableAttribute]
public ref class FiredEventCount : public TimeInstrumentationLongGauge
[SerializableAttribute]
public ref class FiredEventCount : public TimeInstrumentationLongGauge
[<SerializableAttribute>]
type FiredEventCount =
    class
        inherit TimeInstrumentationLongGauge
    end
[<SerializableAttribute>]
type FiredEventCount =
    class
        inherit TimeInstrumentationLongGauge
    end
See Also
FiredEventCount Members
NFX.Time.Instrumentation Namespace


FiredEventCount Members

FiredEventCount Members NFX Class Library

The FiredEventCount type exposes the following members.
Constructors
 | Name | Description
Protected method | FiredEventCount | Initializes a new instance of the FiredEventCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
FiredEventCount Class
NFX.Time.Instrumentation Namespace


FiredEventCount Constructor

FiredEventCount Constructor NFX Class Library

Initializes a new instance of the FiredEventCount class

Namespace: NFX.Time.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FiredEventCount(
    long value
)
protected FiredEventCount(
    long value
)
Protected Sub New (
    value As Long
)
Protected Sub New (
    value As Long
)
protected:
FiredEventCount(
    long long value
)
protected:
FiredEventCount(
    long long value
)
new :
        value : int64 -> FiredEventCount
new :
        value : int64 -> FiredEventCount

Parameters

value
Type: Online System Int64
See Also
FiredEventCount Class
FiredEventCount Members
NFX.Time.Instrumentation Namespace


FiredEventCount Fields

FiredEventCount Fields NFX Class Library

The FiredEventCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
FiredEventCount Class
NFX.Time.Instrumentation Namespace


FiredEventCount Methods

FiredEventCount Methods NFX Class Library

The FiredEventCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FiredEventCount Class
NFX.Time.Instrumentation Namespace


FiredEventCount.MakeAggregateInstance Method

FiredEventCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Time.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
FiredEventCount Class
FiredEventCount Members
NFX.Time.Instrumentation Namespace


FiredEventCount.Record Method

FiredEventCount Record Method NFX Class Library

Namespace: NFX.Time.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    long value
)
public static void Record(
    long value
)
Public Shared Sub Record (
    value As Long
)
Public Shared Sub Record (
    value As Long
)
public:
static void Record(
    long long value
)
public:
static void Record(
    long long value
)
static member Record :
        value : int64 -> unit
static member Record :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
FiredEventCount Class
FiredEventCount Members
NFX.Time.Instrumentation Namespace


FiredEventCount Properties

FiredEventCount Properties NFX Class Library

The FiredEventCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
FiredEventCount Class
NFX.Time.Instrumentation Namespace


FiredEventCount.Description Property

FiredEventCount Description Property NFX Class Library

Namespace: NFX.Time.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
FiredEventCount Class
FiredEventCount Members
NFX.Time.Instrumentation Namespace


FiredEventCount.ValueUnitName Property

FiredEventCount ValueUnitName Property NFX Class Library

Namespace: NFX.Time.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
FiredEventCount Class
FiredEventCount Members
NFX.Time.Instrumentation Namespace


TimeInstrumentationLongGauge Class

TimeInstrumentationLongGauge Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Time.Instrumentation TimeInstrumentationLongGauge
NFX.Time.Instrumentation EventCount
NFX.Time.Instrumentation FiredEventCount

Namespace: NFX.Time.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class TimeInstrumentationLongGauge : LongGauge,
    ISchedulingInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public abstract class TimeInstrumentationLongGauge : LongGauge,
    ISchedulingInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class TimeInstrumentationLongGauge
    Inherits LongGauge
    Implements ISchedulingInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class TimeInstrumentationLongGauge
    Inherits LongGauge
    Implements ISchedulingInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class TimeInstrumentationLongGauge abstract : public LongGauge,
    ISchedulingInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class TimeInstrumentationLongGauge abstract : public LongGauge,
    ISchedulingInstrument, IOperationClass, IInstrumentClass
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type TimeInstrumentationLongGauge =
    class
        inherit LongGauge
        interface ISchedulingInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type TimeInstrumentationLongGauge =
    class
        inherit LongGauge
        interface ISchedulingInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
TimeInstrumentationLongGauge Members
NFX.Time.Instrumentation Namespace


TimeInstrumentationLongGauge Members

TimeInstrumentationLongGauge Members NFX Class Library

The TimeInstrumentationLongGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | TimeInstrumentationLongGauge | Initializes a new instance of the TimeInstrumentationLongGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
TimeInstrumentationLongGauge Class
NFX.Time.Instrumentation Namespace


TimeInstrumentationLongGauge Constructor

TimeInstrumentationLongGauge Constructor NFX Class Library

Initializes a new instance of the TimeInstrumentationLongGauge class

Namespace: NFX.Time.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TimeInstrumentationLongGauge(
    long value
)
protected TimeInstrumentationLongGauge(
    long value
)
Protected Sub New (
    value As Long
)
Protected Sub New (
    value As Long
)
protected:
TimeInstrumentationLongGauge(
    long long value
)
protected:
TimeInstrumentationLongGauge(
    long long value
)
new :
        value : int64 -> TimeInstrumentationLongGauge
new :
        value : int64 -> TimeInstrumentationLongGauge

Parameters

value
Type: Online System Int64
See Also
TimeInstrumentationLongGauge Class
TimeInstrumentationLongGauge Members
NFX.Time.Instrumentation Namespace


TimeInstrumentationLongGauge Fields

TimeInstrumentationLongGauge Fields NFX Class Library

The TimeInstrumentationLongGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
TimeInstrumentationLongGauge Class
NFX.Time.Instrumentation Namespace


TimeInstrumentationLongGauge Methods

TimeInstrumentationLongGauge Methods NFX Class Library

The TimeInstrumentationLongGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TimeInstrumentationLongGauge Class
NFX.Time.Instrumentation Namespace


TimeInstrumentationLongGauge Properties

TimeInstrumentationLongGauge Properties NFX Class Library

The TimeInstrumentationLongGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
TimeInstrumentationLongGauge Class
NFX.Time.Instrumentation Namespace


NFX.Wave Namespace

NFX.Wave Namespace NFX Class Library

Classes
Class | Description
Public class ExceptionExtensions
Provides various extension methods
Public class ExceptionMatch
Used for matching of exceptions passed to Make(context)
Public class FilterPipelineException
Thrown by filter pipeline
Public class HTTPStatusException
Thrown to indicate various Http status conditions
Public class MVCActionException
Wraps inner exceptions capturing stack trace in inner implementing blocks
Public class NotAuthorizationExceptionMatch
Used for matches to bypass AuthorizationExceptions, requires EXCEPTION passed in Make(context)
Public class | PlatformUtils
Public class Portal
Represents a web portal that controls the mapping of types and themes within the site. Portals allow to host differently-looking/behaving sites in the same web application
Public class PortalHub
Portal hub - a registry of portals, It establishes a context for portal inter-operation (i.e. so one portal may locate another by name) when some settings need to be cloned. This is an app-started singleton instance class
Public class Response
Represents Response object used to generate web responses to client
Protected class StringConsts
A dictionary of framework text messages. Localization may be done in this class in future
Public class SysConsts
Non-localizable constants
Public class Theme
Represents a portal theme. Theme groups various resources (such as css, scripts etc..) whitin a portal. Do not inherit your themes from this class directly, instead use Theme(TPortal)
Public class Theme TPortal
Represents a portal theme. Theme groups various resources (such as css, scripts etc..) whitin a portal. Inherit your themes from this class
Public class URIPattern
Represents a URI pattern that can get matched against URI requests. The pattern is formed using regular URL grammar and captures segments denoted by "{}". Example: '/profiles/{controller}/{action="dflt value"}/{*params}' The class uses CSharp lexer, so it allows to use string escapes and unicode chars like CSharp
Public class WaveException
Base exception thrown by the WAVE framework
Public class WaveServer
Represents "(W)eb(A)pp(V)iew(E)nhanced" web server which provides DYNAMIC web site services. This server is not meant to be exposed directly to the public Internet, rather it should be used as an application server behind the reverse proxy, such as NGINX. This server is designed to serve dynamic data-driven requests/APIs and not meant to be used for serving static content files (although it can). The implementation is based on a lightweight HttpListener that processes incoming Http requests via an injectable WorkDispatcher which governs the threading and WorkContext lifecycle. The server processing pipeline is purposely designed to be synchronous-blocking (thread per call) which does not mean that the server is inefficient, to the contrary - this server design is specifically targeting short-called methods relying on a classical thread call stack. This approach obviates the need to create surrogate message loops/synchro contexts, tasks and other objects that introduce extra GC load. The server easily support "dangling"(left open indefinitely) WorkContext instances that can stream events (i.e. SSE/Server Push) and WebSockets from specially-purposed asynchronous notification threads.
Public class WaveSession
Represents a session in a WAVE server application
Public class WaveTemplateRenderingException
Wraps WAVE template rendering execptions
Public class WorkContext
Represents a context for request/response server processing in WAVE framework
Public class WorkDispatcher
Represents a default dispatcher that dispatches WorkContext calls on the same thread that calls Dispatch(work). May extend this class to implement custom dispatchers, i.e. the once that maintain their won work queue/worker threads
Public class WorkFilter
Represents a base for all work filters. Unlike handlers, filters do not necessarily handle work rather augment the work context
Public class WorkHandler
Represents a base for all work handlers. Handlers are final work execution destination
Public class WorkMatch
Decides whether the specifies WorkContext matches the requirements specified in the instance. The match may consider Request and Items properties of work context for match determination. Work matches do not belong to particular handler or filter, so they ARE STATELESS and their instances can be used by multiple different processors (i.e. handlers and filters).
Public class WorkMatch Variable
Represents capture variable
Structures
 | Structure | Description
Public structure | WorkMatch NameValuePair | Represents name/value tuple
Enumerations
 | Enumeration | Description
Protected enumeration | PlatformUtils HTTP_SERVER_PROPERTY |
Public enumeration | Portal DateTimeFormat |
Public enumeration | Portal MoneyFormat |


ExceptionExtensions Class

ExceptionExtensions Class NFX Class Library

Provides various extension methods
Inheritance Hierarchy
Online System Object
NFX.Wave ExceptionExtensions

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ExceptionExtensions
public static class ExceptionExtensions
<ExtensionAttribute>
Public NotInheritable Class ExceptionExtensions
<ExtensionAttribute>
Public NotInheritable Class ExceptionExtensions
[ExtensionAttribute]
public ref class ExceptionExtensions abstract sealed
[ExtensionAttribute]
public ref class ExceptionExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExceptionExtensions =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExceptionExtensions =  class end
See Also
ExceptionExtensions Members
NFX.Wave Namespace


ExceptionExtensions Members

ExceptionExtensions Members NFX Class Library

The ExceptionExtensions type exposes the following members.
Methods
Name | Description
ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap
Back to Top
See Also
ExceptionExtensions Class
NFX.Wave Namespace


ExceptionExtensions Methods

ExceptionExtensions Methods NFX Class Library

The ExceptionExtensions type exposes the following members.
Methods
Name | Description
ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap
Back to Top
See Also
ExceptionExtensions Class
NFX.Wave Namespace


ExceptionExtensions.ToClientResponseJSONMap Method

ExceptionExtensions ToClientResponseJSONMap Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Describes exception for client response transmission as JSONDataMap

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONDataMap ToClientResponseJSONMap(
    this Exception error,
    bool detailed
)
public static JSONDataMap ToClientResponseJSONMap(
    this Exception error,
    bool detailed
)
<ExtensionAttribute>
Public Shared Function ToClientResponseJSONMap (
    error As Exception,
    detailed As Boolean
) As JSONDataMap
<ExtensionAttribute>
Public Shared Function ToClientResponseJSONMap (
    error As Exception,
    detailed As Boolean
) As JSONDataMap
public:
[ExtensionAttribute]
static JSONDataMap^ ToClientResponseJSONMap(
    Exception^ error,
    bool detailed
)
public:
[ExtensionAttribute]
static JSONDataMap^ ToClientResponseJSONMap(
    Exception^ error,
    bool detailed
)
static member ToClientResponseJSONMap :
        error : Exception *
        detailed : bool -> JSONDataMap
static member ToClientResponseJSONMap :
        error : Exception *
        detailed : bool -> JSONDataMap

Parameters

error
Type: Online System Exception
detailed
Type: Online System Boolean

Return Value

Type: JSONDataMap

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Exception. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ExceptionExtensions Class
ExceptionExtensions Members
NFX.Wave Namespace


ExceptionMatch Class

ExceptionMatch Class NFX Class Library

Used for matching of exceptions passed to Make(context)
Inheritance Hierarchy
Online System Object
NFX.Wave WorkMatch
NFX.Wave ExceptionMatch

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ExceptionMatch : WorkMatch
public sealed class ExceptionMatch : WorkMatch
Public NotInheritable Class ExceptionMatch
    Inherits WorkMatch
Public NotInheritable Class ExceptionMatch
    Inherits WorkMatch
public ref class ExceptionMatch sealed : public WorkMatch
public ref class ExceptionMatch sealed : public WorkMatch
[<SealedAttribute>]
type ExceptionMatch =
    class
        inherit WorkMatch
    end
[<SealedAttribute>]
type ExceptionMatch =
    class
        inherit WorkMatch
    end
See Also
ExceptionMatch Members
NFX.Wave Namespace


ExceptionMatch Members

ExceptionMatch Members NFX Class Library

The ExceptionMatch type exposes the following members.
Constructors
 | Name | Description
Public method | ExceptionMatch(IConfigSectionNode) | Initializes a new instance of the ExceptionMatch class
Public method | ExceptionMatch(String, Int32) | Initializes a new instance of the ExceptionMatch class
Back to Top
Methods
 | Name | Description
Protected method | Check_AbsentCookies | (Inherited from WorkMatch.)
Protected method | Check_AbsentHeaders | (Inherited from WorkMatch.)
Protected method | Check_AcceptTypes | (Inherited from WorkMatch.)
Protected method | Check_ApiVersions | (Inherited from WorkMatch.)
Protected method | Check_ContentTypes | (Inherited from WorkMatch.)
Protected method | Check_Cookies | (Inherited from WorkMatch.)
Protected method | Check_Headers | (Inherited from WorkMatch.)
Protected method | Check_Hosts | (Inherited from WorkMatch.)
Protected method | Check_IsLocal | (Inherited from WorkMatch.)
Protected method | Check_IsSocialNetBot | (Inherited from WorkMatch.)
Protected method | Check_Methods | (Inherited from WorkMatch.)
Protected method | Check_Permissions | (Inherited from WorkMatch.)
Protected method | Check_Ports | (Inherited from WorkMatch.)
Protected method | Check_Schemes | (Inherited from WorkMatch.)
Protected method | Check_UserAgents | (Inherited from WorkMatch.)
Protected method | Check_UserHosts | (Inherited from WorkMatch.)
Protected method | Check_VariablesAndGetValues | (Inherited from WorkMatch.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Make | (Overrides WorkMatch Make(WorkContext, Object).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AbsentCookies | (Inherited from WorkMatch.)
Public property | AbsentHeaders | (Inherited from WorkMatch.)
Public property | AcceptJson | Shortcut to AcceptTypes contaioning application/json (Inherited from WorkMatch.)
Public property | AcceptTypes | (Inherited from WorkMatch.)
Public property | ApiMaxVer | (Inherited from WorkMatch.)
Public property | ApiMinVer | (Inherited from WorkMatch.)
Public property | ContentTypes | (Inherited from WorkMatch.)
Public property | Cookies | (Inherited from WorkMatch.)
Public property | ExceptionType |
Public property | Headers | (Inherited from WorkMatch.)
Public property | Hosts | (Inherited from WorkMatch.)
Public property | IsLocal | (Inherited from WorkMatch.)
Public property | IsNot |
Public property | IsSocialNetBot | (Inherited from WorkMatch.)
Public property | Methods | (Inherited from WorkMatch.)
Public property | Name | Returns the match instance name (Inherited from WorkMatch.)
Public property | NotPathPattern | Returns the URIPattern matcher for reverse URI path segment matching (Inherited from WorkMatch.)
Public property | Order | Returns the match order in handler registry. Order is used for URI pattern matching. Although Order property can change the match needs to be Unregistered/Registered again with the handler to change pattern matching order (Inherited from WorkMatch.)
Public property | PathPattern | Returns the URIPattern matcher for URI path segment matching (Inherited from WorkMatch.)
Public property | Permissions | (Inherited from WorkMatch.)
Public property | Ports | (Inherited from WorkMatch.)
Public property | Schemes | (Inherited from WorkMatch.)
Public property | TypeNsPrefix | Namespace prefix used for type lookups. The prefix uses '/' or '\' path separation char not '.' (Inherited from WorkMatch.)
Public property | UserAgents | (Inherited from WorkMatch.)
Public property | UserHosts | (Inherited from WorkMatch.)
Public property | Variables | Returns registry of variables. May register/unregister variables at runtime (Inherited from WorkMatch.)
Back to Top
See Also
ExceptionMatch Class
NFX.Wave Namespace


ExceptionMatch Constructor

ExceptionMatch Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ExceptionMatch(IConfigSectionNode) | Initializes a new instance of the ExceptionMatch class
Public method | ExceptionMatch(String, Int32) | Initializes a new instance of the ExceptionMatch class
Back to Top
See Also
ExceptionMatch Class
ExceptionMatch Members
NFX.Wave Namespace


ExceptionMatch Constructor (IConfigSectionNode)

ExceptionMatch Constructor (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ExceptionMatch class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExceptionMatch(
    IConfigSectionNode confNode
)
public ExceptionMatch(
    IConfigSectionNode confNode
)
Public Sub New (
    confNode As IConfigSectionNode
)
Public Sub New (
    confNode As IConfigSectionNode
)
public:
ExceptionMatch(
    IConfigSectionNode^ confNode
)
public:
ExceptionMatch(
    IConfigSectionNode^ confNode
)
new :
        confNode : IConfigSectionNode -> ExceptionMatch
new :
        confNode : IConfigSectionNode -> ExceptionMatch

Parameters

confNode
Type: NFX.Environment IConfigSectionNode
See Also
ExceptionMatch Class
ExceptionMatch Members
ExceptionMatch Overload
NFX.Wave Namespace


ExceptionMatch Constructor (String, Int32)

ExceptionMatch Constructor (String, Int32) NFX Class Library

Initializes a new instance of the ExceptionMatch class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExceptionMatch(
    string name,
    int order
)
public ExceptionMatch(
    string name,
    int order
)
Public Sub New (
    name As String,
    order As Integer
)
Public Sub New (
    name As String,
    order As Integer
)
public:
ExceptionMatch(
    String^ name,
    int order
)
public:
ExceptionMatch(
    String^ name,
    int order
)
new :
        name : string *
        order : int -> ExceptionMatch
new :
        name : string *
        order : int -> ExceptionMatch

Parameters

name
Type: Online System String
order
Type: Online System Int32
See Also
ExceptionMatch Class
ExceptionMatch Members
ExceptionMatch Overload
NFX.Wave Namespace


ExceptionMatch Methods

ExceptionMatch Methods NFX Class Library

The ExceptionMatch type exposes the following members.
Methods
 | Name | Description
Protected method | Check_AbsentCookies | (Inherited from WorkMatch.)
Protected method | Check_AbsentHeaders | (Inherited from WorkMatch.)
Protected method | Check_AcceptTypes | (Inherited from WorkMatch.)
Protected method | Check_ApiVersions | (Inherited from WorkMatch.)
Protected method | Check_ContentTypes | (Inherited from WorkMatch.)
Protected method | Check_Cookies | (Inherited from WorkMatch.)
Protected method | Check_Headers | (Inherited from WorkMatch.)
Protected method | Check_Hosts | (Inherited from WorkMatch.)
Protected method | Check_IsLocal | (Inherited from WorkMatch.)
Protected method | Check_IsSocialNetBot | (Inherited from WorkMatch.)
Protected method | Check_Methods | (Inherited from WorkMatch.)
Protected method | Check_Permissions | (Inherited from WorkMatch.)
Protected method | Check_Ports | (Inherited from WorkMatch.)
Protected method | Check_Schemes | (Inherited from WorkMatch.)
Protected method | Check_UserAgents | (Inherited from WorkMatch.)
Protected method | Check_UserHosts | (Inherited from WorkMatch.)
Protected method | Check_VariablesAndGetValues | (Inherited from WorkMatch.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Make | (Overrides WorkMatch Make(WorkContext, Object).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ExceptionMatch Class
NFX.Wave Namespace


ExceptionMatch.Make Method

ExceptionMatch Make Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override JSONDataMap Make(
    WorkContext work,
    Object context = null
)
public override JSONDataMap Make(
    WorkContext work,
    Object context = null
)
Public Overrides Function Make (
    work As WorkContext,
    Optional context As Object = Nothing
) As JSONDataMap
Public Overrides Function Make (
    work As WorkContext,
    Optional context As Object = Nothing
) As JSONDataMap
public:
virtual JSONDataMap^ Make(
    WorkContext^ work,
    Object^ context = nullptr
) override
public:
virtual JSONDataMap^ Make(
    WorkContext^ work,
    Object^ context = nullptr
) override
abstract Make :
        work : WorkContext *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> JSONDataMap
override Make :
        work : WorkContext *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> JSONDataMap
abstract Make :
        work : WorkContext *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> JSONDataMap
override Make :
        work : WorkContext *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> JSONDataMap

Parameters

work
Type: NFX.Wave WorkContext
context (Optional)
Type: Online System Object

Return Value

Type: JSONDataMap
See Also
ExceptionMatch Class
ExceptionMatch Members
NFX.Wave Namespace


ExceptionMatch Properties

ExceptionMatch Properties NFX Class Library

The ExceptionMatch type exposes the following members.
Properties
 | Name | Description
Public property | AbsentCookies | (Inherited from WorkMatch.)
Public property | AbsentHeaders | (Inherited from WorkMatch.)
Public property | AcceptJson | Shortcut to AcceptTypes contaioning application/json (Inherited from WorkMatch.)
Public property | AcceptTypes | (Inherited from WorkMatch.)
Public property | ApiMaxVer | (Inherited from WorkMatch.)
Public property | ApiMinVer | (Inherited from WorkMatch.)
Public property | ContentTypes | (Inherited from WorkMatch.)
Public property | Cookies | (Inherited from WorkMatch.)
Public property | ExceptionType |
Public property | Headers | (Inherited from WorkMatch.)
Public property | Hosts | (Inherited from WorkMatch.)
Public property | IsLocal | (Inherited from WorkMatch.)
Public property | IsNot |
Public property | IsSocialNetBot | (Inherited from WorkMatch.)
Public property | Methods | (Inherited from WorkMatch.)
Public property | Name | Returns the match instance name (Inherited from WorkMatch.)
Public property | NotPathPattern | Returns the URIPattern matcher for reverse URI path segment matching (Inherited from WorkMatch.)
Public property | Order | Returns the match order in handler registry. Order is used for URI pattern matching. Although Order property can change the match needs to be Unregistered/Registered again with the handler to change pattern matching order (Inherited from WorkMatch.)
Public property | PathPattern | Returns the URIPattern matcher for URI path segment matching (Inherited from WorkMatch.)
Public property | Permissions | (Inherited from WorkMatch.)
Public property | Ports | (Inherited from WorkMatch.)
Public property | Schemes | (Inherited from WorkMatch.)
Public property | TypeNsPrefix | Namespace prefix used for type lookups. The prefix uses '/' or '\' path separation char not '.' (Inherited from WorkMatch.)
Public property | UserAgents | (Inherited from WorkMatch.)
Public property | UserHosts | (Inherited from WorkMatch.)
Public property | Variables | Returns registry of variables. May register/unregister variables at runtime (Inherited from WorkMatch.)
Back to Top
See Also
ExceptionMatch Class
NFX.Wave Namespace


ExceptionMatch.ExceptionType Property

ExceptionMatch ExceptionType Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string ExceptionType { get; set; }
[ConfigAttribute]
public string ExceptionType { get; set; }
<ConfigAttribute>
Public Property ExceptionType As String
    Get
    Set
<ConfigAttribute>
Public Property ExceptionType As String
    Get
    Set
public:
[ConfigAttribute]
property String^ ExceptionType {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ ExceptionType {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member ExceptionType : string with get, set
[<ConfigAttribute>]
member ExceptionType : string with get, set

Property Value

Type: Online String
See Also
ExceptionMatch Class
ExceptionMatch Members
NFX.Wave Namespace


ExceptionMatch.IsNot Property

ExceptionMatch IsNot Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool IsNot { get; set; }
[ConfigAttribute]
public bool IsNot { get; set; }
<ConfigAttribute>
Public Property IsNot As Boolean
    Get
    Set
<ConfigAttribute>
Public Property IsNot As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool IsNot {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool IsNot {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member IsNot : bool with get, set
[<ConfigAttribute>]
member IsNot : bool with get, set

Property Value

Type: Online Boolean
See Also
ExceptionMatch Class
ExceptionMatch Members
NFX.Wave Namespace


FilterPipelineException Class

FilterPipelineException Class NFX Class Library

Thrown by filter pipeline
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Wave WaveException
NFX.Wave FilterPipelineException

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FilterPipelineException : WaveException
[SerializableAttribute]
public class FilterPipelineException : WaveException
<SerializableAttribute>
Public Class FilterPipelineException
    Inherits WaveException
<SerializableAttribute>
Public Class FilterPipelineException
    Inherits WaveException
[SerializableAttribute]
public ref class FilterPipelineException : public WaveException
[SerializableAttribute]
public ref class FilterPipelineException : public WaveException
[<SerializableAttribute>]
type FilterPipelineException =
    class
        inherit WaveException
    end
[<SerializableAttribute>]
type FilterPipelineException =
    class
        inherit WaveException
    end
See Also
FilterPipelineException Members
NFX.Wave Namespace


FilterPipelineException Members

FilterPipelineException Members NFX Class Library

The FilterPipelineException type exposes the following members.
Constructors
 | Name | Description
Public method | FilterPipelineException | Initializes a new instance of the FilterPipelineException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | FilterName |
Public field | FilterOrder |
Public field | FilterType |
Public field | HandlerName |
Public field | HandlerType |
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | FilterPath | Returns a mnemonic filter sequence where the root exception originated from
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Overrides Online Exception Message.)
Public property | RootException | Returns unwound root exception - unwrapping it from FilterPipelineException
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
FilterPipelineException Class
NFX.Wave Namespace


FilterPipelineException Constructor

FilterPipelineException Constructor NFX Class Library

Initializes a new instance of the FilterPipelineException class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FilterPipelineException(
    WorkFilter filter,
    Exception inner
)
public FilterPipelineException(
    WorkFilter filter,
    Exception inner
)
Public Sub New (
    filter As WorkFilter,
    inner As Exception
)
Public Sub New (
    filter As WorkFilter,
    inner As Exception
)
public:
FilterPipelineException(
    WorkFilter^ filter,
    Exception^ inner
)
public:
FilterPipelineException(
    WorkFilter^ filter,
    Exception^ inner
)
new :
        filter : WorkFilter *
        inner : Exception -> FilterPipelineException
new :
        filter : WorkFilter *
        inner : Exception -> FilterPipelineException

Parameters

filter
Type: NFX.Wave WorkFilter
inner
Type: Online System Exception
See Also
FilterPipelineException Class
FilterPipelineException Members
NFX.Wave Namespace


FilterPipelineException Fields

FilterPipelineException Fields NFX Class Library

The FilterPipelineException type exposes the following members.
Fields
 | Name | Description
Public field | FilterName |
Public field | FilterOrder |
Public field | FilterType |
Public field | HandlerName |
Public field | HandlerType |
Back to Top
See Also
FilterPipelineException Class
NFX.Wave Namespace


FilterPipelineException.FilterName Field

FilterPipelineException FilterName Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string FilterName
public readonly string FilterName
Public ReadOnly FilterName As String
Public ReadOnly FilterName As String
public:
initonly String^ FilterName
public:
initonly String^ FilterName
val FilterName: string
val FilterName: string

Field Value

Type: Online String
See Also
FilterPipelineException Class
FilterPipelineException Members
NFX.Wave Namespace


FilterPipelineException.FilterOrder Field

FilterPipelineException FilterOrder Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int FilterOrder
public readonly int FilterOrder
Public ReadOnly FilterOrder As Integer
Public ReadOnly FilterOrder As Integer
public:
initonly int FilterOrder
public:
initonly int FilterOrder
val FilterOrder: int
val FilterOrder: int

Field Value

Type: Online Int32
See Also
FilterPipelineException Class
FilterPipelineException Members
NFX.Wave Namespace


FilterPipelineException.FilterType Field

FilterPipelineException FilterType Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Type FilterType
public readonly Type FilterType
Public ReadOnly FilterType As Type
Public ReadOnly FilterType As Type
public:
initonly Type^ FilterType
public:
initonly Type^ FilterType
val FilterType: Type
val FilterType: Type

Field Value

Type: Online Type
See Also
FilterPipelineException Class
FilterPipelineException Members
NFX.Wave Namespace


FilterPipelineException.HandlerName Field

FilterPipelineException HandlerName Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string HandlerName
public readonly string HandlerName
Public ReadOnly HandlerName As String
Public ReadOnly HandlerName As String
public:
initonly String^ HandlerName
public:
initonly String^ HandlerName
val HandlerName: string
val HandlerName: string

Field Value

Type: Online String
See Also
FilterPipelineException Class
FilterPipelineException Members
NFX.Wave Namespace


FilterPipelineException.HandlerType Field

FilterPipelineException HandlerType Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Type HandlerType
public readonly Type HandlerType
Public ReadOnly HandlerType As Type
Public ReadOnly HandlerType As Type
public:
initonly Type^ HandlerType
public:
initonly Type^ HandlerType
val HandlerType: Type
val HandlerType: Type

Field Value

Type: Online Type
See Also
FilterPipelineException Class
FilterPipelineException Members
NFX.Wave Namespace


FilterPipelineException Methods

FilterPipelineException Methods NFX Class Library

The FilterPipelineException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
FilterPipelineException Class
NFX.Wave Namespace


FilterPipelineException Properties

FilterPipelineException Properties NFX Class Library

The FilterPipelineException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | FilterPath | Returns a mnemonic filter sequence where the root exception originated from
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Overrides Online Exception Message.)
Public property | RootException | Returns unwound root exception - unwrapping it from FilterPipelineException
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
FilterPipelineException Class
NFX.Wave Namespace


FilterPipelineException.FilterPath Property

FilterPipelineException FilterPath Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a mnemonic filter sequence where the root exception originated from

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FilterPath { get; }
public string FilterPath { get; }
Public ReadOnly Property FilterPath As String
    Get
Public ReadOnly Property FilterPath As String
    Get
public:
property String^ FilterPath {
    String^ get ();
}
public:
property String^ FilterPath {
    String^ get ();
}
member FilterPath : string with get
member FilterPath : string with get

Property Value

Type: Online String
See Also
FilterPipelineException Class
FilterPipelineException Members
NFX.Wave Namespace


FilterPipelineException.Message Property

FilterPipelineException Message Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Message { get; }
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
Public Overrides ReadOnly Property Message As String
    Get
public:
virtual property String^ Message {
    String^ get () override;
}
public:
virtual property String^ Message {
    String^ get () override;
}
abstract Message : string with get
override Message : string with get
abstract Message : string with get
override Message : string with get

Property Value

Type: Online String

Implements

Online _Exception Message
See Also
FilterPipelineException Class
FilterPipelineException Members
NFX.Wave Namespace


FilterPipelineException.RootException Property

FilterPipelineException RootException Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns unwound root exception - unwrapping it from FilterPipelineException

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception RootException { get; }
public Exception RootException { get; }
Public ReadOnly Property RootException As Exception
    Get
Public ReadOnly Property RootException As Exception
    Get
public:
property Exception^ RootException {
    Exception^ get ();
}
public:
property Exception^ RootException {
    Exception^ get ();
}
member RootException : Exception with get
member RootException : Exception with get

Property Value

Type: Online Exception
See Also
FilterPipelineException Class
FilterPipelineException Members
NFX.Wave Namespace


FilterPipelineException Events

FilterPipelineException Events NFX Class Library

The FilterPipelineException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
FilterPipelineException Class
NFX.Wave Namespace


HTTPStatusException Class

HTTPStatusException Class NFX Class Library

Thrown to indicate various Http status conditions
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Wave WaveException
NFX.Wave HTTPStatusException

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class HTTPStatusException : WaveException
[SerializableAttribute]
public class HTTPStatusException : WaveException
<SerializableAttribute>
Public Class HTTPStatusException
    Inherits WaveException
<SerializableAttribute>
Public Class HTTPStatusException
    Inherits WaveException
[SerializableAttribute]
public ref class HTTPStatusException : public WaveException
[SerializableAttribute]
public ref class HTTPStatusException : public WaveException
[<SerializableAttribute>]
type HTTPStatusException =
    class
        inherit WaveException
    end
[<SerializableAttribute>]
type HTTPStatusException =
    class
        inherit WaveException
    end
See Also
HTTPStatusException Members
NFX.Wave Namespace


HTTPStatusException Members

HTTPStatusException Members NFX Class Library

The HTTPStatusException type exposes the following members.
Constructors
 | Name | Description
Public method | HTTPStatusException(Int32, String) | Initializes a new instance of the HTTPStatusException class
Protected method | HTTPStatusException(SerializationInfo, StreamingContext) | Initializes a new instance of the HTTPStatusException class
Public method | HTTPStatusException(Int32, String, String) | Initializes a new instance of the HTTPStatusException class
Public method | HTTPStatusException(Int32, String, String, Exception) | Initializes a new instance of the HTTPStatusException class
Back to Top
Methods
 | Name | Description
 | BadRequest_400 |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | Forbidden_403 |
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
 | InternalError_500 |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | MethodNotAllowed_405 |
 | NotAcceptable_406 |
 | NotFound_404 |
 | TooManyRequests_429 |
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
 | Unauthorized_401 |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | StatusCode | Http status code
Public field | StatusDescription | Http status description
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
HTTPStatusException Class
NFX.Wave Namespace


HTTPStatusException Constructor

HTTPStatusException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | HTTPStatusException(Int32, String) | Initializes a new instance of the HTTPStatusException class
Protected method | HTTPStatusException(SerializationInfo, StreamingContext) | Initializes a new instance of the HTTPStatusException class
Public method | HTTPStatusException(Int32, String, String) | Initializes a new instance of the HTTPStatusException class
Public method | HTTPStatusException(Int32, String, String, Exception) | Initializes a new instance of the HTTPStatusException class
Back to Top
See Also
HTTPStatusException Class
HTTPStatusException Members
NFX.Wave Namespace


HTTPStatusException Constructor (Int32, String)

HTTPStatusException Constructor (Int32, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HTTPStatusException class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HTTPStatusException(
    int statusCode,
    string statusDescription
)
public HTTPStatusException(
    int statusCode,
    string statusDescription
)
Public Sub New (
    statusCode As Integer,
    statusDescription As String
)
Public Sub New (
    statusCode As Integer,
    statusDescription As String
)
public:
HTTPStatusException(
    int statusCode,
    String^ statusDescription
)
public:
HTTPStatusException(
    int statusCode,
    String^ statusDescription
)
new :
        statusCode : int *
        statusDescription : string -> HTTPStatusException
new :
        statusCode : int *
        statusDescription : string -> HTTPStatusException

Parameters

statusCode
Type: Online System Int32
statusDescription
Type: Online System String
See Also
HTTPStatusException Class
HTTPStatusException Members
HTTPStatusException Overload
NFX.Wave Namespace


HTTPStatusException Constructor (SerializationInfo, StreamingContext)

HTTPStatusException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HTTPStatusException class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected HTTPStatusException(
    SerializationInfo info,
    StreamingContext context
)
protected HTTPStatusException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
HTTPStatusException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
HTTPStatusException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> HTTPStatusException
new :
        info : SerializationInfo *
        context : StreamingContext -> HTTPStatusException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
HTTPStatusException Class
HTTPStatusException Members
HTTPStatusException Overload
NFX.Wave Namespace


HTTPStatusException Constructor (Int32, String, String)

HTTPStatusException Constructor (Int32, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HTTPStatusException class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HTTPStatusException(
    int statusCode,
    string statusDescription,
    string message
)
public HTTPStatusException(
    int statusCode,
    string statusDescription,
    string message
)
Public Sub New (
    statusCode As Integer,
    statusDescription As String,
    message As String
)
Public Sub New (
    statusCode As Integer,
    statusDescription As String,
    message As String
)
public:
HTTPStatusException(
    int statusCode,
    String^ statusDescription,
    String^ message
)
public:
HTTPStatusException(
    int statusCode,
    String^ statusDescription,
    String^ message
)
new :
        statusCode : int *
        statusDescription : string *
        message : string -> HTTPStatusException
new :
        statusCode : int *
        statusDescription : string *
        message : string -> HTTPStatusException

Parameters

statusCode
Type: Online System Int32
statusDescription
Type: Online System String
message
Type: Online System String
See Also
HTTPStatusException Class
HTTPStatusException Members
HTTPStatusException Overload
NFX.Wave Namespace


HTTPStatusException Constructor (Int32, String, String, Exception)

HTTPStatusException Constructor (Int32, String, String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HTTPStatusException class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HTTPStatusException(
    int statusCode,
    string statusDescription,
    string message,
    Exception inner
)
public HTTPStatusException(
    int statusCode,
    string statusDescription,
    string message,
    Exception inner
)
Public Sub New (
    statusCode As Integer,
    statusDescription As String,
    message As String,
    inner As Exception
)
Public Sub New (
    statusCode As Integer,
    statusDescription As String,
    message As String,
    inner As Exception
)
public:
HTTPStatusException(
    int statusCode,
    String^ statusDescription,
    String^ message,
    Exception^ inner
)
public:
HTTPStatusException(
    int statusCode,
    String^ statusDescription,
    String^ message,
    Exception^ inner
)
new :
        statusCode : int *
        statusDescription : string *
        message : string *
        inner : Exception -> HTTPStatusException
new :
        statusCode : int *
        statusDescription : string *
        message : string *
        inner : Exception -> HTTPStatusException

Parameters

statusCode
Type: Online System Int32
statusDescription
Type: Online System String
message
Type: Online System String
inner
Type: Online System Exception
See Also
HTTPStatusException Class
HTTPStatusException Members
HTTPStatusException Overload
NFX.Wave Namespace


HTTPStatusException Fields

HTTPStatusException Fields NFX Class Library

The HTTPStatusException type exposes the following members.
Fields
 | Name | Description
Public field | StatusCode | Http status code
Public field | StatusDescription | Http status description
Back to Top
See Also
HTTPStatusException Class
NFX.Wave Namespace


HTTPStatusException.StatusCode Field

HTTPStatusException StatusCode Field NFX Class Library

Http status code

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int StatusCode
public readonly int StatusCode
Public ReadOnly StatusCode As Integer
Public ReadOnly StatusCode As Integer
public:
initonly int StatusCode
public:
initonly int StatusCode
val StatusCode: int
val StatusCode: int

Field Value

Type: Online Int32
See Also
HTTPStatusException Class
HTTPStatusException Members
NFX.Wave Namespace


HTTPStatusException.StatusDescription Field

HTTPStatusException StatusDescription Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Http status description

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string StatusDescription
public readonly string StatusDescription
Public ReadOnly StatusDescription As String
Public ReadOnly StatusDescription As String
public:
initonly String^ StatusDescription
public:
initonly String^ StatusDescription
val StatusDescription: string
val StatusDescription: string

Field Value

Type: Online String
See Also
HTTPStatusException Class
HTTPStatusException Members
NFX.Wave Namespace


HTTPStatusException Methods

HTTPStatusException Methods NFX Class Library

The HTTPStatusException type exposes the following members.
Methods
 | Name | Description
 | BadRequest_400 |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | Forbidden_403 |
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
 | InternalError_500 |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | MethodNotAllowed_405 |
 | NotAcceptable_406 |
 | NotFound_404 |
 | TooManyRequests_429 |
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
 | Unauthorized_401 |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
HTTPStatusException Class
NFX.Wave Namespace


HTTPStatusException.BadRequest_400 Method

HTTPStatusException BadRequest_400 Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static HTTPStatusException BadRequest_400(
    string descr = null
)
public static HTTPStatusException BadRequest_400(
    string descr = null
)
Public Shared Function BadRequest_400 (
    Optional descr As String = Nothing
) As HTTPStatusException
Public Shared Function BadRequest_400 (
    Optional descr As String = Nothing
) As HTTPStatusException
public:
static HTTPStatusException^ BadRequest_400(
    String^ descr = nullptr
)
public:
static HTTPStatusException^ BadRequest_400(
    String^ descr = nullptr
)
static member BadRequest_400 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException
static member BadRequest_400 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException

Parameters

descr (Optional)
Type: Online System String

Return Value

Type: HTTPStatusException
See Also
HTTPStatusException Class
HTTPStatusException Members
NFX.Wave Namespace


HTTPStatusException.Forbidden_403 Method

HTTPStatusException Forbidden_403 Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static HTTPStatusException Forbidden_403(
    string descr = null
)
public static HTTPStatusException Forbidden_403(
    string descr = null
)
Public Shared Function Forbidden_403 (
    Optional descr As String = Nothing
) As HTTPStatusException
Public Shared Function Forbidden_403 (
    Optional descr As String = Nothing
) As HTTPStatusException
public:
static HTTPStatusException^ Forbidden_403(
    String^ descr = nullptr
)
public:
static HTTPStatusException^ Forbidden_403(
    String^ descr = nullptr
)
static member Forbidden_403 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException
static member Forbidden_403 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException

Parameters

descr (Optional)
Type: Online System String

Return Value

Type: HTTPStatusException
See Also
HTTPStatusException Class
HTTPStatusException Members
NFX.Wave Namespace


HTTPStatusException.InternalError_500 Method

HTTPStatusException InternalError_500 Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static HTTPStatusException InternalError_500(
    string descr = null
)
public static HTTPStatusException InternalError_500(
    string descr = null
)
Public Shared Function InternalError_500 (
    Optional descr As String = Nothing
) As HTTPStatusException
Public Shared Function InternalError_500 (
    Optional descr As String = Nothing
) As HTTPStatusException
public:
static HTTPStatusException^ InternalError_500(
    String^ descr = nullptr
)
public:
static HTTPStatusException^ InternalError_500(
    String^ descr = nullptr
)
static member InternalError_500 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException
static member InternalError_500 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException

Parameters

descr (Optional)
Type: Online System String

Return Value

Type: HTTPStatusException
See Also
HTTPStatusException Class
HTTPStatusException Members
NFX.Wave Namespace


HTTPStatusException.MethodNotAllowed_405 Method

HTTPStatusException MethodNotAllowed_405 Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static HTTPStatusException MethodNotAllowed_405(
    string descr = null
)
public static HTTPStatusException MethodNotAllowed_405(
    string descr = null
)
Public Shared Function MethodNotAllowed_405 (
    Optional descr As String = Nothing
) As HTTPStatusException
Public Shared Function MethodNotAllowed_405 (
    Optional descr As String = Nothing
) As HTTPStatusException
public:
static HTTPStatusException^ MethodNotAllowed_405(
    String^ descr = nullptr
)
public:
static HTTPStatusException^ MethodNotAllowed_405(
    String^ descr = nullptr
)
static member MethodNotAllowed_405 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException
static member MethodNotAllowed_405 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException

Parameters

descr (Optional)
Type: Online System String

Return Value

Type: HTTPStatusException
See Also
HTTPStatusException Class
HTTPStatusException Members
NFX.Wave Namespace


HTTPStatusException.NotAcceptable_406 Method

HTTPStatusException NotAcceptable_406 Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static HTTPStatusException NotAcceptable_406(
    string descr = null
)
public static HTTPStatusException NotAcceptable_406(
    string descr = null
)
Public Shared Function NotAcceptable_406 (
    Optional descr As String = Nothing
) As HTTPStatusException
Public Shared Function NotAcceptable_406 (
    Optional descr As String = Nothing
) As HTTPStatusException
public:
static HTTPStatusException^ NotAcceptable_406(
    String^ descr = nullptr
)
public:
static HTTPStatusException^ NotAcceptable_406(
    String^ descr = nullptr
)
static member NotAcceptable_406 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException
static member NotAcceptable_406 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException

Parameters

descr (Optional)
Type: Online System String

Return Value

Type: HTTPStatusException
See Also
HTTPStatusException Class
HTTPStatusException Members
NFX.Wave Namespace


HTTPStatusException.NotFound_404 Method

HTTPStatusException NotFound_404 Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static HTTPStatusException NotFound_404(
    string descr = null
)
public static HTTPStatusException NotFound_404(
    string descr = null
)
Public Shared Function NotFound_404 (
    Optional descr As String = Nothing
) As HTTPStatusException
Public Shared Function NotFound_404 (
    Optional descr As String = Nothing
) As HTTPStatusException
public:
static HTTPStatusException^ NotFound_404(
    String^ descr = nullptr
)
public:
static HTTPStatusException^ NotFound_404(
    String^ descr = nullptr
)
static member NotFound_404 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException
static member NotFound_404 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException

Parameters

descr (Optional)
Type: Online System String

Return Value

Type: HTTPStatusException
See Also
HTTPStatusException Class
HTTPStatusException Members
NFX.Wave Namespace


HTTPStatusException.TooManyRequests_429 Method

HTTPStatusException TooManyRequests_429 Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static HTTPStatusException TooManyRequests_429(
    string descr = null
)
public static HTTPStatusException TooManyRequests_429(
    string descr = null
)
Public Shared Function TooManyRequests_429 (
    Optional descr As String = Nothing
) As HTTPStatusException
Public Shared Function TooManyRequests_429 (
    Optional descr As String = Nothing
) As HTTPStatusException
public:
static HTTPStatusException^ TooManyRequests_429(
    String^ descr = nullptr
)
public:
static HTTPStatusException^ TooManyRequests_429(
    String^ descr = nullptr
)
static member TooManyRequests_429 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException
static member TooManyRequests_429 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException

Parameters

descr (Optional)
Type: Online System String

Return Value

Type: HTTPStatusException
See Also
HTTPStatusException Class
HTTPStatusException Members
NFX.Wave Namespace


HTTPStatusException.Unauthorized_401 Method

HTTPStatusException Unauthorized_401 Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static HTTPStatusException Unauthorized_401(
    string descr = null
)
public static HTTPStatusException Unauthorized_401(
    string descr = null
)
Public Shared Function Unauthorized_401 (
    Optional descr As String = Nothing
) As HTTPStatusException
Public Shared Function Unauthorized_401 (
    Optional descr As String = Nothing
) As HTTPStatusException
public:
static HTTPStatusException^ Unauthorized_401(
    String^ descr = nullptr
)
public:
static HTTPStatusException^ Unauthorized_401(
    String^ descr = nullptr
)
static member Unauthorized_401 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException
static member Unauthorized_401 :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> HTTPStatusException

Parameters

descr (Optional)
Type: Online System String

Return Value

Type: HTTPStatusException
See Also
HTTPStatusException Class
HTTPStatusException Members
NFX.Wave Namespace


HTTPStatusException Properties

HTTPStatusException Properties NFX Class Library

The HTTPStatusException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
HTTPStatusException Class
NFX.Wave Namespace


HTTPStatusException Events

HTTPStatusException Events NFX Class Library

The HTTPStatusException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
HTTPStatusException Class
NFX.Wave Namespace


MVCActionException Class

MVCActionException Class NFX Class Library

Wraps inner exceptions capturing stack trace in inner implementing blocks
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Wave WaveException
NFX.Wave MVCActionException

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MVCActionException : WaveException
[SerializableAttribute]
public class MVCActionException : WaveException
<SerializableAttribute>
Public Class MVCActionException
    Inherits WaveException
<SerializableAttribute>
Public Class MVCActionException
    Inherits WaveException
[SerializableAttribute]
public ref class MVCActionException : public WaveException
[SerializableAttribute]
public ref class MVCActionException : public WaveException
[<SerializableAttribute>]
type MVCActionException =
    class
        inherit WaveException
    end
[<SerializableAttribute>]
type MVCActionException =
    class
        inherit WaveException
    end
See Also
MVCActionException Members
NFX.Wave Namespace


MVCActionException Members

MVCActionException Members NFX Class Library

The MVCActionException type exposes the following members.
Constructors
 | Name | Description
Protected method | MVCActionException(SerializationInfo, StreamingContext) | Initializes a new instance of the MVCActionException class
Protected method | MVCActionException(String, String, String, Exception) | Initializes a new instance of the MVCActionException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
 | WrapActionBodyError |
 | WrapActionResultError |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | Action |
Public field | Controller |
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MVCActionException Class
NFX.Wave Namespace


MVCActionException Constructor

MVCActionException Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | MVCActionException(SerializationInfo, StreamingContext) | Initializes a new instance of the MVCActionException class
Protected method | MVCActionException(String, String, String, Exception) | Initializes a new instance of the MVCActionException class
Back to Top
See Also
MVCActionException Class
MVCActionException Members
NFX.Wave Namespace


MVCActionException Constructor (SerializationInfo, StreamingContext)

MVCActionException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MVCActionException class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MVCActionException(
    SerializationInfo info,
    StreamingContext context
)
protected MVCActionException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
MVCActionException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
MVCActionException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> MVCActionException
new :
        info : SerializationInfo *
        context : StreamingContext -> MVCActionException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
MVCActionException Class
MVCActionException Members
MVCActionException Overload
NFX.Wave Namespace


MVCActionException Constructor (String, String, String, Exception)

MVCActionException Constructor (String, String, String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MVCActionException class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MVCActionException(
    string controller,
    string action,
    string msg,
    Exception inner
)
protected MVCActionException(
    string controller,
    string action,
    string msg,
    Exception inner
)
Protected Sub New (
    controller As String,
    action As String,
    msg As String,
    inner As Exception
)
Protected Sub New (
    controller As String,
    action As String,
    msg As String,
    inner As Exception
)
protected:
MVCActionException(
    String^ controller,
    String^ action,
    String^ msg,
    Exception^ inner
)
protected:
MVCActionException(
    String^ controller,
    String^ action,
    String^ msg,
    Exception^ inner
)
new :
        controller : string *
        action : string *
        msg : string *
        inner : Exception -> MVCActionException
new :
        controller : string *
        action : string *
        msg : string *
        inner : Exception -> MVCActionException

Parameters

controller
Type: Online System String
action
Type: Online System String
msg
Type: Online System String
inner
Type: Online System Exception
See Also
MVCActionException Class
MVCActionException Members
MVCActionException Overload
NFX.Wave Namespace


MVCActionException Fields

MVCActionException Fields NFX Class Library

The MVCActionException type exposes the following members.
Fields
 | Name | Description
Public field | Action |
Public field | Controller |
Back to Top
See Also
MVCActionException Class
NFX.Wave Namespace


MVCActionException.Action Field

MVCActionException Action Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Action
public readonly string Action
Public ReadOnly Action As String
Public ReadOnly Action As String
public:
initonly String^ Action
public:
initonly String^ Action
val Action: string
val Action: string

Field Value

Type: Online String
See Also
MVCActionException Class
MVCActionException Members
NFX.Wave Namespace


MVCActionException.Controller Field

MVCActionException Controller Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Controller
public readonly string Controller
Public ReadOnly Controller As String
Public ReadOnly Controller As String
public:
initonly String^ Controller
public:
initonly String^ Controller
val Controller: string
val Controller: string

Field Value

Type: Online String
See Also
MVCActionException Class
MVCActionException Members
NFX.Wave Namespace


MVCActionException Methods

MVCActionException Methods NFX Class Library

The MVCActionException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
 | WrapActionBodyError |
 | WrapActionResultError |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
MVCActionException Class
NFX.Wave Namespace


MVCActionException.WrapActionBodyError Method

MVCActionException WrapActionBodyError Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static MVCActionException WrapActionBodyError(
    string controller,
    string action,
    Exception src
)
public static MVCActionException WrapActionBodyError(
    string controller,
    string action,
    Exception src
)
Public Shared Function WrapActionBodyError (
    controller As String,
    action As String,
    src As Exception
) As MVCActionException
Public Shared Function WrapActionBodyError (
    controller As String,
    action As String,
    src As Exception
) As MVCActionException
public:
static MVCActionException^ WrapActionBodyError(
    String^ controller,
    String^ action,
    Exception^ src
)
public:
static MVCActionException^ WrapActionBodyError(
    String^ controller,
    String^ action,
    Exception^ src
)
static member WrapActionBodyError :
        controller : string *
        action : string *
        src : Exception -> MVCActionException
static member WrapActionBodyError :
        controller : string *
        action : string *
        src : Exception -> MVCActionException

Parameters

controller
Type: Online System String
action
Type: Online System String
src
Type: Online System Exception

Return Value

Type: MVCActionException
See Also
MVCActionException Class
MVCActionException Members
NFX.Wave Namespace


MVCActionException.WrapActionResultError Method

MVCActionException WrapActionResultError Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static MVCActionException WrapActionResultError(
    string controller,
    string action,
    Object result,
    Exception src
)
public static MVCActionException WrapActionResultError(
    string controller,
    string action,
    Object result,
    Exception src
)
Public Shared Function WrapActionResultError (
    controller As String,
    action As String,
    result As Object,
    src As Exception
) As MVCActionException
Public Shared Function WrapActionResultError (
    controller As String,
    action As String,
    result As Object,
    src As Exception
) As MVCActionException
public:
static MVCActionException^ WrapActionResultError(
    String^ controller,
    String^ action,
    Object^ result,
    Exception^ src
)
public:
static MVCActionException^ WrapActionResultError(
    String^ controller,
    String^ action,
    Object^ result,
    Exception^ src
)
static member WrapActionResultError :
        controller : string *
        action : string *
        result : Object *
        src : Exception -> MVCActionException
static member WrapActionResultError :
        controller : string *
        action : string *
        result : Object *
        src : Exception -> MVCActionException

Parameters

controller
Type: Online System String
action
Type: Online System String
result
Type: Online System Object
src
Type: Online System Exception

Return Value

Type: MVCActionException
See Also
MVCActionException Class
MVCActionException Members
NFX.Wave Namespace


MVCActionException Properties

MVCActionException Properties NFX Class Library

The MVCActionException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MVCActionException Class
NFX.Wave Namespace


MVCActionException Events

MVCActionException Events NFX Class Library

The MVCActionException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MVCActionException Class
NFX.Wave Namespace


NotAuthorizationExceptionMatch Class

NotAuthorizationExceptionMatch Class NFX Class Library

Used for matches to bypass AuthorizationExceptions, requires EXCEPTION passed in Make(context)
Inheritance Hierarchy
Online System Object
NFX.Wave WorkMatch
NFX.Wave NotAuthorizationExceptionMatch

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NotAuthorizationExceptionMatch : WorkMatch
public sealed class NotAuthorizationExceptionMatch : WorkMatch
Public NotInheritable Class NotAuthorizationExceptionMatch
    Inherits WorkMatch
Public NotInheritable Class NotAuthorizationExceptionMatch
    Inherits WorkMatch
public ref class NotAuthorizationExceptionMatch sealed : public WorkMatch
public ref class NotAuthorizationExceptionMatch sealed : public WorkMatch
[<SealedAttribute>]
type NotAuthorizationExceptionMatch =
    class
        inherit WorkMatch
    end
[<SealedAttribute>]
type NotAuthorizationExceptionMatch =
    class
        inherit WorkMatch
    end
See Also
NotAuthorizationExceptionMatch Members
NFX.Wave Namespace


NotAuthorizationExceptionMatch Members

NotAuthorizationExceptionMatch Members NFX Class Library

The NotAuthorizationExceptionMatch type exposes the following members.
Constructors
 | Name | Description
Public method | NotAuthorizationExceptionMatch | Initializes a new instance of the NotAuthorizationExceptionMatch class
Back to Top
Methods
 | Name | Description
Protected method | Check_AbsentCookies | (Inherited from WorkMatch.)
Protected method | Check_AbsentHeaders | (Inherited from WorkMatch.)
Protected method | Check_AcceptTypes | (Inherited from WorkMatch.)
Protected method | Check_ApiVersions | (Inherited from WorkMatch.)
Protected method | Check_ContentTypes | (Inherited from WorkMatch.)
Protected method | Check_Cookies | (Inherited from WorkMatch.)
Protected method | Check_Headers | (Inherited from WorkMatch.)
Protected method | Check_Hosts | (Inherited from WorkMatch.)
Protected method | Check_IsLocal | (Inherited from WorkMatch.)
Protected method | Check_IsSocialNetBot | (Inherited from WorkMatch.)
Protected method | Check_Methods | (Inherited from WorkMatch.)
Protected method | Check_Permissions | (Inherited from WorkMatch.)
Protected method | Check_Ports | (Inherited from WorkMatch.)
Protected method | Check_Schemes | (Inherited from WorkMatch.)
Protected method | Check_UserAgents | (Inherited from WorkMatch.)
Protected method | Check_UserHosts | (Inherited from WorkMatch.)
Protected method | Check_VariablesAndGetValues | (Inherited from WorkMatch.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Make | (Overrides WorkMatch Make(WorkContext, Object).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AbsentCookies | (Inherited from WorkMatch.)
Public property | AbsentHeaders | (Inherited from WorkMatch.)
Public property | AcceptJson | Shortcut to AcceptTypes contaioning application/json (Inherited from WorkMatch.)
Public property | AcceptTypes | (Inherited from WorkMatch.)
Public property | ApiMaxVer | (Inherited from WorkMatch.)
Public property | ApiMinVer | (Inherited from WorkMatch.)
Public property | ContentTypes | (Inherited from WorkMatch.)
Public property | Cookies | (Inherited from WorkMatch.)
Public property | Headers | (Inherited from WorkMatch.)
Public property | Hosts | (Inherited from WorkMatch.)
Public property | IsLocal | (Inherited from WorkMatch.)
Public property | IsSocialNetBot | (Inherited from WorkMatch.)
Public property | Methods | (Inherited from WorkMatch.)
Public property | Name | Returns the match instance name (Inherited from WorkMatch.)
Public property | NotPathPattern | Returns the URIPattern matcher for reverse URI path segment matching (Inherited from WorkMatch.)
Public property | Order | Returns the match order in handler registry. Order is used for URI pattern matching. Although Order property can change the match needs to be Unregistered/Registered again with the handler to change pattern matching order (Inherited from WorkMatch.)
Public property | PathPattern | Returns the URIPattern matcher for URI path segment matching (Inherited from WorkMatch.)
Public property | Permissions | (Inherited from WorkMatch.)
Public property | Ports | (Inherited from WorkMatch.)
Public property | Schemes | (Inherited from WorkMatch.)
Public property | TypeNsPrefix | Namespace prefix used for type lookups. The prefix uses '/' or '\' path separation char not '.' (Inherited from WorkMatch.)
Public property | UserAgents | (Inherited from WorkMatch.)
Public property | UserHosts | (Inherited from WorkMatch.)
Public property | Variables | Returns registry of variables. May register/unregister variables at runtime (Inherited from WorkMatch.)
Back to Top
See Also
NotAuthorizationExceptionMatch Class
NFX.Wave Namespace


NotAuthorizationExceptionMatch Constructor

NotAuthorizationExceptionMatch Constructor NFX Class Library

Initializes a new instance of the NotAuthorizationExceptionMatch class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NotAuthorizationExceptionMatch(
    IConfigSectionNode confNode
)
public NotAuthorizationExceptionMatch(
    IConfigSectionNode confNode
)
Public Sub New (
    confNode As IConfigSectionNode
)
Public Sub New (
    confNode As IConfigSectionNode
)
public:
NotAuthorizationExceptionMatch(
    IConfigSectionNode^ confNode
)
public:
NotAuthorizationExceptionMatch(
    IConfigSectionNode^ confNode
)
new :
        confNode : IConfigSectionNode -> NotAuthorizationExceptionMatch
new :
        confNode : IConfigSectionNode -> NotAuthorizationExceptionMatch

Parameters

confNode
Type: NFX.Environment IConfigSectionNode
See Also
NotAuthorizationExceptionMatch Class
NotAuthorizationExceptionMatch Members
NFX.Wave Namespace


NotAuthorizationExceptionMatch Methods

NotAuthorizationExceptionMatch Methods NFX Class Library

The NotAuthorizationExceptionMatch type exposes the following members.
Methods
 | Name | Description
Protected method | Check_AbsentCookies | (Inherited from WorkMatch.)
Protected method | Check_AbsentHeaders | (Inherited from WorkMatch.)
Protected method | Check_AcceptTypes | (Inherited from WorkMatch.)
Protected method | Check_ApiVersions | (Inherited from WorkMatch.)
Protected method | Check_ContentTypes | (Inherited from WorkMatch.)
Protected method | Check_Cookies | (Inherited from WorkMatch.)
Protected method | Check_Headers | (Inherited from WorkMatch.)
Protected method | Check_Hosts | (Inherited from WorkMatch.)
Protected method | Check_IsLocal | (Inherited from WorkMatch.)
Protected method | Check_IsSocialNetBot | (Inherited from WorkMatch.)
Protected method | Check_Methods | (Inherited from WorkMatch.)
Protected method | Check_Permissions | (Inherited from WorkMatch.)
Protected method | Check_Ports | (Inherited from WorkMatch.)
Protected method | Check_Schemes | (Inherited from WorkMatch.)
Protected method | Check_UserAgents | (Inherited from WorkMatch.)
Protected method | Check_UserHosts | (Inherited from WorkMatch.)
Protected method | Check_VariablesAndGetValues | (Inherited from WorkMatch.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Make | (Overrides WorkMatch Make(WorkContext, Object).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NotAuthorizationExceptionMatch Class
NFX.Wave Namespace


NotAuthorizationExceptionMatch.Make Method

NotAuthorizationExceptionMatch Make Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override JSONDataMap Make(
    WorkContext work,
    Object context = null
)
public override JSONDataMap Make(
    WorkContext work,
    Object context = null
)
Public Overrides Function Make (
    work As WorkContext,
    Optional context As Object = Nothing
) As JSONDataMap
Public Overrides Function Make (
    work As WorkContext,
    Optional context As Object = Nothing
) As JSONDataMap
public:
virtual JSONDataMap^ Make(
    WorkContext^ work,
    Object^ context = nullptr
) override
public:
virtual JSONDataMap^ Make(
    WorkContext^ work,
    Object^ context = nullptr
) override
abstract Make :
        work : WorkContext *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> JSONDataMap
override Make :
        work : WorkContext *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> JSONDataMap
abstract Make :
        work : WorkContext *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> JSONDataMap
override Make :
        work : WorkContext *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> JSONDataMap

Parameters

work
Type: NFX.Wave WorkContext
context (Optional)
Type: Online System Object

Return Value

Type: JSONDataMap
See Also
NotAuthorizationExceptionMatch Class
NotAuthorizationExceptionMatch Members
NFX.Wave Namespace


NotAuthorizationExceptionMatch Properties

NotAuthorizationExceptionMatch Properties NFX Class Library

The NotAuthorizationExceptionMatch type exposes the following members.
Properties
 | Name | Description
Public property | AbsentCookies | (Inherited from WorkMatch.)
Public property | AbsentHeaders | (Inherited from WorkMatch.)
Public property | AcceptJson | Shortcut to AcceptTypes contaioning application/json (Inherited from WorkMatch.)
Public property | AcceptTypes | (Inherited from WorkMatch.)
Public property | ApiMaxVer | (Inherited from WorkMatch.)
Public property | ApiMinVer | (Inherited from WorkMatch.)
Public property | ContentTypes | (Inherited from WorkMatch.)
Public property | Cookies | (Inherited from WorkMatch.)
Public property | Headers | (Inherited from WorkMatch.)
Public property | Hosts | (Inherited from WorkMatch.)
Public property | IsLocal | (Inherited from WorkMatch.)
Public property | IsSocialNetBot | (Inherited from WorkMatch.)
Public property | Methods | (Inherited from WorkMatch.)
Public property | Name | Returns the match instance name (Inherited from WorkMatch.)
Public property | NotPathPattern | Returns the URIPattern matcher for reverse URI path segment matching (Inherited from WorkMatch.)
Public property | Order | Returns the match order in handler registry. Order is used for URI pattern matching. Although Order property can change the match needs to be Unregistered/Registered again with the handler to change pattern matching order (Inherited from WorkMatch.)
Public property | PathPattern | Returns the URIPattern matcher for URI path segment matching (Inherited from WorkMatch.)
Public property | Permissions | (Inherited from WorkMatch.)
Public property | Ports | (Inherited from WorkMatch.)
Public property | Schemes | (Inherited from WorkMatch.)
Public property | TypeNsPrefix | Namespace prefix used for type lookups. The prefix uses '/' or '\' path separation char not '.' (Inherited from WorkMatch.)
Public property | UserAgents | (Inherited from WorkMatch.)
Public property | UserHosts | (Inherited from WorkMatch.)
Public property | Variables | Returns registry of variables. May register/unregister variables at runtime (Inherited from WorkMatch.)
Back to Top
See Also
NotAuthorizationExceptionMatch Class
NFX.Wave Namespace


PlatformUtils Class

PlatformUtils Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Wave PlatformUtils

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class PlatformUtils
public static class PlatformUtils
Public NotInheritable Class PlatformUtils
Public NotInheritable Class PlatformUtils
public ref class PlatformUtils abstract sealed
public ref class PlatformUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PlatformUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PlatformUtils =  class end
See Also
PlatformUtils Members
NFX.Wave Namespace


PlatformUtils Members

PlatformUtils Members NFX Class Library

The PlatformUtils type exposes the following members.
Methods
Name | Description
HttpSetRequestQueueProperty |
SetRequestQueueLimit | Must be called after Listener.Start();
Back to Top
See Also
PlatformUtils Class
NFX.Wave Namespace


PlatformUtils Methods

PlatformUtils Methods NFX Class Library

The PlatformUtils type exposes the following members.
Methods
Name | Description
HttpSetRequestQueueProperty |
SetRequestQueueLimit | Must be called after Listener.Start();
Back to Top
See Also
PlatformUtils Class
NFX.Wave Namespace


PlatformUtils.HttpSetRequestQueueProperty Method

PlatformUtils HttpSetRequestQueueProperty Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static uint HttpSetRequestQueueProperty(
    CriticalHandle requestQueueHandle,
    PlatformUtils..::..HTTP_SERVER_PROPERTY serverProperty,
    IntPtr pPropertyInfo,
    uint propertyInfoLength,
    uint reserved,
    IntPtr pReserved
)
internal static uint HttpSetRequestQueueProperty(
    CriticalHandle requestQueueHandle,
    PlatformUtils..::..HTTP_SERVER_PROPERTY serverProperty,
    IntPtr pPropertyInfo,
    uint propertyInfoLength,
    uint reserved,
    IntPtr pReserved
)
Friend Shared Function HttpSetRequestQueueProperty (
    requestQueueHandle As CriticalHandle,
    serverProperty As PlatformUtils..::..HTTP_SERVER_PROPERTY,
    pPropertyInfo As IntPtr,
    propertyInfoLength As UInteger,
    reserved As UInteger,
    pReserved As IntPtr
) As UInteger
Friend Shared Function HttpSetRequestQueueProperty (
    requestQueueHandle As CriticalHandle,
    serverProperty As PlatformUtils..::..HTTP_SERVER_PROPERTY,
    pPropertyInfo As IntPtr,
    propertyInfoLength As UInteger,
    reserved As UInteger,
    pReserved As IntPtr
) As UInteger
internal:
static unsigned int HttpSetRequestQueueProperty(
    CriticalHandle^ requestQueueHandle,
    PlatformUtils..::..HTTP_SERVER_PROPERTY serverProperty,
    IntPtr pPropertyInfo,
    unsigned int propertyInfoLength,
    unsigned int reserved,
    IntPtr pReserved
)
internal:
static unsigned int HttpSetRequestQueueProperty(
    CriticalHandle^ requestQueueHandle,
    PlatformUtils..::..HTTP_SERVER_PROPERTY serverProperty,
    IntPtr pPropertyInfo,
    unsigned int propertyInfoLength,
    unsigned int reserved,
    IntPtr pReserved
)
internal static member HttpSetRequestQueueProperty :
        requestQueueHandle : CriticalHandle *
        serverProperty : PlatformUtils..::..HTTP_SERVER_PROPERTY *
        pPropertyInfo : IntPtr *
        propertyInfoLength : uint32 *
        reserved : uint32 *
        pReserved : IntPtr -> uint32
internal static member HttpSetRequestQueueProperty :
        requestQueueHandle : CriticalHandle *
        serverProperty : PlatformUtils..::..HTTP_SERVER_PROPERTY *
        pPropertyInfo : IntPtr *
        propertyInfoLength : uint32 *
        reserved : uint32 *
        pReserved : IntPtr -> uint32

Parameters

requestQueueHandle
Type: Online System.Runtime.InteropServices CriticalHandle
serverProperty
Type: NFX.Wave PlatformUtils HTTP_SERVER_PROPERTY
pPropertyInfo
Type: Online System IntPtr
propertyInfoLength
Type: Online System UInt32
reserved
Type: Online System UInt32
pReserved
Type: Online System IntPtr

Return Value

Type: Online UInt32
See Also
PlatformUtils Class
PlatformUtils Members
NFX.Wave Namespace


PlatformUtils.SetRequestQueueLimit Method

PlatformUtils SetRequestQueueLimit Method NFX Class Library

Must be called after Listener.Start();

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void SetRequestQueueLimit(
    HttpListener listener,
    long len
)
public static void SetRequestQueueLimit(
    HttpListener listener,
    long len
)
Public Shared Sub SetRequestQueueLimit (
    listener As HttpListener,
    len As Long
)
Public Shared Sub SetRequestQueueLimit (
    listener As HttpListener,
    len As Long
)
public:
static void SetRequestQueueLimit(
    HttpListener^ listener,
    long long len
)
public:
static void SetRequestQueueLimit(
    HttpListener^ listener,
    long long len
)
static member SetRequestQueueLimit :
        listener : HttpListener *
        len : int64 -> unit
static member SetRequestQueueLimit :
        listener : HttpListener *
        len : int64 -> unit

Parameters

listener
Type: Online System.Net HttpListener
len
Type: Online System Int64
See Also
PlatformUtils Class
PlatformUtils Members
NFX.Wave Namespace


PlatformUtils.HTTP_SERVER_PROPERTY Enumeration

PlatformUtils HTTP_SERVER_PROPERTY Enumeration NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal enum HTTP_SERVER_PROPERTY
internal enum HTTP_SERVER_PROPERTY
Friend Enumeration HTTP_SERVER_PROPERTY
Friend Enumeration HTTP_SERVER_PROPERTY
internal enum class HTTP_SERVER_PROPERTY
internal enum class HTTP_SERVER_PROPERTY
type internal HTTP_SERVER_PROPERTY
type internal HTTP_SERVER_PROPERTY
Members
Member name | Value | Description
HttpServerAuthenticationProperty | 0 |
HttpServerLoggingProperty | 1 |
HttpServerQosProperty | 2 |
HttpServerTimeoutsProperty | 3 |
HttpServerQueueLengthProperty | 4 |
HttpServerStateProperty | 5 |
HttpServer503VerbosityProperty | 6 |
HttpServerBindingProperty | 7 |
HttpServerExtendedAuthenticationProperty | 8 |
HttpServerListenEndpointProperty | 9 |
HttpServerChannelBindProperty | 10 |
HttpServerProtectionLevelProperty | 11 |
See Also
NFX.Wave Namespace


Portal Class

Portal Class NFX Class Library

Represents a web portal that controls the mapping of types and themes within the site. Portals allow to host differently-looking/behaving sites in the same web application
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave Portal

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Portal : ApplicationComponent,
    INamed, IInstrumentable, IExternallyParameterized
public abstract class Portal : ApplicationComponent,
    INamed, IInstrumentable, IExternallyParameterized
Public MustInherit Class Portal
    Inherits ApplicationComponent
    Implements INamed, IInstrumentable, IExternallyParameterized
Public MustInherit Class Portal
    Inherits ApplicationComponent
    Implements INamed, IInstrumentable, IExternallyParameterized
public ref class Portal abstract : public ApplicationComponent,
    INamed, IInstrumentable, IExternallyParameterized
public ref class Portal abstract : public ApplicationComponent,
    INamed, IInstrumentable, IExternallyParameterized
[<AbstractClassAttribute>]
type Portal =
    class
        inherit ApplicationComponent
        interface INamed
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<AbstractClassAttribute>]
type Portal =
    class
        inherit ApplicationComponent
        interface INamed
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
Portal Members
NFX.Wave Namespace


Portal Members

Portal Members NFX Class Library

The Portal type exposes the following members.
Constructors
 | Name | Description
Protected method | Portal | Makes portal from config. Due to the nature of Portal object there is no need to create other parametrized ctors
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | AmountToString(Decimal, Portal MoneyFormat, ISession) | Converts financial amount in portals.default currency to string per portal
Public method | AmountToString(Amount, Portal MoneyFormat, ISession) | Converts financial amount to string per portal
Public method | CountryISOCodeToLanguageISOCode | Converts country code into language code per this portal
Public method | DateTimeToString | Converts datetime to string per portal
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoLocalizeRecordModel | Localizes record model schema:field:value
Protected method | DoLookupLocalizationValue |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetLanguageISOCode | Tries to determine session/work context lang and returns it or DefaultLanguageISOCode
Protected method | GetLocalizableContent | Override to add localizable system content blocks. Each block has a key of the form: 'keyname_isoLang'. I.e. {"mnuStart_deu", "Anfangen"}...
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Public method | TranslateContent | Translates the named content into desired language trying to infer language from work context/locality/session. The search is first done in this portal then in inherited portals. Returns an empty string if no translation is possible
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_CONTENT_SECTION |
CONFIG_DEFAULT_ATTR |
CONFIG_DESCR_ATTR |
CONFIG_DISPLAY_NAME_ATTR |
CONFIG_LOCALIZATION_SECTION |
CONFIG_MSG_FILE_ATTR |
CONFIG_OFFLINE_ATTR |
CONFIG_PARENT_NAME_ATTR |
CONFIG_PRIMARY_ROOT_URI_ATTR |
CONFIG_RECORD_MODEL_SECTION |
CONFIG_THEME_SECTION |
LOC_ANY_FIELD_KEY |
LOC_ANY_SCHEMA_KEY |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefauISOCurrency | Returns default currency ISO code for this portal
Public property | Default | If true, matches this portal when no other suites
Public property | DefaultISOCountry | Returns default country ISO code for this portal
Public property | DefaultLanguageISOCode | Returns default language ISO code for this portal
Public property | DefaultTheme | Returns the default theme used
Public property | Description | English/primary language description
Public property | DisplayName | Primary site display name in primary language
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | DumpLocalizationErrors | Set to true to capture the localization errors in log - used for development
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | InstrumentationEnabled | Implements IInstrumentable
Public property | Name | Globally-unique portal name/ID
Public property | Offline | If true, does not get matched per request
Public property | Parent | Returns parent portal as identified by ParentName or null. Makes sure that there is no cycle in portal derivation
Public property | ParentName | Points to the parent portal instance where some settings can be cloned (i.e. localization strings)
Public property | PrimaryRootUri | Primary root URL used to access this portal
Public property | RecordModelGenerator | Returns record model generator that creates JSON for WV.JS library form server-supplied metadata
Public property | Themes | Themes tha this portal supports
Back to Top
See Also
Portal Class
NFX.Wave Namespace


Portal Constructor

Portal Constructor NFX Class Library

Makes portal from config. Due to the nature of Portal object there is no need to create other parametrized ctors

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Portal(
    IConfigSectionNode conf
)
protected Portal(
    IConfigSectionNode conf
)
Protected Sub New (
    conf As IConfigSectionNode
)
Protected Sub New (
    conf As IConfigSectionNode
)
protected:
Portal(
    IConfigSectionNode^ conf
)
protected:
Portal(
    IConfigSectionNode^ conf
)
new :
        conf : IConfigSectionNode -> Portal
new :
        conf : IConfigSectionNode -> Portal

Parameters

conf
Type: NFX.Environment IConfigSectionNode
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal Fields

Portal Fields NFX Class Library

The Portal type exposes the following members.
Fields
Name | Description
CONFIG_CONTENT_SECTION |
CONFIG_DEFAULT_ATTR |
CONFIG_DESCR_ATTR |
CONFIG_DISPLAY_NAME_ATTR |
CONFIG_LOCALIZATION_SECTION |
CONFIG_MSG_FILE_ATTR |
CONFIG_OFFLINE_ATTR |
CONFIG_PARENT_NAME_ATTR |
CONFIG_PRIMARY_ROOT_URI_ATTR |
CONFIG_RECORD_MODEL_SECTION |
CONFIG_THEME_SECTION |
LOC_ANY_FIELD_KEY |
LOC_ANY_SCHEMA_KEY |
Back to Top
See Also
Portal Class
NFX.Wave Namespace


Portal.CONFIG_CONTENT_SECTION Field

Portal CONFIG_CONTENT_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CONTENT_SECTION
public const string CONFIG_CONTENT_SECTION
Public Const CONFIG_CONTENT_SECTION As String
Public Const CONFIG_CONTENT_SECTION As String
public:
literal String^ CONFIG_CONTENT_SECTION
public:
literal String^ CONFIG_CONTENT_SECTION
static val mutable CONFIG_CONTENT_SECTION: string
static val mutable CONFIG_CONTENT_SECTION: string

Field Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.CONFIG_DEFAULT_ATTR Field

Portal CONFIG_DEFAULT_ATTR Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DEFAULT_ATTR
public const string CONFIG_DEFAULT_ATTR
Public Const CONFIG_DEFAULT_ATTR As String
Public Const CONFIG_DEFAULT_ATTR As String
public:
literal String^ CONFIG_DEFAULT_ATTR
public:
literal String^ CONFIG_DEFAULT_ATTR
static val mutable CONFIG_DEFAULT_ATTR: string
static val mutable CONFIG_DEFAULT_ATTR: string

Field Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.CONFIG_DESCR_ATTR Field

Portal CONFIG_DESCR_ATTR Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DESCR_ATTR
public const string CONFIG_DESCR_ATTR
Public Const CONFIG_DESCR_ATTR As String
Public Const CONFIG_DESCR_ATTR As String
public:
literal String^ CONFIG_DESCR_ATTR
public:
literal String^ CONFIG_DESCR_ATTR
static val mutable CONFIG_DESCR_ATTR: string
static val mutable CONFIG_DESCR_ATTR: string

Field Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.CONFIG_DISPLAY_NAME_ATTR Field

Portal CONFIG_DISPLAY_NAME_ATTR Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DISPLAY_NAME_ATTR
public const string CONFIG_DISPLAY_NAME_ATTR
Public Const CONFIG_DISPLAY_NAME_ATTR As String
Public Const CONFIG_DISPLAY_NAME_ATTR As String
public:
literal String^ CONFIG_DISPLAY_NAME_ATTR
public:
literal String^ CONFIG_DISPLAY_NAME_ATTR
static val mutable CONFIG_DISPLAY_NAME_ATTR: string
static val mutable CONFIG_DISPLAY_NAME_ATTR: string

Field Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.CONFIG_LOCALIZATION_SECTION Field

Portal CONFIG_LOCALIZATION_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_LOCALIZATION_SECTION
public const string CONFIG_LOCALIZATION_SECTION
Public Const CONFIG_LOCALIZATION_SECTION As String
Public Const CONFIG_LOCALIZATION_SECTION As String
public:
literal String^ CONFIG_LOCALIZATION_SECTION
public:
literal String^ CONFIG_LOCALIZATION_SECTION
static val mutable CONFIG_LOCALIZATION_SECTION: string
static val mutable CONFIG_LOCALIZATION_SECTION: string

Field Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.CONFIG_MSG_FILE_ATTR Field

Portal CONFIG_MSG_FILE_ATTR Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_MSG_FILE_ATTR
public const string CONFIG_MSG_FILE_ATTR
Public Const CONFIG_MSG_FILE_ATTR As String
Public Const CONFIG_MSG_FILE_ATTR As String
public:
literal String^ CONFIG_MSG_FILE_ATTR
public:
literal String^ CONFIG_MSG_FILE_ATTR
static val mutable CONFIG_MSG_FILE_ATTR: string
static val mutable CONFIG_MSG_FILE_ATTR: string

Field Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.CONFIG_OFFLINE_ATTR Field

Portal CONFIG_OFFLINE_ATTR Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_OFFLINE_ATTR
public const string CONFIG_OFFLINE_ATTR
Public Const CONFIG_OFFLINE_ATTR As String
Public Const CONFIG_OFFLINE_ATTR As String
public:
literal String^ CONFIG_OFFLINE_ATTR
public:
literal String^ CONFIG_OFFLINE_ATTR
static val mutable CONFIG_OFFLINE_ATTR: string
static val mutable CONFIG_OFFLINE_ATTR: string

Field Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.CONFIG_PARENT_NAME_ATTR Field

Portal CONFIG_PARENT_NAME_ATTR Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PARENT_NAME_ATTR
public const string CONFIG_PARENT_NAME_ATTR
Public Const CONFIG_PARENT_NAME_ATTR As String
Public Const CONFIG_PARENT_NAME_ATTR As String
public:
literal String^ CONFIG_PARENT_NAME_ATTR
public:
literal String^ CONFIG_PARENT_NAME_ATTR
static val mutable CONFIG_PARENT_NAME_ATTR: string
static val mutable CONFIG_PARENT_NAME_ATTR: string

Field Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.CONFIG_PRIMARY_ROOT_URI_ATTR Field

Portal CONFIG_PRIMARY_ROOT_URI_ATTR Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PRIMARY_ROOT_URI_ATTR
public const string CONFIG_PRIMARY_ROOT_URI_ATTR
Public Const CONFIG_PRIMARY_ROOT_URI_ATTR As String
Public Const CONFIG_PRIMARY_ROOT_URI_ATTR As String
public:
literal String^ CONFIG_PRIMARY_ROOT_URI_ATTR
public:
literal String^ CONFIG_PRIMARY_ROOT_URI_ATTR
static val mutable CONFIG_PRIMARY_ROOT_URI_ATTR: string
static val mutable CONFIG_PRIMARY_ROOT_URI_ATTR: string

Field Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.CONFIG_RECORD_MODEL_SECTION Field

Portal CONFIG_RECORD_MODEL_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_RECORD_MODEL_SECTION
public const string CONFIG_RECORD_MODEL_SECTION
Public Const CONFIG_RECORD_MODEL_SECTION As String
Public Const CONFIG_RECORD_MODEL_SECTION As String
public:
literal String^ CONFIG_RECORD_MODEL_SECTION
public:
literal String^ CONFIG_RECORD_MODEL_SECTION
static val mutable CONFIG_RECORD_MODEL_SECTION: string
static val mutable CONFIG_RECORD_MODEL_SECTION: string

Field Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.CONFIG_THEME_SECTION Field

Portal CONFIG_THEME_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_THEME_SECTION
public const string CONFIG_THEME_SECTION
Public Const CONFIG_THEME_SECTION As String
Public Const CONFIG_THEME_SECTION As String
public:
literal String^ CONFIG_THEME_SECTION
public:
literal String^ CONFIG_THEME_SECTION
static val mutable CONFIG_THEME_SECTION: string
static val mutable CONFIG_THEME_SECTION: string

Field Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.LOC_ANY_FIELD_KEY Field

Portal LOC_ANY_FIELD_KEY Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOC_ANY_FIELD_KEY
public const string LOC_ANY_FIELD_KEY
Public Const LOC_ANY_FIELD_KEY As String
Public Const LOC_ANY_FIELD_KEY As String
public:
literal String^ LOC_ANY_FIELD_KEY
public:
literal String^ LOC_ANY_FIELD_KEY
static val mutable LOC_ANY_FIELD_KEY: string
static val mutable LOC_ANY_FIELD_KEY: string

Field Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.LOC_ANY_SCHEMA_KEY Field

Portal LOC_ANY_SCHEMA_KEY Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOC_ANY_SCHEMA_KEY
public const string LOC_ANY_SCHEMA_KEY
Public Const LOC_ANY_SCHEMA_KEY As String
Public Const LOC_ANY_SCHEMA_KEY As String
public:
literal String^ LOC_ANY_SCHEMA_KEY
public:
literal String^ LOC_ANY_SCHEMA_KEY
static val mutable LOC_ANY_SCHEMA_KEY: string
static val mutable LOC_ANY_SCHEMA_KEY: string

Field Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal Methods

Portal Methods NFX Class Library

The Portal type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | AmountToString(Decimal, Portal MoneyFormat, ISession) | Converts financial amount in portals.default currency to string per portal
Public method | AmountToString(Amount, Portal MoneyFormat, ISession) | Converts financial amount to string per portal
Public method | CountryISOCodeToLanguageISOCode | Converts country code into language code per this portal
Public method | DateTimeToString | Converts datetime to string per portal
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoLocalizeRecordModel | Localizes record model schema:field:value
Protected method | DoLookupLocalizationValue |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetLanguageISOCode | Tries to determine session/work context lang and returns it or DefaultLanguageISOCode
Protected method | GetLocalizableContent | Override to add localizable system content blocks. Each block has a key of the form: 'keyname_isoLang'. I.e. {"mnuStart_deu", "Anfangen"}...
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Public method | TranslateContent | Translates the named content into desired language trying to infer language from work context/locality/session. The search is first done in this portal then in inherited portals. Returns an empty string if no translation is possible
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Portal Class
NFX.Wave Namespace


Portal.AmountToString Method

Portal AmountToString Method NFX Class Library

Overload List
 | Name | Description
Public method | AmountToString(Decimal, Portal MoneyFormat, ISession) | Converts financial amount in portals.default currency to string per portal
Public method | AmountToString(Amount, Portal MoneyFormat, ISession) | Converts financial amount to string per portal
Back to Top
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.AmountToString Method (Decimal, Portal.MoneyFormat, ISession)

Portal AmountToString Method (Decimal, Portal MoneyFormat, ISession) NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts financial amount in portals.default currency to string per portal

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string AmountToString(
    decimal amount,
    Portal..::..MoneyFormat format = Portal..::..MoneyFormat.WithCurrencySymbol,
    ISession session = null
)
public virtual string AmountToString(
    decimal amount,
    Portal..::..MoneyFormat format = Portal..::..MoneyFormat.WithCurrencySymbol,
    ISession session = null
)
Public Overridable Function AmountToString (
    amount As Decimal,
    Optional format As Portal..::..MoneyFormat = Portal..::..MoneyFormat.WithCurrencySymbol,
    Optional session As ISession = Nothing
) As String
Public Overridable Function AmountToString (
    amount As Decimal,
    Optional format As Portal..::..MoneyFormat = Portal..::..MoneyFormat.WithCurrencySymbol,
    Optional session As ISession = Nothing
) As String
public:
virtual String^ AmountToString(
    Decimal amount,
    Portal..::..MoneyFormat format = Portal..::..MoneyFormat::WithCurrencySymbol,
    ISession^ session = nullptr
)
public:
virtual String^ AmountToString(
    Decimal amount,
    Portal..::..MoneyFormat format = Portal..::..MoneyFormat::WithCurrencySymbol,
    ISession^ session = nullptr
)
abstract AmountToString :
        amount : decimal *
        ?format : Portal..::..MoneyFormat *
        ?session : ISession
(* Defaults:
        let _format = defaultArg format Portal..::..MoneyFormat.WithCurrencySymbol
        let _session = defaultArg session null
*)
-> string
override AmountToString :
        amount : decimal *
        ?format : Portal..::..MoneyFormat *
        ?session : ISession
(* Defaults:
        let _format = defaultArg format Portal..::..MoneyFormat.WithCurrencySymbol
        let _session = defaultArg session null
*)
-> string
abstract AmountToString :
        amount : decimal *
        ?format : Portal..::..MoneyFormat *
        ?session : ISession
(* Defaults:
        let _format = defaultArg format Portal..::..MoneyFormat.WithCurrencySymbol
        let _session = defaultArg session null
*)
-> string
override AmountToString :
        amount : decimal *
        ?format : Portal..::..MoneyFormat *
        ?session : ISession
(* Defaults:
        let _format = defaultArg format Portal..::..MoneyFormat.WithCurrencySymbol
        let _session = defaultArg session null
*)
-> string

Parameters

amount
Type: Online System Decimal
format (Optional)
Type: NFX.Wave Portal MoneyFormat
session (Optional)
Type: NFX.ApplicationModel ISession

Return Value

Type: Online String
See Also
Portal Class
Portal Members
AmountToString Overload
NFX.Wave Namespace


Portal.AmountToString Method (Amount, Portal.MoneyFormat, ISession)

Portal AmountToString Method (Amount, Portal MoneyFormat, ISession) NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts financial amount to string per portal

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string AmountToString(
    Amount amount,
    Portal..::..MoneyFormat format = Portal..::..MoneyFormat.WithCurrencySymbol,
    ISession session = null
)
public abstract string AmountToString(
    Amount amount,
    Portal..::..MoneyFormat format = Portal..::..MoneyFormat.WithCurrencySymbol,
    ISession session = null
)
Public MustOverride Function AmountToString (
    amount As Amount,
    Optional format As Portal..::..MoneyFormat = Portal..::..MoneyFormat.WithCurrencySymbol,
    Optional session As ISession = Nothing
) As String
Public MustOverride Function AmountToString (
    amount As Amount,
    Optional format As Portal..::..MoneyFormat = Portal..::..MoneyFormat.WithCurrencySymbol,
    Optional session As ISession = Nothing
) As String
public:
virtual String^ AmountToString(
    Amount amount,
    Portal..::..MoneyFormat format = Portal..::..MoneyFormat::WithCurrencySymbol,
    ISession^ session = nullptr
) abstract
public:
virtual String^ AmountToString(
    Amount amount,
    Portal..::..MoneyFormat format = Portal..::..MoneyFormat::WithCurrencySymbol,
    ISession^ session = nullptr
) abstract
abstract AmountToString :
        amount : Amount *
        ?format : Portal..::..MoneyFormat *
        ?session : ISession
(* Defaults:
        let _format = defaultArg format Portal..::..MoneyFormat.WithCurrencySymbol
        let _session = defaultArg session null
*)
-> string
abstract AmountToString :
        amount : Amount *
        ?format : Portal..::..MoneyFormat *
        ?session : ISession
(* Defaults:
        let _format = defaultArg format Portal..::..MoneyFormat.WithCurrencySymbol
        let _session = defaultArg session null
*)
-> string

Parameters

amount
Type: NFX.Financial Amount
format (Optional)
Type: NFX.Wave Portal MoneyFormat
session (Optional)
Type: NFX.ApplicationModel ISession

Return Value

Type: Online String
See Also
Portal Class
Portal Members
AmountToString Overload
NFX.Wave Namespace


Portal.CountryISOCodeToLanguageISOCode Method

Portal CountryISOCodeToLanguageISOCode Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts country code into language code per this portal

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string CountryISOCodeToLanguageISOCode(
    string countryISOCode
)
public abstract string CountryISOCodeToLanguageISOCode(
    string countryISOCode
)
Public MustOverride Function CountryISOCodeToLanguageISOCode (
    countryISOCode As String
) As String
Public MustOverride Function CountryISOCodeToLanguageISOCode (
    countryISOCode As String
) As String
public:
virtual String^ CountryISOCodeToLanguageISOCode(
    String^ countryISOCode
) abstract
public:
virtual String^ CountryISOCodeToLanguageISOCode(
    String^ countryISOCode
) abstract
abstract CountryISOCodeToLanguageISOCode :
        countryISOCode : string -> string
abstract CountryISOCodeToLanguageISOCode :
        countryISOCode : string -> string

Parameters

countryISOCode
Type: Online System String

Return Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.DateTimeToString Method

Portal DateTimeToString Method NFX Class Library

Converts datetime to string per portal

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string DateTimeToString(
    DateTime dt,
    Portal..::..DateTimeFormat format = Portal..::..DateTimeFormat.LongDateTime,
    ISession session = null
)
public abstract string DateTimeToString(
    DateTime dt,
    Portal..::..DateTimeFormat format = Portal..::..DateTimeFormat.LongDateTime,
    ISession session = null
)
Public MustOverride Function DateTimeToString (
    dt As DateTime,
    Optional format As Portal..::..DateTimeFormat = Portal..::..DateTimeFormat.LongDateTime,
    Optional session As ISession = Nothing
) As String
Public MustOverride Function DateTimeToString (
    dt As DateTime,
    Optional format As Portal..::..DateTimeFormat = Portal..::..DateTimeFormat.LongDateTime,
    Optional session As ISession = Nothing
) As String
public:
virtual String^ DateTimeToString(
    DateTime dt,
    Portal..::..DateTimeFormat format = Portal..::..DateTimeFormat::LongDateTime,
    ISession^ session = nullptr
) abstract
public:
virtual String^ DateTimeToString(
    DateTime dt,
    Portal..::..DateTimeFormat format = Portal..::..DateTimeFormat::LongDateTime,
    ISession^ session = nullptr
) abstract
abstract DateTimeToString :
        dt : DateTime *
        ?format : Portal..::..DateTimeFormat *
        ?session : ISession
(* Defaults:
        let _format = defaultArg format Portal..::..DateTimeFormat.LongDateTime
        let _session = defaultArg session null
*)
-> string
abstract DateTimeToString :
        dt : DateTime *
        ?format : Portal..::..DateTimeFormat *
        ?session : ISession
(* Defaults:
        let _format = defaultArg format Portal..::..DateTimeFormat.LongDateTime
        let _session = defaultArg session null
*)
-> string

Parameters

dt
Type: Online System DateTime
format (Optional)
Type: NFX.Wave Portal DateTimeFormat
session (Optional)
Type: NFX.ApplicationModel ISession

Return Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.Destructor Method

Portal Destructor Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.DoLocalizeRecordModel Method

Portal DoLocalizeRecordModel Method NFX Class Library

Localizes record model schema:field:value

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string DoLocalizeRecordModel(
    string schema,
    string field,
    string value,
    string isoLang
)
protected virtual string DoLocalizeRecordModel(
    string schema,
    string field,
    string value,
    string isoLang
)
Protected Overridable Function DoLocalizeRecordModel (
    schema As String,
    field As String,
    value As String,
    isoLang As String
) As String
Protected Overridable Function DoLocalizeRecordModel (
    schema As String,
    field As String,
    value As String,
    isoLang As String
) As String
protected:
virtual String^ DoLocalizeRecordModel(
    String^ schema,
    String^ field,
    String^ value,
    String^ isoLang
)
protected:
virtual String^ DoLocalizeRecordModel(
    String^ schema,
    String^ field,
    String^ value,
    String^ isoLang
)
abstract DoLocalizeRecordModel :
        schema : string *
        field : string *
        value : string *
        isoLang : string -> string
override DoLocalizeRecordModel :
        schema : string *
        field : string *
        value : string *
        isoLang : string -> string
abstract DoLocalizeRecordModel :
        schema : string *
        field : string *
        value : string *
        isoLang : string -> string
override DoLocalizeRecordModel :
        schema : string *
        field : string *
        value : string *
        isoLang : string -> string

Parameters

schema
Type: Online System String
field
Type: Online System String
value
Type: Online System String
isoLang
Type: Online System String

Return Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.DoLookupLocalizationValue Method

Portal DoLookupLocalizationValue Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string DoLookupLocalizationValue(
    string isoLang,
    string schema,
    string field,
    string value,
    out bool exists
)
protected virtual string DoLookupLocalizationValue(
    string isoLang,
    string schema,
    string field,
    string value,
    out bool exists
)
Protected Overridable Function DoLookupLocalizationValue (
    isoLang As String,
    schema As String,
    field As String,
    value As String,
    <OutAttribute> ByRef exists As Boolean
) As String
Protected Overridable Function DoLookupLocalizationValue (
    isoLang As String,
    schema As String,
    field As String,
    value As String,
    <OutAttribute> ByRef exists As Boolean
) As String
protected:
virtual String^ DoLookupLocalizationValue(
    String^ isoLang,
    String^ schema,
    String^ field,
    String^ value,
    [OutAttribute] bool% exists
)
protected:
virtual String^ DoLookupLocalizationValue(
    String^ isoLang,
    String^ schema,
    String^ field,
    String^ value,
    [OutAttribute] bool% exists
)
abstract DoLookupLocalizationValue :
        isoLang : string *
        schema : string *
        field : string *
        value : string *
        exists : bool byref -> string
override DoLookupLocalizationValue :
        isoLang : string *
        schema : string *
        field : string *
        value : string *
        exists : bool byref -> string
abstract DoLookupLocalizationValue :
        isoLang : string *
        schema : string *
        field : string *
        value : string *
        exists : bool byref -> string
override DoLookupLocalizationValue :
        isoLang : string *
        schema : string *
        field : string *
        value : string *
        exists : bool byref -> string

Parameters

isoLang
Type: Online System String
schema
Type: Online System String
field
Type: Online System String
value
Type: Online System String
exists
Type: Online System Boolean

Return Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.ExternalGetParameter Method

Portal ExternalGetParameter Method NFX Class Library

Gets external parameter value returning true if parameter was found

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public virtual bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Overridable Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Overridable Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
)
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
)
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.ExternalParametersForGroups Method

Portal ExternalParametersForGroups Method NFX Class Library

Returns named parameters that can be used to control this component

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Overridable Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Overridable Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
)
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
)
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.ExternalSetParameter Method

Portal ExternalSetParameter Method NFX Class Library

Sets external parameter value returning true if parameter was found and set

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public virtual bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Overridable Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Overridable Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
)
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
)
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.GetLanguageISOCode Method

Portal GetLanguageISOCode Method NFX Class Library

Tries to determine session/work context lang and returns it or DefaultLanguageISOCode

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string GetLanguageISOCode(
    WorkContext work = null
)
public virtual string GetLanguageISOCode(
    WorkContext work = null
)
Public Overridable Function GetLanguageISOCode (
    Optional work As WorkContext = Nothing
) As String
Public Overridable Function GetLanguageISOCode (
    Optional work As WorkContext = Nothing
) As String
public:
virtual String^ GetLanguageISOCode(
    WorkContext^ work = nullptr
)
public:
virtual String^ GetLanguageISOCode(
    WorkContext^ work = nullptr
)
abstract GetLanguageISOCode :
        ?work : WorkContext
(* Defaults:
        let _work = defaultArg work null
*)
-> string
override GetLanguageISOCode :
        ?work : WorkContext
(* Defaults:
        let _work = defaultArg work null
*)
-> string
abstract GetLanguageISOCode :
        ?work : WorkContext
(* Defaults:
        let _work = defaultArg work null
*)
-> string
override GetLanguageISOCode :
        ?work : WorkContext
(* Defaults:
        let _work = defaultArg work null
*)
-> string

Parameters

work (Optional)
Type: NFX.Wave WorkContext

Return Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.GetLocalizableContent Method

Portal GetLocalizableContent Method NFX Class Library

Override to add localizable system content blocks. Each block has a key of the form: 'keyname_isoLang'. I.e. {"mnuStart_deu", "Anfangen"}...

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Dictionary<string, string> GetLocalizableContent()
protected abstract Dictionary<string, string> GetLocalizableContent()
Protected MustOverride Function GetLocalizableContent As Dictionary(Of String, String)
Protected MustOverride Function GetLocalizableContent As Dictionary(Of String, String)
protected:
virtual Dictionary<String^, String^>^ GetLocalizableContent() abstract
protected:
virtual Dictionary<String^, String^>^ GetLocalizableContent() abstract
abstract GetLocalizableContent : unit -> Dictionary<string, string>
abstract GetLocalizableContent : unit -> Dictionary<string, string>

Return Value

Type: Online Dictionary Online String, Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.ToString Method

Portal ToString Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.TranslateContent Method

Portal TranslateContent Method NFX Class Library

Translates the named content into desired language trying to infer language from work context/locality/session. The search is first done in this portal then in inherited portals. Returns an empty string if no translation is possible

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string TranslateContent(
    string contentKey,
    string isoLang = null,
    WorkContext work = null
)
public virtual string TranslateContent(
    string contentKey,
    string isoLang = null,
    WorkContext work = null
)
Public Overridable Function TranslateContent (
    contentKey As String,
    Optional isoLang As String = Nothing,
    Optional work As WorkContext = Nothing
) As String
Public Overridable Function TranslateContent (
    contentKey As String,
    Optional isoLang As String = Nothing,
    Optional work As WorkContext = Nothing
) As String
public:
virtual String^ TranslateContent(
    String^ contentKey,
    String^ isoLang = nullptr,
    WorkContext^ work = nullptr
)
public:
virtual String^ TranslateContent(
    String^ contentKey,
    String^ isoLang = nullptr,
    WorkContext^ work = nullptr
)
abstract TranslateContent :
        contentKey : string *
        ?isoLang : string *
        ?work : WorkContext
(* Defaults:
        let _isoLang = defaultArg isoLang null
        let _work = defaultArg work null
*)
-> string
override TranslateContent :
        contentKey : string *
        ?isoLang : string *
        ?work : WorkContext
(* Defaults:
        let _isoLang = defaultArg isoLang null
        let _work = defaultArg work null
*)
-> string
abstract TranslateContent :
        contentKey : string *
        ?isoLang : string *
        ?work : WorkContext
(* Defaults:
        let _isoLang = defaultArg isoLang null
        let _work = defaultArg work null
*)
-> string
override TranslateContent :
        contentKey : string *
        ?isoLang : string *
        ?work : WorkContext
(* Defaults:
        let _isoLang = defaultArg isoLang null
        let _work = defaultArg work null
*)
-> string

Parameters

contentKey
Type: Online System String
isoLang (Optional)
Type: Online System String
work (Optional)
Type: NFX.Wave WorkContext

Return Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal Properties

Portal Properties NFX Class Library

The Portal type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefauISOCurrency | Returns default currency ISO code for this portal
Public property | Default | If true, matches this portal when no other suites
Public property | DefaultISOCountry | Returns default country ISO code for this portal
Public property | DefaultLanguageISOCode | Returns default language ISO code for this portal
Public property | DefaultTheme | Returns the default theme used
Public property | Description | English/primary language description
Public property | DisplayName | Primary site display name in primary language
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | DumpLocalizationErrors | Set to true to capture the localization errors in log - used for development
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | InstrumentationEnabled | Implements IInstrumentable
Public property | Name | Globally-unique portal name/ID
Public property | Offline | If true, does not get matched per request
Public property | Parent | Returns parent portal as identified by ParentName or null. Makes sure that there is no cycle in portal derivation
Public property | ParentName | Points to the parent portal instance where some settings can be cloned (i.e. localization strings)
Public property | PrimaryRootUri | Primary root URL used to access this portal
Public property | RecordModelGenerator | Returns record model generator that creates JSON for WV.JS library form server-supplied metadata
Public property | Themes | Themes tha this portal supports
Back to Top
See Also
Portal Class
NFX.Wave Namespace


Portal.DefauISOCurrency Property

Portal DefauISOCurrency Property NFX Class Library

Returns default currency ISO code for this portal

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string DefauISOCurrency { get; }
public abstract string DefauISOCurrency { get; }
Public MustOverride ReadOnly Property DefauISOCurrency As String
    Get
Public MustOverride ReadOnly Property DefauISOCurrency As String
    Get
public:
virtual property String^ DefauISOCurrency {
    String^ get () abstract;
}
public:
virtual property String^ DefauISOCurrency {
    String^ get () abstract;
}
abstract DefauISOCurrency : string with get
abstract DefauISOCurrency : string with get

Property Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.Default Property

Portal Default Property NFX Class Library

If true, matches this portal when no other suites

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
public bool Default { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
public bool Default { get; set; }
<ExternalParameterAttribute(New String() { ... })>
Public Property Default As Boolean
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
Public Property Default As Boolean
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool Default {
    bool get ();
    void set (bool value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool Default {
    bool get ();
    void set (bool value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
member Default : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
member Default : bool with get, set

Property Value

Type: Online Boolean
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.DefaultISOCountry Property

Portal DefaultISOCountry Property NFX Class Library

Returns default country ISO code for this portal

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string DefaultISOCountry { get; }
public abstract string DefaultISOCountry { get; }
Public MustOverride ReadOnly Property DefaultISOCountry As String
    Get
Public MustOverride ReadOnly Property DefaultISOCountry As String
    Get
public:
virtual property String^ DefaultISOCountry {
    String^ get () abstract;
}
public:
virtual property String^ DefaultISOCountry {
    String^ get () abstract;
}
abstract DefaultISOCountry : string with get
abstract DefaultISOCountry : string with get

Property Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.DefaultLanguageISOCode Property

Portal DefaultLanguageISOCode Property NFX Class Library

Returns default language ISO code for this portal

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string DefaultLanguageISOCode { get; }
public abstract string DefaultLanguageISOCode { get; }
Public MustOverride ReadOnly Property DefaultLanguageISOCode As String
    Get
Public MustOverride ReadOnly Property DefaultLanguageISOCode As String
    Get
public:
virtual property String^ DefaultLanguageISOCode {
    String^ get () abstract;
}
public:
virtual property String^ DefaultLanguageISOCode {
    String^ get () abstract;
}
abstract DefaultLanguageISOCode : string with get
abstract DefaultLanguageISOCode : string with get

Property Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.DefaultTheme Property

Portal DefaultTheme Property NFX Class Library

Returns the default theme used

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Theme DefaultTheme { get; }
public Theme DefaultTheme { get; }
Public ReadOnly Property DefaultTheme As Theme
    Get
Public ReadOnly Property DefaultTheme As Theme
    Get
public:
property Theme^ DefaultTheme {
    Theme^ get ();
}
public:
property Theme^ DefaultTheme {
    Theme^ get ();
}
member DefaultTheme : Theme with get
member DefaultTheme : Theme with get

Property Value

Type: Theme
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.Description Property

Portal Description Property NFX Class Library

English/primary language description

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; }
public string Description { get; }
Public ReadOnly Property Description As String
    Get
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
public:
property String^ Description {
    String^ get ();
}
member Description : string with get
member Description : string with get

Property Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.DisplayName Property

Portal DisplayName Property NFX Class Library

Primary site display name in primary language

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DisplayName { get; }
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}
public:
property String^ DisplayName {
    String^ get ();
}
member DisplayName : string with get
member DisplayName : string with get

Property Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.DumpLocalizationErrors Property

Portal DumpLocalizationErrors Property NFX Class Library

Set to true to capture the localization errors in log - used for development

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute]
public bool DumpLocalizationErrors { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute]
public bool DumpLocalizationErrors { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute>
Public Property DumpLocalizationErrors As Boolean
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute>
Public Property DumpLocalizationErrors As Boolean
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute]
property bool DumpLocalizationErrors {
    bool get ();
    void set (bool value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute]
property bool DumpLocalizationErrors {
    bool get ();
    void set (bool value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
member DumpLocalizationErrors : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
member DumpLocalizationErrors : bool with get, set

Property Value

Type: Online Boolean
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.ExternalParameters Property

Portal ExternalParameters Property NFX Class Library

Returns named parameters that can be used to control this component

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public Overridable ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public Overridable ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get ();
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get ();
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.InstrumentationEnabled Property

Portal InstrumentationEnabled Property NFX Class Library

Implements IInstrumentable

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public bool InstrumentationEnabled { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public bool InstrumentationEnabled { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Property InstrumentationEnabled As Boolean
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.Name Property

Portal Name Property NFX Class Library

Globally-unique portal name/ID

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.Offline Property

Portal Offline Property NFX Class Library

If true, does not get matched per request

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
public bool Offline { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
public bool Offline { get; set; }
<ExternalParameterAttribute(New String() { ... })>
Public Property Offline As Boolean
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
Public Property Offline As Boolean
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool Offline {
    bool get ();
    void set (bool value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool Offline {
    bool get ();
    void set (bool value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
member Offline : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
member Offline : bool with get, set

Property Value

Type: Online Boolean
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.Parent Property

Portal Parent Property NFX Class Library

Returns parent portal as identified by ParentName or null. Makes sure that there is no cycle in portal derivation

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Portal Parent { get; }
public Portal Parent { get; }
Public ReadOnly Property Parent As Portal
    Get
Public ReadOnly Property Parent As Portal
    Get
public:
property Portal^ Parent {
    Portal^ get ();
}
public:
property Portal^ Parent {
    Portal^ get ();
}
member Parent : Portal with get
member Parent : Portal with get

Property Value

Type: Portal
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.ParentName Property

Portal ParentName Property NFX Class Library

Points to the parent portal instance where some settings can be cloned (i.e. localization strings)

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ParentName { get; }
public string ParentName { get; }
Public ReadOnly Property ParentName As String
    Get
Public ReadOnly Property ParentName As String
    Get
public:
property String^ ParentName {
    String^ get ();
}
public:
property String^ ParentName {
    String^ get ();
}
member ParentName : string with get
member ParentName : string with get

Property Value

Type: Online String
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.PrimaryRootUri Property

Portal PrimaryRootUri Property NFX Class Library

Primary root URL used to access this portal

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Uri PrimaryRootUri { get; }
public Uri PrimaryRootUri { get; }
Public ReadOnly Property PrimaryRootUri As Uri
    Get
Public ReadOnly Property PrimaryRootUri As Uri
    Get
public:
property Uri^ PrimaryRootUri {
    Uri^ get ();
}
public:
property Uri^ PrimaryRootUri {
    Uri^ get ();
}
member PrimaryRootUri : Uri with get
member PrimaryRootUri : Uri with get

Property Value

Type: Online Uri
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.RecordModelGenerator Property

Portal RecordModelGenerator Property NFX Class Library

Returns record model generator that creates JSON for WV.JS library form server-supplied metadata

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RecordModelGenerator RecordModelGenerator { get; }
public RecordModelGenerator RecordModelGenerator { get; }
Public ReadOnly Property RecordModelGenerator As RecordModelGenerator
    Get
Public ReadOnly Property RecordModelGenerator As RecordModelGenerator
    Get
public:
property RecordModelGenerator^ RecordModelGenerator {
    RecordModelGenerator^ get ();
}
public:
property RecordModelGenerator^ RecordModelGenerator {
    RecordModelGenerator^ get ();
}
member RecordModelGenerator : RecordModelGenerator with get
member RecordModelGenerator : RecordModelGenerator with get

Property Value

Type: RecordModelGenerator
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.Themes Property

Portal Themes Property NFX Class Library

Themes tha this portal supports

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<Theme> Themes { get; }
public IRegistry<Theme> Themes { get; }
Public ReadOnly Property Themes As IRegistry(Of Theme)
    Get
Public ReadOnly Property Themes As IRegistry(Of Theme)
    Get
public:
property IRegistry<Theme^>^ Themes {
    IRegistry<Theme^>^ get ();
}
public:
property IRegistry<Theme^>^ Themes {
    IRegistry<Theme^>^ get ();
}
member Themes : IRegistry<Theme> with get
member Themes : IRegistry<Theme> with get

Property Value

Type: IRegistry Theme
See Also
Portal Class
Portal Members
NFX.Wave Namespace


Portal.DateTimeFormat Enumeration

Portal DateTimeFormat Enumeration NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum DateTimeFormat
public enum DateTimeFormat
Public Enumeration DateTimeFormat
Public Enumeration DateTimeFormat
public enum class DateTimeFormat
public enum class DateTimeFormat
type DateTimeFormat
type DateTimeFormat
Members
Member name | Value | Description
ShortDate | 0 |
LongDate | 1 |
ShortDateTime | 2 |
LongDateTime | 3 |
ShortDayMonth | 4 |
See Also
NFX.Wave Namespace


Portal.MoneyFormat Enumeration

Portal MoneyFormat Enumeration NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum MoneyFormat
public enum MoneyFormat
Public Enumeration MoneyFormat
Public Enumeration MoneyFormat
public enum class MoneyFormat
public enum class MoneyFormat
type MoneyFormat
type MoneyFormat
Members
Member name | Value | Description
WithCurrencySymbol | 0 |
WithoutCurrencySymbol | 1 |
See Also
NFX.Wave Namespace


PortalHub Class

PortalHub Class NFX Class Library

Portal hub - a registry of portals, It establishes a context for portal inter-operation (i.e. so one portal may locate another by name) when some settings need to be cloned. This is an app-started singleton instance class
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave PortalHub

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class PortalHub : ApplicationComponent,
    IApplicationStarter, IConfigurable, IApplicationFinishNotifiable, INamed
public sealed class PortalHub : ApplicationComponent,
    IApplicationStarter, IConfigurable, IApplicationFinishNotifiable, INamed
Public NotInheritable Class PortalHub
    Inherits ApplicationComponent
    Implements IApplicationStarter, IConfigurable, IApplicationFinishNotifiable, INamed
Public NotInheritable Class PortalHub
    Inherits ApplicationComponent
    Implements IApplicationStarter, IConfigurable, IApplicationFinishNotifiable, INamed
public ref class PortalHub sealed : public ApplicationComponent,
    IApplicationStarter, IConfigurable, IApplicationFinishNotifiable, INamed
public ref class PortalHub sealed : public ApplicationComponent,
    IApplicationStarter, IConfigurable, IApplicationFinishNotifiable, INamed
[<SealedAttribute>]
type PortalHub =
    class
        inherit ApplicationComponent
        interface IApplicationStarter
        interface IConfigurable
        interface IApplicationFinishNotifiable
        interface INamed
    end
[<SealedAttribute>]
type PortalHub =
    class
        inherit ApplicationComponent
        interface IApplicationStarter
        interface IConfigurable
        interface IApplicationFinishNotifiable
        interface INamed
    end
See Also
PortalHub Members
NFX.Wave Namespace


PortalHub Members

PortalHub Members NFX Class Library

The PortalHub type exposes the following members.
Constructors
 | Name | Description
Protected method | PortalHub | Initializes a new instance of the PortalHub class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GenerateContentFileVersionSegment | Generates file version path segment suitable for usage in file name. This method is slow as it does byte file sig calculation
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_CONTENT_FS_SECTION |
 | CONFIG_FS_CONNECT_PARAMS_SECTION |
 | CONFIG_FS_ROOT_PATH_ATTR |
 | CONFIG_PORTAL_SECTION |
Protected field | m_Portals |
 | s_Instance |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ContentFileSystem | Returns file system that serves static content for portals
Public property | ContentFileSystemConnectParams |
Public property | ContentFileSystemRootPath | Returns root path for content file system
Public property | DefaultOnline | Returns first portal which is not Offline and marked as default
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
 | Instance | Returns singleton instance
 | InstanceAvailable | True if instance is allocated
Public property | Name |
Public property | Portals | Registry of all portals in the hub
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IApplicationFinishNotifiable ApplicationFinishAfterCleanup |
Explicit interface implemetation | IApplicationFinishNotifiable ApplicationFinishBeforeCleanup |
Explicit interface implemetation | IApplicationStarter ApplicationStartAfterInit |
Explicit interface implemetation | IApplicationStarter ApplicationStartBeforeInit |
Explicit interface implemetation | IApplicationStarter ApplicationStartBreakOnException |
Explicit interface implemetation | IConfigurable Configure |
Back to Top
See Also
PortalHub Class
NFX.Wave Namespace


PortalHub Constructor

PortalHub Constructor NFX Class Library

Initializes a new instance of the PortalHub class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PortalHub()
internal PortalHub()
Friend Sub New
Friend Sub New
internal:
PortalHub()
internal:
PortalHub()
new : unit -> PortalHub
new : unit -> PortalHub
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub Fields

PortalHub Fields NFX Class Library

The PortalHub type exposes the following members.
Fields
 | Name | Description
 | CONFIG_CONTENT_FS_SECTION |
 | CONFIG_FS_CONNECT_PARAMS_SECTION |
 | CONFIG_FS_ROOT_PATH_ATTR |
 | CONFIG_PORTAL_SECTION |
Protected field | m_Portals |
 | s_Instance |
Back to Top
See Also
PortalHub Class
NFX.Wave Namespace


PortalHub.CONFIG_CONTENT_FS_SECTION Field

PortalHub CONFIG_CONTENT_FS_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CONTENT_FS_SECTION
public const string CONFIG_CONTENT_FS_SECTION
Public Const CONFIG_CONTENT_FS_SECTION As String
Public Const CONFIG_CONTENT_FS_SECTION As String
public:
literal String^ CONFIG_CONTENT_FS_SECTION
public:
literal String^ CONFIG_CONTENT_FS_SECTION
static val mutable CONFIG_CONTENT_FS_SECTION: string
static val mutable CONFIG_CONTENT_FS_SECTION: string

Field Value

Type: Online String
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.CONFIG_FS_CONNECT_PARAMS_SECTION Field

PortalHub CONFIG_FS_CONNECT_PARAMS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FS_CONNECT_PARAMS_SECTION
public const string CONFIG_FS_CONNECT_PARAMS_SECTION
Public Const CONFIG_FS_CONNECT_PARAMS_SECTION As String
Public Const CONFIG_FS_CONNECT_PARAMS_SECTION As String
public:
literal String^ CONFIG_FS_CONNECT_PARAMS_SECTION
public:
literal String^ CONFIG_FS_CONNECT_PARAMS_SECTION
static val mutable CONFIG_FS_CONNECT_PARAMS_SECTION: string
static val mutable CONFIG_FS_CONNECT_PARAMS_SECTION: string

Field Value

Type: Online String
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.CONFIG_FS_ROOT_PATH_ATTR Field

PortalHub CONFIG_FS_ROOT_PATH_ATTR Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FS_ROOT_PATH_ATTR
public const string CONFIG_FS_ROOT_PATH_ATTR
Public Const CONFIG_FS_ROOT_PATH_ATTR As String
Public Const CONFIG_FS_ROOT_PATH_ATTR As String
public:
literal String^ CONFIG_FS_ROOT_PATH_ATTR
public:
literal String^ CONFIG_FS_ROOT_PATH_ATTR
static val mutable CONFIG_FS_ROOT_PATH_ATTR: string
static val mutable CONFIG_FS_ROOT_PATH_ATTR: string

Field Value

Type: Online String
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.CONFIG_PORTAL_SECTION Field

PortalHub CONFIG_PORTAL_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PORTAL_SECTION
public const string CONFIG_PORTAL_SECTION
Public Const CONFIG_PORTAL_SECTION As String
Public Const CONFIG_PORTAL_SECTION As String
public:
literal String^ CONFIG_PORTAL_SECTION
public:
literal String^ CONFIG_PORTAL_SECTION
static val mutable CONFIG_PORTAL_SECTION: string
static val mutable CONFIG_PORTAL_SECTION: string

Field Value

Type: Online String
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.m_Portals Field

PortalHub m_Portals Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Registry<Portal> m_Portals
internal Registry<Portal> m_Portals
Friend m_Portals As Registry(Of Portal)
Friend m_Portals As Registry(Of Portal)
internal:
Registry<Portal^>^ m_Portals
internal:
Registry<Portal^>^ m_Portals
val mutable internal m_Portals: Registry<Portal>
val mutable internal m_Portals: Registry<Portal>

Field Value

Type: Registry Portal
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.s_Instance Field

PortalHub s_Instance Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static PortalHub s_Instance
internal static PortalHub s_Instance
Friend Shared s_Instance As PortalHub
Friend Shared s_Instance As PortalHub
internal:
static PortalHub^ s_Instance
internal:
static PortalHub^ s_Instance
static val mutable internal s_Instance: PortalHub
static val mutable internal s_Instance: PortalHub

Field Value

Type: PortalHub
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub Methods

PortalHub Methods NFX Class Library

The PortalHub type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GenerateContentFileVersionSegment | Generates file version path segment suitable for usage in file name. This method is slow as it does byte file sig calculation
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IApplicationFinishNotifiable ApplicationFinishAfterCleanup |
Explicit interface implemetation | IApplicationFinishNotifiable ApplicationFinishBeforeCleanup |
Explicit interface implemetation | IApplicationStarter ApplicationStartAfterInit |
Explicit interface implemetation | IApplicationStarter ApplicationStartBeforeInit |
Explicit interface implemetation | IConfigurable Configure |
Back to Top
See Also
PortalHub Class
NFX.Wave Namespace


PortalHub.Destructor Method

PortalHub Destructor Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.GenerateContentFileVersionSegment Method

PortalHub GenerateContentFileVersionSegment Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates file version path segment suitable for usage in file name. This method is slow as it does byte file sig calculation

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GenerateContentFileVersionSegment(
    string filePath
)
public string GenerateContentFileVersionSegment(
    string filePath
)
Public Function GenerateContentFileVersionSegment (
    filePath As String
) As String
Public Function GenerateContentFileVersionSegment (
    filePath As String
) As String
public:
String^ GenerateContentFileVersionSegment(
    String^ filePath
)
public:
String^ GenerateContentFileVersionSegment(
    String^ filePath
)
member GenerateContentFileVersionSegment :
        filePath : string -> string
member GenerateContentFileVersionSegment :
        filePath : string -> string

Parameters

filePath
Type: Online System String

Return Value

Type: Online String
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.IApplicationFinishNotifiable.ApplicationFinishAfterCleanup Method

PortalHub IApplicationFinishNotifiable ApplicationFinishAfterCleanup Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IApplicationFinishNotifiable.ApplicationFinishAfterCleanup(
    IApplication application
)
void IApplicationFinishNotifiable.ApplicationFinishAfterCleanup(
    IApplication application
)
Private Sub ApplicationFinishAfterCleanup (
    application As IApplication
) Implements IApplicationFinishNotifiable.ApplicationFinishAfterCleanup
Private Sub ApplicationFinishAfterCleanup (
    application As IApplication
) Implements IApplicationFinishNotifiable.ApplicationFinishAfterCleanup
private:
virtual void ApplicationFinishAfterCleanup(
    IApplication^ application
) sealed = IApplicationFinishNotifiable::ApplicationFinishAfterCleanup
private:
virtual void ApplicationFinishAfterCleanup(
    IApplication^ application
) sealed = IApplicationFinishNotifiable::ApplicationFinishAfterCleanup
private abstract ApplicationFinishAfterCleanup :
        application : IApplication -> unit
private override ApplicationFinishAfterCleanup :
        application : IApplication -> unit
private abstract ApplicationFinishAfterCleanup :
        application : IApplication -> unit
private override ApplicationFinishAfterCleanup :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationFinishNotifiable ApplicationFinishAfterCleanup(IApplication)
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup Method

PortalHub IApplicationFinishNotifiable ApplicationFinishBeforeCleanup Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup(
    IApplication application
)
void IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup(
    IApplication application
)
Private Sub ApplicationFinishBeforeCleanup (
    application As IApplication
) Implements IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup
Private Sub ApplicationFinishBeforeCleanup (
    application As IApplication
) Implements IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup
private:
virtual void ApplicationFinishBeforeCleanup(
    IApplication^ application
) sealed = IApplicationFinishNotifiable::ApplicationFinishBeforeCleanup
private:
virtual void ApplicationFinishBeforeCleanup(
    IApplication^ application
) sealed = IApplicationFinishNotifiable::ApplicationFinishBeforeCleanup
private abstract ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
private override ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
private abstract ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
private override ApplicationFinishBeforeCleanup :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationFinishNotifiable ApplicationFinishBeforeCleanup(IApplication)
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.IApplicationStarter.ApplicationStartAfterInit Method

PortalHub IApplicationStarter ApplicationStartAfterInit Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IApplicationStarter.ApplicationStartAfterInit(
    IApplication application
)
void IApplicationStarter.ApplicationStartAfterInit(
    IApplication application
)
Private Sub ApplicationStartAfterInit (
    application As IApplication
) Implements IApplicationStarter.ApplicationStartAfterInit
Private Sub ApplicationStartAfterInit (
    application As IApplication
) Implements IApplicationStarter.ApplicationStartAfterInit
private:
virtual void ApplicationStartAfterInit(
    IApplication^ application
) sealed = IApplicationStarter::ApplicationStartAfterInit
private:
virtual void ApplicationStartAfterInit(
    IApplication^ application
) sealed = IApplicationStarter::ApplicationStartAfterInit
private abstract ApplicationStartAfterInit :
        application : IApplication -> unit
private override ApplicationStartAfterInit :
        application : IApplication -> unit
private abstract ApplicationStartAfterInit :
        application : IApplication -> unit
private override ApplicationStartAfterInit :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationStarter ApplicationStartAfterInit(IApplication)
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.IApplicationStarter.ApplicationStartBeforeInit Method

PortalHub IApplicationStarter ApplicationStartBeforeInit Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IApplicationStarter.ApplicationStartBeforeInit(
    IApplication application
)
void IApplicationStarter.ApplicationStartBeforeInit(
    IApplication application
)
Private Sub ApplicationStartBeforeInit (
    application As IApplication
) Implements IApplicationStarter.ApplicationStartBeforeInit
Private Sub ApplicationStartBeforeInit (
    application As IApplication
) Implements IApplicationStarter.ApplicationStartBeforeInit
private:
virtual void ApplicationStartBeforeInit(
    IApplication^ application
) sealed = IApplicationStarter::ApplicationStartBeforeInit
private:
virtual void ApplicationStartBeforeInit(
    IApplication^ application
) sealed = IApplicationStarter::ApplicationStartBeforeInit
private abstract ApplicationStartBeforeInit :
        application : IApplication -> unit
private override ApplicationStartBeforeInit :
        application : IApplication -> unit
private abstract ApplicationStartBeforeInit :
        application : IApplication -> unit
private override ApplicationStartBeforeInit :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationStarter ApplicationStartBeforeInit(IApplication)
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.IConfigurable.Configure Method

PortalHub IConfigurable Configure Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IConfigurable.Configure(
    IConfigSectionNode node
)
void IConfigurable.Configure(
    IConfigSectionNode node
)
Private Sub Configure (
    node As IConfigSectionNode
) Implements IConfigurable.Configure
Private Sub Configure (
    node As IConfigSectionNode
) Implements IConfigurable.Configure
private:
virtual void Configure(
    IConfigSectionNode^ node
) sealed = IConfigurable::Configure
private:
virtual void Configure(
    IConfigSectionNode^ node
) sealed = IConfigurable::Configure
private abstract Configure :
        node : IConfigSectionNode -> unit
private override Configure :
        node : IConfigSectionNode -> unit
private abstract Configure :
        node : IConfigSectionNode -> unit
private override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub Properties

PortalHub Properties NFX Class Library

The PortalHub type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ContentFileSystem | Returns file system that serves static content for portals
Public property | ContentFileSystemConnectParams |
Public property | ContentFileSystemRootPath | Returns root path for content file system
Public property | DefaultOnline | Returns first portal which is not Offline and marked as default
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
 | Instance | Returns singleton instance
 | InstanceAvailable | True if instance is allocated
Public property | Name |
Public property | Portals | Registry of all portals in the hub
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IApplicationStarter ApplicationStartBreakOnException |
Back to Top
See Also
PortalHub Class
NFX.Wave Namespace


PortalHub.ContentFileSystem Property

PortalHub ContentFileSystem Property NFX Class Library

Returns file system that serves static content for portals

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IFileSystem ContentFileSystem { get; }
public IFileSystem ContentFileSystem { get; }
Public ReadOnly Property ContentFileSystem As IFileSystem
    Get
Public ReadOnly Property ContentFileSystem As IFileSystem
    Get
public:
property IFileSystem^ ContentFileSystem {
    IFileSystem^ get ();
}
public:
property IFileSystem^ ContentFileSystem {
    IFileSystem^ get ();
}
member ContentFileSystem : IFileSystem with get
member ContentFileSystem : IFileSystem with get

Property Value

Type: IFileSystem
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.ContentFileSystemConnectParams Property

PortalHub ContentFileSystemConnectParams Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemSessionConnectParams ContentFileSystemConnectParams { get; }
public FileSystemSessionConnectParams ContentFileSystemConnectParams { get; }
Public ReadOnly Property ContentFileSystemConnectParams As FileSystemSessionConnectParams
    Get
Public ReadOnly Property ContentFileSystemConnectParams As FileSystemSessionConnectParams
    Get
public:
property FileSystemSessionConnectParams^ ContentFileSystemConnectParams {
    FileSystemSessionConnectParams^ get ();
}
public:
property FileSystemSessionConnectParams^ ContentFileSystemConnectParams {
    FileSystemSessionConnectParams^ get ();
}
member ContentFileSystemConnectParams : FileSystemSessionConnectParams with get
member ContentFileSystemConnectParams : FileSystemSessionConnectParams with get

Property Value

Type: FileSystemSessionConnectParams
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.ContentFileSystemRootPath Property

PortalHub ContentFileSystemRootPath Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns root path for content file system

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ContentFileSystemRootPath { get; }
public string ContentFileSystemRootPath { get; }
Public ReadOnly Property ContentFileSystemRootPath As String
    Get
Public ReadOnly Property ContentFileSystemRootPath As String
    Get
public:
property String^ ContentFileSystemRootPath {
    String^ get ();
}
public:
property String^ ContentFileSystemRootPath {
    String^ get ();
}
member ContentFileSystemRootPath : string with get
member ContentFileSystemRootPath : string with get

Property Value

Type: Online String
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.DefaultOnline Property

PortalHub DefaultOnline Property NFX Class Library

Returns first portal which is not Offline and marked as default

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Portal DefaultOnline { get; }
public Portal DefaultOnline { get; }
Public ReadOnly Property DefaultOnline As Portal
    Get
Public ReadOnly Property DefaultOnline As Portal
    Get
public:
property Portal^ DefaultOnline {
    Portal^ get ();
}
public:
property Portal^ DefaultOnline {
    Portal^ get ();
}
member DefaultOnline : Portal with get
member DefaultOnline : Portal with get

Property Value

Type: Portal
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.IApplicationStarter.ApplicationStartBreakOnException Property

PortalHub IApplicationStarter ApplicationStartBreakOnException Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IApplicationStarter.ApplicationStartBreakOnException { get; }
bool IApplicationStarter.ApplicationStartBreakOnException { get; }
Private ReadOnly Property ApplicationStartBreakOnException As Boolean
    Implements IApplicationStarter.ApplicationStartBreakOnException
    Get
Private ReadOnly Property ApplicationStartBreakOnException As Boolean
    Implements IApplicationStarter.ApplicationStartBreakOnException
    Get
private:
virtual property bool ApplicationStartBreakOnException {
    bool get () sealed = IApplicationStarter::ApplicationStartBreakOnException::get;
}
private:
virtual property bool ApplicationStartBreakOnException {
    bool get () sealed = IApplicationStarter::ApplicationStartBreakOnException::get;
}
private abstract ApplicationStartBreakOnException : bool with get
private override ApplicationStartBreakOnException : bool with get
private abstract ApplicationStartBreakOnException : bool with get
private override ApplicationStartBreakOnException : bool with get

Property Value

Type: Online Boolean

Implements

IApplicationStarter ApplicationStartBreakOnException
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.Instance Property

PortalHub Instance Property NFX Class Library

Returns singleton instance

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PortalHub Instance { get; }
public static PortalHub Instance { get; }
Public Shared ReadOnly Property Instance As PortalHub
    Get
Public Shared ReadOnly Property Instance As PortalHub
    Get
public:
static property PortalHub^ Instance {
    PortalHub^ get ();
}
public:
static property PortalHub^ Instance {
    PortalHub^ get ();
}
static member Instance : PortalHub with get
static member Instance : PortalHub with get

Property Value

Type: PortalHub
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.InstanceAvailable Property

PortalHub InstanceAvailable Property NFX Class Library

True if instance is allocated

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool InstanceAvailable { get; }
public static bool InstanceAvailable { get; }
Public Shared ReadOnly Property InstanceAvailable As Boolean
    Get
Public Shared ReadOnly Property InstanceAvailable As Boolean
    Get
public:
static property bool InstanceAvailable {
    bool get ();
}
public:
static property bool InstanceAvailable {
    bool get ();
}
static member InstanceAvailable : bool with get
static member InstanceAvailable : bool with get

Property Value

Type: Online Boolean
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.Name Property

PortalHub Name Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


PortalHub.Portals Property

PortalHub Portals Property NFX Class Library

Registry of all portals in the hub

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<Portal> Portals { get; }
public IRegistry<Portal> Portals { get; }
Public ReadOnly Property Portals As IRegistry(Of Portal)
    Get
Public ReadOnly Property Portals As IRegistry(Of Portal)
    Get
public:
property IRegistry<Portal^>^ Portals {
    IRegistry<Portal^>^ get ();
}
public:
property IRegistry<Portal^>^ Portals {
    IRegistry<Portal^>^ get ();
}
member Portals : IRegistry<Portal> with get
member Portals : IRegistry<Portal> with get

Property Value

Type: IRegistry Portal
See Also
PortalHub Class
PortalHub Members
NFX.Wave Namespace


Response Class

Response Class NFX Class Library

Represents Response object used to generate web responses to client
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Wave Response

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Response : DisposableObject
public sealed class Response : DisposableObject
Public NotInheritable Class Response
    Inherits DisposableObject
Public NotInheritable Class Response
    Inherits DisposableObject
public ref class Response sealed : public DisposableObject
public ref class Response sealed : public DisposableObject
[<SealedAttribute>]
type Response =
    class
        inherit DisposableObject
    end
[<SealedAttribute>]
type Response =
    class
        inherit DisposableObject
    end
See Also
Response Members
NFX.Wave Namespace


Response Members

Response Members NFX Class Library

The Response type exposes the following members.
Constructors
 | Name | Description
Protected method | Response | Initializes a new instance of the Response class
Back to Top
Methods
 | Name | Description
Public method | AddHeader | Adds Http header
Public method | AppendCookie | Appends cookie to the response
Public method | CancelBuffered | Cancels the buffered content. Throws if the response is not Buffered
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Flush | RESERVED FOR FUTURE USE. Flushes the internally buffered content
Public method | GetClientVar | Provides access to client state object which gets persisted as a cookie. Client states need to be used instead of cookies because of some HttpListener+Browser limitations that can not parse multiple cookies set into one Set-Cookie header
Public method | GetClientVarNames | Provides access to client state object which gets persisted as a cookie. Client states need to be used instead of cookies because of some HttpListener+Browser limitations that can not parse multiple cookies set into one Set-Cookie header
Public method | GetDirectOutputStreamForWriting | Returns output stream for direct output and marks response as beeing written into
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Redirect | Configures response with redirect status and headers. This method DOES NOT ABORT the work pipeline,so the processing of filters and handlers continues unless 'work.Aborted = true' is issued in code. See also 'RedirectAndAbort(url)'
Public method | RedirectAndAbort | Configures response with redirect status and headers. This method also aborts the work pipeline,so the processing of filters and handlers does not continue. See also 'Redirect(url)'
Public method | SetCacheControlHeaders |
Public method | SetClientVar | Provides access to client state object which gets persisted as a cookie. Client states need to be used instead of cookies because of some HttpListener+Browser limitations that can not parse multiple cookies set into one Set-Cookie header. Pass null for value to delete the var form the collection. The values are generally expected to be base64 encoded by the caller
Public method | SetNoCacheHeaders | Sets headers so all downstream, layers (browsers, proxies) do not cache response. If Force==true(default) then overrides existing headers with no cache. Returns true when headers were set
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write(Object) | Writes an object into response as string
Public method | Write(String) | Writes a string into response
Public method | WriteFile | Write the file to the client so client can download it. May set Buffered=false to use chunked encoding for big files
Public method | WriteJSON | Writes an object as JSON. Does nothing if object is null
Public method | WriteLine(Object) | Writes an object into response as string
Public method | WriteLine(String) | Writes a string into response
Public method | WriteStream | Write the contents of the stream to the client so client can download it. May set Buffered=false to use chunked encoding for big files
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | DEFAULT_DOWNLOAD_BUFFER_SIZE |
 | MAX_DOWNLOAD_BUFFER_SIZE |
 | MAX_DOWNLOAD_FILE_SIZE |
 | MIN_DOWNLOAD_BUFFER_SIZE |
Public field | Work |
Back to Top
Properties
 | Name | Description
Public property | Buffered | Determines whether the content is buffered locally. This property can not be set after the response has been written to
Public property | ClientVarsChanged | Returns true if current request processing cycle has changed the client var
Public property | ContentType | Http content type
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Encoding | Gets/sets content encoding
Public property | Headers | Returns http headers of the response
Public property | StatusCode | Http status code
Public property | StatusDescription | Http status description
Public property | WasWrittenTo | Returns true if some output has been performed
Back to Top
See Also
Response Class
NFX.Wave Namespace


Response Constructor

Response Constructor NFX Class Library

Initializes a new instance of the Response class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Response(
    WorkContext work,
    HttpListenerResponse netResponse
)
internal Response(
    WorkContext work,
    HttpListenerResponse netResponse
)
Friend Sub New (
    work As WorkContext,
    netResponse As HttpListenerResponse
)
Friend Sub New (
    work As WorkContext,
    netResponse As HttpListenerResponse
)
internal:
Response(
    WorkContext^ work,
    HttpListenerResponse^ netResponse
)
internal:
Response(
    WorkContext^ work,
    HttpListenerResponse^ netResponse
)
new :
        work : WorkContext *
        netResponse : HttpListenerResponse -> Response
new :
        work : WorkContext *
        netResponse : HttpListenerResponse -> Response

Parameters

work
Type: NFX.Wave WorkContext
netResponse
Type: Online System.Net HttpListenerResponse
See Also
Response Class
Response Members
NFX.Wave Namespace


Response Fields

Response Fields NFX Class Library

The Response type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_DOWNLOAD_BUFFER_SIZE |
 | MAX_DOWNLOAD_BUFFER_SIZE |
 | MAX_DOWNLOAD_FILE_SIZE |
 | MIN_DOWNLOAD_BUFFER_SIZE |
Public field | Work |
Back to Top
See Also
Response Class
NFX.Wave Namespace


Response.DEFAULT_DOWNLOAD_BUFFER_SIZE Field

Response DEFAULT_DOWNLOAD_BUFFER_SIZE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_DOWNLOAD_BUFFER_SIZE
public const int DEFAULT_DOWNLOAD_BUFFER_SIZE
Public Const DEFAULT_DOWNLOAD_BUFFER_SIZE As Integer
Public Const DEFAULT_DOWNLOAD_BUFFER_SIZE As Integer
public:
literal int DEFAULT_DOWNLOAD_BUFFER_SIZE
public:
literal int DEFAULT_DOWNLOAD_BUFFER_SIZE
static val mutable DEFAULT_DOWNLOAD_BUFFER_SIZE: int
static val mutable DEFAULT_DOWNLOAD_BUFFER_SIZE: int

Field Value

Type: Online Int32
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.MAX_DOWNLOAD_BUFFER_SIZE Field

Response MAX_DOWNLOAD_BUFFER_SIZE Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_DOWNLOAD_BUFFER_SIZE
public const int MAX_DOWNLOAD_BUFFER_SIZE
Public Const MAX_DOWNLOAD_BUFFER_SIZE As Integer
Public Const MAX_DOWNLOAD_BUFFER_SIZE As Integer
public:
literal int MAX_DOWNLOAD_BUFFER_SIZE
public:
literal int MAX_DOWNLOAD_BUFFER_SIZE
static val mutable MAX_DOWNLOAD_BUFFER_SIZE: int
static val mutable MAX_DOWNLOAD_BUFFER_SIZE: int

Field Value

Type: Online Int32
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.MAX_DOWNLOAD_FILE_SIZE Field

Response MAX_DOWNLOAD_FILE_SIZE Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_DOWNLOAD_FILE_SIZE
public const int MAX_DOWNLOAD_FILE_SIZE
Public Const MAX_DOWNLOAD_FILE_SIZE As Integer
Public Const MAX_DOWNLOAD_FILE_SIZE As Integer
public:
literal int MAX_DOWNLOAD_FILE_SIZE
public:
literal int MAX_DOWNLOAD_FILE_SIZE
static val mutable MAX_DOWNLOAD_FILE_SIZE: int
static val mutable MAX_DOWNLOAD_FILE_SIZE: int

Field Value

Type: Online Int32
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.MIN_DOWNLOAD_BUFFER_SIZE Field

Response MIN_DOWNLOAD_BUFFER_SIZE Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MIN_DOWNLOAD_BUFFER_SIZE
public const int MIN_DOWNLOAD_BUFFER_SIZE
Public Const MIN_DOWNLOAD_BUFFER_SIZE As Integer
Public Const MIN_DOWNLOAD_BUFFER_SIZE As Integer
public:
literal int MIN_DOWNLOAD_BUFFER_SIZE
public:
literal int MIN_DOWNLOAD_BUFFER_SIZE
static val mutable MIN_DOWNLOAD_BUFFER_SIZE: int
static val mutable MIN_DOWNLOAD_BUFFER_SIZE: int

Field Value

Type: Online Int32
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.Work Field

Response Work Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly WorkContext Work
public readonly WorkContext Work
Public ReadOnly Work As WorkContext
Public ReadOnly Work As WorkContext
public:
initonly WorkContext^ Work
public:
initonly WorkContext^ Work
val Work: WorkContext
val Work: WorkContext

Field Value

Type: WorkContext
See Also
Response Class
Response Members
NFX.Wave Namespace


Response Methods

Response Methods NFX Class Library

The Response type exposes the following members.
Methods
 | Name | Description
Public method | AddHeader | Adds Http header
Public method | AppendCookie | Appends cookie to the response
Public method | CancelBuffered | Cancels the buffered content. Throws if the response is not Buffered
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Flush | RESERVED FOR FUTURE USE. Flushes the internally buffered content
Public method | GetClientVar | Provides access to client state object which gets persisted as a cookie. Client states need to be used instead of cookies because of some HttpListener+Browser limitations that can not parse multiple cookies set into one Set-Cookie header
Public method | GetClientVarNames | Provides access to client state object which gets persisted as a cookie. Client states need to be used instead of cookies because of some HttpListener+Browser limitations that can not parse multiple cookies set into one Set-Cookie header
Public method | GetDirectOutputStreamForWriting | Returns output stream for direct output and marks response as beeing written into
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Redirect | Configures response with redirect status and headers. This method DOES NOT ABORT the work pipeline,so the processing of filters and handlers continues unless 'work.Aborted = true' is issued in code. See also 'RedirectAndAbort(url)'
Public method | RedirectAndAbort | Configures response with redirect status and headers. This method also aborts the work pipeline,so the processing of filters and handlers does not continue. See also 'Redirect(url)'
Public method | SetCacheControlHeaders |
Public method | SetClientVar | Provides access to client state object which gets persisted as a cookie. Client states need to be used instead of cookies because of some HttpListener+Browser limitations that can not parse multiple cookies set into one Set-Cookie header. Pass null for value to delete the var form the collection. The values are generally expected to be base64 encoded by the caller
Public method | SetNoCacheHeaders | Sets headers so all downstream, layers (browsers, proxies) do not cache response. If Force==true(default) then overrides existing headers with no cache. Returns true when headers were set
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write(Object) | Writes an object into response as string
Public method | Write(String) | Writes a string into response
Public method | WriteFile | Write the file to the client so client can download it. May set Buffered=false to use chunked encoding for big files
Public method | WriteJSON | Writes an object as JSON. Does nothing if object is null
Public method | WriteLine(Object) | Writes an object into response as string
Public method | WriteLine(String) | Writes a string into response
Public method | WriteStream | Write the contents of the stream to the client so client can download it. May set Buffered=false to use chunked encoding for big files
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Response Class
NFX.Wave Namespace


Response.AddHeader Method

Response AddHeader Method NFX Class Library

Adds Http header

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddHeader(
    string name,
    string value
)
public void AddHeader(
    string name,
    string value
)
Public Sub AddHeader (
    name As String,
    value As String
)
Public Sub AddHeader (
    name As String,
    value As String
)
public:
void AddHeader(
    String^ name,
    String^ value
)
public:
void AddHeader(
    String^ name,
    String^ value
)
member AddHeader :
        name : string *
        value : string -> unit
member AddHeader :
        name : string *
        value : string -> unit

Parameters

name
Type: Online System String
value
Type: Online System String
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.AppendCookie Method

Response AppendCookie Method NFX Class Library

Appends cookie to the response

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AppendCookie(
    Cookie cookie
)
public void AppendCookie(
    Cookie cookie
)
Public Sub AppendCookie (
    cookie As Cookie
)
Public Sub AppendCookie (
    cookie As Cookie
)
public:
void AppendCookie(
    Cookie^ cookie
)
public:
void AppendCookie(
    Cookie^ cookie
)
member AppendCookie :
        cookie : Cookie -> unit
member AppendCookie :
        cookie : Cookie -> unit

Parameters

cookie
Type: Online System.Net Cookie
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.CancelBuffered Method

Response CancelBuffered Method NFX Class Library

Cancels the buffered content. Throws if the response is not Buffered

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CancelBuffered()
public void CancelBuffered()
Public Sub CancelBuffered
Public Sub CancelBuffered
public:
void CancelBuffered()
public:
void CancelBuffered()
member CancelBuffered : unit -> unit
member CancelBuffered : unit -> unit
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.Destructor Method

Response Destructor Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.Flush Method

Response Flush Method NFX Class Library

RESERVED FOR FUTURE USE. Flushes the internally buffered content

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Flush()
public void Flush()
Public Sub Flush
Public Sub Flush
public:
void Flush()
public:
void Flush()
member Flush : unit -> unit
member Flush : unit -> unit
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.GetClientVar Method

Response GetClientVar Method NFX Class Library

Provides access to client state object which gets persisted as a cookie. Client states need to be used instead of cookies because of some HttpListener+Browser limitations that can not parse multiple cookies set into one Set-Cookie header

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetClientVar(
    string key
)
public string GetClientVar(
    string key
)
Public Function GetClientVar (
    key As String
) As String
Public Function GetClientVar (
    key As String
) As String
public:
String^ GetClientVar(
    String^ key
)
public:
String^ GetClientVar(
    String^ key
)
member GetClientVar :
        key : string -> string
member GetClientVar :
        key : string -> string

Parameters

key
Type: Online System String

Return Value

Type: Online String
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.GetClientVarNames Method

Response GetClientVarNames Method NFX Class Library

Provides access to client state object which gets persisted as a cookie. Client states need to be used instead of cookies because of some HttpListener+Browser limitations that can not parse multiple cookies set into one Set-Cookie header

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<string> GetClientVarNames()
public IEnumerable<string> GetClientVarNames()
Public Function GetClientVarNames As IEnumerable(Of String)
Public Function GetClientVarNames As IEnumerable(Of String)
public:
IEnumerable<String^>^ GetClientVarNames()
public:
IEnumerable<String^>^ GetClientVarNames()
member GetClientVarNames : unit -> IEnumerable<string>
member GetClientVarNames : unit -> IEnumerable<string>

Return Value

Type: Online IEnumerable Online String
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.GetDirectOutputStreamForWriting Method

Response GetDirectOutputStreamForWriting Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns output stream for direct output and marks response as beeing written into

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Stream GetDirectOutputStreamForWriting()
public Stream GetDirectOutputStreamForWriting()
Public Function GetDirectOutputStreamForWriting As Stream
Public Function GetDirectOutputStreamForWriting As Stream
public:
Stream^ GetDirectOutputStreamForWriting()
public:
Stream^ GetDirectOutputStreamForWriting()
member GetDirectOutputStreamForWriting : unit -> Stream
member GetDirectOutputStreamForWriting : unit -> Stream

Return Value

Type: Online Stream
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.Redirect Method

Response Redirect Method NFX Class Library

Configures response with redirect status and headers. This method DOES NOT ABORT the work pipeline,so the processing of filters and handlers continues unless 'work.Aborted = true' is issued in code. See also 'RedirectAndAbort(url)'

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Redirect(
    string url,
    WebConsts..::..RedirectCode code = WebConsts..::..RedirectCode.Found_302
)
public void Redirect(
    string url,
    WebConsts..::..RedirectCode code = WebConsts..::..RedirectCode.Found_302
)
Public Sub Redirect (
    url As String,
    Optional code As WebConsts..::..RedirectCode = WebConsts..::..RedirectCode.Found_302
)
Public Sub Redirect (
    url As String,
    Optional code As WebConsts..::..RedirectCode = WebConsts..::..RedirectCode.Found_302
)
public:
void Redirect(
    String^ url,
    WebConsts..::..RedirectCode code = WebConsts..::..RedirectCode::Found_302
)
public:
void Redirect(
    String^ url,
    WebConsts..::..RedirectCode code = WebConsts..::..RedirectCode::Found_302
)
member Redirect :
        url : string *
        ?code : WebConsts..::..RedirectCode
(* Defaults:
        let _code = defaultArg code WebConsts..::..RedirectCode.Found_302
*)
-> unit
member Redirect :
        url : string *
        ?code : WebConsts..::..RedirectCode
(* Defaults:
        let _code = defaultArg code WebConsts..::..RedirectCode.Found_302
*)
-> unit

Parameters

url
Type: Online System String
code (Optional)
Type: NFX.Web WebConsts RedirectCode
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.RedirectAndAbort Method

Response RedirectAndAbort Method NFX Class Library

Configures response with redirect status and headers. This method also aborts the work pipeline,so the processing of filters and handlers does not continue. See also 'Redirect(url)'

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RedirectAndAbort(
    string url,
    WebConsts..::..RedirectCode code = WebConsts..::..RedirectCode.Found_302
)
public void RedirectAndAbort(
    string url,
    WebConsts..::..RedirectCode code = WebConsts..::..RedirectCode.Found_302
)
Public Sub RedirectAndAbort (
    url As String,
    Optional code As WebConsts..::..RedirectCode = WebConsts..::..RedirectCode.Found_302
)
Public Sub RedirectAndAbort (
    url As String,
    Optional code As WebConsts..::..RedirectCode = WebConsts..::..RedirectCode.Found_302
)
public:
void RedirectAndAbort(
    String^ url,
    WebConsts..::..RedirectCode code = WebConsts..::..RedirectCode::Found_302
)
public:
void RedirectAndAbort(
    String^ url,
    WebConsts..::..RedirectCode code = WebConsts..::..RedirectCode::Found_302
)
member RedirectAndAbort :
        url : string *
        ?code : WebConsts..::..RedirectCode
(* Defaults:
        let _code = defaultArg code WebConsts..::..RedirectCode.Found_302
*)
-> unit
member RedirectAndAbort :
        url : string *
        ?code : WebConsts..::..RedirectCode
(* Defaults:
        let _code = defaultArg code WebConsts..::..RedirectCode.Found_302
*)
-> unit

Parameters

url
Type: Online System String
code (Optional)
Type: NFX.Web WebConsts RedirectCode
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.SetCacheControlHeaders Method

Response SetCacheControlHeaders Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SetCacheControlHeaders(
    CacheControl control,
    bool force = true,
    string vary = null
)
public bool SetCacheControlHeaders(
    CacheControl control,
    bool force = true,
    string vary = null
)
Public Function SetCacheControlHeaders (
    control As CacheControl,
    Optional force As Boolean = true,
    Optional vary As String = Nothing
) As Boolean
Public Function SetCacheControlHeaders (
    control As CacheControl,
    Optional force As Boolean = true,
    Optional vary As String = Nothing
) As Boolean
public:
bool SetCacheControlHeaders(
    CacheControl control,
    bool force = true,
    String^ vary = nullptr
)
public:
bool SetCacheControlHeaders(
    CacheControl control,
    bool force = true,
    String^ vary = nullptr
)
member SetCacheControlHeaders :
        control : CacheControl *
        ?force : bool *
        ?vary : string
(* Defaults:
        let _force = defaultArg force true
        let _vary = defaultArg vary null
*)
-> bool
member SetCacheControlHeaders :
        control : CacheControl *
        ?force : bool *
        ?vary : string
(* Defaults:
        let _force = defaultArg force true
        let _vary = defaultArg vary null
*)
-> bool

Parameters

control
Type: NFX.Web CacheControl
force (Optional)
Type: Online System Boolean
vary (Optional)
Type: Online System String

Return Value

Type: Online Boolean
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.SetClientVar Method

Response SetClientVar Method NFX Class Library

Provides access to client state object which gets persisted as a cookie. Client states need to be used instead of cookies because of some HttpListener+Browser limitations that can not parse multiple cookies set into one Set-Cookie header. Pass null for value to delete the var form the collection. The values are generally expected to be base64 encoded by the caller

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetClientVar(
    string key,
    string value
)
public void SetClientVar(
    string key,
    string value
)
Public Sub SetClientVar (
    key As String,
    value As String
)
Public Sub SetClientVar (
    key As String,
    value As String
)
public:
void SetClientVar(
    String^ key,
    String^ value
)
public:
void SetClientVar(
    String^ key,
    String^ value
)
member SetClientVar :
        key : string *
        value : string -> unit
member SetClientVar :
        key : string *
        value : string -> unit

Parameters

key
Type: Online System String
value
Type: Online System String
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.SetNoCacheHeaders Method

Response SetNoCacheHeaders Method NFX Class Library

Sets headers so all downstream, layers (browsers, proxies) do not cache response. If Force==true(default) then overrides existing headers with no cache. Returns true when headers were set

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SetNoCacheHeaders(
    bool force = true
)
public bool SetNoCacheHeaders(
    bool force = true
)
Public Function SetNoCacheHeaders (
    Optional force As Boolean = true
) As Boolean
Public Function SetNoCacheHeaders (
    Optional force As Boolean = true
) As Boolean
public:
bool SetNoCacheHeaders(
    bool force = true
)
public:
bool SetNoCacheHeaders(
    bool force = true
)
member SetNoCacheHeaders :
        ?force : bool
(* Defaults:
        let _force = defaultArg force true
*)
-> bool
member SetNoCacheHeaders :
        ?force : bool
(* Defaults:
        let _force = defaultArg force true
*)
-> bool

Parameters

force (Optional)
Type: Online System Boolean

Return Value

Type: Online Boolean
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.Write Method

Response Write Method NFX Class Library

Overload List
 | Name | Description
Public method | Write(Object) | Writes an object into response as string
Public method | Write(String) | Writes a string into response
Back to Top
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.Write Method (Object)

Response Write Method (Object) NFX Class Library

Writes an object into response as string

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    Object content
)
public void Write(
    Object content
)
Public Sub Write (
    content As Object
)
Public Sub Write (
    content As Object
)
public:
void Write(
    Object^ content
)
public:
void Write(
    Object^ content
)
member Write :
        content : Object -> unit
member Write :
        content : Object -> unit

Parameters

content
Type: Online System Object
See Also
Response Class
Response Members
Write Overload
NFX.Wave Namespace


Response.Write Method (String)

Response Write Method (String) NFX Class Library

Writes a string into response

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    string content
)
public void Write(
    string content
)
Public Sub Write (
    content As String
)
Public Sub Write (
    content As String
)
public:
void Write(
    String^ content
)
public:
void Write(
    String^ content
)
member Write :
        content : string -> unit
member Write :
        content : string -> unit

Parameters

content
Type: Online System String
See Also
Response Class
Response Members
Write Overload
NFX.Wave Namespace


Response.WriteFile Method

Response WriteFile Method NFX Class Library

Write the file to the client so client can download it. May set Buffered=false to use chunked encoding for big files

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteFile(
    string localFileName,
    int bufferSize = 131072,
    bool attachment = false
)
public void WriteFile(
    string localFileName,
    int bufferSize = 131072,
    bool attachment = false
)
Public Sub WriteFile (
    localFileName As String,
    Optional bufferSize As Integer = 131072,
    Optional attachment As Boolean = false
)
Public Sub WriteFile (
    localFileName As String,
    Optional bufferSize As Integer = 131072,
    Optional attachment As Boolean = false
)
public:
void WriteFile(
    String^ localFileName,
    int bufferSize = 131072,
    bool attachment = false
)
public:
void WriteFile(
    String^ localFileName,
    int bufferSize = 131072,
    bool attachment = false
)
member WriteFile :
        localFileName : string *
        ?bufferSize : int *
        ?attachment : bool
(* Defaults:
        let _bufferSize = defaultArg bufferSize 131072
        let _attachment = defaultArg attachment false
*)
-> unit
member WriteFile :
        localFileName : string *
        ?bufferSize : int *
        ?attachment : bool
(* Defaults:
        let _bufferSize = defaultArg bufferSize 131072
        let _attachment = defaultArg attachment false
*)
-> unit

Parameters

localFileName
Type: Online System String
bufferSize (Optional)
Type: Online System Int32
attachment (Optional)
Type: Online System Boolean
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.WriteJSON Method

Response WriteJSON Method NFX Class Library

Writes an object as JSON. Does nothing if object is null

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteJSON(
    Object data,
    JSONWritingOptions options = null
)
public void WriteJSON(
    Object data,
    JSONWritingOptions options = null
)
Public Sub WriteJSON (
    data As Object,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteJSON (
    data As Object,
    Optional options As JSONWritingOptions = Nothing
)
public:
void WriteJSON(
    Object^ data,
    JSONWritingOptions^ options = nullptr
)
public:
void WriteJSON(
    Object^ data,
    JSONWritingOptions^ options = nullptr
)
member WriteJSON :
        data : Object *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
member WriteJSON :
        data : Object *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

data
Type: Online System Object
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.WriteLine Method

Response WriteLine Method NFX Class Library

Overload List
 | Name | Description
Public method | WriteLine(Object) | Writes an object into response as string
Public method | WriteLine(String) | Writes a string into response
Back to Top
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.WriteLine Method (Object)

Response WriteLine Method (Object) NFX Class Library

Writes an object into response as string

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteLine(
    Object content
)
public void WriteLine(
    Object content
)
Public Sub WriteLine (
    content As Object
)
Public Sub WriteLine (
    content As Object
)
public:
void WriteLine(
    Object^ content
)
public:
void WriteLine(
    Object^ content
)
member WriteLine :
        content : Object -> unit
member WriteLine :
        content : Object -> unit

Parameters

content
Type: Online System Object
See Also
Response Class
Response Members
WriteLine Overload
NFX.Wave Namespace


Response.WriteLine Method (String)

Response WriteLine Method (String) NFX Class Library

Writes a string into response

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteLine(
    string content
)
public void WriteLine(
    string content
)
Public Sub WriteLine (
    content As String
)
Public Sub WriteLine (
    content As String
)
public:
void WriteLine(
    String^ content
)
public:
void WriteLine(
    String^ content
)
member WriteLine :
        content : string -> unit
member WriteLine :
        content : string -> unit

Parameters

content
Type: Online System String
See Also
Response Class
Response Members
WriteLine Overload
NFX.Wave Namespace


Response.WriteStream Method

Response WriteStream Method NFX Class Library

Write the contents of the stream to the client so client can download it. May set Buffered=false to use chunked encoding for big files

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteStream(
    Stream stream,
    int bufferSize = 131072,
    string attachmentName = null
)
public void WriteStream(
    Stream stream,
    int bufferSize = 131072,
    string attachmentName = null
)
Public Sub WriteStream (
    stream As Stream,
    Optional bufferSize As Integer = 131072,
    Optional attachmentName As String = Nothing
)
Public Sub WriteStream (
    stream As Stream,
    Optional bufferSize As Integer = 131072,
    Optional attachmentName As String = Nothing
)
public:
void WriteStream(
    Stream^ stream,
    int bufferSize = 131072,
    String^ attachmentName = nullptr
)
public:
void WriteStream(
    Stream^ stream,
    int bufferSize = 131072,
    String^ attachmentName = nullptr
)
member WriteStream :
        stream : Stream *
        ?bufferSize : int *
        ?attachmentName : string
(* Defaults:
        let _bufferSize = defaultArg bufferSize 131072
        let _attachmentName = defaultArg attachmentName null
*)
-> unit
member WriteStream :
        stream : Stream *
        ?bufferSize : int *
        ?attachmentName : string
(* Defaults:
        let _bufferSize = defaultArg bufferSize 131072
        let _attachmentName = defaultArg attachmentName null
*)
-> unit

Parameters

stream
Type: Online System.IO Stream
bufferSize (Optional)
Type: Online System Int32
attachmentName (Optional)
Type: Online System String
See Also
Response Class
Response Members
NFX.Wave Namespace


Response Properties

Response Properties NFX Class Library

The Response type exposes the following members.
Properties
 | Name | Description
Public property | Buffered | Determines whether the content is buffered locally. This property can not be set after the response has been written to
Public property | ClientVarsChanged | Returns true if current request processing cycle has changed the client var
Public property | ContentType | Http content type
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Encoding | Gets/sets content encoding
Public property | Headers | Returns http headers of the response
Public property | StatusCode | Http status code
Public property | StatusDescription | Http status description
Public property | WasWrittenTo | Returns true if some output has been performed
Back to Top
See Also
Response Class
NFX.Wave Namespace


Response.Buffered Property

Response Buffered Property NFX Class Library

Determines whether the content is buffered locally. This property can not be set after the response has been written to

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Buffered { get; set; }
public bool Buffered { get; set; }
Public Property Buffered As Boolean
    Get
    Set
Public Property Buffered As Boolean
    Get
    Set
public:
property bool Buffered {
    bool get ();
    void set (bool value);
}
public:
property bool Buffered {
    bool get ();
    void set (bool value);
}
member Buffered : bool with get, set
member Buffered : bool with get, set

Property Value

Type: Online Boolean
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.ClientVarsChanged Property

Response ClientVarsChanged Property NFX Class Library

Returns true if current request processing cycle has changed the client var

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ClientVarsChanged { get; }
public bool ClientVarsChanged { get; }
Public ReadOnly Property ClientVarsChanged As Boolean
    Get
Public ReadOnly Property ClientVarsChanged As Boolean
    Get
public:
property bool ClientVarsChanged {
    bool get ();
}
public:
property bool ClientVarsChanged {
    bool get ();
}
member ClientVarsChanged : bool with get
member ClientVarsChanged : bool with get

Property Value

Type: Online Boolean
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.ContentType Property

Response ContentType Property NFX Class Library

Http content type

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ContentType { get; set; }
public string ContentType { get; set; }
Public Property ContentType As String
    Get
    Set
Public Property ContentType As String
    Get
    Set
public:
property String^ ContentType {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ContentType {
    String^ get ();
    void set (String^ value);
}
member ContentType : string with get, set
member ContentType : string with get, set

Property Value

Type: Online String
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.Encoding Property

Response Encoding Property NFX Class Library

Gets/sets content encoding

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Encoding Encoding { get; set; }
public Encoding Encoding { get; set; }
Public Property Encoding As Encoding
    Get
    Set
Public Property Encoding As Encoding
    Get
    Set
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
member Encoding : Encoding with get, set
member Encoding : Encoding with get, set

Property Value

Type: Online Encoding
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.Headers Property

Response Headers Property NFX Class Library

Returns http headers of the response

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebHeaderCollection Headers { get; }
public WebHeaderCollection Headers { get; }
Public ReadOnly Property Headers As WebHeaderCollection
    Get
Public ReadOnly Property Headers As WebHeaderCollection
    Get
public:
property WebHeaderCollection^ Headers {
    WebHeaderCollection^ get ();
}
public:
property WebHeaderCollection^ Headers {
    WebHeaderCollection^ get ();
}
member Headers : WebHeaderCollection with get
member Headers : WebHeaderCollection with get

Property Value

Type: Online WebHeaderCollection
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.StatusCode Property

Response StatusCode Property NFX Class Library

Http status code

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int StatusCode { get; set; }
public int StatusCode { get; set; }
Public Property StatusCode As Integer
    Get
    Set
Public Property StatusCode As Integer
    Get
    Set
public:
property int StatusCode {
    int get ();
    void set (int value);
}
public:
property int StatusCode {
    int get ();
    void set (int value);
}
member StatusCode : int with get, set
member StatusCode : int with get, set

Property Value

Type: Online Int32
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.StatusDescription Property

Response StatusDescription Property NFX Class Library

Http status description

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string StatusDescription { get; set; }
public string StatusDescription { get; set; }
Public Property StatusDescription As String
    Get
    Set
Public Property StatusDescription As String
    Get
    Set
public:
property String^ StatusDescription {
    String^ get ();
    void set (String^ value);
}
public:
property String^ StatusDescription {
    String^ get ();
    void set (String^ value);
}
member StatusDescription : string with get, set
member StatusDescription : string with get, set

Property Value

Type: Online String
See Also
Response Class
Response Members
NFX.Wave Namespace


Response.WasWrittenTo Property

Response WasWrittenTo Property NFX Class Library

Returns true if some output has been performed

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool WasWrittenTo { get; }
public bool WasWrittenTo { get; }
Public ReadOnly Property WasWrittenTo As Boolean
    Get
Public ReadOnly Property WasWrittenTo As Boolean
    Get
public:
property bool WasWrittenTo {
    bool get ();
}
public:
property bool WasWrittenTo {
    bool get ();
}
member WasWrittenTo : bool with get
member WasWrittenTo : bool with get

Property Value

Type: Online Boolean
See Also
Response Class
Response Members
NFX.Wave Namespace


StringConsts Class

StringConsts Class NFX Class Library

A dictionary of framework text messages. Localization may be done in this class in future
Inheritance Hierarchy
Online System Object
NFX.Wave StringConsts

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class StringConsts
internal static class StringConsts
Friend NotInheritable Class StringConsts
Friend NotInheritable Class StringConsts
internal ref class StringConsts abstract sealed
internal ref class StringConsts abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringConsts =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringConsts =  class end
See Also
StringConsts Members
NFX.Wave Namespace


StringConsts Members

StringConsts Members NFX Class Library

The StringConsts type exposes the following members.
Fields
Name | Description
ARGUMENT_ERROR |
CLIENT_VARS_LENGTH_OVER_LIMIT_ERROR |
CONFIG_DUPLICATE_FILTER_NAME_ERROR |
CONFIG_DUPLICATE_HANDLER_NAME_ERROR |
CONFIG_HANDLER_DUPLICATE_FILTER_NAME_ERROR |
CONFIG_HANDLER_DUPLICATE_MATCH_NAME_ERROR |
CONFIG_OTHER_DUPLICATE_MATCH_NAME_ERROR |
CONFIG_OTHER_DUPLICATE_PORTAL_NAME_ERROR |
CONFIG_PORTAL_DUPLICATE_THEME_NAME_ERROR |
CONFIG_PORTAL_HUB_FS_ROOT_PATH_ERROR |
CONFIG_PORTAL_HUB_NODE_ERROR |
CONFIG_PORTAL_LOCALIZATION_FILE_ERROR |
CONFIG_PORTAL_NO_DEFAULT_THEME_ERROR |
CONFIG_PORTAL_NO_THEMES_ERROR |
CONFIG_PORTAL_ROOT_URI_ERROR |
CONFIG_PORTAL_THEME_NO_NAME_ERROR |
DISPATCHER_NOT_THIS_SERVER_ERROR |
DONT_KNOW_ACTION_ERROR |
ERROR_PAGE_TEMPLATE_TYPE_ERROR |
FILE_DL_HANDLER_NOT_FOUND_INFO |
MVC_ACTION_ATTR_MATCH_PARSING_ERROR |
MVC_CONTROLLER_REFLECTION_ERROR |
MVCCONTROLLER_ACTION_PARAM_BINDER_ERROR |
MVCCONTROLLER_ACTION_UNKNOWN_ERROR |
MVCCONTROLLER_ACTION_UNMATCHED_HANDLER_ERROR |
NO_HANDLER_FOR_WORK_ERROR |
NOT_FOUND_ERROR |
PORTAL_HUB_INSTANCE_ALREADY_CONTAINS_PORTAL_ERROR |
PORTAL_HUB_INSTANCE_IS_ALREADY_AVAILABLE_ERROR |
PORTAL_HUB_INSTANCE_IS_NOT_AVAILABLE_ERROR |
PORTAL_PARENT_DEPTH_ERROR |
PORTAL_PARENT_INVALID_ERROR |
RESPONSE_CANCEL_NON_BUFFERED_ERROR |
RESPONSE_WAS_WRITTEN_TO_ERROR |
RESPONSE_WRITE_FILE_DOES_NOT_EXIST_ERROR |
RESPONSE_WRITE_FILE_OVER_MAX_SIZE_ERROR |
SERVER_COULD_NOT_GET_REGISTERED_ERROR |
SERVER_DEFAULT_ERROR_HANDLER_ERROR |
SERVER_DEFAULT_ERROR_WC_NULL_ERROR |
SERVER_NO_PREFIXES_ERROR |
SESSION_NOT_AVAILABLE_ERROR |
URI_PATTERN_PARSE_ERROR |
URI_WILDCARD_PARSE_ERROR |
WORK_NO_DEFAULT_AUTO_CLOSE_ERROR |
WRONG_DISPATCHER_FILTER_REGISTRATION_ERROR |
WRONG_DISPATCHER_FILTER_UNREGISTRATION_ERROR |
WRONG_DISPATCHER_HANDLER_REGISTRATION_ERROR |
WRONG_DISPATCHER_HANDLER_UNREGISTRATION_ERROR |
Back to Top
See Also
StringConsts Class
NFX.Wave Namespace


StringConsts Fields

StringConsts Fields NFX Class Library

The StringConsts type exposes the following members.
Fields
Name | Description
ARGUMENT_ERROR |
CLIENT_VARS_LENGTH_OVER_LIMIT_ERROR |
CONFIG_DUPLICATE_FILTER_NAME_ERROR |
CONFIG_DUPLICATE_HANDLER_NAME_ERROR |
CONFIG_HANDLER_DUPLICATE_FILTER_NAME_ERROR |
CONFIG_HANDLER_DUPLICATE_MATCH_NAME_ERROR |
CONFIG_OTHER_DUPLICATE_MATCH_NAME_ERROR |
CONFIG_OTHER_DUPLICATE_PORTAL_NAME_ERROR |
CONFIG_PORTAL_DUPLICATE_THEME_NAME_ERROR |
CONFIG_PORTAL_HUB_FS_ROOT_PATH_ERROR |
CONFIG_PORTAL_HUB_NODE_ERROR |
CONFIG_PORTAL_LOCALIZATION_FILE_ERROR |
CONFIG_PORTAL_NO_DEFAULT_THEME_ERROR |
CONFIG_PORTAL_NO_THEMES_ERROR |
CONFIG_PORTAL_ROOT_URI_ERROR |
CONFIG_PORTAL_THEME_NO_NAME_ERROR |
DISPATCHER_NOT_THIS_SERVER_ERROR |
DONT_KNOW_ACTION_ERROR |
ERROR_PAGE_TEMPLATE_TYPE_ERROR |
FILE_DL_HANDLER_NOT_FOUND_INFO |
MVC_ACTION_ATTR_MATCH_PARSING_ERROR |
MVC_CONTROLLER_REFLECTION_ERROR |
MVCCONTROLLER_ACTION_PARAM_BINDER_ERROR |
MVCCONTROLLER_ACTION_UNKNOWN_ERROR |
MVCCONTROLLER_ACTION_UNMATCHED_HANDLER_ERROR |
NO_HANDLER_FOR_WORK_ERROR |
NOT_FOUND_ERROR |
PORTAL_HUB_INSTANCE_ALREADY_CONTAINS_PORTAL_ERROR |
PORTAL_HUB_INSTANCE_IS_ALREADY_AVAILABLE_ERROR |
PORTAL_HUB_INSTANCE_IS_NOT_AVAILABLE_ERROR |
PORTAL_PARENT_DEPTH_ERROR |
PORTAL_PARENT_INVALID_ERROR |
RESPONSE_CANCEL_NON_BUFFERED_ERROR |
RESPONSE_WAS_WRITTEN_TO_ERROR |
RESPONSE_WRITE_FILE_DOES_NOT_EXIST_ERROR |
RESPONSE_WRITE_FILE_OVER_MAX_SIZE_ERROR |
SERVER_COULD_NOT_GET_REGISTERED_ERROR |
SERVER_DEFAULT_ERROR_HANDLER_ERROR |
SERVER_DEFAULT_ERROR_WC_NULL_ERROR |
SERVER_NO_PREFIXES_ERROR |
SESSION_NOT_AVAILABLE_ERROR |
URI_PATTERN_PARSE_ERROR |
URI_WILDCARD_PARSE_ERROR |
WORK_NO_DEFAULT_AUTO_CLOSE_ERROR |
WRONG_DISPATCHER_FILTER_REGISTRATION_ERROR |
WRONG_DISPATCHER_FILTER_UNREGISTRATION_ERROR |
WRONG_DISPATCHER_HANDLER_REGISTRATION_ERROR |
WRONG_DISPATCHER_HANDLER_UNREGISTRATION_ERROR |
Back to Top
See Also
StringConsts Class
NFX.Wave Namespace


StringConsts.ARGUMENT_ERROR Field

StringConsts ARGUMENT_ERROR Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ARGUMENT_ERROR
public const string ARGUMENT_ERROR
Public Const ARGUMENT_ERROR As String
Public Const ARGUMENT_ERROR As String
public:
literal String^ ARGUMENT_ERROR
public:
literal String^ ARGUMENT_ERROR
static val mutable ARGUMENT_ERROR: string
static val mutable ARGUMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CLIENT_VARS_LENGTH_OVER_LIMIT_ERROR Field

StringConsts CLIENT_VARS_LENGTH_OVER_LIMIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CLIENT_VARS_LENGTH_OVER_LIMIT_ERROR
public const string CLIENT_VARS_LENGTH_OVER_LIMIT_ERROR
Public Const CLIENT_VARS_LENGTH_OVER_LIMIT_ERROR As String
Public Const CLIENT_VARS_LENGTH_OVER_LIMIT_ERROR As String
public:
literal String^ CLIENT_VARS_LENGTH_OVER_LIMIT_ERROR
public:
literal String^ CLIENT_VARS_LENGTH_OVER_LIMIT_ERROR
static val mutable CLIENT_VARS_LENGTH_OVER_LIMIT_ERROR: string
static val mutable CLIENT_VARS_LENGTH_OVER_LIMIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CONFIG_DUPLICATE_FILTER_NAME_ERROR Field

StringConsts CONFIG_DUPLICATE_FILTER_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DUPLICATE_FILTER_NAME_ERROR
public const string CONFIG_DUPLICATE_FILTER_NAME_ERROR
Public Const CONFIG_DUPLICATE_FILTER_NAME_ERROR As String
Public Const CONFIG_DUPLICATE_FILTER_NAME_ERROR As String
public:
literal String^ CONFIG_DUPLICATE_FILTER_NAME_ERROR
public:
literal String^ CONFIG_DUPLICATE_FILTER_NAME_ERROR
static val mutable CONFIG_DUPLICATE_FILTER_NAME_ERROR: string
static val mutable CONFIG_DUPLICATE_FILTER_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CONFIG_DUPLICATE_HANDLER_NAME_ERROR Field

StringConsts CONFIG_DUPLICATE_HANDLER_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DUPLICATE_HANDLER_NAME_ERROR
public const string CONFIG_DUPLICATE_HANDLER_NAME_ERROR
Public Const CONFIG_DUPLICATE_HANDLER_NAME_ERROR As String
Public Const CONFIG_DUPLICATE_HANDLER_NAME_ERROR As String
public:
literal String^ CONFIG_DUPLICATE_HANDLER_NAME_ERROR
public:
literal String^ CONFIG_DUPLICATE_HANDLER_NAME_ERROR
static val mutable CONFIG_DUPLICATE_HANDLER_NAME_ERROR: string
static val mutable CONFIG_DUPLICATE_HANDLER_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CONFIG_HANDLER_DUPLICATE_FILTER_NAME_ERROR Field

StringConsts CONFIG_HANDLER_DUPLICATE_FILTER_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_HANDLER_DUPLICATE_FILTER_NAME_ERROR
public const string CONFIG_HANDLER_DUPLICATE_FILTER_NAME_ERROR
Public Const CONFIG_HANDLER_DUPLICATE_FILTER_NAME_ERROR As String
Public Const CONFIG_HANDLER_DUPLICATE_FILTER_NAME_ERROR As String
public:
literal String^ CONFIG_HANDLER_DUPLICATE_FILTER_NAME_ERROR
public:
literal String^ CONFIG_HANDLER_DUPLICATE_FILTER_NAME_ERROR
static val mutable CONFIG_HANDLER_DUPLICATE_FILTER_NAME_ERROR: string
static val mutable CONFIG_HANDLER_DUPLICATE_FILTER_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CONFIG_HANDLER_DUPLICATE_MATCH_NAME_ERROR Field

StringConsts CONFIG_HANDLER_DUPLICATE_MATCH_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_HANDLER_DUPLICATE_MATCH_NAME_ERROR
public const string CONFIG_HANDLER_DUPLICATE_MATCH_NAME_ERROR
Public Const CONFIG_HANDLER_DUPLICATE_MATCH_NAME_ERROR As String
Public Const CONFIG_HANDLER_DUPLICATE_MATCH_NAME_ERROR As String
public:
literal String^ CONFIG_HANDLER_DUPLICATE_MATCH_NAME_ERROR
public:
literal String^ CONFIG_HANDLER_DUPLICATE_MATCH_NAME_ERROR
static val mutable CONFIG_HANDLER_DUPLICATE_MATCH_NAME_ERROR: string
static val mutable CONFIG_HANDLER_DUPLICATE_MATCH_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CONFIG_OTHER_DUPLICATE_MATCH_NAME_ERROR Field

StringConsts CONFIG_OTHER_DUPLICATE_MATCH_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_OTHER_DUPLICATE_MATCH_NAME_ERROR
public const string CONFIG_OTHER_DUPLICATE_MATCH_NAME_ERROR
Public Const CONFIG_OTHER_DUPLICATE_MATCH_NAME_ERROR As String
Public Const CONFIG_OTHER_DUPLICATE_MATCH_NAME_ERROR As String
public:
literal String^ CONFIG_OTHER_DUPLICATE_MATCH_NAME_ERROR
public:
literal String^ CONFIG_OTHER_DUPLICATE_MATCH_NAME_ERROR
static val mutable CONFIG_OTHER_DUPLICATE_MATCH_NAME_ERROR: string
static val mutable CONFIG_OTHER_DUPLICATE_MATCH_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CONFIG_OTHER_DUPLICATE_PORTAL_NAME_ERROR Field

StringConsts CONFIG_OTHER_DUPLICATE_PORTAL_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_OTHER_DUPLICATE_PORTAL_NAME_ERROR
public const string CONFIG_OTHER_DUPLICATE_PORTAL_NAME_ERROR
Public Const CONFIG_OTHER_DUPLICATE_PORTAL_NAME_ERROR As String
Public Const CONFIG_OTHER_DUPLICATE_PORTAL_NAME_ERROR As String
public:
literal String^ CONFIG_OTHER_DUPLICATE_PORTAL_NAME_ERROR
public:
literal String^ CONFIG_OTHER_DUPLICATE_PORTAL_NAME_ERROR
static val mutable CONFIG_OTHER_DUPLICATE_PORTAL_NAME_ERROR: string
static val mutable CONFIG_OTHER_DUPLICATE_PORTAL_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CONFIG_PORTAL_DUPLICATE_THEME_NAME_ERROR Field

StringConsts CONFIG_PORTAL_DUPLICATE_THEME_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PORTAL_DUPLICATE_THEME_NAME_ERROR
public const string CONFIG_PORTAL_DUPLICATE_THEME_NAME_ERROR
Public Const CONFIG_PORTAL_DUPLICATE_THEME_NAME_ERROR As String
Public Const CONFIG_PORTAL_DUPLICATE_THEME_NAME_ERROR As String
public:
literal String^ CONFIG_PORTAL_DUPLICATE_THEME_NAME_ERROR
public:
literal String^ CONFIG_PORTAL_DUPLICATE_THEME_NAME_ERROR
static val mutable CONFIG_PORTAL_DUPLICATE_THEME_NAME_ERROR: string
static val mutable CONFIG_PORTAL_DUPLICATE_THEME_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CONFIG_PORTAL_HUB_FS_ROOT_PATH_ERROR Field

StringConsts CONFIG_PORTAL_HUB_FS_ROOT_PATH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PORTAL_HUB_FS_ROOT_PATH_ERROR
public const string CONFIG_PORTAL_HUB_FS_ROOT_PATH_ERROR
Public Const CONFIG_PORTAL_HUB_FS_ROOT_PATH_ERROR As String
Public Const CONFIG_PORTAL_HUB_FS_ROOT_PATH_ERROR As String
public:
literal String^ CONFIG_PORTAL_HUB_FS_ROOT_PATH_ERROR
public:
literal String^ CONFIG_PORTAL_HUB_FS_ROOT_PATH_ERROR
static val mutable CONFIG_PORTAL_HUB_FS_ROOT_PATH_ERROR: string
static val mutable CONFIG_PORTAL_HUB_FS_ROOT_PATH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CONFIG_PORTAL_HUB_NODE_ERROR Field

StringConsts CONFIG_PORTAL_HUB_NODE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PORTAL_HUB_NODE_ERROR
public const string CONFIG_PORTAL_HUB_NODE_ERROR
Public Const CONFIG_PORTAL_HUB_NODE_ERROR As String
Public Const CONFIG_PORTAL_HUB_NODE_ERROR As String
public:
literal String^ CONFIG_PORTAL_HUB_NODE_ERROR
public:
literal String^ CONFIG_PORTAL_HUB_NODE_ERROR
static val mutable CONFIG_PORTAL_HUB_NODE_ERROR: string
static val mutable CONFIG_PORTAL_HUB_NODE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CONFIG_PORTAL_LOCALIZATION_FILE_ERROR Field

StringConsts CONFIG_PORTAL_LOCALIZATION_FILE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PORTAL_LOCALIZATION_FILE_ERROR
public const string CONFIG_PORTAL_LOCALIZATION_FILE_ERROR
Public Const CONFIG_PORTAL_LOCALIZATION_FILE_ERROR As String
Public Const CONFIG_PORTAL_LOCALIZATION_FILE_ERROR As String
public:
literal String^ CONFIG_PORTAL_LOCALIZATION_FILE_ERROR
public:
literal String^ CONFIG_PORTAL_LOCALIZATION_FILE_ERROR
static val mutable CONFIG_PORTAL_LOCALIZATION_FILE_ERROR: string
static val mutable CONFIG_PORTAL_LOCALIZATION_FILE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CONFIG_PORTAL_NO_DEFAULT_THEME_ERROR Field

StringConsts CONFIG_PORTAL_NO_DEFAULT_THEME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PORTAL_NO_DEFAULT_THEME_ERROR
public const string CONFIG_PORTAL_NO_DEFAULT_THEME_ERROR
Public Const CONFIG_PORTAL_NO_DEFAULT_THEME_ERROR As String
Public Const CONFIG_PORTAL_NO_DEFAULT_THEME_ERROR As String
public:
literal String^ CONFIG_PORTAL_NO_DEFAULT_THEME_ERROR
public:
literal String^ CONFIG_PORTAL_NO_DEFAULT_THEME_ERROR
static val mutable CONFIG_PORTAL_NO_DEFAULT_THEME_ERROR: string
static val mutable CONFIG_PORTAL_NO_DEFAULT_THEME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CONFIG_PORTAL_NO_THEMES_ERROR Field

StringConsts CONFIG_PORTAL_NO_THEMES_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PORTAL_NO_THEMES_ERROR
public const string CONFIG_PORTAL_NO_THEMES_ERROR
Public Const CONFIG_PORTAL_NO_THEMES_ERROR As String
Public Const CONFIG_PORTAL_NO_THEMES_ERROR As String
public:
literal String^ CONFIG_PORTAL_NO_THEMES_ERROR
public:
literal String^ CONFIG_PORTAL_NO_THEMES_ERROR
static val mutable CONFIG_PORTAL_NO_THEMES_ERROR: string
static val mutable CONFIG_PORTAL_NO_THEMES_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CONFIG_PORTAL_ROOT_URI_ERROR Field

StringConsts CONFIG_PORTAL_ROOT_URI_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PORTAL_ROOT_URI_ERROR
public const string CONFIG_PORTAL_ROOT_URI_ERROR
Public Const CONFIG_PORTAL_ROOT_URI_ERROR As String
Public Const CONFIG_PORTAL_ROOT_URI_ERROR As String
public:
literal String^ CONFIG_PORTAL_ROOT_URI_ERROR
public:
literal String^ CONFIG_PORTAL_ROOT_URI_ERROR
static val mutable CONFIG_PORTAL_ROOT_URI_ERROR: string
static val mutable CONFIG_PORTAL_ROOT_URI_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.CONFIG_PORTAL_THEME_NO_NAME_ERROR Field

StringConsts CONFIG_PORTAL_THEME_NO_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PORTAL_THEME_NO_NAME_ERROR
public const string CONFIG_PORTAL_THEME_NO_NAME_ERROR
Public Const CONFIG_PORTAL_THEME_NO_NAME_ERROR As String
Public Const CONFIG_PORTAL_THEME_NO_NAME_ERROR As String
public:
literal String^ CONFIG_PORTAL_THEME_NO_NAME_ERROR
public:
literal String^ CONFIG_PORTAL_THEME_NO_NAME_ERROR
static val mutable CONFIG_PORTAL_THEME_NO_NAME_ERROR: string
static val mutable CONFIG_PORTAL_THEME_NO_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.DISPATCHER_NOT_THIS_SERVER_ERROR Field

StringConsts DISPATCHER_NOT_THIS_SERVER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DISPATCHER_NOT_THIS_SERVER_ERROR
public const string DISPATCHER_NOT_THIS_SERVER_ERROR
Public Const DISPATCHER_NOT_THIS_SERVER_ERROR As String
Public Const DISPATCHER_NOT_THIS_SERVER_ERROR As String
public:
literal String^ DISPATCHER_NOT_THIS_SERVER_ERROR
public:
literal String^ DISPATCHER_NOT_THIS_SERVER_ERROR
static val mutable DISPATCHER_NOT_THIS_SERVER_ERROR: string
static val mutable DISPATCHER_NOT_THIS_SERVER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.DONT_KNOW_ACTION_ERROR Field

StringConsts DONT_KNOW_ACTION_ERROR Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DONT_KNOW_ACTION_ERROR
public const string DONT_KNOW_ACTION_ERROR
Public Const DONT_KNOW_ACTION_ERROR As String
Public Const DONT_KNOW_ACTION_ERROR As String
public:
literal String^ DONT_KNOW_ACTION_ERROR
public:
literal String^ DONT_KNOW_ACTION_ERROR
static val mutable DONT_KNOW_ACTION_ERROR: string
static val mutable DONT_KNOW_ACTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.ERROR_PAGE_TEMPLATE_TYPE_ERROR Field

StringConsts ERROR_PAGE_TEMPLATE_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERROR_PAGE_TEMPLATE_TYPE_ERROR
public const string ERROR_PAGE_TEMPLATE_TYPE_ERROR
Public Const ERROR_PAGE_TEMPLATE_TYPE_ERROR As String
Public Const ERROR_PAGE_TEMPLATE_TYPE_ERROR As String
public:
literal String^ ERROR_PAGE_TEMPLATE_TYPE_ERROR
public:
literal String^ ERROR_PAGE_TEMPLATE_TYPE_ERROR
static val mutable ERROR_PAGE_TEMPLATE_TYPE_ERROR: string
static val mutable ERROR_PAGE_TEMPLATE_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.FILE_DL_HANDLER_NOT_FOUND_INFO Field

StringConsts FILE_DL_HANDLER_NOT_FOUND_INFO Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FILE_DL_HANDLER_NOT_FOUND_INFO
public const string FILE_DL_HANDLER_NOT_FOUND_INFO
Public Const FILE_DL_HANDLER_NOT_FOUND_INFO As String
Public Const FILE_DL_HANDLER_NOT_FOUND_INFO As String
public:
literal String^ FILE_DL_HANDLER_NOT_FOUND_INFO
public:
literal String^ FILE_DL_HANDLER_NOT_FOUND_INFO
static val mutable FILE_DL_HANDLER_NOT_FOUND_INFO: string
static val mutable FILE_DL_HANDLER_NOT_FOUND_INFO: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.MVC_ACTION_ATTR_MATCH_PARSING_ERROR Field

StringConsts MVC_ACTION_ATTR_MATCH_PARSING_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MVC_ACTION_ATTR_MATCH_PARSING_ERROR
public const string MVC_ACTION_ATTR_MATCH_PARSING_ERROR
Public Const MVC_ACTION_ATTR_MATCH_PARSING_ERROR As String
Public Const MVC_ACTION_ATTR_MATCH_PARSING_ERROR As String
public:
literal String^ MVC_ACTION_ATTR_MATCH_PARSING_ERROR
public:
literal String^ MVC_ACTION_ATTR_MATCH_PARSING_ERROR
static val mutable MVC_ACTION_ATTR_MATCH_PARSING_ERROR: string
static val mutable MVC_ACTION_ATTR_MATCH_PARSING_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.MVC_CONTROLLER_REFLECTION_ERROR Field

StringConsts MVC_CONTROLLER_REFLECTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MVC_CONTROLLER_REFLECTION_ERROR
public const string MVC_CONTROLLER_REFLECTION_ERROR
Public Const MVC_CONTROLLER_REFLECTION_ERROR As String
Public Const MVC_CONTROLLER_REFLECTION_ERROR As String
public:
literal String^ MVC_CONTROLLER_REFLECTION_ERROR
public:
literal String^ MVC_CONTROLLER_REFLECTION_ERROR
static val mutable MVC_CONTROLLER_REFLECTION_ERROR: string
static val mutable MVC_CONTROLLER_REFLECTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.MVCCONTROLLER_ACTION_PARAM_BINDER_ERROR Field

StringConsts MVCCONTROLLER_ACTION_PARAM_BINDER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MVCCONTROLLER_ACTION_PARAM_BINDER_ERROR
public const string MVCCONTROLLER_ACTION_PARAM_BINDER_ERROR
Public Const MVCCONTROLLER_ACTION_PARAM_BINDER_ERROR As String
Public Const MVCCONTROLLER_ACTION_PARAM_BINDER_ERROR As String
public:
literal String^ MVCCONTROLLER_ACTION_PARAM_BINDER_ERROR
public:
literal String^ MVCCONTROLLER_ACTION_PARAM_BINDER_ERROR
static val mutable MVCCONTROLLER_ACTION_PARAM_BINDER_ERROR: string
static val mutable MVCCONTROLLER_ACTION_PARAM_BINDER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.MVCCONTROLLER_ACTION_UNKNOWN_ERROR Field

StringConsts MVCCONTROLLER_ACTION_UNKNOWN_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MVCCONTROLLER_ACTION_UNKNOWN_ERROR
public const string MVCCONTROLLER_ACTION_UNKNOWN_ERROR
Public Const MVCCONTROLLER_ACTION_UNKNOWN_ERROR As String
Public Const MVCCONTROLLER_ACTION_UNKNOWN_ERROR As String
public:
literal String^ MVCCONTROLLER_ACTION_UNKNOWN_ERROR
public:
literal String^ MVCCONTROLLER_ACTION_UNKNOWN_ERROR
static val mutable MVCCONTROLLER_ACTION_UNKNOWN_ERROR: string
static val mutable MVCCONTROLLER_ACTION_UNKNOWN_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.MVCCONTROLLER_ACTION_UNMATCHED_HANDLER_ERROR Field

StringConsts MVCCONTROLLER_ACTION_UNMATCHED_HANDLER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MVCCONTROLLER_ACTION_UNMATCHED_HANDLER_ERROR
public const string MVCCONTROLLER_ACTION_UNMATCHED_HANDLER_ERROR
Public Const MVCCONTROLLER_ACTION_UNMATCHED_HANDLER_ERROR As String
Public Const MVCCONTROLLER_ACTION_UNMATCHED_HANDLER_ERROR As String
public:
literal String^ MVCCONTROLLER_ACTION_UNMATCHED_HANDLER_ERROR
public:
literal String^ MVCCONTROLLER_ACTION_UNMATCHED_HANDLER_ERROR
static val mutable MVCCONTROLLER_ACTION_UNMATCHED_HANDLER_ERROR: string
static val mutable MVCCONTROLLER_ACTION_UNMATCHED_HANDLER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.NO_HANDLER_FOR_WORK_ERROR Field

StringConsts NO_HANDLER_FOR_WORK_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NO_HANDLER_FOR_WORK_ERROR
public const string NO_HANDLER_FOR_WORK_ERROR
Public Const NO_HANDLER_FOR_WORK_ERROR As String
Public Const NO_HANDLER_FOR_WORK_ERROR As String
public:
literal String^ NO_HANDLER_FOR_WORK_ERROR
public:
literal String^ NO_HANDLER_FOR_WORK_ERROR
static val mutable NO_HANDLER_FOR_WORK_ERROR: string
static val mutable NO_HANDLER_FOR_WORK_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.NOT_FOUND_ERROR Field

StringConsts NOT_FOUND_ERROR Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NOT_FOUND_ERROR
public const string NOT_FOUND_ERROR
Public Const NOT_FOUND_ERROR As String
Public Const NOT_FOUND_ERROR As String
public:
literal String^ NOT_FOUND_ERROR
public:
literal String^ NOT_FOUND_ERROR
static val mutable NOT_FOUND_ERROR: string
static val mutable NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.PORTAL_HUB_INSTANCE_ALREADY_CONTAINS_PORTAL_ERROR Field

StringConsts PORTAL_HUB_INSTANCE_ALREADY_CONTAINS_PORTAL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PORTAL_HUB_INSTANCE_ALREADY_CONTAINS_PORTAL_ERROR
public const string PORTAL_HUB_INSTANCE_ALREADY_CONTAINS_PORTAL_ERROR
Public Const PORTAL_HUB_INSTANCE_ALREADY_CONTAINS_PORTAL_ERROR As String
Public Const PORTAL_HUB_INSTANCE_ALREADY_CONTAINS_PORTAL_ERROR As String
public:
literal String^ PORTAL_HUB_INSTANCE_ALREADY_CONTAINS_PORTAL_ERROR
public:
literal String^ PORTAL_HUB_INSTANCE_ALREADY_CONTAINS_PORTAL_ERROR
static val mutable PORTAL_HUB_INSTANCE_ALREADY_CONTAINS_PORTAL_ERROR: string
static val mutable PORTAL_HUB_INSTANCE_ALREADY_CONTAINS_PORTAL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.PORTAL_HUB_INSTANCE_IS_ALREADY_AVAILABLE_ERROR Field

StringConsts PORTAL_HUB_INSTANCE_IS_ALREADY_AVAILABLE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PORTAL_HUB_INSTANCE_IS_ALREADY_AVAILABLE_ERROR
public const string PORTAL_HUB_INSTANCE_IS_ALREADY_AVAILABLE_ERROR
Public Const PORTAL_HUB_INSTANCE_IS_ALREADY_AVAILABLE_ERROR As String
Public Const PORTAL_HUB_INSTANCE_IS_ALREADY_AVAILABLE_ERROR As String
public:
literal String^ PORTAL_HUB_INSTANCE_IS_ALREADY_AVAILABLE_ERROR
public:
literal String^ PORTAL_HUB_INSTANCE_IS_ALREADY_AVAILABLE_ERROR
static val mutable PORTAL_HUB_INSTANCE_IS_ALREADY_AVAILABLE_ERROR: string
static val mutable PORTAL_HUB_INSTANCE_IS_ALREADY_AVAILABLE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.PORTAL_HUB_INSTANCE_IS_NOT_AVAILABLE_ERROR Field

StringConsts PORTAL_HUB_INSTANCE_IS_NOT_AVAILABLE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PORTAL_HUB_INSTANCE_IS_NOT_AVAILABLE_ERROR
public const string PORTAL_HUB_INSTANCE_IS_NOT_AVAILABLE_ERROR
Public Const PORTAL_HUB_INSTANCE_IS_NOT_AVAILABLE_ERROR As String
Public Const PORTAL_HUB_INSTANCE_IS_NOT_AVAILABLE_ERROR As String
public:
literal String^ PORTAL_HUB_INSTANCE_IS_NOT_AVAILABLE_ERROR
public:
literal String^ PORTAL_HUB_INSTANCE_IS_NOT_AVAILABLE_ERROR
static val mutable PORTAL_HUB_INSTANCE_IS_NOT_AVAILABLE_ERROR: string
static val mutable PORTAL_HUB_INSTANCE_IS_NOT_AVAILABLE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.PORTAL_PARENT_DEPTH_ERROR Field

StringConsts PORTAL_PARENT_DEPTH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PORTAL_PARENT_DEPTH_ERROR
public const string PORTAL_PARENT_DEPTH_ERROR
Public Const PORTAL_PARENT_DEPTH_ERROR As String
Public Const PORTAL_PARENT_DEPTH_ERROR As String
public:
literal String^ PORTAL_PARENT_DEPTH_ERROR
public:
literal String^ PORTAL_PARENT_DEPTH_ERROR
static val mutable PORTAL_PARENT_DEPTH_ERROR: string
static val mutable PORTAL_PARENT_DEPTH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.PORTAL_PARENT_INVALID_ERROR Field

StringConsts PORTAL_PARENT_INVALID_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PORTAL_PARENT_INVALID_ERROR
public const string PORTAL_PARENT_INVALID_ERROR
Public Const PORTAL_PARENT_INVALID_ERROR As String
Public Const PORTAL_PARENT_INVALID_ERROR As String
public:
literal String^ PORTAL_PARENT_INVALID_ERROR
public:
literal String^ PORTAL_PARENT_INVALID_ERROR
static val mutable PORTAL_PARENT_INVALID_ERROR: string
static val mutable PORTAL_PARENT_INVALID_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.RESPONSE_CANCEL_NON_BUFFERED_ERROR Field

StringConsts RESPONSE_CANCEL_NON_BUFFERED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string RESPONSE_CANCEL_NON_BUFFERED_ERROR
public const string RESPONSE_CANCEL_NON_BUFFERED_ERROR
Public Const RESPONSE_CANCEL_NON_BUFFERED_ERROR As String
Public Const RESPONSE_CANCEL_NON_BUFFERED_ERROR As String
public:
literal String^ RESPONSE_CANCEL_NON_BUFFERED_ERROR
public:
literal String^ RESPONSE_CANCEL_NON_BUFFERED_ERROR
static val mutable RESPONSE_CANCEL_NON_BUFFERED_ERROR: string
static val mutable RESPONSE_CANCEL_NON_BUFFERED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.RESPONSE_WAS_WRITTEN_TO_ERROR Field

StringConsts RESPONSE_WAS_WRITTEN_TO_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string RESPONSE_WAS_WRITTEN_TO_ERROR
public const string RESPONSE_WAS_WRITTEN_TO_ERROR
Public Const RESPONSE_WAS_WRITTEN_TO_ERROR As String
Public Const RESPONSE_WAS_WRITTEN_TO_ERROR As String
public:
literal String^ RESPONSE_WAS_WRITTEN_TO_ERROR
public:
literal String^ RESPONSE_WAS_WRITTEN_TO_ERROR
static val mutable RESPONSE_WAS_WRITTEN_TO_ERROR: string
static val mutable RESPONSE_WAS_WRITTEN_TO_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.RESPONSE_WRITE_FILE_DOES_NOT_EXIST_ERROR Field

StringConsts RESPONSE_WRITE_FILE_DOES_NOT_EXIST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string RESPONSE_WRITE_FILE_DOES_NOT_EXIST_ERROR
public const string RESPONSE_WRITE_FILE_DOES_NOT_EXIST_ERROR
Public Const RESPONSE_WRITE_FILE_DOES_NOT_EXIST_ERROR As String
Public Const RESPONSE_WRITE_FILE_DOES_NOT_EXIST_ERROR As String
public:
literal String^ RESPONSE_WRITE_FILE_DOES_NOT_EXIST_ERROR
public:
literal String^ RESPONSE_WRITE_FILE_DOES_NOT_EXIST_ERROR
static val mutable RESPONSE_WRITE_FILE_DOES_NOT_EXIST_ERROR: string
static val mutable RESPONSE_WRITE_FILE_DOES_NOT_EXIST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.RESPONSE_WRITE_FILE_OVER_MAX_SIZE_ERROR Field

StringConsts RESPONSE_WRITE_FILE_OVER_MAX_SIZE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string RESPONSE_WRITE_FILE_OVER_MAX_SIZE_ERROR
public const string RESPONSE_WRITE_FILE_OVER_MAX_SIZE_ERROR
Public Const RESPONSE_WRITE_FILE_OVER_MAX_SIZE_ERROR As String
Public Const RESPONSE_WRITE_FILE_OVER_MAX_SIZE_ERROR As String
public:
literal String^ RESPONSE_WRITE_FILE_OVER_MAX_SIZE_ERROR
public:
literal String^ RESPONSE_WRITE_FILE_OVER_MAX_SIZE_ERROR
static val mutable RESPONSE_WRITE_FILE_OVER_MAX_SIZE_ERROR: string
static val mutable RESPONSE_WRITE_FILE_OVER_MAX_SIZE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.SERVER_COULD_NOT_GET_REGISTERED_ERROR Field

StringConsts SERVER_COULD_NOT_GET_REGISTERED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SERVER_COULD_NOT_GET_REGISTERED_ERROR
public const string SERVER_COULD_NOT_GET_REGISTERED_ERROR
Public Const SERVER_COULD_NOT_GET_REGISTERED_ERROR As String
Public Const SERVER_COULD_NOT_GET_REGISTERED_ERROR As String
public:
literal String^ SERVER_COULD_NOT_GET_REGISTERED_ERROR
public:
literal String^ SERVER_COULD_NOT_GET_REGISTERED_ERROR
static val mutable SERVER_COULD_NOT_GET_REGISTERED_ERROR: string
static val mutable SERVER_COULD_NOT_GET_REGISTERED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.SERVER_DEFAULT_ERROR_HANDLER_ERROR Field

StringConsts SERVER_DEFAULT_ERROR_HANDLER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SERVER_DEFAULT_ERROR_HANDLER_ERROR
public const string SERVER_DEFAULT_ERROR_HANDLER_ERROR
Public Const SERVER_DEFAULT_ERROR_HANDLER_ERROR As String
Public Const SERVER_DEFAULT_ERROR_HANDLER_ERROR As String
public:
literal String^ SERVER_DEFAULT_ERROR_HANDLER_ERROR
public:
literal String^ SERVER_DEFAULT_ERROR_HANDLER_ERROR
static val mutable SERVER_DEFAULT_ERROR_HANDLER_ERROR: string
static val mutable SERVER_DEFAULT_ERROR_HANDLER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.SERVER_DEFAULT_ERROR_WC_NULL_ERROR Field

StringConsts SERVER_DEFAULT_ERROR_WC_NULL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SERVER_DEFAULT_ERROR_WC_NULL_ERROR
public const string SERVER_DEFAULT_ERROR_WC_NULL_ERROR
Public Const SERVER_DEFAULT_ERROR_WC_NULL_ERROR As String
Public Const SERVER_DEFAULT_ERROR_WC_NULL_ERROR As String
public:
literal String^ SERVER_DEFAULT_ERROR_WC_NULL_ERROR
public:
literal String^ SERVER_DEFAULT_ERROR_WC_NULL_ERROR
static val mutable SERVER_DEFAULT_ERROR_WC_NULL_ERROR: string
static val mutable SERVER_DEFAULT_ERROR_WC_NULL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.SERVER_NO_PREFIXES_ERROR Field

StringConsts SERVER_NO_PREFIXES_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SERVER_NO_PREFIXES_ERROR
public const string SERVER_NO_PREFIXES_ERROR
Public Const SERVER_NO_PREFIXES_ERROR As String
Public Const SERVER_NO_PREFIXES_ERROR As String
public:
literal String^ SERVER_NO_PREFIXES_ERROR
public:
literal String^ SERVER_NO_PREFIXES_ERROR
static val mutable SERVER_NO_PREFIXES_ERROR: string
static val mutable SERVER_NO_PREFIXES_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.SESSION_NOT_AVAILABLE_ERROR Field

StringConsts SESSION_NOT_AVAILABLE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SESSION_NOT_AVAILABLE_ERROR
public const string SESSION_NOT_AVAILABLE_ERROR
Public Const SESSION_NOT_AVAILABLE_ERROR As String
Public Const SESSION_NOT_AVAILABLE_ERROR As String
public:
literal String^ SESSION_NOT_AVAILABLE_ERROR
public:
literal String^ SESSION_NOT_AVAILABLE_ERROR
static val mutable SESSION_NOT_AVAILABLE_ERROR: string
static val mutable SESSION_NOT_AVAILABLE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.URI_PATTERN_PARSE_ERROR Field

StringConsts URI_PATTERN_PARSE_ERROR Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string URI_PATTERN_PARSE_ERROR
public const string URI_PATTERN_PARSE_ERROR
Public Const URI_PATTERN_PARSE_ERROR As String
Public Const URI_PATTERN_PARSE_ERROR As String
public:
literal String^ URI_PATTERN_PARSE_ERROR
public:
literal String^ URI_PATTERN_PARSE_ERROR
static val mutable URI_PATTERN_PARSE_ERROR: string
static val mutable URI_PATTERN_PARSE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.URI_WILDCARD_PARSE_ERROR Field

StringConsts URI_WILDCARD_PARSE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string URI_WILDCARD_PARSE_ERROR
public const string URI_WILDCARD_PARSE_ERROR
Public Const URI_WILDCARD_PARSE_ERROR As String
Public Const URI_WILDCARD_PARSE_ERROR As String
public:
literal String^ URI_WILDCARD_PARSE_ERROR
public:
literal String^ URI_WILDCARD_PARSE_ERROR
static val mutable URI_WILDCARD_PARSE_ERROR: string
static val mutable URI_WILDCARD_PARSE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.WORK_NO_DEFAULT_AUTO_CLOSE_ERROR Field

StringConsts WORK_NO_DEFAULT_AUTO_CLOSE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string WORK_NO_DEFAULT_AUTO_CLOSE_ERROR
public const string WORK_NO_DEFAULT_AUTO_CLOSE_ERROR
Public Const WORK_NO_DEFAULT_AUTO_CLOSE_ERROR As String
Public Const WORK_NO_DEFAULT_AUTO_CLOSE_ERROR As String
public:
literal String^ WORK_NO_DEFAULT_AUTO_CLOSE_ERROR
public:
literal String^ WORK_NO_DEFAULT_AUTO_CLOSE_ERROR
static val mutable WORK_NO_DEFAULT_AUTO_CLOSE_ERROR: string
static val mutable WORK_NO_DEFAULT_AUTO_CLOSE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.WRONG_DISPATCHER_FILTER_REGISTRATION_ERROR Field

StringConsts WRONG_DISPATCHER_FILTER_REGISTRATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string WRONG_DISPATCHER_FILTER_REGISTRATION_ERROR
public const string WRONG_DISPATCHER_FILTER_REGISTRATION_ERROR
Public Const WRONG_DISPATCHER_FILTER_REGISTRATION_ERROR As String
Public Const WRONG_DISPATCHER_FILTER_REGISTRATION_ERROR As String
public:
literal String^ WRONG_DISPATCHER_FILTER_REGISTRATION_ERROR
public:
literal String^ WRONG_DISPATCHER_FILTER_REGISTRATION_ERROR
static val mutable WRONG_DISPATCHER_FILTER_REGISTRATION_ERROR: string
static val mutable WRONG_DISPATCHER_FILTER_REGISTRATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.WRONG_DISPATCHER_FILTER_UNREGISTRATION_ERROR Field

StringConsts WRONG_DISPATCHER_FILTER_UNREGISTRATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string WRONG_DISPATCHER_FILTER_UNREGISTRATION_ERROR
public const string WRONG_DISPATCHER_FILTER_UNREGISTRATION_ERROR
Public Const WRONG_DISPATCHER_FILTER_UNREGISTRATION_ERROR As String
Public Const WRONG_DISPATCHER_FILTER_UNREGISTRATION_ERROR As String
public:
literal String^ WRONG_DISPATCHER_FILTER_UNREGISTRATION_ERROR
public:
literal String^ WRONG_DISPATCHER_FILTER_UNREGISTRATION_ERROR
static val mutable WRONG_DISPATCHER_FILTER_UNREGISTRATION_ERROR: string
static val mutable WRONG_DISPATCHER_FILTER_UNREGISTRATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.WRONG_DISPATCHER_HANDLER_REGISTRATION_ERROR Field

StringConsts WRONG_DISPATCHER_HANDLER_REGISTRATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string WRONG_DISPATCHER_HANDLER_REGISTRATION_ERROR
public const string WRONG_DISPATCHER_HANDLER_REGISTRATION_ERROR
Public Const WRONG_DISPATCHER_HANDLER_REGISTRATION_ERROR As String
Public Const WRONG_DISPATCHER_HANDLER_REGISTRATION_ERROR As String
public:
literal String^ WRONG_DISPATCHER_HANDLER_REGISTRATION_ERROR
public:
literal String^ WRONG_DISPATCHER_HANDLER_REGISTRATION_ERROR
static val mutable WRONG_DISPATCHER_HANDLER_REGISTRATION_ERROR: string
static val mutable WRONG_DISPATCHER_HANDLER_REGISTRATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


StringConsts.WRONG_DISPATCHER_HANDLER_UNREGISTRATION_ERROR Field

StringConsts WRONG_DISPATCHER_HANDLER_UNREGISTRATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string WRONG_DISPATCHER_HANDLER_UNREGISTRATION_ERROR
public const string WRONG_DISPATCHER_HANDLER_UNREGISTRATION_ERROR
Public Const WRONG_DISPATCHER_HANDLER_UNREGISTRATION_ERROR As String
Public Const WRONG_DISPATCHER_HANDLER_UNREGISTRATION_ERROR As String
public:
literal String^ WRONG_DISPATCHER_HANDLER_UNREGISTRATION_ERROR
public:
literal String^ WRONG_DISPATCHER_HANDLER_UNREGISTRATION_ERROR
static val mutable WRONG_DISPATCHER_HANDLER_UNREGISTRATION_ERROR: string
static val mutable WRONG_DISPATCHER_HANDLER_UNREGISTRATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Wave Namespace


SysConsts Class

SysConsts Class NFX Class Library

Non-localizable constants
Inheritance Hierarchy
Online System Object
NFX.Wave SysConsts

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class SysConsts
public static class SysConsts
Public NotInheritable Class SysConsts
Public NotInheritable Class SysConsts
public ref class SysConsts abstract sealed
public ref class SysConsts abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SysConsts =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SysConsts =  class end
See Also
SysConsts Members
NFX.Wave Namespace


SysConsts Members

SysConsts Members NFX Class Library

The SysConsts type exposes the following members.
Fields
Name | Description
CONFIG_WAVE_SECTION |
HEADER_API_SESSION |
HEADER_API_VERSION |
HEADER_IF_MODIFIED_SINCE |
JSON_RESULT_ERROR | Returns object {OK = false}
JSON_RESULT_OK | Returns object {OK = true}
NULL_STRING |
UNSPECIFIED |
WAVE_LOG_TOPIC |
Back to Top
See Also
SysConsts Class
NFX.Wave Namespace


SysConsts Fields

SysConsts Fields NFX Class Library

The SysConsts type exposes the following members.
Fields
Name | Description
CONFIG_WAVE_SECTION |
HEADER_API_SESSION |
HEADER_API_VERSION |
HEADER_IF_MODIFIED_SINCE |
JSON_RESULT_ERROR | Returns object {OK = false}
JSON_RESULT_OK | Returns object {OK = true}
NULL_STRING |
UNSPECIFIED |
WAVE_LOG_TOPIC |
Back to Top
See Also
SysConsts Class
NFX.Wave Namespace


SysConsts.CONFIG_WAVE_SECTION Field

SysConsts CONFIG_WAVE_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_WAVE_SECTION
public const string CONFIG_WAVE_SECTION
Public Const CONFIG_WAVE_SECTION As String
Public Const CONFIG_WAVE_SECTION As String
public:
literal String^ CONFIG_WAVE_SECTION
public:
literal String^ CONFIG_WAVE_SECTION
static val mutable CONFIG_WAVE_SECTION: string
static val mutable CONFIG_WAVE_SECTION: string

Field Value

Type: Online String
See Also
SysConsts Class
SysConsts Members
NFX.Wave Namespace


SysConsts.HEADER_API_SESSION Field

SysConsts HEADER_API_SESSION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HEADER_API_SESSION
public const string HEADER_API_SESSION
Public Const HEADER_API_SESSION As String
Public Const HEADER_API_SESSION As String
public:
literal String^ HEADER_API_SESSION
public:
literal String^ HEADER_API_SESSION
static val mutable HEADER_API_SESSION: string
static val mutable HEADER_API_SESSION: string

Field Value

Type: Online String
See Also
SysConsts Class
SysConsts Members
NFX.Wave Namespace


SysConsts.HEADER_API_VERSION Field

SysConsts HEADER_API_VERSION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HEADER_API_VERSION
public const string HEADER_API_VERSION
Public Const HEADER_API_VERSION As String
Public Const HEADER_API_VERSION As String
public:
literal String^ HEADER_API_VERSION
public:
literal String^ HEADER_API_VERSION
static val mutable HEADER_API_VERSION: string
static val mutable HEADER_API_VERSION: string

Field Value

Type: Online String
See Also
SysConsts Class
SysConsts Members
NFX.Wave Namespace


SysConsts.HEADER_IF_MODIFIED_SINCE Field

SysConsts HEADER_IF_MODIFIED_SINCE Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HEADER_IF_MODIFIED_SINCE
public const string HEADER_IF_MODIFIED_SINCE
Public Const HEADER_IF_MODIFIED_SINCE As String
Public Const HEADER_IF_MODIFIED_SINCE As String
public:
literal String^ HEADER_IF_MODIFIED_SINCE
public:
literal String^ HEADER_IF_MODIFIED_SINCE
static val mutable HEADER_IF_MODIFIED_SINCE: string
static val mutable HEADER_IF_MODIFIED_SINCE: string

Field Value

Type: Online String
See Also
SysConsts Class
SysConsts Members
NFX.Wave Namespace


SysConsts.JSON_RESULT_ERROR Field

SysConsts JSON_RESULT_ERROR Field NFX Class Library

Returns object {OK = false}

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Object JSON_RESULT_ERROR
public static readonly Object JSON_RESULT_ERROR
Public Shared ReadOnly JSON_RESULT_ERROR As Object
Public Shared ReadOnly JSON_RESULT_ERROR As Object
public:
static initonly Object^ JSON_RESULT_ERROR
public:
static initonly Object^ JSON_RESULT_ERROR
static val JSON_RESULT_ERROR: Object
static val JSON_RESULT_ERROR: Object

Field Value

Type: Online Object
See Also
SysConsts Class
SysConsts Members
NFX.Wave Namespace


SysConsts.JSON_RESULT_OK Field

SysConsts JSON_RESULT_OK Field NFX Class Library

Returns object {OK = true}

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Object JSON_RESULT_OK
public static readonly Object JSON_RESULT_OK
Public Shared ReadOnly JSON_RESULT_OK As Object
Public Shared ReadOnly JSON_RESULT_OK As Object
public:
static initonly Object^ JSON_RESULT_OK
public:
static initonly Object^ JSON_RESULT_OK
static val JSON_RESULT_OK: Object
static val JSON_RESULT_OK: Object

Field Value

Type: Online Object
See Also
SysConsts Class
SysConsts Members
NFX.Wave Namespace


SysConsts.NULL_STRING Field

SysConsts NULL_STRING Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NULL_STRING
public const string NULL_STRING
Public Const NULL_STRING As String
Public Const NULL_STRING As String
public:
literal String^ NULL_STRING
public:
literal String^ NULL_STRING
static val mutable NULL_STRING: string
static val mutable NULL_STRING: string

Field Value

Type: Online String
See Also
SysConsts Class
SysConsts Members
NFX.Wave Namespace


SysConsts.UNSPECIFIED Field

SysConsts UNSPECIFIED Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNSPECIFIED
public const string UNSPECIFIED
Public Const UNSPECIFIED As String
Public Const UNSPECIFIED As String
public:
literal String^ UNSPECIFIED
public:
literal String^ UNSPECIFIED
static val mutable UNSPECIFIED: string
static val mutable UNSPECIFIED: string

Field Value

Type: Online String
See Also
SysConsts Class
SysConsts Members
NFX.Wave Namespace


SysConsts.WAVE_LOG_TOPIC Field

SysConsts WAVE_LOG_TOPIC Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string WAVE_LOG_TOPIC
public const string WAVE_LOG_TOPIC
Public Const WAVE_LOG_TOPIC As String
Public Const WAVE_LOG_TOPIC As String
public:
literal String^ WAVE_LOG_TOPIC
public:
literal String^ WAVE_LOG_TOPIC
static val mutable WAVE_LOG_TOPIC: string
static val mutable WAVE_LOG_TOPIC: string

Field Value

Type: Online String
See Also
SysConsts Class
SysConsts Members
NFX.Wave Namespace


Theme Class

Theme Class NFX Class Library

Represents a portal theme. Theme groups various resources (such as css, scripts etc..) whitin a portal. Do not inherit your themes from this class directly, instead use Theme(TPortal)
Inheritance Hierarchy
Online System Object
NFX.Wave Theme
NFX.Wave Theme TPortal

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Theme : INamed
public abstract class Theme : INamed
Public MustInherit Class Theme
    Implements INamed
Public MustInherit Class Theme
    Implements INamed
public ref class Theme abstract : INamed
public ref class Theme abstract : INamed
[<AbstractClassAttribute>]
type Theme =
    class
        interface INamed
    end
[<AbstractClassAttribute>]
type Theme =
    class
        interface INamed
    end
See Also
Theme Members
NFX.Wave Namespace


Theme Members

Theme Members NFX Class Library

The Theme type exposes the following members.
Constructors
 | Name | Description
Protected method | Theme | Initializes a new instance of the Theme class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Default | If true, gets matched when no other suites
Public property | Description | English/primary language description
Public property | Name | Globally-unique portal name/ID
Public property | Portal | Parent portal that this theme is under
Back to Top
See Also
Theme Class
NFX.Wave Namespace


Theme Constructor

Theme Constructor NFX Class Library

Initializes a new instance of the Theme class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Theme(
    Portal portal,
    IConfigSectionNode conf
)
protected Theme(
    Portal portal,
    IConfigSectionNode conf
)
Protected Sub New (
    portal As Portal,
    conf As IConfigSectionNode
)
Protected Sub New (
    portal As Portal,
    conf As IConfigSectionNode
)
protected:
Theme(
    Portal^ portal,
    IConfigSectionNode^ conf
)
protected:
Theme(
    Portal^ portal,
    IConfigSectionNode^ conf
)
new :
        portal : Portal *
        conf : IConfigSectionNode -> Theme
new :
        portal : Portal *
        conf : IConfigSectionNode -> Theme

Parameters

portal
Type: NFX.Wave Portal
conf
Type: NFX.Environment IConfigSectionNode
See Also
Theme Class
Theme Members
NFX.Wave Namespace


Theme Methods

Theme Methods NFX Class Library

The Theme type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Theme Class
NFX.Wave Namespace


Theme.ToString Method

Theme ToString Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Theme Class
Theme Members
NFX.Wave Namespace


Theme Properties

Theme Properties NFX Class Library

The Theme type exposes the following members.
Properties
 | Name | Description
Public property | Default | If true, gets matched when no other suites
Public property | Description | English/primary language description
Public property | Name | Globally-unique portal name/ID
Public property | Portal | Parent portal that this theme is under
Back to Top
See Also
Theme Class
NFX.Wave Namespace


Theme.Default Property

Theme Default Property NFX Class Library

If true, gets matched when no other suites

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Default { get; }
public bool Default { get; }
Public ReadOnly Property Default As Boolean
    Get
Public ReadOnly Property Default As Boolean
    Get
public:
property bool Default {
    bool get ();
}
public:
property bool Default {
    bool get ();
}
member Default : bool with get
member Default : bool with get

Property Value

Type: Online Boolean
See Also
Theme Class
Theme Members
NFX.Wave Namespace


Theme.Description Property

Theme Description Property NFX Class Library

English/primary language description

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; }
public string Description { get; }
Public ReadOnly Property Description As String
    Get
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
public:
property String^ Description {
    String^ get ();
}
member Description : string with get
member Description : string with get

Property Value

Type: Online String
See Also
Theme Class
Theme Members
NFX.Wave Namespace


Theme.Name Property

Theme Name Property NFX Class Library

Globally-unique portal name/ID

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Theme Class
Theme Members
NFX.Wave Namespace


Theme.Portal Property

Theme Portal Property NFX Class Library

Parent portal that this theme is under

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Portal Portal { get; }
public Portal Portal { get; }
Public ReadOnly Property Portal As Portal
    Get
Public ReadOnly Property Portal As Portal
    Get
public:
property Portal^ Portal {
    Portal^ get ();
}
public:
property Portal^ Portal {
    Portal^ get ();
}
member Portal : Portal with get
member Portal : Portal with get

Property Value

Type: Portal
See Also
Theme Class
Theme Members
NFX.Wave Namespace


Theme(TPortal) Class

Theme TPortal Class NFX Class Library

Represents a portal theme. Theme groups various resources (such as css, scripts etc..) whitin a portal. Inherit your themes from this class
Inheritance Hierarchy
Online System Object
NFX.Wave Theme
NFX.Wave Theme TPortal

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Theme<TPortal> : Theme
where TPortal : Portal
public abstract class Theme<TPortal> : Theme
where TPortal : Portal
Public MustInherit Class Theme(Of TPortal As Portal)
    Inherits Theme
Public MustInherit Class Theme(Of TPortal As Portal)
    Inherits Theme
generic<typename TPortal>
where TPortal : Portal
public ref class Theme abstract : public Theme
generic<typename TPortal>
where TPortal : Portal
public ref class Theme abstract : public Theme
[<AbstractClassAttribute>]
type Theme<'TPortal when 'TPortal : Portal> =
    class
        inherit Theme
    end
[<AbstractClassAttribute>]
type Theme<'TPortal when 'TPortal : Portal> =
    class
        inherit Theme
    end
Type Parameters
TPortal
See Also
Theme TPortal Members
NFX.Wave Namespace


Theme(TPortal) Members

Theme TPortal Members NFX Class Library

The Theme TPortal type exposes the following members.
Constructors
 | Name | Description
Protected method | Theme TPortal | Initializes a new instance of the Theme TPortal class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Theme.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Default | If true, gets matched when no other suites (Inherited from Theme.)
Public property | Description | English/primary language description (Inherited from Theme.)
Public property | Name | Globally-unique portal name/ID (Inherited from Theme.)
Public property | Portal | Parent portal that this theme is under
Back to Top
See Also
Theme TPortal Class
NFX.Wave Namespace


Theme(TPortal) Constructor

Theme TPortal Constructor NFX Class Library

Initializes a new instance of the Theme TPortal class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Theme(
    TPortal portal,
    IConfigSectionNode conf
)
protected Theme(
    TPortal portal,
    IConfigSectionNode conf
)
Protected Sub New (
    portal As TPortal,
    conf As IConfigSectionNode
)
Protected Sub New (
    portal As TPortal,
    conf As IConfigSectionNode
)
protected:
Theme(
    TPortal portal,
    IConfigSectionNode^ conf
)
protected:
Theme(
    TPortal portal,
    IConfigSectionNode^ conf
)
new :
        portal : 'TPortal *
        conf : IConfigSectionNode -> Theme
new :
        portal : 'TPortal *
        conf : IConfigSectionNode -> Theme

Parameters

portal
Type: TPortal
conf
Type: NFX.Environment IConfigSectionNode
See Also
Theme TPortal Class
Theme TPortal Members
NFX.Wave Namespace


Theme(TPortal) Methods

Theme TPortal Methods NFX Class Library

The Theme TPortal type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Theme.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Theme TPortal Class
NFX.Wave Namespace


Theme(TPortal) Properties

Theme TPortal Properties NFX Class Library

The Theme TPortal type exposes the following members.
Properties
 | Name | Description
Public property | Default | If true, gets matched when no other suites (Inherited from Theme.)
Public property | Description | English/primary language description (Inherited from Theme.)
Public property | Name | Globally-unique portal name/ID (Inherited from Theme.)
Public property | Portal | Parent portal that this theme is under
Back to Top
See Also
Theme TPortal Class
NFX.Wave Namespace


Theme(TPortal).Portal Property

Theme TPortal Portal Property NFX Class Library

Parent portal that this theme is under

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TPortal Portal { get; }
public TPortal Portal { get; }
Public ReadOnly Property Portal As TPortal
    Get
Public ReadOnly Property Portal As TPortal
    Get
public:
property TPortal Portal {
    TPortal get ();
}
public:
property TPortal Portal {
    TPortal get ();
}
member Portal : 'TPortal with get
member Portal : 'TPortal with get

Property Value

Type: TPortal
See Also
Theme TPortal Class
Theme TPortal Members
NFX.Wave Namespace


URIPattern Class

URIPattern Class NFX Class Library

Represents a URI pattern that can get matched against URI requests. The pattern is formed using regular URL grammar and captures segments denoted by "{}". Example: '/profiles/{controller}/{action="dflt value"}/{*params}' The class uses CSharp lexer, so it allows to use string escapes and unicode chars like CSharp
Inheritance Hierarchy
Online System Object
NFX.Wave URIPattern

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class URIPattern
public sealed class URIPattern
Public NotInheritable Class URIPattern
Public NotInheritable Class URIPattern
public ref class URIPattern sealed
public ref class URIPattern sealed
[<SealedAttribute>]
type URIPattern =  class end
[<SealedAttribute>]
type URIPattern =  class end
See Also
URIPattern Members
NFX.Wave Namespace


URIPattern Members

URIPattern Members NFX Class Library

The URIPattern type exposes the following members.
Constructors
 | Name | Description
Public method | URIPattern | Initializes a new instance of the URIPattern class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeURI | Creates URI from the supplied values for this pattern
Public method | MatchURIPath | Tries to match the pattern against the URI path section and returns a JSONDataMap match object filled with pattern match or NULL if pattern could not be matched. JSONDataMap may be easily converted to dynamic by calling new JSONDynamicObject(map)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Protected property | _____Chunks |
Public property | Pattern | Returns the original pattern
Back to Top
See Also
URIPattern Class
NFX.Wave Namespace


URIPattern Constructor

URIPattern Constructor NFX Class Library

Initializes a new instance of the URIPattern class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public URIPattern(
    string pattern
)
public URIPattern(
    string pattern
)
Public Sub New (
    pattern As String
)
Public Sub New (
    pattern As String
)
public:
URIPattern(
    String^ pattern
)
public:
URIPattern(
    String^ pattern
)
new :
        pattern : string -> URIPattern
new :
        pattern : string -> URIPattern

Parameters

pattern
Type: Online System String
See Also
URIPattern Class
URIPattern Members
NFX.Wave Namespace


URIPattern Methods

URIPattern Methods NFX Class Library

The URIPattern type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeURI | Creates URI from the supplied values for this pattern
Public method | MatchURIPath | Tries to match the pattern against the URI path section and returns a JSONDataMap match object filled with pattern match or NULL if pattern could not be matched. JSONDataMap may be easily converted to dynamic by calling new JSONDynamicObject(map)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
URIPattern Class
NFX.Wave Namespace


URIPattern.MakeURI Method

URIPattern MakeURI Method NFX Class Library

Creates URI from the supplied values for this pattern

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Uri MakeURI(
    IDictionary<string, Object> values,
    Uri prefix = null
)
public Uri MakeURI(
    IDictionary<string, Object> values,
    Uri prefix = null
)
Public Function MakeURI (
    values As IDictionary(Of String, Object),
    Optional prefix As Uri = Nothing
) As Uri
Public Function MakeURI (
    values As IDictionary(Of String, Object),
    Optional prefix As Uri = Nothing
) As Uri
public:
Uri^ MakeURI(
    IDictionary<String^, Object^>^ values,
    Uri^ prefix = nullptr
)
public:
Uri^ MakeURI(
    IDictionary<String^, Object^>^ values,
    Uri^ prefix = nullptr
)
member MakeURI :
        values : IDictionary<string, Object> *
        ?prefix : Uri
(* Defaults:
        let _prefix = defaultArg prefix null
*)
-> Uri
member MakeURI :
        values : IDictionary<string, Object> *
        ?prefix : Uri
(* Defaults:
        let _prefix = defaultArg prefix null
*)
-> Uri

Parameters

values
Type: Online System.Collections.Generic IDictionary Online String, Online Object
prefix (Optional)
Type: Online System Uri

Return Value

Type: Online Uri
See Also
URIPattern Class
URIPattern Members
NFX.Wave Namespace


URIPattern.MatchURIPath Method

URIPattern MatchURIPath Method NFX Class Library

Tries to match the pattern against the URI path section and returns a JSONDataMap match object filled with pattern match or NULL if pattern could not be matched. JSONDataMap may be easily converted to dynamic by calling new JSONDynamicObject(map)

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap MatchURIPath(
    Uri uri,
    bool senseCase = false
)
public JSONDataMap MatchURIPath(
    Uri uri,
    bool senseCase = false
)
Public Function MatchURIPath (
    uri As Uri,
    Optional senseCase As Boolean = false
) As JSONDataMap
Public Function MatchURIPath (
    uri As Uri,
    Optional senseCase As Boolean = false
) As JSONDataMap
public:
JSONDataMap^ MatchURIPath(
    Uri^ uri,
    bool senseCase = false
)
public:
JSONDataMap^ MatchURIPath(
    Uri^ uri,
    bool senseCase = false
)
member MatchURIPath :
        uri : Uri *
        ?senseCase : bool
(* Defaults:
        let _senseCase = defaultArg senseCase false
*)
-> JSONDataMap
member MatchURIPath :
        uri : Uri *
        ?senseCase : bool
(* Defaults:
        let _senseCase = defaultArg senseCase false
*)
-> JSONDataMap

Parameters

uri
Type: Online System Uri
senseCase (Optional)
Type: Online System Boolean

Return Value

Type: JSONDataMap
See Also
URIPattern Class
URIPattern Members
NFX.Wave Namespace


URIPattern Properties

URIPattern Properties NFX Class Library

The URIPattern type exposes the following members.
Properties
 | Name | Description
Protected property | _____Chunks |
Public property | Pattern | Returns the original pattern
Back to Top
See Also
URIPattern Class
NFX.Wave Namespace


URIPattern._____Chunks Property

URIPattern _____Chunks Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal string _____Chunks { get; }
internal string _____Chunks { get; }
Friend ReadOnly Property _____Chunks As String
    Get
Friend ReadOnly Property _____Chunks As String
    Get
internal:
property String^ _____Chunks {
    String^ get ();
}
internal:
property String^ _____Chunks {
    String^ get ();
}
internal member _____Chunks : string with get
internal member _____Chunks : string with get

Property Value

Type: Online String
See Also
URIPattern Class
URIPattern Members
NFX.Wave Namespace


URIPattern.Pattern Property

URIPattern Pattern Property NFX Class Library

Returns the original pattern

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Pattern { get; }
public string Pattern { get; }
Public ReadOnly Property Pattern As String
    Get
Public ReadOnly Property Pattern As String
    Get
public:
property String^ Pattern {
    String^ get ();
}
public:
property String^ Pattern {
    String^ get ();
}
member Pattern : string with get
member Pattern : string with get

Property Value

Type: Online String
See Also
URIPattern Class
URIPattern Members
NFX.Wave Namespace


WaveException Class

WaveException Class NFX Class Library

Base exception thrown by the WAVE framework
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Wave WaveException
NFX.Wave FilterPipelineException
NFX.Wave HTTPStatusException
NFX.Wave MVCActionException
NFX.Wave WaveTemplateRenderingException

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WaveException : NFXException
[SerializableAttribute]
public class WaveException : NFXException
<SerializableAttribute>
Public Class WaveException
    Inherits NFXException
<SerializableAttribute>
Public Class WaveException
    Inherits NFXException
[SerializableAttribute]
public ref class WaveException : public NFXException
[SerializableAttribute]
public ref class WaveException : public NFXException
[<SerializableAttribute>]
type WaveException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type WaveException =
    class
        inherit NFXException
    end
See Also
WaveException Members
NFX.Wave Namespace


WaveException Members

WaveException Members NFX Class Library

The WaveException type exposes the following members.
Constructors
 | Name | Description
Public method | WaveException | Initializes a new instance of the WaveException class
Public method | WaveException(String) | Initializes a new instance of the WaveException class
Protected method | WaveException(SerializationInfo, StreamingContext) | Initializes a new instance of the WaveException class
Public method | WaveException(String, Exception) | Initializes a new instance of the WaveException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
WaveException Class
NFX.Wave Namespace


WaveException Constructor

WaveException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | WaveException | Initializes a new instance of the WaveException class
Public method | WaveException(String) | Initializes a new instance of the WaveException class
Protected method | WaveException(SerializationInfo, StreamingContext) | Initializes a new instance of the WaveException class
Public method | WaveException(String, Exception) | Initializes a new instance of the WaveException class
Back to Top
See Also
WaveException Class
WaveException Members
NFX.Wave Namespace


WaveException Constructor

WaveException Constructor NFX Class Library

Initializes a new instance of the WaveException class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveException()
public WaveException()
Public Sub New
Public Sub New
public:
WaveException()
public:
WaveException()
new : unit -> WaveException
new : unit -> WaveException
See Also
WaveException Class
WaveException Members
WaveException Overload
NFX.Wave Namespace


WaveException Constructor (String)

WaveException Constructor (String) NFX Class Library

Initializes a new instance of the WaveException class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveException(
    string message
)
public WaveException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
WaveException(
    String^ message
)
public:
WaveException(
    String^ message
)
new :
        message : string -> WaveException
new :
        message : string -> WaveException

Parameters

message
Type: Online System String
See Also
WaveException Class
WaveException Members
WaveException Overload
NFX.Wave Namespace


WaveException Constructor (SerializationInfo, StreamingContext)

WaveException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WaveException class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected WaveException(
    SerializationInfo info,
    StreamingContext context
)
protected WaveException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
WaveException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
WaveException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> WaveException
new :
        info : SerializationInfo *
        context : StreamingContext -> WaveException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
WaveException Class
WaveException Members
WaveException Overload
NFX.Wave Namespace


WaveException Constructor (String, Exception)

WaveException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WaveException class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveException(
    string message,
    Exception inner
)
public WaveException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
WaveException(
    String^ message,
    Exception^ inner
)
public:
WaveException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> WaveException
new :
        message : string *
        inner : Exception -> WaveException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
WaveException Class
WaveException Members
WaveException Overload
NFX.Wave Namespace


WaveException Methods

WaveException Methods NFX Class Library

The WaveException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
WaveException Class
NFX.Wave Namespace


WaveException Properties

WaveException Properties NFX Class Library

The WaveException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
WaveException Class
NFX.Wave Namespace


WaveException Events

WaveException Events NFX Class Library

The WaveException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
WaveException Class
NFX.Wave Namespace


WaveServer Class

WaveServer Class NFX Class Library

Represents "(W)eb(A)pp(V)iew(E)nhanced" web server which provides DYNAMIC web site services. This server is not meant to be exposed directly to the public Internet, rather it should be used as an application server behind the reverse proxy, such as NGINX. This server is designed to serve dynamic data-driven requests/APIs and not meant to be used for serving static content files (although it can). The implementation is based on a lightweight HttpListener that processes incoming Http requests via an injectable WorkDispatcher which governs the threading and WorkContext lifecycle. The server processing pipeline is purposely designed to be synchronous-blocking (thread per call) which does not mean that the server is inefficient, to the contrary - this server design is specifically targeting short-called methods relying on a classical thread call stack. This approach obviates the need to create surrogate message loops/synchro contexts, tasks and other objects that introduce extra GC load. The server easily support "dangling"(left open indefinitely) WorkContext instances that can stream events (i.e. SSE/Server Push) and WebSockets from specially-purposed asynchronous notification threads.
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Online Object
NFX.ServiceModel ServiceWithInstrumentationBase Online Object
NFX.Wave WaveServer

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class WaveServer : ServiceWithInstrumentationBase<Object>
public class WaveServer : ServiceWithInstrumentationBase<Object>
Public Class WaveServer
    Inherits ServiceWithInstrumentationBase(Of Object)
Public Class WaveServer
    Inherits ServiceWithInstrumentationBase(Of Object)
public ref class WaveServer : public ServiceWithInstrumentationBase<Object^>
public ref class WaveServer : public ServiceWithInstrumentationBase<Object^>
type WaveServer =
    class
        inherit ServiceWithInstrumentationBase<Object>
    end
type WaveServer =
    class
        inherit ServiceWithInstrumentationBase<Object>
    end
Remarks
The common belief that asynchronous non-thread-based web servers always work faster (i.e. Node.js) is not true in the data-oriented systems of high scale because eventually multiple web server machines still block on common data access resources, so it is much more important to design the database backend in an asynchronous fashion, as it is the real bottle neck of the system. Even if most of the available threads are not physically paused by IO, they are paused logically as the logical units of work are waiting for IO and the fact that server can accept more socket requests does not mean that they will not timeout. The downsides of asynchronous web layers are: (a) much increased implementation/maintenance complexity (b) many additional task/thread context switches and extra objects that facilitate the event loops/messages/tasks etc...
See Also
WaveServer Members
NFX.Wave Namespace


WaveServer Members

WaveServer Members NFX Class Library

The WaveServer type exposes the following members.
Constructors
 | Name | Description
Public method | WaveServer | Initializes a new instance of the WaveServer class
Public method | WaveServer(String) | Initializes a new instance of the WaveServer class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Protected method | AfterListenerStart | Override to set listener options such as TimeoutManager.MinSendBytesPerSecond after listener.Start()
Protected method | BeforeListenerStart | Override to set listener options such as TimeoutManager.MinSendBytesPerSecond before listener.Start()
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleException | Handles processing exception by calling ErrorFilter.HandleException(work, error). All parameters except ERROR can be null - which indicates error that happened during WorkContext dispose
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Public method | Log | Facilitates server logging
Protected method | MakeContext | Factory method that makes new WorkContext instances. Override to make a WorkContext-derivative
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | ACCEPT_THREAD_GRANULARITY_MS |
 | CONFIG_DEFAULT_ERROR_HANDLER_SECTION |
 | CONFIG_DISPATCHER_SECTION |
 | CONFIG_GATE_SECTION |
 | CONFIG_PREFIX_SECTION |
 | CONFIG_SERVER_SECTION |
 | DEFAULT_CLIENT_VARS_COOKIE_NAME |
 | DEFAULT_KERNEL_HTTP_QUEUE_LIMIT |
 | DEFAULT_PARALLEL_ACCEPTS |
 | DEFAULT_PARALLEL_WORKS |
 | INSTRUMENTATION_DUMP_PERIOD_MS |
Protected field | m_InstrumentationEnabled |
Protected field | m_stat_FilterHandleException |
Protected field | m_stat_GeoLookup |
Protected field | m_stat_GeoLookupHit |
Protected field | m_stat_PortalRequest |
Protected field | m_stat_ServerAcceptSemaphoreCount |
Protected field | m_stat_ServerGateDenial |
Protected field | m_stat_ServerHandleException |
Protected field | m_stat_ServerRequest |
Protected field | m_stat_ServerWorkSemaphoreCount |
Protected field | m_stat_SessionEnd |
Protected field | m_stat_SessionExisting |
Protected field | m_stat_SessionInvalidID |
Protected field | m_stat_SessionNew |
Protected field | m_stat_WorkContextAborted |
Protected field | m_stat_WorkContextBufferedResponse |
Protected field | m_stat_WorkContextBufferedResponseBytes |
Protected field | m_stat_WorkContextCtor |
Protected field | m_stat_WorkContextDctor |
Protected field | m_stat_WorkContextHandled |
Protected field | m_stat_WorkContextNeedsSession |
Protected field | m_stat_WorkContextNoDefaultClose |
Protected field | m_stat_WorkContextWorkSemaphoreRelease |
Protected field | m_stat_WorkContextWrittenResponse |
Protected field | m_WorkSemaphore |
 | MAX_KERNEL_HTTP_QUEUE_LIMIT |
 | MAX_PARALLEL_ACCEPTS |
 | MAX_PARALLEL_WORKS |
 | MIN_KERNEL_HTTP_QUEUE_LIMIT |
 | MIN_PARALLEL_ACCEPTS |
 | MIN_PARALLEL_WORKS |
 | s_Servers |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ClientVarsCookieName | Provides the name of cookie where server keeps client vars
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Gets/sets work dispatcher
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EnvironmentName | Provides the name of environment, i.e. DEV,PROD, TEST i.e. some handlers may depend on environment name to serve DEV vs PROD java script files etc.
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Gate | Gets/sets network gate
Public property | GateCallerRealIpAddressHeader |
Public property | IgnoreClientWriteErrors | When true does not throw exceptions on client channel write
Public property | InstrumentationEnabled | When true, emits instrumentation messages (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | KernelHttpQueueLimit | Establishes HTTP.sys kernel queue limit
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | LogHandleExceptionErrors | When true writes errors that get thrown in server cathc-all HandleException methods
Public property | LogMatches | Returns matches used by the server's default error handler to determine whether exception details should be logged
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | ParallelAccepts | Specifies how many requests can get accepted from kernel queue in parallel
Public property | ParallelWorks | Specifies how many instances of WorkContext(or derivatives) can be processed at the same time
Public property | Prefixes | Returns HttpListener prefixes such as "http://+:8080/"
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
 | Servers | Returns the global registry of all server instances that are active in this process
Public property | ShowDumpMatches | Returns matches used by the server's default error handler to determine whether exception details should be shown
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
WaveServer Class
NFX.Wave Namespace


WaveServer Constructor

WaveServer Constructor NFX Class Library

Overload List
 | Name | Description
Public method | WaveServer | Initializes a new instance of the WaveServer class
Public method | WaveServer(String) | Initializes a new instance of the WaveServer class
Back to Top
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer Constructor

WaveServer Constructor NFX Class Library

Initializes a new instance of the WaveServer class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveServer()
public WaveServer()
Public Sub New
Public Sub New
public:
WaveServer()
public:
WaveServer()
new : unit -> WaveServer
new : unit -> WaveServer
See Also
WaveServer Class
WaveServer Members
WaveServer Overload
NFX.Wave Namespace


WaveServer Constructor (String)

WaveServer Constructor (String) NFX Class Library

Initializes a new instance of the WaveServer class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveServer(
    string name
)
public WaveServer(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
WaveServer(
    String^ name
)
public:
WaveServer(
    String^ name
)
new :
        name : string -> WaveServer
new :
        name : string -> WaveServer

Parameters

name
Type: Online System String
See Also
WaveServer Class
WaveServer Members
WaveServer Overload
NFX.Wave Namespace


WaveServer Fields

WaveServer Fields NFX Class Library

The WaveServer type exposes the following members.
Fields
 | Name | Description
 | ACCEPT_THREAD_GRANULARITY_MS |
 | CONFIG_DEFAULT_ERROR_HANDLER_SECTION |
 | CONFIG_DISPATCHER_SECTION |
 | CONFIG_GATE_SECTION |
 | CONFIG_PREFIX_SECTION |
 | CONFIG_SERVER_SECTION |
 | DEFAULT_CLIENT_VARS_COOKIE_NAME |
 | DEFAULT_KERNEL_HTTP_QUEUE_LIMIT |
 | DEFAULT_PARALLEL_ACCEPTS |
 | DEFAULT_PARALLEL_WORKS |
 | INSTRUMENTATION_DUMP_PERIOD_MS |
Protected field | m_InstrumentationEnabled |
Protected field | m_stat_FilterHandleException |
Protected field | m_stat_GeoLookup |
Protected field | m_stat_GeoLookupHit |
Protected field | m_stat_PortalRequest |
Protected field | m_stat_ServerAcceptSemaphoreCount |
Protected field | m_stat_ServerGateDenial |
Protected field | m_stat_ServerHandleException |
Protected field | m_stat_ServerRequest |
Protected field | m_stat_ServerWorkSemaphoreCount |
Protected field | m_stat_SessionEnd |
Protected field | m_stat_SessionExisting |
Protected field | m_stat_SessionInvalidID |
Protected field | m_stat_SessionNew |
Protected field | m_stat_WorkContextAborted |
Protected field | m_stat_WorkContextBufferedResponse |
Protected field | m_stat_WorkContextBufferedResponseBytes |
Protected field | m_stat_WorkContextCtor |
Protected field | m_stat_WorkContextDctor |
Protected field | m_stat_WorkContextHandled |
Protected field | m_stat_WorkContextNeedsSession |
Protected field | m_stat_WorkContextNoDefaultClose |
Protected field | m_stat_WorkContextWorkSemaphoreRelease |
Protected field | m_stat_WorkContextWrittenResponse |
Protected field | m_WorkSemaphore |
 | MAX_KERNEL_HTTP_QUEUE_LIMIT |
 | MAX_PARALLEL_ACCEPTS |
 | MAX_PARALLEL_WORKS |
 | MIN_KERNEL_HTTP_QUEUE_LIMIT |
 | MIN_PARALLEL_ACCEPTS |
 | MIN_PARALLEL_WORKS |
 | s_Servers |
Back to Top
See Also
WaveServer Class
NFX.Wave Namespace


WaveServer.ACCEPT_THREAD_GRANULARITY_MS Field

WaveServer ACCEPT_THREAD_GRANULARITY_MS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int ACCEPT_THREAD_GRANULARITY_MS
public const int ACCEPT_THREAD_GRANULARITY_MS
Public Const ACCEPT_THREAD_GRANULARITY_MS As Integer
Public Const ACCEPT_THREAD_GRANULARITY_MS As Integer
public:
literal int ACCEPT_THREAD_GRANULARITY_MS
public:
literal int ACCEPT_THREAD_GRANULARITY_MS
static val mutable ACCEPT_THREAD_GRANULARITY_MS: int
static val mutable ACCEPT_THREAD_GRANULARITY_MS: int

Field Value

Type: Online Int32
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.CONFIG_DEFAULT_ERROR_HANDLER_SECTION Field

WaveServer CONFIG_DEFAULT_ERROR_HANDLER_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DEFAULT_ERROR_HANDLER_SECTION
public const string CONFIG_DEFAULT_ERROR_HANDLER_SECTION
Public Const CONFIG_DEFAULT_ERROR_HANDLER_SECTION As String
Public Const CONFIG_DEFAULT_ERROR_HANDLER_SECTION As String
public:
literal String^ CONFIG_DEFAULT_ERROR_HANDLER_SECTION
public:
literal String^ CONFIG_DEFAULT_ERROR_HANDLER_SECTION
static val mutable CONFIG_DEFAULT_ERROR_HANDLER_SECTION: string
static val mutable CONFIG_DEFAULT_ERROR_HANDLER_SECTION: string

Field Value

Type: Online String
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.CONFIG_DISPATCHER_SECTION Field

WaveServer CONFIG_DISPATCHER_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DISPATCHER_SECTION
public const string CONFIG_DISPATCHER_SECTION
Public Const CONFIG_DISPATCHER_SECTION As String
Public Const CONFIG_DISPATCHER_SECTION As String
public:
literal String^ CONFIG_DISPATCHER_SECTION
public:
literal String^ CONFIG_DISPATCHER_SECTION
static val mutable CONFIG_DISPATCHER_SECTION: string
static val mutable CONFIG_DISPATCHER_SECTION: string

Field Value

Type: Online String
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.CONFIG_GATE_SECTION Field

WaveServer CONFIG_GATE_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_GATE_SECTION
public const string CONFIG_GATE_SECTION
Public Const CONFIG_GATE_SECTION As String
Public Const CONFIG_GATE_SECTION As String
public:
literal String^ CONFIG_GATE_SECTION
public:
literal String^ CONFIG_GATE_SECTION
static val mutable CONFIG_GATE_SECTION: string
static val mutable CONFIG_GATE_SECTION: string

Field Value

Type: Online String
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.CONFIG_PREFIX_SECTION Field

WaveServer CONFIG_PREFIX_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PREFIX_SECTION
public const string CONFIG_PREFIX_SECTION
Public Const CONFIG_PREFIX_SECTION As String
Public Const CONFIG_PREFIX_SECTION As String
public:
literal String^ CONFIG_PREFIX_SECTION
public:
literal String^ CONFIG_PREFIX_SECTION
static val mutable CONFIG_PREFIX_SECTION: string
static val mutable CONFIG_PREFIX_SECTION: string

Field Value

Type: Online String
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.CONFIG_SERVER_SECTION Field

WaveServer CONFIG_SERVER_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SERVER_SECTION
public const string CONFIG_SERVER_SECTION
Public Const CONFIG_SERVER_SECTION As String
Public Const CONFIG_SERVER_SECTION As String
public:
literal String^ CONFIG_SERVER_SECTION
public:
literal String^ CONFIG_SERVER_SECTION
static val mutable CONFIG_SERVER_SECTION: string
static val mutable CONFIG_SERVER_SECTION: string

Field Value

Type: Online String
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.DEFAULT_CLIENT_VARS_COOKIE_NAME Field

WaveServer DEFAULT_CLIENT_VARS_COOKIE_NAME Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_CLIENT_VARS_COOKIE_NAME
public const string DEFAULT_CLIENT_VARS_COOKIE_NAME
Public Const DEFAULT_CLIENT_VARS_COOKIE_NAME As String
Public Const DEFAULT_CLIENT_VARS_COOKIE_NAME As String
public:
literal String^ DEFAULT_CLIENT_VARS_COOKIE_NAME
public:
literal String^ DEFAULT_CLIENT_VARS_COOKIE_NAME
static val mutable DEFAULT_CLIENT_VARS_COOKIE_NAME: string
static val mutable DEFAULT_CLIENT_VARS_COOKIE_NAME: string

Field Value

Type: Online String
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.DEFAULT_KERNEL_HTTP_QUEUE_LIMIT Field

WaveServer DEFAULT_KERNEL_HTTP_QUEUE_LIMIT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_KERNEL_HTTP_QUEUE_LIMIT
public const int DEFAULT_KERNEL_HTTP_QUEUE_LIMIT
Public Const DEFAULT_KERNEL_HTTP_QUEUE_LIMIT As Integer
Public Const DEFAULT_KERNEL_HTTP_QUEUE_LIMIT As Integer
public:
literal int DEFAULT_KERNEL_HTTP_QUEUE_LIMIT
public:
literal int DEFAULT_KERNEL_HTTP_QUEUE_LIMIT
static val mutable DEFAULT_KERNEL_HTTP_QUEUE_LIMIT: int
static val mutable DEFAULT_KERNEL_HTTP_QUEUE_LIMIT: int

Field Value

Type: Online Int32
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.DEFAULT_PARALLEL_ACCEPTS Field

WaveServer DEFAULT_PARALLEL_ACCEPTS Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_PARALLEL_ACCEPTS
public const int DEFAULT_PARALLEL_ACCEPTS
Public Const DEFAULT_PARALLEL_ACCEPTS As Integer
Public Const DEFAULT_PARALLEL_ACCEPTS As Integer
public:
literal int DEFAULT_PARALLEL_ACCEPTS
public:
literal int DEFAULT_PARALLEL_ACCEPTS
static val mutable DEFAULT_PARALLEL_ACCEPTS: int
static val mutable DEFAULT_PARALLEL_ACCEPTS: int

Field Value

Type: Online Int32
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.DEFAULT_PARALLEL_WORKS Field

WaveServer DEFAULT_PARALLEL_WORKS Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_PARALLEL_WORKS
public const int DEFAULT_PARALLEL_WORKS
Public Const DEFAULT_PARALLEL_WORKS As Integer
Public Const DEFAULT_PARALLEL_WORKS As Integer
public:
literal int DEFAULT_PARALLEL_WORKS
public:
literal int DEFAULT_PARALLEL_WORKS
static val mutable DEFAULT_PARALLEL_WORKS: int
static val mutable DEFAULT_PARALLEL_WORKS: int

Field Value

Type: Online Int32
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.INSTRUMENTATION_DUMP_PERIOD_MS Field

WaveServer INSTRUMENTATION_DUMP_PERIOD_MS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int INSTRUMENTATION_DUMP_PERIOD_MS
public const int INSTRUMENTATION_DUMP_PERIOD_MS
Public Const INSTRUMENTATION_DUMP_PERIOD_MS As Integer
Public Const INSTRUMENTATION_DUMP_PERIOD_MS As Integer
public:
literal int INSTRUMENTATION_DUMP_PERIOD_MS
public:
literal int INSTRUMENTATION_DUMP_PERIOD_MS
static val mutable INSTRUMENTATION_DUMP_PERIOD_MS: int
static val mutable INSTRUMENTATION_DUMP_PERIOD_MS: int

Field Value

Type: Online Int32
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_InstrumentationEnabled Field

WaveServer m_InstrumentationEnabled Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal bool m_InstrumentationEnabled
internal bool m_InstrumentationEnabled
Friend m_InstrumentationEnabled As Boolean
Friend m_InstrumentationEnabled As Boolean
internal:
bool m_InstrumentationEnabled
internal:
bool m_InstrumentationEnabled
val mutable internal m_InstrumentationEnabled: bool
val mutable internal m_InstrumentationEnabled: bool

Field Value

Type: Online Boolean
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_FilterHandleException Field

WaveServer m_stat_FilterHandleException Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_FilterHandleException
internal long m_stat_FilterHandleException
Friend m_stat_FilterHandleException As Long
Friend m_stat_FilterHandleException As Long
internal:
long long m_stat_FilterHandleException
internal:
long long m_stat_FilterHandleException
val mutable internal m_stat_FilterHandleException: int64
val mutable internal m_stat_FilterHandleException: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_GeoLookup Field

WaveServer m_stat_GeoLookup Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_GeoLookup
internal long m_stat_GeoLookup
Friend m_stat_GeoLookup As Long
Friend m_stat_GeoLookup As Long
internal:
long long m_stat_GeoLookup
internal:
long long m_stat_GeoLookup
val mutable internal m_stat_GeoLookup: int64
val mutable internal m_stat_GeoLookup: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_GeoLookupHit Field

WaveServer m_stat_GeoLookupHit Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_GeoLookupHit
internal long m_stat_GeoLookupHit
Friend m_stat_GeoLookupHit As Long
Friend m_stat_GeoLookupHit As Long
internal:
long long m_stat_GeoLookupHit
internal:
long long m_stat_GeoLookupHit
val mutable internal m_stat_GeoLookupHit: int64
val mutable internal m_stat_GeoLookupHit: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_PortalRequest Field

WaveServer m_stat_PortalRequest Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal NamedInterlocked m_stat_PortalRequest
internal NamedInterlocked m_stat_PortalRequest
Friend m_stat_PortalRequest As NamedInterlocked
Friend m_stat_PortalRequest As NamedInterlocked
internal:
NamedInterlocked^ m_stat_PortalRequest
internal:
NamedInterlocked^ m_stat_PortalRequest
val mutable internal m_stat_PortalRequest: NamedInterlocked
val mutable internal m_stat_PortalRequest: NamedInterlocked

Field Value

Type: NamedInterlocked
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_ServerAcceptSemaphoreCount Field

WaveServer m_stat_ServerAcceptSemaphoreCount Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_ServerAcceptSemaphoreCount
internal long m_stat_ServerAcceptSemaphoreCount
Friend m_stat_ServerAcceptSemaphoreCount As Long
Friend m_stat_ServerAcceptSemaphoreCount As Long
internal:
long long m_stat_ServerAcceptSemaphoreCount
internal:
long long m_stat_ServerAcceptSemaphoreCount
val mutable internal m_stat_ServerAcceptSemaphoreCount: int64
val mutable internal m_stat_ServerAcceptSemaphoreCount: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_ServerGateDenial Field

WaveServer m_stat_ServerGateDenial Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_ServerGateDenial
internal long m_stat_ServerGateDenial
Friend m_stat_ServerGateDenial As Long
Friend m_stat_ServerGateDenial As Long
internal:
long long m_stat_ServerGateDenial
internal:
long long m_stat_ServerGateDenial
val mutable internal m_stat_ServerGateDenial: int64
val mutable internal m_stat_ServerGateDenial: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_ServerHandleException Field

WaveServer m_stat_ServerHandleException Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_ServerHandleException
internal long m_stat_ServerHandleException
Friend m_stat_ServerHandleException As Long
Friend m_stat_ServerHandleException As Long
internal:
long long m_stat_ServerHandleException
internal:
long long m_stat_ServerHandleException
val mutable internal m_stat_ServerHandleException: int64
val mutable internal m_stat_ServerHandleException: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_ServerRequest Field

WaveServer m_stat_ServerRequest Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_ServerRequest
internal long m_stat_ServerRequest
Friend m_stat_ServerRequest As Long
Friend m_stat_ServerRequest As Long
internal:
long long m_stat_ServerRequest
internal:
long long m_stat_ServerRequest
val mutable internal m_stat_ServerRequest: int64
val mutable internal m_stat_ServerRequest: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_ServerWorkSemaphoreCount Field

WaveServer m_stat_ServerWorkSemaphoreCount Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_ServerWorkSemaphoreCount
internal long m_stat_ServerWorkSemaphoreCount
Friend m_stat_ServerWorkSemaphoreCount As Long
Friend m_stat_ServerWorkSemaphoreCount As Long
internal:
long long m_stat_ServerWorkSemaphoreCount
internal:
long long m_stat_ServerWorkSemaphoreCount
val mutable internal m_stat_ServerWorkSemaphoreCount: int64
val mutable internal m_stat_ServerWorkSemaphoreCount: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_SessionEnd Field

WaveServer m_stat_SessionEnd Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_SessionEnd
internal long m_stat_SessionEnd
Friend m_stat_SessionEnd As Long
Friend m_stat_SessionEnd As Long
internal:
long long m_stat_SessionEnd
internal:
long long m_stat_SessionEnd
val mutable internal m_stat_SessionEnd: int64
val mutable internal m_stat_SessionEnd: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_SessionExisting Field

WaveServer m_stat_SessionExisting Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_SessionExisting
internal long m_stat_SessionExisting
Friend m_stat_SessionExisting As Long
Friend m_stat_SessionExisting As Long
internal:
long long m_stat_SessionExisting
internal:
long long m_stat_SessionExisting
val mutable internal m_stat_SessionExisting: int64
val mutable internal m_stat_SessionExisting: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_SessionInvalidID Field

WaveServer m_stat_SessionInvalidID Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_SessionInvalidID
internal long m_stat_SessionInvalidID
Friend m_stat_SessionInvalidID As Long
Friend m_stat_SessionInvalidID As Long
internal:
long long m_stat_SessionInvalidID
internal:
long long m_stat_SessionInvalidID
val mutable internal m_stat_SessionInvalidID: int64
val mutable internal m_stat_SessionInvalidID: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_SessionNew Field

WaveServer m_stat_SessionNew Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_SessionNew
internal long m_stat_SessionNew
Friend m_stat_SessionNew As Long
Friend m_stat_SessionNew As Long
internal:
long long m_stat_SessionNew
internal:
long long m_stat_SessionNew
val mutable internal m_stat_SessionNew: int64
val mutable internal m_stat_SessionNew: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_WorkContextAborted Field

WaveServer m_stat_WorkContextAborted Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_WorkContextAborted
internal long m_stat_WorkContextAborted
Friend m_stat_WorkContextAborted As Long
Friend m_stat_WorkContextAborted As Long
internal:
long long m_stat_WorkContextAborted
internal:
long long m_stat_WorkContextAborted
val mutable internal m_stat_WorkContextAborted: int64
val mutable internal m_stat_WorkContextAborted: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_WorkContextBufferedResponse Field

WaveServer m_stat_WorkContextBufferedResponse Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_WorkContextBufferedResponse
internal long m_stat_WorkContextBufferedResponse
Friend m_stat_WorkContextBufferedResponse As Long
Friend m_stat_WorkContextBufferedResponse As Long
internal:
long long m_stat_WorkContextBufferedResponse
internal:
long long m_stat_WorkContextBufferedResponse
val mutable internal m_stat_WorkContextBufferedResponse: int64
val mutable internal m_stat_WorkContextBufferedResponse: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_WorkContextBufferedResponseBytes Field

WaveServer m_stat_WorkContextBufferedResponseBytes Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_WorkContextBufferedResponseBytes
internal long m_stat_WorkContextBufferedResponseBytes
Friend m_stat_WorkContextBufferedResponseBytes As Long
Friend m_stat_WorkContextBufferedResponseBytes As Long
internal:
long long m_stat_WorkContextBufferedResponseBytes
internal:
long long m_stat_WorkContextBufferedResponseBytes
val mutable internal m_stat_WorkContextBufferedResponseBytes: int64
val mutable internal m_stat_WorkContextBufferedResponseBytes: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_WorkContextCtor Field

WaveServer m_stat_WorkContextCtor Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_WorkContextCtor
internal long m_stat_WorkContextCtor
Friend m_stat_WorkContextCtor As Long
Friend m_stat_WorkContextCtor As Long
internal:
long long m_stat_WorkContextCtor
internal:
long long m_stat_WorkContextCtor
val mutable internal m_stat_WorkContextCtor: int64
val mutable internal m_stat_WorkContextCtor: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_WorkContextDctor Field

WaveServer m_stat_WorkContextDctor Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_WorkContextDctor
internal long m_stat_WorkContextDctor
Friend m_stat_WorkContextDctor As Long
Friend m_stat_WorkContextDctor As Long
internal:
long long m_stat_WorkContextDctor
internal:
long long m_stat_WorkContextDctor
val mutable internal m_stat_WorkContextDctor: int64
val mutable internal m_stat_WorkContextDctor: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_WorkContextHandled Field

WaveServer m_stat_WorkContextHandled Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_WorkContextHandled
internal long m_stat_WorkContextHandled
Friend m_stat_WorkContextHandled As Long
Friend m_stat_WorkContextHandled As Long
internal:
long long m_stat_WorkContextHandled
internal:
long long m_stat_WorkContextHandled
val mutable internal m_stat_WorkContextHandled: int64
val mutable internal m_stat_WorkContextHandled: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_WorkContextNeedsSession Field

WaveServer m_stat_WorkContextNeedsSession Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_WorkContextNeedsSession
internal long m_stat_WorkContextNeedsSession
Friend m_stat_WorkContextNeedsSession As Long
Friend m_stat_WorkContextNeedsSession As Long
internal:
long long m_stat_WorkContextNeedsSession
internal:
long long m_stat_WorkContextNeedsSession
val mutable internal m_stat_WorkContextNeedsSession: int64
val mutable internal m_stat_WorkContextNeedsSession: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_WorkContextNoDefaultClose Field

WaveServer m_stat_WorkContextNoDefaultClose Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_WorkContextNoDefaultClose
internal long m_stat_WorkContextNoDefaultClose
Friend m_stat_WorkContextNoDefaultClose As Long
Friend m_stat_WorkContextNoDefaultClose As Long
internal:
long long m_stat_WorkContextNoDefaultClose
internal:
long long m_stat_WorkContextNoDefaultClose
val mutable internal m_stat_WorkContextNoDefaultClose: int64
val mutable internal m_stat_WorkContextNoDefaultClose: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_WorkContextWorkSemaphoreRelease Field

WaveServer m_stat_WorkContextWorkSemaphoreRelease Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_WorkContextWorkSemaphoreRelease
internal long m_stat_WorkContextWorkSemaphoreRelease
Friend m_stat_WorkContextWorkSemaphoreRelease As Long
Friend m_stat_WorkContextWorkSemaphoreRelease As Long
internal:
long long m_stat_WorkContextWorkSemaphoreRelease
internal:
long long m_stat_WorkContextWorkSemaphoreRelease
val mutable internal m_stat_WorkContextWorkSemaphoreRelease: int64
val mutable internal m_stat_WorkContextWorkSemaphoreRelease: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_stat_WorkContextWrittenResponse Field

WaveServer m_stat_WorkContextWrittenResponse Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long m_stat_WorkContextWrittenResponse
internal long m_stat_WorkContextWrittenResponse
Friend m_stat_WorkContextWrittenResponse As Long
Friend m_stat_WorkContextWrittenResponse As Long
internal:
long long m_stat_WorkContextWrittenResponse
internal:
long long m_stat_WorkContextWrittenResponse
val mutable internal m_stat_WorkContextWrittenResponse: int64
val mutable internal m_stat_WorkContextWrittenResponse: int64

Field Value

Type: Online Int64
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.m_WorkSemaphore Field

WaveServer m_WorkSemaphore Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Semaphore m_WorkSemaphore
internal Semaphore m_WorkSemaphore
Friend m_WorkSemaphore As Semaphore
Friend m_WorkSemaphore As Semaphore
internal:
Semaphore^ m_WorkSemaphore
internal:
Semaphore^ m_WorkSemaphore
val mutable internal m_WorkSemaphore: Semaphore
val mutable internal m_WorkSemaphore: Semaphore

Field Value

Type: Online Semaphore
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.MAX_KERNEL_HTTP_QUEUE_LIMIT Field

WaveServer MAX_KERNEL_HTTP_QUEUE_LIMIT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_KERNEL_HTTP_QUEUE_LIMIT
public const int MAX_KERNEL_HTTP_QUEUE_LIMIT
Public Const MAX_KERNEL_HTTP_QUEUE_LIMIT As Integer
Public Const MAX_KERNEL_HTTP_QUEUE_LIMIT As Integer
public:
literal int MAX_KERNEL_HTTP_QUEUE_LIMIT
public:
literal int MAX_KERNEL_HTTP_QUEUE_LIMIT
static val mutable MAX_KERNEL_HTTP_QUEUE_LIMIT: int
static val mutable MAX_KERNEL_HTTP_QUEUE_LIMIT: int

Field Value

Type: Online Int32
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.MAX_PARALLEL_ACCEPTS Field

WaveServer MAX_PARALLEL_ACCEPTS Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_PARALLEL_ACCEPTS
public const int MAX_PARALLEL_ACCEPTS
Public Const MAX_PARALLEL_ACCEPTS As Integer
Public Const MAX_PARALLEL_ACCEPTS As Integer
public:
literal int MAX_PARALLEL_ACCEPTS
public:
literal int MAX_PARALLEL_ACCEPTS
static val mutable MAX_PARALLEL_ACCEPTS: int
static val mutable MAX_PARALLEL_ACCEPTS: int

Field Value

Type: Online Int32
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.MAX_PARALLEL_WORKS Field

WaveServer MAX_PARALLEL_WORKS Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_PARALLEL_WORKS
public const int MAX_PARALLEL_WORKS
Public Const MAX_PARALLEL_WORKS As Integer
Public Const MAX_PARALLEL_WORKS As Integer
public:
literal int MAX_PARALLEL_WORKS
public:
literal int MAX_PARALLEL_WORKS
static val mutable MAX_PARALLEL_WORKS: int
static val mutable MAX_PARALLEL_WORKS: int

Field Value

Type: Online Int32
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.MIN_KERNEL_HTTP_QUEUE_LIMIT Field

WaveServer MIN_KERNEL_HTTP_QUEUE_LIMIT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MIN_KERNEL_HTTP_QUEUE_LIMIT
public const int MIN_KERNEL_HTTP_QUEUE_LIMIT
Public Const MIN_KERNEL_HTTP_QUEUE_LIMIT As Integer
Public Const MIN_KERNEL_HTTP_QUEUE_LIMIT As Integer
public:
literal int MIN_KERNEL_HTTP_QUEUE_LIMIT
public:
literal int MIN_KERNEL_HTTP_QUEUE_LIMIT
static val mutable MIN_KERNEL_HTTP_QUEUE_LIMIT: int
static val mutable MIN_KERNEL_HTTP_QUEUE_LIMIT: int

Field Value

Type: Online Int32
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.MIN_PARALLEL_ACCEPTS Field

WaveServer MIN_PARALLEL_ACCEPTS Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MIN_PARALLEL_ACCEPTS
public const int MIN_PARALLEL_ACCEPTS
Public Const MIN_PARALLEL_ACCEPTS As Integer
Public Const MIN_PARALLEL_ACCEPTS As Integer
public:
literal int MIN_PARALLEL_ACCEPTS
public:
literal int MIN_PARALLEL_ACCEPTS
static val mutable MIN_PARALLEL_ACCEPTS: int
static val mutable MIN_PARALLEL_ACCEPTS: int

Field Value

Type: Online Int32
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.MIN_PARALLEL_WORKS Field

WaveServer MIN_PARALLEL_WORKS Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MIN_PARALLEL_WORKS
public const int MIN_PARALLEL_WORKS
Public Const MIN_PARALLEL_WORKS As Integer
Public Const MIN_PARALLEL_WORKS As Integer
public:
literal int MIN_PARALLEL_WORKS
public:
literal int MIN_PARALLEL_WORKS
static val mutable MIN_PARALLEL_WORKS: int
static val mutable MIN_PARALLEL_WORKS: int

Field Value

Type: Online Int32
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.s_Servers Field

WaveServer s_Servers Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Registry<WaveServer> s_Servers
public static Registry<WaveServer> s_Servers
Public Shared s_Servers As Registry(Of WaveServer)
Public Shared s_Servers As Registry(Of WaveServer)
public:
static Registry<WaveServer^>^ s_Servers
public:
static Registry<WaveServer^>^ s_Servers
static val mutable s_Servers: Registry<WaveServer>
static val mutable s_Servers: Registry<WaveServer>

Field Value

Type: Registry WaveServer
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer Methods

WaveServer Methods NFX Class Library

The WaveServer type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Protected method | AfterListenerStart | Override to set listener options such as TimeoutManager.MinSendBytesPerSecond after listener.Start()
Protected method | BeforeListenerStart | Override to set listener options such as TimeoutManager.MinSendBytesPerSecond before listener.Start()
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleException | Handles processing exception by calling ErrorFilter.HandleException(work, error). All parameters except ERROR can be null - which indicates error that happened during WorkContext dispose
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Public method | Log | Facilitates server logging
Protected method | MakeContext | Factory method that makes new WorkContext instances. Override to make a WorkContext-derivative
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WaveServer Class
NFX.Wave Namespace


WaveServer.AfterListenerStart Method

WaveServer AfterListenerStart Method NFX Class Library

Override to set listener options such as TimeoutManager.MinSendBytesPerSecond after listener.Start()

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void AfterListenerStart(
    HttpListener listener
)
protected virtual void AfterListenerStart(
    HttpListener listener
)
Protected Overridable Sub AfterListenerStart (
    listener As HttpListener
)
Protected Overridable Sub AfterListenerStart (
    listener As HttpListener
)
protected:
virtual void AfterListenerStart(
    HttpListener^ listener
)
protected:
virtual void AfterListenerStart(
    HttpListener^ listener
)
abstract AfterListenerStart :
        listener : HttpListener -> unit
override AfterListenerStart :
        listener : HttpListener -> unit
abstract AfterListenerStart :
        listener : HttpListener -> unit
override AfterListenerStart :
        listener : HttpListener -> unit

Parameters

listener
Type: Online System.Net HttpListener
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.BeforeListenerStart Method

WaveServer BeforeListenerStart Method NFX Class Library

Override to set listener options such as TimeoutManager.MinSendBytesPerSecond before listener.Start()

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void BeforeListenerStart(
    HttpListener listener
)
protected virtual void BeforeListenerStart(
    HttpListener listener
)
Protected Overridable Sub BeforeListenerStart (
    listener As HttpListener
)
Protected Overridable Sub BeforeListenerStart (
    listener As HttpListener
)
protected:
virtual void BeforeListenerStart(
    HttpListener^ listener
)
protected:
virtual void BeforeListenerStart(
    HttpListener^ listener
)
abstract BeforeListenerStart :
        listener : HttpListener -> unit
override BeforeListenerStart :
        listener : HttpListener -> unit
abstract BeforeListenerStart :
        listener : HttpListener -> unit
override BeforeListenerStart :
        listener : HttpListener -> unit

Parameters

listener
Type: Online System.Net HttpListener
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.DoConfigure Method

WaveServer DoConfigure Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.DoSignalStop Method

WaveServer DoSignalStop Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSignalStop()
protected override void DoSignalStop()
Protected Overrides Sub DoSignalStop
Protected Overrides Sub DoSignalStop
protected:
virtual void DoSignalStop() override
protected:
virtual void DoSignalStop() override
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.DoStart Method

WaveServer DoStart Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.DoWaitForCompleteStop Method

WaveServer DoWaitForCompleteStop Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.HandleException Method

WaveServer HandleException Method NFX Class Library

Handles processing exception by calling ErrorFilter.HandleException(work, error). All parameters except ERROR can be null - which indicates error that happened during WorkContext dispose

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void HandleException(
    WorkContext work,
    WorkFilter filter,
    WorkHandler handler,
    Exception error
)
public virtual void HandleException(
    WorkContext work,
    WorkFilter filter,
    WorkHandler handler,
    Exception error
)
Public Overridable Sub HandleException (
    work As WorkContext,
    filter As WorkFilter,
    handler As WorkHandler,
    error As Exception
)
Public Overridable Sub HandleException (
    work As WorkContext,
    filter As WorkFilter,
    handler As WorkHandler,
    error As Exception
)
public:
virtual void HandleException(
    WorkContext^ work,
    WorkFilter^ filter,
    WorkHandler^ handler,
    Exception^ error
)
public:
virtual void HandleException(
    WorkContext^ work,
    WorkFilter^ filter,
    WorkHandler^ handler,
    Exception^ error
)
abstract HandleException :
        work : WorkContext *
        filter : WorkFilter *
        handler : WorkHandler *
        error : Exception -> unit
override HandleException :
        work : WorkContext *
        filter : WorkFilter *
        handler : WorkHandler *
        error : Exception -> unit
abstract HandleException :
        work : WorkContext *
        filter : WorkFilter *
        handler : WorkHandler *
        error : Exception -> unit
override HandleException :
        work : WorkContext *
        filter : WorkFilter *
        handler : WorkHandler *
        error : Exception -> unit

Parameters

work
Type: NFX.Wave WorkContext
filter
Type: NFX.Wave WorkFilter
handler
Type: NFX.Wave WorkHandler
error
Type: Online System Exception
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.Log Method

WaveServer Log Method NFX Class Library

Facilitates server logging

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Log(
    MessageType type,
    string text,
    string from = null,
    Exception error = null,
    string pars = null,
    Nullable<Guid> related = null
)
public void Log(
    MessageType type,
    string text,
    string from = null,
    Exception error = null,
    string pars = null,
    Nullable<Guid> related = null
)
Public Sub Log (
    type As MessageType,
    text As String,
    Optional from As String = Nothing,
    Optional error As Exception = Nothing,
    Optional pars As String = Nothing,
    Optional related As Nullable(Of Guid) = Nothing
)
Public Sub Log (
    type As MessageType,
    text As String,
    Optional from As String = Nothing,
    Optional error As Exception = Nothing,
    Optional pars As String = Nothing,
    Optional related As Nullable(Of Guid) = Nothing
)
public:
void Log(
    MessageType type,
    String^ text,
    String^ from = nullptr,
    Exception^ error = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> related = nullptr
)
public:
void Log(
    MessageType type,
    String^ text,
    String^ from = nullptr,
    Exception^ error = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> related = nullptr
)
member Log :
        type : MessageType *
        text : string *
        ?from : string *
        ?error : Exception *
        ?pars : string *
        ?related : Nullable<Guid>
(* Defaults:
        let _from = defaultArg from null
        let _error = defaultArg error null
        let _pars = defaultArg pars null
        let _related = defaultArg related null
*)
-> unit
member Log :
        type : MessageType *
        text : string *
        ?from : string *
        ?error : Exception *
        ?pars : string *
        ?related : Nullable<Guid>
(* Defaults:
        let _from = defaultArg from null
        let _error = defaultArg error null
        let _pars = defaultArg pars null
        let _related = defaultArg related null
*)
-> unit

Parameters

type
Type: NFX.Log MessageType
text
Type: Online System String
from (Optional)
Type: Online System String
error (Optional)
Type: Online System Exception
pars (Optional)
Type: Online System String
related (Optional)
Type: Online System Nullable Online Guid
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.MakeContext Method

WaveServer MakeContext Method NFX Class Library

Factory method that makes new WorkContext instances. Override to make a WorkContext-derivative

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual WorkContext MakeContext(
    HttpListenerContext listenerContext
)
protected virtual WorkContext MakeContext(
    HttpListenerContext listenerContext
)
Protected Overridable Function MakeContext (
    listenerContext As HttpListenerContext
) As WorkContext
Protected Overridable Function MakeContext (
    listenerContext As HttpListenerContext
) As WorkContext
protected:
virtual WorkContext^ MakeContext(
    HttpListenerContext^ listenerContext
)
protected:
virtual WorkContext^ MakeContext(
    HttpListenerContext^ listenerContext
)
abstract MakeContext :
        listenerContext : HttpListenerContext -> WorkContext
override MakeContext :
        listenerContext : HttpListenerContext -> WorkContext
abstract MakeContext :
        listenerContext : HttpListenerContext -> WorkContext
override MakeContext :
        listenerContext : HttpListenerContext -> WorkContext

Parameters

listenerContext
Type: Online System.Net HttpListenerContext

Return Value

Type: WorkContext
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer Properties

WaveServer Properties NFX Class Library

The WaveServer type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ClientVarsCookieName | Provides the name of cookie where server keeps client vars
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Gets/sets work dispatcher
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EnvironmentName | Provides the name of environment, i.e. DEV,PROD, TEST i.e. some handlers may depend on environment name to serve DEV vs PROD java script files etc.
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Gate | Gets/sets network gate
Public property | GateCallerRealIpAddressHeader |
Public property | IgnoreClientWriteErrors | When true does not throw exceptions on client channel write
Public property | InstrumentationEnabled | When true, emits instrumentation messages (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | KernelHttpQueueLimit | Establishes HTTP.sys kernel queue limit
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | LogHandleExceptionErrors | When true writes errors that get thrown in server cathc-all HandleException methods
Public property | LogMatches | Returns matches used by the server's default error handler to determine whether exception details should be logged
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | ParallelAccepts | Specifies how many requests can get accepted from kernel queue in parallel
Public property | ParallelWorks | Specifies how many instances of WorkContext(or derivatives) can be processed at the same time
Public property | Prefixes | Returns HttpListener prefixes such as "http://+:8080/"
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
 | Servers | Returns the global registry of all server instances that are active in this process
Public property | ShowDumpMatches | Returns matches used by the server's default error handler to determine whether exception details should be shown
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
WaveServer Class
NFX.Wave Namespace


WaveServer.ClientVarsCookieName Property

WaveServer ClientVarsCookieName Property NFX Class Library

Provides the name of cookie where server keeps client vars

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute]
public string ClientVarsCookieName { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute]
public string ClientVarsCookieName { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute>
Public Property ClientVarsCookieName As String
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute>
Public Property ClientVarsCookieName As String
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute]
property String^ ClientVarsCookieName {
    String^ get ();
    void set (String^ value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute]
property String^ ClientVarsCookieName {
    String^ get ();
    void set (String^ value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
member ClientVarsCookieName : string with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
member ClientVarsCookieName : string with get, set

Property Value

Type: Online String
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.ComponentCommonName Property

WaveServer ComponentCommonName Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ComponentCommonName { get; }
public override string ComponentCommonName { get; }
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get

Property Value

Type: Online String

Implements

IApplicationComponent ComponentCommonName
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.Dispatcher Property

WaveServer Dispatcher Property NFX Class Library

Gets/sets work dispatcher

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkDispatcher Dispatcher { get; set; }
public WorkDispatcher Dispatcher { get; set; }
Public Property Dispatcher As WorkDispatcher
    Get
    Set
Public Property Dispatcher As WorkDispatcher
    Get
    Set
public:
property WorkDispatcher^ Dispatcher {
    WorkDispatcher^ get ();
    void set (WorkDispatcher^ value);
}
public:
property WorkDispatcher^ Dispatcher {
    WorkDispatcher^ get ();
    void set (WorkDispatcher^ value);
}
member Dispatcher : WorkDispatcher with get, set
member Dispatcher : WorkDispatcher with get, set

Property Value

Type: WorkDispatcher
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.EnvironmentName Property

WaveServer EnvironmentName Property NFX Class Library

Provides the name of environment, i.e. DEV,PROD, TEST i.e. some handlers may depend on environment name to serve DEV vs PROD java script files etc.

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string EnvironmentName { get; set; }
[ConfigAttribute]
public string EnvironmentName { get; set; }
<ConfigAttribute>
Public Property EnvironmentName As String
    Get
    Set
<ConfigAttribute>
Public Property EnvironmentName As String
    Get
    Set
public:
[ConfigAttribute]
property String^ EnvironmentName {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ EnvironmentName {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member EnvironmentName : string with get, set
[<ConfigAttribute>]
member EnvironmentName : string with get, set

Property Value

Type: Online String
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.Gate Property

WaveServer Gate Property NFX Class Library

Gets/sets network gate

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public INetGate Gate { get; set; }
public INetGate Gate { get; set; }
Public Property Gate As INetGate
    Get
    Set
Public Property Gate As INetGate
    Get
    Set
public:
property INetGate^ Gate {
    INetGate^ get ();
    void set (INetGate^ value);
}
public:
property INetGate^ Gate {
    INetGate^ get ();
    void set (INetGate^ value);
}
member Gate : INetGate with get, set
member Gate : INetGate with get, set

Property Value

Type: INetGate
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.GateCallerRealIpAddressHeader Property

WaveServer GateCallerRealIpAddressHeader Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string GateCallerRealIpAddressHeader { get; set; }
[ConfigAttribute]
public string GateCallerRealIpAddressHeader { get; set; }
<ConfigAttribute>
Public Property GateCallerRealIpAddressHeader As String
    Get
    Set
<ConfigAttribute>
Public Property GateCallerRealIpAddressHeader As String
    Get
    Set
public:
[ConfigAttribute]
property String^ GateCallerRealIpAddressHeader {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ GateCallerRealIpAddressHeader {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member GateCallerRealIpAddressHeader : string with get, set
[<ConfigAttribute>]
member GateCallerRealIpAddressHeader : string with get, set

Property Value

Type: Online String
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.IgnoreClientWriteErrors Property

WaveServer IgnoreClientWriteErrors Property NFX Class Library

[This is preliminary documentation and is subject to change.]

When true does not throw exceptions on client channel write

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = true)]
public bool IgnoreClientWriteErrors { get; set; }
[ConfigAttribute(Default = true)]
public bool IgnoreClientWriteErrors { get; set; }
<ConfigAttribute(Default := true)>
Public Property IgnoreClientWriteErrors As Boolean
    Get
    Set
<ConfigAttribute(Default := true)>
Public Property IgnoreClientWriteErrors As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = true)]
property bool IgnoreClientWriteErrors {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(Default = true)]
property bool IgnoreClientWriteErrors {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute(Default = true)>]
member IgnoreClientWriteErrors : bool with get, set
[<ConfigAttribute(Default = true)>]
member IgnoreClientWriteErrors : bool with get, set

Property Value

Type: Online Boolean
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.InstrumentationEnabled Property

WaveServer InstrumentationEnabled Property NFX Class Library

When true, emits instrumentation messages

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.KernelHttpQueueLimit Property

WaveServer KernelHttpQueueLimit Property NFX Class Library

Establishes HTTP.sys kernel queue limit

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int KernelHttpQueueLimit { get; set; }
[ConfigAttribute]
public int KernelHttpQueueLimit { get; set; }
<ConfigAttribute>
Public Property KernelHttpQueueLimit As Integer
    Get
    Set
<ConfigAttribute>
Public Property KernelHttpQueueLimit As Integer
    Get
    Set
public:
[ConfigAttribute]
property int KernelHttpQueueLimit {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int KernelHttpQueueLimit {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member KernelHttpQueueLimit : int with get, set
[<ConfigAttribute>]
member KernelHttpQueueLimit : int with get, set

Property Value

Type: Online Int32
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.LogHandleExceptionErrors Property

WaveServer LogHandleExceptionErrors Property NFX Class Library

[This is preliminary documentation and is subject to change.]

When true writes errors that get thrown in server cathc-all HandleException methods

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public bool LogHandleExceptionErrors { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public bool LogHandleExceptionErrors { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property LogHandleExceptionErrors As Boolean
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property LogHandleExceptionErrors As Boolean
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool LogHandleExceptionErrors {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool LogHandleExceptionErrors {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member LogHandleExceptionErrors : bool with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member LogHandleExceptionErrors : bool with get, set

Property Value

Type: Online Boolean
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.LogMatches Property

WaveServer LogMatches Property NFX Class Library

Returns matches used by the server's default error handler to determine whether exception details should be logged

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<WorkMatch> LogMatches { get; }
public OrderedRegistry<WorkMatch> LogMatches { get; }
Public ReadOnly Property LogMatches As OrderedRegistry(Of WorkMatch)
    Get
Public ReadOnly Property LogMatches As OrderedRegistry(Of WorkMatch)
    Get
public:
property OrderedRegistry<WorkMatch^>^ LogMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
public:
property OrderedRegistry<WorkMatch^>^ LogMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
member LogMatches : OrderedRegistry<WorkMatch> with get
member LogMatches : OrderedRegistry<WorkMatch> with get

Property Value

Type: OrderedRegistry WorkMatch
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.ParallelAccepts Property

WaveServer ParallelAccepts Property NFX Class Library

Specifies how many requests can get accepted from kernel queue in parallel

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = 64)]
public int ParallelAccepts { get; set; }
[ConfigAttribute(Default = 64)]
public int ParallelAccepts { get; set; }
<ConfigAttribute(Default := 64)>
Public Property ParallelAccepts As Integer
    Get
    Set
<ConfigAttribute(Default := 64)>
Public Property ParallelAccepts As Integer
    Get
    Set
public:
[ConfigAttribute(Default = 64)]
property int ParallelAccepts {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(Default = 64)]
property int ParallelAccepts {
    int get ();
    void set (int value);
}
[<ConfigAttribute(Default = 64)>]
member ParallelAccepts : int with get, set
[<ConfigAttribute(Default = 64)>]
member ParallelAccepts : int with get, set

Property Value

Type: Online Int32
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.ParallelWorks Property

WaveServer ParallelWorks Property NFX Class Library

Specifies how many instances of WorkContext(or derivatives) can be processed at the same time

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = 256)]
public int ParallelWorks { get; set; }
[ConfigAttribute(Default = 256)]
public int ParallelWorks { get; set; }
<ConfigAttribute(Default := 256)>
Public Property ParallelWorks As Integer
    Get
    Set
<ConfigAttribute(Default := 256)>
Public Property ParallelWorks As Integer
    Get
    Set
public:
[ConfigAttribute(Default = 256)]
property int ParallelWorks {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(Default = 256)]
property int ParallelWorks {
    int get ();
    void set (int value);
}
[<ConfigAttribute(Default = 256)>]
member ParallelWorks : int with get, set
[<ConfigAttribute(Default = 256)>]
member ParallelWorks : int with get, set

Property Value

Type: Online Int32
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.Prefixes Property

WaveServer Prefixes Property NFX Class Library

Returns HttpListener prefixes such as "http://+:8080/"

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<string> Prefixes { get; }
public IList<string> Prefixes { get; }
Public ReadOnly Property Prefixes As IList(Of String)
    Get
Public ReadOnly Property Prefixes As IList(Of String)
    Get
public:
property IList<String^>^ Prefixes {
    IList<String^>^ get ();
}
public:
property IList<String^>^ Prefixes {
    IList<String^>^ get ();
}
member Prefixes : IList<string> with get
member Prefixes : IList<string> with get

Property Value

Type: Online IList Online String
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.Servers Property

WaveServer Servers Property NFX Class Library

Returns the global registry of all server instances that are active in this process

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IRegistry<WaveServer> Servers { get; }
public static IRegistry<WaveServer> Servers { get; }
Public Shared ReadOnly Property Servers As IRegistry(Of WaveServer)
    Get
Public Shared ReadOnly Property Servers As IRegistry(Of WaveServer)
    Get
public:
static property IRegistry<WaveServer^>^ Servers {
    IRegistry<WaveServer^>^ get ();
}
public:
static property IRegistry<WaveServer^>^ Servers {
    IRegistry<WaveServer^>^ get ();
}
static member Servers : IRegistry<WaveServer> with get
static member Servers : IRegistry<WaveServer> with get

Property Value

Type: IRegistry WaveServer
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveServer.ShowDumpMatches Property

WaveServer ShowDumpMatches Property NFX Class Library

Returns matches used by the server's default error handler to determine whether exception details should be shown

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<WorkMatch> ShowDumpMatches { get; }
public OrderedRegistry<WorkMatch> ShowDumpMatches { get; }
Public ReadOnly Property ShowDumpMatches As OrderedRegistry(Of WorkMatch)
    Get
Public ReadOnly Property ShowDumpMatches As OrderedRegistry(Of WorkMatch)
    Get
public:
property OrderedRegistry<WorkMatch^>^ ShowDumpMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
public:
property OrderedRegistry<WorkMatch^>^ ShowDumpMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
member ShowDumpMatches : OrderedRegistry<WorkMatch> with get
member ShowDumpMatches : OrderedRegistry<WorkMatch> with get

Property Value

Type: OrderedRegistry WorkMatch
See Also
WaveServer Class
WaveServer Members
NFX.Wave Namespace


WaveSession Class

WaveSession Class NFX Class Library

Represents a session in a WAVE server application
Inheritance Hierarchy
Online System Object
NFX.ApplicationModel BaseSession
NFX.Wave WaveSession

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WaveSession : BaseSession
[SerializableAttribute]
public class WaveSession : BaseSession
<SerializableAttribute>
Public Class WaveSession
    Inherits BaseSession
<SerializableAttribute>
Public Class WaveSession
    Inherits BaseSession
[SerializableAttribute]
public ref class WaveSession : public BaseSession
[SerializableAttribute]
public ref class WaveSession : public BaseSession
[<SerializableAttribute>]
type WaveSession =
    class
        inherit BaseSession
    end
[<SerializableAttribute>]
type WaveSession =
    class
        inherit BaseSession
    end
See Also
WaveSession Members
NFX.Wave Namespace


WaveSession Members

WaveSession Members NFX Class Library

The WaveSession type exposes the following members.
Constructors
 | Name | Description
Protected method | WaveSession | Initializes a new instance of the WaveSession class
Public method | WaveSession(Guid) | Initializes a new instance of the WaveSession class
Back to Top
Methods
 | Name | Description
Public method | Acquire | (Inherited from BaseSession.)
Public method | End | Ends session (Inherited from BaseSession.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasJustLoggedIn | Called from business code when user supplies login credentals and/or performs another action that can be qualified as a reliable user identity proof (Inherited from BaseSession.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegenerateID | Generates new GUID and stores it in ID storing old ID value in OldID property which is not serializable. The implementations may elect to re-stow the existing session under the new ID. This method is usefull for security, i.e. when user logs-in we may want to re-generate ID (Inherited from BaseSession.)
Public method | Release | (Inherited from BaseSession.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | GeoEntity | Stores user Geographical/Location information
Protected field | m_IsEnded | (Inherited from BaseSession.)
Protected field | m_IsJustLoggedIn | (Inherited from BaseSession.)
Protected field | m_IsNew | (Inherited from BaseSession.)
Back to Top
Properties
 | Name | Description
Public property | CSRFToken | Unique token assigned at session start used for checking of form posts. This is for Cross Site Request Forgery protection.
Public property | ID | Returns Session ID (Inherited from BaseSession.)
Public property | IDSecret | Returns Session ID secret - the ulong that identifies this session. This property is needed for cross-check upon GUID id lookup, so that Session ID GUID can not be forged by the client - a form of a "password" (Inherited from BaseSession.)
Public property | IsEnded | Indicates whether this session was ended and will be destroyed after current request processing cycle (Inherited from BaseSession.)
Public property | IsJustLoggedIn | Indicates that user login happened in current request processing cycle. This flag is useful for long term token assignment on release (Inherited from BaseSession.)
Public property | IsNew | Indicates that session object was just created with current request processing cycle (Inherited from BaseSession.)
Public property | Item | Shortcut to .Items. Getter return null instead of throwing if key is not found (Inherited from BaseSession.)
Public property | Items | Provides a thread-safe dictionary of items (Inherited from BaseSession.)
Public property | LanguageISOCode | Returns user language preference or null (Inherited from BaseSession.)
Public property | LastLoginType | Returns the last login type (Inherited from BaseSession.)
Public property | LastLoginUTC | Returns the UTC DateTime of the last login/when HasJustLoggedIn() was called for the last time within the lifetime of this session object or NULL (Inherited from BaseSession.)
Public property | OldID | When this parameter is not null then RegenerateID() was called and session provider may need to re-stow session object under a new ID (Inherited from BaseSession.)
Public property | User | Returns session user (Inherited from BaseSession.)
Back to Top
See Also
WaveSession Class
NFX.Wave Namespace


WaveSession Constructor

WaveSession Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | WaveSession | Initializes a new instance of the WaveSession class
Public method | WaveSession(Guid) | Initializes a new instance of the WaveSession class
Back to Top
See Also
WaveSession Class
WaveSession Members
NFX.Wave Namespace


WaveSession Constructor

WaveSession Constructor NFX Class Library

Initializes a new instance of the WaveSession class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected WaveSession()
protected WaveSession()
Protected Sub New
Protected Sub New
protected:
WaveSession()
protected:
WaveSession()
new : unit -> WaveSession
new : unit -> WaveSession
See Also
WaveSession Class
WaveSession Members
WaveSession Overload
NFX.Wave Namespace


WaveSession Constructor (Guid)

WaveSession Constructor (Guid) NFX Class Library

Initializes a new instance of the WaveSession class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveSession(
    Guid id
)
public WaveSession(
    Guid id
)
Public Sub New (
    id As Guid
)
Public Sub New (
    id As Guid
)
public:
WaveSession(
    Guid id
)
public:
WaveSession(
    Guid id
)
new :
        id : Guid -> WaveSession
new :
        id : Guid -> WaveSession

Parameters

id
Type: Online System Guid
See Also
WaveSession Class
WaveSession Members
WaveSession Overload
NFX.Wave Namespace


WaveSession Fields

WaveSession Fields NFX Class Library

The WaveSession type exposes the following members.
Fields
 | Name | Description
Public field | GeoEntity | Stores user Geographical/Location information
Protected field | m_IsEnded | (Inherited from BaseSession.)
Protected field | m_IsJustLoggedIn | (Inherited from BaseSession.)
Protected field | m_IsNew | (Inherited from BaseSession.)
Back to Top
See Also
WaveSession Class
NFX.Wave Namespace


WaveSession.GeoEntity Field

WaveSession GeoEntity Field NFX Class Library

Stores user Geographical/Location information

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
public GeoEntity GeoEntity
[NonSerializedAttribute]
public GeoEntity GeoEntity
<NonSerializedAttribute>
Public GeoEntity As GeoEntity
<NonSerializedAttribute>
Public GeoEntity As GeoEntity
public:
[NonSerializedAttribute]
GeoEntity^ GeoEntity
public:
[NonSerializedAttribute]
GeoEntity^ GeoEntity
[<NonSerializedAttribute>]
val mutable GeoEntity: GeoEntity
[<NonSerializedAttribute>]
val mutable GeoEntity: GeoEntity

Field Value

Type: GeoEntity
See Also
WaveSession Class
WaveSession Members
NFX.Wave Namespace


WaveSession Methods

WaveSession Methods NFX Class Library

The WaveSession type exposes the following members.
Methods
 | Name | Description
Public method | Acquire | (Inherited from BaseSession.)
Public method | End | Ends session (Inherited from BaseSession.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasJustLoggedIn | Called from business code when user supplies login credentals and/or performs another action that can be qualified as a reliable user identity proof (Inherited from BaseSession.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegenerateID | Generates new GUID and stores it in ID storing old ID value in OldID property which is not serializable. The implementations may elect to re-stow the existing session under the new ID. This method is usefull for security, i.e. when user logs-in we may want to re-generate ID (Inherited from BaseSession.)
Public method | Release | (Inherited from BaseSession.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WaveSession Class
NFX.Wave Namespace


WaveSession Properties

WaveSession Properties NFX Class Library

The WaveSession type exposes the following members.
Properties
 | Name | Description
Public property | CSRFToken | Unique token assigned at session start used for checking of form posts. This is for Cross Site Request Forgery protection.
Public property | ID | Returns Session ID (Inherited from BaseSession.)
Public property | IDSecret | Returns Session ID secret - the ulong that identifies this session. This property is needed for cross-check upon GUID id lookup, so that Session ID GUID can not be forged by the client - a form of a "password" (Inherited from BaseSession.)
Public property | IsEnded | Indicates whether this session was ended and will be destroyed after current request processing cycle (Inherited from BaseSession.)
Public property | IsJustLoggedIn | Indicates that user login happened in current request processing cycle. This flag is useful for long term token assignment on release (Inherited from BaseSession.)
Public property | IsNew | Indicates that session object was just created with current request processing cycle (Inherited from BaseSession.)
Public property | Item | Shortcut to .Items. Getter return null instead of throwing if key is not found (Inherited from BaseSession.)
Public property | Items | Provides a thread-safe dictionary of items (Inherited from BaseSession.)
Public property | LanguageISOCode | Returns user language preference or null (Inherited from BaseSession.)
Public property | LastLoginType | Returns the last login type (Inherited from BaseSession.)
Public property | LastLoginUTC | Returns the UTC DateTime of the last login/when HasJustLoggedIn() was called for the last time within the lifetime of this session object or NULL (Inherited from BaseSession.)
Public property | OldID | When this parameter is not null then RegenerateID() was called and session provider may need to re-stow session object under a new ID (Inherited from BaseSession.)
Public property | User | Returns session user (Inherited from BaseSession.)
Back to Top
See Also
WaveSession Class
NFX.Wave Namespace


WaveSession.CSRFToken Property

WaveSession CSRFToken Property NFX Class Library

Unique token assigned at session start used for checking of form posts. This is for Cross Site Request Forgery protection.

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CSRFToken { get; }
public string CSRFToken { get; }
Public ReadOnly Property CSRFToken As String
    Get
Public ReadOnly Property CSRFToken As String
    Get
public:
property String^ CSRFToken {
    String^ get ();
}
public:
property String^ CSRFToken {
    String^ get ();
}
member CSRFToken : string with get
member CSRFToken : string with get

Property Value

Type: Online String
See Also
WaveSession Class
WaveSession Members
NFX.Wave Namespace


WaveTemplateRenderingException Class

WaveTemplateRenderingException Class NFX Class Library

Wraps WAVE template rendering execptions
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Wave WaveException
NFX.Wave WaveTemplateRenderingException

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WaveTemplateRenderingException : WaveException
[SerializableAttribute]
public class WaveTemplateRenderingException : WaveException
<SerializableAttribute>
Public Class WaveTemplateRenderingException
    Inherits WaveException
<SerializableAttribute>
Public Class WaveTemplateRenderingException
    Inherits WaveException
[SerializableAttribute]
public ref class WaveTemplateRenderingException : public WaveException
[SerializableAttribute]
public ref class WaveTemplateRenderingException : public WaveException
[<SerializableAttribute>]
type WaveTemplateRenderingException =
    class
        inherit WaveException
    end
[<SerializableAttribute>]
type WaveTemplateRenderingException =
    class
        inherit WaveException
    end
See Also
WaveTemplateRenderingException Members
NFX.Wave Namespace


WaveTemplateRenderingException Members

WaveTemplateRenderingException Members NFX Class Library

The WaveTemplateRenderingException type exposes the following members.
Constructors
 | Name | Description
Protected method | WaveTemplateRenderingException(SerializationInfo, StreamingContext) | Initializes a new instance of the WaveTemplateRenderingException class
Public method | WaveTemplateRenderingException(String, Exception) | Initializes a new instance of the WaveTemplateRenderingException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
WaveTemplateRenderingException Class
NFX.Wave Namespace


WaveTemplateRenderingException Constructor

WaveTemplateRenderingException Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | WaveTemplateRenderingException(SerializationInfo, StreamingContext) | Initializes a new instance of the WaveTemplateRenderingException class
Public method | WaveTemplateRenderingException(String, Exception) | Initializes a new instance of the WaveTemplateRenderingException class
Back to Top
See Also
WaveTemplateRenderingException Class
WaveTemplateRenderingException Members
NFX.Wave Namespace


WaveTemplateRenderingException Constructor (SerializationInfo, StreamingContext)

WaveTemplateRenderingException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WaveTemplateRenderingException class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected WaveTemplateRenderingException(
    SerializationInfo info,
    StreamingContext context
)
protected WaveTemplateRenderingException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
WaveTemplateRenderingException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
WaveTemplateRenderingException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> WaveTemplateRenderingException
new :
        info : SerializationInfo *
        context : StreamingContext -> WaveTemplateRenderingException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
WaveTemplateRenderingException Class
WaveTemplateRenderingException Members
WaveTemplateRenderingException Overload
NFX.Wave Namespace


WaveTemplateRenderingException Constructor (String, Exception)

WaveTemplateRenderingException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WaveTemplateRenderingException class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveTemplateRenderingException(
    string message,
    Exception inner
)
public WaveTemplateRenderingException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
WaveTemplateRenderingException(
    String^ message,
    Exception^ inner
)
public:
WaveTemplateRenderingException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> WaveTemplateRenderingException
new :
        message : string *
        inner : Exception -> WaveTemplateRenderingException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
WaveTemplateRenderingException Class
WaveTemplateRenderingException Members
WaveTemplateRenderingException Overload
NFX.Wave Namespace


WaveTemplateRenderingException Methods

WaveTemplateRenderingException Methods NFX Class Library

The WaveTemplateRenderingException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
WaveTemplateRenderingException Class
NFX.Wave Namespace


WaveTemplateRenderingException Properties

WaveTemplateRenderingException Properties NFX Class Library

The WaveTemplateRenderingException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
WaveTemplateRenderingException Class
NFX.Wave Namespace


WaveTemplateRenderingException Events

WaveTemplateRenderingException Events NFX Class Library

The WaveTemplateRenderingException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
WaveTemplateRenderingException Class
NFX.Wave Namespace


WorkContext Class

WorkContext Class NFX Class Library

Represents a context for request/response server processing in WAVE framework
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Wave WorkContext

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class WorkContext : DisposableObject
public class WorkContext : DisposableObject
Public Class WorkContext
    Inherits DisposableObject
Public Class WorkContext
    Inherits DisposableObject
public ref class WorkContext : public DisposableObject
public ref class WorkContext : public DisposableObject
type WorkContext =
    class
        inherit DisposableObject
    end
type WorkContext =
    class
        inherit DisposableObject
    end
See Also
WorkContext Members
NFX.Wave Namespace


WorkContext Members

WorkContext Members NFX Class Library

The WorkContext type exposes the following members.
Constructors
 | Name | Description
Protected method | WorkContext | Initializes a new instance of the WorkContext class
Back to Top
Methods
 | Name | Description
Public method | ___InternalInjectPortal | DEVELOPERS do not use! A hack method needed in some VERY RARE cases, like serving an error page form the filter which is out of portal scope.
Protected method | ___SetWorkMatch | Internal method. Developers do not call
Protected method | Destructor | Warning: if overridden, must call base otherwise semaphore will not get released (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | GetWholeRequestAsJSONDataMap | Converts request body and MatchedVars into a single JSONDataMap. Users should call WholeRequestAsJSONDataMap.get() as it caches the result
Public method | HasAnyVarsMatchingFieldNames | Returns true if the whole request (body or matched vars) contains any names matching any field names of the specified row
Public method | Log | Facilitates context-aware logging
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NeedsSession | Ensures that session is injected if session filter is present in processing chain. If session is already available (Session!=null) then does nothing, otherwise fills Session poroperty with either NEW session (if onlyExisting=false(default)) if user supplied no session token, OR gets session from session store as defined by the first SessionFilter in the chain
Protected method | ParseRequestBodyAsJSONDataMap | This method is called only once as it touches the input streams
Public method | ReleaseWorkSemaphore | Releases work semaphore that throttles the processing of WorkContext instances. The WorkContext is released automatically in destructor, however there are cases when the semaphore release may be needed sooner, i.e. in a HTTP streaming application where work context instances are kept open indefinitely it may not be desirable to consider long-living work context instances as a throtteling factor. Returns true if semaphore was released, false if it was not released during this call as it was already released before
Public method | SetAuthenticated | Invoked by applications to signify the presence of authentication
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_EffectiveCallerIPEndPoint |
Protected field | m_Handled |
Protected field | m_Handler |
Protected field | m_Portal |
Protected field | m_PortalFilter |
Protected field | m_PortalMatch |
Protected field | m_PortalMatchedVars |
Protected field | m_PortalTheme |
Protected field | m_Session |
Protected field | m_SessionFilter |
Back to Top
Properties
 | Name | Description
Public property | Aborted | Indicates whether the work context is logically finished and its nested processing (i.e. through Filters/Handlers) should stop. For example, when some filter detects a special condition (judging by the request) and generates the response and needs to abort the work request so it does no get filtered/processed anymore, it can set this property to true. This mechanism performs much better than throwing exceptions
Public property | About | Generates short context description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EffectiveCallerIPEndPoint | Returns the effective caller endpoint- that is, if the real caller filter is set it will inject the real IP as seen before any proxy devices. By default this property returns the Request.RemoteEndPoint
Public property | GeoEntity | Gets sets geo location information as detected by GeoLookupHandler. If Session context is injected then get/set passes through into session object
Public property | Handled | Returns true when the work has been executed by the WorkHandler instance
Public property | Handler | Returns the work handler instance that was matched to perform work on this context or null if the match has not been made yet
Public property | ID | Uniquely identifies the request
Public property | IsAuthenticated | Returns true to indicate that this context is/was authenticated. Used to not redirect users to login page on authorization exception
Public property | IsDELETE | Indicates that request method id DELETE
Public property | IsGET | Indicates that request method id GET
Public property | IsPATCH | Indicates that request method id PATCH
Public property | IsPOST | Indicates that request method id POST
Public property | IsPUT | Indicates that request method id PUT
Public property | Items | Provides a thread-safe dictionary of items. The underlying collection is lazily allocated
Public property | LastError | Captures last error
Public property | Match | Returns the work match instances that was made for this requested work or null if nothing was matched yet
Public property | Matched | Returns dynamic object that contains variables that have been extracted by WorkMatch when dispatcher assigned request to WorkHandler. If variables have not been assigned yet returns empty object
Public property | MatchedVars | Returns variables that have been extracted by WorkMatch when dispatcher assigned request to WorkHandler. If variables have not been assigned yet returns empty object
Public property | NoDefaultAutoClose | Indicates whether the default dispatcher should close the WorkContext upon completion of async processing. This property may ONLY be set to TRUE IF Response.Buffered = false (chunked transfer) and Response has already been written to. When this property is set to true the WorkDispatcher will not auto dispose this WorkContext instance. This may be needed for a server that streams chat messages and some other thread manages the lifetime of this WorkContext. Keep in mind that alternative implementations of WorkDispatcher (derived classes that implement alternative threading/lifecycle) may disregard this flag altogether
Public property | Portal | Returns portal object for this request or null if no portal was injected
Public property | PortalFilter | Returns the first portal filter which was injected in the processing line. It is the filter that manages the portals for this context
Public property | PortalMatch | Returns matched that was made by portal filter or null
Public property | PortalMatchedVars | Returns variables that have been extracted by WorkMatch when PortalFilter assigned portal. Returns null if no portal was matched
Public property | PortalTheme | Gets/sets portal theme. This may be null as this is just a holder variable
Public property | Request | Returns HttpListenerRequest object for this context
Public property | RequestBodyAsJSONDataMap | Fetches request body: multipart content, url encoded content, or JSON body into one JSONDataMap bag, or null if there is no body. The property does caching
Public property | RequestedJSON | Returns true if client indicated in response that "application/json" is accepted
Public property | Response | Returns Response object for this context
Public property | Server | Returns the server this context is under
Public property | Session | Returns session that this context is linked with or null
Public property | SessionFilter | Returns the first session filter which was injected in the processing line. It is the filter that manages the session state for this context
Public property | SupportsSession | Returns true when the context was configured to support SessionFilter so Session can be injected
Public property | WholeRequestAsJSONDataMap | Fetches matched vars, multipart content, url encoded content, or JSON body into one JSONDataMap bag. The property does caching
Public property | WorkSemaphoreReleased | Returns true to indicate that work semaphore has been already released. It is not necessary to use this property or ReleaseWorkSemaphore() method as the framework does it automatically in 99% cases. ReleaseWorkSemaphore() may need to be called from special places like HTTP streaming servers that need to keep WorkContext instances open for a long time
Back to Top
See Also
WorkContext Class
NFX.Wave Namespace


WorkContext Constructor

WorkContext Constructor NFX Class Library

Initializes a new instance of the WorkContext class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WorkContext(
    WaveServer server,
    HttpListenerContext listenerContext
)
internal WorkContext(
    WaveServer server,
    HttpListenerContext listenerContext
)
Friend Sub New (
    server As WaveServer,
    listenerContext As HttpListenerContext
)
Friend Sub New (
    server As WaveServer,
    listenerContext As HttpListenerContext
)
internal:
WorkContext(
    WaveServer^ server,
    HttpListenerContext^ listenerContext
)
internal:
WorkContext(
    WaveServer^ server,
    HttpListenerContext^ listenerContext
)
new :
        server : WaveServer *
        listenerContext : HttpListenerContext -> WorkContext
new :
        server : WaveServer *
        listenerContext : HttpListenerContext -> WorkContext

Parameters

server
Type: NFX.Wave WaveServer
listenerContext
Type: Online System.Net HttpListenerContext
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext Fields

WorkContext Fields NFX Class Library

The WorkContext type exposes the following members.
Fields
 | Name | Description
Protected field | m_EffectiveCallerIPEndPoint |
Protected field | m_Handled |
Protected field | m_Handler |
Protected field | m_Portal |
Protected field | m_PortalFilter |
Protected field | m_PortalMatch |
Protected field | m_PortalMatchedVars |
Protected field | m_PortalTheme |
Protected field | m_Session |
Protected field | m_SessionFilter |
Back to Top
See Also
WorkContext Class
NFX.Wave Namespace


WorkContext.m_EffectiveCallerIPEndPoint Field

WorkContext m_EffectiveCallerIPEndPoint Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal IPEndPoint m_EffectiveCallerIPEndPoint
internal IPEndPoint m_EffectiveCallerIPEndPoint
Friend m_EffectiveCallerIPEndPoint As IPEndPoint
Friend m_EffectiveCallerIPEndPoint As IPEndPoint
internal:
IPEndPoint^ m_EffectiveCallerIPEndPoint
internal:
IPEndPoint^ m_EffectiveCallerIPEndPoint
val mutable internal m_EffectiveCallerIPEndPoint: IPEndPoint
val mutable internal m_EffectiveCallerIPEndPoint: IPEndPoint

Field Value

Type: Online IPEndPoint
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.m_Handled Field

WorkContext m_Handled Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal bool m_Handled
internal bool m_Handled
Friend m_Handled As Boolean
Friend m_Handled As Boolean
internal:
bool m_Handled
internal:
bool m_Handled
val mutable internal m_Handled: bool
val mutable internal m_Handled: bool

Field Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.m_Handler Field

WorkContext m_Handler Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WorkHandler m_Handler
internal WorkHandler m_Handler
Friend m_Handler As WorkHandler
Friend m_Handler As WorkHandler
internal:
WorkHandler^ m_Handler
internal:
WorkHandler^ m_Handler
val mutable internal m_Handler: WorkHandler
val mutable internal m_Handler: WorkHandler

Field Value

Type: WorkHandler
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.m_Portal Field

WorkContext m_Portal Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Portal m_Portal
internal Portal m_Portal
Friend m_Portal As Portal
Friend m_Portal As Portal
internal:
Portal^ m_Portal
internal:
Portal^ m_Portal
val mutable internal m_Portal: Portal
val mutable internal m_Portal: Portal

Field Value

Type: Portal
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.m_PortalFilter Field

WorkContext m_PortalFilter Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PortalFilter m_PortalFilter
internal PortalFilter m_PortalFilter
Friend m_PortalFilter As PortalFilter
Friend m_PortalFilter As PortalFilter
internal:
PortalFilter^ m_PortalFilter
internal:
PortalFilter^ m_PortalFilter
val mutable internal m_PortalFilter: PortalFilter
val mutable internal m_PortalFilter: PortalFilter

Field Value

Type: PortalFilter
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.m_PortalMatch Field

WorkContext m_PortalMatch Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WorkMatch m_PortalMatch
internal WorkMatch m_PortalMatch
Friend m_PortalMatch As WorkMatch
Friend m_PortalMatch As WorkMatch
internal:
WorkMatch^ m_PortalMatch
internal:
WorkMatch^ m_PortalMatch
val mutable internal m_PortalMatch: WorkMatch
val mutable internal m_PortalMatch: WorkMatch

Field Value

Type: WorkMatch
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.m_PortalMatchedVars Field

WorkContext m_PortalMatchedVars Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal JSONDataMap m_PortalMatchedVars
internal JSONDataMap m_PortalMatchedVars
Friend m_PortalMatchedVars As JSONDataMap
Friend m_PortalMatchedVars As JSONDataMap
internal:
JSONDataMap^ m_PortalMatchedVars
internal:
JSONDataMap^ m_PortalMatchedVars
val mutable internal m_PortalMatchedVars: JSONDataMap
val mutable internal m_PortalMatchedVars: JSONDataMap

Field Value

Type: JSONDataMap
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.m_PortalTheme Field

WorkContext m_PortalTheme Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Theme m_PortalTheme
internal Theme m_PortalTheme
Friend m_PortalTheme As Theme
Friend m_PortalTheme As Theme
internal:
Theme^ m_PortalTheme
internal:
Theme^ m_PortalTheme
val mutable internal m_PortalTheme: Theme
val mutable internal m_PortalTheme: Theme

Field Value

Type: Theme
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.m_Session Field

WorkContext m_Session Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WaveSession m_Session
internal WaveSession m_Session
Friend m_Session As WaveSession
Friend m_Session As WaveSession
internal:
WaveSession^ m_Session
internal:
WaveSession^ m_Session
val mutable internal m_Session: WaveSession
val mutable internal m_Session: WaveSession

Field Value

Type: WaveSession
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.m_SessionFilter Field

WorkContext m_SessionFilter Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal SessionFilter m_SessionFilter
internal SessionFilter m_SessionFilter
Friend m_SessionFilter As SessionFilter
Friend m_SessionFilter As SessionFilter
internal:
SessionFilter^ m_SessionFilter
internal:
SessionFilter^ m_SessionFilter
val mutable internal m_SessionFilter: SessionFilter
val mutable internal m_SessionFilter: SessionFilter

Field Value

Type: SessionFilter
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext Methods

WorkContext Methods NFX Class Library

The WorkContext type exposes the following members.
Methods
 | Name | Description
Public method | ___InternalInjectPortal | DEVELOPERS do not use! A hack method needed in some VERY RARE cases, like serving an error page form the filter which is out of portal scope.
Protected method | ___SetWorkMatch | Internal method. Developers do not call
Protected method | Destructor | Warning: if overridden, must call base otherwise semaphore will not get released (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | GetWholeRequestAsJSONDataMap | Converts request body and MatchedVars into a single JSONDataMap. Users should call WholeRequestAsJSONDataMap.get() as it caches the result
Public method | HasAnyVarsMatchingFieldNames | Returns true if the whole request (body or matched vars) contains any names matching any field names of the specified row
Public method | Log | Facilitates context-aware logging
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NeedsSession | Ensures that session is injected if session filter is present in processing chain. If session is already available (Session!=null) then does nothing, otherwise fills Session poroperty with either NEW session (if onlyExisting=false(default)) if user supplied no session token, OR gets session from session store as defined by the first SessionFilter in the chain
Protected method | ParseRequestBodyAsJSONDataMap | This method is called only once as it touches the input streams
Public method | ReleaseWorkSemaphore | Releases work semaphore that throttles the processing of WorkContext instances. The WorkContext is released automatically in destructor, however there are cases when the semaphore release may be needed sooner, i.e. in a HTTP streaming application where work context instances are kept open indefinitely it may not be desirable to consider long-living work context instances as a throtteling factor. Returns true if semaphore was released, false if it was not released during this call as it was already released before
Public method | SetAuthenticated | Invoked by applications to signify the presence of authentication
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkContext Class
NFX.Wave Namespace


WorkContext.___InternalInjectPortal Method

WorkContext ___InternalInjectPortal Method NFX Class Library

DEVELOPERS do not use! A hack method needed in some VERY RARE cases, like serving an error page form the filter which is out of portal scope.

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ___InternalInjectPortal(
    Portal portal = null,
    Theme theme = null,
    WorkMatch match = null,
    JSONDataMap matchedVars = null
)
public void ___InternalInjectPortal(
    Portal portal = null,
    Theme theme = null,
    WorkMatch match = null,
    JSONDataMap matchedVars = null
)
Public Sub ___InternalInjectPortal (
    Optional portal As Portal = Nothing,
    Optional theme As Theme = Nothing,
    Optional match As WorkMatch = Nothing,
    Optional matchedVars As JSONDataMap = Nothing
)
Public Sub ___InternalInjectPortal (
    Optional portal As Portal = Nothing,
    Optional theme As Theme = Nothing,
    Optional match As WorkMatch = Nothing,
    Optional matchedVars As JSONDataMap = Nothing
)
public:
void ___InternalInjectPortal(
    Portal^ portal = nullptr,
    Theme^ theme = nullptr,
    WorkMatch^ match = nullptr,
    JSONDataMap^ matchedVars = nullptr
)
public:
void ___InternalInjectPortal(
    Portal^ portal = nullptr,
    Theme^ theme = nullptr,
    WorkMatch^ match = nullptr,
    JSONDataMap^ matchedVars = nullptr
)
member ___InternalInjectPortal :
        ?portal : Portal *
        ?theme : Theme *
        ?match : WorkMatch *
        ?matchedVars : JSONDataMap
(* Defaults:
        let _portal = defaultArg portal null
        let _theme = defaultArg theme null
        let _match = defaultArg match null
        let _matchedVars = defaultArg matchedVars null
*)
-> unit
member ___InternalInjectPortal :
        ?portal : Portal *
        ?theme : Theme *
        ?match : WorkMatch *
        ?matchedVars : JSONDataMap
(* Defaults:
        let _portal = defaultArg portal null
        let _theme = defaultArg theme null
        let _match = defaultArg match null
        let _matchedVars = defaultArg matchedVars null
*)
-> unit

Parameters

portal (Optional)
Type: NFX.Wave Portal
theme (Optional)
Type: NFX.Wave Theme
match (Optional)
Type: NFX.Wave WorkMatch
matchedVars (Optional)
Type: NFX.Serialization.JSON JSONDataMap
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.___SetWorkMatch Method

WorkContext ___SetWorkMatch Method NFX Class Library

Internal method. Developers do not call

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void ___SetWorkMatch(
    WorkMatch match,
    JSONDataMap vars
)
internal void ___SetWorkMatch(
    WorkMatch match,
    JSONDataMap vars
)
Friend Sub ___SetWorkMatch (
    match As WorkMatch,
    vars As JSONDataMap
)
Friend Sub ___SetWorkMatch (
    match As WorkMatch,
    vars As JSONDataMap
)
internal:
void ___SetWorkMatch(
    WorkMatch^ match,
    JSONDataMap^ vars
)
internal:
void ___SetWorkMatch(
    WorkMatch^ match,
    JSONDataMap^ vars
)
internal member ___SetWorkMatch :
        match : WorkMatch *
        vars : JSONDataMap -> unit
internal member ___SetWorkMatch :
        match : WorkMatch *
        vars : JSONDataMap -> unit

Parameters

match
Type: NFX.Wave WorkMatch
vars
Type: NFX.Serialization.JSON JSONDataMap
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.Destructor Method

WorkContext Destructor Method NFX Class Library

Warning: if overridden, must call base otherwise semaphore will not get released

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.GetWholeRequestAsJSONDataMap Method

WorkContext GetWholeRequestAsJSONDataMap Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts request body and MatchedVars into a single JSONDataMap. Users should call WholeRequestAsJSONDataMap.get() as it caches the result

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual JSONDataMap GetWholeRequestAsJSONDataMap()
protected virtual JSONDataMap GetWholeRequestAsJSONDataMap()
Protected Overridable Function GetWholeRequestAsJSONDataMap As JSONDataMap
Protected Overridable Function GetWholeRequestAsJSONDataMap As JSONDataMap
protected:
virtual JSONDataMap^ GetWholeRequestAsJSONDataMap()
protected:
virtual JSONDataMap^ GetWholeRequestAsJSONDataMap()
abstract GetWholeRequestAsJSONDataMap : unit -> JSONDataMap
override GetWholeRequestAsJSONDataMap : unit -> JSONDataMap
abstract GetWholeRequestAsJSONDataMap : unit -> JSONDataMap
override GetWholeRequestAsJSONDataMap : unit -> JSONDataMap

Return Value

Type: JSONDataMap
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.HasAnyVarsMatchingFieldNames Method

WorkContext HasAnyVarsMatchingFieldNames Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true if the whole request (body or matched vars) contains any names matching any field names of the specified row

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasAnyVarsMatchingFieldNames(
    Row row
)
public bool HasAnyVarsMatchingFieldNames(
    Row row
)
Public Function HasAnyVarsMatchingFieldNames (
    row As Row
) As Boolean
Public Function HasAnyVarsMatchingFieldNames (
    row As Row
) As Boolean
public:
bool HasAnyVarsMatchingFieldNames(
    Row^ row
)
public:
bool HasAnyVarsMatchingFieldNames(
    Row^ row
)
member HasAnyVarsMatchingFieldNames :
        row : Row -> bool
member HasAnyVarsMatchingFieldNames :
        row : Row -> bool

Parameters

row
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.Log Method

WorkContext Log Method NFX Class Library

Facilitates context-aware logging

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Log(
    MessageType type,
    string text,
    string from = null,
    Exception error = null,
    string pars = null,
    Nullable<Guid> related = null
)
public void Log(
    MessageType type,
    string text,
    string from = null,
    Exception error = null,
    string pars = null,
    Nullable<Guid> related = null
)
Public Sub Log (
    type As MessageType,
    text As String,
    Optional from As String = Nothing,
    Optional error As Exception = Nothing,
    Optional pars As String = Nothing,
    Optional related As Nullable(Of Guid) = Nothing
)
Public Sub Log (
    type As MessageType,
    text As String,
    Optional from As String = Nothing,
    Optional error As Exception = Nothing,
    Optional pars As String = Nothing,
    Optional related As Nullable(Of Guid) = Nothing
)
public:
void Log(
    MessageType type,
    String^ text,
    String^ from = nullptr,
    Exception^ error = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> related = nullptr
)
public:
void Log(
    MessageType type,
    String^ text,
    String^ from = nullptr,
    Exception^ error = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> related = nullptr
)
member Log :
        type : MessageType *
        text : string *
        ?from : string *
        ?error : Exception *
        ?pars : string *
        ?related : Nullable<Guid>
(* Defaults:
        let _from = defaultArg from null
        let _error = defaultArg error null
        let _pars = defaultArg pars null
        let _related = defaultArg related null
*)
-> unit
member Log :
        type : MessageType *
        text : string *
        ?from : string *
        ?error : Exception *
        ?pars : string *
        ?related : Nullable<Guid>
(* Defaults:
        let _from = defaultArg from null
        let _error = defaultArg error null
        let _pars = defaultArg pars null
        let _related = defaultArg related null
*)
-> unit

Parameters

type
Type: NFX.Log MessageType
text
Type: Online System String
from (Optional)
Type: Online System String
error (Optional)
Type: Online System Exception
pars (Optional)
Type: Online System String
related (Optional)
Type: Online System Nullable Online Guid
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.NeedsSession Method

WorkContext NeedsSession Method NFX Class Library

Ensures that session is injected if session filter is present in processing chain. If session is already available (Session!=null) then does nothing, otherwise fills Session poroperty with either NEW session (if onlyExisting=false(default)) if user supplied no session token, OR gets session from session store as defined by the first SessionFilter in the chain

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveSession NeedsSession(
    bool onlyExisting = false
)
public WaveSession NeedsSession(
    bool onlyExisting = false
)
Public Function NeedsSession (
    Optional onlyExisting As Boolean = false
) As WaveSession
Public Function NeedsSession (
    Optional onlyExisting As Boolean = false
) As WaveSession
public:
WaveSession^ NeedsSession(
    bool onlyExisting = false
)
public:
WaveSession^ NeedsSession(
    bool onlyExisting = false
)
member NeedsSession :
        ?onlyExisting : bool
(* Defaults:
        let _onlyExisting = defaultArg onlyExisting false
*)
-> WaveSession
member NeedsSession :
        ?onlyExisting : bool
(* Defaults:
        let _onlyExisting = defaultArg onlyExisting false
*)
-> WaveSession

Parameters

onlyExisting (Optional)
Type: Online System Boolean

Return Value

Type: WaveSession
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.ParseRequestBodyAsJSONDataMap Method

WorkContext ParseRequestBodyAsJSONDataMap Method NFX Class Library

[This is preliminary documentation and is subject to change.]

This method is called only once as it touches the input streams

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual JSONDataMap ParseRequestBodyAsJSONDataMap()
protected virtual JSONDataMap ParseRequestBodyAsJSONDataMap()
Protected Overridable Function ParseRequestBodyAsJSONDataMap As JSONDataMap
Protected Overridable Function ParseRequestBodyAsJSONDataMap As JSONDataMap
protected:
virtual JSONDataMap^ ParseRequestBodyAsJSONDataMap()
protected:
virtual JSONDataMap^ ParseRequestBodyAsJSONDataMap()
abstract ParseRequestBodyAsJSONDataMap : unit -> JSONDataMap
override ParseRequestBodyAsJSONDataMap : unit -> JSONDataMap
abstract ParseRequestBodyAsJSONDataMap : unit -> JSONDataMap
override ParseRequestBodyAsJSONDataMap : unit -> JSONDataMap

Return Value

Type: JSONDataMap
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.ReleaseWorkSemaphore Method

WorkContext ReleaseWorkSemaphore Method NFX Class Library

Releases work semaphore that throttles the processing of WorkContext instances. The WorkContext is released automatically in destructor, however there are cases when the semaphore release may be needed sooner, i.e. in a HTTP streaming application where work context instances are kept open indefinitely it may not be desirable to consider long-living work context instances as a throtteling factor. Returns true if semaphore was released, false if it was not released during this call as it was already released before

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ReleaseWorkSemaphore()
public bool ReleaseWorkSemaphore()
Public Function ReleaseWorkSemaphore As Boolean
Public Function ReleaseWorkSemaphore As Boolean
public:
bool ReleaseWorkSemaphore()
public:
bool ReleaseWorkSemaphore()
member ReleaseWorkSemaphore : unit -> bool
member ReleaseWorkSemaphore : unit -> bool

Return Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.SetAuthenticated Method

WorkContext SetAuthenticated Method NFX Class Library

Invoked by applications to signify the presence of authentication

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetAuthenticated(
    bool value
)
public void SetAuthenticated(
    bool value
)
Public Sub SetAuthenticated (
    value As Boolean
)
Public Sub SetAuthenticated (
    value As Boolean
)
public:
void SetAuthenticated(
    bool value
)
public:
void SetAuthenticated(
    bool value
)
member SetAuthenticated :
        value : bool -> unit
member SetAuthenticated :
        value : bool -> unit

Parameters

value
Type: Online System Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.ToString Method

WorkContext ToString Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext Properties

WorkContext Properties NFX Class Library

The WorkContext type exposes the following members.
Properties
 | Name | Description
Public property | Aborted | Indicates whether the work context is logically finished and its nested processing (i.e. through Filters/Handlers) should stop. For example, when some filter detects a special condition (judging by the request) and generates the response and needs to abort the work request so it does no get filtered/processed anymore, it can set this property to true. This mechanism performs much better than throwing exceptions
Public property | About | Generates short context description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EffectiveCallerIPEndPoint | Returns the effective caller endpoint- that is, if the real caller filter is set it will inject the real IP as seen before any proxy devices. By default this property returns the Request.RemoteEndPoint
Public property | GeoEntity | Gets sets geo location information as detected by GeoLookupHandler. If Session context is injected then get/set passes through into session object
Public property | Handled | Returns true when the work has been executed by the WorkHandler instance
Public property | Handler | Returns the work handler instance that was matched to perform work on this context or null if the match has not been made yet
Public property | ID | Uniquely identifies the request
Public property | IsAuthenticated | Returns true to indicate that this context is/was authenticated. Used to not redirect users to login page on authorization exception
Public property | IsDELETE | Indicates that request method id DELETE
Public property | IsGET | Indicates that request method id GET
Public property | IsPATCH | Indicates that request method id PATCH
Public property | IsPOST | Indicates that request method id POST
Public property | IsPUT | Indicates that request method id PUT
Public property | Items | Provides a thread-safe dictionary of items. The underlying collection is lazily allocated
Public property | LastError | Captures last error
Public property | Match | Returns the work match instances that was made for this requested work or null if nothing was matched yet
Public property | Matched | Returns dynamic object that contains variables that have been extracted by WorkMatch when dispatcher assigned request to WorkHandler. If variables have not been assigned yet returns empty object
Public property | MatchedVars | Returns variables that have been extracted by WorkMatch when dispatcher assigned request to WorkHandler. If variables have not been assigned yet returns empty object
Public property | NoDefaultAutoClose | Indicates whether the default dispatcher should close the WorkContext upon completion of async processing. This property may ONLY be set to TRUE IF Response.Buffered = false (chunked transfer) and Response has already been written to. When this property is set to true the WorkDispatcher will not auto dispose this WorkContext instance. This may be needed for a server that streams chat messages and some other thread manages the lifetime of this WorkContext. Keep in mind that alternative implementations of WorkDispatcher (derived classes that implement alternative threading/lifecycle) may disregard this flag altogether
Public property | Portal | Returns portal object for this request or null if no portal was injected
Public property | PortalFilter | Returns the first portal filter which was injected in the processing line. It is the filter that manages the portals for this context
Public property | PortalMatch | Returns matched that was made by portal filter or null
Public property | PortalMatchedVars | Returns variables that have been extracted by WorkMatch when PortalFilter assigned portal. Returns null if no portal was matched
Public property | PortalTheme | Gets/sets portal theme. This may be null as this is just a holder variable
Public property | Request | Returns HttpListenerRequest object for this context
Public property | RequestBodyAsJSONDataMap | Fetches request body: multipart content, url encoded content, or JSON body into one JSONDataMap bag, or null if there is no body. The property does caching
Public property | RequestedJSON | Returns true if client indicated in response that "application/json" is accepted
Public property | Response | Returns Response object for this context
Public property | Server | Returns the server this context is under
Public property | Session | Returns session that this context is linked with or null
Public property | SessionFilter | Returns the first session filter which was injected in the processing line. It is the filter that manages the session state for this context
Public property | SupportsSession | Returns true when the context was configured to support SessionFilter so Session can be injected
Public property | WholeRequestAsJSONDataMap | Fetches matched vars, multipart content, url encoded content, or JSON body into one JSONDataMap bag. The property does caching
Public property | WorkSemaphoreReleased | Returns true to indicate that work semaphore has been already released. It is not necessary to use this property or ReleaseWorkSemaphore() method as the framework does it automatically in 99% cases. ReleaseWorkSemaphore() may need to be called from special places like HTTP streaming servers that need to keep WorkContext instances open for a long time
Back to Top
See Also
WorkContext Class
NFX.Wave Namespace


WorkContext.Aborted Property

WorkContext Aborted Property NFX Class Library

Indicates whether the work context is logically finished and its nested processing (i.e. through Filters/Handlers) should stop. For example, when some filter detects a special condition (judging by the request) and generates the response and needs to abort the work request so it does no get filtered/processed anymore, it can set this property to true. This mechanism performs much better than throwing exceptions

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Aborted { get; set; }
public bool Aborted { get; set; }
Public Property Aborted As Boolean
    Get
    Set
Public Property Aborted As Boolean
    Get
    Set
public:
property bool Aborted {
    bool get ();
    void set (bool value);
}
public:
property bool Aborted {
    bool get ();
    void set (bool value);
}
member Aborted : bool with get, set
member Aborted : bool with get, set

Property Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.About Property

WorkContext About Property NFX Class Library

Generates short context description

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string About { get; }
public string About { get; }
Public ReadOnly Property About As String
    Get
Public ReadOnly Property About As String
    Get
public:
property String^ About {
    String^ get ();
}
public:
property String^ About {
    String^ get ();
}
member About : string with get
member About : string with get

Property Value

Type: Online String
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.EffectiveCallerIPEndPoint Property

WorkContext EffectiveCallerIPEndPoint Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the effective caller endpoint- that is, if the real caller filter is set it will inject the real IP as seen before any proxy devices. By default this property returns the Request.RemoteEndPoint

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPEndPoint EffectiveCallerIPEndPoint { get; }
public IPEndPoint EffectiveCallerIPEndPoint { get; }
Public ReadOnly Property EffectiveCallerIPEndPoint As IPEndPoint
    Get
Public ReadOnly Property EffectiveCallerIPEndPoint As IPEndPoint
    Get
public:
property IPEndPoint^ EffectiveCallerIPEndPoint {
    IPEndPoint^ get ();
}
public:
property IPEndPoint^ EffectiveCallerIPEndPoint {
    IPEndPoint^ get ();
}
member EffectiveCallerIPEndPoint : IPEndPoint with get
member EffectiveCallerIPEndPoint : IPEndPoint with get

Property Value

Type: Online IPEndPoint
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.GeoEntity Property

WorkContext GeoEntity Property NFX Class Library

Gets sets geo location information as detected by GeoLookupHandler. If Session context is injected then get/set passes through into session object

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GeoEntity GeoEntity { get; set; }
public GeoEntity GeoEntity { get; set; }
Public Property GeoEntity As GeoEntity
    Get
    Set
Public Property GeoEntity As GeoEntity
    Get
    Set
public:
property GeoEntity^ GeoEntity {
    GeoEntity^ get ();
    void set (GeoEntity^ value);
}
public:
property GeoEntity^ GeoEntity {
    GeoEntity^ get ();
    void set (GeoEntity^ value);
}
member GeoEntity : GeoEntity with get, set
member GeoEntity : GeoEntity with get, set

Property Value

Type: GeoEntity
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.Handled Property

WorkContext Handled Property NFX Class Library

Returns true when the work has been executed by the WorkHandler instance

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Handled { get; }
public bool Handled { get; }
Public ReadOnly Property Handled As Boolean
    Get
Public ReadOnly Property Handled As Boolean
    Get
public:
property bool Handled {
    bool get ();
}
public:
property bool Handled {
    bool get ();
}
member Handled : bool with get
member Handled : bool with get

Property Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.Handler Property

WorkContext Handler Property NFX Class Library

Returns the work handler instance that was matched to perform work on this context or null if the match has not been made yet

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkHandler Handler { get; }
public WorkHandler Handler { get; }
Public ReadOnly Property Handler As WorkHandler
    Get
Public ReadOnly Property Handler As WorkHandler
    Get
public:
property WorkHandler^ Handler {
    WorkHandler^ get ();
}
public:
property WorkHandler^ Handler {
    WorkHandler^ get ();
}
member Handler : WorkHandler with get
member Handler : WorkHandler with get

Property Value

Type: WorkHandler
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.ID Property

WorkContext ID Property NFX Class Library

Uniquely identifies the request

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ID { get; }
public Guid ID { get; }
Public ReadOnly Property ID As Guid
    Get
Public ReadOnly Property ID As Guid
    Get
public:
property Guid ID {
    Guid get ();
}
public:
property Guid ID {
    Guid get ();
}
member ID : Guid with get
member ID : Guid with get

Property Value

Type: Online Guid
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.IsAuthenticated Property

WorkContext IsAuthenticated Property NFX Class Library

Returns true to indicate that this context is/was authenticated. Used to not redirect users to login page on authorization exception

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAuthenticated { get; }
public bool IsAuthenticated { get; }
Public ReadOnly Property IsAuthenticated As Boolean
    Get
Public ReadOnly Property IsAuthenticated As Boolean
    Get
public:
property bool IsAuthenticated {
    bool get ();
}
public:
property bool IsAuthenticated {
    bool get ();
}
member IsAuthenticated : bool with get
member IsAuthenticated : bool with get

Property Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.IsDELETE Property

WorkContext IsDELETE Property NFX Class Library

Indicates that request method id DELETE

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsDELETE { get; }
public bool IsDELETE { get; }
Public ReadOnly Property IsDELETE As Boolean
    Get
Public ReadOnly Property IsDELETE As Boolean
    Get
public:
property bool IsDELETE {
    bool get ();
}
public:
property bool IsDELETE {
    bool get ();
}
member IsDELETE : bool with get
member IsDELETE : bool with get

Property Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.IsGET Property

WorkContext IsGET Property NFX Class Library

Indicates that request method id GET

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsGET { get; }
public bool IsGET { get; }
Public ReadOnly Property IsGET As Boolean
    Get
Public ReadOnly Property IsGET As Boolean
    Get
public:
property bool IsGET {
    bool get ();
}
public:
property bool IsGET {
    bool get ();
}
member IsGET : bool with get
member IsGET : bool with get

Property Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.IsPATCH Property

WorkContext IsPATCH Property NFX Class Library

Indicates that request method id PATCH

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsPATCH { get; }
public bool IsPATCH { get; }
Public ReadOnly Property IsPATCH As Boolean
    Get
Public ReadOnly Property IsPATCH As Boolean
    Get
public:
property bool IsPATCH {
    bool get ();
}
public:
property bool IsPATCH {
    bool get ();
}
member IsPATCH : bool with get
member IsPATCH : bool with get

Property Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.IsPOST Property

WorkContext IsPOST Property NFX Class Library

Indicates that request method id POST

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsPOST { get; }
public bool IsPOST { get; }
Public ReadOnly Property IsPOST As Boolean
    Get
Public ReadOnly Property IsPOST As Boolean
    Get
public:
property bool IsPOST {
    bool get ();
}
public:
property bool IsPOST {
    bool get ();
}
member IsPOST : bool with get
member IsPOST : bool with get

Property Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.IsPUT Property

WorkContext IsPUT Property NFX Class Library

Indicates that request method id PUT

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsPUT { get; }
public bool IsPUT { get; }
Public ReadOnly Property IsPUT As Boolean
    Get
Public ReadOnly Property IsPUT As Boolean
    Get
public:
property bool IsPUT {
    bool get ();
}
public:
property bool IsPUT {
    bool get ();
}
member IsPUT : bool with get
member IsPUT : bool with get

Property Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.Items Property

WorkContext Items Property NFX Class Library

Provides a thread-safe dictionary of items. The underlying collection is lazily allocated

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConcurrentDictionary<Object, Object> Items { get; }
public ConcurrentDictionary<Object, Object> Items { get; }
Public ReadOnly Property Items As ConcurrentDictionary(Of Object, Object)
    Get
Public ReadOnly Property Items As ConcurrentDictionary(Of Object, Object)
    Get
public:
property ConcurrentDictionary<Object^, Object^>^ Items {
    ConcurrentDictionary<Object^, Object^>^ get ();
}
public:
property ConcurrentDictionary<Object^, Object^>^ Items {
    ConcurrentDictionary<Object^, Object^>^ get ();
}
member Items : ConcurrentDictionary<Object, Object> with get
member Items : ConcurrentDictionary<Object, Object> with get

Property Value

Type: Online ConcurrentDictionary Online Object, Online Object
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.LastError Property

WorkContext LastError Property NFX Class Library

Captures last error

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception LastError { get; set; }
public Exception LastError { get; set; }
Public Property LastError As Exception
    Get
    Set
Public Property LastError As Exception
    Get
    Set
public:
property Exception^ LastError {
    Exception^ get ();
    void set (Exception^ value);
}
public:
property Exception^ LastError {
    Exception^ get ();
    void set (Exception^ value);
}
member LastError : Exception with get, set
member LastError : Exception with get, set

Property Value

Type: Online Exception
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.Match Property

WorkContext Match Property NFX Class Library

Returns the work match instances that was made for this requested work or null if nothing was matched yet

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkMatch Match { get; }
public WorkMatch Match { get; }
Public ReadOnly Property Match As WorkMatch
    Get
Public ReadOnly Property Match As WorkMatch
    Get
public:
property WorkMatch^ Match {
    WorkMatch^ get ();
}
public:
property WorkMatch^ Match {
    WorkMatch^ get ();
}
member Match : WorkMatch with get
member Match : WorkMatch with get

Property Value

Type: WorkMatch
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.Matched Property

WorkContext Matched Property NFX Class Library

Returns dynamic object that contains variables that have been extracted by WorkMatch when dispatcher assigned request to WorkHandler. If variables have not been assigned yet returns empty object

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Matched { get; }
public Object Matched { get; }
Public ReadOnly Property Matched As Object
    Get
Public ReadOnly Property Matched As Object
    Get
public:
property Object^ Matched {
    Object^ get ();
}
public:
property Object^ Matched {
    Object^ get ();
}
member Matched : Object with get
member Matched : Object with get

Property Value

Type: Online Object
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.MatchedVars Property

WorkContext MatchedVars Property NFX Class Library

Returns variables that have been extracted by WorkMatch when dispatcher assigned request to WorkHandler. If variables have not been assigned yet returns empty object

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap MatchedVars { get; }
public JSONDataMap MatchedVars { get; }
Public ReadOnly Property MatchedVars As JSONDataMap
    Get
Public ReadOnly Property MatchedVars As JSONDataMap
    Get
public:
property JSONDataMap^ MatchedVars {
    JSONDataMap^ get ();
}
public:
property JSONDataMap^ MatchedVars {
    JSONDataMap^ get ();
}
member MatchedVars : JSONDataMap with get
member MatchedVars : JSONDataMap with get

Property Value

Type: JSONDataMap
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.NoDefaultAutoClose Property

WorkContext NoDefaultAutoClose Property NFX Class Library

Indicates whether the default dispatcher should close the WorkContext upon completion of async processing. This property may ONLY be set to TRUE IF Response.Buffered = false (chunked transfer) and Response has already been written to. When this property is set to true the WorkDispatcher will not auto dispose this WorkContext instance. This may be needed for a server that streams chat messages and some other thread manages the lifetime of this WorkContext. Keep in mind that alternative implementations of WorkDispatcher (derived classes that implement alternative threading/lifecycle) may disregard this flag altogether

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool NoDefaultAutoClose { get; set; }
public bool NoDefaultAutoClose { get; set; }
Public Property NoDefaultAutoClose As Boolean
    Get
    Set
Public Property NoDefaultAutoClose As Boolean
    Get
    Set
public:
property bool NoDefaultAutoClose {
    bool get ();
    void set (bool value);
}
public:
property bool NoDefaultAutoClose {
    bool get ();
    void set (bool value);
}
member NoDefaultAutoClose : bool with get, set
member NoDefaultAutoClose : bool with get, set

Property Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.Portal Property

WorkContext Portal Property NFX Class Library

Returns portal object for this request or null if no portal was injected

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Portal Portal { get; }
public Portal Portal { get; }
Public ReadOnly Property Portal As Portal
    Get
Public ReadOnly Property Portal As Portal
    Get
public:
property Portal^ Portal {
    Portal^ get ();
}
public:
property Portal^ Portal {
    Portal^ get ();
}
member Portal : Portal with get
member Portal : Portal with get

Property Value

Type: Portal
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.PortalFilter Property

WorkContext PortalFilter Property NFX Class Library

Returns the first portal filter which was injected in the processing line. It is the filter that manages the portals for this context

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PortalFilter PortalFilter { get; }
public PortalFilter PortalFilter { get; }
Public ReadOnly Property PortalFilter As PortalFilter
    Get
Public ReadOnly Property PortalFilter As PortalFilter
    Get
public:
property PortalFilter^ PortalFilter {
    PortalFilter^ get ();
}
public:
property PortalFilter^ PortalFilter {
    PortalFilter^ get ();
}
member PortalFilter : PortalFilter with get
member PortalFilter : PortalFilter with get

Property Value

Type: PortalFilter
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.PortalMatch Property

WorkContext PortalMatch Property NFX Class Library

Returns matched that was made by portal filter or null

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkMatch PortalMatch { get; }
public WorkMatch PortalMatch { get; }
Public ReadOnly Property PortalMatch As WorkMatch
    Get
Public ReadOnly Property PortalMatch As WorkMatch
    Get
public:
property WorkMatch^ PortalMatch {
    WorkMatch^ get ();
}
public:
property WorkMatch^ PortalMatch {
    WorkMatch^ get ();
}
member PortalMatch : WorkMatch with get
member PortalMatch : WorkMatch with get

Property Value

Type: WorkMatch
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.PortalMatchedVars Property

WorkContext PortalMatchedVars Property NFX Class Library

Returns variables that have been extracted by WorkMatch when PortalFilter assigned portal. Returns null if no portal was matched

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap PortalMatchedVars { get; }
public JSONDataMap PortalMatchedVars { get; }
Public ReadOnly Property PortalMatchedVars As JSONDataMap
    Get
Public ReadOnly Property PortalMatchedVars As JSONDataMap
    Get
public:
property JSONDataMap^ PortalMatchedVars {
    JSONDataMap^ get ();
}
public:
property JSONDataMap^ PortalMatchedVars {
    JSONDataMap^ get ();
}
member PortalMatchedVars : JSONDataMap with get
member PortalMatchedVars : JSONDataMap with get

Property Value

Type: JSONDataMap
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.PortalTheme Property

WorkContext PortalTheme Property NFX Class Library

Gets/sets portal theme. This may be null as this is just a holder variable

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Theme PortalTheme { get; set; }
public Theme PortalTheme { get; set; }
Public Property PortalTheme As Theme
    Get
    Set
Public Property PortalTheme As Theme
    Get
    Set
public:
property Theme^ PortalTheme {
    Theme^ get ();
    void set (Theme^ value);
}
public:
property Theme^ PortalTheme {
    Theme^ get ();
    void set (Theme^ value);
}
member PortalTheme : Theme with get, set
member PortalTheme : Theme with get, set

Property Value

Type: Theme
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.Request Property

WorkContext Request Property NFX Class Library

Returns HttpListenerRequest object for this context

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HttpListenerRequest Request { get; }
public HttpListenerRequest Request { get; }
Public ReadOnly Property Request As HttpListenerRequest
    Get
Public ReadOnly Property Request As HttpListenerRequest
    Get
public:
property HttpListenerRequest^ Request {
    HttpListenerRequest^ get ();
}
public:
property HttpListenerRequest^ Request {
    HttpListenerRequest^ get ();
}
member Request : HttpListenerRequest with get
member Request : HttpListenerRequest with get

Property Value

Type: Online HttpListenerRequest
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.RequestBodyAsJSONDataMap Property

WorkContext RequestBodyAsJSONDataMap Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Fetches request body: multipart content, url encoded content, or JSON body into one JSONDataMap bag, or null if there is no body. The property does caching

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap RequestBodyAsJSONDataMap { get; }
public JSONDataMap RequestBodyAsJSONDataMap { get; }
Public ReadOnly Property RequestBodyAsJSONDataMap As JSONDataMap
    Get
Public ReadOnly Property RequestBodyAsJSONDataMap As JSONDataMap
    Get
public:
property JSONDataMap^ RequestBodyAsJSONDataMap {
    JSONDataMap^ get ();
}
public:
property JSONDataMap^ RequestBodyAsJSONDataMap {
    JSONDataMap^ get ();
}
member RequestBodyAsJSONDataMap : JSONDataMap with get
member RequestBodyAsJSONDataMap : JSONDataMap with get

Property Value

Type: JSONDataMap
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.RequestedJSON Property

WorkContext RequestedJSON Property NFX Class Library

Returns true if client indicated in response that "application/json" is accepted

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RequestedJSON { get; }
public bool RequestedJSON { get; }
Public ReadOnly Property RequestedJSON As Boolean
    Get
Public ReadOnly Property RequestedJSON As Boolean
    Get
public:
property bool RequestedJSON {
    bool get ();
}
public:
property bool RequestedJSON {
    bool get ();
}
member RequestedJSON : bool with get
member RequestedJSON : bool with get

Property Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.Response Property

WorkContext Response Property NFX Class Library

Returns Response object for this context

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Response Response { get; }
public Response Response { get; }
Public ReadOnly Property Response As Response
    Get
Public ReadOnly Property Response As Response
    Get
public:
property Response^ Response {
    Response^ get ();
}
public:
property Response^ Response {
    Response^ get ();
}
member Response : Response with get
member Response : Response with get

Property Value

Type: Response
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.Server Property

WorkContext Server Property NFX Class Library

Returns the server this context is under

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveServer Server { get; }
public WaveServer Server { get; }
Public ReadOnly Property Server As WaveServer
    Get
Public ReadOnly Property Server As WaveServer
    Get
public:
property WaveServer^ Server {
    WaveServer^ get ();
}
public:
property WaveServer^ Server {
    WaveServer^ get ();
}
member Server : WaveServer with get
member Server : WaveServer with get

Property Value

Type: WaveServer
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.Session Property

WorkContext Session Property NFX Class Library

Returns session that this context is linked with or null

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveSession Session { get; }
public WaveSession Session { get; }
Public ReadOnly Property Session As WaveSession
    Get
Public ReadOnly Property Session As WaveSession
    Get
public:
property WaveSession^ Session {
    WaveSession^ get ();
}
public:
property WaveSession^ Session {
    WaveSession^ get ();
}
member Session : WaveSession with get
member Session : WaveSession with get

Property Value

Type: WaveSession
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.SessionFilter Property

WorkContext SessionFilter Property NFX Class Library

Returns the first session filter which was injected in the processing line. It is the filter that manages the session state for this context

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SessionFilter SessionFilter { get; }
public SessionFilter SessionFilter { get; }
Public ReadOnly Property SessionFilter As SessionFilter
    Get
Public ReadOnly Property SessionFilter As SessionFilter
    Get
public:
property SessionFilter^ SessionFilter {
    SessionFilter^ get ();
}
public:
property SessionFilter^ SessionFilter {
    SessionFilter^ get ();
}
member SessionFilter : SessionFilter with get
member SessionFilter : SessionFilter with get

Property Value

Type: SessionFilter
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.SupportsSession Property

WorkContext SupportsSession Property NFX Class Library

Returns true when the context was configured to support SessionFilter so Session can be injected

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsSession { get; }
public bool SupportsSession { get; }
Public ReadOnly Property SupportsSession As Boolean
    Get
Public ReadOnly Property SupportsSession As Boolean
    Get
public:
property bool SupportsSession {
    bool get ();
}
public:
property bool SupportsSession {
    bool get ();
}
member SupportsSession : bool with get
member SupportsSession : bool with get

Property Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.WholeRequestAsJSONDataMap Property

WorkContext WholeRequestAsJSONDataMap Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Fetches matched vars, multipart content, url encoded content, or JSON body into one JSONDataMap bag. The property does caching

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap WholeRequestAsJSONDataMap { get; }
public JSONDataMap WholeRequestAsJSONDataMap { get; }
Public ReadOnly Property WholeRequestAsJSONDataMap As JSONDataMap
    Get
Public ReadOnly Property WholeRequestAsJSONDataMap As JSONDataMap
    Get
public:
property JSONDataMap^ WholeRequestAsJSONDataMap {
    JSONDataMap^ get ();
}
public:
property JSONDataMap^ WholeRequestAsJSONDataMap {
    JSONDataMap^ get ();
}
member WholeRequestAsJSONDataMap : JSONDataMap with get
member WholeRequestAsJSONDataMap : JSONDataMap with get

Property Value

Type: JSONDataMap
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkContext.WorkSemaphoreReleased Property

WorkContext WorkSemaphoreReleased Property NFX Class Library

Returns true to indicate that work semaphore has been already released. It is not necessary to use this property or ReleaseWorkSemaphore() method as the framework does it automatically in 99% cases. ReleaseWorkSemaphore() may need to be called from special places like HTTP streaming servers that need to keep WorkContext instances open for a long time

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool WorkSemaphoreReleased { get; }
public bool WorkSemaphoreReleased { get; }
Public ReadOnly Property WorkSemaphoreReleased As Boolean
    Get
Public ReadOnly Property WorkSemaphoreReleased As Boolean
    Get
public:
property bool WorkSemaphoreReleased {
    bool get ();
}
public:
property bool WorkSemaphoreReleased {
    bool get ();
}
member WorkSemaphoreReleased : bool with get
member WorkSemaphoreReleased : bool with get

Property Value

Type: Online Boolean
See Also
WorkContext Class
WorkContext Members
NFX.Wave Namespace


WorkDispatcher Class

WorkDispatcher Class NFX Class Library

Represents a default dispatcher that dispatches WorkContext calls on the same thread that calls Dispatch(work). May extend this class to implement custom dispatchers, i.e. the once that maintain their won work queue/worker threads
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service WaveServer
NFX.Wave WorkDispatcher

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class WorkDispatcher : Service<WaveServer>
public class WorkDispatcher : Service<WaveServer>
Public Class WorkDispatcher
    Inherits Service(Of WaveServer)
Public Class WorkDispatcher
    Inherits Service(Of WaveServer)
public ref class WorkDispatcher : public Service<WaveServer^>
public ref class WorkDispatcher : public Service<WaveServer^>
type WorkDispatcher =
    class
        inherit Service<WaveServer>
    end
type WorkDispatcher =
    class
        inherit Service<WaveServer>
    end
See Also
WorkDispatcher Members
NFX.Wave Namespace


WorkDispatcher Members

WorkDispatcher Members NFX Class Library

The WorkDispatcher type exposes the following members.
Constructors
 | Name | Description
Public method | WorkDispatcher | Initializes a new instance of the WorkDispatcher class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispatch | Dispatches work into appropriate handler passing through filters. The default implementation processes requests on the calling thread and disposes WorkContext deterministically
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWorkHandler | Finds the most appropriate work handler to do the work. The default implementation finds first handler with matching URI pattern or null
Public method | HandleException | Handles processing exception - this implementation uses server-wide behavior. All parameters except ERROR can be null - which indicates error that happened during WorkContext dispose
Public method | InvokeHandler | Finds appropriate handler and invokes it. Returns the appropriate handler or null if work was aborted or already handled. Throws if appropriate handler was not found
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests
Public method | RegisterHandler | Registers handler and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject handlers while serving requests
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests
Public method | UnRegisterHandler | Unregisters handler and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove handlers while serving requests
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters
Public property | Handlers | Returns ordered registry of handlers
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
WorkDispatcher Class
NFX.Wave Namespace


WorkDispatcher Constructor

WorkDispatcher Constructor NFX Class Library

Initializes a new instance of the WorkDispatcher class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkDispatcher(
    WaveServer director
)
public WorkDispatcher(
    WaveServer director
)
Public Sub New (
    director As WaveServer
)
Public Sub New (
    director As WaveServer
)
public:
WorkDispatcher(
    WaveServer^ director
)
public:
WorkDispatcher(
    WaveServer^ director
)
new :
        director : WaveServer -> WorkDispatcher
new :
        director : WaveServer -> WorkDispatcher

Parameters

director
Type: NFX.Wave WaveServer
See Also
WorkDispatcher Class
WorkDispatcher Members
NFX.Wave Namespace


WorkDispatcher Methods

WorkDispatcher Methods NFX Class Library

The WorkDispatcher type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispatch | Dispatches work into appropriate handler passing through filters. The default implementation processes requests on the calling thread and disposes WorkContext deterministically
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWorkHandler | Finds the most appropriate work handler to do the work. The default implementation finds first handler with matching URI pattern or null
Public method | HandleException | Handles processing exception - this implementation uses server-wide behavior. All parameters except ERROR can be null - which indicates error that happened during WorkContext dispose
Public method | InvokeHandler | Finds appropriate handler and invokes it. Returns the appropriate handler or null if work was aborted or already handled. Throws if appropriate handler was not found
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests
Public method | RegisterHandler | Registers handler and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject handlers while serving requests
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests
Public method | UnRegisterHandler | Unregisters handler and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove handlers while serving requests
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkDispatcher Class
NFX.Wave Namespace


WorkDispatcher.Destructor Method

WorkDispatcher Destructor Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
WorkDispatcher Class
WorkDispatcher Members
NFX.Wave Namespace


WorkDispatcher.Dispatch Method

WorkDispatcher Dispatch Method NFX Class Library

Dispatches work into appropriate handler passing through filters. The default implementation processes requests on the calling thread and disposes WorkContext deterministically

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Dispatch(
    WorkContext work
)
public virtual void Dispatch(
    WorkContext work
)
Public Overridable Sub Dispatch (
    work As WorkContext
)
Public Overridable Sub Dispatch (
    work As WorkContext
)
public:
virtual void Dispatch(
    WorkContext^ work
)
public:
virtual void Dispatch(
    WorkContext^ work
)
abstract Dispatch :
        work : WorkContext -> unit
override Dispatch :
        work : WorkContext -> unit
abstract Dispatch :
        work : WorkContext -> unit
override Dispatch :
        work : WorkContext -> unit

Parameters

work
Type: NFX.Wave WorkContext
See Also
WorkDispatcher Class
WorkDispatcher Members
NFX.Wave Namespace


WorkDispatcher.DoConfigure Method

WorkDispatcher DoConfigure Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
WorkDispatcher Class
WorkDispatcher Members
NFX.Wave Namespace


WorkDispatcher.GetWorkHandler Method

WorkDispatcher GetWorkHandler Method NFX Class Library

Finds the most appropriate work handler to do the work. The default implementation finds first handler with matching URI pattern or null

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual WorkHandler GetWorkHandler(
    WorkContext work
)
public virtual WorkHandler GetWorkHandler(
    WorkContext work
)
Public Overridable Function GetWorkHandler (
    work As WorkContext
) As WorkHandler
Public Overridable Function GetWorkHandler (
    work As WorkContext
) As WorkHandler
public:
virtual WorkHandler^ GetWorkHandler(
    WorkContext^ work
)
public:
virtual WorkHandler^ GetWorkHandler(
    WorkContext^ work
)
abstract GetWorkHandler :
        work : WorkContext -> WorkHandler
override GetWorkHandler :
        work : WorkContext -> WorkHandler
abstract GetWorkHandler :
        work : WorkContext -> WorkHandler
override GetWorkHandler :
        work : WorkContext -> WorkHandler

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: WorkHandler
See Also
WorkDispatcher Class
WorkDispatcher Members
NFX.Wave Namespace


WorkDispatcher.HandleException Method

WorkDispatcher HandleException Method NFX Class Library

Handles processing exception - this implementation uses server-wide behavior. All parameters except ERROR can be null - which indicates error that happened during WorkContext dispose

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void HandleException(
    WorkContext work,
    WorkFilter filter,
    WorkHandler handler,
    Exception error
)
public virtual void HandleException(
    WorkContext work,
    WorkFilter filter,
    WorkHandler handler,
    Exception error
)
Public Overridable Sub HandleException (
    work As WorkContext,
    filter As WorkFilter,
    handler As WorkHandler,
    error As Exception
)
Public Overridable Sub HandleException (
    work As WorkContext,
    filter As WorkFilter,
    handler As WorkHandler,
    error As Exception
)
public:
virtual void HandleException(
    WorkContext^ work,
    WorkFilter^ filter,
    WorkHandler^ handler,
    Exception^ error
)
public:
virtual void HandleException(
    WorkContext^ work,
    WorkFilter^ filter,
    WorkHandler^ handler,
    Exception^ error
)
abstract HandleException :
        work : WorkContext *
        filter : WorkFilter *
        handler : WorkHandler *
        error : Exception -> unit
override HandleException :
        work : WorkContext *
        filter : WorkFilter *
        handler : WorkHandler *
        error : Exception -> unit
abstract HandleException :
        work : WorkContext *
        filter : WorkFilter *
        handler : WorkHandler *
        error : Exception -> unit
override HandleException :
        work : WorkContext *
        filter : WorkFilter *
        handler : WorkHandler *
        error : Exception -> unit

Parameters

work
Type: NFX.Wave WorkContext
filter
Type: NFX.Wave WorkFilter
handler
Type: NFX.Wave WorkHandler
error
Type: Online System Exception
See Also
WorkDispatcher Class
WorkDispatcher Members
NFX.Wave Namespace


WorkDispatcher.InvokeHandler Method

WorkDispatcher InvokeHandler Method NFX Class Library

Finds appropriate handler and invokes it. Returns the appropriate handler or null if work was aborted or already handled. Throws if appropriate handler was not found

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void InvokeHandler(
    WorkContext work,
    out WorkHandler handler
)
public virtual void InvokeHandler(
    WorkContext work,
    out WorkHandler handler
)
Public Overridable Sub InvokeHandler (
    work As WorkContext,
    <OutAttribute> ByRef handler As WorkHandler
)
Public Overridable Sub InvokeHandler (
    work As WorkContext,
    <OutAttribute> ByRef handler As WorkHandler
)
public:
virtual void InvokeHandler(
    WorkContext^ work,
    [OutAttribute] WorkHandler^% handler
)
public:
virtual void InvokeHandler(
    WorkContext^ work,
    [OutAttribute] WorkHandler^% handler
)
abstract InvokeHandler :
        work : WorkContext *
        handler : WorkHandler byref -> unit
override InvokeHandler :
        work : WorkContext *
        handler : WorkHandler byref -> unit
abstract InvokeHandler :
        work : WorkContext *
        handler : WorkHandler byref -> unit
override InvokeHandler :
        work : WorkContext *
        handler : WorkHandler byref -> unit

Parameters

work
Type: NFX.Wave WorkContext
handler
Type: NFX.Wave WorkHandler
See Also
WorkDispatcher Class
WorkDispatcher Members
NFX.Wave Namespace


WorkDispatcher.RegisterFilter Method

WorkDispatcher RegisterFilter Method NFX Class Library

Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RegisterFilter(
    WorkFilter filter
)
public bool RegisterFilter(
    WorkFilter filter
)
Public Function RegisterFilter (
    filter As WorkFilter
) As Boolean
Public Function RegisterFilter (
    filter As WorkFilter
) As Boolean
public:
bool RegisterFilter(
    WorkFilter^ filter
)
public:
bool RegisterFilter(
    WorkFilter^ filter
)
member RegisterFilter :
        filter : WorkFilter -> bool
member RegisterFilter :
        filter : WorkFilter -> bool

Parameters

filter
Type: NFX.Wave WorkFilter

Return Value

Type: Online Boolean
See Also
WorkDispatcher Class
WorkDispatcher Members
NFX.Wave Namespace


WorkDispatcher.RegisterHandler Method

WorkDispatcher RegisterHandler Method NFX Class Library

Registers handler and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject handlers while serving requests

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RegisterHandler(
    WorkHandler handler
)
public bool RegisterHandler(
    WorkHandler handler
)
Public Function RegisterHandler (
    handler As WorkHandler
) As Boolean
Public Function RegisterHandler (
    handler As WorkHandler
) As Boolean
public:
bool RegisterHandler(
    WorkHandler^ handler
)
public:
bool RegisterHandler(
    WorkHandler^ handler
)
member RegisterHandler :
        handler : WorkHandler -> bool
member RegisterHandler :
        handler : WorkHandler -> bool

Parameters

handler
Type: NFX.Wave WorkHandler

Return Value

Type: Online Boolean
See Also
WorkDispatcher Class
WorkDispatcher Members
NFX.Wave Namespace


WorkDispatcher.UnRegisterFilter Method

WorkDispatcher UnRegisterFilter Method NFX Class Library

Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnRegisterFilter(
    WorkFilter filter
)
public bool UnRegisterFilter(
    WorkFilter filter
)
Public Function UnRegisterFilter (
    filter As WorkFilter
) As Boolean
Public Function UnRegisterFilter (
    filter As WorkFilter
) As Boolean
public:
bool UnRegisterFilter(
    WorkFilter^ filter
)
public:
bool UnRegisterFilter(
    WorkFilter^ filter
)
member UnRegisterFilter :
        filter : WorkFilter -> bool
member UnRegisterFilter :
        filter : WorkFilter -> bool

Parameters

filter
Type: NFX.Wave WorkFilter

Return Value

Type: Online Boolean
See Also
WorkDispatcher Class
WorkDispatcher Members
NFX.Wave Namespace


WorkDispatcher.UnRegisterHandler Method

WorkDispatcher UnRegisterHandler Method NFX Class Library

Unregisters handler and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove handlers while serving requests

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnRegisterHandler(
    WorkHandler handler
)
public bool UnRegisterHandler(
    WorkHandler handler
)
Public Function UnRegisterHandler (
    handler As WorkHandler
) As Boolean
Public Function UnRegisterHandler (
    handler As WorkHandler
) As Boolean
public:
bool UnRegisterHandler(
    WorkHandler^ handler
)
public:
bool UnRegisterHandler(
    WorkHandler^ handler
)
member UnRegisterHandler :
        handler : WorkHandler -> bool
member UnRegisterHandler :
        handler : WorkHandler -> bool

Parameters

handler
Type: NFX.Wave WorkHandler

Return Value

Type: Online Boolean
See Also
WorkDispatcher Class
WorkDispatcher Members
NFX.Wave Namespace


WorkDispatcher Properties

WorkDispatcher Properties NFX Class Library

The WorkDispatcher type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters
Public property | Handlers | Returns ordered registry of handlers
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
WorkDispatcher Class
NFX.Wave Namespace


WorkDispatcher.Filters Property

WorkDispatcher Filters Property NFX Class Library

Returns ordered registry of filters

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<WorkFilter> Filters { get; }
public IRegistry<WorkFilter> Filters { get; }
Public ReadOnly Property Filters As IRegistry(Of WorkFilter)
    Get
Public ReadOnly Property Filters As IRegistry(Of WorkFilter)
    Get
public:
property IRegistry<WorkFilter^>^ Filters {
    IRegistry<WorkFilter^>^ get ();
}
public:
property IRegistry<WorkFilter^>^ Filters {
    IRegistry<WorkFilter^>^ get ();
}
member Filters : IRegistry<WorkFilter> with get
member Filters : IRegistry<WorkFilter> with get

Property Value

Type: IRegistry WorkFilter
See Also
WorkDispatcher Class
WorkDispatcher Members
NFX.Wave Namespace


WorkDispatcher.Handlers Property

WorkDispatcher Handlers Property NFX Class Library

Returns ordered registry of handlers

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<WorkHandler> Handlers { get; }
public IRegistry<WorkHandler> Handlers { get; }
Public ReadOnly Property Handlers As IRegistry(Of WorkHandler)
    Get
Public ReadOnly Property Handlers As IRegistry(Of WorkHandler)
    Get
public:
property IRegistry<WorkHandler^>^ Handlers {
    IRegistry<WorkHandler^>^ get ();
}
public:
property IRegistry<WorkHandler^>^ Handlers {
    IRegistry<WorkHandler^>^ get ();
}
member Handlers : IRegistry<WorkHandler> with get
member Handlers : IRegistry<WorkHandler> with get

Property Value

Type: IRegistry WorkHandler
See Also
WorkDispatcher Class
WorkDispatcher Members
NFX.Wave Namespace


WorkFilter Class

WorkFilter Class NFX Class Library

Represents a base for all work filters. Unlike handlers, filters do not necessarily handle work rather augment the work context
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkFilter
NFX.Wave.Filters BeforeAfterFilterBase
NFX.Wave.Filters EffectiveCallerIPEndPointFilter
NFX.Wave.Filters ErrorFilter
NFX.Wave.Filters GeoLookupFilter
NFX.Wave.Filters PortalFilter
NFX.Wave.Filters RedirectFilter
NFX.Wave.Filters SecurityFilter
NFX.Wave.Filters SessionFilter

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class WorkFilter : ApplicationComponent,
    INamed, IOrdered
public abstract class WorkFilter : ApplicationComponent,
    INamed, IOrdered
Public MustInherit Class WorkFilter
    Inherits ApplicationComponent
    Implements INamed, IOrdered
Public MustInherit Class WorkFilter
    Inherits ApplicationComponent
    Implements INamed, IOrdered
public ref class WorkFilter abstract : public ApplicationComponent,
    INamed, IOrdered
public ref class WorkFilter abstract : public ApplicationComponent,
    INamed, IOrdered
[<AbstractClassAttribute>]
type WorkFilter =
    class
        inherit ApplicationComponent
        interface INamed
        interface IOrdered
    end
[<AbstractClassAttribute>]
type WorkFilter =
    class
        inherit ApplicationComponent
        interface INamed
        interface IOrdered
    end
See Also
WorkFilter Members
NFX.Wave Namespace


WorkFilter Members

WorkFilter Members NFX Class Library

The WorkFilter type exposes the following members.
Constructors
 | Name | Description
Protected method | WorkFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the WorkFilter class
Protected method | WorkFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the WorkFilter class
Protected method | WorkFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the WorkFilter class
Protected method | WorkFilter(WorkHandler, String, Int32) | Initializes a new instance of the WorkFilter class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads. Do not forget to call InvokeNextWorker() to continue request processing, otherwise the work will not be handled (which may be a desired behavior)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_FILTER_SECTION |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher
Public property | Name | Returns the filter instance name
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching
Public property | Server | Returns the server that this filter works under
Back to Top
See Also
WorkFilter Class
NFX.Wave Namespace


WorkFilter Constructor

WorkFilter Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | WorkFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the WorkFilter class
Protected method | WorkFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the WorkFilter class
Protected method | WorkFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the WorkFilter class
Protected method | WorkFilter(WorkHandler, String, Int32) | Initializes a new instance of the WorkFilter class
Back to Top
See Also
WorkFilter Class
WorkFilter Members
NFX.Wave Namespace


WorkFilter Constructor (WorkDispatcher, IConfigSectionNode)

WorkFilter Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WorkFilter class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected WorkFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
protected WorkFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
protected:
WorkFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
protected:
WorkFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> WorkFilter
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> WorkFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
WorkFilter Class
WorkFilter Members
WorkFilter Overload
NFX.Wave Namespace


WorkFilter Constructor (WorkHandler, IConfigSectionNode)

WorkFilter Constructor (WorkHandler, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WorkFilter class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected WorkFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
protected WorkFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
Protected Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
Protected Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
protected:
WorkFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
protected:
WorkFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> WorkFilter
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> WorkFilter

Parameters

handler
Type: NFX.Wave WorkHandler
confNode
Type: NFX.Environment IConfigSectionNode
See Also
WorkFilter Class
WorkFilter Members
WorkFilter Overload
NFX.Wave Namespace


WorkFilter Constructor (WorkDispatcher, String, Int32)

WorkFilter Constructor (WorkDispatcher, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WorkFilter class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected WorkFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
protected WorkFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
protected:
WorkFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
protected:
WorkFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> WorkFilter
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> WorkFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
See Also
WorkFilter Class
WorkFilter Members
WorkFilter Overload
NFX.Wave Namespace


WorkFilter Constructor (WorkHandler, String, Int32)

WorkFilter Constructor (WorkHandler, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WorkFilter class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected WorkFilter(
    WorkHandler handler,
    string name,
    int order
)
protected WorkFilter(
    WorkHandler handler,
    string name,
    int order
)
Protected Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
Protected Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
protected:
WorkFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
protected:
WorkFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
new :
        handler : WorkHandler *
        name : string *
        order : int -> WorkFilter
new :
        handler : WorkHandler *
        name : string *
        order : int -> WorkFilter

Parameters

handler
Type: NFX.Wave WorkHandler
name
Type: Online System String
order
Type: Online System Int32
See Also
WorkFilter Class
WorkFilter Members
WorkFilter Overload
NFX.Wave Namespace


WorkFilter Fields

WorkFilter Fields NFX Class Library

The WorkFilter type exposes the following members.
Fields
Name | Description
CONFIG_FILTER_SECTION |
Back to Top
See Also
WorkFilter Class
NFX.Wave Namespace


WorkFilter.CONFIG_FILTER_SECTION Field

WorkFilter CONFIG_FILTER_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FILTER_SECTION
public const string CONFIG_FILTER_SECTION
Public Const CONFIG_FILTER_SECTION As String
Public Const CONFIG_FILTER_SECTION As String
public:
literal String^ CONFIG_FILTER_SECTION
public:
literal String^ CONFIG_FILTER_SECTION
static val mutable CONFIG_FILTER_SECTION: string
static val mutable CONFIG_FILTER_SECTION: string

Field Value

Type: Online String
See Also
WorkFilter Class
WorkFilter Members
NFX.Wave Namespace


WorkFilter Methods

WorkFilter Methods NFX Class Library

The WorkFilter type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads. Do not forget to call InvokeNextWorker() to continue request processing, otherwise the work will not be handled (which may be a desired behavior)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkFilter Class
NFX.Wave Namespace


WorkFilter.DoFilterWork Method

WorkFilter DoFilterWork Method NFX Class Library

Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads. Do not forget to call InvokeNextWorker() to continue request processing, otherwise the work will not be handled (which may be a desired behavior)

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
protected abstract void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
Protected MustOverride Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
Protected MustOverride Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) abstract
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) abstract
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit

Parameters

work
Type: NFX.Wave WorkContext
Work context
filters
Type: Online System.Collections.Generic IList WorkFilter
The filters that participated in a call. Note the Dipatcher.Filters may yield different results as it may change with time, whereas this parameter captures all filters during the call start
thisFilterIndex
Type: Online System Int32
The index of THIS filter in filters
See Also
WorkFilter Class
WorkFilter Members
NFX.Wave Namespace


WorkFilter.FilterWork Method

WorkFilter FilterWork Method NFX Class Library

Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void FilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
public void FilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
Public Sub FilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
Public Sub FilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
public:
void FilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
)
public:
void FilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
)
member FilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
member FilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit

Parameters

work
Type: NFX.Wave WorkContext
Work context
filters
Type: Online System.Collections.Generic IList WorkFilter
The filters that participated in a call. Note the Dipatcher.Filters may yield different results as it may change with time, whereas this parameter captures all filters during the call start
thisFilterIndex
Type: Online System Int32
The index of THIS filter in filters
See Also
WorkFilter Class
WorkFilter Members
NFX.Wave Namespace


WorkFilter.InvokeNextWorker Method

WorkFilter InvokeNextWorker Method NFX Class Library

Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void InvokeNextWorker(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
protected void InvokeNextWorker(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
Protected Sub InvokeNextWorker (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
Protected Sub InvokeNextWorker (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
protected:
void InvokeNextWorker(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
)
protected:
void InvokeNextWorker(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
)
member InvokeNextWorker :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
member InvokeNextWorker :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit

Parameters

work
Type: NFX.Wave WorkContext
filters
Type: Online System.Collections.Generic IList WorkFilter
thisFilterIndex
Type: Online System Int32
See Also
WorkFilter Class
WorkFilter Members
NFX.Wave Namespace


WorkFilter.ToString Method

WorkFilter ToString Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
WorkFilter Class
WorkFilter Members
NFX.Wave Namespace


WorkFilter Properties

WorkFilter Properties NFX Class Library

The WorkFilter type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher
Public property | Name | Returns the filter instance name
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching
Public property | Server | Returns the server that this filter works under
Back to Top
See Also
WorkFilter Class
NFX.Wave Namespace


WorkFilter.Dispatcher Property

WorkFilter Dispatcher Property NFX Class Library

Returns the dispatcher that this filter works under

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkDispatcher Dispatcher { get; }
public WorkDispatcher Dispatcher { get; }
Public ReadOnly Property Dispatcher As WorkDispatcher
    Get
Public ReadOnly Property Dispatcher As WorkDispatcher
    Get
public:
property WorkDispatcher^ Dispatcher {
    WorkDispatcher^ get ();
}
public:
property WorkDispatcher^ Dispatcher {
    WorkDispatcher^ get ();
}
member Dispatcher : WorkDispatcher with get
member Dispatcher : WorkDispatcher with get

Property Value

Type: WorkDispatcher
See Also
WorkFilter Class
WorkFilter Members
NFX.Wave Namespace


WorkFilter.Handler Property

WorkFilter Handler Property NFX Class Library

Returns the handler that this filter works under. May be null if the filter works under dispatcher

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkHandler Handler { get; }
public WorkHandler Handler { get; }
Public ReadOnly Property Handler As WorkHandler
    Get
Public ReadOnly Property Handler As WorkHandler
    Get
public:
property WorkHandler^ Handler {
    WorkHandler^ get ();
}
public:
property WorkHandler^ Handler {
    WorkHandler^ get ();
}
member Handler : WorkHandler with get
member Handler : WorkHandler with get

Property Value

Type: WorkHandler
See Also
WorkFilter Class
WorkFilter Members
NFX.Wave Namespace


WorkFilter.Name Property

WorkFilter Name Property NFX Class Library

Returns the filter instance name

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
WorkFilter Class
WorkFilter Members
NFX.Wave Namespace


WorkFilter.NetGate Property

WorkFilter NetGate Property NFX Class Library

Returns network gate that filter implementation may use to set business variables or null

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public INetGate NetGate { get; }
public INetGate NetGate { get; }
Public ReadOnly Property NetGate As INetGate
    Get
Public ReadOnly Property NetGate As INetGate
    Get
public:
property INetGate^ NetGate {
    INetGate^ get ();
}
public:
property INetGate^ NetGate {
    INetGate^ get ();
}
member NetGate : INetGate with get
member NetGate : INetGate with get

Property Value

Type: INetGate
See Also
WorkFilter Class
WorkFilter Members
NFX.Wave Namespace


WorkFilter.Order Property

WorkFilter Order Property NFX Class Library

Returns the filter order in filter registry. Order is used for URI pattern matching

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Order { get; }
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
Public ReadOnly Property Order As Integer
    Get
public:
virtual property int Order {
    int get () sealed;
}
public:
virtual property int Order {
    int get () sealed;
}
abstract Order : int with get
override Order : int with get
abstract Order : int with get
override Order : int with get

Property Value

Type: Online Int32

Implements

IOrdered Order
See Also
WorkFilter Class
WorkFilter Members
NFX.Wave Namespace


WorkFilter.Server Property

WorkFilter Server Property NFX Class Library

Returns the server that this filter works under

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveServer Server { get; }
public WaveServer Server { get; }
Public ReadOnly Property Server As WaveServer
    Get
Public ReadOnly Property Server As WaveServer
    Get
public:
property WaveServer^ Server {
    WaveServer^ get ();
}
public:
property WaveServer^ Server {
    WaveServer^ get ();
}
member Server : WaveServer with get
member Server : WaveServer with get

Property Value

Type: WaveServer
See Also
WorkFilter Class
WorkFilter Members
NFX.Wave Namespace


WorkHandler Class

WorkHandler Class NFX Class Library

Represents a base for all work handlers. Handlers are final work execution destination
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkHandler
NFX.Wave.Handlers CompositeHandler
NFX.Wave.Handlers ContextDumpHandler
NFX.Wave.Handlers EmbeddedSiteHandler
NFX.Wave.Handlers FileDownloadHandler
NFX.Wave.Handlers NOPHandler
NFX.Wave.Handlers TypeLookupHandler TTarget

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class WorkHandler : ApplicationComponent,
    INamed, IOrdered
public abstract class WorkHandler : ApplicationComponent,
    INamed, IOrdered
Public MustInherit Class WorkHandler
    Inherits ApplicationComponent
    Implements INamed, IOrdered
Public MustInherit Class WorkHandler
    Inherits ApplicationComponent
    Implements INamed, IOrdered
public ref class WorkHandler abstract : public ApplicationComponent,
    INamed, IOrdered
public ref class WorkHandler abstract : public ApplicationComponent,
    INamed, IOrdered
[<AbstractClassAttribute>]
type WorkHandler =
    class
        inherit ApplicationComponent
        interface INamed
        interface IOrdered
    end
[<AbstractClassAttribute>]
type WorkHandler =
    class
        inherit ApplicationComponent
        interface INamed
        interface IOrdered
    end
See Also
WorkHandler Members
NFX.Wave Namespace


WorkHandler Members

WorkHandler Members NFX Class Library

The WorkHandler type exposes the following members.
Constructors
 | Name | Description
Protected method | WorkHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the WorkHandler class
Protected method | WorkHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the WorkHandler class
Back to Top
Methods
 | Name | Description
Protected method | ___setParentHandler |
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoHandleWork | Override to handle the work - i.e. render a template page or call MVC controller method. Note: This method is re-entrant by multiple threads
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests
Public method | ToString | (Overrides Online Object ToString .)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_HANDLER_SECTION |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this handler works under
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches)
Public property | Name | Returns the handler instance name
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching
Public property | ParentHandler | Returns parent handler that this handler is under or null
Public property | Server | Returns the server that this handler works under
Back to Top
See Also
WorkHandler Class
NFX.Wave Namespace


WorkHandler Constructor

WorkHandler Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | WorkHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the WorkHandler class
Protected method | WorkHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the WorkHandler class
Back to Top
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler Constructor (WorkDispatcher, IConfigSectionNode)

WorkHandler Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WorkHandler class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected WorkHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
protected WorkHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
protected:
WorkHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
protected:
WorkHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> WorkHandler
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> WorkHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
WorkHandler Class
WorkHandler Members
WorkHandler Overload
NFX.Wave Namespace


WorkHandler Constructor (WorkDispatcher, String, Int32, WorkMatch)

WorkHandler Constructor (WorkDispatcher, String, Int32, WorkMatch) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WorkHandler class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected WorkHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
protected WorkHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
protected:
WorkHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
protected:
WorkHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> WorkHandler
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> WorkHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
match
Type: NFX.Wave WorkMatch
See Also
WorkHandler Class
WorkHandler Members
WorkHandler Overload
NFX.Wave Namespace


WorkHandler Fields

WorkHandler Fields NFX Class Library

The WorkHandler type exposes the following members.
Fields
Name | Description
CONFIG_HANDLER_SECTION |
Back to Top
See Also
WorkHandler Class
NFX.Wave Namespace


WorkHandler.CONFIG_HANDLER_SECTION Field

WorkHandler CONFIG_HANDLER_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_HANDLER_SECTION
public const string CONFIG_HANDLER_SECTION
Public Const CONFIG_HANDLER_SECTION As String
Public Const CONFIG_HANDLER_SECTION As String
public:
literal String^ CONFIG_HANDLER_SECTION
public:
literal String^ CONFIG_HANDLER_SECTION
static val mutable CONFIG_HANDLER_SECTION: string
static val mutable CONFIG_HANDLER_SECTION: string

Field Value

Type: Online String
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler Methods

WorkHandler Methods NFX Class Library

The WorkHandler type exposes the following members.
Methods
 | Name | Description
Protected method | ___setParentHandler |
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoHandleWork | Override to handle the work - i.e. render a template page or call MVC controller method. Note: This method is re-entrant by multiple threads
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests
Public method | ToString | (Overrides Online Object ToString .)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkHandler Class
NFX.Wave Namespace


WorkHandler.___setParentHandler Method

WorkHandler ___setParentHandler Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void ___setParentHandler(
    WorkHandler parent
)
internal void ___setParentHandler(
    WorkHandler parent
)
Friend Sub ___setParentHandler (
    parent As WorkHandler
)
Friend Sub ___setParentHandler (
    parent As WorkHandler
)
internal:
void ___setParentHandler(
    WorkHandler^ parent
)
internal:
void ___setParentHandler(
    WorkHandler^ parent
)
internal member ___setParentHandler :
        parent : WorkHandler -> unit
internal member ___setParentHandler :
        parent : WorkHandler -> unit

Parameters

parent
Type: NFX.Wave WorkHandler
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.Destructor Method

WorkHandler Destructor Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.DoHandleWork Method

WorkHandler DoHandleWork Method NFX Class Library

Override to handle the work - i.e. render a template page or call MVC controller method. Note: This method is re-entrant by multiple threads

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoHandleWork(
    WorkContext work
)
protected abstract void DoHandleWork(
    WorkContext work
)
Protected MustOverride Sub DoHandleWork (
    work As WorkContext
)
Protected MustOverride Sub DoHandleWork (
    work As WorkContext
)
protected:
virtual void DoHandleWork(
    WorkContext^ work
) abstract
protected:
virtual void DoHandleWork(
    WorkContext^ work
) abstract
abstract DoHandleWork :
        work : WorkContext -> unit
abstract DoHandleWork :
        work : WorkContext -> unit

Parameters

work
Type: NFX.Wave WorkContext
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.FilterAndHandleWork Method

WorkHandler FilterAndHandleWork Method NFX Class Library

Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void FilterAndHandleWork(
    WorkContext work
)
public void FilterAndHandleWork(
    WorkContext work
)
Public Sub FilterAndHandleWork (
    work As WorkContext
)
Public Sub FilterAndHandleWork (
    work As WorkContext
)
public:
void FilterAndHandleWork(
    WorkContext^ work
)
public:
void FilterAndHandleWork(
    WorkContext^ work
)
member FilterAndHandleWork :
        work : WorkContext -> unit
member FilterAndHandleWork :
        work : WorkContext -> unit

Parameters

work
Type: NFX.Wave WorkContext
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.HandleWork Method

WorkHandler HandleWork Method NFX Class Library

Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void HandleWork(
    WorkContext work
)
public void HandleWork(
    WorkContext work
)
Public Sub HandleWork (
    work As WorkContext
)
Public Sub HandleWork (
    work As WorkContext
)
public:
void HandleWork(
    WorkContext^ work
)
public:
void HandleWork(
    WorkContext^ work
)
member HandleWork :
        work : WorkContext -> unit
member HandleWork :
        work : WorkContext -> unit

Parameters

work
Type: NFX.Wave WorkContext
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.MakeMatch Method

WorkHandler MakeMatch Method NFX Class Library

Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool MakeMatch(
    WorkContext work
)
public virtual bool MakeMatch(
    WorkContext work
)
Public Overridable Function MakeMatch (
    work As WorkContext
) As Boolean
Public Overridable Function MakeMatch (
    work As WorkContext
) As Boolean
public:
virtual bool MakeMatch(
    WorkContext^ work
)
public:
virtual bool MakeMatch(
    WorkContext^ work
)
abstract MakeMatch :
        work : WorkContext -> bool
override MakeMatch :
        work : WorkContext -> bool
abstract MakeMatch :
        work : WorkContext -> bool
override MakeMatch :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.RegisterFilter Method

WorkHandler RegisterFilter Method NFX Class Library

Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RegisterFilter(
    WorkFilter filter
)
public bool RegisterFilter(
    WorkFilter filter
)
Public Function RegisterFilter (
    filter As WorkFilter
) As Boolean
Public Function RegisterFilter (
    filter As WorkFilter
) As Boolean
public:
bool RegisterFilter(
    WorkFilter^ filter
)
public:
bool RegisterFilter(
    WorkFilter^ filter
)
member RegisterFilter :
        filter : WorkFilter -> bool
member RegisterFilter :
        filter : WorkFilter -> bool

Parameters

filter
Type: NFX.Wave WorkFilter

Return Value

Type: Online Boolean
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.ToString Method

WorkHandler ToString Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.UnRegisterFilter Method

WorkHandler UnRegisterFilter Method NFX Class Library

Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnRegisterFilter(
    WorkFilter filter
)
public bool UnRegisterFilter(
    WorkFilter filter
)
Public Function UnRegisterFilter (
    filter As WorkFilter
) As Boolean
Public Function UnRegisterFilter (
    filter As WorkFilter
) As Boolean
public:
bool UnRegisterFilter(
    WorkFilter^ filter
)
public:
bool UnRegisterFilter(
    WorkFilter^ filter
)
member UnRegisterFilter :
        filter : WorkFilter -> bool
member UnRegisterFilter :
        filter : WorkFilter -> bool

Parameters

filter
Type: NFX.Wave WorkFilter

Return Value

Type: Online Boolean
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler Properties

WorkHandler Properties NFX Class Library

The WorkHandler type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this handler works under
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches)
Public property | Name | Returns the handler instance name
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching
Public property | ParentHandler | Returns parent handler that this handler is under or null
Public property | Server | Returns the server that this handler works under
Back to Top
See Also
WorkHandler Class
NFX.Wave Namespace


WorkHandler.Dispatcher Property

WorkHandler Dispatcher Property NFX Class Library

Returns the dispatcher that this handler works under

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkDispatcher Dispatcher { get; }
public WorkDispatcher Dispatcher { get; }
Public ReadOnly Property Dispatcher As WorkDispatcher
    Get
Public ReadOnly Property Dispatcher As WorkDispatcher
    Get
public:
property WorkDispatcher^ Dispatcher {
    WorkDispatcher^ get ();
}
public:
property WorkDispatcher^ Dispatcher {
    WorkDispatcher^ get ();
}
member Dispatcher : WorkDispatcher with get
member Dispatcher : WorkDispatcher with get

Property Value

Type: WorkDispatcher
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.Filters Property

WorkHandler Filters Property NFX Class Library

Returns ordered registry of filters

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<WorkFilter> Filters { get; }
public IRegistry<WorkFilter> Filters { get; }
Public ReadOnly Property Filters As IRegistry(Of WorkFilter)
    Get
Public ReadOnly Property Filters As IRegistry(Of WorkFilter)
    Get
public:
property IRegistry<WorkFilter^>^ Filters {
    IRegistry<WorkFilter^>^ get ();
}
public:
property IRegistry<WorkFilter^>^ Filters {
    IRegistry<WorkFilter^>^ get ();
}
member Filters : IRegistry<WorkFilter> with get
member Filters : IRegistry<WorkFilter> with get

Property Value

Type: IRegistry WorkFilter
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.Matches Property

WorkHandler Matches Property NFX Class Library

Returns matches used by this handler. May change the registry at runtime (inject/remove matches)

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<WorkMatch> Matches { get; }
public OrderedRegistry<WorkMatch> Matches { get; }
Public ReadOnly Property Matches As OrderedRegistry(Of WorkMatch)
    Get
Public ReadOnly Property Matches As OrderedRegistry(Of WorkMatch)
    Get
public:
property OrderedRegistry<WorkMatch^>^ Matches {
    OrderedRegistry<WorkMatch^>^ get ();
}
public:
property OrderedRegistry<WorkMatch^>^ Matches {
    OrderedRegistry<WorkMatch^>^ get ();
}
member Matches : OrderedRegistry<WorkMatch> with get
member Matches : OrderedRegistry<WorkMatch> with get

Property Value

Type: OrderedRegistry WorkMatch
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.Name Property

WorkHandler Name Property NFX Class Library

Returns the handler instance name

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.NetGate Property

WorkHandler NetGate Property NFX Class Library

Returns network gate that handler implementation may use to set business variables or null

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public INetGate NetGate { get; }
public INetGate NetGate { get; }
Public ReadOnly Property NetGate As INetGate
    Get
Public ReadOnly Property NetGate As INetGate
    Get
public:
property INetGate^ NetGate {
    INetGate^ get ();
}
public:
property INetGate^ NetGate {
    INetGate^ get ();
}
member NetGate : INetGate with get
member NetGate : INetGate with get

Property Value

Type: INetGate
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.Order Property

WorkHandler Order Property NFX Class Library

Returns the handler order in handler registry. Order is used for URI pattern matching

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Order { get; }
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
Public ReadOnly Property Order As Integer
    Get
public:
virtual property int Order {
    int get () sealed;
}
public:
virtual property int Order {
    int get () sealed;
}
abstract Order : int with get
override Order : int with get
abstract Order : int with get
override Order : int with get

Property Value

Type: Online Int32

Implements

IOrdered Order
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.ParentHandler Property

WorkHandler ParentHandler Property NFX Class Library

Returns parent handler that this handler is under or null

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkHandler ParentHandler { get; }
public WorkHandler ParentHandler { get; }
Public ReadOnly Property ParentHandler As WorkHandler
    Get
Public ReadOnly Property ParentHandler As WorkHandler
    Get
public:
property WorkHandler^ ParentHandler {
    WorkHandler^ get ();
}
public:
property WorkHandler^ ParentHandler {
    WorkHandler^ get ();
}
member ParentHandler : WorkHandler with get
member ParentHandler : WorkHandler with get

Property Value

Type: WorkHandler
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkHandler.Server Property

WorkHandler Server Property NFX Class Library

Returns the server that this handler works under

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveServer Server { get; }
public WaveServer Server { get; }
Public ReadOnly Property Server As WaveServer
    Get
Public ReadOnly Property Server As WaveServer
    Get
public:
property WaveServer^ Server {
    WaveServer^ get ();
}
public:
property WaveServer^ Server {
    WaveServer^ get ();
}
member Server : WaveServer with get
member Server : WaveServer with get

Property Value

Type: WaveServer
See Also
WorkHandler Class
WorkHandler Members
NFX.Wave Namespace


WorkMatch Class

WorkMatch Class NFX Class Library

Decides whether the specifies WorkContext matches the requirements specified in the instance. The match may consider Request and Items properties of work context for match determination. Work matches do not belong to particular handler or filter, so they ARE STATELESS and their instances can be used by multiple different processors (i.e. handlers and filters).
Inheritance Hierarchy
Online System Object
NFX.Wave WorkMatch
NFX.Wave ExceptionMatch
NFX.Wave NotAuthorizationExceptionMatch

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class WorkMatch : INamed, IOrdered
public class WorkMatch : INamed, IOrdered
Public Class WorkMatch
    Implements INamed, IOrdered
Public Class WorkMatch
    Implements INamed, IOrdered
public ref class WorkMatch : INamed,
    IOrdered
public ref class WorkMatch : INamed,
    IOrdered
type WorkMatch =
    class
        interface INamed
        interface IOrdered
    end
type WorkMatch =
    class
        interface INamed
        interface IOrdered
    end
See Also
WorkMatch Members
NFX.Wave Namespace


WorkMatch Members

WorkMatch Members NFX Class Library

The WorkMatch type exposes the following members.
Constructors
 | Name | Description
Public method | WorkMatch(IConfigSectionNode) | Initializes a new instance of the WorkMatch class
Public method | WorkMatch(String, Int32) | Initializes a new instance of the WorkMatch class
Back to Top
Methods
 | Name | Description
Protected method | Check_AbsentCookies |
Protected method | Check_AbsentHeaders |
Protected method | Check_AcceptTypes |
Protected method | Check_ApiVersions |
Protected method | Check_ContentTypes |
Protected method | Check_Cookies |
Protected method | Check_Headers |
Protected method | Check_Hosts |
Protected method | Check_IsLocal |
Protected method | Check_IsSocialNetBot |
Protected method | Check_Methods |
Protected method | Check_Permissions |
Protected method | Check_Ports |
Protected method | Check_Schemes |
Protected method | Check_UserAgents |
Protected method | Check_UserHosts |
Protected method | Check_VariablesAndGetValues |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Make | Decides whether the specified WorkContext makes the match per this instance and if it does, returns the match variables. Returns null if match was not made
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_MATCH_SECTION |
CONFIG_NOT_PATH_ATTR |
CONFIG_PATH_ATTR |
CONFIG_VAR_SECTION |
LIST_DELIMITERS |
Back to Top
Properties
 | Name | Description
Public property | AbsentCookies |
Public property | AbsentHeaders |
Public property | AcceptJson | Shortcut to AcceptTypes contaioning application/json
Public property | AcceptTypes |
Public property | ApiMaxVer |
Public property | ApiMinVer |
Public property | ContentTypes |
Public property | Cookies |
Public property | Headers |
Public property | Hosts |
Public property | IsLocal |
Public property | IsSocialNetBot |
Public property | Methods |
Public property | Name | Returns the match instance name
Public property | NotPathPattern | Returns the URIPattern matcher for reverse URI path segment matching
Public property | Order | Returns the match order in handler registry. Order is used for URI pattern matching. Although Order property can change the match needs to be Unregistered/Registered again with the handler to change pattern matching order
Public property | PathPattern | Returns the URIPattern matcher for URI path segment matching
Public property | Permissions |
Public property | Ports |
Public property | Schemes |
Public property | TypeNsPrefix | Namespace prefix used for type lookups. The prefix uses '/' or '\' path separation char not '.'
Public property | UserAgents |
Public property | UserHosts |
Public property | Variables | Returns registry of variables. May register/unregister variables at runtime
Back to Top
See Also
WorkMatch Class
NFX.Wave Namespace


WorkMatch Constructor

WorkMatch Constructor NFX Class Library

Overload List
 | Name | Description
Public method | WorkMatch(IConfigSectionNode) | Initializes a new instance of the WorkMatch class
Public method | WorkMatch(String, Int32) | Initializes a new instance of the WorkMatch class
Back to Top
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch Constructor (IConfigSectionNode)

WorkMatch Constructor (IConfigSectionNode) NFX Class Library

Initializes a new instance of the WorkMatch class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkMatch(
    IConfigSectionNode confNode
)
public WorkMatch(
    IConfigSectionNode confNode
)
Public Sub New (
    confNode As IConfigSectionNode
)
Public Sub New (
    confNode As IConfigSectionNode
)
public:
WorkMatch(
    IConfigSectionNode^ confNode
)
public:
WorkMatch(
    IConfigSectionNode^ confNode
)
new :
        confNode : IConfigSectionNode -> WorkMatch
new :
        confNode : IConfigSectionNode -> WorkMatch

Parameters

confNode
Type: NFX.Environment IConfigSectionNode
See Also
WorkMatch Class
WorkMatch Members
WorkMatch Overload
NFX.Wave Namespace


WorkMatch Constructor (String, Int32)

WorkMatch Constructor (String, Int32) NFX Class Library

Initializes a new instance of the WorkMatch class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkMatch(
    string name,
    int order
)
public WorkMatch(
    string name,
    int order
)
Public Sub New (
    name As String,
    order As Integer
)
Public Sub New (
    name As String,
    order As Integer
)
public:
WorkMatch(
    String^ name,
    int order
)
public:
WorkMatch(
    String^ name,
    int order
)
new :
        name : string *
        order : int -> WorkMatch
new :
        name : string *
        order : int -> WorkMatch

Parameters

name
Type: Online System String
order
Type: Online System Int32
See Also
WorkMatch Class
WorkMatch Members
WorkMatch Overload
NFX.Wave Namespace


WorkMatch Fields

WorkMatch Fields NFX Class Library

The WorkMatch type exposes the following members.
Fields
Name | Description
CONFIG_MATCH_SECTION |
CONFIG_NOT_PATH_ATTR |
CONFIG_PATH_ATTR |
CONFIG_VAR_SECTION |
LIST_DELIMITERS |
Back to Top
See Also
WorkMatch Class
NFX.Wave Namespace


WorkMatch.CONFIG_MATCH_SECTION Field

WorkMatch CONFIG_MATCH_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_MATCH_SECTION
public const string CONFIG_MATCH_SECTION
Public Const CONFIG_MATCH_SECTION As String
Public Const CONFIG_MATCH_SECTION As String
public:
literal String^ CONFIG_MATCH_SECTION
public:
literal String^ CONFIG_MATCH_SECTION
static val mutable CONFIG_MATCH_SECTION: string
static val mutable CONFIG_MATCH_SECTION: string

Field Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.CONFIG_NOT_PATH_ATTR Field

WorkMatch CONFIG_NOT_PATH_ATTR Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NOT_PATH_ATTR
public const string CONFIG_NOT_PATH_ATTR
Public Const CONFIG_NOT_PATH_ATTR As String
Public Const CONFIG_NOT_PATH_ATTR As String
public:
literal String^ CONFIG_NOT_PATH_ATTR
public:
literal String^ CONFIG_NOT_PATH_ATTR
static val mutable CONFIG_NOT_PATH_ATTR: string
static val mutable CONFIG_NOT_PATH_ATTR: string

Field Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.CONFIG_PATH_ATTR Field

WorkMatch CONFIG_PATH_ATTR Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PATH_ATTR
public const string CONFIG_PATH_ATTR
Public Const CONFIG_PATH_ATTR As String
Public Const CONFIG_PATH_ATTR As String
public:
literal String^ CONFIG_PATH_ATTR
public:
literal String^ CONFIG_PATH_ATTR
static val mutable CONFIG_PATH_ATTR: string
static val mutable CONFIG_PATH_ATTR: string

Field Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.CONFIG_VAR_SECTION Field

WorkMatch CONFIG_VAR_SECTION Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_VAR_SECTION
public const string CONFIG_VAR_SECTION
Public Const CONFIG_VAR_SECTION As String
Public Const CONFIG_VAR_SECTION As String
public:
literal String^ CONFIG_VAR_SECTION
public:
literal String^ CONFIG_VAR_SECTION
static val mutable CONFIG_VAR_SECTION: string
static val mutable CONFIG_VAR_SECTION: string

Field Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.LIST_DELIMITERS Field

WorkMatch LIST_DELIMITERS Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly char[] LIST_DELIMITERS
public static readonly char[] LIST_DELIMITERS
Public Shared ReadOnly LIST_DELIMITERS As Char()
Public Shared ReadOnly LIST_DELIMITERS As Char()
public:
static initonly array<wchar_t>^ LIST_DELIMITERS
public:
static initonly array<wchar_t>^ LIST_DELIMITERS
static val LIST_DELIMITERS: char[]
static val LIST_DELIMITERS: char[]

Field Value

Type: Online Char
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch Methods

WorkMatch Methods NFX Class Library

The WorkMatch type exposes the following members.
Methods
 | Name | Description
Protected method | Check_AbsentCookies |
Protected method | Check_AbsentHeaders |
Protected method | Check_AcceptTypes |
Protected method | Check_ApiVersions |
Protected method | Check_ContentTypes |
Protected method | Check_Cookies |
Protected method | Check_Headers |
Protected method | Check_Hosts |
Protected method | Check_IsLocal |
Protected method | Check_IsSocialNetBot |
Protected method | Check_Methods |
Protected method | Check_Permissions |
Protected method | Check_Ports |
Protected method | Check_Schemes |
Protected method | Check_UserAgents |
Protected method | Check_UserHosts |
Protected method | Check_VariablesAndGetValues |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Make | Decides whether the specified WorkContext makes the match per this instance and if it does, returns the match variables. Returns null if match was not made
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkMatch Class
NFX.Wave Namespace


WorkMatch.Check_AbsentCookies Method

WorkMatch Check_AbsentCookies Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_AbsentCookies(
    WorkContext work
)
protected virtual bool Check_AbsentCookies(
    WorkContext work
)
Protected Overridable Function Check_AbsentCookies (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_AbsentCookies (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_AbsentCookies(
    WorkContext^ work
)
protected:
virtual bool Check_AbsentCookies(
    WorkContext^ work
)
abstract Check_AbsentCookies :
        work : WorkContext -> bool
override Check_AbsentCookies :
        work : WorkContext -> bool
abstract Check_AbsentCookies :
        work : WorkContext -> bool
override Check_AbsentCookies :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_AbsentHeaders Method

WorkMatch Check_AbsentHeaders Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_AbsentHeaders(
    WorkContext work
)
protected virtual bool Check_AbsentHeaders(
    WorkContext work
)
Protected Overridable Function Check_AbsentHeaders (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_AbsentHeaders (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_AbsentHeaders(
    WorkContext^ work
)
protected:
virtual bool Check_AbsentHeaders(
    WorkContext^ work
)
abstract Check_AbsentHeaders :
        work : WorkContext -> bool
override Check_AbsentHeaders :
        work : WorkContext -> bool
abstract Check_AbsentHeaders :
        work : WorkContext -> bool
override Check_AbsentHeaders :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_AcceptTypes Method

WorkMatch Check_AcceptTypes Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_AcceptTypes(
    WorkContext work
)
protected virtual bool Check_AcceptTypes(
    WorkContext work
)
Protected Overridable Function Check_AcceptTypes (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_AcceptTypes (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_AcceptTypes(
    WorkContext^ work
)
protected:
virtual bool Check_AcceptTypes(
    WorkContext^ work
)
abstract Check_AcceptTypes :
        work : WorkContext -> bool
override Check_AcceptTypes :
        work : WorkContext -> bool
abstract Check_AcceptTypes :
        work : WorkContext -> bool
override Check_AcceptTypes :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_ApiVersions Method

WorkMatch Check_ApiVersions Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_ApiVersions(
    WorkContext work
)
protected virtual bool Check_ApiVersions(
    WorkContext work
)
Protected Overridable Function Check_ApiVersions (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_ApiVersions (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_ApiVersions(
    WorkContext^ work
)
protected:
virtual bool Check_ApiVersions(
    WorkContext^ work
)
abstract Check_ApiVersions :
        work : WorkContext -> bool
override Check_ApiVersions :
        work : WorkContext -> bool
abstract Check_ApiVersions :
        work : WorkContext -> bool
override Check_ApiVersions :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_ContentTypes Method

WorkMatch Check_ContentTypes Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_ContentTypes(
    WorkContext work
)
protected virtual bool Check_ContentTypes(
    WorkContext work
)
Protected Overridable Function Check_ContentTypes (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_ContentTypes (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_ContentTypes(
    WorkContext^ work
)
protected:
virtual bool Check_ContentTypes(
    WorkContext^ work
)
abstract Check_ContentTypes :
        work : WorkContext -> bool
override Check_ContentTypes :
        work : WorkContext -> bool
abstract Check_ContentTypes :
        work : WorkContext -> bool
override Check_ContentTypes :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_Cookies Method

WorkMatch Check_Cookies Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_Cookies(
    WorkContext work
)
protected virtual bool Check_Cookies(
    WorkContext work
)
Protected Overridable Function Check_Cookies (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_Cookies (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_Cookies(
    WorkContext^ work
)
protected:
virtual bool Check_Cookies(
    WorkContext^ work
)
abstract Check_Cookies :
        work : WorkContext -> bool
override Check_Cookies :
        work : WorkContext -> bool
abstract Check_Cookies :
        work : WorkContext -> bool
override Check_Cookies :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_Headers Method

WorkMatch Check_Headers Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_Headers(
    WorkContext work
)
protected virtual bool Check_Headers(
    WorkContext work
)
Protected Overridable Function Check_Headers (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_Headers (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_Headers(
    WorkContext^ work
)
protected:
virtual bool Check_Headers(
    WorkContext^ work
)
abstract Check_Headers :
        work : WorkContext -> bool
override Check_Headers :
        work : WorkContext -> bool
abstract Check_Headers :
        work : WorkContext -> bool
override Check_Headers :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_Hosts Method

WorkMatch Check_Hosts Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_Hosts(
    WorkContext work
)
protected virtual bool Check_Hosts(
    WorkContext work
)
Protected Overridable Function Check_Hosts (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_Hosts (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_Hosts(
    WorkContext^ work
)
protected:
virtual bool Check_Hosts(
    WorkContext^ work
)
abstract Check_Hosts :
        work : WorkContext -> bool
override Check_Hosts :
        work : WorkContext -> bool
abstract Check_Hosts :
        work : WorkContext -> bool
override Check_Hosts :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_IsLocal Method

WorkMatch Check_IsLocal Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_IsLocal(
    WorkContext work
)
protected virtual bool Check_IsLocal(
    WorkContext work
)
Protected Overridable Function Check_IsLocal (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_IsLocal (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_IsLocal(
    WorkContext^ work
)
protected:
virtual bool Check_IsLocal(
    WorkContext^ work
)
abstract Check_IsLocal :
        work : WorkContext -> bool
override Check_IsLocal :
        work : WorkContext -> bool
abstract Check_IsLocal :
        work : WorkContext -> bool
override Check_IsLocal :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_IsSocialNetBot Method

WorkMatch Check_IsSocialNetBot Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_IsSocialNetBot(
    WorkContext work
)
protected virtual bool Check_IsSocialNetBot(
    WorkContext work
)
Protected Overridable Function Check_IsSocialNetBot (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_IsSocialNetBot (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_IsSocialNetBot(
    WorkContext^ work
)
protected:
virtual bool Check_IsSocialNetBot(
    WorkContext^ work
)
abstract Check_IsSocialNetBot :
        work : WorkContext -> bool
override Check_IsSocialNetBot :
        work : WorkContext -> bool
abstract Check_IsSocialNetBot :
        work : WorkContext -> bool
override Check_IsSocialNetBot :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_Methods Method

WorkMatch Check_Methods Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_Methods(
    WorkContext work
)
protected virtual bool Check_Methods(
    WorkContext work
)
Protected Overridable Function Check_Methods (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_Methods (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_Methods(
    WorkContext^ work
)
protected:
virtual bool Check_Methods(
    WorkContext^ work
)
abstract Check_Methods :
        work : WorkContext -> bool
override Check_Methods :
        work : WorkContext -> bool
abstract Check_Methods :
        work : WorkContext -> bool
override Check_Methods :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_Permissions Method

WorkMatch Check_Permissions Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_Permissions(
    WorkContext work
)
protected virtual bool Check_Permissions(
    WorkContext work
)
Protected Overridable Function Check_Permissions (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_Permissions (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_Permissions(
    WorkContext^ work
)
protected:
virtual bool Check_Permissions(
    WorkContext^ work
)
abstract Check_Permissions :
        work : WorkContext -> bool
override Check_Permissions :
        work : WorkContext -> bool
abstract Check_Permissions :
        work : WorkContext -> bool
override Check_Permissions :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_Ports Method

WorkMatch Check_Ports Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_Ports(
    WorkContext work
)
protected virtual bool Check_Ports(
    WorkContext work
)
Protected Overridable Function Check_Ports (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_Ports (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_Ports(
    WorkContext^ work
)
protected:
virtual bool Check_Ports(
    WorkContext^ work
)
abstract Check_Ports :
        work : WorkContext -> bool
override Check_Ports :
        work : WorkContext -> bool
abstract Check_Ports :
        work : WorkContext -> bool
override Check_Ports :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_Schemes Method

WorkMatch Check_Schemes Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_Schemes(
    WorkContext work
)
protected virtual bool Check_Schemes(
    WorkContext work
)
Protected Overridable Function Check_Schemes (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_Schemes (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_Schemes(
    WorkContext^ work
)
protected:
virtual bool Check_Schemes(
    WorkContext^ work
)
abstract Check_Schemes :
        work : WorkContext -> bool
override Check_Schemes :
        work : WorkContext -> bool
abstract Check_Schemes :
        work : WorkContext -> bool
override Check_Schemes :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_UserAgents Method

WorkMatch Check_UserAgents Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_UserAgents(
    WorkContext work
)
protected virtual bool Check_UserAgents(
    WorkContext work
)
Protected Overridable Function Check_UserAgents (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_UserAgents (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_UserAgents(
    WorkContext^ work
)
protected:
virtual bool Check_UserAgents(
    WorkContext^ work
)
abstract Check_UserAgents :
        work : WorkContext -> bool
override Check_UserAgents :
        work : WorkContext -> bool
abstract Check_UserAgents :
        work : WorkContext -> bool
override Check_UserAgents :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_UserHosts Method

WorkMatch Check_UserHosts Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_UserHosts(
    WorkContext work
)
protected virtual bool Check_UserHosts(
    WorkContext work
)
Protected Overridable Function Check_UserHosts (
    work As WorkContext
) As Boolean
Protected Overridable Function Check_UserHosts (
    work As WorkContext
) As Boolean
protected:
virtual bool Check_UserHosts(
    WorkContext^ work
)
protected:
virtual bool Check_UserHosts(
    WorkContext^ work
)
abstract Check_UserHosts :
        work : WorkContext -> bool
override Check_UserHosts :
        work : WorkContext -> bool
abstract Check_UserHosts :
        work : WorkContext -> bool
override Check_UserHosts :
        work : WorkContext -> bool

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Check_VariablesAndGetValues Method

WorkMatch Check_VariablesAndGetValues Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_VariablesAndGetValues(
    WorkContext work,
    ref JSONDataMap result
)
protected virtual bool Check_VariablesAndGetValues(
    WorkContext work,
    ref JSONDataMap result
)
Protected Overridable Function Check_VariablesAndGetValues (
    work As WorkContext,
    ByRef result As JSONDataMap
) As Boolean
Protected Overridable Function Check_VariablesAndGetValues (
    work As WorkContext,
    ByRef result As JSONDataMap
) As Boolean
protected:
virtual bool Check_VariablesAndGetValues(
    WorkContext^ work,
    JSONDataMap^% result
)
protected:
virtual bool Check_VariablesAndGetValues(
    WorkContext^ work,
    JSONDataMap^% result
)
abstract Check_VariablesAndGetValues :
        work : WorkContext *
        result : JSONDataMap byref -> bool
override Check_VariablesAndGetValues :
        work : WorkContext *
        result : JSONDataMap byref -> bool
abstract Check_VariablesAndGetValues :
        work : WorkContext *
        result : JSONDataMap byref -> bool
override Check_VariablesAndGetValues :
        work : WorkContext *
        result : JSONDataMap byref -> bool

Parameters

work
Type: NFX.Wave WorkContext
result
Type: NFX.Serialization.JSON JSONDataMap

Return Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Make Method

WorkMatch Make Method NFX Class Library

Decides whether the specified WorkContext makes the match per this instance and if it does, returns the match variables. Returns null if match was not made

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual JSONDataMap Make(
    WorkContext work,
    Object context = null
)
public virtual JSONDataMap Make(
    WorkContext work,
    Object context = null
)
Public Overridable Function Make (
    work As WorkContext,
    Optional context As Object = Nothing
) As JSONDataMap
Public Overridable Function Make (
    work As WorkContext,
    Optional context As Object = Nothing
) As JSONDataMap
public:
virtual JSONDataMap^ Make(
    WorkContext^ work,
    Object^ context = nullptr
)
public:
virtual JSONDataMap^ Make(
    WorkContext^ work,
    Object^ context = nullptr
)
abstract Make :
        work : WorkContext *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> JSONDataMap
override Make :
        work : WorkContext *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> JSONDataMap
abstract Make :
        work : WorkContext *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> JSONDataMap
override Make :
        work : WorkContext *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> JSONDataMap

Parameters

work
Type: NFX.Wave WorkContext
context (Optional)
Type: Online System Object

Return Value

Type: JSONDataMap
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch Properties

WorkMatch Properties NFX Class Library

The WorkMatch type exposes the following members.
Properties
 | Name | Description
Public property | AbsentCookies |
Public property | AbsentHeaders |
Public property | AcceptJson | Shortcut to AcceptTypes contaioning application/json
Public property | AcceptTypes |
Public property | ApiMaxVer |
Public property | ApiMinVer |
Public property | ContentTypes |
Public property | Cookies |
Public property | Headers |
Public property | Hosts |
Public property | IsLocal |
Public property | IsSocialNetBot |
Public property | Methods |
Public property | Name | Returns the match instance name
Public property | NotPathPattern | Returns the URIPattern matcher for reverse URI path segment matching
Public property | Order | Returns the match order in handler registry. Order is used for URI pattern matching. Although Order property can change the match needs to be Unregistered/Registered again with the handler to change pattern matching order
Public property | PathPattern | Returns the URIPattern matcher for URI path segment matching
Public property | Permissions |
Public property | Ports |
Public property | Schemes |
Public property | TypeNsPrefix | Namespace prefix used for type lookups. The prefix uses '/' or '\' path separation char not '.'
Public property | UserAgents |
Public property | UserHosts |
Public property | Variables | Returns registry of variables. May register/unregister variables at runtime
Back to Top
See Also
WorkMatch Class
NFX.Wave Namespace


WorkMatch.AbsentCookies Property

WorkMatch AbsentCookies Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string AbsentCookies { get; set; }
[ConfigAttribute]
public string AbsentCookies { get; set; }
<ConfigAttribute>
Public Property AbsentCookies As String
    Get
    Set
<ConfigAttribute>
Public Property AbsentCookies As String
    Get
    Set
public:
[ConfigAttribute]
property String^ AbsentCookies {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ AbsentCookies {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member AbsentCookies : string with get, set
[<ConfigAttribute>]
member AbsentCookies : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.AbsentHeaders Property

WorkMatch AbsentHeaders Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string AbsentHeaders { get; set; }
[ConfigAttribute]
public string AbsentHeaders { get; set; }
<ConfigAttribute>
Public Property AbsentHeaders As String
    Get
    Set
<ConfigAttribute>
Public Property AbsentHeaders As String
    Get
    Set
public:
[ConfigAttribute]
property String^ AbsentHeaders {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ AbsentHeaders {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member AbsentHeaders : string with get, set
[<ConfigAttribute>]
member AbsentHeaders : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.AcceptJson Property

WorkMatch AcceptJson Property NFX Class Library

Shortcut to AcceptTypes contaioning application/json

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool AcceptJson { get; set; }
[ConfigAttribute]
public bool AcceptJson { get; set; }
<ConfigAttribute>
Public Property AcceptJson As Boolean
    Get
    Set
<ConfigAttribute>
Public Property AcceptJson As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool AcceptJson {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool AcceptJson {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member AcceptJson : bool with get, set
[<ConfigAttribute>]
member AcceptJson : bool with get, set

Property Value

Type: Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.AcceptTypes Property

WorkMatch AcceptTypes Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string AcceptTypes { get; set; }
[ConfigAttribute]
public string AcceptTypes { get; set; }
<ConfigAttribute>
Public Property AcceptTypes As String
    Get
    Set
<ConfigAttribute>
Public Property AcceptTypes As String
    Get
    Set
public:
[ConfigAttribute]
property String^ AcceptTypes {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ AcceptTypes {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member AcceptTypes : string with get, set
[<ConfigAttribute>]
member AcceptTypes : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.ApiMaxVer Property

WorkMatch ApiMaxVer Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public Nullable<int> ApiMaxVer { get; set; }
[ConfigAttribute]
public Nullable<int> ApiMaxVer { get; set; }
<ConfigAttribute>
Public Property ApiMaxVer As Nullable(Of Integer)
    Get
    Set
<ConfigAttribute>
Public Property ApiMaxVer As Nullable(Of Integer)
    Get
    Set
public:
[ConfigAttribute]
property Nullable<int> ApiMaxVer {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
public:
[ConfigAttribute]
property Nullable<int> ApiMaxVer {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
[<ConfigAttribute>]
member ApiMaxVer : Nullable<int> with get, set
[<ConfigAttribute>]
member ApiMaxVer : Nullable<int> with get, set

Property Value

Type: Online Nullable Online Int32
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.ApiMinVer Property

WorkMatch ApiMinVer Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public Nullable<int> ApiMinVer { get; set; }
[ConfigAttribute]
public Nullable<int> ApiMinVer { get; set; }
<ConfigAttribute>
Public Property ApiMinVer As Nullable(Of Integer)
    Get
    Set
<ConfigAttribute>
Public Property ApiMinVer As Nullable(Of Integer)
    Get
    Set
public:
[ConfigAttribute]
property Nullable<int> ApiMinVer {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
public:
[ConfigAttribute]
property Nullable<int> ApiMinVer {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
[<ConfigAttribute>]
member ApiMinVer : Nullable<int> with get, set
[<ConfigAttribute>]
member ApiMinVer : Nullable<int> with get, set

Property Value

Type: Online Nullable Online Int32
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.ContentTypes Property

WorkMatch ContentTypes Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string ContentTypes { get; set; }
[ConfigAttribute]
public string ContentTypes { get; set; }
<ConfigAttribute>
Public Property ContentTypes As String
    Get
    Set
<ConfigAttribute>
Public Property ContentTypes As String
    Get
    Set
public:
[ConfigAttribute]
property String^ ContentTypes {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ ContentTypes {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member ContentTypes : string with get, set
[<ConfigAttribute>]
member ContentTypes : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Cookies Property

WorkMatch Cookies Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Cookies { get; set; }
[ConfigAttribute]
public string Cookies { get; set; }
<ConfigAttribute>
Public Property Cookies As String
    Get
    Set
<ConfigAttribute>
Public Property Cookies As String
    Get
    Set
public:
[ConfigAttribute]
property String^ Cookies {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ Cookies {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member Cookies : string with get, set
[<ConfigAttribute>]
member Cookies : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Headers Property

WorkMatch Headers Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Headers { get; set; }
[ConfigAttribute]
public string Headers { get; set; }
<ConfigAttribute>
Public Property Headers As String
    Get
    Set
<ConfigAttribute>
Public Property Headers As String
    Get
    Set
public:
[ConfigAttribute]
property String^ Headers {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ Headers {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member Headers : string with get, set
[<ConfigAttribute>]
member Headers : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Hosts Property

WorkMatch Hosts Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Hosts { get; set; }
[ConfigAttribute]
public string Hosts { get; set; }
<ConfigAttribute>
Public Property Hosts As String
    Get
    Set
<ConfigAttribute>
Public Property Hosts As String
    Get
    Set
public:
[ConfigAttribute]
property String^ Hosts {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ Hosts {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member Hosts : string with get, set
[<ConfigAttribute>]
member Hosts : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.IsLocal Property

WorkMatch IsLocal Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public Nullable<bool> IsLocal { get; set; }
[ConfigAttribute]
public Nullable<bool> IsLocal { get; set; }
<ConfigAttribute>
Public Property IsLocal As Nullable(Of Boolean)
    Get
    Set
<ConfigAttribute>
Public Property IsLocal As Nullable(Of Boolean)
    Get
    Set
public:
[ConfigAttribute]
property Nullable<bool> IsLocal {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
public:
[ConfigAttribute]
property Nullable<bool> IsLocal {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
[<ConfigAttribute>]
member IsLocal : Nullable<bool> with get, set
[<ConfigAttribute>]
member IsLocal : Nullable<bool> with get, set

Property Value

Type: Online Nullable Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.IsSocialNetBot Property

WorkMatch IsSocialNetBot Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public Nullable<bool> IsSocialNetBot { get; set; }
[ConfigAttribute]
public Nullable<bool> IsSocialNetBot { get; set; }
<ConfigAttribute>
Public Property IsSocialNetBot As Nullable(Of Boolean)
    Get
    Set
<ConfigAttribute>
Public Property IsSocialNetBot As Nullable(Of Boolean)
    Get
    Set
public:
[ConfigAttribute]
property Nullable<bool> IsSocialNetBot {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
public:
[ConfigAttribute]
property Nullable<bool> IsSocialNetBot {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
[<ConfigAttribute>]
member IsSocialNetBot : Nullable<bool> with get, set
[<ConfigAttribute>]
member IsSocialNetBot : Nullable<bool> with get, set

Property Value

Type: Online Nullable Online Boolean
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Methods Property

WorkMatch Methods Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Methods { get; set; }
[ConfigAttribute]
public string Methods { get; set; }
<ConfigAttribute>
Public Property Methods As String
    Get
    Set
<ConfigAttribute>
Public Property Methods As String
    Get
    Set
public:
[ConfigAttribute]
property String^ Methods {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ Methods {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member Methods : string with get, set
[<ConfigAttribute>]
member Methods : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Name Property

WorkMatch Name Property NFX Class Library

Returns the match instance name

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.NotPathPattern Property

WorkMatch NotPathPattern Property NFX Class Library

Returns the URIPattern matcher for reverse URI path segment matching

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public URIPattern NotPathPattern { get; set; }
public URIPattern NotPathPattern { get; set; }
Public Property NotPathPattern As URIPattern
    Get
    Set
Public Property NotPathPattern As URIPattern
    Get
    Set
public:
property URIPattern^ NotPathPattern {
    URIPattern^ get ();
    void set (URIPattern^ value);
}
public:
property URIPattern^ NotPathPattern {
    URIPattern^ get ();
    void set (URIPattern^ value);
}
member NotPathPattern : URIPattern with get, set
member NotPathPattern : URIPattern with get, set

Property Value

Type: URIPattern
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Order Property

WorkMatch Order Property NFX Class Library

Returns the match order in handler registry. Order is used for URI pattern matching. Although Order property can change the match needs to be Unregistered/Registered again with the handler to change pattern matching order

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Order { get; set; }
public int Order { get; set; }
Public Property Order As Integer
    Get
    Set
Public Property Order As Integer
    Get
    Set
public:
virtual property int Order {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int Order {
    int get () sealed;
    void set (int value) sealed;
}
abstract Order : int with get, set
override Order : int with get, set
abstract Order : int with get, set
override Order : int with get, set

Property Value

Type: Online Int32

Implements

IOrdered Order
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.PathPattern Property

WorkMatch PathPattern Property NFX Class Library

Returns the URIPattern matcher for URI path segment matching

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public URIPattern PathPattern { get; set; }
public URIPattern PathPattern { get; set; }
Public Property PathPattern As URIPattern
    Get
    Set
Public Property PathPattern As URIPattern
    Get
    Set
public:
property URIPattern^ PathPattern {
    URIPattern^ get ();
    void set (URIPattern^ value);
}
public:
property URIPattern^ PathPattern {
    URIPattern^ get ();
    void set (URIPattern^ value);
}
member PathPattern : URIPattern with get, set
member PathPattern : URIPattern with get, set

Property Value

Type: URIPattern
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Permissions Property

WorkMatch Permissions Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Permission> Permissions { get; set; }
public IEnumerable<Permission> Permissions { get; set; }
Public Property Permissions As IEnumerable(Of Permission)
    Get
    Set
Public Property Permissions As IEnumerable(Of Permission)
    Get
    Set
public:
property IEnumerable<Permission^>^ Permissions {
    IEnumerable<Permission^>^ get ();
    void set (IEnumerable<Permission^>^ value);
}
public:
property IEnumerable<Permission^>^ Permissions {
    IEnumerable<Permission^>^ get ();
    void set (IEnumerable<Permission^>^ value);
}
member Permissions : IEnumerable<Permission> with get, set
member Permissions : IEnumerable<Permission> with get, set

Property Value

Type: Online IEnumerable Permission
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Ports Property

WorkMatch Ports Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Ports { get; set; }
[ConfigAttribute]
public string Ports { get; set; }
<ConfigAttribute>
Public Property Ports As String
    Get
    Set
<ConfigAttribute>
Public Property Ports As String
    Get
    Set
public:
[ConfigAttribute]
property String^ Ports {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ Ports {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member Ports : string with get, set
[<ConfigAttribute>]
member Ports : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Schemes Property

WorkMatch Schemes Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Schemes { get; set; }
[ConfigAttribute]
public string Schemes { get; set; }
<ConfigAttribute>
Public Property Schemes As String
    Get
    Set
<ConfigAttribute>
Public Property Schemes As String
    Get
    Set
public:
[ConfigAttribute]
property String^ Schemes {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ Schemes {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member Schemes : string with get, set
[<ConfigAttribute>]
member Schemes : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.TypeNsPrefix Property

WorkMatch TypeNsPrefix Property NFX Class Library

Namespace prefix used for type lookups. The prefix uses '/' or '\' path separation char not '.'

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string TypeNsPrefix { get; set; }
[ConfigAttribute]
public string TypeNsPrefix { get; set; }
<ConfigAttribute>
Public Property TypeNsPrefix As String
    Get
    Set
<ConfigAttribute>
Public Property TypeNsPrefix As String
    Get
    Set
public:
[ConfigAttribute]
property String^ TypeNsPrefix {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ TypeNsPrefix {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member TypeNsPrefix : string with get, set
[<ConfigAttribute>]
member TypeNsPrefix : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.UserAgents Property

WorkMatch UserAgents Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string UserAgents { get; set; }
[ConfigAttribute]
public string UserAgents { get; set; }
<ConfigAttribute>
Public Property UserAgents As String
    Get
    Set
<ConfigAttribute>
Public Property UserAgents As String
    Get
    Set
public:
[ConfigAttribute]
property String^ UserAgents {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ UserAgents {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member UserAgents : string with get, set
[<ConfigAttribute>]
member UserAgents : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.UserHosts Property

WorkMatch UserHosts Property NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string UserHosts { get; set; }
[ConfigAttribute]
public string UserHosts { get; set; }
<ConfigAttribute>
Public Property UserHosts As String
    Get
    Set
<ConfigAttribute>
Public Property UserHosts As String
    Get
    Set
public:
[ConfigAttribute]
property String^ UserHosts {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ UserHosts {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member UserHosts : string with get, set
[<ConfigAttribute>]
member UserHosts : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.Variables Property

WorkMatch Variables Property NFX Class Library

Returns registry of variables. May register/unregister variables at runtime

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Registry<WorkMatch..::..Variable> Variables { get; }
public Registry<WorkMatch..::..Variable> Variables { get; }
Public ReadOnly Property Variables As Registry(Of WorkMatch..::..Variable)
    Get
Public ReadOnly Property Variables As Registry(Of WorkMatch..::..Variable)
    Get
public:
property Registry<WorkMatch..::..Variable^>^ Variables {
    Registry<WorkMatch..::..Variable^>^ get ();
}
public:
property Registry<WorkMatch..::..Variable^>^ Variables {
    Registry<WorkMatch..::..Variable^>^ get ();
}
member Variables : Registry<WorkMatch..::..Variable> with get
member Variables : Registry<WorkMatch..::..Variable> with get

Property Value

Type: Registry WorkMatch Variable
See Also
WorkMatch Class
WorkMatch Members
NFX.Wave Namespace


WorkMatch.NameValuePair Structure

WorkMatch NameValuePair Structure NFX Class Library

Represents name/value tuple

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct NameValuePair
public struct NameValuePair
Public Structure NameValuePair
Public Structure NameValuePair
public value class NameValuePair
public value class NameValuePair
[<SealedAttribute>]
type NameValuePair =  struct end
[<SealedAttribute>]
type NameValuePair =  struct end
See Also
WorkMatch NameValuePair Members
NFX.Wave Namespace


WorkMatch.NameValuePair Members

WorkMatch NameValuePair Members NFX Class Library

The WorkMatch NameValuePair type exposes the following members.
Constructors
 | Name | Description
Public method | WorkMatch NameValuePair | Initializes a new instance of the WorkMatch NameValuePair class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ParseList | Converts a string with a list of separated pairs into a list i.e. "a=1;b=2"
Public method | ToString | (Overrides Online ValueType ToString .)
 | ToStringList | Joins NameValuePair sequence into a string list i.e. "a=1;b=2"
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Name |
Public field | Value |
Back to Top
See Also
WorkMatch NameValuePair Structure
NFX.Wave Namespace


WorkMatch.NameValuePair Constructor

WorkMatch NameValuePair Constructor NFX Class Library

Initializes a new instance of the WorkMatch NameValuePair class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NameValuePair(
    string name,
    string value
)
public NameValuePair(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
Public Sub New (
    name As String,
    value As String
)
public:
NameValuePair(
    String^ name,
    String^ value
)
public:
NameValuePair(
    String^ name,
    String^ value
)
new :
        name : string *
        value : string -> NameValuePair
new :
        name : string *
        value : string -> NameValuePair

Parameters

name
Type: Online System String
value
Type: Online System String
See Also
WorkMatch NameValuePair Structure
WorkMatch NameValuePair Members
NFX.Wave Namespace


WorkMatch.NameValuePair Fields

WorkMatch NameValuePair Fields NFX Class Library

The WorkMatch NameValuePair type exposes the following members.
Fields
 | Name | Description
Public field | Name |
Public field | Value |
Back to Top
See Also
WorkMatch NameValuePair Structure
NFX.Wave Namespace


WorkMatch.NameValuePair.Name Field

WorkMatch NameValuePair Name Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Name
public readonly string Name
Public ReadOnly Name As String
Public ReadOnly Name As String
public:
initonly String^ Name
public:
initonly String^ Name
val Name: string
val Name: string

Field Value

Type: Online String
See Also
WorkMatch NameValuePair Structure
WorkMatch NameValuePair Members
NFX.Wave Namespace


WorkMatch.NameValuePair.Value Field

WorkMatch NameValuePair Value Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Value
public readonly string Value
Public ReadOnly Value As String
Public ReadOnly Value As String
public:
initonly String^ Value
public:
initonly String^ Value
val Value: string
val Value: string

Field Value

Type: Online String
See Also
WorkMatch NameValuePair Structure
WorkMatch NameValuePair Members
NFX.Wave Namespace


WorkMatch.NameValuePair Methods

WorkMatch NameValuePair Methods NFX Class Library

The WorkMatch NameValuePair type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ParseList | Converts a string with a list of separated pairs into a list i.e. "a=1;b=2"
Public method | ToString | (Overrides Online ValueType ToString .)
 | ToStringList | Joins NameValuePair sequence into a string list i.e. "a=1;b=2"
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkMatch NameValuePair Structure
NFX.Wave Namespace


WorkMatch.NameValuePair.ParseList Method

WorkMatch NameValuePair ParseList Method NFX Class Library

Converts a string with a list of separated pairs into a list i.e. "a=1;b=2"

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<WorkMatch..::..NameValuePair> ParseList(
    string list
)
public static List<WorkMatch..::..NameValuePair> ParseList(
    string list
)
Public Shared Function ParseList (
    list As String
) As List(Of WorkMatch..::..NameValuePair)
Public Shared Function ParseList (
    list As String
) As List(Of WorkMatch..::..NameValuePair)
public:
static List<WorkMatch..::..NameValuePair>^ ParseList(
    String^ list
)
public:
static List<WorkMatch..::..NameValuePair>^ ParseList(
    String^ list
)
static member ParseList :
        list : string -> List<WorkMatch..::..NameValuePair>
static member ParseList :
        list : string -> List<WorkMatch..::..NameValuePair>

Parameters

list
Type: Online System String

Return Value

Type: Online List WorkMatch NameValuePair
See Also
WorkMatch NameValuePair Structure
WorkMatch NameValuePair Members
NFX.Wave Namespace


WorkMatch.NameValuePair.ToString Method

WorkMatch NameValuePair ToString Method NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
WorkMatch NameValuePair Structure
WorkMatch NameValuePair Members
NFX.Wave Namespace


WorkMatch.NameValuePair.ToStringList Method

WorkMatch NameValuePair ToStringList Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Joins NameValuePair sequence into a string list i.e. "a=1;b=2"

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToStringList(
    IEnumerable<WorkMatch..::..NameValuePair> list
)
public static string ToStringList(
    IEnumerable<WorkMatch..::..NameValuePair> list
)
Public Shared Function ToStringList (
    list As IEnumerable(Of WorkMatch..::..NameValuePair)
) As String
Public Shared Function ToStringList (
    list As IEnumerable(Of WorkMatch..::..NameValuePair)
) As String
public:
static String^ ToStringList(
    IEnumerable<WorkMatch..::..NameValuePair>^ list
)
public:
static String^ ToStringList(
    IEnumerable<WorkMatch..::..NameValuePair>^ list
)
static member ToStringList :
        list : IEnumerable<WorkMatch..::..NameValuePair> -> string
static member ToStringList :
        list : IEnumerable<WorkMatch..::..NameValuePair> -> string

Parameters

list
Type: Online System.Collections.Generic IEnumerable WorkMatch NameValuePair

Return Value

Type: Online String
See Also
WorkMatch NameValuePair Structure
WorkMatch NameValuePair Members
NFX.Wave Namespace


WorkMatch.Variable Class

WorkMatch Variable Class NFX Class Library

Represents capture variable
Inheritance Hierarchy
Online System Object
NFX.Wave WorkMatch Variable

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Variable : INamed
public class Variable : INamed
Public Class Variable
    Implements INamed
Public Class Variable
    Implements INamed
public ref class Variable : INamed
public ref class Variable : INamed
type Variable =
    class
        interface INamed
    end
type Variable =
    class
        interface INamed
    end
See Also
WorkMatch Variable Members
NFX.Wave Namespace


WorkMatch.Variable Members

WorkMatch Variable Members NFX Class Library

The WorkMatch Variable type exposes the following members.
Constructors
 | Name | Description
Public method | WorkMatch Variable(String) | Initializes a new instance of the WorkMatch Variable class
Public method | WorkMatch Variable(IConfigSectionNode) | Initializes a new instance of the WorkMatch Variable class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
QUERY_NAME_WC |
Back to Top
Properties
 | Name | Description
Public property | Default | Default value if no URI match could be made
Public property | MatchCaseSensitive | Optional value comparison case sensitivity for the whole match to succeed
Public property | MatchContains | Optional value that must be contained in the captured value for the whole match to succeed
Public property | MatchEquals | Optional value that must exactly equal the captured value for the whole match to succeed
Public property | Name | Name of variable
Public property | QueryName | Name of URI query variable to fetch into this variable
Back to Top
See Also
WorkMatch Variable Class
NFX.Wave Namespace


WorkMatch.Variable Constructor

WorkMatch Variable Constructor NFX Class Library

Overload List
 | Name | Description
Public method | WorkMatch Variable(String) | Initializes a new instance of the WorkMatch Variable class
Public method | WorkMatch Variable(IConfigSectionNode) | Initializes a new instance of the WorkMatch Variable class
Back to Top
See Also
WorkMatch Variable Class
WorkMatch Variable Members
NFX.Wave Namespace


WorkMatch.Variable Constructor (String)

WorkMatch Variable Constructor (String) NFX Class Library

Initializes a new instance of the WorkMatch Variable class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Variable(
    string name
)
public Variable(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
Variable(
    String^ name
)
public:
Variable(
    String^ name
)
new :
        name : string -> Variable
new :
        name : string -> Variable

Parameters

name
Type: Online System String
See Also
WorkMatch Variable Class
WorkMatch Variable Members
WorkMatch Variable Overload
NFX.Wave Namespace


WorkMatch.Variable Constructor (IConfigSectionNode)

WorkMatch Variable Constructor (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WorkMatch Variable class

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Variable(
    IConfigSectionNode confNode
)
public Variable(
    IConfigSectionNode confNode
)
Public Sub New (
    confNode As IConfigSectionNode
)
Public Sub New (
    confNode As IConfigSectionNode
)
public:
Variable(
    IConfigSectionNode^ confNode
)
public:
Variable(
    IConfigSectionNode^ confNode
)
new :
        confNode : IConfigSectionNode -> Variable
new :
        confNode : IConfigSectionNode -> Variable

Parameters

confNode
Type: NFX.Environment IConfigSectionNode
See Also
WorkMatch Variable Class
WorkMatch Variable Members
WorkMatch Variable Overload
NFX.Wave Namespace


WorkMatch.Variable Fields

WorkMatch Variable Fields NFX Class Library

The WorkMatch Variable type exposes the following members.
Fields
Name | Description
QUERY_NAME_WC |
Back to Top
See Also
WorkMatch Variable Class
NFX.Wave Namespace


WorkMatch.Variable.QUERY_NAME_WC Field

WorkMatch Variable QUERY_NAME_WC Field NFX Class Library

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string QUERY_NAME_WC
public const string QUERY_NAME_WC
Public Const QUERY_NAME_WC As String
Public Const QUERY_NAME_WC As String
public:
literal String^ QUERY_NAME_WC
public:
literal String^ QUERY_NAME_WC
static val mutable QUERY_NAME_WC: string
static val mutable QUERY_NAME_WC: string

Field Value

Type: Online String
See Also
WorkMatch Variable Class
WorkMatch Variable Members
NFX.Wave Namespace


WorkMatch.Variable Methods

WorkMatch Variable Methods NFX Class Library

The WorkMatch Variable type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkMatch Variable Class
NFX.Wave Namespace


WorkMatch.Variable Properties

WorkMatch Variable Properties NFX Class Library

The WorkMatch Variable type exposes the following members.
Properties
 | Name | Description
Public property | Default | Default value if no URI match could be made
Public property | MatchCaseSensitive | Optional value comparison case sensitivity for the whole match to succeed
Public property | MatchContains | Optional value that must be contained in the captured value for the whole match to succeed
Public property | MatchEquals | Optional value that must exactly equal the captured value for the whole match to succeed
Public property | Name | Name of variable
Public property | QueryName | Name of URI query variable to fetch into this variable
Back to Top
See Also
WorkMatch Variable Class
NFX.Wave Namespace


WorkMatch.Variable.Default Property

WorkMatch Variable Default Property NFX Class Library

Default value if no URI match could be made

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Default { get; set; }
public string Default { get; set; }
Public Property Default As String
    Get
    Set
Public Property Default As String
    Get
    Set
public:
property String^ Default {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Default {
    String^ get ();
    void set (String^ value);
}
member Default : string with get, set
member Default : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Variable Class
WorkMatch Variable Members
NFX.Wave Namespace


WorkMatch.Variable.MatchCaseSensitive Property

WorkMatch Variable MatchCaseSensitive Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Optional value comparison case sensitivity for the whole match to succeed

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MatchCaseSensitive { get; set; }
public bool MatchCaseSensitive { get; set; }
Public Property MatchCaseSensitive As Boolean
    Get
    Set
Public Property MatchCaseSensitive As Boolean
    Get
    Set
public:
property bool MatchCaseSensitive {
    bool get ();
    void set (bool value);
}
public:
property bool MatchCaseSensitive {
    bool get ();
    void set (bool value);
}
member MatchCaseSensitive : bool with get, set
member MatchCaseSensitive : bool with get, set

Property Value

Type: Online Boolean
See Also
WorkMatch Variable Class
WorkMatch Variable Members
NFX.Wave Namespace


WorkMatch.Variable.MatchContains Property

WorkMatch Variable MatchContains Property NFX Class Library

Optional value that must be contained in the captured value for the whole match to succeed

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MatchContains { get; set; }
public string MatchContains { get; set; }
Public Property MatchContains As String
    Get
    Set
Public Property MatchContains As String
    Get
    Set
public:
property String^ MatchContains {
    String^ get ();
    void set (String^ value);
}
public:
property String^ MatchContains {
    String^ get ();
    void set (String^ value);
}
member MatchContains : string with get, set
member MatchContains : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Variable Class
WorkMatch Variable Members
NFX.Wave Namespace


WorkMatch.Variable.MatchEquals Property

WorkMatch Variable MatchEquals Property NFX Class Library

Optional value that must exactly equal the captured value for the whole match to succeed

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MatchEquals { get; set; }
public string MatchEquals { get; set; }
Public Property MatchEquals As String
    Get
    Set
Public Property MatchEquals As String
    Get
    Set
public:
property String^ MatchEquals {
    String^ get ();
    void set (String^ value);
}
public:
property String^ MatchEquals {
    String^ get ();
    void set (String^ value);
}
member MatchEquals : string with get, set
member MatchEquals : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Variable Class
WorkMatch Variable Members
NFX.Wave Namespace


WorkMatch.Variable.Name Property

WorkMatch Variable Name Property NFX Class Library

Name of variable

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
WorkMatch Variable Class
WorkMatch Variable Members
NFX.Wave Namespace


WorkMatch.Variable.QueryName Property

WorkMatch Variable QueryName Property NFX Class Library

Name of URI query variable to fetch into this variable

Namespace: NFX.Wave
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string QueryName { get; set; }
public string QueryName { get; set; }
Public Property QueryName As String
    Get
    Set
Public Property QueryName As String
    Get
    Set
public:
property String^ QueryName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ QueryName {
    String^ get ();
    void set (String^ value);
}
member QueryName : string with get, set
member QueryName : string with get, set

Property Value

Type: Online String
See Also
WorkMatch Variable Class
WorkMatch Variable Members
NFX.Wave Namespace


NFX.Wave.Client Namespace

NFX.Wave.Client Namespace NFX Class Library

Classes
 | Class | Description
Public class | Record | Represents a client-side "Form" an analogue of WAVE.RecordModel.Record on C# server-side. The class is initialized from schema obtained from the server via JSON. The JSON is generated by RecordModelGenerator class. This class is usually used for API consumers that need to have the JS/client-like functionality on the server
Public class | RecordModelGenerator | Facilitates tasks of JSON generation for record models/rows as needed by WV.RecordModel client library. This class does not generate nested models, only flat models for particular row (i.e. id row has a complex type field, it will be serialized as "object")
Structures
 | Structure | Description
Public structure | Record ServerError |
Delegates
 | Delegate | Description
Public delegate | ModelFieldValueListLookupFunc | Invoked by generator to obtain a list of dynamic lookup values for a field. This event is invoked ONLY for fields that DO NOT have valueList specified
Public delegate | ModelLocalizationEventHandler | Invoked by generator to obtain localized versions of certain properties


ModelFieldValueListLookupFunc Delegate

ModelFieldValueListLookupFunc Delegate NFX Class Library

Invoked by generator to obtain a list of dynamic lookup values for a field. This event is invoked ONLY for fields that DO NOT have valueList specified

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate JSONDataMap ModelFieldValueListLookupFunc(
    RecordModelGenerator sender,
    Row row,
    Schema..::..FieldDef fdef,
    string target,
    string isoLang
)
public delegate JSONDataMap ModelFieldValueListLookupFunc(
    RecordModelGenerator sender,
    Row row,
    Schema..::..FieldDef fdef,
    string target,
    string isoLang
)
Public Delegate Function ModelFieldValueListLookupFunc (
    sender As RecordModelGenerator,
    row As Row,
    fdef As Schema..::..FieldDef,
    target As String,
    isoLang As String
) As JSONDataMap
Public Delegate Function ModelFieldValueListLookupFunc (
    sender As RecordModelGenerator,
    row As Row,
    fdef As Schema..::..FieldDef,
    target As String,
    isoLang As String
) As JSONDataMap
public delegate JSONDataMap^ ModelFieldValueListLookupFunc(
    RecordModelGenerator^ sender,
    Row^ row,
    Schema..::..FieldDef^ fdef,
    String^ target,
    String^ isoLang
)
public delegate JSONDataMap^ ModelFieldValueListLookupFunc(
    RecordModelGenerator^ sender,
    Row^ row,
    Schema..::..FieldDef^ fdef,
    String^ target,
    String^ isoLang
)
type ModelFieldValueListLookupFunc =
    delegate of
        sender : RecordModelGenerator *
        row : Row *
        fdef : Schema..::..FieldDef *
        target : string *
        isoLang : string -> JSONDataMap
type ModelFieldValueListLookupFunc =
    delegate of
        sender : RecordModelGenerator *
        row : Row *
        fdef : Schema..::..FieldDef *
        target : string *
        isoLang : string -> JSONDataMap

Parameters

sender
Type: NFX.Wave.Client RecordModelGenerator
Generator
row
Type: NFX.DataAccess.CRUD Row
Row that data model is generated for
fdef
Type: NFX.DataAccess.CRUD Schema FieldDef
Field definition
target
Type: Online System String
Target name
isoLang
Type: Online System String
Desired isoLang for localization

Return Value

Type: JSONDataMap
JSONDataMap populated by business logic or null to indicate that no lookup values are available
See Also
NFX.Wave.Client Namespace


ModelLocalizationEventHandler Delegate

ModelLocalizationEventHandler Delegate NFX Class Library

Invoked by generator to obtain localized versions of certain properties

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate string ModelLocalizationEventHandler(
    RecordModelGenerator sender,
    string schema,
    string field,
    string value,
    string isoLang
)
public delegate string ModelLocalizationEventHandler(
    RecordModelGenerator sender,
    string schema,
    string field,
    string value,
    string isoLang
)
Public Delegate Function ModelLocalizationEventHandler (
    sender As RecordModelGenerator,
    schema As String,
    field As String,
    value As String,
    isoLang As String
) As String
Public Delegate Function ModelLocalizationEventHandler (
    sender As RecordModelGenerator,
    schema As String,
    field As String,
    value As String,
    isoLang As String
) As String
public delegate String^ ModelLocalizationEventHandler(
    RecordModelGenerator^ sender,
    String^ schema,
    String^ field,
    String^ value,
    String^ isoLang
)
public delegate String^ ModelLocalizationEventHandler(
    RecordModelGenerator^ sender,
    String^ schema,
    String^ field,
    String^ value,
    String^ isoLang
)
type ModelLocalizationEventHandler =
    delegate of
        sender : RecordModelGenerator *
        schema : string *
        field : string *
        value : string *
        isoLang : string -> string
type ModelLocalizationEventHandler =
    delegate of
        sender : RecordModelGenerator *
        schema : string *
        field : string *
        value : string *
        isoLang : string -> string

Parameters

sender
Type: NFX.Wave.Client RecordModelGenerator
Generator
schema
Type: Online System String
Name of schema, i.e. Type of row
field
Type: Online System String
Name of property/field
value
Type: Online System String
English value
isoLang
Type: Online System String
Requested language or null

Return Value

Type: Online String
Localized value, i.e. depending on user culture looks-up culture-specific version of value
See Also
NFX.Wave.Client Namespace


Record Class

Record Class NFX Class Library

Represents a client-side "Form" an analogue of WAVE.RecordModel.Record on C# server-side. The class is initialized from schema obtained from the server via JSON. The JSON is generated by RecordModelGenerator class. This class is usually used for API consumers that need to have the JS/client-like functionality on the server
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD Row
NFX.DataAccess.CRUD DynamicRow
NFX.Wave.Client Record

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Record : DynamicRow
public class Record : DynamicRow
Public Class Record
    Inherits DynamicRow
Public Class Record
    Inherits DynamicRow
public ref class Record : public DynamicRow
public ref class Record : public DynamicRow
type Record =
    class
        inherit DynamicRow
    end
type Record =
    class
        inherit DynamicRow
    end
See Also
Record Members
NFX.Wave.Client Namespace


Record Members

Record Members NFX Class Library

The Record type exposes the following members.
Constructors
 | Name | Description
Public method | Record(String) | Initializes a new instance of the Record class
Public method | Record(JSONDataMap) | Initializes a new instance of the Record class
Back to Top
Methods
 | Name | Description
Protected method | __ctor | Developers do not call, lazily injects the statr of this object, this is needed for speed and other optimizations (Inherited from DynamicRow.)
Public method | ApplyDefaultFieldValues | Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default) (Inherited from Row.)
Protected method | CheckMinMax | (Inherited from Row.)
Public method | ClearErrors |
Public method | Configure | In base class applies Config attribute. Useful for typed rows (Inherited from Row.)
Public method | ConvertFieldValueToDef | Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer (Inherited from Row.)
Public method | CopyFields | Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over (Inherited from Row.)
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Inherited from Row.)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields (Inherited from Row.)
Protected method | FilterJSONSerializerField | Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON) (Inherited from Row.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClientFieldDef | Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic (Inherited from Row.)
Public method | GetClientFieldValue | Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic (Inherited from Row.)
Public method | GetClientFieldValueList | Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef (Inherited from Row.)
Public method | GetDataStoreKey | Returns values for fields that represent row's primary key (Inherited from Row.)
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetEnumerator | (Inherited from Row.)
Protected method | GetFieldDefFromJSON |
Public method | GetFieldValue | (Inherited from DynamicRow.)
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetHashCode | Object override - gets hash code from key fields (Inherited from Row.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | LoadData |
Protected method | MapInitToSchema |
Protected method | MapJSToCLRCharCase |
Protected method | MapJSToCLRKind |
Protected method | MapJSToCLRType |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PersistConfiguration | The base class does not implement this method. Override to persist row fields into config node (Inherited from Row.)
Public method | SetFieldValue | (Inherited from DynamicRow.)
Public method | SimpleFilterPredicate | Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value (Inherited from Row.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend (Inherited from Row.)
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef) (Inherited from Row.)
Public method | WriteAsJSON | Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from Row.)
Back to Top
Extension Methods
Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method ToErlObject Overloaded.
Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(ErlTypeOrder, Boolean) Overloaded.
Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(String, String, Boolean) Overloaded.
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
(Defined by ErlSchemaUtils.)
Public Extension Method ToJSON(JSONWritingOptions) Overloaded.
Serializes object into JSON string
(Defined by JSONExtensions.)
Public Extension Method ToJSON(TextWriter, JSONWritingOptions) Overloaded.
Serializes object into JSON format using provided TextWriter
(Defined by JSONExtensions.)
Public Extension Method ToJSON(Stream, JSONWritingOptions, Encoding) Overloaded.
Serializes object into JSON format using provided stream and optional encoding
(Defined by JSONExtensions.)
Public Extension Method Update
Convert an Erlang hierarchical term representing a schema to a Row.
(Defined by ErlSchemaUtils.)
Back to Top
Fields
 | Name | Description
Protected field | m_Errors |
Protected field | m_Init |
Back to Top
Properties
 | Name | Description
Public property | CSRFToken |
Public property | Data | Provides access to raw array of values that this row contains (Inherited from DynamicRow.)
Public property | FormMode |
Public property | ID |
Public property | Init |
Public property | ISOLang |
Public property | Item Int32 | Gets/sets field values by positional index(Order) (Inherited from Row.)
Public property | Item String | Gets/sets field values by name (Inherited from Row.)
Public property | JSONData | Returns JSON representation of the Record including MODE, CSRF token and Roundtrip metafields
Public property | OK |
Public property | Roundtrip |
Public property | Schema | References a schema for a table that this row is a part of (Inherited from DynamicRow.)
Public property | ServerErrors |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Row.)
Back to Top
See Also
Record Class
NFX.Wave.Client Namespace


Record Constructor

Record Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Record(String) | Initializes a new instance of the Record class
Public method | Record(JSONDataMap) | Initializes a new instance of the Record class
Back to Top
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record Constructor (String)

Record Constructor (String) NFX Class Library

Initializes a new instance of the Record class

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Record(
    string init
)
public Record(
    string init
)
Public Sub New (
    init As String
)
Public Sub New (
    init As String
)
public:
Record(
    String^ init
)
public:
Record(
    String^ init
)
new :
        init : string -> Record
new :
        init : string -> Record

Parameters

init
Type: Online System String
See Also
Record Class
Record Members
Record Overload
NFX.Wave.Client Namespace


Record Constructor (JSONDataMap)

Record Constructor (JSONDataMap) NFX Class Library

Initializes a new instance of the Record class

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Record(
    JSONDataMap init
)
public Record(
    JSONDataMap init
)
Public Sub New (
    init As JSONDataMap
)
Public Sub New (
    init As JSONDataMap
)
public:
Record(
    JSONDataMap^ init
)
public:
Record(
    JSONDataMap^ init
)
new :
        init : JSONDataMap -> Record
new :
        init : JSONDataMap -> Record

Parameters

init
Type: NFX.Serialization.JSON JSONDataMap
See Also
Record Class
Record Members
Record Overload
NFX.Wave.Client Namespace


Record Fields

Record Fields NFX Class Library

The Record type exposes the following members.
Fields
 | Name | Description
Protected field | m_Errors |
Protected field | m_Init |
Back to Top
See Also
Record Class
NFX.Wave.Client Namespace


Record.m_Errors Field

Record m_Errors Field NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected List<Record..::..ServerError> m_Errors
protected List<Record..::..ServerError> m_Errors
Protected m_Errors As List(Of Record..::..ServerError)
Protected m_Errors As List(Of Record..::..ServerError)
protected:
List<Record..::..ServerError>^ m_Errors
protected:
List<Record..::..ServerError>^ m_Errors
val mutable m_Errors: List<Record..::..ServerError>
val mutable m_Errors: List<Record..::..ServerError>

Field Value

Type: Online List Record ServerError
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.m_Init Field

Record m_Init Field NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected JSONDataMap m_Init
protected JSONDataMap m_Init
Protected m_Init As JSONDataMap
Protected m_Init As JSONDataMap
protected:
JSONDataMap^ m_Init
protected:
JSONDataMap^ m_Init
val mutable m_Init: JSONDataMap
val mutable m_Init: JSONDataMap

Field Value

Type: JSONDataMap
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record Methods

Record Methods NFX Class Library

The Record type exposes the following members.
Methods
 | Name | Description
Protected method | __ctor | Developers do not call, lazily injects the statr of this object, this is needed for speed and other optimizations (Inherited from DynamicRow.)
Public method | ApplyDefaultFieldValues | Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default) (Inherited from Row.)
Protected method | CheckMinMax | (Inherited from Row.)
Public method | ClearErrors |
Public method | Configure | In base class applies Config attribute. Useful for typed rows (Inherited from Row.)
Public method | ConvertFieldValueToDef | Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer (Inherited from Row.)
Public method | CopyFields | Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over (Inherited from Row.)
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Inherited from Row.)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields (Inherited from Row.)
Protected method | FilterJSONSerializerField | Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON) (Inherited from Row.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClientFieldDef | Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic (Inherited from Row.)
Public method | GetClientFieldValue | Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic (Inherited from Row.)
Public method | GetClientFieldValueList | Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef (Inherited from Row.)
Public method | GetDataStoreKey | Returns values for fields that represent row's primary key (Inherited from Row.)
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetEnumerator | (Inherited from Row.)
Protected method | GetFieldDefFromJSON |
Public method | GetFieldValue | (Inherited from DynamicRow.)
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetHashCode | Object override - gets hash code from key fields (Inherited from Row.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | LoadData |
Protected method | MapInitToSchema |
Protected method | MapJSToCLRCharCase |
Protected method | MapJSToCLRKind |
Protected method | MapJSToCLRType |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PersistConfiguration | The base class does not implement this method. Override to persist row fields into config node (Inherited from Row.)
Public method | SetFieldValue | (Inherited from DynamicRow.)
Public method | SimpleFilterPredicate | Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value (Inherited from Row.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend (Inherited from Row.)
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef) (Inherited from Row.)
Public method | WriteAsJSON | Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from Row.)
Back to Top
Extension Methods
Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method ToErlObject Overloaded.
Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(ErlTypeOrder, Boolean) Overloaded.
Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(String, String, Boolean) Overloaded.
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
(Defined by ErlSchemaUtils.)
Public Extension Method ToJSON(JSONWritingOptions) Overloaded.
Serializes object into JSON string
(Defined by JSONExtensions.)
Public Extension Method ToJSON(TextWriter, JSONWritingOptions) Overloaded.
Serializes object into JSON format using provided TextWriter
(Defined by JSONExtensions.)
Public Extension Method ToJSON(Stream, JSONWritingOptions, Encoding) Overloaded.
Serializes object into JSON format using provided stream and optional encoding
(Defined by JSONExtensions.)
Public Extension Method Update
Convert an Erlang hierarchical term representing a schema to a Row.
(Defined by ErlSchemaUtils.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Row.)
Back to Top
See Also
Record Class
NFX.Wave.Client Namespace


Record.ClearErrors Method

Record ClearErrors Method NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ClearErrors()
public virtual void ClearErrors()
Public Overridable Sub ClearErrors
Public Overridable Sub ClearErrors
public:
virtual void ClearErrors()
public:
virtual void ClearErrors()
abstract ClearErrors : unit -> unit
override ClearErrors : unit -> unit
abstract ClearErrors : unit -> unit
override ClearErrors : unit -> unit
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.GetFieldDefFromJSON Method

Record GetFieldDefFromJSON Method NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Schema..::..FieldDef GetFieldDefFromJSON(
    JSONDataMap def
)
protected virtual Schema..::..FieldDef GetFieldDefFromJSON(
    JSONDataMap def
)
Protected Overridable Function GetFieldDefFromJSON (
    def As JSONDataMap
) As Schema..::..FieldDef
Protected Overridable Function GetFieldDefFromJSON (
    def As JSONDataMap
) As Schema..::..FieldDef
protected:
virtual Schema..::..FieldDef^ GetFieldDefFromJSON(
    JSONDataMap^ def
)
protected:
virtual Schema..::..FieldDef^ GetFieldDefFromJSON(
    JSONDataMap^ def
)
abstract GetFieldDefFromJSON :
        def : JSONDataMap -> Schema..::..FieldDef
override GetFieldDefFromJSON :
        def : JSONDataMap -> Schema..::..FieldDef
abstract GetFieldDefFromJSON :
        def : JSONDataMap -> Schema..::..FieldDef
override GetFieldDefFromJSON :
        def : JSONDataMap -> Schema..::..FieldDef

Parameters

def
Type: NFX.Serialization.JSON JSONDataMap

Return Value

Type: Schema FieldDef
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.LoadData Method

Record LoadData Method NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void LoadData()
protected virtual void LoadData()
Protected Overridable Sub LoadData
Protected Overridable Sub LoadData
protected:
virtual void LoadData()
protected:
virtual void LoadData()
abstract LoadData : unit -> unit
override LoadData : unit -> unit
abstract LoadData : unit -> unit
override LoadData : unit -> unit
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.MapInitToSchema Method

Record MapInitToSchema Method NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Schema MapInitToSchema()
protected virtual Schema MapInitToSchema()
Protected Overridable Function MapInitToSchema As Schema
Protected Overridable Function MapInitToSchema As Schema
protected:
virtual Schema^ MapInitToSchema()
protected:
virtual Schema^ MapInitToSchema()
abstract MapInitToSchema : unit -> Schema
override MapInitToSchema : unit -> Schema
abstract MapInitToSchema : unit -> Schema
override MapInitToSchema : unit -> Schema

Return Value

Type: Schema
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.MapJSToCLRCharCase Method

Record MapJSToCLRCharCase Method NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual CharCase MapJSToCLRCharCase(
    string kind
)
protected virtual CharCase MapJSToCLRCharCase(
    string kind
)
Protected Overridable Function MapJSToCLRCharCase (
    kind As String
) As CharCase
Protected Overridable Function MapJSToCLRCharCase (
    kind As String
) As CharCase
protected:
virtual CharCase MapJSToCLRCharCase(
    String^ kind
)
protected:
virtual CharCase MapJSToCLRCharCase(
    String^ kind
)
abstract MapJSToCLRCharCase :
        kind : string -> CharCase
override MapJSToCLRCharCase :
        kind : string -> CharCase
abstract MapJSToCLRCharCase :
        kind : string -> CharCase
override MapJSToCLRCharCase :
        kind : string -> CharCase

Parameters

kind
Type: Online System String

Return Value

Type: CharCase
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.MapJSToCLRKind Method

Record MapJSToCLRKind Method NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual DataKind MapJSToCLRKind(
    string kind
)
protected virtual DataKind MapJSToCLRKind(
    string kind
)
Protected Overridable Function MapJSToCLRKind (
    kind As String
) As DataKind
Protected Overridable Function MapJSToCLRKind (
    kind As String
) As DataKind
protected:
virtual DataKind MapJSToCLRKind(
    String^ kind
)
protected:
virtual DataKind MapJSToCLRKind(
    String^ kind
)
abstract MapJSToCLRKind :
        kind : string -> DataKind
override MapJSToCLRKind :
        kind : string -> DataKind
abstract MapJSToCLRKind :
        kind : string -> DataKind
override MapJSToCLRKind :
        kind : string -> DataKind

Parameters

kind
Type: Online System String

Return Value

Type: DataKind
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.MapJSToCLRType Method

Record MapJSToCLRType Method NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Type MapJSToCLRType(
    string tp
)
protected virtual Type MapJSToCLRType(
    string tp
)
Protected Overridable Function MapJSToCLRType (
    tp As String
) As Type
Protected Overridable Function MapJSToCLRType (
    tp As String
) As Type
protected:
virtual Type^ MapJSToCLRType(
    String^ tp
)
protected:
virtual Type^ MapJSToCLRType(
    String^ tp
)
abstract MapJSToCLRType :
        tp : string -> Type
override MapJSToCLRType :
        tp : string -> Type
abstract MapJSToCLRType :
        tp : string -> Type
override MapJSToCLRType :
        tp : string -> Type

Parameters

tp
Type: Online System String

Return Value

Type: Online Type
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record Properties

Record Properties NFX Class Library

The Record type exposes the following members.
Properties
 | Name | Description
Public property | CSRFToken |
Public property | Data | Provides access to raw array of values that this row contains (Inherited from DynamicRow.)
Public property | FormMode |
Public property | ID |
Public property | Init |
Public property | ISOLang |
Public property | Item Int32 | Gets/sets field values by positional index(Order) (Inherited from Row.)
Public property | Item String | Gets/sets field values by name (Inherited from Row.)
Public property | JSONData | Returns JSON representation of the Record including MODE, CSRF token and Roundtrip metafields
Public property | OK |
Public property | Roundtrip |
Public property | Schema | References a schema for a table that this row is a part of (Inherited from DynamicRow.)
Public property | ServerErrors |
Back to Top
See Also
Record Class
NFX.Wave.Client Namespace


Record.CSRFToken Property

Record CSRFToken Property NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CSRFToken { get; private set; }
public string CSRFToken { get; private set; }
Public Property CSRFToken As String
    Get
    Private Set
Public Property CSRFToken As String
    Get
    Private Set
public:
property String^ CSRFToken {
    String^ get ();
    private: void set (String^ value);
}
public:
property String^ CSRFToken {
    String^ get ();
    private: void set (String^ value);
}
member CSRFToken : string with get, private set
member CSRFToken : string with get, private set

Property Value

Type: Online String
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.FormMode Property

Record FormMode Property NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FormMode { get; private set; }
public string FormMode { get; private set; }
Public Property FormMode As String
    Get
    Private Set
Public Property FormMode As String
    Get
    Private Set
public:
property String^ FormMode {
    String^ get ();
    private: void set (String^ value);
}
public:
property String^ FormMode {
    String^ get ();
    private: void set (String^ value);
}
member FormMode : string with get, private set
member FormMode : string with get, private set

Property Value

Type: Online String
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.ID Property

Record ID Property NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> ID { get; private set; }
public Nullable<Guid> ID { get; private set; }
Public Property ID As Nullable(Of Guid)
    Get
    Private Set
Public Property ID As Nullable(Of Guid)
    Get
    Private Set
public:
property Nullable<Guid> ID {
    Nullable<Guid> get ();
    private: void set (Nullable<Guid> value);
}
public:
property Nullable<Guid> ID {
    Nullable<Guid> get ();
    private: void set (Nullable<Guid> value);
}
member ID : Nullable<Guid> with get, private set
member ID : Nullable<Guid> with get, private set

Property Value

Type: Online Nullable Online Guid
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.Init Property

Record Init Property NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap Init { get; }
public JSONDataMap Init { get; }
Public ReadOnly Property Init As JSONDataMap
    Get
Public ReadOnly Property Init As JSONDataMap
    Get
public:
property JSONDataMap^ Init {
    JSONDataMap^ get ();
}
public:
property JSONDataMap^ Init {
    JSONDataMap^ get ();
}
member Init : JSONDataMap with get
member Init : JSONDataMap with get

Property Value

Type: JSONDataMap
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.ISOLang Property

Record ISOLang Property NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ISOLang { get; private set; }
public string ISOLang { get; private set; }
Public Property ISOLang As String
    Get
    Private Set
Public Property ISOLang As String
    Get
    Private Set
public:
property String^ ISOLang {
    String^ get ();
    private: void set (String^ value);
}
public:
property String^ ISOLang {
    String^ get ();
    private: void set (String^ value);
}
member ISOLang : string with get, private set
member ISOLang : string with get, private set

Property Value

Type: Online String
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.JSONData Property

Record JSONData Property NFX Class Library

Returns JSON representation of the Record including MODE, CSRF token and Roundtrip metafields

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap JSONData { get; }
public JSONDataMap JSONData { get; }
Public ReadOnly Property JSONData As JSONDataMap
    Get
Public ReadOnly Property JSONData As JSONDataMap
    Get
public:
property JSONDataMap^ JSONData {
    JSONDataMap^ get ();
}
public:
property JSONDataMap^ JSONData {
    JSONDataMap^ get ();
}
member JSONData : JSONDataMap with get
member JSONData : JSONDataMap with get

Property Value

Type: JSONDataMap
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.OK Property

Record OK Property NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<bool> OK { get; private set; }
public Nullable<bool> OK { get; private set; }
Public Property OK As Nullable(Of Boolean)
    Get
    Private Set
Public Property OK As Nullable(Of Boolean)
    Get
    Private Set
public:
property Nullable<bool> OK {
    Nullable<bool> get ();
    private: void set (Nullable<bool> value);
}
public:
property Nullable<bool> OK {
    Nullable<bool> get ();
    private: void set (Nullable<bool> value);
}
member OK : Nullable<bool> with get, private set
member OK : Nullable<bool> with get, private set

Property Value

Type: Online Nullable Online Boolean
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.Roundtrip Property

Record Roundtrip Property NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap Roundtrip { get; private set; }
public JSONDataMap Roundtrip { get; private set; }
Public Property Roundtrip As JSONDataMap
    Get
    Private Set
Public Property Roundtrip As JSONDataMap
    Get
    Private Set
public:
property JSONDataMap^ Roundtrip {
    JSONDataMap^ get ();
    private: void set (JSONDataMap^ value);
}
public:
property JSONDataMap^ Roundtrip {
    JSONDataMap^ get ();
    private: void set (JSONDataMap^ value);
}
member Roundtrip : JSONDataMap with get, private set
member Roundtrip : JSONDataMap with get, private set

Property Value

Type: JSONDataMap
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.ServerErrors Property

Record ServerErrors Property NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Record..::..ServerError> ServerErrors { get; }
public IEnumerable<Record..::..ServerError> ServerErrors { get; }
Public ReadOnly Property ServerErrors As IEnumerable(Of Record..::..ServerError)
    Get
Public ReadOnly Property ServerErrors As IEnumerable(Of Record..::..ServerError)
    Get
public:
property IEnumerable<Record..::..ServerError>^ ServerErrors {
    IEnumerable<Record..::..ServerError>^ get ();
}
public:
property IEnumerable<Record..::..ServerError>^ ServerErrors {
    IEnumerable<Record..::..ServerError>^ get ();
}
member ServerErrors : IEnumerable<Record..::..ServerError> with get
member ServerErrors : IEnumerable<Record..::..ServerError> with get

Property Value

Type: Online IEnumerable Record ServerError
See Also
Record Class
Record Members
NFX.Wave.Client Namespace


Record.ServerError Structure

Record ServerError Structure NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ServerError
public struct ServerError
Public Structure ServerError
Public Structure ServerError
public value class ServerError
public value class ServerError
[<SealedAttribute>]
type ServerError =  struct end
[<SealedAttribute>]
type ServerError =  struct end
See Also
Record ServerError Members
NFX.Wave.Client Namespace


Record.ServerError Members

Record ServerError Members NFX Class Library

The Record ServerError type exposes the following members.
Constructors
 | Name | Description
Protected method | Record ServerError | Initializes a new instance of the Record ServerError class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Error |
Public field | FieldName |
Public field | Text |
Back to Top
See Also
Record ServerError Structure
NFX.Wave.Client Namespace


Record.ServerError Constructor

Record ServerError Constructor NFX Class Library

Initializes a new instance of the Record ServerError class

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ServerError(
    string fname,
    string error,
    string text
)
internal ServerError(
    string fname,
    string error,
    string text
)
Friend Sub New (
    fname As String,
    error As String,
    text As String
)
Friend Sub New (
    fname As String,
    error As String,
    text As String
)
internal:
ServerError(
    String^ fname,
    String^ error,
    String^ text
)
internal:
ServerError(
    String^ fname,
    String^ error,
    String^ text
)
new :
        fname : string *
        error : string *
        text : string -> ServerError
new :
        fname : string *
        error : string *
        text : string -> ServerError

Parameters

fname
Type: Online System String
error
Type: Online System String
text
Type: Online System String
See Also
Record ServerError Structure
Record ServerError Members
NFX.Wave.Client Namespace


Record.ServerError Fields

Record ServerError Fields NFX Class Library

The Record ServerError type exposes the following members.
Fields
 | Name | Description
Public field | Error |
Public field | FieldName |
Public field | Text |
Back to Top
See Also
Record ServerError Structure
NFX.Wave.Client Namespace


Record.ServerError.Error Field

Record ServerError Error Field NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Error
public readonly string Error
Public ReadOnly Error As String
Public ReadOnly Error As String
public:
initonly String^ Error
public:
initonly String^ Error
val Error: string
val Error: string

Field Value

Type: Online String
See Also
Record ServerError Structure
Record ServerError Members
NFX.Wave.Client Namespace


Record.ServerError.FieldName Field

Record ServerError FieldName Field NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string FieldName
public readonly string FieldName
Public ReadOnly FieldName As String
Public ReadOnly FieldName As String
public:
initonly String^ FieldName
public:
initonly String^ FieldName
val FieldName: string
val FieldName: string

Field Value

Type: Online String
See Also
Record ServerError Structure
Record ServerError Members
NFX.Wave.Client Namespace


Record.ServerError.Text Field

Record ServerError Text Field NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Text
public readonly string Text
Public ReadOnly Text As String
Public ReadOnly Text As String
public:
initonly String^ Text
public:
initonly String^ Text
val Text: string
val Text: string

Field Value

Type: Online String
See Also
Record ServerError Structure
Record ServerError Members
NFX.Wave.Client Namespace


Record.ServerError Methods

Record ServerError Methods NFX Class Library

The Record ServerError type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Record ServerError Structure
NFX.Wave.Client Namespace


RecordModelGenerator Class

RecordModelGenerator Class NFX Class Library

Facilitates tasks of JSON generation for record models/rows as needed by WV.RecordModel client library. This class does not generate nested models, only flat models for particular row (i.e. id row has a complex type field, it will be serialized as "object")
Inheritance Hierarchy
Online System Object
NFX.Wave.Client RecordModelGenerator

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RecordModelGenerator
public class RecordModelGenerator
Public Class RecordModelGenerator
Public Class RecordModelGenerator
public ref class RecordModelGenerator
public ref class RecordModelGenerator
type RecordModelGenerator =  class end
type RecordModelGenerator =  class end
See Also
RecordModelGenerator Members
NFX.Wave.Client Namespace


RecordModelGenerator Members

RecordModelGenerator Members NFX Class Library

The RecordModelGenerator type exposes the following members.
Constructors
 | Name | Description
Public method | RecordModelGenerator | Initializes a new instance of the RecordModelGenerator class
Public method | RecordModelGenerator(IConfigSectionNode) | Initializes a new instance of the RecordModelGenerator class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | FieldDefToJSON |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MapCLRCharCaseToJS |
Protected method | MapCLRKindToJS |
Protected method | MapCLRTypeToJS |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnLocalizeString |
Public method | RowToRecordInitJSON | Generates JSON object suitable for passing into WV.RecordModel.Record(...) constructor on the client. Pass target to select attributes targeted to ANY target or to the specified one, for example may get attributes for client data entry screen that sees field metadata differently, in which case target will reflect the name of the screen
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
METADATA_CONFIG_FIELD |
METADATA_FIELDS |
Back to Top
Properties
Name | Description
DefaultInstance | Returns Default instance for simple use-cases
Back to Top
Events
 | Name | Description
Public event | ModelLocalization | Allows localization framework to install hook so that values can get translated per user-selected culture. The hook functor has the following signature: (string propertyName, string propValue): string. Returns translated propValue.
Back to Top
See Also
RecordModelGenerator Class
NFX.Wave.Client Namespace


RecordModelGenerator Constructor

RecordModelGenerator Constructor NFX Class Library

Overload List
 | Name | Description
Public method | RecordModelGenerator | Initializes a new instance of the RecordModelGenerator class
Public method | RecordModelGenerator(IConfigSectionNode) | Initializes a new instance of the RecordModelGenerator class
Back to Top
See Also
RecordModelGenerator Class
RecordModelGenerator Members
NFX.Wave.Client Namespace


RecordModelGenerator Constructor

RecordModelGenerator Constructor NFX Class Library

Initializes a new instance of the RecordModelGenerator class

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RecordModelGenerator()
public RecordModelGenerator()
Public Sub New
Public Sub New
public:
RecordModelGenerator()
public:
RecordModelGenerator()
new : unit -> RecordModelGenerator
new : unit -> RecordModelGenerator
See Also
RecordModelGenerator Class
RecordModelGenerator Members
RecordModelGenerator Overload
NFX.Wave.Client Namespace


RecordModelGenerator Constructor (IConfigSectionNode)

RecordModelGenerator Constructor (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RecordModelGenerator class

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RecordModelGenerator(
    IConfigSectionNode conf
)
public RecordModelGenerator(
    IConfigSectionNode conf
)
Public Sub New (
    conf As IConfigSectionNode
)
Public Sub New (
    conf As IConfigSectionNode
)
public:
RecordModelGenerator(
    IConfigSectionNode^ conf
)
public:
RecordModelGenerator(
    IConfigSectionNode^ conf
)
new :
        conf : IConfigSectionNode -> RecordModelGenerator
new :
        conf : IConfigSectionNode -> RecordModelGenerator

Parameters

conf
Type: NFX.Environment IConfigSectionNode
See Also
RecordModelGenerator Class
RecordModelGenerator Members
RecordModelGenerator Overload
NFX.Wave.Client Namespace


RecordModelGenerator Fields

RecordModelGenerator Fields NFX Class Library

The RecordModelGenerator type exposes the following members.
Fields
Name | Description
METADATA_CONFIG_FIELD |
METADATA_FIELDS |
Back to Top
See Also
RecordModelGenerator Class
NFX.Wave.Client Namespace


RecordModelGenerator.METADATA_CONFIG_FIELD Field

RecordModelGenerator METADATA_CONFIG_FIELD Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string METADATA_CONFIG_FIELD
public const string METADATA_CONFIG_FIELD
Public Const METADATA_CONFIG_FIELD As String
Public Const METADATA_CONFIG_FIELD As String
public:
literal String^ METADATA_CONFIG_FIELD
public:
literal String^ METADATA_CONFIG_FIELD
static val mutable METADATA_CONFIG_FIELD: string
static val mutable METADATA_CONFIG_FIELD: string

Field Value

Type: Online String
See Also
RecordModelGenerator Class
RecordModelGenerator Members
NFX.Wave.Client Namespace


RecordModelGenerator.METADATA_FIELDS Field

RecordModelGenerator METADATA_FIELDS Field NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly HashSet<string> METADATA_FIELDS
public static readonly HashSet<string> METADATA_FIELDS
Public Shared ReadOnly METADATA_FIELDS As HashSet(Of String)
Public Shared ReadOnly METADATA_FIELDS As HashSet(Of String)
public:
static initonly HashSet<String^>^ METADATA_FIELDS
public:
static initonly HashSet<String^>^ METADATA_FIELDS
static val METADATA_FIELDS: HashSet<string>
static val METADATA_FIELDS: HashSet<string>

Field Value

Type: Online HashSet Online String
See Also
RecordModelGenerator Class
RecordModelGenerator Members
NFX.Wave.Client Namespace


RecordModelGenerator Methods

RecordModelGenerator Methods NFX Class Library

The RecordModelGenerator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | FieldDefToJSON |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MapCLRCharCaseToJS |
Protected method | MapCLRKindToJS |
Protected method | MapCLRTypeToJS |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnLocalizeString |
Public method | RowToRecordInitJSON | Generates JSON object suitable for passing into WV.RecordModel.Record(...) constructor on the client. Pass target to select attributes targeted to ANY target or to the specified one, for example may get attributes for client data entry screen that sees field metadata differently, in which case target will reflect the name of the screen
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RecordModelGenerator Class
NFX.Wave.Client Namespace


RecordModelGenerator.FieldDefToJSON Method

RecordModelGenerator FieldDefToJSON Method NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual JSONDataMap FieldDefToJSON(
    Row row,
    string schema,
    Schema..::..FieldDef fdef,
    string target,
    string isoLang,
    ModelFieldValueListLookupFunc valueListLookup
)
protected virtual JSONDataMap FieldDefToJSON(
    Row row,
    string schema,
    Schema..::..FieldDef fdef,
    string target,
    string isoLang,
    ModelFieldValueListLookupFunc valueListLookup
)
Protected Overridable Function FieldDefToJSON (
    row As Row,
    schema As String,
    fdef As Schema..::..FieldDef,
    target As String,
    isoLang As String,
    valueListLookup As ModelFieldValueListLookupFunc
) As JSONDataMap
Protected Overridable Function FieldDefToJSON (
    row As Row,
    schema As String,
    fdef As Schema..::..FieldDef,
    target As String,
    isoLang As String,
    valueListLookup As ModelFieldValueListLookupFunc
) As JSONDataMap
protected:
virtual JSONDataMap^ FieldDefToJSON(
    Row^ row,
    String^ schema,
    Schema..::..FieldDef^ fdef,
    String^ target,
    String^ isoLang,
    ModelFieldValueListLookupFunc^ valueListLookup
)
protected:
virtual JSONDataMap^ FieldDefToJSON(
    Row^ row,
    String^ schema,
    Schema..::..FieldDef^ fdef,
    String^ target,
    String^ isoLang,
    ModelFieldValueListLookupFunc^ valueListLookup
)
abstract FieldDefToJSON :
        row : Row *
        schema : string *
        fdef : Schema..::..FieldDef *
        target : string *
        isoLang : string *
        valueListLookup : ModelFieldValueListLookupFunc -> JSONDataMap
override FieldDefToJSON :
        row : Row *
        schema : string *
        fdef : Schema..::..FieldDef *
        target : string *
        isoLang : string *
        valueListLookup : ModelFieldValueListLookupFunc -> JSONDataMap
abstract FieldDefToJSON :
        row : Row *
        schema : string *
        fdef : Schema..::..FieldDef *
        target : string *
        isoLang : string *
        valueListLookup : ModelFieldValueListLookupFunc -> JSONDataMap
override FieldDefToJSON :
        row : Row *
        schema : string *
        fdef : Schema..::..FieldDef *
        target : string *
        isoLang : string *
        valueListLookup : ModelFieldValueListLookupFunc -> JSONDataMap

Parameters

row
Type: NFX.DataAccess.CRUD Row
schema
Type: Online System String
fdef
Type: NFX.DataAccess.CRUD Schema FieldDef
target
Type: Online System String
isoLang
Type: Online System String
valueListLookup
Type: NFX.Wave.Client ModelFieldValueListLookupFunc

Return Value

Type: JSONDataMap
See Also
RecordModelGenerator Class
RecordModelGenerator Members
NFX.Wave.Client Namespace


RecordModelGenerator.MapCLRCharCaseToJS Method

RecordModelGenerator MapCLRCharCaseToJS Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string MapCLRCharCaseToJS(
    CharCase kind
)
protected virtual string MapCLRCharCaseToJS(
    CharCase kind
)
Protected Overridable Function MapCLRCharCaseToJS (
    kind As CharCase
) As String
Protected Overridable Function MapCLRCharCaseToJS (
    kind As CharCase
) As String
protected:
virtual String^ MapCLRCharCaseToJS(
    CharCase kind
)
protected:
virtual String^ MapCLRCharCaseToJS(
    CharCase kind
)
abstract MapCLRCharCaseToJS :
        kind : CharCase -> string
override MapCLRCharCaseToJS :
        kind : CharCase -> string
abstract MapCLRCharCaseToJS :
        kind : CharCase -> string
override MapCLRCharCaseToJS :
        kind : CharCase -> string

Parameters

kind
Type: NFX.DataAccess CharCase

Return Value

Type: Online String
See Also
RecordModelGenerator Class
RecordModelGenerator Members
NFX.Wave.Client Namespace


RecordModelGenerator.MapCLRKindToJS Method

RecordModelGenerator MapCLRKindToJS Method NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string MapCLRKindToJS(
    DataKind kind
)
protected virtual string MapCLRKindToJS(
    DataKind kind
)
Protected Overridable Function MapCLRKindToJS (
    kind As DataKind
) As String
Protected Overridable Function MapCLRKindToJS (
    kind As DataKind
) As String
protected:
virtual String^ MapCLRKindToJS(
    DataKind kind
)
protected:
virtual String^ MapCLRKindToJS(
    DataKind kind
)
abstract MapCLRKindToJS :
        kind : DataKind -> string
override MapCLRKindToJS :
        kind : DataKind -> string
abstract MapCLRKindToJS :
        kind : DataKind -> string
override MapCLRKindToJS :
        kind : DataKind -> string

Parameters

kind
Type: NFX.DataAccess.CRUD DataKind

Return Value

Type: Online String
See Also
RecordModelGenerator Class
RecordModelGenerator Members
NFX.Wave.Client Namespace


RecordModelGenerator.MapCLRTypeToJS Method

RecordModelGenerator MapCLRTypeToJS Method NFX Class Library

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string MapCLRTypeToJS(
    Type tp
)
protected virtual string MapCLRTypeToJS(
    Type tp
)
Protected Overridable Function MapCLRTypeToJS (
    tp As Type
) As String
Protected Overridable Function MapCLRTypeToJS (
    tp As Type
) As String
protected:
virtual String^ MapCLRTypeToJS(
    Type^ tp
)
protected:
virtual String^ MapCLRTypeToJS(
    Type^ tp
)
abstract MapCLRTypeToJS :
        tp : Type -> string
override MapCLRTypeToJS :
        tp : Type -> string
abstract MapCLRTypeToJS :
        tp : Type -> string
override MapCLRTypeToJS :
        tp : Type -> string

Parameters

tp
Type: Online System Type

Return Value

Type: Online String
See Also
RecordModelGenerator Class
RecordModelGenerator Members
NFX.Wave.Client Namespace


RecordModelGenerator.OnLocalizeString Method

RecordModelGenerator OnLocalizeString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string OnLocalizeString(
    string schema,
    string prop,
    string value,
    string isoLang
)
protected virtual string OnLocalizeString(
    string schema,
    string prop,
    string value,
    string isoLang
)
Protected Overridable Function OnLocalizeString (
    schema As String,
    prop As String,
    value As String,
    isoLang As String
) As String
Protected Overridable Function OnLocalizeString (
    schema As String,
    prop As String,
    value As String,
    isoLang As String
) As String
protected:
virtual String^ OnLocalizeString(
    String^ schema,
    String^ prop,
    String^ value,
    String^ isoLang
)
protected:
virtual String^ OnLocalizeString(
    String^ schema,
    String^ prop,
    String^ value,
    String^ isoLang
)
abstract OnLocalizeString :
        schema : string *
        prop : string *
        value : string *
        isoLang : string -> string
override OnLocalizeString :
        schema : string *
        prop : string *
        value : string *
        isoLang : string -> string
abstract OnLocalizeString :
        schema : string *
        prop : string *
        value : string *
        isoLang : string -> string
override OnLocalizeString :
        schema : string *
        prop : string *
        value : string *
        isoLang : string -> string

Parameters

schema
Type: Online System String
prop
Type: Online System String
value
Type: Online System String
isoLang
Type: Online System String

Return Value

Type: Online String
See Also
RecordModelGenerator Class
RecordModelGenerator Members
NFX.Wave.Client Namespace


RecordModelGenerator.RowToRecordInitJSON Method

RecordModelGenerator RowToRecordInitJSON Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates JSON object suitable for passing into WV.RecordModel.Record(...) constructor on the client. Pass target to select attributes targeted to ANY target or to the specified one, for example may get attributes for client data entry screen that sees field metadata differently, in which case target will reflect the name of the screen

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual JSONDataMap RowToRecordInitJSON(
    Row row,
    Exception validationError,
    string recID = null,
    string target = null,
    string isoLang = null,
    ModelFieldValueListLookupFunc valueListLookup = null
)
public virtual JSONDataMap RowToRecordInitJSON(
    Row row,
    Exception validationError,
    string recID = null,
    string target = null,
    string isoLang = null,
    ModelFieldValueListLookupFunc valueListLookup = null
)
Public Overridable Function RowToRecordInitJSON (
    row As Row,
    validationError As Exception,
    Optional recID As String = Nothing,
    Optional target As String = Nothing,
    Optional isoLang As String = Nothing,
    Optional valueListLookup As ModelFieldValueListLookupFunc = Nothing
) As JSONDataMap
Public Overridable Function RowToRecordInitJSON (
    row As Row,
    validationError As Exception,
    Optional recID As String = Nothing,
    Optional target As String = Nothing,
    Optional isoLang As String = Nothing,
    Optional valueListLookup As ModelFieldValueListLookupFunc = Nothing
) As JSONDataMap
public:
virtual JSONDataMap^ RowToRecordInitJSON(
    Row^ row,
    Exception^ validationError,
    String^ recID = nullptr,
    String^ target = nullptr,
    String^ isoLang = nullptr,
    ModelFieldValueListLookupFunc^ valueListLookup = nullptr
)
public:
virtual JSONDataMap^ RowToRecordInitJSON(
    Row^ row,
    Exception^ validationError,
    String^ recID = nullptr,
    String^ target = nullptr,
    String^ isoLang = nullptr,
    ModelFieldValueListLookupFunc^ valueListLookup = nullptr
)
abstract RowToRecordInitJSON :
        row : Row *
        validationError : Exception *
        ?recID : string *
        ?target : string *
        ?isoLang : string *
        ?valueListLookup : ModelFieldValueListLookupFunc
(* Defaults:
        let _recID = defaultArg recID null
        let _target = defaultArg target null
        let _isoLang = defaultArg isoLang null
        let _valueListLookup = defaultArg valueListLookup null
*)
-> JSONDataMap
override RowToRecordInitJSON :
        row : Row *
        validationError : Exception *
        ?recID : string *
        ?target : string *
        ?isoLang : string *
        ?valueListLookup : ModelFieldValueListLookupFunc
(* Defaults:
        let _recID = defaultArg recID null
        let _target = defaultArg target null
        let _isoLang = defaultArg isoLang null
        let _valueListLookup = defaultArg valueListLookup null
*)
-> JSONDataMap
abstract RowToRecordInitJSON :
        row : Row *
        validationError : Exception *
        ?recID : string *
        ?target : string *
        ?isoLang : string *
        ?valueListLookup : ModelFieldValueListLookupFunc
(* Defaults:
        let _recID = defaultArg recID null
        let _target = defaultArg target null
        let _isoLang = defaultArg isoLang null
        let _valueListLookup = defaultArg valueListLookup null
*)
-> JSONDataMap
override RowToRecordInitJSON :
        row : Row *
        validationError : Exception *
        ?recID : string *
        ?target : string *
        ?isoLang : string *
        ?valueListLookup : ModelFieldValueListLookupFunc
(* Defaults:
        let _recID = defaultArg recID null
        let _target = defaultArg target null
        let _isoLang = defaultArg isoLang null
        let _valueListLookup = defaultArg valueListLookup null
*)
-> JSONDataMap

Parameters

row
Type: NFX.DataAccess.CRUD Row
validationError
Type: Online System Exception
recID (Optional)
Type: Online System String
target (Optional)
Type: Online System String
isoLang (Optional)
Type: Online System String
valueListLookup (Optional)
Type: NFX.Wave.Client ModelFieldValueListLookupFunc

Return Value

Type: JSONDataMap
See Also
RecordModelGenerator Class
RecordModelGenerator Members
NFX.Wave.Client Namespace


RecordModelGenerator Properties

RecordModelGenerator Properties NFX Class Library

The RecordModelGenerator type exposes the following members.
Properties
Name | Description
DefaultInstance | Returns Default instance for simple use-cases
Back to Top
See Also
RecordModelGenerator Class
NFX.Wave.Client Namespace


RecordModelGenerator.DefaultInstance Property

RecordModelGenerator DefaultInstance Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns Default instance for simple use-cases

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static RecordModelGenerator DefaultInstance { get; }
public static RecordModelGenerator DefaultInstance { get; }
Public Shared ReadOnly Property DefaultInstance As RecordModelGenerator
    Get
Public Shared ReadOnly Property DefaultInstance As RecordModelGenerator
    Get
public:
static property RecordModelGenerator^ DefaultInstance {
    RecordModelGenerator^ get ();
}
public:
static property RecordModelGenerator^ DefaultInstance {
    RecordModelGenerator^ get ();
}
static member DefaultInstance : RecordModelGenerator with get
static member DefaultInstance : RecordModelGenerator with get

Property Value

Type: RecordModelGenerator
See Also
RecordModelGenerator Class
RecordModelGenerator Members
NFX.Wave.Client Namespace


RecordModelGenerator Events

RecordModelGenerator Events NFX Class Library

The RecordModelGenerator type exposes the following members.
Events
 | Name | Description
Public event | ModelLocalization | Allows localization framework to install hook so that values can get translated per user-selected culture. The hook functor has the following signature: (string propertyName, string propValue): string. Returns translated propValue.
Back to Top
See Also
RecordModelGenerator Class
NFX.Wave.Client Namespace


RecordModelGenerator.ModelLocalization Event

RecordModelGenerator ModelLocalization Event NFX Class Library

[This is preliminary documentation and is subject to change.]

Allows localization framework to install hook so that values can get translated per user-selected culture. The hook functor has the following signature: (string propertyName, string propValue): string. Returns translated propValue.

Namespace: NFX.Wave.Client
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event ModelLocalizationEventHandler ModelLocalization
public event ModelLocalizationEventHandler ModelLocalization
Public Event ModelLocalization As ModelLocalizationEventHandler
Public Event ModelLocalization As ModelLocalizationEventHandler
public:
 event ModelLocalizationEventHandler^ ModelLocalization {
    void add (ModelLocalizationEventHandler^ value);
    void remove (ModelLocalizationEventHandler^ value);
}
public:
 event ModelLocalizationEventHandler^ ModelLocalization {
    void add (ModelLocalizationEventHandler^ value);
    void remove (ModelLocalizationEventHandler^ value);
}
member ModelLocalization : IEvent<ModelLocalizationEventHandler,
    EventArgs>
member ModelLocalization : IEvent<ModelLocalizationEventHandler,
    EventArgs>

Value

Type: NFX.Wave.Client ModelLocalizationEventHandler
See Also
RecordModelGenerator Class
RecordModelGenerator Members
NFX.Wave.Client Namespace


NFX.Wave.Filters Namespace

NFX.Wave.Filters Namespace NFX Class Library

Classes
 | Class | Description
Public class | BeforeAfterFilterBase | Provides base for filters that have before/after semantics
Public class | EffectiveCallerIPEndPointFilter | Upon match, injects real caller WorkContext.EffectiveCallerIPEndPoint
Public class | ErrorFilter | Intercepts error that arise during processing and displays an error page for exceptions and error codes
Public class | GeoLookupFilter | Upon match, looks up user's geo location based on a IP addresses
Public class | LoggingFilter | Logs information extracted from WorkContext
Public class | PortalFilter | Manages injection of portal into the work context
Public class | RedirectFilter | Upon match, redirects client to the specified URL resource. Specify matches with 'redirect-url' var
Public class | SecurityFilter | Checks permissions before doing work
Public class | SessionFilter | Manages session state in work context
Public class | StopFilter | Stops the processing of WorkContext by throwing exception upon match


BeforeAfterFilterBase Class

BeforeAfterFilterBase Class NFX Class Library

Provides base for filters that have before/after semantics
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkFilter
NFX.Wave.Filters BeforeAfterFilterBase
NFX.Wave.Filters LoggingFilter
NFX.Wave.Filters StopFilter

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class BeforeAfterFilterBase : WorkFilter
public abstract class BeforeAfterFilterBase : WorkFilter
Public MustInherit Class BeforeAfterFilterBase
    Inherits WorkFilter
Public MustInherit Class BeforeAfterFilterBase
    Inherits WorkFilter
public ref class BeforeAfterFilterBase abstract : public WorkFilter
public ref class BeforeAfterFilterBase abstract : public WorkFilter
[<AbstractClassAttribute>]
type BeforeAfterFilterBase =
    class
        inherit WorkFilter
    end
[<AbstractClassAttribute>]
type BeforeAfterFilterBase =
    class
        inherit WorkFilter
    end
See Also
BeforeAfterFilterBase Members
NFX.Wave.Filters Namespace


BeforeAfterFilterBase Members

BeforeAfterFilterBase Members NFX Class Library

The BeforeAfterFilterBase type exposes the following members.
Constructors
 | Name | Description
Public method | BeforeAfterFilterBase(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the BeforeAfterFilterBase class
Public method | BeforeAfterFilterBase(WorkHandler, IConfigSectionNode) | Initializes a new instance of the BeforeAfterFilterBase class
Public method | BeforeAfterFilterBase(WorkDispatcher, String, Int32) | Initializes a new instance of the BeforeAfterFilterBase class
Public method | BeforeAfterFilterBase(WorkHandler, String, Int32) | Initializes a new instance of the BeforeAfterFilterBase class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAfterWork | Override to do the work when one of the AfterMatches was matched
Protected method | DoBeforeWork | Override to do the work when one of the BeforeMatches was matched
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_AFTER_SECTION |
CONFIG_BEFORE_SECTION |
Back to Top
Properties
 | Name | Description
Public property | AfterMatches | Returns matches used by the handler to determine whether match should be made before the work processing
Public property | BeforeMatches | Returns matches used by the handler to determine whether match should be made before the work processing
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Back to Top
See Also
BeforeAfterFilterBase Class
NFX.Wave.Filters Namespace


BeforeAfterFilterBase Constructor

BeforeAfterFilterBase Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BeforeAfterFilterBase(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the BeforeAfterFilterBase class
Public method | BeforeAfterFilterBase(WorkHandler, IConfigSectionNode) | Initializes a new instance of the BeforeAfterFilterBase class
Public method | BeforeAfterFilterBase(WorkDispatcher, String, Int32) | Initializes a new instance of the BeforeAfterFilterBase class
Public method | BeforeAfterFilterBase(WorkHandler, String, Int32) | Initializes a new instance of the BeforeAfterFilterBase class
Back to Top
See Also
BeforeAfterFilterBase Class
BeforeAfterFilterBase Members
NFX.Wave.Filters Namespace


BeforeAfterFilterBase Constructor (WorkDispatcher, IConfigSectionNode)

BeforeAfterFilterBase Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BeforeAfterFilterBase class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BeforeAfterFilterBase(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
public BeforeAfterFilterBase(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
public:
BeforeAfterFilterBase(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
public:
BeforeAfterFilterBase(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> BeforeAfterFilterBase
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> BeforeAfterFilterBase

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
BeforeAfterFilterBase Class
BeforeAfterFilterBase Members
BeforeAfterFilterBase Overload
NFX.Wave.Filters Namespace


BeforeAfterFilterBase Constructor (WorkHandler, IConfigSectionNode)

BeforeAfterFilterBase Constructor (WorkHandler, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BeforeAfterFilterBase class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BeforeAfterFilterBase(
    WorkHandler handler,
    IConfigSectionNode confNode
)
public BeforeAfterFilterBase(
    WorkHandler handler,
    IConfigSectionNode confNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
public:
BeforeAfterFilterBase(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
public:
BeforeAfterFilterBase(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> BeforeAfterFilterBase
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> BeforeAfterFilterBase

Parameters

handler
Type: NFX.Wave WorkHandler
confNode
Type: NFX.Environment IConfigSectionNode
See Also
BeforeAfterFilterBase Class
BeforeAfterFilterBase Members
BeforeAfterFilterBase Overload
NFX.Wave.Filters Namespace


BeforeAfterFilterBase Constructor (WorkDispatcher, String, Int32)

BeforeAfterFilterBase Constructor (WorkDispatcher, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BeforeAfterFilterBase class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BeforeAfterFilterBase(
    WorkDispatcher dispatcher,
    string name,
    int order
)
public BeforeAfterFilterBase(
    WorkDispatcher dispatcher,
    string name,
    int order
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
public:
BeforeAfterFilterBase(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
public:
BeforeAfterFilterBase(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> BeforeAfterFilterBase
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> BeforeAfterFilterBase

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
See Also
BeforeAfterFilterBase Class
BeforeAfterFilterBase Members
BeforeAfterFilterBase Overload
NFX.Wave.Filters Namespace


BeforeAfterFilterBase Constructor (WorkHandler, String, Int32)

BeforeAfterFilterBase Constructor (WorkHandler, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BeforeAfterFilterBase class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BeforeAfterFilterBase(
    WorkHandler handler,
    string name,
    int order
)
public BeforeAfterFilterBase(
    WorkHandler handler,
    string name,
    int order
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
public:
BeforeAfterFilterBase(
    WorkHandler^ handler,
    String^ name,
    int order
)
public:
BeforeAfterFilterBase(
    WorkHandler^ handler,
    String^ name,
    int order
)
new :
        handler : WorkHandler *
        name : string *
        order : int -> BeforeAfterFilterBase
new :
        handler : WorkHandler *
        name : string *
        order : int -> BeforeAfterFilterBase

Parameters

handler
Type: NFX.Wave WorkHandler
name
Type: Online System String
order
Type: Online System Int32
See Also
BeforeAfterFilterBase Class
BeforeAfterFilterBase Members
BeforeAfterFilterBase Overload
NFX.Wave.Filters Namespace


BeforeAfterFilterBase Fields

BeforeAfterFilterBase Fields NFX Class Library

The BeforeAfterFilterBase type exposes the following members.
Fields
Name | Description
CONFIG_AFTER_SECTION |
CONFIG_BEFORE_SECTION |
Back to Top
See Also
BeforeAfterFilterBase Class
NFX.Wave.Filters Namespace


BeforeAfterFilterBase.CONFIG_AFTER_SECTION Field

BeforeAfterFilterBase CONFIG_AFTER_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_AFTER_SECTION
public const string CONFIG_AFTER_SECTION
Public Const CONFIG_AFTER_SECTION As String
Public Const CONFIG_AFTER_SECTION As String
public:
literal String^ CONFIG_AFTER_SECTION
public:
literal String^ CONFIG_AFTER_SECTION
static val mutable CONFIG_AFTER_SECTION: string
static val mutable CONFIG_AFTER_SECTION: string

Field Value

Type: Online String
See Also
BeforeAfterFilterBase Class
BeforeAfterFilterBase Members
NFX.Wave.Filters Namespace


BeforeAfterFilterBase.CONFIG_BEFORE_SECTION Field

BeforeAfterFilterBase CONFIG_BEFORE_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_BEFORE_SECTION
public const string CONFIG_BEFORE_SECTION
Public Const CONFIG_BEFORE_SECTION As String
Public Const CONFIG_BEFORE_SECTION As String
public:
literal String^ CONFIG_BEFORE_SECTION
public:
literal String^ CONFIG_BEFORE_SECTION
static val mutable CONFIG_BEFORE_SECTION: string
static val mutable CONFIG_BEFORE_SECTION: string

Field Value

Type: Online String
See Also
BeforeAfterFilterBase Class
BeforeAfterFilterBase Members
NFX.Wave.Filters Namespace


BeforeAfterFilterBase Methods

BeforeAfterFilterBase Methods NFX Class Library

The BeforeAfterFilterBase type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAfterWork | Override to do the work when one of the AfterMatches was matched
Protected method | DoBeforeWork | Override to do the work when one of the BeforeMatches was matched
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BeforeAfterFilterBase Class
NFX.Wave.Filters Namespace


BeforeAfterFilterBase.DoAfterWork Method

BeforeAfterFilterBase DoAfterWork Method NFX Class Library

Override to do the work when one of the AfterMatches was matched

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoAfterWork(
    WorkContext work,
    JSONDataMap matched
)
protected abstract void DoAfterWork(
    WorkContext work,
    JSONDataMap matched
)
Protected MustOverride Sub DoAfterWork (
    work As WorkContext,
    matched As JSONDataMap
)
Protected MustOverride Sub DoAfterWork (
    work As WorkContext,
    matched As JSONDataMap
)
protected:
virtual void DoAfterWork(
    WorkContext^ work,
    JSONDataMap^ matched
) abstract
protected:
virtual void DoAfterWork(
    WorkContext^ work,
    JSONDataMap^ matched
) abstract
abstract DoAfterWork :
        work : WorkContext *
        matched : JSONDataMap -> unit
abstract DoAfterWork :
        work : WorkContext *
        matched : JSONDataMap -> unit

Parameters

work
Type: NFX.Wave WorkContext
matched
Type: NFX.Serialization.JSON JSONDataMap
See Also
BeforeAfterFilterBase Class
BeforeAfterFilterBase Members
NFX.Wave.Filters Namespace


BeforeAfterFilterBase.DoBeforeWork Method

BeforeAfterFilterBase DoBeforeWork Method NFX Class Library

Override to do the work when one of the BeforeMatches was matched

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoBeforeWork(
    WorkContext work,
    JSONDataMap matched
)
protected abstract void DoBeforeWork(
    WorkContext work,
    JSONDataMap matched
)
Protected MustOverride Sub DoBeforeWork (
    work As WorkContext,
    matched As JSONDataMap
)
Protected MustOverride Sub DoBeforeWork (
    work As WorkContext,
    matched As JSONDataMap
)
protected:
virtual void DoBeforeWork(
    WorkContext^ work,
    JSONDataMap^ matched
) abstract
protected:
virtual void DoBeforeWork(
    WorkContext^ work,
    JSONDataMap^ matched
) abstract
abstract DoBeforeWork :
        work : WorkContext *
        matched : JSONDataMap -> unit
abstract DoBeforeWork :
        work : WorkContext *
        matched : JSONDataMap -> unit

Parameters

work
Type: NFX.Wave WorkContext
matched
Type: NFX.Serialization.JSON JSONDataMap
See Also
BeforeAfterFilterBase Class
BeforeAfterFilterBase Members
NFX.Wave.Filters Namespace


BeforeAfterFilterBase.DoFilterWork Method

BeforeAfterFilterBase DoFilterWork Method NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override sealed void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
protected override sealed void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
Protected Overrides NotOverridable Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
Protected Overrides NotOverridable Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override sealed
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override sealed
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit

Parameters

work
Type: NFX.Wave WorkContext
filters
Type: Online System.Collections.Generic IList WorkFilter
thisFilterIndex
Type: Online System Int32
See Also
BeforeAfterFilterBase Class
BeforeAfterFilterBase Members
NFX.Wave.Filters Namespace


BeforeAfterFilterBase Properties

BeforeAfterFilterBase Properties NFX Class Library

The BeforeAfterFilterBase type exposes the following members.
Properties
 | Name | Description
Public property | AfterMatches | Returns matches used by the handler to determine whether match should be made before the work processing
Public property | BeforeMatches | Returns matches used by the handler to determine whether match should be made before the work processing
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Back to Top
See Also
BeforeAfterFilterBase Class
NFX.Wave.Filters Namespace


BeforeAfterFilterBase.AfterMatches Property

BeforeAfterFilterBase AfterMatches Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns matches used by the handler to determine whether match should be made before the work processing

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<WorkMatch> AfterMatches { get; }
public OrderedRegistry<WorkMatch> AfterMatches { get; }
Public ReadOnly Property AfterMatches As OrderedRegistry(Of WorkMatch)
    Get
Public ReadOnly Property AfterMatches As OrderedRegistry(Of WorkMatch)
    Get
public:
property OrderedRegistry<WorkMatch^>^ AfterMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
public:
property OrderedRegistry<WorkMatch^>^ AfterMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
member AfterMatches : OrderedRegistry<WorkMatch> with get
member AfterMatches : OrderedRegistry<WorkMatch> with get

Property Value

Type: OrderedRegistry WorkMatch
See Also
BeforeAfterFilterBase Class
BeforeAfterFilterBase Members
NFX.Wave.Filters Namespace


BeforeAfterFilterBase.BeforeMatches Property

BeforeAfterFilterBase BeforeMatches Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns matches used by the handler to determine whether match should be made before the work processing

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<WorkMatch> BeforeMatches { get; }
public OrderedRegistry<WorkMatch> BeforeMatches { get; }
Public ReadOnly Property BeforeMatches As OrderedRegistry(Of WorkMatch)
    Get
Public ReadOnly Property BeforeMatches As OrderedRegistry(Of WorkMatch)
    Get
public:
property OrderedRegistry<WorkMatch^>^ BeforeMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
public:
property OrderedRegistry<WorkMatch^>^ BeforeMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
member BeforeMatches : OrderedRegistry<WorkMatch> with get
member BeforeMatches : OrderedRegistry<WorkMatch> with get

Property Value

Type: OrderedRegistry WorkMatch
See Also
BeforeAfterFilterBase Class
BeforeAfterFilterBase Members
NFX.Wave.Filters Namespace


EffectiveCallerIPEndPointFilter Class

EffectiveCallerIPEndPointFilter Class NFX Class Library

Upon match, injects real caller WorkContext.EffectiveCallerIPEndPoint
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkFilter
NFX.Wave.Filters EffectiveCallerIPEndPointFilter

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class EffectiveCallerIPEndPointFilter : WorkFilter
public class EffectiveCallerIPEndPointFilter : WorkFilter
Public Class EffectiveCallerIPEndPointFilter
    Inherits WorkFilter
Public Class EffectiveCallerIPEndPointFilter
    Inherits WorkFilter
public ref class EffectiveCallerIPEndPointFilter : public WorkFilter
public ref class EffectiveCallerIPEndPointFilter : public WorkFilter
type EffectiveCallerIPEndPointFilter =
    class
        inherit WorkFilter
    end
type EffectiveCallerIPEndPointFilter =
    class
        inherit WorkFilter
    end
See Also
EffectiveCallerIPEndPointFilter Members
NFX.Wave.Filters Namespace


EffectiveCallerIPEndPointFilter Members

EffectiveCallerIPEndPointFilter Members NFX Class Library

The EffectiveCallerIPEndPointFilter type exposes the following members.
Constructors
 | Name | Description
Public method | EffectiveCallerIPEndPointFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the EffectiveCallerIPEndPointFilter class
Public method | EffectiveCallerIPEndPointFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the EffectiveCallerIPEndPointFilter class
Public method | EffectiveCallerIPEndPointFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the EffectiveCallerIPEndPointFilter class
Public method | EffectiveCallerIPEndPointFilter(WorkHandler, String, Int32) | Initializes a new instance of the EffectiveCallerIPEndPointFilter class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | RealIpHdr |
Public property | RealPortHdr |
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Back to Top
See Also
EffectiveCallerIPEndPointFilter Class
NFX.Wave.Filters Namespace


EffectiveCallerIPEndPointFilter Constructor

EffectiveCallerIPEndPointFilter Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | EffectiveCallerIPEndPointFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the EffectiveCallerIPEndPointFilter class
Public method | EffectiveCallerIPEndPointFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the EffectiveCallerIPEndPointFilter class
Public method | EffectiveCallerIPEndPointFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the EffectiveCallerIPEndPointFilter class
Public method | EffectiveCallerIPEndPointFilter(WorkHandler, String, Int32) | Initializes a new instance of the EffectiveCallerIPEndPointFilter class
Back to Top
See Also
EffectiveCallerIPEndPointFilter Class
EffectiveCallerIPEndPointFilter Members
NFX.Wave.Filters Namespace


EffectiveCallerIPEndPointFilter Constructor (WorkDispatcher, IConfigSectionNode)

EffectiveCallerIPEndPointFilter Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EffectiveCallerIPEndPointFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EffectiveCallerIPEndPointFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
public EffectiveCallerIPEndPointFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
public:
EffectiveCallerIPEndPointFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
public:
EffectiveCallerIPEndPointFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> EffectiveCallerIPEndPointFilter
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> EffectiveCallerIPEndPointFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
EffectiveCallerIPEndPointFilter Class
EffectiveCallerIPEndPointFilter Members
EffectiveCallerIPEndPointFilter Overload
NFX.Wave.Filters Namespace


EffectiveCallerIPEndPointFilter Constructor (WorkHandler, IConfigSectionNode)

EffectiveCallerIPEndPointFilter Constructor (WorkHandler, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EffectiveCallerIPEndPointFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EffectiveCallerIPEndPointFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
public EffectiveCallerIPEndPointFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
public:
EffectiveCallerIPEndPointFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
public:
EffectiveCallerIPEndPointFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> EffectiveCallerIPEndPointFilter
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> EffectiveCallerIPEndPointFilter

Parameters

handler
Type: NFX.Wave WorkHandler
confNode
Type: NFX.Environment IConfigSectionNode
See Also
EffectiveCallerIPEndPointFilter Class
EffectiveCallerIPEndPointFilter Members
EffectiveCallerIPEndPointFilter Overload
NFX.Wave.Filters Namespace


EffectiveCallerIPEndPointFilter Constructor (WorkDispatcher, String, Int32)

EffectiveCallerIPEndPointFilter Constructor (WorkDispatcher, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EffectiveCallerIPEndPointFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EffectiveCallerIPEndPointFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
public EffectiveCallerIPEndPointFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
public:
EffectiveCallerIPEndPointFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
public:
EffectiveCallerIPEndPointFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> EffectiveCallerIPEndPointFilter
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> EffectiveCallerIPEndPointFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
See Also
EffectiveCallerIPEndPointFilter Class
EffectiveCallerIPEndPointFilter Members
EffectiveCallerIPEndPointFilter Overload
NFX.Wave.Filters Namespace


EffectiveCallerIPEndPointFilter Constructor (WorkHandler, String, Int32)

EffectiveCallerIPEndPointFilter Constructor (WorkHandler, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EffectiveCallerIPEndPointFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EffectiveCallerIPEndPointFilter(
    WorkHandler handler,
    string name,
    int order
)
public EffectiveCallerIPEndPointFilter(
    WorkHandler handler,
    string name,
    int order
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
public:
EffectiveCallerIPEndPointFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
public:
EffectiveCallerIPEndPointFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
new :
        handler : WorkHandler *
        name : string *
        order : int -> EffectiveCallerIPEndPointFilter
new :
        handler : WorkHandler *
        name : string *
        order : int -> EffectiveCallerIPEndPointFilter

Parameters

handler
Type: NFX.Wave WorkHandler
name
Type: Online System String
order
Type: Online System Int32
See Also
EffectiveCallerIPEndPointFilter Class
EffectiveCallerIPEndPointFilter Members
EffectiveCallerIPEndPointFilter Overload
NFX.Wave.Filters Namespace


EffectiveCallerIPEndPointFilter Methods

EffectiveCallerIPEndPointFilter Methods NFX Class Library

The EffectiveCallerIPEndPointFilter type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
EffectiveCallerIPEndPointFilter Class
NFX.Wave.Filters Namespace


EffectiveCallerIPEndPointFilter.DoFilterWork Method

EffectiveCallerIPEndPointFilter DoFilterWork Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
protected override void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
Protected Overrides Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
Protected Overrides Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit

Parameters

work
Type: NFX.Wave WorkContext
filters
Type: Online System.Collections.Generic IList WorkFilter
thisFilterIndex
Type: Online System Int32
See Also
EffectiveCallerIPEndPointFilter Class
EffectiveCallerIPEndPointFilter Members
NFX.Wave.Filters Namespace


EffectiveCallerIPEndPointFilter Properties

EffectiveCallerIPEndPointFilter Properties NFX Class Library

The EffectiveCallerIPEndPointFilter type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | RealIpHdr |
Public property | RealPortHdr |
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Back to Top
See Also
EffectiveCallerIPEndPointFilter Class
NFX.Wave.Filters Namespace


EffectiveCallerIPEndPointFilter.RealIpHdr Property

EffectiveCallerIPEndPointFilter RealIpHdr Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string RealIpHdr { get; set; }
[ConfigAttribute]
public string RealIpHdr { get; set; }
<ConfigAttribute>
Public Property RealIpHdr As String
    Get
    Set
<ConfigAttribute>
Public Property RealIpHdr As String
    Get
    Set
public:
[ConfigAttribute]
property String^ RealIpHdr {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ RealIpHdr {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member RealIpHdr : string with get, set
[<ConfigAttribute>]
member RealIpHdr : string with get, set

Property Value

Type: Online String
See Also
EffectiveCallerIPEndPointFilter Class
EffectiveCallerIPEndPointFilter Members
NFX.Wave.Filters Namespace


EffectiveCallerIPEndPointFilter.RealPortHdr Property

EffectiveCallerIPEndPointFilter RealPortHdr Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string RealPortHdr { get; set; }
[ConfigAttribute]
public string RealPortHdr { get; set; }
<ConfigAttribute>
Public Property RealPortHdr As String
    Get
    Set
<ConfigAttribute>
Public Property RealPortHdr As String
    Get
    Set
public:
[ConfigAttribute]
property String^ RealPortHdr {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ RealPortHdr {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member RealPortHdr : string with get, set
[<ConfigAttribute>]
member RealPortHdr : string with get, set

Property Value

Type: Online String
See Also
EffectiveCallerIPEndPointFilter Class
EffectiveCallerIPEndPointFilter Members
NFX.Wave.Filters Namespace


ErrorFilter Class

ErrorFilter Class NFX Class Library

Intercepts error that arise during processing and displays an error page for exceptions and error codes
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkFilter
NFX.Wave.Filters ErrorFilter

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ErrorFilter : WorkFilter
public sealed class ErrorFilter : WorkFilter
Public NotInheritable Class ErrorFilter
    Inherits WorkFilter
Public NotInheritable Class ErrorFilter
    Inherits WorkFilter
public ref class ErrorFilter sealed : public WorkFilter
public ref class ErrorFilter sealed : public WorkFilter
[<SealedAttribute>]
type ErrorFilter =
    class
        inherit WorkFilter
    end
[<SealedAttribute>]
type ErrorFilter =
    class
        inherit WorkFilter
    end
See Also
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter Members

ErrorFilter Members NFX Class Library

The ErrorFilter type exposes the following members.
Constructors
 | Name | Description
Public method | ErrorFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the ErrorFilter class
Public method | ErrorFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the ErrorFilter class
Public method | ErrorFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the ErrorFilter class
Public method | ErrorFilter(WorkHandler, String, Int32) | Initializes a new instance of the ErrorFilter class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
 | ConfigureMatches |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | HandleException | Handles the exception by responding appropriately with error page with conditional level of details and logging
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_LOG_SECTION |
CONFIG_SECURITY_REDIRECT_SECTION |
CONFIG_SHOW_DUMP_SECTION |
VAR_SECURITY_REDIRECT_TARGET |
VAR_SECURITY_REDIRECT_URL |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | CustomErrorPageType | Specifies a type for custom error page. Must be WebTemplate-derived type
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | LogMatches | Returns matches used by the filter to determine whether exception details should be logged
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | SecurityRedirectMatches | Returns matches used by the filter to supply custom redirect urls via redirect-url and redirect-target variables
Public property | SecurityRedirectTarget | When set redirects response to the specified URL if security exceptions are thrown
Public property | SecurityRedirectURL | When set redirects response to the specified URL if security exceptions are thrown
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Public property | ShowDumpMatches | Returns matches used by the filter to determine whether exception details should be shown
Back to Top
See Also
ErrorFilter Class
NFX.Wave.Filters Namespace


ErrorFilter Constructor

ErrorFilter Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErrorFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the ErrorFilter class
Public method | ErrorFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the ErrorFilter class
Public method | ErrorFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the ErrorFilter class
Public method | ErrorFilter(WorkHandler, String, Int32) | Initializes a new instance of the ErrorFilter class
Back to Top
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter Constructor (WorkDispatcher, IConfigSectionNode)

ErrorFilter Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErrorFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErrorFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
public ErrorFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
public:
ErrorFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
public:
ErrorFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> ErrorFilter
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> ErrorFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
ErrorFilter Class
ErrorFilter Members
ErrorFilter Overload
NFX.Wave.Filters Namespace


ErrorFilter Constructor (WorkHandler, IConfigSectionNode)

ErrorFilter Constructor (WorkHandler, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErrorFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErrorFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
public ErrorFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
public:
ErrorFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
public:
ErrorFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> ErrorFilter
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> ErrorFilter

Parameters

handler
Type: NFX.Wave WorkHandler
confNode
Type: NFX.Environment IConfigSectionNode
See Also
ErrorFilter Class
ErrorFilter Members
ErrorFilter Overload
NFX.Wave.Filters Namespace


ErrorFilter Constructor (WorkDispatcher, String, Int32)

ErrorFilter Constructor (WorkDispatcher, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErrorFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErrorFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
public ErrorFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
public:
ErrorFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
public:
ErrorFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> ErrorFilter
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> ErrorFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
See Also
ErrorFilter Class
ErrorFilter Members
ErrorFilter Overload
NFX.Wave.Filters Namespace


ErrorFilter Constructor (WorkHandler, String, Int32)

ErrorFilter Constructor (WorkHandler, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErrorFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErrorFilter(
    WorkHandler handler,
    string name,
    int order
)
public ErrorFilter(
    WorkHandler handler,
    string name,
    int order
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
public:
ErrorFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
public:
ErrorFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
new :
        handler : WorkHandler *
        name : string *
        order : int -> ErrorFilter
new :
        handler : WorkHandler *
        name : string *
        order : int -> ErrorFilter

Parameters

handler
Type: NFX.Wave WorkHandler
name
Type: Online System String
order
Type: Online System Int32
See Also
ErrorFilter Class
ErrorFilter Members
ErrorFilter Overload
NFX.Wave.Filters Namespace


ErrorFilter Fields

ErrorFilter Fields NFX Class Library

The ErrorFilter type exposes the following members.
Fields
Name | Description
CONFIG_LOG_SECTION |
CONFIG_SECURITY_REDIRECT_SECTION |
CONFIG_SHOW_DUMP_SECTION |
VAR_SECURITY_REDIRECT_TARGET |
VAR_SECURITY_REDIRECT_URL |
Back to Top
See Also
ErrorFilter Class
NFX.Wave.Filters Namespace


ErrorFilter.CONFIG_LOG_SECTION Field

ErrorFilter CONFIG_LOG_SECTION Field NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_LOG_SECTION
public const string CONFIG_LOG_SECTION
Public Const CONFIG_LOG_SECTION As String
Public Const CONFIG_LOG_SECTION As String
public:
literal String^ CONFIG_LOG_SECTION
public:
literal String^ CONFIG_LOG_SECTION
static val mutable CONFIG_LOG_SECTION: string
static val mutable CONFIG_LOG_SECTION: string

Field Value

Type: Online String
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter.CONFIG_SECURITY_REDIRECT_SECTION Field

ErrorFilter CONFIG_SECURITY_REDIRECT_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SECURITY_REDIRECT_SECTION
public const string CONFIG_SECURITY_REDIRECT_SECTION
Public Const CONFIG_SECURITY_REDIRECT_SECTION As String
Public Const CONFIG_SECURITY_REDIRECT_SECTION As String
public:
literal String^ CONFIG_SECURITY_REDIRECT_SECTION
public:
literal String^ CONFIG_SECURITY_REDIRECT_SECTION
static val mutable CONFIG_SECURITY_REDIRECT_SECTION: string
static val mutable CONFIG_SECURITY_REDIRECT_SECTION: string

Field Value

Type: Online String
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter.CONFIG_SHOW_DUMP_SECTION Field

ErrorFilter CONFIG_SHOW_DUMP_SECTION Field NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SHOW_DUMP_SECTION
public const string CONFIG_SHOW_DUMP_SECTION
Public Const CONFIG_SHOW_DUMP_SECTION As String
Public Const CONFIG_SHOW_DUMP_SECTION As String
public:
literal String^ CONFIG_SHOW_DUMP_SECTION
public:
literal String^ CONFIG_SHOW_DUMP_SECTION
static val mutable CONFIG_SHOW_DUMP_SECTION: string
static val mutable CONFIG_SHOW_DUMP_SECTION: string

Field Value

Type: Online String
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter.VAR_SECURITY_REDIRECT_TARGET Field

ErrorFilter VAR_SECURITY_REDIRECT_TARGET Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_SECURITY_REDIRECT_TARGET
public const string VAR_SECURITY_REDIRECT_TARGET
Public Const VAR_SECURITY_REDIRECT_TARGET As String
Public Const VAR_SECURITY_REDIRECT_TARGET As String
public:
literal String^ VAR_SECURITY_REDIRECT_TARGET
public:
literal String^ VAR_SECURITY_REDIRECT_TARGET
static val mutable VAR_SECURITY_REDIRECT_TARGET: string
static val mutable VAR_SECURITY_REDIRECT_TARGET: string

Field Value

Type: Online String
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter.VAR_SECURITY_REDIRECT_URL Field

ErrorFilter VAR_SECURITY_REDIRECT_URL Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_SECURITY_REDIRECT_URL
public const string VAR_SECURITY_REDIRECT_URL
Public Const VAR_SECURITY_REDIRECT_URL As String
Public Const VAR_SECURITY_REDIRECT_URL As String
public:
literal String^ VAR_SECURITY_REDIRECT_URL
public:
literal String^ VAR_SECURITY_REDIRECT_URL
static val mutable VAR_SECURITY_REDIRECT_URL: string
static val mutable VAR_SECURITY_REDIRECT_URL: string

Field Value

Type: Online String
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter Methods

ErrorFilter Methods NFX Class Library

The ErrorFilter type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
 | ConfigureMatches |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | HandleException | Handles the exception by responding appropriately with error page with conditional level of details and logging
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErrorFilter Class
NFX.Wave.Filters Namespace


ErrorFilter.ConfigureMatches Method

ErrorFilter ConfigureMatches Method NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static void ConfigureMatches(
    IConfigSectionNode confNode,
    OrderedRegistry<WorkMatch> showDumpMatches,
    OrderedRegistry<WorkMatch> logMatches,
    OrderedRegistry<WorkMatch> securityRedirectMatches,
    string from
)
internal static void ConfigureMatches(
    IConfigSectionNode confNode,
    OrderedRegistry<WorkMatch> showDumpMatches,
    OrderedRegistry<WorkMatch> logMatches,
    OrderedRegistry<WorkMatch> securityRedirectMatches,
    string from
)
Friend Shared Sub ConfigureMatches (
    confNode As IConfigSectionNode,
    showDumpMatches As OrderedRegistry(Of WorkMatch),
    logMatches As OrderedRegistry(Of WorkMatch),
    securityRedirectMatches As OrderedRegistry(Of WorkMatch),
    from As String
)
Friend Shared Sub ConfigureMatches (
    confNode As IConfigSectionNode,
    showDumpMatches As OrderedRegistry(Of WorkMatch),
    logMatches As OrderedRegistry(Of WorkMatch),
    securityRedirectMatches As OrderedRegistry(Of WorkMatch),
    from As String
)
internal:
static void ConfigureMatches(
    IConfigSectionNode^ confNode,
    OrderedRegistry<WorkMatch^>^ showDumpMatches,
    OrderedRegistry<WorkMatch^>^ logMatches,
    OrderedRegistry<WorkMatch^>^ securityRedirectMatches,
    String^ from
)
internal:
static void ConfigureMatches(
    IConfigSectionNode^ confNode,
    OrderedRegistry<WorkMatch^>^ showDumpMatches,
    OrderedRegistry<WorkMatch^>^ logMatches,
    OrderedRegistry<WorkMatch^>^ securityRedirectMatches,
    String^ from
)
internal static member ConfigureMatches :
        confNode : IConfigSectionNode *
        showDumpMatches : OrderedRegistry<WorkMatch> *
        logMatches : OrderedRegistry<WorkMatch> *
        securityRedirectMatches : OrderedRegistry<WorkMatch> *
        from : string -> unit
internal static member ConfigureMatches :
        confNode : IConfigSectionNode *
        showDumpMatches : OrderedRegistry<WorkMatch> *
        logMatches : OrderedRegistry<WorkMatch> *
        securityRedirectMatches : OrderedRegistry<WorkMatch> *
        from : string -> unit

Parameters

confNode
Type: NFX.Environment IConfigSectionNode
showDumpMatches
Type: NFX OrderedRegistry WorkMatch
logMatches
Type: NFX OrderedRegistry WorkMatch
securityRedirectMatches
Type: NFX OrderedRegistry WorkMatch
from
Type: Online System String
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter.DoFilterWork Method

ErrorFilter DoFilterWork Method NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
protected override void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
Protected Overrides Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
Protected Overrides Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit

Parameters

work
Type: NFX.Wave WorkContext
filters
Type: Online System.Collections.Generic IList WorkFilter
thisFilterIndex
Type: Online System Int32
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter.HandleException Method

ErrorFilter HandleException Method NFX Class Library

Handles the exception by responding appropriately with error page with conditional level of details and logging

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void HandleException(
    WorkContext work,
    Exception error,
    OrderedRegistry<WorkMatch> showDumpMatches,
    OrderedRegistry<WorkMatch> logMatches,
    string securityRedirectURL = null,
    string secrurityRedirectTarget = null,
    OrderedRegistry<WorkMatch> securityRedirectMatches = null,
    Type customPageType = null
)
public static void HandleException(
    WorkContext work,
    Exception error,
    OrderedRegistry<WorkMatch> showDumpMatches,
    OrderedRegistry<WorkMatch> logMatches,
    string securityRedirectURL = null,
    string secrurityRedirectTarget = null,
    OrderedRegistry<WorkMatch> securityRedirectMatches = null,
    Type customPageType = null
)
Public Shared Sub HandleException (
    work As WorkContext,
    error As Exception,
    showDumpMatches As OrderedRegistry(Of WorkMatch),
    logMatches As OrderedRegistry(Of WorkMatch),
    Optional securityRedirectURL As String = Nothing,
    Optional secrurityRedirectTarget As String = Nothing,
    Optional securityRedirectMatches As OrderedRegistry(Of WorkMatch) = Nothing,
    Optional customPageType As Type = Nothing
)
Public Shared Sub HandleException (
    work As WorkContext,
    error As Exception,
    showDumpMatches As OrderedRegistry(Of WorkMatch),
    logMatches As OrderedRegistry(Of WorkMatch),
    Optional securityRedirectURL As String = Nothing,
    Optional secrurityRedirectTarget As String = Nothing,
    Optional securityRedirectMatches As OrderedRegistry(Of WorkMatch) = Nothing,
    Optional customPageType As Type = Nothing
)
public:
static void HandleException(
    WorkContext^ work,
    Exception^ error,
    OrderedRegistry<WorkMatch^>^ showDumpMatches,
    OrderedRegistry<WorkMatch^>^ logMatches,
    String^ securityRedirectURL = nullptr,
    String^ secrurityRedirectTarget = nullptr,
    OrderedRegistry<WorkMatch^>^ securityRedirectMatches = nullptr,
    Type^ customPageType = nullptr
)
public:
static void HandleException(
    WorkContext^ work,
    Exception^ error,
    OrderedRegistry<WorkMatch^>^ showDumpMatches,
    OrderedRegistry<WorkMatch^>^ logMatches,
    String^ securityRedirectURL = nullptr,
    String^ secrurityRedirectTarget = nullptr,
    OrderedRegistry<WorkMatch^>^ securityRedirectMatches = nullptr,
    Type^ customPageType = nullptr
)
static member HandleException :
        work : WorkContext *
        error : Exception *
        showDumpMatches : OrderedRegistry<WorkMatch> *
        logMatches : OrderedRegistry<WorkMatch> *
        ?securityRedirectURL : string *
        ?secrurityRedirectTarget : string *
        ?securityRedirectMatches : OrderedRegistry<WorkMatch> *
        ?customPageType : Type
(* Defaults:
        let _securityRedirectURL = defaultArg securityRedirectURL null
        let _secrurityRedirectTarget = defaultArg secrurityRedirectTarget null
        let _securityRedirectMatches = defaultArg securityRedirectMatches null
        let _customPageType = defaultArg customPageType null
*)
-> unit
static member HandleException :
        work : WorkContext *
        error : Exception *
        showDumpMatches : OrderedRegistry<WorkMatch> *
        logMatches : OrderedRegistry<WorkMatch> *
        ?securityRedirectURL : string *
        ?secrurityRedirectTarget : string *
        ?securityRedirectMatches : OrderedRegistry<WorkMatch> *
        ?customPageType : Type
(* Defaults:
        let _securityRedirectURL = defaultArg securityRedirectURL null
        let _secrurityRedirectTarget = defaultArg secrurityRedirectTarget null
        let _securityRedirectMatches = defaultArg securityRedirectMatches null
        let _customPageType = defaultArg customPageType null
*)
-> unit

Parameters

work
Type: NFX.Wave WorkContext
error
Type: Online System Exception
showDumpMatches
Type: NFX OrderedRegistry WorkMatch
logMatches
Type: NFX OrderedRegistry WorkMatch
securityRedirectURL (Optional)
Type: Online System String
secrurityRedirectTarget (Optional)
Type: Online System String
securityRedirectMatches (Optional)
Type: NFX OrderedRegistry WorkMatch
customPageType (Optional)
Type: Online System Type
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter Properties

ErrorFilter Properties NFX Class Library

The ErrorFilter type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | CustomErrorPageType | Specifies a type for custom error page. Must be WebTemplate-derived type
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | LogMatches | Returns matches used by the filter to determine whether exception details should be logged
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | SecurityRedirectMatches | Returns matches used by the filter to supply custom redirect urls via redirect-url and redirect-target variables
Public property | SecurityRedirectTarget | When set redirects response to the specified URL if security exceptions are thrown
Public property | SecurityRedirectURL | When set redirects response to the specified URL if security exceptions are thrown
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Public property | ShowDumpMatches | Returns matches used by the filter to determine whether exception details should be shown
Back to Top
See Also
ErrorFilter Class
NFX.Wave.Filters Namespace


ErrorFilter.CustomErrorPageType Property

ErrorFilter CustomErrorPageType Property NFX Class Library

Specifies a type for custom error page. Must be WebTemplate-derived type

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string CustomErrorPageType { get; set; }
[ConfigAttribute]
public string CustomErrorPageType { get; set; }
<ConfigAttribute>
Public Property CustomErrorPageType As String
    Get
    Set
<ConfigAttribute>
Public Property CustomErrorPageType As String
    Get
    Set
public:
[ConfigAttribute]
property String^ CustomErrorPageType {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ CustomErrorPageType {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member CustomErrorPageType : string with get, set
[<ConfigAttribute>]
member CustomErrorPageType : string with get, set

Property Value

Type: Online String
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter.LogMatches Property

ErrorFilter LogMatches Property NFX Class Library

Returns matches used by the filter to determine whether exception details should be logged

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<WorkMatch> LogMatches { get; }
public OrderedRegistry<WorkMatch> LogMatches { get; }
Public ReadOnly Property LogMatches As OrderedRegistry(Of WorkMatch)
    Get
Public ReadOnly Property LogMatches As OrderedRegistry(Of WorkMatch)
    Get
public:
property OrderedRegistry<WorkMatch^>^ LogMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
public:
property OrderedRegistry<WorkMatch^>^ LogMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
member LogMatches : OrderedRegistry<WorkMatch> with get
member LogMatches : OrderedRegistry<WorkMatch> with get

Property Value

Type: OrderedRegistry WorkMatch
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter.SecurityRedirectMatches Property

ErrorFilter SecurityRedirectMatches Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns matches used by the filter to supply custom redirect urls via redirect-url and redirect-target variables

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<WorkMatch> SecurityRedirectMatches { get; }
public OrderedRegistry<WorkMatch> SecurityRedirectMatches { get; }
Public ReadOnly Property SecurityRedirectMatches As OrderedRegistry(Of WorkMatch)
    Get
Public ReadOnly Property SecurityRedirectMatches As OrderedRegistry(Of WorkMatch)
    Get
public:
property OrderedRegistry<WorkMatch^>^ SecurityRedirectMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
public:
property OrderedRegistry<WorkMatch^>^ SecurityRedirectMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
member SecurityRedirectMatches : OrderedRegistry<WorkMatch> with get
member SecurityRedirectMatches : OrderedRegistry<WorkMatch> with get

Property Value

Type: OrderedRegistry WorkMatch
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter.SecurityRedirectTarget Property

ErrorFilter SecurityRedirectTarget Property NFX Class Library

[This is preliminary documentation and is subject to change.]

When set redirects response to the specified URL if security exceptions are thrown

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string SecurityRedirectTarget { get; set; }
[ConfigAttribute]
public string SecurityRedirectTarget { get; set; }
<ConfigAttribute>
Public Property SecurityRedirectTarget As String
    Get
    Set
<ConfigAttribute>
Public Property SecurityRedirectTarget As String
    Get
    Set
public:
[ConfigAttribute]
property String^ SecurityRedirectTarget {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ SecurityRedirectTarget {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member SecurityRedirectTarget : string with get, set
[<ConfigAttribute>]
member SecurityRedirectTarget : string with get, set

Property Value

Type: Online String
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter.SecurityRedirectURL Property

ErrorFilter SecurityRedirectURL Property NFX Class Library

When set redirects response to the specified URL if security exceptions are thrown

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string SecurityRedirectURL { get; set; }
[ConfigAttribute]
public string SecurityRedirectURL { get; set; }
<ConfigAttribute>
Public Property SecurityRedirectURL As String
    Get
    Set
<ConfigAttribute>
Public Property SecurityRedirectURL As String
    Get
    Set
public:
[ConfigAttribute]
property String^ SecurityRedirectURL {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ SecurityRedirectURL {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member SecurityRedirectURL : string with get, set
[<ConfigAttribute>]
member SecurityRedirectURL : string with get, set

Property Value

Type: Online String
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


ErrorFilter.ShowDumpMatches Property

ErrorFilter ShowDumpMatches Property NFX Class Library

Returns matches used by the filter to determine whether exception details should be shown

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<WorkMatch> ShowDumpMatches { get; }
public OrderedRegistry<WorkMatch> ShowDumpMatches { get; }
Public ReadOnly Property ShowDumpMatches As OrderedRegistry(Of WorkMatch)
    Get
Public ReadOnly Property ShowDumpMatches As OrderedRegistry(Of WorkMatch)
    Get
public:
property OrderedRegistry<WorkMatch^>^ ShowDumpMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
public:
property OrderedRegistry<WorkMatch^>^ ShowDumpMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
member ShowDumpMatches : OrderedRegistry<WorkMatch> with get
member ShowDumpMatches : OrderedRegistry<WorkMatch> with get

Property Value

Type: OrderedRegistry WorkMatch
See Also
ErrorFilter Class
ErrorFilter Members
NFX.Wave.Filters Namespace


GeoLookupFilter Class

GeoLookupFilter Class NFX Class Library

Upon match, looks up user's geo location based on a IP addresses
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkFilter
NFX.Wave.Filters GeoLookupFilter

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GeoLookupFilter : WorkFilter
public class GeoLookupFilter : WorkFilter
Public Class GeoLookupFilter
    Inherits WorkFilter
Public Class GeoLookupFilter
    Inherits WorkFilter
public ref class GeoLookupFilter : public WorkFilter
public ref class GeoLookupFilter : public WorkFilter
type GeoLookupFilter =
    class
        inherit WorkFilter
    end
type GeoLookupFilter =
    class
        inherit WorkFilter
    end
See Also
GeoLookupFilter Members
NFX.Wave.Filters Namespace


GeoLookupFilter Members

GeoLookupFilter Members NFX Class Library

The GeoLookupFilter type exposes the following members.
Constructors
 | Name | Description
Public method | GeoLookupFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the GeoLookupFilter class
Public method | GeoLookupFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the GeoLookupFilter class
Public method | GeoLookupFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the GeoLookupFilter class
Public method | GeoLookupFilter(WorkHandler, String, Int32) | Initializes a new instance of the GeoLookupFilter class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
VAR_USE_ADDR | Allows to override user real address with this one
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | LookupMatches | Returns matches used by the filter to determine whether user's location should be looked-up
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Back to Top
See Also
GeoLookupFilter Class
NFX.Wave.Filters Namespace


GeoLookupFilter Constructor

GeoLookupFilter Constructor NFX Class Library

Overload List
 | Name | Description
Public method | GeoLookupFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the GeoLookupFilter class
Public method | GeoLookupFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the GeoLookupFilter class
Public method | GeoLookupFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the GeoLookupFilter class
Public method | GeoLookupFilter(WorkHandler, String, Int32) | Initializes a new instance of the GeoLookupFilter class
Back to Top
See Also
GeoLookupFilter Class
GeoLookupFilter Members
NFX.Wave.Filters Namespace


GeoLookupFilter Constructor (WorkDispatcher, IConfigSectionNode)

GeoLookupFilter Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GeoLookupFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GeoLookupFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
public GeoLookupFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
public:
GeoLookupFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
public:
GeoLookupFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> GeoLookupFilter
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> GeoLookupFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
GeoLookupFilter Class
GeoLookupFilter Members
GeoLookupFilter Overload
NFX.Wave.Filters Namespace


GeoLookupFilter Constructor (WorkHandler, IConfigSectionNode)

GeoLookupFilter Constructor (WorkHandler, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GeoLookupFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GeoLookupFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
public GeoLookupFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
public:
GeoLookupFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
public:
GeoLookupFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> GeoLookupFilter
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> GeoLookupFilter

Parameters

handler
Type: NFX.Wave WorkHandler
confNode
Type: NFX.Environment IConfigSectionNode
See Also
GeoLookupFilter Class
GeoLookupFilter Members
GeoLookupFilter Overload
NFX.Wave.Filters Namespace


GeoLookupFilter Constructor (WorkDispatcher, String, Int32)

GeoLookupFilter Constructor (WorkDispatcher, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GeoLookupFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GeoLookupFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
public GeoLookupFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
public:
GeoLookupFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
public:
GeoLookupFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> GeoLookupFilter
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> GeoLookupFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
See Also
GeoLookupFilter Class
GeoLookupFilter Members
GeoLookupFilter Overload
NFX.Wave.Filters Namespace


GeoLookupFilter Constructor (WorkHandler, String, Int32)

GeoLookupFilter Constructor (WorkHandler, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GeoLookupFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GeoLookupFilter(
    WorkHandler handler,
    string name,
    int order
)
public GeoLookupFilter(
    WorkHandler handler,
    string name,
    int order
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
public:
GeoLookupFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
public:
GeoLookupFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
new :
        handler : WorkHandler *
        name : string *
        order : int -> GeoLookupFilter
new :
        handler : WorkHandler *
        name : string *
        order : int -> GeoLookupFilter

Parameters

handler
Type: NFX.Wave WorkHandler
name
Type: Online System String
order
Type: Online System Int32
See Also
GeoLookupFilter Class
GeoLookupFilter Members
GeoLookupFilter Overload
NFX.Wave.Filters Namespace


GeoLookupFilter Fields

GeoLookupFilter Fields NFX Class Library

The GeoLookupFilter type exposes the following members.
Fields
Name | Description
VAR_USE_ADDR | Allows to override user real address with this one
Back to Top
See Also
GeoLookupFilter Class
NFX.Wave.Filters Namespace


GeoLookupFilter.VAR_USE_ADDR Field

GeoLookupFilter VAR_USE_ADDR Field NFX Class Library

Allows to override user real address with this one

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_USE_ADDR
public const string VAR_USE_ADDR
Public Const VAR_USE_ADDR As String
Public Const VAR_USE_ADDR As String
public:
literal String^ VAR_USE_ADDR
public:
literal String^ VAR_USE_ADDR
static val mutable VAR_USE_ADDR: string
static val mutable VAR_USE_ADDR: string

Field Value

Type: Online String
See Also
GeoLookupFilter Class
GeoLookupFilter Members
NFX.Wave.Filters Namespace


GeoLookupFilter Methods

GeoLookupFilter Methods NFX Class Library

The GeoLookupFilter type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GeoLookupFilter Class
NFX.Wave.Filters Namespace


GeoLookupFilter.DoFilterWork Method

GeoLookupFilter DoFilterWork Method NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
protected override void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
Protected Overrides Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
Protected Overrides Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit

Parameters

work
Type: NFX.Wave WorkContext
filters
Type: Online System.Collections.Generic IList WorkFilter
thisFilterIndex
Type: Online System Int32
See Also
GeoLookupFilter Class
GeoLookupFilter Members
NFX.Wave.Filters Namespace


GeoLookupFilter Properties

GeoLookupFilter Properties NFX Class Library

The GeoLookupFilter type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | LookupMatches | Returns matches used by the filter to determine whether user's location should be looked-up
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Back to Top
See Also
GeoLookupFilter Class
NFX.Wave.Filters Namespace


GeoLookupFilter.LookupMatches Property

GeoLookupFilter LookupMatches Property NFX Class Library

Returns matches used by the filter to determine whether user's location should be looked-up

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<WorkMatch> LookupMatches { get; }
public OrderedRegistry<WorkMatch> LookupMatches { get; }
Public ReadOnly Property LookupMatches As OrderedRegistry(Of WorkMatch)
    Get
Public ReadOnly Property LookupMatches As OrderedRegistry(Of WorkMatch)
    Get
public:
property OrderedRegistry<WorkMatch^>^ LookupMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
public:
property OrderedRegistry<WorkMatch^>^ LookupMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
member LookupMatches : OrderedRegistry<WorkMatch> with get
member LookupMatches : OrderedRegistry<WorkMatch> with get

Property Value

Type: OrderedRegistry WorkMatch
See Also
GeoLookupFilter Class
GeoLookupFilter Members
NFX.Wave.Filters Namespace


LoggingFilter Class

LoggingFilter Class NFX Class Library

Logs information extracted from WorkContext
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkFilter
NFX.Wave.Filters BeforeAfterFilterBase
NFX.Wave.Filters LoggingFilter

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LoggingFilter : BeforeAfterFilterBase
public class LoggingFilter : BeforeAfterFilterBase
Public Class LoggingFilter
    Inherits BeforeAfterFilterBase
Public Class LoggingFilter
    Inherits BeforeAfterFilterBase
public ref class LoggingFilter : public BeforeAfterFilterBase
public ref class LoggingFilter : public BeforeAfterFilterBase
type LoggingFilter =
    class
        inherit BeforeAfterFilterBase
    end
type LoggingFilter =
    class
        inherit BeforeAfterFilterBase
    end
See Also
LoggingFilter Members
NFX.Wave.Filters Namespace


LoggingFilter Members

LoggingFilter Members NFX Class Library

The LoggingFilter type exposes the following members.
Constructors
 | Name | Description
Public method | LoggingFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the LoggingFilter class
Public method | LoggingFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the LoggingFilter class
Public method | LoggingFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the LoggingFilter class
Public method | LoggingFilter(WorkHandler, String, Int32) | Initializes a new instance of the LoggingFilter class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAfterWork | (Overrides BeforeAfterFilterBase DoAfterWork(WorkContext, JSONDataMap).)
Protected method | DoBeforeWork | (Overrides BeforeAfterFilterBase DoBeforeWork(WorkContext, JSONDataMap).)
Protected method | DoFilterWork | (Inherited from BeforeAfterFilterBase.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
VAR_FROM |
VAR_TEXT |
VAR_TYPE |
Back to Top
Properties
 | Name | Description
Public property | AfterMatches | Returns matches used by the handler to determine whether match should be made before the work processing (Inherited from BeforeAfterFilterBase.)
Public property | BeforeMatches | Returns matches used by the handler to determine whether match should be made before the work processing (Inherited from BeforeAfterFilterBase.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Back to Top
See Also
LoggingFilter Class
NFX.Wave.Filters Namespace


LoggingFilter Constructor

LoggingFilter Constructor NFX Class Library

Overload List
 | Name | Description
Public method | LoggingFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the LoggingFilter class
Public method | LoggingFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the LoggingFilter class
Public method | LoggingFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the LoggingFilter class
Public method | LoggingFilter(WorkHandler, String, Int32) | Initializes a new instance of the LoggingFilter class
Back to Top
See Also
LoggingFilter Class
LoggingFilter Members
NFX.Wave.Filters Namespace


LoggingFilter Constructor (WorkDispatcher, IConfigSectionNode)

LoggingFilter Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LoggingFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
public LoggingFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
public:
LoggingFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
public:
LoggingFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> LoggingFilter
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> LoggingFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
LoggingFilter Class
LoggingFilter Members
LoggingFilter Overload
NFX.Wave.Filters Namespace


LoggingFilter Constructor (WorkHandler, IConfigSectionNode)

LoggingFilter Constructor (WorkHandler, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LoggingFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
public LoggingFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
public:
LoggingFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
public:
LoggingFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> LoggingFilter
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> LoggingFilter

Parameters

handler
Type: NFX.Wave WorkHandler
confNode
Type: NFX.Environment IConfigSectionNode
See Also
LoggingFilter Class
LoggingFilter Members
LoggingFilter Overload
NFX.Wave.Filters Namespace


LoggingFilter Constructor (WorkDispatcher, String, Int32)

LoggingFilter Constructor (WorkDispatcher, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LoggingFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
public LoggingFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
public:
LoggingFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
public:
LoggingFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> LoggingFilter
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> LoggingFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
See Also
LoggingFilter Class
LoggingFilter Members
LoggingFilter Overload
NFX.Wave.Filters Namespace


LoggingFilter Constructor (WorkHandler, String, Int32)

LoggingFilter Constructor (WorkHandler, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LoggingFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingFilter(
    WorkHandler handler,
    string name,
    int order
)
public LoggingFilter(
    WorkHandler handler,
    string name,
    int order
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
public:
LoggingFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
public:
LoggingFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
new :
        handler : WorkHandler *
        name : string *
        order : int -> LoggingFilter
new :
        handler : WorkHandler *
        name : string *
        order : int -> LoggingFilter

Parameters

handler
Type: NFX.Wave WorkHandler
name
Type: Online System String
order
Type: Online System Int32
See Also
LoggingFilter Class
LoggingFilter Members
LoggingFilter Overload
NFX.Wave.Filters Namespace


LoggingFilter Fields

LoggingFilter Fields NFX Class Library

The LoggingFilter type exposes the following members.
Fields
Name | Description
VAR_FROM |
VAR_TEXT |
VAR_TYPE |
Back to Top
See Also
LoggingFilter Class
NFX.Wave.Filters Namespace


LoggingFilter.VAR_FROM Field

LoggingFilter VAR_FROM Field NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_FROM
public const string VAR_FROM
Public Const VAR_FROM As String
Public Const VAR_FROM As String
public:
literal String^ VAR_FROM
public:
literal String^ VAR_FROM
static val mutable VAR_FROM: string
static val mutable VAR_FROM: string

Field Value

Type: Online String
See Also
LoggingFilter Class
LoggingFilter Members
NFX.Wave.Filters Namespace


LoggingFilter.VAR_TEXT Field

LoggingFilter VAR_TEXT Field NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_TEXT
public const string VAR_TEXT
Public Const VAR_TEXT As String
Public Const VAR_TEXT As String
public:
literal String^ VAR_TEXT
public:
literal String^ VAR_TEXT
static val mutable VAR_TEXT: string
static val mutable VAR_TEXT: string

Field Value

Type: Online String
See Also
LoggingFilter Class
LoggingFilter Members
NFX.Wave.Filters Namespace


LoggingFilter.VAR_TYPE Field

LoggingFilter VAR_TYPE Field NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_TYPE
public const string VAR_TYPE
Public Const VAR_TYPE As String
Public Const VAR_TYPE As String
public:
literal String^ VAR_TYPE
public:
literal String^ VAR_TYPE
static val mutable VAR_TYPE: string
static val mutable VAR_TYPE: string

Field Value

Type: Online String
See Also
LoggingFilter Class
LoggingFilter Members
NFX.Wave.Filters Namespace


LoggingFilter Methods

LoggingFilter Methods NFX Class Library

The LoggingFilter type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAfterWork | (Overrides BeforeAfterFilterBase DoAfterWork(WorkContext, JSONDataMap).)
Protected method | DoBeforeWork | (Overrides BeforeAfterFilterBase DoBeforeWork(WorkContext, JSONDataMap).)
Protected method | DoFilterWork | (Inherited from BeforeAfterFilterBase.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LoggingFilter Class
NFX.Wave.Filters Namespace


LoggingFilter.DoAfterWork Method

LoggingFilter DoAfterWork Method NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoAfterWork(
    WorkContext work,
    JSONDataMap matched
)
protected override void DoAfterWork(
    WorkContext work,
    JSONDataMap matched
)
Protected Overrides Sub DoAfterWork (
    work As WorkContext,
    matched As JSONDataMap
)
Protected Overrides Sub DoAfterWork (
    work As WorkContext,
    matched As JSONDataMap
)
protected:
virtual void DoAfterWork(
    WorkContext^ work,
    JSONDataMap^ matched
) override
protected:
virtual void DoAfterWork(
    WorkContext^ work,
    JSONDataMap^ matched
) override
abstract DoAfterWork :
        work : WorkContext *
        matched : JSONDataMap -> unit
override DoAfterWork :
        work : WorkContext *
        matched : JSONDataMap -> unit
abstract DoAfterWork :
        work : WorkContext *
        matched : JSONDataMap -> unit
override DoAfterWork :
        work : WorkContext *
        matched : JSONDataMap -> unit

Parameters

work
Type: NFX.Wave WorkContext
matched
Type: NFX.Serialization.JSON JSONDataMap
See Also
LoggingFilter Class
LoggingFilter Members
NFX.Wave.Filters Namespace


LoggingFilter.DoBeforeWork Method

LoggingFilter DoBeforeWork Method NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoBeforeWork(
    WorkContext work,
    JSONDataMap matched
)
protected override void DoBeforeWork(
    WorkContext work,
    JSONDataMap matched
)
Protected Overrides Sub DoBeforeWork (
    work As WorkContext,
    matched As JSONDataMap
)
Protected Overrides Sub DoBeforeWork (
    work As WorkContext,
    matched As JSONDataMap
)
protected:
virtual void DoBeforeWork(
    WorkContext^ work,
    JSONDataMap^ matched
) override
protected:
virtual void DoBeforeWork(
    WorkContext^ work,
    JSONDataMap^ matched
) override
abstract DoBeforeWork :
        work : WorkContext *
        matched : JSONDataMap -> unit
override DoBeforeWork :
        work : WorkContext *
        matched : JSONDataMap -> unit
abstract DoBeforeWork :
        work : WorkContext *
        matched : JSONDataMap -> unit
override DoBeforeWork :
        work : WorkContext *
        matched : JSONDataMap -> unit

Parameters

work
Type: NFX.Wave WorkContext
matched
Type: NFX.Serialization.JSON JSONDataMap
See Also
LoggingFilter Class
LoggingFilter Members
NFX.Wave.Filters Namespace


LoggingFilter Properties

LoggingFilter Properties NFX Class Library

The LoggingFilter type exposes the following members.
Properties
 | Name | Description
Public property | AfterMatches | Returns matches used by the handler to determine whether match should be made before the work processing (Inherited from BeforeAfterFilterBase.)
Public property | BeforeMatches | Returns matches used by the handler to determine whether match should be made before the work processing (Inherited from BeforeAfterFilterBase.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Back to Top
See Also
LoggingFilter Class
NFX.Wave.Filters Namespace


PortalFilter Class

PortalFilter Class NFX Class Library

Manages injection of portal into the work context
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkFilter
NFX.Wave.Filters PortalFilter

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PortalFilter : WorkFilter
public class PortalFilter : WorkFilter
Public Class PortalFilter
    Inherits WorkFilter
Public Class PortalFilter
    Inherits WorkFilter
public ref class PortalFilter : public WorkFilter
public ref class PortalFilter : public WorkFilter
type PortalFilter =
    class
        inherit WorkFilter
    end
type PortalFilter =
    class
        inherit WorkFilter
    end
See Also
PortalFilter Members
NFX.Wave.Filters Namespace


PortalFilter Members

PortalFilter Members NFX Class Library

The PortalFilter type exposes the following members.
Constructors
 | Name | Description
Public method | PortalFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the PortalFilter class
Public method | PortalFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the PortalFilter class
Public method | PortalFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the PortalFilter class
Public method | PortalFilter(WorkHandler, String, Int32) | Initializes a new instance of the PortalFilter class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONF_THEME_COOKIE_NAME_ATTR |
CONF_USE_THEME_COOKIE_ATTR |
DEFAULT_THEME_COOKIE_NAME |
VAR_PORTAL_NAME |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | PortalMatches | OrderedRegistry of matches used by the filter to determine whether work should match a portal
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Public property | ThemeCookieName | Specifies theme cookie name
Public property | UseThemeCookie | Specifies true to interpret ThemeCookieName
Back to Top
See Also
PortalFilter Class
NFX.Wave.Filters Namespace


PortalFilter Constructor

PortalFilter Constructor NFX Class Library

Overload List
 | Name | Description
Public method | PortalFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the PortalFilter class
Public method | PortalFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the PortalFilter class
Public method | PortalFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the PortalFilter class
Public method | PortalFilter(WorkHandler, String, Int32) | Initializes a new instance of the PortalFilter class
Back to Top
See Also
PortalFilter Class
PortalFilter Members
NFX.Wave.Filters Namespace


PortalFilter Constructor (WorkDispatcher, IConfigSectionNode)

PortalFilter Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PortalFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PortalFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
public PortalFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
public:
PortalFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
public:
PortalFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> PortalFilter
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> PortalFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
PortalFilter Class
PortalFilter Members
PortalFilter Overload
NFX.Wave.Filters Namespace


PortalFilter Constructor (WorkHandler, IConfigSectionNode)

PortalFilter Constructor (WorkHandler, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PortalFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PortalFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
public PortalFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
public:
PortalFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
public:
PortalFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> PortalFilter
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> PortalFilter

Parameters

handler
Type: NFX.Wave WorkHandler
confNode
Type: NFX.Environment IConfigSectionNode
See Also
PortalFilter Class
PortalFilter Members
PortalFilter Overload
NFX.Wave.Filters Namespace


PortalFilter Constructor (WorkDispatcher, String, Int32)

PortalFilter Constructor (WorkDispatcher, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PortalFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PortalFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
public PortalFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
public:
PortalFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
public:
PortalFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> PortalFilter
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> PortalFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
See Also
PortalFilter Class
PortalFilter Members
PortalFilter Overload
NFX.Wave.Filters Namespace


PortalFilter Constructor (WorkHandler, String, Int32)

PortalFilter Constructor (WorkHandler, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PortalFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PortalFilter(
    WorkHandler handler,
    string name,
    int order
)
public PortalFilter(
    WorkHandler handler,
    string name,
    int order
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
public:
PortalFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
public:
PortalFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
new :
        handler : WorkHandler *
        name : string *
        order : int -> PortalFilter
new :
        handler : WorkHandler *
        name : string *
        order : int -> PortalFilter

Parameters

handler
Type: NFX.Wave WorkHandler
name
Type: Online System String
order
Type: Online System Int32
See Also
PortalFilter Class
PortalFilter Members
PortalFilter Overload
NFX.Wave.Filters Namespace


PortalFilter Fields

PortalFilter Fields NFX Class Library

The PortalFilter type exposes the following members.
Fields
Name | Description
CONF_THEME_COOKIE_NAME_ATTR |
CONF_USE_THEME_COOKIE_ATTR |
DEFAULT_THEME_COOKIE_NAME |
VAR_PORTAL_NAME |
Back to Top
See Also
PortalFilter Class
NFX.Wave.Filters Namespace


PortalFilter.CONF_THEME_COOKIE_NAME_ATTR Field

PortalFilter CONF_THEME_COOKIE_NAME_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONF_THEME_COOKIE_NAME_ATTR
public const string CONF_THEME_COOKIE_NAME_ATTR
Public Const CONF_THEME_COOKIE_NAME_ATTR As String
Public Const CONF_THEME_COOKIE_NAME_ATTR As String
public:
literal String^ CONF_THEME_COOKIE_NAME_ATTR
public:
literal String^ CONF_THEME_COOKIE_NAME_ATTR
static val mutable CONF_THEME_COOKIE_NAME_ATTR: string
static val mutable CONF_THEME_COOKIE_NAME_ATTR: string

Field Value

Type: Online String
See Also
PortalFilter Class
PortalFilter Members
NFX.Wave.Filters Namespace


PortalFilter.CONF_USE_THEME_COOKIE_ATTR Field

PortalFilter CONF_USE_THEME_COOKIE_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONF_USE_THEME_COOKIE_ATTR
public const string CONF_USE_THEME_COOKIE_ATTR
Public Const CONF_USE_THEME_COOKIE_ATTR As String
Public Const CONF_USE_THEME_COOKIE_ATTR As String
public:
literal String^ CONF_USE_THEME_COOKIE_ATTR
public:
literal String^ CONF_USE_THEME_COOKIE_ATTR
static val mutable CONF_USE_THEME_COOKIE_ATTR: string
static val mutable CONF_USE_THEME_COOKIE_ATTR: string

Field Value

Type: Online String
See Also
PortalFilter Class
PortalFilter Members
NFX.Wave.Filters Namespace


PortalFilter.DEFAULT_THEME_COOKIE_NAME Field

PortalFilter DEFAULT_THEME_COOKIE_NAME Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_THEME_COOKIE_NAME
public const string DEFAULT_THEME_COOKIE_NAME
Public Const DEFAULT_THEME_COOKIE_NAME As String
Public Const DEFAULT_THEME_COOKIE_NAME As String
public:
literal String^ DEFAULT_THEME_COOKIE_NAME
public:
literal String^ DEFAULT_THEME_COOKIE_NAME
static val mutable DEFAULT_THEME_COOKIE_NAME: string
static val mutable DEFAULT_THEME_COOKIE_NAME: string

Field Value

Type: Online String
See Also
PortalFilter Class
PortalFilter Members
NFX.Wave.Filters Namespace


PortalFilter.VAR_PORTAL_NAME Field

PortalFilter VAR_PORTAL_NAME Field NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_PORTAL_NAME
public const string VAR_PORTAL_NAME
Public Const VAR_PORTAL_NAME As String
Public Const VAR_PORTAL_NAME As String
public:
literal String^ VAR_PORTAL_NAME
public:
literal String^ VAR_PORTAL_NAME
static val mutable VAR_PORTAL_NAME: string
static val mutable VAR_PORTAL_NAME: string

Field Value

Type: Online String
See Also
PortalFilter Class
PortalFilter Members
NFX.Wave.Filters Namespace


PortalFilter Methods

PortalFilter Methods NFX Class Library

The PortalFilter type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PortalFilter Class
NFX.Wave.Filters Namespace


PortalFilter.DoFilterWork Method

PortalFilter DoFilterWork Method NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override sealed void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
protected override sealed void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
Protected Overrides NotOverridable Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
Protected Overrides NotOverridable Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override sealed
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override sealed
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit

Parameters

work
Type: NFX.Wave WorkContext
filters
Type: Online System.Collections.Generic IList WorkFilter
thisFilterIndex
Type: Online System Int32
See Also
PortalFilter Class
PortalFilter Members
NFX.Wave.Filters Namespace


PortalFilter Properties

PortalFilter Properties NFX Class Library

The PortalFilter type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | PortalMatches | OrderedRegistry of matches used by the filter to determine whether work should match a portal
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Public property | ThemeCookieName | Specifies theme cookie name
Public property | UseThemeCookie | Specifies true to interpret ThemeCookieName
Back to Top
See Also
PortalFilter Class
NFX.Wave.Filters Namespace


PortalFilter.PortalMatches Property

PortalFilter PortalMatches Property NFX Class Library

OrderedRegistry of matches used by the filter to determine whether work should match a portal

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<WorkMatch> PortalMatches { get; }
public OrderedRegistry<WorkMatch> PortalMatches { get; }
Public ReadOnly Property PortalMatches As OrderedRegistry(Of WorkMatch)
    Get
Public ReadOnly Property PortalMatches As OrderedRegistry(Of WorkMatch)
    Get
public:
property OrderedRegistry<WorkMatch^>^ PortalMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
public:
property OrderedRegistry<WorkMatch^>^ PortalMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
member PortalMatches : OrderedRegistry<WorkMatch> with get
member PortalMatches : OrderedRegistry<WorkMatch> with get

Property Value

Type: OrderedRegistry WorkMatch
See Also
PortalFilter Class
PortalFilter Members
NFX.Wave.Filters Namespace


PortalFilter.ThemeCookieName Property

PortalFilter ThemeCookieName Property NFX Class Library

Specifies theme cookie name

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ThemeCookieName { get; set; }
public string ThemeCookieName { get; set; }
Public Property ThemeCookieName As String
    Get
    Set
Public Property ThemeCookieName As String
    Get
    Set
public:
property String^ ThemeCookieName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ThemeCookieName {
    String^ get ();
    void set (String^ value);
}
member ThemeCookieName : string with get, set
member ThemeCookieName : string with get, set

Property Value

Type: Online String
See Also
PortalFilter Class
PortalFilter Members
NFX.Wave.Filters Namespace


PortalFilter.UseThemeCookie Property

PortalFilter UseThemeCookie Property NFX Class Library

Specifies true to interpret ThemeCookieName

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UseThemeCookie { get; set; }
public bool UseThemeCookie { get; set; }
Public Property UseThemeCookie As Boolean
    Get
    Set
Public Property UseThemeCookie As Boolean
    Get
    Set
public:
property bool UseThemeCookie {
    bool get ();
    void set (bool value);
}
public:
property bool UseThemeCookie {
    bool get ();
    void set (bool value);
}
member UseThemeCookie : bool with get, set
member UseThemeCookie : bool with get, set

Property Value

Type: Online Boolean
See Also
PortalFilter Class
PortalFilter Members
NFX.Wave.Filters Namespace


RedirectFilter Class

RedirectFilter Class NFX Class Library

Upon match, redirects client to the specified URL resource. Specify matches with 'redirect-url' var
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkFilter
NFX.Wave.Filters RedirectFilter

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RedirectFilter : WorkFilter
public class RedirectFilter : WorkFilter
Public Class RedirectFilter
    Inherits WorkFilter
Public Class RedirectFilter
    Inherits WorkFilter
public ref class RedirectFilter : public WorkFilter
public ref class RedirectFilter : public WorkFilter
type RedirectFilter =
    class
        inherit WorkFilter
    end
type RedirectFilter =
    class
        inherit WorkFilter
    end
See Also
RedirectFilter Members
NFX.Wave.Filters Namespace


RedirectFilter Members

RedirectFilter Members NFX Class Library

The RedirectFilter type exposes the following members.
Constructors
 | Name | Description
Public method | RedirectFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the RedirectFilter class
Public method | RedirectFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the RedirectFilter class
Public method | RedirectFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the RedirectFilter class
Public method | RedirectFilter(WorkHandler, String, Int32) | Initializes a new instance of the RedirectFilter class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
VAR_REDIRECT_TARGET |
VAR_REDIRECT_URL |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | RedirectMatches | Returns matches used by the filter to determine whether redirect should be issued
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Back to Top
See Also
RedirectFilter Class
NFX.Wave.Filters Namespace


RedirectFilter Constructor

RedirectFilter Constructor NFX Class Library

Overload List
 | Name | Description
Public method | RedirectFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the RedirectFilter class
Public method | RedirectFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the RedirectFilter class
Public method | RedirectFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the RedirectFilter class
Public method | RedirectFilter(WorkHandler, String, Int32) | Initializes a new instance of the RedirectFilter class
Back to Top
See Also
RedirectFilter Class
RedirectFilter Members
NFX.Wave.Filters Namespace


RedirectFilter Constructor (WorkDispatcher, IConfigSectionNode)

RedirectFilter Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RedirectFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RedirectFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
public RedirectFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
public:
RedirectFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
public:
RedirectFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> RedirectFilter
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> RedirectFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
RedirectFilter Class
RedirectFilter Members
RedirectFilter Overload
NFX.Wave.Filters Namespace


RedirectFilter Constructor (WorkHandler, IConfigSectionNode)

RedirectFilter Constructor (WorkHandler, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RedirectFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RedirectFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
public RedirectFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
public:
RedirectFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
public:
RedirectFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> RedirectFilter
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> RedirectFilter

Parameters

handler
Type: NFX.Wave WorkHandler
confNode
Type: NFX.Environment IConfigSectionNode
See Also
RedirectFilter Class
RedirectFilter Members
RedirectFilter Overload
NFX.Wave.Filters Namespace


RedirectFilter Constructor (WorkDispatcher, String, Int32)

RedirectFilter Constructor (WorkDispatcher, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RedirectFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RedirectFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
public RedirectFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
public:
RedirectFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
public:
RedirectFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> RedirectFilter
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> RedirectFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
See Also
RedirectFilter Class
RedirectFilter Members
RedirectFilter Overload
NFX.Wave.Filters Namespace


RedirectFilter Constructor (WorkHandler, String, Int32)

RedirectFilter Constructor (WorkHandler, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RedirectFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RedirectFilter(
    WorkHandler handler,
    string name,
    int order
)
public RedirectFilter(
    WorkHandler handler,
    string name,
    int order
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
public:
RedirectFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
public:
RedirectFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
new :
        handler : WorkHandler *
        name : string *
        order : int -> RedirectFilter
new :
        handler : WorkHandler *
        name : string *
        order : int -> RedirectFilter

Parameters

handler
Type: NFX.Wave WorkHandler
name
Type: Online System String
order
Type: Online System Int32
See Also
RedirectFilter Class
RedirectFilter Members
RedirectFilter Overload
NFX.Wave.Filters Namespace


RedirectFilter Fields

RedirectFilter Fields NFX Class Library

The RedirectFilter type exposes the following members.
Fields
Name | Description
VAR_REDIRECT_TARGET |
VAR_REDIRECT_URL |
Back to Top
See Also
RedirectFilter Class
NFX.Wave.Filters Namespace


RedirectFilter.VAR_REDIRECT_TARGET Field

RedirectFilter VAR_REDIRECT_TARGET Field NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_REDIRECT_TARGET
public const string VAR_REDIRECT_TARGET
Public Const VAR_REDIRECT_TARGET As String
Public Const VAR_REDIRECT_TARGET As String
public:
literal String^ VAR_REDIRECT_TARGET
public:
literal String^ VAR_REDIRECT_TARGET
static val mutable VAR_REDIRECT_TARGET: string
static val mutable VAR_REDIRECT_TARGET: string

Field Value

Type: Online String
See Also
RedirectFilter Class
RedirectFilter Members
NFX.Wave.Filters Namespace


RedirectFilter.VAR_REDIRECT_URL Field

RedirectFilter VAR_REDIRECT_URL Field NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_REDIRECT_URL
public const string VAR_REDIRECT_URL
Public Const VAR_REDIRECT_URL As String
Public Const VAR_REDIRECT_URL As String
public:
literal String^ VAR_REDIRECT_URL
public:
literal String^ VAR_REDIRECT_URL
static val mutable VAR_REDIRECT_URL: string
static val mutable VAR_REDIRECT_URL: string

Field Value

Type: Online String
See Also
RedirectFilter Class
RedirectFilter Members
NFX.Wave.Filters Namespace


RedirectFilter Methods

RedirectFilter Methods NFX Class Library

The RedirectFilter type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RedirectFilter Class
NFX.Wave.Filters Namespace


RedirectFilter.DoFilterWork Method

RedirectFilter DoFilterWork Method NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
protected override void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
Protected Overrides Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
Protected Overrides Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit

Parameters

work
Type: NFX.Wave WorkContext
filters
Type: Online System.Collections.Generic IList WorkFilter
thisFilterIndex
Type: Online System Int32
See Also
RedirectFilter Class
RedirectFilter Members
NFX.Wave.Filters Namespace


RedirectFilter Properties

RedirectFilter Properties NFX Class Library

The RedirectFilter type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | RedirectMatches | Returns matches used by the filter to determine whether redirect should be issued
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Back to Top
See Also
RedirectFilter Class
NFX.Wave.Filters Namespace


RedirectFilter.RedirectMatches Property

RedirectFilter RedirectMatches Property NFX Class Library

Returns matches used by the filter to determine whether redirect should be issued

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<WorkMatch> RedirectMatches { get; }
public OrderedRegistry<WorkMatch> RedirectMatches { get; }
Public ReadOnly Property RedirectMatches As OrderedRegistry(Of WorkMatch)
    Get
Public ReadOnly Property RedirectMatches As OrderedRegistry(Of WorkMatch)
    Get
public:
property OrderedRegistry<WorkMatch^>^ RedirectMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
public:
property OrderedRegistry<WorkMatch^>^ RedirectMatches {
    OrderedRegistry<WorkMatch^>^ get ();
}
member RedirectMatches : OrderedRegistry<WorkMatch> with get
member RedirectMatches : OrderedRegistry<WorkMatch> with get

Property Value

Type: OrderedRegistry WorkMatch
See Also
RedirectFilter Class
RedirectFilter Members
NFX.Wave.Filters Namespace


SecurityFilter Class

SecurityFilter Class NFX Class Library

Checks permissions before doing work
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkFilter
NFX.Wave.Filters SecurityFilter

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class SecurityFilter : WorkFilter
public sealed class SecurityFilter : WorkFilter
Public NotInheritable Class SecurityFilter
    Inherits WorkFilter
Public NotInheritable Class SecurityFilter
    Inherits WorkFilter
public ref class SecurityFilter sealed : public WorkFilter
public ref class SecurityFilter sealed : public WorkFilter
[<SealedAttribute>]
type SecurityFilter =
    class
        inherit WorkFilter
    end
[<SealedAttribute>]
type SecurityFilter =
    class
        inherit WorkFilter
    end
See Also
SecurityFilter Members
NFX.Wave.Filters Namespace


SecurityFilter Members

SecurityFilter Members NFX Class Library

The SecurityFilter type exposes the following members.
Constructors
 | Name | Description
Public method | SecurityFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the SecurityFilter class
Public method | SecurityFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the SecurityFilter class
Public method | SecurityFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the SecurityFilter class
Public method | SecurityFilter(WorkHandler, String, Int32) | Initializes a new instance of the SecurityFilter class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_BYPASS_SECTION |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | Permissions | Gets/sets permissions that get checked by this filter instance
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Back to Top
See Also
SecurityFilter Class
NFX.Wave.Filters Namespace


SecurityFilter Constructor

SecurityFilter Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SecurityFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the SecurityFilter class
Public method | SecurityFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the SecurityFilter class
Public method | SecurityFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the SecurityFilter class
Public method | SecurityFilter(WorkHandler, String, Int32) | Initializes a new instance of the SecurityFilter class
Back to Top
See Also
SecurityFilter Class
SecurityFilter Members
NFX.Wave.Filters Namespace


SecurityFilter Constructor (WorkDispatcher, IConfigSectionNode)

SecurityFilter Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SecurityFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecurityFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
public SecurityFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
public:
SecurityFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
public:
SecurityFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> SecurityFilter
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> SecurityFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
SecurityFilter Class
SecurityFilter Members
SecurityFilter Overload
NFX.Wave.Filters Namespace


SecurityFilter Constructor (WorkHandler, IConfigSectionNode)

SecurityFilter Constructor (WorkHandler, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SecurityFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecurityFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
public SecurityFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
public:
SecurityFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
public:
SecurityFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> SecurityFilter
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> SecurityFilter

Parameters

handler
Type: NFX.Wave WorkHandler
confNode
Type: NFX.Environment IConfigSectionNode
See Also
SecurityFilter Class
SecurityFilter Members
SecurityFilter Overload
NFX.Wave.Filters Namespace


SecurityFilter Constructor (WorkDispatcher, String, Int32)

SecurityFilter Constructor (WorkDispatcher, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SecurityFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecurityFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
public SecurityFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
public:
SecurityFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
public:
SecurityFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> SecurityFilter
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> SecurityFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
See Also
SecurityFilter Class
SecurityFilter Members
SecurityFilter Overload
NFX.Wave.Filters Namespace


SecurityFilter Constructor (WorkHandler, String, Int32)

SecurityFilter Constructor (WorkHandler, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SecurityFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecurityFilter(
    WorkHandler handler,
    string name,
    int order
)
public SecurityFilter(
    WorkHandler handler,
    string name,
    int order
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
public:
SecurityFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
public:
SecurityFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
new :
        handler : WorkHandler *
        name : string *
        order : int -> SecurityFilter
new :
        handler : WorkHandler *
        name : string *
        order : int -> SecurityFilter

Parameters

handler
Type: NFX.Wave WorkHandler
name
Type: Online System String
order
Type: Online System Int32
See Also
SecurityFilter Class
SecurityFilter Members
SecurityFilter Overload
NFX.Wave.Filters Namespace


SecurityFilter Fields

SecurityFilter Fields NFX Class Library

The SecurityFilter type exposes the following members.
Fields
Name | Description
CONFIG_BYPASS_SECTION |
Back to Top
See Also
SecurityFilter Class
NFX.Wave.Filters Namespace


SecurityFilter.CONFIG_BYPASS_SECTION Field

SecurityFilter CONFIG_BYPASS_SECTION Field NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_BYPASS_SECTION
public const string CONFIG_BYPASS_SECTION
Public Const CONFIG_BYPASS_SECTION As String
Public Const CONFIG_BYPASS_SECTION As String
public:
literal String^ CONFIG_BYPASS_SECTION
public:
literal String^ CONFIG_BYPASS_SECTION
static val mutable CONFIG_BYPASS_SECTION: string
static val mutable CONFIG_BYPASS_SECTION: string

Field Value

Type: Online String
See Also
SecurityFilter Class
SecurityFilter Members
NFX.Wave.Filters Namespace


SecurityFilter Methods

SecurityFilter Methods NFX Class Library

The SecurityFilter type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecurityFilter Class
NFX.Wave.Filters Namespace


SecurityFilter.DoFilterWork Method

SecurityFilter DoFilterWork Method NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
protected override void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
Protected Overrides Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
Protected Overrides Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit

Parameters

work
Type: NFX.Wave WorkContext
filters
Type: Online System.Collections.Generic IList WorkFilter
thisFilterIndex
Type: Online System Int32
See Also
SecurityFilter Class
SecurityFilter Members
NFX.Wave.Filters Namespace


SecurityFilter Properties

SecurityFilter Properties NFX Class Library

The SecurityFilter type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | Permissions | Gets/sets permissions that get checked by this filter instance
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Back to Top
See Also
SecurityFilter Class
NFX.Wave.Filters Namespace


SecurityFilter.Permissions Property

SecurityFilter Permissions Property NFX Class Library

Gets/sets permissions that get checked by this filter instance

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Permission> Permissions { get; set; }
public IEnumerable<Permission> Permissions { get; set; }
Public Property Permissions As IEnumerable(Of Permission)
    Get
    Set
Public Property Permissions As IEnumerable(Of Permission)
    Get
    Set
public:
property IEnumerable<Permission^>^ Permissions {
    IEnumerable<Permission^>^ get ();
    void set (IEnumerable<Permission^>^ value);
}
public:
property IEnumerable<Permission^>^ Permissions {
    IEnumerable<Permission^>^ get ();
    void set (IEnumerable<Permission^>^ value);
}
member Permissions : IEnumerable<Permission> with get, set
member Permissions : IEnumerable<Permission> with get, set

Property Value

Type: Online IEnumerable Permission
See Also
SecurityFilter Class
SecurityFilter Members
NFX.Wave.Filters Namespace


SessionFilter Class

SessionFilter Class NFX Class Library

Manages session state in work context
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkFilter
NFX.Wave.Filters SessionFilter

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SessionFilter : WorkFilter
public class SessionFilter : WorkFilter
Public Class SessionFilter
    Inherits WorkFilter
Public Class SessionFilter
    Inherits WorkFilter
public ref class SessionFilter : public WorkFilter
public ref class SessionFilter : public WorkFilter
type SessionFilter =
    class
        inherit WorkFilter
    end
type SessionFilter =
    class
        inherit WorkFilter
    end
See Also
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter Members

SessionFilter Members NFX Class Library

The SessionFilter type exposes the following members.
Constructors
 | Name | Description
Public method | SessionFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the SessionFilter class
Public method | SessionFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the SessionFilter class
Public method | SessionFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the SessionFilter class
Public method | SessionFilter(WorkHandler, String, Int32) | Initializes a new instance of the SessionFilter class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | DecodeSessionID | Override to decode session ID GUID from string representation. Return null if conversion not possible
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Protected method | EncodeSessionID | Override to encode session ID GUID into string representation
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | ExtractSessionID | Extracts session ID from work request. The default implementation uses cookie
Protected method | FetchExistingOrMakeNewSession | Override to get session object using whatever parameters are available in response context (i.e. a cookie), or create a new one if 'onlyExisting'=false(default)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | MakeNewSession | Called to create a new session
Protected method | MakeNewSessionInstance | Override to create a new session instance
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | StowSession | Override to put session object back into whatever storage medium is provided (i.e. DB) and respond with appropriate session identifying token(i.e. a cookie)
Public method | ToString | (Inherited from WorkFilter.)
Protected method | TryMakeSessionFromExistingLongTermToken | Override in session filters that support long-term tokens. This method tries to re-create "existing" session from a valid long-term token, otherwise null should be returned (the base implementation)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONF_COOKIE_NAME_ATTR |
CONF_SESSION_TIMEOUT_MS_ATTR |
DEFAULT_COOKIE_NAME |
DEFAULT_SESSION_TIMEOUT_MS |
NETGATE_NEWSESSION_VAR_NAME | Use this name in access deny rule in NetGate setup to block user who create too many sessions
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | CookieName | Specifies session cookie name
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Public property | SessionTimeoutMs | Specifies session inactivity timeout in milliseconds. For default implementation: assign 0 to use App.ObjectStore default object timeout value
Back to Top
See Also
SessionFilter Class
NFX.Wave.Filters Namespace


SessionFilter Constructor

SessionFilter Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SessionFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the SessionFilter class
Public method | SessionFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the SessionFilter class
Public method | SessionFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the SessionFilter class
Public method | SessionFilter(WorkHandler, String, Int32) | Initializes a new instance of the SessionFilter class
Back to Top
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter Constructor (WorkDispatcher, IConfigSectionNode)

SessionFilter Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SessionFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SessionFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
public SessionFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
public:
SessionFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
public:
SessionFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> SessionFilter
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> SessionFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
SessionFilter Class
SessionFilter Members
SessionFilter Overload
NFX.Wave.Filters Namespace


SessionFilter Constructor (WorkHandler, IConfigSectionNode)

SessionFilter Constructor (WorkHandler, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SessionFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SessionFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
public SessionFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
public:
SessionFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
public:
SessionFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> SessionFilter
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> SessionFilter

Parameters

handler
Type: NFX.Wave WorkHandler
confNode
Type: NFX.Environment IConfigSectionNode
See Also
SessionFilter Class
SessionFilter Members
SessionFilter Overload
NFX.Wave.Filters Namespace


SessionFilter Constructor (WorkDispatcher, String, Int32)

SessionFilter Constructor (WorkDispatcher, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SessionFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SessionFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
public SessionFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
public:
SessionFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
public:
SessionFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> SessionFilter
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> SessionFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
See Also
SessionFilter Class
SessionFilter Members
SessionFilter Overload
NFX.Wave.Filters Namespace


SessionFilter Constructor (WorkHandler, String, Int32)

SessionFilter Constructor (WorkHandler, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SessionFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SessionFilter(
    WorkHandler handler,
    string name,
    int order
)
public SessionFilter(
    WorkHandler handler,
    string name,
    int order
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
public:
SessionFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
public:
SessionFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
new :
        handler : WorkHandler *
        name : string *
        order : int -> SessionFilter
new :
        handler : WorkHandler *
        name : string *
        order : int -> SessionFilter

Parameters

handler
Type: NFX.Wave WorkHandler
name
Type: Online System String
order
Type: Online System Int32
See Also
SessionFilter Class
SessionFilter Members
SessionFilter Overload
NFX.Wave.Filters Namespace


SessionFilter Fields

SessionFilter Fields NFX Class Library

The SessionFilter type exposes the following members.
Fields
Name | Description
CONF_COOKIE_NAME_ATTR |
CONF_SESSION_TIMEOUT_MS_ATTR |
DEFAULT_COOKIE_NAME |
DEFAULT_SESSION_TIMEOUT_MS |
NETGATE_NEWSESSION_VAR_NAME | Use this name in access deny rule in NetGate setup to block user who create too many sessions
Back to Top
See Also
SessionFilter Class
NFX.Wave.Filters Namespace


SessionFilter.CONF_COOKIE_NAME_ATTR Field

SessionFilter CONF_COOKIE_NAME_ATTR Field NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONF_COOKIE_NAME_ATTR
public const string CONF_COOKIE_NAME_ATTR
Public Const CONF_COOKIE_NAME_ATTR As String
Public Const CONF_COOKIE_NAME_ATTR As String
public:
literal String^ CONF_COOKIE_NAME_ATTR
public:
literal String^ CONF_COOKIE_NAME_ATTR
static val mutable CONF_COOKIE_NAME_ATTR: string
static val mutable CONF_COOKIE_NAME_ATTR: string

Field Value

Type: Online String
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter.CONF_SESSION_TIMEOUT_MS_ATTR Field

SessionFilter CONF_SESSION_TIMEOUT_MS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONF_SESSION_TIMEOUT_MS_ATTR
public const string CONF_SESSION_TIMEOUT_MS_ATTR
Public Const CONF_SESSION_TIMEOUT_MS_ATTR As String
Public Const CONF_SESSION_TIMEOUT_MS_ATTR As String
public:
literal String^ CONF_SESSION_TIMEOUT_MS_ATTR
public:
literal String^ CONF_SESSION_TIMEOUT_MS_ATTR
static val mutable CONF_SESSION_TIMEOUT_MS_ATTR: string
static val mutable CONF_SESSION_TIMEOUT_MS_ATTR: string

Field Value

Type: Online String
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter.DEFAULT_COOKIE_NAME Field

SessionFilter DEFAULT_COOKIE_NAME Field NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_COOKIE_NAME
public const string DEFAULT_COOKIE_NAME
Public Const DEFAULT_COOKIE_NAME As String
Public Const DEFAULT_COOKIE_NAME As String
public:
literal String^ DEFAULT_COOKIE_NAME
public:
literal String^ DEFAULT_COOKIE_NAME
static val mutable DEFAULT_COOKIE_NAME: string
static val mutable DEFAULT_COOKIE_NAME: string

Field Value

Type: Online String
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter.DEFAULT_SESSION_TIMEOUT_MS Field

SessionFilter DEFAULT_SESSION_TIMEOUT_MS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_SESSION_TIMEOUT_MS
public const int DEFAULT_SESSION_TIMEOUT_MS
Public Const DEFAULT_SESSION_TIMEOUT_MS As Integer
Public Const DEFAULT_SESSION_TIMEOUT_MS As Integer
public:
literal int DEFAULT_SESSION_TIMEOUT_MS
public:
literal int DEFAULT_SESSION_TIMEOUT_MS
static val mutable DEFAULT_SESSION_TIMEOUT_MS: int
static val mutable DEFAULT_SESSION_TIMEOUT_MS: int

Field Value

Type: Online Int32
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter.NETGATE_NEWSESSION_VAR_NAME Field

SessionFilter NETGATE_NEWSESSION_VAR_NAME Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Use this name in access deny rule in NetGate setup to block user who create too many sessions

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NETGATE_NEWSESSION_VAR_NAME
public const string NETGATE_NEWSESSION_VAR_NAME
Public Const NETGATE_NEWSESSION_VAR_NAME As String
Public Const NETGATE_NEWSESSION_VAR_NAME As String
public:
literal String^ NETGATE_NEWSESSION_VAR_NAME
public:
literal String^ NETGATE_NEWSESSION_VAR_NAME
static val mutable NETGATE_NEWSESSION_VAR_NAME: string
static val mutable NETGATE_NEWSESSION_VAR_NAME: string

Field Value

Type: Online String
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter Methods

SessionFilter Methods NFX Class Library

The SessionFilter type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | DecodeSessionID | Override to decode session ID GUID from string representation. Return null if conversion not possible
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFilterWork | (Overrides WorkFilter DoFilterWork(WorkContext, IList WorkFilter , Int32).)
Protected method | EncodeSessionID | Override to encode session ID GUID into string representation
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | ExtractSessionID | Extracts session ID from work request. The default implementation uses cookie
Protected method | FetchExistingOrMakeNewSession | Override to get session object using whatever parameters are available in response context (i.e. a cookie), or create a new one if 'onlyExisting'=false(default)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | MakeNewSession | Called to create a new session
Protected method | MakeNewSessionInstance | Override to create a new session instance
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | StowSession | Override to put session object back into whatever storage medium is provided (i.e. DB) and respond with appropriate session identifying token(i.e. a cookie)
Public method | ToString | (Inherited from WorkFilter.)
Protected method | TryMakeSessionFromExistingLongTermToken | Override in session filters that support long-term tokens. This method tries to re-create "existing" session from a valid long-term token, otherwise null should be returned (the base implementation)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SessionFilter Class
NFX.Wave.Filters Namespace


SessionFilter.DecodeSessionID Method

SessionFilter DecodeSessionID Method NFX Class Library

Override to decode session ID GUID from string representation. Return null if conversion not possible

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Nullable<Guid> DecodeSessionID(
    WorkContext work,
    string id,
    bool hasApiHeaders,
    out ulong idSecret
)
protected virtual Nullable<Guid> DecodeSessionID(
    WorkContext work,
    string id,
    bool hasApiHeaders,
    out ulong idSecret
)
Protected Overridable Function DecodeSessionID (
    work As WorkContext,
    id As String,
    hasApiHeaders As Boolean,
    <OutAttribute> ByRef idSecret As ULong
) As Nullable(Of Guid)
Protected Overridable Function DecodeSessionID (
    work As WorkContext,
    id As String,
    hasApiHeaders As Boolean,
    <OutAttribute> ByRef idSecret As ULong
) As Nullable(Of Guid)
protected:
virtual Nullable<Guid> DecodeSessionID(
    WorkContext^ work,
    String^ id,
    bool hasApiHeaders,
    [OutAttribute] unsigned long long% idSecret
)
protected:
virtual Nullable<Guid> DecodeSessionID(
    WorkContext^ work,
    String^ id,
    bool hasApiHeaders,
    [OutAttribute] unsigned long long% idSecret
)
abstract DecodeSessionID :
        work : WorkContext *
        id : string *
        hasApiHeaders : bool *
        idSecret : uint64 byref -> Nullable<Guid>
override DecodeSessionID :
        work : WorkContext *
        id : string *
        hasApiHeaders : bool *
        idSecret : uint64 byref -> Nullable<Guid>
abstract DecodeSessionID :
        work : WorkContext *
        id : string *
        hasApiHeaders : bool *
        idSecret : uint64 byref -> Nullable<Guid>
override DecodeSessionID :
        work : WorkContext *
        id : string *
        hasApiHeaders : bool *
        idSecret : uint64 byref -> Nullable<Guid>

Parameters

work
Type: NFX.Wave WorkContext
id
Type: Online System String
hasApiHeaders
Type: Online System Boolean
idSecret
Type: Online System UInt64

Return Value

Type: Online Nullable Online Guid
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter.DoFilterWork Method

SessionFilter DoFilterWork Method NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override sealed void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
protected override sealed void DoFilterWork(
    WorkContext work,
    IList<WorkFilter> filters,
    int thisFilterIndex
)
Protected Overrides NotOverridable Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
Protected Overrides NotOverridable Sub DoFilterWork (
    work As WorkContext,
    filters As IList(Of WorkFilter),
    thisFilterIndex As Integer
)
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override sealed
protected:
virtual void DoFilterWork(
    WorkContext^ work,
    IList<WorkFilter^>^ filters,
    int thisFilterIndex
) override sealed
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
abstract DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit
override DoFilterWork :
        work : WorkContext *
        filters : IList<WorkFilter> *
        thisFilterIndex : int -> unit

Parameters

work
Type: NFX.Wave WorkContext
filters
Type: Online System.Collections.Generic IList WorkFilter
thisFilterIndex
Type: Online System Int32
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter.EncodeSessionID Method

SessionFilter EncodeSessionID Method NFX Class Library

Override to encode session ID GUID into string representation

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string EncodeSessionID(
    WorkContext work,
    WaveSession session,
    bool hasApiHeaders
)
protected virtual string EncodeSessionID(
    WorkContext work,
    WaveSession session,
    bool hasApiHeaders
)
Protected Overridable Function EncodeSessionID (
    work As WorkContext,
    session As WaveSession,
    hasApiHeaders As Boolean
) As String
Protected Overridable Function EncodeSessionID (
    work As WorkContext,
    session As WaveSession,
    hasApiHeaders As Boolean
) As String
protected:
virtual String^ EncodeSessionID(
    WorkContext^ work,
    WaveSession^ session,
    bool hasApiHeaders
)
protected:
virtual String^ EncodeSessionID(
    WorkContext^ work,
    WaveSession^ session,
    bool hasApiHeaders
)
abstract EncodeSessionID :
        work : WorkContext *
        session : WaveSession *
        hasApiHeaders : bool -> string
override EncodeSessionID :
        work : WorkContext *
        session : WaveSession *
        hasApiHeaders : bool -> string
abstract EncodeSessionID :
        work : WorkContext *
        session : WaveSession *
        hasApiHeaders : bool -> string
override EncodeSessionID :
        work : WorkContext *
        session : WaveSession *
        hasApiHeaders : bool -> string

Parameters

work
Type: NFX.Wave WorkContext
session
Type: NFX.Wave WaveSession
hasApiHeaders
Type: Online System Boolean

Return Value

Type: Online String
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter.ExtractSessionID Method

SessionFilter ExtractSessionID Method NFX Class Library

Extracts session ID from work request. The default implementation uses cookie

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Nullable<Guid> ExtractSessionID(
    WorkContext work,
    out ulong idSecret
)
protected virtual Nullable<Guid> ExtractSessionID(
    WorkContext work,
    out ulong idSecret
)
Protected Overridable Function ExtractSessionID (
    work As WorkContext,
    <OutAttribute> ByRef idSecret As ULong
) As Nullable(Of Guid)
Protected Overridable Function ExtractSessionID (
    work As WorkContext,
    <OutAttribute> ByRef idSecret As ULong
) As Nullable(Of Guid)
protected:
virtual Nullable<Guid> ExtractSessionID(
    WorkContext^ work,
    [OutAttribute] unsigned long long% idSecret
)
protected:
virtual Nullable<Guid> ExtractSessionID(
    WorkContext^ work,
    [OutAttribute] unsigned long long% idSecret
)
abstract ExtractSessionID :
        work : WorkContext *
        idSecret : uint64 byref -> Nullable<Guid>
override ExtractSessionID :
        work : WorkContext *
        idSecret : uint64 byref -> Nullable<Guid>
abstract ExtractSessionID :
        work : WorkContext *
        idSecret : uint64 byref -> Nullable<Guid>
override ExtractSessionID :
        work : WorkContext *
        idSecret : uint64 byref -> Nullable<Guid>

Parameters

work
Type: NFX.Wave WorkContext
idSecret
Type: Online System UInt64

Return Value

Type: Online Nullable Online Guid
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter.FetchExistingOrMakeNewSession Method

SessionFilter FetchExistingOrMakeNewSession Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to get session object using whatever parameters are available in response context (i.e. a cookie), or create a new one if 'onlyExisting'=false(default)

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void FetchExistingOrMakeNewSession(
    WorkContext work,
    bool onlyExisting = false
)
protected internal virtual void FetchExistingOrMakeNewSession(
    WorkContext work,
    bool onlyExisting = false
)
Protected Friend Overridable Sub FetchExistingOrMakeNewSession (
    work As WorkContext,
    Optional onlyExisting As Boolean = false
)
Protected Friend Overridable Sub FetchExistingOrMakeNewSession (
    work As WorkContext,
    Optional onlyExisting As Boolean = false
)
protected public:
virtual void FetchExistingOrMakeNewSession(
    WorkContext^ work,
    bool onlyExisting = false
)
protected public:
virtual void FetchExistingOrMakeNewSession(
    WorkContext^ work,
    bool onlyExisting = false
)
abstract FetchExistingOrMakeNewSession :
        work : WorkContext *
        ?onlyExisting : bool
(* Defaults:
        let _onlyExisting = defaultArg onlyExisting false
*)
-> unit
override FetchExistingOrMakeNewSession :
        work : WorkContext *
        ?onlyExisting : bool
(* Defaults:
        let _onlyExisting = defaultArg onlyExisting false
*)
-> unit
abstract FetchExistingOrMakeNewSession :
        work : WorkContext *
        ?onlyExisting : bool
(* Defaults:
        let _onlyExisting = defaultArg onlyExisting false
*)
-> unit
override FetchExistingOrMakeNewSession :
        work : WorkContext *
        ?onlyExisting : bool
(* Defaults:
        let _onlyExisting = defaultArg onlyExisting false
*)
-> unit

Parameters

work
Type: NFX.Wave WorkContext
onlyExisting (Optional)
Type: Online System Boolean
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter.MakeNewSession Method

SessionFilter MakeNewSession Method NFX Class Library

Called to create a new session

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected WaveSession MakeNewSession(
    WorkContext work
)
protected WaveSession MakeNewSession(
    WorkContext work
)
Protected Function MakeNewSession (
    work As WorkContext
) As WaveSession
Protected Function MakeNewSession (
    work As WorkContext
) As WaveSession
protected:
WaveSession^ MakeNewSession(
    WorkContext^ work
)
protected:
WaveSession^ MakeNewSession(
    WorkContext^ work
)
member MakeNewSession :
        work : WorkContext -> WaveSession
member MakeNewSession :
        work : WorkContext -> WaveSession

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: WaveSession
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter.MakeNewSessionInstance Method

SessionFilter MakeNewSessionInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to create a new session instance

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual WaveSession MakeNewSessionInstance(
    WorkContext work
)
protected virtual WaveSession MakeNewSessionInstance(
    WorkContext work
)
Protected Overridable Function MakeNewSessionInstance (
    work As WorkContext
) As WaveSession
Protected Overridable Function MakeNewSessionInstance (
    work As WorkContext
) As WaveSession
protected:
virtual WaveSession^ MakeNewSessionInstance(
    WorkContext^ work
)
protected:
virtual WaveSession^ MakeNewSessionInstance(
    WorkContext^ work
)
abstract MakeNewSessionInstance :
        work : WorkContext -> WaveSession
override MakeNewSessionInstance :
        work : WorkContext -> WaveSession
abstract MakeNewSessionInstance :
        work : WorkContext -> WaveSession
override MakeNewSessionInstance :
        work : WorkContext -> WaveSession

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: WaveSession
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter.StowSession Method

SessionFilter StowSession Method NFX Class Library

Override to put session object back into whatever storage medium is provided (i.e. DB) and respond with appropriate session identifying token(i.e. a cookie)

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void StowSession(
    WorkContext work
)
protected virtual void StowSession(
    WorkContext work
)
Protected Overridable Sub StowSession (
    work As WorkContext
)
Protected Overridable Sub StowSession (
    work As WorkContext
)
protected:
virtual void StowSession(
    WorkContext^ work
)
protected:
virtual void StowSession(
    WorkContext^ work
)
abstract StowSession :
        work : WorkContext -> unit
override StowSession :
        work : WorkContext -> unit
abstract StowSession :
        work : WorkContext -> unit
override StowSession :
        work : WorkContext -> unit

Parameters

work
Type: NFX.Wave WorkContext
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter.TryMakeSessionFromExistingLongTermToken Method

SessionFilter TryMakeSessionFromExistingLongTermToken Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override in session filters that support long-term tokens. This method tries to re-create "existing" session from a valid long-term token, otherwise null should be returned (the base implementation)

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual WaveSession TryMakeSessionFromExistingLongTermToken(
    WorkContext work
)
protected virtual WaveSession TryMakeSessionFromExistingLongTermToken(
    WorkContext work
)
Protected Overridable Function TryMakeSessionFromExistingLongTermToken (
    work As WorkContext
) As WaveSession
Protected Overridable Function TryMakeSessionFromExistingLongTermToken (
    work As WorkContext
) As WaveSession
protected:
virtual WaveSession^ TryMakeSessionFromExistingLongTermToken(
    WorkContext^ work
)
protected:
virtual WaveSession^ TryMakeSessionFromExistingLongTermToken(
    WorkContext^ work
)
abstract TryMakeSessionFromExistingLongTermToken :
        work : WorkContext -> WaveSession
override TryMakeSessionFromExistingLongTermToken :
        work : WorkContext -> WaveSession
abstract TryMakeSessionFromExistingLongTermToken :
        work : WorkContext -> WaveSession
override TryMakeSessionFromExistingLongTermToken :
        work : WorkContext -> WaveSession

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: WaveSession
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter Properties

SessionFilter Properties NFX Class Library

The SessionFilter type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | CookieName | Specifies session cookie name
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Public property | SessionTimeoutMs | Specifies session inactivity timeout in milliseconds. For default implementation: assign 0 to use App.ObjectStore default object timeout value
Back to Top
See Also
SessionFilter Class
NFX.Wave.Filters Namespace


SessionFilter.CookieName Property

SessionFilter CookieName Property NFX Class Library

Specifies session cookie name

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CookieName { get; set; }
public string CookieName { get; set; }
Public Property CookieName As String
    Get
    Set
Public Property CookieName As String
    Get
    Set
public:
property String^ CookieName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CookieName {
    String^ get ();
    void set (String^ value);
}
member CookieName : string with get, set
member CookieName : string with get, set

Property Value

Type: Online String
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


SessionFilter.SessionTimeoutMs Property

SessionFilter SessionTimeoutMs Property NFX Class Library

Specifies session inactivity timeout in milliseconds. For default implementation: assign 0 to use App.ObjectStore default object timeout value

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int SessionTimeoutMs { get; set; }
public int SessionTimeoutMs { get; set; }
Public Property SessionTimeoutMs As Integer
    Get
    Set
Public Property SessionTimeoutMs As Integer
    Get
    Set
public:
property int SessionTimeoutMs {
    int get ();
    void set (int value);
}
public:
property int SessionTimeoutMs {
    int get ();
    void set (int value);
}
member SessionTimeoutMs : int with get, set
member SessionTimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
SessionFilter Class
SessionFilter Members
NFX.Wave.Filters Namespace


StopFilter Class

StopFilter Class NFX Class Library

Stops the processing of WorkContext by throwing exception upon match
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkFilter
NFX.Wave.Filters BeforeAfterFilterBase
NFX.Wave.Filters StopFilter

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StopFilter : BeforeAfterFilterBase
public class StopFilter : BeforeAfterFilterBase
Public Class StopFilter
    Inherits BeforeAfterFilterBase
Public Class StopFilter
    Inherits BeforeAfterFilterBase
public ref class StopFilter : public BeforeAfterFilterBase
public ref class StopFilter : public BeforeAfterFilterBase
type StopFilter =
    class
        inherit BeforeAfterFilterBase
    end
type StopFilter =
    class
        inherit BeforeAfterFilterBase
    end
See Also
StopFilter Members
NFX.Wave.Filters Namespace


StopFilter Members

StopFilter Members NFX Class Library

The StopFilter type exposes the following members.
Constructors
 | Name | Description
Public method | StopFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the StopFilter class
Public method | StopFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the StopFilter class
Public method | StopFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the StopFilter class
Public method | StopFilter(WorkHandler, String, Int32) | Initializes a new instance of the StopFilter class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAfterWork | (Overrides BeforeAfterFilterBase DoAfterWork(WorkContext, JSONDataMap).)
Protected method | DoBeforeWork | (Overrides BeforeAfterFilterBase DoBeforeWork(WorkContext, JSONDataMap).)
Protected method | DoFilterWork | (Inherited from BeforeAfterFilterBase.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
VAR_CODE |
VAR_ERROR |
Back to Top
Properties
 | Name | Description
Public property | AfterMatches | Returns matches used by the handler to determine whether match should be made before the work processing (Inherited from BeforeAfterFilterBase.)
Public property | BeforeMatches | Returns matches used by the handler to determine whether match should be made before the work processing (Inherited from BeforeAfterFilterBase.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Back to Top
See Also
StopFilter Class
NFX.Wave.Filters Namespace


StopFilter Constructor

StopFilter Constructor NFX Class Library

Overload List
 | Name | Description
Public method | StopFilter(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the StopFilter class
Public method | StopFilter(WorkHandler, IConfigSectionNode) | Initializes a new instance of the StopFilter class
Public method | StopFilter(WorkDispatcher, String, Int32) | Initializes a new instance of the StopFilter class
Public method | StopFilter(WorkHandler, String, Int32) | Initializes a new instance of the StopFilter class
Back to Top
See Also
StopFilter Class
StopFilter Members
NFX.Wave.Filters Namespace


StopFilter Constructor (WorkDispatcher, IConfigSectionNode)

StopFilter Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StopFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StopFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
public StopFilter(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
public:
StopFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
public:
StopFilter(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> StopFilter
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> StopFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
StopFilter Class
StopFilter Members
StopFilter Overload
NFX.Wave.Filters Namespace


StopFilter Constructor (WorkHandler, IConfigSectionNode)

StopFilter Constructor (WorkHandler, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StopFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StopFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
public StopFilter(
    WorkHandler handler,
    IConfigSectionNode confNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
Public Sub New (
    handler As WorkHandler,
    confNode As IConfigSectionNode
)
public:
StopFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
public:
StopFilter(
    WorkHandler^ handler,
    IConfigSectionNode^ confNode
)
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> StopFilter
new :
        handler : WorkHandler *
        confNode : IConfigSectionNode -> StopFilter

Parameters

handler
Type: NFX.Wave WorkHandler
confNode
Type: NFX.Environment IConfigSectionNode
See Also
StopFilter Class
StopFilter Members
StopFilter Overload
NFX.Wave.Filters Namespace


StopFilter Constructor (WorkDispatcher, String, Int32)

StopFilter Constructor (WorkDispatcher, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StopFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StopFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
public StopFilter(
    WorkDispatcher dispatcher,
    string name,
    int order
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer
)
public:
StopFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
public:
StopFilter(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> StopFilter
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int -> StopFilter

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
See Also
StopFilter Class
StopFilter Members
StopFilter Overload
NFX.Wave.Filters Namespace


StopFilter Constructor (WorkHandler, String, Int32)

StopFilter Constructor (WorkHandler, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StopFilter class

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StopFilter(
    WorkHandler handler,
    string name,
    int order
)
public StopFilter(
    WorkHandler handler,
    string name,
    int order
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
Public Sub New (
    handler As WorkHandler,
    name As String,
    order As Integer
)
public:
StopFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
public:
StopFilter(
    WorkHandler^ handler,
    String^ name,
    int order
)
new :
        handler : WorkHandler *
        name : string *
        order : int -> StopFilter
new :
        handler : WorkHandler *
        name : string *
        order : int -> StopFilter

Parameters

handler
Type: NFX.Wave WorkHandler
name
Type: Online System String
order
Type: Online System Int32
See Also
StopFilter Class
StopFilter Members
StopFilter Overload
NFX.Wave.Filters Namespace


StopFilter Fields

StopFilter Fields NFX Class Library

The StopFilter type exposes the following members.
Fields
Name | Description
VAR_CODE |
VAR_ERROR |
Back to Top
See Also
StopFilter Class
NFX.Wave.Filters Namespace


StopFilter.VAR_CODE Field

StopFilter VAR_CODE Field NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_CODE
public const string VAR_CODE
Public Const VAR_CODE As String
Public Const VAR_CODE As String
public:
literal String^ VAR_CODE
public:
literal String^ VAR_CODE
static val mutable VAR_CODE: string
static val mutable VAR_CODE: string

Field Value

Type: Online String
See Also
StopFilter Class
StopFilter Members
NFX.Wave.Filters Namespace


StopFilter.VAR_ERROR Field

StopFilter VAR_ERROR Field NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_ERROR
public const string VAR_ERROR
Public Const VAR_ERROR As String
Public Const VAR_ERROR As String
public:
literal String^ VAR_ERROR
public:
literal String^ VAR_ERROR
static val mutable VAR_ERROR: string
static val mutable VAR_ERROR: string

Field Value

Type: Online String
See Also
StopFilter Class
StopFilter Members
NFX.Wave.Filters Namespace


StopFilter Methods

StopFilter Methods NFX Class Library

The StopFilter type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAfterWork | (Overrides BeforeAfterFilterBase DoAfterWork(WorkContext, JSONDataMap).)
Protected method | DoBeforeWork | (Overrides BeforeAfterFilterBase DoBeforeWork(WorkContext, JSONDataMap).)
Protected method | DoFilterWork | (Inherited from BeforeAfterFilterBase.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterWork | Override to filter the work - i.e. extract some security name from cookies and check access, turn exception in error page etc. Note: This method is re-entrant by multiple threads (Inherited from WorkFilter.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeNextWorker | Invokes next processing body be it the next filter or handler (when all filters are iterated through). The filter implementors must call this method to pass WorkContext processing along the line. Does nothing if work is Aborted or Handled (Inherited from WorkFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WorkFilter.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
StopFilter Class
NFX.Wave.Filters Namespace


StopFilter.DoAfterWork Method

StopFilter DoAfterWork Method NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoAfterWork(
    WorkContext work,
    JSONDataMap matched
)
protected override void DoAfterWork(
    WorkContext work,
    JSONDataMap matched
)
Protected Overrides Sub DoAfterWork (
    work As WorkContext,
    matched As JSONDataMap
)
Protected Overrides Sub DoAfterWork (
    work As WorkContext,
    matched As JSONDataMap
)
protected:
virtual void DoAfterWork(
    WorkContext^ work,
    JSONDataMap^ matched
) override
protected:
virtual void DoAfterWork(
    WorkContext^ work,
    JSONDataMap^ matched
) override
abstract DoAfterWork :
        work : WorkContext *
        matched : JSONDataMap -> unit
override DoAfterWork :
        work : WorkContext *
        matched : JSONDataMap -> unit
abstract DoAfterWork :
        work : WorkContext *
        matched : JSONDataMap -> unit
override DoAfterWork :
        work : WorkContext *
        matched : JSONDataMap -> unit

Parameters

work
Type: NFX.Wave WorkContext
matched
Type: NFX.Serialization.JSON JSONDataMap
See Also
StopFilter Class
StopFilter Members
NFX.Wave.Filters Namespace


StopFilter.DoBeforeWork Method

StopFilter DoBeforeWork Method NFX Class Library

Namespace: NFX.Wave.Filters
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoBeforeWork(
    WorkContext work,
    JSONDataMap matched
)
protected override void DoBeforeWork(
    WorkContext work,
    JSONDataMap matched
)
Protected Overrides Sub DoBeforeWork (
    work As WorkContext,
    matched As JSONDataMap
)
Protected Overrides Sub DoBeforeWork (
    work As WorkContext,
    matched As JSONDataMap
)
protected:
virtual void DoBeforeWork(
    WorkContext^ work,
    JSONDataMap^ matched
) override
protected:
virtual void DoBeforeWork(
    WorkContext^ work,
    JSONDataMap^ matched
) override
abstract DoBeforeWork :
        work : WorkContext *
        matched : JSONDataMap -> unit
override DoBeforeWork :
        work : WorkContext *
        matched : JSONDataMap -> unit
abstract DoBeforeWork :
        work : WorkContext *
        matched : JSONDataMap -> unit
override DoBeforeWork :
        work : WorkContext *
        matched : JSONDataMap -> unit

Parameters

work
Type: NFX.Wave WorkContext
matched
Type: NFX.Serialization.JSON JSONDataMap
See Also
StopFilter Class
StopFilter Members
NFX.Wave.Filters Namespace


StopFilter Properties

StopFilter Properties NFX Class Library

The StopFilter type exposes the following members.
Properties
 | Name | Description
Public property | AfterMatches | Returns matches used by the handler to determine whether match should be made before the work processing (Inherited from BeforeAfterFilterBase.)
Public property | BeforeMatches | Returns matches used by the handler to determine whether match should be made before the work processing (Inherited from BeforeAfterFilterBase.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this filter works under (Inherited from WorkFilter.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Handler | Returns the handler that this filter works under. May be null if the filter works under dispatcher (Inherited from WorkFilter.)
Public property | Name | Returns the filter instance name (Inherited from WorkFilter.)
Public property | NetGate | Returns network gate that filter implementation may use to set business variables or null (Inherited from WorkFilter.)
Public property | Order | Returns the filter order in filter registry. Order is used for URI pattern matching (Inherited from WorkFilter.)
Public property | Server | Returns the server that this filter works under (Inherited from WorkFilter.)
Back to Top
See Also
StopFilter Class
NFX.Wave.Filters Namespace


NFX.Wave.Handlers Namespace

NFX.Wave.Handlers Namespace NFX Class Library

Classes
 | Class | Description
Public class | CompositeHandler | Dispatched work to sub-handlers just like dispatcher does
Public class | ContextDumpHandler | Dumps WorkContext status - used for debugging purposes
Public class | EmbeddedSiteHandler | Implements handler that serves content from assembly-embedded resources and class actions. Inherit from this class to implement actual handler that serves from particular assembly/namespace root
Public class | FileDownloadHandler | Downloads local files or files from portal content file system. Be carefull with this handler as the incorrect root setup may allow users to download system-internal files
Public class | MVCHandler | Handles MVC-related requests
Public class | NOPHandler | Implements handler that does nothing
Public class | StockContentSiteHandler | This handler serves the embedded content of NFX.Wave library
Public class | TemplateHandler | Implements handler that serves WaveTemplates
Public class | TypeLocation | Represents a location used for dynamic type searches
Public class | TypeLocations | A list of type search locations used for dynamic type searches
Protected class | TypeLookup | Lookup table string->Type
Public class | TypeLookupHandler TTarget | Represents a base handler for all handlers that dynamicaly resolve type that performs actual work
Interfaces
 | Interface | Description
Public interface | EmbeddedSiteHandler IAction | Represents an action that can be dispatched by a EmbeddedSiteHandler. The instance of this interface implementor is shared between requests (must be thread-safe)


CompositeHandler Class

CompositeHandler Class NFX Class Library

Dispatched work to sub-handlers just like dispatcher does
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkHandler
NFX.Wave.Handlers CompositeHandler

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CompositeHandler : WorkHandler
public sealed class CompositeHandler : WorkHandler
Public NotInheritable Class CompositeHandler
    Inherits WorkHandler
Public NotInheritable Class CompositeHandler
    Inherits WorkHandler
public ref class CompositeHandler sealed : public WorkHandler
public ref class CompositeHandler sealed : public WorkHandler
[<SealedAttribute>]
type CompositeHandler =
    class
        inherit WorkHandler
    end
[<SealedAttribute>]
type CompositeHandler =
    class
        inherit WorkHandler
    end
See Also
CompositeHandler Members
NFX.Wave.Handlers Namespace


CompositeHandler Members

CompositeHandler Members NFX Class Library

The CompositeHandler type exposes the following members.
Constructors
 | Name | Description
Public method | CompositeHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the CompositeHandler class
Public method | CompositeHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the CompositeHandler class
Back to Top
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from WorkHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoHandleWork | (Overrides WorkHandler DoHandleWork(WorkContext).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Public method | RegisterHandler | Registers handler and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject handlers while serving requests
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Public method | UnRegisterHandler | Unregisters handler and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove handlers while serving requests
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Handlers | Returns ordered registry of handlers
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Back to Top
See Also
CompositeHandler Class
NFX.Wave.Handlers Namespace


CompositeHandler Constructor

CompositeHandler Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CompositeHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the CompositeHandler class
Public method | CompositeHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the CompositeHandler class
Back to Top
See Also
CompositeHandler Class
CompositeHandler Members
NFX.Wave.Handlers Namespace


CompositeHandler Constructor (WorkDispatcher, IConfigSectionNode)

CompositeHandler Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CompositeHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompositeHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
public CompositeHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
public:
CompositeHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
public:
CompositeHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> CompositeHandler
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> CompositeHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
CompositeHandler Class
CompositeHandler Members
CompositeHandler Overload
NFX.Wave.Handlers Namespace


CompositeHandler Constructor (WorkDispatcher, String, Int32, WorkMatch)

CompositeHandler Constructor (WorkDispatcher, String, Int32, WorkMatch) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CompositeHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompositeHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
public CompositeHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
public:
CompositeHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
public:
CompositeHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> CompositeHandler
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> CompositeHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
match
Type: NFX.Wave WorkMatch
See Also
CompositeHandler Class
CompositeHandler Members
CompositeHandler Overload
NFX.Wave.Handlers Namespace


CompositeHandler Methods

CompositeHandler Methods NFX Class Library

The CompositeHandler type exposes the following members.
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from WorkHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoHandleWork | (Overrides WorkHandler DoHandleWork(WorkContext).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Public method | RegisterHandler | Registers handler and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject handlers while serving requests
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Public method | UnRegisterHandler | Unregisters handler and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove handlers while serving requests
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CompositeHandler Class
NFX.Wave.Handlers Namespace


CompositeHandler.DoHandleWork Method

CompositeHandler DoHandleWork Method NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoHandleWork(
    WorkContext work
)
protected override void DoHandleWork(
    WorkContext work
)
Protected Overrides Sub DoHandleWork (
    work As WorkContext
)
Protected Overrides Sub DoHandleWork (
    work As WorkContext
)
protected:
virtual void DoHandleWork(
    WorkContext^ work
) override
protected:
virtual void DoHandleWork(
    WorkContext^ work
) override
abstract DoHandleWork :
        work : WorkContext -> unit
override DoHandleWork :
        work : WorkContext -> unit
abstract DoHandleWork :
        work : WorkContext -> unit
override DoHandleWork :
        work : WorkContext -> unit

Parameters

work
Type: NFX.Wave WorkContext
See Also
CompositeHandler Class
CompositeHandler Members
NFX.Wave.Handlers Namespace


CompositeHandler.RegisterHandler Method

CompositeHandler RegisterHandler Method NFX Class Library

Registers handler and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject handlers while serving requests

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RegisterHandler(
    WorkHandler handler
)
public bool RegisterHandler(
    WorkHandler handler
)
Public Function RegisterHandler (
    handler As WorkHandler
) As Boolean
Public Function RegisterHandler (
    handler As WorkHandler
) As Boolean
public:
bool RegisterHandler(
    WorkHandler^ handler
)
public:
bool RegisterHandler(
    WorkHandler^ handler
)
member RegisterHandler :
        handler : WorkHandler -> bool
member RegisterHandler :
        handler : WorkHandler -> bool

Parameters

handler
Type: NFX.Wave WorkHandler

Return Value

Type: Online Boolean
See Also
CompositeHandler Class
CompositeHandler Members
NFX.Wave.Handlers Namespace


CompositeHandler.UnRegisterHandler Method

CompositeHandler UnRegisterHandler Method NFX Class Library

Unregisters handler and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove handlers while serving requests

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnRegisterHandler(
    WorkHandler handler
)
public bool UnRegisterHandler(
    WorkHandler handler
)
Public Function UnRegisterHandler (
    handler As WorkHandler
) As Boolean
Public Function UnRegisterHandler (
    handler As WorkHandler
) As Boolean
public:
bool UnRegisterHandler(
    WorkHandler^ handler
)
public:
bool UnRegisterHandler(
    WorkHandler^ handler
)
member UnRegisterHandler :
        handler : WorkHandler -> bool
member UnRegisterHandler :
        handler : WorkHandler -> bool

Parameters

handler
Type: NFX.Wave WorkHandler

Return Value

Type: Online Boolean
See Also
CompositeHandler Class
CompositeHandler Members
NFX.Wave.Handlers Namespace


CompositeHandler Properties

CompositeHandler Properties NFX Class Library

The CompositeHandler type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Handlers | Returns ordered registry of handlers
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Back to Top
See Also
CompositeHandler Class
NFX.Wave.Handlers Namespace


CompositeHandler.Handlers Property

CompositeHandler Handlers Property NFX Class Library

Returns ordered registry of handlers

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<WorkHandler> Handlers { get; }
public IRegistry<WorkHandler> Handlers { get; }
Public ReadOnly Property Handlers As IRegistry(Of WorkHandler)
    Get
Public ReadOnly Property Handlers As IRegistry(Of WorkHandler)
    Get
public:
property IRegistry<WorkHandler^>^ Handlers {
    IRegistry<WorkHandler^>^ get ();
}
public:
property IRegistry<WorkHandler^>^ Handlers {
    IRegistry<WorkHandler^>^ get ();
}
member Handlers : IRegistry<WorkHandler> with get
member Handlers : IRegistry<WorkHandler> with get

Property Value

Type: IRegistry WorkHandler
See Also
CompositeHandler Class
CompositeHandler Members
NFX.Wave.Handlers Namespace


ContextDumpHandler Class

ContextDumpHandler Class NFX Class Library

Dumps WorkContext status - used for debugging purposes
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkHandler
NFX.Wave.Handlers ContextDumpHandler

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ContextDumpHandler : WorkHandler
public class ContextDumpHandler : WorkHandler
Public Class ContextDumpHandler
    Inherits WorkHandler
Public Class ContextDumpHandler
    Inherits WorkHandler
public ref class ContextDumpHandler : public WorkHandler
public ref class ContextDumpHandler : public WorkHandler
type ContextDumpHandler =
    class
        inherit WorkHandler
    end
type ContextDumpHandler =
    class
        inherit WorkHandler
    end
See Also
ContextDumpHandler Members
NFX.Wave.Handlers Namespace


ContextDumpHandler Members

ContextDumpHandler Members NFX Class Library

The ContextDumpHandler type exposes the following members.
Constructors
 | Name | Description
Protected method | ContextDumpHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the ContextDumpHandler class
Protected method | ContextDumpHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the ContextDumpHandler class
Back to Top
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from WorkHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoHandleWork | (Overrides WorkHandler DoHandleWork(WorkContext).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Back to Top
See Also
ContextDumpHandler Class
NFX.Wave.Handlers Namespace


ContextDumpHandler Constructor

ContextDumpHandler Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ContextDumpHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the ContextDumpHandler class
Protected method | ContextDumpHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the ContextDumpHandler class
Back to Top
See Also
ContextDumpHandler Class
ContextDumpHandler Members
NFX.Wave.Handlers Namespace


ContextDumpHandler Constructor (WorkDispatcher, IConfigSectionNode)

ContextDumpHandler Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ContextDumpHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ContextDumpHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
protected ContextDumpHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
protected:
ContextDumpHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
protected:
ContextDumpHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> ContextDumpHandler
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> ContextDumpHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
ContextDumpHandler Class
ContextDumpHandler Members
ContextDumpHandler Overload
NFX.Wave.Handlers Namespace


ContextDumpHandler Constructor (WorkDispatcher, String, Int32, WorkMatch)

ContextDumpHandler Constructor (WorkDispatcher, String, Int32, WorkMatch) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ContextDumpHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ContextDumpHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
protected ContextDumpHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
protected:
ContextDumpHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
protected:
ContextDumpHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> ContextDumpHandler
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> ContextDumpHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
match
Type: NFX.Wave WorkMatch
See Also
ContextDumpHandler Class
ContextDumpHandler Members
ContextDumpHandler Overload
NFX.Wave.Handlers Namespace


ContextDumpHandler Methods

ContextDumpHandler Methods NFX Class Library

The ContextDumpHandler type exposes the following members.
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from WorkHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoHandleWork | (Overrides WorkHandler DoHandleWork(WorkContext).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ContextDumpHandler Class
NFX.Wave.Handlers Namespace


ContextDumpHandler.DoHandleWork Method

ContextDumpHandler DoHandleWork Method NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoHandleWork(
    WorkContext work
)
protected override void DoHandleWork(
    WorkContext work
)
Protected Overrides Sub DoHandleWork (
    work As WorkContext
)
Protected Overrides Sub DoHandleWork (
    work As WorkContext
)
protected:
virtual void DoHandleWork(
    WorkContext^ work
) override
protected:
virtual void DoHandleWork(
    WorkContext^ work
) override
abstract DoHandleWork :
        work : WorkContext -> unit
override DoHandleWork :
        work : WorkContext -> unit
abstract DoHandleWork :
        work : WorkContext -> unit
override DoHandleWork :
        work : WorkContext -> unit

Parameters

work
Type: NFX.Wave WorkContext
See Also
ContextDumpHandler Class
ContextDumpHandler Members
NFX.Wave.Handlers Namespace


ContextDumpHandler Properties

ContextDumpHandler Properties NFX Class Library

The ContextDumpHandler type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Back to Top
See Also
ContextDumpHandler Class
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler Class

EmbeddedSiteHandler Class NFX Class Library

Implements handler that serves content from assembly-embedded resources and class actions. Inherit from this class to implement actual handler that serves from particular assembly/namespace root
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkHandler
NFX.Wave.Handlers EmbeddedSiteHandler
NFX.Wave.Handlers StockContentSiteHandler

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class EmbeddedSiteHandler : WorkHandler
public abstract class EmbeddedSiteHandler : WorkHandler
Public MustInherit Class EmbeddedSiteHandler
    Inherits WorkHandler
Public MustInherit Class EmbeddedSiteHandler
    Inherits WorkHandler
public ref class EmbeddedSiteHandler abstract : public WorkHandler
public ref class EmbeddedSiteHandler abstract : public WorkHandler
[<AbstractClassAttribute>]
type EmbeddedSiteHandler =
    class
        inherit WorkHandler
    end
[<AbstractClassAttribute>]
type EmbeddedSiteHandler =
    class
        inherit WorkHandler
    end
See Also
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler Members

EmbeddedSiteHandler Members NFX Class Library

The EmbeddedSiteHandler type exposes the following members.
Constructors
 | Name | Description
Protected method | EmbeddedSiteHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the EmbeddedSiteHandler class
Protected method | EmbeddedSiteHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the EmbeddedSiteHandler class
Back to Top
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from WorkHandler.)
Protected method | DispatchAction | Dispatched appropriate action
Protected method | DispatchNonSiteAction | Dispatches an action which is not a site-serving one
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoHandleWork | (Overrides WorkHandler DoHandleWork(WorkContext).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetActions | Override to declare what actions this site can perform
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ParseWork | Override to extract action and path form request
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Protected method | SetResourceCacheHeader | Override to set specific cache header set per resource name
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_CACHE_CONTROL_SECTION |
DEFAULT_SITE_PATH |
SITE_ACTION |
VAR_PATH |
Back to Top
Properties
 | Name | Description
Public property | Actions | Returns actions that this site can perform
Public property | CacheControl |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultSitePath | Returns default site path that serves site root
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | RootResourcePath | Returns resource path root, i.e. namespace prefixes where resources reside
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Public property | SiteAction | Returns name for action that serves embedded site
Public property | SupportsEnvironmentBranching | Override in sites that do not support named environment sub-folders in resource structure. True by default
Public property | VersionSegmentPrefix | When set indicates the case-insensitive prefix of a path segment that should be ignored by the handler path resolver. Version prefixes are used for attaching a surrogate path "folder" that makes resource differ based on their content. For example when prefix is "@", path '/embedded/img/@767868768768/picture.png' resolves to actual '/embedded/img/picture.png'
Back to Top
See Also
EmbeddedSiteHandler Class
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler Constructor

EmbeddedSiteHandler Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | EmbeddedSiteHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the EmbeddedSiteHandler class
Protected method | EmbeddedSiteHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the EmbeddedSiteHandler class
Back to Top
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler Constructor (WorkDispatcher, IConfigSectionNode)

EmbeddedSiteHandler Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EmbeddedSiteHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected EmbeddedSiteHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
protected EmbeddedSiteHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
protected:
EmbeddedSiteHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
protected:
EmbeddedSiteHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> EmbeddedSiteHandler
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> EmbeddedSiteHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
EmbeddedSiteHandler Overload
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler Constructor (WorkDispatcher, String, Int32, WorkMatch)

EmbeddedSiteHandler Constructor (WorkDispatcher, String, Int32, WorkMatch) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EmbeddedSiteHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected EmbeddedSiteHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
protected EmbeddedSiteHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
protected:
EmbeddedSiteHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
protected:
EmbeddedSiteHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> EmbeddedSiteHandler
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> EmbeddedSiteHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
match
Type: NFX.Wave WorkMatch
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
EmbeddedSiteHandler Overload
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler Fields

EmbeddedSiteHandler Fields NFX Class Library

The EmbeddedSiteHandler type exposes the following members.
Fields
Name | Description
CONFIG_CACHE_CONTROL_SECTION |
DEFAULT_SITE_PATH |
SITE_ACTION |
VAR_PATH |
Back to Top
See Also
EmbeddedSiteHandler Class
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.CONFIG_CACHE_CONTROL_SECTION Field

EmbeddedSiteHandler CONFIG_CACHE_CONTROL_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CACHE_CONTROL_SECTION
public const string CONFIG_CACHE_CONTROL_SECTION
Public Const CONFIG_CACHE_CONTROL_SECTION As String
Public Const CONFIG_CACHE_CONTROL_SECTION As String
public:
literal String^ CONFIG_CACHE_CONTROL_SECTION
public:
literal String^ CONFIG_CACHE_CONTROL_SECTION
static val mutable CONFIG_CACHE_CONTROL_SECTION: string
static val mutable CONFIG_CACHE_CONTROL_SECTION: string

Field Value

Type: Online String
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.DEFAULT_SITE_PATH Field

EmbeddedSiteHandler DEFAULT_SITE_PATH Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_SITE_PATH
public const string DEFAULT_SITE_PATH
Public Const DEFAULT_SITE_PATH As String
Public Const DEFAULT_SITE_PATH As String
public:
literal String^ DEFAULT_SITE_PATH
public:
literal String^ DEFAULT_SITE_PATH
static val mutable DEFAULT_SITE_PATH: string
static val mutable DEFAULT_SITE_PATH: string

Field Value

Type: Online String
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.SITE_ACTION Field

EmbeddedSiteHandler SITE_ACTION Field NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SITE_ACTION
public const string SITE_ACTION
Public Const SITE_ACTION As String
Public Const SITE_ACTION As String
public:
literal String^ SITE_ACTION
public:
literal String^ SITE_ACTION
static val mutable SITE_ACTION: string
static val mutable SITE_ACTION: string

Field Value

Type: Online String
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.VAR_PATH Field

EmbeddedSiteHandler VAR_PATH Field NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_PATH
public const string VAR_PATH
Public Const VAR_PATH As String
Public Const VAR_PATH As String
public:
literal String^ VAR_PATH
public:
literal String^ VAR_PATH
static val mutable VAR_PATH: string
static val mutable VAR_PATH: string

Field Value

Type: Online String
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler Methods

EmbeddedSiteHandler Methods NFX Class Library

The EmbeddedSiteHandler type exposes the following members.
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from WorkHandler.)
Protected method | DispatchAction | Dispatched appropriate action
Protected method | DispatchNonSiteAction | Dispatches an action which is not a site-serving one
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoHandleWork | (Overrides WorkHandler DoHandleWork(WorkContext).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetActions | Override to declare what actions this site can perform
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ParseWork | Override to extract action and path form request
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Protected method | SetResourceCacheHeader | Override to set specific cache header set per resource name
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
EmbeddedSiteHandler Class
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.DispatchAction Method

EmbeddedSiteHandler DispatchAction Method NFX Class Library

Dispatched appropriate action

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DispatchAction(
    WorkContext work,
    string action,
    string path
)
protected virtual void DispatchAction(
    WorkContext work,
    string action,
    string path
)
Protected Overridable Sub DispatchAction (
    work As WorkContext,
    action As String,
    path As String
)
Protected Overridable Sub DispatchAction (
    work As WorkContext,
    action As String,
    path As String
)
protected:
virtual void DispatchAction(
    WorkContext^ work,
    String^ action,
    String^ path
)
protected:
virtual void DispatchAction(
    WorkContext^ work,
    String^ action,
    String^ path
)
abstract DispatchAction :
        work : WorkContext *
        action : string *
        path : string -> unit
override DispatchAction :
        work : WorkContext *
        action : string *
        path : string -> unit
abstract DispatchAction :
        work : WorkContext *
        action : string *
        path : string -> unit
override DispatchAction :
        work : WorkContext *
        action : string *
        path : string -> unit

Parameters

work
Type: NFX.Wave WorkContext
action
Type: Online System String
path
Type: Online System String
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.DispatchNonSiteAction Method

EmbeddedSiteHandler DispatchNonSiteAction Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Dispatches an action which is not a site-serving one

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DispatchNonSiteAction(
    WorkContext context,
    string action
)
protected virtual void DispatchNonSiteAction(
    WorkContext context,
    string action
)
Protected Overridable Sub DispatchNonSiteAction (
    context As WorkContext,
    action As String
)
Protected Overridable Sub DispatchNonSiteAction (
    context As WorkContext,
    action As String
)
protected:
virtual void DispatchNonSiteAction(
    WorkContext^ context,
    String^ action
)
protected:
virtual void DispatchNonSiteAction(
    WorkContext^ context,
    String^ action
)
abstract DispatchNonSiteAction :
        context : WorkContext *
        action : string -> unit
override DispatchNonSiteAction :
        context : WorkContext *
        action : string -> unit
abstract DispatchNonSiteAction :
        context : WorkContext *
        action : string -> unit
override DispatchNonSiteAction :
        context : WorkContext *
        action : string -> unit

Parameters

context
Type: NFX.Wave WorkContext
action
Type: Online System String
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.DoHandleWork Method

EmbeddedSiteHandler DoHandleWork Method NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoHandleWork(
    WorkContext work
)
protected override void DoHandleWork(
    WorkContext work
)
Protected Overrides Sub DoHandleWork (
    work As WorkContext
)
Protected Overrides Sub DoHandleWork (
    work As WorkContext
)
protected:
virtual void DoHandleWork(
    WorkContext^ work
) override
protected:
virtual void DoHandleWork(
    WorkContext^ work
) override
abstract DoHandleWork :
        work : WorkContext -> unit
override DoHandleWork :
        work : WorkContext -> unit
abstract DoHandleWork :
        work : WorkContext -> unit
override DoHandleWork :
        work : WorkContext -> unit

Parameters

work
Type: NFX.Wave WorkContext
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.GetActions Method

EmbeddedSiteHandler GetActions Method NFX Class Library

Override to declare what actions this site can perform

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract IEnumerable<EmbeddedSiteHandler..::..IAction> GetActions()
protected abstract IEnumerable<EmbeddedSiteHandler..::..IAction> GetActions()
Protected MustOverride Function GetActions As IEnumerable(Of EmbeddedSiteHandler..::..IAction)
Protected MustOverride Function GetActions As IEnumerable(Of EmbeddedSiteHandler..::..IAction)
protected:
virtual IEnumerable<EmbeddedSiteHandler..::..IAction^>^ GetActions() abstract
protected:
virtual IEnumerable<EmbeddedSiteHandler..::..IAction^>^ GetActions() abstract
abstract GetActions : unit -> IEnumerable<EmbeddedSiteHandler..::..IAction>
abstract GetActions : unit -> IEnumerable<EmbeddedSiteHandler..::..IAction>

Return Value

Type: Online IEnumerable EmbeddedSiteHandler IAction
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.ParseWork Method

EmbeddedSiteHandler ParseWork Method NFX Class Library

Override to extract action and path form request

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string ParseWork(
    WorkContext work,
    out string path
)
protected virtual string ParseWork(
    WorkContext work,
    out string path
)
Protected Overridable Function ParseWork (
    work As WorkContext,
    <OutAttribute> ByRef path As String
) As String
Protected Overridable Function ParseWork (
    work As WorkContext,
    <OutAttribute> ByRef path As String
) As String
protected:
virtual String^ ParseWork(
    WorkContext^ work,
    [OutAttribute] String^% path
)
protected:
virtual String^ ParseWork(
    WorkContext^ work,
    [OutAttribute] String^% path
)
abstract ParseWork :
        work : WorkContext *
        path : string byref -> string
override ParseWork :
        work : WorkContext *
        path : string byref -> string
abstract ParseWork :
        work : WorkContext *
        path : string byref -> string
override ParseWork :
        work : WorkContext *
        path : string byref -> string

Parameters

work
Type: NFX.Wave WorkContext
path
Type: Online System String

Return Value

Type: Online String
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.SetResourceCacheHeader Method

EmbeddedSiteHandler SetResourceCacheHeader Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to set specific cache header set per resource name

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void SetResourceCacheHeader(
    WorkContext work,
    string sitePath,
    string resName
)
protected virtual void SetResourceCacheHeader(
    WorkContext work,
    string sitePath,
    string resName
)
Protected Overridable Sub SetResourceCacheHeader (
    work As WorkContext,
    sitePath As String,
    resName As String
)
Protected Overridable Sub SetResourceCacheHeader (
    work As WorkContext,
    sitePath As String,
    resName As String
)
protected:
virtual void SetResourceCacheHeader(
    WorkContext^ work,
    String^ sitePath,
    String^ resName
)
protected:
virtual void SetResourceCacheHeader(
    WorkContext^ work,
    String^ sitePath,
    String^ resName
)
abstract SetResourceCacheHeader :
        work : WorkContext *
        sitePath : string *
        resName : string -> unit
override SetResourceCacheHeader :
        work : WorkContext *
        sitePath : string *
        resName : string -> unit
abstract SetResourceCacheHeader :
        work : WorkContext *
        sitePath : string *
        resName : string -> unit
override SetResourceCacheHeader :
        work : WorkContext *
        sitePath : string *
        resName : string -> unit

Parameters

work
Type: NFX.Wave WorkContext
sitePath
Type: Online System String
resName
Type: Online System String
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler Properties

EmbeddedSiteHandler Properties NFX Class Library

The EmbeddedSiteHandler type exposes the following members.
Properties
 | Name | Description
Public property | Actions | Returns actions that this site can perform
Public property | CacheControl |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultSitePath | Returns default site path that serves site root
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | RootResourcePath | Returns resource path root, i.e. namespace prefixes where resources reside
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Public property | SiteAction | Returns name for action that serves embedded site
Public property | SupportsEnvironmentBranching | Override in sites that do not support named environment sub-folders in resource structure. True by default
Public property | VersionSegmentPrefix | When set indicates the case-insensitive prefix of a path segment that should be ignored by the handler path resolver. Version prefixes are used for attaching a surrogate path "folder" that makes resource differ based on their content. For example when prefix is "@", path '/embedded/img/@767868768768/picture.png' resolves to actual '/embedded/img/picture.png'
Back to Top
See Also
EmbeddedSiteHandler Class
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.Actions Property

EmbeddedSiteHandler Actions Property NFX Class Library

Returns actions that this site can perform

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<EmbeddedSiteHandler..::..IAction> Actions { get; }
public IRegistry<EmbeddedSiteHandler..::..IAction> Actions { get; }
Public ReadOnly Property Actions As IRegistry(Of EmbeddedSiteHandler..::..IAction)
    Get
Public ReadOnly Property Actions As IRegistry(Of EmbeddedSiteHandler..::..IAction)
    Get
public:
property IRegistry<EmbeddedSiteHandler..::..IAction^>^ Actions {
    IRegistry<EmbeddedSiteHandler..::..IAction^>^ get ();
}
public:
property IRegistry<EmbeddedSiteHandler..::..IAction^>^ Actions {
    IRegistry<EmbeddedSiteHandler..::..IAction^>^ get ();
}
member Actions : IRegistry<EmbeddedSiteHandler..::..IAction> with get
member Actions : IRegistry<EmbeddedSiteHandler..::..IAction> with get

Property Value

Type: IRegistry EmbeddedSiteHandler IAction
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.CacheControl Property

EmbeddedSiteHandler CacheControl Property NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CacheControl CacheControl { get; set; }
public CacheControl CacheControl { get; set; }
Public Property CacheControl As CacheControl
    Get
    Set
Public Property CacheControl As CacheControl
    Get
    Set
public:
property CacheControl CacheControl {
    CacheControl get ();
    void set (CacheControl value);
}
public:
property CacheControl CacheControl {
    CacheControl get ();
    void set (CacheControl value);
}
member CacheControl : CacheControl with get, set
member CacheControl : CacheControl with get, set

Property Value

Type: CacheControl
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.DefaultSitePath Property

EmbeddedSiteHandler DefaultSitePath Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns default site path that serves site root

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string DefaultSitePath { get; }
public virtual string DefaultSitePath { get; }
Public Overridable ReadOnly Property DefaultSitePath As String
    Get
Public Overridable ReadOnly Property DefaultSitePath As String
    Get
public:
virtual property String^ DefaultSitePath {
    String^ get ();
}
public:
virtual property String^ DefaultSitePath {
    String^ get ();
}
abstract DefaultSitePath : string with get
override DefaultSitePath : string with get
abstract DefaultSitePath : string with get
override DefaultSitePath : string with get

Property Value

Type: Online String
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.RootResourcePath Property

EmbeddedSiteHandler RootResourcePath Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns resource path root, i.e. namespace prefixes where resources reside

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string RootResourcePath { get; }
public abstract string RootResourcePath { get; }
Public MustOverride ReadOnly Property RootResourcePath As String
    Get
Public MustOverride ReadOnly Property RootResourcePath As String
    Get
public:
virtual property String^ RootResourcePath {
    String^ get () abstract;
}
public:
virtual property String^ RootResourcePath {
    String^ get () abstract;
}
abstract RootResourcePath : string with get
abstract RootResourcePath : string with get

Property Value

Type: Online String
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.SiteAction Property

EmbeddedSiteHandler SiteAction Property NFX Class Library

Returns name for action that serves embedded site

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string SiteAction { get; }
public virtual string SiteAction { get; }
Public Overridable ReadOnly Property SiteAction As String
    Get
Public Overridable ReadOnly Property SiteAction As String
    Get
public:
virtual property String^ SiteAction {
    String^ get ();
}
public:
virtual property String^ SiteAction {
    String^ get ();
}
abstract SiteAction : string with get
override SiteAction : string with get
abstract SiteAction : string with get
override SiteAction : string with get

Property Value

Type: Online String
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.SupportsEnvironmentBranching Property

EmbeddedSiteHandler SupportsEnvironmentBranching Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Override in sites that do not support named environment sub-folders in resource structure. True by default

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool SupportsEnvironmentBranching { get; }
public virtual bool SupportsEnvironmentBranching { get; }
Public Overridable ReadOnly Property SupportsEnvironmentBranching As Boolean
    Get
Public Overridable ReadOnly Property SupportsEnvironmentBranching As Boolean
    Get
public:
virtual property bool SupportsEnvironmentBranching {
    bool get ();
}
public:
virtual property bool SupportsEnvironmentBranching {
    bool get ();
}
abstract SupportsEnvironmentBranching : bool with get
override SupportsEnvironmentBranching : bool with get
abstract SupportsEnvironmentBranching : bool with get
override SupportsEnvironmentBranching : bool with get

Property Value

Type: Online Boolean
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.VersionSegmentPrefix Property

EmbeddedSiteHandler VersionSegmentPrefix Property NFX Class Library

[This is preliminary documentation and is subject to change.]

When set indicates the case-insensitive prefix of a path segment that should be ignored by the handler path resolver. Version prefixes are used for attaching a surrogate path "folder" that makes resource differ based on their content. For example when prefix is "@", path '/embedded/img/@767868768768/picture.png' resolves to actual '/embedded/img/picture.png'

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string VersionSegmentPrefix { get; set; }
public string VersionSegmentPrefix { get; set; }
Public Property VersionSegmentPrefix As String
    Get
    Set
Public Property VersionSegmentPrefix As String
    Get
    Set
public:
property String^ VersionSegmentPrefix {
    String^ get ();
    void set (String^ value);
}
public:
property String^ VersionSegmentPrefix {
    String^ get ();
    void set (String^ value);
}
member VersionSegmentPrefix : string with get, set
member VersionSegmentPrefix : string with get, set

Property Value

Type: Online String
See Also
EmbeddedSiteHandler Class
EmbeddedSiteHandler Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.IAction Interface

EmbeddedSiteHandler IAction Interface NFX Class Library

Represents an action that can be dispatched by a EmbeddedSiteHandler. The instance of this interface implementor is shared between requests (must be thread-safe)

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IAction : INamed
public interface IAction : INamed
Public Interface IAction
    Inherits INamed
Public Interface IAction
    Inherits INamed
public interface class IAction : INamed
public interface class IAction : INamed
type IAction =
    interface
        interface INamed
    end
type IAction =
    interface
        interface INamed
    end
See Also
EmbeddedSiteHandler IAction Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.IAction Members

EmbeddedSiteHandler IAction Members NFX Class Library

The EmbeddedSiteHandler IAction type exposes the following members.
Methods
 | Name | Description
Public method | Perform | Performs the action - by performing action work
Back to Top
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
EmbeddedSiteHandler IAction Interface
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.IAction Methods

EmbeddedSiteHandler IAction Methods NFX Class Library

The EmbeddedSiteHandler IAction type exposes the following members.
Methods
 | Name | Description
Public method | Perform | Performs the action - by performing action work
Back to Top
See Also
EmbeddedSiteHandler IAction Interface
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.IAction.Perform Method

EmbeddedSiteHandler IAction Perform Method NFX Class Library

Performs the action - by performing action work

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Perform(
    WorkContext context
)
void Perform(
    WorkContext context
)
Sub Perform (
    context As WorkContext
)
Sub Perform (
    context As WorkContext
)
void Perform(
    WorkContext^ context
)
void Perform(
    WorkContext^ context
)
abstract Perform :
        context : WorkContext -> unit
abstract Perform :
        context : WorkContext -> unit

Parameters

context
Type: NFX.Wave WorkContext
See Also
EmbeddedSiteHandler IAction Interface
EmbeddedSiteHandler IAction Members
NFX.Wave.Handlers Namespace


EmbeddedSiteHandler.IAction Properties

EmbeddedSiteHandler IAction Properties NFX Class Library

The EmbeddedSiteHandler IAction type exposes the following members.
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
EmbeddedSiteHandler IAction Interface
NFX.Wave.Handlers Namespace


FileDownloadHandler Class

FileDownloadHandler Class NFX Class Library

Downloads local files or files from portal content file system. Be carefull with this handler as the incorrect root setup may allow users to download system-internal files
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkHandler
NFX.Wave.Handlers FileDownloadHandler

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FileDownloadHandler : WorkHandler
public class FileDownloadHandler : WorkHandler
Public Class FileDownloadHandler
    Inherits WorkHandler
Public Class FileDownloadHandler
    Inherits WorkHandler
public ref class FileDownloadHandler : public WorkHandler
public ref class FileDownloadHandler : public WorkHandler
type FileDownloadHandler =
    class
        inherit WorkHandler
    end
type FileDownloadHandler =
    class
        inherit WorkHandler
    end
See Also
FileDownloadHandler Members
NFX.Wave.Handlers Namespace


FileDownloadHandler Members

FileDownloadHandler Members NFX Class Library

The FileDownloadHandler type exposes the following members.
Constructors
 | Name | Description
Protected method | FileDownloadHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the FileDownloadHandler class
Protected method | FileDownloadHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the FileDownloadHandler class
Back to Top
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
 | CutVersionSegment |
Protected method | Destructor | (Inherited from WorkHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoHandleWork | (Overrides WorkHandler DoHandleWork(WorkContext).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_CACHE_CONTROL_SECTION |
INVALID_ROOT |
VAR_ATTACHMENT |
VAR_CHUNKED |
VAR_FILE_PATH |
Back to Top
Properties
 | Name | Description
Public property | CacheControl |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | RootPath | Specifies local root path
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Public property | Throw | Specifies whether the handler generates simple 404 text or throws
Public property | UsePortalHub | When true, downloads files from PortalHub.ContentFileSystem for selected portal
Public property | VersionSegmentPrefix | When set indicates the case-insensitive prefix of a path segment that should be ignored by the file system. Version prefixes are used for attaching a surrogate path "folder" that makes resource differ based on their content. For example when prefix is "@", path '/static/img/@767868768768/picture.png' resolves to actual '/static/img/picture.png'
Back to Top
See Also
FileDownloadHandler Class
NFX.Wave.Handlers Namespace


FileDownloadHandler Constructor

FileDownloadHandler Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | FileDownloadHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the FileDownloadHandler class
Protected method | FileDownloadHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the FileDownloadHandler class
Back to Top
See Also
FileDownloadHandler Class
FileDownloadHandler Members
NFX.Wave.Handlers Namespace


FileDownloadHandler Constructor (WorkDispatcher, IConfigSectionNode)

FileDownloadHandler Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FileDownloadHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FileDownloadHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
protected FileDownloadHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
protected:
FileDownloadHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
protected:
FileDownloadHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> FileDownloadHandler
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> FileDownloadHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
FileDownloadHandler Class
FileDownloadHandler Members
FileDownloadHandler Overload
NFX.Wave.Handlers Namespace


FileDownloadHandler Constructor (WorkDispatcher, String, Int32, WorkMatch)

FileDownloadHandler Constructor (WorkDispatcher, String, Int32, WorkMatch) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FileDownloadHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FileDownloadHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
protected FileDownloadHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
protected:
FileDownloadHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
protected:
FileDownloadHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> FileDownloadHandler
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> FileDownloadHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
match
Type: NFX.Wave WorkMatch
See Also
FileDownloadHandler Class
FileDownloadHandler Members
FileDownloadHandler Overload
NFX.Wave.Handlers Namespace


FileDownloadHandler Fields

FileDownloadHandler Fields NFX Class Library

The FileDownloadHandler type exposes the following members.
Fields
Name | Description
CONFIG_CACHE_CONTROL_SECTION |
INVALID_ROOT |
VAR_ATTACHMENT |
VAR_CHUNKED |
VAR_FILE_PATH |
Back to Top
See Also
FileDownloadHandler Class
NFX.Wave.Handlers Namespace


FileDownloadHandler.CONFIG_CACHE_CONTROL_SECTION Field

FileDownloadHandler CONFIG_CACHE_CONTROL_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CACHE_CONTROL_SECTION
public const string CONFIG_CACHE_CONTROL_SECTION
Public Const CONFIG_CACHE_CONTROL_SECTION As String
Public Const CONFIG_CACHE_CONTROL_SECTION As String
public:
literal String^ CONFIG_CACHE_CONTROL_SECTION
public:
literal String^ CONFIG_CACHE_CONTROL_SECTION
static val mutable CONFIG_CACHE_CONTROL_SECTION: string
static val mutable CONFIG_CACHE_CONTROL_SECTION: string

Field Value

Type: Online String
See Also
FileDownloadHandler Class
FileDownloadHandler Members
NFX.Wave.Handlers Namespace


FileDownloadHandler.INVALID_ROOT Field

FileDownloadHandler INVALID_ROOT Field NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INVALID_ROOT
public const string INVALID_ROOT
Public Const INVALID_ROOT As String
Public Const INVALID_ROOT As String
public:
literal String^ INVALID_ROOT
public:
literal String^ INVALID_ROOT
static val mutable INVALID_ROOT: string
static val mutable INVALID_ROOT: string

Field Value

Type: Online String
See Also
FileDownloadHandler Class
FileDownloadHandler Members
NFX.Wave.Handlers Namespace


FileDownloadHandler.VAR_ATTACHMENT Field

FileDownloadHandler VAR_ATTACHMENT Field NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_ATTACHMENT
public const string VAR_ATTACHMENT
Public Const VAR_ATTACHMENT As String
Public Const VAR_ATTACHMENT As String
public:
literal String^ VAR_ATTACHMENT
public:
literal String^ VAR_ATTACHMENT
static val mutable VAR_ATTACHMENT: string
static val mutable VAR_ATTACHMENT: string

Field Value

Type: Online String
See Also
FileDownloadHandler Class
FileDownloadHandler Members
NFX.Wave.Handlers Namespace


FileDownloadHandler.VAR_CHUNKED Field

FileDownloadHandler VAR_CHUNKED Field NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_CHUNKED
public const string VAR_CHUNKED
Public Const VAR_CHUNKED As String
Public Const VAR_CHUNKED As String
public:
literal String^ VAR_CHUNKED
public:
literal String^ VAR_CHUNKED
static val mutable VAR_CHUNKED: string
static val mutable VAR_CHUNKED: string

Field Value

Type: Online String
See Also
FileDownloadHandler Class
FileDownloadHandler Members
NFX.Wave.Handlers Namespace


FileDownloadHandler.VAR_FILE_PATH Field

FileDownloadHandler VAR_FILE_PATH Field NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_FILE_PATH
public const string VAR_FILE_PATH
Public Const VAR_FILE_PATH As String
Public Const VAR_FILE_PATH As String
public:
literal String^ VAR_FILE_PATH
public:
literal String^ VAR_FILE_PATH
static val mutable VAR_FILE_PATH: string
static val mutable VAR_FILE_PATH: string

Field Value

Type: Online String
See Also
FileDownloadHandler Class
FileDownloadHandler Members
NFX.Wave.Handlers Namespace


FileDownloadHandler Methods

FileDownloadHandler Methods NFX Class Library

The FileDownloadHandler type exposes the following members.
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
 | CutVersionSegment |
Protected method | Destructor | (Inherited from WorkHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoHandleWork | (Overrides WorkHandler DoHandleWork(WorkContext).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FileDownloadHandler Class
NFX.Wave.Handlers Namespace


FileDownloadHandler.CutVersionSegment Method

FileDownloadHandler CutVersionSegment Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static string CutVersionSegment(
    string path,
    string pfxVer
)
internal static string CutVersionSegment(
    string path,
    string pfxVer
)
Friend Shared Function CutVersionSegment (
    path As String,
    pfxVer As String
) As String
Friend Shared Function CutVersionSegment (
    path As String,
    pfxVer As String
) As String
internal:
static String^ CutVersionSegment(
    String^ path,
    String^ pfxVer
)
internal:
static String^ CutVersionSegment(
    String^ path,
    String^ pfxVer
)
internal static member CutVersionSegment :
        path : string *
        pfxVer : string -> string
internal static member CutVersionSegment :
        path : string *
        pfxVer : string -> string

Parameters

path
Type: Online System String
pfxVer
Type: Online System String

Return Value

Type: Online String
See Also
FileDownloadHandler Class
FileDownloadHandler Members
NFX.Wave.Handlers Namespace


FileDownloadHandler.DoHandleWork Method

FileDownloadHandler DoHandleWork Method NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoHandleWork(
    WorkContext work
)
protected override void DoHandleWork(
    WorkContext work
)
Protected Overrides Sub DoHandleWork (
    work As WorkContext
)
Protected Overrides Sub DoHandleWork (
    work As WorkContext
)
protected:
virtual void DoHandleWork(
    WorkContext^ work
) override
protected:
virtual void DoHandleWork(
    WorkContext^ work
) override
abstract DoHandleWork :
        work : WorkContext -> unit
override DoHandleWork :
        work : WorkContext -> unit
abstract DoHandleWork :
        work : WorkContext -> unit
override DoHandleWork :
        work : WorkContext -> unit

Parameters

work
Type: NFX.Wave WorkContext
See Also
FileDownloadHandler Class
FileDownloadHandler Members
NFX.Wave.Handlers Namespace


FileDownloadHandler Properties

FileDownloadHandler Properties NFX Class Library

The FileDownloadHandler type exposes the following members.
Properties
 | Name | Description
Public property | CacheControl |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | RootPath | Specifies local root path
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Public property | Throw | Specifies whether the handler generates simple 404 text or throws
Public property | UsePortalHub | When true, downloads files from PortalHub.ContentFileSystem for selected portal
Public property | VersionSegmentPrefix | When set indicates the case-insensitive prefix of a path segment that should be ignored by the file system. Version prefixes are used for attaching a surrogate path "folder" that makes resource differ based on their content. For example when prefix is "@", path '/static/img/@767868768768/picture.png' resolves to actual '/static/img/picture.png'
Back to Top
See Also
FileDownloadHandler Class
NFX.Wave.Handlers Namespace


FileDownloadHandler.CacheControl Property

FileDownloadHandler CacheControl Property NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CacheControl CacheControl { get; set; }
public CacheControl CacheControl { get; set; }
Public Property CacheControl As CacheControl
    Get
    Set
Public Property CacheControl As CacheControl
    Get
    Set
public:
property CacheControl CacheControl {
    CacheControl get ();
    void set (CacheControl value);
}
public:
property CacheControl CacheControl {
    CacheControl get ();
    void set (CacheControl value);
}
member CacheControl : CacheControl with get, set
member CacheControl : CacheControl with get, set

Property Value

Type: CacheControl
See Also
FileDownloadHandler Class
FileDownloadHandler Members
NFX.Wave.Handlers Namespace


FileDownloadHandler.RootPath Property

FileDownloadHandler RootPath Property NFX Class Library

Specifies local root path

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RootPath { get; set; }
public string RootPath { get; set; }
Public Property RootPath As String
    Get
    Set
Public Property RootPath As String
    Get
    Set
public:
property String^ RootPath {
    String^ get ();
    void set (String^ value);
}
public:
property String^ RootPath {
    String^ get ();
    void set (String^ value);
}
member RootPath : string with get, set
member RootPath : string with get, set

Property Value

Type: Online String
See Also
FileDownloadHandler Class
FileDownloadHandler Members
NFX.Wave.Handlers Namespace


FileDownloadHandler.Throw Property

FileDownloadHandler Throw Property NFX Class Library

Specifies whether the handler generates simple 404 text or throws

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Throw { get; set; }
public bool Throw { get; set; }
Public Property Throw As Boolean
    Get
    Set
Public Property Throw As Boolean
    Get
    Set
public:
property bool Throw {
    bool get ();
    void set (bool value);
}
public:
property bool Throw {
    bool get ();
    void set (bool value);
}
member Throw : bool with get, set
member Throw : bool with get, set

Property Value

Type: Online Boolean
See Also
FileDownloadHandler Class
FileDownloadHandler Members
NFX.Wave.Handlers Namespace


FileDownloadHandler.UsePortalHub Property

FileDownloadHandler UsePortalHub Property NFX Class Library

When true, downloads files from PortalHub.ContentFileSystem for selected portal

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UsePortalHub { get; set; }
public bool UsePortalHub { get; set; }
Public Property UsePortalHub As Boolean
    Get
    Set
Public Property UsePortalHub As Boolean
    Get
    Set
public:
property bool UsePortalHub {
    bool get ();
    void set (bool value);
}
public:
property bool UsePortalHub {
    bool get ();
    void set (bool value);
}
member UsePortalHub : bool with get, set
member UsePortalHub : bool with get, set

Property Value

Type: Online Boolean
See Also
FileDownloadHandler Class
FileDownloadHandler Members
NFX.Wave.Handlers Namespace


FileDownloadHandler.VersionSegmentPrefix Property

FileDownloadHandler VersionSegmentPrefix Property NFX Class Library

[This is preliminary documentation and is subject to change.]

When set indicates the case-insensitive prefix of a path segment that should be ignored by the file system. Version prefixes are used for attaching a surrogate path "folder" that makes resource differ based on their content. For example when prefix is "@", path '/static/img/@767868768768/picture.png' resolves to actual '/static/img/picture.png'

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string VersionSegmentPrefix { get; set; }
public string VersionSegmentPrefix { get; set; }
Public Property VersionSegmentPrefix As String
    Get
    Set
Public Property VersionSegmentPrefix As String
    Get
    Set
public:
property String^ VersionSegmentPrefix {
    String^ get ();
    void set (String^ value);
}
public:
property String^ VersionSegmentPrefix {
    String^ get ();
    void set (String^ value);
}
member VersionSegmentPrefix : string with get, set
member VersionSegmentPrefix : string with get, set

Property Value

Type: Online String
See Also
FileDownloadHandler Class
FileDownloadHandler Members
NFX.Wave.Handlers Namespace


MVCHandler Class

MVCHandler Class NFX Class Library

Handles MVC-related requests
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkHandler
NFX.Wave.Handlers TypeLookupHandler Controller
NFX.Wave.Handlers MVCHandler

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MVCHandler : TypeLookupHandler<Controller>
public class MVCHandler : TypeLookupHandler<Controller>
Public Class MVCHandler
    Inherits TypeLookupHandler(Of Controller)
Public Class MVCHandler
    Inherits TypeLookupHandler(Of Controller)
public ref class MVCHandler : public TypeLookupHandler<Controller^>
public ref class MVCHandler : public TypeLookupHandler<Controller^>
type MVCHandler =
    class
        inherit TypeLookupHandler<Controller>
    end
type MVCHandler =
    class
        inherit TypeLookupHandler<Controller>
    end
See Also
MVCHandler Members
NFX.Wave.Handlers Namespace


MVCHandler Members

MVCHandler Members NFX Class Library

The MVCHandler type exposes the following members.
Constructors
 | Name | Description
Protected method | MVCHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the MVCHandler class
Protected method | MVCHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the MVCHandler class
Back to Top
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | BindParameters | Fills method invocation param array with args doing some interpretation for widely used types like JSONDataMaps, Rows etc..
Protected method | CreateTargetInstance | Factory method - Override to create and init more particular template implementation (i.e. based on model) (Inherited from TypeLookupHandler TTarget .)
Protected method | DeleteTargetInstanceByID | Deletes target instance with id from store. Default implementation uses Application.ObjectStore. (Inherited from TypeLookupHandler TTarget .)
Protected method | Destructor | (Inherited from WorkHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | Do404 | Override to handle 404 condition, i.e. may write into response instead of generating a exception. The default implementation returns a HttpStatusException with 404 code (Inherited from TypeLookupHandler TTarget .)
Protected method | DoError | Override to handle error processing, i.e. may elect to write error data into response. The dafault implementation throws the error. It is recommended to handle errors with filters instead (Inherited from TypeLookupHandler TTarget .)
Protected method | DoHandleWork | Sealed. Override DoTargetWork(TTarget, WorkContext) to do actual work (Inherited from TypeLookupHandler TTarget .)
Protected method | DoTargetWork | (Overrides TypeLookupHandler TTarget DoTargetWork(TTarget, WorkContext).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | FindMatchingAction | Finds matching method that has the specified action name and best matches the supplied input
Protected method | GetActionName | Gets name of MVC action from work and controller. Controller may override name of variable
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Protected method | GetTargetInstanceByID | Retrieves target instance from id. Default implementation uses Application.ObjectStore. If this method is called by the framework then complementary matching PutTargetInstanceWithID() is guaranteed to be called as well (Inherited from TypeLookupHandler TTarget .)
Protected method | GetTargetInstanceID | Override to extract instance ID from WorkContext (Inherited from TypeLookupHandler TTarget .)
Protected method | GetTargetType | Override to resolve route/URL parameters to type (Inherited from TypeLookupHandler TTarget .)
Protected method | GetTargetTypeNameFromWorkContext | Override to get type name from WorkContext. Default implementation looks for MatchedVars[VAR_TARGET_TYPE] (Inherited from TypeLookupHandler TTarget .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ProcessResult | Turns result object into appropriate response
Protected method | PutTargetInstanceByID | Puts target instance with id into store. Default implementation uses Application.ObjectStore. This method is called by the framework to complement GetTargetInstanceFromID() (Inherited from TypeLookupHandler TTarget .)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CloakTypeName | Provides type name which is used if the prior one was not found. This allows to block 404 errors, i.e. if page with requested name is not found then always return the specified page (Inherited from TypeLookupHandler TTarget .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultTypeName | Provides default type name (Inherited from TypeLookupHandler TTarget .)
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | NotFoundRedirectURL | Provides redirect URL where the user gets redirected when type name could not be resolved. Note: CloakTypeName is used first when set. (Inherited from TypeLookupHandler TTarget .)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Public property | SupportsInstanceID | Indicates whether instance IDs are supported in requests. Default is false. Override to return true for handlers that support target instance state between requests (Inherited from TypeLookupHandler TTarget .)
Public property | TypeLocations | Returns a registry of type locations (Inherited from TypeLookupHandler TTarget .)
Back to Top
See Also
MVCHandler Class
NFX.Wave.Handlers Namespace


MVCHandler Constructor

MVCHandler Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | MVCHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the MVCHandler class
Protected method | MVCHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the MVCHandler class
Back to Top
See Also
MVCHandler Class
MVCHandler Members
NFX.Wave.Handlers Namespace


MVCHandler Constructor (WorkDispatcher, IConfigSectionNode)

MVCHandler Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MVCHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MVCHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
protected MVCHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
protected:
MVCHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
protected:
MVCHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> MVCHandler
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> MVCHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
MVCHandler Class
MVCHandler Members
MVCHandler Overload
NFX.Wave.Handlers Namespace


MVCHandler Constructor (WorkDispatcher, String, Int32, WorkMatch)

MVCHandler Constructor (WorkDispatcher, String, Int32, WorkMatch) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MVCHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MVCHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
protected MVCHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
protected:
MVCHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
protected:
MVCHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> MVCHandler
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> MVCHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
match
Type: NFX.Wave WorkMatch
See Also
MVCHandler Class
MVCHandler Members
MVCHandler Overload
NFX.Wave.Handlers Namespace


MVCHandler Methods

MVCHandler Methods NFX Class Library

The MVCHandler type exposes the following members.
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | BindParameters | Fills method invocation param array with args doing some interpretation for widely used types like JSONDataMaps, Rows etc..
Protected method | CreateTargetInstance | Factory method - Override to create and init more particular template implementation (i.e. based on model) (Inherited from TypeLookupHandler TTarget .)
Protected method | DeleteTargetInstanceByID | Deletes target instance with id from store. Default implementation uses Application.ObjectStore. (Inherited from TypeLookupHandler TTarget .)
Protected method | Destructor | (Inherited from WorkHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | Do404 | Override to handle 404 condition, i.e. may write into response instead of generating a exception. The default implementation returns a HttpStatusException with 404 code (Inherited from TypeLookupHandler TTarget .)
Protected method | DoError | Override to handle error processing, i.e. may elect to write error data into response. The dafault implementation throws the error. It is recommended to handle errors with filters instead (Inherited from TypeLookupHandler TTarget .)
Protected method | DoHandleWork | Sealed. Override DoTargetWork(TTarget, WorkContext) to do actual work (Inherited from TypeLookupHandler TTarget .)
Protected method | DoTargetWork | (Overrides TypeLookupHandler TTarget DoTargetWork(TTarget, WorkContext).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | FindMatchingAction | Finds matching method that has the specified action name and best matches the supplied input
Protected method | GetActionName | Gets name of MVC action from work and controller. Controller may override name of variable
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Protected method | GetTargetInstanceByID | Retrieves target instance from id. Default implementation uses Application.ObjectStore. If this method is called by the framework then complementary matching PutTargetInstanceWithID() is guaranteed to be called as well (Inherited from TypeLookupHandler TTarget .)
Protected method | GetTargetInstanceID | Override to extract instance ID from WorkContext (Inherited from TypeLookupHandler TTarget .)
Protected method | GetTargetType | Override to resolve route/URL parameters to type (Inherited from TypeLookupHandler TTarget .)
Protected method | GetTargetTypeNameFromWorkContext | Override to get type name from WorkContext. Default implementation looks for MatchedVars[VAR_TARGET_TYPE] (Inherited from TypeLookupHandler TTarget .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ProcessResult | Turns result object into appropriate response
Protected method | PutTargetInstanceByID | Puts target instance with id into store. Default implementation uses Application.ObjectStore. This method is called by the framework to complement GetTargetInstanceFromID() (Inherited from TypeLookupHandler TTarget .)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MVCHandler Class
NFX.Wave.Handlers Namespace


MVCHandler.BindParameters Method

MVCHandler BindParameters Method NFX Class Library

Fills method invocation param array with args doing some interpretation for widely used types like JSONDataMaps, Rows etc..

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void BindParameters(
    Controller controller,
    string action,
    ActionAttribute attrAction,
    MethodInfo method,
    WorkContext work,
    out Object[] args
)
protected virtual void BindParameters(
    Controller controller,
    string action,
    ActionAttribute attrAction,
    MethodInfo method,
    WorkContext work,
    out Object[] args
)
Protected Overridable Sub BindParameters (
    controller As Controller,
    action As String,
    attrAction As ActionAttribute,
    method As MethodInfo,
    work As WorkContext,
    <OutAttribute> ByRef args As Object()
)
Protected Overridable Sub BindParameters (
    controller As Controller,
    action As String,
    attrAction As ActionAttribute,
    method As MethodInfo,
    work As WorkContext,
    <OutAttribute> ByRef args As Object()
)
protected:
virtual void BindParameters(
    Controller^ controller,
    String^ action,
    ActionAttribute^ attrAction,
    MethodInfo^ method,
    WorkContext^ work,
    [OutAttribute] array<Object^>^% args
)
protected:
virtual void BindParameters(
    Controller^ controller,
    String^ action,
    ActionAttribute^ attrAction,
    MethodInfo^ method,
    WorkContext^ work,
    [OutAttribute] array<Object^>^% args
)
abstract BindParameters :
        controller : Controller *
        action : string *
        attrAction : ActionAttribute *
        method : MethodInfo *
        work : WorkContext *
        args : Object[] byref -> unit
override BindParameters :
        controller : Controller *
        action : string *
        attrAction : ActionAttribute *
        method : MethodInfo *
        work : WorkContext *
        args : Object[] byref -> unit
abstract BindParameters :
        controller : Controller *
        action : string *
        attrAction : ActionAttribute *
        method : MethodInfo *
        work : WorkContext *
        args : Object[] byref -> unit
override BindParameters :
        controller : Controller *
        action : string *
        attrAction : ActionAttribute *
        method : MethodInfo *
        work : WorkContext *
        args : Object[] byref -> unit

Parameters

controller
Type: NFX.Wave.MVC Controller
action
Type: Online System String
attrAction
Type: NFX.Wave.MVC ActionAttribute
method
Type: Online System.Reflection MethodInfo
work
Type: NFX.Wave WorkContext
args
Type: Online System Object
See Also
MVCHandler Class
MVCHandler Members
NFX.Wave.Handlers Namespace


MVCHandler.DoTargetWork Method

MVCHandler DoTargetWork Method NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoTargetWork(
    Controller target,
    WorkContext work
)
protected override void DoTargetWork(
    Controller target,
    WorkContext work
)
Protected Overrides Sub DoTargetWork (
    target As Controller,
    work As WorkContext
)
Protected Overrides Sub DoTargetWork (
    target As Controller,
    work As WorkContext
)
protected:
virtual void DoTargetWork(
    Controller^ target,
    WorkContext^ work
) override
protected:
virtual void DoTargetWork(
    Controller^ target,
    WorkContext^ work
) override
abstract DoTargetWork :
        target : Controller *
        work : WorkContext -> unit
override DoTargetWork :
        target : Controller *
        work : WorkContext -> unit
abstract DoTargetWork :
        target : Controller *
        work : WorkContext -> unit
override DoTargetWork :
        target : Controller *
        work : WorkContext -> unit

Parameters

target
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
See Also
MVCHandler Class
MVCHandler Members
NFX.Wave.Handlers Namespace


MVCHandler.FindMatchingAction Method

MVCHandler FindMatchingAction Method NFX Class Library

Finds matching method that has the specified action name and best matches the supplied input

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual MethodInfo FindMatchingAction(
    Controller controller,
    WorkContext work,
    string action,
    out Object[] args
)
protected virtual MethodInfo FindMatchingAction(
    Controller controller,
    WorkContext work,
    string action,
    out Object[] args
)
Protected Overridable Function FindMatchingAction (
    controller As Controller,
    work As WorkContext,
    action As String,
    <OutAttribute> ByRef args As Object()
) As MethodInfo
Protected Overridable Function FindMatchingAction (
    controller As Controller,
    work As WorkContext,
    action As String,
    <OutAttribute> ByRef args As Object()
) As MethodInfo
protected:
virtual MethodInfo^ FindMatchingAction(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    [OutAttribute] array<Object^>^% args
)
protected:
virtual MethodInfo^ FindMatchingAction(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    [OutAttribute] array<Object^>^% args
)
abstract FindMatchingAction :
        controller : Controller *
        work : WorkContext *
        action : string *
        args : Object[] byref -> MethodInfo
override FindMatchingAction :
        controller : Controller *
        work : WorkContext *
        action : string *
        args : Object[] byref -> MethodInfo
abstract FindMatchingAction :
        controller : Controller *
        work : WorkContext *
        action : string *
        args : Object[] byref -> MethodInfo
override FindMatchingAction :
        controller : Controller *
        work : WorkContext *
        action : string *
        args : Object[] byref -> MethodInfo

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
action
Type: Online System String
args
Type: Online System Object

Return Value

Type: Online MethodInfo
See Also
MVCHandler Class
MVCHandler Members
NFX.Wave.Handlers Namespace


MVCHandler.GetActionName Method

MVCHandler GetActionName Method NFX Class Library

Gets name of MVC action from work and controller. Controller may override name of variable

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string GetActionName(
    Controller controller,
    WorkContext work
)
protected virtual string GetActionName(
    Controller controller,
    WorkContext work
)
Protected Overridable Function GetActionName (
    controller As Controller,
    work As WorkContext
) As String
Protected Overridable Function GetActionName (
    controller As Controller,
    work As WorkContext
) As String
protected:
virtual String^ GetActionName(
    Controller^ controller,
    WorkContext^ work
)
protected:
virtual String^ GetActionName(
    Controller^ controller,
    WorkContext^ work
)
abstract GetActionName :
        controller : Controller *
        work : WorkContext -> string
override GetActionName :
        controller : Controller *
        work : WorkContext -> string
abstract GetActionName :
        controller : Controller *
        work : WorkContext -> string
override GetActionName :
        controller : Controller *
        work : WorkContext -> string

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext

Return Value

Type: Online String
See Also
MVCHandler Class
MVCHandler Members
NFX.Wave.Handlers Namespace


MVCHandler.ProcessResult Method

MVCHandler ProcessResult Method NFX Class Library

Turns result object into appropriate response

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void ProcessResult(
    Controller controller,
    WorkContext work,
    Object result
)
protected virtual void ProcessResult(
    Controller controller,
    WorkContext work,
    Object result
)
Protected Overridable Sub ProcessResult (
    controller As Controller,
    work As WorkContext,
    result As Object
)
Protected Overridable Sub ProcessResult (
    controller As Controller,
    work As WorkContext,
    result As Object
)
protected:
virtual void ProcessResult(
    Controller^ controller,
    WorkContext^ work,
    Object^ result
)
protected:
virtual void ProcessResult(
    Controller^ controller,
    WorkContext^ work,
    Object^ result
)
abstract ProcessResult :
        controller : Controller *
        work : WorkContext *
        result : Object -> unit
override ProcessResult :
        controller : Controller *
        work : WorkContext *
        result : Object -> unit
abstract ProcessResult :
        controller : Controller *
        work : WorkContext *
        result : Object -> unit
override ProcessResult :
        controller : Controller *
        work : WorkContext *
        result : Object -> unit

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
result
Type: Online System Object
See Also
MVCHandler Class
MVCHandler Members
NFX.Wave.Handlers Namespace


MVCHandler Properties

MVCHandler Properties NFX Class Library

The MVCHandler type exposes the following members.
Properties
 | Name | Description
Public property | CloakTypeName | Provides type name which is used if the prior one was not found. This allows to block 404 errors, i.e. if page with requested name is not found then always return the specified page (Inherited from TypeLookupHandler TTarget .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultTypeName | Provides default type name (Inherited from TypeLookupHandler TTarget .)
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | NotFoundRedirectURL | Provides redirect URL where the user gets redirected when type name could not be resolved. Note: CloakTypeName is used first when set. (Inherited from TypeLookupHandler TTarget .)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Public property | SupportsInstanceID | Indicates whether instance IDs are supported in requests. Default is false. Override to return true for handlers that support target instance state between requests (Inherited from TypeLookupHandler TTarget .)
Public property | TypeLocations | Returns a registry of type locations (Inherited from TypeLookupHandler TTarget .)
Back to Top
See Also
MVCHandler Class
NFX.Wave.Handlers Namespace


NOPHandler Class

NOPHandler Class NFX Class Library

Implements handler that does nothing
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkHandler
NFX.Wave.Handlers NOPHandler

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NOPHandler : WorkHandler
public sealed class NOPHandler : WorkHandler
Public NotInheritable Class NOPHandler
    Inherits WorkHandler
Public NotInheritable Class NOPHandler
    Inherits WorkHandler
public ref class NOPHandler sealed : public WorkHandler
public ref class NOPHandler sealed : public WorkHandler
[<SealedAttribute>]
type NOPHandler =
    class
        inherit WorkHandler
    end
[<SealedAttribute>]
type NOPHandler =
    class
        inherit WorkHandler
    end
See Also
NOPHandler Members
NFX.Wave.Handlers Namespace


NOPHandler Members

NOPHandler Members NFX Class Library

The NOPHandler type exposes the following members.
Constructors
 | Name | Description
Public method | NOPHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the NOPHandler class
Public method | NOPHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the NOPHandler class
Back to Top
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from WorkHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoHandleWork | (Overrides WorkHandler DoHandleWork(WorkContext).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Back to Top
See Also
NOPHandler Class
NFX.Wave.Handlers Namespace


NOPHandler Constructor

NOPHandler Constructor NFX Class Library

Overload List
 | Name | Description
Public method | NOPHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the NOPHandler class
Public method | NOPHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the NOPHandler class
Back to Top
See Also
NOPHandler Class
NOPHandler Members
NFX.Wave.Handlers Namespace


NOPHandler Constructor (WorkDispatcher, IConfigSectionNode)

NOPHandler Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NOPHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NOPHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
public NOPHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
public:
NOPHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
public:
NOPHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> NOPHandler
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> NOPHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
NOPHandler Class
NOPHandler Members
NOPHandler Overload
NFX.Wave.Handlers Namespace


NOPHandler Constructor (WorkDispatcher, String, Int32, WorkMatch)

NOPHandler Constructor (WorkDispatcher, String, Int32, WorkMatch) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NOPHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NOPHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
public NOPHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
public:
NOPHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
public:
NOPHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> NOPHandler
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> NOPHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
match
Type: NFX.Wave WorkMatch
See Also
NOPHandler Class
NOPHandler Members
NOPHandler Overload
NFX.Wave.Handlers Namespace


NOPHandler Methods

NOPHandler Methods NFX Class Library

The NOPHandler type exposes the following members.
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from WorkHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoHandleWork | (Overrides WorkHandler DoHandleWork(WorkContext).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPHandler Class
NFX.Wave.Handlers Namespace


NOPHandler.DoHandleWork Method

NOPHandler DoHandleWork Method NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoHandleWork(
    WorkContext work
)
protected override void DoHandleWork(
    WorkContext work
)
Protected Overrides Sub DoHandleWork (
    work As WorkContext
)
Protected Overrides Sub DoHandleWork (
    work As WorkContext
)
protected:
virtual void DoHandleWork(
    WorkContext^ work
) override
protected:
virtual void DoHandleWork(
    WorkContext^ work
) override
abstract DoHandleWork :
        work : WorkContext -> unit
override DoHandleWork :
        work : WorkContext -> unit
abstract DoHandleWork :
        work : WorkContext -> unit
override DoHandleWork :
        work : WorkContext -> unit

Parameters

work
Type: NFX.Wave WorkContext
See Also
NOPHandler Class
NOPHandler Members
NFX.Wave.Handlers Namespace


NOPHandler Properties

NOPHandler Properties NFX Class Library

The NOPHandler type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Back to Top
See Also
NOPHandler Class
NFX.Wave.Handlers Namespace


StockContentSiteHandler Class

StockContentSiteHandler Class NFX Class Library

This handler serves the embedded content of NFX.Wave library
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkHandler
NFX.Wave.Handlers EmbeddedSiteHandler
NFX.Wave.Handlers StockContentSiteHandler

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StockContentSiteHandler : EmbeddedSiteHandler
public class StockContentSiteHandler : EmbeddedSiteHandler
Public Class StockContentSiteHandler
    Inherits EmbeddedSiteHandler
Public Class StockContentSiteHandler
    Inherits EmbeddedSiteHandler
public ref class StockContentSiteHandler : public EmbeddedSiteHandler
public ref class StockContentSiteHandler : public EmbeddedSiteHandler
type StockContentSiteHandler =
    class
        inherit EmbeddedSiteHandler
    end
type StockContentSiteHandler =
    class
        inherit EmbeddedSiteHandler
    end
See Also
StockContentSiteHandler Members
NFX.Wave.Handlers Namespace


StockContentSiteHandler Members

StockContentSiteHandler Members NFX Class Library

The StockContentSiteHandler type exposes the following members.
Constructors
 | Name | Description
Public method | StockContentSiteHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the StockContentSiteHandler class
Public method | StockContentSiteHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the StockContentSiteHandler class
Back to Top
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from WorkHandler.)
Protected method | DispatchAction | Dispatched appropriate action (Inherited from EmbeddedSiteHandler.)
Protected method | DispatchNonSiteAction | Dispatches an action which is not a site-serving one (Inherited from EmbeddedSiteHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoHandleWork | (Inherited from EmbeddedSiteHandler.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetActions | (Overrides EmbeddedSiteHandler GetActions .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ParseWork | Override to extract action and path form request (Inherited from EmbeddedSiteHandler.)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Protected method | SetResourceCacheHeader | Override to set specific cache header set per resource name (Inherited from EmbeddedSiteHandler.)
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Actions | Returns actions that this site can perform (Inherited from EmbeddedSiteHandler.)
Public property | CacheControl | (Inherited from EmbeddedSiteHandler.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultSitePath | Returns default site path that serves site root (Inherited from EmbeddedSiteHandler.)
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | RootResourcePath | (Overrides EmbeddedSiteHandler RootResourcePath.)
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Public property | SiteAction | Returns name for action that serves embedded site (Inherited from EmbeddedSiteHandler.)
Public property | SupportsEnvironmentBranching | (Overrides EmbeddedSiteHandler SupportsEnvironmentBranching.)
Public property | VersionSegmentPrefix | When set indicates the case-insensitive prefix of a path segment that should be ignored by the handler path resolver. Version prefixes are used for attaching a surrogate path "folder" that makes resource differ based on their content. For example when prefix is "@", path '/embedded/img/@767868768768/picture.png' resolves to actual '/embedded/img/picture.png' (Inherited from EmbeddedSiteHandler.)
Back to Top
See Also
StockContentSiteHandler Class
NFX.Wave.Handlers Namespace


StockContentSiteHandler Constructor

StockContentSiteHandler Constructor NFX Class Library

Overload List
 | Name | Description
Public method | StockContentSiteHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the StockContentSiteHandler class
Public method | StockContentSiteHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the StockContentSiteHandler class
Back to Top
See Also
StockContentSiteHandler Class
StockContentSiteHandler Members
NFX.Wave.Handlers Namespace


StockContentSiteHandler Constructor (WorkDispatcher, IConfigSectionNode)

StockContentSiteHandler Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StockContentSiteHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StockContentSiteHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
public StockContentSiteHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Public Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
public:
StockContentSiteHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
public:
StockContentSiteHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> StockContentSiteHandler
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> StockContentSiteHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
StockContentSiteHandler Class
StockContentSiteHandler Members
StockContentSiteHandler Overload
NFX.Wave.Handlers Namespace


StockContentSiteHandler Constructor (WorkDispatcher, String, Int32, WorkMatch)

StockContentSiteHandler Constructor (WorkDispatcher, String, Int32, WorkMatch) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StockContentSiteHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StockContentSiteHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
public StockContentSiteHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
Public Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
public:
StockContentSiteHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
public:
StockContentSiteHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> StockContentSiteHandler
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> StockContentSiteHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
match
Type: NFX.Wave WorkMatch
See Also
StockContentSiteHandler Class
StockContentSiteHandler Members
StockContentSiteHandler Overload
NFX.Wave.Handlers Namespace


StockContentSiteHandler Methods

StockContentSiteHandler Methods NFX Class Library

The StockContentSiteHandler type exposes the following members.
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from WorkHandler.)
Protected method | DispatchAction | Dispatched appropriate action (Inherited from EmbeddedSiteHandler.)
Protected method | DispatchNonSiteAction | Dispatches an action which is not a site-serving one (Inherited from EmbeddedSiteHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoHandleWork | (Inherited from EmbeddedSiteHandler.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetActions | (Overrides EmbeddedSiteHandler GetActions .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ParseWork | Override to extract action and path form request (Inherited from EmbeddedSiteHandler.)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Protected method | SetResourceCacheHeader | Override to set specific cache header set per resource name (Inherited from EmbeddedSiteHandler.)
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
StockContentSiteHandler Class
NFX.Wave.Handlers Namespace


StockContentSiteHandler.GetActions Method

StockContentSiteHandler GetActions Method NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override IEnumerable<EmbeddedSiteHandler..::..IAction> GetActions()
protected override IEnumerable<EmbeddedSiteHandler..::..IAction> GetActions()
Protected Overrides Function GetActions As IEnumerable(Of EmbeddedSiteHandler..::..IAction)
Protected Overrides Function GetActions As IEnumerable(Of EmbeddedSiteHandler..::..IAction)
protected:
virtual IEnumerable<EmbeddedSiteHandler..::..IAction^>^ GetActions() override
protected:
virtual IEnumerable<EmbeddedSiteHandler..::..IAction^>^ GetActions() override
abstract GetActions : unit -> IEnumerable<EmbeddedSiteHandler..::..IAction>
override GetActions : unit -> IEnumerable<EmbeddedSiteHandler..::..IAction>
abstract GetActions : unit -> IEnumerable<EmbeddedSiteHandler..::..IAction>
override GetActions : unit -> IEnumerable<EmbeddedSiteHandler..::..IAction>

Return Value

Type: Online IEnumerable EmbeddedSiteHandler IAction
See Also
StockContentSiteHandler Class
StockContentSiteHandler Members
NFX.Wave.Handlers Namespace


StockContentSiteHandler Properties

StockContentSiteHandler Properties NFX Class Library

The StockContentSiteHandler type exposes the following members.
Properties
 | Name | Description
Public property | Actions | Returns actions that this site can perform (Inherited from EmbeddedSiteHandler.)
Public property | CacheControl | (Inherited from EmbeddedSiteHandler.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultSitePath | Returns default site path that serves site root (Inherited from EmbeddedSiteHandler.)
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | RootResourcePath | (Overrides EmbeddedSiteHandler RootResourcePath.)
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Public property | SiteAction | Returns name for action that serves embedded site (Inherited from EmbeddedSiteHandler.)
Public property | SupportsEnvironmentBranching | (Overrides EmbeddedSiteHandler SupportsEnvironmentBranching.)
Public property | VersionSegmentPrefix | When set indicates the case-insensitive prefix of a path segment that should be ignored by the handler path resolver. Version prefixes are used for attaching a surrogate path "folder" that makes resource differ based on their content. For example when prefix is "@", path '/embedded/img/@767868768768/picture.png' resolves to actual '/embedded/img/picture.png' (Inherited from EmbeddedSiteHandler.)
Back to Top
See Also
StockContentSiteHandler Class
NFX.Wave.Handlers Namespace


StockContentSiteHandler.RootResourcePath Property

StockContentSiteHandler RootResourcePath Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string RootResourcePath { get; }
public override string RootResourcePath { get; }
Public Overrides ReadOnly Property RootResourcePath As String
    Get
Public Overrides ReadOnly Property RootResourcePath As String
    Get
public:
virtual property String^ RootResourcePath {
    String^ get () override;
}
public:
virtual property String^ RootResourcePath {
    String^ get () override;
}
abstract RootResourcePath : string with get
override RootResourcePath : string with get
abstract RootResourcePath : string with get
override RootResourcePath : string with get

Property Value

Type: Online String
See Also
StockContentSiteHandler Class
StockContentSiteHandler Members
NFX.Wave.Handlers Namespace


StockContentSiteHandler.SupportsEnvironmentBranching Property

StockContentSiteHandler SupportsEnvironmentBranching Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool SupportsEnvironmentBranching { get; }
public override bool SupportsEnvironmentBranching { get; }
Public Overrides ReadOnly Property SupportsEnvironmentBranching As Boolean
    Get
Public Overrides ReadOnly Property SupportsEnvironmentBranching As Boolean
    Get
public:
virtual property bool SupportsEnvironmentBranching {
    bool get () override;
}
public:
virtual property bool SupportsEnvironmentBranching {
    bool get () override;
}
abstract SupportsEnvironmentBranching : bool with get
override SupportsEnvironmentBranching : bool with get
abstract SupportsEnvironmentBranching : bool with get
override SupportsEnvironmentBranching : bool with get

Property Value

Type: Online Boolean
See Also
StockContentSiteHandler Class
StockContentSiteHandler Members
NFX.Wave.Handlers Namespace


TemplateHandler Class

TemplateHandler Class NFX Class Library

Implements handler that serves WaveTemplates
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkHandler
NFX.Wave.Handlers TypeLookupHandler WaveTemplate
NFX.Wave.Handlers TemplateHandler

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TemplateHandler : TypeLookupHandler<WaveTemplate>
public class TemplateHandler : TypeLookupHandler<WaveTemplate>
Public Class TemplateHandler
    Inherits TypeLookupHandler(Of WaveTemplate)
Public Class TemplateHandler
    Inherits TypeLookupHandler(Of WaveTemplate)
public ref class TemplateHandler : public TypeLookupHandler<WaveTemplate^>
public ref class TemplateHandler : public TypeLookupHandler<WaveTemplate^>
type TemplateHandler =
    class
        inherit TypeLookupHandler<WaveTemplate>
    end
type TemplateHandler =
    class
        inherit TypeLookupHandler<WaveTemplate>
    end
See Also
TemplateHandler Members
NFX.Wave.Handlers Namespace


TemplateHandler Members

TemplateHandler Members NFX Class Library

The TemplateHandler type exposes the following members.
Constructors
 | Name | Description
Protected method | TemplateHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the TemplateHandler class
Protected method | TemplateHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the TemplateHandler class
Back to Top
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | CreateTargetInstance | Factory method - Override to create and init more particular template implementation (i.e. based on model) (Inherited from TypeLookupHandler TTarget .)
Protected method | DeleteTargetInstanceByID | Deletes target instance with id from store. Default implementation uses Application.ObjectStore. (Inherited from TypeLookupHandler TTarget .)
Protected method | Destructor | (Inherited from WorkHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | Do404 | Override to handle 404 condition, i.e. may write into response instead of generating a exception. The default implementation returns a HttpStatusException with 404 code (Inherited from TypeLookupHandler TTarget .)
Protected method | DoError | Override to handle error processing, i.e. may elect to write error data into response. The dafault implementation throws the error. It is recommended to handle errors with filters instead (Inherited from TypeLookupHandler TTarget .)
Protected method | DoHandleWork | Sealed. Override DoTargetWork(TTarget, WorkContext) to do actual work (Inherited from TypeLookupHandler TTarget .)
Protected method | DoTargetWork | (Overrides TypeLookupHandler TTarget DoTargetWork(TTarget, WorkContext).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Protected method | GetTargetInstanceByID | Retrieves target instance from id. Default implementation uses Application.ObjectStore. If this method is called by the framework then complementary matching PutTargetInstanceWithID() is guaranteed to be called as well (Inherited from TypeLookupHandler TTarget .)
Protected method | GetTargetInstanceID | Override to extract instance ID from WorkContext (Inherited from TypeLookupHandler TTarget .)
Protected method | GetTargetType | Override to resolve route/URL parameters to type (Inherited from TypeLookupHandler TTarget .)
Protected method | GetTargetTypeNameFromWorkContext | Override to get type name from WorkContext. Default implementation looks for MatchedVars[VAR_TARGET_TYPE] (Inherited from TypeLookupHandler TTarget .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | PutTargetInstanceByID | Puts target instance with id into store. Default implementation uses Application.ObjectStore. This method is called by the framework to complement GetTargetInstanceFromID() (Inherited from TypeLookupHandler TTarget .)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CloakTypeName | Provides type name which is used if the prior one was not found. This allows to block 404 errors, i.e. if page with requested name is not found then always return the specified page (Inherited from TypeLookupHandler TTarget .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultTypeName | Provides default type name (Inherited from TypeLookupHandler TTarget .)
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | NotFoundRedirectURL | Provides redirect URL where the user gets redirected when type name could not be resolved. Note: CloakTypeName is used first when set. (Inherited from TypeLookupHandler TTarget .)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Public property | SupportsInstanceID | Indicates whether instance IDs are supported in requests. Default is false. Override to return true for handlers that support target instance state between requests (Inherited from TypeLookupHandler TTarget .)
Public property | TypeLocations | Returns a registry of type locations (Inherited from TypeLookupHandler TTarget .)
Back to Top
See Also
TemplateHandler Class
NFX.Wave.Handlers Namespace


TemplateHandler Constructor

TemplateHandler Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | TemplateHandler(WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the TemplateHandler class
Protected method | TemplateHandler(WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the TemplateHandler class
Back to Top
See Also
TemplateHandler Class
TemplateHandler Members
NFX.Wave.Handlers Namespace


TemplateHandler Constructor (WorkDispatcher, IConfigSectionNode)

TemplateHandler Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TemplateHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TemplateHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
protected TemplateHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
protected:
TemplateHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
protected:
TemplateHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> TemplateHandler
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> TemplateHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
TemplateHandler Class
TemplateHandler Members
TemplateHandler Overload
NFX.Wave.Handlers Namespace


TemplateHandler Constructor (WorkDispatcher, String, Int32, WorkMatch)

TemplateHandler Constructor (WorkDispatcher, String, Int32, WorkMatch) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TemplateHandler class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TemplateHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
protected TemplateHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
protected:
TemplateHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
protected:
TemplateHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> TemplateHandler
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> TemplateHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
match
Type: NFX.Wave WorkMatch
See Also
TemplateHandler Class
TemplateHandler Members
TemplateHandler Overload
NFX.Wave.Handlers Namespace


TemplateHandler Methods

TemplateHandler Methods NFX Class Library

The TemplateHandler type exposes the following members.
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | CreateTargetInstance | Factory method - Override to create and init more particular template implementation (i.e. based on model) (Inherited from TypeLookupHandler TTarget .)
Protected method | DeleteTargetInstanceByID | Deletes target instance with id from store. Default implementation uses Application.ObjectStore. (Inherited from TypeLookupHandler TTarget .)
Protected method | Destructor | (Inherited from WorkHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | Do404 | Override to handle 404 condition, i.e. may write into response instead of generating a exception. The default implementation returns a HttpStatusException with 404 code (Inherited from TypeLookupHandler TTarget .)
Protected method | DoError | Override to handle error processing, i.e. may elect to write error data into response. The dafault implementation throws the error. It is recommended to handle errors with filters instead (Inherited from TypeLookupHandler TTarget .)
Protected method | DoHandleWork | Sealed. Override DoTargetWork(TTarget, WorkContext) to do actual work (Inherited from TypeLookupHandler TTarget .)
Protected method | DoTargetWork | (Overrides TypeLookupHandler TTarget DoTargetWork(TTarget, WorkContext).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Protected method | GetTargetInstanceByID | Retrieves target instance from id. Default implementation uses Application.ObjectStore. If this method is called by the framework then complementary matching PutTargetInstanceWithID() is guaranteed to be called as well (Inherited from TypeLookupHandler TTarget .)
Protected method | GetTargetInstanceID | Override to extract instance ID from WorkContext (Inherited from TypeLookupHandler TTarget .)
Protected method | GetTargetType | Override to resolve route/URL parameters to type (Inherited from TypeLookupHandler TTarget .)
Protected method | GetTargetTypeNameFromWorkContext | Override to get type name from WorkContext. Default implementation looks for MatchedVars[VAR_TARGET_TYPE] (Inherited from TypeLookupHandler TTarget .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | PutTargetInstanceByID | Puts target instance with id into store. Default implementation uses Application.ObjectStore. This method is called by the framework to complement GetTargetInstanceFromID() (Inherited from TypeLookupHandler TTarget .)
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TemplateHandler Class
NFX.Wave.Handlers Namespace


TemplateHandler.DoTargetWork Method

TemplateHandler DoTargetWork Method NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoTargetWork(
    WaveTemplate target,
    WorkContext work
)
protected override void DoTargetWork(
    WaveTemplate target,
    WorkContext work
)
Protected Overrides Sub DoTargetWork (
    target As WaveTemplate,
    work As WorkContext
)
Protected Overrides Sub DoTargetWork (
    target As WaveTemplate,
    work As WorkContext
)
protected:
virtual void DoTargetWork(
    WaveTemplate^ target,
    WorkContext^ work
) override
protected:
virtual void DoTargetWork(
    WaveTemplate^ target,
    WorkContext^ work
) override
abstract DoTargetWork :
        target : WaveTemplate *
        work : WorkContext -> unit
override DoTargetWork :
        target : WaveTemplate *
        work : WorkContext -> unit
abstract DoTargetWork :
        target : WaveTemplate *
        work : WorkContext -> unit
override DoTargetWork :
        target : WaveTemplate *
        work : WorkContext -> unit

Parameters

target
Type: NFX.Wave.Templatization WaveTemplate
work
Type: NFX.Wave WorkContext
See Also
TemplateHandler Class
TemplateHandler Members
NFX.Wave.Handlers Namespace


TemplateHandler Properties

TemplateHandler Properties NFX Class Library

The TemplateHandler type exposes the following members.
Properties
 | Name | Description
Public property | CloakTypeName | Provides type name which is used if the prior one was not found. This allows to block 404 errors, i.e. if page with requested name is not found then always return the specified page (Inherited from TypeLookupHandler TTarget .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultTypeName | Provides default type name (Inherited from TypeLookupHandler TTarget .)
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | NotFoundRedirectURL | Provides redirect URL where the user gets redirected when type name could not be resolved. Note: CloakTypeName is used first when set. (Inherited from TypeLookupHandler TTarget .)
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Public property | SupportsInstanceID | Indicates whether instance IDs are supported in requests. Default is false. Override to return true for handlers that support target instance state between requests (Inherited from TypeLookupHandler TTarget .)
Public property | TypeLocations | Returns a registry of type locations (Inherited from TypeLookupHandler TTarget .)
Back to Top
See Also
TemplateHandler Class
NFX.Wave.Handlers Namespace


TypeLocation Class

TypeLocation Class NFX Class Library

Represents a location used for dynamic type searches
Inheritance Hierarchy
Online System Object
NFX.Wave.Handlers TypeLocation

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TypeLocation : INamed,
    IOrdered
public sealed class TypeLocation : INamed,
    IOrdered
Public NotInheritable Class TypeLocation
    Implements INamed, IOrdered
Public NotInheritable Class TypeLocation
    Implements INamed, IOrdered
public ref class TypeLocation sealed : INamed,
    IOrdered
public ref class TypeLocation sealed : INamed,
    IOrdered
[<SealedAttribute>]
type TypeLocation =
    class
        interface INamed
        interface IOrdered
    end
[<SealedAttribute>]
type TypeLocation =
    class
        interface INamed
        interface IOrdered
    end
See Also
TypeLocation Members
NFX.Wave.Handlers Namespace


TypeLocation Members

TypeLocation Members NFX Class Library

The TypeLocation type exposes the following members.
Constructors
 | Name | Description
Public method | TypeLocation(IConfigSectionNode) | Initializes a new instance of the TypeLocation class
Public method | TypeLocation(String, Int32, String, Assembly, String ) | Initializes a new instance of the TypeLocation class
Public method | TypeLocation(String, Int32, String, String, String ) | Initializes a new instance of the TypeLocation class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Assembly | Assembly reference. When this property is set then AssemblyName==null
Public field | AssemblyName | Name of assembly. When this property is set then Assembly==null
 | CONFIG_ASSEMBLY_NAME_ATTR |
 | CONFIG_NAMESPACE_SECTION |
 | CONFIG_PORTAL_ATTR |
 | CONFIG_TYPE_LOCATION_SECTION |
Public field | Namespaces | A list of namespaces
Public field | Portal | Name of portal. When this property is set then this location will only be matched if WorkContext.Portal.Name matches for given request. NUll by default
Back to Top
Properties
 | Name | Description
Public property | Name | Location name
Public property | Order | Location order
Back to Top
See Also
TypeLocation Class
NFX.Wave.Handlers Namespace


TypeLocation Constructor

TypeLocation Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TypeLocation(IConfigSectionNode) | Initializes a new instance of the TypeLocation class
Public method | TypeLocation(String, Int32, String, Assembly, String ) | Initializes a new instance of the TypeLocation class
Public method | TypeLocation(String, Int32, String, String, String ) | Initializes a new instance of the TypeLocation class
Back to Top
See Also
TypeLocation Class
TypeLocation Members
NFX.Wave.Handlers Namespace


TypeLocation Constructor (IConfigSectionNode)

TypeLocation Constructor (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TypeLocation class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeLocation(
    IConfigSectionNode confNode
)
public TypeLocation(
    IConfigSectionNode confNode
)
Public Sub New (
    confNode As IConfigSectionNode
)
Public Sub New (
    confNode As IConfigSectionNode
)
public:
TypeLocation(
    IConfigSectionNode^ confNode
)
public:
TypeLocation(
    IConfigSectionNode^ confNode
)
new :
        confNode : IConfigSectionNode -> TypeLocation
new :
        confNode : IConfigSectionNode -> TypeLocation

Parameters

confNode
Type: NFX.Environment IConfigSectionNode
See Also
TypeLocation Class
TypeLocation Members
TypeLocation Overload
NFX.Wave.Handlers Namespace


TypeLocation Constructor (String, Int32, String, Assembly, String[])

TypeLocation Constructor (String, Int32, String, Assembly, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TypeLocation class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeLocation(
    string name,
    int order,
    string portal,
    Assembly assembly,
    params string[] namespaces
)
public TypeLocation(
    string name,
    int order,
    string portal,
    Assembly assembly,
    params string[] namespaces
)
Public Sub New (
    name As String,
    order As Integer,
    portal As String,
    assembly As Assembly,
    ParamArray namespaces As String()
)
Public Sub New (
    name As String,
    order As Integer,
    portal As String,
    assembly As Assembly,
    ParamArray namespaces As String()
)
public:
TypeLocation(
    String^ name,
    int order,
    String^ portal,
    Assembly^ assembly,
    ... array<String^>^ namespaces
)
public:
TypeLocation(
    String^ name,
    int order,
    String^ portal,
    Assembly^ assembly,
    ... array<String^>^ namespaces
)
new :
        name : string *
        order : int *
        portal : string *
        assembly : Assembly *
        namespaces : string[] -> TypeLocation
new :
        name : string *
        order : int *
        portal : string *
        assembly : Assembly *
        namespaces : string[] -> TypeLocation

Parameters

name
Type: Online System String
order
Type: Online System Int32
portal
Type: Online System String
assembly
Type: Online System.Reflection Assembly
namespaces
Type: Online System String
See Also
TypeLocation Class
TypeLocation Members
TypeLocation Overload
NFX.Wave.Handlers Namespace


TypeLocation Constructor (String, Int32, String, String, String[])

TypeLocation Constructor (String, Int32, String, String, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TypeLocation class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeLocation(
    string name,
    int order,
    string portal,
    string assemblyName,
    params string[] namespaces
)
public TypeLocation(
    string name,
    int order,
    string portal,
    string assemblyName,
    params string[] namespaces
)
Public Sub New (
    name As String,
    order As Integer,
    portal As String,
    assemblyName As String,
    ParamArray namespaces As String()
)
Public Sub New (
    name As String,
    order As Integer,
    portal As String,
    assemblyName As String,
    ParamArray namespaces As String()
)
public:
TypeLocation(
    String^ name,
    int order,
    String^ portal,
    String^ assemblyName,
    ... array<String^>^ namespaces
)
public:
TypeLocation(
    String^ name,
    int order,
    String^ portal,
    String^ assemblyName,
    ... array<String^>^ namespaces
)
new :
        name : string *
        order : int *
        portal : string *
        assemblyName : string *
        namespaces : string[] -> TypeLocation
new :
        name : string *
        order : int *
        portal : string *
        assemblyName : string *
        namespaces : string[] -> TypeLocation

Parameters

name
Type: Online System String
order
Type: Online System Int32
portal
Type: Online System String
assemblyName
Type: Online System String
namespaces
Type: Online System String
See Also
TypeLocation Class
TypeLocation Members
TypeLocation Overload
NFX.Wave.Handlers Namespace


TypeLocation Fields

TypeLocation Fields NFX Class Library

The TypeLocation type exposes the following members.
Fields
 | Name | Description
Public field | Assembly | Assembly reference. When this property is set then AssemblyName==null
Public field | AssemblyName | Name of assembly. When this property is set then Assembly==null
 | CONFIG_ASSEMBLY_NAME_ATTR |
 | CONFIG_NAMESPACE_SECTION |
 | CONFIG_PORTAL_ATTR |
 | CONFIG_TYPE_LOCATION_SECTION |
Public field | Namespaces | A list of namespaces
Public field | Portal | Name of portal. When this property is set then this location will only be matched if WorkContext.Portal.Name matches for given request. NUll by default
Back to Top
See Also
TypeLocation Class
NFX.Wave.Handlers Namespace


TypeLocation.Assembly Field

TypeLocation Assembly Field NFX Class Library

Assembly reference. When this property is set then AssemblyName==null

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Assembly Assembly
public readonly Assembly Assembly
Public ReadOnly Assembly As Assembly
Public ReadOnly Assembly As Assembly
public:
initonly Assembly^ Assembly
public:
initonly Assembly^ Assembly
val Assembly: Assembly
val Assembly: Assembly

Field Value

Type: Online Assembly
See Also
TypeLocation Class
TypeLocation Members
NFX.Wave.Handlers Namespace


TypeLocation.AssemblyName Field

TypeLocation AssemblyName Field NFX Class Library

Name of assembly. When this property is set then Assembly==null

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string AssemblyName
public readonly string AssemblyName
Public ReadOnly AssemblyName As String
Public ReadOnly AssemblyName As String
public:
initonly String^ AssemblyName
public:
initonly String^ AssemblyName
val AssemblyName: string
val AssemblyName: string

Field Value

Type: Online String
See Also
TypeLocation Class
TypeLocation Members
NFX.Wave.Handlers Namespace


TypeLocation.CONFIG_ASSEMBLY_NAME_ATTR Field

TypeLocation CONFIG_ASSEMBLY_NAME_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ASSEMBLY_NAME_ATTR
public const string CONFIG_ASSEMBLY_NAME_ATTR
Public Const CONFIG_ASSEMBLY_NAME_ATTR As String
Public Const CONFIG_ASSEMBLY_NAME_ATTR As String
public:
literal String^ CONFIG_ASSEMBLY_NAME_ATTR
public:
literal String^ CONFIG_ASSEMBLY_NAME_ATTR
static val mutable CONFIG_ASSEMBLY_NAME_ATTR: string
static val mutable CONFIG_ASSEMBLY_NAME_ATTR: string

Field Value

Type: Online String
See Also
TypeLocation Class
TypeLocation Members
NFX.Wave.Handlers Namespace


TypeLocation.CONFIG_NAMESPACE_SECTION Field

TypeLocation CONFIG_NAMESPACE_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NAMESPACE_SECTION
public const string CONFIG_NAMESPACE_SECTION
Public Const CONFIG_NAMESPACE_SECTION As String
Public Const CONFIG_NAMESPACE_SECTION As String
public:
literal String^ CONFIG_NAMESPACE_SECTION
public:
literal String^ CONFIG_NAMESPACE_SECTION
static val mutable CONFIG_NAMESPACE_SECTION: string
static val mutable CONFIG_NAMESPACE_SECTION: string

Field Value

Type: Online String
See Also
TypeLocation Class
TypeLocation Members
NFX.Wave.Handlers Namespace


TypeLocation.CONFIG_PORTAL_ATTR Field

TypeLocation CONFIG_PORTAL_ATTR Field NFX Class Library

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PORTAL_ATTR
public const string CONFIG_PORTAL_ATTR
Public Const CONFIG_PORTAL_ATTR As String
Public Const CONFIG_PORTAL_ATTR As String
public:
literal String^ CONFIG_PORTAL_ATTR
public:
literal String^ CONFIG_PORTAL_ATTR
static val mutable CONFIG_PORTAL_ATTR: string
static val mutable CONFIG_PORTAL_ATTR: string

Field Value

Type: Online String
See Also
TypeLocation Class
TypeLocation Members
NFX.Wave.Handlers Namespace


TypeLocation.CONFIG_TYPE_LOCATION_SECTION Field

TypeLocation CONFIG_TYPE_LOCATION_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TYPE_LOCATION_SECTION
public const string CONFIG_TYPE_LOCATION_SECTION
Public Const CONFIG_TYPE_LOCATION_SECTION As String
Public Const CONFIG_TYPE_LOCATION_SECTION As String
public:
literal String^ CONFIG_TYPE_LOCATION_SECTION
public:
literal String^ CONFIG_TYPE_LOCATION_SECTION
static val mutable CONFIG_TYPE_LOCATION_SECTION: string
static val mutable CONFIG_TYPE_LOCATION_SECTION: string

Field Value

Type: Online String
See Also
TypeLocation Class
TypeLocation Members
NFX.Wave.Handlers Namespace


TypeLocation.Namespaces Field

TypeLocation Namespaces Field NFX Class Library

A list of namespaces

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IEnumerable<string> Namespaces
public readonly IEnumerable<string> Namespaces
Public ReadOnly Namespaces As IEnumerable(Of String)
Public ReadOnly Namespaces As IEnumerable(Of String)
public:
initonly IEnumerable<String^>^ Namespaces
public:
initonly IEnumerable<String^>^ Namespaces
val Namespaces: IEnumerable<string>
val Namespaces: IEnumerable<string>

Field Value

Type: Online IEnumerable Online String
See Also
TypeLocation Class
TypeLocation Members
NFX.Wave.Handlers Namespace


TypeLocation.Portal Field

TypeLocation Portal Field NFX Class Library

Name of portal. When this property is set then this location will only be matched if WorkContext.Portal.Name matches for given request. NUll by default

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Portal
public readonly string Portal
Public ReadOnly Portal As String
Public ReadOnly Portal As String
public:
initonly String^ Portal
public:
initonly String^ Portal
val Portal: string
val Portal: string

Field Value

Type: Online String
See Also
TypeLocation Class
TypeLocation Members
NFX.Wave.Handlers Namespace


TypeLocation Methods

TypeLocation Methods NFX Class Library

The TypeLocation type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TypeLocation Class
NFX.Wave.Handlers Namespace


TypeLocation Properties

TypeLocation Properties NFX Class Library

The TypeLocation type exposes the following members.
Properties
 | Name | Description
Public property | Name | Location name
Public property | Order | Location order
Back to Top
See Also
TypeLocation Class
NFX.Wave.Handlers Namespace


TypeLocation.Name Property

TypeLocation Name Property NFX Class Library

Location name

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
TypeLocation Class
TypeLocation Members
NFX.Wave.Handlers Namespace


TypeLocation.Order Property

TypeLocation Order Property NFX Class Library

Location order

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Order { get; }
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
Public ReadOnly Property Order As Integer
    Get
public:
virtual property int Order {
    int get () sealed;
}
public:
virtual property int Order {
    int get () sealed;
}
abstract Order : int with get
override Order : int with get
abstract Order : int with get
override Order : int with get

Property Value

Type: Online Int32

Implements

IOrdered Order
See Also
TypeLocation Class
TypeLocation Members
NFX.Wave.Handlers Namespace


TypeLocations Class

TypeLocations Class NFX Class Library

A list of type search locations used for dynamic type searches
Inheritance Hierarchy
Online System Object
NFX Registry TypeLocation
NFX OrderedRegistry TypeLocation
NFX.Wave.Handlers TypeLocations

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TypeLocations : OrderedRegistry<TypeLocation>
public sealed class TypeLocations : OrderedRegistry<TypeLocation>
Public NotInheritable Class TypeLocations
    Inherits OrderedRegistry(Of TypeLocation)
Public NotInheritable Class TypeLocations
    Inherits OrderedRegistry(Of TypeLocation)
public ref class TypeLocations sealed : public OrderedRegistry<TypeLocation^>
public ref class TypeLocations sealed : public OrderedRegistry<TypeLocation^>
[<SealedAttribute>]
type TypeLocations =
    class
        inherit OrderedRegistry<TypeLocation>
    end
[<SealedAttribute>]
type TypeLocations =
    class
        inherit OrderedRegistry<TypeLocation>
    end
See Also
TypeLocations Members
NFX.Wave.Handlers Namespace


TypeLocations Members

TypeLocations Members NFX Class Library

The TypeLocations type exposes the following members.
Constructors
 | Name | Description
Public method | TypeLocations | Initializes a new instance of the TypeLocations class
Back to Top
Methods
 | Name | Description
Public method | Clear | Deletes all items from ordered registry (Inherited from OrderedRegistry T .)
Public method | ContainsName | (Inherited from Registry T .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Registry T .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext, Boolean ) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | JustRegistered | (Inherited from OrderedRegistry T .)
Protected method | JustReplaced | (Inherited from OrderedRegistry T .)
Protected method | JustUnregistered | (Inherited from OrderedRegistry T .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Registers item and returns true if it was registered, false if this named instance already existed in the list (Inherited from Registry T .)
Public method | RegisterOrReplace(T) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | RegisterOrReplace(T, T ) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue | (Inherited from Registry T .)
Public method | Unregister(String) | Unregisters item by name and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Public method | Unregister(T) | Unregisters item and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Sync | (Inherited from Registry T .)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns the number of entries in the registry (Inherited from Registry T .)
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case (Inherited from Registry T .)
Public property | Item Int32 | Tries to return an item by its position index in ordered set of items that this registry keeps. Null is returned when index is out of bounds. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry (Inherited from OrderedRegistry T .)
Public property | Item String | Returns a value by name or null if not found (Inherited from Registry T .)
Public property | Names | (Inherited from Registry T .)
Public property | OrderedValues | Returns items that registry contains ordered by their Order property. The returned sequence is pre-sorted during alteration of registry, so this property access is efficient. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry (Inherited from OrderedRegistry T .)
Public property | Values | (Inherited from Registry T .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Registry T .)
Back to Top
See Also
TypeLocations Class
NFX.Wave.Handlers Namespace


TypeLocations Constructor

TypeLocations Constructor NFX Class Library

Initializes a new instance of the TypeLocations class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeLocations()
public TypeLocations()
Public Sub New
Public Sub New
public:
TypeLocations()
public:
TypeLocations()
new : unit -> TypeLocations
new : unit -> TypeLocations
See Also
TypeLocations Class
TypeLocations Members
NFX.Wave.Handlers Namespace


TypeLocations Fields

TypeLocations Fields NFX Class Library

The TypeLocations type exposes the following members.
Fields
 | Name | Description
Protected field | m_Sync | (Inherited from Registry T .)
Back to Top
See Also
TypeLocations Class
NFX.Wave.Handlers Namespace


TypeLocations Methods

TypeLocations Methods NFX Class Library

The TypeLocations type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Deletes all items from ordered registry (Inherited from OrderedRegistry T .)
Public method | ContainsName | (Inherited from Registry T .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Registry T .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext, Boolean ) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | JustRegistered | (Inherited from OrderedRegistry T .)
Protected method | JustReplaced | (Inherited from OrderedRegistry T .)
Protected method | JustUnregistered | (Inherited from OrderedRegistry T .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Registers item and returns true if it was registered, false if this named instance already existed in the list (Inherited from Registry T .)
Public method | RegisterOrReplace(T) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | RegisterOrReplace(T, T ) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue | (Inherited from Registry T .)
Public method | Unregister(String) | Unregisters item by name and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Public method | Unregister(T) | Unregisters item and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Registry T .)
Back to Top
See Also
TypeLocations Class
NFX.Wave.Handlers Namespace


TypeLocations Properties

TypeLocations Properties NFX Class Library

The TypeLocations type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns the number of entries in the registry (Inherited from Registry T .)
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case (Inherited from Registry T .)
Public property | Item Int32 | Tries to return an item by its position index in ordered set of items that this registry keeps. Null is returned when index is out of bounds. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry (Inherited from OrderedRegistry T .)
Public property | Item String | Returns a value by name or null if not found (Inherited from Registry T .)
Public property | Names | (Inherited from Registry T .)
Public property | OrderedValues | Returns items that registry contains ordered by their Order property. The returned sequence is pre-sorted during alteration of registry, so this property access is efficient. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry (Inherited from OrderedRegistry T .)
Public property | Values | (Inherited from Registry T .)
Back to Top
See Also
TypeLocations Class
NFX.Wave.Handlers Namespace


TypeLookup Class

TypeLookup Class NFX Class Library

Lookup table string->Type
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic Dictionary Online String, Online Type
NFX.Wave.Handlers TypeLookup

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal sealed class TypeLookup : Dictionary<string, Type>
internal sealed class TypeLookup : Dictionary<string, Type>
Friend NotInheritable Class TypeLookup
    Inherits Dictionary(Of String, Type)
Friend NotInheritable Class TypeLookup
    Inherits Dictionary(Of String, Type)
internal ref class TypeLookup sealed : public Dictionary<String^, Type^>
internal ref class TypeLookup sealed : public Dictionary<String^, Type^>
[<SealedAttribute>]
type TypeLookup =
    class
        inherit Dictionary<string, Type>
    end
[<SealedAttribute>]
type TypeLookup =
    class
        inherit Dictionary<string, Type>
    end
See Also
TypeLookup Members
NFX.Wave.Handlers Namespace


TypeLookup Members

TypeLookup Members NFX Class Library

The TypeLookup type exposes the following members.
Constructors
 | Name | Description
Public method | TypeLookup | Initializes a new instance of the TypeLookup class
Public method | TypeLookup(TypeLookup) | Initializes a new instance of the TypeLookup class
Back to Top
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online Clear | (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online Remove | (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online String, Online Type .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online String, Online Type .)
Public property | Online Count | (Inherited from Online Dictionary Online String, Online Type .)
Public property | Online Item | (Inherited from Online Dictionary Online String, Online Type .)
Public property | Online Keys | (Inherited from Online Dictionary Online String, Online Type .)
Public property | Online Values | (Inherited from Online Dictionary Online String, Online Type .)
Back to Top
See Also
TypeLookup Class
NFX.Wave.Handlers Namespace


TypeLookup Constructor

TypeLookup Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TypeLookup | Initializes a new instance of the TypeLookup class
Public method | TypeLookup(TypeLookup) | Initializes a new instance of the TypeLookup class
Back to Top
See Also
TypeLookup Class
TypeLookup Members
NFX.Wave.Handlers Namespace


TypeLookup Constructor

TypeLookup Constructor NFX Class Library

Initializes a new instance of the TypeLookup class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeLookup()
public TypeLookup()
Public Sub New
Public Sub New
public:
TypeLookup()
public:
TypeLookup()
new : unit -> TypeLookup
new : unit -> TypeLookup
See Also
TypeLookup Class
TypeLookup Members
TypeLookup Overload
NFX.Wave.Handlers Namespace


TypeLookup Constructor (TypeLookup)

TypeLookup Constructor (TypeLookup) NFX Class Library

Initializes a new instance of the TypeLookup class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeLookup(
    TypeLookup clone
)
public TypeLookup(
    TypeLookup clone
)
Public Sub New (
    clone As TypeLookup
)
Public Sub New (
    clone As TypeLookup
)
public:
TypeLookup(
    TypeLookup^ clone
)
public:
TypeLookup(
    TypeLookup^ clone
)
new :
        clone : TypeLookup -> TypeLookup
new :
        clone : TypeLookup -> TypeLookup

Parameters

clone
Type: NFX.Wave.Handlers TypeLookup
See Also
TypeLookup Class
TypeLookup Members
TypeLookup Overload
NFX.Wave.Handlers Namespace


TypeLookup Methods

TypeLookup Methods NFX Class Library

The TypeLookup type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online Clear | (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online Remove | (Inherited from Online Dictionary Online String, Online Type .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online String, Online Type .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TypeLookup Class
NFX.Wave.Handlers Namespace


TypeLookup Properties

TypeLookup Properties NFX Class Library

The TypeLookup type exposes the following members.
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online String, Online Type .)
Public property | Online Count | (Inherited from Online Dictionary Online String, Online Type .)
Public property | Online Item | (Inherited from Online Dictionary Online String, Online Type .)
Public property | Online Keys | (Inherited from Online Dictionary Online String, Online Type .)
Public property | Online Values | (Inherited from Online Dictionary Online String, Online Type .)
Back to Top
See Also
TypeLookup Class
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget) Class

TypeLookupHandler TTarget Class NFX Class Library

Represents a base handler for all handlers that dynamicaly resolve type that performs actual work
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Wave WorkHandler
NFX.Wave.Handlers TypeLookupHandler TTarget
NFX.Wave.Handlers MVCHandler
NFX.Wave.Handlers TemplateHandler

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TypeLookupHandler<TTarget> : WorkHandler
where TTarget : class
public abstract class TypeLookupHandler<TTarget> : WorkHandler
where TTarget : class
Public MustInherit Class TypeLookupHandler(Of TTarget As Class)
    Inherits WorkHandler
Public MustInherit Class TypeLookupHandler(Of TTarget As Class)
    Inherits WorkHandler
generic<typename TTarget>
where TTarget : ref class
public ref class TypeLookupHandler abstract : public WorkHandler
generic<typename TTarget>
where TTarget : ref class
public ref class TypeLookupHandler abstract : public WorkHandler
[<AbstractClassAttribute>]
type TypeLookupHandler<'TTarget when 'TTarget : not struct> =
    class
        inherit WorkHandler
    end
[<AbstractClassAttribute>]
type TypeLookupHandler<'TTarget when 'TTarget : not struct> =
    class
        inherit WorkHandler
    end
Type Parameters
TTarget
See Also
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget) Members

TypeLookupHandler TTarget Members NFX Class Library

The TypeLookupHandler TTarget type exposes the following members.
Constructors
 | Name | Description
Protected method | TypeLookupHandler TTarget (WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the TypeLookupHandler TTarget class
Protected method | TypeLookupHandler TTarget (WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the TypeLookupHandler TTarget class
Back to Top
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | CreateTargetInstance | Factory method - Override to create and init more particular template implementation (i.e. based on model)
Protected method | DeleteTargetInstanceByID | Deletes target instance with id from store. Default implementation uses Application.ObjectStore.
Protected method | Destructor | (Inherited from WorkHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | Do404 | Override to handle 404 condition, i.e. may write into response instead of generating a exception. The default implementation returns a HttpStatusException with 404 code
Protected method | DoError | Override to handle error processing, i.e. may elect to write error data into response. The dafault implementation throws the error. It is recommended to handle errors with filters instead
Protected method | DoHandleWork | Sealed. Override DoTargetWork(TTarget, WorkContext) to do actual work (Overrides WorkHandler DoHandleWork(WorkContext).)
Protected method | DoTargetWork | Performs work on the target instance
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Protected method | GetTargetInstanceByID | Retrieves target instance from id. Default implementation uses Application.ObjectStore. If this method is called by the framework then complementary matching PutTargetInstanceWithID() is guaranteed to be called as well
Protected method | GetTargetInstanceID | Override to extract instance ID from WorkContext
Protected method | GetTargetType | Override to resolve route/URL parameters to type
Protected method | GetTargetTypeNameFromWorkContext | Override to get type name from WorkContext. Default implementation looks for MatchedVars[VAR_TARGET_TYPE]
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | PutTargetInstanceByID | Puts target instance with id into store. Default implementation uses Application.ObjectStore. This method is called by the framework to complement GetTargetInstanceFromID()
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_CLOAK_TYPE_ATTR |
CONFIG_DEFAULT_TYPE_ATTR |
CONFIG_NOT_FOUND_REDIRECT_URL_ATTR |
VAR_INSTANCE_ID |
VAR_TARGET_TYPE |
Back to Top
Properties
 | Name | Description
Public property | CloakTypeName | Provides type name which is used if the prior one was not found. This allows to block 404 errors, i.e. if page with requested name is not found then always return the specified page
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultTypeName | Provides default type name
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | NotFoundRedirectURL | Provides redirect URL where the user gets redirected when type name could not be resolved. Note: CloakTypeName is used first when set.
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Public property | SupportsInstanceID | Indicates whether instance IDs are supported in requests. Default is false. Override to return true for handlers that support target instance state between requests
Public property | TypeLocations | Returns a registry of type locations
Back to Top
See Also
TypeLookupHandler TTarget Class
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget) Constructor

TypeLookupHandler TTarget Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | TypeLookupHandler TTarget (WorkDispatcher, IConfigSectionNode) | Initializes a new instance of the TypeLookupHandler TTarget class
Protected method | TypeLookupHandler TTarget (WorkDispatcher, String, Int32, WorkMatch) | Initializes a new instance of the TypeLookupHandler TTarget class
Back to Top
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget) Constructor (WorkDispatcher, IConfigSectionNode)

TypeLookupHandler TTarget Constructor (WorkDispatcher, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TypeLookupHandler TTarget class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TypeLookupHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
protected TypeLookupHandler(
    WorkDispatcher dispatcher,
    IConfigSectionNode confNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    confNode As IConfigSectionNode
)
protected:
TypeLookupHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
protected:
TypeLookupHandler(
    WorkDispatcher^ dispatcher,
    IConfigSectionNode^ confNode
)
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> TypeLookupHandler
new :
        dispatcher : WorkDispatcher *
        confNode : IConfigSectionNode -> TypeLookupHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
confNode
Type: NFX.Environment IConfigSectionNode
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
TypeLookupHandler TTarget Overload
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget) Constructor (WorkDispatcher, String, Int32, WorkMatch)

TypeLookupHandler TTarget Constructor (WorkDispatcher, String, Int32, WorkMatch) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TypeLookupHandler TTarget class

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TypeLookupHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
protected TypeLookupHandler(
    WorkDispatcher dispatcher,
    string name,
    int order,
    WorkMatch match
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
Protected Sub New (
    dispatcher As WorkDispatcher,
    name As String,
    order As Integer,
    match As WorkMatch
)
protected:
TypeLookupHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
protected:
TypeLookupHandler(
    WorkDispatcher^ dispatcher,
    String^ name,
    int order,
    WorkMatch^ match
)
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> TypeLookupHandler
new :
        dispatcher : WorkDispatcher *
        name : string *
        order : int *
        match : WorkMatch -> TypeLookupHandler

Parameters

dispatcher
Type: NFX.Wave WorkDispatcher
name
Type: Online System String
order
Type: Online System Int32
match
Type: NFX.Wave WorkMatch
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
TypeLookupHandler TTarget Overload
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget) Fields

TypeLookupHandler TTarget Fields NFX Class Library

The TypeLookupHandler TTarget type exposes the following members.
Fields
Name | Description
CONFIG_CLOAK_TYPE_ATTR |
CONFIG_DEFAULT_TYPE_ATTR |
CONFIG_NOT_FOUND_REDIRECT_URL_ATTR |
VAR_INSTANCE_ID |
VAR_TARGET_TYPE |
Back to Top
See Also
TypeLookupHandler TTarget Class
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).CONFIG_CLOAK_TYPE_ATTR Field

TypeLookupHandler TTarget CONFIG_CLOAK_TYPE_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CLOAK_TYPE_ATTR
public const string CONFIG_CLOAK_TYPE_ATTR
Public Const CONFIG_CLOAK_TYPE_ATTR As String
Public Const CONFIG_CLOAK_TYPE_ATTR As String
public:
literal String^ CONFIG_CLOAK_TYPE_ATTR
public:
literal String^ CONFIG_CLOAK_TYPE_ATTR
static val mutable CONFIG_CLOAK_TYPE_ATTR: string
static val mutable CONFIG_CLOAK_TYPE_ATTR: string

Field Value

Type: Online String
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).CONFIG_DEFAULT_TYPE_ATTR Field

TypeLookupHandler TTarget CONFIG_DEFAULT_TYPE_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DEFAULT_TYPE_ATTR
public const string CONFIG_DEFAULT_TYPE_ATTR
Public Const CONFIG_DEFAULT_TYPE_ATTR As String
Public Const CONFIG_DEFAULT_TYPE_ATTR As String
public:
literal String^ CONFIG_DEFAULT_TYPE_ATTR
public:
literal String^ CONFIG_DEFAULT_TYPE_ATTR
static val mutable CONFIG_DEFAULT_TYPE_ATTR: string
static val mutable CONFIG_DEFAULT_TYPE_ATTR: string

Field Value

Type: Online String
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).CONFIG_NOT_FOUND_REDIRECT_URL_ATTR Field

TypeLookupHandler TTarget CONFIG_NOT_FOUND_REDIRECT_URL_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NOT_FOUND_REDIRECT_URL_ATTR
public const string CONFIG_NOT_FOUND_REDIRECT_URL_ATTR
Public Const CONFIG_NOT_FOUND_REDIRECT_URL_ATTR As String
Public Const CONFIG_NOT_FOUND_REDIRECT_URL_ATTR As String
public:
literal String^ CONFIG_NOT_FOUND_REDIRECT_URL_ATTR
public:
literal String^ CONFIG_NOT_FOUND_REDIRECT_URL_ATTR
static val mutable CONFIG_NOT_FOUND_REDIRECT_URL_ATTR: string
static val mutable CONFIG_NOT_FOUND_REDIRECT_URL_ATTR: string

Field Value

Type: Online String
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).VAR_INSTANCE_ID Field

TypeLookupHandler TTarget VAR_INSTANCE_ID Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_INSTANCE_ID
public const string VAR_INSTANCE_ID
Public Const VAR_INSTANCE_ID As String
Public Const VAR_INSTANCE_ID As String
public:
literal String^ VAR_INSTANCE_ID
public:
literal String^ VAR_INSTANCE_ID
static val mutable VAR_INSTANCE_ID: string
static val mutable VAR_INSTANCE_ID: string

Field Value

Type: Online String
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).VAR_TARGET_TYPE Field

TypeLookupHandler TTarget VAR_TARGET_TYPE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VAR_TARGET_TYPE
public const string VAR_TARGET_TYPE
Public Const VAR_TARGET_TYPE As String
Public Const VAR_TARGET_TYPE As String
public:
literal String^ VAR_TARGET_TYPE
public:
literal String^ VAR_TARGET_TYPE
static val mutable VAR_TARGET_TYPE: string
static val mutable VAR_TARGET_TYPE: string

Field Value

Type: Online String
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget) Methods

TypeLookupHandler TTarget Methods NFX Class Library

The TypeLookupHandler TTarget type exposes the following members.
Methods
 | Name | Description
Protected method | ___setParentHandler | (Inherited from WorkHandler.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | CreateTargetInstance | Factory method - Override to create and init more particular template implementation (i.e. based on model)
Protected method | DeleteTargetInstanceByID | Deletes target instance with id from store. Default implementation uses Application.ObjectStore.
Protected method | Destructor | (Inherited from WorkHandler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | Do404 | Override to handle 404 condition, i.e. may write into response instead of generating a exception. The default implementation returns a HttpStatusException with 404 code
Protected method | DoError | Override to handle error processing, i.e. may elect to write error data into response. The dafault implementation throws the error. It is recommended to handle errors with filters instead
Protected method | DoHandleWork | Sealed. Override DoTargetWork(TTarget, WorkContext) to do actual work (Overrides WorkHandler DoHandleWork(WorkContext).)
Protected method | DoTargetWork | Performs work on the target instance
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FilterAndHandleWork | Handles the work - first involes all filters then calls HandleWork to do actual processing Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Protected method | GetTargetInstanceByID | Retrieves target instance from id. Default implementation uses Application.ObjectStore. If this method is called by the framework then complementary matching PutTargetInstanceWithID() is guaranteed to be called as well
Protected method | GetTargetInstanceID | Override to extract instance ID from WorkContext
Protected method | GetTargetType | Override to resolve route/URL parameters to type
Protected method | GetTargetTypeNameFromWorkContext | Override to get type name from WorkContext. Default implementation looks for MatchedVars[VAR_TARGET_TYPE]
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleWork | Handles the work - i.e. renders a template page or calls MVC controller method. This method does not pass through handler's filters Note: This method is re-entrant by multiple threads (Inherited from WorkHandler.)
Public method | MakeMatch | Returns true when the particular work request matches the pattern match of this handler. Also sets the WorkHandler's MatchedVars property filled with matched values (Inherited from WorkHandler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | PutTargetInstanceByID | Puts target instance with id into store. Default implementation uses Application.ObjectStore. This method is called by the framework to complement GetTargetInstanceFromID()
Public method | RegisterFilter | Registers filter and returns true if the named instance has not been registered yet Note: it is possible to call this method on active server that is - inject filters while serving requests (Inherited from WorkHandler.)
Public method | ToString | (Inherited from WorkHandler.)
Public method | UnRegisterFilter | Unregisters filter and returns true if the named instance has been removed Note: it is possible to call this method on active server that is - remove filters while serving requests (Inherited from WorkHandler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TypeLookupHandler TTarget Class
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).CreateTargetInstance Method

TypeLookupHandler TTarget CreateTargetInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Factory method - Override to create and init more particular template implementation (i.e. based on model)

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual TTarget CreateTargetInstance(
    WorkContext work,
    Type tt
)
protected virtual TTarget CreateTargetInstance(
    WorkContext work,
    Type tt
)
Protected Overridable Function CreateTargetInstance (
    work As WorkContext,
    tt As Type
) As TTarget
Protected Overridable Function CreateTargetInstance (
    work As WorkContext,
    tt As Type
) As TTarget
protected:
virtual TTarget CreateTargetInstance(
    WorkContext^ work,
    Type^ tt
)
protected:
virtual TTarget CreateTargetInstance(
    WorkContext^ work,
    Type^ tt
)
abstract CreateTargetInstance :
        work : WorkContext *
        tt : Type -> 'TTarget
override CreateTargetInstance :
        work : WorkContext *
        tt : Type -> 'TTarget
abstract CreateTargetInstance :
        work : WorkContext *
        tt : Type -> 'TTarget
override CreateTargetInstance :
        work : WorkContext *
        tt : Type -> 'TTarget

Parameters

work
Type: NFX.Wave WorkContext
tt
Type: Online System Type

Return Value

Type: TTarget
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).DeleteTargetInstanceByID Method

TypeLookupHandler TTarget DeleteTargetInstanceByID Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Deletes target instance with id from store. Default implementation uses Application.ObjectStore.

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DeleteTargetInstanceByID(
    WorkContext work,
    Guid id
)
protected virtual void DeleteTargetInstanceByID(
    WorkContext work,
    Guid id
)
Protected Overridable Sub DeleteTargetInstanceByID (
    work As WorkContext,
    id As Guid
)
Protected Overridable Sub DeleteTargetInstanceByID (
    work As WorkContext,
    id As Guid
)
protected:
virtual void DeleteTargetInstanceByID(
    WorkContext^ work,
    Guid id
)
protected:
virtual void DeleteTargetInstanceByID(
    WorkContext^ work,
    Guid id
)
abstract DeleteTargetInstanceByID :
        work : WorkContext *
        id : Guid -> unit
override DeleteTargetInstanceByID :
        work : WorkContext *
        id : Guid -> unit
abstract DeleteTargetInstanceByID :
        work : WorkContext *
        id : Guid -> unit
override DeleteTargetInstanceByID :
        work : WorkContext *
        id : Guid -> unit

Parameters

work
Type: NFX.Wave WorkContext
id
Type: Online System Guid
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).Do404 Method

TypeLookupHandler TTarget Do404 Method NFX Class Library

Override to handle 404 condition, i.e. may write into response instead of generating a exception. The default implementation returns a HttpStatusException with 404 code

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual HTTPStatusException Do404(
    WorkContext context
)
protected virtual HTTPStatusException Do404(
    WorkContext context
)
Protected Overridable Function Do404 (
    context As WorkContext
) As HTTPStatusException
Protected Overridable Function Do404 (
    context As WorkContext
) As HTTPStatusException
protected:
virtual HTTPStatusException^ Do404(
    WorkContext^ context
)
protected:
virtual HTTPStatusException^ Do404(
    WorkContext^ context
)
abstract Do404 :
        context : WorkContext -> HTTPStatusException
override Do404 :
        context : WorkContext -> HTTPStatusException
abstract Do404 :
        context : WorkContext -> HTTPStatusException
override Do404 :
        context : WorkContext -> HTTPStatusException

Parameters

context
Type: NFX.Wave WorkContext

Return Value

Type: HTTPStatusException
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).DoError Method

TypeLookupHandler TTarget DoError Method NFX Class Library

Override to handle error processing, i.e. may elect to write error data into response. The dafault implementation throws the error. It is recommended to handle errors with filters instead

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoError(
    WorkContext work,
    Exception error
)
protected virtual void DoError(
    WorkContext work,
    Exception error
)
Protected Overridable Sub DoError (
    work As WorkContext,
    error As Exception
)
Protected Overridable Sub DoError (
    work As WorkContext,
    error As Exception
)
protected:
virtual void DoError(
    WorkContext^ work,
    Exception^ error
)
protected:
virtual void DoError(
    WorkContext^ work,
    Exception^ error
)
abstract DoError :
        work : WorkContext *
        error : Exception -> unit
override DoError :
        work : WorkContext *
        error : Exception -> unit
abstract DoError :
        work : WorkContext *
        error : Exception -> unit
override DoError :
        work : WorkContext *
        error : Exception -> unit

Parameters

work
Type: NFX.Wave WorkContext
error
Type: Online System Exception
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).DoHandleWork Method

TypeLookupHandler TTarget DoHandleWork Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Sealed. Override DoTargetWork(TTarget, WorkContext) to do actual work

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override sealed void DoHandleWork(
    WorkContext work
)
protected override sealed void DoHandleWork(
    WorkContext work
)
Protected Overrides NotOverridable Sub DoHandleWork (
    work As WorkContext
)
Protected Overrides NotOverridable Sub DoHandleWork (
    work As WorkContext
)
protected:
virtual void DoHandleWork(
    WorkContext^ work
) override sealed
protected:
virtual void DoHandleWork(
    WorkContext^ work
) override sealed
abstract DoHandleWork :
        work : WorkContext -> unit
override DoHandleWork :
        work : WorkContext -> unit
abstract DoHandleWork :
        work : WorkContext -> unit
override DoHandleWork :
        work : WorkContext -> unit

Parameters

work
Type: NFX.Wave WorkContext
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).DoTargetWork Method

TypeLookupHandler TTarget DoTargetWork Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Performs work on the target instance

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoTargetWork(
    TTarget target,
    WorkContext work
)
protected abstract void DoTargetWork(
    TTarget target,
    WorkContext work
)
Protected MustOverride Sub DoTargetWork (
    target As TTarget,
    work As WorkContext
)
Protected MustOverride Sub DoTargetWork (
    target As TTarget,
    work As WorkContext
)
protected:
virtual void DoTargetWork(
    TTarget target,
    WorkContext^ work
) abstract
protected:
virtual void DoTargetWork(
    TTarget target,
    WorkContext^ work
) abstract
abstract DoTargetWork :
        target : 'TTarget *
        work : WorkContext -> unit
abstract DoTargetWork :
        target : 'TTarget *
        work : WorkContext -> unit

Parameters

target
Type: TTarget
work
Type: NFX.Wave WorkContext
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).GetTargetInstanceByID Method

TypeLookupHandler TTarget GetTargetInstanceByID Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Retrieves target instance from id. Default implementation uses Application.ObjectStore. If this method is called by the framework then complementary matching PutTargetInstanceWithID() is guaranteed to be called as well

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual TTarget GetTargetInstanceByID(
    WorkContext work,
    Guid id
)
protected virtual TTarget GetTargetInstanceByID(
    WorkContext work,
    Guid id
)
Protected Overridable Function GetTargetInstanceByID (
    work As WorkContext,
    id As Guid
) As TTarget
Protected Overridable Function GetTargetInstanceByID (
    work As WorkContext,
    id As Guid
) As TTarget
protected:
virtual TTarget GetTargetInstanceByID(
    WorkContext^ work,
    Guid id
)
protected:
virtual TTarget GetTargetInstanceByID(
    WorkContext^ work,
    Guid id
)
abstract GetTargetInstanceByID :
        work : WorkContext *
        id : Guid -> 'TTarget
override GetTargetInstanceByID :
        work : WorkContext *
        id : Guid -> 'TTarget
abstract GetTargetInstanceByID :
        work : WorkContext *
        id : Guid -> 'TTarget
override GetTargetInstanceByID :
        work : WorkContext *
        id : Guid -> 'TTarget

Parameters

work
Type: NFX.Wave WorkContext
id
Type: Online System Guid

Return Value

Type: TTarget
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).GetTargetInstanceID Method

TypeLookupHandler TTarget GetTargetInstanceID Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to extract instance ID from WorkContext

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool GetTargetInstanceID(
    WorkContext work,
    ref Guid id
)
protected virtual bool GetTargetInstanceID(
    WorkContext work,
    ref Guid id
)
Protected Overridable Function GetTargetInstanceID (
    work As WorkContext,
    ByRef id As Guid
) As Boolean
Protected Overridable Function GetTargetInstanceID (
    work As WorkContext,
    ByRef id As Guid
) As Boolean
protected:
virtual bool GetTargetInstanceID(
    WorkContext^ work,
    Guid% id
)
protected:
virtual bool GetTargetInstanceID(
    WorkContext^ work,
    Guid% id
)
abstract GetTargetInstanceID :
        work : WorkContext *
        id : Guid byref -> bool
override GetTargetInstanceID :
        work : WorkContext *
        id : Guid byref -> bool
abstract GetTargetInstanceID :
        work : WorkContext *
        id : Guid byref -> bool
override GetTargetInstanceID :
        work : WorkContext *
        id : Guid byref -> bool

Parameters

work
Type: NFX.Wave WorkContext
id
Type: Online System Guid

Return Value

Type: Online Boolean
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).GetTargetType Method

TypeLookupHandler TTarget GetTargetType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to resolve route/URL parameters to type

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Type GetTargetType(
    WorkContext work
)
protected virtual Type GetTargetType(
    WorkContext work
)
Protected Overridable Function GetTargetType (
    work As WorkContext
) As Type
Protected Overridable Function GetTargetType (
    work As WorkContext
) As Type
protected:
virtual Type^ GetTargetType(
    WorkContext^ work
)
protected:
virtual Type^ GetTargetType(
    WorkContext^ work
)
abstract GetTargetType :
        work : WorkContext -> Type
override GetTargetType :
        work : WorkContext -> Type
abstract GetTargetType :
        work : WorkContext -> Type
override GetTargetType :
        work : WorkContext -> Type

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online Type
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).GetTargetTypeNameFromWorkContext Method

TypeLookupHandler TTarget GetTargetTypeNameFromWorkContext Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to get type name from WorkContext. Default implementation looks for MatchedVars[VAR_TARGET_TYPE]

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string GetTargetTypeNameFromWorkContext(
    WorkContext work
)
protected virtual string GetTargetTypeNameFromWorkContext(
    WorkContext work
)
Protected Overridable Function GetTargetTypeNameFromWorkContext (
    work As WorkContext
) As String
Protected Overridable Function GetTargetTypeNameFromWorkContext (
    work As WorkContext
) As String
protected:
virtual String^ GetTargetTypeNameFromWorkContext(
    WorkContext^ work
)
protected:
virtual String^ GetTargetTypeNameFromWorkContext(
    WorkContext^ work
)
abstract GetTargetTypeNameFromWorkContext :
        work : WorkContext -> string
override GetTargetTypeNameFromWorkContext :
        work : WorkContext -> string
abstract GetTargetTypeNameFromWorkContext :
        work : WorkContext -> string
override GetTargetTypeNameFromWorkContext :
        work : WorkContext -> string

Parameters

work
Type: NFX.Wave WorkContext

Return Value

Type: Online String
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).PutTargetInstanceByID Method

TypeLookupHandler TTarget PutTargetInstanceByID Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Puts target instance with id into store. Default implementation uses Application.ObjectStore. This method is called by the framework to complement GetTargetInstanceFromID()

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void PutTargetInstanceByID(
    WorkContext work,
    Guid id,
    TTarget target,
    int msTimeout = 0
)
protected virtual void PutTargetInstanceByID(
    WorkContext work,
    Guid id,
    TTarget target,
    int msTimeout = 0
)
Protected Overridable Sub PutTargetInstanceByID (
    work As WorkContext,
    id As Guid,
    target As TTarget,
    Optional msTimeout As Integer = 0
)
Protected Overridable Sub PutTargetInstanceByID (
    work As WorkContext,
    id As Guid,
    target As TTarget,
    Optional msTimeout As Integer = 0
)
protected:
virtual void PutTargetInstanceByID(
    WorkContext^ work,
    Guid id,
    TTarget target,
    int msTimeout = 0
)
protected:
virtual void PutTargetInstanceByID(
    WorkContext^ work,
    Guid id,
    TTarget target,
    int msTimeout = 0
)
abstract PutTargetInstanceByID :
        work : WorkContext *
        id : Guid *
        target : 'TTarget *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
override PutTargetInstanceByID :
        work : WorkContext *
        id : Guid *
        target : 'TTarget *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
abstract PutTargetInstanceByID :
        work : WorkContext *
        id : Guid *
        target : 'TTarget *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
override PutTargetInstanceByID :
        work : WorkContext *
        id : Guid *
        target : 'TTarget *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit

Parameters

work
Type: NFX.Wave WorkContext
id
Type: Online System Guid
target
Type: TTarget
msTimeout (Optional)
Type: Online System Int32
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget) Properties

TypeLookupHandler TTarget Properties NFX Class Library

The TypeLookupHandler TTarget type exposes the following members.
Properties
 | Name | Description
Public property | CloakTypeName | Provides type name which is used if the prior one was not found. This allows to block 404 errors, i.e. if page with requested name is not found then always return the specified page
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultTypeName | Provides default type name
Public property | Dispatcher | Returns the dispatcher that this handler works under (Inherited from WorkHandler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Filters | Returns ordered registry of filters (Inherited from WorkHandler.)
Public property | Matches | Returns matches used by this handler. May change the registry at runtime (inject/remove matches) (Inherited from WorkHandler.)
Public property | Name | Returns the handler instance name (Inherited from WorkHandler.)
Public property | NetGate | Returns network gate that handler implementation may use to set business variables or null (Inherited from WorkHandler.)
Public property | NotFoundRedirectURL | Provides redirect URL where the user gets redirected when type name could not be resolved. Note: CloakTypeName is used first when set.
Public property | Order | Returns the handler order in handler registry. Order is used for URI pattern matching (Inherited from WorkHandler.)
Public property | ParentHandler | Returns parent handler that this handler is under or null (Inherited from WorkHandler.)
Public property | Server | Returns the server that this handler works under (Inherited from WorkHandler.)
Public property | SupportsInstanceID | Indicates whether instance IDs are supported in requests. Default is false. Override to return true for handlers that support target instance state between requests
Public property | TypeLocations | Returns a registry of type locations
Back to Top
See Also
TypeLookupHandler TTarget Class
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).CloakTypeName Property

TypeLookupHandler TTarget CloakTypeName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides type name which is used if the prior one was not found. This allows to block 404 errors, i.e. if page with requested name is not found then always return the specified page

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CloakTypeName { get; set; }
public string CloakTypeName { get; set; }
Public Property CloakTypeName As String
    Get
    Set
Public Property CloakTypeName As String
    Get
    Set
public:
property String^ CloakTypeName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CloakTypeName {
    String^ get ();
    void set (String^ value);
}
member CloakTypeName : string with get, set
member CloakTypeName : string with get, set

Property Value

Type: Online String
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).DefaultTypeName Property

TypeLookupHandler TTarget DefaultTypeName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides default type name

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DefaultTypeName { get; set; }
public string DefaultTypeName { get; set; }
Public Property DefaultTypeName As String
    Get
    Set
Public Property DefaultTypeName As String
    Get
    Set
public:
property String^ DefaultTypeName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ DefaultTypeName {
    String^ get ();
    void set (String^ value);
}
member DefaultTypeName : string with get, set
member DefaultTypeName : string with get, set

Property Value

Type: Online String
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).NotFoundRedirectURL Property

TypeLookupHandler TTarget NotFoundRedirectURL Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides redirect URL where the user gets redirected when type name could not be resolved. Note: CloakTypeName is used first when set.

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string NotFoundRedirectURL { get; set; }
public string NotFoundRedirectURL { get; set; }
Public Property NotFoundRedirectURL As String
    Get
    Set
Public Property NotFoundRedirectURL As String
    Get
    Set
public:
property String^ NotFoundRedirectURL {
    String^ get ();
    void set (String^ value);
}
public:
property String^ NotFoundRedirectURL {
    String^ get ();
    void set (String^ value);
}
member NotFoundRedirectURL : string with get, set
member NotFoundRedirectURL : string with get, set

Property Value

Type: Online String
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).SupportsInstanceID Property

TypeLookupHandler TTarget SupportsInstanceID Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Indicates whether instance IDs are supported in requests. Default is false. Override to return true for handlers that support target instance state between requests

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool SupportsInstanceID { get; }
public virtual bool SupportsInstanceID { get; }
Public Overridable ReadOnly Property SupportsInstanceID As Boolean
    Get
Public Overridable ReadOnly Property SupportsInstanceID As Boolean
    Get
public:
virtual property bool SupportsInstanceID {
    bool get ();
}
public:
virtual property bool SupportsInstanceID {
    bool get ();
}
abstract SupportsInstanceID : bool with get
override SupportsInstanceID : bool with get
abstract SupportsInstanceID : bool with get
override SupportsInstanceID : bool with get

Property Value

Type: Online Boolean
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


TypeLookupHandler(TTarget).TypeLocations Property

TypeLookupHandler TTarget TypeLocations Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a registry of type locations

Namespace: NFX.Wave.Handlers
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeLocations TypeLocations { get; }
public TypeLocations TypeLocations { get; }
Public ReadOnly Property TypeLocations As TypeLocations
    Get
Public ReadOnly Property TypeLocations As TypeLocations
    Get
public:
property TypeLocations^ TypeLocations {
    TypeLocations^ get ();
}
public:
property TypeLocations^ TypeLocations {
    TypeLocations^ get ();
}
member TypeLocations : TypeLocations with get
member TypeLocations : TypeLocations with get

Property Value

Type: TypeLocations
See Also
TypeLookupHandler TTarget Class
TypeLookupHandler TTarget Members
NFX.Wave.Handlers Namespace


NFX.Wave.Instrumentation Namespace

NFX.Wave.Instrumentation Namespace NFX Class Library

Classes
 | Class | Description
Public class | FilterHandleException | Provides the count of exceptions that filter handled
Public class | GeoLookup | How many geo lookups have been requested
Public class | GeoLookupHit | How many geo lookups have resulted in finding the geo location
Public class | ServerAcceptSemaphoreCount | The current level of taken request accept semaphore slots
Public class | ServerGateDenial | Provides request count that were denied by the server gate
Public class | ServerHandleException | Provides the count of exceptions that server had to handle as no other memebr of processing chain did
Public class | ServerPortalRequest | Provides request count received by server portal
Public class | ServerRequest | Provides request count received by server
Public class | ServerWorkSemaphoreCount | The current level of taken request work semaphore slots
Public class | SessionEnd | How many sessions ended by request
Public class | SessionExisting | How many existing sessions found
Public class | SessionInvalidID | How many sessions supplied invalid identifier (by client)
Public class | SessionNew | How many new sessions created
Public class | WaveDoubleGauge | Provides base for Wave double gauges
Public class | WaveLongGauge | Provides base for Wave long gauges
Public class | WorkContextAborted | How many work contexts got aborted
Public class | WorkContextBufferedResponse | How many response object were buffered
Public class | WorkContextBufferedResponseBytes | How many response bytes were buffered
Public class | WorkContextCtor | How many work contexts were created
Public class | WorkContextDctor | How many work contexts were destroyed
Public class | WorkContextHandled | How many work contexts got handled
Public class | WorkContextNeedsSession | How many work contexts requested session state
Public class | WorkContextNoDefaultClose | How many work contexts requested not to be closed at the end of the initial request processing cycle
Public class | WorkContextWorkSemaphoreRelease | How many times work semaphore was released
Public class | WorkContextWrittenResponse | How many response object were written into


FilterHandleException Class

FilterHandleException Class NFX Class Library

Provides the count of exceptions that filter handled
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation FilterHandleException

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FilterHandleException : WaveLongGauge,
    IErrorInstrument, IProblemClass, IInstrumentClass
[SerializableAttribute]
public class FilterHandleException : WaveLongGauge,
    IErrorInstrument, IProblemClass, IInstrumentClass
<SerializableAttribute>
Public Class FilterHandleException
    Inherits WaveLongGauge
    Implements IErrorInstrument, IProblemClass, IInstrumentClass
<SerializableAttribute>
Public Class FilterHandleException
    Inherits WaveLongGauge
    Implements IErrorInstrument, IProblemClass, IInstrumentClass
[SerializableAttribute]
public ref class FilterHandleException : public WaveLongGauge,
    IErrorInstrument, IProblemClass, IInstrumentClass
[SerializableAttribute]
public ref class FilterHandleException : public WaveLongGauge,
    IErrorInstrument, IProblemClass, IInstrumentClass
[<SerializableAttribute>]
type FilterHandleException =
    class
        inherit WaveLongGauge
        interface IErrorInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type FilterHandleException =
    class
        inherit WaveLongGauge
        interface IErrorInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
See Also
FilterHandleException Members
NFX.Wave.Instrumentation Namespace


FilterHandleException Members

FilterHandleException Members NFX Class Library

The FilterHandleException type exposes the following members.
Constructors
 | Name | Description
Protected method | FilterHandleException | Initializes a new instance of the FilterHandleException class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
FilterHandleException Class
NFX.Wave.Instrumentation Namespace


FilterHandleException Constructor

FilterHandleException Constructor NFX Class Library

Initializes a new instance of the FilterHandleException class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal FilterHandleException(
    string src,
    long value
)
internal FilterHandleException(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
FilterHandleException(
    String^ src,
    long long value
)
internal:
FilterHandleException(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> FilterHandleException
new :
        src : string *
        value : int64 -> FilterHandleException

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
FilterHandleException Class
FilterHandleException Members
NFX.Wave.Instrumentation Namespace


FilterHandleException Fields

FilterHandleException Fields NFX Class Library

The FilterHandleException type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
FilterHandleException Class
NFX.Wave.Instrumentation Namespace


FilterHandleException Methods

FilterHandleException Methods NFX Class Library

The FilterHandleException type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FilterHandleException Class
NFX.Wave.Instrumentation Namespace


FilterHandleException.MakeAggregateInstance Method

FilterHandleException MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
FilterHandleException Class
FilterHandleException Members
NFX.Wave.Instrumentation Namespace


FilterHandleException Properties

FilterHandleException Properties NFX Class Library

The FilterHandleException type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
FilterHandleException Class
NFX.Wave.Instrumentation Namespace


FilterHandleException.Description Property

FilterHandleException Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
FilterHandleException Class
FilterHandleException Members
NFX.Wave.Instrumentation Namespace


FilterHandleException.ValueUnitName Property

FilterHandleException ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
FilterHandleException Class
FilterHandleException Members
NFX.Wave.Instrumentation Namespace


GeoLookup Class

GeoLookup Class NFX Class Library

How many geo lookups have been requested
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation GeoLookup

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GeoLookup : WaveLongGauge
[SerializableAttribute]
public class GeoLookup : WaveLongGauge
<SerializableAttribute>
Public Class GeoLookup
    Inherits WaveLongGauge
<SerializableAttribute>
Public Class GeoLookup
    Inherits WaveLongGauge
[SerializableAttribute]
public ref class GeoLookup : public WaveLongGauge
[SerializableAttribute]
public ref class GeoLookup : public WaveLongGauge
[<SerializableAttribute>]
type GeoLookup =
    class
        inherit WaveLongGauge
    end
[<SerializableAttribute>]
type GeoLookup =
    class
        inherit WaveLongGauge
    end
See Also
GeoLookup Members
NFX.Wave.Instrumentation Namespace


GeoLookup Members

GeoLookup Members NFX Class Library

The GeoLookup type exposes the following members.
Constructors
 | Name | Description
Protected method | GeoLookup | Initializes a new instance of the GeoLookup class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
GeoLookup Class
NFX.Wave.Instrumentation Namespace


GeoLookup Constructor

GeoLookup Constructor NFX Class Library

Initializes a new instance of the GeoLookup class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal GeoLookup(
    string src,
    long value
)
internal GeoLookup(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
GeoLookup(
    String^ src,
    long long value
)
internal:
GeoLookup(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> GeoLookup
new :
        src : string *
        value : int64 -> GeoLookup

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
GeoLookup Class
GeoLookup Members
NFX.Wave.Instrumentation Namespace


GeoLookup Fields

GeoLookup Fields NFX Class Library

The GeoLookup type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
GeoLookup Class
NFX.Wave.Instrumentation Namespace


GeoLookup Methods

GeoLookup Methods NFX Class Library

The GeoLookup type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GeoLookup Class
NFX.Wave.Instrumentation Namespace


GeoLookup.MakeAggregateInstance Method

GeoLookup MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
GeoLookup Class
GeoLookup Members
NFX.Wave.Instrumentation Namespace


GeoLookup Properties

GeoLookup Properties NFX Class Library

The GeoLookup type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
GeoLookup Class
NFX.Wave.Instrumentation Namespace


GeoLookup.Description Property

GeoLookup Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
GeoLookup Class
GeoLookup Members
NFX.Wave.Instrumentation Namespace


GeoLookup.ValueUnitName Property

GeoLookup ValueUnitName Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
GeoLookup Class
GeoLookup Members
NFX.Wave.Instrumentation Namespace


GeoLookupHit Class

GeoLookupHit Class NFX Class Library

How many geo lookups have resulted in finding the geo location
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation GeoLookupHit

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GeoLookupHit : WaveLongGauge
[SerializableAttribute]
public class GeoLookupHit : WaveLongGauge
<SerializableAttribute>
Public Class GeoLookupHit
    Inherits WaveLongGauge
<SerializableAttribute>
Public Class GeoLookupHit
    Inherits WaveLongGauge
[SerializableAttribute]
public ref class GeoLookupHit : public WaveLongGauge
[SerializableAttribute]
public ref class GeoLookupHit : public WaveLongGauge
[<SerializableAttribute>]
type GeoLookupHit =
    class
        inherit WaveLongGauge
    end
[<SerializableAttribute>]
type GeoLookupHit =
    class
        inherit WaveLongGauge
    end
See Also
GeoLookupHit Members
NFX.Wave.Instrumentation Namespace


GeoLookupHit Members

GeoLookupHit Members NFX Class Library

The GeoLookupHit type exposes the following members.
Constructors
 | Name | Description
Protected method | GeoLookupHit | Initializes a new instance of the GeoLookupHit class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
GeoLookupHit Class
NFX.Wave.Instrumentation Namespace


GeoLookupHit Constructor

GeoLookupHit Constructor NFX Class Library

Initializes a new instance of the GeoLookupHit class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal GeoLookupHit(
    string src,
    long value
)
internal GeoLookupHit(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
GeoLookupHit(
    String^ src,
    long long value
)
internal:
GeoLookupHit(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> GeoLookupHit
new :
        src : string *
        value : int64 -> GeoLookupHit

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
GeoLookupHit Class
GeoLookupHit Members
NFX.Wave.Instrumentation Namespace


GeoLookupHit Fields

GeoLookupHit Fields NFX Class Library

The GeoLookupHit type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
GeoLookupHit Class
NFX.Wave.Instrumentation Namespace


GeoLookupHit Methods

GeoLookupHit Methods NFX Class Library

The GeoLookupHit type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GeoLookupHit Class
NFX.Wave.Instrumentation Namespace


GeoLookupHit.MakeAggregateInstance Method

GeoLookupHit MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
GeoLookupHit Class
GeoLookupHit Members
NFX.Wave.Instrumentation Namespace


GeoLookupHit Properties

GeoLookupHit Properties NFX Class Library

The GeoLookupHit type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
GeoLookupHit Class
NFX.Wave.Instrumentation Namespace


GeoLookupHit.Description Property

GeoLookupHit Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
GeoLookupHit Class
GeoLookupHit Members
NFX.Wave.Instrumentation Namespace


GeoLookupHit.ValueUnitName Property

GeoLookupHit ValueUnitName Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
GeoLookupHit Class
GeoLookupHit Members
NFX.Wave.Instrumentation Namespace


ServerAcceptSemaphoreCount Class

ServerAcceptSemaphoreCount Class NFX Class Library

The current level of taken request accept semaphore slots
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation ServerAcceptSemaphoreCount

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerAcceptSemaphoreCount : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ServerAcceptSemaphoreCount : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerAcceptSemaphoreCount
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass,
    IInstrumentClass
<SerializableAttribute>
Public Class ServerAcceptSemaphoreCount
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass,
    IInstrumentClass
[SerializableAttribute]
public ref class ServerAcceptSemaphoreCount : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerAcceptSemaphoreCount : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ServerAcceptSemaphoreCount =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface ICPUInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerAcceptSemaphoreCount =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface ICPUInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerAcceptSemaphoreCount Members
NFX.Wave.Instrumentation Namespace


ServerAcceptSemaphoreCount Members

ServerAcceptSemaphoreCount Members NFX Class Library

The ServerAcceptSemaphoreCount type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerAcceptSemaphoreCount | Initializes a new instance of the ServerAcceptSemaphoreCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerAcceptSemaphoreCount Class
NFX.Wave.Instrumentation Namespace


ServerAcceptSemaphoreCount Constructor

ServerAcceptSemaphoreCount Constructor NFX Class Library

Initializes a new instance of the ServerAcceptSemaphoreCount class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ServerAcceptSemaphoreCount(
    string src,
    long value
)
internal ServerAcceptSemaphoreCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
ServerAcceptSemaphoreCount(
    String^ src,
    long long value
)
internal:
ServerAcceptSemaphoreCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerAcceptSemaphoreCount
new :
        src : string *
        value : int64 -> ServerAcceptSemaphoreCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerAcceptSemaphoreCount Class
ServerAcceptSemaphoreCount Members
NFX.Wave.Instrumentation Namespace


ServerAcceptSemaphoreCount Fields

ServerAcceptSemaphoreCount Fields NFX Class Library

The ServerAcceptSemaphoreCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerAcceptSemaphoreCount Class
NFX.Wave.Instrumentation Namespace


ServerAcceptSemaphoreCount Methods

ServerAcceptSemaphoreCount Methods NFX Class Library

The ServerAcceptSemaphoreCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerAcceptSemaphoreCount Class
NFX.Wave.Instrumentation Namespace


ServerAcceptSemaphoreCount.MakeAggregateInstance Method

ServerAcceptSemaphoreCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerAcceptSemaphoreCount Class
ServerAcceptSemaphoreCount Members
NFX.Wave.Instrumentation Namespace


ServerAcceptSemaphoreCount Properties

ServerAcceptSemaphoreCount Properties NFX Class Library

The ServerAcceptSemaphoreCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerAcceptSemaphoreCount Class
NFX.Wave.Instrumentation Namespace


ServerAcceptSemaphoreCount.Description Property

ServerAcceptSemaphoreCount Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerAcceptSemaphoreCount Class
ServerAcceptSemaphoreCount Members
NFX.Wave.Instrumentation Namespace


ServerAcceptSemaphoreCount.ValueUnitName Property

ServerAcceptSemaphoreCount ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerAcceptSemaphoreCount Class
ServerAcceptSemaphoreCount Members
NFX.Wave.Instrumentation Namespace


ServerGateDenial Class

ServerGateDenial Class NFX Class Library

Provides request count that were denied by the server gate
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation ServerGateDenial

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerGateDenial : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ISecurityInstrument, IOperationClass, IWarningInstrument,
    IProblemClass, IInstrumentClass
[SerializableAttribute]
public class ServerGateDenial : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ISecurityInstrument, IOperationClass, IWarningInstrument,
    IProblemClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerGateDenial
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, ISecurityInstrument, IOperationClass,
    IWarningInstrument, IProblemClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerGateDenial
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, ISecurityInstrument, IOperationClass,
    IWarningInstrument, IProblemClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerGateDenial : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ISecurityInstrument, IOperationClass, IWarningInstrument,
    IProblemClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerGateDenial : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ISecurityInstrument, IOperationClass, IWarningInstrument,
    IProblemClass, IInstrumentClass
[<SerializableAttribute>]
type ServerGateDenial =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface ISecurityInstrument
        interface IOperationClass
        interface IWarningInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerGateDenial =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface ISecurityInstrument
        interface IOperationClass
        interface IWarningInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
See Also
ServerGateDenial Members
NFX.Wave.Instrumentation Namespace


ServerGateDenial Members

ServerGateDenial Members NFX Class Library

The ServerGateDenial type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerGateDenial | Initializes a new instance of the ServerGateDenial class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerGateDenial Class
NFX.Wave.Instrumentation Namespace


ServerGateDenial Constructor

ServerGateDenial Constructor NFX Class Library

Initializes a new instance of the ServerGateDenial class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ServerGateDenial(
    string src,
    long value
)
internal ServerGateDenial(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
ServerGateDenial(
    String^ src,
    long long value
)
internal:
ServerGateDenial(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerGateDenial
new :
        src : string *
        value : int64 -> ServerGateDenial

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerGateDenial Class
ServerGateDenial Members
NFX.Wave.Instrumentation Namespace


ServerGateDenial Fields

ServerGateDenial Fields NFX Class Library

The ServerGateDenial type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerGateDenial Class
NFX.Wave.Instrumentation Namespace


ServerGateDenial Methods

ServerGateDenial Methods NFX Class Library

The ServerGateDenial type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerGateDenial Class
NFX.Wave.Instrumentation Namespace


ServerGateDenial.MakeAggregateInstance Method

ServerGateDenial MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerGateDenial Class
ServerGateDenial Members
NFX.Wave.Instrumentation Namespace


ServerGateDenial Properties

ServerGateDenial Properties NFX Class Library

The ServerGateDenial type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerGateDenial Class
NFX.Wave.Instrumentation Namespace


ServerGateDenial.Description Property

ServerGateDenial Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerGateDenial Class
ServerGateDenial Members
NFX.Wave.Instrumentation Namespace


ServerGateDenial.ValueUnitName Property

ServerGateDenial ValueUnitName Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerGateDenial Class
ServerGateDenial Members
NFX.Wave.Instrumentation Namespace


ServerHandleException Class

ServerHandleException Class NFX Class Library

Provides the count of exceptions that server had to handle as no other memebr of processing chain did
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation ServerHandleException

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerHandleException : WaveLongGauge,
    IErrorInstrument, IProblemClass, IInstrumentClass
[SerializableAttribute]
public class ServerHandleException : WaveLongGauge,
    IErrorInstrument, IProblemClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerHandleException
    Inherits WaveLongGauge
    Implements IErrorInstrument, IProblemClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerHandleException
    Inherits WaveLongGauge
    Implements IErrorInstrument, IProblemClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerHandleException : public WaveLongGauge,
    IErrorInstrument, IProblemClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerHandleException : public WaveLongGauge,
    IErrorInstrument, IProblemClass, IInstrumentClass
[<SerializableAttribute>]
type ServerHandleException =
    class
        inherit WaveLongGauge
        interface IErrorInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerHandleException =
    class
        inherit WaveLongGauge
        interface IErrorInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
See Also
ServerHandleException Members
NFX.Wave.Instrumentation Namespace


ServerHandleException Members

ServerHandleException Members NFX Class Library

The ServerHandleException type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerHandleException | Initializes a new instance of the ServerHandleException class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerHandleException Class
NFX.Wave.Instrumentation Namespace


ServerHandleException Constructor

ServerHandleException Constructor NFX Class Library

Initializes a new instance of the ServerHandleException class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ServerHandleException(
    string src,
    long value
)
internal ServerHandleException(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
ServerHandleException(
    String^ src,
    long long value
)
internal:
ServerHandleException(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerHandleException
new :
        src : string *
        value : int64 -> ServerHandleException

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerHandleException Class
ServerHandleException Members
NFX.Wave.Instrumentation Namespace


ServerHandleException Fields

ServerHandleException Fields NFX Class Library

The ServerHandleException type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerHandleException Class
NFX.Wave.Instrumentation Namespace


ServerHandleException Methods

ServerHandleException Methods NFX Class Library

The ServerHandleException type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerHandleException Class
NFX.Wave.Instrumentation Namespace


ServerHandleException.MakeAggregateInstance Method

ServerHandleException MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerHandleException Class
ServerHandleException Members
NFX.Wave.Instrumentation Namespace


ServerHandleException Properties

ServerHandleException Properties NFX Class Library

The ServerHandleException type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerHandleException Class
NFX.Wave.Instrumentation Namespace


ServerHandleException.Description Property

ServerHandleException Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerHandleException Class
ServerHandleException Members
NFX.Wave.Instrumentation Namespace


ServerHandleException.ValueUnitName Property

ServerHandleException ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerHandleException Class
ServerHandleException Members
NFX.Wave.Instrumentation Namespace


ServerPortalRequest Class

ServerPortalRequest Class NFX Class Library

Provides request count received by server portal
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation ServerPortalRequest

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerPortalRequest : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ServerPortalRequest : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerPortalRequest
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerPortalRequest
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerPortalRequest : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerPortalRequest : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ServerPortalRequest =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerPortalRequest =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerPortalRequest Members
NFX.Wave.Instrumentation Namespace


ServerPortalRequest Members

ServerPortalRequest Members NFX Class Library

The ServerPortalRequest type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerPortalRequest | Initializes a new instance of the ServerPortalRequest class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerPortalRequest Class
NFX.Wave.Instrumentation Namespace


ServerPortalRequest Constructor

ServerPortalRequest Constructor NFX Class Library

Initializes a new instance of the ServerPortalRequest class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ServerPortalRequest(
    string src,
    long value
)
internal ServerPortalRequest(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
ServerPortalRequest(
    String^ src,
    long long value
)
internal:
ServerPortalRequest(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerPortalRequest
new :
        src : string *
        value : int64 -> ServerPortalRequest

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerPortalRequest Class
ServerPortalRequest Members
NFX.Wave.Instrumentation Namespace


ServerPortalRequest Fields

ServerPortalRequest Fields NFX Class Library

The ServerPortalRequest type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerPortalRequest Class
NFX.Wave.Instrumentation Namespace


ServerPortalRequest Methods

ServerPortalRequest Methods NFX Class Library

The ServerPortalRequest type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerPortalRequest Class
NFX.Wave.Instrumentation Namespace


ServerPortalRequest.MakeAggregateInstance Method

ServerPortalRequest MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerPortalRequest Class
ServerPortalRequest Members
NFX.Wave.Instrumentation Namespace


ServerPortalRequest Properties

ServerPortalRequest Properties NFX Class Library

The ServerPortalRequest type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerPortalRequest Class
NFX.Wave.Instrumentation Namespace


ServerPortalRequest.Description Property

ServerPortalRequest Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerPortalRequest Class
ServerPortalRequest Members
NFX.Wave.Instrumentation Namespace


ServerPortalRequest.ValueUnitName Property

ServerPortalRequest ValueUnitName Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerPortalRequest Class
ServerPortalRequest Members
NFX.Wave.Instrumentation Namespace


ServerRequest Class

ServerRequest Class NFX Class Library

Provides request count received by server
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation ServerRequest

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerRequest : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ServerRequest : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerRequest
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerRequest
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerRequest : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerRequest : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ServerRequest =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerRequest =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerRequest Members
NFX.Wave.Instrumentation Namespace


ServerRequest Members

ServerRequest Members NFX Class Library

The ServerRequest type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerRequest | Initializes a new instance of the ServerRequest class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerRequest Class
NFX.Wave.Instrumentation Namespace


ServerRequest Constructor

ServerRequest Constructor NFX Class Library

Initializes a new instance of the ServerRequest class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ServerRequest(
    string src,
    long value
)
internal ServerRequest(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
ServerRequest(
    String^ src,
    long long value
)
internal:
ServerRequest(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerRequest
new :
        src : string *
        value : int64 -> ServerRequest

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerRequest Class
ServerRequest Members
NFX.Wave.Instrumentation Namespace


ServerRequest Fields

ServerRequest Fields NFX Class Library

The ServerRequest type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerRequest Class
NFX.Wave.Instrumentation Namespace


ServerRequest Methods

ServerRequest Methods NFX Class Library

The ServerRequest type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerRequest Class
NFX.Wave.Instrumentation Namespace


ServerRequest.MakeAggregateInstance Method

ServerRequest MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerRequest Class
ServerRequest Members
NFX.Wave.Instrumentation Namespace


ServerRequest Properties

ServerRequest Properties NFX Class Library

The ServerRequest type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerRequest Class
NFX.Wave.Instrumentation Namespace


ServerRequest.Description Property

ServerRequest Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerRequest Class
ServerRequest Members
NFX.Wave.Instrumentation Namespace


ServerRequest.ValueUnitName Property

ServerRequest ValueUnitName Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerRequest Class
ServerRequest Members
NFX.Wave.Instrumentation Namespace


ServerWorkSemaphoreCount Class

ServerWorkSemaphoreCount Class NFX Class Library

The current level of taken request work semaphore slots
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation ServerWorkSemaphoreCount

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerWorkSemaphoreCount : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ServerWorkSemaphoreCount : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerWorkSemaphoreCount
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass,
    IInstrumentClass
<SerializableAttribute>
Public Class ServerWorkSemaphoreCount
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass,
    IInstrumentClass
[SerializableAttribute]
public ref class ServerWorkSemaphoreCount : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerWorkSemaphoreCount : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ServerWorkSemaphoreCount =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface ICPUInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerWorkSemaphoreCount =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface ICPUInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerWorkSemaphoreCount Members
NFX.Wave.Instrumentation Namespace


ServerWorkSemaphoreCount Members

ServerWorkSemaphoreCount Members NFX Class Library

The ServerWorkSemaphoreCount type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerWorkSemaphoreCount | Initializes a new instance of the ServerWorkSemaphoreCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerWorkSemaphoreCount Class
NFX.Wave.Instrumentation Namespace


ServerWorkSemaphoreCount Constructor

ServerWorkSemaphoreCount Constructor NFX Class Library

Initializes a new instance of the ServerWorkSemaphoreCount class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ServerWorkSemaphoreCount(
    string src,
    long value
)
internal ServerWorkSemaphoreCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
ServerWorkSemaphoreCount(
    String^ src,
    long long value
)
internal:
ServerWorkSemaphoreCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerWorkSemaphoreCount
new :
        src : string *
        value : int64 -> ServerWorkSemaphoreCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerWorkSemaphoreCount Class
ServerWorkSemaphoreCount Members
NFX.Wave.Instrumentation Namespace


ServerWorkSemaphoreCount Fields

ServerWorkSemaphoreCount Fields NFX Class Library

The ServerWorkSemaphoreCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerWorkSemaphoreCount Class
NFX.Wave.Instrumentation Namespace


ServerWorkSemaphoreCount Methods

ServerWorkSemaphoreCount Methods NFX Class Library

The ServerWorkSemaphoreCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerWorkSemaphoreCount Class
NFX.Wave.Instrumentation Namespace


ServerWorkSemaphoreCount.MakeAggregateInstance Method

ServerWorkSemaphoreCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerWorkSemaphoreCount Class
ServerWorkSemaphoreCount Members
NFX.Wave.Instrumentation Namespace


ServerWorkSemaphoreCount Properties

ServerWorkSemaphoreCount Properties NFX Class Library

The ServerWorkSemaphoreCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerWorkSemaphoreCount Class
NFX.Wave.Instrumentation Namespace


ServerWorkSemaphoreCount.Description Property

ServerWorkSemaphoreCount Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerWorkSemaphoreCount Class
ServerWorkSemaphoreCount Members
NFX.Wave.Instrumentation Namespace


ServerWorkSemaphoreCount.ValueUnitName Property

ServerWorkSemaphoreCount ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerWorkSemaphoreCount Class
ServerWorkSemaphoreCount Members
NFX.Wave.Instrumentation Namespace


SessionEnd Class

SessionEnd Class NFX Class Library

How many sessions ended by request
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation SessionEnd

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SessionEnd : WaveLongGauge
[SerializableAttribute]
public class SessionEnd : WaveLongGauge
<SerializableAttribute>
Public Class SessionEnd
    Inherits WaveLongGauge
<SerializableAttribute>
Public Class SessionEnd
    Inherits WaveLongGauge
[SerializableAttribute]
public ref class SessionEnd : public WaveLongGauge
[SerializableAttribute]
public ref class SessionEnd : public WaveLongGauge
[<SerializableAttribute>]
type SessionEnd =
    class
        inherit WaveLongGauge
    end
[<SerializableAttribute>]
type SessionEnd =
    class
        inherit WaveLongGauge
    end
See Also
SessionEnd Members
NFX.Wave.Instrumentation Namespace


SessionEnd Members

SessionEnd Members NFX Class Library

The SessionEnd type exposes the following members.
Constructors
 | Name | Description
Protected method | SessionEnd | Initializes a new instance of the SessionEnd class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SessionEnd Class
NFX.Wave.Instrumentation Namespace


SessionEnd Constructor

SessionEnd Constructor NFX Class Library

Initializes a new instance of the SessionEnd class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal SessionEnd(
    string src,
    long value
)
internal SessionEnd(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
SessionEnd(
    String^ src,
    long long value
)
internal:
SessionEnd(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> SessionEnd
new :
        src : string *
        value : int64 -> SessionEnd

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
SessionEnd Class
SessionEnd Members
NFX.Wave.Instrumentation Namespace


SessionEnd Fields

SessionEnd Fields NFX Class Library

The SessionEnd type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
SessionEnd Class
NFX.Wave.Instrumentation Namespace


SessionEnd Methods

SessionEnd Methods NFX Class Library

The SessionEnd type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SessionEnd Class
NFX.Wave.Instrumentation Namespace


SessionEnd.MakeAggregateInstance Method

SessionEnd MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
SessionEnd Class
SessionEnd Members
NFX.Wave.Instrumentation Namespace


SessionEnd Properties

SessionEnd Properties NFX Class Library

The SessionEnd type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SessionEnd Class
NFX.Wave.Instrumentation Namespace


SessionEnd.Description Property

SessionEnd Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
SessionEnd Class
SessionEnd Members
NFX.Wave.Instrumentation Namespace


SessionEnd.ValueUnitName Property

SessionEnd ValueUnitName Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
SessionEnd Class
SessionEnd Members
NFX.Wave.Instrumentation Namespace


SessionExisting Class

SessionExisting Class NFX Class Library

How many existing sessions found
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation SessionExisting

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SessionExisting : WaveLongGauge
[SerializableAttribute]
public class SessionExisting : WaveLongGauge
<SerializableAttribute>
Public Class SessionExisting
    Inherits WaveLongGauge
<SerializableAttribute>
Public Class SessionExisting
    Inherits WaveLongGauge
[SerializableAttribute]
public ref class SessionExisting : public WaveLongGauge
[SerializableAttribute]
public ref class SessionExisting : public WaveLongGauge
[<SerializableAttribute>]
type SessionExisting =
    class
        inherit WaveLongGauge
    end
[<SerializableAttribute>]
type SessionExisting =
    class
        inherit WaveLongGauge
    end
See Also
SessionExisting Members
NFX.Wave.Instrumentation Namespace


SessionExisting Members

SessionExisting Members NFX Class Library

The SessionExisting type exposes the following members.
Constructors
 | Name | Description
Protected method | SessionExisting | Initializes a new instance of the SessionExisting class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SessionExisting Class
NFX.Wave.Instrumentation Namespace


SessionExisting Constructor

SessionExisting Constructor NFX Class Library

Initializes a new instance of the SessionExisting class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal SessionExisting(
    string src,
    long value
)
internal SessionExisting(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
SessionExisting(
    String^ src,
    long long value
)
internal:
SessionExisting(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> SessionExisting
new :
        src : string *
        value : int64 -> SessionExisting

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
SessionExisting Class
SessionExisting Members
NFX.Wave.Instrumentation Namespace


SessionExisting Fields

SessionExisting Fields NFX Class Library

The SessionExisting type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
SessionExisting Class
NFX.Wave.Instrumentation Namespace


SessionExisting Methods

SessionExisting Methods NFX Class Library

The SessionExisting type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SessionExisting Class
NFX.Wave.Instrumentation Namespace


SessionExisting.MakeAggregateInstance Method

SessionExisting MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
SessionExisting Class
SessionExisting Members
NFX.Wave.Instrumentation Namespace


SessionExisting Properties

SessionExisting Properties NFX Class Library

The SessionExisting type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SessionExisting Class
NFX.Wave.Instrumentation Namespace


SessionExisting.Description Property

SessionExisting Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
SessionExisting Class
SessionExisting Members
NFX.Wave.Instrumentation Namespace


SessionExisting.ValueUnitName Property

SessionExisting ValueUnitName Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
SessionExisting Class
SessionExisting Members
NFX.Wave.Instrumentation Namespace


SessionInvalidID Class

SessionInvalidID Class NFX Class Library

How many sessions supplied invalid identifier (by client)
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation SessionInvalidID

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SessionInvalidID : WaveLongGauge
[SerializableAttribute]
public class SessionInvalidID : WaveLongGauge
<SerializableAttribute>
Public Class SessionInvalidID
    Inherits WaveLongGauge
<SerializableAttribute>
Public Class SessionInvalidID
    Inherits WaveLongGauge
[SerializableAttribute]
public ref class SessionInvalidID : public WaveLongGauge
[SerializableAttribute]
public ref class SessionInvalidID : public WaveLongGauge
[<SerializableAttribute>]
type SessionInvalidID =
    class
        inherit WaveLongGauge
    end
[<SerializableAttribute>]
type SessionInvalidID =
    class
        inherit WaveLongGauge
    end
See Also
SessionInvalidID Members
NFX.Wave.Instrumentation Namespace


SessionInvalidID Members

SessionInvalidID Members NFX Class Library

The SessionInvalidID type exposes the following members.
Constructors
 | Name | Description
Protected method | SessionInvalidID | Initializes a new instance of the SessionInvalidID class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SessionInvalidID Class
NFX.Wave.Instrumentation Namespace


SessionInvalidID Constructor

SessionInvalidID Constructor NFX Class Library

Initializes a new instance of the SessionInvalidID class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal SessionInvalidID(
    string src,
    long value
)
internal SessionInvalidID(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
SessionInvalidID(
    String^ src,
    long long value
)
internal:
SessionInvalidID(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> SessionInvalidID
new :
        src : string *
        value : int64 -> SessionInvalidID

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
SessionInvalidID Class
SessionInvalidID Members
NFX.Wave.Instrumentation Namespace


SessionInvalidID Fields

SessionInvalidID Fields NFX Class Library

The SessionInvalidID type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
SessionInvalidID Class
NFX.Wave.Instrumentation Namespace


SessionInvalidID Methods

SessionInvalidID Methods NFX Class Library

The SessionInvalidID type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SessionInvalidID Class
NFX.Wave.Instrumentation Namespace


SessionInvalidID.MakeAggregateInstance Method

SessionInvalidID MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
SessionInvalidID Class
SessionInvalidID Members
NFX.Wave.Instrumentation Namespace


SessionInvalidID Properties

SessionInvalidID Properties NFX Class Library

The SessionInvalidID type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SessionInvalidID Class
NFX.Wave.Instrumentation Namespace


SessionInvalidID.Description Property

SessionInvalidID Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
SessionInvalidID Class
SessionInvalidID Members
NFX.Wave.Instrumentation Namespace


SessionInvalidID.ValueUnitName Property

SessionInvalidID ValueUnitName Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
SessionInvalidID Class
SessionInvalidID Members
NFX.Wave.Instrumentation Namespace


SessionNew Class

SessionNew Class NFX Class Library

How many new sessions created
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation SessionNew

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SessionNew : WaveLongGauge
[SerializableAttribute]
public class SessionNew : WaveLongGauge
<SerializableAttribute>
Public Class SessionNew
    Inherits WaveLongGauge
<SerializableAttribute>
Public Class SessionNew
    Inherits WaveLongGauge
[SerializableAttribute]
public ref class SessionNew : public WaveLongGauge
[SerializableAttribute]
public ref class SessionNew : public WaveLongGauge
[<SerializableAttribute>]
type SessionNew =
    class
        inherit WaveLongGauge
    end
[<SerializableAttribute>]
type SessionNew =
    class
        inherit WaveLongGauge
    end
See Also
SessionNew Members
NFX.Wave.Instrumentation Namespace


SessionNew Members

SessionNew Members NFX Class Library

The SessionNew type exposes the following members.
Constructors
 | Name | Description
Protected method | SessionNew | Initializes a new instance of the SessionNew class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SessionNew Class
NFX.Wave.Instrumentation Namespace


SessionNew Constructor

SessionNew Constructor NFX Class Library

Initializes a new instance of the SessionNew class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal SessionNew(
    string src,
    long value
)
internal SessionNew(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
SessionNew(
    String^ src,
    long long value
)
internal:
SessionNew(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> SessionNew
new :
        src : string *
        value : int64 -> SessionNew

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
SessionNew Class
SessionNew Members
NFX.Wave.Instrumentation Namespace


SessionNew Fields

SessionNew Fields NFX Class Library

The SessionNew type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
SessionNew Class
NFX.Wave.Instrumentation Namespace


SessionNew Methods

SessionNew Methods NFX Class Library

The SessionNew type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SessionNew Class
NFX.Wave.Instrumentation Namespace


SessionNew.MakeAggregateInstance Method

SessionNew MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
SessionNew Class
SessionNew Members
NFX.Wave.Instrumentation Namespace


SessionNew Properties

SessionNew Properties NFX Class Library

The SessionNew type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SessionNew Class
NFX.Wave.Instrumentation Namespace


SessionNew.Description Property

SessionNew Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
SessionNew Class
SessionNew Members
NFX.Wave.Instrumentation Namespace


SessionNew.ValueUnitName Property

SessionNew ValueUnitName Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
SessionNew Class
SessionNew Members
NFX.Wave.Instrumentation Namespace


WaveDoubleGauge Class

WaveDoubleGauge Class NFX Class Library

Provides base for Wave double gauges
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation DoubleGauge
NFX.Wave.Instrumentation WaveDoubleGauge

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class WaveDoubleGauge : DoubleGauge,
    IWebInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public abstract class WaveDoubleGauge : DoubleGauge,
    IWebInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class WaveDoubleGauge
    Inherits DoubleGauge
    Implements IWebInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class WaveDoubleGauge
    Inherits DoubleGauge
    Implements IWebInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class WaveDoubleGauge abstract : public DoubleGauge,
    IWebInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class WaveDoubleGauge abstract : public DoubleGauge,
    IWebInstrument, IOperationClass, IInstrumentClass
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type WaveDoubleGauge =
    class
        inherit DoubleGauge
        interface IWebInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type WaveDoubleGauge =
    class
        inherit DoubleGauge
        interface IWebInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
WaveDoubleGauge Members
NFX.Wave.Instrumentation Namespace


WaveDoubleGauge Members

WaveDoubleGauge Members NFX Class Library

The WaveDoubleGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | WaveDoubleGauge | Initializes a new instance of the WaveDoubleGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Inherited from DoubleGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WaveDoubleGauge Class
NFX.Wave.Instrumentation Namespace


WaveDoubleGauge Constructor

WaveDoubleGauge Constructor NFX Class Library

Initializes a new instance of the WaveDoubleGauge class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected WaveDoubleGauge(
    string src,
    double value
)
protected WaveDoubleGauge(
    string src,
    double value
)
Protected Sub New (
    src As String,
    value As Double
)
Protected Sub New (
    src As String,
    value As Double
)
protected:
WaveDoubleGauge(
    String^ src,
    double value
)
protected:
WaveDoubleGauge(
    String^ src,
    double value
)
new :
        src : string *
        value : float -> WaveDoubleGauge
new :
        src : string *
        value : float -> WaveDoubleGauge

Parameters

src
Type: Online System String
value
Type: Online System Double
See Also
WaveDoubleGauge Class
WaveDoubleGauge Members
NFX.Wave.Instrumentation Namespace


WaveDoubleGauge Fields

WaveDoubleGauge Fields NFX Class Library

The WaveDoubleGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
WaveDoubleGauge Class
NFX.Wave.Instrumentation Namespace


WaveDoubleGauge Methods

WaveDoubleGauge Methods NFX Class Library

The WaveDoubleGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WaveDoubleGauge Class
NFX.Wave.Instrumentation Namespace


WaveDoubleGauge Properties

WaveDoubleGauge Properties NFX Class Library

The WaveDoubleGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Inherited from DoubleGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WaveDoubleGauge Class
NFX.Wave.Instrumentation Namespace


WaveLongGauge Class

WaveLongGauge Class NFX Class Library

Provides base for Wave long gauges
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation FilterHandleException
NFX.Wave.Instrumentation GeoLookup
NFX.Wave.Instrumentation GeoLookupHit
NFX.Wave.Instrumentation ServerAcceptSemaphoreCount
NFX.Wave.Instrumentation ServerGateDenial
NFX.Wave.Instrumentation ServerHandleException
NFX.Wave.Instrumentation ServerPortalRequest
NFX.Wave.Instrumentation ServerRequest
NFX.Wave.Instrumentation ServerWorkSemaphoreCount
NFX.Wave.Instrumentation SessionEnd
NFX.Wave.Instrumentation SessionExisting
NFX.Wave.Instrumentation SessionInvalidID
NFX.Wave.Instrumentation SessionNew
NFX.Wave.Instrumentation WorkContextAborted
NFX.Wave.Instrumentation WorkContextBufferedResponse
NFX.Wave.Instrumentation WorkContextBufferedResponseBytes
NFX.Wave.Instrumentation WorkContextCtor
NFX.Wave.Instrumentation WorkContextDctor
NFX.Wave.Instrumentation WorkContextHandled
NFX.Wave.Instrumentation WorkContextNeedsSession
NFX.Wave.Instrumentation WorkContextNoDefaultClose
NFX.Wave.Instrumentation WorkContextWorkSemaphoreRelease
NFX.Wave.Instrumentation WorkContextWrittenResponse

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class WaveLongGauge : LongGauge,
    IWebInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public abstract class WaveLongGauge : LongGauge,
    IWebInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class WaveLongGauge
    Inherits LongGauge
    Implements IWebInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class WaveLongGauge
    Inherits LongGauge
    Implements IWebInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class WaveLongGauge abstract : public LongGauge,
    IWebInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class WaveLongGauge abstract : public LongGauge,
    IWebInstrument, IOperationClass, IInstrumentClass
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type WaveLongGauge =
    class
        inherit LongGauge
        interface IWebInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type WaveLongGauge =
    class
        inherit LongGauge
        interface IWebInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
WaveLongGauge Members
NFX.Wave.Instrumentation Namespace


WaveLongGauge Members

WaveLongGauge Members NFX Class Library

The WaveLongGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | WaveLongGauge | Initializes a new instance of the WaveLongGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WaveLongGauge Class
NFX.Wave.Instrumentation Namespace


WaveLongGauge Constructor

WaveLongGauge Constructor NFX Class Library

Initializes a new instance of the WaveLongGauge class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected WaveLongGauge(
    string src,
    long value
)
protected WaveLongGauge(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
WaveLongGauge(
    String^ src,
    long long value
)
protected:
WaveLongGauge(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> WaveLongGauge
new :
        src : string *
        value : int64 -> WaveLongGauge

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
WaveLongGauge Class
WaveLongGauge Members
NFX.Wave.Instrumentation Namespace


WaveLongGauge Fields

WaveLongGauge Fields NFX Class Library

The WaveLongGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
WaveLongGauge Class
NFX.Wave.Instrumentation Namespace


WaveLongGauge Methods

WaveLongGauge Methods NFX Class Library

The WaveLongGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WaveLongGauge Class
NFX.Wave.Instrumentation Namespace


WaveLongGauge Properties

WaveLongGauge Properties NFX Class Library

The WaveLongGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WaveLongGauge Class
NFX.Wave.Instrumentation Namespace


WorkContextAborted Class

WorkContextAborted Class NFX Class Library

How many work contexts got aborted
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation WorkContextAborted

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WorkContextAborted : WaveLongGauge
[SerializableAttribute]
public class WorkContextAborted : WaveLongGauge
<SerializableAttribute>
Public Class WorkContextAborted
    Inherits WaveLongGauge
<SerializableAttribute>
Public Class WorkContextAborted
    Inherits WaveLongGauge
[SerializableAttribute]
public ref class WorkContextAborted : public WaveLongGauge
[SerializableAttribute]
public ref class WorkContextAborted : public WaveLongGauge
[<SerializableAttribute>]
type WorkContextAborted =
    class
        inherit WaveLongGauge
    end
[<SerializableAttribute>]
type WorkContextAborted =
    class
        inherit WaveLongGauge
    end
See Also
WorkContextAborted Members
NFX.Wave.Instrumentation Namespace


WorkContextAborted Members

WorkContextAborted Members NFX Class Library

The WorkContextAborted type exposes the following members.
Constructors
 | Name | Description
Protected method | WorkContextAborted | Initializes a new instance of the WorkContextAborted class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextAborted Class
NFX.Wave.Instrumentation Namespace


WorkContextAborted Constructor

WorkContextAborted Constructor NFX Class Library

Initializes a new instance of the WorkContextAborted class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WorkContextAborted(
    string src,
    long value
)
internal WorkContextAborted(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
WorkContextAborted(
    String^ src,
    long long value
)
internal:
WorkContextAborted(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> WorkContextAborted
new :
        src : string *
        value : int64 -> WorkContextAborted

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
WorkContextAborted Class
WorkContextAborted Members
NFX.Wave.Instrumentation Namespace


WorkContextAborted Fields

WorkContextAborted Fields NFX Class Library

The WorkContextAborted type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
WorkContextAborted Class
NFX.Wave.Instrumentation Namespace


WorkContextAborted Methods

WorkContextAborted Methods NFX Class Library

The WorkContextAborted type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkContextAborted Class
NFX.Wave.Instrumentation Namespace


WorkContextAborted.MakeAggregateInstance Method

WorkContextAborted MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
WorkContextAborted Class
WorkContextAborted Members
NFX.Wave.Instrumentation Namespace


WorkContextAborted Properties

WorkContextAborted Properties NFX Class Library

The WorkContextAborted type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextAborted Class
NFX.Wave.Instrumentation Namespace


WorkContextAborted.Description Property

WorkContextAborted Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
WorkContextAborted Class
WorkContextAborted Members
NFX.Wave.Instrumentation Namespace


WorkContextAborted.ValueUnitName Property

WorkContextAborted ValueUnitName Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
WorkContextAborted Class
WorkContextAborted Members
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponse Class

WorkContextBufferedResponse Class NFX Class Library

How many response object were buffered
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation WorkContextBufferedResponse

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WorkContextBufferedResponse : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class WorkContextBufferedResponse : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class WorkContextBufferedResponse
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, IMemoryInstrument, IOperationClass,
    IInstrumentClass
<SerializableAttribute>
Public Class WorkContextBufferedResponse
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, IMemoryInstrument, IOperationClass,
    IInstrumentClass
[SerializableAttribute]
public ref class WorkContextBufferedResponse : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class WorkContextBufferedResponse : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IMemoryInstrument, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type WorkContextBufferedResponse =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type WorkContextBufferedResponse =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
WorkContextBufferedResponse Members
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponse Members

WorkContextBufferedResponse Members NFX Class Library

The WorkContextBufferedResponse type exposes the following members.
Constructors
 | Name | Description
Protected method | WorkContextBufferedResponse | Initializes a new instance of the WorkContextBufferedResponse class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextBufferedResponse Class
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponse Constructor

WorkContextBufferedResponse Constructor NFX Class Library

Initializes a new instance of the WorkContextBufferedResponse class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WorkContextBufferedResponse(
    string src,
    long value
)
internal WorkContextBufferedResponse(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
WorkContextBufferedResponse(
    String^ src,
    long long value
)
internal:
WorkContextBufferedResponse(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> WorkContextBufferedResponse
new :
        src : string *
        value : int64 -> WorkContextBufferedResponse

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
WorkContextBufferedResponse Class
WorkContextBufferedResponse Members
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponse Fields

WorkContextBufferedResponse Fields NFX Class Library

The WorkContextBufferedResponse type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
WorkContextBufferedResponse Class
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponse Methods

WorkContextBufferedResponse Methods NFX Class Library

The WorkContextBufferedResponse type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkContextBufferedResponse Class
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponse.MakeAggregateInstance Method

WorkContextBufferedResponse MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
WorkContextBufferedResponse Class
WorkContextBufferedResponse Members
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponse Properties

WorkContextBufferedResponse Properties NFX Class Library

The WorkContextBufferedResponse type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextBufferedResponse Class
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponse.Description Property

WorkContextBufferedResponse Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
WorkContextBufferedResponse Class
WorkContextBufferedResponse Members
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponse.ValueUnitName Property

WorkContextBufferedResponse ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
WorkContextBufferedResponse Class
WorkContextBufferedResponse Members
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponseBytes Class

WorkContextBufferedResponseBytes Class NFX Class Library

How many response bytes were buffered
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation WorkContextBufferedResponseBytes

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WorkContextBufferedResponseBytes : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class WorkContextBufferedResponseBytes : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class WorkContextBufferedResponseBytes
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, IMemoryInstrument, IOperationClass,
    IInstrumentClass
<SerializableAttribute>
Public Class WorkContextBufferedResponseBytes
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, IMemoryInstrument, IOperationClass,
    IInstrumentClass
[SerializableAttribute]
public ref class WorkContextBufferedResponseBytes : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class WorkContextBufferedResponseBytes : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IMemoryInstrument, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type WorkContextBufferedResponseBytes =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type WorkContextBufferedResponseBytes =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
WorkContextBufferedResponseBytes Members
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponseBytes Members

WorkContextBufferedResponseBytes Members NFX Class Library

The WorkContextBufferedResponseBytes type exposes the following members.
Constructors
 | Name | Description
Protected method | WorkContextBufferedResponseBytes | Initializes a new instance of the WorkContextBufferedResponseBytes class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextBufferedResponseBytes Class
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponseBytes Constructor

WorkContextBufferedResponseBytes Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WorkContextBufferedResponseBytes class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WorkContextBufferedResponseBytes(
    string src,
    long value
)
internal WorkContextBufferedResponseBytes(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
WorkContextBufferedResponseBytes(
    String^ src,
    long long value
)
internal:
WorkContextBufferedResponseBytes(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> WorkContextBufferedResponseBytes
new :
        src : string *
        value : int64 -> WorkContextBufferedResponseBytes

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
WorkContextBufferedResponseBytes Class
WorkContextBufferedResponseBytes Members
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponseBytes Fields

WorkContextBufferedResponseBytes Fields NFX Class Library

The WorkContextBufferedResponseBytes type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
WorkContextBufferedResponseBytes Class
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponseBytes Methods

WorkContextBufferedResponseBytes Methods NFX Class Library

The WorkContextBufferedResponseBytes type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkContextBufferedResponseBytes Class
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponseBytes.MakeAggregateInstance Method

WorkContextBufferedResponseBytes MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
WorkContextBufferedResponseBytes Class
WorkContextBufferedResponseBytes Members
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponseBytes Properties

WorkContextBufferedResponseBytes Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The WorkContextBufferedResponseBytes type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextBufferedResponseBytes Class
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponseBytes.Description Property

WorkContextBufferedResponseBytes Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
WorkContextBufferedResponseBytes Class
WorkContextBufferedResponseBytes Members
NFX.Wave.Instrumentation Namespace


WorkContextBufferedResponseBytes.ValueUnitName Property

WorkContextBufferedResponseBytes ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
WorkContextBufferedResponseBytes Class
WorkContextBufferedResponseBytes Members
NFX.Wave.Instrumentation Namespace


WorkContextCtor Class

WorkContextCtor Class NFX Class Library

How many work contexts were created
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation WorkContextCtor

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WorkContextCtor : WaveLongGauge
[SerializableAttribute]
public class WorkContextCtor : WaveLongGauge
<SerializableAttribute>
Public Class WorkContextCtor
    Inherits WaveLongGauge
<SerializableAttribute>
Public Class WorkContextCtor
    Inherits WaveLongGauge
[SerializableAttribute]
public ref class WorkContextCtor : public WaveLongGauge
[SerializableAttribute]
public ref class WorkContextCtor : public WaveLongGauge
[<SerializableAttribute>]
type WorkContextCtor =
    class
        inherit WaveLongGauge
    end
[<SerializableAttribute>]
type WorkContextCtor =
    class
        inherit WaveLongGauge
    end
See Also
WorkContextCtor Members
NFX.Wave.Instrumentation Namespace


WorkContextCtor Members

WorkContextCtor Members NFX Class Library

The WorkContextCtor type exposes the following members.
Constructors
 | Name | Description
Protected method | WorkContextCtor | Initializes a new instance of the WorkContextCtor class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextCtor Class
NFX.Wave.Instrumentation Namespace


WorkContextCtor Constructor

WorkContextCtor Constructor NFX Class Library

Initializes a new instance of the WorkContextCtor class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WorkContextCtor(
    string src,
    long value
)
internal WorkContextCtor(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
WorkContextCtor(
    String^ src,
    long long value
)
internal:
WorkContextCtor(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> WorkContextCtor
new :
        src : string *
        value : int64 -> WorkContextCtor

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
WorkContextCtor Class
WorkContextCtor Members
NFX.Wave.Instrumentation Namespace


WorkContextCtor Fields

WorkContextCtor Fields NFX Class Library

The WorkContextCtor type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
WorkContextCtor Class
NFX.Wave.Instrumentation Namespace


WorkContextCtor Methods

WorkContextCtor Methods NFX Class Library

The WorkContextCtor type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkContextCtor Class
NFX.Wave.Instrumentation Namespace


WorkContextCtor.MakeAggregateInstance Method

WorkContextCtor MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
WorkContextCtor Class
WorkContextCtor Members
NFX.Wave.Instrumentation Namespace


WorkContextCtor Properties

WorkContextCtor Properties NFX Class Library

The WorkContextCtor type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextCtor Class
NFX.Wave.Instrumentation Namespace


WorkContextCtor.Description Property

WorkContextCtor Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
WorkContextCtor Class
WorkContextCtor Members
NFX.Wave.Instrumentation Namespace


WorkContextCtor.ValueUnitName Property

WorkContextCtor ValueUnitName Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
WorkContextCtor Class
WorkContextCtor Members
NFX.Wave.Instrumentation Namespace


WorkContextDctor Class

WorkContextDctor Class NFX Class Library

How many work contexts were destroyed
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation WorkContextDctor

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WorkContextDctor : WaveLongGauge
[SerializableAttribute]
public class WorkContextDctor : WaveLongGauge
<SerializableAttribute>
Public Class WorkContextDctor
    Inherits WaveLongGauge
<SerializableAttribute>
Public Class WorkContextDctor
    Inherits WaveLongGauge
[SerializableAttribute]
public ref class WorkContextDctor : public WaveLongGauge
[SerializableAttribute]
public ref class WorkContextDctor : public WaveLongGauge
[<SerializableAttribute>]
type WorkContextDctor =
    class
        inherit WaveLongGauge
    end
[<SerializableAttribute>]
type WorkContextDctor =
    class
        inherit WaveLongGauge
    end
See Also
WorkContextDctor Members
NFX.Wave.Instrumentation Namespace


WorkContextDctor Members

WorkContextDctor Members NFX Class Library

The WorkContextDctor type exposes the following members.
Constructors
 | Name | Description
Protected method | WorkContextDctor | Initializes a new instance of the WorkContextDctor class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextDctor Class
NFX.Wave.Instrumentation Namespace


WorkContextDctor Constructor

WorkContextDctor Constructor NFX Class Library

Initializes a new instance of the WorkContextDctor class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WorkContextDctor(
    string src,
    long value
)
internal WorkContextDctor(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
WorkContextDctor(
    String^ src,
    long long value
)
internal:
WorkContextDctor(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> WorkContextDctor
new :
        src : string *
        value : int64 -> WorkContextDctor

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
WorkContextDctor Class
WorkContextDctor Members
NFX.Wave.Instrumentation Namespace


WorkContextDctor Fields

WorkContextDctor Fields NFX Class Library

The WorkContextDctor type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
WorkContextDctor Class
NFX.Wave.Instrumentation Namespace


WorkContextDctor Methods

WorkContextDctor Methods NFX Class Library

The WorkContextDctor type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkContextDctor Class
NFX.Wave.Instrumentation Namespace


WorkContextDctor.MakeAggregateInstance Method

WorkContextDctor MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
WorkContextDctor Class
WorkContextDctor Members
NFX.Wave.Instrumentation Namespace


WorkContextDctor Properties

WorkContextDctor Properties NFX Class Library

The WorkContextDctor type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextDctor Class
NFX.Wave.Instrumentation Namespace


WorkContextDctor.Description Property

WorkContextDctor Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
WorkContextDctor Class
WorkContextDctor Members
NFX.Wave.Instrumentation Namespace


WorkContextDctor.ValueUnitName Property

WorkContextDctor ValueUnitName Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
WorkContextDctor Class
WorkContextDctor Members
NFX.Wave.Instrumentation Namespace


WorkContextHandled Class

WorkContextHandled Class NFX Class Library

How many work contexts got handled
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation WorkContextHandled

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WorkContextHandled : WaveLongGauge
[SerializableAttribute]
public class WorkContextHandled : WaveLongGauge
<SerializableAttribute>
Public Class WorkContextHandled
    Inherits WaveLongGauge
<SerializableAttribute>
Public Class WorkContextHandled
    Inherits WaveLongGauge
[SerializableAttribute]
public ref class WorkContextHandled : public WaveLongGauge
[SerializableAttribute]
public ref class WorkContextHandled : public WaveLongGauge
[<SerializableAttribute>]
type WorkContextHandled =
    class
        inherit WaveLongGauge
    end
[<SerializableAttribute>]
type WorkContextHandled =
    class
        inherit WaveLongGauge
    end
See Also
WorkContextHandled Members
NFX.Wave.Instrumentation Namespace


WorkContextHandled Members

WorkContextHandled Members NFX Class Library

The WorkContextHandled type exposes the following members.
Constructors
 | Name | Description
Protected method | WorkContextHandled | Initializes a new instance of the WorkContextHandled class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextHandled Class
NFX.Wave.Instrumentation Namespace


WorkContextHandled Constructor

WorkContextHandled Constructor NFX Class Library

Initializes a new instance of the WorkContextHandled class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WorkContextHandled(
    string src,
    long value
)
internal WorkContextHandled(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
WorkContextHandled(
    String^ src,
    long long value
)
internal:
WorkContextHandled(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> WorkContextHandled
new :
        src : string *
        value : int64 -> WorkContextHandled

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
WorkContextHandled Class
WorkContextHandled Members
NFX.Wave.Instrumentation Namespace


WorkContextHandled Fields

WorkContextHandled Fields NFX Class Library

The WorkContextHandled type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
WorkContextHandled Class
NFX.Wave.Instrumentation Namespace


WorkContextHandled Methods

WorkContextHandled Methods NFX Class Library

The WorkContextHandled type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkContextHandled Class
NFX.Wave.Instrumentation Namespace


WorkContextHandled.MakeAggregateInstance Method

WorkContextHandled MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
WorkContextHandled Class
WorkContextHandled Members
NFX.Wave.Instrumentation Namespace


WorkContextHandled Properties

WorkContextHandled Properties NFX Class Library

The WorkContextHandled type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextHandled Class
NFX.Wave.Instrumentation Namespace


WorkContextHandled.Description Property

WorkContextHandled Description Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
WorkContextHandled Class
WorkContextHandled Members
NFX.Wave.Instrumentation Namespace


WorkContextHandled.ValueUnitName Property

WorkContextHandled ValueUnitName Property NFX Class Library

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
WorkContextHandled Class
WorkContextHandled Members
NFX.Wave.Instrumentation Namespace


WorkContextNeedsSession Class

WorkContextNeedsSession Class NFX Class Library

How many work contexts requested session state
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation WorkContextNeedsSession

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WorkContextNeedsSession : WaveLongGauge
[SerializableAttribute]
public class WorkContextNeedsSession : WaveLongGauge
<SerializableAttribute>
Public Class WorkContextNeedsSession
    Inherits WaveLongGauge
<SerializableAttribute>
Public Class WorkContextNeedsSession
    Inherits WaveLongGauge
[SerializableAttribute]
public ref class WorkContextNeedsSession : public WaveLongGauge
[SerializableAttribute]
public ref class WorkContextNeedsSession : public WaveLongGauge
[<SerializableAttribute>]
type WorkContextNeedsSession =
    class
        inherit WaveLongGauge
    end
[<SerializableAttribute>]
type WorkContextNeedsSession =
    class
        inherit WaveLongGauge
    end
See Also
WorkContextNeedsSession Members
NFX.Wave.Instrumentation Namespace


WorkContextNeedsSession Members

WorkContextNeedsSession Members NFX Class Library

The WorkContextNeedsSession type exposes the following members.
Constructors
 | Name | Description
Protected method | WorkContextNeedsSession | Initializes a new instance of the WorkContextNeedsSession class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextNeedsSession Class
NFX.Wave.Instrumentation Namespace


WorkContextNeedsSession Constructor

WorkContextNeedsSession Constructor NFX Class Library

Initializes a new instance of the WorkContextNeedsSession class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WorkContextNeedsSession(
    string src,
    long value
)
internal WorkContextNeedsSession(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
WorkContextNeedsSession(
    String^ src,
    long long value
)
internal:
WorkContextNeedsSession(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> WorkContextNeedsSession
new :
        src : string *
        value : int64 -> WorkContextNeedsSession

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
WorkContextNeedsSession Class
WorkContextNeedsSession Members
NFX.Wave.Instrumentation Namespace


WorkContextNeedsSession Fields

WorkContextNeedsSession Fields NFX Class Library

The WorkContextNeedsSession type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
WorkContextNeedsSession Class
NFX.Wave.Instrumentation Namespace


WorkContextNeedsSession Methods

WorkContextNeedsSession Methods NFX Class Library

The WorkContextNeedsSession type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkContextNeedsSession Class
NFX.Wave.Instrumentation Namespace


WorkContextNeedsSession.MakeAggregateInstance Method

WorkContextNeedsSession MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
WorkContextNeedsSession Class
WorkContextNeedsSession Members
NFX.Wave.Instrumentation Namespace


WorkContextNeedsSession Properties

WorkContextNeedsSession Properties NFX Class Library

The WorkContextNeedsSession type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextNeedsSession Class
NFX.Wave.Instrumentation Namespace


WorkContextNeedsSession.Description Property

WorkContextNeedsSession Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
WorkContextNeedsSession Class
WorkContextNeedsSession Members
NFX.Wave.Instrumentation Namespace


WorkContextNeedsSession.ValueUnitName Property

WorkContextNeedsSession ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
WorkContextNeedsSession Class
WorkContextNeedsSession Members
NFX.Wave.Instrumentation Namespace


WorkContextNoDefaultClose Class

WorkContextNoDefaultClose Class NFX Class Library

How many work contexts requested not to be closed at the end of the initial request processing cycle
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation WorkContextNoDefaultClose

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WorkContextNoDefaultClose : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class WorkContextNoDefaultClose : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class WorkContextNoDefaultClose
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class WorkContextNoDefaultClose
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class WorkContextNoDefaultClose : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class WorkContextNoDefaultClose : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type WorkContextNoDefaultClose =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type WorkContextNoDefaultClose =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
WorkContextNoDefaultClose Members
NFX.Wave.Instrumentation Namespace


WorkContextNoDefaultClose Members

WorkContextNoDefaultClose Members NFX Class Library

The WorkContextNoDefaultClose type exposes the following members.
Constructors
 | Name | Description
Protected method | WorkContextNoDefaultClose | Initializes a new instance of the WorkContextNoDefaultClose class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextNoDefaultClose Class
NFX.Wave.Instrumentation Namespace


WorkContextNoDefaultClose Constructor

WorkContextNoDefaultClose Constructor NFX Class Library

Initializes a new instance of the WorkContextNoDefaultClose class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WorkContextNoDefaultClose(
    string src,
    long value
)
internal WorkContextNoDefaultClose(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
WorkContextNoDefaultClose(
    String^ src,
    long long value
)
internal:
WorkContextNoDefaultClose(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> WorkContextNoDefaultClose
new :
        src : string *
        value : int64 -> WorkContextNoDefaultClose

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
WorkContextNoDefaultClose Class
WorkContextNoDefaultClose Members
NFX.Wave.Instrumentation Namespace


WorkContextNoDefaultClose Fields

WorkContextNoDefaultClose Fields NFX Class Library

The WorkContextNoDefaultClose type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
WorkContextNoDefaultClose Class
NFX.Wave.Instrumentation Namespace


WorkContextNoDefaultClose Methods

WorkContextNoDefaultClose Methods NFX Class Library

The WorkContextNoDefaultClose type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkContextNoDefaultClose Class
NFX.Wave.Instrumentation Namespace


WorkContextNoDefaultClose.MakeAggregateInstance Method

WorkContextNoDefaultClose MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
WorkContextNoDefaultClose Class
WorkContextNoDefaultClose Members
NFX.Wave.Instrumentation Namespace


WorkContextNoDefaultClose Properties

WorkContextNoDefaultClose Properties NFX Class Library

The WorkContextNoDefaultClose type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextNoDefaultClose Class
NFX.Wave.Instrumentation Namespace


WorkContextNoDefaultClose.Description Property

WorkContextNoDefaultClose Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
WorkContextNoDefaultClose Class
WorkContextNoDefaultClose Members
NFX.Wave.Instrumentation Namespace


WorkContextNoDefaultClose.ValueUnitName Property

WorkContextNoDefaultClose ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
WorkContextNoDefaultClose Class
WorkContextNoDefaultClose Members
NFX.Wave.Instrumentation Namespace


WorkContextWorkSemaphoreRelease Class

WorkContextWorkSemaphoreRelease Class NFX Class Library

How many times work semaphore was released
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation WorkContextWorkSemaphoreRelease

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WorkContextWorkSemaphoreRelease : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class WorkContextWorkSemaphoreRelease : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class WorkContextWorkSemaphoreRelease
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass,
    IInstrumentClass
<SerializableAttribute>
Public Class WorkContextWorkSemaphoreRelease
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass,
    IInstrumentClass
[SerializableAttribute]
public ref class WorkContextWorkSemaphoreRelease : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class WorkContextWorkSemaphoreRelease : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, ICPUInstrument, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type WorkContextWorkSemaphoreRelease =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface ICPUInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type WorkContextWorkSemaphoreRelease =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface ICPUInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
WorkContextWorkSemaphoreRelease Members
NFX.Wave.Instrumentation Namespace


WorkContextWorkSemaphoreRelease Members

WorkContextWorkSemaphoreRelease Members NFX Class Library

The WorkContextWorkSemaphoreRelease type exposes the following members.
Constructors
 | Name | Description
Protected method | WorkContextWorkSemaphoreRelease | Initializes a new instance of the WorkContextWorkSemaphoreRelease class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextWorkSemaphoreRelease Class
NFX.Wave.Instrumentation Namespace


WorkContextWorkSemaphoreRelease Constructor

WorkContextWorkSemaphoreRelease Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WorkContextWorkSemaphoreRelease class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WorkContextWorkSemaphoreRelease(
    string src,
    long value
)
internal WorkContextWorkSemaphoreRelease(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
WorkContextWorkSemaphoreRelease(
    String^ src,
    long long value
)
internal:
WorkContextWorkSemaphoreRelease(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> WorkContextWorkSemaphoreRelease
new :
        src : string *
        value : int64 -> WorkContextWorkSemaphoreRelease

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
WorkContextWorkSemaphoreRelease Class
WorkContextWorkSemaphoreRelease Members
NFX.Wave.Instrumentation Namespace


WorkContextWorkSemaphoreRelease Fields

WorkContextWorkSemaphoreRelease Fields NFX Class Library

The WorkContextWorkSemaphoreRelease type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
WorkContextWorkSemaphoreRelease Class
NFX.Wave.Instrumentation Namespace


WorkContextWorkSemaphoreRelease Methods

WorkContextWorkSemaphoreRelease Methods NFX Class Library

The WorkContextWorkSemaphoreRelease type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkContextWorkSemaphoreRelease Class
NFX.Wave.Instrumentation Namespace


WorkContextWorkSemaphoreRelease.MakeAggregateInstance Method

WorkContextWorkSemaphoreRelease MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
WorkContextWorkSemaphoreRelease Class
WorkContextWorkSemaphoreRelease Members
NFX.Wave.Instrumentation Namespace


WorkContextWorkSemaphoreRelease Properties

WorkContextWorkSemaphoreRelease Properties NFX Class Library

The WorkContextWorkSemaphoreRelease type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextWorkSemaphoreRelease Class
NFX.Wave.Instrumentation Namespace


WorkContextWorkSemaphoreRelease.Description Property

WorkContextWorkSemaphoreRelease Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
WorkContextWorkSemaphoreRelease Class
WorkContextWorkSemaphoreRelease Members
NFX.Wave.Instrumentation Namespace


WorkContextWorkSemaphoreRelease.ValueUnitName Property

WorkContextWorkSemaphoreRelease ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
WorkContextWorkSemaphoreRelease Class
WorkContextWorkSemaphoreRelease Members
NFX.Wave.Instrumentation Namespace


WorkContextWrittenResponse Class

WorkContextWrittenResponse Class NFX Class Library

How many response object were written into
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Wave.Instrumentation WorkContextWrittenResponse

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WorkContextWrittenResponse : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class WorkContextWrittenResponse : WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class WorkContextWrittenResponse
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class WorkContextWrittenResponse
    Inherits WaveLongGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class WorkContextWrittenResponse : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class WorkContextWrittenResponse : public WaveLongGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type WorkContextWrittenResponse =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type WorkContextWrittenResponse =
    class
        inherit WaveLongGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
WorkContextWrittenResponse Members
NFX.Wave.Instrumentation Namespace


WorkContextWrittenResponse Members

WorkContextWrittenResponse Members NFX Class Library

The WorkContextWrittenResponse type exposes the following members.
Constructors
 | Name | Description
Protected method | WorkContextWrittenResponse | Initializes a new instance of the WorkContextWrittenResponse class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextWrittenResponse Class
NFX.Wave.Instrumentation Namespace


WorkContextWrittenResponse Constructor

WorkContextWrittenResponse Constructor NFX Class Library

Initializes a new instance of the WorkContextWrittenResponse class

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WorkContextWrittenResponse(
    string src,
    long value
)
internal WorkContextWrittenResponse(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
WorkContextWrittenResponse(
    String^ src,
    long long value
)
internal:
WorkContextWrittenResponse(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> WorkContextWrittenResponse
new :
        src : string *
        value : int64 -> WorkContextWrittenResponse

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
WorkContextWrittenResponse Class
WorkContextWrittenResponse Members
NFX.Wave.Instrumentation Namespace


WorkContextWrittenResponse Fields

WorkContextWrittenResponse Fields NFX Class Library

The WorkContextWrittenResponse type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
WorkContextWrittenResponse Class
NFX.Wave.Instrumentation Namespace


WorkContextWrittenResponse Methods

WorkContextWrittenResponse Methods NFX Class Library

The WorkContextWrittenResponse type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkContextWrittenResponse Class
NFX.Wave.Instrumentation Namespace


WorkContextWrittenResponse.MakeAggregateInstance Method

WorkContextWrittenResponse MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
WorkContextWrittenResponse Class
WorkContextWrittenResponse Members
NFX.Wave.Instrumentation Namespace


WorkContextWrittenResponse Properties

WorkContextWrittenResponse Properties NFX Class Library

The WorkContextWrittenResponse type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
WorkContextWrittenResponse Class
NFX.Wave.Instrumentation Namespace


WorkContextWrittenResponse.Description Property

WorkContextWrittenResponse Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
WorkContextWrittenResponse Class
WorkContextWrittenResponse Members
NFX.Wave.Instrumentation Namespace


WorkContextWrittenResponse.ValueUnitName Property

WorkContextWrittenResponse ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.Instrumentation
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
WorkContextWrittenResponse Class
WorkContextWrittenResponse Members
NFX.Wave.Instrumentation Namespace


NFX.Wave.MVC Namespace

NFX.Wave.MVC Namespace NFX Class Library

Classes
 | Class | Description
Public class | ActionAttribute | Decorates MVC Actions
Public class | ActionFilterAttribute | General ancestor for MVC Action Filters - get invoked before and after actions
Public class | ActionGroupInfo | Provides reflection information about a group of action methods which all share the same action name(invocation name) within controller type. Invocation names are mapped to actual method names, as ActionAttribute may override the name of actual method that it decorates. This is a framework internal method which is not intended to be used by business logic developers
Public class | ActionInfo | Provides reflection information about a particular action method of a controller type. This is a framework internal method which is not intended to be used by business logic developers
Public class | CacheControlAttribute | Decorates controller classes or actions that set NoCache headers in response. By default Force = true
Public class | Controller | Represents controller that all MVC controllers must inherit from
Public class | ControllerInfo | Provides reflection information about controller type. This is a framework internal method which is not intended to be used by business logic developers
Public class | NoCacheAttribute | Decorates controller classes or actions that set NoCache headers in response. By default Force = true
Public class | SessionCSRFCheckAttribute | Decorates controller classes or actions that need to check CSRF token on POST against the user session
Structures
 | Structure | Description
Public structure | ClientRecord | Represents MVC action result that returns ROW as JSON object for WV.RecordModel(...) ctor init
Public structure | FileDownload | Represents MVC action result that downloads a local file
Public structure | Http403Forbidden | Returns HTTP 403 - forbidden This should be used in place of returning exceptions where needed as it is faster
Public structure | Http404NotFound | Returns HTTP 404 - not found. This should be used in place of returning exceptions where needed as it is faster
Public structure | JSONResult | Represents MVC action result that returns JSON object with options. If JSON options are not needed then just return CLR object directly from controller action without this wrapper
Public structure | Picture | Represents MVC action result that returns/downloads an image
Public structure | Redirect | Represents MVC action result that redirects user to some URL
Interfaces
 | Interface | Description
Public interface | IActionResult | Decorates entities that get returned by MVC actions and can get executed to generate some result action (command pattern)


ActionAttribute Class

ActionAttribute Class NFX Class Library

Decorates MVC Actions
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Wave.MVC ActionAttribute

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = true)]
public class ActionAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = true)]
public class ActionAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Method, Inherited := false, AllowMultiple := true)>
Public Class ActionAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Method, Inherited := false, AllowMultiple := true)>
Public Class ActionAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Method, Inherited = false, AllowMultiple = true)]
public ref class ActionAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Method, Inherited = false, AllowMultiple = true)]
public ref class ActionAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = true)>]
type ActionAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = true)>]
type ActionAttribute =
    class
        inherit Attribute
    end
See Also
ActionAttribute Members
NFX.Wave.MVC Namespace


ActionAttribute Members

ActionAttribute Members NFX Class Library

The ActionAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | ActionAttribute | Initializes a new instance of the ActionAttribute class
Public method | ActionAttribute(Int32) | Initializes a new instance of the ActionAttribute class
Public method | ActionAttribute(String, Int32, Boolean) | Specifies name override
Public method | ActionAttribute(String, Int32, String, Boolean) | Specifies name override and WorkMatch instances in Laconic format. i.e.: 'match{name="A" order=0 is-local=false} match{name="B" order=0 methods="post,put" is-local=true}'
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Matches | Returns ordered matches configured from script or empty enum
Public property | MatchScript | Returns match script in Laconic config format if the one was supplied or empty string
Public property | Name | When set, specifies the invocation name override, null by default which means that the name of decorated member should be used
Public property | Order | Dictates the match making order of actions within the group
Public property | StrictParamBinding | Returns true if default parameter binder should not perform indirect value conversions, i.e. integer tick number as date time. False by default
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ActionAttribute Class
NFX.Wave.MVC Namespace


ActionAttribute Constructor

ActionAttribute Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ActionAttribute | Initializes a new instance of the ActionAttribute class
Public method | ActionAttribute(Int32) | Initializes a new instance of the ActionAttribute class
Public method | ActionAttribute(String, Int32, Boolean) | Specifies name override
Public method | ActionAttribute(String, Int32, String, Boolean) | Specifies name override and WorkMatch instances in Laconic format. i.e.: 'match{name="A" order=0 is-local=false} match{name="B" order=0 methods="post,put" is-local=true}'
Back to Top
See Also
ActionAttribute Class
ActionAttribute Members
NFX.Wave.MVC Namespace


ActionAttribute Constructor

ActionAttribute Constructor NFX Class Library

Initializes a new instance of the ActionAttribute class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ActionAttribute()
public ActionAttribute()
Public Sub New
Public Sub New
public:
ActionAttribute()
public:
ActionAttribute()
new : unit -> ActionAttribute
new : unit -> ActionAttribute
See Also
ActionAttribute Class
ActionAttribute Members
ActionAttribute Overload
NFX.Wave.MVC Namespace


ActionAttribute Constructor (Int32)

ActionAttribute Constructor (Int32) NFX Class Library

Initializes a new instance of the ActionAttribute class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ActionAttribute(
    int order
)
public ActionAttribute(
    int order
)
Public Sub New (
    order As Integer
)
Public Sub New (
    order As Integer
)
public:
ActionAttribute(
    int order
)
public:
ActionAttribute(
    int order
)
new :
        order : int -> ActionAttribute
new :
        order : int -> ActionAttribute

Parameters

order
Type: Online System Int32
See Also
ActionAttribute Class
ActionAttribute Members
ActionAttribute Overload
NFX.Wave.MVC Namespace


ActionAttribute Constructor (String, Int32, Boolean)

ActionAttribute Constructor (String, Int32, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies name override

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ActionAttribute(
    string name,
    int order,
    bool strictParamBinding = false
)
public ActionAttribute(
    string name,
    int order,
    bool strictParamBinding = false
)
Public Sub New (
    name As String,
    order As Integer,
    Optional strictParamBinding As Boolean = false
)
Public Sub New (
    name As String,
    order As Integer,
    Optional strictParamBinding As Boolean = false
)
public:
ActionAttribute(
    String^ name,
    int order,
    bool strictParamBinding = false
)
public:
ActionAttribute(
    String^ name,
    int order,
    bool strictParamBinding = false
)
new :
        name : string *
        order : int *
        ?strictParamBinding : bool
(* Defaults:
        let _strictParamBinding = defaultArg strictParamBinding false
*)
-> ActionAttribute
new :
        name : string *
        order : int *
        ?strictParamBinding : bool
(* Defaults:
        let _strictParamBinding = defaultArg strictParamBinding false
*)
-> ActionAttribute

Parameters

name
Type: Online System String
order
Type: Online System Int32
strictParamBinding (Optional)
Type: Online System Boolean
See Also
ActionAttribute Class
ActionAttribute Members
ActionAttribute Overload
NFX.Wave.MVC Namespace


ActionAttribute Constructor (String, Int32, String, Boolean)

ActionAttribute Constructor (String, Int32, String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies name override and WorkMatch instances in Laconic format. i.e.: 'match{name="A" order=0 is-local=false} match{name="B" order=0 methods="post,put" is-local=true}'

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ActionAttribute(
    string name,
    int order,
    string matchScript,
    bool strictParamBinding = false
)
public ActionAttribute(
    string name,
    int order,
    string matchScript,
    bool strictParamBinding = false
)
Public Sub New (
    name As String,
    order As Integer,
    matchScript As String,
    Optional strictParamBinding As Boolean = false
)
Public Sub New (
    name As String,
    order As Integer,
    matchScript As String,
    Optional strictParamBinding As Boolean = false
)
public:
ActionAttribute(
    String^ name,
    int order,
    String^ matchScript,
    bool strictParamBinding = false
)
public:
ActionAttribute(
    String^ name,
    int order,
    String^ matchScript,
    bool strictParamBinding = false
)
new :
        name : string *
        order : int *
        matchScript : string *
        ?strictParamBinding : bool
(* Defaults:
        let _strictParamBinding = defaultArg strictParamBinding false
*)
-> ActionAttribute
new :
        name : string *
        order : int *
        matchScript : string *
        ?strictParamBinding : bool
(* Defaults:
        let _strictParamBinding = defaultArg strictParamBinding false
*)
-> ActionAttribute

Parameters

name
Type: Online System String
order
Type: Online System Int32
matchScript
Type: Online System String
strictParamBinding (Optional)
Type: Online System Boolean
See Also
ActionAttribute Class
ActionAttribute Members
ActionAttribute Overload
NFX.Wave.MVC Namespace


ActionAttribute Methods

ActionAttribute Methods NFX Class Library

The ActionAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ActionAttribute Class
NFX.Wave.MVC Namespace


ActionAttribute Properties

ActionAttribute Properties NFX Class Library

The ActionAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Matches | Returns ordered matches configured from script or empty enum
Public property | MatchScript | Returns match script in Laconic config format if the one was supplied or empty string
Public property | Name | When set, specifies the invocation name override, null by default which means that the name of decorated member should be used
Public property | Order | Dictates the match making order of actions within the group
Public property | StrictParamBinding | Returns true if default parameter binder should not perform indirect value conversions, i.e. integer tick number as date time. False by default
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ActionAttribute Class
NFX.Wave.MVC Namespace


ActionAttribute.Matches Property

ActionAttribute Matches Property NFX Class Library

Returns ordered matches configured from script or empty enum

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<WorkMatch> Matches { get; }
public IEnumerable<WorkMatch> Matches { get; }
Public ReadOnly Property Matches As IEnumerable(Of WorkMatch)
    Get
Public ReadOnly Property Matches As IEnumerable(Of WorkMatch)
    Get
public:
property IEnumerable<WorkMatch^>^ Matches {
    IEnumerable<WorkMatch^>^ get ();
}
public:
property IEnumerable<WorkMatch^>^ Matches {
    IEnumerable<WorkMatch^>^ get ();
}
member Matches : IEnumerable<WorkMatch> with get
member Matches : IEnumerable<WorkMatch> with get

Property Value

Type: Online IEnumerable WorkMatch
See Also
ActionAttribute Class
ActionAttribute Members
NFX.Wave.MVC Namespace


ActionAttribute.MatchScript Property

ActionAttribute MatchScript Property NFX Class Library

Returns match script in Laconic config format if the one was supplied or empty string

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MatchScript { get; }
public string MatchScript { get; }
Public ReadOnly Property MatchScript As String
    Get
Public ReadOnly Property MatchScript As String
    Get
public:
property String^ MatchScript {
    String^ get ();
}
public:
property String^ MatchScript {
    String^ get ();
}
member MatchScript : string with get
member MatchScript : string with get

Property Value

Type: Online String
See Also
ActionAttribute Class
ActionAttribute Members
NFX.Wave.MVC Namespace


ActionAttribute.Name Property

ActionAttribute Name Property NFX Class Library

When set, specifies the invocation name override, null by default which means that the name of decorated member should be used

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
public:
property String^ Name {
    String^ get ();
}
member Name : string with get
member Name : string with get

Property Value

Type: Online String
See Also
ActionAttribute Class
ActionAttribute Members
NFX.Wave.MVC Namespace


ActionAttribute.Order Property

ActionAttribute Order Property NFX Class Library

Dictates the match making order of actions within the group

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Order { get; }
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
Public ReadOnly Property Order As Integer
    Get
public:
property int Order {
    int get ();
}
public:
property int Order {
    int get ();
}
member Order : int with get
member Order : int with get

Property Value

Type: Online Int32
See Also
ActionAttribute Class
ActionAttribute Members
NFX.Wave.MVC Namespace


ActionAttribute.StrictParamBinding Property

ActionAttribute StrictParamBinding Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true if default parameter binder should not perform indirect value conversions, i.e. integer tick number as date time. False by default

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool StrictParamBinding { get; }
public bool StrictParamBinding { get; }
Public ReadOnly Property StrictParamBinding As Boolean
    Get
Public ReadOnly Property StrictParamBinding As Boolean
    Get
public:
property bool StrictParamBinding {
    bool get ();
}
public:
property bool StrictParamBinding {
    bool get ();
}
member StrictParamBinding : bool with get
member StrictParamBinding : bool with get

Property Value

Type: Online Boolean
See Also
ActionAttribute Class
ActionAttribute Members
NFX.Wave.MVC Namespace


ActionFilterAttribute Class

ActionFilterAttribute Class NFX Class Library

General ancestor for MVC Action Filters - get invoked before and after actions
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Wave.MVC ActionFilterAttribute
NFX.Wave.MVC CacheControlAttribute
NFX.Wave.MVC NoCacheAttribute
NFX.Wave.MVC SessionCSRFCheckAttribute

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = true)]
public abstract class ActionFilterAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = true)]
public abstract class ActionFilterAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Method, Inherited := false,
    AllowMultiple := true)>
Public MustInherit Class ActionFilterAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Method, Inherited := false,
    AllowMultiple := true)>
Public MustInherit Class ActionFilterAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Method, Inherited = false,
    AllowMultiple = true)]
public ref class ActionFilterAttribute abstract : public Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Method, Inherited = false,
    AllowMultiple = true)]
public ref class ActionFilterAttribute abstract : public Attribute
[<AbstractClassAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = true)>]
type ActionFilterAttribute =
    class
        inherit Attribute
    end
[<AbstractClassAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = true)>]
type ActionFilterAttribute =
    class
        inherit Attribute
    end
See Also
ActionFilterAttribute Members
NFX.Wave.MVC Namespace


ActionFilterAttribute Members

ActionFilterAttribute Members NFX Class Library

The ActionFilterAttribute type exposes the following members.
Constructors
 | Name | Description
Protected method | ActionFilterAttribute | Initializes a new instance of the ActionFilterAttribute class
Protected method | ActionFilterAttribute(Int32) | Initializes a new instance of the ActionFilterAttribute class
Back to Top
Methods
 | Name | Description
Protected method | ActionInvocationFinally | Override to add logic/filtering finally after the invocation of action method. Must return TRUE to stop processing chain
Protected method | AfterActionInvocation | Override to add logic/filtering right after the invocation of action method. Must return TRUE to stop processing chain
Protected method | BeforeActionInvocation | Override to add logic/filtering right before the invocation of action method. Return TRUE to indicate that request has already been handled and no need to call method body and AfterActionInvocation in which case return result via 'out result' paremeter
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Order | Dictates the call order
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ActionFilterAttribute Class
NFX.Wave.MVC Namespace


ActionFilterAttribute Constructor

ActionFilterAttribute Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ActionFilterAttribute | Initializes a new instance of the ActionFilterAttribute class
Protected method | ActionFilterAttribute(Int32) | Initializes a new instance of the ActionFilterAttribute class
Back to Top
See Also
ActionFilterAttribute Class
ActionFilterAttribute Members
NFX.Wave.MVC Namespace


ActionFilterAttribute Constructor

ActionFilterAttribute Constructor NFX Class Library

Initializes a new instance of the ActionFilterAttribute class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ActionFilterAttribute()
protected ActionFilterAttribute()
Protected Sub New
Protected Sub New
protected:
ActionFilterAttribute()
protected:
ActionFilterAttribute()
new : unit -> ActionFilterAttribute
new : unit -> ActionFilterAttribute
See Also
ActionFilterAttribute Class
ActionFilterAttribute Members
ActionFilterAttribute Overload
NFX.Wave.MVC Namespace


ActionFilterAttribute Constructor (Int32)

ActionFilterAttribute Constructor (Int32) NFX Class Library

Initializes a new instance of the ActionFilterAttribute class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ActionFilterAttribute(
    int order
)
protected ActionFilterAttribute(
    int order
)
Protected Sub New (
    order As Integer
)
Protected Sub New (
    order As Integer
)
protected:
ActionFilterAttribute(
    int order
)
protected:
ActionFilterAttribute(
    int order
)
new :
        order : int -> ActionFilterAttribute
new :
        order : int -> ActionFilterAttribute

Parameters

order
Type: Online System Int32
See Also
ActionFilterAttribute Class
ActionFilterAttribute Members
ActionFilterAttribute Overload
NFX.Wave.MVC Namespace


ActionFilterAttribute Fields

ActionFilterAttribute Fields NFX Class Library

The ActionFilterAttribute type exposes the following members.
Fields
 | Name | Description
Public field | Order | Dictates the call order
Back to Top
See Also
ActionFilterAttribute Class
NFX.Wave.MVC Namespace


ActionFilterAttribute.Order Field

ActionFilterAttribute Order Field NFX Class Library

Dictates the call order

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Order
public readonly int Order
Public ReadOnly Order As Integer
Public ReadOnly Order As Integer
public:
initonly int Order
public:
initonly int Order
val Order: int
val Order: int

Field Value

Type: Online Int32
See Also
ActionFilterAttribute Class
ActionFilterAttribute Members
NFX.Wave.MVC Namespace


ActionFilterAttribute Methods

ActionFilterAttribute Methods NFX Class Library

The ActionFilterAttribute type exposes the following members.
Methods
 | Name | Description
Protected method | ActionInvocationFinally | Override to add logic/filtering finally after the invocation of action method. Must return TRUE to stop processing chain
Protected method | AfterActionInvocation | Override to add logic/filtering right after the invocation of action method. Must return TRUE to stop processing chain
Protected method | BeforeActionInvocation | Override to add logic/filtering right before the invocation of action method. Return TRUE to indicate that request has already been handled and no need to call method body and AfterActionInvocation in which case return result via 'out result' paremeter
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ActionFilterAttribute Class
NFX.Wave.MVC Namespace


ActionFilterAttribute.ActionInvocationFinally Method

ActionFilterAttribute ActionInvocationFinally Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to add logic/filtering finally after the invocation of action method. Must return TRUE to stop processing chain

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract void ActionInvocationFinally(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
protected internal abstract void ActionInvocationFinally(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
Protected Friend MustOverride Sub ActionInvocationFinally (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
)
Protected Friend MustOverride Sub ActionInvocationFinally (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
)
protected public:
virtual void ActionInvocationFinally(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) abstract
protected public:
virtual void ActionInvocationFinally(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) abstract
abstract ActionInvocationFinally :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> unit
abstract ActionInvocationFinally :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> unit

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object
See Also
ActionFilterAttribute Class
ActionFilterAttribute Members
NFX.Wave.MVC Namespace


ActionFilterAttribute.AfterActionInvocation Method

ActionFilterAttribute AfterActionInvocation Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to add logic/filtering right after the invocation of action method. Must return TRUE to stop processing chain

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract bool AfterActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
protected internal abstract bool AfterActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
Protected Friend MustOverride Function AfterActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
Protected Friend MustOverride Function AfterActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
protected public:
virtual bool AfterActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) abstract
protected public:
virtual bool AfterActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) abstract
abstract AfterActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
abstract AfterActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ActionFilterAttribute Class
ActionFilterAttribute Members
NFX.Wave.MVC Namespace


ActionFilterAttribute.BeforeActionInvocation Method

ActionFilterAttribute BeforeActionInvocation Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to add logic/filtering right before the invocation of action method. Return TRUE to indicate that request has already been handled and no need to call method body and AfterActionInvocation in which case return result via 'out result' paremeter

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract bool BeforeActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
protected internal abstract bool BeforeActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
Protected Friend MustOverride Function BeforeActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
Protected Friend MustOverride Function BeforeActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
protected public:
virtual bool BeforeActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) abstract
protected public:
virtual bool BeforeActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) abstract
abstract BeforeActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
abstract BeforeActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ActionFilterAttribute Class
ActionFilterAttribute Members
NFX.Wave.MVC Namespace


ActionFilterAttribute Properties

ActionFilterAttribute Properties NFX Class Library

The ActionFilterAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ActionFilterAttribute Class
NFX.Wave.MVC Namespace


ActionGroupInfo Class

ActionGroupInfo Class NFX Class Library

Provides reflection information about a group of action methods which all share the same action name(invocation name) within controller type. Invocation names are mapped to actual method names, as ActionAttribute may override the name of actual method that it decorates. This is a framework internal method which is not intended to be used by business logic developers
Inheritance Hierarchy
Online System Object
NFX.Wave.MVC ActionGroupInfo

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ActionGroupInfo : INamed
public sealed class ActionGroupInfo : INamed
Public NotInheritable Class ActionGroupInfo
    Implements INamed
Public NotInheritable Class ActionGroupInfo
    Implements INamed
public ref class ActionGroupInfo sealed : INamed
public ref class ActionGroupInfo sealed : INamed
[<SealedAttribute>]
type ActionGroupInfo =
    class
        interface INamed
    end
[<SealedAttribute>]
type ActionGroupInfo =
    class
        interface INamed
    end
See Also
ActionGroupInfo Members
NFX.Wave.MVC Namespace


ActionGroupInfo Members

ActionGroupInfo Members NFX Class Library

The ActionGroupInfo type exposes the following members.
Constructors
 | Name | Description
Protected method | ActionGroupInfo | Initializes a new instance of the ActionGroupInfo class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Actions | Returns the actions in the order suitable for match making
Public field | Controller |
Back to Top
Properties
 | Name | Description
Public property | Name | Action invocation name- may be diffrent from method name
Back to Top
See Also
ActionGroupInfo Class
NFX.Wave.MVC Namespace


ActionGroupInfo Constructor

ActionGroupInfo Constructor NFX Class Library

Initializes a new instance of the ActionGroupInfo class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ActionGroupInfo(
    ControllerInfo controller,
    string actionInvocationName
)
internal ActionGroupInfo(
    ControllerInfo controller,
    string actionInvocationName
)
Friend Sub New (
    controller As ControllerInfo,
    actionInvocationName As String
)
Friend Sub New (
    controller As ControllerInfo,
    actionInvocationName As String
)
internal:
ActionGroupInfo(
    ControllerInfo^ controller,
    String^ actionInvocationName
)
internal:
ActionGroupInfo(
    ControllerInfo^ controller,
    String^ actionInvocationName
)
new :
        controller : ControllerInfo *
        actionInvocationName : string -> ActionGroupInfo
new :
        controller : ControllerInfo *
        actionInvocationName : string -> ActionGroupInfo

Parameters

controller
Type: NFX.Wave.MVC ControllerInfo
actionInvocationName
Type: Online System String
See Also
ActionGroupInfo Class
ActionGroupInfo Members
NFX.Wave.MVC Namespace


ActionGroupInfo Fields

ActionGroupInfo Fields NFX Class Library

The ActionGroupInfo type exposes the following members.
Fields
 | Name | Description
Public field | Actions | Returns the actions in the order suitable for match making
Public field | Controller |
Back to Top
See Also
ActionGroupInfo Class
NFX.Wave.MVC Namespace


ActionGroupInfo.Actions Field

ActionGroupInfo Actions Field NFX Class Library

Returns the actions in the order suitable for match making

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ActionInfo> Actions
public IEnumerable<ActionInfo> Actions
Public Actions As IEnumerable(Of ActionInfo)
Public Actions As IEnumerable(Of ActionInfo)
public:
IEnumerable<ActionInfo^>^ Actions
public:
IEnumerable<ActionInfo^>^ Actions
val mutable Actions: IEnumerable<ActionInfo>
val mutable Actions: IEnumerable<ActionInfo>

Field Value

Type: Online IEnumerable ActionInfo
See Also
ActionGroupInfo Class
ActionGroupInfo Members
NFX.Wave.MVC Namespace


ActionGroupInfo.Controller Field

ActionGroupInfo Controller Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ControllerInfo Controller
public readonly ControllerInfo Controller
Public ReadOnly Controller As ControllerInfo
Public ReadOnly Controller As ControllerInfo
public:
initonly ControllerInfo^ Controller
public:
initonly ControllerInfo^ Controller
val Controller: ControllerInfo
val Controller: ControllerInfo

Field Value

Type: ControllerInfo
See Also
ActionGroupInfo Class
ActionGroupInfo Members
NFX.Wave.MVC Namespace


ActionGroupInfo Methods

ActionGroupInfo Methods NFX Class Library

The ActionGroupInfo type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ActionGroupInfo Class
NFX.Wave.MVC Namespace


ActionGroupInfo Properties

ActionGroupInfo Properties NFX Class Library

The ActionGroupInfo type exposes the following members.
Properties
 | Name | Description
Public property | Name | Action invocation name- may be diffrent from method name
Back to Top
See Also
ActionGroupInfo Class
NFX.Wave.MVC Namespace


ActionGroupInfo.Name Property

ActionGroupInfo Name Property NFX Class Library

Action invocation name- may be diffrent from method name

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
ActionGroupInfo Class
ActionGroupInfo Members
NFX.Wave.MVC Namespace


ActionInfo Class

ActionInfo Class NFX Class Library

Provides reflection information about a particular action method of a controller type. This is a framework internal method which is not intended to be used by business logic developers
Inheritance Hierarchy
Online System Object
NFX.Wave.MVC ActionInfo

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ActionInfo
public sealed class ActionInfo
Public NotInheritable Class ActionInfo
Public NotInheritable Class ActionInfo
public ref class ActionInfo sealed
public ref class ActionInfo sealed
[<SealedAttribute>]
type ActionInfo =  class end
[<SealedAttribute>]
type ActionInfo =  class end
See Also
ActionInfo Members
NFX.Wave.MVC Namespace


ActionInfo Members

ActionInfo Members NFX Class Library

The ActionInfo type exposes the following members.
Constructors
 | Name | Description
Protected method | ActionInfo | Initializes a new instance of the ActionInfo class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Attribute |
Public field | Group |
Public field | Method |
Back to Top
See Also
ActionInfo Class
NFX.Wave.MVC Namespace


ActionInfo Constructor

ActionInfo Constructor NFX Class Library

Initializes a new instance of the ActionInfo class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ActionInfo(
    ActionGroupInfo group,
    MethodInfo method
)
internal ActionInfo(
    ActionGroupInfo group,
    MethodInfo method
)
Friend Sub New (
    group As ActionGroupInfo,
    method As MethodInfo
)
Friend Sub New (
    group As ActionGroupInfo,
    method As MethodInfo
)
internal:
ActionInfo(
    ActionGroupInfo^ group,
    MethodInfo^ method
)
internal:
ActionInfo(
    ActionGroupInfo^ group,
    MethodInfo^ method
)
new :
        group : ActionGroupInfo *
        method : MethodInfo -> ActionInfo
new :
        group : ActionGroupInfo *
        method : MethodInfo -> ActionInfo

Parameters

group
Type: NFX.Wave.MVC ActionGroupInfo
method
Type: Online System.Reflection MethodInfo
See Also
ActionInfo Class
ActionInfo Members
NFX.Wave.MVC Namespace


ActionInfo Fields

ActionInfo Fields NFX Class Library

The ActionInfo type exposes the following members.
Fields
 | Name | Description
Public field | Attribute |
Public field | Group |
Public field | Method |
Back to Top
See Also
ActionInfo Class
NFX.Wave.MVC Namespace


ActionInfo.Attribute Field

ActionInfo Attribute Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ActionAttribute Attribute
public readonly ActionAttribute Attribute
Public ReadOnly Attribute As ActionAttribute
Public ReadOnly Attribute As ActionAttribute
public:
initonly ActionAttribute^ Attribute
public:
initonly ActionAttribute^ Attribute
val Attribute: ActionAttribute
val Attribute: ActionAttribute

Field Value

Type: ActionAttribute
See Also
ActionInfo Class
ActionInfo Members
NFX.Wave.MVC Namespace


ActionInfo.Group Field

ActionInfo Group Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ActionGroupInfo Group
public readonly ActionGroupInfo Group
Public ReadOnly Group As ActionGroupInfo
Public ReadOnly Group As ActionGroupInfo
public:
initonly ActionGroupInfo^ Group
public:
initonly ActionGroupInfo^ Group
val Group: ActionGroupInfo
val Group: ActionGroupInfo

Field Value

Type: ActionGroupInfo
See Also
ActionInfo Class
ActionInfo Members
NFX.Wave.MVC Namespace


ActionInfo.Method Field

ActionInfo Method Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly MethodInfo Method
public readonly MethodInfo Method
Public ReadOnly Method As MethodInfo
Public ReadOnly Method As MethodInfo
public:
initonly MethodInfo^ Method
public:
initonly MethodInfo^ Method
val Method: MethodInfo
val Method: MethodInfo

Field Value

Type: Online MethodInfo
See Also
ActionInfo Class
ActionInfo Members
NFX.Wave.MVC Namespace


ActionInfo Methods

ActionInfo Methods NFX Class Library

The ActionInfo type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ActionInfo Class
NFX.Wave.MVC Namespace


CacheControlAttribute Class

CacheControlAttribute Class NFX Class Library

Decorates controller classes or actions that set NoCache headers in response. By default Force = true
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Wave.MVC ActionFilterAttribute
NFX.Wave.MVC CacheControlAttribute

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = false)]
public sealed class CacheControlAttribute : ActionFilterAttribute
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = false)]
public sealed class CacheControlAttribute : ActionFilterAttribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Method, Inherited := false,
    AllowMultiple := false)>
Public NotInheritable Class CacheControlAttribute
    Inherits ActionFilterAttribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Method, Inherited := false,
    AllowMultiple := false)>
Public NotInheritable Class CacheControlAttribute
    Inherits ActionFilterAttribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Method, Inherited = false,
    AllowMultiple = false)]
public ref class CacheControlAttribute sealed : public ActionFilterAttribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Method, Inherited = false,
    AllowMultiple = false)]
public ref class CacheControlAttribute sealed : public ActionFilterAttribute
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = false)>]
type CacheControlAttribute =
    class
        inherit ActionFilterAttribute
    end
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = false)>]
type CacheControlAttribute =
    class
        inherit ActionFilterAttribute
    end
See Also
CacheControlAttribute Members
NFX.Wave.MVC Namespace


CacheControlAttribute Members

CacheControlAttribute Members NFX Class Library

The CacheControlAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | CacheControlAttribute | Initializes a new instance of the CacheControlAttribute class
Public method | CacheControlAttribute(Int32) | Initializes a new instance of the CacheControlAttribute class
Back to Top
Methods
 | Name | Description
Protected method | ActionInvocationFinally | (Overrides ActionFilterAttribute ActionInvocationFinally(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Protected method | AfterActionInvocation | (Overrides ActionFilterAttribute AfterActionInvocation(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Protected method | BeforeActionInvocation | (Overrides ActionFilterAttribute BeforeActionInvocation(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Order | Dictates the call order (Inherited from ActionFilterAttribute.)
Back to Top
Properties
 | Name | Description
Public property | Cacheability |
Public property | Force |
Public property | MaxAgeSec |
Public property | MustRevalidate |
Public property | NoStore |
Public property | NoTransform |
Public property | ProxyRevalidate |
Public property | SharedMaxAgeSec |
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
CacheControlAttribute Class
NFX.Wave.MVC Namespace


CacheControlAttribute Constructor

CacheControlAttribute Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CacheControlAttribute | Initializes a new instance of the CacheControlAttribute class
Public method | CacheControlAttribute(Int32) | Initializes a new instance of the CacheControlAttribute class
Back to Top
See Also
CacheControlAttribute Class
CacheControlAttribute Members
NFX.Wave.MVC Namespace


CacheControlAttribute Constructor

CacheControlAttribute Constructor NFX Class Library

Initializes a new instance of the CacheControlAttribute class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CacheControlAttribute()
public CacheControlAttribute()
Public Sub New
Public Sub New
public:
CacheControlAttribute()
public:
CacheControlAttribute()
new : unit -> CacheControlAttribute
new : unit -> CacheControlAttribute
See Also
CacheControlAttribute Class
CacheControlAttribute Members
CacheControlAttribute Overload
NFX.Wave.MVC Namespace


CacheControlAttribute Constructor (Int32)

CacheControlAttribute Constructor (Int32) NFX Class Library

Initializes a new instance of the CacheControlAttribute class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CacheControlAttribute(
    int order
)
public CacheControlAttribute(
    int order
)
Public Sub New (
    order As Integer
)
Public Sub New (
    order As Integer
)
public:
CacheControlAttribute(
    int order
)
public:
CacheControlAttribute(
    int order
)
new :
        order : int -> CacheControlAttribute
new :
        order : int -> CacheControlAttribute

Parameters

order
Type: Online System Int32
See Also
CacheControlAttribute Class
CacheControlAttribute Members
CacheControlAttribute Overload
NFX.Wave.MVC Namespace


CacheControlAttribute Fields

CacheControlAttribute Fields NFX Class Library

The CacheControlAttribute type exposes the following members.
Fields
 | Name | Description
Public field | Order | Dictates the call order (Inherited from ActionFilterAttribute.)
Back to Top
See Also
CacheControlAttribute Class
NFX.Wave.MVC Namespace


CacheControlAttribute Methods

CacheControlAttribute Methods NFX Class Library

The CacheControlAttribute type exposes the following members.
Methods
 | Name | Description
Protected method | ActionInvocationFinally | (Overrides ActionFilterAttribute ActionInvocationFinally(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Protected method | AfterActionInvocation | (Overrides ActionFilterAttribute AfterActionInvocation(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Protected method | BeforeActionInvocation | (Overrides ActionFilterAttribute BeforeActionInvocation(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheControlAttribute Class
NFX.Wave.MVC Namespace


CacheControlAttribute.ActionInvocationFinally Method

CacheControlAttribute ActionInvocationFinally Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void ActionInvocationFinally(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
protected internal override void ActionInvocationFinally(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
Protected Friend Overrides Sub ActionInvocationFinally (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
)
Protected Friend Overrides Sub ActionInvocationFinally (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
)
protected public:
virtual void ActionInvocationFinally(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
protected public:
virtual void ActionInvocationFinally(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
abstract ActionInvocationFinally :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> unit
override ActionInvocationFinally :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> unit
abstract ActionInvocationFinally :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> unit
override ActionInvocationFinally :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> unit

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object
See Also
CacheControlAttribute Class
CacheControlAttribute Members
NFX.Wave.MVC Namespace


CacheControlAttribute.AfterActionInvocation Method

CacheControlAttribute AfterActionInvocation Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool AfterActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
protected internal override bool AfterActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
Protected Friend Overrides Function AfterActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
Protected Friend Overrides Function AfterActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
protected public:
virtual bool AfterActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
protected public:
virtual bool AfterActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
abstract AfterActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
override AfterActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
abstract AfterActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
override AfterActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object

Return Value

Type: Online Boolean
See Also
CacheControlAttribute Class
CacheControlAttribute Members
NFX.Wave.MVC Namespace


CacheControlAttribute.BeforeActionInvocation Method

CacheControlAttribute BeforeActionInvocation Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool BeforeActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
protected internal override bool BeforeActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
Protected Friend Overrides Function BeforeActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
Protected Friend Overrides Function BeforeActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
protected public:
virtual bool BeforeActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
protected public:
virtual bool BeforeActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
abstract BeforeActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
override BeforeActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
abstract BeforeActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
override BeforeActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object

Return Value

Type: Online Boolean
See Also
CacheControlAttribute Class
CacheControlAttribute Members
NFX.Wave.MVC Namespace


CacheControlAttribute Properties

CacheControlAttribute Properties NFX Class Library

The CacheControlAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Cacheability |
Public property | Force |
Public property | MaxAgeSec |
Public property | MustRevalidate |
Public property | NoStore |
Public property | NoTransform |
Public property | ProxyRevalidate |
Public property | SharedMaxAgeSec |
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
CacheControlAttribute Class
NFX.Wave.MVC Namespace


CacheControlAttribute.Cacheability Property

CacheControlAttribute Cacheability Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CacheControl..::..Type Cacheability { get; set; }
public CacheControl..::..Type Cacheability { get; set; }
Public Property Cacheability As CacheControl..::..Type
    Get
    Set
Public Property Cacheability As CacheControl..::..Type
    Get
    Set
public:
property CacheControl..::..Type Cacheability {
    CacheControl..::..Type get ();
    void set (CacheControl..::..Type value);
}
public:
property CacheControl..::..Type Cacheability {
    CacheControl..::..Type get ();
    void set (CacheControl..::..Type value);
}
member Cacheability : CacheControl..::..Type with get, set
member Cacheability : CacheControl..::..Type with get, set

Property Value

Type: CacheControl Type
See Also
CacheControlAttribute Class
CacheControlAttribute Members
NFX.Wave.MVC Namespace


CacheControlAttribute.Force Property

CacheControlAttribute Force Property NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Force { get; set; }
public bool Force { get; set; }
Public Property Force As Boolean
    Get
    Set
Public Property Force As Boolean
    Get
    Set
public:
property bool Force {
    bool get ();
    void set (bool value);
}
public:
property bool Force {
    bool get ();
    void set (bool value);
}
member Force : bool with get, set
member Force : bool with get, set

Property Value

Type: Online Boolean
See Also
CacheControlAttribute Class
CacheControlAttribute Members
NFX.Wave.MVC Namespace


CacheControlAttribute.MaxAgeSec Property

CacheControlAttribute MaxAgeSec Property NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> MaxAgeSec { get; set; }
public Nullable<int> MaxAgeSec { get; set; }
Public Property MaxAgeSec As Nullable(Of Integer)
    Get
    Set
Public Property MaxAgeSec As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> MaxAgeSec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
public:
property Nullable<int> MaxAgeSec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member MaxAgeSec : Nullable<int> with get, set
member MaxAgeSec : Nullable<int> with get, set

Property Value

Type: Online Nullable Online Int32
See Also
CacheControlAttribute Class
CacheControlAttribute Members
NFX.Wave.MVC Namespace


CacheControlAttribute.MustRevalidate Property

CacheControlAttribute MustRevalidate Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MustRevalidate { get; set; }
public bool MustRevalidate { get; set; }
Public Property MustRevalidate As Boolean
    Get
    Set
Public Property MustRevalidate As Boolean
    Get
    Set
public:
property bool MustRevalidate {
    bool get ();
    void set (bool value);
}
public:
property bool MustRevalidate {
    bool get ();
    void set (bool value);
}
member MustRevalidate : bool with get, set
member MustRevalidate : bool with get, set

Property Value

Type: Online Boolean
See Also
CacheControlAttribute Class
CacheControlAttribute Members
NFX.Wave.MVC Namespace


CacheControlAttribute.NoStore Property

CacheControlAttribute NoStore Property NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool NoStore { get; set; }
public bool NoStore { get; set; }
Public Property NoStore As Boolean
    Get
    Set
Public Property NoStore As Boolean
    Get
    Set
public:
property bool NoStore {
    bool get ();
    void set (bool value);
}
public:
property bool NoStore {
    bool get ();
    void set (bool value);
}
member NoStore : bool with get, set
member NoStore : bool with get, set

Property Value

Type: Online Boolean
See Also
CacheControlAttribute Class
CacheControlAttribute Members
NFX.Wave.MVC Namespace


CacheControlAttribute.NoTransform Property

CacheControlAttribute NoTransform Property NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool NoTransform { get; set; }
public bool NoTransform { get; set; }
Public Property NoTransform As Boolean
    Get
    Set
Public Property NoTransform As Boolean
    Get
    Set
public:
property bool NoTransform {
    bool get ();
    void set (bool value);
}
public:
property bool NoTransform {
    bool get ();
    void set (bool value);
}
member NoTransform : bool with get, set
member NoTransform : bool with get, set

Property Value

Type: Online Boolean
See Also
CacheControlAttribute Class
CacheControlAttribute Members
NFX.Wave.MVC Namespace


CacheControlAttribute.ProxyRevalidate Property

CacheControlAttribute ProxyRevalidate Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ProxyRevalidate { get; set; }
public bool ProxyRevalidate { get; set; }
Public Property ProxyRevalidate As Boolean
    Get
    Set
Public Property ProxyRevalidate As Boolean
    Get
    Set
public:
property bool ProxyRevalidate {
    bool get ();
    void set (bool value);
}
public:
property bool ProxyRevalidate {
    bool get ();
    void set (bool value);
}
member ProxyRevalidate : bool with get, set
member ProxyRevalidate : bool with get, set

Property Value

Type: Online Boolean
See Also
CacheControlAttribute Class
CacheControlAttribute Members
NFX.Wave.MVC Namespace


CacheControlAttribute.SharedMaxAgeSec Property

CacheControlAttribute SharedMaxAgeSec Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> SharedMaxAgeSec { get; set; }
public Nullable<int> SharedMaxAgeSec { get; set; }
Public Property SharedMaxAgeSec As Nullable(Of Integer)
    Get
    Set
Public Property SharedMaxAgeSec As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> SharedMaxAgeSec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
public:
property Nullable<int> SharedMaxAgeSec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member SharedMaxAgeSec : Nullable<int> with get, set
member SharedMaxAgeSec : Nullable<int> with get, set

Property Value

Type: Online Nullable Online Int32
See Also
CacheControlAttribute Class
CacheControlAttribute Members
NFX.Wave.MVC Namespace


ClientRecord Structure

ClientRecord Structure NFX Class Library

Represents MVC action result that returns ROW as JSON object for WV.RecordModel(...) ctor init

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ClientRecord : IActionResult
public struct ClientRecord : IActionResult
Public Structure ClientRecord
    Implements IActionResult
Public Structure ClientRecord
    Implements IActionResult
public value class ClientRecord : IActionResult
public value class ClientRecord : IActionResult
[<SealedAttribute>]
type ClientRecord =
    struct
        interface IActionResult
    end
[<SealedAttribute>]
type ClientRecord =
    struct
        interface IActionResult
    end
See Also
ClientRecord Members
NFX.Wave.MVC Namespace


ClientRecord Members

ClientRecord Members NFX Class Library

The ClientRecord type exposes the following members.
Constructors
 | Name | Description
Public method | ClientRecord(Row, Exception, Func Schema FieldDef, JSONDataMap , String, String, String) | Initializes a new instance of the ClientRecord class
Public method | ClientRecord(Row, Exception, String, String, String, ModelFieldValueListLookupFunc) | Initializes a new instance of the ClientRecord class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Execute |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | IsoLang |
Public field | RecID |
Public field | Row |
Public field | Target |
Public field | ValidationError |
Public field | ValueListLookupFunc |
Back to Top
See Also
ClientRecord Structure
NFX.Wave.MVC Namespace


ClientRecord Constructor

ClientRecord Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ClientRecord(Row, Exception, Func Schema FieldDef, JSONDataMap , String, String, String) | Initializes a new instance of the ClientRecord class
Public method | ClientRecord(Row, Exception, String, String, String, ModelFieldValueListLookupFunc) | Initializes a new instance of the ClientRecord class
Back to Top
See Also
ClientRecord Structure
ClientRecord Members
NFX.Wave.MVC Namespace


ClientRecord Constructor (Row, Exception, Func(Schema.FieldDef, JSONDataMap), String, String, String)

ClientRecord Constructor (Row, Exception, Func Schema FieldDef, JSONDataMap , String, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientRecord class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientRecord(
    Row row,
    Exception validationError,
    Func<Schema..::..FieldDef, JSONDataMap> simpleValueListLookupFunc,
    string recID = null,
    string target = null,
    string isoLang = null
)
public ClientRecord(
    Row row,
    Exception validationError,
    Func<Schema..::..FieldDef, JSONDataMap> simpleValueListLookupFunc,
    string recID = null,
    string target = null,
    string isoLang = null
)
Public Sub New (
    row As Row,
    validationError As Exception,
    simpleValueListLookupFunc As Func(Of Schema..::..FieldDef, JSONDataMap),
    Optional recID As String = Nothing,
    Optional target As String = Nothing,
    Optional isoLang As String = Nothing
)
Public Sub New (
    row As Row,
    validationError As Exception,
    simpleValueListLookupFunc As Func(Of Schema..::..FieldDef, JSONDataMap),
    Optional recID As String = Nothing,
    Optional target As String = Nothing,
    Optional isoLang As String = Nothing
)
public:
ClientRecord(
    Row^ row,
    Exception^ validationError,
    Func<Schema..::..FieldDef^, JSONDataMap^>^ simpleValueListLookupFunc,
    String^ recID = nullptr,
    String^ target = nullptr,
    String^ isoLang = nullptr
)
public:
ClientRecord(
    Row^ row,
    Exception^ validationError,
    Func<Schema..::..FieldDef^, JSONDataMap^>^ simpleValueListLookupFunc,
    String^ recID = nullptr,
    String^ target = nullptr,
    String^ isoLang = nullptr
)
new :
        row : Row *
        validationError : Exception *
        simpleValueListLookupFunc : Func<Schema..::..FieldDef, JSONDataMap> *
        ?recID : string *
        ?target : string *
        ?isoLang : string
(* Defaults:
        let _recID = defaultArg recID null
        let _target = defaultArg target null
        let _isoLang = defaultArg isoLang null
*)
-> ClientRecord
new :
        row : Row *
        validationError : Exception *
        simpleValueListLookupFunc : Func<Schema..::..FieldDef, JSONDataMap> *
        ?recID : string *
        ?target : string *
        ?isoLang : string
(* Defaults:
        let _recID = defaultArg recID null
        let _target = defaultArg target null
        let _isoLang = defaultArg isoLang null
*)
-> ClientRecord

Parameters

row
Type: NFX.DataAccess.CRUD Row
validationError
Type: Online System Exception
simpleValueListLookupFunc
Type: Online System Func Schema FieldDef, JSONDataMap
recID (Optional)
Type: Online System String
target (Optional)
Type: Online System String
isoLang (Optional)
Type: Online System String
See Also
ClientRecord Structure
ClientRecord Members
ClientRecord Overload
NFX.Wave.MVC Namespace


ClientRecord Constructor (Row, Exception, String, String, String, ModelFieldValueListLookupFunc)

ClientRecord Constructor (Row, Exception, String, String, String, ModelFieldValueListLookupFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientRecord class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientRecord(
    Row row,
    Exception validationError,
    string recID = null,
    string target = null,
    string isoLang = null,
    ModelFieldValueListLookupFunc valueListLookupFunc = null
)
public ClientRecord(
    Row row,
    Exception validationError,
    string recID = null,
    string target = null,
    string isoLang = null,
    ModelFieldValueListLookupFunc valueListLookupFunc = null
)
Public Sub New (
    row As Row,
    validationError As Exception,
    Optional recID As String = Nothing,
    Optional target As String = Nothing,
    Optional isoLang As String = Nothing,
    Optional valueListLookupFunc As ModelFieldValueListLookupFunc = Nothing
)
Public Sub New (
    row As Row,
    validationError As Exception,
    Optional recID As String = Nothing,
    Optional target As String = Nothing,
    Optional isoLang As String = Nothing,
    Optional valueListLookupFunc As ModelFieldValueListLookupFunc = Nothing
)
public:
ClientRecord(
    Row^ row,
    Exception^ validationError,
    String^ recID = nullptr,
    String^ target = nullptr,
    String^ isoLang = nullptr,
    ModelFieldValueListLookupFunc^ valueListLookupFunc = nullptr
)
public:
ClientRecord(
    Row^ row,
    Exception^ validationError,
    String^ recID = nullptr,
    String^ target = nullptr,
    String^ isoLang = nullptr,
    ModelFieldValueListLookupFunc^ valueListLookupFunc = nullptr
)
new :
        row : Row *
        validationError : Exception *
        ?recID : string *
        ?target : string *
        ?isoLang : string *
        ?valueListLookupFunc : ModelFieldValueListLookupFunc
(* Defaults:
        let _recID = defaultArg recID null
        let _target = defaultArg target null
        let _isoLang = defaultArg isoLang null
        let _valueListLookupFunc = defaultArg valueListLookupFunc null
*)
-> ClientRecord
new :
        row : Row *
        validationError : Exception *
        ?recID : string *
        ?target : string *
        ?isoLang : string *
        ?valueListLookupFunc : ModelFieldValueListLookupFunc
(* Defaults:
        let _recID = defaultArg recID null
        let _target = defaultArg target null
        let _isoLang = defaultArg isoLang null
        let _valueListLookupFunc = defaultArg valueListLookupFunc null
*)
-> ClientRecord

Parameters

row
Type: NFX.DataAccess.CRUD Row
validationError
Type: Online System Exception
recID (Optional)
Type: Online System String
target (Optional)
Type: Online System String
isoLang (Optional)
Type: Online System String
valueListLookupFunc (Optional)
Type: NFX.Wave.Client ModelFieldValueListLookupFunc
See Also
ClientRecord Structure
ClientRecord Members
ClientRecord Overload
NFX.Wave.MVC Namespace


ClientRecord Fields

ClientRecord Fields NFX Class Library

The ClientRecord type exposes the following members.
Fields
 | Name | Description
Public field | IsoLang |
Public field | RecID |
Public field | Row |
Public field | Target |
Public field | ValidationError |
Public field | ValueListLookupFunc |
Back to Top
See Also
ClientRecord Structure
NFX.Wave.MVC Namespace


ClientRecord.IsoLang Field

ClientRecord IsoLang Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string IsoLang
public readonly string IsoLang
Public ReadOnly IsoLang As String
Public ReadOnly IsoLang As String
public:
initonly String^ IsoLang
public:
initonly String^ IsoLang
val IsoLang: string
val IsoLang: string

Field Value

Type: Online String
See Also
ClientRecord Structure
ClientRecord Members
NFX.Wave.MVC Namespace


ClientRecord.RecID Field

ClientRecord RecID Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string RecID
public readonly string RecID
Public ReadOnly RecID As String
Public ReadOnly RecID As String
public:
initonly String^ RecID
public:
initonly String^ RecID
val RecID: string
val RecID: string

Field Value

Type: Online String
See Also
ClientRecord Structure
ClientRecord Members
NFX.Wave.MVC Namespace


ClientRecord.Row Field

ClientRecord Row Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Row Row
public readonly Row Row
Public ReadOnly Row As Row
Public ReadOnly Row As Row
public:
initonly Row^ Row
public:
initonly Row^ Row
val Row: Row
val Row: Row

Field Value

Type: Row
See Also
ClientRecord Structure
ClientRecord Members
NFX.Wave.MVC Namespace


ClientRecord.Target Field

ClientRecord Target Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Target
public readonly string Target
Public ReadOnly Target As String
Public ReadOnly Target As String
public:
initonly String^ Target
public:
initonly String^ Target
val Target: string
val Target: string

Field Value

Type: Online String
See Also
ClientRecord Structure
ClientRecord Members
NFX.Wave.MVC Namespace


ClientRecord.ValidationError Field

ClientRecord ValidationError Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Exception ValidationError
public readonly Exception ValidationError
Public ReadOnly ValidationError As Exception
Public ReadOnly ValidationError As Exception
public:
initonly Exception^ ValidationError
public:
initonly Exception^ ValidationError
val ValidationError: Exception
val ValidationError: Exception

Field Value

Type: Online Exception
See Also
ClientRecord Structure
ClientRecord Members
NFX.Wave.MVC Namespace


ClientRecord.ValueListLookupFunc Field

ClientRecord ValueListLookupFunc Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ModelFieldValueListLookupFunc ValueListLookupFunc
public readonly ModelFieldValueListLookupFunc ValueListLookupFunc
Public ReadOnly ValueListLookupFunc As ModelFieldValueListLookupFunc
Public ReadOnly ValueListLookupFunc As ModelFieldValueListLookupFunc
public:
initonly ModelFieldValueListLookupFunc^ ValueListLookupFunc
public:
initonly ModelFieldValueListLookupFunc^ ValueListLookupFunc
val ValueListLookupFunc: ModelFieldValueListLookupFunc
val ValueListLookupFunc: ModelFieldValueListLookupFunc

Field Value

Type: ModelFieldValueListLookupFunc
See Also
ClientRecord Structure
ClientRecord Members
NFX.Wave.MVC Namespace


ClientRecord Methods

ClientRecord Methods NFX Class Library

The ClientRecord type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Execute |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientRecord Structure
NFX.Wave.MVC Namespace


ClientRecord.Execute Method

ClientRecord Execute Method NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Execute(
    Controller controller,
    WorkContext work
)
public void Execute(
    Controller controller,
    WorkContext work
)
Public Sub Execute (
    controller As Controller,
    work As WorkContext
)
Public Sub Execute (
    controller As Controller,
    work As WorkContext
)
public:
virtual void Execute(
    Controller^ controller,
    WorkContext^ work
) sealed
public:
virtual void Execute(
    Controller^ controller,
    WorkContext^ work
) sealed
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
override Execute :
        controller : Controller *
        work : WorkContext -> unit
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
override Execute :
        controller : Controller *
        work : WorkContext -> unit

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext

Implements

IActionResult Execute(Controller, WorkContext)
See Also
ClientRecord Structure
ClientRecord Members
NFX.Wave.MVC Namespace


Controller Class

Controller Class NFX Class Library

Represents controller that all MVC controllers must inherit from
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Wave.MVC Controller

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Controller : DisposableObject
public abstract class Controller : DisposableObject
Public MustInherit Class Controller
    Inherits DisposableObject
Public MustInherit Class Controller
    Inherits DisposableObject
public ref class Controller abstract : public DisposableObject
public ref class Controller abstract : public DisposableObject
[<AbstractClassAttribute>]
type Controller =
    class
        inherit DisposableObject
    end
[<AbstractClassAttribute>]
type Controller =
    class
        inherit DisposableObject
    end
See Also
Controller Members
NFX.Wave.MVC Namespace


Controller Members

Controller Members NFX Class Library

The Controller type exposes the following members.
Constructors
 | Name | Description
Protected method | Controller | Initializes a new instance of the Controller class
Back to Top
Methods
 | Name | Description
Protected method | ActionInvocationFinally | Override to add logic/filtering finally after the invocation of action method
Protected method | AfterActionInvocation | Override to add logic/filtering right after the invocation of action method. Must return the result (which can be altered/filtered). The default implementation calls ActionFilters
Protected method | BeforeActionInvocation | Override to add logic/filtering right before the invocation of action method. Return TRUE to indicate that request has already been handled and no need to call method body and AfterActionInvocation in which case return result via 'out result' paremeter. The default implementation calls ActionFilters
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | FindMatchingAction | Override to perform custom action name + params -> MethodInfo, param array resolution. This method rarely needs to be overridden because the framework does the resolution that suites most cases
 | GetActionFilters(MethodInfo) | Returns cached (for performance)ordered array of ActionFilterAttributes for action method
 | GetActionFilters(Type) | Returns cached (for performance)ordered array of ActionFilterAttributes for type
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | DEFAULT_MVC_ACTION |
 | DEFAULT_VAR_MVC_ACTION |
Protected field | m_WorkContext |
Back to Top
Properties
 | Name | Description
Public property | ActionVarName |
Public property | DefaultActionName |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | WorkContext | Returns current work context
Back to Top
See Also
Controller Class
NFX.Wave.MVC Namespace


Controller Constructor

Controller Constructor NFX Class Library

Initializes a new instance of the Controller class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Controller()
protected Controller()
Protected Sub New
Protected Sub New
protected:
Controller()
protected:
Controller()
new : unit -> Controller
new : unit -> Controller
See Also
Controller Class
Controller Members
NFX.Wave.MVC Namespace


Controller Fields

Controller Fields NFX Class Library

The Controller type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_MVC_ACTION |
 | DEFAULT_VAR_MVC_ACTION |
Protected field | m_WorkContext |
Back to Top
See Also
Controller Class
NFX.Wave.MVC Namespace


Controller.DEFAULT_MVC_ACTION Field

Controller DEFAULT_MVC_ACTION Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_MVC_ACTION
public const string DEFAULT_MVC_ACTION
Public Const DEFAULT_MVC_ACTION As String
Public Const DEFAULT_MVC_ACTION As String
public:
literal String^ DEFAULT_MVC_ACTION
public:
literal String^ DEFAULT_MVC_ACTION
static val mutable DEFAULT_MVC_ACTION: string
static val mutable DEFAULT_MVC_ACTION: string

Field Value

Type: Online String
See Also
Controller Class
Controller Members
NFX.Wave.MVC Namespace


Controller.DEFAULT_VAR_MVC_ACTION Field

Controller DEFAULT_VAR_MVC_ACTION Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_VAR_MVC_ACTION
public const string DEFAULT_VAR_MVC_ACTION
Public Const DEFAULT_VAR_MVC_ACTION As String
Public Const DEFAULT_VAR_MVC_ACTION As String
public:
literal String^ DEFAULT_VAR_MVC_ACTION
public:
literal String^ DEFAULT_VAR_MVC_ACTION
static val mutable DEFAULT_VAR_MVC_ACTION: string
static val mutable DEFAULT_VAR_MVC_ACTION: string

Field Value

Type: Online String
See Also
Controller Class
Controller Members
NFX.Wave.MVC Namespace


Controller.m_WorkContext Field

Controller m_WorkContext Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
internal WorkContext m_WorkContext
[NonSerializedAttribute]
internal WorkContext m_WorkContext
<NonSerializedAttribute>
Friend m_WorkContext As WorkContext
<NonSerializedAttribute>
Friend m_WorkContext As WorkContext
internal:
[NonSerializedAttribute]
WorkContext^ m_WorkContext
internal:
[NonSerializedAttribute]
WorkContext^ m_WorkContext
[<NonSerializedAttribute>]
val mutable internal m_WorkContext: WorkContext
[<NonSerializedAttribute>]
val mutable internal m_WorkContext: WorkContext

Field Value

Type: WorkContext
See Also
Controller Class
Controller Members
NFX.Wave.MVC Namespace


Controller Methods

Controller Methods NFX Class Library

The Controller type exposes the following members.
Methods
 | Name | Description
Protected method | ActionInvocationFinally | Override to add logic/filtering finally after the invocation of action method
Protected method | AfterActionInvocation | Override to add logic/filtering right after the invocation of action method. Must return the result (which can be altered/filtered). The default implementation calls ActionFilters
Protected method | BeforeActionInvocation | Override to add logic/filtering right before the invocation of action method. Return TRUE to indicate that request has already been handled and no need to call method body and AfterActionInvocation in which case return result via 'out result' paremeter. The default implementation calls ActionFilters
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | FindMatchingAction | Override to perform custom action name + params -> MethodInfo, param array resolution. This method rarely needs to be overridden because the framework does the resolution that suites most cases
 | GetActionFilters(MethodInfo) | Returns cached (for performance)ordered array of ActionFilterAttributes for action method
 | GetActionFilters(Type) | Returns cached (for performance)ordered array of ActionFilterAttributes for type
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Controller Class
NFX.Wave.MVC Namespace


Controller.ActionInvocationFinally Method

Controller ActionInvocationFinally Method NFX Class Library

Override to add logic/filtering finally after the invocation of action method

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void ActionInvocationFinally(
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    Object result
)
protected internal virtual void ActionInvocationFinally(
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    Object result
)
Protected Friend Overridable Sub ActionInvocationFinally (
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    result As Object
)
Protected Friend Overridable Sub ActionInvocationFinally (
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    result As Object
)
protected public:
virtual void ActionInvocationFinally(
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^ result
)
protected public:
virtual void ActionInvocationFinally(
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^ result
)
abstract ActionInvocationFinally :
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object -> unit
override ActionInvocationFinally :
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object -> unit
abstract ActionInvocationFinally :
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object -> unit
override ActionInvocationFinally :
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object -> unit

Parameters

work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object
See Also
Controller Class
Controller Members
NFX.Wave.MVC Namespace


Controller.AfterActionInvocation Method

Controller AfterActionInvocation Method NFX Class Library

Override to add logic/filtering right after the invocation of action method. Must return the result (which can be altered/filtered). The default implementation calls ActionFilters

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Object AfterActionInvocation(
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    Object result
)
protected internal virtual Object AfterActionInvocation(
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    Object result
)
Protected Friend Overridable Function AfterActionInvocation (
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    result As Object
) As Object
Protected Friend Overridable Function AfterActionInvocation (
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    result As Object
) As Object
protected public:
virtual Object^ AfterActionInvocation(
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^ result
)
protected public:
virtual Object^ AfterActionInvocation(
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^ result
)
abstract AfterActionInvocation :
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object -> Object
override AfterActionInvocation :
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object -> Object
abstract AfterActionInvocation :
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object -> Object
override AfterActionInvocation :
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object -> Object

Parameters

work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object

Return Value

Type: Online Object
See Also
Controller Class
Controller Members
NFX.Wave.MVC Namespace


Controller.BeforeActionInvocation Method

Controller BeforeActionInvocation Method NFX Class Library

Override to add logic/filtering right before the invocation of action method. Return TRUE to indicate that request has already been handled and no need to call method body and AfterActionInvocation in which case return result via 'out result' paremeter. The default implementation calls ActionFilters

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual bool BeforeActionInvocation(
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
protected internal virtual bool BeforeActionInvocation(
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
Protected Friend Overridable Function BeforeActionInvocation (
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
Protected Friend Overridable Function BeforeActionInvocation (
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
protected public:
virtual bool BeforeActionInvocation(
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
)
protected public:
virtual bool BeforeActionInvocation(
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
)
abstract BeforeActionInvocation :
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
override BeforeActionInvocation :
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
abstract BeforeActionInvocation :
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
override BeforeActionInvocation :
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool

Parameters

work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Controller Class
Controller Members
NFX.Wave.MVC Namespace


Controller.FindMatchingAction Method

Controller FindMatchingAction Method NFX Class Library

Override to perform custom action name + params -> MethodInfo, param array resolution. This method rarely needs to be overridden because the framework does the resolution that suites most cases

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual MethodInfo FindMatchingAction(
    WorkContext work,
    string action,
    out Object[] args
)
protected internal virtual MethodInfo FindMatchingAction(
    WorkContext work,
    string action,
    out Object[] args
)
Protected Friend Overridable Function FindMatchingAction (
    work As WorkContext,
    action As String,
    <OutAttribute> ByRef args As Object()
) As MethodInfo
Protected Friend Overridable Function FindMatchingAction (
    work As WorkContext,
    action As String,
    <OutAttribute> ByRef args As Object()
) As MethodInfo
protected public:
virtual MethodInfo^ FindMatchingAction(
    WorkContext^ work,
    String^ action,
    [OutAttribute] array<Object^>^% args
)
protected public:
virtual MethodInfo^ FindMatchingAction(
    WorkContext^ work,
    String^ action,
    [OutAttribute] array<Object^>^% args
)
abstract FindMatchingAction :
        work : WorkContext *
        action : string *
        args : Object[] byref -> MethodInfo
override FindMatchingAction :
        work : WorkContext *
        action : string *
        args : Object[] byref -> MethodInfo
abstract FindMatchingAction :
        work : WorkContext *
        action : string *
        args : Object[] byref -> MethodInfo
override FindMatchingAction :
        work : WorkContext *
        action : string *
        args : Object[] byref -> MethodInfo

Parameters

work
Type: NFX.Wave WorkContext
action
Type: Online System String
args
Type: Online System Object

Return Value

Type: Online MethodInfo
See Also
Controller Class
Controller Members
NFX.Wave.MVC Namespace


Controller.GetActionFilters Method

Controller GetActionFilters Method NFX Class Library

Overload List
Name | Description
GetActionFilters(MethodInfo) | Returns cached (for performance)ordered array of ActionFilterAttributes for action method
GetActionFilters(Type) | Returns cached (for performance)ordered array of ActionFilterAttributes for type
Back to Top
See Also
Controller Class
Controller Members
NFX.Wave.MVC Namespace


Controller.GetActionFilters Method (MethodInfo)

Controller GetActionFilters Method (MethodInfo) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns cached (for performance)ordered array of ActionFilterAttributes for action method

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static ActionFilterAttribute[] GetActionFilters(
    MethodInfo mi
)
protected static ActionFilterAttribute[] GetActionFilters(
    MethodInfo mi
)
Protected Shared Function GetActionFilters (
    mi As MethodInfo
) As ActionFilterAttribute()
Protected Shared Function GetActionFilters (
    mi As MethodInfo
) As ActionFilterAttribute()
protected:
static array<ActionFilterAttribute^>^ GetActionFilters(
    MethodInfo^ mi
)
protected:
static array<ActionFilterAttribute^>^ GetActionFilters(
    MethodInfo^ mi
)
static member GetActionFilters :
        mi : MethodInfo -> ActionFilterAttribute[]
static member GetActionFilters :
        mi : MethodInfo -> ActionFilterAttribute[]

Parameters

mi
Type: Online System.Reflection MethodInfo

Return Value

Type: ActionFilterAttribute
See Also
Controller Class
Controller Members
GetActionFilters Overload
NFX.Wave.MVC Namespace


Controller.GetActionFilters Method (Type)

Controller GetActionFilters Method (Type) NFX Class Library

Returns cached (for performance)ordered array of ActionFilterAttributes for type

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static ActionFilterAttribute[] GetActionFilters(
    Type tp
)
protected static ActionFilterAttribute[] GetActionFilters(
    Type tp
)
Protected Shared Function GetActionFilters (
    tp As Type
) As ActionFilterAttribute()
Protected Shared Function GetActionFilters (
    tp As Type
) As ActionFilterAttribute()
protected:
static array<ActionFilterAttribute^>^ GetActionFilters(
    Type^ tp
)
protected:
static array<ActionFilterAttribute^>^ GetActionFilters(
    Type^ tp
)
static member GetActionFilters :
        tp : Type -> ActionFilterAttribute[]
static member GetActionFilters :
        tp : Type -> ActionFilterAttribute[]

Parameters

tp
Type: Online System Type

Return Value

Type: ActionFilterAttribute
See Also
Controller Class
Controller Members
GetActionFilters Overload
NFX.Wave.MVC Namespace


Controller Properties

Controller Properties NFX Class Library

The Controller type exposes the following members.
Properties
 | Name | Description
Public property | ActionVarName |
Public property | DefaultActionName |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | WorkContext | Returns current work context
Back to Top
See Also
Controller Class
NFX.Wave.MVC Namespace


Controller.ActionVarName Property

Controller ActionVarName Property NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string ActionVarName { get; }
public virtual string ActionVarName { get; }
Public Overridable ReadOnly Property ActionVarName As String
    Get
Public Overridable ReadOnly Property ActionVarName As String
    Get
public:
virtual property String^ ActionVarName {
    String^ get ();
}
public:
virtual property String^ ActionVarName {
    String^ get ();
}
abstract ActionVarName : string with get
override ActionVarName : string with get
abstract ActionVarName : string with get
override ActionVarName : string with get

Property Value

Type: Online String
See Also
Controller Class
Controller Members
NFX.Wave.MVC Namespace


Controller.DefaultActionName Property

Controller DefaultActionName Property NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string DefaultActionName { get; }
public virtual string DefaultActionName { get; }
Public Overridable ReadOnly Property DefaultActionName As String
    Get
Public Overridable ReadOnly Property DefaultActionName As String
    Get
public:
virtual property String^ DefaultActionName {
    String^ get ();
}
public:
virtual property String^ DefaultActionName {
    String^ get ();
}
abstract DefaultActionName : string with get
override DefaultActionName : string with get
abstract DefaultActionName : string with get
override DefaultActionName : string with get

Property Value

Type: Online String
See Also
Controller Class
Controller Members
NFX.Wave.MVC Namespace


Controller.WorkContext Property

Controller WorkContext Property NFX Class Library

Returns current work context

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkContext WorkContext { get; }
public WorkContext WorkContext { get; }
Public ReadOnly Property WorkContext As WorkContext
    Get
Public ReadOnly Property WorkContext As WorkContext
    Get
public:
property WorkContext^ WorkContext {
    WorkContext^ get ();
}
public:
property WorkContext^ WorkContext {
    WorkContext^ get ();
}
member WorkContext : WorkContext with get
member WorkContext : WorkContext with get

Property Value

Type: WorkContext
See Also
Controller Class
Controller Members
NFX.Wave.MVC Namespace


ControllerInfo Class

ControllerInfo Class NFX Class Library

Provides reflection information about controller type. This is a framework internal method which is not intended to be used by business logic developers
Inheritance Hierarchy
Online System Object
NFX.Wave.MVC ControllerInfo

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ControllerInfo : INamed
public sealed class ControllerInfo : INamed
Public NotInheritable Class ControllerInfo
    Implements INamed
Public NotInheritable Class ControllerInfo
    Implements INamed
public ref class ControllerInfo sealed : INamed
public ref class ControllerInfo sealed : INamed
[<SealedAttribute>]
type ControllerInfo =
    class
        interface INamed
    end
[<SealedAttribute>]
type ControllerInfo =
    class
        interface INamed
    end
See Also
ControllerInfo Members
NFX.Wave.MVC Namespace


ControllerInfo Members

ControllerInfo Members NFX Class Library

The ControllerInfo type exposes the following members.
Constructors
 | Name | Description
Public method | ControllerInfo | Initializes a new instance of the ControllerInfo class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetAllActionMethods |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
 | GetInvocationName |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
 | TypeToKeyName |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Groups |
Public field | Type |
Back to Top
Properties
 | Name | Description
Public property | Name |
Back to Top
See Also
ControllerInfo Class
NFX.Wave.MVC Namespace


ControllerInfo Constructor

ControllerInfo Constructor NFX Class Library

Initializes a new instance of the ControllerInfo class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ControllerInfo(
    Type type
)
public ControllerInfo(
    Type type
)
Public Sub New (
    type As Type
)
Public Sub New (
    type As Type
)
public:
ControllerInfo(
    Type^ type
)
public:
ControllerInfo(
    Type^ type
)
new :
        type : Type -> ControllerInfo
new :
        type : Type -> ControllerInfo

Parameters

type
Type: Online System Type
See Also
ControllerInfo Class
ControllerInfo Members
NFX.Wave.MVC Namespace


ControllerInfo Fields

ControllerInfo Fields NFX Class Library

The ControllerInfo type exposes the following members.
Fields
 | Name | Description
Public field | Groups |
Public field | Type |
Back to Top
See Also
ControllerInfo Class
NFX.Wave.MVC Namespace


ControllerInfo.Groups Field

ControllerInfo Groups Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IRegistry<ActionGroupInfo> Groups
public readonly IRegistry<ActionGroupInfo> Groups
Public ReadOnly Groups As IRegistry(Of ActionGroupInfo)
Public ReadOnly Groups As IRegistry(Of ActionGroupInfo)
public:
initonly IRegistry<ActionGroupInfo^>^ Groups
public:
initonly IRegistry<ActionGroupInfo^>^ Groups
val Groups: IRegistry<ActionGroupInfo>
val Groups: IRegistry<ActionGroupInfo>

Field Value

Type: IRegistry ActionGroupInfo
See Also
ControllerInfo Class
ControllerInfo Members
NFX.Wave.MVC Namespace


ControllerInfo.Type Field

ControllerInfo Type Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Type Type
public readonly Type Type
Public ReadOnly Type As Type
Public ReadOnly Type As Type
public:
initonly Type^ Type
public:
initonly Type^ Type
val Type: Type
val Type: Type

Field Value

Type: Online Type
See Also
ControllerInfo Class
ControllerInfo Members
NFX.Wave.MVC Namespace


ControllerInfo Methods

ControllerInfo Methods NFX Class Library

The ControllerInfo type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetAllActionMethods |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
 | GetInvocationName |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
 | TypeToKeyName |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ControllerInfo Class
NFX.Wave.MVC Namespace


ControllerInfo.GetAllActionMethods Method

ControllerInfo GetAllActionMethods Method NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal IEnumerable<MethodInfo> GetAllActionMethods()
internal IEnumerable<MethodInfo> GetAllActionMethods()
Friend Function GetAllActionMethods As IEnumerable(Of MethodInfo)
Friend Function GetAllActionMethods As IEnumerable(Of MethodInfo)
internal:
IEnumerable<MethodInfo^>^ GetAllActionMethods()
internal:
IEnumerable<MethodInfo^>^ GetAllActionMethods()
internal member GetAllActionMethods : unit -> IEnumerable<MethodInfo>
internal member GetAllActionMethods : unit -> IEnumerable<MethodInfo>

Return Value

Type: Online IEnumerable Online MethodInfo
See Also
ControllerInfo Class
ControllerInfo Members
NFX.Wave.MVC Namespace


ControllerInfo.GetInvocationName Method

ControllerInfo GetInvocationName Method NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetInvocationName(
    MethodInfo mi
)
public static string GetInvocationName(
    MethodInfo mi
)
Public Shared Function GetInvocationName (
    mi As MethodInfo
) As String
Public Shared Function GetInvocationName (
    mi As MethodInfo
) As String
public:
static String^ GetInvocationName(
    MethodInfo^ mi
)
public:
static String^ GetInvocationName(
    MethodInfo^ mi
)
static member GetInvocationName :
        mi : MethodInfo -> string
static member GetInvocationName :
        mi : MethodInfo -> string

Parameters

mi
Type: Online System.Reflection MethodInfo

Return Value

Type: Online String
See Also
ControllerInfo Class
ControllerInfo Members
NFX.Wave.MVC Namespace


ControllerInfo.TypeToKeyName Method

ControllerInfo TypeToKeyName Method NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string TypeToKeyName(
    Type type
)
public static string TypeToKeyName(
    Type type
)
Public Shared Function TypeToKeyName (
    type As Type
) As String
Public Shared Function TypeToKeyName (
    type As Type
) As String
public:
static String^ TypeToKeyName(
    Type^ type
)
public:
static String^ TypeToKeyName(
    Type^ type
)
static member TypeToKeyName :
        type : Type -> string
static member TypeToKeyName :
        type : Type -> string

Parameters

type
Type: Online System Type

Return Value

Type: Online String
See Also
ControllerInfo Class
ControllerInfo Members
NFX.Wave.MVC Namespace


ControllerInfo Properties

ControllerInfo Properties NFX Class Library

The ControllerInfo type exposes the following members.
Properties
 | Name | Description
Public property | Name |
Back to Top
See Also
ControllerInfo Class
NFX.Wave.MVC Namespace


ControllerInfo.Name Property

ControllerInfo Name Property NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
ControllerInfo Class
ControllerInfo Members
NFX.Wave.MVC Namespace


FileDownload Structure

FileDownload Structure NFX Class Library

Represents MVC action result that downloads a local file

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct FileDownload : IActionResult
public struct FileDownload : IActionResult
Public Structure FileDownload
    Implements IActionResult
Public Structure FileDownload
    Implements IActionResult
public value class FileDownload : IActionResult
public value class FileDownload : IActionResult
[<SealedAttribute>]
type FileDownload =
    struct
        interface IActionResult
    end
[<SealedAttribute>]
type FileDownload =
    struct
        interface IActionResult
    end
See Also
FileDownload Members
NFX.Wave.MVC Namespace


FileDownload Members

FileDownload Members NFX Class Library

The FileDownload type exposes the following members.
Constructors
 | Name | Description
Public method | FileDownload | Initializes a new instance of the FileDownload class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Execute |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | BufferSize | Download buffer size. Leave unchanged in most cases
Public field | IsAttachment | When true, asks user to save as attachment
Public field | LocalFileName | Local file name
Back to Top
See Also
FileDownload Structure
NFX.Wave.MVC Namespace


FileDownload Constructor

FileDownload Constructor NFX Class Library

Initializes a new instance of the FileDownload class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileDownload(
    string fileName,
    bool isAttachment = false,
    int bufferSize = 131072
)
public FileDownload(
    string fileName,
    bool isAttachment = false,
    int bufferSize = 131072
)
Public Sub New (
    fileName As String,
    Optional isAttachment As Boolean = false,
    Optional bufferSize As Integer = 131072
)
Public Sub New (
    fileName As String,
    Optional isAttachment As Boolean = false,
    Optional bufferSize As Integer = 131072
)
public:
FileDownload(
    String^ fileName,
    bool isAttachment = false,
    int bufferSize = 131072
)
public:
FileDownload(
    String^ fileName,
    bool isAttachment = false,
    int bufferSize = 131072
)
new :
        fileName : string *
        ?isAttachment : bool *
        ?bufferSize : int
(* Defaults:
        let _isAttachment = defaultArg isAttachment false
        let _bufferSize = defaultArg bufferSize 131072
*)
-> FileDownload
new :
        fileName : string *
        ?isAttachment : bool *
        ?bufferSize : int
(* Defaults:
        let _isAttachment = defaultArg isAttachment false
        let _bufferSize = defaultArg bufferSize 131072
*)
-> FileDownload

Parameters

fileName
Type: Online System String
isAttachment (Optional)
Type: Online System Boolean
bufferSize (Optional)
Type: Online System Int32
See Also
FileDownload Structure
FileDownload Members
NFX.Wave.MVC Namespace


FileDownload Fields

FileDownload Fields NFX Class Library

The FileDownload type exposes the following members.
Fields
 | Name | Description
Public field | BufferSize | Download buffer size. Leave unchanged in most cases
Public field | IsAttachment | When true, asks user to save as attachment
Public field | LocalFileName | Local file name
Back to Top
See Also
FileDownload Structure
NFX.Wave.MVC Namespace


FileDownload.BufferSize Field

FileDownload BufferSize Field NFX Class Library

Download buffer size. Leave unchanged in most cases

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int BufferSize
public readonly int BufferSize
Public ReadOnly BufferSize As Integer
Public ReadOnly BufferSize As Integer
public:
initonly int BufferSize
public:
initonly int BufferSize
val BufferSize: int
val BufferSize: int

Field Value

Type: Online Int32
See Also
FileDownload Structure
FileDownload Members
NFX.Wave.MVC Namespace


FileDownload.IsAttachment Field

FileDownload IsAttachment Field NFX Class Library

When true, asks user to save as attachment

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsAttachment
public readonly bool IsAttachment
Public ReadOnly IsAttachment As Boolean
Public ReadOnly IsAttachment As Boolean
public:
initonly bool IsAttachment
public:
initonly bool IsAttachment
val IsAttachment: bool
val IsAttachment: bool

Field Value

Type: Online Boolean
See Also
FileDownload Structure
FileDownload Members
NFX.Wave.MVC Namespace


FileDownload.LocalFileName Field

FileDownload LocalFileName Field NFX Class Library

Local file name

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string LocalFileName
public readonly string LocalFileName
Public ReadOnly LocalFileName As String
Public ReadOnly LocalFileName As String
public:
initonly String^ LocalFileName
public:
initonly String^ LocalFileName
val LocalFileName: string
val LocalFileName: string

Field Value

Type: Online String
See Also
FileDownload Structure
FileDownload Members
NFX.Wave.MVC Namespace


FileDownload Methods

FileDownload Methods NFX Class Library

The FileDownload type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Execute |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FileDownload Structure
NFX.Wave.MVC Namespace


FileDownload.Execute Method

FileDownload Execute Method NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Execute(
    Controller controller,
    WorkContext work
)
public void Execute(
    Controller controller,
    WorkContext work
)
Public Sub Execute (
    controller As Controller,
    work As WorkContext
)
Public Sub Execute (
    controller As Controller,
    work As WorkContext
)
public:
virtual void Execute(
    Controller^ controller,
    WorkContext^ work
) sealed
public:
virtual void Execute(
    Controller^ controller,
    WorkContext^ work
) sealed
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
override Execute :
        controller : Controller *
        work : WorkContext -> unit
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
override Execute :
        controller : Controller *
        work : WorkContext -> unit

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext

Implements

IActionResult Execute(Controller, WorkContext)
See Also
FileDownload Structure
FileDownload Members
NFX.Wave.MVC Namespace


Http403Forbidden Structure

Http403Forbidden Structure NFX Class Library

Returns HTTP 403 - forbidden This should be used in place of returning exceptions where needed as it is faster

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Http403Forbidden : IActionResult
public struct Http403Forbidden : IActionResult
Public Structure Http403Forbidden
    Implements IActionResult
Public Structure Http403Forbidden
    Implements IActionResult
public value class Http403Forbidden : IActionResult
public value class Http403Forbidden : IActionResult
[<SealedAttribute>]
type Http403Forbidden =
    struct
        interface IActionResult
    end
[<SealedAttribute>]
type Http403Forbidden =
    struct
        interface IActionResult
    end
See Also
Http403Forbidden Members
NFX.Wave.MVC Namespace


Http403Forbidden Members

Http403Forbidden Members NFX Class Library

The Http403Forbidden type exposes the following members.
Constructors
 | Name | Description
Public method | Http403Forbidden | Initializes a new instance of the Http403Forbidden class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Execute |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Description |
Back to Top
See Also
Http403Forbidden Structure
NFX.Wave.MVC Namespace


Http403Forbidden Constructor

Http403Forbidden Constructor NFX Class Library

Initializes a new instance of the Http403Forbidden class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Http403Forbidden(
    string descr = null
)
public Http403Forbidden(
    string descr = null
)
Public Sub New (
    Optional descr As String = Nothing
)
Public Sub New (
    Optional descr As String = Nothing
)
public:
Http403Forbidden(
    String^ descr = nullptr
)
public:
Http403Forbidden(
    String^ descr = nullptr
)
new :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> Http403Forbidden
new :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> Http403Forbidden

Parameters

descr (Optional)
Type: Online System String
See Also
Http403Forbidden Structure
Http403Forbidden Members
NFX.Wave.MVC Namespace


Http403Forbidden Fields

Http403Forbidden Fields NFX Class Library

The Http403Forbidden type exposes the following members.
Fields
 | Name | Description
Public field | Description |
Back to Top
See Also
Http403Forbidden Structure
NFX.Wave.MVC Namespace


Http403Forbidden.Description Field

Http403Forbidden Description Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Description
public readonly string Description
Public ReadOnly Description As String
Public ReadOnly Description As String
public:
initonly String^ Description
public:
initonly String^ Description
val Description: string
val Description: string

Field Value

Type: Online String
See Also
Http403Forbidden Structure
Http403Forbidden Members
NFX.Wave.MVC Namespace


Http403Forbidden Methods

Http403Forbidden Methods NFX Class Library

The Http403Forbidden type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Execute |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Http403Forbidden Structure
NFX.Wave.MVC Namespace


Http403Forbidden.Execute Method

Http403Forbidden Execute Method NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Execute(
    Controller controller,
    WorkContext work
)
public void Execute(
    Controller controller,
    WorkContext work
)
Public Sub Execute (
    controller As Controller,
    work As WorkContext
)
Public Sub Execute (
    controller As Controller,
    work As WorkContext
)
public:
virtual void Execute(
    Controller^ controller,
    WorkContext^ work
) sealed
public:
virtual void Execute(
    Controller^ controller,
    WorkContext^ work
) sealed
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
override Execute :
        controller : Controller *
        work : WorkContext -> unit
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
override Execute :
        controller : Controller *
        work : WorkContext -> unit

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext

Implements

IActionResult Execute(Controller, WorkContext)
See Also
Http403Forbidden Structure
Http403Forbidden Members
NFX.Wave.MVC Namespace


Http404NotFound Structure

Http404NotFound Structure NFX Class Library

Returns HTTP 404 - not found. This should be used in place of returning exceptions where needed as it is faster

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Http404NotFound : IActionResult
public struct Http404NotFound : IActionResult
Public Structure Http404NotFound
    Implements IActionResult
Public Structure Http404NotFound
    Implements IActionResult
public value class Http404NotFound : IActionResult
public value class Http404NotFound : IActionResult
[<SealedAttribute>]
type Http404NotFound =
    struct
        interface IActionResult
    end
[<SealedAttribute>]
type Http404NotFound =
    struct
        interface IActionResult
    end
See Also
Http404NotFound Members
NFX.Wave.MVC Namespace


Http404NotFound Members

Http404NotFound Members NFX Class Library

The Http404NotFound type exposes the following members.
Constructors
 | Name | Description
Public method | Http404NotFound | Initializes a new instance of the Http404NotFound class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Execute |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Description |
Back to Top
See Also
Http404NotFound Structure
NFX.Wave.MVC Namespace


Http404NotFound Constructor

Http404NotFound Constructor NFX Class Library

Initializes a new instance of the Http404NotFound class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Http404NotFound(
    string descr = null
)
public Http404NotFound(
    string descr = null
)
Public Sub New (
    Optional descr As String = Nothing
)
Public Sub New (
    Optional descr As String = Nothing
)
public:
Http404NotFound(
    String^ descr = nullptr
)
public:
Http404NotFound(
    String^ descr = nullptr
)
new :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> Http404NotFound
new :
        ?descr : string
(* Defaults:
        let _descr = defaultArg descr null
*)
-> Http404NotFound

Parameters

descr (Optional)
Type: Online System String
See Also
Http404NotFound Structure
Http404NotFound Members
NFX.Wave.MVC Namespace


Http404NotFound Fields

Http404NotFound Fields NFX Class Library

The Http404NotFound type exposes the following members.
Fields
 | Name | Description
Public field | Description |
Back to Top
See Also
Http404NotFound Structure
NFX.Wave.MVC Namespace


Http404NotFound.Description Field

Http404NotFound Description Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Description
public readonly string Description
Public ReadOnly Description As String
Public ReadOnly Description As String
public:
initonly String^ Description
public:
initonly String^ Description
val Description: string
val Description: string

Field Value

Type: Online String
See Also
Http404NotFound Structure
Http404NotFound Members
NFX.Wave.MVC Namespace


Http404NotFound Methods

Http404NotFound Methods NFX Class Library

The Http404NotFound type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Execute |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Http404NotFound Structure
NFX.Wave.MVC Namespace


Http404NotFound.Execute Method

Http404NotFound Execute Method NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Execute(
    Controller controller,
    WorkContext work
)
public void Execute(
    Controller controller,
    WorkContext work
)
Public Sub Execute (
    controller As Controller,
    work As WorkContext
)
Public Sub Execute (
    controller As Controller,
    work As WorkContext
)
public:
virtual void Execute(
    Controller^ controller,
    WorkContext^ work
) sealed
public:
virtual void Execute(
    Controller^ controller,
    WorkContext^ work
) sealed
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
override Execute :
        controller : Controller *
        work : WorkContext -> unit
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
override Execute :
        controller : Controller *
        work : WorkContext -> unit

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext

Implements

IActionResult Execute(Controller, WorkContext)
See Also
Http404NotFound Structure
Http404NotFound Members
NFX.Wave.MVC Namespace


IActionResult Interface

IActionResult Interface NFX Class Library

Decorates entities that get returned by MVC actions and can get executed to generate some result action (command pattern)

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IActionResult
public interface IActionResult
Public Interface IActionResult
Public Interface IActionResult
public interface class IActionResult
public interface class IActionResult
type IActionResult =  interface end
type IActionResult =  interface end
See Also
IActionResult Members
NFX.Wave.MVC Namespace


IActionResult Members

IActionResult Members NFX Class Library

The IActionResult type exposes the following members.
Methods
 | Name | Description
Public method | Execute |
Back to Top
See Also
IActionResult Interface
NFX.Wave.MVC Namespace


IActionResult Methods

IActionResult Methods NFX Class Library

The IActionResult type exposes the following members.
Methods
 | Name | Description
Public method | Execute |
Back to Top
See Also
IActionResult Interface
NFX.Wave.MVC Namespace


IActionResult.Execute Method

IActionResult Execute Method NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Execute(
    Controller controller,
    WorkContext work
)
void Execute(
    Controller controller,
    WorkContext work
)
Sub Execute (
    controller As Controller,
    work As WorkContext
)
Sub Execute (
    controller As Controller,
    work As WorkContext
)
void Execute(
    Controller^ controller,
    WorkContext^ work
)
void Execute(
    Controller^ controller,
    WorkContext^ work
)
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
See Also
IActionResult Interface
IActionResult Members
NFX.Wave.MVC Namespace


JSONResult Structure

JSONResult Structure NFX Class Library

Represents MVC action result that returns JSON object with options. If JSON options are not needed then just return CLR object directly from controller action without this wrapper

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct JSONResult : IActionResult
public struct JSONResult : IActionResult
Public Structure JSONResult
    Implements IActionResult
Public Structure JSONResult
    Implements IActionResult
public value class JSONResult : IActionResult
public value class JSONResult : IActionResult
[<SealedAttribute>]
type JSONResult =
    struct
        interface IActionResult
    end
[<SealedAttribute>]
type JSONResult =
    struct
        interface IActionResult
    end
See Also
JSONResult Members
NFX.Wave.MVC Namespace


JSONResult Members

JSONResult Members NFX Class Library

The JSONResult type exposes the following members.
Constructors
 | Name | Description
Public method | JSONResult | Initializes a new instance of the JSONResult class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Execute |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Data |
Public field | Options |
Back to Top
See Also
JSONResult Structure
NFX.Wave.MVC Namespace


JSONResult Constructor

JSONResult Constructor NFX Class Library

Initializes a new instance of the JSONResult class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONResult(
    Object data,
    JSONWritingOptions options
)
public JSONResult(
    Object data,
    JSONWritingOptions options
)
Public Sub New (
    data As Object,
    options As JSONWritingOptions
)
Public Sub New (
    data As Object,
    options As JSONWritingOptions
)
public:
JSONResult(
    Object^ data,
    JSONWritingOptions^ options
)
public:
JSONResult(
    Object^ data,
    JSONWritingOptions^ options
)
new :
        data : Object *
        options : JSONWritingOptions -> JSONResult
new :
        data : Object *
        options : JSONWritingOptions -> JSONResult

Parameters

data
Type: Online System Object
options
Type: NFX.Serialization.JSON JSONWritingOptions
See Also
JSONResult Structure
JSONResult Members
NFX.Wave.MVC Namespace


JSONResult Fields

JSONResult Fields NFX Class Library

The JSONResult type exposes the following members.
Fields
 | Name | Description
Public field | Data |
Public field | Options |
Back to Top
See Also
JSONResult Structure
NFX.Wave.MVC Namespace


JSONResult.Data Field

JSONResult Data Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Object Data
public readonly Object Data
Public ReadOnly Data As Object
Public ReadOnly Data As Object
public:
initonly Object^ Data
public:
initonly Object^ Data
val Data: Object
val Data: Object

Field Value

Type: Online Object
See Also
JSONResult Structure
JSONResult Members
NFX.Wave.MVC Namespace


JSONResult.Options Field

JSONResult Options Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly JSONWritingOptions Options
public readonly JSONWritingOptions Options
Public ReadOnly Options As JSONWritingOptions
Public ReadOnly Options As JSONWritingOptions
public:
initonly JSONWritingOptions^ Options
public:
initonly JSONWritingOptions^ Options
val Options: JSONWritingOptions
val Options: JSONWritingOptions

Field Value

Type: JSONWritingOptions
See Also
JSONResult Structure
JSONResult Members
NFX.Wave.MVC Namespace


JSONResult Methods

JSONResult Methods NFX Class Library

The JSONResult type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Execute |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
JSONResult Structure
NFX.Wave.MVC Namespace


JSONResult.Execute Method

JSONResult Execute Method NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Execute(
    Controller controller,
    WorkContext work
)
public void Execute(
    Controller controller,
    WorkContext work
)
Public Sub Execute (
    controller As Controller,
    work As WorkContext
)
Public Sub Execute (
    controller As Controller,
    work As WorkContext
)
public:
virtual void Execute(
    Controller^ controller,
    WorkContext^ work
) sealed
public:
virtual void Execute(
    Controller^ controller,
    WorkContext^ work
) sealed
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
override Execute :
        controller : Controller *
        work : WorkContext -> unit
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
override Execute :
        controller : Controller *
        work : WorkContext -> unit

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext

Implements

IActionResult Execute(Controller, WorkContext)
See Also
JSONResult Structure
JSONResult Members
NFX.Wave.MVC Namespace


NoCacheAttribute Class

NoCacheAttribute Class NFX Class Library

Decorates controller classes or actions that set NoCache headers in response. By default Force = true
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Wave.MVC ActionFilterAttribute
NFX.Wave.MVC NoCacheAttribute

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = false)]
public sealed class NoCacheAttribute : ActionFilterAttribute
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = false)]
public sealed class NoCacheAttribute : ActionFilterAttribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Method, Inherited := false,
    AllowMultiple := false)>
Public NotInheritable Class NoCacheAttribute
    Inherits ActionFilterAttribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Method, Inherited := false,
    AllowMultiple := false)>
Public NotInheritable Class NoCacheAttribute
    Inherits ActionFilterAttribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Method, Inherited = false,
    AllowMultiple = false)]
public ref class NoCacheAttribute sealed : public ActionFilterAttribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Method, Inherited = false,
    AllowMultiple = false)]
public ref class NoCacheAttribute sealed : public ActionFilterAttribute
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = false)>]
type NoCacheAttribute =
    class
        inherit ActionFilterAttribute
    end
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = false)>]
type NoCacheAttribute =
    class
        inherit ActionFilterAttribute
    end
See Also
NoCacheAttribute Members
NFX.Wave.MVC Namespace


NoCacheAttribute Members

NoCacheAttribute Members NFX Class Library

The NoCacheAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | NoCacheAttribute | Initializes a new instance of the NoCacheAttribute class
Public method | NoCacheAttribute(Boolean, Int32) | Initializes a new instance of the NoCacheAttribute class
Back to Top
Methods
 | Name | Description
Protected method | ActionInvocationFinally | (Overrides ActionFilterAttribute ActionInvocationFinally(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Protected method | AfterActionInvocation | (Overrides ActionFilterAttribute AfterActionInvocation(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Protected method | BeforeActionInvocation | (Overrides ActionFilterAttribute BeforeActionInvocation(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Order | Dictates the call order (Inherited from ActionFilterAttribute.)
Back to Top
Properties
 | Name | Description
Public property | Force |
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
NoCacheAttribute Class
NFX.Wave.MVC Namespace


NoCacheAttribute Constructor

NoCacheAttribute Constructor NFX Class Library

Overload List
 | Name | Description
Public method | NoCacheAttribute | Initializes a new instance of the NoCacheAttribute class
Public method | NoCacheAttribute(Boolean, Int32) | Initializes a new instance of the NoCacheAttribute class
Back to Top
See Also
NoCacheAttribute Class
NoCacheAttribute Members
NFX.Wave.MVC Namespace


NoCacheAttribute Constructor

NoCacheAttribute Constructor NFX Class Library

Initializes a new instance of the NoCacheAttribute class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NoCacheAttribute()
public NoCacheAttribute()
Public Sub New
Public Sub New
public:
NoCacheAttribute()
public:
NoCacheAttribute()
new : unit -> NoCacheAttribute
new : unit -> NoCacheAttribute
See Also
NoCacheAttribute Class
NoCacheAttribute Members
NoCacheAttribute Overload
NFX.Wave.MVC Namespace


NoCacheAttribute Constructor (Boolean, Int32)

NoCacheAttribute Constructor (Boolean, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NoCacheAttribute class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NoCacheAttribute(
    bool force,
    int order
)
public NoCacheAttribute(
    bool force,
    int order
)
Public Sub New (
    force As Boolean,
    order As Integer
)
Public Sub New (
    force As Boolean,
    order As Integer
)
public:
NoCacheAttribute(
    bool force,
    int order
)
public:
NoCacheAttribute(
    bool force,
    int order
)
new :
        force : bool *
        order : int -> NoCacheAttribute
new :
        force : bool *
        order : int -> NoCacheAttribute

Parameters

force
Type: Online System Boolean
order
Type: Online System Int32
See Also
NoCacheAttribute Class
NoCacheAttribute Members
NoCacheAttribute Overload
NFX.Wave.MVC Namespace


NoCacheAttribute Fields

NoCacheAttribute Fields NFX Class Library

The NoCacheAttribute type exposes the following members.
Fields
 | Name | Description
Public field | Order | Dictates the call order (Inherited from ActionFilterAttribute.)
Back to Top
See Also
NoCacheAttribute Class
NFX.Wave.MVC Namespace


NoCacheAttribute Methods

NoCacheAttribute Methods NFX Class Library

The NoCacheAttribute type exposes the following members.
Methods
 | Name | Description
Protected method | ActionInvocationFinally | (Overrides ActionFilterAttribute ActionInvocationFinally(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Protected method | AfterActionInvocation | (Overrides ActionFilterAttribute AfterActionInvocation(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Protected method | BeforeActionInvocation | (Overrides ActionFilterAttribute BeforeActionInvocation(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NoCacheAttribute Class
NFX.Wave.MVC Namespace


NoCacheAttribute.ActionInvocationFinally Method

NoCacheAttribute ActionInvocationFinally Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void ActionInvocationFinally(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
protected internal override void ActionInvocationFinally(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
Protected Friend Overrides Sub ActionInvocationFinally (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
)
Protected Friend Overrides Sub ActionInvocationFinally (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
)
protected public:
virtual void ActionInvocationFinally(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
protected public:
virtual void ActionInvocationFinally(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
abstract ActionInvocationFinally :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> unit
override ActionInvocationFinally :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> unit
abstract ActionInvocationFinally :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> unit
override ActionInvocationFinally :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> unit

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object
See Also
NoCacheAttribute Class
NoCacheAttribute Members
NFX.Wave.MVC Namespace


NoCacheAttribute.AfterActionInvocation Method

NoCacheAttribute AfterActionInvocation Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool AfterActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
protected internal override bool AfterActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
Protected Friend Overrides Function AfterActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
Protected Friend Overrides Function AfterActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
protected public:
virtual bool AfterActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
protected public:
virtual bool AfterActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
abstract AfterActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
override AfterActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
abstract AfterActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
override AfterActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object

Return Value

Type: Online Boolean
See Also
NoCacheAttribute Class
NoCacheAttribute Members
NFX.Wave.MVC Namespace


NoCacheAttribute.BeforeActionInvocation Method

NoCacheAttribute BeforeActionInvocation Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool BeforeActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
protected internal override bool BeforeActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
Protected Friend Overrides Function BeforeActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
Protected Friend Overrides Function BeforeActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
protected public:
virtual bool BeforeActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
protected public:
virtual bool BeforeActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
abstract BeforeActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
override BeforeActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
abstract BeforeActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
override BeforeActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object

Return Value

Type: Online Boolean
See Also
NoCacheAttribute Class
NoCacheAttribute Members
NFX.Wave.MVC Namespace


NoCacheAttribute Properties

NoCacheAttribute Properties NFX Class Library

The NoCacheAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Force |
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
NoCacheAttribute Class
NFX.Wave.MVC Namespace


NoCacheAttribute.Force Property

NoCacheAttribute Force Property NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Force { get; private set; }
public bool Force { get; private set; }
Public Property Force As Boolean
    Get
    Private Set
Public Property Force As Boolean
    Get
    Private Set
public:
property bool Force {
    bool get ();
    private: void set (bool value);
}
public:
property bool Force {
    bool get ();
    private: void set (bool value);
}
member Force : bool with get, private set
member Force : bool with get, private set

Property Value

Type: Online Boolean
See Also
NoCacheAttribute Class
NoCacheAttribute Members
NFX.Wave.MVC Namespace


Picture Structure

Picture Structure NFX Class Library

Represents MVC action result that returns/downloads an image

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Picture : IActionResult, IDisposable
public struct Picture : IActionResult, IDisposable
Public Structure Picture
    Implements IActionResult, IDisposable
Public Structure Picture
    Implements IActionResult, IDisposable
public value class Picture : IActionResult,
    IDisposable
public value class Picture : IActionResult,
    IDisposable
[<SealedAttribute>]
type Picture =
    struct
        interface IActionResult
        interface IDisposable
    end
[<SealedAttribute>]
type Picture =
    struct
        interface IActionResult
        interface IDisposable
    end
See Also
Picture Members
NFX.Wave.MVC Namespace


Picture Members

Picture Members NFX Class Library

The Picture type exposes the following members.
Constructors
 | Name | Description
Public method | Picture | Initializes a new instance of the Picture class
Back to Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Picture
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Execute |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | m_AttachmentFileName |
Back to Top
Properties
 | Name | Description
Public property | AttachmentFileName | When non-null asks user to download picture as a named attached file
Public property | Format | Download buffer size. Leave unchanged in most cases
Public property | Image | Picture image
Back to Top
See Also
Picture Structure
NFX.Wave.MVC Namespace


Picture Constructor

Picture Constructor NFX Class Library

Initializes a new instance of the Picture class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Picture(
    Image image,
    ImageFormat format,
    string attachmentFileName = null
)
public Picture(
    Image image,
    ImageFormat format,
    string attachmentFileName = null
)
Public Sub New (
    image As Image,
    format As ImageFormat,
    Optional attachmentFileName As String = Nothing
)
Public Sub New (
    image As Image,
    format As ImageFormat,
    Optional attachmentFileName As String = Nothing
)
public:
Picture(
    Image^ image,
    ImageFormat^ format,
    String^ attachmentFileName = nullptr
)
public:
Picture(
    Image^ image,
    ImageFormat^ format,
    String^ attachmentFileName = nullptr
)
new :
        image : Image *
        format : ImageFormat *
        ?attachmentFileName : string
(* Defaults:
        let _attachmentFileName = defaultArg attachmentFileName null
*)
-> Picture
new :
        image : Image *
        format : ImageFormat *
        ?attachmentFileName : string
(* Defaults:
        let _attachmentFileName = defaultArg attachmentFileName null
*)
-> Picture

Parameters

image
Type: Online System.Drawing Image
format
Type: Online System.Drawing.Imaging ImageFormat
attachmentFileName (Optional)
Type: Online System String
See Also
Picture Structure
Picture Members
NFX.Wave.MVC Namespace


Picture Fields

Picture Fields NFX Class Library

The Picture type exposes the following members.
Fields
 | Name | Description
Public field | m_AttachmentFileName |
Back to Top
See Also
Picture Structure
NFX.Wave.MVC Namespace


Picture.m_AttachmentFileName Field

Picture m_AttachmentFileName Field NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string m_AttachmentFileName
public string m_AttachmentFileName
Public m_AttachmentFileName As String
Public m_AttachmentFileName As String
public:
String^ m_AttachmentFileName
public:
String^ m_AttachmentFileName
val mutable m_AttachmentFileName: string
val mutable m_AttachmentFileName: string

Field Value

Type: Online String
See Also
Picture Structure
Picture Members
NFX.Wave.MVC Namespace


Picture Methods

Picture Methods NFX Class Library

The Picture type exposes the following members.
Methods
 | Name | Description
Public method | Dispose |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Execute |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Picture Structure
NFX.Wave.MVC Namespace


Picture.Dispose Method

Picture Dispose Method NFX Class Library

Releases all resources used by the Picture

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also
Picture Structure
Picture Members
NFX.Wave.MVC Namespace


Picture.Execute Method

Picture Execute Method NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Execute(
    Controller controller,
    WorkContext work
)
public void Execute(
    Controller controller,
    WorkContext work
)
Public Sub Execute (
    controller As Controller,
    work As WorkContext
)
Public Sub Execute (
    controller As Controller,
    work As WorkContext
)
public:
virtual void Execute(
    Controller^ controller,
    WorkContext^ work
) sealed
public:
virtual void Execute(
    Controller^ controller,
    WorkContext^ work
) sealed
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
override Execute :
        controller : Controller *
        work : WorkContext -> unit
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
override Execute :
        controller : Controller *
        work : WorkContext -> unit

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext

Implements

IActionResult Execute(Controller, WorkContext)
See Also
Picture Structure
Picture Members
NFX.Wave.MVC Namespace


Picture Properties

Picture Properties NFX Class Library

The Picture type exposes the following members.
Properties
 | Name | Description
Public property | AttachmentFileName | When non-null asks user to download picture as a named attached file
Public property | Format | Download buffer size. Leave unchanged in most cases
Public property | Image | Picture image
Back to Top
See Also
Picture Structure
NFX.Wave.MVC Namespace


Picture.AttachmentFileName Property

Picture AttachmentFileName Property NFX Class Library

When non-null asks user to download picture as a named attached file

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AttachmentFileName { get; }
public string AttachmentFileName { get; }
Public ReadOnly Property AttachmentFileName As String
    Get
Public ReadOnly Property AttachmentFileName As String
    Get
public:
property String^ AttachmentFileName {
    String^ get ();
}
public:
property String^ AttachmentFileName {
    String^ get ();
}
member AttachmentFileName : string with get
member AttachmentFileName : string with get

Property Value

Type: Online String
See Also
Picture Structure
Picture Members
NFX.Wave.MVC Namespace


Picture.Format Property

Picture Format Property NFX Class Library

Download buffer size. Leave unchanged in most cases

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ImageFormat Format { get; }
public ImageFormat Format { get; }
Public ReadOnly Property Format As ImageFormat
    Get
Public ReadOnly Property Format As ImageFormat
    Get
public:
property ImageFormat^ Format {
    ImageFormat^ get ();
}
public:
property ImageFormat^ Format {
    ImageFormat^ get ();
}
member Format : ImageFormat with get
member Format : ImageFormat with get

Property Value

Type: Online ImageFormat
See Also
Picture Structure
Picture Members
NFX.Wave.MVC Namespace


Picture.Image Property

Picture Image Property NFX Class Library

Picture image

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Image Image { get; }
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
Public ReadOnly Property Image As Image
    Get
public:
property Image^ Image {
    Image^ get ();
}
public:
property Image^ Image {
    Image^ get ();
}
member Image : Image with get
member Image : Image with get

Property Value

Type: Online Image
See Also
Picture Structure
Picture Members
NFX.Wave.MVC Namespace


Redirect Structure

Redirect Structure NFX Class Library

Represents MVC action result that redirects user to some URL

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Redirect : IActionResult
public struct Redirect : IActionResult
Public Structure Redirect
    Implements IActionResult
Public Structure Redirect
    Implements IActionResult
public value class Redirect : IActionResult
public value class Redirect : IActionResult
[<SealedAttribute>]
type Redirect =
    struct
        interface IActionResult
    end
[<SealedAttribute>]
type Redirect =
    struct
        interface IActionResult
    end
See Also
Redirect Members
NFX.Wave.MVC Namespace


Redirect Members

Redirect Members NFX Class Library

The Redirect type exposes the following members.
Constructors
 | Name | Description
Public method | Redirect | Initializes a new instance of the Redirect class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Execute |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Code | Redirect code
Public field | URL | Where to redirect user
Back to Top
See Also
Redirect Structure
NFX.Wave.MVC Namespace


Redirect Constructor

Redirect Constructor NFX Class Library

Initializes a new instance of the Redirect class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Redirect(
    string url,
    WebConsts..::..RedirectCode code = WebConsts..::..RedirectCode.Found_302
)
public Redirect(
    string url,
    WebConsts..::..RedirectCode code = WebConsts..::..RedirectCode.Found_302
)
Public Sub New (
    url As String,
    Optional code As WebConsts..::..RedirectCode = WebConsts..::..RedirectCode.Found_302
)
Public Sub New (
    url As String,
    Optional code As WebConsts..::..RedirectCode = WebConsts..::..RedirectCode.Found_302
)
public:
Redirect(
    String^ url,
    WebConsts..::..RedirectCode code = WebConsts..::..RedirectCode::Found_302
)
public:
Redirect(
    String^ url,
    WebConsts..::..RedirectCode code = WebConsts..::..RedirectCode::Found_302
)
new :
        url : string *
        ?code : WebConsts..::..RedirectCode
(* Defaults:
        let _code = defaultArg code WebConsts..::..RedirectCode.Found_302
*)
-> Redirect
new :
        url : string *
        ?code : WebConsts..::..RedirectCode
(* Defaults:
        let _code = defaultArg code WebConsts..::..RedirectCode.Found_302
*)
-> Redirect

Parameters

url
Type: Online System String
code (Optional)
Type: NFX.Web WebConsts RedirectCode
See Also
Redirect Structure
Redirect Members
NFX.Wave.MVC Namespace


Redirect Fields

Redirect Fields NFX Class Library

The Redirect type exposes the following members.
Fields
 | Name | Description
Public field | Code | Redirect code
Public field | URL | Where to redirect user
Back to Top
See Also
Redirect Structure
NFX.Wave.MVC Namespace


Redirect.Code Field

Redirect Code Field NFX Class Library

Redirect code

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly WebConsts..::..RedirectCode Code
public readonly WebConsts..::..RedirectCode Code
Public ReadOnly Code As WebConsts..::..RedirectCode
Public ReadOnly Code As WebConsts..::..RedirectCode
public:
initonly WebConsts..::..RedirectCode Code
public:
initonly WebConsts..::..RedirectCode Code
val Code: WebConsts..::..RedirectCode
val Code: WebConsts..::..RedirectCode

Field Value

Type: WebConsts RedirectCode
See Also
Redirect Structure
Redirect Members
NFX.Wave.MVC Namespace


Redirect.URL Field

Redirect URL Field NFX Class Library

Where to redirect user

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string URL
public readonly string URL
Public ReadOnly URL As String
Public ReadOnly URL As String
public:
initonly String^ URL
public:
initonly String^ URL
val URL: string
val URL: string

Field Value

Type: Online String
See Also
Redirect Structure
Redirect Members
NFX.Wave.MVC Namespace


Redirect Methods

Redirect Methods NFX Class Library

The Redirect type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Execute |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Redirect Structure
NFX.Wave.MVC Namespace


Redirect.Execute Method

Redirect Execute Method NFX Class Library

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Execute(
    Controller controller,
    WorkContext work
)
public void Execute(
    Controller controller,
    WorkContext work
)
Public Sub Execute (
    controller As Controller,
    work As WorkContext
)
Public Sub Execute (
    controller As Controller,
    work As WorkContext
)
public:
virtual void Execute(
    Controller^ controller,
    WorkContext^ work
) sealed
public:
virtual void Execute(
    Controller^ controller,
    WorkContext^ work
) sealed
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
override Execute :
        controller : Controller *
        work : WorkContext -> unit
abstract Execute :
        controller : Controller *
        work : WorkContext -> unit
override Execute :
        controller : Controller *
        work : WorkContext -> unit

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext

Implements

IActionResult Execute(Controller, WorkContext)
See Also
Redirect Structure
Redirect Members
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute Class

SessionCSRFCheckAttribute Class NFX Class Library

Decorates controller classes or actions that need to check CSRF token on POST against the user session
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Wave.MVC ActionFilterAttribute
NFX.Wave.MVC SessionCSRFCheckAttribute

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = true)]
public sealed class SessionCSRFCheckAttribute : ActionFilterAttribute
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = true)]
public sealed class SessionCSRFCheckAttribute : ActionFilterAttribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Method, Inherited := false,
    AllowMultiple := true)>
Public NotInheritable Class SessionCSRFCheckAttribute
    Inherits ActionFilterAttribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Method, Inherited := false,
    AllowMultiple := true)>
Public NotInheritable Class SessionCSRFCheckAttribute
    Inherits ActionFilterAttribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Method, Inherited = false,
    AllowMultiple = true)]
public ref class SessionCSRFCheckAttribute sealed : public ActionFilterAttribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Method, Inherited = false,
    AllowMultiple = true)]
public ref class SessionCSRFCheckAttribute sealed : public ActionFilterAttribute
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = true)>]
type SessionCSRFCheckAttribute =
    class
        inherit ActionFilterAttribute
    end
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Method, Inherited = false,
    AllowMultiple = true)>]
type SessionCSRFCheckAttribute =
    class
        inherit ActionFilterAttribute
    end
See Also
SessionCSRFCheckAttribute Members
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute Members

SessionCSRFCheckAttribute Members NFX Class Library

The SessionCSRFCheckAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | SessionCSRFCheckAttribute | Initializes a new instance of the SessionCSRFCheckAttribute class
Public method | SessionCSRFCheckAttribute(String) | Initializes a new instance of the SessionCSRFCheckAttribute class
Public method | SessionCSRFCheckAttribute(String, Boolean, Int32) | Initializes a new instance of the SessionCSRFCheckAttribute class
Back to Top
Methods
 | Name | Description
Protected method | ActionInvocationFinally | (Overrides ActionFilterAttribute ActionInvocationFinally(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Protected method | AfterActionInvocation | (Overrides ActionFilterAttribute AfterActionInvocation(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Protected method | BeforeActionInvocation | (Overrides ActionFilterAttribute BeforeActionInvocation(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | DEFAULT_TOKEN_NAME |
Public field | Order | Dictates the call order (Inherited from ActionFilterAttribute.)
Back to Top
Properties
 | Name | Description
Public property | OnlyExistingSession |
Public property | TokenName |
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
SessionCSRFCheckAttribute Class
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute Constructor

SessionCSRFCheckAttribute Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SessionCSRFCheckAttribute | Initializes a new instance of the SessionCSRFCheckAttribute class
Public method | SessionCSRFCheckAttribute(String) | Initializes a new instance of the SessionCSRFCheckAttribute class
Public method | SessionCSRFCheckAttribute(String, Boolean, Int32) | Initializes a new instance of the SessionCSRFCheckAttribute class
Back to Top
See Also
SessionCSRFCheckAttribute Class
SessionCSRFCheckAttribute Members
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute Constructor

SessionCSRFCheckAttribute Constructor NFX Class Library

Initializes a new instance of the SessionCSRFCheckAttribute class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SessionCSRFCheckAttribute()
public SessionCSRFCheckAttribute()
Public Sub New
Public Sub New
public:
SessionCSRFCheckAttribute()
public:
SessionCSRFCheckAttribute()
new : unit -> SessionCSRFCheckAttribute
new : unit -> SessionCSRFCheckAttribute
See Also
SessionCSRFCheckAttribute Class
SessionCSRFCheckAttribute Members
SessionCSRFCheckAttribute Overload
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute Constructor (String)

SessionCSRFCheckAttribute Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SessionCSRFCheckAttribute class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SessionCSRFCheckAttribute(
    string tokenName
)
public SessionCSRFCheckAttribute(
    string tokenName
)
Public Sub New (
    tokenName As String
)
Public Sub New (
    tokenName As String
)
public:
SessionCSRFCheckAttribute(
    String^ tokenName
)
public:
SessionCSRFCheckAttribute(
    String^ tokenName
)
new :
        tokenName : string -> SessionCSRFCheckAttribute
new :
        tokenName : string -> SessionCSRFCheckAttribute

Parameters

tokenName
Type: Online System String
See Also
SessionCSRFCheckAttribute Class
SessionCSRFCheckAttribute Members
SessionCSRFCheckAttribute Overload
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute Constructor (String, Boolean, Int32)

SessionCSRFCheckAttribute Constructor (String, Boolean, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SessionCSRFCheckAttribute class

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SessionCSRFCheckAttribute(
    string tokenName,
    bool onlyExistingSession,
    int order
)
public SessionCSRFCheckAttribute(
    string tokenName,
    bool onlyExistingSession,
    int order
)
Public Sub New (
    tokenName As String,
    onlyExistingSession As Boolean,
    order As Integer
)
Public Sub New (
    tokenName As String,
    onlyExistingSession As Boolean,
    order As Integer
)
public:
SessionCSRFCheckAttribute(
    String^ tokenName,
    bool onlyExistingSession,
    int order
)
public:
SessionCSRFCheckAttribute(
    String^ tokenName,
    bool onlyExistingSession,
    int order
)
new :
        tokenName : string *
        onlyExistingSession : bool *
        order : int -> SessionCSRFCheckAttribute
new :
        tokenName : string *
        onlyExistingSession : bool *
        order : int -> SessionCSRFCheckAttribute

Parameters

tokenName
Type: Online System String
onlyExistingSession
Type: Online System Boolean
order
Type: Online System Int32
See Also
SessionCSRFCheckAttribute Class
SessionCSRFCheckAttribute Members
SessionCSRFCheckAttribute Overload
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute Fields

SessionCSRFCheckAttribute Fields NFX Class Library

The SessionCSRFCheckAttribute type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_TOKEN_NAME |
Public field | Order | Dictates the call order (Inherited from ActionFilterAttribute.)
Back to Top
See Also
SessionCSRFCheckAttribute Class
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute.DEFAULT_TOKEN_NAME Field

SessionCSRFCheckAttribute DEFAULT_TOKEN_NAME Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_TOKEN_NAME
public const string DEFAULT_TOKEN_NAME
Public Const DEFAULT_TOKEN_NAME As String
Public Const DEFAULT_TOKEN_NAME As String
public:
literal String^ DEFAULT_TOKEN_NAME
public:
literal String^ DEFAULT_TOKEN_NAME
static val mutable DEFAULT_TOKEN_NAME: string
static val mutable DEFAULT_TOKEN_NAME: string

Field Value

Type: Online String
See Also
SessionCSRFCheckAttribute Class
SessionCSRFCheckAttribute Members
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute Methods

SessionCSRFCheckAttribute Methods NFX Class Library

The SessionCSRFCheckAttribute type exposes the following members.
Methods
 | Name | Description
Protected method | ActionInvocationFinally | (Overrides ActionFilterAttribute ActionInvocationFinally(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Protected method | AfterActionInvocation | (Overrides ActionFilterAttribute AfterActionInvocation(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Protected method | BeforeActionInvocation | (Overrides ActionFilterAttribute BeforeActionInvocation(Controller, WorkContext, String, MethodInfo, Object , Object ).)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SessionCSRFCheckAttribute Class
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute.ActionInvocationFinally Method

SessionCSRFCheckAttribute ActionInvocationFinally Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void ActionInvocationFinally(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
protected internal override void ActionInvocationFinally(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
Protected Friend Overrides Sub ActionInvocationFinally (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
)
Protected Friend Overrides Sub ActionInvocationFinally (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
)
protected public:
virtual void ActionInvocationFinally(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
protected public:
virtual void ActionInvocationFinally(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
abstract ActionInvocationFinally :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> unit
override ActionInvocationFinally :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> unit
abstract ActionInvocationFinally :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> unit
override ActionInvocationFinally :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> unit

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object
See Also
SessionCSRFCheckAttribute Class
SessionCSRFCheckAttribute Members
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute.AfterActionInvocation Method

SessionCSRFCheckAttribute AfterActionInvocation Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool AfterActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
protected internal override bool AfterActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
Protected Friend Overrides Function AfterActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
Protected Friend Overrides Function AfterActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
protected public:
virtual bool AfterActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
protected public:
virtual bool AfterActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
abstract AfterActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
override AfterActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
abstract AfterActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
override AfterActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object

Return Value

Type: Online Boolean
See Also
SessionCSRFCheckAttribute Class
SessionCSRFCheckAttribute Members
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute.BeforeActionInvocation Method

SessionCSRFCheckAttribute BeforeActionInvocation Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool BeforeActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
protected internal override bool BeforeActionInvocation(
    Controller controller,
    WorkContext work,
    string action,
    MethodInfo method,
    Object[] args,
    ref Object result
)
Protected Friend Overrides Function BeforeActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
Protected Friend Overrides Function BeforeActionInvocation (
    controller As Controller,
    work As WorkContext,
    action As String,
    method As MethodInfo,
    args As Object(),
    ByRef result As Object
) As Boolean
protected public:
virtual bool BeforeActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
protected public:
virtual bool BeforeActionInvocation(
    Controller^ controller,
    WorkContext^ work,
    String^ action,
    MethodInfo^ method,
    array<Object^>^ args,
    Object^% result
) override
abstract BeforeActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
override BeforeActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
abstract BeforeActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool
override BeforeActionInvocation :
        controller : Controller *
        work : WorkContext *
        action : string *
        method : MethodInfo *
        args : Object[] *
        result : Object byref -> bool

Parameters

controller
Type: NFX.Wave.MVC Controller
work
Type: NFX.Wave WorkContext
action
Type: Online System String
method
Type: Online System.Reflection MethodInfo
args
Type: Online System Object
result
Type: Online System Object

Return Value

Type: Online Boolean
See Also
SessionCSRFCheckAttribute Class
SessionCSRFCheckAttribute Members
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute Properties

SessionCSRFCheckAttribute Properties NFX Class Library

The SessionCSRFCheckAttribute type exposes the following members.
Properties
 | Name | Description
Public property | OnlyExistingSession |
Public property | TokenName |
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
SessionCSRFCheckAttribute Class
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute.OnlyExistingSession Property

SessionCSRFCheckAttribute OnlyExistingSession Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool OnlyExistingSession { get; private set; }
public bool OnlyExistingSession { get; private set; }
Public Property OnlyExistingSession As Boolean
    Get
    Private Set
Public Property OnlyExistingSession As Boolean
    Get
    Private Set
public:
property bool OnlyExistingSession {
    bool get ();
    private: void set (bool value);
}
public:
property bool OnlyExistingSession {
    bool get ();
    private: void set (bool value);
}
member OnlyExistingSession : bool with get, private set
member OnlyExistingSession : bool with get, private set

Property Value

Type: Online Boolean
See Also
SessionCSRFCheckAttribute Class
SessionCSRFCheckAttribute Members
NFX.Wave.MVC Namespace


SessionCSRFCheckAttribute.TokenName Property

SessionCSRFCheckAttribute TokenName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Wave.MVC
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TokenName { get; private set; }
public string TokenName { get; private set; }
Public Property TokenName As String
    Get
    Private Set
Public Property TokenName As String
    Get
    Private Set
public:
property String^ TokenName {
    String^ get ();
    private: void set (String^ value);
}
public:
property String^ TokenName {
    String^ get ();
    private: void set (String^ value);
}
member TokenName : string with get, private set
member TokenName : string with get, private set

Property Value

Type: Online String
See Also
SessionCSRFCheckAttribute Class
SessionCSRFCheckAttribute Members
NFX.Wave.MVC Namespace


NFX.Wave.Templatization Namespace

NFX.Wave.Templatization Namespace NFX Class Library

Classes
 | Class | Description
Public class | ResponseRenderingTarget | Renders into HttpResponse object
Public class | WaveTemplate | Defines a base class for web-related templates
Public class | WaveTemplate TModel | Wave template that is scoped to a TModel type for Model (Rendering Context)


ResponseRenderingTarget Class

ResponseRenderingTarget Class NFX Class Library

Renders into HttpResponse object
Inheritance Hierarchy
Online System Object
NFX.Wave.Templatization ResponseRenderingTarget

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ResponseRenderingTarget : IRenderingTarget
public class ResponseRenderingTarget : IRenderingTarget
Public Class ResponseRenderingTarget
    Implements IRenderingTarget
Public Class ResponseRenderingTarget
    Implements IRenderingTarget
public ref class ResponseRenderingTarget : IRenderingTarget
public ref class ResponseRenderingTarget : IRenderingTarget
type ResponseRenderingTarget =
    class
        interface IRenderingTarget
    end
type ResponseRenderingTarget =
    class
        interface IRenderingTarget
    end
See Also
ResponseRenderingTarget Members
NFX.Wave.Templatization Namespace


ResponseRenderingTarget Members

ResponseRenderingTarget Members NFX Class Library

The ResponseRenderingTarget type exposes the following members.
Constructors
 | Name | Description
Public method | ResponseRenderingTarget | Initializes a new instance of the ResponseRenderingTarget class
Back to Top
Methods
 | Name | Description
Public method | Encode |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Context | Returns HttpContext for current request
Public field | Response | Returns Response object for WorkContext
Back to Top
See Also
ResponseRenderingTarget Class
NFX.Wave.Templatization Namespace


ResponseRenderingTarget Constructor

ResponseRenderingTarget Constructor NFX Class Library

Initializes a new instance of the ResponseRenderingTarget class

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponseRenderingTarget(
    WorkContext work
)
public ResponseRenderingTarget(
    WorkContext work
)
Public Sub New (
    work As WorkContext
)
Public Sub New (
    work As WorkContext
)
public:
ResponseRenderingTarget(
    WorkContext^ work
)
public:
ResponseRenderingTarget(
    WorkContext^ work
)
new :
        work : WorkContext -> ResponseRenderingTarget
new :
        work : WorkContext -> ResponseRenderingTarget

Parameters

work
Type: NFX.Wave WorkContext
See Also
ResponseRenderingTarget Class
ResponseRenderingTarget Members
NFX.Wave.Templatization Namespace


ResponseRenderingTarget Fields

ResponseRenderingTarget Fields NFX Class Library

The ResponseRenderingTarget type exposes the following members.
Fields
 | Name | Description
Public field | Context | Returns HttpContext for current request
Public field | Response | Returns Response object for WorkContext
Back to Top
See Also
ResponseRenderingTarget Class
NFX.Wave.Templatization Namespace


ResponseRenderingTarget.Context Field

ResponseRenderingTarget Context Field NFX Class Library

Returns HttpContext for current request

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly WorkContext Context
public readonly WorkContext Context
Public ReadOnly Context As WorkContext
Public ReadOnly Context As WorkContext
public:
initonly WorkContext^ Context
public:
initonly WorkContext^ Context
val Context: WorkContext
val Context: WorkContext

Field Value

Type: WorkContext
See Also
ResponseRenderingTarget Class
ResponseRenderingTarget Members
NFX.Wave.Templatization Namespace


ResponseRenderingTarget.Response Field

ResponseRenderingTarget Response Field NFX Class Library

Returns Response object for WorkContext

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Response Response
public readonly Response Response
Public ReadOnly Response As Response
Public ReadOnly Response As Response
public:
initonly Response^ Response
public:
initonly Response^ Response
val Response: Response
val Response: Response

Field Value

Type: Response
See Also
ResponseRenderingTarget Class
ResponseRenderingTarget Members
NFX.Wave.Templatization Namespace


ResponseRenderingTarget Methods

ResponseRenderingTarget Methods NFX Class Library

The ResponseRenderingTarget type exposes the following members.
Methods
 | Name | Description
Public method | Encode |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ResponseRenderingTarget Class
NFX.Wave.Templatization Namespace


ResponseRenderingTarget.Encode Method

ResponseRenderingTarget Encode Method NFX Class Library

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Encode(
    Object value
)
public Object Encode(
    Object value
)
Public Function Encode (
    value As Object
) As Object
Public Function Encode (
    value As Object
) As Object
public:
virtual Object^ Encode(
    Object^ value
) sealed
public:
virtual Object^ Encode(
    Object^ value
) sealed
abstract Encode :
        value : Object -> Object
override Encode :
        value : Object -> Object
abstract Encode :
        value : Object -> Object
override Encode :
        value : Object -> Object

Parameters

value
Type: Online System Object

Return Value

Type: Online Object

Implements

IRenderingTarget Encode(Object)
See Also
ResponseRenderingTarget Class
ResponseRenderingTarget Members
NFX.Wave.Templatization Namespace


ResponseRenderingTarget.Flush Method

ResponseRenderingTarget Flush Method NFX Class Library

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Flush()
public void Flush()
Public Sub Flush
Public Sub Flush
public:
virtual void Flush() sealed
public:
virtual void Flush() sealed
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit

Implements

IRenderingTarget Flush
See Also
ResponseRenderingTarget Class
ResponseRenderingTarget Members
NFX.Wave.Templatization Namespace


ResponseRenderingTarget.Write Method

ResponseRenderingTarget Write Method NFX Class Library

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    Object value
)
public void Write(
    Object value
)
Public Sub Write (
    value As Object
)
Public Sub Write (
    value As Object
)
public:
virtual void Write(
    Object^ value
) sealed
public:
virtual void Write(
    Object^ value
) sealed
abstract Write :
        value : Object -> unit
override Write :
        value : Object -> unit
abstract Write :
        value : Object -> unit
override Write :
        value : Object -> unit

Parameters

value
Type: Online System Object

Implements

IRenderingTarget Write(Object)
See Also
ResponseRenderingTarget Class
ResponseRenderingTarget Members
NFX.Wave.Templatization Namespace


WaveTemplate Class

WaveTemplate Class NFX Class Library

Defines a base class for web-related templates
Inheritance Hierarchy
Online System Object
NFX.Templatization Template WorkContext, IRenderingTarget, Online Object
NFX.Wave.Templatization WaveTemplate
NFX.Wave.Templatization.StockContent Master
NFX.Wave.Templatization WaveTemplate TModel

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class WaveTemplate : Template<WorkContext, IRenderingTarget, Object>
public abstract class WaveTemplate : Template<WorkContext, IRenderingTarget, Object>
Public MustInherit Class WaveTemplate
    Inherits Template(Of WorkContext, IRenderingTarget, Object)
Public MustInherit Class WaveTemplate
    Inherits Template(Of WorkContext, IRenderingTarget, Object)
public ref class WaveTemplate abstract : public Template<WorkContext^, IRenderingTarget^, Object^>
public ref class WaveTemplate abstract : public Template<WorkContext^, IRenderingTarget^, Object^>
[<AbstractClassAttribute>]
type WaveTemplate =
    class
        inherit Template<WorkContext, IRenderingTarget, Object>
    end
[<AbstractClassAttribute>]
type WaveTemplate =
    class
        inherit Template<WorkContext, IRenderingTarget, Object>
    end
See Also
WaveTemplate Members
NFX.Wave.Templatization Namespace


WaveTemplate Members

WaveTemplate Members NFX Class Library

The WaveTemplate type exposes the following members.
Constructors
 | Name | Description
Public method | WaveTemplate | Initializes a new instance of the WaveTemplate class
Public method | WaveTemplate(WorkContext) | Initializes a new instance of the WaveTemplate class
Back to Top
Methods
 | Name | Description
Public method | BindGlobalContexts | Infrastructure. Sets Context property. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoContextBinding | Infrastructure. Override to perform extra steps after Context property gets set. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoPostRender | (Overrides Template TContext, TTarget, TRenderingContext DoPostRender(Exception).)
Protected method | DoPreRender | Performs pre-rendering actions (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoRender | Performs actual rendering (Inherited from Template TContext, TTarget, TRenderingContext .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
 | EscapeJSLiteral | Escapes JS literal, see NFX.Web.Utils.EscapeJSLiteral
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | HTMLEncode | Converts string to HTML-encoded string
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Render(TTarget, TRenderingContext) | Renders template by generating content into target (Inherited from Template TContext, TTarget, TRenderingContext .)
Public method | Render(ResponseRenderingTarget, Object) | Renders template by generating content into ResponseRenderingTarget
Public method | Render(WorkContext, Object) | Renders template by generating content into WorkContext
Public method | RenderToString(Boolean, Object) | Renders template to string
Public method | RenderToString(WorkContext, Boolean, Object) | Renders template to string in a WorkContext
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CanReuseInstance | Override to indicate whetner the instance of the template may be reused for processing of other requests (possibly by parallel threads). Override to return false if there is any per-request state shared in instance fields False by default so multiple requests can not reuse the instance (Overrides Template TContext, TTarget, TRenderingContext CanReuseInstance.)
Public property | ContentType | Override to provides response content type. Default value is HTML
Public property | Context | Custom context for the lifetime of this template (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | CSRFToken | Returns CSRF token for session if it is available or null
Public property | RenderingContext | Returns thread-local rendering context which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | Response |
Public property | Session | Returns session if it is available or null
Public property | Target | Returns thread-local target which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Context | (Inherited from Template TContext, TTarget, TRenderingContext .)
Explicit interface implemetation | ITemplate Render | (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
See Also
WaveTemplate Class
NFX.Wave.Templatization Namespace


WaveTemplate Constructor

WaveTemplate Constructor NFX Class Library

Overload List
 | Name | Description
Public method | WaveTemplate | Initializes a new instance of the WaveTemplate class
Public method | WaveTemplate(WorkContext) | Initializes a new instance of the WaveTemplate class
Back to Top
See Also
WaveTemplate Class
WaveTemplate Members
NFX.Wave.Templatization Namespace


WaveTemplate Constructor

WaveTemplate Constructor NFX Class Library

Initializes a new instance of the WaveTemplate class

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveTemplate()
public WaveTemplate()
Public Sub New
Public Sub New
public:
WaveTemplate()
public:
WaveTemplate()
new : unit -> WaveTemplate
new : unit -> WaveTemplate
See Also
WaveTemplate Class
WaveTemplate Members
WaveTemplate Overload
NFX.Wave.Templatization Namespace


WaveTemplate Constructor (WorkContext)

WaveTemplate Constructor (WorkContext) NFX Class Library

Initializes a new instance of the WaveTemplate class

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveTemplate(
    WorkContext context
)
public WaveTemplate(
    WorkContext context
)
Public Sub New (
    context As WorkContext
)
Public Sub New (
    context As WorkContext
)
public:
WaveTemplate(
    WorkContext^ context
)
public:
WaveTemplate(
    WorkContext^ context
)
new :
        context : WorkContext -> WaveTemplate
new :
        context : WorkContext -> WaveTemplate

Parameters

context
Type: NFX.Wave WorkContext
See Also
WaveTemplate Class
WaveTemplate Members
WaveTemplate Overload
NFX.Wave.Templatization Namespace


WaveTemplate Methods

WaveTemplate Methods NFX Class Library

The WaveTemplate type exposes the following members.
Methods
 | Name | Description
Public method | BindGlobalContexts | Infrastructure. Sets Context property. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoContextBinding | Infrastructure. Override to perform extra steps after Context property gets set. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoPostRender | (Overrides Template TContext, TTarget, TRenderingContext DoPostRender(Exception).)
Protected method | DoPreRender | Performs pre-rendering actions (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoRender | Performs actual rendering (Inherited from Template TContext, TTarget, TRenderingContext .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
 | EscapeJSLiteral | Escapes JS literal, see NFX.Web.Utils.EscapeJSLiteral
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | HTMLEncode | Converts string to HTML-encoded string
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Render(TTarget, TRenderingContext) | Renders template by generating content into target (Inherited from Template TContext, TTarget, TRenderingContext .)
Public method | Render(ResponseRenderingTarget, Object) | Renders template by generating content into ResponseRenderingTarget
Public method | Render(WorkContext, Object) | Renders template by generating content into WorkContext
Public method | RenderToString(Boolean, Object) | Renders template to string
Public method | RenderToString(WorkContext, Boolean, Object) | Renders template to string in a WorkContext
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Render | (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
See Also
WaveTemplate Class
NFX.Wave.Templatization Namespace


WaveTemplate.DoPostRender Method

WaveTemplate DoPostRender Method NFX Class Library

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool DoPostRender(
    Exception error
)
protected override bool DoPostRender(
    Exception error
)
Protected Overrides Function DoPostRender (
    error As Exception
) As Boolean
Protected Overrides Function DoPostRender (
    error As Exception
) As Boolean
protected:
virtual bool DoPostRender(
    Exception^ error
) override
protected:
virtual bool DoPostRender(
    Exception^ error
) override
abstract DoPostRender :
        error : Exception -> bool
override DoPostRender :
        error : Exception -> bool
abstract DoPostRender :
        error : Exception -> bool
override DoPostRender :
        error : Exception -> bool

Parameters

error
Type: Online System Exception

Return Value

Type: Online Boolean
See Also
WaveTemplate Class
WaveTemplate Members
NFX.Wave.Templatization Namespace


WaveTemplate.EscapeJSLiteral Method

WaveTemplate EscapeJSLiteral Method NFX Class Library

Escapes JS literal, see NFX.Web.Utils.EscapeJSLiteral

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string EscapeJSLiteral(
    string value
)
public static string EscapeJSLiteral(
    string value
)
Public Shared Function EscapeJSLiteral (
    value As String
) As String
Public Shared Function EscapeJSLiteral (
    value As String
) As String
public:
static String^ EscapeJSLiteral(
    String^ value
)
public:
static String^ EscapeJSLiteral(
    String^ value
)
static member EscapeJSLiteral :
        value : string -> string
static member EscapeJSLiteral :
        value : string -> string

Parameters

value
Type: Online System String

Return Value

Type: Online String
See Also
WaveTemplate Class
WaveTemplate Members
NFX.Wave.Templatization Namespace


WaveTemplate.HTMLEncode Method

WaveTemplate HTMLEncode Method NFX Class Library

Converts string to HTML-encoded string

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string HTMLEncode(
    string value
)
public static string HTMLEncode(
    string value
)
Public Shared Function HTMLEncode (
    value As String
) As String
Public Shared Function HTMLEncode (
    value As String
) As String
public:
static String^ HTMLEncode(
    String^ value
)
public:
static String^ HTMLEncode(
    String^ value
)
static member HTMLEncode :
        value : string -> string
static member HTMLEncode :
        value : string -> string

Parameters

value
Type: Online System String

Return Value

Type: Online String
See Also
WaveTemplate Class
WaveTemplate Members
NFX.Wave.Templatization Namespace


WaveTemplate.Render Method

WaveTemplate Render Method NFX Class Library

Overload List
 | Name | Description
Public method | Render(TTarget, TRenderingContext) | Renders template by generating content into target (Inherited from Template TContext, TTarget, TRenderingContext .)
Public method | Render(ResponseRenderingTarget, Object) | Renders template by generating content into ResponseRenderingTarget
Public method | Render(WorkContext, Object) | Renders template by generating content into WorkContext
Back to Top
See Also
WaveTemplate Class
WaveTemplate Members
NFX.Wave.Templatization Namespace


WaveTemplate.Render Method (ResponseRenderingTarget, Object)

WaveTemplate Render Method (ResponseRenderingTarget, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Renders template by generating content into ResponseRenderingTarget

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Render(
    ResponseRenderingTarget target,
    Object model
)
public void Render(
    ResponseRenderingTarget target,
    Object model
)
Public Sub Render (
    target As ResponseRenderingTarget,
    model As Object
)
Public Sub Render (
    target As ResponseRenderingTarget,
    model As Object
)
public:
void Render(
    ResponseRenderingTarget^ target,
    Object^ model
)
public:
void Render(
    ResponseRenderingTarget^ target,
    Object^ model
)
member Render :
        target : ResponseRenderingTarget *
        model : Object -> unit
member Render :
        target : ResponseRenderingTarget *
        model : Object -> unit

Parameters

target
Type: NFX.Wave.Templatization ResponseRenderingTarget
model
Type: Online System Object
See Also
WaveTemplate Class
WaveTemplate Members
Render Overload
NFX.Wave.Templatization Namespace


WaveTemplate.Render Method (WorkContext, Object)

WaveTemplate Render Method (WorkContext, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Renders template by generating content into WorkContext

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Render(
    WorkContext work,
    Object model
)
public void Render(
    WorkContext work,
    Object model
)
Public Sub Render (
    work As WorkContext,
    model As Object
)
Public Sub Render (
    work As WorkContext,
    model As Object
)
public:
void Render(
    WorkContext^ work,
    Object^ model
)
public:
void Render(
    WorkContext^ work,
    Object^ model
)
member Render :
        work : WorkContext *
        model : Object -> unit
member Render :
        work : WorkContext *
        model : Object -> unit

Parameters

work
Type: NFX.Wave WorkContext
model
Type: Online System Object
See Also
WaveTemplate Class
WaveTemplate Members
Render Overload
NFX.Wave.Templatization Namespace


WaveTemplate.RenderToString Method

WaveTemplate RenderToString Method NFX Class Library

Overload List
 | Name | Description
Public method | RenderToString(Boolean, Object) | Renders template to string
Public method | RenderToString(WorkContext, Boolean, Object) | Renders template to string in a WorkContext
Back to Top
See Also
WaveTemplate Class
WaveTemplate Members
NFX.Wave.Templatization Namespace


WaveTemplate.RenderToString Method (Boolean, Object)

WaveTemplate RenderToString Method (Boolean, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Renders template to string

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RenderToString(
    bool encodeHtml = true,
    Object model = null
)
public string RenderToString(
    bool encodeHtml = true,
    Object model = null
)
Public Function RenderToString (
    Optional encodeHtml As Boolean = true,
    Optional model As Object = Nothing
) As String
Public Function RenderToString (
    Optional encodeHtml As Boolean = true,
    Optional model As Object = Nothing
) As String
public:
String^ RenderToString(
    bool encodeHtml = true,
    Object^ model = nullptr
)
public:
String^ RenderToString(
    bool encodeHtml = true,
    Object^ model = nullptr
)
member RenderToString :
        ?encodeHtml : bool *
        ?model : Object
(* Defaults:
        let _encodeHtml = defaultArg encodeHtml true
        let _model = defaultArg model null
*)
-> string
member RenderToString :
        ?encodeHtml : bool *
        ?model : Object
(* Defaults:
        let _encodeHtml = defaultArg encodeHtml true
        let _model = defaultArg model null
*)
-> string

Parameters

encodeHtml (Optional)
Type: Online System Boolean
model (Optional)
Type: Online System Object

Return Value

Type: Online String
See Also
WaveTemplate Class
WaveTemplate Members
RenderToString Overload
NFX.Wave.Templatization Namespace


WaveTemplate.RenderToString Method (WorkContext, Boolean, Object)

WaveTemplate RenderToString Method (WorkContext, Boolean, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Renders template to string in a WorkContext

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RenderToString(
    WorkContext work,
    bool encodeHtml = true,
    Object model = null
)
public string RenderToString(
    WorkContext work,
    bool encodeHtml = true,
    Object model = null
)
Public Function RenderToString (
    work As WorkContext,
    Optional encodeHtml As Boolean = true,
    Optional model As Object = Nothing
) As String
Public Function RenderToString (
    work As WorkContext,
    Optional encodeHtml As Boolean = true,
    Optional model As Object = Nothing
) As String
public:
String^ RenderToString(
    WorkContext^ work,
    bool encodeHtml = true,
    Object^ model = nullptr
)
public:
String^ RenderToString(
    WorkContext^ work,
    bool encodeHtml = true,
    Object^ model = nullptr
)
member RenderToString :
        work : WorkContext *
        ?encodeHtml : bool *
        ?model : Object
(* Defaults:
        let _encodeHtml = defaultArg encodeHtml true
        let _model = defaultArg model null
*)
-> string
member RenderToString :
        work : WorkContext *
        ?encodeHtml : bool *
        ?model : Object
(* Defaults:
        let _encodeHtml = defaultArg encodeHtml true
        let _model = defaultArg model null
*)
-> string

Parameters

work
Type: NFX.Wave WorkContext
encodeHtml (Optional)
Type: Online System Boolean
model (Optional)
Type: Online System Object

Return Value

Type: Online String
See Also
WaveTemplate Class
WaveTemplate Members
RenderToString Overload
NFX.Wave.Templatization Namespace


WaveTemplate Properties

WaveTemplate Properties NFX Class Library

The WaveTemplate type exposes the following members.
Properties
 | Name | Description
Public property | CanReuseInstance | Override to indicate whetner the instance of the template may be reused for processing of other requests (possibly by parallel threads). Override to return false if there is any per-request state shared in instance fields False by default so multiple requests can not reuse the instance (Overrides Template TContext, TTarget, TRenderingContext CanReuseInstance.)
Public property | ContentType | Override to provides response content type. Default value is HTML
Public property | Context | Custom context for the lifetime of this template (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | CSRFToken | Returns CSRF token for session if it is available or null
Public property | RenderingContext | Returns thread-local rendering context which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | Response |
Public property | Session | Returns session if it is available or null
Public property | Target | Returns thread-local target which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Context | (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
See Also
WaveTemplate Class
NFX.Wave.Templatization Namespace


WaveTemplate.CanReuseInstance Property

WaveTemplate CanReuseInstance Property NFX Class Library

Override to indicate whetner the instance of the template may be reused for processing of other requests (possibly by parallel threads). Override to return false if there is any per-request state shared in instance fields False by default so multiple requests can not reuse the instance

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanReuseInstance { get; }
public override bool CanReuseInstance { get; }
Public Overrides ReadOnly Property CanReuseInstance As Boolean
    Get
Public Overrides ReadOnly Property CanReuseInstance As Boolean
    Get
public:
virtual property bool CanReuseInstance {
    bool get () override;
}
public:
virtual property bool CanReuseInstance {
    bool get () override;
}
abstract CanReuseInstance : bool with get
override CanReuseInstance : bool with get
abstract CanReuseInstance : bool with get
override CanReuseInstance : bool with get

Property Value

Type: Online Boolean

Implements

ITemplate CanReuseInstance
See Also
WaveTemplate Class
WaveTemplate Members
NFX.Wave.Templatization Namespace


WaveTemplate.ContentType Property

WaveTemplate ContentType Property NFX Class Library

Override to provides response content type. Default value is HTML

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string ContentType { get; }
public virtual string ContentType { get; }
Public Overridable ReadOnly Property ContentType As String
    Get
Public Overridable ReadOnly Property ContentType As String
    Get
public:
virtual property String^ ContentType {
    String^ get ();
}
public:
virtual property String^ ContentType {
    String^ get ();
}
abstract ContentType : string with get
override ContentType : string with get
abstract ContentType : string with get
override ContentType : string with get

Property Value

Type: Online String
See Also
WaveTemplate Class
WaveTemplate Members
NFX.Wave.Templatization Namespace


WaveTemplate.CSRFToken Property

WaveTemplate CSRFToken Property NFX Class Library

Returns CSRF token for session if it is available or null

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CSRFToken { get; }
public string CSRFToken { get; }
Public ReadOnly Property CSRFToken As String
    Get
Public ReadOnly Property CSRFToken As String
    Get
public:
property String^ CSRFToken {
    String^ get ();
}
public:
property String^ CSRFToken {
    String^ get ();
}
member CSRFToken : string with get
member CSRFToken : string with get

Property Value

Type: Online String
See Also
WaveTemplate Class
WaveTemplate Members
NFX.Wave.Templatization Namespace


WaveTemplate.Response Property

WaveTemplate Response Property NFX Class Library

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Response Response { get; }
public Response Response { get; }
Public ReadOnly Property Response As Response
    Get
Public ReadOnly Property Response As Response
    Get
public:
property Response^ Response {
    Response^ get ();
}
public:
property Response^ Response {
    Response^ get ();
}
member Response : Response with get
member Response : Response with get

Property Value

Type: Response
See Also
WaveTemplate Class
WaveTemplate Members
NFX.Wave.Templatization Namespace


WaveTemplate.Session Property

WaveTemplate Session Property NFX Class Library

Returns session if it is available or null

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveSession Session { get; }
public WaveSession Session { get; }
Public ReadOnly Property Session As WaveSession
    Get
Public ReadOnly Property Session As WaveSession
    Get
public:
property WaveSession^ Session {
    WaveSession^ get ();
}
public:
property WaveSession^ Session {
    WaveSession^ get ();
}
member Session : WaveSession with get
member Session : WaveSession with get

Property Value

Type: WaveSession
See Also
WaveTemplate Class
WaveTemplate Members
NFX.Wave.Templatization Namespace


WaveTemplate(TModel) Class

WaveTemplate TModel Class NFX Class Library

Wave template that is scoped to a TModel type for Model (Rendering Context)
Inheritance Hierarchy
Online System Object
NFX.Templatization Template WorkContext, IRenderingTarget, Online Object
NFX.Wave.Templatization WaveTemplate
NFX.Wave.Templatization WaveTemplate TModel

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class WaveTemplate<TModel> : WaveTemplate
public class WaveTemplate<TModel> : WaveTemplate
Public Class WaveTemplate(Of TModel)
    Inherits WaveTemplate
Public Class WaveTemplate(Of TModel)
    Inherits WaveTemplate
generic<typename TModel>
public ref class WaveTemplate : public WaveTemplate
generic<typename TModel>
public ref class WaveTemplate : public WaveTemplate
type WaveTemplate<'TModel> =
    class
        inherit WaveTemplate
    end
type WaveTemplate<'TModel> =
    class
        inherit WaveTemplate
    end
Type Parameters
TModel
See Also
WaveTemplate TModel Members
NFX.Wave.Templatization Namespace


WaveTemplate(TModel) Members

WaveTemplate TModel Members NFX Class Library

The WaveTemplate TModel type exposes the following members.
Constructors
 | Name | Description
Public method | WaveTemplate TModel | Initializes a new instance of the WaveTemplate TModel class
Public method | WaveTemplate TModel (WorkContext) | Initializes a new instance of the WaveTemplate TModel class
Back to Top
Methods
 | Name | Description
Public method | BindGlobalContexts | Infrastructure. Sets Context property. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoContextBinding | Infrastructure. Override to perform extra steps after Context property gets set. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoPostRender | (Inherited from WaveTemplate.)
Protected method | DoPreRender | Performs pre-rendering actions (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoRender | Performs actual rendering (Inherited from Template TContext, TTarget, TRenderingContext .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Render(TTarget, TRenderingContext) | Renders template by generating content into target (Inherited from Template TContext, TTarget, TRenderingContext .)
Public method | Render(ResponseRenderingTarget, Object) | Renders template by generating content into ResponseRenderingTarget (Inherited from WaveTemplate.)
Public method | Render(ResponseRenderingTarget, TModel) | Renders template by generating content into ResponseRenderingTarget
Public method | Render(WorkContext, Object) | Renders template by generating content into WorkContext (Inherited from WaveTemplate.)
Public method | Render(WorkContext, TModel) | Renders template by generating content into WorkContext
Public method | RenderToString(Boolean, Object) | Renders template to string (Inherited from WaveTemplate.)
Public method | RenderToString(WorkContext, Boolean, Object) | Renders template to string in a WorkContext (Inherited from WaveTemplate.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CanReuseInstance | Override to indicate whetner the instance of the template may be reused for processing of other requests (possibly by parallel threads). Override to return false if there is any per-request state shared in instance fields False by default so multiple requests can not reuse the instance (Inherited from WaveTemplate.)
Public property | ContentType | Override to provides response content type. Default value is HTML (Inherited from WaveTemplate.)
Public property | Context | Custom context for the lifetime of this template (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | CSRFToken | Returns CSRF token for session if it is available or null (Inherited from WaveTemplate.)
Public property | Model | Shortcut to TemplateRenderingContext which is set per call to Render(TModel)
Public property | RenderingContext | Returns thread-local rendering context which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | Response | (Inherited from WaveTemplate.)
Public property | Session | Returns session if it is available or null (Inherited from WaveTemplate.)
Public property | Target | Returns thread-local target which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Context | (Inherited from Template TContext, TTarget, TRenderingContext .)
Explicit interface implemetation | ITemplate Render | (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
See Also
WaveTemplate TModel Class
NFX.Wave.Templatization Namespace


WaveTemplate(TModel) Constructor

WaveTemplate TModel Constructor NFX Class Library

Overload List
 | Name | Description
Public method | WaveTemplate TModel | Initializes a new instance of the WaveTemplate TModel class
Public method | WaveTemplate TModel (WorkContext) | Initializes a new instance of the WaveTemplate TModel class
Back to Top
See Also
WaveTemplate TModel Class
WaveTemplate TModel Members
NFX.Wave.Templatization Namespace


WaveTemplate(TModel) Constructor

WaveTemplate TModel Constructor NFX Class Library

Initializes a new instance of the WaveTemplate TModel class

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveTemplate()
public WaveTemplate()
Public Sub New
Public Sub New
public:
WaveTemplate()
public:
WaveTemplate()
new : unit -> WaveTemplate
new : unit -> WaveTemplate
See Also
WaveTemplate TModel Class
WaveTemplate TModel Members
WaveTemplate TModel Overload
NFX.Wave.Templatization Namespace


WaveTemplate(TModel) Constructor (WorkContext)

WaveTemplate TModel Constructor (WorkContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WaveTemplate TModel class

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaveTemplate(
    WorkContext context
)
public WaveTemplate(
    WorkContext context
)
Public Sub New (
    context As WorkContext
)
Public Sub New (
    context As WorkContext
)
public:
WaveTemplate(
    WorkContext^ context
)
public:
WaveTemplate(
    WorkContext^ context
)
new :
        context : WorkContext -> WaveTemplate
new :
        context : WorkContext -> WaveTemplate

Parameters

context
Type: NFX.Wave WorkContext
See Also
WaveTemplate TModel Class
WaveTemplate TModel Members
WaveTemplate TModel Overload
NFX.Wave.Templatization Namespace


WaveTemplate(TModel) Methods

WaveTemplate TModel Methods NFX Class Library

The WaveTemplate TModel type exposes the following members.
Methods
 | Name | Description
Public method | BindGlobalContexts | Infrastructure. Sets Context property. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoContextBinding | Infrastructure. Override to perform extra steps after Context property gets set. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoPostRender | (Inherited from WaveTemplate.)
Protected method | DoPreRender | Performs pre-rendering actions (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoRender | Performs actual rendering (Inherited from Template TContext, TTarget, TRenderingContext .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Render(TTarget, TRenderingContext) | Renders template by generating content into target (Inherited from Template TContext, TTarget, TRenderingContext .)
Public method | Render(ResponseRenderingTarget, Object) | Renders template by generating content into ResponseRenderingTarget (Inherited from WaveTemplate.)
Public method | Render(ResponseRenderingTarget, TModel) | Renders template by generating content into ResponseRenderingTarget
Public method | Render(WorkContext, Object) | Renders template by generating content into WorkContext (Inherited from WaveTemplate.)
Public method | Render(WorkContext, TModel) | Renders template by generating content into WorkContext
Public method | RenderToString(Boolean, Object) | Renders template to string (Inherited from WaveTemplate.)
Public method | RenderToString(WorkContext, Boolean, Object) | Renders template to string in a WorkContext (Inherited from WaveTemplate.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Render | (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
See Also
WaveTemplate TModel Class
NFX.Wave.Templatization Namespace


WaveTemplate(TModel).Render Method

WaveTemplate TModel Render Method NFX Class Library

Overload List
 | Name | Description
Public method | Render(TTarget, TRenderingContext) | Renders template by generating content into target (Inherited from Template TContext, TTarget, TRenderingContext .)
Public method | Render(ResponseRenderingTarget, Object) | Renders template by generating content into ResponseRenderingTarget (Inherited from WaveTemplate.)
Public method | Render(ResponseRenderingTarget, TModel) | Renders template by generating content into ResponseRenderingTarget
Public method | Render(WorkContext, Object) | Renders template by generating content into WorkContext (Inherited from WaveTemplate.)
Public method | Render(WorkContext, TModel) | Renders template by generating content into WorkContext
Back to Top
See Also
WaveTemplate TModel Class
WaveTemplate TModel Members
NFX.Wave.Templatization Namespace


WaveTemplate(TModel).Render Method (ResponseRenderingTarget, TModel)

WaveTemplate TModel Render Method (ResponseRenderingTarget, TModel) NFX Class Library

[This is preliminary documentation and is subject to change.]

Renders template by generating content into ResponseRenderingTarget

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Render(
    ResponseRenderingTarget target,
    TModel model
)
public void Render(
    ResponseRenderingTarget target,
    TModel model
)
Public Sub Render (
    target As ResponseRenderingTarget,
    model As TModel
)
Public Sub Render (
    target As ResponseRenderingTarget,
    model As TModel
)
public:
void Render(
    ResponseRenderingTarget^ target,
    TModel model
)
public:
void Render(
    ResponseRenderingTarget^ target,
    TModel model
)
member Render :
        target : ResponseRenderingTarget *
        model : 'TModel -> unit
member Render :
        target : ResponseRenderingTarget *
        model : 'TModel -> unit

Parameters

target
Type: NFX.Wave.Templatization ResponseRenderingTarget
A ResponseRenderingTarget target to render output into
model
Type: TModel
A model object for this rendering call
See Also
WaveTemplate TModel Class
WaveTemplate TModel Members
Render Overload
NFX.Wave.Templatization Namespace


WaveTemplate(TModel).Render Method (WorkContext, TModel)

WaveTemplate TModel Render Method (WorkContext, TModel) NFX Class Library

[This is preliminary documentation and is subject to change.]

Renders template by generating content into WorkContext

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Render(
    WorkContext work,
    TModel model
)
public void Render(
    WorkContext work,
    TModel model
)
Public Sub Render (
    work As WorkContext,
    model As TModel
)
Public Sub Render (
    work As WorkContext,
    model As TModel
)
public:
void Render(
    WorkContext^ work,
    TModel model
)
public:
void Render(
    WorkContext^ work,
    TModel model
)
member Render :
        work : WorkContext *
        model : 'TModel -> unit
member Render :
        work : WorkContext *
        model : 'TModel -> unit

Parameters

work
Type: NFX.Wave WorkContext
model
Type: TModel
See Also
WaveTemplate TModel Class
WaveTemplate TModel Members
Render Overload
NFX.Wave.Templatization Namespace


WaveTemplate(TModel) Properties

WaveTemplate TModel Properties NFX Class Library

The WaveTemplate TModel type exposes the following members.
Properties
 | Name | Description
Public property | CanReuseInstance | Override to indicate whetner the instance of the template may be reused for processing of other requests (possibly by parallel threads). Override to return false if there is any per-request state shared in instance fields False by default so multiple requests can not reuse the instance (Inherited from WaveTemplate.)
Public property | ContentType | Override to provides response content type. Default value is HTML (Inherited from WaveTemplate.)
Public property | Context | Custom context for the lifetime of this template (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | CSRFToken | Returns CSRF token for session if it is available or null (Inherited from WaveTemplate.)
Public property | Model | Shortcut to TemplateRenderingContext which is set per call to Render(TModel)
Public property | RenderingContext | Returns thread-local rendering context which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | Response | (Inherited from WaveTemplate.)
Public property | Session | Returns session if it is available or null (Inherited from WaveTemplate.)
Public property | Target | Returns thread-local target which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Context | (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
See Also
WaveTemplate TModel Class
NFX.Wave.Templatization Namespace


WaveTemplate(TModel).Model Property

WaveTemplate TModel Model Property NFX Class Library

Shortcut to TemplateRenderingContext which is set per call to Render(TModel)

Namespace: NFX.Wave.Templatization
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TModel Model { get; }
public TModel Model { get; }
Public ReadOnly Property Model As TModel
    Get
Public ReadOnly Property Model As TModel
    Get
public:
property TModel Model {
    TModel get ();
}
public:
property TModel Model {
    TModel get ();
}
member Model : 'TModel with get
member Model : 'TModel with get

Property Value

Type: TModel
See Also
WaveTemplate TModel Class
WaveTemplate TModel Members
NFX.Wave.Templatization Namespace


NFX.Wave.Templatization.StockContent Namespace

NFX.Wave.Templatization.StockContent Namespace NFX Class Library

[This is preliminary documentation and is subject to change.]

Classes
 | Class | Description
Public class | Error | Displays good-looking 404 page
Public class | Master | Master page for all stock pages


Error Class

Error Class NFX Class Library

Displays good-looking 404 page
Inheritance Hierarchy
Online System Object
NFX.Templatization Template WorkContext, IRenderingTarget, Online Object
NFX.Wave.Templatization WaveTemplate
NFX.Wave.Templatization.StockContent Master
NFX.Wave.Templatization.StockContent Error

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Error : Master
public class Error : Master
Public Class Error
    Inherits Master
Public Class Error
    Inherits Master
public ref class Error : public Master
public ref class Error : public Master
type Error =
    class
        inherit Master
    end
type Error =
    class
        inherit Master
    end
See Also
Error Members
NFX.Wave.Templatization.StockContent Namespace


Error Members

Error Members NFX Class Library

The Error type exposes the following members.
Constructors
 | Name | Description
Public method | Error | Initializes a new instance of the Error class
Back to Top
Methods
 | Name | Description
Public method | BindGlobalContexts | Infrastructure. Sets Context property. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | defaultFooter | (Inherited from Master.)
Protected method | DoContextBinding | Infrastructure. Override to perform extra steps after Context property gets set. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoPostRender | (Inherited from WaveTemplate.)
Protected method | DoPreRender | Performs pre-rendering actions (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoRender | (Overrides Master DoRender .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Render(TTarget, TRenderingContext) | Renders template by generating content into target (Inherited from Template TContext, TTarget, TRenderingContext .)
Public method | Render(ResponseRenderingTarget, Object) | Renders template by generating content into ResponseRenderingTarget (Inherited from WaveTemplate.)
Public method | Render(WorkContext, Object) | Renders template by generating content into WorkContext (Inherited from WaveTemplate.)
Protected method | renderBody | (Overrides Master renderBody .)
Protected method | renderFooter | (Inherited from Master.)
Protected method | renderHeader | (Overrides Master renderHeader .)
Public method | RenderToString(Boolean, Object) | Renders template to string (Inherited from WaveTemplate.)
Public method | RenderToString(WorkContext, Boolean, Object) | Renders template to string in a WorkContext (Inherited from WaveTemplate.)
Protected method | showDumpBody |
Protected method | showException |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | ErrorCause |
Public field | ShowDump |
Back to Top
Properties
 | Name | Description
Public property | CanReuseInstance | Override to indicate whetner the instance of the template may be reused for processing of other requests (possibly by parallel threads). Override to return false if there is any per-request state shared in instance fields False by default so multiple requests can not reuse the instance (Inherited from WaveTemplate.)
Public property | ContentType | Override to provides response content type. Default value is HTML (Inherited from WaveTemplate.)
Public property | Context | Custom context for the lifetime of this template (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | CSRFToken | Returns CSRF token for session if it is available or null (Inherited from WaveTemplate.)
Public property | RenderingContext | Returns thread-local rendering context which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | Response | (Inherited from WaveTemplate.)
Public property | Session | Returns session if it is available or null (Inherited from WaveTemplate.)
Public property | Target | Returns thread-local target which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | Title | (Overrides Master Title.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Context | (Inherited from Template TContext, TTarget, TRenderingContext .)
Explicit interface implemetation | ITemplate Render | (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
See Also
Error Class
NFX.Wave.Templatization.StockContent Namespace


Error Constructor

Error Constructor NFX Class Library

Initializes a new instance of the Error class

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Error(
    WorkContext work,
    Exception error,
    bool showDump
)
public Error(
    WorkContext work,
    Exception error,
    bool showDump
)
Public Sub New (
    work As WorkContext,
    error As Exception,
    showDump As Boolean
)
Public Sub New (
    work As WorkContext,
    error As Exception,
    showDump As Boolean
)
public:
Error(
    WorkContext^ work,
    Exception^ error,
    bool showDump
)
public:
Error(
    WorkContext^ work,
    Exception^ error,
    bool showDump
)
new :
        work : WorkContext *
        error : Exception *
        showDump : bool -> Error
new :
        work : WorkContext *
        error : Exception *
        showDump : bool -> Error

Parameters

work
Type: NFX.Wave WorkContext
error
Type: Online System Exception
showDump
Type: Online System Boolean
See Also
Error Class
Error Members
NFX.Wave.Templatization.StockContent Namespace


Error Fields

Error Fields NFX Class Library

The Error type exposes the following members.
Fields
 | Name | Description
Public field | ErrorCause |
Public field | ShowDump |
Back to Top
See Also
Error Class
NFX.Wave.Templatization.StockContent Namespace


Error.ErrorCause Field

Error ErrorCause Field NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Exception ErrorCause
public readonly Exception ErrorCause
Public ReadOnly ErrorCause As Exception
Public ReadOnly ErrorCause As Exception
public:
initonly Exception^ ErrorCause
public:
initonly Exception^ ErrorCause
val ErrorCause: Exception
val ErrorCause: Exception

Field Value

Type: Online Exception
See Also
Error Class
Error Members
NFX.Wave.Templatization.StockContent Namespace


Error.ShowDump Field

Error ShowDump Field NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool ShowDump
public readonly bool ShowDump
Public ReadOnly ShowDump As Boolean
Public ReadOnly ShowDump As Boolean
public:
initonly bool ShowDump
public:
initonly bool ShowDump
val ShowDump: bool
val ShowDump: bool

Field Value

Type: Online Boolean
See Also
Error Class
Error Members
NFX.Wave.Templatization.StockContent Namespace


Error Methods

Error Methods NFX Class Library

The Error type exposes the following members.
Methods
 | Name | Description
Public method | BindGlobalContexts | Infrastructure. Sets Context property. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | defaultFooter | (Inherited from Master.)
Protected method | DoContextBinding | Infrastructure. Override to perform extra steps after Context property gets set. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoPostRender | (Inherited from WaveTemplate.)
Protected method | DoPreRender | Performs pre-rendering actions (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoRender | (Overrides Master DoRender .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Render(TTarget, TRenderingContext) | Renders template by generating content into target (Inherited from Template TContext, TTarget, TRenderingContext .)
Public method | Render(ResponseRenderingTarget, Object) | Renders template by generating content into ResponseRenderingTarget (Inherited from WaveTemplate.)
Public method | Render(WorkContext, Object) | Renders template by generating content into WorkContext (Inherited from WaveTemplate.)
Protected method | renderBody | (Overrides Master renderBody .)
Protected method | renderFooter | (Inherited from Master.)
Protected method | renderHeader | (Overrides Master renderHeader .)
Public method | RenderToString(Boolean, Object) | Renders template to string (Inherited from WaveTemplate.)
Public method | RenderToString(WorkContext, Boolean, Object) | Renders template to string in a WorkContext (Inherited from WaveTemplate.)
Protected method | showDumpBody |
Protected method | showException |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Render | (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
See Also
Error Class
NFX.Wave.Templatization.StockContent Namespace


Error.DoRender Method

Error DoRender Method NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoRender()
protected override void DoRender()
Protected Overrides Sub DoRender
Protected Overrides Sub DoRender
protected:
virtual void DoRender() override
protected:
virtual void DoRender() override
abstract DoRender : unit -> unit
override DoRender : unit -> unit
abstract DoRender : unit -> unit
override DoRender : unit -> unit
See Also
Error Class
Error Members
NFX.Wave.Templatization.StockContent Namespace


Error.renderBody Method

Error renderBody Method NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void renderBody()
protected override void renderBody()
Protected Overrides Sub renderBody
Protected Overrides Sub renderBody
protected:
virtual void renderBody() override
protected:
virtual void renderBody() override
abstract renderBody : unit -> unit
override renderBody : unit -> unit
abstract renderBody : unit -> unit
override renderBody : unit -> unit
See Also
Error Class
Error Members
NFX.Wave.Templatization.StockContent Namespace


Error.renderHeader Method

Error renderHeader Method NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void renderHeader()
protected override void renderHeader()
Protected Overrides Sub renderHeader
Protected Overrides Sub renderHeader
protected:
virtual void renderHeader() override
protected:
virtual void renderHeader() override
abstract renderHeader : unit -> unit
override renderHeader : unit -> unit
abstract renderHeader : unit -> unit
override renderHeader : unit -> unit
See Also
Error Class
Error Members
NFX.Wave.Templatization.StockContent Namespace


Error.showDumpBody Method

Error showDumpBody Method NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void showDumpBody()
protected void showDumpBody()
Protected Sub showDumpBody
Protected Sub showDumpBody
protected:
void showDumpBody()
protected:
void showDumpBody()
member showDumpBody : unit -> unit
member showDumpBody : unit -> unit
See Also
Error Class
Error Members
NFX.Wave.Templatization.StockContent Namespace


Error.showException Method

Error showException Method NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void showException(
    Exception err
)
protected void showException(
    Exception err
)
Protected Sub showException (
    err As Exception
)
Protected Sub showException (
    err As Exception
)
protected:
void showException(
    Exception^ err
)
protected:
void showException(
    Exception^ err
)
member showException :
        err : Exception -> unit
member showException :
        err : Exception -> unit

Parameters

err
Type: Online System Exception
See Also
Error Class
Error Members
NFX.Wave.Templatization.StockContent Namespace


Error Properties

Error Properties NFX Class Library

The Error type exposes the following members.
Properties
 | Name | Description
Public property | CanReuseInstance | Override to indicate whetner the instance of the template may be reused for processing of other requests (possibly by parallel threads). Override to return false if there is any per-request state shared in instance fields False by default so multiple requests can not reuse the instance (Inherited from WaveTemplate.)
Public property | ContentType | Override to provides response content type. Default value is HTML (Inherited from WaveTemplate.)
Public property | Context | Custom context for the lifetime of this template (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | CSRFToken | Returns CSRF token for session if it is available or null (Inherited from WaveTemplate.)
Public property | RenderingContext | Returns thread-local rendering context which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | Response | (Inherited from WaveTemplate.)
Public property | Session | Returns session if it is available or null (Inherited from WaveTemplate.)
Public property | Target | Returns thread-local target which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | Title | (Overrides Master Title.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Context | (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
See Also
Error Class
NFX.Wave.Templatization.StockContent Namespace


Error.Title Property

Error Title Property NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Title { get; }
public override string Title { get; }
Public Overrides ReadOnly Property Title As String
    Get
Public Overrides ReadOnly Property Title As String
    Get
public:
virtual property String^ Title {
    String^ get () override;
}
public:
virtual property String^ Title {
    String^ get () override;
}
abstract Title : string with get
override Title : string with get
abstract Title : string with get
override Title : string with get

Property Value

Type: Online String
See Also
Error Class
Error Members
NFX.Wave.Templatization.StockContent Namespace


Master Class

Master Class NFX Class Library

Master page for all stock pages
Inheritance Hierarchy
Online System Object
NFX.Templatization Template WorkContext, IRenderingTarget, Online Object
NFX.Wave.Templatization WaveTemplate
NFX.Wave.Templatization.StockContent Master
NFX.Wave.Templatization.StockContent Error

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Master : WaveTemplate
public abstract class Master : WaveTemplate
Public MustInherit Class Master
    Inherits WaveTemplate
Public MustInherit Class Master
    Inherits WaveTemplate
public ref class Master abstract : public WaveTemplate
public ref class Master abstract : public WaveTemplate
[<AbstractClassAttribute>]
type Master =
    class
        inherit WaveTemplate
    end
[<AbstractClassAttribute>]
type Master =
    class
        inherit WaveTemplate
    end
See Also
Master Members
NFX.Wave.Templatization.StockContent Namespace


Master Members

Master Members NFX Class Library

The Master type exposes the following members.
Constructors
 | Name | Description
Public method | Master | Initializes a new instance of the Master class
Back to Top
Methods
 | Name | Description
Public method | BindGlobalContexts | Infrastructure. Sets Context property. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | defaultFooter |
Protected method | DoContextBinding | Infrastructure. Override to perform extra steps after Context property gets set. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoPostRender | (Inherited from WaveTemplate.)
Protected method | DoPreRender | Performs pre-rendering actions (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoRender | (Overrides Template TContext, TTarget, TRenderingContext DoRender .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Render(TTarget, TRenderingContext) | Renders template by generating content into target (Inherited from Template TContext, TTarget, TRenderingContext .)
Public method | Render(ResponseRenderingTarget, Object) | Renders template by generating content into ResponseRenderingTarget (Inherited from WaveTemplate.)
Public method | Render(WorkContext, Object) | Renders template by generating content into WorkContext (Inherited from WaveTemplate.)
Protected method | renderBody |
Protected method | renderFooter |
Protected method | renderHeader |
Public method | RenderToString(Boolean, Object) | Renders template to string (Inherited from WaveTemplate.)
Public method | RenderToString(WorkContext, Boolean, Object) | Renders template to string in a WorkContext (Inherited from WaveTemplate.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONTENT_WIDTH |
Back to Top
Properties
 | Name | Description
Public property | CanReuseInstance | Override to indicate whetner the instance of the template may be reused for processing of other requests (possibly by parallel threads). Override to return false if there is any per-request state shared in instance fields False by default so multiple requests can not reuse the instance (Inherited from WaveTemplate.)
Public property | ContentType | Override to provides response content type. Default value is HTML (Inherited from WaveTemplate.)
Public property | Context | Custom context for the lifetime of this template (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | CSRFToken | Returns CSRF token for session if it is available or null (Inherited from WaveTemplate.)
Public property | RenderingContext | Returns thread-local rendering context which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | Response | (Inherited from WaveTemplate.)
Public property | Session | Returns session if it is available or null (Inherited from WaveTemplate.)
Public property | Target | Returns thread-local target which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | Title |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Context | (Inherited from Template TContext, TTarget, TRenderingContext .)
Explicit interface implemetation | ITemplate Render | (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
See Also
Master Class
NFX.Wave.Templatization.StockContent Namespace


Master Constructor

Master Constructor NFX Class Library

Initializes a new instance of the Master class

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Master(
    WorkContext work
)
public Master(
    WorkContext work
)
Public Sub New (
    work As WorkContext
)
Public Sub New (
    work As WorkContext
)
public:
Master(
    WorkContext^ work
)
public:
Master(
    WorkContext^ work
)
new :
        work : WorkContext -> Master
new :
        work : WorkContext -> Master

Parameters

work
Type: NFX.Wave WorkContext
See Also
Master Class
Master Members
NFX.Wave.Templatization.StockContent Namespace


Master Fields

Master Fields NFX Class Library

The Master type exposes the following members.
Fields
Name | Description
CONTENT_WIDTH |
Back to Top
See Also
Master Class
NFX.Wave.Templatization.StockContent Namespace


Master.CONTENT_WIDTH Field

Master CONTENT_WIDTH Field NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONTENT_WIDTH
public const string CONTENT_WIDTH
Public Const CONTENT_WIDTH As String
Public Const CONTENT_WIDTH As String
public:
literal String^ CONTENT_WIDTH
public:
literal String^ CONTENT_WIDTH
static val mutable CONTENT_WIDTH: string
static val mutable CONTENT_WIDTH: string

Field Value

Type: Online String
See Also
Master Class
Master Members
NFX.Wave.Templatization.StockContent Namespace


Master Methods

Master Methods NFX Class Library

The Master type exposes the following members.
Methods
 | Name | Description
Public method | BindGlobalContexts | Infrastructure. Sets Context property. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | defaultFooter |
Protected method | DoContextBinding | Infrastructure. Override to perform extra steps after Context property gets set. Normally this method should never be called by developers (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoPostRender | (Inherited from WaveTemplate.)
Protected method | DoPreRender | Performs pre-rendering actions (Inherited from Template TContext, TTarget, TRenderingContext .)
Protected method | DoRender | (Overrides Template TContext, TTarget, TRenderingContext DoRender .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Render(TTarget, TRenderingContext) | Renders template by generating content into target (Inherited from Template TContext, TTarget, TRenderingContext .)
Public method | Render(ResponseRenderingTarget, Object) | Renders template by generating content into ResponseRenderingTarget (Inherited from WaveTemplate.)
Public method | Render(WorkContext, Object) | Renders template by generating content into WorkContext (Inherited from WaveTemplate.)
Protected method | renderBody |
Protected method | renderFooter |
Protected method | renderHeader |
Public method | RenderToString(Boolean, Object) | Renders template to string (Inherited from WaveTemplate.)
Public method | RenderToString(WorkContext, Boolean, Object) | Renders template to string in a WorkContext (Inherited from WaveTemplate.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Render | (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
See Also
Master Class
NFX.Wave.Templatization.StockContent Namespace


Master.defaultFooter Method

Master defaultFooter Method NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void defaultFooter()
protected void defaultFooter()
Protected Sub defaultFooter
Protected Sub defaultFooter
protected:
void defaultFooter()
protected:
void defaultFooter()
member defaultFooter : unit -> unit
member defaultFooter : unit -> unit
See Also
Master Class
Master Members
NFX.Wave.Templatization.StockContent Namespace


Master.DoRender Method

Master DoRender Method NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoRender()
protected override void DoRender()
Protected Overrides Sub DoRender
Protected Overrides Sub DoRender
protected:
virtual void DoRender() override
protected:
virtual void DoRender() override
abstract DoRender : unit -> unit
override DoRender : unit -> unit
abstract DoRender : unit -> unit
override DoRender : unit -> unit
See Also
Master Class
Master Members
NFX.Wave.Templatization.StockContent Namespace


Master.renderBody Method

Master renderBody Method NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void renderBody()
protected abstract void renderBody()
Protected MustOverride Sub renderBody
Protected MustOverride Sub renderBody
protected:
virtual void renderBody() abstract
protected:
virtual void renderBody() abstract
abstract renderBody : unit -> unit
abstract renderBody : unit -> unit
See Also
Master Class
Master Members
NFX.Wave.Templatization.StockContent Namespace


Master.renderFooter Method

Master renderFooter Method NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void renderFooter()
protected virtual void renderFooter()
Protected Overridable Sub renderFooter
Protected Overridable Sub renderFooter
protected:
virtual void renderFooter()
protected:
virtual void renderFooter()
abstract renderFooter : unit -> unit
override renderFooter : unit -> unit
abstract renderFooter : unit -> unit
override renderFooter : unit -> unit
See Also
Master Class
Master Members
NFX.Wave.Templatization.StockContent Namespace


Master.renderHeader Method

Master renderHeader Method NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void renderHeader()
protected abstract void renderHeader()
Protected MustOverride Sub renderHeader
Protected MustOverride Sub renderHeader
protected:
virtual void renderHeader() abstract
protected:
virtual void renderHeader() abstract
abstract renderHeader : unit -> unit
abstract renderHeader : unit -> unit
See Also
Master Class
Master Members
NFX.Wave.Templatization.StockContent Namespace


Master Properties

Master Properties NFX Class Library

The Master type exposes the following members.
Properties
 | Name | Description
Public property | CanReuseInstance | Override to indicate whetner the instance of the template may be reused for processing of other requests (possibly by parallel threads). Override to return false if there is any per-request state shared in instance fields False by default so multiple requests can not reuse the instance (Inherited from WaveTemplate.)
Public property | ContentType | Override to provides response content type. Default value is HTML (Inherited from WaveTemplate.)
Public property | Context | Custom context for the lifetime of this template (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | CSRFToken | Returns CSRF token for session if it is available or null (Inherited from WaveTemplate.)
Public property | RenderingContext | Returns thread-local rendering context which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | Response | (Inherited from WaveTemplate.)
Public property | Session | Returns session if it is available or null (Inherited from WaveTemplate.)
Public property | Target | Returns thread-local target which is specific for this call to Render() (Inherited from Template TContext, TTarget, TRenderingContext .)
Public property | Title |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Context | (Inherited from Template TContext, TTarget, TRenderingContext .)
Back to Top
See Also
Master Class
NFX.Wave.Templatization.StockContent Namespace


Master.Title Property

Master Title Property NFX Class Library

Namespace: NFX.Wave.Templatization.StockContent
Assembly: NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Title { get; }
public virtual string Title { get; }
Public Overridable ReadOnly Property Title As String
    Get
Public Overridable ReadOnly Property Title As String
    Get
public:
virtual property String^ Title {
    String^ get ();
}
public:
virtual property String^ Title {
    String^ get ();
}
abstract Title : string with get
override Title : string with get
abstract Title : string with get
override Title : string with get

Property Value

Type: Online String
See Also
Master Class
Master Members
NFX.Wave.Templatization.StockContent Namespace


NFX.Web Namespace

NFX.Web Namespace NFX Class Library

Provides various web functions like MVC, Templates and various utilities
Classes
 | Class | Description
Public class | ContentType | Declares web-related/mime content types
Public class | Multipart | Faciliates working with multipart encoding
Public class | Multipart Part | Represents a part of multipart encoding
Public class | ServicePointManagerConfigurator | Configures ServicePointManager class. Use singleton Instance property
Public class | ServicePointManagerConfigurator OperationPolicy | Provides contract and default implementation for certificate trust and endpoint binding
Protected class | ServicePointManagerConfigurator OperationPolicy _uri |
Public class | ServicePointManagerConfigurator ServicePointConfigurator |
Public class | StringConsts |
Public class | Utils | Provides various utilities for web technologies
Public class | WebClient | Facilitates working with external services provided via HTTP
Public class | WebClient WebClientTimeouted | Provides WebClient functionality with timeout
Public class | WebConsts | Non-localizable constants
Public class | WebException | Base exception class thrown by NFX.WebForms assembly
Public class | WebSettings | Facilitates fast access to important web-related config settings that update their values when underlying config changes
Structures
 | Structure | Description
Public structure | CacheControl | Decorates controller classes or actions that set NoCache headers in response. By default Force = true
Public structure | Multipart EncodedContent | Represents result of multipart encoded content
Public structure | WebClient RequestParams | Provides request parameters for making WebClient calls
Interfaces
 | Interface | Description
Public interface | IWebClientCaller | Stipulates contract for an entity that executes calls via WebClient
Enumerations
 | Enumeration | Description
Public enumeration | CacheControl Type |
Public enumeration | HTTPRequestMethod |
Public enumeration | WebConsts RedirectCode |


CacheControl Structure

CacheControl Structure NFX Class Library

Decorates controller classes or actions that set NoCache headers in response. By default Force = true

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct CacheControl
public struct CacheControl
Public Structure CacheControl
Public Structure CacheControl
public value class CacheControl
public value class CacheControl
[<SealedAttribute>]
type CacheControl =  struct end
[<SealedAttribute>]
type CacheControl =  struct end
See Also
CacheControl Members
NFX.Web Namespace


CacheControl Members

CacheControl Members NFX Class Library

The CacheControl type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromConfig |
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | PrivateMaxAgeSec |
 | PublicMaxAgeSec |
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
DEFAULT_CACHE_MAX_AGE_SEC |
Back to Top
Properties
 | Name | Description
Public property | Cacheability |
Public property | HTTPCacheControl | Build standard cache control header from fields
Public property | MaxAgeSec |
Public property | MustRevalidate |
 | NoCache |
Public property | NoStore |
Public property | NoTransform |
Public property | ProxyRevalidate |
Public property | SharedMaxAgeSec |
Back to Top
See Also
CacheControl Structure
NFX.Web Namespace


CacheControl Fields

CacheControl Fields NFX Class Library

The CacheControl type exposes the following members.
Fields
Name | Description
DEFAULT_CACHE_MAX_AGE_SEC |
Back to Top
See Also
CacheControl Structure
NFX.Web Namespace


CacheControl.DEFAULT_CACHE_MAX_AGE_SEC Field

CacheControl DEFAULT_CACHE_MAX_AGE_SEC Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_CACHE_MAX_AGE_SEC
public const int DEFAULT_CACHE_MAX_AGE_SEC
Public Const DEFAULT_CACHE_MAX_AGE_SEC As Integer
Public Const DEFAULT_CACHE_MAX_AGE_SEC As Integer
public:
literal int DEFAULT_CACHE_MAX_AGE_SEC
public:
literal int DEFAULT_CACHE_MAX_AGE_SEC
static val mutable DEFAULT_CACHE_MAX_AGE_SEC: int
static val mutable DEFAULT_CACHE_MAX_AGE_SEC: int

Field Value

Type: Online Int32
See Also
CacheControl Structure
CacheControl Members
NFX.Web Namespace


CacheControl Methods

CacheControl Methods NFX Class Library

The CacheControl type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromConfig |
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | PrivateMaxAgeSec |
 | PublicMaxAgeSec |
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheControl Structure
NFX.Web Namespace


CacheControl.FromConfig Method

CacheControl FromConfig Method NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CacheControl FromConfig(
    IConfigSectionNode cfg
)
public static CacheControl FromConfig(
    IConfigSectionNode cfg
)
Public Shared Function FromConfig (
    cfg As IConfigSectionNode
) As CacheControl
Public Shared Function FromConfig (
    cfg As IConfigSectionNode
) As CacheControl
public:
static CacheControl FromConfig(
    IConfigSectionNode^ cfg
)
public:
static CacheControl FromConfig(
    IConfigSectionNode^ cfg
)
static member FromConfig :
        cfg : IConfigSectionNode -> CacheControl
static member FromConfig :
        cfg : IConfigSectionNode -> CacheControl

Parameters

cfg
Type: NFX.Environment IConfigSectionNode

Return Value

Type: CacheControl
See Also
CacheControl Structure
CacheControl Members
NFX.Web Namespace


CacheControl.PrivateMaxAgeSec Method

CacheControl PrivateMaxAgeSec Method NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CacheControl PrivateMaxAgeSec(
    int maxAgeSec = 86400
)
public static CacheControl PrivateMaxAgeSec(
    int maxAgeSec = 86400
)
Public Shared Function PrivateMaxAgeSec (
    Optional maxAgeSec As Integer = 86400
) As CacheControl
Public Shared Function PrivateMaxAgeSec (
    Optional maxAgeSec As Integer = 86400
) As CacheControl
public:
static CacheControl PrivateMaxAgeSec(
    int maxAgeSec = 86400
)
public:
static CacheControl PrivateMaxAgeSec(
    int maxAgeSec = 86400
)
static member PrivateMaxAgeSec :
        ?maxAgeSec : int
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec 86400
*)
-> CacheControl
static member PrivateMaxAgeSec :
        ?maxAgeSec : int
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec 86400
*)
-> CacheControl

Parameters

maxAgeSec (Optional)
Type: Online System Int32

Return Value

Type: CacheControl
See Also
CacheControl Structure
CacheControl Members
NFX.Web Namespace


CacheControl.PublicMaxAgeSec Method

CacheControl PublicMaxAgeSec Method NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CacheControl PublicMaxAgeSec(
    int maxAgeSec = 86400
)
public static CacheControl PublicMaxAgeSec(
    int maxAgeSec = 86400
)
Public Shared Function PublicMaxAgeSec (
    Optional maxAgeSec As Integer = 86400
) As CacheControl
Public Shared Function PublicMaxAgeSec (
    Optional maxAgeSec As Integer = 86400
) As CacheControl
public:
static CacheControl PublicMaxAgeSec(
    int maxAgeSec = 86400
)
public:
static CacheControl PublicMaxAgeSec(
    int maxAgeSec = 86400
)
static member PublicMaxAgeSec :
        ?maxAgeSec : int
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec 86400
*)
-> CacheControl
static member PublicMaxAgeSec :
        ?maxAgeSec : int
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec 86400
*)
-> CacheControl

Parameters

maxAgeSec (Optional)
Type: Online System Int32

Return Value

Type: CacheControl
See Also
CacheControl Structure
CacheControl Members
NFX.Web Namespace


CacheControl Properties

CacheControl Properties NFX Class Library

The CacheControl type exposes the following members.
Properties
 | Name | Description
Public property | Cacheability |
Public property | HTTPCacheControl | Build standard cache control header from fields
Public property | MaxAgeSec |
Public property | MustRevalidate |
 | NoCache |
Public property | NoStore |
Public property | NoTransform |
Public property | ProxyRevalidate |
Public property | SharedMaxAgeSec |
Back to Top
See Also
CacheControl Structure
NFX.Web Namespace


CacheControl.Cacheability Property

CacheControl Cacheability Property NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public CacheControl..::..Type Cacheability { get; set; }
[ConfigAttribute]
public CacheControl..::..Type Cacheability { get; set; }
<ConfigAttribute>
Public Property Cacheability As CacheControl..::..Type
    Get
    Set
<ConfigAttribute>
Public Property Cacheability As CacheControl..::..Type
    Get
    Set
public:
[ConfigAttribute]
property CacheControl..::..Type Cacheability {
    CacheControl..::..Type get ();
    void set (CacheControl..::..Type value);
}
public:
[ConfigAttribute]
property CacheControl..::..Type Cacheability {
    CacheControl..::..Type get ();
    void set (CacheControl..::..Type value);
}
[<ConfigAttribute>]
member Cacheability : CacheControl..::..Type with get, set
[<ConfigAttribute>]
member Cacheability : CacheControl..::..Type with get, set

Property Value

Type: CacheControl Type
See Also
CacheControl Structure
CacheControl Members
NFX.Web Namespace


CacheControl.HTTPCacheControl Property

CacheControl HTTPCacheControl Property NFX Class Library

Build standard cache control header from fields

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HTTPCacheControl { get; }
public string HTTPCacheControl { get; }
Public ReadOnly Property HTTPCacheControl As String
    Get
Public ReadOnly Property HTTPCacheControl As String
    Get
public:
property String^ HTTPCacheControl {
    String^ get ();
}
public:
property String^ HTTPCacheControl {
    String^ get ();
}
member HTTPCacheControl : string with get
member HTTPCacheControl : string with get

Property Value

Type: Online String
See Also
CacheControl Structure
CacheControl Members
NFX.Web Namespace


CacheControl.MaxAgeSec Property

CacheControl MaxAgeSec Property NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public Nullable<int> MaxAgeSec { get; set; }
[ConfigAttribute]
public Nullable<int> MaxAgeSec { get; set; }
<ConfigAttribute>
Public Property MaxAgeSec As Nullable(Of Integer)
    Get
    Set
<ConfigAttribute>
Public Property MaxAgeSec As Nullable(Of Integer)
    Get
    Set
public:
[ConfigAttribute]
property Nullable<int> MaxAgeSec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
public:
[ConfigAttribute]
property Nullable<int> MaxAgeSec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
[<ConfigAttribute>]
member MaxAgeSec : Nullable<int> with get, set
[<ConfigAttribute>]
member MaxAgeSec : Nullable<int> with get, set

Property Value

Type: Online Nullable Online Int32
See Also
CacheControl Structure
CacheControl Members
NFX.Web Namespace


CacheControl.MustRevalidate Property

CacheControl MustRevalidate Property NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool MustRevalidate { get; set; }
[ConfigAttribute]
public bool MustRevalidate { get; set; }
<ConfigAttribute>
Public Property MustRevalidate As Boolean
    Get
    Set
<ConfigAttribute>
Public Property MustRevalidate As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool MustRevalidate {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool MustRevalidate {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member MustRevalidate : bool with get, set
[<ConfigAttribute>]
member MustRevalidate : bool with get, set

Property Value

Type: Online Boolean
See Also
CacheControl Structure
CacheControl Members
NFX.Web Namespace


CacheControl.NoCache Property

CacheControl NoCache Property NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CacheControl NoCache { get; }
public static CacheControl NoCache { get; }
Public Shared ReadOnly Property NoCache As CacheControl
    Get
Public Shared ReadOnly Property NoCache As CacheControl
    Get
public:
static property CacheControl NoCache {
    CacheControl get ();
}
public:
static property CacheControl NoCache {
    CacheControl get ();
}
static member NoCache : CacheControl with get
static member NoCache : CacheControl with get

Property Value

Type: CacheControl
See Also
CacheControl Structure
CacheControl Members
NFX.Web Namespace


CacheControl.NoStore Property

CacheControl NoStore Property NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool NoStore { get; set; }
[ConfigAttribute]
public bool NoStore { get; set; }
<ConfigAttribute>
Public Property NoStore As Boolean
    Get
    Set
<ConfigAttribute>
Public Property NoStore As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool NoStore {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool NoStore {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member NoStore : bool with get, set
[<ConfigAttribute>]
member NoStore : bool with get, set

Property Value

Type: Online Boolean
See Also
CacheControl Structure
CacheControl Members
NFX.Web Namespace


CacheControl.NoTransform Property

CacheControl NoTransform Property NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool NoTransform { get; set; }
[ConfigAttribute]
public bool NoTransform { get; set; }
<ConfigAttribute>
Public Property NoTransform As Boolean
    Get
    Set
<ConfigAttribute>
Public Property NoTransform As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool NoTransform {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool NoTransform {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member NoTransform : bool with get, set
[<ConfigAttribute>]
member NoTransform : bool with get, set

Property Value

Type: Online Boolean
See Also
CacheControl Structure
CacheControl Members
NFX.Web Namespace


CacheControl.ProxyRevalidate Property

CacheControl ProxyRevalidate Property NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool ProxyRevalidate { get; set; }
[ConfigAttribute]
public bool ProxyRevalidate { get; set; }
<ConfigAttribute>
Public Property ProxyRevalidate As Boolean
    Get
    Set
<ConfigAttribute>
Public Property ProxyRevalidate As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool ProxyRevalidate {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool ProxyRevalidate {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member ProxyRevalidate : bool with get, set
[<ConfigAttribute>]
member ProxyRevalidate : bool with get, set

Property Value

Type: Online Boolean
See Also
CacheControl Structure
CacheControl Members
NFX.Web Namespace


CacheControl.SharedMaxAgeSec Property

CacheControl SharedMaxAgeSec Property NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public Nullable<int> SharedMaxAgeSec { get; set; }
[ConfigAttribute]
public Nullable<int> SharedMaxAgeSec { get; set; }
<ConfigAttribute>
Public Property SharedMaxAgeSec As Nullable(Of Integer)
    Get
    Set
<ConfigAttribute>
Public Property SharedMaxAgeSec As Nullable(Of Integer)
    Get
    Set
public:
[ConfigAttribute]
property Nullable<int> SharedMaxAgeSec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
public:
[ConfigAttribute]
property Nullable<int> SharedMaxAgeSec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
[<ConfigAttribute>]
member SharedMaxAgeSec : Nullable<int> with get, set
[<ConfigAttribute>]
member SharedMaxAgeSec : Nullable<int> with get, set

Property Value

Type: Online Nullable Online Int32
See Also
CacheControl Structure
CacheControl Members
NFX.Web Namespace


CacheControl.Type Enumeration

CacheControl Type Enumeration NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Type
public enum Type
Public Enumeration Type
Public Enumeration Type
public enum class Type
public enum class Type
type Type
type Type
Members
Member name | Value | Description
Public | 0 |
Private | 1 |
NoCache | 2 |
See Also
NFX.Web Namespace


ContentType Class

ContentType Class NFX Class Library

Declares web-related/mime content types
Inheritance Hierarchy
Online System Object
NFX.Web ContentType

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ContentType
public static class ContentType
Public NotInheritable Class ContentType
Public NotInheritable Class ContentType
public ref class ContentType abstract sealed
public ref class ContentType abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ContentType =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ContentType =  class end
See Also
ContentType Members
NFX.Web Namespace


ContentType Members

ContentType Members NFX Class Library

The ContentType type exposes the following members.
Methods
Name | Description
ExtensionToContentType |
Back to Top
Fields
Name | Description
BINARY |
CSS |
EOT |
EXE |
FORM_MULTIPART_ENCODED |
FORM_URL_ENCODED |
GIF |
HTML |
ICO |
JPEG |
JS |
JSON |
OTF |
PDF |
PNG |
TEXT |
TTF |
WOFF |
XML_APP |
XML_TEXT |
Back to Top
See Also
ContentType Class
NFX.Web Namespace


ContentType Fields

ContentType Fields NFX Class Library

The ContentType type exposes the following members.
Fields
Name | Description
BINARY |
CSS |
EOT |
EXE |
FORM_MULTIPART_ENCODED |
FORM_URL_ENCODED |
GIF |
HTML |
ICO |
JPEG |
JS |
JSON |
OTF |
PDF |
PNG |
TEXT |
TTF |
WOFF |
XML_APP |
XML_TEXT |
Back to Top
See Also
ContentType Class
NFX.Web Namespace


ContentType.BINARY Field

ContentType BINARY Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BINARY
public const string BINARY
Public Const BINARY As String
Public Const BINARY As String
public:
literal String^ BINARY
public:
literal String^ BINARY
static val mutable BINARY: string
static val mutable BINARY: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.CSS Field

ContentType CSS Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CSS
public const string CSS
Public Const CSS As String
Public Const CSS As String
public:
literal String^ CSS
public:
literal String^ CSS
static val mutable CSS: string
static val mutable CSS: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.EOT Field

ContentType EOT Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EOT
public const string EOT
Public Const EOT As String
Public Const EOT As String
public:
literal String^ EOT
public:
literal String^ EOT
static val mutable EOT: string
static val mutable EOT: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.EXE Field

ContentType EXE Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXE
public const string EXE
Public Const EXE As String
Public Const EXE As String
public:
literal String^ EXE
public:
literal String^ EXE
static val mutable EXE: string
static val mutable EXE: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.FORM_MULTIPART_ENCODED Field

ContentType FORM_MULTIPART_ENCODED Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FORM_MULTIPART_ENCODED
public const string FORM_MULTIPART_ENCODED
Public Const FORM_MULTIPART_ENCODED As String
Public Const FORM_MULTIPART_ENCODED As String
public:
literal String^ FORM_MULTIPART_ENCODED
public:
literal String^ FORM_MULTIPART_ENCODED
static val mutable FORM_MULTIPART_ENCODED: string
static val mutable FORM_MULTIPART_ENCODED: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.FORM_URL_ENCODED Field

ContentType FORM_URL_ENCODED Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FORM_URL_ENCODED
public const string FORM_URL_ENCODED
Public Const FORM_URL_ENCODED As String
Public Const FORM_URL_ENCODED As String
public:
literal String^ FORM_URL_ENCODED
public:
literal String^ FORM_URL_ENCODED
static val mutable FORM_URL_ENCODED: string
static val mutable FORM_URL_ENCODED: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.GIF Field

ContentType GIF Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GIF
public const string GIF
Public Const GIF As String
Public Const GIF As String
public:
literal String^ GIF
public:
literal String^ GIF
static val mutable GIF: string
static val mutable GIF: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.HTML Field

ContentType HTML Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HTML
public const string HTML
Public Const HTML As String
Public Const HTML As String
public:
literal String^ HTML
public:
literal String^ HTML
static val mutable HTML: string
static val mutable HTML: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.ICO Field

ContentType ICO Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ICO
public const string ICO
Public Const ICO As String
Public Const ICO As String
public:
literal String^ ICO
public:
literal String^ ICO
static val mutable ICO: string
static val mutable ICO: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.JPEG Field

ContentType JPEG Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string JPEG
public const string JPEG
Public Const JPEG As String
Public Const JPEG As String
public:
literal String^ JPEG
public:
literal String^ JPEG
static val mutable JPEG: string
static val mutable JPEG: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.JS Field

ContentType JS Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string JS
public const string JS
Public Const JS As String
Public Const JS As String
public:
literal String^ JS
public:
literal String^ JS
static val mutable JS: string
static val mutable JS: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.JSON Field

ContentType JSON Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string JSON
public const string JSON
Public Const JSON As String
Public Const JSON As String
public:
literal String^ JSON
public:
literal String^ JSON
static val mutable JSON: string
static val mutable JSON: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.OTF Field

ContentType OTF Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string OTF
public const string OTF
Public Const OTF As String
Public Const OTF As String
public:
literal String^ OTF
public:
literal String^ OTF
static val mutable OTF: string
static val mutable OTF: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.PDF Field

ContentType PDF Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PDF
public const string PDF
Public Const PDF As String
Public Const PDF As String
public:
literal String^ PDF
public:
literal String^ PDF
static val mutable PDF: string
static val mutable PDF: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.PNG Field

ContentType PNG Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PNG
public const string PNG
Public Const PNG As String
Public Const PNG As String
public:
literal String^ PNG
public:
literal String^ PNG
static val mutable PNG: string
static val mutable PNG: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.TEXT Field

ContentType TEXT Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TEXT
public const string TEXT
Public Const TEXT As String
Public Const TEXT As String
public:
literal String^ TEXT
public:
literal String^ TEXT
static val mutable TEXT: string
static val mutable TEXT: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.TTF Field

ContentType TTF Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TTF
public const string TTF
Public Const TTF As String
Public Const TTF As String
public:
literal String^ TTF
public:
literal String^ TTF
static val mutable TTF: string
static val mutable TTF: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.WOFF Field

ContentType WOFF Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string WOFF
public const string WOFF
Public Const WOFF As String
Public Const WOFF As String
public:
literal String^ WOFF
public:
literal String^ WOFF
static val mutable WOFF: string
static val mutable WOFF: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.XML_APP Field

ContentType XML_APP Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string XML_APP
public const string XML_APP
Public Const XML_APP As String
Public Const XML_APP As String
public:
literal String^ XML_APP
public:
literal String^ XML_APP
static val mutable XML_APP: string
static val mutable XML_APP: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType.XML_TEXT Field

ContentType XML_TEXT Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string XML_TEXT
public const string XML_TEXT
Public Const XML_TEXT As String
Public Const XML_TEXT As String
public:
literal String^ XML_TEXT
public:
literal String^ XML_TEXT
static val mutable XML_TEXT: string
static val mutable XML_TEXT: string

Field Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


ContentType Methods

ContentType Methods NFX Class Library

The ContentType type exposes the following members.
Methods
Name | Description
ExtensionToContentType |
Back to Top
See Also
ContentType Class
NFX.Web Namespace


ContentType.ExtensionToContentType Method

ContentType ExtensionToContentType Method NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ExtensionToContentType(
    string ext,
    string dflt = "text/html"
)
public static string ExtensionToContentType(
    string ext,
    string dflt = "text/html"
)
Public Shared Function ExtensionToContentType (
    ext As String,
    Optional dflt As String = "text/html"
) As String
Public Shared Function ExtensionToContentType (
    ext As String,
    Optional dflt As String = "text/html"
) As String
public:
static String^ ExtensionToContentType(
    String^ ext,
    String^ dflt = L"text/html"
)
public:
static String^ ExtensionToContentType(
    String^ ext,
    String^ dflt = L"text/html"
)
static member ExtensionToContentType :
        ext : string *
        ?dflt : string
(* Defaults:
        let _dflt = defaultArg dflt "text/html"
*)
-> string
static member ExtensionToContentType :
        ext : string *
        ?dflt : string
(* Defaults:
        let _dflt = defaultArg dflt "text/html"
*)
-> string

Parameters

ext
Type: Online System String
dflt (Optional)
Type: Online System String

Return Value

Type: Online String
See Also
ContentType Class
ContentType Members
NFX.Web Namespace


HTTPRequestMethod Enumeration

HTTPRequestMethod Enumeration NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum HTTPRequestMethod
public enum HTTPRequestMethod
Public Enumeration HTTPRequestMethod
Public Enumeration HTTPRequestMethod
public enum class HTTPRequestMethod
public enum class HTTPRequestMethod
type HTTPRequestMethod
type HTTPRequestMethod
Members
Member name | Value | Description
GET | 0 |
HEAD | 1 |
POST | 2 |
PUT | 3 |
DELETE | 4 |
CONNECT | 5 |
OPTIONS | 6 |
TRACE | 7 |
PATCH | 8 |
See Also
NFX.Web Namespace


IWebClientCaller Interface

IWebClientCaller Interface NFX Class Library

Stipulates contract for an entity that executes calls via WebClient

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IWebClientCaller
public interface IWebClientCaller
Public Interface IWebClientCaller
Public Interface IWebClientCaller
public interface class IWebClientCaller
public interface class IWebClientCaller
type IWebClientCaller =  interface end
type IWebClientCaller =  interface end
See Also
IWebClientCaller Members
NFX.Web Namespace


IWebClientCaller Members

IWebClientCaller Members NFX Class Library

The IWebClientCaller type exposes the following members.
Properties
 | Name | Description
Public property | KeepAlive | Specifies keepalive option for web request
Public property | Pipelined | Specifies if pipelining is used for web request
Public property | WebServiceCallTimeoutMs | Specifies timeout for web call. If zero then default is used
Back to Top
See Also
IWebClientCaller Interface
NFX.Web Namespace


IWebClientCaller Properties

IWebClientCaller Properties NFX Class Library

The IWebClientCaller type exposes the following members.
Properties
 | Name | Description
Public property | KeepAlive | Specifies keepalive option for web request
Public property | Pipelined | Specifies if pipelining is used for web request
Public property | WebServiceCallTimeoutMs | Specifies timeout for web call. If zero then default is used
Back to Top
See Also
IWebClientCaller Interface
NFX.Web Namespace


IWebClientCaller.KeepAlive Property

IWebClientCaller KeepAlive Property NFX Class Library

Specifies keepalive option for web request

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool KeepAlive { get; }
bool KeepAlive { get; }
ReadOnly Property KeepAlive As Boolean
    Get
ReadOnly Property KeepAlive As Boolean
    Get
property bool KeepAlive {
    bool get ();
}
property bool KeepAlive {
    bool get ();
}
abstract KeepAlive : bool with get
abstract KeepAlive : bool with get

Property Value

Type: Online Boolean
See Also
IWebClientCaller Interface
IWebClientCaller Members
NFX.Web Namespace


IWebClientCaller.Pipelined Property

IWebClientCaller Pipelined Property NFX Class Library

Specifies if pipelining is used for web request

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Pipelined { get; }
bool Pipelined { get; }
ReadOnly Property Pipelined As Boolean
    Get
ReadOnly Property Pipelined As Boolean
    Get
property bool Pipelined {
    bool get ();
}
property bool Pipelined {
    bool get ();
}
abstract Pipelined : bool with get
abstract Pipelined : bool with get

Property Value

Type: Online Boolean
See Also
IWebClientCaller Interface
IWebClientCaller Members
NFX.Web Namespace


IWebClientCaller.WebServiceCallTimeoutMs Property

IWebClientCaller WebServiceCallTimeoutMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies timeout for web call. If zero then default is used

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int WebServiceCallTimeoutMs { get; }
int WebServiceCallTimeoutMs { get; }
ReadOnly Property WebServiceCallTimeoutMs As Integer
    Get
ReadOnly Property WebServiceCallTimeoutMs As Integer
    Get
property int WebServiceCallTimeoutMs {
    int get ();
}
property int WebServiceCallTimeoutMs {
    int get ();
}
abstract WebServiceCallTimeoutMs : int with get
abstract WebServiceCallTimeoutMs : int with get

Property Value

Type: Online Int32
See Also
IWebClientCaller Interface
IWebClientCaller Members
NFX.Web Namespace


Multipart Class

Multipart Class NFX Class Library

Faciliates working with multipart encoding
Inheritance Hierarchy
Online System Object
NFX.Web Multipart

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Multipart
public sealed class Multipart
Public NotInheritable Class Multipart
Public NotInheritable Class Multipart
public ref class Multipart sealed
public ref class Multipart sealed
[<SealedAttribute>]
type Multipart =  class end
[<SealedAttribute>]
type Multipart =  class end
See Also
Multipart Members
NFX.Web Namespace


Multipart Members

Multipart Members NFX Class Library

The Multipart type exposes the following members.
Constructors
 | Name | Description
Public method | Multipart | Initializes a new instance of the Multipart class
Public method | Multipart(IEnumerable Multipart Part ) | Initializes a new instance of the Multipart class
Back to Top
Methods
 | Name | Description
Public method | Encode(Encoding) |
Public method | Encode(MemoryStream, Encoding) |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ParseContentType |
 | ReadFromBytes |
 | ReadFromStream |
Public method | ToJSONDataMap |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
NOT_FOUND_POS |
Back to Top
Properties
 | Name | Description
Public property | Parts |
Back to Top
See Also
Multipart Class
NFX.Web Namespace


Multipart Constructor

Multipart Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Multipart | Initializes a new instance of the Multipart class
Public method | Multipart(IEnumerable Multipart Part ) | Initializes a new instance of the Multipart class
Back to Top
See Also
Multipart Class
Multipart Members
NFX.Web Namespace


Multipart Constructor

Multipart Constructor NFX Class Library

Initializes a new instance of the Multipart class

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Multipart()
public Multipart()
Public Sub New
Public Sub New
public:
Multipart()
public:
Multipart()
new : unit -> Multipart
new : unit -> Multipart
See Also
Multipart Class
Multipart Members
Multipart Overload
NFX.Web Namespace


Multipart Constructor (IEnumerable(Multipart.Part))

Multipart Constructor (IEnumerable Multipart Part ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Multipart class

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Multipart(
    IEnumerable<Multipart..::..Part> parts
)
public Multipart(
    IEnumerable<Multipart..::..Part> parts
)
Public Sub New (
    parts As IEnumerable(Of Multipart..::..Part)
)
Public Sub New (
    parts As IEnumerable(Of Multipart..::..Part)
)
public:
Multipart(
    IEnumerable<Multipart..::..Part^>^ parts
)
public:
Multipart(
    IEnumerable<Multipart..::..Part^>^ parts
)
new :
        parts : IEnumerable<Multipart..::..Part> -> Multipart
new :
        parts : IEnumerable<Multipart..::..Part> -> Multipart

Parameters

parts
Type: Online System.Collections.Generic IEnumerable Multipart Part
See Also
Multipart Class
Multipart Members
Multipart Overload
NFX.Web Namespace


Multipart Fields

Multipart Fields NFX Class Library

The Multipart type exposes the following members.
Fields
Name | Description
NOT_FOUND_POS |
Back to Top
See Also
Multipart Class
NFX.Web Namespace


Multipart.NOT_FOUND_POS Field

Multipart NOT_FOUND_POS Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int NOT_FOUND_POS
public const int NOT_FOUND_POS
Public Const NOT_FOUND_POS As Integer
Public Const NOT_FOUND_POS As Integer
public:
literal int NOT_FOUND_POS
public:
literal int NOT_FOUND_POS
static val mutable NOT_FOUND_POS: int
static val mutable NOT_FOUND_POS: int

Field Value

Type: Online Int32
See Also
Multipart Class
Multipart Members
NFX.Web Namespace


Multipart Methods

Multipart Methods NFX Class Library

The Multipart type exposes the following members.
Methods
 | Name | Description
Public method | Encode(Encoding) |
Public method | Encode(MemoryStream, Encoding) |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ParseContentType |
 | ReadFromBytes |
 | ReadFromStream |
Public method | ToJSONDataMap |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Multipart Class
NFX.Web Namespace


Multipart.Encode Method

Multipart Encode Method NFX Class Library

Overload List
 | Name | Description
Public method | Encode(Encoding) |
Public method | Encode(MemoryStream, Encoding) |
Back to Top
See Also
Multipart Class
Multipart Members
NFX.Web Namespace


Multipart.Encode Method (Encoding)

Multipart Encode Method (Encoding) NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Multipart..::..EncodedContent Encode(
    Encoding encoding = null
)
public Multipart..::..EncodedContent Encode(
    Encoding encoding = null
)
Public Function Encode (
    Optional encoding As Encoding = Nothing
) As Multipart..::..EncodedContent
Public Function Encode (
    Optional encoding As Encoding = Nothing
) As Multipart..::..EncodedContent
public:
Multipart..::..EncodedContent Encode(
    Encoding^ encoding = nullptr
)
public:
Multipart..::..EncodedContent Encode(
    Encoding^ encoding = nullptr
)
member Encode :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> Multipart..::..EncodedContent
member Encode :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> Multipart..::..EncodedContent

Parameters

encoding (Optional)
Type: Online System.Text Encoding

Return Value

Type: Multipart EncodedContent
See Also
Multipart Class
Multipart Members
Encode Overload
NFX.Web Namespace


Multipart.Encode Method (MemoryStream, Encoding)

Multipart Encode Method (MemoryStream, Encoding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Multipart..::..EncodedContent Encode(
    MemoryStream stream,
    Encoding encoding = null
)
public Multipart..::..EncodedContent Encode(
    MemoryStream stream,
    Encoding encoding = null
)
Public Function Encode (
    stream As MemoryStream,
    Optional encoding As Encoding = Nothing
) As Multipart..::..EncodedContent
Public Function Encode (
    stream As MemoryStream,
    Optional encoding As Encoding = Nothing
) As Multipart..::..EncodedContent
public:
Multipart..::..EncodedContent Encode(
    MemoryStream^ stream,
    Encoding^ encoding = nullptr
)
public:
Multipart..::..EncodedContent Encode(
    MemoryStream^ stream,
    Encoding^ encoding = nullptr
)
member Encode :
        stream : MemoryStream *
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> Multipart..::..EncodedContent
member Encode :
        stream : MemoryStream *
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> Multipart..::..EncodedContent

Parameters

stream
Type: Online System.IO MemoryStream
encoding (Optional)
Type: Online System.Text Encoding

Return Value

Type: Multipart EncodedContent
See Also
Multipart Class
Multipart Members
Encode Overload
NFX.Web Namespace


Multipart.ParseContentType Method

Multipart ParseContentType Method NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ParseContentType(
    string contentType
)
public static string ParseContentType(
    string contentType
)
Public Shared Function ParseContentType (
    contentType As String
) As String
Public Shared Function ParseContentType (
    contentType As String
) As String
public:
static String^ ParseContentType(
    String^ contentType
)
public:
static String^ ParseContentType(
    String^ contentType
)
static member ParseContentType :
        contentType : string -> string
static member ParseContentType :
        contentType : string -> string

Parameters

contentType
Type: Online System String

Return Value

Type: Online String
See Also
Multipart Class
Multipart Members
NFX.Web Namespace


Multipart.ReadFromBytes Method

Multipart ReadFromBytes Method NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Multipart ReadFromBytes(
    byte[] buffer,
    ref string boundary,
    Encoding encoding = null
)
public static Multipart ReadFromBytes(
    byte[] buffer,
    ref string boundary,
    Encoding encoding = null
)
Public Shared Function ReadFromBytes (
    buffer As Byte(),
    ByRef boundary As String,
    Optional encoding As Encoding = Nothing
) As Multipart
Public Shared Function ReadFromBytes (
    buffer As Byte(),
    ByRef boundary As String,
    Optional encoding As Encoding = Nothing
) As Multipart
public:
static Multipart^ ReadFromBytes(
    array<unsigned char>^ buffer,
    String^% boundary,
    Encoding^ encoding = nullptr
)
public:
static Multipart^ ReadFromBytes(
    array<unsigned char>^ buffer,
    String^% boundary,
    Encoding^ encoding = nullptr
)
static member ReadFromBytes :
        buffer : byte[] *
        boundary : string byref *
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> Multipart
static member ReadFromBytes :
        buffer : byte[] *
        boundary : string byref *
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> Multipart

Parameters

buffer
Type: Online System Byte
boundary
Type: Online System String
encoding (Optional)
Type: Online System.Text Encoding

Return Value

Type: Multipart
See Also
Multipart Class
Multipart Members
NFX.Web Namespace


Multipart.ReadFromStream Method

Multipart ReadFromStream Method NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Multipart ReadFromStream(
    Stream stream,
    ref string boundary,
    Encoding encoding = null
)
public static Multipart ReadFromStream(
    Stream stream,
    ref string boundary,
    Encoding encoding = null
)
Public Shared Function ReadFromStream (
    stream As Stream,
    ByRef boundary As String,
    Optional encoding As Encoding = Nothing
) As Multipart
Public Shared Function ReadFromStream (
    stream As Stream,
    ByRef boundary As String,
    Optional encoding As Encoding = Nothing
) As Multipart
public:
static Multipart^ ReadFromStream(
    Stream^ stream,
    String^% boundary,
    Encoding^ encoding = nullptr
)
public:
static Multipart^ ReadFromStream(
    Stream^ stream,
    String^% boundary,
    Encoding^ encoding = nullptr
)
static member ReadFromStream :
        stream : Stream *
        boundary : string byref *
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> Multipart
static member ReadFromStream :
        stream : Stream *
        boundary : string byref *
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> Multipart

Parameters

stream
Type: Online System.IO Stream
boundary
Type: Online System String
encoding (Optional)
Type: Online System.Text Encoding

Return Value

Type: Multipart
See Also
Multipart Class
Multipart Members
NFX.Web Namespace


Multipart.ToJSONDataMap Method

Multipart ToJSONDataMap Method NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap ToJSONDataMap()
public JSONDataMap ToJSONDataMap()
Public Function ToJSONDataMap As JSONDataMap
Public Function ToJSONDataMap As JSONDataMap
public:
JSONDataMap^ ToJSONDataMap()
public:
JSONDataMap^ ToJSONDataMap()
member ToJSONDataMap : unit -> JSONDataMap
member ToJSONDataMap : unit -> JSONDataMap

Return Value

Type: JSONDataMap
See Also
Multipart Class
Multipart Members
NFX.Web Namespace


Multipart Properties

Multipart Properties NFX Class Library

The Multipart type exposes the following members.
Properties
 | Name | Description
Public property | Parts |
Back to Top
See Also
Multipart Class
NFX.Web Namespace


Multipart.Parts Property

Multipart Parts Property NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Registry<Multipart..::..Part> Parts { get; }
public Registry<Multipart..::..Part> Parts { get; }
Public ReadOnly Property Parts As Registry(Of Multipart..::..Part)
    Get
Public ReadOnly Property Parts As Registry(Of Multipart..::..Part)
    Get
public:
property Registry<Multipart..::..Part^>^ Parts {
    Registry<Multipart..::..Part^>^ get ();
}
public:
property Registry<Multipart..::..Part^>^ Parts {
    Registry<Multipart..::..Part^>^ get ();
}
member Parts : Registry<Multipart..::..Part> with get
member Parts : Registry<Multipart..::..Part> with get

Property Value

Type: Registry Multipart Part
See Also
Multipart Class
Multipart Members
NFX.Web Namespace


Multipart.EncodedContent Structure

Multipart EncodedContent Structure NFX Class Library

Represents result of multipart encoded content

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct EncodedContent
public struct EncodedContent
Public Structure EncodedContent
Public Structure EncodedContent
public value class EncodedContent
public value class EncodedContent
[<SealedAttribute>]
type EncodedContent =  struct end
[<SealedAttribute>]
type EncodedContent =  struct end
See Also
Multipart EncodedContent Members
NFX.Web Namespace


Multipart.EncodedContent Members

Multipart EncodedContent Members NFX Class Library

The Multipart EncodedContent type exposes the following members.
Constructors
 | Name | Description
Protected method | Multipart EncodedContent | Initializes a new instance of the Multipart EncodedContent class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Boundary |
Public field | Buffer |
Public field | Encoding |
Public field | Length |
Public field | StartIdx |
Back to Top
See Also
Multipart EncodedContent Structure
NFX.Web Namespace


Multipart.EncodedContent Constructor

Multipart EncodedContent Constructor NFX Class Library

Initializes a new instance of the Multipart EncodedContent class

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal EncodedContent(
    string boundary,
    byte[] buf,
    long idx,
    long len,
    Encoding enc
)
internal EncodedContent(
    string boundary,
    byte[] buf,
    long idx,
    long len,
    Encoding enc
)
Friend Sub New (
    boundary As String,
    buf As Byte(),
    idx As Long,
    len As Long,
    enc As Encoding
)
Friend Sub New (
    boundary As String,
    buf As Byte(),
    idx As Long,
    len As Long,
    enc As Encoding
)
internal:
EncodedContent(
    String^ boundary,
    array<unsigned char>^ buf,
    long long idx,
    long long len,
    Encoding^ enc
)
internal:
EncodedContent(
    String^ boundary,
    array<unsigned char>^ buf,
    long long idx,
    long long len,
    Encoding^ enc
)
new :
        boundary : string *
        buf : byte[] *
        idx : int64 *
        len : int64 *
        enc : Encoding -> EncodedContent
new :
        boundary : string *
        buf : byte[] *
        idx : int64 *
        len : int64 *
        enc : Encoding -> EncodedContent

Parameters

boundary
Type: Online System String
buf
Type: Online System Byte
idx
Type: Online System Int64
len
Type: Online System Int64
enc
Type: Online System.Text Encoding
See Also
Multipart EncodedContent Structure
Multipart EncodedContent Members
NFX.Web Namespace


Multipart.EncodedContent Fields

Multipart EncodedContent Fields NFX Class Library

The Multipart EncodedContent type exposes the following members.
Fields
 | Name | Description
Public field | Boundary |
Public field | Buffer |
Public field | Encoding |
Public field | Length |
Public field | StartIdx |
Back to Top
See Also
Multipart EncodedContent Structure
NFX.Web Namespace


Multipart.EncodedContent.Boundary Field

Multipart EncodedContent Boundary Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Boundary
public readonly string Boundary
Public ReadOnly Boundary As String
Public ReadOnly Boundary As String
public:
initonly String^ Boundary
public:
initonly String^ Boundary
val Boundary: string
val Boundary: string

Field Value

Type: Online String
See Also
Multipart EncodedContent Structure
Multipart EncodedContent Members
NFX.Web Namespace


Multipart.EncodedContent.Buffer Field

Multipart EncodedContent Buffer Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly byte[] Buffer
public readonly byte[] Buffer
Public ReadOnly Buffer As Byte()
Public ReadOnly Buffer As Byte()
public:
initonly array<unsigned char>^ Buffer
public:
initonly array<unsigned char>^ Buffer
val Buffer: byte[]
val Buffer: byte[]

Field Value

Type: Online Byte
See Also
Multipart EncodedContent Structure
Multipart EncodedContent Members
NFX.Web Namespace


Multipart.EncodedContent.Encoding Field

Multipart EncodedContent Encoding Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Encoding Encoding
public readonly Encoding Encoding
Public ReadOnly Encoding As Encoding
Public ReadOnly Encoding As Encoding
public:
initonly Encoding^ Encoding
public:
initonly Encoding^ Encoding
val Encoding: Encoding
val Encoding: Encoding

Field Value

Type: Online Encoding
See Also
Multipart EncodedContent Structure
Multipart EncodedContent Members
NFX.Web Namespace


Multipart.EncodedContent.Length Field

Multipart EncodedContent Length Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long Length
public readonly long Length
Public ReadOnly Length As Long
Public ReadOnly Length As Long
public:
initonly long long Length
public:
initonly long long Length
val Length: int64
val Length: int64

Field Value

Type: Online Int64
See Also
Multipart EncodedContent Structure
Multipart EncodedContent Members
NFX.Web Namespace


Multipart.EncodedContent.StartIdx Field

Multipart EncodedContent StartIdx Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long StartIdx
public readonly long StartIdx
Public ReadOnly StartIdx As Long
Public ReadOnly StartIdx As Long
public:
initonly long long StartIdx
public:
initonly long long StartIdx
val StartIdx: int64
val StartIdx: int64

Field Value

Type: Online Int64
See Also
Multipart EncodedContent Structure
Multipart EncodedContent Members
NFX.Web Namespace


Multipart.EncodedContent Methods

Multipart EncodedContent Methods NFX Class Library

The Multipart EncodedContent type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Multipart EncodedContent Structure
NFX.Web Namespace


Multipart.Part Class

Multipart Part Class NFX Class Library

Represents a part of multipart encoding
Inheritance Hierarchy
Online System Object
NFX.Web Multipart Part

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Part : INamed
public sealed class Part : INamed
Public NotInheritable Class Part
    Implements INamed
Public NotInheritable Class Part
    Implements INamed
public ref class Part sealed : INamed
public ref class Part sealed : INamed
[<SealedAttribute>]
type Part =
    class
        interface INamed
    end
[<SealedAttribute>]
type Part =
    class
        interface INamed
    end
See Also
Multipart Part Members
NFX.Web Namespace


Multipart.Part Members

Multipart Part Members NFX Class Library

The Multipart Part type exposes the following members.
Constructors
 | Name | Description
Protected method | Multipart Part | Initializes a new instance of the Multipart Part class
Public method | Multipart Part(String) | Initializes a new instance of the Multipart Part class
Back to Top
Methods
 | Name | Description
Protected method | ____SetName |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Content |
Public property | ContentType |
Public property | FileName |
Public property | Name |
Back to Top
See Also
Multipart Part Class
NFX.Web Namespace


Multipart.Part Constructor

Multipart Part Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | Multipart Part | Initializes a new instance of the Multipart Part class
Public method | Multipart Part(String) | Initializes a new instance of the Multipart Part class
Back to Top
See Also
Multipart Part Class
Multipart Part Members
NFX.Web Namespace


Multipart.Part Constructor

Multipart Part Constructor NFX Class Library

Initializes a new instance of the Multipart Part class

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Part()
internal Part()
Friend Sub New
Friend Sub New
internal:
Part()
internal:
Part()
new : unit -> Part
new : unit -> Part
See Also
Multipart Part Class
Multipart Part Members
Multipart Part Overload
NFX.Web Namespace


Multipart.Part Constructor (String)

Multipart Part Constructor (String) NFX Class Library

Initializes a new instance of the Multipart Part class

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Part(
    string name
)
public Part(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
Part(
    String^ name
)
public:
Part(
    String^ name
)
new :
        name : string -> Part
new :
        name : string -> Part

Parameters

name
Type: Online System String
See Also
Multipart Part Class
Multipart Part Members
Multipart Part Overload
NFX.Web Namespace


Multipart.Part Methods

Multipart Part Methods NFX Class Library

The Multipart Part type exposes the following members.
Methods
 | Name | Description
Protected method | ____SetName |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Multipart Part Class
NFX.Web Namespace


Multipart.Part.____SetName Method

Multipart Part ____SetName Method NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void ____SetName(
    string name
)
internal void ____SetName(
    string name
)
Friend Sub ____SetName (
    name As String
)
Friend Sub ____SetName (
    name As String
)
internal:
void ____SetName(
    String^ name
)
internal:
void ____SetName(
    String^ name
)
internal member ____SetName :
        name : string -> unit
internal member ____SetName :
        name : string -> unit

Parameters

name
Type: Online System String
See Also
Multipart Part Class
Multipart Part Members
NFX.Web Namespace


Multipart.Part Properties

Multipart Part Properties NFX Class Library

The Multipart Part type exposes the following members.
Properties
 | Name | Description
Public property | Content |
Public property | ContentType |
Public property | FileName |
Public property | Name |
Back to Top
See Also
Multipart Part Class
NFX.Web Namespace


Multipart.Part.Content Property

Multipart Part Content Property NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Content { get; set; }
public Object Content { get; set; }
Public Property Content As Object
    Get
    Set
Public Property Content As Object
    Get
    Set
public:
property Object^ Content {
    Object^ get ();
    void set (Object^ value);
}
public:
property Object^ Content {
    Object^ get ();
    void set (Object^ value);
}
member Content : Object with get, set
member Content : Object with get, set

Property Value

Type: Online Object
See Also
Multipart Part Class
Multipart Part Members
NFX.Web Namespace


Multipart.Part.ContentType Property

Multipart Part ContentType Property NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ContentType { get; set; }
public string ContentType { get; set; }
Public Property ContentType As String
    Get
    Set
Public Property ContentType As String
    Get
    Set
public:
property String^ ContentType {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ContentType {
    String^ get ();
    void set (String^ value);
}
member ContentType : string with get, set
member ContentType : string with get, set

Property Value

Type: Online String
See Also
Multipart Part Class
Multipart Part Members
NFX.Web Namespace


Multipart.Part.FileName Property

Multipart Part FileName Property NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FileName { get; set; }
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set
member FileName : string with get, set

Property Value

Type: Online String
See Also
Multipart Part Class
Multipart Part Members
NFX.Web Namespace


Multipart.Part.Name Property

Multipart Part Name Property NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Multipart Part Class
Multipart Part Members
NFX.Web Namespace


ServicePointManagerConfigurator Class

ServicePointManagerConfigurator Class NFX Class Library

Configures ServicePointManager class. Use singleton Instance property
Inheritance Hierarchy
Online System Object
NFX.Web ServicePointManagerConfigurator

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ServicePointManagerConfigurator : IConfigurable
public sealed class ServicePointManagerConfigurator : IConfigurable
Public NotInheritable Class ServicePointManagerConfigurator
    Implements IConfigurable
Public NotInheritable Class ServicePointManagerConfigurator
    Implements IConfigurable
public ref class ServicePointManagerConfigurator sealed : IConfigurable
public ref class ServicePointManagerConfigurator sealed : IConfigurable
[<SealedAttribute>]
type ServicePointManagerConfigurator =
    class
        interface IConfigurable
    end
[<SealedAttribute>]
type ServicePointManagerConfigurator =
    class
        interface IConfigurable
    end
See Also
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator Members

ServicePointManagerConfigurator Members NFX Class Library

The ServicePointManagerConfigurator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_POLICY_SECTION |
CONFIG_SERVICE_POINT_SECTION |
CONFIG_TCP_KEEPALIVE_ENABLED_ATTR |
CONFIG_TCP_KEEPALIVE_INTERVAL_MS_ATTR |
CONFIG_TCP_KEEPALIVE_TIME_MS_ATTR |
CONFIG_URI_ATTR |
s_Instance |
Back to Top
Properties
 | Name | Description
Public property | CheckCertificateRevocationList |
Public property | DefaultConnectionLimit |
Public property | DnsRefreshTimeout |
Public property | EnableDnsRoundRobin |
Public property | Expect100Continue |
Public property | MaxServicePointIdleTime |
Public property | MaxServicePoints |
Public property | Policy |
Public property | SecurityProtocol |
Public property | ServicePoints |
Public property | UseNagleAlgorithm |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IConfigurable Configure |
Back to Top
See Also
ServicePointManagerConfigurator Class
NFX.Web Namespace


ServicePointManagerConfigurator Fields

ServicePointManagerConfigurator Fields NFX Class Library

The ServicePointManagerConfigurator type exposes the following members.
Fields
Name | Description
CONFIG_POLICY_SECTION |
CONFIG_SERVICE_POINT_SECTION |
CONFIG_TCP_KEEPALIVE_ENABLED_ATTR |
CONFIG_TCP_KEEPALIVE_INTERVAL_MS_ATTR |
CONFIG_TCP_KEEPALIVE_TIME_MS_ATTR |
CONFIG_URI_ATTR |
s_Instance |
Back to Top
See Also
ServicePointManagerConfigurator Class
NFX.Web Namespace


ServicePointManagerConfigurator.CONFIG_POLICY_SECTION Field

ServicePointManagerConfigurator CONFIG_POLICY_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_POLICY_SECTION
public const string CONFIG_POLICY_SECTION
Public Const CONFIG_POLICY_SECTION As String
Public Const CONFIG_POLICY_SECTION As String
public:
literal String^ CONFIG_POLICY_SECTION
public:
literal String^ CONFIG_POLICY_SECTION
static val mutable CONFIG_POLICY_SECTION: string
static val mutable CONFIG_POLICY_SECTION: string

Field Value

Type: Online String
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.CONFIG_SERVICE_POINT_SECTION Field

ServicePointManagerConfigurator CONFIG_SERVICE_POINT_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SERVICE_POINT_SECTION
public const string CONFIG_SERVICE_POINT_SECTION
Public Const CONFIG_SERVICE_POINT_SECTION As String
Public Const CONFIG_SERVICE_POINT_SECTION As String
public:
literal String^ CONFIG_SERVICE_POINT_SECTION
public:
literal String^ CONFIG_SERVICE_POINT_SECTION
static val mutable CONFIG_SERVICE_POINT_SECTION: string
static val mutable CONFIG_SERVICE_POINT_SECTION: string

Field Value

Type: Online String
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.CONFIG_TCP_KEEPALIVE_ENABLED_ATTR Field

ServicePointManagerConfigurator CONFIG_TCP_KEEPALIVE_ENABLED_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TCP_KEEPALIVE_ENABLED_ATTR
public const string CONFIG_TCP_KEEPALIVE_ENABLED_ATTR
Public Const CONFIG_TCP_KEEPALIVE_ENABLED_ATTR As String
Public Const CONFIG_TCP_KEEPALIVE_ENABLED_ATTR As String
public:
literal String^ CONFIG_TCP_KEEPALIVE_ENABLED_ATTR
public:
literal String^ CONFIG_TCP_KEEPALIVE_ENABLED_ATTR
static val mutable CONFIG_TCP_KEEPALIVE_ENABLED_ATTR: string
static val mutable CONFIG_TCP_KEEPALIVE_ENABLED_ATTR: string

Field Value

Type: Online String
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.CONFIG_TCP_KEEPALIVE_INTERVAL_MS_ATTR Field

ServicePointManagerConfigurator CONFIG_TCP_KEEPALIVE_INTERVAL_MS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TCP_KEEPALIVE_INTERVAL_MS_ATTR
public const string CONFIG_TCP_KEEPALIVE_INTERVAL_MS_ATTR
Public Const CONFIG_TCP_KEEPALIVE_INTERVAL_MS_ATTR As String
Public Const CONFIG_TCP_KEEPALIVE_INTERVAL_MS_ATTR As String
public:
literal String^ CONFIG_TCP_KEEPALIVE_INTERVAL_MS_ATTR
public:
literal String^ CONFIG_TCP_KEEPALIVE_INTERVAL_MS_ATTR
static val mutable CONFIG_TCP_KEEPALIVE_INTERVAL_MS_ATTR: string
static val mutable CONFIG_TCP_KEEPALIVE_INTERVAL_MS_ATTR: string

Field Value

Type: Online String
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.CONFIG_TCP_KEEPALIVE_TIME_MS_ATTR Field

ServicePointManagerConfigurator CONFIG_TCP_KEEPALIVE_TIME_MS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TCP_KEEPALIVE_TIME_MS_ATTR
public const string CONFIG_TCP_KEEPALIVE_TIME_MS_ATTR
Public Const CONFIG_TCP_KEEPALIVE_TIME_MS_ATTR As String
Public Const CONFIG_TCP_KEEPALIVE_TIME_MS_ATTR As String
public:
literal String^ CONFIG_TCP_KEEPALIVE_TIME_MS_ATTR
public:
literal String^ CONFIG_TCP_KEEPALIVE_TIME_MS_ATTR
static val mutable CONFIG_TCP_KEEPALIVE_TIME_MS_ATTR: string
static val mutable CONFIG_TCP_KEEPALIVE_TIME_MS_ATTR: string

Field Value

Type: Online String
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.CONFIG_URI_ATTR Field

ServicePointManagerConfigurator CONFIG_URI_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_URI_ATTR
public const string CONFIG_URI_ATTR
Public Const CONFIG_URI_ATTR As String
Public Const CONFIG_URI_ATTR As String
public:
literal String^ CONFIG_URI_ATTR
public:
literal String^ CONFIG_URI_ATTR
static val mutable CONFIG_URI_ATTR: string
static val mutable CONFIG_URI_ATTR: string

Field Value

Type: Online String
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.s_Instance Field

ServicePointManagerConfigurator s_Instance Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ServicePointManagerConfigurator s_Instance
internal static ServicePointManagerConfigurator s_Instance
Friend Shared s_Instance As ServicePointManagerConfigurator
Friend Shared s_Instance As ServicePointManagerConfigurator
internal:
static ServicePointManagerConfigurator^ s_Instance
internal:
static ServicePointManagerConfigurator^ s_Instance
static val mutable internal s_Instance: ServicePointManagerConfigurator
static val mutable internal s_Instance: ServicePointManagerConfigurator

Field Value

Type: ServicePointManagerConfigurator
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator Methods

ServicePointManagerConfigurator Methods NFX Class Library

The ServicePointManagerConfigurator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IConfigurable Configure |
Back to Top
See Also
ServicePointManagerConfigurator Class
NFX.Web Namespace


ServicePointManagerConfigurator.IConfigurable.Configure Method

ServicePointManagerConfigurator IConfigurable Configure Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IConfigurable.Configure(
    IConfigSectionNode node
)
void IConfigurable.Configure(
    IConfigSectionNode node
)
Private Sub Configure (
    node As IConfigSectionNode
) Implements IConfigurable.Configure
Private Sub Configure (
    node As IConfigSectionNode
) Implements IConfigurable.Configure
private:
virtual void Configure(
    IConfigSectionNode^ node
) sealed = IConfigurable::Configure
private:
virtual void Configure(
    IConfigSectionNode^ node
) sealed = IConfigurable::Configure
private abstract Configure :
        node : IConfigSectionNode -> unit
private override Configure :
        node : IConfigSectionNode -> unit
private abstract Configure :
        node : IConfigSectionNode -> unit
private override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator Properties

ServicePointManagerConfigurator Properties NFX Class Library

The ServicePointManagerConfigurator type exposes the following members.
Properties
 | Name | Description
Public property | CheckCertificateRevocationList |
Public property | DefaultConnectionLimit |
Public property | DnsRefreshTimeout |
Public property | EnableDnsRoundRobin |
Public property | Expect100Continue |
Public property | MaxServicePointIdleTime |
Public property | MaxServicePoints |
Public property | Policy |
Public property | SecurityProtocol |
Public property | ServicePoints |
Public property | UseNagleAlgorithm |
Back to Top
See Also
ServicePointManagerConfigurator Class
NFX.Web Namespace


ServicePointManagerConfigurator.CheckCertificateRevocationList Property

ServicePointManagerConfigurator CheckCertificateRevocationList Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool CheckCertificateRevocationList { get; private set; }
[ConfigAttribute]
public bool CheckCertificateRevocationList { get; private set; }
<ConfigAttribute>
Public Property CheckCertificateRevocationList As Boolean
    Get
    Private Set
<ConfigAttribute>
Public Property CheckCertificateRevocationList As Boolean
    Get
    Private Set
public:
[ConfigAttribute]
property bool CheckCertificateRevocationList {
    bool get ();
    private: void set (bool value);
}
public:
[ConfigAttribute]
property bool CheckCertificateRevocationList {
    bool get ();
    private: void set (bool value);
}
[<ConfigAttribute>]
member CheckCertificateRevocationList : bool with get, private set
[<ConfigAttribute>]
member CheckCertificateRevocationList : bool with get, private set

Property Value

Type: Online Boolean
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.DefaultConnectionLimit Property

ServicePointManagerConfigurator DefaultConnectionLimit Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int DefaultConnectionLimit { get; private set; }
[ConfigAttribute]
public int DefaultConnectionLimit { get; private set; }
<ConfigAttribute>
Public Property DefaultConnectionLimit As Integer
    Get
    Private Set
<ConfigAttribute>
Public Property DefaultConnectionLimit As Integer
    Get
    Private Set
public:
[ConfigAttribute]
property int DefaultConnectionLimit {
    int get ();
    private: void set (int value);
}
public:
[ConfigAttribute]
property int DefaultConnectionLimit {
    int get ();
    private: void set (int value);
}
[<ConfigAttribute>]
member DefaultConnectionLimit : int with get, private set
[<ConfigAttribute>]
member DefaultConnectionLimit : int with get, private set

Property Value

Type: Online Int32
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.DnsRefreshTimeout Property

ServicePointManagerConfigurator DnsRefreshTimeout Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int DnsRefreshTimeout { get; private set; }
[ConfigAttribute]
public int DnsRefreshTimeout { get; private set; }
<ConfigAttribute>
Public Property DnsRefreshTimeout As Integer
    Get
    Private Set
<ConfigAttribute>
Public Property DnsRefreshTimeout As Integer
    Get
    Private Set
public:
[ConfigAttribute]
property int DnsRefreshTimeout {
    int get ();
    private: void set (int value);
}
public:
[ConfigAttribute]
property int DnsRefreshTimeout {
    int get ();
    private: void set (int value);
}
[<ConfigAttribute>]
member DnsRefreshTimeout : int with get, private set
[<ConfigAttribute>]
member DnsRefreshTimeout : int with get, private set

Property Value

Type: Online Int32
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.EnableDnsRoundRobin Property

ServicePointManagerConfigurator EnableDnsRoundRobin Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool EnableDnsRoundRobin { get; private set; }
[ConfigAttribute]
public bool EnableDnsRoundRobin { get; private set; }
<ConfigAttribute>
Public Property EnableDnsRoundRobin As Boolean
    Get
    Private Set
<ConfigAttribute>
Public Property EnableDnsRoundRobin As Boolean
    Get
    Private Set
public:
[ConfigAttribute]
property bool EnableDnsRoundRobin {
    bool get ();
    private: void set (bool value);
}
public:
[ConfigAttribute]
property bool EnableDnsRoundRobin {
    bool get ();
    private: void set (bool value);
}
[<ConfigAttribute>]
member EnableDnsRoundRobin : bool with get, private set
[<ConfigAttribute>]
member EnableDnsRoundRobin : bool with get, private set

Property Value

Type: Online Boolean
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.Expect100Continue Property

ServicePointManagerConfigurator Expect100Continue Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$expect-100-continue")]
public bool Expect100Continue { get; private set; }
[ConfigAttribute("$expect-100-continue")]
public bool Expect100Continue { get; private set; }
<ConfigAttribute("$expect-100-continue")>
Public Property Expect100Continue As Boolean
    Get
    Private Set
<ConfigAttribute("$expect-100-continue")>
Public Property Expect100Continue As Boolean
    Get
    Private Set
public:
[ConfigAttribute(L"$expect-100-continue")]
property bool Expect100Continue {
    bool get ();
    private: void set (bool value);
}
public:
[ConfigAttribute(L"$expect-100-continue")]
property bool Expect100Continue {
    bool get ();
    private: void set (bool value);
}
[<ConfigAttribute("$expect-100-continue")>]
member Expect100Continue : bool with get, private set
[<ConfigAttribute("$expect-100-continue")>]
member Expect100Continue : bool with get, private set

Property Value

Type: Online Boolean
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.MaxServicePointIdleTime Property

ServicePointManagerConfigurator MaxServicePointIdleTime Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int MaxServicePointIdleTime { get; private set; }
[ConfigAttribute]
public int MaxServicePointIdleTime { get; private set; }
<ConfigAttribute>
Public Property MaxServicePointIdleTime As Integer
    Get
    Private Set
<ConfigAttribute>
Public Property MaxServicePointIdleTime As Integer
    Get
    Private Set
public:
[ConfigAttribute]
property int MaxServicePointIdleTime {
    int get ();
    private: void set (int value);
}
public:
[ConfigAttribute]
property int MaxServicePointIdleTime {
    int get ();
    private: void set (int value);
}
[<ConfigAttribute>]
member MaxServicePointIdleTime : int with get, private set
[<ConfigAttribute>]
member MaxServicePointIdleTime : int with get, private set

Property Value

Type: Online Int32
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.MaxServicePoints Property

ServicePointManagerConfigurator MaxServicePoints Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int MaxServicePoints { get; private set; }
[ConfigAttribute]
public int MaxServicePoints { get; private set; }
<ConfigAttribute>
Public Property MaxServicePoints As Integer
    Get
    Private Set
<ConfigAttribute>
Public Property MaxServicePoints As Integer
    Get
    Private Set
public:
[ConfigAttribute]
property int MaxServicePoints {
    int get ();
    private: void set (int value);
}
public:
[ConfigAttribute]
property int MaxServicePoints {
    int get ();
    private: void set (int value);
}
[<ConfigAttribute>]
member MaxServicePoints : int with get, private set
[<ConfigAttribute>]
member MaxServicePoints : int with get, private set

Property Value

Type: Online Int32
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.Policy Property

ServicePointManagerConfigurator Policy Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServicePointManagerConfigurator..::..OperationPolicy Policy { get; private set; }
public ServicePointManagerConfigurator..::..OperationPolicy Policy { get; private set; }
Public Property Policy As ServicePointManagerConfigurator..::..OperationPolicy
    Get
    Private Set
Public Property Policy As ServicePointManagerConfigurator..::..OperationPolicy
    Get
    Private Set
public:
property ServicePointManagerConfigurator..::..OperationPolicy^ Policy {
    ServicePointManagerConfigurator..::..OperationPolicy^ get ();
    private: void set (ServicePointManagerConfigurator..::..OperationPolicy^ value);
}
public:
property ServicePointManagerConfigurator..::..OperationPolicy^ Policy {
    ServicePointManagerConfigurator..::..OperationPolicy^ get ();
    private: void set (ServicePointManagerConfigurator..::..OperationPolicy^ value);
}
member Policy : ServicePointManagerConfigurator..::..OperationPolicy with get, private set
member Policy : ServicePointManagerConfigurator..::..OperationPolicy with get, private set

Property Value

Type: ServicePointManagerConfigurator OperationPolicy
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.SecurityProtocol Property

ServicePointManagerConfigurator SecurityProtocol Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public SecurityProtocolType SecurityProtocol { get; private set; }
[ConfigAttribute]
public SecurityProtocolType SecurityProtocol { get; private set; }
<ConfigAttribute>
Public Property SecurityProtocol As SecurityProtocolType
    Get
    Private Set
<ConfigAttribute>
Public Property SecurityProtocol As SecurityProtocolType
    Get
    Private Set
public:
[ConfigAttribute]
property SecurityProtocolType SecurityProtocol {
    SecurityProtocolType get ();
    private: void set (SecurityProtocolType value);
}
public:
[ConfigAttribute]
property SecurityProtocolType SecurityProtocol {
    SecurityProtocolType get ();
    private: void set (SecurityProtocolType value);
}
[<ConfigAttribute>]
member SecurityProtocol : SecurityProtocolType with get, private set
[<ConfigAttribute>]
member SecurityProtocol : SecurityProtocolType with get, private set

Property Value

Type: Online SecurityProtocolType
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.ServicePoints Property

ServicePointManagerConfigurator ServicePoints Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ServicePointManagerConfigurator..::..ServicePointConfigurator> ServicePoints { get; }
public IEnumerable<ServicePointManagerConfigurator..::..ServicePointConfigurator> ServicePoints { get; }
Public ReadOnly Property ServicePoints As IEnumerable(Of ServicePointManagerConfigurator..::..ServicePointConfigurator)
    Get
Public ReadOnly Property ServicePoints As IEnumerable(Of ServicePointManagerConfigurator..::..ServicePointConfigurator)
    Get
public:
property IEnumerable<ServicePointManagerConfigurator..::..ServicePointConfigurator^>^ ServicePoints {
    IEnumerable<ServicePointManagerConfigurator..::..ServicePointConfigurator^>^ get ();
}
public:
property IEnumerable<ServicePointManagerConfigurator..::..ServicePointConfigurator^>^ ServicePoints {
    IEnumerable<ServicePointManagerConfigurator..::..ServicePointConfigurator^>^ get ();
}
member ServicePoints : IEnumerable<ServicePointManagerConfigurator..::..ServicePointConfigurator> with get
member ServicePoints : IEnumerable<ServicePointManagerConfigurator..::..ServicePointConfigurator> with get

Property Value

Type: Online IEnumerable ServicePointManagerConfigurator ServicePointConfigurator
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.UseNagleAlgorithm Property

ServicePointManagerConfigurator UseNagleAlgorithm Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool UseNagleAlgorithm { get; private set; }
[ConfigAttribute]
public bool UseNagleAlgorithm { get; private set; }
<ConfigAttribute>
Public Property UseNagleAlgorithm As Boolean
    Get
    Private Set
<ConfigAttribute>
Public Property UseNagleAlgorithm As Boolean
    Get
    Private Set
public:
[ConfigAttribute]
property bool UseNagleAlgorithm {
    bool get ();
    private: void set (bool value);
}
public:
[ConfigAttribute]
property bool UseNagleAlgorithm {
    bool get ();
    private: void set (bool value);
}
[<ConfigAttribute>]
member UseNagleAlgorithm : bool with get, private set
[<ConfigAttribute>]
member UseNagleAlgorithm : bool with get, private set

Property Value

Type: Online Boolean
See Also
ServicePointManagerConfigurator Class
ServicePointManagerConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy Class

ServicePointManagerConfigurator OperationPolicy Class NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides contract and default implementation for certificate trust and endpoint binding
Inheritance Hierarchy
Online System Object
NFX.Web ServicePointManagerConfigurator OperationPolicy

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class OperationPolicy : IConfigurable
public class OperationPolicy : IConfigurable
Public Class OperationPolicy
    Implements IConfigurable
Public Class OperationPolicy
    Implements IConfigurable
public ref class OperationPolicy : IConfigurable
public ref class OperationPolicy : IConfigurable
type OperationPolicy =
    class
        interface IConfigurable
    end
type OperationPolicy =
    class
        interface IConfigurable
    end
See Also
ServicePointManagerConfigurator OperationPolicy Members
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy Members

ServicePointManagerConfigurator OperationPolicy Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServicePointManagerConfigurator OperationPolicy type exposes the following members.
Constructors
 | Name | Description
Public method | ServicePointManagerConfigurator OperationPolicy | Initializes a new instance of the ServicePointManagerConfigurator OperationPolicy class
Back to Top
Methods
 | Name | Description
Public method | BindIPEndPoint |
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ServerCertificateValidationCallback |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_CASE_SECTION |
 | CONFIG_DEFAULT_CERTIFICATE_VALIDATION_SECTION |
 | CONFIG_TRUSTED_ATTR |
Protected field | m_DefaultCertValUris |
Back to Top
Properties
 | Name | Description
Public property | CertValTrustedDefault |
Back to Top
See Also
ServicePointManagerConfigurator OperationPolicy Class
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy Constructor

ServicePointManagerConfigurator OperationPolicy Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServicePointManagerConfigurator OperationPolicy class

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OperationPolicy()
public OperationPolicy()
Public Sub New
Public Sub New
public:
OperationPolicy()
public:
OperationPolicy()
new : unit -> OperationPolicy
new : unit -> OperationPolicy
See Also
ServicePointManagerConfigurator OperationPolicy Class
ServicePointManagerConfigurator OperationPolicy Members
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy Fields

ServicePointManagerConfigurator OperationPolicy Fields NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServicePointManagerConfigurator OperationPolicy type exposes the following members.
Fields
 | Name | Description
 | CONFIG_CASE_SECTION |
 | CONFIG_DEFAULT_CERTIFICATE_VALIDATION_SECTION |
 | CONFIG_TRUSTED_ATTR |
Protected field | m_DefaultCertValUris |
Back to Top
See Also
ServicePointManagerConfigurator OperationPolicy Class
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy.CONFIG_CASE_SECTION Field

ServicePointManagerConfigurator OperationPolicy CONFIG_CASE_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CASE_SECTION
public const string CONFIG_CASE_SECTION
Public Const CONFIG_CASE_SECTION As String
Public Const CONFIG_CASE_SECTION As String
public:
literal String^ CONFIG_CASE_SECTION
public:
literal String^ CONFIG_CASE_SECTION
static val mutable CONFIG_CASE_SECTION: string
static val mutable CONFIG_CASE_SECTION: string

Field Value

Type: Online String
See Also
ServicePointManagerConfigurator OperationPolicy Class
ServicePointManagerConfigurator OperationPolicy Members
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy.CONFIG_DEFAULT_CERTIFICATE_VALIDATION_SECTION Field

ServicePointManagerConfigurator OperationPolicy CONFIG_DEFAULT_CERTIFICATE_VALIDATION_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DEFAULT_CERTIFICATE_VALIDATION_SECTION
public const string CONFIG_DEFAULT_CERTIFICATE_VALIDATION_SECTION
Public Const CONFIG_DEFAULT_CERTIFICATE_VALIDATION_SECTION As String
Public Const CONFIG_DEFAULT_CERTIFICATE_VALIDATION_SECTION As String
public:
literal String^ CONFIG_DEFAULT_CERTIFICATE_VALIDATION_SECTION
public:
literal String^ CONFIG_DEFAULT_CERTIFICATE_VALIDATION_SECTION
static val mutable CONFIG_DEFAULT_CERTIFICATE_VALIDATION_SECTION: string
static val mutable CONFIG_DEFAULT_CERTIFICATE_VALIDATION_SECTION: string

Field Value

Type: Online String
See Also
ServicePointManagerConfigurator OperationPolicy Class
ServicePointManagerConfigurator OperationPolicy Members
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy.CONFIG_TRUSTED_ATTR Field

ServicePointManagerConfigurator OperationPolicy CONFIG_TRUSTED_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TRUSTED_ATTR
public const string CONFIG_TRUSTED_ATTR
Public Const CONFIG_TRUSTED_ATTR As String
Public Const CONFIG_TRUSTED_ATTR As String
public:
literal String^ CONFIG_TRUSTED_ATTR
public:
literal String^ CONFIG_TRUSTED_ATTR
static val mutable CONFIG_TRUSTED_ATTR: string
static val mutable CONFIG_TRUSTED_ATTR: string

Field Value

Type: Online String
See Also
ServicePointManagerConfigurator OperationPolicy Class
ServicePointManagerConfigurator OperationPolicy Members
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy.m_DefaultCertValUris Field

ServicePointManagerConfigurator OperationPolicy m_DefaultCertValUris Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Registry<ServicePointManagerConfigurator..::..OperationPolicy..::.._uri> m_DefaultCertValUris
protected Registry<ServicePointManagerConfigurator..::..OperationPolicy..::.._uri> m_DefaultCertValUris
Protected m_DefaultCertValUris As Registry(Of ServicePointManagerConfigurator..::..OperationPolicy..::.._uri)
Protected m_DefaultCertValUris As Registry(Of ServicePointManagerConfigurator..::..OperationPolicy..::.._uri)
protected:
Registry<ServicePointManagerConfigurator..::..OperationPolicy..::.._uri^>^ m_DefaultCertValUris
protected:
Registry<ServicePointManagerConfigurator..::..OperationPolicy..::.._uri^>^ m_DefaultCertValUris
val mutable m_DefaultCertValUris: Registry<ServicePointManagerConfigurator..::..OperationPolicy..::.._uri>
val mutable m_DefaultCertValUris: Registry<ServicePointManagerConfigurator..::..OperationPolicy..::.._uri>

Field Value

Type: Registry ServicePointManagerConfigurator OperationPolicy _uri
See Also
ServicePointManagerConfigurator OperationPolicy Class
ServicePointManagerConfigurator OperationPolicy Members
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy Methods

ServicePointManagerConfigurator OperationPolicy Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServicePointManagerConfigurator OperationPolicy type exposes the following members.
Methods
 | Name | Description
Public method | BindIPEndPoint |
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ServerCertificateValidationCallback |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServicePointManagerConfigurator OperationPolicy Class
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy.BindIPEndPoint Method

ServicePointManagerConfigurator OperationPolicy BindIPEndPoint Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IPEndPoint BindIPEndPoint(
    ServicePointManagerConfigurator..::..ServicePointConfigurator servicePointConfigurator,
    IPEndPoint remoteEndPoint,
    int retryCount
)
public virtual IPEndPoint BindIPEndPoint(
    ServicePointManagerConfigurator..::..ServicePointConfigurator servicePointConfigurator,
    IPEndPoint remoteEndPoint,
    int retryCount
)
Public Overridable Function BindIPEndPoint (
    servicePointConfigurator As ServicePointManagerConfigurator..::..ServicePointConfigurator,
    remoteEndPoint As IPEndPoint,
    retryCount As Integer
) As IPEndPoint
Public Overridable Function BindIPEndPoint (
    servicePointConfigurator As ServicePointManagerConfigurator..::..ServicePointConfigurator,
    remoteEndPoint As IPEndPoint,
    retryCount As Integer
) As IPEndPoint
public:
virtual IPEndPoint^ BindIPEndPoint(
    ServicePointManagerConfigurator..::..ServicePointConfigurator^ servicePointConfigurator,
    IPEndPoint^ remoteEndPoint,
    int retryCount
)
public:
virtual IPEndPoint^ BindIPEndPoint(
    ServicePointManagerConfigurator..::..ServicePointConfigurator^ servicePointConfigurator,
    IPEndPoint^ remoteEndPoint,
    int retryCount
)
abstract BindIPEndPoint :
        servicePointConfigurator : ServicePointManagerConfigurator..::..ServicePointConfigurator *
        remoteEndPoint : IPEndPoint *
        retryCount : int -> IPEndPoint
override BindIPEndPoint :
        servicePointConfigurator : ServicePointManagerConfigurator..::..ServicePointConfigurator *
        remoteEndPoint : IPEndPoint *
        retryCount : int -> IPEndPoint
abstract BindIPEndPoint :
        servicePointConfigurator : ServicePointManagerConfigurator..::..ServicePointConfigurator *
        remoteEndPoint : IPEndPoint *
        retryCount : int -> IPEndPoint
override BindIPEndPoint :
        servicePointConfigurator : ServicePointManagerConfigurator..::..ServicePointConfigurator *
        remoteEndPoint : IPEndPoint *
        retryCount : int -> IPEndPoint

Parameters

servicePointConfigurator
Type: NFX.Web ServicePointManagerConfigurator ServicePointConfigurator
remoteEndPoint
Type: Online System.Net IPEndPoint
retryCount
Type: Online System Int32

Return Value

Type: Online IPEndPoint
See Also
ServicePointManagerConfigurator OperationPolicy Class
ServicePointManagerConfigurator OperationPolicy Members
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy.Configure Method

ServicePointManagerConfigurator OperationPolicy Configure Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Configure(
    IConfigSectionNode node
)
public virtual void Configure(
    IConfigSectionNode node
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
ServicePointManagerConfigurator OperationPolicy Class
ServicePointManagerConfigurator OperationPolicy Members
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy.ServerCertificateValidationCallback Method

ServicePointManagerConfigurator OperationPolicy ServerCertificateValidationCallback Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool ServerCertificateValidationCallback(
    Object sender,
    X509Certificate certificate,
    X509Chain chain,
    SslPolicyErrors sslPolicyErrors
)
public virtual bool ServerCertificateValidationCallback(
    Object sender,
    X509Certificate certificate,
    X509Chain chain,
    SslPolicyErrors sslPolicyErrors
)
Public Overridable Function ServerCertificateValidationCallback (
    sender As Object,
    certificate As X509Certificate,
    chain As X509Chain,
    sslPolicyErrors As SslPolicyErrors
) As Boolean
Public Overridable Function ServerCertificateValidationCallback (
    sender As Object,
    certificate As X509Certificate,
    chain As X509Chain,
    sslPolicyErrors As SslPolicyErrors
) As Boolean
public:
virtual bool ServerCertificateValidationCallback(
    Object^ sender,
    X509Certificate^ certificate,
    X509Chain^ chain,
    SslPolicyErrors sslPolicyErrors
)
public:
virtual bool ServerCertificateValidationCallback(
    Object^ sender,
    X509Certificate^ certificate,
    X509Chain^ chain,
    SslPolicyErrors sslPolicyErrors
)
abstract ServerCertificateValidationCallback :
        sender : Object *
        certificate : X509Certificate *
        chain : X509Chain *
        sslPolicyErrors : SslPolicyErrors -> bool
override ServerCertificateValidationCallback :
        sender : Object *
        certificate : X509Certificate *
        chain : X509Chain *
        sslPolicyErrors : SslPolicyErrors -> bool
abstract ServerCertificateValidationCallback :
        sender : Object *
        certificate : X509Certificate *
        chain : X509Chain *
        sslPolicyErrors : SslPolicyErrors -> bool
override ServerCertificateValidationCallback :
        sender : Object *
        certificate : X509Certificate *
        chain : X509Chain *
        sslPolicyErrors : SslPolicyErrors -> bool

Parameters

sender
Type: Online System Object
certificate
Type: Online System.Security.Cryptography.X509Certificates X509Certificate
chain
Type: Online System.Security.Cryptography.X509Certificates X509Chain
sslPolicyErrors
Type: Online System.Net.Security SslPolicyErrors

Return Value

Type: Online Boolean
See Also
ServicePointManagerConfigurator OperationPolicy Class
ServicePointManagerConfigurator OperationPolicy Members
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy Properties

ServicePointManagerConfigurator OperationPolicy Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServicePointManagerConfigurator OperationPolicy type exposes the following members.
Properties
 | Name | Description
Public property | CertValTrustedDefault |
Back to Top
See Also
ServicePointManagerConfigurator OperationPolicy Class
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy.CertValTrustedDefault Property

ServicePointManagerConfigurator OperationPolicy CertValTrustedDefault Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CertValTrustedDefault { get; set; }
public bool CertValTrustedDefault { get; set; }
Public Property CertValTrustedDefault As Boolean
    Get
    Set
Public Property CertValTrustedDefault As Boolean
    Get
    Set
public:
property bool CertValTrustedDefault {
    bool get ();
    void set (bool value);
}
public:
property bool CertValTrustedDefault {
    bool get ();
    void set (bool value);
}
member CertValTrustedDefault : bool with get, set
member CertValTrustedDefault : bool with get, set

Property Value

Type: Online Boolean
See Also
ServicePointManagerConfigurator OperationPolicy Class
ServicePointManagerConfigurator OperationPolicy Members
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy._uri Class

ServicePointManagerConfigurator OperationPolicy _uri Class NFX Class Library

[This is preliminary documentation and is subject to change.]

Inheritance Hierarchy
Online System Object
NFX.Web ServicePointManagerConfigurator OperationPolicy _uri

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected class _uri : INamed
protected class _uri : INamed
Protected Class _uri
    Implements INamed
Protected Class _uri
    Implements INamed
protected ref class _uri : INamed
protected ref class _uri : INamed
type _uri =
    class
        interface INamed
    end
type _uri =
    class
        interface INamed
    end
See Also
ServicePointManagerConfigurator OperationPolicy _uri Members
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy._uri Members

ServicePointManagerConfigurator OperationPolicy _uri Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServicePointManagerConfigurator OperationPolicy _uri type exposes the following members.
Constructors
 | Name | Description
Public method | ServicePointManagerConfigurator OperationPolicy _uri | Initializes a new instance of the ServicePointManagerConfigurator OperationPolicy _uri class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name |
Public property | Trusted |
Back to Top
See Also
ServicePointManagerConfigurator OperationPolicy _uri Class
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy._uri Constructor

ServicePointManagerConfigurator OperationPolicy _uri Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServicePointManagerConfigurator OperationPolicy _uri class

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public _uri()
public _uri()
Public Sub New
Public Sub New
public:
_uri()
public:
_uri()
new : unit -> _uri
new : unit -> _uri
See Also
ServicePointManagerConfigurator OperationPolicy _uri Class
ServicePointManagerConfigurator OperationPolicy _uri Members
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy._uri Methods

ServicePointManagerConfigurator OperationPolicy _uri Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServicePointManagerConfigurator OperationPolicy _uri type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServicePointManagerConfigurator OperationPolicy _uri Class
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy._uri Properties

ServicePointManagerConfigurator OperationPolicy _uri Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServicePointManagerConfigurator OperationPolicy _uri type exposes the following members.
Properties
 | Name | Description
Public property | Name |
Public property | Trusted |
Back to Top
See Also
ServicePointManagerConfigurator OperationPolicy _uri Class
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy._uri.Name Property

ServicePointManagerConfigurator OperationPolicy _uri Name Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; internal set; }
public string Name { get; internal set; }
Public Property Name As String
    Get
    Friend Set
Public Property Name As String
    Get
    Friend Set
public:
virtual property String^ Name {
    String^ get () sealed;
    internal: void set (String^ value) sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
    internal: void set (String^ value) sealed;
}
abstract Name : string with get, internal set
override Name : string with get, internal set
abstract Name : string with get, internal set
override Name : string with get, internal set

Property Value

Type: Online String

Implements

INamed Name
See Also
ServicePointManagerConfigurator OperationPolicy _uri Class
ServicePointManagerConfigurator OperationPolicy _uri Members
NFX.Web Namespace


ServicePointManagerConfigurator.OperationPolicy._uri.Trusted Property

ServicePointManagerConfigurator OperationPolicy _uri Trusted Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Trusted { get; internal set; }
public bool Trusted { get; internal set; }
Public Property Trusted As Boolean
    Get
    Friend Set
Public Property Trusted As Boolean
    Get
    Friend Set
public:
property bool Trusted {
    bool get ();
    internal: void set (bool value);
}
public:
property bool Trusted {
    bool get ();
    internal: void set (bool value);
}
member Trusted : bool with get, internal set
member Trusted : bool with get, internal set

Property Value

Type: Online Boolean
See Also
ServicePointManagerConfigurator OperationPolicy _uri Class
ServicePointManagerConfigurator OperationPolicy _uri Members
NFX.Web Namespace


ServicePointManagerConfigurator.ServicePointConfigurator Class

ServicePointManagerConfigurator ServicePointConfigurator Class NFX Class Library

[This is preliminary documentation and is subject to change.]

Inheritance Hierarchy
Online System Object
NFX.Web ServicePointManagerConfigurator ServicePointConfigurator

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ServicePointConfigurator
public sealed class ServicePointConfigurator
Public NotInheritable Class ServicePointConfigurator
Public NotInheritable Class ServicePointConfigurator
public ref class ServicePointConfigurator sealed
public ref class ServicePointConfigurator sealed
[<SealedAttribute>]
type ServicePointConfigurator =  class end
[<SealedAttribute>]
type ServicePointConfigurator =  class end
See Also
ServicePointManagerConfigurator ServicePointConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.ServicePointConfigurator Members

ServicePointManagerConfigurator ServicePointConfigurator Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServicePointManagerConfigurator ServicePointConfigurator type exposes the following members.
Constructors
 | Name | Description
Protected method | ServicePointManagerConfigurator ServicePointConfigurator | Initializes a new instance of the ServicePointManagerConfigurator ServicePointConfigurator class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | ServicePoint |
Back to Top
Properties
 | Name | Description
Public property | ConnectionLeaseTimeout |
Public property | ConnectionLimit |
Public property | Expect100Continue |
Public property | MaxIdleTime |
Public property | ReceiveBufferSize |
Public property | UseNagleAlgorithm |
Back to Top
See Also
ServicePointManagerConfigurator ServicePointConfigurator Class
NFX.Web Namespace


ServicePointManagerConfigurator.ServicePointConfigurator Constructor

ServicePointManagerConfigurator ServicePointConfigurator Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServicePointManagerConfigurator ServicePointConfigurator class

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ServicePointConfigurator(
    ServicePoint sp,
    IConfigSectionNode node
)
internal ServicePointConfigurator(
    ServicePoint sp,
    IConfigSectionNode node
)
Friend Sub New (
    sp As ServicePoint,
    node As IConfigSectionNode
)
Friend Sub New (
    sp As ServicePoint,
    node As IConfigSectionNode
)
internal:
ServicePointConfigurator(
    ServicePoint^ sp,
    IConfigSectionNode^ node
)
internal:
ServicePointConfigurator(
    ServicePoint^ sp,
    IConfigSectionNode^ node
)
new :
        sp : ServicePoint *
        node : IConfigSectionNode -> ServicePointConfigurator
new :
        sp : ServicePoint *
        node : IConfigSectionNode -> ServicePointConfigurator

Parameters

sp
Type: Online System.Net ServicePoint
node
Type: NFX.Environment IConfigSectionNode
See Also
ServicePointManagerConfigurator ServicePointConfigurator Class
ServicePointManagerConfigurator ServicePointConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.ServicePointConfigurator Fields

ServicePointManagerConfigurator ServicePointConfigurator Fields NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServicePointManagerConfigurator ServicePointConfigurator type exposes the following members.
Fields
 | Name | Description
Public field | ServicePoint |
Back to Top
See Also
ServicePointManagerConfigurator ServicePointConfigurator Class
NFX.Web Namespace


ServicePointManagerConfigurator.ServicePointConfigurator.ServicePoint Field

ServicePointManagerConfigurator ServicePointConfigurator ServicePoint Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ServicePoint ServicePoint
public readonly ServicePoint ServicePoint
Public ReadOnly ServicePoint As ServicePoint
Public ReadOnly ServicePoint As ServicePoint
public:
initonly ServicePoint^ ServicePoint
public:
initonly ServicePoint^ ServicePoint
val ServicePoint: ServicePoint
val ServicePoint: ServicePoint

Field Value

Type: Online ServicePoint
See Also
ServicePointManagerConfigurator ServicePointConfigurator Class
ServicePointManagerConfigurator ServicePointConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.ServicePointConfigurator Methods

ServicePointManagerConfigurator ServicePointConfigurator Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServicePointManagerConfigurator ServicePointConfigurator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServicePointManagerConfigurator ServicePointConfigurator Class
NFX.Web Namespace


ServicePointManagerConfigurator.ServicePointConfigurator Properties

ServicePointManagerConfigurator ServicePointConfigurator Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServicePointManagerConfigurator ServicePointConfigurator type exposes the following members.
Properties
 | Name | Description
Public property | ConnectionLeaseTimeout |
Public property | ConnectionLimit |
Public property | Expect100Continue |
Public property | MaxIdleTime |
Public property | ReceiveBufferSize |
Public property | UseNagleAlgorithm |
Back to Top
See Also
ServicePointManagerConfigurator ServicePointConfigurator Class
NFX.Web Namespace


ServicePointManagerConfigurator.ServicePointConfigurator.ConnectionLeaseTimeout Property

ServicePointManagerConfigurator ServicePointConfigurator ConnectionLeaseTimeout Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int ConnectionLeaseTimeout { get; private set; }
[ConfigAttribute]
public int ConnectionLeaseTimeout { get; private set; }
<ConfigAttribute>
Public Property ConnectionLeaseTimeout As Integer
    Get
    Private Set
<ConfigAttribute>
Public Property ConnectionLeaseTimeout As Integer
    Get
    Private Set
public:
[ConfigAttribute]
property int ConnectionLeaseTimeout {
    int get ();
    private: void set (int value);
}
public:
[ConfigAttribute]
property int ConnectionLeaseTimeout {
    int get ();
    private: void set (int value);
}
[<ConfigAttribute>]
member ConnectionLeaseTimeout : int with get, private set
[<ConfigAttribute>]
member ConnectionLeaseTimeout : int with get, private set

Property Value

Type: Online Int32
See Also
ServicePointManagerConfigurator ServicePointConfigurator Class
ServicePointManagerConfigurator ServicePointConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.ServicePointConfigurator.ConnectionLimit Property

ServicePointManagerConfigurator ServicePointConfigurator ConnectionLimit Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int ConnectionLimit { get; private set; }
[ConfigAttribute]
public int ConnectionLimit { get; private set; }
<ConfigAttribute>
Public Property ConnectionLimit As Integer
    Get
    Private Set
<ConfigAttribute>
Public Property ConnectionLimit As Integer
    Get
    Private Set
public:
[ConfigAttribute]
property int ConnectionLimit {
    int get ();
    private: void set (int value);
}
public:
[ConfigAttribute]
property int ConnectionLimit {
    int get ();
    private: void set (int value);
}
[<ConfigAttribute>]
member ConnectionLimit : int with get, private set
[<ConfigAttribute>]
member ConnectionLimit : int with get, private set

Property Value

Type: Online Int32
See Also
ServicePointManagerConfigurator ServicePointConfigurator Class
ServicePointManagerConfigurator ServicePointConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.ServicePointConfigurator.Expect100Continue Property

ServicePointManagerConfigurator ServicePointConfigurator Expect100Continue Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$expect-100-continue")]
public bool Expect100Continue { get; private set; }
[ConfigAttribute("$expect-100-continue")]
public bool Expect100Continue { get; private set; }
<ConfigAttribute("$expect-100-continue")>
Public Property Expect100Continue As Boolean
    Get
    Private Set
<ConfigAttribute("$expect-100-continue")>
Public Property Expect100Continue As Boolean
    Get
    Private Set
public:
[ConfigAttribute(L"$expect-100-continue")]
property bool Expect100Continue {
    bool get ();
    private: void set (bool value);
}
public:
[ConfigAttribute(L"$expect-100-continue")]
property bool Expect100Continue {
    bool get ();
    private: void set (bool value);
}
[<ConfigAttribute("$expect-100-continue")>]
member Expect100Continue : bool with get, private set
[<ConfigAttribute("$expect-100-continue")>]
member Expect100Continue : bool with get, private set

Property Value

Type: Online Boolean
See Also
ServicePointManagerConfigurator ServicePointConfigurator Class
ServicePointManagerConfigurator ServicePointConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.ServicePointConfigurator.MaxIdleTime Property

ServicePointManagerConfigurator ServicePointConfigurator MaxIdleTime Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int MaxIdleTime { get; private set; }
[ConfigAttribute]
public int MaxIdleTime { get; private set; }
<ConfigAttribute>
Public Property MaxIdleTime As Integer
    Get
    Private Set
<ConfigAttribute>
Public Property MaxIdleTime As Integer
    Get
    Private Set
public:
[ConfigAttribute]
property int MaxIdleTime {
    int get ();
    private: void set (int value);
}
public:
[ConfigAttribute]
property int MaxIdleTime {
    int get ();
    private: void set (int value);
}
[<ConfigAttribute>]
member MaxIdleTime : int with get, private set
[<ConfigAttribute>]
member MaxIdleTime : int with get, private set

Property Value

Type: Online Int32
See Also
ServicePointManagerConfigurator ServicePointConfigurator Class
ServicePointManagerConfigurator ServicePointConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.ServicePointConfigurator.ReceiveBufferSize Property

ServicePointManagerConfigurator ServicePointConfigurator ReceiveBufferSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int ReceiveBufferSize { get; private set; }
[ConfigAttribute]
public int ReceiveBufferSize { get; private set; }
<ConfigAttribute>
Public Property ReceiveBufferSize As Integer
    Get
    Private Set
<ConfigAttribute>
Public Property ReceiveBufferSize As Integer
    Get
    Private Set
public:
[ConfigAttribute]
property int ReceiveBufferSize {
    int get ();
    private: void set (int value);
}
public:
[ConfigAttribute]
property int ReceiveBufferSize {
    int get ();
    private: void set (int value);
}
[<ConfigAttribute>]
member ReceiveBufferSize : int with get, private set
[<ConfigAttribute>]
member ReceiveBufferSize : int with get, private set

Property Value

Type: Online Int32
See Also
ServicePointManagerConfigurator ServicePointConfigurator Class
ServicePointManagerConfigurator ServicePointConfigurator Members
NFX.Web Namespace


ServicePointManagerConfigurator.ServicePointConfigurator.UseNagleAlgorithm Property

ServicePointManagerConfigurator ServicePointConfigurator UseNagleAlgorithm Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool UseNagleAlgorithm { get; private set; }
[ConfigAttribute]
public bool UseNagleAlgorithm { get; private set; }
<ConfigAttribute>
Public Property UseNagleAlgorithm As Boolean
    Get
    Private Set
<ConfigAttribute>
Public Property UseNagleAlgorithm As Boolean
    Get
    Private Set
public:
[ConfigAttribute]
property bool UseNagleAlgorithm {
    bool get ();
    private: void set (bool value);
}
public:
[ConfigAttribute]
property bool UseNagleAlgorithm {
    bool get ();
    private: void set (bool value);
}
[<ConfigAttribute>]
member UseNagleAlgorithm : bool with get, private set
[<ConfigAttribute>]
member UseNagleAlgorithm : bool with get, private set

Property Value

Type: Online Boolean
See Also
ServicePointManagerConfigurator ServicePointConfigurator Class
ServicePointManagerConfigurator ServicePointConfigurator Members
NFX.Web Namespace


StringConsts Class

StringConsts Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Web StringConsts

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class StringConsts
public static class StringConsts
Public NotInheritable Class StringConsts
Public NotInheritable Class StringConsts
public ref class StringConsts abstract sealed
public ref class StringConsts abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringConsts =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringConsts =  class end
See Also
StringConsts Members
NFX.Web Namespace


StringConsts Members

StringConsts Members NFX Class Library

The StringConsts type exposes the following members.
Fields
Name | Description
APP_DATA_STORE_INIT_ERROR |
APP_FORMS_FACTORY_INIT_ERROR |
APP_INIT_CONFIG_ERROR |
APP_INSTANCE_ALREADY_CREATED_ERROR |
APP_INSTANCE_NULL_ERROR |
APP_INSTRUMENTATION_INIT_ERROR |
APP_LOG_INIT_ERROR |
APP_OBJECT_STORE_INIT_ERROR |
APP_SESSION_STRATEGY_INIT_ERROR |
ARGUMENT_ERROR |
BASE_HANDLER_EXCEPTION_ERROR |
CONTEXT_NOT_AVAILABLE_ERROR |
CONTRACT_NS |
CONTROLLER_ACTION_METHOD_NOT_FOUND_ERROR |
CONTROLLER_SESSION_MISMATCH_WARNING |
DELETE_MODIFY_ERROR |
DONT_KNOW_ACTION_ERROR |
FS_S3_PARAMS_SERVER_URL_ERROR |
FS_SESSION_BAD_PARAMS_ERROR |
FS_SVN_PARAMS_SERVER_URL_ERROR |
GEO_LOOKUP_SVC_CANCELED_ERROR |
GEO_LOOKUP_SVC_DATA_FILE_ERROR |
GEO_LOOKUP_SVC_PATH_ERROR |
GEO_LOOKUP_SVC_RESOLUTION_ERROR |
GUID_KEY |
HTTP_OPERATION_ERROR |
MAILER_LOG_TOPIC |
MAILER_SINK_IS_NOT_OWNED_ERROR |
MAILER_SINK_IS_NOT_SET_ERROR |
MAILER_SINK_SMTP_IS_NOT_CONFIGURED_ERROR |
MODEL_CLIENT_REQUEST_READ_ERROR |
MODEL_FIELD_NOT_FOUND_ERROR |
MODEL_METHOD_NOT_FOUND_ERROR |
MODEL_NOT_FOUND_ERROR |
MODEL_PROTOCOL_ERROR |
MODEL_ROUTE_HANDLER_ERROR |
MULTIPART_BOUNDARY_COULDNT_BE_SHORTER_3_ERROR |
MULTIPART_BOUNDARY_IS_TOO_SHORT |
MULTIPART_BOUNDARY_MISMATCH_ERROR |
MULTIPART_BOUNDARY_SHOULD_START_WITH_HYPHENS |
MULTIPART_DOUBLE_EOL_ISNT_FOUND_AFTER_HEADER_ERROR |
MULTIPART_NO_LF_NOR_CRLF_ISNT_FOUND_ERROR |
MULTIPART_PART_COULDNT_BE_EMPTY_ERROR |
MULTIPART_PART_EMPTY_NAME_ERROR |
MULTIPART_PART_IS_ALREADY_REGISTERED_ERROR |
MULTIPART_PART_MUST_BE_ENDED_WITH_EOL_ERROR |
MULTIPART_PART_SEGMENT_ISNT_TERMINATED_CORRECTLY_ERROR |
MULTIPART_PARTS_COULDNT_BE_EMPTY_ERROR |
MULTIPART_SPECIFIED_BOUNDARY_ISNT_FOUND_ERROR |
MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_READ_ERROR |
MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_WRITE_ERROR |
MULTIPART_TERMINATOR_ISNT_FOUND_ERROR |
NAME_KEY |
NFX_WEB_APP_CONFIGURATION_FILE |
NO_RECORD_IN_VOLATILE_STORE_ERROR |
NO_ROUTE_CONTEXT |
NOT_FOUND_ERROR |
OPERATION_NOT_SUPPORTED_ERROR |
PAYMENT_CANNOT_CAPTURE_CAPTURED_PAYMENT_ERROR |
PAYMENT_CANNOT_CHARGE_PAYMENT_ERROR |
PAYMENT_CANNOT_CREATE_RECIPIENT_ERROR |
PAYMENT_CANNOT_TRANSFER_ERROR |
PAYMENT_CANNOT_VOID_ERROR |
PAYMENT_CAPTURE_CURRENCY_MUST_MATCH_CHARGE_ERROR |
PAYMENT_CURRENCY_CONVERSION_MAPPING_ERROR |
PAYMENT_CURRENCY_NOT_SUPPORTED_ERROR |
PAYMENT_INVALID_ADDR_ERROR |
PAYMENT_INVALID_CARD_NUMBER_ERROR |
PAYMENT_INVALID_CUSTOMER_ERROR |
PAYMENT_INVALID_CVC_ERROR |
PAYMENT_INVALID_EXPIRATION_DATE_ERROR |
PAYMENT_INVALID_PAYSYSTEM_ERROR |
PAYMENT_PAYPAL_200_STATUSCODE |
PAYMENT_PAYPAL_201_STATUSCODE |
PAYMENT_PAYPAL_400_STATUSCODE |
PAYMENT_PAYPAL_401_STATUSCODE |
PAYMENT_PAYPAL_402_STATUSCODE |
PAYMENT_PAYPAL_403_STATUSCODE |
PAYMENT_PAYPAL_404_STATUSCODE |
PAYMENT_PAYPAL_405_STATUSCODE |
PAYMENT_PAYPAL_415_STATUSCODE |
PAYMENT_PAYPAL_422_STATUSCODE |
PAYMENT_PAYPAL_429_STATUSCODE |
PAYMENT_PAYPAL_50x_STATUSCODE |
PAYMENT_PAYPAL_UNKNOWN_STATUSCODE |
PAYMENT_REFUND_CANNOT_BE_REFUNDED_ERROR |
PAYMENT_REFUND_CURRENCY_MUST_MATCH_CHARGE_ERROR |
PAYMENT_REFUND_EXCEEDS_CHARGE_ERROR |
PAYMENT_STRIPE_400_ERROR |
PAYMENT_STRIPE_401_ERROR |
PAYMENT_STRIPE_402_ERROR |
PAYMENT_STRIPE_404_ERROR |
PAYMENT_STRIPE_50X_ERROR |
PAYMENT_STRIPE_ERR_MSG_ERROR |
PAYMENT_SYSTEM_DUPLICATE_NAME_ERROR |
PAYMENT_SYSTEM_HOST_NULL_ERROR |
PAYMENT_UNKNOWN_ACCOUNT_ERROR |
PAYPAL_GENERATE_OAUTH_ERROR_MESSAGE |
PAYPAL_PAYOUT_ERROR |
PAYPAL_PAYOUT_ITEM_CANCEL_ERROR_MESSAGE |
PAYPAL_PAYOUT_ITEM_FETCH_ERROR_MESSAGE |
PAYPAL_PAYOUT_NOT_SUCCEEDED_MESSAGE |
PAYPAL_PAYOUTS_CREATE_ERROR_MESSAGE |
PAYPAL_PAYOUTS_FETCH_ERROR_MESSAGE |
PAYPAL_VOID_ERROR_MESSAGE |
SCRIPT_NAME_MISSING_ERROR |
SCRIPT_READ_ERROR |
SCRIPT_ROUTE_HANDLER_ERROR |
SHIPPING_SYSTEM_DUPLICATE_NAME_ERROR |
SHIPPING_SYSTEM_HOST_NULL_ERROR |
SHIPPO_CAN_NOT_MAP_LABEL_FORMAT |
SHIPPO_CREATE_LABEL_ERROR |
SHIPPO_CREATE_LABEL_MESSAGE |
SHIPPO_ESTIMATE_SHIPPING_COST_ERROR |
SHIPPO_ESTIMATE_SHIPPING_COST_MESSAGE |
SHIPPO_GET_RATE_ERROR |
SHIPPO_OPERATION_FAILED |
SHIPPO_TRACK_SHIPMENT_ERROR |
SHIPPO_TRACK_SHIPMENT_MESSAGE |
SHIPPO_VALIDATE_ADDRESS_ERROR |
SHIPPO_VALIDATE_ADDRESS_INVALID_ERROR |
SHIPPO_VALIDATE_ADDRESS_MESSAGE |
SOCIAL_NETWORK_DUPLICATE_NAME |
STRIP_KEY |
TAX_CALC_DIFFERENT_CURRENCIES_ERROR |
TAX_CALC_ERROR |
TAX_CALCULATOR_DUPLICATE_NAME_ERROR |
TAX_TAXJAR_TOADDRESS_ISNT_SUPPLIED_ERROR |
TYPELOOKUP_404_LOG_MSG |
UNKNOWN |
WEB_HANDLER_TOPIC |
WEB_LOG_TOPIC |
WEB_REQUEST_ERROR |
Back to Top
See Also
StringConsts Class
NFX.Web Namespace


StringConsts Fields

StringConsts Fields NFX Class Library

The StringConsts type exposes the following members.
Fields
Name | Description
APP_DATA_STORE_INIT_ERROR |
APP_FORMS_FACTORY_INIT_ERROR |
APP_INIT_CONFIG_ERROR |
APP_INSTANCE_ALREADY_CREATED_ERROR |
APP_INSTANCE_NULL_ERROR |
APP_INSTRUMENTATION_INIT_ERROR |
APP_LOG_INIT_ERROR |
APP_OBJECT_STORE_INIT_ERROR |
APP_SESSION_STRATEGY_INIT_ERROR |
ARGUMENT_ERROR |
BASE_HANDLER_EXCEPTION_ERROR |
CONTEXT_NOT_AVAILABLE_ERROR |
CONTRACT_NS |
CONTROLLER_ACTION_METHOD_NOT_FOUND_ERROR |
CONTROLLER_SESSION_MISMATCH_WARNING |
DELETE_MODIFY_ERROR |
DONT_KNOW_ACTION_ERROR |
FS_S3_PARAMS_SERVER_URL_ERROR |
FS_SESSION_BAD_PARAMS_ERROR |
FS_SVN_PARAMS_SERVER_URL_ERROR |
GEO_LOOKUP_SVC_CANCELED_ERROR |
GEO_LOOKUP_SVC_DATA_FILE_ERROR |
GEO_LOOKUP_SVC_PATH_ERROR |
GEO_LOOKUP_SVC_RESOLUTION_ERROR |
GUID_KEY |
HTTP_OPERATION_ERROR |
MAILER_LOG_TOPIC |
MAILER_SINK_IS_NOT_OWNED_ERROR |
MAILER_SINK_IS_NOT_SET_ERROR |
MAILER_SINK_SMTP_IS_NOT_CONFIGURED_ERROR |
MODEL_CLIENT_REQUEST_READ_ERROR |
MODEL_FIELD_NOT_FOUND_ERROR |
MODEL_METHOD_NOT_FOUND_ERROR |
MODEL_NOT_FOUND_ERROR |
MODEL_PROTOCOL_ERROR |
MODEL_ROUTE_HANDLER_ERROR |
MULTIPART_BOUNDARY_COULDNT_BE_SHORTER_3_ERROR |
MULTIPART_BOUNDARY_IS_TOO_SHORT |
MULTIPART_BOUNDARY_MISMATCH_ERROR |
MULTIPART_BOUNDARY_SHOULD_START_WITH_HYPHENS |
MULTIPART_DOUBLE_EOL_ISNT_FOUND_AFTER_HEADER_ERROR |
MULTIPART_NO_LF_NOR_CRLF_ISNT_FOUND_ERROR |
MULTIPART_PART_COULDNT_BE_EMPTY_ERROR |
MULTIPART_PART_EMPTY_NAME_ERROR |
MULTIPART_PART_IS_ALREADY_REGISTERED_ERROR |
MULTIPART_PART_MUST_BE_ENDED_WITH_EOL_ERROR |
MULTIPART_PART_SEGMENT_ISNT_TERMINATED_CORRECTLY_ERROR |
MULTIPART_PARTS_COULDNT_BE_EMPTY_ERROR |
MULTIPART_SPECIFIED_BOUNDARY_ISNT_FOUND_ERROR |
MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_READ_ERROR |
MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_WRITE_ERROR |
MULTIPART_TERMINATOR_ISNT_FOUND_ERROR |
NAME_KEY |
NFX_WEB_APP_CONFIGURATION_FILE |
NO_RECORD_IN_VOLATILE_STORE_ERROR |
NO_ROUTE_CONTEXT |
NOT_FOUND_ERROR |
OPERATION_NOT_SUPPORTED_ERROR |
PAYMENT_CANNOT_CAPTURE_CAPTURED_PAYMENT_ERROR |
PAYMENT_CANNOT_CHARGE_PAYMENT_ERROR |
PAYMENT_CANNOT_CREATE_RECIPIENT_ERROR |
PAYMENT_CANNOT_TRANSFER_ERROR |
PAYMENT_CANNOT_VOID_ERROR |
PAYMENT_CAPTURE_CURRENCY_MUST_MATCH_CHARGE_ERROR |
PAYMENT_CURRENCY_CONVERSION_MAPPING_ERROR |
PAYMENT_CURRENCY_NOT_SUPPORTED_ERROR |
PAYMENT_INVALID_ADDR_ERROR |
PAYMENT_INVALID_CARD_NUMBER_ERROR |
PAYMENT_INVALID_CUSTOMER_ERROR |
PAYMENT_INVALID_CVC_ERROR |
PAYMENT_INVALID_EXPIRATION_DATE_ERROR |
PAYMENT_INVALID_PAYSYSTEM_ERROR |
PAYMENT_PAYPAL_200_STATUSCODE |
PAYMENT_PAYPAL_201_STATUSCODE |
PAYMENT_PAYPAL_400_STATUSCODE |
PAYMENT_PAYPAL_401_STATUSCODE |
PAYMENT_PAYPAL_402_STATUSCODE |
PAYMENT_PAYPAL_403_STATUSCODE |
PAYMENT_PAYPAL_404_STATUSCODE |
PAYMENT_PAYPAL_405_STATUSCODE |
PAYMENT_PAYPAL_415_STATUSCODE |
PAYMENT_PAYPAL_422_STATUSCODE |
PAYMENT_PAYPAL_429_STATUSCODE |
PAYMENT_PAYPAL_50x_STATUSCODE |
PAYMENT_PAYPAL_UNKNOWN_STATUSCODE |
PAYMENT_REFUND_CANNOT_BE_REFUNDED_ERROR |
PAYMENT_REFUND_CURRENCY_MUST_MATCH_CHARGE_ERROR |
PAYMENT_REFUND_EXCEEDS_CHARGE_ERROR |
PAYMENT_STRIPE_400_ERROR |
PAYMENT_STRIPE_401_ERROR |
PAYMENT_STRIPE_402_ERROR |
PAYMENT_STRIPE_404_ERROR |
PAYMENT_STRIPE_50X_ERROR |
PAYMENT_STRIPE_ERR_MSG_ERROR |
PAYMENT_SYSTEM_DUPLICATE_NAME_ERROR |
PAYMENT_SYSTEM_HOST_NULL_ERROR |
PAYMENT_UNKNOWN_ACCOUNT_ERROR |
PAYPAL_GENERATE_OAUTH_ERROR_MESSAGE |
PAYPAL_PAYOUT_ERROR |
PAYPAL_PAYOUT_ITEM_CANCEL_ERROR_MESSAGE |
PAYPAL_PAYOUT_ITEM_FETCH_ERROR_MESSAGE |
PAYPAL_PAYOUT_NOT_SUCCEEDED_MESSAGE |
PAYPAL_PAYOUTS_CREATE_ERROR_MESSAGE |
PAYPAL_PAYOUTS_FETCH_ERROR_MESSAGE |
PAYPAL_VOID_ERROR_MESSAGE |
SCRIPT_NAME_MISSING_ERROR |
SCRIPT_READ_ERROR |
SCRIPT_ROUTE_HANDLER_ERROR |
SHIPPING_SYSTEM_DUPLICATE_NAME_ERROR |
SHIPPING_SYSTEM_HOST_NULL_ERROR |
SHIPPO_CAN_NOT_MAP_LABEL_FORMAT |
SHIPPO_CREATE_LABEL_ERROR |
SHIPPO_CREATE_LABEL_MESSAGE |
SHIPPO_ESTIMATE_SHIPPING_COST_ERROR |
SHIPPO_ESTIMATE_SHIPPING_COST_MESSAGE |
SHIPPO_GET_RATE_ERROR |
SHIPPO_OPERATION_FAILED |
SHIPPO_TRACK_SHIPMENT_ERROR |
SHIPPO_TRACK_SHIPMENT_MESSAGE |
SHIPPO_VALIDATE_ADDRESS_ERROR |
SHIPPO_VALIDATE_ADDRESS_INVALID_ERROR |
SHIPPO_VALIDATE_ADDRESS_MESSAGE |
SOCIAL_NETWORK_DUPLICATE_NAME |
STRIP_KEY |
TAX_CALC_DIFFERENT_CURRENCIES_ERROR |
TAX_CALC_ERROR |
TAX_CALCULATOR_DUPLICATE_NAME_ERROR |
TAX_TAXJAR_TOADDRESS_ISNT_SUPPLIED_ERROR |
TYPELOOKUP_404_LOG_MSG |
UNKNOWN |
WEB_HANDLER_TOPIC |
WEB_LOG_TOPIC |
WEB_REQUEST_ERROR |
Back to Top
See Also
StringConsts Class
NFX.Web Namespace


StringConsts.APP_DATA_STORE_INIT_ERROR Field

StringConsts APP_DATA_STORE_INIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_DATA_STORE_INIT_ERROR
public const string APP_DATA_STORE_INIT_ERROR
Public Const APP_DATA_STORE_INIT_ERROR As String
Public Const APP_DATA_STORE_INIT_ERROR As String
public:
literal String^ APP_DATA_STORE_INIT_ERROR
public:
literal String^ APP_DATA_STORE_INIT_ERROR
static val mutable APP_DATA_STORE_INIT_ERROR: string
static val mutable APP_DATA_STORE_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.APP_FORMS_FACTORY_INIT_ERROR Field

StringConsts APP_FORMS_FACTORY_INIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_FORMS_FACTORY_INIT_ERROR
public const string APP_FORMS_FACTORY_INIT_ERROR
Public Const APP_FORMS_FACTORY_INIT_ERROR As String
Public Const APP_FORMS_FACTORY_INIT_ERROR As String
public:
literal String^ APP_FORMS_FACTORY_INIT_ERROR
public:
literal String^ APP_FORMS_FACTORY_INIT_ERROR
static val mutable APP_FORMS_FACTORY_INIT_ERROR: string
static val mutable APP_FORMS_FACTORY_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.APP_INIT_CONFIG_ERROR Field

StringConsts APP_INIT_CONFIG_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_INIT_CONFIG_ERROR
public const string APP_INIT_CONFIG_ERROR
Public Const APP_INIT_CONFIG_ERROR As String
Public Const APP_INIT_CONFIG_ERROR As String
public:
literal String^ APP_INIT_CONFIG_ERROR
public:
literal String^ APP_INIT_CONFIG_ERROR
static val mutable APP_INIT_CONFIG_ERROR: string
static val mutable APP_INIT_CONFIG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.APP_INSTANCE_ALREADY_CREATED_ERROR Field

StringConsts APP_INSTANCE_ALREADY_CREATED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_INSTANCE_ALREADY_CREATED_ERROR
public const string APP_INSTANCE_ALREADY_CREATED_ERROR
Public Const APP_INSTANCE_ALREADY_CREATED_ERROR As String
Public Const APP_INSTANCE_ALREADY_CREATED_ERROR As String
public:
literal String^ APP_INSTANCE_ALREADY_CREATED_ERROR
public:
literal String^ APP_INSTANCE_ALREADY_CREATED_ERROR
static val mutable APP_INSTANCE_ALREADY_CREATED_ERROR: string
static val mutable APP_INSTANCE_ALREADY_CREATED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.APP_INSTANCE_NULL_ERROR Field

StringConsts APP_INSTANCE_NULL_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_INSTANCE_NULL_ERROR
public const string APP_INSTANCE_NULL_ERROR
Public Const APP_INSTANCE_NULL_ERROR As String
Public Const APP_INSTANCE_NULL_ERROR As String
public:
literal String^ APP_INSTANCE_NULL_ERROR
public:
literal String^ APP_INSTANCE_NULL_ERROR
static val mutable APP_INSTANCE_NULL_ERROR: string
static val mutable APP_INSTANCE_NULL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.APP_INSTRUMENTATION_INIT_ERROR Field

StringConsts APP_INSTRUMENTATION_INIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_INSTRUMENTATION_INIT_ERROR
public const string APP_INSTRUMENTATION_INIT_ERROR
Public Const APP_INSTRUMENTATION_INIT_ERROR As String
Public Const APP_INSTRUMENTATION_INIT_ERROR As String
public:
literal String^ APP_INSTRUMENTATION_INIT_ERROR
public:
literal String^ APP_INSTRUMENTATION_INIT_ERROR
static val mutable APP_INSTRUMENTATION_INIT_ERROR: string
static val mutable APP_INSTRUMENTATION_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.APP_LOG_INIT_ERROR Field

StringConsts APP_LOG_INIT_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_LOG_INIT_ERROR
public const string APP_LOG_INIT_ERROR
Public Const APP_LOG_INIT_ERROR As String
Public Const APP_LOG_INIT_ERROR As String
public:
literal String^ APP_LOG_INIT_ERROR
public:
literal String^ APP_LOG_INIT_ERROR
static val mutable APP_LOG_INIT_ERROR: string
static val mutable APP_LOG_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.APP_OBJECT_STORE_INIT_ERROR Field

StringConsts APP_OBJECT_STORE_INIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_OBJECT_STORE_INIT_ERROR
public const string APP_OBJECT_STORE_INIT_ERROR
Public Const APP_OBJECT_STORE_INIT_ERROR As String
Public Const APP_OBJECT_STORE_INIT_ERROR As String
public:
literal String^ APP_OBJECT_STORE_INIT_ERROR
public:
literal String^ APP_OBJECT_STORE_INIT_ERROR
static val mutable APP_OBJECT_STORE_INIT_ERROR: string
static val mutable APP_OBJECT_STORE_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.APP_SESSION_STRATEGY_INIT_ERROR Field

StringConsts APP_SESSION_STRATEGY_INIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_SESSION_STRATEGY_INIT_ERROR
public const string APP_SESSION_STRATEGY_INIT_ERROR
Public Const APP_SESSION_STRATEGY_INIT_ERROR As String
Public Const APP_SESSION_STRATEGY_INIT_ERROR As String
public:
literal String^ APP_SESSION_STRATEGY_INIT_ERROR
public:
literal String^ APP_SESSION_STRATEGY_INIT_ERROR
static val mutable APP_SESSION_STRATEGY_INIT_ERROR: string
static val mutable APP_SESSION_STRATEGY_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.ARGUMENT_ERROR Field

StringConsts ARGUMENT_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ARGUMENT_ERROR
public const string ARGUMENT_ERROR
Public Const ARGUMENT_ERROR As String
Public Const ARGUMENT_ERROR As String
public:
literal String^ ARGUMENT_ERROR
public:
literal String^ ARGUMENT_ERROR
static val mutable ARGUMENT_ERROR: string
static val mutable ARGUMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.BASE_HANDLER_EXCEPTION_ERROR Field

StringConsts BASE_HANDLER_EXCEPTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BASE_HANDLER_EXCEPTION_ERROR
public const string BASE_HANDLER_EXCEPTION_ERROR
Public Const BASE_HANDLER_EXCEPTION_ERROR As String
Public Const BASE_HANDLER_EXCEPTION_ERROR As String
public:
literal String^ BASE_HANDLER_EXCEPTION_ERROR
public:
literal String^ BASE_HANDLER_EXCEPTION_ERROR
static val mutable BASE_HANDLER_EXCEPTION_ERROR: string
static val mutable BASE_HANDLER_EXCEPTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.CONTEXT_NOT_AVAILABLE_ERROR Field

StringConsts CONTEXT_NOT_AVAILABLE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONTEXT_NOT_AVAILABLE_ERROR
public const string CONTEXT_NOT_AVAILABLE_ERROR
Public Const CONTEXT_NOT_AVAILABLE_ERROR As String
Public Const CONTEXT_NOT_AVAILABLE_ERROR As String
public:
literal String^ CONTEXT_NOT_AVAILABLE_ERROR
public:
literal String^ CONTEXT_NOT_AVAILABLE_ERROR
static val mutable CONTEXT_NOT_AVAILABLE_ERROR: string
static val mutable CONTEXT_NOT_AVAILABLE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.CONTRACT_NS Field

StringConsts CONTRACT_NS Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONTRACT_NS
public const string CONTRACT_NS
Public Const CONTRACT_NS As String
Public Const CONTRACT_NS As String
public:
literal String^ CONTRACT_NS
public:
literal String^ CONTRACT_NS
static val mutable CONTRACT_NS: string
static val mutable CONTRACT_NS: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.CONTROLLER_ACTION_METHOD_NOT_FOUND_ERROR Field

StringConsts CONTROLLER_ACTION_METHOD_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONTROLLER_ACTION_METHOD_NOT_FOUND_ERROR
public const string CONTROLLER_ACTION_METHOD_NOT_FOUND_ERROR
Public Const CONTROLLER_ACTION_METHOD_NOT_FOUND_ERROR As String
Public Const CONTROLLER_ACTION_METHOD_NOT_FOUND_ERROR As String
public:
literal String^ CONTROLLER_ACTION_METHOD_NOT_FOUND_ERROR
public:
literal String^ CONTROLLER_ACTION_METHOD_NOT_FOUND_ERROR
static val mutable CONTROLLER_ACTION_METHOD_NOT_FOUND_ERROR: string
static val mutable CONTROLLER_ACTION_METHOD_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.CONTROLLER_SESSION_MISMATCH_WARNING Field

StringConsts CONTROLLER_SESSION_MISMATCH_WARNING Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONTROLLER_SESSION_MISMATCH_WARNING
public const string CONTROLLER_SESSION_MISMATCH_WARNING
Public Const CONTROLLER_SESSION_MISMATCH_WARNING As String
Public Const CONTROLLER_SESSION_MISMATCH_WARNING As String
public:
literal String^ CONTROLLER_SESSION_MISMATCH_WARNING
public:
literal String^ CONTROLLER_SESSION_MISMATCH_WARNING
static val mutable CONTROLLER_SESSION_MISMATCH_WARNING: string
static val mutable CONTROLLER_SESSION_MISMATCH_WARNING: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.DELETE_MODIFY_ERROR Field

StringConsts DELETE_MODIFY_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DELETE_MODIFY_ERROR
public const string DELETE_MODIFY_ERROR
Public Const DELETE_MODIFY_ERROR As String
Public Const DELETE_MODIFY_ERROR As String
public:
literal String^ DELETE_MODIFY_ERROR
public:
literal String^ DELETE_MODIFY_ERROR
static val mutable DELETE_MODIFY_ERROR: string
static val mutable DELETE_MODIFY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.DONT_KNOW_ACTION_ERROR Field

StringConsts DONT_KNOW_ACTION_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DONT_KNOW_ACTION_ERROR
public const string DONT_KNOW_ACTION_ERROR
Public Const DONT_KNOW_ACTION_ERROR As String
Public Const DONT_KNOW_ACTION_ERROR As String
public:
literal String^ DONT_KNOW_ACTION_ERROR
public:
literal String^ DONT_KNOW_ACTION_ERROR
static val mutable DONT_KNOW_ACTION_ERROR: string
static val mutable DONT_KNOW_ACTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.FS_S3_PARAMS_SERVER_URL_ERROR Field

StringConsts FS_S3_PARAMS_SERVER_URL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FS_S3_PARAMS_SERVER_URL_ERROR
public const string FS_S3_PARAMS_SERVER_URL_ERROR
Public Const FS_S3_PARAMS_SERVER_URL_ERROR As String
Public Const FS_S3_PARAMS_SERVER_URL_ERROR As String
public:
literal String^ FS_S3_PARAMS_SERVER_URL_ERROR
public:
literal String^ FS_S3_PARAMS_SERVER_URL_ERROR
static val mutable FS_S3_PARAMS_SERVER_URL_ERROR: string
static val mutable FS_S3_PARAMS_SERVER_URL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.FS_SESSION_BAD_PARAMS_ERROR Field

StringConsts FS_SESSION_BAD_PARAMS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FS_SESSION_BAD_PARAMS_ERROR
public const string FS_SESSION_BAD_PARAMS_ERROR
Public Const FS_SESSION_BAD_PARAMS_ERROR As String
Public Const FS_SESSION_BAD_PARAMS_ERROR As String
public:
literal String^ FS_SESSION_BAD_PARAMS_ERROR
public:
literal String^ FS_SESSION_BAD_PARAMS_ERROR
static val mutable FS_SESSION_BAD_PARAMS_ERROR: string
static val mutable FS_SESSION_BAD_PARAMS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.FS_SVN_PARAMS_SERVER_URL_ERROR Field

StringConsts FS_SVN_PARAMS_SERVER_URL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FS_SVN_PARAMS_SERVER_URL_ERROR
public const string FS_SVN_PARAMS_SERVER_URL_ERROR
Public Const FS_SVN_PARAMS_SERVER_URL_ERROR As String
Public Const FS_SVN_PARAMS_SERVER_URL_ERROR As String
public:
literal String^ FS_SVN_PARAMS_SERVER_URL_ERROR
public:
literal String^ FS_SVN_PARAMS_SERVER_URL_ERROR
static val mutable FS_SVN_PARAMS_SERVER_URL_ERROR: string
static val mutable FS_SVN_PARAMS_SERVER_URL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.GEO_LOOKUP_SVC_CANCELED_ERROR Field

StringConsts GEO_LOOKUP_SVC_CANCELED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GEO_LOOKUP_SVC_CANCELED_ERROR
public const string GEO_LOOKUP_SVC_CANCELED_ERROR
Public Const GEO_LOOKUP_SVC_CANCELED_ERROR As String
Public Const GEO_LOOKUP_SVC_CANCELED_ERROR As String
public:
literal String^ GEO_LOOKUP_SVC_CANCELED_ERROR
public:
literal String^ GEO_LOOKUP_SVC_CANCELED_ERROR
static val mutable GEO_LOOKUP_SVC_CANCELED_ERROR: string
static val mutable GEO_LOOKUP_SVC_CANCELED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.GEO_LOOKUP_SVC_DATA_FILE_ERROR Field

StringConsts GEO_LOOKUP_SVC_DATA_FILE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GEO_LOOKUP_SVC_DATA_FILE_ERROR
public const string GEO_LOOKUP_SVC_DATA_FILE_ERROR
Public Const GEO_LOOKUP_SVC_DATA_FILE_ERROR As String
Public Const GEO_LOOKUP_SVC_DATA_FILE_ERROR As String
public:
literal String^ GEO_LOOKUP_SVC_DATA_FILE_ERROR
public:
literal String^ GEO_LOOKUP_SVC_DATA_FILE_ERROR
static val mutable GEO_LOOKUP_SVC_DATA_FILE_ERROR: string
static val mutable GEO_LOOKUP_SVC_DATA_FILE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.GEO_LOOKUP_SVC_PATH_ERROR Field

StringConsts GEO_LOOKUP_SVC_PATH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GEO_LOOKUP_SVC_PATH_ERROR
public const string GEO_LOOKUP_SVC_PATH_ERROR
Public Const GEO_LOOKUP_SVC_PATH_ERROR As String
Public Const GEO_LOOKUP_SVC_PATH_ERROR As String
public:
literal String^ GEO_LOOKUP_SVC_PATH_ERROR
public:
literal String^ GEO_LOOKUP_SVC_PATH_ERROR
static val mutable GEO_LOOKUP_SVC_PATH_ERROR: string
static val mutable GEO_LOOKUP_SVC_PATH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.GEO_LOOKUP_SVC_RESOLUTION_ERROR Field

StringConsts GEO_LOOKUP_SVC_RESOLUTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GEO_LOOKUP_SVC_RESOLUTION_ERROR
public const string GEO_LOOKUP_SVC_RESOLUTION_ERROR
Public Const GEO_LOOKUP_SVC_RESOLUTION_ERROR As String
Public Const GEO_LOOKUP_SVC_RESOLUTION_ERROR As String
public:
literal String^ GEO_LOOKUP_SVC_RESOLUTION_ERROR
public:
literal String^ GEO_LOOKUP_SVC_RESOLUTION_ERROR
static val mutable GEO_LOOKUP_SVC_RESOLUTION_ERROR: string
static val mutable GEO_LOOKUP_SVC_RESOLUTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.GUID_KEY Field

StringConsts GUID_KEY Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GUID_KEY
public const string GUID_KEY
Public Const GUID_KEY As String
Public Const GUID_KEY As String
public:
literal String^ GUID_KEY
public:
literal String^ GUID_KEY
static val mutable GUID_KEY: string
static val mutable GUID_KEY: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.HTTP_OPERATION_ERROR Field

StringConsts HTTP_OPERATION_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HTTP_OPERATION_ERROR
public const string HTTP_OPERATION_ERROR
Public Const HTTP_OPERATION_ERROR As String
Public Const HTTP_OPERATION_ERROR As String
public:
literal String^ HTTP_OPERATION_ERROR
public:
literal String^ HTTP_OPERATION_ERROR
static val mutable HTTP_OPERATION_ERROR: string
static val mutable HTTP_OPERATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MAILER_LOG_TOPIC Field

StringConsts MAILER_LOG_TOPIC Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MAILER_LOG_TOPIC
public const string MAILER_LOG_TOPIC
Public Const MAILER_LOG_TOPIC As String
Public Const MAILER_LOG_TOPIC As String
public:
literal String^ MAILER_LOG_TOPIC
public:
literal String^ MAILER_LOG_TOPIC
static val mutable MAILER_LOG_TOPIC: string
static val mutable MAILER_LOG_TOPIC: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MAILER_SINK_IS_NOT_OWNED_ERROR Field

StringConsts MAILER_SINK_IS_NOT_OWNED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MAILER_SINK_IS_NOT_OWNED_ERROR
public const string MAILER_SINK_IS_NOT_OWNED_ERROR
Public Const MAILER_SINK_IS_NOT_OWNED_ERROR As String
Public Const MAILER_SINK_IS_NOT_OWNED_ERROR As String
public:
literal String^ MAILER_SINK_IS_NOT_OWNED_ERROR
public:
literal String^ MAILER_SINK_IS_NOT_OWNED_ERROR
static val mutable MAILER_SINK_IS_NOT_OWNED_ERROR: string
static val mutable MAILER_SINK_IS_NOT_OWNED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MAILER_SINK_IS_NOT_SET_ERROR Field

StringConsts MAILER_SINK_IS_NOT_SET_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MAILER_SINK_IS_NOT_SET_ERROR
public const string MAILER_SINK_IS_NOT_SET_ERROR
Public Const MAILER_SINK_IS_NOT_SET_ERROR As String
Public Const MAILER_SINK_IS_NOT_SET_ERROR As String
public:
literal String^ MAILER_SINK_IS_NOT_SET_ERROR
public:
literal String^ MAILER_SINK_IS_NOT_SET_ERROR
static val mutable MAILER_SINK_IS_NOT_SET_ERROR: string
static val mutable MAILER_SINK_IS_NOT_SET_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MAILER_SINK_SMTP_IS_NOT_CONFIGURED_ERROR Field

StringConsts MAILER_SINK_SMTP_IS_NOT_CONFIGURED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MAILER_SINK_SMTP_IS_NOT_CONFIGURED_ERROR
public const string MAILER_SINK_SMTP_IS_NOT_CONFIGURED_ERROR
Public Const MAILER_SINK_SMTP_IS_NOT_CONFIGURED_ERROR As String
Public Const MAILER_SINK_SMTP_IS_NOT_CONFIGURED_ERROR As String
public:
literal String^ MAILER_SINK_SMTP_IS_NOT_CONFIGURED_ERROR
public:
literal String^ MAILER_SINK_SMTP_IS_NOT_CONFIGURED_ERROR
static val mutable MAILER_SINK_SMTP_IS_NOT_CONFIGURED_ERROR: string
static val mutable MAILER_SINK_SMTP_IS_NOT_CONFIGURED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MODEL_CLIENT_REQUEST_READ_ERROR Field

StringConsts MODEL_CLIENT_REQUEST_READ_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MODEL_CLIENT_REQUEST_READ_ERROR
public const string MODEL_CLIENT_REQUEST_READ_ERROR
Public Const MODEL_CLIENT_REQUEST_READ_ERROR As String
Public Const MODEL_CLIENT_REQUEST_READ_ERROR As String
public:
literal String^ MODEL_CLIENT_REQUEST_READ_ERROR
public:
literal String^ MODEL_CLIENT_REQUEST_READ_ERROR
static val mutable MODEL_CLIENT_REQUEST_READ_ERROR: string
static val mutable MODEL_CLIENT_REQUEST_READ_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MODEL_FIELD_NOT_FOUND_ERROR Field

StringConsts MODEL_FIELD_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MODEL_FIELD_NOT_FOUND_ERROR
public const string MODEL_FIELD_NOT_FOUND_ERROR
Public Const MODEL_FIELD_NOT_FOUND_ERROR As String
Public Const MODEL_FIELD_NOT_FOUND_ERROR As String
public:
literal String^ MODEL_FIELD_NOT_FOUND_ERROR
public:
literal String^ MODEL_FIELD_NOT_FOUND_ERROR
static val mutable MODEL_FIELD_NOT_FOUND_ERROR: string
static val mutable MODEL_FIELD_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MODEL_METHOD_NOT_FOUND_ERROR Field

StringConsts MODEL_METHOD_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MODEL_METHOD_NOT_FOUND_ERROR
public const string MODEL_METHOD_NOT_FOUND_ERROR
Public Const MODEL_METHOD_NOT_FOUND_ERROR As String
Public Const MODEL_METHOD_NOT_FOUND_ERROR As String
public:
literal String^ MODEL_METHOD_NOT_FOUND_ERROR
public:
literal String^ MODEL_METHOD_NOT_FOUND_ERROR
static val mutable MODEL_METHOD_NOT_FOUND_ERROR: string
static val mutable MODEL_METHOD_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MODEL_NOT_FOUND_ERROR Field

StringConsts MODEL_NOT_FOUND_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MODEL_NOT_FOUND_ERROR
public const string MODEL_NOT_FOUND_ERROR
Public Const MODEL_NOT_FOUND_ERROR As String
Public Const MODEL_NOT_FOUND_ERROR As String
public:
literal String^ MODEL_NOT_FOUND_ERROR
public:
literal String^ MODEL_NOT_FOUND_ERROR
static val mutable MODEL_NOT_FOUND_ERROR: string
static val mutable MODEL_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MODEL_PROTOCOL_ERROR Field

StringConsts MODEL_PROTOCOL_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MODEL_PROTOCOL_ERROR
public const string MODEL_PROTOCOL_ERROR
Public Const MODEL_PROTOCOL_ERROR As String
Public Const MODEL_PROTOCOL_ERROR As String
public:
literal String^ MODEL_PROTOCOL_ERROR
public:
literal String^ MODEL_PROTOCOL_ERROR
static val mutable MODEL_PROTOCOL_ERROR: string
static val mutable MODEL_PROTOCOL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MODEL_ROUTE_HANDLER_ERROR Field

StringConsts MODEL_ROUTE_HANDLER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MODEL_ROUTE_HANDLER_ERROR
public const string MODEL_ROUTE_HANDLER_ERROR
Public Const MODEL_ROUTE_HANDLER_ERROR As String
Public Const MODEL_ROUTE_HANDLER_ERROR As String
public:
literal String^ MODEL_ROUTE_HANDLER_ERROR
public:
literal String^ MODEL_ROUTE_HANDLER_ERROR
static val mutable MODEL_ROUTE_HANDLER_ERROR: string
static val mutable MODEL_ROUTE_HANDLER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_BOUNDARY_COULDNT_BE_SHORTER_3_ERROR Field

StringConsts MULTIPART_BOUNDARY_COULDNT_BE_SHORTER_3_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_BOUNDARY_COULDNT_BE_SHORTER_3_ERROR
public const string MULTIPART_BOUNDARY_COULDNT_BE_SHORTER_3_ERROR
Public Const MULTIPART_BOUNDARY_COULDNT_BE_SHORTER_3_ERROR As String
Public Const MULTIPART_BOUNDARY_COULDNT_BE_SHORTER_3_ERROR As String
public:
literal String^ MULTIPART_BOUNDARY_COULDNT_BE_SHORTER_3_ERROR
public:
literal String^ MULTIPART_BOUNDARY_COULDNT_BE_SHORTER_3_ERROR
static val mutable MULTIPART_BOUNDARY_COULDNT_BE_SHORTER_3_ERROR: string
static val mutable MULTIPART_BOUNDARY_COULDNT_BE_SHORTER_3_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_BOUNDARY_IS_TOO_SHORT Field

StringConsts MULTIPART_BOUNDARY_IS_TOO_SHORT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_BOUNDARY_IS_TOO_SHORT
public const string MULTIPART_BOUNDARY_IS_TOO_SHORT
Public Const MULTIPART_BOUNDARY_IS_TOO_SHORT As String
Public Const MULTIPART_BOUNDARY_IS_TOO_SHORT As String
public:
literal String^ MULTIPART_BOUNDARY_IS_TOO_SHORT
public:
literal String^ MULTIPART_BOUNDARY_IS_TOO_SHORT
static val mutable MULTIPART_BOUNDARY_IS_TOO_SHORT: string
static val mutable MULTIPART_BOUNDARY_IS_TOO_SHORT: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_BOUNDARY_MISMATCH_ERROR Field

StringConsts MULTIPART_BOUNDARY_MISMATCH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_BOUNDARY_MISMATCH_ERROR
public const string MULTIPART_BOUNDARY_MISMATCH_ERROR
Public Const MULTIPART_BOUNDARY_MISMATCH_ERROR As String
Public Const MULTIPART_BOUNDARY_MISMATCH_ERROR As String
public:
literal String^ MULTIPART_BOUNDARY_MISMATCH_ERROR
public:
literal String^ MULTIPART_BOUNDARY_MISMATCH_ERROR
static val mutable MULTIPART_BOUNDARY_MISMATCH_ERROR: string
static val mutable MULTIPART_BOUNDARY_MISMATCH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_BOUNDARY_SHOULD_START_WITH_HYPHENS Field

StringConsts MULTIPART_BOUNDARY_SHOULD_START_WITH_HYPHENS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_BOUNDARY_SHOULD_START_WITH_HYPHENS
public const string MULTIPART_BOUNDARY_SHOULD_START_WITH_HYPHENS
Public Const MULTIPART_BOUNDARY_SHOULD_START_WITH_HYPHENS As String
Public Const MULTIPART_BOUNDARY_SHOULD_START_WITH_HYPHENS As String
public:
literal String^ MULTIPART_BOUNDARY_SHOULD_START_WITH_HYPHENS
public:
literal String^ MULTIPART_BOUNDARY_SHOULD_START_WITH_HYPHENS
static val mutable MULTIPART_BOUNDARY_SHOULD_START_WITH_HYPHENS: string
static val mutable MULTIPART_BOUNDARY_SHOULD_START_WITH_HYPHENS: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_DOUBLE_EOL_ISNT_FOUND_AFTER_HEADER_ERROR Field

StringConsts MULTIPART_DOUBLE_EOL_ISNT_FOUND_AFTER_HEADER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_DOUBLE_EOL_ISNT_FOUND_AFTER_HEADER_ERROR
public const string MULTIPART_DOUBLE_EOL_ISNT_FOUND_AFTER_HEADER_ERROR
Public Const MULTIPART_DOUBLE_EOL_ISNT_FOUND_AFTER_HEADER_ERROR As String
Public Const MULTIPART_DOUBLE_EOL_ISNT_FOUND_AFTER_HEADER_ERROR As String
public:
literal String^ MULTIPART_DOUBLE_EOL_ISNT_FOUND_AFTER_HEADER_ERROR
public:
literal String^ MULTIPART_DOUBLE_EOL_ISNT_FOUND_AFTER_HEADER_ERROR
static val mutable MULTIPART_DOUBLE_EOL_ISNT_FOUND_AFTER_HEADER_ERROR: string
static val mutable MULTIPART_DOUBLE_EOL_ISNT_FOUND_AFTER_HEADER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_NO_LF_NOR_CRLF_ISNT_FOUND_ERROR Field

StringConsts MULTIPART_NO_LF_NOR_CRLF_ISNT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_NO_LF_NOR_CRLF_ISNT_FOUND_ERROR
public const string MULTIPART_NO_LF_NOR_CRLF_ISNT_FOUND_ERROR
Public Const MULTIPART_NO_LF_NOR_CRLF_ISNT_FOUND_ERROR As String
Public Const MULTIPART_NO_LF_NOR_CRLF_ISNT_FOUND_ERROR As String
public:
literal String^ MULTIPART_NO_LF_NOR_CRLF_ISNT_FOUND_ERROR
public:
literal String^ MULTIPART_NO_LF_NOR_CRLF_ISNT_FOUND_ERROR
static val mutable MULTIPART_NO_LF_NOR_CRLF_ISNT_FOUND_ERROR: string
static val mutable MULTIPART_NO_LF_NOR_CRLF_ISNT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_PART_COULDNT_BE_EMPTY_ERROR Field

StringConsts MULTIPART_PART_COULDNT_BE_EMPTY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_PART_COULDNT_BE_EMPTY_ERROR
public const string MULTIPART_PART_COULDNT_BE_EMPTY_ERROR
Public Const MULTIPART_PART_COULDNT_BE_EMPTY_ERROR As String
Public Const MULTIPART_PART_COULDNT_BE_EMPTY_ERROR As String
public:
literal String^ MULTIPART_PART_COULDNT_BE_EMPTY_ERROR
public:
literal String^ MULTIPART_PART_COULDNT_BE_EMPTY_ERROR
static val mutable MULTIPART_PART_COULDNT_BE_EMPTY_ERROR: string
static val mutable MULTIPART_PART_COULDNT_BE_EMPTY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_PART_EMPTY_NAME_ERROR Field

StringConsts MULTIPART_PART_EMPTY_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_PART_EMPTY_NAME_ERROR
public const string MULTIPART_PART_EMPTY_NAME_ERROR
Public Const MULTIPART_PART_EMPTY_NAME_ERROR As String
Public Const MULTIPART_PART_EMPTY_NAME_ERROR As String
public:
literal String^ MULTIPART_PART_EMPTY_NAME_ERROR
public:
literal String^ MULTIPART_PART_EMPTY_NAME_ERROR
static val mutable MULTIPART_PART_EMPTY_NAME_ERROR: string
static val mutable MULTIPART_PART_EMPTY_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_PART_IS_ALREADY_REGISTERED_ERROR Field

StringConsts MULTIPART_PART_IS_ALREADY_REGISTERED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_PART_IS_ALREADY_REGISTERED_ERROR
public const string MULTIPART_PART_IS_ALREADY_REGISTERED_ERROR
Public Const MULTIPART_PART_IS_ALREADY_REGISTERED_ERROR As String
Public Const MULTIPART_PART_IS_ALREADY_REGISTERED_ERROR As String
public:
literal String^ MULTIPART_PART_IS_ALREADY_REGISTERED_ERROR
public:
literal String^ MULTIPART_PART_IS_ALREADY_REGISTERED_ERROR
static val mutable MULTIPART_PART_IS_ALREADY_REGISTERED_ERROR: string
static val mutable MULTIPART_PART_IS_ALREADY_REGISTERED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_PART_MUST_BE_ENDED_WITH_EOL_ERROR Field

StringConsts MULTIPART_PART_MUST_BE_ENDED_WITH_EOL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_PART_MUST_BE_ENDED_WITH_EOL_ERROR
public const string MULTIPART_PART_MUST_BE_ENDED_WITH_EOL_ERROR
Public Const MULTIPART_PART_MUST_BE_ENDED_WITH_EOL_ERROR As String
Public Const MULTIPART_PART_MUST_BE_ENDED_WITH_EOL_ERROR As String
public:
literal String^ MULTIPART_PART_MUST_BE_ENDED_WITH_EOL_ERROR
public:
literal String^ MULTIPART_PART_MUST_BE_ENDED_WITH_EOL_ERROR
static val mutable MULTIPART_PART_MUST_BE_ENDED_WITH_EOL_ERROR: string
static val mutable MULTIPART_PART_MUST_BE_ENDED_WITH_EOL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_PART_SEGMENT_ISNT_TERMINATED_CORRECTLY_ERROR Field

StringConsts MULTIPART_PART_SEGMENT_ISNT_TERMINATED_CORRECTLY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_PART_SEGMENT_ISNT_TERMINATED_CORRECTLY_ERROR
public const string MULTIPART_PART_SEGMENT_ISNT_TERMINATED_CORRECTLY_ERROR
Public Const MULTIPART_PART_SEGMENT_ISNT_TERMINATED_CORRECTLY_ERROR As String
Public Const MULTIPART_PART_SEGMENT_ISNT_TERMINATED_CORRECTLY_ERROR As String
public:
literal String^ MULTIPART_PART_SEGMENT_ISNT_TERMINATED_CORRECTLY_ERROR
public:
literal String^ MULTIPART_PART_SEGMENT_ISNT_TERMINATED_CORRECTLY_ERROR
static val mutable MULTIPART_PART_SEGMENT_ISNT_TERMINATED_CORRECTLY_ERROR: string
static val mutable MULTIPART_PART_SEGMENT_ISNT_TERMINATED_CORRECTLY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_PARTS_COULDNT_BE_EMPTY_ERROR Field

StringConsts MULTIPART_PARTS_COULDNT_BE_EMPTY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_PARTS_COULDNT_BE_EMPTY_ERROR
public const string MULTIPART_PARTS_COULDNT_BE_EMPTY_ERROR
Public Const MULTIPART_PARTS_COULDNT_BE_EMPTY_ERROR As String
Public Const MULTIPART_PARTS_COULDNT_BE_EMPTY_ERROR As String
public:
literal String^ MULTIPART_PARTS_COULDNT_BE_EMPTY_ERROR
public:
literal String^ MULTIPART_PARTS_COULDNT_BE_EMPTY_ERROR
static val mutable MULTIPART_PARTS_COULDNT_BE_EMPTY_ERROR: string
static val mutable MULTIPART_PARTS_COULDNT_BE_EMPTY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_SPECIFIED_BOUNDARY_ISNT_FOUND_ERROR Field

StringConsts MULTIPART_SPECIFIED_BOUNDARY_ISNT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_SPECIFIED_BOUNDARY_ISNT_FOUND_ERROR
public const string MULTIPART_SPECIFIED_BOUNDARY_ISNT_FOUND_ERROR
Public Const MULTIPART_SPECIFIED_BOUNDARY_ISNT_FOUND_ERROR As String
Public Const MULTIPART_SPECIFIED_BOUNDARY_ISNT_FOUND_ERROR As String
public:
literal String^ MULTIPART_SPECIFIED_BOUNDARY_ISNT_FOUND_ERROR
public:
literal String^ MULTIPART_SPECIFIED_BOUNDARY_ISNT_FOUND_ERROR
static val mutable MULTIPART_SPECIFIED_BOUNDARY_ISNT_FOUND_ERROR: string
static val mutable MULTIPART_SPECIFIED_BOUNDARY_ISNT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_READ_ERROR Field

StringConsts MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_READ_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_READ_ERROR
public const string MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_READ_ERROR
Public Const MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_READ_ERROR As String
Public Const MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_READ_ERROR As String
public:
literal String^ MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_READ_ERROR
public:
literal String^ MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_READ_ERROR
static val mutable MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_READ_ERROR: string
static val mutable MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_READ_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_WRITE_ERROR Field

StringConsts MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_WRITE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_WRITE_ERROR
public const string MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_WRITE_ERROR
Public Const MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_WRITE_ERROR As String
Public Const MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_WRITE_ERROR As String
public:
literal String^ MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_WRITE_ERROR
public:
literal String^ MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_WRITE_ERROR
static val mutable MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_WRITE_ERROR: string
static val mutable MULTIPART_STREAM_NOT_NULL_MUST_SUPPORT_WRITE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.MULTIPART_TERMINATOR_ISNT_FOUND_ERROR Field

StringConsts MULTIPART_TERMINATOR_ISNT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MULTIPART_TERMINATOR_ISNT_FOUND_ERROR
public const string MULTIPART_TERMINATOR_ISNT_FOUND_ERROR
Public Const MULTIPART_TERMINATOR_ISNT_FOUND_ERROR As String
Public Const MULTIPART_TERMINATOR_ISNT_FOUND_ERROR As String
public:
literal String^ MULTIPART_TERMINATOR_ISNT_FOUND_ERROR
public:
literal String^ MULTIPART_TERMINATOR_ISNT_FOUND_ERROR
static val mutable MULTIPART_TERMINATOR_ISNT_FOUND_ERROR: string
static val mutable MULTIPART_TERMINATOR_ISNT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.NAME_KEY Field

StringConsts NAME_KEY Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NAME_KEY
public const string NAME_KEY
Public Const NAME_KEY As String
Public Const NAME_KEY As String
public:
literal String^ NAME_KEY
public:
literal String^ NAME_KEY
static val mutable NAME_KEY: string
static val mutable NAME_KEY: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.NFX_WEB_APP_CONFIGURATION_FILE Field

StringConsts NFX_WEB_APP_CONFIGURATION_FILE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NFX_WEB_APP_CONFIGURATION_FILE
public const string NFX_WEB_APP_CONFIGURATION_FILE
Public Const NFX_WEB_APP_CONFIGURATION_FILE As String
Public Const NFX_WEB_APP_CONFIGURATION_FILE As String
public:
literal String^ NFX_WEB_APP_CONFIGURATION_FILE
public:
literal String^ NFX_WEB_APP_CONFIGURATION_FILE
static val mutable NFX_WEB_APP_CONFIGURATION_FILE: string
static val mutable NFX_WEB_APP_CONFIGURATION_FILE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.NO_RECORD_IN_VOLATILE_STORE_ERROR Field

StringConsts NO_RECORD_IN_VOLATILE_STORE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NO_RECORD_IN_VOLATILE_STORE_ERROR
public const string NO_RECORD_IN_VOLATILE_STORE_ERROR
Public Const NO_RECORD_IN_VOLATILE_STORE_ERROR As String
Public Const NO_RECORD_IN_VOLATILE_STORE_ERROR As String
public:
literal String^ NO_RECORD_IN_VOLATILE_STORE_ERROR
public:
literal String^ NO_RECORD_IN_VOLATILE_STORE_ERROR
static val mutable NO_RECORD_IN_VOLATILE_STORE_ERROR: string
static val mutable NO_RECORD_IN_VOLATILE_STORE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.NO_ROUTE_CONTEXT Field

StringConsts NO_ROUTE_CONTEXT Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NO_ROUTE_CONTEXT
public const string NO_ROUTE_CONTEXT
Public Const NO_ROUTE_CONTEXT As String
Public Const NO_ROUTE_CONTEXT As String
public:
literal String^ NO_ROUTE_CONTEXT
public:
literal String^ NO_ROUTE_CONTEXT
static val mutable NO_ROUTE_CONTEXT: string
static val mutable NO_ROUTE_CONTEXT: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.NOT_FOUND_ERROR Field

StringConsts NOT_FOUND_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NOT_FOUND_ERROR
public const string NOT_FOUND_ERROR
Public Const NOT_FOUND_ERROR As String
Public Const NOT_FOUND_ERROR As String
public:
literal String^ NOT_FOUND_ERROR
public:
literal String^ NOT_FOUND_ERROR
static val mutable NOT_FOUND_ERROR: string
static val mutable NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.OPERATION_NOT_SUPPORTED_ERROR Field

StringConsts OPERATION_NOT_SUPPORTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string OPERATION_NOT_SUPPORTED_ERROR
public const string OPERATION_NOT_SUPPORTED_ERROR
Public Const OPERATION_NOT_SUPPORTED_ERROR As String
Public Const OPERATION_NOT_SUPPORTED_ERROR As String
public:
literal String^ OPERATION_NOT_SUPPORTED_ERROR
public:
literal String^ OPERATION_NOT_SUPPORTED_ERROR
static val mutable OPERATION_NOT_SUPPORTED_ERROR: string
static val mutable OPERATION_NOT_SUPPORTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_CANNOT_CAPTURE_CAPTURED_PAYMENT_ERROR Field

StringConsts PAYMENT_CANNOT_CAPTURE_CAPTURED_PAYMENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_CANNOT_CAPTURE_CAPTURED_PAYMENT_ERROR
public const string PAYMENT_CANNOT_CAPTURE_CAPTURED_PAYMENT_ERROR
Public Const PAYMENT_CANNOT_CAPTURE_CAPTURED_PAYMENT_ERROR As String
Public Const PAYMENT_CANNOT_CAPTURE_CAPTURED_PAYMENT_ERROR As String
public:
literal String^ PAYMENT_CANNOT_CAPTURE_CAPTURED_PAYMENT_ERROR
public:
literal String^ PAYMENT_CANNOT_CAPTURE_CAPTURED_PAYMENT_ERROR
static val mutable PAYMENT_CANNOT_CAPTURE_CAPTURED_PAYMENT_ERROR: string
static val mutable PAYMENT_CANNOT_CAPTURE_CAPTURED_PAYMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_CANNOT_CHARGE_PAYMENT_ERROR Field

StringConsts PAYMENT_CANNOT_CHARGE_PAYMENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_CANNOT_CHARGE_PAYMENT_ERROR
public const string PAYMENT_CANNOT_CHARGE_PAYMENT_ERROR
Public Const PAYMENT_CANNOT_CHARGE_PAYMENT_ERROR As String
Public Const PAYMENT_CANNOT_CHARGE_PAYMENT_ERROR As String
public:
literal String^ PAYMENT_CANNOT_CHARGE_PAYMENT_ERROR
public:
literal String^ PAYMENT_CANNOT_CHARGE_PAYMENT_ERROR
static val mutable PAYMENT_CANNOT_CHARGE_PAYMENT_ERROR: string
static val mutable PAYMENT_CANNOT_CHARGE_PAYMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_CANNOT_CREATE_RECIPIENT_ERROR Field

StringConsts PAYMENT_CANNOT_CREATE_RECIPIENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_CANNOT_CREATE_RECIPIENT_ERROR
public const string PAYMENT_CANNOT_CREATE_RECIPIENT_ERROR
Public Const PAYMENT_CANNOT_CREATE_RECIPIENT_ERROR As String
Public Const PAYMENT_CANNOT_CREATE_RECIPIENT_ERROR As String
public:
literal String^ PAYMENT_CANNOT_CREATE_RECIPIENT_ERROR
public:
literal String^ PAYMENT_CANNOT_CREATE_RECIPIENT_ERROR
static val mutable PAYMENT_CANNOT_CREATE_RECIPIENT_ERROR: string
static val mutable PAYMENT_CANNOT_CREATE_RECIPIENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_CANNOT_TRANSFER_ERROR Field

StringConsts PAYMENT_CANNOT_TRANSFER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_CANNOT_TRANSFER_ERROR
public const string PAYMENT_CANNOT_TRANSFER_ERROR
Public Const PAYMENT_CANNOT_TRANSFER_ERROR As String
Public Const PAYMENT_CANNOT_TRANSFER_ERROR As String
public:
literal String^ PAYMENT_CANNOT_TRANSFER_ERROR
public:
literal String^ PAYMENT_CANNOT_TRANSFER_ERROR
static val mutable PAYMENT_CANNOT_TRANSFER_ERROR: string
static val mutable PAYMENT_CANNOT_TRANSFER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_CANNOT_VOID_ERROR Field

StringConsts PAYMENT_CANNOT_VOID_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_CANNOT_VOID_ERROR
public const string PAYMENT_CANNOT_VOID_ERROR
Public Const PAYMENT_CANNOT_VOID_ERROR As String
Public Const PAYMENT_CANNOT_VOID_ERROR As String
public:
literal String^ PAYMENT_CANNOT_VOID_ERROR
public:
literal String^ PAYMENT_CANNOT_VOID_ERROR
static val mutable PAYMENT_CANNOT_VOID_ERROR: string
static val mutable PAYMENT_CANNOT_VOID_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_CAPTURE_CURRENCY_MUST_MATCH_CHARGE_ERROR Field

StringConsts PAYMENT_CAPTURE_CURRENCY_MUST_MATCH_CHARGE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_CAPTURE_CURRENCY_MUST_MATCH_CHARGE_ERROR
public const string PAYMENT_CAPTURE_CURRENCY_MUST_MATCH_CHARGE_ERROR
Public Const PAYMENT_CAPTURE_CURRENCY_MUST_MATCH_CHARGE_ERROR As String
Public Const PAYMENT_CAPTURE_CURRENCY_MUST_MATCH_CHARGE_ERROR As String
public:
literal String^ PAYMENT_CAPTURE_CURRENCY_MUST_MATCH_CHARGE_ERROR
public:
literal String^ PAYMENT_CAPTURE_CURRENCY_MUST_MATCH_CHARGE_ERROR
static val mutable PAYMENT_CAPTURE_CURRENCY_MUST_MATCH_CHARGE_ERROR: string
static val mutable PAYMENT_CAPTURE_CURRENCY_MUST_MATCH_CHARGE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_CURRENCY_CONVERSION_MAPPING_ERROR Field

StringConsts PAYMENT_CURRENCY_CONVERSION_MAPPING_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_CURRENCY_CONVERSION_MAPPING_ERROR
public const string PAYMENT_CURRENCY_CONVERSION_MAPPING_ERROR
Public Const PAYMENT_CURRENCY_CONVERSION_MAPPING_ERROR As String
Public Const PAYMENT_CURRENCY_CONVERSION_MAPPING_ERROR As String
public:
literal String^ PAYMENT_CURRENCY_CONVERSION_MAPPING_ERROR
public:
literal String^ PAYMENT_CURRENCY_CONVERSION_MAPPING_ERROR
static val mutable PAYMENT_CURRENCY_CONVERSION_MAPPING_ERROR: string
static val mutable PAYMENT_CURRENCY_CONVERSION_MAPPING_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_CURRENCY_NOT_SUPPORTED_ERROR Field

StringConsts PAYMENT_CURRENCY_NOT_SUPPORTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_CURRENCY_NOT_SUPPORTED_ERROR
public const string PAYMENT_CURRENCY_NOT_SUPPORTED_ERROR
Public Const PAYMENT_CURRENCY_NOT_SUPPORTED_ERROR As String
Public Const PAYMENT_CURRENCY_NOT_SUPPORTED_ERROR As String
public:
literal String^ PAYMENT_CURRENCY_NOT_SUPPORTED_ERROR
public:
literal String^ PAYMENT_CURRENCY_NOT_SUPPORTED_ERROR
static val mutable PAYMENT_CURRENCY_NOT_SUPPORTED_ERROR: string
static val mutable PAYMENT_CURRENCY_NOT_SUPPORTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_INVALID_ADDR_ERROR Field

StringConsts PAYMENT_INVALID_ADDR_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_INVALID_ADDR_ERROR
public const string PAYMENT_INVALID_ADDR_ERROR
Public Const PAYMENT_INVALID_ADDR_ERROR As String
Public Const PAYMENT_INVALID_ADDR_ERROR As String
public:
literal String^ PAYMENT_INVALID_ADDR_ERROR
public:
literal String^ PAYMENT_INVALID_ADDR_ERROR
static val mutable PAYMENT_INVALID_ADDR_ERROR: string
static val mutable PAYMENT_INVALID_ADDR_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_INVALID_CARD_NUMBER_ERROR Field

StringConsts PAYMENT_INVALID_CARD_NUMBER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_INVALID_CARD_NUMBER_ERROR
public const string PAYMENT_INVALID_CARD_NUMBER_ERROR
Public Const PAYMENT_INVALID_CARD_NUMBER_ERROR As String
Public Const PAYMENT_INVALID_CARD_NUMBER_ERROR As String
public:
literal String^ PAYMENT_INVALID_CARD_NUMBER_ERROR
public:
literal String^ PAYMENT_INVALID_CARD_NUMBER_ERROR
static val mutable PAYMENT_INVALID_CARD_NUMBER_ERROR: string
static val mutable PAYMENT_INVALID_CARD_NUMBER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_INVALID_CUSTOMER_ERROR Field

StringConsts PAYMENT_INVALID_CUSTOMER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_INVALID_CUSTOMER_ERROR
public const string PAYMENT_INVALID_CUSTOMER_ERROR
Public Const PAYMENT_INVALID_CUSTOMER_ERROR As String
Public Const PAYMENT_INVALID_CUSTOMER_ERROR As String
public:
literal String^ PAYMENT_INVALID_CUSTOMER_ERROR
public:
literal String^ PAYMENT_INVALID_CUSTOMER_ERROR
static val mutable PAYMENT_INVALID_CUSTOMER_ERROR: string
static val mutable PAYMENT_INVALID_CUSTOMER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_INVALID_CVC_ERROR Field

StringConsts PAYMENT_INVALID_CVC_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_INVALID_CVC_ERROR
public const string PAYMENT_INVALID_CVC_ERROR
Public Const PAYMENT_INVALID_CVC_ERROR As String
Public Const PAYMENT_INVALID_CVC_ERROR As String
public:
literal String^ PAYMENT_INVALID_CVC_ERROR
public:
literal String^ PAYMENT_INVALID_CVC_ERROR
static val mutable PAYMENT_INVALID_CVC_ERROR: string
static val mutable PAYMENT_INVALID_CVC_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_INVALID_EXPIRATION_DATE_ERROR Field

StringConsts PAYMENT_INVALID_EXPIRATION_DATE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_INVALID_EXPIRATION_DATE_ERROR
public const string PAYMENT_INVALID_EXPIRATION_DATE_ERROR
Public Const PAYMENT_INVALID_EXPIRATION_DATE_ERROR As String
Public Const PAYMENT_INVALID_EXPIRATION_DATE_ERROR As String
public:
literal String^ PAYMENT_INVALID_EXPIRATION_DATE_ERROR
public:
literal String^ PAYMENT_INVALID_EXPIRATION_DATE_ERROR
static val mutable PAYMENT_INVALID_EXPIRATION_DATE_ERROR: string
static val mutable PAYMENT_INVALID_EXPIRATION_DATE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_INVALID_PAYSYSTEM_ERROR Field

StringConsts PAYMENT_INVALID_PAYSYSTEM_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_INVALID_PAYSYSTEM_ERROR
public const string PAYMENT_INVALID_PAYSYSTEM_ERROR
Public Const PAYMENT_INVALID_PAYSYSTEM_ERROR As String
Public Const PAYMENT_INVALID_PAYSYSTEM_ERROR As String
public:
literal String^ PAYMENT_INVALID_PAYSYSTEM_ERROR
public:
literal String^ PAYMENT_INVALID_PAYSYSTEM_ERROR
static val mutable PAYMENT_INVALID_PAYSYSTEM_ERROR: string
static val mutable PAYMENT_INVALID_PAYSYSTEM_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_PAYPAL_200_STATUSCODE Field

StringConsts PAYMENT_PAYPAL_200_STATUSCODE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_PAYPAL_200_STATUSCODE
public const string PAYMENT_PAYPAL_200_STATUSCODE
Public Const PAYMENT_PAYPAL_200_STATUSCODE As String
Public Const PAYMENT_PAYPAL_200_STATUSCODE As String
public:
literal String^ PAYMENT_PAYPAL_200_STATUSCODE
public:
literal String^ PAYMENT_PAYPAL_200_STATUSCODE
static val mutable PAYMENT_PAYPAL_200_STATUSCODE: string
static val mutable PAYMENT_PAYPAL_200_STATUSCODE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_PAYPAL_201_STATUSCODE Field

StringConsts PAYMENT_PAYPAL_201_STATUSCODE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_PAYPAL_201_STATUSCODE
public const string PAYMENT_PAYPAL_201_STATUSCODE
Public Const PAYMENT_PAYPAL_201_STATUSCODE As String
Public Const PAYMENT_PAYPAL_201_STATUSCODE As String
public:
literal String^ PAYMENT_PAYPAL_201_STATUSCODE
public:
literal String^ PAYMENT_PAYPAL_201_STATUSCODE
static val mutable PAYMENT_PAYPAL_201_STATUSCODE: string
static val mutable PAYMENT_PAYPAL_201_STATUSCODE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_PAYPAL_400_STATUSCODE Field

StringConsts PAYMENT_PAYPAL_400_STATUSCODE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_PAYPAL_400_STATUSCODE
public const string PAYMENT_PAYPAL_400_STATUSCODE
Public Const PAYMENT_PAYPAL_400_STATUSCODE As String
Public Const PAYMENT_PAYPAL_400_STATUSCODE As String
public:
literal String^ PAYMENT_PAYPAL_400_STATUSCODE
public:
literal String^ PAYMENT_PAYPAL_400_STATUSCODE
static val mutable PAYMENT_PAYPAL_400_STATUSCODE: string
static val mutable PAYMENT_PAYPAL_400_STATUSCODE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_PAYPAL_401_STATUSCODE Field

StringConsts PAYMENT_PAYPAL_401_STATUSCODE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_PAYPAL_401_STATUSCODE
public const string PAYMENT_PAYPAL_401_STATUSCODE
Public Const PAYMENT_PAYPAL_401_STATUSCODE As String
Public Const PAYMENT_PAYPAL_401_STATUSCODE As String
public:
literal String^ PAYMENT_PAYPAL_401_STATUSCODE
public:
literal String^ PAYMENT_PAYPAL_401_STATUSCODE
static val mutable PAYMENT_PAYPAL_401_STATUSCODE: string
static val mutable PAYMENT_PAYPAL_401_STATUSCODE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_PAYPAL_402_STATUSCODE Field

StringConsts PAYMENT_PAYPAL_402_STATUSCODE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_PAYPAL_402_STATUSCODE
public const string PAYMENT_PAYPAL_402_STATUSCODE
Public Const PAYMENT_PAYPAL_402_STATUSCODE As String
Public Const PAYMENT_PAYPAL_402_STATUSCODE As String
public:
literal String^ PAYMENT_PAYPAL_402_STATUSCODE
public:
literal String^ PAYMENT_PAYPAL_402_STATUSCODE
static val mutable PAYMENT_PAYPAL_402_STATUSCODE: string
static val mutable PAYMENT_PAYPAL_402_STATUSCODE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_PAYPAL_403_STATUSCODE Field

StringConsts PAYMENT_PAYPAL_403_STATUSCODE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_PAYPAL_403_STATUSCODE
public const string PAYMENT_PAYPAL_403_STATUSCODE
Public Const PAYMENT_PAYPAL_403_STATUSCODE As String
Public Const PAYMENT_PAYPAL_403_STATUSCODE As String
public:
literal String^ PAYMENT_PAYPAL_403_STATUSCODE
public:
literal String^ PAYMENT_PAYPAL_403_STATUSCODE
static val mutable PAYMENT_PAYPAL_403_STATUSCODE: string
static val mutable PAYMENT_PAYPAL_403_STATUSCODE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_PAYPAL_404_STATUSCODE Field

StringConsts PAYMENT_PAYPAL_404_STATUSCODE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_PAYPAL_404_STATUSCODE
public const string PAYMENT_PAYPAL_404_STATUSCODE
Public Const PAYMENT_PAYPAL_404_STATUSCODE As String
Public Const PAYMENT_PAYPAL_404_STATUSCODE As String
public:
literal String^ PAYMENT_PAYPAL_404_STATUSCODE
public:
literal String^ PAYMENT_PAYPAL_404_STATUSCODE
static val mutable PAYMENT_PAYPAL_404_STATUSCODE: string
static val mutable PAYMENT_PAYPAL_404_STATUSCODE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_PAYPAL_405_STATUSCODE Field

StringConsts PAYMENT_PAYPAL_405_STATUSCODE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_PAYPAL_405_STATUSCODE
public const string PAYMENT_PAYPAL_405_STATUSCODE
Public Const PAYMENT_PAYPAL_405_STATUSCODE As String
Public Const PAYMENT_PAYPAL_405_STATUSCODE As String
public:
literal String^ PAYMENT_PAYPAL_405_STATUSCODE
public:
literal String^ PAYMENT_PAYPAL_405_STATUSCODE
static val mutable PAYMENT_PAYPAL_405_STATUSCODE: string
static val mutable PAYMENT_PAYPAL_405_STATUSCODE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_PAYPAL_415_STATUSCODE Field

StringConsts PAYMENT_PAYPAL_415_STATUSCODE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_PAYPAL_415_STATUSCODE
public const string PAYMENT_PAYPAL_415_STATUSCODE
Public Const PAYMENT_PAYPAL_415_STATUSCODE As String
Public Const PAYMENT_PAYPAL_415_STATUSCODE As String
public:
literal String^ PAYMENT_PAYPAL_415_STATUSCODE
public:
literal String^ PAYMENT_PAYPAL_415_STATUSCODE
static val mutable PAYMENT_PAYPAL_415_STATUSCODE: string
static val mutable PAYMENT_PAYPAL_415_STATUSCODE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_PAYPAL_422_STATUSCODE Field

StringConsts PAYMENT_PAYPAL_422_STATUSCODE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_PAYPAL_422_STATUSCODE
public const string PAYMENT_PAYPAL_422_STATUSCODE
Public Const PAYMENT_PAYPAL_422_STATUSCODE As String
Public Const PAYMENT_PAYPAL_422_STATUSCODE As String
public:
literal String^ PAYMENT_PAYPAL_422_STATUSCODE
public:
literal String^ PAYMENT_PAYPAL_422_STATUSCODE
static val mutable PAYMENT_PAYPAL_422_STATUSCODE: string
static val mutable PAYMENT_PAYPAL_422_STATUSCODE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_PAYPAL_429_STATUSCODE Field

StringConsts PAYMENT_PAYPAL_429_STATUSCODE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_PAYPAL_429_STATUSCODE
public const string PAYMENT_PAYPAL_429_STATUSCODE
Public Const PAYMENT_PAYPAL_429_STATUSCODE As String
Public Const PAYMENT_PAYPAL_429_STATUSCODE As String
public:
literal String^ PAYMENT_PAYPAL_429_STATUSCODE
public:
literal String^ PAYMENT_PAYPAL_429_STATUSCODE
static val mutable PAYMENT_PAYPAL_429_STATUSCODE: string
static val mutable PAYMENT_PAYPAL_429_STATUSCODE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_PAYPAL_50x_STATUSCODE Field

StringConsts PAYMENT_PAYPAL_50x_STATUSCODE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_PAYPAL_50x_STATUSCODE
public const string PAYMENT_PAYPAL_50x_STATUSCODE
Public Const PAYMENT_PAYPAL_50x_STATUSCODE As String
Public Const PAYMENT_PAYPAL_50x_STATUSCODE As String
public:
literal String^ PAYMENT_PAYPAL_50x_STATUSCODE
public:
literal String^ PAYMENT_PAYPAL_50x_STATUSCODE
static val mutable PAYMENT_PAYPAL_50x_STATUSCODE: string
static val mutable PAYMENT_PAYPAL_50x_STATUSCODE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_PAYPAL_UNKNOWN_STATUSCODE Field

StringConsts PAYMENT_PAYPAL_UNKNOWN_STATUSCODE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_PAYPAL_UNKNOWN_STATUSCODE
public const string PAYMENT_PAYPAL_UNKNOWN_STATUSCODE
Public Const PAYMENT_PAYPAL_UNKNOWN_STATUSCODE As String
Public Const PAYMENT_PAYPAL_UNKNOWN_STATUSCODE As String
public:
literal String^ PAYMENT_PAYPAL_UNKNOWN_STATUSCODE
public:
literal String^ PAYMENT_PAYPAL_UNKNOWN_STATUSCODE
static val mutable PAYMENT_PAYPAL_UNKNOWN_STATUSCODE: string
static val mutable PAYMENT_PAYPAL_UNKNOWN_STATUSCODE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_REFUND_CANNOT_BE_REFUNDED_ERROR Field

StringConsts PAYMENT_REFUND_CANNOT_BE_REFUNDED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_REFUND_CANNOT_BE_REFUNDED_ERROR
public const string PAYMENT_REFUND_CANNOT_BE_REFUNDED_ERROR
Public Const PAYMENT_REFUND_CANNOT_BE_REFUNDED_ERROR As String
Public Const PAYMENT_REFUND_CANNOT_BE_REFUNDED_ERROR As String
public:
literal String^ PAYMENT_REFUND_CANNOT_BE_REFUNDED_ERROR
public:
literal String^ PAYMENT_REFUND_CANNOT_BE_REFUNDED_ERROR
static val mutable PAYMENT_REFUND_CANNOT_BE_REFUNDED_ERROR: string
static val mutable PAYMENT_REFUND_CANNOT_BE_REFUNDED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_REFUND_CURRENCY_MUST_MATCH_CHARGE_ERROR Field

StringConsts PAYMENT_REFUND_CURRENCY_MUST_MATCH_CHARGE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_REFUND_CURRENCY_MUST_MATCH_CHARGE_ERROR
public const string PAYMENT_REFUND_CURRENCY_MUST_MATCH_CHARGE_ERROR
Public Const PAYMENT_REFUND_CURRENCY_MUST_MATCH_CHARGE_ERROR As String
Public Const PAYMENT_REFUND_CURRENCY_MUST_MATCH_CHARGE_ERROR As String
public:
literal String^ PAYMENT_REFUND_CURRENCY_MUST_MATCH_CHARGE_ERROR
public:
literal String^ PAYMENT_REFUND_CURRENCY_MUST_MATCH_CHARGE_ERROR
static val mutable PAYMENT_REFUND_CURRENCY_MUST_MATCH_CHARGE_ERROR: string
static val mutable PAYMENT_REFUND_CURRENCY_MUST_MATCH_CHARGE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_REFUND_EXCEEDS_CHARGE_ERROR Field

StringConsts PAYMENT_REFUND_EXCEEDS_CHARGE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_REFUND_EXCEEDS_CHARGE_ERROR
public const string PAYMENT_REFUND_EXCEEDS_CHARGE_ERROR
Public Const PAYMENT_REFUND_EXCEEDS_CHARGE_ERROR As String
Public Const PAYMENT_REFUND_EXCEEDS_CHARGE_ERROR As String
public:
literal String^ PAYMENT_REFUND_EXCEEDS_CHARGE_ERROR
public:
literal String^ PAYMENT_REFUND_EXCEEDS_CHARGE_ERROR
static val mutable PAYMENT_REFUND_EXCEEDS_CHARGE_ERROR: string
static val mutable PAYMENT_REFUND_EXCEEDS_CHARGE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_STRIPE_400_ERROR Field

StringConsts PAYMENT_STRIPE_400_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_STRIPE_400_ERROR
public const string PAYMENT_STRIPE_400_ERROR
Public Const PAYMENT_STRIPE_400_ERROR As String
Public Const PAYMENT_STRIPE_400_ERROR As String
public:
literal String^ PAYMENT_STRIPE_400_ERROR
public:
literal String^ PAYMENT_STRIPE_400_ERROR
static val mutable PAYMENT_STRIPE_400_ERROR: string
static val mutable PAYMENT_STRIPE_400_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_STRIPE_401_ERROR Field

StringConsts PAYMENT_STRIPE_401_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_STRIPE_401_ERROR
public const string PAYMENT_STRIPE_401_ERROR
Public Const PAYMENT_STRIPE_401_ERROR As String
Public Const PAYMENT_STRIPE_401_ERROR As String
public:
literal String^ PAYMENT_STRIPE_401_ERROR
public:
literal String^ PAYMENT_STRIPE_401_ERROR
static val mutable PAYMENT_STRIPE_401_ERROR: string
static val mutable PAYMENT_STRIPE_401_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_STRIPE_402_ERROR Field

StringConsts PAYMENT_STRIPE_402_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_STRIPE_402_ERROR
public const string PAYMENT_STRIPE_402_ERROR
Public Const PAYMENT_STRIPE_402_ERROR As String
Public Const PAYMENT_STRIPE_402_ERROR As String
public:
literal String^ PAYMENT_STRIPE_402_ERROR
public:
literal String^ PAYMENT_STRIPE_402_ERROR
static val mutable PAYMENT_STRIPE_402_ERROR: string
static val mutable PAYMENT_STRIPE_402_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_STRIPE_404_ERROR Field

StringConsts PAYMENT_STRIPE_404_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_STRIPE_404_ERROR
public const string PAYMENT_STRIPE_404_ERROR
Public Const PAYMENT_STRIPE_404_ERROR As String
Public Const PAYMENT_STRIPE_404_ERROR As String
public:
literal String^ PAYMENT_STRIPE_404_ERROR
public:
literal String^ PAYMENT_STRIPE_404_ERROR
static val mutable PAYMENT_STRIPE_404_ERROR: string
static val mutable PAYMENT_STRIPE_404_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_STRIPE_50X_ERROR Field

StringConsts PAYMENT_STRIPE_50X_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_STRIPE_50X_ERROR
public const string PAYMENT_STRIPE_50X_ERROR
Public Const PAYMENT_STRIPE_50X_ERROR As String
Public Const PAYMENT_STRIPE_50X_ERROR As String
public:
literal String^ PAYMENT_STRIPE_50X_ERROR
public:
literal String^ PAYMENT_STRIPE_50X_ERROR
static val mutable PAYMENT_STRIPE_50X_ERROR: string
static val mutable PAYMENT_STRIPE_50X_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_STRIPE_ERR_MSG_ERROR Field

StringConsts PAYMENT_STRIPE_ERR_MSG_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_STRIPE_ERR_MSG_ERROR
public const string PAYMENT_STRIPE_ERR_MSG_ERROR
Public Const PAYMENT_STRIPE_ERR_MSG_ERROR As String
Public Const PAYMENT_STRIPE_ERR_MSG_ERROR As String
public:
literal String^ PAYMENT_STRIPE_ERR_MSG_ERROR
public:
literal String^ PAYMENT_STRIPE_ERR_MSG_ERROR
static val mutable PAYMENT_STRIPE_ERR_MSG_ERROR: string
static val mutable PAYMENT_STRIPE_ERR_MSG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_SYSTEM_DUPLICATE_NAME_ERROR Field

StringConsts PAYMENT_SYSTEM_DUPLICATE_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_SYSTEM_DUPLICATE_NAME_ERROR
public const string PAYMENT_SYSTEM_DUPLICATE_NAME_ERROR
Public Const PAYMENT_SYSTEM_DUPLICATE_NAME_ERROR As String
Public Const PAYMENT_SYSTEM_DUPLICATE_NAME_ERROR As String
public:
literal String^ PAYMENT_SYSTEM_DUPLICATE_NAME_ERROR
public:
literal String^ PAYMENT_SYSTEM_DUPLICATE_NAME_ERROR
static val mutable PAYMENT_SYSTEM_DUPLICATE_NAME_ERROR: string
static val mutable PAYMENT_SYSTEM_DUPLICATE_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_SYSTEM_HOST_NULL_ERROR Field

StringConsts PAYMENT_SYSTEM_HOST_NULL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_SYSTEM_HOST_NULL_ERROR
public const string PAYMENT_SYSTEM_HOST_NULL_ERROR
Public Const PAYMENT_SYSTEM_HOST_NULL_ERROR As String
Public Const PAYMENT_SYSTEM_HOST_NULL_ERROR As String
public:
literal String^ PAYMENT_SYSTEM_HOST_NULL_ERROR
public:
literal String^ PAYMENT_SYSTEM_HOST_NULL_ERROR
static val mutable PAYMENT_SYSTEM_HOST_NULL_ERROR: string
static val mutable PAYMENT_SYSTEM_HOST_NULL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYMENT_UNKNOWN_ACCOUNT_ERROR Field

StringConsts PAYMENT_UNKNOWN_ACCOUNT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYMENT_UNKNOWN_ACCOUNT_ERROR
public const string PAYMENT_UNKNOWN_ACCOUNT_ERROR
Public Const PAYMENT_UNKNOWN_ACCOUNT_ERROR As String
Public Const PAYMENT_UNKNOWN_ACCOUNT_ERROR As String
public:
literal String^ PAYMENT_UNKNOWN_ACCOUNT_ERROR
public:
literal String^ PAYMENT_UNKNOWN_ACCOUNT_ERROR
static val mutable PAYMENT_UNKNOWN_ACCOUNT_ERROR: string
static val mutable PAYMENT_UNKNOWN_ACCOUNT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYPAL_GENERATE_OAUTH_ERROR_MESSAGE Field

StringConsts PAYPAL_GENERATE_OAUTH_ERROR_MESSAGE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYPAL_GENERATE_OAUTH_ERROR_MESSAGE
public const string PAYPAL_GENERATE_OAUTH_ERROR_MESSAGE
Public Const PAYPAL_GENERATE_OAUTH_ERROR_MESSAGE As String
Public Const PAYPAL_GENERATE_OAUTH_ERROR_MESSAGE As String
public:
literal String^ PAYPAL_GENERATE_OAUTH_ERROR_MESSAGE
public:
literal String^ PAYPAL_GENERATE_OAUTH_ERROR_MESSAGE
static val mutable PAYPAL_GENERATE_OAUTH_ERROR_MESSAGE: string
static val mutable PAYPAL_GENERATE_OAUTH_ERROR_MESSAGE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYPAL_PAYOUT_ERROR Field

StringConsts PAYPAL_PAYOUT_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYPAL_PAYOUT_ERROR
public const string PAYPAL_PAYOUT_ERROR
Public Const PAYPAL_PAYOUT_ERROR As String
Public Const PAYPAL_PAYOUT_ERROR As String
public:
literal String^ PAYPAL_PAYOUT_ERROR
public:
literal String^ PAYPAL_PAYOUT_ERROR
static val mutable PAYPAL_PAYOUT_ERROR: string
static val mutable PAYPAL_PAYOUT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYPAL_PAYOUT_ITEM_CANCEL_ERROR_MESSAGE Field

StringConsts PAYPAL_PAYOUT_ITEM_CANCEL_ERROR_MESSAGE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYPAL_PAYOUT_ITEM_CANCEL_ERROR_MESSAGE
public const string PAYPAL_PAYOUT_ITEM_CANCEL_ERROR_MESSAGE
Public Const PAYPAL_PAYOUT_ITEM_CANCEL_ERROR_MESSAGE As String
Public Const PAYPAL_PAYOUT_ITEM_CANCEL_ERROR_MESSAGE As String
public:
literal String^ PAYPAL_PAYOUT_ITEM_CANCEL_ERROR_MESSAGE
public:
literal String^ PAYPAL_PAYOUT_ITEM_CANCEL_ERROR_MESSAGE
static val mutable PAYPAL_PAYOUT_ITEM_CANCEL_ERROR_MESSAGE: string
static val mutable PAYPAL_PAYOUT_ITEM_CANCEL_ERROR_MESSAGE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYPAL_PAYOUT_ITEM_FETCH_ERROR_MESSAGE Field

StringConsts PAYPAL_PAYOUT_ITEM_FETCH_ERROR_MESSAGE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYPAL_PAYOUT_ITEM_FETCH_ERROR_MESSAGE
public const string PAYPAL_PAYOUT_ITEM_FETCH_ERROR_MESSAGE
Public Const PAYPAL_PAYOUT_ITEM_FETCH_ERROR_MESSAGE As String
Public Const PAYPAL_PAYOUT_ITEM_FETCH_ERROR_MESSAGE As String
public:
literal String^ PAYPAL_PAYOUT_ITEM_FETCH_ERROR_MESSAGE
public:
literal String^ PAYPAL_PAYOUT_ITEM_FETCH_ERROR_MESSAGE
static val mutable PAYPAL_PAYOUT_ITEM_FETCH_ERROR_MESSAGE: string
static val mutable PAYPAL_PAYOUT_ITEM_FETCH_ERROR_MESSAGE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYPAL_PAYOUT_NOT_SUCCEEDED_MESSAGE Field

StringConsts PAYPAL_PAYOUT_NOT_SUCCEEDED_MESSAGE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYPAL_PAYOUT_NOT_SUCCEEDED_MESSAGE
public const string PAYPAL_PAYOUT_NOT_SUCCEEDED_MESSAGE
Public Const PAYPAL_PAYOUT_NOT_SUCCEEDED_MESSAGE As String
Public Const PAYPAL_PAYOUT_NOT_SUCCEEDED_MESSAGE As String
public:
literal String^ PAYPAL_PAYOUT_NOT_SUCCEEDED_MESSAGE
public:
literal String^ PAYPAL_PAYOUT_NOT_SUCCEEDED_MESSAGE
static val mutable PAYPAL_PAYOUT_NOT_SUCCEEDED_MESSAGE: string
static val mutable PAYPAL_PAYOUT_NOT_SUCCEEDED_MESSAGE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYPAL_PAYOUTS_CREATE_ERROR_MESSAGE Field

StringConsts PAYPAL_PAYOUTS_CREATE_ERROR_MESSAGE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYPAL_PAYOUTS_CREATE_ERROR_MESSAGE
public const string PAYPAL_PAYOUTS_CREATE_ERROR_MESSAGE
Public Const PAYPAL_PAYOUTS_CREATE_ERROR_MESSAGE As String
Public Const PAYPAL_PAYOUTS_CREATE_ERROR_MESSAGE As String
public:
literal String^ PAYPAL_PAYOUTS_CREATE_ERROR_MESSAGE
public:
literal String^ PAYPAL_PAYOUTS_CREATE_ERROR_MESSAGE
static val mutable PAYPAL_PAYOUTS_CREATE_ERROR_MESSAGE: string
static val mutable PAYPAL_PAYOUTS_CREATE_ERROR_MESSAGE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYPAL_PAYOUTS_FETCH_ERROR_MESSAGE Field

StringConsts PAYPAL_PAYOUTS_FETCH_ERROR_MESSAGE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYPAL_PAYOUTS_FETCH_ERROR_MESSAGE
public const string PAYPAL_PAYOUTS_FETCH_ERROR_MESSAGE
Public Const PAYPAL_PAYOUTS_FETCH_ERROR_MESSAGE As String
Public Const PAYPAL_PAYOUTS_FETCH_ERROR_MESSAGE As String
public:
literal String^ PAYPAL_PAYOUTS_FETCH_ERROR_MESSAGE
public:
literal String^ PAYPAL_PAYOUTS_FETCH_ERROR_MESSAGE
static val mutable PAYPAL_PAYOUTS_FETCH_ERROR_MESSAGE: string
static val mutable PAYPAL_PAYOUTS_FETCH_ERROR_MESSAGE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.PAYPAL_VOID_ERROR_MESSAGE Field

StringConsts PAYPAL_VOID_ERROR_MESSAGE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PAYPAL_VOID_ERROR_MESSAGE
public const string PAYPAL_VOID_ERROR_MESSAGE
Public Const PAYPAL_VOID_ERROR_MESSAGE As String
Public Const PAYPAL_VOID_ERROR_MESSAGE As String
public:
literal String^ PAYPAL_VOID_ERROR_MESSAGE
public:
literal String^ PAYPAL_VOID_ERROR_MESSAGE
static val mutable PAYPAL_VOID_ERROR_MESSAGE: string
static val mutable PAYPAL_VOID_ERROR_MESSAGE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SCRIPT_NAME_MISSING_ERROR Field

StringConsts SCRIPT_NAME_MISSING_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCRIPT_NAME_MISSING_ERROR
public const string SCRIPT_NAME_MISSING_ERROR
Public Const SCRIPT_NAME_MISSING_ERROR As String
Public Const SCRIPT_NAME_MISSING_ERROR As String
public:
literal String^ SCRIPT_NAME_MISSING_ERROR
public:
literal String^ SCRIPT_NAME_MISSING_ERROR
static val mutable SCRIPT_NAME_MISSING_ERROR: string
static val mutable SCRIPT_NAME_MISSING_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SCRIPT_READ_ERROR Field

StringConsts SCRIPT_READ_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCRIPT_READ_ERROR
public const string SCRIPT_READ_ERROR
Public Const SCRIPT_READ_ERROR As String
Public Const SCRIPT_READ_ERROR As String
public:
literal String^ SCRIPT_READ_ERROR
public:
literal String^ SCRIPT_READ_ERROR
static val mutable SCRIPT_READ_ERROR: string
static val mutable SCRIPT_READ_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SCRIPT_ROUTE_HANDLER_ERROR Field

StringConsts SCRIPT_ROUTE_HANDLER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCRIPT_ROUTE_HANDLER_ERROR
public const string SCRIPT_ROUTE_HANDLER_ERROR
Public Const SCRIPT_ROUTE_HANDLER_ERROR As String
Public Const SCRIPT_ROUTE_HANDLER_ERROR As String
public:
literal String^ SCRIPT_ROUTE_HANDLER_ERROR
public:
literal String^ SCRIPT_ROUTE_HANDLER_ERROR
static val mutable SCRIPT_ROUTE_HANDLER_ERROR: string
static val mutable SCRIPT_ROUTE_HANDLER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SHIPPING_SYSTEM_DUPLICATE_NAME_ERROR Field

StringConsts SHIPPING_SYSTEM_DUPLICATE_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHIPPING_SYSTEM_DUPLICATE_NAME_ERROR
public const string SHIPPING_SYSTEM_DUPLICATE_NAME_ERROR
Public Const SHIPPING_SYSTEM_DUPLICATE_NAME_ERROR As String
Public Const SHIPPING_SYSTEM_DUPLICATE_NAME_ERROR As String
public:
literal String^ SHIPPING_SYSTEM_DUPLICATE_NAME_ERROR
public:
literal String^ SHIPPING_SYSTEM_DUPLICATE_NAME_ERROR
static val mutable SHIPPING_SYSTEM_DUPLICATE_NAME_ERROR: string
static val mutable SHIPPING_SYSTEM_DUPLICATE_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SHIPPING_SYSTEM_HOST_NULL_ERROR Field

StringConsts SHIPPING_SYSTEM_HOST_NULL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHIPPING_SYSTEM_HOST_NULL_ERROR
public const string SHIPPING_SYSTEM_HOST_NULL_ERROR
Public Const SHIPPING_SYSTEM_HOST_NULL_ERROR As String
Public Const SHIPPING_SYSTEM_HOST_NULL_ERROR As String
public:
literal String^ SHIPPING_SYSTEM_HOST_NULL_ERROR
public:
literal String^ SHIPPING_SYSTEM_HOST_NULL_ERROR
static val mutable SHIPPING_SYSTEM_HOST_NULL_ERROR: string
static val mutable SHIPPING_SYSTEM_HOST_NULL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SHIPPO_CAN_NOT_MAP_LABEL_FORMAT Field

StringConsts SHIPPO_CAN_NOT_MAP_LABEL_FORMAT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHIPPO_CAN_NOT_MAP_LABEL_FORMAT
public const string SHIPPO_CAN_NOT_MAP_LABEL_FORMAT
Public Const SHIPPO_CAN_NOT_MAP_LABEL_FORMAT As String
Public Const SHIPPO_CAN_NOT_MAP_LABEL_FORMAT As String
public:
literal String^ SHIPPO_CAN_NOT_MAP_LABEL_FORMAT
public:
literal String^ SHIPPO_CAN_NOT_MAP_LABEL_FORMAT
static val mutable SHIPPO_CAN_NOT_MAP_LABEL_FORMAT: string
static val mutable SHIPPO_CAN_NOT_MAP_LABEL_FORMAT: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SHIPPO_CREATE_LABEL_ERROR Field

StringConsts SHIPPO_CREATE_LABEL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHIPPO_CREATE_LABEL_ERROR
public const string SHIPPO_CREATE_LABEL_ERROR
Public Const SHIPPO_CREATE_LABEL_ERROR As String
Public Const SHIPPO_CREATE_LABEL_ERROR As String
public:
literal String^ SHIPPO_CREATE_LABEL_ERROR
public:
literal String^ SHIPPO_CREATE_LABEL_ERROR
static val mutable SHIPPO_CREATE_LABEL_ERROR: string
static val mutable SHIPPO_CREATE_LABEL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SHIPPO_CREATE_LABEL_MESSAGE Field

StringConsts SHIPPO_CREATE_LABEL_MESSAGE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHIPPO_CREATE_LABEL_MESSAGE
public const string SHIPPO_CREATE_LABEL_MESSAGE
Public Const SHIPPO_CREATE_LABEL_MESSAGE As String
Public Const SHIPPO_CREATE_LABEL_MESSAGE As String
public:
literal String^ SHIPPO_CREATE_LABEL_MESSAGE
public:
literal String^ SHIPPO_CREATE_LABEL_MESSAGE
static val mutable SHIPPO_CREATE_LABEL_MESSAGE: string
static val mutable SHIPPO_CREATE_LABEL_MESSAGE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SHIPPO_ESTIMATE_SHIPPING_COST_ERROR Field

StringConsts SHIPPO_ESTIMATE_SHIPPING_COST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHIPPO_ESTIMATE_SHIPPING_COST_ERROR
public const string SHIPPO_ESTIMATE_SHIPPING_COST_ERROR
Public Const SHIPPO_ESTIMATE_SHIPPING_COST_ERROR As String
Public Const SHIPPO_ESTIMATE_SHIPPING_COST_ERROR As String
public:
literal String^ SHIPPO_ESTIMATE_SHIPPING_COST_ERROR
public:
literal String^ SHIPPO_ESTIMATE_SHIPPING_COST_ERROR
static val mutable SHIPPO_ESTIMATE_SHIPPING_COST_ERROR: string
static val mutable SHIPPO_ESTIMATE_SHIPPING_COST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SHIPPO_ESTIMATE_SHIPPING_COST_MESSAGE Field

StringConsts SHIPPO_ESTIMATE_SHIPPING_COST_MESSAGE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHIPPO_ESTIMATE_SHIPPING_COST_MESSAGE
public const string SHIPPO_ESTIMATE_SHIPPING_COST_MESSAGE
Public Const SHIPPO_ESTIMATE_SHIPPING_COST_MESSAGE As String
Public Const SHIPPO_ESTIMATE_SHIPPING_COST_MESSAGE As String
public:
literal String^ SHIPPO_ESTIMATE_SHIPPING_COST_MESSAGE
public:
literal String^ SHIPPO_ESTIMATE_SHIPPING_COST_MESSAGE
static val mutable SHIPPO_ESTIMATE_SHIPPING_COST_MESSAGE: string
static val mutable SHIPPO_ESTIMATE_SHIPPING_COST_MESSAGE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SHIPPO_GET_RATE_ERROR Field

StringConsts SHIPPO_GET_RATE_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHIPPO_GET_RATE_ERROR
public const string SHIPPO_GET_RATE_ERROR
Public Const SHIPPO_GET_RATE_ERROR As String
Public Const SHIPPO_GET_RATE_ERROR As String
public:
literal String^ SHIPPO_GET_RATE_ERROR
public:
literal String^ SHIPPO_GET_RATE_ERROR
static val mutable SHIPPO_GET_RATE_ERROR: string
static val mutable SHIPPO_GET_RATE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SHIPPO_OPERATION_FAILED Field

StringConsts SHIPPO_OPERATION_FAILED Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHIPPO_OPERATION_FAILED
public const string SHIPPO_OPERATION_FAILED
Public Const SHIPPO_OPERATION_FAILED As String
Public Const SHIPPO_OPERATION_FAILED As String
public:
literal String^ SHIPPO_OPERATION_FAILED
public:
literal String^ SHIPPO_OPERATION_FAILED
static val mutable SHIPPO_OPERATION_FAILED: string
static val mutable SHIPPO_OPERATION_FAILED: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SHIPPO_TRACK_SHIPMENT_ERROR Field

StringConsts SHIPPO_TRACK_SHIPMENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHIPPO_TRACK_SHIPMENT_ERROR
public const string SHIPPO_TRACK_SHIPMENT_ERROR
Public Const SHIPPO_TRACK_SHIPMENT_ERROR As String
Public Const SHIPPO_TRACK_SHIPMENT_ERROR As String
public:
literal String^ SHIPPO_TRACK_SHIPMENT_ERROR
public:
literal String^ SHIPPO_TRACK_SHIPMENT_ERROR
static val mutable SHIPPO_TRACK_SHIPMENT_ERROR: string
static val mutable SHIPPO_TRACK_SHIPMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SHIPPO_TRACK_SHIPMENT_MESSAGE Field

StringConsts SHIPPO_TRACK_SHIPMENT_MESSAGE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHIPPO_TRACK_SHIPMENT_MESSAGE
public const string SHIPPO_TRACK_SHIPMENT_MESSAGE
Public Const SHIPPO_TRACK_SHIPMENT_MESSAGE As String
Public Const SHIPPO_TRACK_SHIPMENT_MESSAGE As String
public:
literal String^ SHIPPO_TRACK_SHIPMENT_MESSAGE
public:
literal String^ SHIPPO_TRACK_SHIPMENT_MESSAGE
static val mutable SHIPPO_TRACK_SHIPMENT_MESSAGE: string
static val mutable SHIPPO_TRACK_SHIPMENT_MESSAGE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SHIPPO_VALIDATE_ADDRESS_ERROR Field

StringConsts SHIPPO_VALIDATE_ADDRESS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHIPPO_VALIDATE_ADDRESS_ERROR
public const string SHIPPO_VALIDATE_ADDRESS_ERROR
Public Const SHIPPO_VALIDATE_ADDRESS_ERROR As String
Public Const SHIPPO_VALIDATE_ADDRESS_ERROR As String
public:
literal String^ SHIPPO_VALIDATE_ADDRESS_ERROR
public:
literal String^ SHIPPO_VALIDATE_ADDRESS_ERROR
static val mutable SHIPPO_VALIDATE_ADDRESS_ERROR: string
static val mutable SHIPPO_VALIDATE_ADDRESS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SHIPPO_VALIDATE_ADDRESS_INVALID_ERROR Field

StringConsts SHIPPO_VALIDATE_ADDRESS_INVALID_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHIPPO_VALIDATE_ADDRESS_INVALID_ERROR
public const string SHIPPO_VALIDATE_ADDRESS_INVALID_ERROR
Public Const SHIPPO_VALIDATE_ADDRESS_INVALID_ERROR As String
Public Const SHIPPO_VALIDATE_ADDRESS_INVALID_ERROR As String
public:
literal String^ SHIPPO_VALIDATE_ADDRESS_INVALID_ERROR
public:
literal String^ SHIPPO_VALIDATE_ADDRESS_INVALID_ERROR
static val mutable SHIPPO_VALIDATE_ADDRESS_INVALID_ERROR: string
static val mutable SHIPPO_VALIDATE_ADDRESS_INVALID_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SHIPPO_VALIDATE_ADDRESS_MESSAGE Field

StringConsts SHIPPO_VALIDATE_ADDRESS_MESSAGE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHIPPO_VALIDATE_ADDRESS_MESSAGE
public const string SHIPPO_VALIDATE_ADDRESS_MESSAGE
Public Const SHIPPO_VALIDATE_ADDRESS_MESSAGE As String
Public Const SHIPPO_VALIDATE_ADDRESS_MESSAGE As String
public:
literal String^ SHIPPO_VALIDATE_ADDRESS_MESSAGE
public:
literal String^ SHIPPO_VALIDATE_ADDRESS_MESSAGE
static val mutable SHIPPO_VALIDATE_ADDRESS_MESSAGE: string
static val mutable SHIPPO_VALIDATE_ADDRESS_MESSAGE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.SOCIAL_NETWORK_DUPLICATE_NAME Field

StringConsts SOCIAL_NETWORK_DUPLICATE_NAME Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SOCIAL_NETWORK_DUPLICATE_NAME
public const string SOCIAL_NETWORK_DUPLICATE_NAME
Public Const SOCIAL_NETWORK_DUPLICATE_NAME As String
Public Const SOCIAL_NETWORK_DUPLICATE_NAME As String
public:
literal String^ SOCIAL_NETWORK_DUPLICATE_NAME
public:
literal String^ SOCIAL_NETWORK_DUPLICATE_NAME
static val mutable SOCIAL_NETWORK_DUPLICATE_NAME: string
static val mutable SOCIAL_NETWORK_DUPLICATE_NAME: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.STRIP_KEY Field

StringConsts STRIP_KEY Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STRIP_KEY
public const string STRIP_KEY
Public Const STRIP_KEY As String
Public Const STRIP_KEY As String
public:
literal String^ STRIP_KEY
public:
literal String^ STRIP_KEY
static val mutable STRIP_KEY: string
static val mutable STRIP_KEY: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.TAX_CALC_DIFFERENT_CURRENCIES_ERROR Field

StringConsts TAX_CALC_DIFFERENT_CURRENCIES_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TAX_CALC_DIFFERENT_CURRENCIES_ERROR
public const string TAX_CALC_DIFFERENT_CURRENCIES_ERROR
Public Const TAX_CALC_DIFFERENT_CURRENCIES_ERROR As String
Public Const TAX_CALC_DIFFERENT_CURRENCIES_ERROR As String
public:
literal String^ TAX_CALC_DIFFERENT_CURRENCIES_ERROR
public:
literal String^ TAX_CALC_DIFFERENT_CURRENCIES_ERROR
static val mutable TAX_CALC_DIFFERENT_CURRENCIES_ERROR: string
static val mutable TAX_CALC_DIFFERENT_CURRENCIES_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.TAX_CALC_ERROR Field

StringConsts TAX_CALC_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TAX_CALC_ERROR
public const string TAX_CALC_ERROR
Public Const TAX_CALC_ERROR As String
Public Const TAX_CALC_ERROR As String
public:
literal String^ TAX_CALC_ERROR
public:
literal String^ TAX_CALC_ERROR
static val mutable TAX_CALC_ERROR: string
static val mutable TAX_CALC_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.TAX_CALCULATOR_DUPLICATE_NAME_ERROR Field

StringConsts TAX_CALCULATOR_DUPLICATE_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TAX_CALCULATOR_DUPLICATE_NAME_ERROR
public const string TAX_CALCULATOR_DUPLICATE_NAME_ERROR
Public Const TAX_CALCULATOR_DUPLICATE_NAME_ERROR As String
Public Const TAX_CALCULATOR_DUPLICATE_NAME_ERROR As String
public:
literal String^ TAX_CALCULATOR_DUPLICATE_NAME_ERROR
public:
literal String^ TAX_CALCULATOR_DUPLICATE_NAME_ERROR
static val mutable TAX_CALCULATOR_DUPLICATE_NAME_ERROR: string
static val mutable TAX_CALCULATOR_DUPLICATE_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.TAX_TAXJAR_TOADDRESS_ISNT_SUPPLIED_ERROR Field

StringConsts TAX_TAXJAR_TOADDRESS_ISNT_SUPPLIED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TAX_TAXJAR_TOADDRESS_ISNT_SUPPLIED_ERROR
public const string TAX_TAXJAR_TOADDRESS_ISNT_SUPPLIED_ERROR
Public Const TAX_TAXJAR_TOADDRESS_ISNT_SUPPLIED_ERROR As String
Public Const TAX_TAXJAR_TOADDRESS_ISNT_SUPPLIED_ERROR As String
public:
literal String^ TAX_TAXJAR_TOADDRESS_ISNT_SUPPLIED_ERROR
public:
literal String^ TAX_TAXJAR_TOADDRESS_ISNT_SUPPLIED_ERROR
static val mutable TAX_TAXJAR_TOADDRESS_ISNT_SUPPLIED_ERROR: string
static val mutable TAX_TAXJAR_TOADDRESS_ISNT_SUPPLIED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.TYPELOOKUP_404_LOG_MSG Field

StringConsts TYPELOOKUP_404_LOG_MSG Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TYPELOOKUP_404_LOG_MSG
public const string TYPELOOKUP_404_LOG_MSG
Public Const TYPELOOKUP_404_LOG_MSG As String
Public Const TYPELOOKUP_404_LOG_MSG As String
public:
literal String^ TYPELOOKUP_404_LOG_MSG
public:
literal String^ TYPELOOKUP_404_LOG_MSG
static val mutable TYPELOOKUP_404_LOG_MSG: string
static val mutable TYPELOOKUP_404_LOG_MSG: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.UNKNOWN Field

StringConsts UNKNOWN Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNKNOWN
public const string UNKNOWN
Public Const UNKNOWN As String
Public Const UNKNOWN As String
public:
literal String^ UNKNOWN
public:
literal String^ UNKNOWN
static val mutable UNKNOWN: string
static val mutable UNKNOWN: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.WEB_HANDLER_TOPIC Field

StringConsts WEB_HANDLER_TOPIC Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string WEB_HANDLER_TOPIC
public const string WEB_HANDLER_TOPIC
Public Const WEB_HANDLER_TOPIC As String
Public Const WEB_HANDLER_TOPIC As String
public:
literal String^ WEB_HANDLER_TOPIC
public:
literal String^ WEB_HANDLER_TOPIC
static val mutable WEB_HANDLER_TOPIC: string
static val mutable WEB_HANDLER_TOPIC: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.WEB_LOG_TOPIC Field

StringConsts WEB_LOG_TOPIC Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string WEB_LOG_TOPIC
public const string WEB_LOG_TOPIC
Public Const WEB_LOG_TOPIC As String
Public Const WEB_LOG_TOPIC As String
public:
literal String^ WEB_LOG_TOPIC
public:
literal String^ WEB_LOG_TOPIC
static val mutable WEB_LOG_TOPIC: string
static val mutable WEB_LOG_TOPIC: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


StringConsts.WEB_REQUEST_ERROR Field

StringConsts WEB_REQUEST_ERROR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string WEB_REQUEST_ERROR
public const string WEB_REQUEST_ERROR
Public Const WEB_REQUEST_ERROR As String
Public Const WEB_REQUEST_ERROR As String
public:
literal String^ WEB_REQUEST_ERROR
public:
literal String^ WEB_REQUEST_ERROR
static val mutable WEB_REQUEST_ERROR: string
static val mutable WEB_REQUEST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Web Namespace


Utils Class

Utils Class NFX Class Library

Provides various utilities for web technologies
Inheritance Hierarchy
Online System Object
NFX.Web Utils

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class Utils
public static class Utils
<ExtensionAttribute>
Public NotInheritable Class Utils
<ExtensionAttribute>
Public NotInheritable Class Utils
[ExtensionAttribute]
public ref class Utils abstract sealed
[ExtensionAttribute]
public ref class Utils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Utils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Utils =  class end
See Also
Utils Members
NFX.Web Namespace


Utils Members

Utils Members NFX Class Library

The Utils type exposes the following members.
Methods
Name | Description
DateTimeToHTTPCookieDateTime | Converts UTC date timne string suitable for use as Cookie expiration filed
EscapeJSLiteral | Escapes JS literal, replacing / \ \r \n " ' < > & chars with their hex codes
Back to Top
See Also
Utils Class
NFX.Web Namespace


Utils Methods

Utils Methods NFX Class Library

The Utils type exposes the following members.
Methods
Name | Description
DateTimeToHTTPCookieDateTime | Converts UTC date timne string suitable for use as Cookie expiration filed
EscapeJSLiteral | Escapes JS literal, replacing / \ \r \n " ' < > & chars with their hex codes
Back to Top
See Also
Utils Class
NFX.Web Namespace


Utils.DateTimeToHTTPCookieDateTime Method

Utils DateTimeToHTTPCookieDateTime Method NFX Class Library

Converts UTC date timne string suitable for use as Cookie expiration filed

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string DateTimeToHTTPCookieDateTime(
    this DateTime utcDateTime
)
public static string DateTimeToHTTPCookieDateTime(
    this DateTime utcDateTime
)
<ExtensionAttribute>
Public Shared Function DateTimeToHTTPCookieDateTime (
    utcDateTime As DateTime
) As String
<ExtensionAttribute>
Public Shared Function DateTimeToHTTPCookieDateTime (
    utcDateTime As DateTime
) As String
public:
[ExtensionAttribute]
static String^ DateTimeToHTTPCookieDateTime(
    DateTime utcDateTime
)
public:
[ExtensionAttribute]
static String^ DateTimeToHTTPCookieDateTime(
    DateTime utcDateTime
)
static member DateTimeToHTTPCookieDateTime :
        utcDateTime : DateTime -> string
static member DateTimeToHTTPCookieDateTime :
        utcDateTime : DateTime -> string

Parameters

utcDateTime
Type: Online System DateTime

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
Utils Class
Utils Members
NFX.Web Namespace


Utils.EscapeJSLiteral Method

Utils EscapeJSLiteral Method NFX Class Library

Escapes JS literal, replacing / \ \r \n " ' < > & chars with their hex codes

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string EscapeJSLiteral(
    this string value
)
public static string EscapeJSLiteral(
    this string value
)
<ExtensionAttribute>
Public Shared Function EscapeJSLiteral (
    value As String
) As String
<ExtensionAttribute>
Public Shared Function EscapeJSLiteral (
    value As String
) As String
public:
[ExtensionAttribute]
static String^ EscapeJSLiteral(
    String^ value
)
public:
[ExtensionAttribute]
static String^ EscapeJSLiteral(
    String^ value
)
static member EscapeJSLiteral :
        value : string -> string
static member EscapeJSLiteral :
        value : string -> string

Parameters

value
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
Utils Class
Utils Members
NFX.Web Namespace


WebClient Class

WebClient Class NFX Class Library

Facilitates working with external services provided via HTTP
Inheritance Hierarchy
Online System Object
NFX.Web WebClient

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class WebClient
public static class WebClient
Public NotInheritable Class WebClient
Public NotInheritable Class WebClient
public ref class WebClient abstract sealed
public ref class WebClient abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WebClient =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WebClient =  class end
See Also
WebClient Members
NFX.Web Namespace


WebClient Members

WebClient Members NFX Class Library

Methods
Name | Description
DoRequest(Action WebClient , WebClient RequestParams) |
DoRequest(Func WebClient, Task , WebClient RequestParams) |
DoRequest T (Func WebClient, Task T , WebClient RequestParams) |
DoRequest T (Func WebClient, T , WebClient RequestParams) |
GetData(String, WebClient RequestParams) |
GetData(Uri, WebClient RequestParams) |
GetData(String, WebClient RequestParams, String ) |
GetData(Uri, WebClient RequestParams, String ) |
GetDataAsync(String, WebClient RequestParams) |
GetDataAsync(Uri, WebClient RequestParams) |
GetDataAsyncWithContentType(String, WebClient RequestParams) |
GetDataAsyncWithContentType(Uri, WebClient RequestParams) |
GetFile(String, WebClient RequestParams, String) |
GetFile(Uri, WebClient RequestParams, String) |
GetFileAsync(String, WebClient RequestParams, String) |
GetFileAsync(Uri, WebClient RequestParams, String) |
GetImage(String, WebClient RequestParams) |
GetImage(Uri, WebClient RequestParams) |
GetImageAsync(String, WebClient RequestParams) |
GetImageAsync(Uri, WebClient RequestParams) |
GetJson(String, WebClient RequestParams) |
GetJson(Uri, WebClient RequestParams) |
GetJsonArray(String, WebClient RequestParams) |
GetJsonArray(Uri, WebClient RequestParams) |
GetJsonArrayAsync(String, WebClient RequestParams) |
GetJsonArrayAsync(Uri, WebClient RequestParams) |
GetJsonAsDynamic(String, WebClient RequestParams) |
GetJsonAsDynamic(Uri, WebClient RequestParams) |
GetJsonAsDynamicAsync(String, WebClient RequestParams) |
GetJsonAsDynamicAsync(Uri, WebClient RequestParams) |
GetJsonAsync(String, WebClient RequestParams) |
GetJsonAsync(Uri, WebClient RequestParams) |
GetString(String, WebClient RequestParams) |
GetString(Uri, WebClient RequestParams) |
GetStringAsync(String, WebClient RequestParams) |
GetStringAsync(Uri, WebClient RequestParams) |
GetValueMap(String, WebClient RequestParams) |
GetValueMap(Uri, WebClient RequestParams) |
GetValueMapAsync(String, WebClient RequestParams) |
GetValueMapAsync(Uri, WebClient RequestParams) |
GetXML(String, WebClient RequestParams) |
GetXML(Uri, WebClient RequestParams) |
GetXMLAsync(String, WebClient RequestParams) |
GetXMLAsync(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
NFX.Web Namespace


WebClient Methods

WebClient Methods NFX Class Library

Methods
Name | Description
DoRequest(Action WebClient , WebClient RequestParams) |
DoRequest(Func WebClient, Task , WebClient RequestParams) |
DoRequest T (Func WebClient, Task T , WebClient RequestParams) |
DoRequest T (Func WebClient, T , WebClient RequestParams) |
GetData(String, WebClient RequestParams) |
GetData(Uri, WebClient RequestParams) |
GetData(String, WebClient RequestParams, String ) |
GetData(Uri, WebClient RequestParams, String ) |
GetDataAsync(String, WebClient RequestParams) |
GetDataAsync(Uri, WebClient RequestParams) |
GetDataAsyncWithContentType(String, WebClient RequestParams) |
GetDataAsyncWithContentType(Uri, WebClient RequestParams) |
GetFile(String, WebClient RequestParams, String) |
GetFile(Uri, WebClient RequestParams, String) |
GetFileAsync(String, WebClient RequestParams, String) |
GetFileAsync(Uri, WebClient RequestParams, String) |
GetImage(String, WebClient RequestParams) |
GetImage(Uri, WebClient RequestParams) |
GetImageAsync(String, WebClient RequestParams) |
GetImageAsync(Uri, WebClient RequestParams) |
GetJson(String, WebClient RequestParams) |
GetJson(Uri, WebClient RequestParams) |
GetJsonArray(String, WebClient RequestParams) |
GetJsonArray(Uri, WebClient RequestParams) |
GetJsonArrayAsync(String, WebClient RequestParams) |
GetJsonArrayAsync(Uri, WebClient RequestParams) |
GetJsonAsDynamic(String, WebClient RequestParams) |
GetJsonAsDynamic(Uri, WebClient RequestParams) |
GetJsonAsDynamicAsync(String, WebClient RequestParams) |
GetJsonAsDynamicAsync(Uri, WebClient RequestParams) |
GetJsonAsync(String, WebClient RequestParams) |
GetJsonAsync(Uri, WebClient RequestParams) |
GetString(String, WebClient RequestParams) |
GetString(Uri, WebClient RequestParams) |
GetStringAsync(String, WebClient RequestParams) |
GetStringAsync(Uri, WebClient RequestParams) |
GetValueMap(String, WebClient RequestParams) |
GetValueMap(Uri, WebClient RequestParams) |
GetValueMapAsync(String, WebClient RequestParams) |
GetValueMapAsync(Uri, WebClient RequestParams) |
GetXML(String, WebClient RequestParams) |
GetXML(Uri, WebClient RequestParams) |
GetXMLAsync(String, WebClient RequestParams) |
GetXMLAsync(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
NFX.Web Namespace


WebClient.DoRequest Method

WebClient DoRequest Method NFX Class Library

Overload List
Name | Description
DoRequest(Action WebClient , WebClient RequestParams) |
DoRequest T (Func WebClient, Task T , WebClient RequestParams) |
DoRequest(Func WebClient, Task , WebClient RequestParams) |
DoRequest T (Func WebClient, T , WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.DoRequest Method (Action(WebClient), WebClient.RequestParams)

WebClient DoRequest Method (Action WebClient , WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void DoRequest(
    Action<WebClient> actor,
    WebClient..::..RequestParams request
)
public static void DoRequest(
    Action<WebClient> actor,
    WebClient..::..RequestParams request
)
Public Shared Sub DoRequest (
    actor As Action(Of WebClient),
    request As WebClient..::..RequestParams
)
Public Shared Sub DoRequest (
    actor As Action(Of WebClient),
    request As WebClient..::..RequestParams
)
public:
static void DoRequest(
    Action<WebClient^>^ actor,
    WebClient..::..RequestParams request
)
public:
static void DoRequest(
    Action<WebClient^>^ actor,
    WebClient..::..RequestParams request
)
static member DoRequest :
        actor : Action<WebClient> *
        request : WebClient..::..RequestParams -> unit
static member DoRequest :
        actor : Action<WebClient> *
        request : WebClient..::..RequestParams -> unit

Parameters

actor
Type: Online System Action Online WebClient
request
Type: NFX.Web WebClient RequestParams
See Also
WebClient Class
WebClient Members
DoRequest Overload
NFX.Web Namespace


WebClient.DoRequest(T) Method (Func(WebClient, Task(T)), WebClient.RequestParams)

WebClient DoRequest T Method (Func WebClient, Task T , WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<T> DoRequest<T>(
    Func<WebClient, Task<T>> actor,
    WebClient..::..RequestParams request
)
public static Task<T> DoRequest<T>(
    Func<WebClient, Task<T>> actor,
    WebClient..::..RequestParams request
)
Public Shared Function DoRequest(Of T) (
    actor As Func(Of WebClient, Task(Of T)),
    request As WebClient..::..RequestParams
) As Task(Of T)
Public Shared Function DoRequest(Of T) (
    actor As Func(Of WebClient, Task(Of T)),
    request As WebClient..::..RequestParams
) As Task(Of T)
public:
generic<typename T>
static Task<T>^ DoRequest(
    Func<WebClient^, Task<T>^>^ actor,
    WebClient..::..RequestParams request
)
public:
generic<typename T>
static Task<T>^ DoRequest(
    Func<WebClient^, Task<T>^>^ actor,
    WebClient..::..RequestParams request
)
static member DoRequest :
        actor : Func<WebClient, Task<'T>> *
        request : WebClient..::..RequestParams -> Task<'T>
static member DoRequest :
        actor : Func<WebClient, Task<'T>> *
        request : WebClient..::..RequestParams -> Task<'T>

Parameters

actor
Type: Online System Func Online WebClient, Online Task T
request
Type: NFX.Web WebClient RequestParams
Type Parameters
T

Return Value

Type: Online Task T
See Also
WebClient Class
WebClient Members
DoRequest Overload
NFX.Web Namespace


WebClient.DoRequest Method (Func(WebClient, Task), WebClient.RequestParams)

WebClient DoRequest Method (Func WebClient, Task , WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task DoRequest(
    Func<WebClient, Task> actor,
    WebClient..::..RequestParams request
)
public static Task DoRequest(
    Func<WebClient, Task> actor,
    WebClient..::..RequestParams request
)
Public Shared Function DoRequest (
    actor As Func(Of WebClient, Task),
    request As WebClient..::..RequestParams
) As Task
Public Shared Function DoRequest (
    actor As Func(Of WebClient, Task),
    request As WebClient..::..RequestParams
) As Task
public:
static Task^ DoRequest(
    Func<WebClient^, Task^>^ actor,
    WebClient..::..RequestParams request
)
public:
static Task^ DoRequest(
    Func<WebClient^, Task^>^ actor,
    WebClient..::..RequestParams request
)
static member DoRequest :
        actor : Func<WebClient, Task> *
        request : WebClient..::..RequestParams -> Task
static member DoRequest :
        actor : Func<WebClient, Task> *
        request : WebClient..::..RequestParams -> Task

Parameters

actor
Type: Online System Func Online WebClient, Online Task
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task
See Also
WebClient Class
WebClient Members
DoRequest Overload
NFX.Web Namespace


WebClient.DoRequest(T) Method (Func(WebClient, T), WebClient.RequestParams)

WebClient DoRequest T Method (Func WebClient, T , WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T DoRequest<T>(
    Func<WebClient, T> actor,
    WebClient..::..RequestParams request
)
public static T DoRequest<T>(
    Func<WebClient, T> actor,
    WebClient..::..RequestParams request
)
Public Shared Function DoRequest(Of T) (
    actor As Func(Of WebClient, T),
    request As WebClient..::..RequestParams
) As T
Public Shared Function DoRequest(Of T) (
    actor As Func(Of WebClient, T),
    request As WebClient..::..RequestParams
) As T
public:
generic<typename T>
static T DoRequest(
    Func<WebClient^, T>^ actor,
    WebClient..::..RequestParams request
)
public:
generic<typename T>
static T DoRequest(
    Func<WebClient^, T>^ actor,
    WebClient..::..RequestParams request
)
static member DoRequest :
        actor : Func<WebClient, 'T> *
        request : WebClient..::..RequestParams -> 'T
static member DoRequest :
        actor : Func<WebClient, 'T> *
        request : WebClient..::..RequestParams -> 'T

Parameters

actor
Type: Online System Func Online WebClient, T
request
Type: NFX.Web WebClient RequestParams
Type Parameters
T

Return Value

Type: T
See Also
WebClient Class
WebClient Members
DoRequest Overload
NFX.Web Namespace


WebClient.GetData Method

WebClient GetData Method NFX Class Library

Overload List
Name | Description
GetData(String, WebClient RequestParams) |
GetData(Uri, WebClient RequestParams) |
GetData(String, WebClient RequestParams, String ) |
GetData(Uri, WebClient RequestParams, String ) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetData Method (String, WebClient.RequestParams)

WebClient GetData Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] GetData(
    string uri,
    WebClient..::..RequestParams request
)
public static byte[] GetData(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetData (
    uri As String,
    request As WebClient..::..RequestParams
) As Byte()
Public Shared Function GetData (
    uri As String,
    request As WebClient..::..RequestParams
) As Byte()
public:
static array<unsigned char>^ GetData(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static array<unsigned char>^ GetData(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetData :
        uri : string *
        request : WebClient..::..RequestParams -> byte[]
static member GetData :
        uri : string *
        request : WebClient..::..RequestParams -> byte[]

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Byte
See Also
WebClient Class
WebClient Members
GetData Overload
NFX.Web Namespace


WebClient.GetData Method (Uri, WebClient.RequestParams)

WebClient GetData Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] GetData(
    Uri uri,
    WebClient..::..RequestParams request
)
public static byte[] GetData(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetData (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Byte()
Public Shared Function GetData (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Byte()
public:
static array<unsigned char>^ GetData(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static array<unsigned char>^ GetData(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetData :
        uri : Uri *
        request : WebClient..::..RequestParams -> byte[]
static member GetData :
        uri : Uri *
        request : WebClient..::..RequestParams -> byte[]

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Byte
See Also
WebClient Class
WebClient Members
GetData Overload
NFX.Web Namespace


WebClient.GetData Method (String, WebClient.RequestParams, String)

WebClient GetData Method (String, WebClient RequestParams, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] GetData(
    string uri,
    WebClient..::..RequestParams request,
    out string contentType
)
public static byte[] GetData(
    string uri,
    WebClient..::..RequestParams request,
    out string contentType
)
Public Shared Function GetData (
    uri As String,
    request As WebClient..::..RequestParams,
    <OutAttribute> ByRef contentType As String
) As Byte()
Public Shared Function GetData (
    uri As String,
    request As WebClient..::..RequestParams,
    <OutAttribute> ByRef contentType As String
) As Byte()
public:
static array<unsigned char>^ GetData(
    String^ uri,
    WebClient..::..RequestParams request,
    [OutAttribute] String^% contentType
)
public:
static array<unsigned char>^ GetData(
    String^ uri,
    WebClient..::..RequestParams request,
    [OutAttribute] String^% contentType
)
static member GetData :
        uri : string *
        request : WebClient..::..RequestParams *
        contentType : string byref -> byte[]
static member GetData :
        uri : string *
        request : WebClient..::..RequestParams *
        contentType : string byref -> byte[]

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams
contentType
Type: Online System String

Return Value

Type: Online Byte
See Also
WebClient Class
WebClient Members
GetData Overload
NFX.Web Namespace


WebClient.GetData Method (Uri, WebClient.RequestParams, String)

WebClient GetData Method (Uri, WebClient RequestParams, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] GetData(
    Uri uri,
    WebClient..::..RequestParams request,
    out string contentType
)
public static byte[] GetData(
    Uri uri,
    WebClient..::..RequestParams request,
    out string contentType
)
Public Shared Function GetData (
    uri As Uri,
    request As WebClient..::..RequestParams,
    <OutAttribute> ByRef contentType As String
) As Byte()
Public Shared Function GetData (
    uri As Uri,
    request As WebClient..::..RequestParams,
    <OutAttribute> ByRef contentType As String
) As Byte()
public:
static array<unsigned char>^ GetData(
    Uri^ uri,
    WebClient..::..RequestParams request,
    [OutAttribute] String^% contentType
)
public:
static array<unsigned char>^ GetData(
    Uri^ uri,
    WebClient..::..RequestParams request,
    [OutAttribute] String^% contentType
)
static member GetData :
        uri : Uri *
        request : WebClient..::..RequestParams *
        contentType : string byref -> byte[]
static member GetData :
        uri : Uri *
        request : WebClient..::..RequestParams *
        contentType : string byref -> byte[]

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams
contentType
Type: Online System String

Return Value

Type: Online Byte
See Also
WebClient Class
WebClient Members
GetData Overload
NFX.Web Namespace


WebClient.GetDataAsync Method

WebClient GetDataAsync Method NFX Class Library

Overload List
Name | Description
GetDataAsync(String, WebClient RequestParams) |
GetDataAsync(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetDataAsync Method (String, WebClient.RequestParams)

WebClient GetDataAsync Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<byte[]> GetDataAsync(
    string uri,
    WebClient..::..RequestParams request
)
public static Task<byte[]> GetDataAsync(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetDataAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of Byte())
Public Shared Function GetDataAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of Byte())
public:
static Task<array<unsigned char>^>^ GetDataAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<array<unsigned char>^>^ GetDataAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetDataAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<byte[]>
static member GetDataAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<byte[]>

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task Online Byte
See Also
WebClient Class
WebClient Members
GetDataAsync Overload
NFX.Web Namespace


WebClient.GetDataAsync Method (Uri, WebClient.RequestParams)

WebClient GetDataAsync Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<byte[]> GetDataAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
public static Task<byte[]> GetDataAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetDataAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of Byte())
Public Shared Function GetDataAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of Byte())
public:
static Task<array<unsigned char>^>^ GetDataAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<array<unsigned char>^>^ GetDataAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetDataAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<byte[]>
static member GetDataAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<byte[]>

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task Online Byte
See Also
WebClient Class
WebClient Members
GetDataAsync Overload
NFX.Web Namespace


WebClient.GetDataAsyncWithContentType Method

WebClient GetDataAsyncWithContentType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
Name | Description
GetDataAsyncWithContentType(String, WebClient RequestParams) |
GetDataAsyncWithContentType(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetDataAsyncWithContentType Method (String, WebClient.RequestParams)

WebClient GetDataAsyncWithContentType Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<Tuple<byte[], string>> GetDataAsyncWithContentType(
    string uri,
    WebClient..::..RequestParams request
)
public static Task<Tuple<byte[], string>> GetDataAsyncWithContentType(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetDataAsyncWithContentType (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of Tuple(Of Byte(), String))
Public Shared Function GetDataAsyncWithContentType (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of Tuple(Of Byte(), String))
public:
static Task<Tuple<array<unsigned char>^, String^>^>^ GetDataAsyncWithContentType(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<Tuple<array<unsigned char>^, String^>^>^ GetDataAsyncWithContentType(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetDataAsyncWithContentType :
        uri : string *
        request : WebClient..::..RequestParams -> Task<Tuple<byte[], string>>
static member GetDataAsyncWithContentType :
        uri : string *
        request : WebClient..::..RequestParams -> Task<Tuple<byte[], string>>

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task Online Tuple Online Byte , Online String
See Also
WebClient Class
WebClient Members
GetDataAsyncWithContentType Overload
NFX.Web Namespace


WebClient.GetDataAsyncWithContentType Method (Uri, WebClient.RequestParams)

WebClient GetDataAsyncWithContentType Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<Tuple<byte[], string>> GetDataAsyncWithContentType(
    Uri uri,
    WebClient..::..RequestParams request
)
public static Task<Tuple<byte[], string>> GetDataAsyncWithContentType(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetDataAsyncWithContentType (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of Tuple(Of Byte(), String))
Public Shared Function GetDataAsyncWithContentType (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of Tuple(Of Byte(), String))
public:
static Task<Tuple<array<unsigned char>^, String^>^>^ GetDataAsyncWithContentType(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<Tuple<array<unsigned char>^, String^>^>^ GetDataAsyncWithContentType(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetDataAsyncWithContentType :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<Tuple<byte[], string>>
static member GetDataAsyncWithContentType :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<Tuple<byte[], string>>

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task Online Tuple Online Byte , Online String
See Also
WebClient Class
WebClient Members
GetDataAsyncWithContentType Overload
NFX.Web Namespace


WebClient.GetFile Method

WebClient GetFile Method NFX Class Library

Overload List
Name | Description
GetFile(String, WebClient RequestParams, String) |
GetFile(Uri, WebClient RequestParams, String) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetFile Method (String, WebClient.RequestParams, String)

WebClient GetFile Method (String, WebClient RequestParams, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void GetFile(
    string uri,
    WebClient..::..RequestParams request,
    string file
)
public static void GetFile(
    string uri,
    WebClient..::..RequestParams request,
    string file
)
Public Shared Sub GetFile (
    uri As String,
    request As WebClient..::..RequestParams,
    file As String
)
Public Shared Sub GetFile (
    uri As String,
    request As WebClient..::..RequestParams,
    file As String
)
public:
static void GetFile(
    String^ uri,
    WebClient..::..RequestParams request,
    String^ file
)
public:
static void GetFile(
    String^ uri,
    WebClient..::..RequestParams request,
    String^ file
)
static member GetFile :
        uri : string *
        request : WebClient..::..RequestParams *
        file : string -> unit
static member GetFile :
        uri : string *
        request : WebClient..::..RequestParams *
        file : string -> unit

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams
file
Type: Online System String
See Also
WebClient Class
WebClient Members
GetFile Overload
NFX.Web Namespace


WebClient.GetFile Method (Uri, WebClient.RequestParams, String)

WebClient GetFile Method (Uri, WebClient RequestParams, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void GetFile(
    Uri uri,
    WebClient..::..RequestParams request,
    string file
)
public static void GetFile(
    Uri uri,
    WebClient..::..RequestParams request,
    string file
)
Public Shared Sub GetFile (
    uri As Uri,
    request As WebClient..::..RequestParams,
    file As String
)
Public Shared Sub GetFile (
    uri As Uri,
    request As WebClient..::..RequestParams,
    file As String
)
public:
static void GetFile(
    Uri^ uri,
    WebClient..::..RequestParams request,
    String^ file
)
public:
static void GetFile(
    Uri^ uri,
    WebClient..::..RequestParams request,
    String^ file
)
static member GetFile :
        uri : Uri *
        request : WebClient..::..RequestParams *
        file : string -> unit
static member GetFile :
        uri : Uri *
        request : WebClient..::..RequestParams *
        file : string -> unit

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams
file
Type: Online System String
See Also
WebClient Class
WebClient Members
GetFile Overload
NFX.Web Namespace


WebClient.GetFileAsync Method

WebClient GetFileAsync Method NFX Class Library

Overload List
Name | Description
GetFileAsync(String, WebClient RequestParams, String) |
GetFileAsync(Uri, WebClient RequestParams, String) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetFileAsync Method (String, WebClient.RequestParams, String)

WebClient GetFileAsync Method (String, WebClient RequestParams, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task GetFileAsync(
    string uri,
    WebClient..::..RequestParams request,
    string file
)
public static Task GetFileAsync(
    string uri,
    WebClient..::..RequestParams request,
    string file
)
Public Shared Function GetFileAsync (
    uri As String,
    request As WebClient..::..RequestParams,
    file As String
) As Task
Public Shared Function GetFileAsync (
    uri As String,
    request As WebClient..::..RequestParams,
    file As String
) As Task
public:
static Task^ GetFileAsync(
    String^ uri,
    WebClient..::..RequestParams request,
    String^ file
)
public:
static Task^ GetFileAsync(
    String^ uri,
    WebClient..::..RequestParams request,
    String^ file
)
static member GetFileAsync :
        uri : string *
        request : WebClient..::..RequestParams *
        file : string -> Task
static member GetFileAsync :
        uri : string *
        request : WebClient..::..RequestParams *
        file : string -> Task

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams
file
Type: Online System String

Return Value

Type: Online Task
See Also
WebClient Class
WebClient Members
GetFileAsync Overload
NFX.Web Namespace


WebClient.GetFileAsync Method (Uri, WebClient.RequestParams, String)

WebClient GetFileAsync Method (Uri, WebClient RequestParams, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task GetFileAsync(
    Uri uri,
    WebClient..::..RequestParams request,
    string file
)
public static Task GetFileAsync(
    Uri uri,
    WebClient..::..RequestParams request,
    string file
)
Public Shared Function GetFileAsync (
    uri As Uri,
    request As WebClient..::..RequestParams,
    file As String
) As Task
Public Shared Function GetFileAsync (
    uri As Uri,
    request As WebClient..::..RequestParams,
    file As String
) As Task
public:
static Task^ GetFileAsync(
    Uri^ uri,
    WebClient..::..RequestParams request,
    String^ file
)
public:
static Task^ GetFileAsync(
    Uri^ uri,
    WebClient..::..RequestParams request,
    String^ file
)
static member GetFileAsync :
        uri : Uri *
        request : WebClient..::..RequestParams *
        file : string -> Task
static member GetFileAsync :
        uri : Uri *
        request : WebClient..::..RequestParams *
        file : string -> Task

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams
file
Type: Online System String

Return Value

Type: Online Task
See Also
WebClient Class
WebClient Members
GetFileAsync Overload
NFX.Web Namespace


WebClient.GetImage Method

WebClient GetImage Method NFX Class Library

Overload List
Name | Description
GetImage(String, WebClient RequestParams) |
GetImage(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetImage Method (String, WebClient.RequestParams)

WebClient GetImage Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Image GetImage(
    string uri,
    WebClient..::..RequestParams request
)
public static Image GetImage(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetImage (
    uri As String,
    request As WebClient..::..RequestParams
) As Image
Public Shared Function GetImage (
    uri As String,
    request As WebClient..::..RequestParams
) As Image
public:
static Image^ GetImage(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static Image^ GetImage(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetImage :
        uri : string *
        request : WebClient..::..RequestParams -> Image
static member GetImage :
        uri : string *
        request : WebClient..::..RequestParams -> Image

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Image
See Also
WebClient Class
WebClient Members
GetImage Overload
NFX.Web Namespace


WebClient.GetImage Method (Uri, WebClient.RequestParams)

WebClient GetImage Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Image GetImage(
    Uri uri,
    WebClient..::..RequestParams request
)
public static Image GetImage(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetImage (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Image
Public Shared Function GetImage (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Image
public:
static Image^ GetImage(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static Image^ GetImage(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetImage :
        uri : Uri *
        request : WebClient..::..RequestParams -> Image
static member GetImage :
        uri : Uri *
        request : WebClient..::..RequestParams -> Image

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Image
See Also
WebClient Class
WebClient Members
GetImage Overload
NFX.Web Namespace


WebClient.GetImageAsync Method

WebClient GetImageAsync Method NFX Class Library

Overload List
Name | Description
GetImageAsync(String, WebClient RequestParams) |
GetImageAsync(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetImageAsync Method (String, WebClient.RequestParams)

WebClient GetImageAsync Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<Image> GetImageAsync(
    string uri,
    WebClient..::..RequestParams request
)
public static Task<Image> GetImageAsync(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetImageAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of Image)
Public Shared Function GetImageAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of Image)
public:
static Task<Image^>^ GetImageAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<Image^>^ GetImageAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetImageAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<Image>
static member GetImageAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<Image>

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task Online Image
See Also
WebClient Class
WebClient Members
GetImageAsync Overload
NFX.Web Namespace


WebClient.GetImageAsync Method (Uri, WebClient.RequestParams)

WebClient GetImageAsync Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<Image> GetImageAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
public static Task<Image> GetImageAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetImageAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of Image)
Public Shared Function GetImageAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of Image)
public:
static Task<Image^>^ GetImageAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<Image^>^ GetImageAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetImageAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<Image>
static member GetImageAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<Image>

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task Online Image
See Also
WebClient Class
WebClient Members
GetImageAsync Overload
NFX.Web Namespace


WebClient.GetJson Method

WebClient GetJson Method NFX Class Library

Overload List
Name | Description
GetJson(String, WebClient RequestParams) |
GetJson(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetJson Method (String, WebClient.RequestParams)

WebClient GetJson Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONDataMap GetJson(
    string uri,
    WebClient..::..RequestParams request
)
public static JSONDataMap GetJson(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetJson (
    uri As String,
    request As WebClient..::..RequestParams
) As JSONDataMap
Public Shared Function GetJson (
    uri As String,
    request As WebClient..::..RequestParams
) As JSONDataMap
public:
static JSONDataMap^ GetJson(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static JSONDataMap^ GetJson(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetJson :
        uri : string *
        request : WebClient..::..RequestParams -> JSONDataMap
static member GetJson :
        uri : string *
        request : WebClient..::..RequestParams -> JSONDataMap

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: JSONDataMap
See Also
WebClient Class
WebClient Members
GetJson Overload
NFX.Web Namespace


WebClient.GetJson Method (Uri, WebClient.RequestParams)

WebClient GetJson Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONDataMap GetJson(
    Uri uri,
    WebClient..::..RequestParams request
)
public static JSONDataMap GetJson(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetJson (
    uri As Uri,
    request As WebClient..::..RequestParams
) As JSONDataMap
Public Shared Function GetJson (
    uri As Uri,
    request As WebClient..::..RequestParams
) As JSONDataMap
public:
static JSONDataMap^ GetJson(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static JSONDataMap^ GetJson(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetJson :
        uri : Uri *
        request : WebClient..::..RequestParams -> JSONDataMap
static member GetJson :
        uri : Uri *
        request : WebClient..::..RequestParams -> JSONDataMap

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: JSONDataMap
See Also
WebClient Class
WebClient Members
GetJson Overload
NFX.Web Namespace


WebClient.GetJsonArray Method

WebClient GetJsonArray Method NFX Class Library

Overload List
Name | Description
GetJsonArray(String, WebClient RequestParams) |
GetJsonArray(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetJsonArray Method (String, WebClient.RequestParams)

WebClient GetJsonArray Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONDataArray GetJsonArray(
    string uri,
    WebClient..::..RequestParams request
)
public static JSONDataArray GetJsonArray(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetJsonArray (
    uri As String,
    request As WebClient..::..RequestParams
) As JSONDataArray
Public Shared Function GetJsonArray (
    uri As String,
    request As WebClient..::..RequestParams
) As JSONDataArray
public:
static JSONDataArray^ GetJsonArray(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static JSONDataArray^ GetJsonArray(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetJsonArray :
        uri : string *
        request : WebClient..::..RequestParams -> JSONDataArray
static member GetJsonArray :
        uri : string *
        request : WebClient..::..RequestParams -> JSONDataArray

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: JSONDataArray
See Also
WebClient Class
WebClient Members
GetJsonArray Overload
NFX.Web Namespace


WebClient.GetJsonArray Method (Uri, WebClient.RequestParams)

WebClient GetJsonArray Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONDataArray GetJsonArray(
    Uri uri,
    WebClient..::..RequestParams request
)
public static JSONDataArray GetJsonArray(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetJsonArray (
    uri As Uri,
    request As WebClient..::..RequestParams
) As JSONDataArray
Public Shared Function GetJsonArray (
    uri As Uri,
    request As WebClient..::..RequestParams
) As JSONDataArray
public:
static JSONDataArray^ GetJsonArray(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static JSONDataArray^ GetJsonArray(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetJsonArray :
        uri : Uri *
        request : WebClient..::..RequestParams -> JSONDataArray
static member GetJsonArray :
        uri : Uri *
        request : WebClient..::..RequestParams -> JSONDataArray

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: JSONDataArray
See Also
WebClient Class
WebClient Members
GetJsonArray Overload
NFX.Web Namespace


WebClient.GetJsonArrayAsync Method

WebClient GetJsonArrayAsync Method NFX Class Library

Overload List
Name | Description
GetJsonArrayAsync(String, WebClient RequestParams) |
GetJsonArrayAsync(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetJsonArrayAsync Method (String, WebClient.RequestParams)

WebClient GetJsonArrayAsync Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<JSONDataArray> GetJsonArrayAsync(
    string uri,
    WebClient..::..RequestParams request
)
public static Task<JSONDataArray> GetJsonArrayAsync(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetJsonArrayAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of JSONDataArray)
Public Shared Function GetJsonArrayAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of JSONDataArray)
public:
static Task<JSONDataArray^>^ GetJsonArrayAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<JSONDataArray^>^ GetJsonArrayAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetJsonArrayAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<JSONDataArray>
static member GetJsonArrayAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<JSONDataArray>

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task JSONDataArray
See Also
WebClient Class
WebClient Members
GetJsonArrayAsync Overload
NFX.Web Namespace


WebClient.GetJsonArrayAsync Method (Uri, WebClient.RequestParams)

WebClient GetJsonArrayAsync Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<JSONDataArray> GetJsonArrayAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
public static Task<JSONDataArray> GetJsonArrayAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetJsonArrayAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of JSONDataArray)
Public Shared Function GetJsonArrayAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of JSONDataArray)
public:
static Task<JSONDataArray^>^ GetJsonArrayAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<JSONDataArray^>^ GetJsonArrayAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetJsonArrayAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<JSONDataArray>
static member GetJsonArrayAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<JSONDataArray>

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task JSONDataArray
See Also
WebClient Class
WebClient Members
GetJsonArrayAsync Overload
NFX.Web Namespace


WebClient.GetJsonAsDynamic Method

WebClient GetJsonAsDynamic Method NFX Class Library

Overload List
Name | Description
GetJsonAsDynamic(String, WebClient RequestParams) |
GetJsonAsDynamic(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetJsonAsDynamic Method (String, WebClient.RequestParams)

WebClient GetJsonAsDynamic Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONDynamicObject GetJsonAsDynamic(
    string uri,
    WebClient..::..RequestParams request
)
public static JSONDynamicObject GetJsonAsDynamic(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetJsonAsDynamic (
    uri As String,
    request As WebClient..::..RequestParams
) As JSONDynamicObject
Public Shared Function GetJsonAsDynamic (
    uri As String,
    request As WebClient..::..RequestParams
) As JSONDynamicObject
public:
static JSONDynamicObject^ GetJsonAsDynamic(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static JSONDynamicObject^ GetJsonAsDynamic(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetJsonAsDynamic :
        uri : string *
        request : WebClient..::..RequestParams -> JSONDynamicObject
static member GetJsonAsDynamic :
        uri : string *
        request : WebClient..::..RequestParams -> JSONDynamicObject

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: JSONDynamicObject
See Also
WebClient Class
WebClient Members
GetJsonAsDynamic Overload
NFX.Web Namespace


WebClient.GetJsonAsDynamic Method (Uri, WebClient.RequestParams)

WebClient GetJsonAsDynamic Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONDynamicObject GetJsonAsDynamic(
    Uri uri,
    WebClient..::..RequestParams request
)
public static JSONDynamicObject GetJsonAsDynamic(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetJsonAsDynamic (
    uri As Uri,
    request As WebClient..::..RequestParams
) As JSONDynamicObject
Public Shared Function GetJsonAsDynamic (
    uri As Uri,
    request As WebClient..::..RequestParams
) As JSONDynamicObject
public:
static JSONDynamicObject^ GetJsonAsDynamic(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static JSONDynamicObject^ GetJsonAsDynamic(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetJsonAsDynamic :
        uri : Uri *
        request : WebClient..::..RequestParams -> JSONDynamicObject
static member GetJsonAsDynamic :
        uri : Uri *
        request : WebClient..::..RequestParams -> JSONDynamicObject

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: JSONDynamicObject
See Also
WebClient Class
WebClient Members
GetJsonAsDynamic Overload
NFX.Web Namespace


WebClient.GetJsonAsDynamicAsync Method

WebClient GetJsonAsDynamicAsync Method NFX Class Library

Overload List
Name | Description
GetJsonAsDynamicAsync(String, WebClient RequestParams) |
GetJsonAsDynamicAsync(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetJsonAsDynamicAsync Method (String, WebClient.RequestParams)

WebClient GetJsonAsDynamicAsync Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<JSONDynamicObject> GetJsonAsDynamicAsync(
    string uri,
    WebClient..::..RequestParams request
)
public static Task<JSONDynamicObject> GetJsonAsDynamicAsync(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetJsonAsDynamicAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of JSONDynamicObject)
Public Shared Function GetJsonAsDynamicAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of JSONDynamicObject)
public:
static Task<JSONDynamicObject^>^ GetJsonAsDynamicAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<JSONDynamicObject^>^ GetJsonAsDynamicAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetJsonAsDynamicAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<JSONDynamicObject>
static member GetJsonAsDynamicAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<JSONDynamicObject>

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task JSONDynamicObject
See Also
WebClient Class
WebClient Members
GetJsonAsDynamicAsync Overload
NFX.Web Namespace


WebClient.GetJsonAsDynamicAsync Method (Uri, WebClient.RequestParams)

WebClient GetJsonAsDynamicAsync Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<JSONDynamicObject> GetJsonAsDynamicAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
public static Task<JSONDynamicObject> GetJsonAsDynamicAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetJsonAsDynamicAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of JSONDynamicObject)
Public Shared Function GetJsonAsDynamicAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of JSONDynamicObject)
public:
static Task<JSONDynamicObject^>^ GetJsonAsDynamicAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<JSONDynamicObject^>^ GetJsonAsDynamicAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetJsonAsDynamicAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<JSONDynamicObject>
static member GetJsonAsDynamicAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<JSONDynamicObject>

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task JSONDynamicObject
See Also
WebClient Class
WebClient Members
GetJsonAsDynamicAsync Overload
NFX.Web Namespace


WebClient.GetJsonAsync Method

WebClient GetJsonAsync Method NFX Class Library

Overload List
Name | Description
GetJsonAsync(String, WebClient RequestParams) |
GetJsonAsync(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetJsonAsync Method (String, WebClient.RequestParams)

WebClient GetJsonAsync Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<JSONDataMap> GetJsonAsync(
    string uri,
    WebClient..::..RequestParams request
)
public static Task<JSONDataMap> GetJsonAsync(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetJsonAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of JSONDataMap)
Public Shared Function GetJsonAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of JSONDataMap)
public:
static Task<JSONDataMap^>^ GetJsonAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<JSONDataMap^>^ GetJsonAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetJsonAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<JSONDataMap>
static member GetJsonAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<JSONDataMap>

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task JSONDataMap
See Also
WebClient Class
WebClient Members
GetJsonAsync Overload
NFX.Web Namespace


WebClient.GetJsonAsync Method (Uri, WebClient.RequestParams)

WebClient GetJsonAsync Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<JSONDataMap> GetJsonAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
public static Task<JSONDataMap> GetJsonAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetJsonAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of JSONDataMap)
Public Shared Function GetJsonAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of JSONDataMap)
public:
static Task<JSONDataMap^>^ GetJsonAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<JSONDataMap^>^ GetJsonAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetJsonAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<JSONDataMap>
static member GetJsonAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<JSONDataMap>

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task JSONDataMap
See Also
WebClient Class
WebClient Members
GetJsonAsync Overload
NFX.Web Namespace


WebClient.GetString Method

WebClient GetString Method NFX Class Library

Overload List
Name | Description
GetString(String, WebClient RequestParams) |
GetString(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetString Method (String, WebClient.RequestParams)

WebClient GetString Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetString(
    string uri,
    WebClient..::..RequestParams request
)
public static string GetString(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetString (
    uri As String,
    request As WebClient..::..RequestParams
) As String
Public Shared Function GetString (
    uri As String,
    request As WebClient..::..RequestParams
) As String
public:
static String^ GetString(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static String^ GetString(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetString :
        uri : string *
        request : WebClient..::..RequestParams -> string
static member GetString :
        uri : string *
        request : WebClient..::..RequestParams -> string

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online String
See Also
WebClient Class
WebClient Members
GetString Overload
NFX.Web Namespace


WebClient.GetString Method (Uri, WebClient.RequestParams)

WebClient GetString Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetString(
    Uri uri,
    WebClient..::..RequestParams request
)
public static string GetString(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetString (
    uri As Uri,
    request As WebClient..::..RequestParams
) As String
Public Shared Function GetString (
    uri As Uri,
    request As WebClient..::..RequestParams
) As String
public:
static String^ GetString(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static String^ GetString(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetString :
        uri : Uri *
        request : WebClient..::..RequestParams -> string
static member GetString :
        uri : Uri *
        request : WebClient..::..RequestParams -> string

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online String
See Also
WebClient Class
WebClient Members
GetString Overload
NFX.Web Namespace


WebClient.GetStringAsync Method

WebClient GetStringAsync Method NFX Class Library

Overload List
Name | Description
GetStringAsync(String, WebClient RequestParams) |
GetStringAsync(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetStringAsync Method (String, WebClient.RequestParams)

WebClient GetStringAsync Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<string> GetStringAsync(
    string uri,
    WebClient..::..RequestParams request
)
public static Task<string> GetStringAsync(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetStringAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of String)
Public Shared Function GetStringAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of String)
public:
static Task<String^>^ GetStringAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<String^>^ GetStringAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetStringAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<string>
static member GetStringAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<string>

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task Online String
See Also
WebClient Class
WebClient Members
GetStringAsync Overload
NFX.Web Namespace


WebClient.GetStringAsync Method (Uri, WebClient.RequestParams)

WebClient GetStringAsync Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<string> GetStringAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
public static Task<string> GetStringAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetStringAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of String)
Public Shared Function GetStringAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of String)
public:
static Task<String^>^ GetStringAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<String^>^ GetStringAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetStringAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<string>
static member GetStringAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<string>

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task Online String
See Also
WebClient Class
WebClient Members
GetStringAsync Overload
NFX.Web Namespace


WebClient.GetValueMap Method

WebClient GetValueMap Method NFX Class Library

Overload List
Name | Description
GetValueMap(String, WebClient RequestParams) |
GetValueMap(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetValueMap Method (String, WebClient.RequestParams)

WebClient GetValueMap Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONDataMap GetValueMap(
    string uri,
    WebClient..::..RequestParams request
)
public static JSONDataMap GetValueMap(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetValueMap (
    uri As String,
    request As WebClient..::..RequestParams
) As JSONDataMap
Public Shared Function GetValueMap (
    uri As String,
    request As WebClient..::..RequestParams
) As JSONDataMap
public:
static JSONDataMap^ GetValueMap(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static JSONDataMap^ GetValueMap(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetValueMap :
        uri : string *
        request : WebClient..::..RequestParams -> JSONDataMap
static member GetValueMap :
        uri : string *
        request : WebClient..::..RequestParams -> JSONDataMap

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: JSONDataMap
See Also
WebClient Class
WebClient Members
GetValueMap Overload
NFX.Web Namespace


WebClient.GetValueMap Method (Uri, WebClient.RequestParams)

WebClient GetValueMap Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONDataMap GetValueMap(
    Uri uri,
    WebClient..::..RequestParams request
)
public static JSONDataMap GetValueMap(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetValueMap (
    uri As Uri,
    request As WebClient..::..RequestParams
) As JSONDataMap
Public Shared Function GetValueMap (
    uri As Uri,
    request As WebClient..::..RequestParams
) As JSONDataMap
public:
static JSONDataMap^ GetValueMap(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static JSONDataMap^ GetValueMap(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetValueMap :
        uri : Uri *
        request : WebClient..::..RequestParams -> JSONDataMap
static member GetValueMap :
        uri : Uri *
        request : WebClient..::..RequestParams -> JSONDataMap

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: JSONDataMap
See Also
WebClient Class
WebClient Members
GetValueMap Overload
NFX.Web Namespace


WebClient.GetValueMapAsync Method

WebClient GetValueMapAsync Method NFX Class Library

Overload List
Name | Description
GetValueMapAsync(String, WebClient RequestParams) |
GetValueMapAsync(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetValueMapAsync Method (String, WebClient.RequestParams)

WebClient GetValueMapAsync Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<JSONDataMap> GetValueMapAsync(
    string uri,
    WebClient..::..RequestParams request
)
public static Task<JSONDataMap> GetValueMapAsync(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetValueMapAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of JSONDataMap)
Public Shared Function GetValueMapAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of JSONDataMap)
public:
static Task<JSONDataMap^>^ GetValueMapAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<JSONDataMap^>^ GetValueMapAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetValueMapAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<JSONDataMap>
static member GetValueMapAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<JSONDataMap>

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task JSONDataMap
See Also
WebClient Class
WebClient Members
GetValueMapAsync Overload
NFX.Web Namespace


WebClient.GetValueMapAsync Method (Uri, WebClient.RequestParams)

WebClient GetValueMapAsync Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<JSONDataMap> GetValueMapAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
public static Task<JSONDataMap> GetValueMapAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetValueMapAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of JSONDataMap)
Public Shared Function GetValueMapAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of JSONDataMap)
public:
static Task<JSONDataMap^>^ GetValueMapAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<JSONDataMap^>^ GetValueMapAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetValueMapAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<JSONDataMap>
static member GetValueMapAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<JSONDataMap>

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task JSONDataMap
See Also
WebClient Class
WebClient Members
GetValueMapAsync Overload
NFX.Web Namespace


WebClient.GetXML Method

WebClient GetXML Method NFX Class Library

Overload List
Name | Description
GetXML(String, WebClient RequestParams) |
GetXML(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetXML Method (String, WebClient.RequestParams)

WebClient GetXML Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static XDocument GetXML(
    string uri,
    WebClient..::..RequestParams request
)
public static XDocument GetXML(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetXML (
    uri As String,
    request As WebClient..::..RequestParams
) As XDocument
Public Shared Function GetXML (
    uri As String,
    request As WebClient..::..RequestParams
) As XDocument
public:
static XDocument^ GetXML(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static XDocument^ GetXML(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetXML :
        uri : string *
        request : WebClient..::..RequestParams -> XDocument
static member GetXML :
        uri : string *
        request : WebClient..::..RequestParams -> XDocument

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online XDocument
See Also
WebClient Class
WebClient Members
GetXML Overload
NFX.Web Namespace


WebClient.GetXML Method (Uri, WebClient.RequestParams)

WebClient GetXML Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static XDocument GetXML(
    Uri uri,
    WebClient..::..RequestParams request
)
public static XDocument GetXML(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetXML (
    uri As Uri,
    request As WebClient..::..RequestParams
) As XDocument
Public Shared Function GetXML (
    uri As Uri,
    request As WebClient..::..RequestParams
) As XDocument
public:
static XDocument^ GetXML(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static XDocument^ GetXML(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetXML :
        uri : Uri *
        request : WebClient..::..RequestParams -> XDocument
static member GetXML :
        uri : Uri *
        request : WebClient..::..RequestParams -> XDocument

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online XDocument
See Also
WebClient Class
WebClient Members
GetXML Overload
NFX.Web Namespace


WebClient.GetXMLAsync Method

WebClient GetXMLAsync Method NFX Class Library

Overload List
Name | Description
GetXMLAsync(String, WebClient RequestParams) |
GetXMLAsync(Uri, WebClient RequestParams) |
Back to Top
See Also
WebClient Class
WebClient Members
NFX.Web Namespace


WebClient.GetXMLAsync Method (String, WebClient.RequestParams)

WebClient GetXMLAsync Method (String, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<XDocument> GetXMLAsync(
    string uri,
    WebClient..::..RequestParams request
)
public static Task<XDocument> GetXMLAsync(
    string uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetXMLAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of XDocument)
Public Shared Function GetXMLAsync (
    uri As String,
    request As WebClient..::..RequestParams
) As Task(Of XDocument)
public:
static Task<XDocument^>^ GetXMLAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<XDocument^>^ GetXMLAsync(
    String^ uri,
    WebClient..::..RequestParams request
)
static member GetXMLAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<XDocument>
static member GetXMLAsync :
        uri : string *
        request : WebClient..::..RequestParams -> Task<XDocument>

Parameters

uri
Type: Online System String
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task Online XDocument
See Also
WebClient Class
WebClient Members
GetXMLAsync Overload
NFX.Web Namespace


WebClient.GetXMLAsync Method (Uri, WebClient.RequestParams)

WebClient GetXMLAsync Method (Uri, WebClient RequestParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<XDocument> GetXMLAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
public static Task<XDocument> GetXMLAsync(
    Uri uri,
    WebClient..::..RequestParams request
)
Public Shared Function GetXMLAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of XDocument)
Public Shared Function GetXMLAsync (
    uri As Uri,
    request As WebClient..::..RequestParams
) As Task(Of XDocument)
public:
static Task<XDocument^>^ GetXMLAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
public:
static Task<XDocument^>^ GetXMLAsync(
    Uri^ uri,
    WebClient..::..RequestParams request
)
static member GetXMLAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<XDocument>
static member GetXMLAsync :
        uri : Uri *
        request : WebClient..::..RequestParams -> Task<XDocument>

Parameters

uri
Type: Online System Uri
request
Type: NFX.Web WebClient RequestParams

Return Value

Type: Online Task Online XDocument
See Also
WebClient Class
WebClient Members
GetXMLAsync Overload
NFX.Web Namespace


WebClient.RequestParams Structure

WebClient RequestParams Structure NFX Class Library

Provides request parameters for making WebClient calls

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct RequestParams
public struct RequestParams
Public Structure RequestParams
Public Structure RequestParams
public value class RequestParams
public value class RequestParams
[<SealedAttribute>]
type RequestParams =  struct end
[<SealedAttribute>]
type RequestParams =  struct end
See Also
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams Members

WebClient RequestParams Members NFX Class Library

The WebClient RequestParams type exposes the following members.
Constructors
 | Name | Description
Public method | WebClient RequestParams | Initializes a new instance of the WebClient RequestParams class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBody |
Public method | GetCredentials |
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | GetHeaders |
Public method | GetQueryString |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | AcceptType |
Public field | Body |
Public field | BodyParameters |
Public field | Caller |
Public field | ContentType |
Public field | Headers |
Public field | Method |
Public field | Password |
Public field | QueryParameters |
Public field | UserName |
Back to Top
Properties
 | Name | Description
Public property | HasBody |
Public property | HasCredentials |
Back to Top
See Also
WebClient RequestParams Structure
NFX.Web Namespace


WebClient.RequestParams Constructor

WebClient RequestParams Constructor NFX Class Library

Initializes a new instance of the WebClient RequestParams class

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RequestParams(
    IWebClientCaller caller
)
public RequestParams(
    IWebClientCaller caller
)
Public Sub New (
    caller As IWebClientCaller
)
Public Sub New (
    caller As IWebClientCaller
)
public:
RequestParams(
    IWebClientCaller^ caller
)
public:
RequestParams(
    IWebClientCaller^ caller
)
new :
        caller : IWebClientCaller -> RequestParams
new :
        caller : IWebClientCaller -> RequestParams

Parameters

caller
Type: NFX.Web IWebClientCaller
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams Fields

WebClient RequestParams Fields NFX Class Library

The WebClient RequestParams type exposes the following members.
Fields
 | Name | Description
Public field | AcceptType |
Public field | Body |
Public field | BodyParameters |
Public field | Caller |
Public field | ContentType |
Public field | Headers |
Public field | Method |
Public field | Password |
Public field | QueryParameters |
Public field | UserName |
Back to Top
See Also
WebClient RequestParams Structure
NFX.Web Namespace


WebClient.RequestParams.AcceptType Field

WebClient RequestParams AcceptType Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AcceptType
public string AcceptType
Public AcceptType As String
Public AcceptType As String
public:
String^ AcceptType
public:
String^ AcceptType
val mutable AcceptType: string
val mutable AcceptType: string

Field Value

Type: Online String
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams.Body Field

WebClient RequestParams Body Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Body
public string Body
Public Body As String
Public Body As String
public:
String^ Body
public:
String^ Body
val mutable Body: string
val mutable Body: string

Field Value

Type: Online String
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams.BodyParameters Field

WebClient RequestParams BodyParameters Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> BodyParameters
public IDictionary<string, string> BodyParameters
Public BodyParameters As IDictionary(Of String, String)
Public BodyParameters As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ BodyParameters
public:
IDictionary<String^, String^>^ BodyParameters
val mutable BodyParameters: IDictionary<string, string>
val mutable BodyParameters: IDictionary<string, string>

Field Value

Type: Online IDictionary Online String, Online String
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams.Caller Field

WebClient RequestParams Caller Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IWebClientCaller Caller
public readonly IWebClientCaller Caller
Public ReadOnly Caller As IWebClientCaller
Public ReadOnly Caller As IWebClientCaller
public:
initonly IWebClientCaller^ Caller
public:
initonly IWebClientCaller^ Caller
val Caller: IWebClientCaller
val Caller: IWebClientCaller

Field Value

Type: IWebClientCaller
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams.ContentType Field

WebClient RequestParams ContentType Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ContentType
public string ContentType
Public ContentType As String
Public ContentType As String
public:
String^ ContentType
public:
String^ ContentType
val mutable ContentType: string
val mutable ContentType: string

Field Value

Type: Online String
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams.Headers Field

WebClient RequestParams Headers Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> Headers
public IDictionary<string, string> Headers
Public Headers As IDictionary(Of String, String)
Public Headers As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ Headers
public:
IDictionary<String^, String^>^ Headers
val mutable Headers: IDictionary<string, string>
val mutable Headers: IDictionary<string, string>

Field Value

Type: Online IDictionary Online String, Online String
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams.Method Field

WebClient RequestParams Method Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HTTPRequestMethod Method
public HTTPRequestMethod Method
Public Method As HTTPRequestMethod
Public Method As HTTPRequestMethod
public:
HTTPRequestMethod Method
public:
HTTPRequestMethod Method
val mutable Method: HTTPRequestMethod
val mutable Method: HTTPRequestMethod

Field Value

Type: HTTPRequestMethod
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams.Password Field

WebClient RequestParams Password Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Password
public string Password
Public Password As String
Public Password As String
public:
String^ Password
public:
String^ Password
val mutable Password: string
val mutable Password: string

Field Value

Type: Online String
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams.QueryParameters Field

WebClient RequestParams QueryParameters Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> QueryParameters
public IDictionary<string, string> QueryParameters
Public QueryParameters As IDictionary(Of String, String)
Public QueryParameters As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ QueryParameters
public:
IDictionary<String^, String^>^ QueryParameters
val mutable QueryParameters: IDictionary<string, string>
val mutable QueryParameters: IDictionary<string, string>

Field Value

Type: Online IDictionary Online String, Online String
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams.UserName Field

WebClient RequestParams UserName Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UserName
public string UserName
Public UserName As String
Public UserName As String
public:
String^ UserName
public:
String^ UserName
val mutable UserName: string
val mutable UserName: string

Field Value

Type: Online String
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams Methods

WebClient RequestParams Methods NFX Class Library

The WebClient RequestParams type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBody |
Public method | GetCredentials |
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | GetHeaders |
Public method | GetQueryString |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WebClient RequestParams Structure
NFX.Web Namespace


WebClient.RequestParams.GetBody Method

WebClient RequestParams GetBody Method NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetBody()
public string GetBody()
Public Function GetBody As String
Public Function GetBody As String
public:
String^ GetBody()
public:
String^ GetBody()
member GetBody : unit -> string
member GetBody : unit -> string

Return Value

Type: Online String
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams.GetCredentials Method

WebClient RequestParams GetCredentials Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICredentials GetCredentials()
public ICredentials GetCredentials()
Public Function GetCredentials As ICredentials
Public Function GetCredentials As ICredentials
public:
ICredentials^ GetCredentials()
public:
ICredentials^ GetCredentials()
member GetCredentials : unit -> ICredentials
member GetCredentials : unit -> ICredentials

Return Value

Type: Online ICredentials
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams.GetHeaders Method

WebClient RequestParams GetHeaders Method NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebHeaderCollection GetHeaders()
public WebHeaderCollection GetHeaders()
Public Function GetHeaders As WebHeaderCollection
Public Function GetHeaders As WebHeaderCollection
public:
WebHeaderCollection^ GetHeaders()
public:
WebHeaderCollection^ GetHeaders()
member GetHeaders : unit -> WebHeaderCollection
member GetHeaders : unit -> WebHeaderCollection

Return Value

Type: Online WebHeaderCollection
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams.GetQueryString Method

WebClient RequestParams GetQueryString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NameValueCollection GetQueryString()
public NameValueCollection GetQueryString()
Public Function GetQueryString As NameValueCollection
Public Function GetQueryString As NameValueCollection
public:
NameValueCollection^ GetQueryString()
public:
NameValueCollection^ GetQueryString()
member GetQueryString : unit -> NameValueCollection
member GetQueryString : unit -> NameValueCollection

Return Value

Type: Online NameValueCollection
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams Properties

WebClient RequestParams Properties NFX Class Library

The WebClient RequestParams type exposes the following members.
Properties
 | Name | Description
Public property | HasBody |
Public property | HasCredentials |
Back to Top
See Also
WebClient RequestParams Structure
NFX.Web Namespace


WebClient.RequestParams.HasBody Property

WebClient RequestParams HasBody Property NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasBody { get; }
public bool HasBody { get; }
Public ReadOnly Property HasBody As Boolean
    Get
Public ReadOnly Property HasBody As Boolean
    Get
public:
property bool HasBody {
    bool get ();
}
public:
property bool HasBody {
    bool get ();
}
member HasBody : bool with get
member HasBody : bool with get

Property Value

Type: Online Boolean
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.RequestParams.HasCredentials Property

WebClient RequestParams HasCredentials Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasCredentials { get; }
public bool HasCredentials { get; }
Public ReadOnly Property HasCredentials As Boolean
    Get
Public ReadOnly Property HasCredentials As Boolean
    Get
public:
property bool HasCredentials {
    bool get ();
}
public:
property bool HasCredentials {
    bool get ();
}
member HasCredentials : bool with get
member HasCredentials : bool with get

Property Value

Type: Online Boolean
See Also
WebClient RequestParams Structure
WebClient RequestParams Members
NFX.Web Namespace


WebClient.WebClientTimeouted Class

WebClient WebClientTimeouted Class NFX Class Library

Provides WebClient functionality with timeout
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.ComponentModel Component
Online System.Net WebClient
NFX.Web WebClient WebClientTimeouted

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class WebClientTimeouted : WebClient
public class WebClientTimeouted : WebClient
Public Class WebClientTimeouted
    Inherits WebClient
Public Class WebClientTimeouted
    Inherits WebClient
public ref class WebClientTimeouted : public WebClient
public ref class WebClientTimeouted : public WebClient
type WebClientTimeouted =
    class
        inherit WebClient
    end
type WebClientTimeouted =
    class
        inherit WebClient
    end
See Also
WebClient WebClientTimeouted Members
NFX.Web Namespace


WebClient.WebClientTimeouted Members

WebClient WebClientTimeouted Members NFX Class Library

The WebClient WebClientTimeouted type exposes the following members.
Constructors
 | Name | Description
Public method | WebClient WebClientTimeouted | Initializes a new instance of the WebClient WebClientTimeouted class
Back to Top
Methods
 | Name | Description
Public method | Online CancelAsync | Cancels a pending asynchronous operation. (Inherited from Online WebClient.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Dispose | Releases all resources used by the Online Component. (Inherited from Online Component.)
Protected method | Online Dispose(Boolean) | Releases the unmanaged resources used by the Online Component and optionally releases the managed resources. (Inherited from Online Component.)
Public method | Online DownloadData(String) | Downloads the resource as a Online Byte array from the URI specified. (Inherited from Online WebClient.)
Public method | Online DownloadData(Uri) | Downloads the resource as a Online Byte array from the URI specified. (Inherited from Online WebClient.)
Public method | Online DownloadDataAsync(Uri) | Downloads the resource as a Online Byte array from the URI specified as an asynchronous operation. (Inherited from Online WebClient.)
Public method | Online DownloadDataAsync(Uri, Object) | Downloads the resource as a Online Byte array from the URI specified as an asynchronous operation. (Inherited from Online WebClient.)
Public method | DownloadDataTaskAsync(String) | Downloads the resource as a Online Byte array from the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | DownloadDataTaskAsync(Uri) | Downloads the resource as a Online Byte array from the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online DownloadFile(String, String) | Downloads the resource with the specified URI to a local file. (Inherited from Online WebClient.)
Public method | Online DownloadFile(Uri, String) | Downloads the resource with the specified URI to a local file. (Inherited from Online WebClient.)
Public method | Online DownloadFileAsync(Uri, String) | Downloads, to a local file, the resource with the specified URI. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online DownloadFileAsync(Uri, String, Object) | Downloads, to a local file, the resource with the specified URI. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | DownloadFileTaskAsync(String, String) | Downloads the specified resource to a local file as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | DownloadFileTaskAsync(Uri, String) | Downloads the specified resource to a local file as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online DownloadString(String) | Downloads the requested resource as a Online String. The resource to download is specified as a Online String containing the URI. (Inherited from Online WebClient.)
Public method | Online DownloadString(Uri) | Downloads the requested resource as a Online String. The resource to download is specified as a Online Uri. (Inherited from Online WebClient.)
Public method | Online DownloadStringAsync(Uri) | Downloads the resource specified as a Online Uri. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online DownloadStringAsync(Uri, Object) | Downloads the specified string to the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | DownloadStringTaskAsync(String) | Downloads the resource as a Online String from the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | DownloadStringTaskAsync(Uri) | Downloads the resource as a Online String from the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Releases unmanaged resources and performs other cleanup operations before the Online Component is reclaimed by garbage collection. (Inherited from Online Component.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online GetService | Returns an object that represents a service provided by the Online Component or by its Online Container. (Inherited from Online Component.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | GetWebRequest | (Overrides Online WebClient GetWebRequest(Uri).)
Protected method | Online GetWebResponse(WebRequest) | Returns the Online WebResponse for the specified Online WebRequest. (Inherited from Online WebClient.)
Protected method | Online GetWebResponse(WebRequest, IAsyncResult) | Returns the Online WebResponse for the specified Online WebRequest using the specified Online IAsyncResult. (Inherited from Online WebClient.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online OnDownloadDataCompleted | Raises the Online DownloadDataCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnDownloadFileCompleted | Raises the Online DownloadFileCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnDownloadProgressChanged | Raises the Online DownloadProgressChanged event. (Inherited from Online WebClient.)
Protected method | Online OnDownloadStringCompleted | Raises the Online DownloadStringCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnOpenReadCompleted | Raises the Online OpenReadCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnOpenWriteCompleted | Raises the Online OpenWriteCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnUploadDataCompleted | Raises the Online UploadDataCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnUploadFileCompleted | Raises the Online UploadFileCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnUploadProgressChanged | Raises the Online UploadProgressChanged event. (Inherited from Online WebClient.)
Protected method | Online OnUploadStringCompleted | Raises the Online UploadStringCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnUploadValuesCompleted | Raises the Online UploadValuesCompleted event. (Inherited from Online WebClient.)
Protected method | OnWriteStreamClosed | Obsolete. Raises the WriteStreamClosed event. (Inherited from Online WebClient.)
Public method | Online OpenRead(String) | Opens a readable stream for the data downloaded from a resource with the URI specified as a Online String. (Inherited from Online WebClient.)
Public method | Online OpenRead(Uri) | Opens a readable stream for the data downloaded from a resource with the URI specified as a Online Uri (Inherited from Online WebClient.)
Public method | Online OpenReadAsync(Uri) | Opens a readable stream containing the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online OpenReadAsync(Uri, Object) | Opens a readable stream containing the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | OpenReadTaskAsync(String) | Opens a readable stream containing the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | OpenReadTaskAsync(Uri) | Opens a readable stream containing the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online OpenWrite(String) | Opens a stream for writing data to the specified resource. (Inherited from Online WebClient.)
Public method | Online OpenWrite(Uri) | Opens a stream for writing data to the specified resource. (Inherited from Online WebClient.)
Public method | Online OpenWrite(String, String) | Opens a stream for writing data to the specified resource, using the specified method. (Inherited from Online WebClient.)
Public method | Online OpenWrite(Uri, String) | Opens a stream for writing data to the specified resource, by using the specified method. (Inherited from Online WebClient.)
Public method | Online OpenWriteAsync(Uri) | Opens a stream for writing data to the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online OpenWriteAsync(Uri, String) | Opens a stream for writing data to the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online OpenWriteAsync(Uri, String, Object) | Opens a stream for writing data to the specified resource, using the specified method. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | OpenWriteTaskAsync(String) | Opens a stream for writing data to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | OpenWriteTaskAsync(Uri) | Opens a stream for writing data to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | OpenWriteTaskAsync(String, String) | Opens a stream for writing data to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | OpenWriteTaskAsync(Uri, String) | Opens a stream for writing data to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online ToString | Returns a Online String containing the name of the Online Component, if any. This method should not be overridden. (Inherited from Online Component.)
Public method | Online UploadData(String, Byte ) | Uploads a data buffer to a resource identified by a URI. (Inherited from Online WebClient.)
Public method | Online UploadData(Uri, Byte ) | Uploads a data buffer to a resource identified by a URI. (Inherited from Online WebClient.)
Public method | Online UploadData(String, String, Byte ) | Uploads a data buffer to the specified resource, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadData(Uri, String, Byte ) | Uploads a data buffer to the specified resource, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadDataAsync(Uri, Byte ) | Uploads a data buffer to a resource identified by a URI, using the POST method. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadDataAsync(Uri, String, Byte ) | Uploads a data buffer to a resource identified by a URI, using the specified method. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadDataAsync(Uri, String, Byte , Object) | Uploads a data buffer to a resource identified by a URI, using the specified method and identifying token. (Inherited from Online WebClient.)
Public method | UploadDataTaskAsync(String, Byte ) | Uploads a data buffer that contains a Online Byte array to the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadDataTaskAsync(Uri, Byte ) | Uploads a data buffer that contains a Online Byte array to the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadDataTaskAsync(String, String, Byte ) | Uploads a data buffer that contains a Online Byte array to the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadDataTaskAsync(Uri, String, Byte ) | Uploads a data buffer that contains a Online Byte array to the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online UploadFile(String, String) | Uploads the specified local file to a resource with the specified URI. (Inherited from Online WebClient.)
Public method | Online UploadFile(Uri, String) | Uploads the specified local file to a resource with the specified URI. (Inherited from Online WebClient.)
Public method | Online UploadFile(String, String, String) | Uploads the specified local file to the specified resource, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadFile(Uri, String, String) | Uploads the specified local file to the specified resource, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadFileAsync(Uri, String) | Uploads the specified local file to the specified resource, using the POST method. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadFileAsync(Uri, String, String) | Uploads the specified local file to the specified resource, using the POST method. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadFileAsync(Uri, String, String, Object) | Uploads the specified local file to the specified resource, using the POST method. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | UploadFileTaskAsync(String, String) | Uploads the specified local file to a resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadFileTaskAsync(Uri, String) | Uploads the specified local file to a resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadFileTaskAsync(String, String, String) | Uploads the specified local file to a resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadFileTaskAsync(Uri, String, String) | Uploads the specified local file to a resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online UploadString(String, String) | Uploads the specified string to the specified resource, using the POST method. (Inherited from Online WebClient.)
Public method | Online UploadString(Uri, String) | Uploads the specified string to the specified resource, using the POST method. (Inherited from Online WebClient.)
Public method | Online UploadString(String, String, String) | Uploads the specified string to the specified resource, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadString(Uri, String, String) | Uploads the specified string to the specified resource, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadStringAsync(Uri, String) | Uploads the specified string to the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadStringAsync(Uri, String, String) | Uploads the specified string to the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadStringAsync(Uri, String, String, Object) | Uploads the specified string to the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | UploadStringTaskAsync(String, String) | Uploads the specified string to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadStringTaskAsync(Uri, String) | Uploads the specified string to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadStringTaskAsync(String, String, String) | Uploads the specified string to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadStringTaskAsync(Uri, String, String) | Uploads the specified string to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online UploadValues(String, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI. (Inherited from Online WebClient.)
Public method | Online UploadValues(Uri, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI. (Inherited from Online WebClient.)
Public method | Online UploadValues(String, String, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadValues(Uri, String, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadValuesAsync(Uri, NameValueCollection) | Uploads the data in the specified name/value collection to the resource identified by the specified URI. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadValuesAsync(Uri, String, NameValueCollection) | Uploads the data in the specified name/value collection to the resource identified by the specified URI, using the specified method. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadValuesAsync(Uri, String, NameValueCollection, Object) | Uploads the data in the specified name/value collection to the resource identified by the specified URI, using the specified method. This method does not block the calling thread, and allows the caller to pass an object to the method that is invoked when the operation completes. (Inherited from Online WebClient.)
Public method | UploadValuesTaskAsync(String, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadValuesTaskAsync(Uri, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadValuesTaskAsync(String, String, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadValuesTaskAsync(Uri, String, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AllowReadStreamBuffering | Obsolete. Gets or sets a value that indicates whether to buffer the data read from the Internet resource for a Online WebClient instance. (Inherited from Online WebClient.)
Public property | AllowWriteStreamBuffering | Obsolete. Gets or sets a value that indicates whether to buffer the data written to the Internet resource for a Online WebClient instance. (Inherited from Online WebClient.)
Public property | Online BaseAddress | Gets or sets the base URI for requests made by a Online WebClient. (Inherited from Online WebClient.)
Public property | Online CachePolicy | Gets or sets the application's cache policy for any resources obtained by this WebClient instance using Online WebRequest objects. (Inherited from Online WebClient.)
Protected property | Online CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Online Component.)
Public property | Online Container | Gets the Online IContainer that contains the Online Component. (Inherited from Online Component.)
Public property | Online Credentials | Gets or sets the network credentials that are sent to the host and used to authenticate the request. (Inherited from Online WebClient.)
Protected property | Online DesignMode | Gets a value that indicates whether the Online Component is currently in design mode. (Inherited from Online Component.)
Public property | Online Encoding | Gets and sets the Online Encoding used to upload and download strings. (Inherited from Online WebClient.)
Protected property | Online Events | Gets the list of event handlers that are attached to this Online Component. (Inherited from Online Component.)
Public property | Online Headers | Gets or sets a collection of header name/value pairs associated with the request. (Inherited from Online WebClient.)
Public property | Online IsBusy | Gets whether a Web request is in progress. (Inherited from Online WebClient.)
Public property | Online Proxy | Gets or sets the proxy used by this Online WebClient object. (Inherited from Online WebClient.)
Public property | Online QueryString | Gets or sets a collection of query name/value pairs associated with the request. (Inherited from Online WebClient.)
Public property | Online ResponseHeaders | Gets a collection of header name/value pairs associated with the response. (Inherited from Online WebClient.)
Public property | Online Site | Gets or sets the Online ISite of the Online Component. (Inherited from Online Component.)
Public property | Online UseDefaultCredentials | Gets or sets a Online Boolean value that controls whether the Online DefaultCredentials are sent with requests. (Inherited from Online WebClient.)
Back to Top
Events
 | Name | Description
Public event | Online Disposed | Occurs when the component is disposed by a call to the Online Dispose method. (Inherited from Online Component.)
Public event | Online DownloadDataCompleted | Occurs when an asynchronous data download operation completes. (Inherited from Online WebClient.)
Public event | Online DownloadFileCompleted | Occurs when an asynchronous file download operation completes. (Inherited from Online WebClient.)
Public event | Online DownloadProgressChanged | Occurs when an asynchronous download operation successfully transfers some or all of the data. (Inherited from Online WebClient.)
Public event | Online DownloadStringCompleted | Occurs when an asynchronous resource-download operation completes. (Inherited from Online WebClient.)
Public event | Online OpenReadCompleted | Occurs when an asynchronous operation to open a stream containing a resource completes. (Inherited from Online WebClient.)
Public event | Online OpenWriteCompleted | Occurs when an asynchronous operation to open a stream to write data to a resource completes. (Inherited from Online WebClient.)
Public event | Online UploadDataCompleted | Occurs when an asynchronous data-upload operation completes. (Inherited from Online WebClient.)
Public event | Online UploadFileCompleted | Occurs when an asynchronous file-upload operation completes. (Inherited from Online WebClient.)
Public event | Online UploadProgressChanged | Occurs when an asynchronous upload operation successfully transfers some or all of the data. (Inherited from Online WebClient.)
Public event | Online UploadStringCompleted | Occurs when an asynchronous string-upload operation completes. (Inherited from Online WebClient.)
Public event | Online UploadValuesCompleted | Occurs when an asynchronous upload of a name/value collection completes. (Inherited from Online WebClient.)
Public event | WriteStreamClosed | Obsolete. Occurs when an asynchronous operation to write data to a resource using a write stream is closed. (Inherited from Online WebClient.)
Back to Top
See Also
WebClient WebClientTimeouted Class
NFX.Web Namespace


WebClient.WebClientTimeouted Constructor

WebClient WebClientTimeouted Constructor NFX Class Library

Initializes a new instance of the WebClient WebClientTimeouted class

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebClientTimeouted(
    IWebClientCaller caller
)
public WebClientTimeouted(
    IWebClientCaller caller
)
Public Sub New (
    caller As IWebClientCaller
)
Public Sub New (
    caller As IWebClientCaller
)
public:
WebClientTimeouted(
    IWebClientCaller^ caller
)
public:
WebClientTimeouted(
    IWebClientCaller^ caller
)
new :
        caller : IWebClientCaller -> WebClientTimeouted
new :
        caller : IWebClientCaller -> WebClientTimeouted

Parameters

caller
Type: NFX.Web IWebClientCaller
See Also
WebClient WebClientTimeouted Class
WebClient WebClientTimeouted Members
NFX.Web Namespace


WebClient.WebClientTimeouted Methods

WebClient WebClientTimeouted Methods NFX Class Library

The WebClient WebClientTimeouted type exposes the following members.
Methods
 | Name | Description
Public method | Online CancelAsync | Cancels a pending asynchronous operation. (Inherited from Online WebClient.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Dispose | Releases all resources used by the Online Component. (Inherited from Online Component.)
Protected method | Online Dispose(Boolean) | Releases the unmanaged resources used by the Online Component and optionally releases the managed resources. (Inherited from Online Component.)
Public method | Online DownloadData(String) | Downloads the resource as a Online Byte array from the URI specified. (Inherited from Online WebClient.)
Public method | Online DownloadData(Uri) | Downloads the resource as a Online Byte array from the URI specified. (Inherited from Online WebClient.)
Public method | Online DownloadDataAsync(Uri) | Downloads the resource as a Online Byte array from the URI specified as an asynchronous operation. (Inherited from Online WebClient.)
Public method | Online DownloadDataAsync(Uri, Object) | Downloads the resource as a Online Byte array from the URI specified as an asynchronous operation. (Inherited from Online WebClient.)
Public method | DownloadDataTaskAsync(String) | Downloads the resource as a Online Byte array from the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | DownloadDataTaskAsync(Uri) | Downloads the resource as a Online Byte array from the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online DownloadFile(String, String) | Downloads the resource with the specified URI to a local file. (Inherited from Online WebClient.)
Public method | Online DownloadFile(Uri, String) | Downloads the resource with the specified URI to a local file. (Inherited from Online WebClient.)
Public method | Online DownloadFileAsync(Uri, String) | Downloads, to a local file, the resource with the specified URI. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online DownloadFileAsync(Uri, String, Object) | Downloads, to a local file, the resource with the specified URI. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | DownloadFileTaskAsync(String, String) | Downloads the specified resource to a local file as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | DownloadFileTaskAsync(Uri, String) | Downloads the specified resource to a local file as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online DownloadString(String) | Downloads the requested resource as a Online String. The resource to download is specified as a Online String containing the URI. (Inherited from Online WebClient.)
Public method | Online DownloadString(Uri) | Downloads the requested resource as a Online String. The resource to download is specified as a Online Uri. (Inherited from Online WebClient.)
Public method | Online DownloadStringAsync(Uri) | Downloads the resource specified as a Online Uri. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online DownloadStringAsync(Uri, Object) | Downloads the specified string to the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | DownloadStringTaskAsync(String) | Downloads the resource as a Online String from the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | DownloadStringTaskAsync(Uri) | Downloads the resource as a Online String from the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Releases unmanaged resources and performs other cleanup operations before the Online Component is reclaimed by garbage collection. (Inherited from Online Component.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online GetService | Returns an object that represents a service provided by the Online Component or by its Online Container. (Inherited from Online Component.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | GetWebRequest | (Overrides Online WebClient GetWebRequest(Uri).)
Protected method | Online GetWebResponse(WebRequest) | Returns the Online WebResponse for the specified Online WebRequest. (Inherited from Online WebClient.)
Protected method | Online GetWebResponse(WebRequest, IAsyncResult) | Returns the Online WebResponse for the specified Online WebRequest using the specified Online IAsyncResult. (Inherited from Online WebClient.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online OnDownloadDataCompleted | Raises the Online DownloadDataCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnDownloadFileCompleted | Raises the Online DownloadFileCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnDownloadProgressChanged | Raises the Online DownloadProgressChanged event. (Inherited from Online WebClient.)
Protected method | Online OnDownloadStringCompleted | Raises the Online DownloadStringCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnOpenReadCompleted | Raises the Online OpenReadCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnOpenWriteCompleted | Raises the Online OpenWriteCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnUploadDataCompleted | Raises the Online UploadDataCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnUploadFileCompleted | Raises the Online UploadFileCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnUploadProgressChanged | Raises the Online UploadProgressChanged event. (Inherited from Online WebClient.)
Protected method | Online OnUploadStringCompleted | Raises the Online UploadStringCompleted event. (Inherited from Online WebClient.)
Protected method | Online OnUploadValuesCompleted | Raises the Online UploadValuesCompleted event. (Inherited from Online WebClient.)
Protected method | OnWriteStreamClosed | Obsolete. Raises the WriteStreamClosed event. (Inherited from Online WebClient.)
Public method | Online OpenRead(String) | Opens a readable stream for the data downloaded from a resource with the URI specified as a Online String. (Inherited from Online WebClient.)
Public method | Online OpenRead(Uri) | Opens a readable stream for the data downloaded from a resource with the URI specified as a Online Uri (Inherited from Online WebClient.)
Public method | Online OpenReadAsync(Uri) | Opens a readable stream containing the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online OpenReadAsync(Uri, Object) | Opens a readable stream containing the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | OpenReadTaskAsync(String) | Opens a readable stream containing the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | OpenReadTaskAsync(Uri) | Opens a readable stream containing the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online OpenWrite(String) | Opens a stream for writing data to the specified resource. (Inherited from Online WebClient.)
Public method | Online OpenWrite(Uri) | Opens a stream for writing data to the specified resource. (Inherited from Online WebClient.)
Public method | Online OpenWrite(String, String) | Opens a stream for writing data to the specified resource, using the specified method. (Inherited from Online WebClient.)
Public method | Online OpenWrite(Uri, String) | Opens a stream for writing data to the specified resource, by using the specified method. (Inherited from Online WebClient.)
Public method | Online OpenWriteAsync(Uri) | Opens a stream for writing data to the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online OpenWriteAsync(Uri, String) | Opens a stream for writing data to the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online OpenWriteAsync(Uri, String, Object) | Opens a stream for writing data to the specified resource, using the specified method. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | OpenWriteTaskAsync(String) | Opens a stream for writing data to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | OpenWriteTaskAsync(Uri) | Opens a stream for writing data to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | OpenWriteTaskAsync(String, String) | Opens a stream for writing data to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | OpenWriteTaskAsync(Uri, String) | Opens a stream for writing data to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online ToString | Returns a Online String containing the name of the Online Component, if any. This method should not be overridden. (Inherited from Online Component.)
Public method | Online UploadData(String, Byte ) | Uploads a data buffer to a resource identified by a URI. (Inherited from Online WebClient.)
Public method | Online UploadData(Uri, Byte ) | Uploads a data buffer to a resource identified by a URI. (Inherited from Online WebClient.)
Public method | Online UploadData(String, String, Byte ) | Uploads a data buffer to the specified resource, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadData(Uri, String, Byte ) | Uploads a data buffer to the specified resource, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadDataAsync(Uri, Byte ) | Uploads a data buffer to a resource identified by a URI, using the POST method. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadDataAsync(Uri, String, Byte ) | Uploads a data buffer to a resource identified by a URI, using the specified method. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadDataAsync(Uri, String, Byte , Object) | Uploads a data buffer to a resource identified by a URI, using the specified method and identifying token. (Inherited from Online WebClient.)
Public method | UploadDataTaskAsync(String, Byte ) | Uploads a data buffer that contains a Online Byte array to the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadDataTaskAsync(Uri, Byte ) | Uploads a data buffer that contains a Online Byte array to the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadDataTaskAsync(String, String, Byte ) | Uploads a data buffer that contains a Online Byte array to the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadDataTaskAsync(Uri, String, Byte ) | Uploads a data buffer that contains a Online Byte array to the URI specified as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online UploadFile(String, String) | Uploads the specified local file to a resource with the specified URI. (Inherited from Online WebClient.)
Public method | Online UploadFile(Uri, String) | Uploads the specified local file to a resource with the specified URI. (Inherited from Online WebClient.)
Public method | Online UploadFile(String, String, String) | Uploads the specified local file to the specified resource, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadFile(Uri, String, String) | Uploads the specified local file to the specified resource, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadFileAsync(Uri, String) | Uploads the specified local file to the specified resource, using the POST method. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadFileAsync(Uri, String, String) | Uploads the specified local file to the specified resource, using the POST method. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadFileAsync(Uri, String, String, Object) | Uploads the specified local file to the specified resource, using the POST method. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | UploadFileTaskAsync(String, String) | Uploads the specified local file to a resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadFileTaskAsync(Uri, String) | Uploads the specified local file to a resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadFileTaskAsync(String, String, String) | Uploads the specified local file to a resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadFileTaskAsync(Uri, String, String) | Uploads the specified local file to a resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online UploadString(String, String) | Uploads the specified string to the specified resource, using the POST method. (Inherited from Online WebClient.)
Public method | Online UploadString(Uri, String) | Uploads the specified string to the specified resource, using the POST method. (Inherited from Online WebClient.)
Public method | Online UploadString(String, String, String) | Uploads the specified string to the specified resource, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadString(Uri, String, String) | Uploads the specified string to the specified resource, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadStringAsync(Uri, String) | Uploads the specified string to the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadStringAsync(Uri, String, String) | Uploads the specified string to the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadStringAsync(Uri, String, String, Object) | Uploads the specified string to the specified resource. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | UploadStringTaskAsync(String, String) | Uploads the specified string to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadStringTaskAsync(Uri, String) | Uploads the specified string to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadStringTaskAsync(String, String, String) | Uploads the specified string to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadStringTaskAsync(Uri, String, String) | Uploads the specified string to the specified resource as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | Online UploadValues(String, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI. (Inherited from Online WebClient.)
Public method | Online UploadValues(Uri, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI. (Inherited from Online WebClient.)
Public method | Online UploadValues(String, String, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadValues(Uri, String, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI, using the specified method. (Inherited from Online WebClient.)
Public method | Online UploadValuesAsync(Uri, NameValueCollection) | Uploads the data in the specified name/value collection to the resource identified by the specified URI. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadValuesAsync(Uri, String, NameValueCollection) | Uploads the data in the specified name/value collection to the resource identified by the specified URI, using the specified method. This method does not block the calling thread. (Inherited from Online WebClient.)
Public method | Online UploadValuesAsync(Uri, String, NameValueCollection, Object) | Uploads the data in the specified name/value collection to the resource identified by the specified URI, using the specified method. This method does not block the calling thread, and allows the caller to pass an object to the method that is invoked when the operation completes. (Inherited from Online WebClient.)
Public method | UploadValuesTaskAsync(String, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadValuesTaskAsync(Uri, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadValuesTaskAsync(String, String, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Public method | UploadValuesTaskAsync(Uri, String, NameValueCollection) | Uploads the specified name/value collection to the resource identified by the specified URI as an asynchronous operation using a task object. (Inherited from Online WebClient.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WebClient WebClientTimeouted Class
NFX.Web Namespace


WebClient.WebClientTimeouted.GetWebRequest Method

WebClient WebClientTimeouted GetWebRequest Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override WebRequest GetWebRequest(
    Uri uri
)
protected override WebRequest GetWebRequest(
    Uri uri
)
Protected Overrides Function GetWebRequest (
    uri As Uri
) As WebRequest
Protected Overrides Function GetWebRequest (
    uri As Uri
) As WebRequest
protected:
virtual WebRequest^ GetWebRequest(
    Uri^ uri
) override
protected:
virtual WebRequest^ GetWebRequest(
    Uri^ uri
) override
abstract GetWebRequest :
        uri : Uri -> WebRequest
override GetWebRequest :
        uri : Uri -> WebRequest
abstract GetWebRequest :
        uri : Uri -> WebRequest
override GetWebRequest :
        uri : Uri -> WebRequest

Parameters

uri
Type: Online System Uri

Return Value

Type: Online WebRequest
See Also
WebClient WebClientTimeouted Class
WebClient WebClientTimeouted Members
NFX.Web Namespace


WebClient.WebClientTimeouted Properties

WebClient WebClientTimeouted Properties NFX Class Library

The WebClient WebClientTimeouted type exposes the following members.
Properties
 | Name | Description
Public property | AllowReadStreamBuffering | Obsolete. Gets or sets a value that indicates whether to buffer the data read from the Internet resource for a Online WebClient instance. (Inherited from Online WebClient.)
Public property | AllowWriteStreamBuffering | Obsolete. Gets or sets a value that indicates whether to buffer the data written to the Internet resource for a Online WebClient instance. (Inherited from Online WebClient.)
Public property | Online BaseAddress | Gets or sets the base URI for requests made by a Online WebClient. (Inherited from Online WebClient.)
Public property | Online CachePolicy | Gets or sets the application's cache policy for any resources obtained by this WebClient instance using Online WebRequest objects. (Inherited from Online WebClient.)
Protected property | Online CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Online Component.)
Public property | Online Container | Gets the Online IContainer that contains the Online Component. (Inherited from Online Component.)
Public property | Online Credentials | Gets or sets the network credentials that are sent to the host and used to authenticate the request. (Inherited from Online WebClient.)
Protected property | Online DesignMode | Gets a value that indicates whether the Online Component is currently in design mode. (Inherited from Online Component.)
Public property | Online Encoding | Gets and sets the Online Encoding used to upload and download strings. (Inherited from Online WebClient.)
Protected property | Online Events | Gets the list of event handlers that are attached to this Online Component. (Inherited from Online Component.)
Public property | Online Headers | Gets or sets a collection of header name/value pairs associated with the request. (Inherited from Online WebClient.)
Public property | Online IsBusy | Gets whether a Web request is in progress. (Inherited from Online WebClient.)
Public property | Online Proxy | Gets or sets the proxy used by this Online WebClient object. (Inherited from Online WebClient.)
Public property | Online QueryString | Gets or sets a collection of query name/value pairs associated with the request. (Inherited from Online WebClient.)
Public property | Online ResponseHeaders | Gets a collection of header name/value pairs associated with the response. (Inherited from Online WebClient.)
Public property | Online Site | Gets or sets the Online ISite of the Online Component. (Inherited from Online Component.)
Public property | Online UseDefaultCredentials | Gets or sets a Online Boolean value that controls whether the Online DefaultCredentials are sent with requests. (Inherited from Online WebClient.)
Back to Top
See Also
WebClient WebClientTimeouted Class
NFX.Web Namespace


WebClient.WebClientTimeouted Events

WebClient WebClientTimeouted Events NFX Class Library

The WebClient WebClientTimeouted type exposes the following members.
Events
 | Name | Description
Public event | Online Disposed | Occurs when the component is disposed by a call to the Online Dispose method. (Inherited from Online Component.)
Public event | Online DownloadDataCompleted | Occurs when an asynchronous data download operation completes. (Inherited from Online WebClient.)
Public event | Online DownloadFileCompleted | Occurs when an asynchronous file download operation completes. (Inherited from Online WebClient.)
Public event | Online DownloadProgressChanged | Occurs when an asynchronous download operation successfully transfers some or all of the data. (Inherited from Online WebClient.)
Public event | Online DownloadStringCompleted | Occurs when an asynchronous resource-download operation completes. (Inherited from Online WebClient.)
Public event | Online OpenReadCompleted | Occurs when an asynchronous operation to open a stream containing a resource completes. (Inherited from Online WebClient.)
Public event | Online OpenWriteCompleted | Occurs when an asynchronous operation to open a stream to write data to a resource completes. (Inherited from Online WebClient.)
Public event | Online UploadDataCompleted | Occurs when an asynchronous data-upload operation completes. (Inherited from Online WebClient.)
Public event | Online UploadFileCompleted | Occurs when an asynchronous file-upload operation completes. (Inherited from Online WebClient.)
Public event | Online UploadProgressChanged | Occurs when an asynchronous upload operation successfully transfers some or all of the data. (Inherited from Online WebClient.)
Public event | Online UploadStringCompleted | Occurs when an asynchronous string-upload operation completes. (Inherited from Online WebClient.)
Public event | Online UploadValuesCompleted | Occurs when an asynchronous upload of a name/value collection completes. (Inherited from Online WebClient.)
Public event | WriteStreamClosed | Obsolete. Occurs when an asynchronous operation to write data to a resource using a write stream is closed. (Inherited from Online WebClient.)
Back to Top
See Also
WebClient WebClientTimeouted Class
NFX.Web Namespace


WebConsts Class

WebConsts Class NFX Class Library

Non-localizable constants
Inheritance Hierarchy
Online System Object
NFX.Web WebConsts

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class WebConsts
public static class WebConsts
Public NotInheritable Class WebConsts
Public NotInheritable Class WebConsts
public ref class WebConsts abstract sealed
public ref class WebConsts abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WebConsts =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WebConsts =  class end
See Also
WebConsts Members
NFX.Web Namespace


WebConsts Members

WebConsts Members NFX Class Library

The WebConsts type exposes the following members.
Methods
Name | Description
GetRedirectStatusCode |
GetRedirectStatusDescription |
Back to Top
Fields
Name | Description
HTTP_DELETE |
HTTP_GET |
HTTP_HDR_ACCEPT |
HTTP_HDR_AUTHORIZATION |
HTTP_HDR_CONTENT_DISPOSITION |
HTTP_PATCH |
HTTP_POST |
HTTP_PUT |
HTTP_SET_COOKIE |
HTTP_WWW_AUTHENTICATE |
STATUS_200 |
STATUS_200_DESCRIPTION |
STATUS_400 |
STATUS_400_DESCRIPTION |
STATUS_401 |
STATUS_401_DESCRIPTION |
STATUS_403 |
STATUS_403_DESCRIPTION |
STATUS_404 |
STATUS_404_DESCRIPTION |
STATUS_405 |
STATUS_405_DESCRIPTION |
STATUS_406 |
STATUS_406_DESCRIPTION |
STATUS_429 |
STATUS_429_DESCRIPTION |
STATUS_500 |
STATUS_500_DESCRIPTION |
Back to Top
See Also
WebConsts Class
NFX.Web Namespace


WebConsts Fields

WebConsts Fields NFX Class Library

The WebConsts type exposes the following members.
Fields
Name | Description
HTTP_DELETE |
HTTP_GET |
HTTP_HDR_ACCEPT |
HTTP_HDR_AUTHORIZATION |
HTTP_HDR_CONTENT_DISPOSITION |
HTTP_PATCH |
HTTP_POST |
HTTP_PUT |
HTTP_SET_COOKIE |
HTTP_WWW_AUTHENTICATE |
STATUS_200 |
STATUS_200_DESCRIPTION |
STATUS_400 |
STATUS_400_DESCRIPTION |
STATUS_401 |
STATUS_401_DESCRIPTION |
STATUS_403 |
STATUS_403_DESCRIPTION |
STATUS_404 |
STATUS_404_DESCRIPTION |
STATUS_405 |
STATUS_405_DESCRIPTION |
STATUS_406 |
STATUS_406_DESCRIPTION |
STATUS_429 |
STATUS_429_DESCRIPTION |
STATUS_500 |
STATUS_500_DESCRIPTION |
Back to Top
See Also
WebConsts Class
NFX.Web Namespace


WebConsts.HTTP_DELETE Field

WebConsts HTTP_DELETE Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HTTP_DELETE
public const string HTTP_DELETE
Public Const HTTP_DELETE As String
Public Const HTTP_DELETE As String
public:
literal String^ HTTP_DELETE
public:
literal String^ HTTP_DELETE
static val mutable HTTP_DELETE: string
static val mutable HTTP_DELETE: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.HTTP_GET Field

WebConsts HTTP_GET Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HTTP_GET
public const string HTTP_GET
Public Const HTTP_GET As String
Public Const HTTP_GET As String
public:
literal String^ HTTP_GET
public:
literal String^ HTTP_GET
static val mutable HTTP_GET: string
static val mutable HTTP_GET: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.HTTP_HDR_ACCEPT Field

WebConsts HTTP_HDR_ACCEPT Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HTTP_HDR_ACCEPT
public const string HTTP_HDR_ACCEPT
Public Const HTTP_HDR_ACCEPT As String
Public Const HTTP_HDR_ACCEPT As String
public:
literal String^ HTTP_HDR_ACCEPT
public:
literal String^ HTTP_HDR_ACCEPT
static val mutable HTTP_HDR_ACCEPT: string
static val mutable HTTP_HDR_ACCEPT: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.HTTP_HDR_AUTHORIZATION Field

WebConsts HTTP_HDR_AUTHORIZATION Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HTTP_HDR_AUTHORIZATION
public const string HTTP_HDR_AUTHORIZATION
Public Const HTTP_HDR_AUTHORIZATION As String
Public Const HTTP_HDR_AUTHORIZATION As String
public:
literal String^ HTTP_HDR_AUTHORIZATION
public:
literal String^ HTTP_HDR_AUTHORIZATION
static val mutable HTTP_HDR_AUTHORIZATION: string
static val mutable HTTP_HDR_AUTHORIZATION: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.HTTP_HDR_CONTENT_DISPOSITION Field

WebConsts HTTP_HDR_CONTENT_DISPOSITION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HTTP_HDR_CONTENT_DISPOSITION
public const string HTTP_HDR_CONTENT_DISPOSITION
Public Const HTTP_HDR_CONTENT_DISPOSITION As String
Public Const HTTP_HDR_CONTENT_DISPOSITION As String
public:
literal String^ HTTP_HDR_CONTENT_DISPOSITION
public:
literal String^ HTTP_HDR_CONTENT_DISPOSITION
static val mutable HTTP_HDR_CONTENT_DISPOSITION: string
static val mutable HTTP_HDR_CONTENT_DISPOSITION: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.HTTP_PATCH Field

WebConsts HTTP_PATCH Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HTTP_PATCH
public const string HTTP_PATCH
Public Const HTTP_PATCH As String
Public Const HTTP_PATCH As String
public:
literal String^ HTTP_PATCH
public:
literal String^ HTTP_PATCH
static val mutable HTTP_PATCH: string
static val mutable HTTP_PATCH: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.HTTP_POST Field

WebConsts HTTP_POST Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HTTP_POST
public const string HTTP_POST
Public Const HTTP_POST As String
Public Const HTTP_POST As String
public:
literal String^ HTTP_POST
public:
literal String^ HTTP_POST
static val mutable HTTP_POST: string
static val mutable HTTP_POST: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.HTTP_PUT Field

WebConsts HTTP_PUT Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HTTP_PUT
public const string HTTP_PUT
Public Const HTTP_PUT As String
Public Const HTTP_PUT As String
public:
literal String^ HTTP_PUT
public:
literal String^ HTTP_PUT
static val mutable HTTP_PUT: string
static val mutable HTTP_PUT: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.HTTP_SET_COOKIE Field

WebConsts HTTP_SET_COOKIE Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HTTP_SET_COOKIE
public const string HTTP_SET_COOKIE
Public Const HTTP_SET_COOKIE As String
Public Const HTTP_SET_COOKIE As String
public:
literal String^ HTTP_SET_COOKIE
public:
literal String^ HTTP_SET_COOKIE
static val mutable HTTP_SET_COOKIE: string
static val mutable HTTP_SET_COOKIE: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.HTTP_WWW_AUTHENTICATE Field

WebConsts HTTP_WWW_AUTHENTICATE Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HTTP_WWW_AUTHENTICATE
public const string HTTP_WWW_AUTHENTICATE
Public Const HTTP_WWW_AUTHENTICATE As String
Public Const HTTP_WWW_AUTHENTICATE As String
public:
literal String^ HTTP_WWW_AUTHENTICATE
public:
literal String^ HTTP_WWW_AUTHENTICATE
static val mutable HTTP_WWW_AUTHENTICATE: string
static val mutable HTTP_WWW_AUTHENTICATE: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_200 Field

WebConsts STATUS_200 Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int STATUS_200
public const int STATUS_200
Public Const STATUS_200 As Integer
Public Const STATUS_200 As Integer
public:
literal int STATUS_200
public:
literal int STATUS_200
static val mutable STATUS_200: int
static val mutable STATUS_200: int

Field Value

Type: Online Int32
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_200_DESCRIPTION Field

WebConsts STATUS_200_DESCRIPTION Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STATUS_200_DESCRIPTION
public const string STATUS_200_DESCRIPTION
Public Const STATUS_200_DESCRIPTION As String
Public Const STATUS_200_DESCRIPTION As String
public:
literal String^ STATUS_200_DESCRIPTION
public:
literal String^ STATUS_200_DESCRIPTION
static val mutable STATUS_200_DESCRIPTION: string
static val mutable STATUS_200_DESCRIPTION: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_400 Field

WebConsts STATUS_400 Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int STATUS_400
public const int STATUS_400
Public Const STATUS_400 As Integer
Public Const STATUS_400 As Integer
public:
literal int STATUS_400
public:
literal int STATUS_400
static val mutable STATUS_400: int
static val mutable STATUS_400: int

Field Value

Type: Online Int32
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_400_DESCRIPTION Field

WebConsts STATUS_400_DESCRIPTION Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STATUS_400_DESCRIPTION
public const string STATUS_400_DESCRIPTION
Public Const STATUS_400_DESCRIPTION As String
Public Const STATUS_400_DESCRIPTION As String
public:
literal String^ STATUS_400_DESCRIPTION
public:
literal String^ STATUS_400_DESCRIPTION
static val mutable STATUS_400_DESCRIPTION: string
static val mutable STATUS_400_DESCRIPTION: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_401 Field

WebConsts STATUS_401 Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int STATUS_401
public const int STATUS_401
Public Const STATUS_401 As Integer
Public Const STATUS_401 As Integer
public:
literal int STATUS_401
public:
literal int STATUS_401
static val mutable STATUS_401: int
static val mutable STATUS_401: int

Field Value

Type: Online Int32
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_401_DESCRIPTION Field

WebConsts STATUS_401_DESCRIPTION Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STATUS_401_DESCRIPTION
public const string STATUS_401_DESCRIPTION
Public Const STATUS_401_DESCRIPTION As String
Public Const STATUS_401_DESCRIPTION As String
public:
literal String^ STATUS_401_DESCRIPTION
public:
literal String^ STATUS_401_DESCRIPTION
static val mutable STATUS_401_DESCRIPTION: string
static val mutable STATUS_401_DESCRIPTION: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_403 Field

WebConsts STATUS_403 Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int STATUS_403
public const int STATUS_403
Public Const STATUS_403 As Integer
Public Const STATUS_403 As Integer
public:
literal int STATUS_403
public:
literal int STATUS_403
static val mutable STATUS_403: int
static val mutable STATUS_403: int

Field Value

Type: Online Int32
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_403_DESCRIPTION Field

WebConsts STATUS_403_DESCRIPTION Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STATUS_403_DESCRIPTION
public const string STATUS_403_DESCRIPTION
Public Const STATUS_403_DESCRIPTION As String
Public Const STATUS_403_DESCRIPTION As String
public:
literal String^ STATUS_403_DESCRIPTION
public:
literal String^ STATUS_403_DESCRIPTION
static val mutable STATUS_403_DESCRIPTION: string
static val mutable STATUS_403_DESCRIPTION: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_404 Field

WebConsts STATUS_404 Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int STATUS_404
public const int STATUS_404
Public Const STATUS_404 As Integer
Public Const STATUS_404 As Integer
public:
literal int STATUS_404
public:
literal int STATUS_404
static val mutable STATUS_404: int
static val mutable STATUS_404: int

Field Value

Type: Online Int32
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_404_DESCRIPTION Field

WebConsts STATUS_404_DESCRIPTION Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STATUS_404_DESCRIPTION
public const string STATUS_404_DESCRIPTION
Public Const STATUS_404_DESCRIPTION As String
Public Const STATUS_404_DESCRIPTION As String
public:
literal String^ STATUS_404_DESCRIPTION
public:
literal String^ STATUS_404_DESCRIPTION
static val mutable STATUS_404_DESCRIPTION: string
static val mutable STATUS_404_DESCRIPTION: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_405 Field

WebConsts STATUS_405 Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int STATUS_405
public const int STATUS_405
Public Const STATUS_405 As Integer
Public Const STATUS_405 As Integer
public:
literal int STATUS_405
public:
literal int STATUS_405
static val mutable STATUS_405: int
static val mutable STATUS_405: int

Field Value

Type: Online Int32
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_405_DESCRIPTION Field

WebConsts STATUS_405_DESCRIPTION Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STATUS_405_DESCRIPTION
public const string STATUS_405_DESCRIPTION
Public Const STATUS_405_DESCRIPTION As String
Public Const STATUS_405_DESCRIPTION As String
public:
literal String^ STATUS_405_DESCRIPTION
public:
literal String^ STATUS_405_DESCRIPTION
static val mutable STATUS_405_DESCRIPTION: string
static val mutable STATUS_405_DESCRIPTION: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_406 Field

WebConsts STATUS_406 Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int STATUS_406
public const int STATUS_406
Public Const STATUS_406 As Integer
Public Const STATUS_406 As Integer
public:
literal int STATUS_406
public:
literal int STATUS_406
static val mutable STATUS_406: int
static val mutable STATUS_406: int

Field Value

Type: Online Int32
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_406_DESCRIPTION Field

WebConsts STATUS_406_DESCRIPTION Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STATUS_406_DESCRIPTION
public const string STATUS_406_DESCRIPTION
Public Const STATUS_406_DESCRIPTION As String
Public Const STATUS_406_DESCRIPTION As String
public:
literal String^ STATUS_406_DESCRIPTION
public:
literal String^ STATUS_406_DESCRIPTION
static val mutable STATUS_406_DESCRIPTION: string
static val mutable STATUS_406_DESCRIPTION: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_429 Field

WebConsts STATUS_429 Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int STATUS_429
public const int STATUS_429
Public Const STATUS_429 As Integer
Public Const STATUS_429 As Integer
public:
literal int STATUS_429
public:
literal int STATUS_429
static val mutable STATUS_429: int
static val mutable STATUS_429: int

Field Value

Type: Online Int32
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_429_DESCRIPTION Field

WebConsts STATUS_429_DESCRIPTION Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STATUS_429_DESCRIPTION
public const string STATUS_429_DESCRIPTION
Public Const STATUS_429_DESCRIPTION As String
Public Const STATUS_429_DESCRIPTION As String
public:
literal String^ STATUS_429_DESCRIPTION
public:
literal String^ STATUS_429_DESCRIPTION
static val mutable STATUS_429_DESCRIPTION: string
static val mutable STATUS_429_DESCRIPTION: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_500 Field

WebConsts STATUS_500 Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int STATUS_500
public const int STATUS_500
Public Const STATUS_500 As Integer
Public Const STATUS_500 As Integer
public:
literal int STATUS_500
public:
literal int STATUS_500
static val mutable STATUS_500: int
static val mutable STATUS_500: int

Field Value

Type: Online Int32
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.STATUS_500_DESCRIPTION Field

WebConsts STATUS_500_DESCRIPTION Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STATUS_500_DESCRIPTION
public const string STATUS_500_DESCRIPTION
Public Const STATUS_500_DESCRIPTION As String
Public Const STATUS_500_DESCRIPTION As String
public:
literal String^ STATUS_500_DESCRIPTION
public:
literal String^ STATUS_500_DESCRIPTION
static val mutable STATUS_500_DESCRIPTION: string
static val mutable STATUS_500_DESCRIPTION: string

Field Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts Methods

WebConsts Methods NFX Class Library

The WebConsts type exposes the following members.
Methods
Name | Description
GetRedirectStatusCode |
GetRedirectStatusDescription |
Back to Top
See Also
WebConsts Class
NFX.Web Namespace


WebConsts.GetRedirectStatusCode Method

WebConsts GetRedirectStatusCode Method NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetRedirectStatusCode(
    WebConsts..::..RedirectCode code
)
public static int GetRedirectStatusCode(
    WebConsts..::..RedirectCode code
)
Public Shared Function GetRedirectStatusCode (
    code As WebConsts..::..RedirectCode
) As Integer
Public Shared Function GetRedirectStatusCode (
    code As WebConsts..::..RedirectCode
) As Integer
public:
static int GetRedirectStatusCode(
    WebConsts..::..RedirectCode code
)
public:
static int GetRedirectStatusCode(
    WebConsts..::..RedirectCode code
)
static member GetRedirectStatusCode :
        code : WebConsts..::..RedirectCode -> int
static member GetRedirectStatusCode :
        code : WebConsts..::..RedirectCode -> int

Parameters

code
Type: NFX.Web WebConsts RedirectCode

Return Value

Type: Online Int32
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.GetRedirectStatusDescription Method

WebConsts GetRedirectStatusDescription Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetRedirectStatusDescription(
    WebConsts..::..RedirectCode code
)
public static string GetRedirectStatusDescription(
    WebConsts..::..RedirectCode code
)
Public Shared Function GetRedirectStatusDescription (
    code As WebConsts..::..RedirectCode
) As String
Public Shared Function GetRedirectStatusDescription (
    code As WebConsts..::..RedirectCode
) As String
public:
static String^ GetRedirectStatusDescription(
    WebConsts..::..RedirectCode code
)
public:
static String^ GetRedirectStatusDescription(
    WebConsts..::..RedirectCode code
)
static member GetRedirectStatusDescription :
        code : WebConsts..::..RedirectCode -> string
static member GetRedirectStatusDescription :
        code : WebConsts..::..RedirectCode -> string

Parameters

code
Type: NFX.Web WebConsts RedirectCode

Return Value

Type: Online String
See Also
WebConsts Class
WebConsts Members
NFX.Web Namespace


WebConsts.RedirectCode Enumeration

WebConsts RedirectCode Enumeration NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum RedirectCode
public enum RedirectCode
Public Enumeration RedirectCode
Public Enumeration RedirectCode
public enum class RedirectCode
public enum class RedirectCode
type RedirectCode
type RedirectCode
Members
Member name | Value | Description
MultipleChoices_300 | 300 |
MovedPermanently_301 | 301 |
Found_302 | 302 |
SeeOther_303 | 303 |
NotModified_304 | 304 |
UseProxy_305 | 305 |
SwitchProxy_306 | 306 |
Temporary_307 | 307 |
Permanent_308 | 308 |
See Also
NFX.Web Namespace


WebException Class

WebException Class NFX Class Library

Base exception class thrown by NFX.WebForms assembly
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Web WebException
NFX.Web.GeoLookup GeoException

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WebException : NFXException
[SerializableAttribute]
public class WebException : NFXException
<SerializableAttribute>
Public Class WebException
    Inherits NFXException
<SerializableAttribute>
Public Class WebException
    Inherits NFXException
[SerializableAttribute]
public ref class WebException : public NFXException
[SerializableAttribute]
public ref class WebException : public NFXException
[<SerializableAttribute>]
type WebException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type WebException =
    class
        inherit NFXException
    end
See Also
WebException Members
NFX.Web Namespace


WebException Members

WebException Members NFX Class Library

The WebException type exposes the following members.
Constructors
 | Name | Description
Public method | WebException | Initializes a new instance of the WebException class
Public method | WebException(String) | Initializes a new instance of the WebException class
Protected method | WebException(SerializationInfo, StreamingContext) | Initializes a new instance of the WebException class
Public method | WebException(String, Exception) | Initializes a new instance of the WebException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
WebException Class
NFX.Web Namespace


WebException Constructor

WebException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | WebException | Initializes a new instance of the WebException class
Public method | WebException(String) | Initializes a new instance of the WebException class
Protected method | WebException(SerializationInfo, StreamingContext) | Initializes a new instance of the WebException class
Public method | WebException(String, Exception) | Initializes a new instance of the WebException class
Back to Top
See Also
WebException Class
WebException Members
NFX.Web Namespace


WebException Constructor

WebException Constructor NFX Class Library

Initializes a new instance of the WebException class

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebException()
public WebException()
Public Sub New
Public Sub New
public:
WebException()
public:
WebException()
new : unit -> WebException
new : unit -> WebException
See Also
WebException Class
WebException Members
WebException Overload
NFX.Web Namespace


WebException Constructor (String)

WebException Constructor (String) NFX Class Library

Initializes a new instance of the WebException class

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebException(
    string message
)
public WebException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
WebException(
    String^ message
)
public:
WebException(
    String^ message
)
new :
        message : string -> WebException
new :
        message : string -> WebException

Parameters

message
Type: Online System String
See Also
WebException Class
WebException Members
WebException Overload
NFX.Web Namespace


WebException Constructor (SerializationInfo, StreamingContext)

WebException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WebException class

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected WebException(
    SerializationInfo info,
    StreamingContext context
)
protected WebException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
WebException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
WebException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> WebException
new :
        info : SerializationInfo *
        context : StreamingContext -> WebException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
WebException Class
WebException Members
WebException Overload
NFX.Web Namespace


WebException Constructor (String, Exception)

WebException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WebException class

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebException(
    string message,
    Exception inner
)
public WebException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
WebException(
    String^ message,
    Exception^ inner
)
public:
WebException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> WebException
new :
        message : string *
        inner : Exception -> WebException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
WebException Class
WebException Members
WebException Overload
NFX.Web Namespace


WebException Methods

WebException Methods NFX Class Library

The WebException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
WebException Class
NFX.Web Namespace


WebException Properties

WebException Properties NFX Class Library

The WebException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
WebException Class
NFX.Web Namespace


WebException Events

WebException Events NFX Class Library

The WebException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
WebException Class
NFX.Web Namespace


WebSettings Class

WebSettings Class NFX Class Library

Facilitates fast access to important web-related config settings that update their values when underlying config changes
Inheritance Hierarchy
Online System Object
NFX.Web WebSettings

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class WebSettings : IConfigSettings
public class WebSettings : IConfigSettings
Public Class WebSettings
    Implements IConfigSettings
Public Class WebSettings
    Implements IConfigSettings
public ref class WebSettings : IConfigSettings
public ref class WebSettings : IConfigSettings
type WebSettings =
    class
        interface IConfigSettings
    end
type WebSettings =
    class
        interface IConfigSettings
    end
See Also
WebSettings Members
NFX.Web Namespace


WebSettings Members

WebSettings Members NFX Class Library

The WebSettings type exposes the following members.
Methods
 | Name | Description
 | ChangeConfig |
Public method | ConfigChanged |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | RequireInitializedSettings | Called by framework components that rely on initialized web settings. If the settings have been initialized that this method just does a lock-free check and returns
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_DEFAULT_TIMEOUT_MS_ATTR |
CONFIG_LOGTYPE_ATTR |
CONFIG_SERVICEPOINTMANAGER_SECTION |
CONFIG_SESSION_TIMEOUT_MS_ATTR |
CONFIG_SOCIAL_PROVIDER_SECTION |
CONFIG_SOCIAL_SECTION |
CONFIG_TAX_CALCULATOR_SECTION |
CONFIG_TAX_SECTION |
CONFIG_WEBDAV_SECTION |
CONFIG_WEBSETTINGS_SECTION |
DEFAULT_SESSION_TIMEOUT_MS |
MIN_SESSION_TIMEOUT_MS |
WEBDAV_DEFAULT_TIMEOUT_MS_DEFAULT |
Back to Top
Properties
Name | Description
ServicePointManager | Provides settings related to Http traffic handling
SocialNetworks | Social network providers currently present in the system
WebDavDefaultTimeoutMs | Sets default timeout for WebDAV requests 0 means indefinite
WebDavLogType | When set turns on WebDAV logging
Back to Top
See Also
WebSettings Class
NFX.Web Namespace


WebSettings Fields

WebSettings Fields NFX Class Library

The WebSettings type exposes the following members.
Fields
Name | Description
CONFIG_DEFAULT_TIMEOUT_MS_ATTR |
CONFIG_LOGTYPE_ATTR |
CONFIG_SERVICEPOINTMANAGER_SECTION |
CONFIG_SESSION_TIMEOUT_MS_ATTR |
CONFIG_SOCIAL_PROVIDER_SECTION |
CONFIG_SOCIAL_SECTION |
CONFIG_TAX_CALCULATOR_SECTION |
CONFIG_TAX_SECTION |
CONFIG_WEBDAV_SECTION |
CONFIG_WEBSETTINGS_SECTION |
DEFAULT_SESSION_TIMEOUT_MS |
MIN_SESSION_TIMEOUT_MS |
WEBDAV_DEFAULT_TIMEOUT_MS_DEFAULT |
Back to Top
See Also
WebSettings Class
NFX.Web Namespace


WebSettings.CONFIG_DEFAULT_TIMEOUT_MS_ATTR Field

WebSettings CONFIG_DEFAULT_TIMEOUT_MS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DEFAULT_TIMEOUT_MS_ATTR
public const string CONFIG_DEFAULT_TIMEOUT_MS_ATTR
Public Const CONFIG_DEFAULT_TIMEOUT_MS_ATTR As String
Public Const CONFIG_DEFAULT_TIMEOUT_MS_ATTR As String
public:
literal String^ CONFIG_DEFAULT_TIMEOUT_MS_ATTR
public:
literal String^ CONFIG_DEFAULT_TIMEOUT_MS_ATTR
static val mutable CONFIG_DEFAULT_TIMEOUT_MS_ATTR: string
static val mutable CONFIG_DEFAULT_TIMEOUT_MS_ATTR: string

Field Value

Type: Online String
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.CONFIG_LOGTYPE_ATTR Field

WebSettings CONFIG_LOGTYPE_ATTR Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_LOGTYPE_ATTR
public const string CONFIG_LOGTYPE_ATTR
Public Const CONFIG_LOGTYPE_ATTR As String
Public Const CONFIG_LOGTYPE_ATTR As String
public:
literal String^ CONFIG_LOGTYPE_ATTR
public:
literal String^ CONFIG_LOGTYPE_ATTR
static val mutable CONFIG_LOGTYPE_ATTR: string
static val mutable CONFIG_LOGTYPE_ATTR: string

Field Value

Type: Online String
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.CONFIG_SERVICEPOINTMANAGER_SECTION Field

WebSettings CONFIG_SERVICEPOINTMANAGER_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SERVICEPOINTMANAGER_SECTION
public const string CONFIG_SERVICEPOINTMANAGER_SECTION
Public Const CONFIG_SERVICEPOINTMANAGER_SECTION As String
Public Const CONFIG_SERVICEPOINTMANAGER_SECTION As String
public:
literal String^ CONFIG_SERVICEPOINTMANAGER_SECTION
public:
literal String^ CONFIG_SERVICEPOINTMANAGER_SECTION
static val mutable CONFIG_SERVICEPOINTMANAGER_SECTION: string
static val mutable CONFIG_SERVICEPOINTMANAGER_SECTION: string

Field Value

Type: Online String
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.CONFIG_SESSION_TIMEOUT_MS_ATTR Field

WebSettings CONFIG_SESSION_TIMEOUT_MS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SESSION_TIMEOUT_MS_ATTR
public const string CONFIG_SESSION_TIMEOUT_MS_ATTR
Public Const CONFIG_SESSION_TIMEOUT_MS_ATTR As String
Public Const CONFIG_SESSION_TIMEOUT_MS_ATTR As String
public:
literal String^ CONFIG_SESSION_TIMEOUT_MS_ATTR
public:
literal String^ CONFIG_SESSION_TIMEOUT_MS_ATTR
static val mutable CONFIG_SESSION_TIMEOUT_MS_ATTR: string
static val mutable CONFIG_SESSION_TIMEOUT_MS_ATTR: string

Field Value

Type: Online String
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.CONFIG_SOCIAL_PROVIDER_SECTION Field

WebSettings CONFIG_SOCIAL_PROVIDER_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SOCIAL_PROVIDER_SECTION
public const string CONFIG_SOCIAL_PROVIDER_SECTION
Public Const CONFIG_SOCIAL_PROVIDER_SECTION As String
Public Const CONFIG_SOCIAL_PROVIDER_SECTION As String
public:
literal String^ CONFIG_SOCIAL_PROVIDER_SECTION
public:
literal String^ CONFIG_SOCIAL_PROVIDER_SECTION
static val mutable CONFIG_SOCIAL_PROVIDER_SECTION: string
static val mutable CONFIG_SOCIAL_PROVIDER_SECTION: string

Field Value

Type: Online String
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.CONFIG_SOCIAL_SECTION Field

WebSettings CONFIG_SOCIAL_SECTION Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SOCIAL_SECTION
public const string CONFIG_SOCIAL_SECTION
Public Const CONFIG_SOCIAL_SECTION As String
Public Const CONFIG_SOCIAL_SECTION As String
public:
literal String^ CONFIG_SOCIAL_SECTION
public:
literal String^ CONFIG_SOCIAL_SECTION
static val mutable CONFIG_SOCIAL_SECTION: string
static val mutable CONFIG_SOCIAL_SECTION: string

Field Value

Type: Online String
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.CONFIG_TAX_CALCULATOR_SECTION Field

WebSettings CONFIG_TAX_CALCULATOR_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TAX_CALCULATOR_SECTION
public const string CONFIG_TAX_CALCULATOR_SECTION
Public Const CONFIG_TAX_CALCULATOR_SECTION As String
Public Const CONFIG_TAX_CALCULATOR_SECTION As String
public:
literal String^ CONFIG_TAX_CALCULATOR_SECTION
public:
literal String^ CONFIG_TAX_CALCULATOR_SECTION
static val mutable CONFIG_TAX_CALCULATOR_SECTION: string
static val mutable CONFIG_TAX_CALCULATOR_SECTION: string

Field Value

Type: Online String
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.CONFIG_TAX_SECTION Field

WebSettings CONFIG_TAX_SECTION Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TAX_SECTION
public const string CONFIG_TAX_SECTION
Public Const CONFIG_TAX_SECTION As String
Public Const CONFIG_TAX_SECTION As String
public:
literal String^ CONFIG_TAX_SECTION
public:
literal String^ CONFIG_TAX_SECTION
static val mutable CONFIG_TAX_SECTION: string
static val mutable CONFIG_TAX_SECTION: string

Field Value

Type: Online String
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.CONFIG_WEBDAV_SECTION Field

WebSettings CONFIG_WEBDAV_SECTION Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_WEBDAV_SECTION
public const string CONFIG_WEBDAV_SECTION
Public Const CONFIG_WEBDAV_SECTION As String
Public Const CONFIG_WEBDAV_SECTION As String
public:
literal String^ CONFIG_WEBDAV_SECTION
public:
literal String^ CONFIG_WEBDAV_SECTION
static val mutable CONFIG_WEBDAV_SECTION: string
static val mutable CONFIG_WEBDAV_SECTION: string

Field Value

Type: Online String
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.CONFIG_WEBSETTINGS_SECTION Field

WebSettings CONFIG_WEBSETTINGS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_WEBSETTINGS_SECTION
public const string CONFIG_WEBSETTINGS_SECTION
Public Const CONFIG_WEBSETTINGS_SECTION As String
Public Const CONFIG_WEBSETTINGS_SECTION As String
public:
literal String^ CONFIG_WEBSETTINGS_SECTION
public:
literal String^ CONFIG_WEBSETTINGS_SECTION
static val mutable CONFIG_WEBSETTINGS_SECTION: string
static val mutable CONFIG_WEBSETTINGS_SECTION: string

Field Value

Type: Online String
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.DEFAULT_SESSION_TIMEOUT_MS Field

WebSettings DEFAULT_SESSION_TIMEOUT_MS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_SESSION_TIMEOUT_MS
public const int DEFAULT_SESSION_TIMEOUT_MS
Public Const DEFAULT_SESSION_TIMEOUT_MS As Integer
Public Const DEFAULT_SESSION_TIMEOUT_MS As Integer
public:
literal int DEFAULT_SESSION_TIMEOUT_MS
public:
literal int DEFAULT_SESSION_TIMEOUT_MS
static val mutable DEFAULT_SESSION_TIMEOUT_MS: int
static val mutable DEFAULT_SESSION_TIMEOUT_MS: int

Field Value

Type: Online Int32
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.MIN_SESSION_TIMEOUT_MS Field

WebSettings MIN_SESSION_TIMEOUT_MS Field NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MIN_SESSION_TIMEOUT_MS
public const int MIN_SESSION_TIMEOUT_MS
Public Const MIN_SESSION_TIMEOUT_MS As Integer
Public Const MIN_SESSION_TIMEOUT_MS As Integer
public:
literal int MIN_SESSION_TIMEOUT_MS
public:
literal int MIN_SESSION_TIMEOUT_MS
static val mutable MIN_SESSION_TIMEOUT_MS: int
static val mutable MIN_SESSION_TIMEOUT_MS: int

Field Value

Type: Online Int32
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.WEBDAV_DEFAULT_TIMEOUT_MS_DEFAULT Field

WebSettings WEBDAV_DEFAULT_TIMEOUT_MS_DEFAULT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int WEBDAV_DEFAULT_TIMEOUT_MS_DEFAULT
public const int WEBDAV_DEFAULT_TIMEOUT_MS_DEFAULT
Public Const WEBDAV_DEFAULT_TIMEOUT_MS_DEFAULT As Integer
Public Const WEBDAV_DEFAULT_TIMEOUT_MS_DEFAULT As Integer
public:
literal int WEBDAV_DEFAULT_TIMEOUT_MS_DEFAULT
public:
literal int WEBDAV_DEFAULT_TIMEOUT_MS_DEFAULT
static val mutable WEBDAV_DEFAULT_TIMEOUT_MS_DEFAULT: int
static val mutable WEBDAV_DEFAULT_TIMEOUT_MS_DEFAULT: int

Field Value

Type: Online Int32
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings Methods

WebSettings Methods NFX Class Library

The WebSettings type exposes the following members.
Methods
 | Name | Description
 | ChangeConfig |
Public method | ConfigChanged |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | RequireInitializedSettings | Called by framework components that rely on initialized web settings. If the settings have been initialized that this method just does a lock-free check and returns
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WebSettings Class
NFX.Web Namespace


WebSettings.ChangeConfig Method

WebSettings ChangeConfig Method NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ChangeConfig(
    IConfigSectionNode atNode
)
public static void ChangeConfig(
    IConfigSectionNode atNode
)
Public Shared Sub ChangeConfig (
    atNode As IConfigSectionNode
)
Public Shared Sub ChangeConfig (
    atNode As IConfigSectionNode
)
public:
static void ChangeConfig(
    IConfigSectionNode^ atNode
)
public:
static void ChangeConfig(
    IConfigSectionNode^ atNode
)
static member ChangeConfig :
        atNode : IConfigSectionNode -> unit
static member ChangeConfig :
        atNode : IConfigSectionNode -> unit

Parameters

atNode
Type: NFX.Environment IConfigSectionNode
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.ConfigChanged Method

WebSettings ConfigChanged Method NFX Class Library

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ConfigChanged(
    IConfigSectionNode atNode
)
public void ConfigChanged(
    IConfigSectionNode atNode
)
Public Sub ConfigChanged (
    atNode As IConfigSectionNode
)
Public Sub ConfigChanged (
    atNode As IConfigSectionNode
)
public:
virtual void ConfigChanged(
    IConfigSectionNode^ atNode
) sealed
public:
virtual void ConfigChanged(
    IConfigSectionNode^ atNode
) sealed
abstract ConfigChanged :
        atNode : IConfigSectionNode -> unit
override ConfigChanged :
        atNode : IConfigSectionNode -> unit
abstract ConfigChanged :
        atNode : IConfigSectionNode -> unit
override ConfigChanged :
        atNode : IConfigSectionNode -> unit

Parameters

atNode
Type: NFX.Environment IConfigSectionNode

Implements

IConfigSettings ConfigChanged(IConfigSectionNode)
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.RequireInitializedSettings Method

WebSettings RequireInitializedSettings Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Called by framework components that rely on initialized web settings. If the settings have been initialized that this method just does a lock-free check and returns

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void RequireInitializedSettings()
public static void RequireInitializedSettings()
Public Shared Sub RequireInitializedSettings
Public Shared Sub RequireInitializedSettings
public:
static void RequireInitializedSettings()
public:
static void RequireInitializedSettings()
static member RequireInitializedSettings : unit -> unit
static member RequireInitializedSettings : unit -> unit
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings Properties

WebSettings Properties NFX Class Library

The WebSettings type exposes the following members.
Properties
Name | Description
ServicePointManager | Provides settings related to Http traffic handling
SocialNetworks | Social network providers currently present in the system
WebDavDefaultTimeoutMs | Sets default timeout for WebDAV requests 0 means indefinite
WebDavLogType | When set turns on WebDAV logging
Back to Top
See Also
WebSettings Class
NFX.Web Namespace


WebSettings.ServicePointManager Property

WebSettings ServicePointManager Property NFX Class Library

Provides settings related to Http traffic handling

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ServicePointManagerConfigurator ServicePointManager { get; }
public static ServicePointManagerConfigurator ServicePointManager { get; }
Public Shared ReadOnly Property ServicePointManager As ServicePointManagerConfigurator
    Get
Public Shared ReadOnly Property ServicePointManager As ServicePointManagerConfigurator
    Get
public:
static property ServicePointManagerConfigurator^ ServicePointManager {
    ServicePointManagerConfigurator^ get ();
}
public:
static property ServicePointManagerConfigurator^ ServicePointManager {
    ServicePointManagerConfigurator^ get ();
}
static member ServicePointManager : ServicePointManagerConfigurator with get
static member ServicePointManager : ServicePointManagerConfigurator with get

Property Value

Type: ServicePointManagerConfigurator
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.SocialNetworks Property

WebSettings SocialNetworks Property NFX Class Library

Social network providers currently present in the system

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IRegistry<SocialNetwork> SocialNetworks { get; }
public static IRegistry<SocialNetwork> SocialNetworks { get; }
Public Shared ReadOnly Property SocialNetworks As IRegistry(Of SocialNetwork)
    Get
Public Shared ReadOnly Property SocialNetworks As IRegistry(Of SocialNetwork)
    Get
public:
static property IRegistry<SocialNetwork^>^ SocialNetworks {
    IRegistry<SocialNetwork^>^ get ();
}
public:
static property IRegistry<SocialNetwork^>^ SocialNetworks {
    IRegistry<SocialNetwork^>^ get ();
}
static member SocialNetworks : IRegistry<SocialNetwork> with get
static member SocialNetworks : IRegistry<SocialNetwork> with get

Property Value

Type: IRegistry SocialNetwork
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.WebDavDefaultTimeoutMs Property

WebSettings WebDavDefaultTimeoutMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Sets default timeout for WebDAV requests 0 means indefinite

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int WebDavDefaultTimeoutMs { get; }
public static int WebDavDefaultTimeoutMs { get; }
Public Shared ReadOnly Property WebDavDefaultTimeoutMs As Integer
    Get
Public Shared ReadOnly Property WebDavDefaultTimeoutMs As Integer
    Get
public:
static property int WebDavDefaultTimeoutMs {
    int get ();
}
public:
static property int WebDavDefaultTimeoutMs {
    int get ();
}
static member WebDavDefaultTimeoutMs : int with get
static member WebDavDefaultTimeoutMs : int with get

Property Value

Type: Online Int32
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


WebSettings.WebDavLogType Property

WebSettings WebDavLogType Property NFX Class Library

When set turns on WebDAV logging

Namespace: NFX.Web
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<MessageType> WebDavLogType { get; }
public static Nullable<MessageType> WebDavLogType { get; }
Public Shared ReadOnly Property WebDavLogType As Nullable(Of MessageType)
    Get
Public Shared ReadOnly Property WebDavLogType As Nullable(Of MessageType)
    Get
public:
static property Nullable<MessageType> WebDavLogType {
    Nullable<MessageType> get ();
}
public:
static property Nullable<MessageType> WebDavLogType {
    Nullable<MessageType> get ();
}
static member WebDavLogType : Nullable<MessageType> with get
static member WebDavLogType : Nullable<MessageType> with get

Property Value

Type: Online Nullable MessageType
See Also
WebSettings Class
WebSettings Members
NFX.Web Namespace


NFX.Web.GeoLookup Namespace

NFX.Web.GeoLookup Namespace NFX Class Library

Classes
 | Class | Description
Public class | BinaryIndexedTree K, V |
Public class | BinaryTree K, V |
Public class | BinaryTree K, V Node T |
Public class | GeoEntity | Represents lookup result
Public class | GeoException | Base exception class thrown by geo-related logic
Public class | GeoLookupService | Represents a service that can lookup country/city names by domainnames/ip addresses. Thehis implementatuion uses free data from: http://dev.maxmind.com/geoip/geoip2/geolite2/. Must include MaxMind attribution on the public site that uses this data (see License section on maxmind.com)
Public class | SubnetTree V |
Structures
 | Structure | Description
Public structure | BinaryIndexedTree K, V Node |
Public structure | IPSubnetBlock | Provides address segment block information
Public structure | Location | Provides location information
Public structure | Subnet |
Interfaces
 | Interface | Description
Public interface | IGeoLookup | Looks-up entities by their ip addr
Enumerations
 | Enumeration | Description
Public enumeration | LookupResolution |


BinaryIndexedTree(K, V) Class

BinaryIndexedTree K, V Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Web.GeoLookup BinaryIndexedTree K, V
NFX.Web.GeoLookup SubnetTree V

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class BinaryIndexedTree<K, V>
where K : Object, IEnumerable<bool>
public class BinaryIndexedTree<K, V>
where K : Object, IEnumerable<bool>
Public Class BinaryIndexedTree(Of K As {Object, IEnumerable(Of Boolean)}, V)
Public Class BinaryIndexedTree(Of K As {Object, IEnumerable(Of Boolean)}, V)
generic<typename K, typename V>
where K : Object, IEnumerable<bool>
public ref class BinaryIndexedTree
generic<typename K, typename V>
where K : Object, IEnumerable<bool>
public ref class BinaryIndexedTree
type BinaryIndexedTree<'K, 'V when 'K : Object and IEnumerable<bool>> =  class end
type BinaryIndexedTree<'K, 'V when 'K : Object and IEnumerable<bool>> =  class end
Type Parameters
K
V
See Also
BinaryIndexedTree K, V Members
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V) Members

BinaryIndexedTree K, V Members NFX Class Library

The BinaryIndexedTree K, V type exposes the following members.
Constructors
 | Name | Description
Public method | BinaryIndexedTree K, V | Initializes a new instance of the BinaryIndexedTree K, V class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | Find |
Protected method | FindIndex |
Protected method | FindOffset |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Nodes |
Public field | Values |
Back to Top
Properties
 | Name | Description
Public property | Item |
Back to Top
See Also
BinaryIndexedTree K, V Class
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V) Constructor

BinaryIndexedTree K, V Constructor NFX Class Library

Initializes a new instance of the BinaryIndexedTree K, V class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BinaryIndexedTree(
    BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node[] nodes,
    V[] values
)
public BinaryIndexedTree(
    BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node[] nodes,
    V[] values
)
Public Sub New (
    nodes As BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node(),
    values As V()
)
Public Sub New (
    nodes As BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node(),
    values As V()
)
public:
BinaryIndexedTree(
    array<BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node>^ nodes,
    array<V>^ values
)
public:
BinaryIndexedTree(
    array<BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node>^ nodes,
    array<V>^ values
)
new :
        nodes : BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node[] *
        values : 'V[] -> BinaryIndexedTree
new :
        nodes : BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node[] *
        values : 'V[] -> BinaryIndexedTree

Parameters

nodes
Type: NFX.Web.GeoLookup BinaryIndexedTree K, V Node
values
Type: V
See Also
BinaryIndexedTree K, V Class
BinaryIndexedTree K, V Members
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V) Fields

BinaryIndexedTree K, V Fields NFX Class Library

The BinaryIndexedTree K, V type exposes the following members.
Fields
 | Name | Description
Public field | Nodes |
Public field | Values |
Back to Top
See Also
BinaryIndexedTree K, V Class
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V).Nodes Field

BinaryIndexedTree K, V Nodes Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node[] Nodes
public readonly BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node[] Nodes
Public ReadOnly Nodes As BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node()
Public ReadOnly Nodes As BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node()
public:
initonly array<BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node>^ Nodes
public:
initonly array<BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node>^ Nodes
val Nodes: BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node[]
val Nodes: BinaryIndexedTree<(Of <(<'K, V>)>)>..::..Node[]

Field Value

Type: BinaryIndexedTree K, V Node
See Also
BinaryIndexedTree K, V Class
BinaryIndexedTree K, V Members
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V).Values Field

BinaryIndexedTree K, V Values Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly V[] Values
public readonly V[] Values
Public ReadOnly Values As V()
Public ReadOnly Values As V()
public:
initonly array<V>^ Values
public:
initonly array<V>^ Values
val Values: 'V[]
val Values: 'V[]

Field Value

Type: V
See Also
BinaryIndexedTree K, V Class
BinaryIndexedTree K, V Members
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V) Methods

BinaryIndexedTree K, V Methods NFX Class Library

The BinaryIndexedTree K, V type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | Find |
Protected method | FindIndex |
Protected method | FindOffset |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BinaryIndexedTree K, V Class
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V).Find Method

BinaryIndexedTree K, V Find Method NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected V Find(
    K key,
    uint offset
)
protected V Find(
    K key,
    uint offset
)
Protected Function Find (
    key As K,
    offset As UInteger
) As V
Protected Function Find (
    key As K,
    offset As UInteger
) As V
protected:
V Find(
    K key,
    unsigned int offset
)
protected:
V Find(
    K key,
    unsigned int offset
)
member Find :
        key : 'K *
        offset : uint32 -> 'V
member Find :
        key : 'K *
        offset : uint32 -> 'V

Parameters

key
Type: K
offset
Type: Online System UInt32

Return Value

Type: V
See Also
BinaryIndexedTree K, V Class
BinaryIndexedTree K, V Members
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V).FindIndex Method

BinaryIndexedTree K, V FindIndex Method NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int FindIndex(
    K key,
    uint offset
)
protected int FindIndex(
    K key,
    uint offset
)
Protected Function FindIndex (
    key As K,
    offset As UInteger
) As Integer
Protected Function FindIndex (
    key As K,
    offset As UInteger
) As Integer
protected:
int FindIndex(
    K key,
    unsigned int offset
)
protected:
int FindIndex(
    K key,
    unsigned int offset
)
member FindIndex :
        key : 'K *
        offset : uint32 -> int
member FindIndex :
        key : 'K *
        offset : uint32 -> int

Parameters

key
Type: K
offset
Type: Online System UInt32

Return Value

Type: Online Int32
See Also
BinaryIndexedTree K, V Class
BinaryIndexedTree K, V Members
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V).FindOffset Method

BinaryIndexedTree K, V FindOffset Method NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool FindOffset(
    K key,
    ref uint offset
)
protected bool FindOffset(
    K key,
    ref uint offset
)
Protected Function FindOffset (
    key As K,
    ByRef offset As UInteger
) As Boolean
Protected Function FindOffset (
    key As K,
    ByRef offset As UInteger
) As Boolean
protected:
bool FindOffset(
    K key,
    unsigned int% offset
)
protected:
bool FindOffset(
    K key,
    unsigned int% offset
)
member FindOffset :
        key : 'K *
        offset : uint32 byref -> bool
member FindOffset :
        key : 'K *
        offset : uint32 byref -> bool

Parameters

key
Type: K
offset
Type: Online System UInt32

Return Value

Type: Online Boolean
See Also
BinaryIndexedTree K, V Class
BinaryIndexedTree K, V Members
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V) Properties

BinaryIndexedTree K, V Properties NFX Class Library

The BinaryIndexedTree K, V type exposes the following members.
Properties
 | Name | Description
Public property | Item |
Back to Top
See Also
BinaryIndexedTree K, V Class
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V).Item Property

BinaryIndexedTree K, V Item Property NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual V this[
    K key
] { get; }
public virtual V this[
    K key
] { get; }
Public Overridable ReadOnly Default Property Item (
    key As K
) As V
    Get
Public Overridable ReadOnly Default Property Item (
    key As K
) As V
    Get
public:
virtual property V default[K key] {
    V get (K key);
}
public:
virtual property V default[K key] {
    V get (K key);
}
abstract Item : 'V with get
override Item : 'V with get
abstract Item : 'V with get
override Item : 'V with get

Parameters

key
Type: K

Property Value

Type: V
See Also
BinaryIndexedTree K, V Class
BinaryIndexedTree K, V Members
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V).Node Structure

BinaryIndexedTree K, V Node Structure NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Node
public struct Node
Public Structure Node
Public Structure Node
public value class Node
public value class Node
[<SealedAttribute>]
type Node =  struct end
[<SealedAttribute>]
type Node =  struct end
See Also
BinaryIndexedTree K, V Node Members
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V).Node Members

BinaryIndexedTree K, V Node Members NFX Class Library

The BinaryIndexedTree K, V Node generic type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Index |
Public field | Left |
Public field | Right |
Back to Top
See Also
BinaryIndexedTree K, V Node Structure
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V).Node Fields

BinaryIndexedTree K, V Node Fields NFX Class Library

The BinaryIndexedTree K, V Node generic type exposes the following members.
Fields
 | Name | Description
Public field | Index |
Public field | Left |
Public field | Right |
Back to Top
See Also
BinaryIndexedTree K, V Node Structure
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V).Node.Index Field

BinaryIndexedTree K, V Node Index Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Index
public int Index
Public Index As Integer
Public Index As Integer
public:
int Index
public:
int Index
val mutable Index: int
val mutable Index: int

Field Value

Type: Online Int32
See Also
BinaryIndexedTree K, V Node Structure
BinaryIndexedTree K, V Node Members
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V).Node.Left Field

BinaryIndexedTree K, V Node Left Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Left
public uint Left
Public Left As UInteger
Public Left As UInteger
public:
unsigned int Left
public:
unsigned int Left
val mutable Left: uint32
val mutable Left: uint32

Field Value

Type: Online UInt32
See Also
BinaryIndexedTree K, V Node Structure
BinaryIndexedTree K, V Node Members
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V).Node.Right Field

BinaryIndexedTree K, V Node Right Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Right
public uint Right
Public Right As UInteger
Public Right As UInteger
public:
unsigned int Right
public:
unsigned int Right
val mutable Right: uint32
val mutable Right: uint32

Field Value

Type: Online UInt32
See Also
BinaryIndexedTree K, V Node Structure
BinaryIndexedTree K, V Node Members
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V).Node Methods

BinaryIndexedTree K, V Node Methods NFX Class Library

The BinaryIndexedTree K, V Node generic type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BinaryIndexedTree K, V Node Structure
NFX.Web.GeoLookup Namespace


BinaryIndexedTree(K, V).Node.ToString Method

BinaryIndexedTree K, V Node ToString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
BinaryIndexedTree K, V Node Structure
BinaryIndexedTree K, V Node Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V) Class

BinaryTree K, V Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Web.GeoLookup BinaryTree K, V

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class BinaryTree<K, V>
where K : Object, IEnumerable<bool>
public class BinaryTree<K, V>
where K : Object, IEnumerable<bool>
Public Class BinaryTree(Of K As {Object, IEnumerable(Of Boolean)}, V)
Public Class BinaryTree(Of K As {Object, IEnumerable(Of Boolean)}, V)
generic<typename K, typename V>
where K : Object, IEnumerable<bool>
public ref class BinaryTree
generic<typename K, typename V>
where K : Object, IEnumerable<bool>
public ref class BinaryTree
type BinaryTree<'K, 'V when 'K : Object and IEnumerable<bool>> =  class end
type BinaryTree<'K, 'V when 'K : Object and IEnumerable<bool>> =  class end
Type Parameters
K
V
See Also
BinaryTree K, V Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V) Members

BinaryTree K, V Members NFX Class Library

The BinaryTree K, V type exposes the following members.
Constructors
 | Name | Description
Public method | BinaryTree K, V | Initializes a new instance of the BinaryTree K, V class
Back to Top
Methods
 | Name | Description
Public method | BuildIndex |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Root |
Public field | Values |
Back to Top
Properties
 | Name | Description
Public property | Item |
Back to Top
See Also
BinaryTree K, V Class
NFX.Web.GeoLookup Namespace


BinaryTree(K, V) Constructor

BinaryTree K, V Constructor NFX Class Library

Initializes a new instance of the BinaryTree K, V class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BinaryTree()
public BinaryTree()
Public Sub New
Public Sub New
public:
BinaryTree()
public:
BinaryTree()
new : unit -> BinaryTree
new : unit -> BinaryTree
See Also
BinaryTree K, V Class
BinaryTree K, V Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V) Fields

BinaryTree K, V Fields NFX Class Library

The BinaryTree K, V type exposes the following members.
Fields
 | Name | Description
Public field | Root |
Public field | Values |
Back to Top
See Also
BinaryTree K, V Class
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Root Field

BinaryTree K, V Root Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly BinaryTree<(Of <(<'K, V>)>)>..::..Node<K> Root
public readonly BinaryTree<(Of <(<'K, V>)>)>..::..Node<K> Root
Public ReadOnly Root As BinaryTree<(Of <(<'K, V>)>)>..::..Node(Of K)
Public ReadOnly Root As BinaryTree<(Of <(<'K, V>)>)>..::..Node(Of K)
public:
initonly BinaryTree<(Of <(<'K, V>)>)>..::..Node<K>^ Root
public:
initonly BinaryTree<(Of <(<'K, V>)>)>..::..Node<K>^ Root
val Root: BinaryTree<(Of <(<'K, V>)>)>..::..Node<'K>
val Root: BinaryTree<(Of <(<'K, V>)>)>..::..Node<'K>

Field Value

Type: BinaryTree K, V Node K
See Also
BinaryTree K, V Class
BinaryTree K, V Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Values Field

BinaryTree K, V Values Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly List<V> Values
public readonly List<V> Values
Public ReadOnly Values As List(Of V)
Public ReadOnly Values As List(Of V)
public:
initonly List<V>^ Values
public:
initonly List<V>^ Values
val Values: List<'V>
val Values: List<'V>

Field Value

Type: Online List V
See Also
BinaryTree K, V Class
BinaryTree K, V Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V) Methods

BinaryTree K, V Methods NFX Class Library

The BinaryTree K, V type exposes the following members.
Methods
 | Name | Description
Public method | BuildIndex |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BinaryTree K, V Class
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).BuildIndex Method

BinaryTree K, V BuildIndex Method NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BinaryIndexedTree<K, V> BuildIndex()
public BinaryIndexedTree<K, V> BuildIndex()
Public Function BuildIndex As BinaryIndexedTree(Of K, V)
Public Function BuildIndex As BinaryIndexedTree(Of K, V)
public:
BinaryIndexedTree<K, V>^ BuildIndex()
public:
BinaryIndexedTree<K, V>^ BuildIndex()
member BuildIndex : unit -> BinaryIndexedTree<'K, 'V>
member BuildIndex : unit -> BinaryIndexedTree<'K, 'V>

Return Value

Type: BinaryIndexedTree K, V
See Also
BinaryTree K, V Class
BinaryTree K, V Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V) Properties

BinaryTree K, V Properties NFX Class Library

The BinaryTree K, V type exposes the following members.
Properties
 | Name | Description
Public property | Item |
Back to Top
See Also
BinaryTree K, V Class
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Item Property

BinaryTree K, V Item Property NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public V this[
    K key
] { get; set; }
public V this[
    K key
] { get; set; }
Public Default Property Item (
    key As K
) As V
    Get
    Set
Public Default Property Item (
    key As K
) As V
    Get
    Set
public:
property V default[K key] {
    V get (K key);
    void set (K key, V value);
}
public:
property V default[K key] {
    V get (K key);
    void set (K key, V value);
}
member Item : 'V with get, set
member Item : 'V with get, set

Parameters

key
Type: K

Property Value

Type: V
See Also
BinaryTree K, V Class
BinaryTree K, V Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Node(T) Class

BinaryTree K, V Node T Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Web.GeoLookup BinaryTree K, V Node T

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Node<T>
where T : Object, IEnumerable<bool>
public class Node<T>
where T : Object, IEnumerable<bool>
Public Class Node(Of T As {Object, IEnumerable(Of Boolean)})
Public Class Node(Of T As {Object, IEnumerable(Of Boolean)})
generic<typename T>
where T : Object, IEnumerable<bool>
public ref class Node
generic<typename T>
where T : Object, IEnumerable<bool>
public ref class Node
type Node<'T when 'T : Object and IEnumerable<bool>> =  class end
type Node<'T when 'T : Object and IEnumerable<bool>> =  class end
Type Parameters
T
See Also
BinaryTree K, V Node T Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Node(T) Members

BinaryTree K, V Node T Members NFX Class Library

The BinaryTree K, V Node T generic type exposes the following members.
Constructors
 | Name | Description
Public method | BinaryTree K, V Node T | Initializes a new instance of the BinaryTree K, V Node T class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Find |
Public method | FindIndex |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Index |
Public property | Item |
Public property | Left |
Public property | Offset |
Public property | Right |
Back to Top
See Also
BinaryTree K, V Node T Class
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Node(T) Constructor

BinaryTree K, V Node T Constructor NFX Class Library

Initializes a new instance of the BinaryTree K, V Node T class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Node()
public Node()
Public Sub New
Public Sub New
public:
Node()
public:
Node()
new : unit -> Node
new : unit -> Node
See Also
BinaryTree K, V Node T Class
BinaryTree K, V Node T Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Node(T) Methods

BinaryTree K, V Node T Methods NFX Class Library

The BinaryTree K, V Node T generic type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Find |
Public method | FindIndex |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BinaryTree K, V Node T Class
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Node(T).Find Method

BinaryTree K, V Node T Find Method NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BinaryTree<(Of <(<'K, V>)>)>..::..Node<T> Find(
    T key
)
public BinaryTree<(Of <(<'K, V>)>)>..::..Node<T> Find(
    T key
)
Public Function Find (
    key As T
) As BinaryTree<(Of <(<'K, V>)>)>..::..Node(Of T)
Public Function Find (
    key As T
) As BinaryTree<(Of <(<'K, V>)>)>..::..Node(Of T)
public:
BinaryTree<(Of <(<'K, V>)>)>..::..Node<T>^ Find(
    T key
)
public:
BinaryTree<(Of <(<'K, V>)>)>..::..Node<T>^ Find(
    T key
)
member Find :
        key : 'T -> BinaryTree<(Of <(<'K, V>)>)>..::..Node<'T>
member Find :
        key : 'T -> BinaryTree<(Of <(<'K, V>)>)>..::..Node<'T>

Parameters

key
Type: T

Return Value

Type: BinaryTree K, V Node T
See Also
BinaryTree K, V Node T Class
BinaryTree K, V Node T Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Node(T).FindIndex Method

BinaryTree K, V Node T FindIndex Method NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int FindIndex(
    T key
)
public int FindIndex(
    T key
)
Public Function FindIndex (
    key As T
) As Integer
Public Function FindIndex (
    key As T
) As Integer
public:
int FindIndex(
    T key
)
public:
int FindIndex(
    T key
)
member FindIndex :
        key : 'T -> int
member FindIndex :
        key : 'T -> int

Parameters

key
Type: T

Return Value

Type: Online Int32
See Also
BinaryTree K, V Node T Class
BinaryTree K, V Node T Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Node(T) Properties

BinaryTree K, V Node T Properties NFX Class Library

The BinaryTree K, V Node T generic type exposes the following members.
Properties
 | Name | Description
Public property | Index |
Public property | Item |
Public property | Left |
Public property | Offset |
Public property | Right |
Back to Top
See Also
BinaryTree K, V Node T Class
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Node(T).Index Property

BinaryTree K, V Node T Index Property NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Index { get; set; }
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set
member Index : int with get, set

Property Value

Type: Online Int32
See Also
BinaryTree K, V Node T Class
BinaryTree K, V Node T Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Node(T).Item Property

BinaryTree K, V Node T Item Property NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int this[
    T key
] { get; set; }
public int this[
    T key
] { get; set; }
Public Default Property Item (
    key As T
) As Integer
    Get
    Set
Public Default Property Item (
    key As T
) As Integer
    Get
    Set
public:
property int default[T key] {
    int get (T key);
    void set (T key, int value);
}
public:
property int default[T key] {
    int get (T key);
    void set (T key, int value);
}
member Item : int with get, set
member Item : int with get, set

Parameters

key
Type: T

Property Value

Type: Online Int32
See Also
BinaryTree K, V Node T Class
BinaryTree K, V Node T Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Node(T).Left Property

BinaryTree K, V Node T Left Property NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BinaryTree<(Of <(<'K, V>)>)>..::..Node<T> Left { get; set; }
public BinaryTree<(Of <(<'K, V>)>)>..::..Node<T> Left { get; set; }
Public Property Left As BinaryTree<(Of <(<'K, V>)>)>..::..Node(Of T)
    Get
    Set
Public Property Left As BinaryTree<(Of <(<'K, V>)>)>..::..Node(Of T)
    Get
    Set
public:
property BinaryTree<(Of <(<'K, V>)>)>..::..Node<T>^ Left {
    BinaryTree<(Of <(<'K, V>)>)>..::..Node<T>^ get ();
    void set (BinaryTree<(Of <(<'K, V>)>)>..::..Node<T>^ value);
}
public:
property BinaryTree<(Of <(<'K, V>)>)>..::..Node<T>^ Left {
    BinaryTree<(Of <(<'K, V>)>)>..::..Node<T>^ get ();
    void set (BinaryTree<(Of <(<'K, V>)>)>..::..Node<T>^ value);
}
member Left : BinaryTree<(Of <(<'K, V>)>)>..::..Node<'T> with get, set
member Left : BinaryTree<(Of <(<'K, V>)>)>..::..Node<'T> with get, set

Property Value

Type: BinaryTree K, V Node T
See Also
BinaryTree K, V Node T Class
BinaryTree K, V Node T Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Node(T).Offset Property

BinaryTree K, V Node T Offset Property NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Offset { get; set; }
public uint Offset { get; set; }
Public Property Offset As UInteger
    Get
    Set
Public Property Offset As UInteger
    Get
    Set
public:
property unsigned int Offset {
    unsigned int get ();
    void set (unsigned int value);
}
public:
property unsigned int Offset {
    unsigned int get ();
    void set (unsigned int value);
}
member Offset : uint32 with get, set
member Offset : uint32 with get, set

Property Value

Type: Online UInt32
See Also
BinaryTree K, V Node T Class
BinaryTree K, V Node T Members
NFX.Web.GeoLookup Namespace


BinaryTree(K, V).Node(T).Right Property

BinaryTree K, V Node T Right Property NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BinaryTree<(Of <(<'K, V>)>)>..::..Node<T> Right { get; set; }
public BinaryTree<(Of <(<'K, V>)>)>..::..Node<T> Right { get; set; }
Public Property Right As BinaryTree<(Of <(<'K, V>)>)>..::..Node(Of T)
    Get
    Set
Public Property Right As BinaryTree<(Of <(<'K, V>)>)>..::..Node(Of T)
    Get
    Set
public:
property BinaryTree<(Of <(<'K, V>)>)>..::..Node<T>^ Right {
    BinaryTree<(Of <(<'K, V>)>)>..::..Node<T>^ get ();
    void set (BinaryTree<(Of <(<'K, V>)>)>..::..Node<T>^ value);
}
public:
property BinaryTree<(Of <(<'K, V>)>)>..::..Node<T>^ Right {
    BinaryTree<(Of <(<'K, V>)>)>..::..Node<T>^ get ();
    void set (BinaryTree<(Of <(<'K, V>)>)>..::..Node<T>^ value);
}
member Right : BinaryTree<(Of <(<'K, V>)>)>..::..Node<'T> with get, set
member Right : BinaryTree<(Of <(<'K, V>)>)>..::..Node<'T> with get, set

Property Value

Type: BinaryTree K, V Node T
See Also
BinaryTree K, V Node T Class
BinaryTree K, V Node T Members
NFX.Web.GeoLookup Namespace


GeoEntity Class

GeoEntity Class NFX Class Library

Represents lookup result
Inheritance Hierarchy
Online System Object
NFX.Web.GeoLookup GeoEntity

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SlimSerializationProhibitedAttribute]
public class GeoEntity
[SlimSerializationProhibitedAttribute]
public class GeoEntity
<SlimSerializationProhibitedAttribute>
Public Class GeoEntity
<SlimSerializationProhibitedAttribute>
Public Class GeoEntity
[SlimSerializationProhibitedAttribute]
public ref class GeoEntity
[SlimSerializationProhibitedAttribute]
public ref class GeoEntity
[<SlimSerializationProhibitedAttribute>]
type GeoEntity =  class end
[<SlimSerializationProhibitedAttribute>]
type GeoEntity =  class end
See Also
GeoEntity Members
NFX.Web.GeoLookup Namespace


GeoEntity Members

GeoEntity Members NFX Class Library

The GeoEntity type exposes the following members.
Constructors
 | Name | Description
Protected method | GeoEntity | Initializes a new instance of the GeoEntity class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Block | Information about IP address block
Public field | Location | Information about geo location
Public field | Query | Returns the address originally requested
Back to Top
Properties
 | Name | Description
Public property | CountryISOName |
Public property | CountryName |
Public property | LocalityName | Returns handy name of locality, i.e. "City, Country" if city is available
Back to Top
See Also
GeoEntity Class
NFX.Web.GeoLookup Namespace


GeoEntity Constructor

GeoEntity Constructor NFX Class Library

Initializes a new instance of the GeoEntity class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal GeoEntity(
    IPAddress query,
    IPSubnetBlock block,
    Nullable<Location> location
)
protected internal GeoEntity(
    IPAddress query,
    IPSubnetBlock block,
    Nullable<Location> location
)
Protected Friend Sub New (
    query As IPAddress,
    block As IPSubnetBlock,
    location As Nullable(Of Location)
)
Protected Friend Sub New (
    query As IPAddress,
    block As IPSubnetBlock,
    location As Nullable(Of Location)
)
protected public:
GeoEntity(
    IPAddress^ query,
    IPSubnetBlock block,
    Nullable<Location> location
)
protected public:
GeoEntity(
    IPAddress^ query,
    IPSubnetBlock block,
    Nullable<Location> location
)
new :
        query : IPAddress *
        block : IPSubnetBlock *
        location : Nullable<Location> -> GeoEntity
new :
        query : IPAddress *
        block : IPSubnetBlock *
        location : Nullable<Location> -> GeoEntity

Parameters

query
Type: Online System.Net IPAddress
block
Type: NFX.Web.GeoLookup IPSubnetBlock
location
Type: Online System Nullable Location
See Also
GeoEntity Class
GeoEntity Members
NFX.Web.GeoLookup Namespace


GeoEntity Fields

GeoEntity Fields NFX Class Library

The GeoEntity type exposes the following members.
Fields
 | Name | Description
Public field | Block | Information about IP address block
Public field | Location | Information about geo location
Public field | Query | Returns the address originally requested
Back to Top
See Also
GeoEntity Class
NFX.Web.GeoLookup Namespace


GeoEntity.Block Field

GeoEntity Block Field NFX Class Library

Information about IP address block

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IPSubnetBlock Block
public readonly IPSubnetBlock Block
Public ReadOnly Block As IPSubnetBlock
Public ReadOnly Block As IPSubnetBlock
public:
initonly IPSubnetBlock Block
public:
initonly IPSubnetBlock Block
val Block: IPSubnetBlock
val Block: IPSubnetBlock

Field Value

Type: IPSubnetBlock
See Also
GeoEntity Class
GeoEntity Members
NFX.Web.GeoLookup Namespace


GeoEntity.Location Field

GeoEntity Location Field NFX Class Library

Information about geo location

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Nullable<Location> Location
public readonly Nullable<Location> Location
Public ReadOnly Location As Nullable(Of Location)
Public ReadOnly Location As Nullable(Of Location)
public:
initonly Nullable<Location> Location
public:
initonly Nullable<Location> Location
val Location: Nullable<Location>
val Location: Nullable<Location>

Field Value

Type: Online Nullable Location
See Also
GeoEntity Class
GeoEntity Members
NFX.Web.GeoLookup Namespace


GeoEntity.Query Field

GeoEntity Query Field NFX Class Library

Returns the address originally requested

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IPAddress Query
public readonly IPAddress Query
Public ReadOnly Query As IPAddress
Public ReadOnly Query As IPAddress
public:
initonly IPAddress^ Query
public:
initonly IPAddress^ Query
val Query: IPAddress
val Query: IPAddress

Field Value

Type: Online IPAddress
See Also
GeoEntity Class
GeoEntity Members
NFX.Web.GeoLookup Namespace


GeoEntity Methods

GeoEntity Methods NFX Class Library

The GeoEntity type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GeoEntity Class
NFX.Web.GeoLookup Namespace


GeoEntity.ToString Method

GeoEntity ToString Method NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
GeoEntity Class
GeoEntity Members
NFX.Web.GeoLookup Namespace


GeoEntity Properties

GeoEntity Properties NFX Class Library

The GeoEntity type exposes the following members.
Properties
 | Name | Description
Public property | CountryISOName |
Public property | CountryName |
Public property | LocalityName | Returns handy name of locality, i.e. "City, Country" if city is available
Back to Top
See Also
GeoEntity Class
NFX.Web.GeoLookup Namespace


GeoEntity.CountryISOName Property

GeoEntity CountryISOName Property NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CountryISOName { get; }
public string CountryISOName { get; }
Public ReadOnly Property CountryISOName As String
    Get
Public ReadOnly Property CountryISOName As String
    Get
public:
property String^ CountryISOName {
    String^ get ();
}
public:
property String^ CountryISOName {
    String^ get ();
}
member CountryISOName : string with get
member CountryISOName : string with get

Property Value

Type: Online String
See Also
GeoEntity Class
GeoEntity Members
NFX.Web.GeoLookup Namespace


GeoEntity.CountryName Property

GeoEntity CountryName Property NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CountryName { get; }
public string CountryName { get; }
Public ReadOnly Property CountryName As String
    Get
Public ReadOnly Property CountryName As String
    Get
public:
property String^ CountryName {
    String^ get ();
}
public:
property String^ CountryName {
    String^ get ();
}
member CountryName : string with get
member CountryName : string with get

Property Value

Type: Online String
See Also
GeoEntity Class
GeoEntity Members
NFX.Web.GeoLookup Namespace


GeoEntity.LocalityName Property

GeoEntity LocalityName Property NFX Class Library

Returns handy name of locality, i.e. "City, Country" if city is available

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LocalityName { get; }
public string LocalityName { get; }
Public ReadOnly Property LocalityName As String
    Get
Public ReadOnly Property LocalityName As String
    Get
public:
property String^ LocalityName {
    String^ get ();
}
public:
property String^ LocalityName {
    String^ get ();
}
member LocalityName : string with get
member LocalityName : string with get

Property Value

Type: Online String
See Also
GeoEntity Class
GeoEntity Members
NFX.Web.GeoLookup Namespace


GeoException Class

GeoException Class NFX Class Library

Base exception class thrown by geo-related logic
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Web WebException
NFX.Web.GeoLookup GeoException

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GeoException : WebException
[SerializableAttribute]
public class GeoException : WebException
<SerializableAttribute>
Public Class GeoException
    Inherits WebException
<SerializableAttribute>
Public Class GeoException
    Inherits WebException
[SerializableAttribute]
public ref class GeoException : public WebException
[SerializableAttribute]
public ref class GeoException : public WebException
[<SerializableAttribute>]
type GeoException =
    class
        inherit WebException
    end
[<SerializableAttribute>]
type GeoException =
    class
        inherit WebException
    end
See Also
GeoException Members
NFX.Web.GeoLookup Namespace


GeoException Members

GeoException Members NFX Class Library

The GeoException type exposes the following members.
Constructors
 | Name | Description
Public method | GeoException | Initializes a new instance of the GeoException class
Public method | GeoException(String) | Initializes a new instance of the GeoException class
Protected method | GeoException(SerializationInfo, StreamingContext) | Initializes a new instance of the GeoException class
Public method | GeoException(String, Exception) | Initializes a new instance of the GeoException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
GeoException Class
NFX.Web.GeoLookup Namespace


GeoException Constructor

GeoException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | GeoException | Initializes a new instance of the GeoException class
Public method | GeoException(String) | Initializes a new instance of the GeoException class
Protected method | GeoException(SerializationInfo, StreamingContext) | Initializes a new instance of the GeoException class
Public method | GeoException(String, Exception) | Initializes a new instance of the GeoException class
Back to Top
See Also
GeoException Class
GeoException Members
NFX.Web.GeoLookup Namespace


GeoException Constructor

GeoException Constructor NFX Class Library

Initializes a new instance of the GeoException class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GeoException()
public GeoException()
Public Sub New
Public Sub New
public:
GeoException()
public:
GeoException()
new : unit -> GeoException
new : unit -> GeoException
See Also
GeoException Class
GeoException Members
GeoException Overload
NFX.Web.GeoLookup Namespace


GeoException Constructor (String)

GeoException Constructor (String) NFX Class Library

Initializes a new instance of the GeoException class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GeoException(
    string message
)
public GeoException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
GeoException(
    String^ message
)
public:
GeoException(
    String^ message
)
new :
        message : string -> GeoException
new :
        message : string -> GeoException

Parameters

message
Type: Online System String
See Also
GeoException Class
GeoException Members
GeoException Overload
NFX.Web.GeoLookup Namespace


GeoException Constructor (SerializationInfo, StreamingContext)

GeoException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GeoException class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected GeoException(
    SerializationInfo info,
    StreamingContext context
)
protected GeoException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
GeoException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
GeoException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GeoException
new :
        info : SerializationInfo *
        context : StreamingContext -> GeoException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
GeoException Class
GeoException Members
GeoException Overload
NFX.Web.GeoLookup Namespace


GeoException Constructor (String, Exception)

GeoException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GeoException class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GeoException(
    string message,
    Exception inner
)
public GeoException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
GeoException(
    String^ message,
    Exception^ inner
)
public:
GeoException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> GeoException
new :
        message : string *
        inner : Exception -> GeoException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
GeoException Class
GeoException Members
GeoException Overload
NFX.Web.GeoLookup Namespace


GeoException Methods

GeoException Methods NFX Class Library

The GeoException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
GeoException Class
NFX.Web.GeoLookup Namespace


GeoException Properties

GeoException Properties NFX Class Library

The GeoException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
GeoException Class
NFX.Web.GeoLookup Namespace


GeoException Events

GeoException Events NFX Class Library

The GeoException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
GeoException Class
NFX.Web.GeoLookup Namespace


GeoLookupService Class

GeoLookupService Class NFX Class Library

Represents a service that can lookup country/city names by domainnames/ip addresses. Thehis implementatuion uses free data from: http://dev.maxmind.com/geoip/geoip2/geolite2/. Must include MaxMind attribution on the public site that uses this data (see License section on maxmind.com)
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.Web.GeoLookup GeoLookupService

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GeoLookupService : Service,
    IGeoLookup, IApplicationComponent, IDisposable
public class GeoLookupService : Service,
    IGeoLookup, IApplicationComponent, IDisposable
Public Class GeoLookupService
    Inherits Service
    Implements IGeoLookup, IApplicationComponent, IDisposable
Public Class GeoLookupService
    Inherits Service
    Implements IGeoLookup, IApplicationComponent, IDisposable
public ref class GeoLookupService : public Service,
    IGeoLookup, IApplicationComponent, IDisposable
public ref class GeoLookupService : public Service,
    IGeoLookup, IApplicationComponent, IDisposable
type GeoLookupService =
    class
        inherit Service
        interface IGeoLookup
        interface IApplicationComponent
        interface IDisposable
    end
type GeoLookupService =
    class
        inherit Service
        interface IGeoLookup
        interface IApplicationComponent
        interface IDisposable
    end
See Also
GeoLookupService Members
NFX.Web.GeoLookup Namespace


GeoLookupService Members

GeoLookupService Members NFX Class Library

The GeoLookupService type exposes the following members.
Constructors
 | Name | Description
Public method | GeoLookupService | Initializes a new instance of the GeoLookupService class
Public method | GeoLookupService(Object) | Initializes a new instance of the GeoLookupService class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CancelStart | Cancels service start. This method may be needed when Start() blocks for a long time due to large volumes of data
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Public method | Lookup | Tries to lookup the location by ip/dns name. Returns null if no match could be made
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_GEO_LOOKUP_SECTION |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Available | Returns true to indoicate that service has loaded and ready to serve data
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DataPath | Specifies where the data is
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
 | Instance | Lazily creates the default service instance
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Resolution | Specifies what resolution service provides
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | StartCanceled | Returns true to indicate that previous attempt to start service - load data, was canceled
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
GeoLookupService Class
NFX.Web.GeoLookup Namespace


GeoLookupService Constructor

GeoLookupService Constructor NFX Class Library

Overload List
 | Name | Description
Public method | GeoLookupService | Initializes a new instance of the GeoLookupService class
Public method | GeoLookupService(Object) | Initializes a new instance of the GeoLookupService class
Back to Top
See Also
GeoLookupService Class
GeoLookupService Members
NFX.Web.GeoLookup Namespace


GeoLookupService Constructor

GeoLookupService Constructor NFX Class Library

Initializes a new instance of the GeoLookupService class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GeoLookupService()
public GeoLookupService()
Public Sub New
Public Sub New
public:
GeoLookupService()
public:
GeoLookupService()
new : unit -> GeoLookupService
new : unit -> GeoLookupService
See Also
GeoLookupService Class
GeoLookupService Members
GeoLookupService Overload
NFX.Web.GeoLookup Namespace


GeoLookupService Constructor (Object)

GeoLookupService Constructor (Object) NFX Class Library

Initializes a new instance of the GeoLookupService class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GeoLookupService(
    Object director
)
public GeoLookupService(
    Object director
)
Public Sub New (
    director As Object
)
Public Sub New (
    director As Object
)
public:
GeoLookupService(
    Object^ director
)
public:
GeoLookupService(
    Object^ director
)
new :
        director : Object -> GeoLookupService
new :
        director : Object -> GeoLookupService

Parameters

director
Type: Online System Object
See Also
GeoLookupService Class
GeoLookupService Members
GeoLookupService Overload
NFX.Web.GeoLookup Namespace


GeoLookupService Fields

GeoLookupService Fields NFX Class Library

The GeoLookupService type exposes the following members.
Fields
Name | Description
CONFIG_GEO_LOOKUP_SECTION |
Back to Top
See Also
GeoLookupService Class
NFX.Web.GeoLookup Namespace


GeoLookupService.CONFIG_GEO_LOOKUP_SECTION Field

GeoLookupService CONFIG_GEO_LOOKUP_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_GEO_LOOKUP_SECTION
public const string CONFIG_GEO_LOOKUP_SECTION
Public Const CONFIG_GEO_LOOKUP_SECTION As String
Public Const CONFIG_GEO_LOOKUP_SECTION As String
public:
literal String^ CONFIG_GEO_LOOKUP_SECTION
public:
literal String^ CONFIG_GEO_LOOKUP_SECTION
static val mutable CONFIG_GEO_LOOKUP_SECTION: string
static val mutable CONFIG_GEO_LOOKUP_SECTION: string

Field Value

Type: Online String
See Also
GeoLookupService Class
GeoLookupService Members
NFX.Web.GeoLookup Namespace


GeoLookupService Methods

GeoLookupService Methods NFX Class Library

The GeoLookupService type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CancelStart | Cancels service start. This method may be needed when Start() blocks for a long time due to large volumes of data
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Public method | Lookup | Tries to lookup the location by ip/dns name. Returns null if no match could be made
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GeoLookupService Class
NFX.Web.GeoLookup Namespace


GeoLookupService.CancelStart Method

GeoLookupService CancelStart Method NFX Class Library

Cancels service start. This method may be needed when Start() blocks for a long time due to large volumes of data

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CancelStart()
public void CancelStart()
Public Sub CancelStart
Public Sub CancelStart
public:
void CancelStart()
public:
void CancelStart()
member CancelStart : unit -> unit
member CancelStart : unit -> unit
See Also
GeoLookupService Class
GeoLookupService Members
NFX.Web.GeoLookup Namespace


GeoLookupService.DoConfigure Method

GeoLookupService DoConfigure Method NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
GeoLookupService Class
GeoLookupService Members
NFX.Web.GeoLookup Namespace


GeoLookupService.DoStart Method

GeoLookupService DoStart Method NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
GeoLookupService Class
GeoLookupService Members
NFX.Web.GeoLookup Namespace


GeoLookupService.DoWaitForCompleteStop Method

GeoLookupService DoWaitForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
GeoLookupService Class
GeoLookupService Members
NFX.Web.GeoLookup Namespace


GeoLookupService.Lookup Method

GeoLookupService Lookup Method NFX Class Library

Tries to lookup the location by ip/dns name. Returns null if no match could be made

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GeoEntity Lookup(
    IPAddress address
)
public GeoEntity Lookup(
    IPAddress address
)
Public Function Lookup (
    address As IPAddress
) As GeoEntity
Public Function Lookup (
    address As IPAddress
) As GeoEntity
public:
virtual GeoEntity^ Lookup(
    IPAddress^ address
) sealed
public:
virtual GeoEntity^ Lookup(
    IPAddress^ address
) sealed
abstract Lookup :
        address : IPAddress -> GeoEntity
override Lookup :
        address : IPAddress -> GeoEntity
abstract Lookup :
        address : IPAddress -> GeoEntity
override Lookup :
        address : IPAddress -> GeoEntity

Parameters

address
Type: Online System.Net IPAddress

Return Value

Type: GeoEntity

Implements

IGeoLookup Lookup(IPAddress)
See Also
GeoLookupService Class
GeoLookupService Members
NFX.Web.GeoLookup Namespace


GeoLookupService Properties

GeoLookupService Properties NFX Class Library

The GeoLookupService type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Available | Returns true to indoicate that service has loaded and ready to serve data
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DataPath | Specifies where the data is
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
 | Instance | Lazily creates the default service instance
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Resolution | Specifies what resolution service provides
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | StartCanceled | Returns true to indicate that previous attempt to start service - load data, was canceled
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
GeoLookupService Class
NFX.Web.GeoLookup Namespace


GeoLookupService.Available Property

GeoLookupService Available Property NFX Class Library

Returns true to indoicate that service has loaded and ready to serve data

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Available { get; }
public bool Available { get; }
Public ReadOnly Property Available As Boolean
    Get
Public ReadOnly Property Available As Boolean
    Get
public:
virtual property bool Available {
    bool get () sealed;
}
public:
virtual property bool Available {
    bool get () sealed;
}
abstract Available : bool with get
override Available : bool with get
abstract Available : bool with get
override Available : bool with get

Property Value

Type: Online Boolean

Implements

IGeoLookup Available
See Also
GeoLookupService Class
GeoLookupService Members
NFX.Web.GeoLookup Namespace


GeoLookupService.DataPath Property

GeoLookupService DataPath Property NFX Class Library

Specifies where the data is

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string DataPath { get; set; }
[ConfigAttribute]
public string DataPath { get; set; }
<ConfigAttribute>
Public Property DataPath As String
    Get
    Set
<ConfigAttribute>
Public Property DataPath As String
    Get
    Set
public:
[ConfigAttribute]
property String^ DataPath {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ DataPath {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member DataPath : string with get, set
[<ConfigAttribute>]
member DataPath : string with get, set

Property Value

Type: Online String
See Also
GeoLookupService Class
GeoLookupService Members
NFX.Web.GeoLookup Namespace


GeoLookupService.Instance Property

GeoLookupService Instance Property NFX Class Library

Lazily creates the default service instance

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IGeoLookup Instance { get; }
public static IGeoLookup Instance { get; }
Public Shared ReadOnly Property Instance As IGeoLookup
    Get
Public Shared ReadOnly Property Instance As IGeoLookup
    Get
public:
static property IGeoLookup^ Instance {
    IGeoLookup^ get ();
}
public:
static property IGeoLookup^ Instance {
    IGeoLookup^ get ();
}
static member Instance : IGeoLookup with get
static member Instance : IGeoLookup with get

Property Value

Type: IGeoLookup
See Also
GeoLookupService Class
GeoLookupService Members
NFX.Web.GeoLookup Namespace


GeoLookupService.Resolution Property

GeoLookupService Resolution Property NFX Class Library

Specifies what resolution service provides

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public LookupResolution Resolution { get; set; }
[ConfigAttribute]
public LookupResolution Resolution { get; set; }
<ConfigAttribute>
Public Property Resolution As LookupResolution
    Get
    Set
<ConfigAttribute>
Public Property Resolution As LookupResolution
    Get
    Set
public:
[ConfigAttribute]
virtual property LookupResolution Resolution {
    LookupResolution get () sealed;
    void set (LookupResolution value) sealed;
}
public:
[ConfigAttribute]
virtual property LookupResolution Resolution {
    LookupResolution get () sealed;
    void set (LookupResolution value) sealed;
}
[<ConfigAttribute>]
abstract Resolution : LookupResolution with get, set
[<ConfigAttribute>]
override Resolution : LookupResolution with get, set
[<ConfigAttribute>]
abstract Resolution : LookupResolution with get, set
[<ConfigAttribute>]
override Resolution : LookupResolution with get, set

Property Value

Type: LookupResolution

Implements

IGeoLookup Resolution
See Also
GeoLookupService Class
GeoLookupService Members
NFX.Web.GeoLookup Namespace


GeoLookupService.StartCanceled Property

GeoLookupService StartCanceled Property NFX Class Library

Returns true to indicate that previous attempt to start service - load data, was canceled

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool StartCanceled { get; }
public bool StartCanceled { get; }
Public ReadOnly Property StartCanceled As Boolean
    Get
Public ReadOnly Property StartCanceled As Boolean
    Get
public:
property bool StartCanceled {
    bool get ();
}
public:
property bool StartCanceled {
    bool get ();
}
member StartCanceled : bool with get
member StartCanceled : bool with get

Property Value

Type: Online Boolean
See Also
GeoLookupService Class
GeoLookupService Members
NFX.Web.GeoLookup Namespace


IGeoLookup Interface

IGeoLookup Interface NFX Class Library

Looks-up entities by their ip addr

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGeoLookup : IApplicationComponent,
    IDisposable
public interface IGeoLookup : IApplicationComponent,
    IDisposable
Public Interface IGeoLookup
    Inherits IApplicationComponent, IDisposable
Public Interface IGeoLookup
    Inherits IApplicationComponent, IDisposable
public interface class IGeoLookup : IApplicationComponent,
    IDisposable
public interface class IGeoLookup : IApplicationComponent,
    IDisposable
type IGeoLookup =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
type IGeoLookup =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
See Also
IGeoLookup Members
NFX.Web.GeoLookup Namespace


IGeoLookup Members

IGeoLookup Members NFX Class Library

The IGeoLookup type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | Lookup | Tries to lookup the geo entitiy by domain IPAddress. Returns null when no match could be made
Back to Top
Properties
 | Name | Description
Public property | Available | Returns true when the underlying provider is initialized and ready to serve queries
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Resolution | Specifies how accurate the lookup is
Back to Top
See Also
IGeoLookup Interface
NFX.Web.GeoLookup Namespace


IGeoLookup Methods

IGeoLookup Methods NFX Class Library

The IGeoLookup type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | Lookup | Tries to lookup the geo entitiy by domain IPAddress. Returns null when no match could be made
Back to Top
See Also
IGeoLookup Interface
NFX.Web.GeoLookup Namespace


IGeoLookup.Lookup Method

IGeoLookup Lookup Method NFX Class Library

Tries to lookup the geo entitiy by domain IPAddress. Returns null when no match could be made

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GeoEntity Lookup(
    IPAddress address
)
GeoEntity Lookup(
    IPAddress address
)
Function Lookup (
    address As IPAddress
) As GeoEntity
Function Lookup (
    address As IPAddress
) As GeoEntity
GeoEntity^ Lookup(
    IPAddress^ address
)
GeoEntity^ Lookup(
    IPAddress^ address
)
abstract Lookup :
        address : IPAddress -> GeoEntity
abstract Lookup :
        address : IPAddress -> GeoEntity

Parameters

address
Type: Online System.Net IPAddress

Return Value

Type: GeoEntity
See Also
IGeoLookup Interface
IGeoLookup Members
NFX.Web.GeoLookup Namespace


IGeoLookup Properties

IGeoLookup Properties NFX Class Library

The IGeoLookup type exposes the following members.
Properties
 | Name | Description
Public property | Available | Returns true when the underlying provider is initialized and ready to serve queries
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Resolution | Specifies how accurate the lookup is
Back to Top
See Also
IGeoLookup Interface
NFX.Web.GeoLookup Namespace


IGeoLookup.Available Property

IGeoLookup Available Property NFX Class Library

Returns true when the underlying provider is initialized and ready to serve queries

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Available { get; }
bool Available { get; }
ReadOnly Property Available As Boolean
    Get
ReadOnly Property Available As Boolean
    Get
property bool Available {
    bool get ();
}
property bool Available {
    bool get ();
}
abstract Available : bool with get
abstract Available : bool with get

Property Value

Type: Online Boolean
See Also
IGeoLookup Interface
IGeoLookup Members
NFX.Web.GeoLookup Namespace


IGeoLookup.Resolution Property

IGeoLookup Resolution Property NFX Class Library

Specifies how accurate the lookup is

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
LookupResolution Resolution { get; }
LookupResolution Resolution { get; }
ReadOnly Property Resolution As LookupResolution
    Get
ReadOnly Property Resolution As LookupResolution
    Get
property LookupResolution Resolution {
    LookupResolution get ();
}
property LookupResolution Resolution {
    LookupResolution get ();
}
abstract Resolution : LookupResolution with get
abstract Resolution : LookupResolution with get

Property Value

Type: LookupResolution
See Also
IGeoLookup Interface
IGeoLookup Members
NFX.Web.GeoLookup Namespace


IPSubnetBlock Structure

IPSubnetBlock Structure NFX Class Library

Provides address segment block information

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct IPSubnetBlock
public struct IPSubnetBlock
Public Structure IPSubnetBlock
Public Structure IPSubnetBlock
public value class IPSubnetBlock
public value class IPSubnetBlock
[<SealedAttribute>]
type IPSubnetBlock =  struct end
[<SealedAttribute>]
type IPSubnetBlock =  struct end
See Also
IPSubnetBlock Members
NFX.Web.GeoLookup Namespace


IPSubnetBlock Members

IPSubnetBlock Members NFX Class Library

The IPSubnetBlock type exposes the following members.
Constructors
 | Name | Description
Public method | IPSubnetBlock | Initializes a new instance of the IPSubnetBlock class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | AnonymousProxy |
Public field | Lat |
Public field | Lng |
Public field | LocationID |
Public field | PostalCode |
Public field | RegisteredLocationID |
Public field | RepresentedLocationID |
Public field | SatelliteProvider |
Public field | Subnet |
Back to Top
See Also
IPSubnetBlock Structure
NFX.Web.GeoLookup Namespace


IPSubnetBlock Constructor

IPSubnetBlock Constructor NFX Class Library

Initializes a new instance of the IPSubnetBlock class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPSubnetBlock(
    SealedString subnet,
    SealedString locationID,
    SealedString registeredLocationID,
    SealedString representedLocationID,
    bool anonymousProxy,
    bool satelliteProvider,
    SealedString postalCode,
    float lat,
    float lng
)
public IPSubnetBlock(
    SealedString subnet,
    SealedString locationID,
    SealedString registeredLocationID,
    SealedString representedLocationID,
    bool anonymousProxy,
    bool satelliteProvider,
    SealedString postalCode,
    float lat,
    float lng
)
Public Sub New (
    subnet As SealedString,
    locationID As SealedString,
    registeredLocationID As SealedString,
    representedLocationID As SealedString,
    anonymousProxy As Boolean,
    satelliteProvider As Boolean,
    postalCode As SealedString,
    lat As Single,
    lng As Single
)
Public Sub New (
    subnet As SealedString,
    locationID As SealedString,
    registeredLocationID As SealedString,
    representedLocationID As SealedString,
    anonymousProxy As Boolean,
    satelliteProvider As Boolean,
    postalCode As SealedString,
    lat As Single,
    lng As Single
)
public:
IPSubnetBlock(
    SealedString subnet,
    SealedString locationID,
    SealedString registeredLocationID,
    SealedString representedLocationID,
    bool anonymousProxy,
    bool satelliteProvider,
    SealedString postalCode,
    float lat,
    float lng
)
public:
IPSubnetBlock(
    SealedString subnet,
    SealedString locationID,
    SealedString registeredLocationID,
    SealedString representedLocationID,
    bool anonymousProxy,
    bool satelliteProvider,
    SealedString postalCode,
    float lat,
    float lng
)
new :
        subnet : SealedString *
        locationID : SealedString *
        registeredLocationID : SealedString *
        representedLocationID : SealedString *
        anonymousProxy : bool *
        satelliteProvider : bool *
        postalCode : SealedString *
        lat : float32 *
        lng : float32 -> IPSubnetBlock
new :
        subnet : SealedString *
        locationID : SealedString *
        registeredLocationID : SealedString *
        representedLocationID : SealedString *
        anonymousProxy : bool *
        satelliteProvider : bool *
        postalCode : SealedString *
        lat : float32 *
        lng : float32 -> IPSubnetBlock

Parameters

subnet
Type: NFX SealedString
locationID
Type: NFX SealedString
registeredLocationID
Type: NFX SealedString
representedLocationID
Type: NFX SealedString
anonymousProxy
Type: Online System Boolean
satelliteProvider
Type: Online System Boolean
postalCode
Type: NFX SealedString
lat
Type: Online System Single
lng
Type: Online System Single
See Also
IPSubnetBlock Structure
IPSubnetBlock Members
NFX.Web.GeoLookup Namespace


IPSubnetBlock Fields

IPSubnetBlock Fields NFX Class Library

The IPSubnetBlock type exposes the following members.
Fields
 | Name | Description
Public field | AnonymousProxy |
Public field | Lat |
Public field | Lng |
Public field | LocationID |
Public field | PostalCode |
Public field | RegisteredLocationID |
Public field | RepresentedLocationID |
Public field | SatelliteProvider |
Public field | Subnet |
Back to Top
See Also
IPSubnetBlock Structure
NFX.Web.GeoLookup Namespace


IPSubnetBlock.AnonymousProxy Field

IPSubnetBlock AnonymousProxy Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool AnonymousProxy
public readonly bool AnonymousProxy
Public ReadOnly AnonymousProxy As Boolean
Public ReadOnly AnonymousProxy As Boolean
public:
initonly bool AnonymousProxy
public:
initonly bool AnonymousProxy
val AnonymousProxy: bool
val AnonymousProxy: bool

Field Value

Type: Online Boolean
See Also
IPSubnetBlock Structure
IPSubnetBlock Members
NFX.Web.GeoLookup Namespace


IPSubnetBlock.Lat Field

IPSubnetBlock Lat Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly float Lat
public readonly float Lat
Public ReadOnly Lat As Single
Public ReadOnly Lat As Single
public:
initonly float Lat
public:
initonly float Lat
val Lat: float32
val Lat: float32

Field Value

Type: Online Single
See Also
IPSubnetBlock Structure
IPSubnetBlock Members
NFX.Web.GeoLookup Namespace


IPSubnetBlock.Lng Field

IPSubnetBlock Lng Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly float Lng
public readonly float Lng
Public ReadOnly Lng As Single
Public ReadOnly Lng As Single
public:
initonly float Lng
public:
initonly float Lng
val Lng: float32
val Lng: float32

Field Value

Type: Online Single
See Also
IPSubnetBlock Structure
IPSubnetBlock Members
NFX.Web.GeoLookup Namespace


IPSubnetBlock.LocationID Field

IPSubnetBlock LocationID Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString LocationID
public readonly SealedString LocationID
Public ReadOnly LocationID As SealedString
Public ReadOnly LocationID As SealedString
public:
initonly SealedString LocationID
public:
initonly SealedString LocationID
val LocationID: SealedString
val LocationID: SealedString

Field Value

Type: SealedString
See Also
IPSubnetBlock Structure
IPSubnetBlock Members
NFX.Web.GeoLookup Namespace


IPSubnetBlock.PostalCode Field

IPSubnetBlock PostalCode Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString PostalCode
public readonly SealedString PostalCode
Public ReadOnly PostalCode As SealedString
Public ReadOnly PostalCode As SealedString
public:
initonly SealedString PostalCode
public:
initonly SealedString PostalCode
val PostalCode: SealedString
val PostalCode: SealedString

Field Value

Type: SealedString
See Also
IPSubnetBlock Structure
IPSubnetBlock Members
NFX.Web.GeoLookup Namespace


IPSubnetBlock.RegisteredLocationID Field

IPSubnetBlock RegisteredLocationID Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString RegisteredLocationID
public readonly SealedString RegisteredLocationID
Public ReadOnly RegisteredLocationID As SealedString
Public ReadOnly RegisteredLocationID As SealedString
public:
initonly SealedString RegisteredLocationID
public:
initonly SealedString RegisteredLocationID
val RegisteredLocationID: SealedString
val RegisteredLocationID: SealedString

Field Value

Type: SealedString
See Also
IPSubnetBlock Structure
IPSubnetBlock Members
NFX.Web.GeoLookup Namespace


IPSubnetBlock.RepresentedLocationID Field

IPSubnetBlock RepresentedLocationID Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString RepresentedLocationID
public readonly SealedString RepresentedLocationID
Public ReadOnly RepresentedLocationID As SealedString
Public ReadOnly RepresentedLocationID As SealedString
public:
initonly SealedString RepresentedLocationID
public:
initonly SealedString RepresentedLocationID
val RepresentedLocationID: SealedString
val RepresentedLocationID: SealedString

Field Value

Type: SealedString
See Also
IPSubnetBlock Structure
IPSubnetBlock Members
NFX.Web.GeoLookup Namespace


IPSubnetBlock.SatelliteProvider Field

IPSubnetBlock SatelliteProvider Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool SatelliteProvider
public readonly bool SatelliteProvider
Public ReadOnly SatelliteProvider As Boolean
Public ReadOnly SatelliteProvider As Boolean
public:
initonly bool SatelliteProvider
public:
initonly bool SatelliteProvider
val SatelliteProvider: bool
val SatelliteProvider: bool

Field Value

Type: Online Boolean
See Also
IPSubnetBlock Structure
IPSubnetBlock Members
NFX.Web.GeoLookup Namespace


IPSubnetBlock.Subnet Field

IPSubnetBlock Subnet Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString Subnet
public readonly SealedString Subnet
Public ReadOnly Subnet As SealedString
Public ReadOnly Subnet As SealedString
public:
initonly SealedString Subnet
public:
initonly SealedString Subnet
val Subnet: SealedString
val Subnet: SealedString

Field Value

Type: SealedString
See Also
IPSubnetBlock Structure
IPSubnetBlock Members
NFX.Web.GeoLookup Namespace


IPSubnetBlock Methods

IPSubnetBlock Methods NFX Class Library

The IPSubnetBlock type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
IPSubnetBlock Structure
NFX.Web.GeoLookup Namespace


Location Structure

Location Structure NFX Class Library

Provides location information

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Location
public struct Location
Public Structure Location
Public Structure Location
public value class Location
public value class Location
[<SealedAttribute>]
type Location =  struct end
[<SealedAttribute>]
type Location =  struct end
See Also
Location Members
NFX.Web.GeoLookup Namespace


Location Members

Location Members NFX Class Library

The Location type exposes the following members.
Constructors
 | Name | Description
Public method | Location | Initializes a new instance of the Location class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | CityName |
Public field | ContinentID |
Public field | ContinentName |
Public field | CountryISOName |
Public field | CountryName |
Public field | ID |
Public field | LocaleCode |
Public field | MetroCode |
Public field | Subdivision2ISOCode |
Public field | Subdivision2Name |
Public field | SubdivisionISOCode |
Public field | SubdivisionName |
Public field | TimeZone |
Back to Top
See Also
Location Structure
NFX.Web.GeoLookup Namespace


Location Constructor

Location Constructor NFX Class Library

Initializes a new instance of the Location class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Location(
    SealedString id,
    SealedString localeCode,
    SealedString continentID,
    SealedString continentName,
    SealedString countryISOName,
    SealedString countryName,
    SealedString subdivisionISOCode,
    SealedString subdivisionName,
    SealedString subdivision2ISOCode,
    SealedString subdivision2Name,
    SealedString cityName,
    SealedString metroCode,
    SealedString timeZone
)
public Location(
    SealedString id,
    SealedString localeCode,
    SealedString continentID,
    SealedString continentName,
    SealedString countryISOName,
    SealedString countryName,
    SealedString subdivisionISOCode,
    SealedString subdivisionName,
    SealedString subdivision2ISOCode,
    SealedString subdivision2Name,
    SealedString cityName,
    SealedString metroCode,
    SealedString timeZone
)
Public Sub New (
    id As SealedString,
    localeCode As SealedString,
    continentID As SealedString,
    continentName As SealedString,
    countryISOName As SealedString,
    countryName As SealedString,
    subdivisionISOCode As SealedString,
    subdivisionName As SealedString,
    subdivision2ISOCode As SealedString,
    subdivision2Name As SealedString,
    cityName As SealedString,
    metroCode As SealedString,
    timeZone As SealedString
)
Public Sub New (
    id As SealedString,
    localeCode As SealedString,
    continentID As SealedString,
    continentName As SealedString,
    countryISOName As SealedString,
    countryName As SealedString,
    subdivisionISOCode As SealedString,
    subdivisionName As SealedString,
    subdivision2ISOCode As SealedString,
    subdivision2Name As SealedString,
    cityName As SealedString,
    metroCode As SealedString,
    timeZone As SealedString
)
public:
Location(
    SealedString id,
    SealedString localeCode,
    SealedString continentID,
    SealedString continentName,
    SealedString countryISOName,
    SealedString countryName,
    SealedString subdivisionISOCode,
    SealedString subdivisionName,
    SealedString subdivision2ISOCode,
    SealedString subdivision2Name,
    SealedString cityName,
    SealedString metroCode,
    SealedString timeZone
)
public:
Location(
    SealedString id,
    SealedString localeCode,
    SealedString continentID,
    SealedString continentName,
    SealedString countryISOName,
    SealedString countryName,
    SealedString subdivisionISOCode,
    SealedString subdivisionName,
    SealedString subdivision2ISOCode,
    SealedString subdivision2Name,
    SealedString cityName,
    SealedString metroCode,
    SealedString timeZone
)
new :
        id : SealedString *
        localeCode : SealedString *
        continentID : SealedString *
        continentName : SealedString *
        countryISOName : SealedString *
        countryName : SealedString *
        subdivisionISOCode : SealedString *
        subdivisionName : SealedString *
        subdivision2ISOCode : SealedString *
        subdivision2Name : SealedString *
        cityName : SealedString *
        metroCode : SealedString *
        timeZone : SealedString -> Location
new :
        id : SealedString *
        localeCode : SealedString *
        continentID : SealedString *
        continentName : SealedString *
        countryISOName : SealedString *
        countryName : SealedString *
        subdivisionISOCode : SealedString *
        subdivisionName : SealedString *
        subdivision2ISOCode : SealedString *
        subdivision2Name : SealedString *
        cityName : SealedString *
        metroCode : SealedString *
        timeZone : SealedString -> Location

Parameters

id
Type: NFX SealedString
localeCode
Type: NFX SealedString
continentID
Type: NFX SealedString
continentName
Type: NFX SealedString
countryISOName
Type: NFX SealedString
countryName
Type: NFX SealedString
subdivisionISOCode
Type: NFX SealedString
subdivisionName
Type: NFX SealedString
subdivision2ISOCode
Type: NFX SealedString
subdivision2Name
Type: NFX SealedString
cityName
Type: NFX SealedString
metroCode
Type: NFX SealedString
timeZone
Type: NFX SealedString
See Also
Location Structure
Location Members
NFX.Web.GeoLookup Namespace


Location Fields

Location Fields NFX Class Library

The Location type exposes the following members.
Fields
 | Name | Description
Public field | CityName |
Public field | ContinentID |
Public field | ContinentName |
Public field | CountryISOName |
Public field | CountryName |
Public field | ID |
Public field | LocaleCode |
Public field | MetroCode |
Public field | Subdivision2ISOCode |
Public field | Subdivision2Name |
Public field | SubdivisionISOCode |
Public field | SubdivisionName |
Public field | TimeZone |
Back to Top
See Also
Location Structure
NFX.Web.GeoLookup Namespace


Location.CityName Field

Location CityName Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString CityName
public readonly SealedString CityName
Public ReadOnly CityName As SealedString
Public ReadOnly CityName As SealedString
public:
initonly SealedString CityName
public:
initonly SealedString CityName
val CityName: SealedString
val CityName: SealedString

Field Value

Type: SealedString
See Also
Location Structure
Location Members
NFX.Web.GeoLookup Namespace


Location.ContinentID Field

Location ContinentID Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString ContinentID
public readonly SealedString ContinentID
Public ReadOnly ContinentID As SealedString
Public ReadOnly ContinentID As SealedString
public:
initonly SealedString ContinentID
public:
initonly SealedString ContinentID
val ContinentID: SealedString
val ContinentID: SealedString

Field Value

Type: SealedString
See Also
Location Structure
Location Members
NFX.Web.GeoLookup Namespace


Location.ContinentName Field

Location ContinentName Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString ContinentName
public readonly SealedString ContinentName
Public ReadOnly ContinentName As SealedString
Public ReadOnly ContinentName As SealedString
public:
initonly SealedString ContinentName
public:
initonly SealedString ContinentName
val ContinentName: SealedString
val ContinentName: SealedString

Field Value

Type: SealedString
See Also
Location Structure
Location Members
NFX.Web.GeoLookup Namespace


Location.CountryISOName Field

Location CountryISOName Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString CountryISOName
public readonly SealedString CountryISOName
Public ReadOnly CountryISOName As SealedString
Public ReadOnly CountryISOName As SealedString
public:
initonly SealedString CountryISOName
public:
initonly SealedString CountryISOName
val CountryISOName: SealedString
val CountryISOName: SealedString

Field Value

Type: SealedString
See Also
Location Structure
Location Members
NFX.Web.GeoLookup Namespace


Location.CountryName Field

Location CountryName Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString CountryName
public readonly SealedString CountryName
Public ReadOnly CountryName As SealedString
Public ReadOnly CountryName As SealedString
public:
initonly SealedString CountryName
public:
initonly SealedString CountryName
val CountryName: SealedString
val CountryName: SealedString

Field Value

Type: SealedString
See Also
Location Structure
Location Members
NFX.Web.GeoLookup Namespace


Location.ID Field

Location ID Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString ID
public readonly SealedString ID
Public ReadOnly ID As SealedString
Public ReadOnly ID As SealedString
public:
initonly SealedString ID
public:
initonly SealedString ID
val ID: SealedString
val ID: SealedString

Field Value

Type: SealedString
See Also
Location Structure
Location Members
NFX.Web.GeoLookup Namespace


Location.LocaleCode Field

Location LocaleCode Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString LocaleCode
public readonly SealedString LocaleCode
Public ReadOnly LocaleCode As SealedString
Public ReadOnly LocaleCode As SealedString
public:
initonly SealedString LocaleCode
public:
initonly SealedString LocaleCode
val LocaleCode: SealedString
val LocaleCode: SealedString

Field Value

Type: SealedString
See Also
Location Structure
Location Members
NFX.Web.GeoLookup Namespace


Location.MetroCode Field

Location MetroCode Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString MetroCode
public readonly SealedString MetroCode
Public ReadOnly MetroCode As SealedString
Public ReadOnly MetroCode As SealedString
public:
initonly SealedString MetroCode
public:
initonly SealedString MetroCode
val MetroCode: SealedString
val MetroCode: SealedString

Field Value

Type: SealedString
See Also
Location Structure
Location Members
NFX.Web.GeoLookup Namespace


Location.Subdivision2ISOCode Field

Location Subdivision2ISOCode Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString Subdivision2ISOCode
public readonly SealedString Subdivision2ISOCode
Public ReadOnly Subdivision2ISOCode As SealedString
Public ReadOnly Subdivision2ISOCode As SealedString
public:
initonly SealedString Subdivision2ISOCode
public:
initonly SealedString Subdivision2ISOCode
val Subdivision2ISOCode: SealedString
val Subdivision2ISOCode: SealedString

Field Value

Type: SealedString
See Also
Location Structure
Location Members
NFX.Web.GeoLookup Namespace


Location.Subdivision2Name Field

Location Subdivision2Name Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString Subdivision2Name
public readonly SealedString Subdivision2Name
Public ReadOnly Subdivision2Name As SealedString
Public ReadOnly Subdivision2Name As SealedString
public:
initonly SealedString Subdivision2Name
public:
initonly SealedString Subdivision2Name
val Subdivision2Name: SealedString
val Subdivision2Name: SealedString

Field Value

Type: SealedString
See Also
Location Structure
Location Members
NFX.Web.GeoLookup Namespace


Location.SubdivisionISOCode Field

Location SubdivisionISOCode Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString SubdivisionISOCode
public readonly SealedString SubdivisionISOCode
Public ReadOnly SubdivisionISOCode As SealedString
Public ReadOnly SubdivisionISOCode As SealedString
public:
initonly SealedString SubdivisionISOCode
public:
initonly SealedString SubdivisionISOCode
val SubdivisionISOCode: SealedString
val SubdivisionISOCode: SealedString

Field Value

Type: SealedString
See Also
Location Structure
Location Members
NFX.Web.GeoLookup Namespace


Location.SubdivisionName Field

Location SubdivisionName Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString SubdivisionName
public readonly SealedString SubdivisionName
Public ReadOnly SubdivisionName As SealedString
Public ReadOnly SubdivisionName As SealedString
public:
initonly SealedString SubdivisionName
public:
initonly SealedString SubdivisionName
val SubdivisionName: SealedString
val SubdivisionName: SealedString

Field Value

Type: SealedString
See Also
Location Structure
Location Members
NFX.Web.GeoLookup Namespace


Location.TimeZone Field

Location TimeZone Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SealedString TimeZone
public readonly SealedString TimeZone
Public ReadOnly TimeZone As SealedString
Public ReadOnly TimeZone As SealedString
public:
initonly SealedString TimeZone
public:
initonly SealedString TimeZone
val TimeZone: SealedString
val TimeZone: SealedString

Field Value

Type: SealedString
See Also
Location Structure
Location Members
NFX.Web.GeoLookup Namespace


Location Methods

Location Methods NFX Class Library

The Location type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Location Structure
NFX.Web.GeoLookup Namespace


LookupResolution Enumeration

LookupResolution Enumeration NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum LookupResolution
public enum LookupResolution
Public Enumeration LookupResolution
Public Enumeration LookupResolution
public enum class LookupResolution
public enum class LookupResolution
type LookupResolution
type LookupResolution
Members
Member name | Value | Description
Planet | 0 |
Continent | 1 |
Country | 2 |
City | 3 |
Street | 4 |
See Also
NFX.Web.GeoLookup Namespace


Subnet Structure

Subnet Structure NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Subnet : IEnumerable<bool>,
    IEnumerable
public struct Subnet : IEnumerable<bool>,
    IEnumerable
Public Structure Subnet
    Implements IEnumerable(Of Boolean), IEnumerable
Public Structure Subnet
    Implements IEnumerable(Of Boolean), IEnumerable
public value class Subnet : IEnumerable<bool>,
    IEnumerable
public value class Subnet : IEnumerable<bool>,
    IEnumerable
[<SealedAttribute>]
type Subnet =
    struct
        interface IEnumerable<bool>
        interface IEnumerable
    end
[<SealedAttribute>]
type Subnet =
    struct
        interface IEnumerable<bool>
        interface IEnumerable
    end
See Also
Subnet Members
NFX.Web.GeoLookup Namespace


Subnet Members

Subnet Members NFX Class Library

The Subnet type exposes the following members.
Constructors
 | Name | Description
Public method | Subnet(String, Boolean) | Initializes a new instance of the Subnet class
Public method | Subnet(IPAddress, Int32, Boolean) | Initializes a new instance of the Subnet class
Back to Top
Methods
 | Name | Description
 | Enumerate |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | IsIPv6 |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable Boolean | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct Boolean, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax Boolean, TComparand (Func Boolean, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax Boolean, TComparand (Func Boolean, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Boolean, TComparand (Func Boolean, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Boolean, TComparand (Func Boolean, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault Boolean | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach Boolean (Action Boolean ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach Boolean (Action Boolean, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast Boolean | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast Boolean (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Address |
Public field | CIDR |
 | CIDRv4Subnet |
Public field | MapToIPv6 |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Subnet Structure
NFX.Web.GeoLookup Namespace


Subnet Constructor

Subnet Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Subnet(String, Boolean) | Initializes a new instance of the Subnet class
Public method | Subnet(IPAddress, Int32, Boolean) | Initializes a new instance of the Subnet class
Back to Top
See Also
Subnet Structure
Subnet Members
NFX.Web.GeoLookup Namespace


Subnet Constructor (String, Boolean)

Subnet Constructor (String, Boolean) NFX Class Library

Initializes a new instance of the Subnet class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Subnet(
    string subnet,
    bool mapToIPv6 = false
)
public Subnet(
    string subnet,
    bool mapToIPv6 = false
)
Public Sub New (
    subnet As String,
    Optional mapToIPv6 As Boolean = false
)
Public Sub New (
    subnet As String,
    Optional mapToIPv6 As Boolean = false
)
public:
Subnet(
    String^ subnet,
    bool mapToIPv6 = false
)
public:
Subnet(
    String^ subnet,
    bool mapToIPv6 = false
)
new :
        subnet : string *
        ?mapToIPv6 : bool
(* Defaults:
        let _mapToIPv6 = defaultArg mapToIPv6 false
*)
-> Subnet
new :
        subnet : string *
        ?mapToIPv6 : bool
(* Defaults:
        let _mapToIPv6 = defaultArg mapToIPv6 false
*)
-> Subnet

Parameters

subnet
Type: Online System String
mapToIPv6 (Optional)
Type: Online System Boolean
See Also
Subnet Structure
Subnet Members
Subnet Overload
NFX.Web.GeoLookup Namespace


Subnet Constructor (IPAddress, Int32, Boolean)

Subnet Constructor (IPAddress, Int32, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Subnet class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Subnet(
    IPAddress address,
    int cidr = -1,
    bool mapToIPv6 = false
)
public Subnet(
    IPAddress address,
    int cidr = -1,
    bool mapToIPv6 = false
)
Public Sub New (
    address As IPAddress,
    Optional cidr As Integer = -1,
    Optional mapToIPv6 As Boolean = false
)
Public Sub New (
    address As IPAddress,
    Optional cidr As Integer = -1,
    Optional mapToIPv6 As Boolean = false
)
public:
Subnet(
    IPAddress^ address,
    int cidr = -1,
    bool mapToIPv6 = false
)
public:
Subnet(
    IPAddress^ address,
    int cidr = -1,
    bool mapToIPv6 = false
)
new :
        address : IPAddress *
        ?cidr : int *
        ?mapToIPv6 : bool
(* Defaults:
        let _cidr = defaultArg cidr -1
        let _mapToIPv6 = defaultArg mapToIPv6 false
*)
-> Subnet
new :
        address : IPAddress *
        ?cidr : int *
        ?mapToIPv6 : bool
(* Defaults:
        let _cidr = defaultArg cidr -1
        let _mapToIPv6 = defaultArg mapToIPv6 false
*)
-> Subnet

Parameters

address
Type: Online System.Net IPAddress
cidr (Optional)
Type: Online System Int32
mapToIPv6 (Optional)
Type: Online System Boolean
See Also
Subnet Structure
Subnet Members
Subnet Overload
NFX.Web.GeoLookup Namespace


Subnet Fields

Subnet Fields NFX Class Library

The Subnet type exposes the following members.
Fields
 | Name | Description
Public field | Address |
Public field | CIDR |
 | CIDRv4Subnet |
Public field | MapToIPv6 |
Back to Top
See Also
Subnet Structure
NFX.Web.GeoLookup Namespace


Subnet.Address Field

Subnet Address Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IPAddress Address
public readonly IPAddress Address
Public ReadOnly Address As IPAddress
Public ReadOnly Address As IPAddress
public:
initonly IPAddress^ Address
public:
initonly IPAddress^ Address
val Address: IPAddress
val Address: IPAddress

Field Value

Type: Online IPAddress
See Also
Subnet Structure
Subnet Members
NFX.Web.GeoLookup Namespace


Subnet.CIDR Field

Subnet CIDR Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int CIDR
public readonly int CIDR
Public ReadOnly CIDR As Integer
Public ReadOnly CIDR As Integer
public:
initonly int CIDR
public:
initonly int CIDR
val CIDR: int
val CIDR: int

Field Value

Type: Online Int32
See Also
Subnet Structure
Subnet Members
NFX.Web.GeoLookup Namespace


Subnet.CIDRv4Subnet Field

Subnet CIDRv4Subnet Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CIDRv4Subnet
public const int CIDRv4Subnet
Public Const CIDRv4Subnet As Integer
Public Const CIDRv4Subnet As Integer
public:
literal int CIDRv4Subnet
public:
literal int CIDRv4Subnet
static val mutable CIDRv4Subnet: int
static val mutable CIDRv4Subnet: int

Field Value

Type: Online Int32
See Also
Subnet Structure
Subnet Members
NFX.Web.GeoLookup Namespace


Subnet.MapToIPv6 Field

Subnet MapToIPv6 Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MapToIPv6
public bool MapToIPv6
Public MapToIPv6 As Boolean
Public MapToIPv6 As Boolean
public:
bool MapToIPv6
public:
bool MapToIPv6
val mutable MapToIPv6: bool
val mutable MapToIPv6: bool

Field Value

Type: Online Boolean
See Also
Subnet Structure
Subnet Members
NFX.Web.GeoLookup Namespace


Subnet Methods

Subnet Methods NFX Class Library

The Subnet type exposes the following members.
Methods
 | Name | Description
 | Enumerate |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | IsIPv6 |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable Boolean | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct Boolean, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax Boolean, TComparand (Func Boolean, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax Boolean, TComparand (Func Boolean, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Boolean, TComparand (Func Boolean, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Boolean, TComparand (Func Boolean, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault Boolean | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach Boolean (Action Boolean ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach Boolean (Action Boolean, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast Boolean | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast Boolean (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Subnet Structure
NFX.Web.GeoLookup Namespace


Subnet.IEnumerable.GetEnumerator Method

Subnet IEnumerable GetEnumerator Method NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
Subnet Structure
Subnet Members
NFX.Web.GeoLookup Namespace


Subnet.Enumerate Method

Subnet Enumerate Method NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<bool> Enumerate(
    IPAddress address,
    int CIDR = -1,
    bool mapToIPv6 = false
)
public static IEnumerable<bool> Enumerate(
    IPAddress address,
    int CIDR = -1,
    bool mapToIPv6 = false
)
Public Shared Function Enumerate (
    address As IPAddress,
    Optional CIDR As Integer = -1,
    Optional mapToIPv6 As Boolean = false
) As IEnumerable(Of Boolean)
Public Shared Function Enumerate (
    address As IPAddress,
    Optional CIDR As Integer = -1,
    Optional mapToIPv6 As Boolean = false
) As IEnumerable(Of Boolean)
public:
static IEnumerable<bool>^ Enumerate(
    IPAddress^ address,
    int CIDR = -1,
    bool mapToIPv6 = false
)
public:
static IEnumerable<bool>^ Enumerate(
    IPAddress^ address,
    int CIDR = -1,
    bool mapToIPv6 = false
)
static member Enumerate :
        address : IPAddress *
        ?CIDR : int *
        ?mapToIPv6 : bool
(* Defaults:
        let _CIDR = defaultArg CIDR -1
        let _mapToIPv6 = defaultArg mapToIPv6 false
*)
-> IEnumerable<bool>
static member Enumerate :
        address : IPAddress *
        ?CIDR : int *
        ?mapToIPv6 : bool
(* Defaults:
        let _CIDR = defaultArg CIDR -1
        let _mapToIPv6 = defaultArg mapToIPv6 false
*)
-> IEnumerable<bool>

Parameters

address
Type: Online System.Net IPAddress
CIDR (Optional)
Type: Online System Int32
mapToIPv6 (Optional)
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online Boolean
See Also
Subnet Structure
Subnet Members
NFX.Web.GeoLookup Namespace


Subnet.GetEnumerator Method

Subnet GetEnumerator Method NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<bool> GetEnumerator()
public IEnumerator<bool> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Boolean)
Public Function GetEnumerator As IEnumerator(Of Boolean)
public:
virtual IEnumerator<bool>^ GetEnumerator() sealed
public:
virtual IEnumerator<bool>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<bool>
override GetEnumerator : unit -> IEnumerator<bool>
abstract GetEnumerator : unit -> IEnumerator<bool>
override GetEnumerator : unit -> IEnumerator<bool>

Return Value

Type: Online IEnumerator Online Boolean

Implements

Online IEnumerable T GetEnumerator
See Also
Subnet Structure
Subnet Members
NFX.Web.GeoLookup Namespace


Subnet.IsIPv6 Method

Subnet IsIPv6 Method NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsIPv6(
    IPAddress original
)
public static bool IsIPv6(
    IPAddress original
)
Public Shared Function IsIPv6 (
    original As IPAddress
) As Boolean
Public Shared Function IsIPv6 (
    original As IPAddress
) As Boolean
public:
static bool IsIPv6(
    IPAddress^ original
)
public:
static bool IsIPv6(
    IPAddress^ original
)
static member IsIPv6 :
        original : IPAddress -> bool
static member IsIPv6 :
        original : IPAddress -> bool

Parameters

original
Type: Online System.Net IPAddress

Return Value

Type: Online Boolean
See Also
Subnet Structure
Subnet Members
NFX.Web.GeoLookup Namespace


SubnetTree(V) Class

SubnetTree V Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Web.GeoLookup BinaryIndexedTree Subnet, V
NFX.Web.GeoLookup SubnetTree V

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SubnetTree<V> : BinaryIndexedTree<Subnet, V>
public class SubnetTree<V> : BinaryIndexedTree<Subnet, V>
Public Class SubnetTree(Of V)
    Inherits BinaryIndexedTree(Of Subnet, V)
Public Class SubnetTree(Of V)
    Inherits BinaryIndexedTree(Of Subnet, V)
generic<typename V>
public ref class SubnetTree : public BinaryIndexedTree<Subnet, V>
generic<typename V>
public ref class SubnetTree : public BinaryIndexedTree<Subnet, V>
type SubnetTree<'V> =
    class
        inherit BinaryIndexedTree<Subnet, 'V>
    end
type SubnetTree<'V> =
    class
        inherit BinaryIndexedTree<Subnet, 'V>
    end
Type Parameters
V
See Also
SubnetTree V Members
NFX.Web.GeoLookup Namespace


SubnetTree(V) Members

SubnetTree V Members NFX Class Library

The SubnetTree V type exposes the following members.
Constructors
 | Name | Description
Public method | SubnetTree V | Initializes a new instance of the SubnetTree V class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | Find | (Inherited from BinaryIndexedTree K, V .)
Protected method | FindIndex | (Inherited from BinaryIndexedTree K, V .)
Protected method | FindOffset | (Inherited from BinaryIndexedTree K, V .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Nodes | (Inherited from BinaryIndexedTree K, V .)
Public field | OffsetIPv4 |
Public field | Values | (Inherited from BinaryIndexedTree K, V .)
Back to Top
Properties
 | Name | Description
Public property | Item | (Overrides BinaryIndexedTree K, V Item K .)
Back to Top
See Also
SubnetTree V Class
NFX.Web.GeoLookup Namespace


SubnetTree(V) Constructor

SubnetTree V Constructor NFX Class Library

Initializes a new instance of the SubnetTree V class

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SubnetTree(
    BinaryIndexedTree<Subnet, V> tree
)
public SubnetTree(
    BinaryIndexedTree<Subnet, V> tree
)
Public Sub New (
    tree As BinaryIndexedTree(Of Subnet, V)
)
Public Sub New (
    tree As BinaryIndexedTree(Of Subnet, V)
)
public:
SubnetTree(
    BinaryIndexedTree<Subnet, V>^ tree
)
public:
SubnetTree(
    BinaryIndexedTree<Subnet, V>^ tree
)
new :
        tree : BinaryIndexedTree<Subnet, 'V> -> SubnetTree
new :
        tree : BinaryIndexedTree<Subnet, 'V> -> SubnetTree

Parameters

tree
Type: NFX.Web.GeoLookup BinaryIndexedTree Subnet, V
See Also
SubnetTree V Class
SubnetTree V Members
NFX.Web.GeoLookup Namespace


SubnetTree(V) Fields

SubnetTree V Fields NFX Class Library

The SubnetTree V type exposes the following members.
Fields
 | Name | Description
Public field | Nodes | (Inherited from BinaryIndexedTree K, V .)
Public field | OffsetIPv4 |
Public field | Values | (Inherited from BinaryIndexedTree K, V .)
Back to Top
See Also
SubnetTree V Class
NFX.Web.GeoLookup Namespace


SubnetTree(V).OffsetIPv4 Field

SubnetTree V OffsetIPv4 Field NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly uint OffsetIPv4
public readonly uint OffsetIPv4
Public ReadOnly OffsetIPv4 As UInteger
Public ReadOnly OffsetIPv4 As UInteger
public:
initonly unsigned int OffsetIPv4
public:
initonly unsigned int OffsetIPv4
val OffsetIPv4: uint32
val OffsetIPv4: uint32

Field Value

Type: Online UInt32
See Also
SubnetTree V Class
SubnetTree V Members
NFX.Web.GeoLookup Namespace


SubnetTree(V) Methods

SubnetTree V Methods NFX Class Library

The SubnetTree V type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | Find | (Inherited from BinaryIndexedTree K, V .)
Protected method | FindIndex | (Inherited from BinaryIndexedTree K, V .)
Protected method | FindOffset | (Inherited from BinaryIndexedTree K, V .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SubnetTree V Class
NFX.Web.GeoLookup Namespace


SubnetTree(V) Properties

SubnetTree V Properties NFX Class Library

The SubnetTree V type exposes the following members.
Properties
 | Name | Description
Public property | Item | (Overrides BinaryIndexedTree K, V Item K .)
Back to Top
See Also
SubnetTree V Class
NFX.Web.GeoLookup Namespace


SubnetTree(V).Item Property

SubnetTree V Item Property NFX Class Library

Namespace: NFX.Web.GeoLookup
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override V this[
    Subnet key
] { get; }
public override V this[
    Subnet key
] { get; }
Public Overrides ReadOnly Default Property Item (
    key As Subnet
) As V
    Get
Public Overrides ReadOnly Default Property Item (
    key As Subnet
) As V
    Get
public:
virtual property V default[Subnet key] {
    V get (Subnet key) override;
}
public:
virtual property V default[Subnet key] {
    V get (Subnet key) override;
}
abstract Item : 'V with get
override Item : 'V with get
abstract Item : 'V with get
override Item : 'V with get

Parameters

key
Type: NFX.Web.GeoLookup Subnet

Property Value

Type: V
See Also
SubnetTree V Class
SubnetTree V Members
NFX.Web.GeoLookup Namespace


NFX.Web.IO Namespace

NFX.Web.IO Namespace NFX Class Library

Classes
 | Class | Description
Public class | RFC3986 |


RFC3986 Class

RFC3986 Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Web.IO RFC3986

Namespace: NFX.Web.IO
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class RFC3986
public static class RFC3986
Public NotInheritable Class RFC3986
Public NotInheritable Class RFC3986
public ref class RFC3986 abstract sealed
public ref class RFC3986 abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RFC3986 =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RFC3986 =  class end
See Also
RFC3986 Members
NFX.Web.IO Namespace


RFC3986 Members

RFC3986 Members NFX Class Library

The RFC3986 type exposes the following members.
Methods
Name | Description
Encode | Encodes string according to RFC3986
URLEncode | Encodes URL string according to RFC3986
Back to Top
See Also
RFC3986 Class
NFX.Web.IO Namespace


RFC3986 Methods

RFC3986 Methods NFX Class Library

The RFC3986 type exposes the following members.
Methods
Name | Description
Encode | Encodes string according to RFC3986
URLEncode | Encodes URL string according to RFC3986
Back to Top
See Also
RFC3986 Class
NFX.Web.IO Namespace


RFC3986.Encode Method

RFC3986 Encode Method NFX Class Library

Encodes string according to RFC3986

Namespace: NFX.Web.IO
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Encode(
    string input
)
public static string Encode(
    string input
)
Public Shared Function Encode (
    input As String
) As String
Public Shared Function Encode (
    input As String
) As String
public:
static String^ Encode(
    String^ input
)
public:
static String^ Encode(
    String^ input
)
static member Encode :
        input : string -> string
static member Encode :
        input : string -> string

Parameters

input
Type: Online System String

Return Value

Type: Online String
See Also
RFC3986 Class
RFC3986 Members
NFX.Web.IO Namespace


RFC3986.URLEncode Method

RFC3986 URLEncode Method NFX Class Library

Encodes URL string according to RFC3986

Namespace: NFX.Web.IO
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string URLEncode(
    string input
)
public static string URLEncode(
    string input
)
Public Shared Function URLEncode (
    input As String
) As String
Public Shared Function URLEncode (
    input As String
) As String
public:
static String^ URLEncode(
    String^ input
)
public:
static String^ URLEncode(
    String^ input
)
static member URLEncode :
        input : string -> string
static member URLEncode :
        input : string -> string

Parameters

input
Type: Online System String

Return Value

Type: Online String
See Also
RFC3986 Class
RFC3986 Members
NFX.Web.IO Namespace


NFX.Web.Messaging Namespace

NFX.Web.Messaging Namespace NFX Class Library

Classes
 | Class | Description
Public class | MailgunMailerSink | Implements mailer sink using Mailgun service
Public class | Message | Represents an email msg that needs to be sent
Public class | MessageService | Provides implementation for IMessenger service
Public class | MessageSink | Base for ALL implementations that work under MailerService
Public class | NOPMessageSink |
Public class | NOPMessenger | Implements NOP Mailer that does nothing
Public class | SMTPMessageSink | Implements msg sink based on SMTPClient
Structures
 | Structure | Description
Public structure | Message Attachment |
Interfaces
 | Interface | Description
Public interface | IMessageSink | Marker interface for injection into MailerSerive.Sink property from code
Public interface | IMessenger | Describes an entity that can send EMails
Public interface | IMessengerImplementation |
Enumerations
 | Enumeration | Description
Public enumeration | MsgChannels |
Public enumeration | MsgImportance |
Public enumeration | MsgPriority |


IMessageSink Interface

IMessageSink Interface NFX Class Library

Marker interface for injection into MailerSerive.Sink property from code

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IMessageSink
public interface IMessageSink
Public Interface IMessageSink
Public Interface IMessageSink
public interface class IMessageSink
public interface class IMessageSink
type IMessageSink =  interface end
type IMessageSink =  interface end
See Also
IMessageSink Members
NFX.Web.Messaging Namespace


IMessageSink Members

IMessageSink Members NFX Class Library

The IMessageSink type exposes the following members.
Properties
 | Name | Description
Public property | ComponentDirector |
Back to Top
See Also
IMessageSink Interface
NFX.Web.Messaging Namespace


IMessageSink Properties

IMessageSink Properties NFX Class Library

The IMessageSink type exposes the following members.
Properties
 | Name | Description
Public property | ComponentDirector |
Back to Top
See Also
IMessageSink Interface
NFX.Web.Messaging Namespace


IMessageSink.ComponentDirector Property

IMessageSink ComponentDirector Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
MessageService ComponentDirector { get; }
MessageService ComponentDirector { get; }
ReadOnly Property ComponentDirector As MessageService
    Get
ReadOnly Property ComponentDirector As MessageService
    Get
property MessageService^ ComponentDirector {
    MessageService^ get ();
}
property MessageService^ ComponentDirector {
    MessageService^ get ();
}
abstract ComponentDirector : MessageService with get
abstract ComponentDirector : MessageService with get

Property Value

Type: MessageService
See Also
IMessageSink Interface
IMessageSink Members
NFX.Web.Messaging Namespace


IMessenger Interface

IMessenger Interface NFX Class Library

Describes an entity that can send EMails

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IMessenger : IApplicationComponent,
    IDisposable
public interface IMessenger : IApplicationComponent,
    IDisposable
Public Interface IMessenger
    Inherits IApplicationComponent, IDisposable
Public Interface IMessenger
    Inherits IApplicationComponent, IDisposable
public interface class IMessenger : IApplicationComponent,
    IDisposable
public interface class IMessenger : IApplicationComponent,
    IDisposable
type IMessenger =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
type IMessenger =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
See Also
IMessenger Members
NFX.Web.Messaging Namespace


IMessenger Members

IMessenger Members NFX Class Library

The IMessenger type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | SendMsg |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Back to Top
See Also
IMessenger Interface
NFX.Web.Messaging Namespace


IMessenger Methods

IMessenger Methods NFX Class Library

The IMessenger type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | SendMsg |
Back to Top
See Also
IMessenger Interface
NFX.Web.Messaging Namespace


IMessenger.SendMsg Method

IMessenger SendMsg Method NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SendMsg(
    Message msg
)
void SendMsg(
    Message msg
)
Sub SendMsg (
    msg As Message
)
Sub SendMsg (
    msg As Message
)
void SendMsg(
    Message^ msg
)
void SendMsg(
    Message^ msg
)
abstract SendMsg :
        msg : Message -> unit
abstract SendMsg :
        msg : Message -> unit

Parameters

msg
Type: NFX.Web.Messaging Message
See Also
IMessenger Interface
IMessenger Members
NFX.Web.Messaging Namespace


IMessenger Properties

IMessenger Properties NFX Class Library

The IMessenger type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Back to Top
See Also
IMessenger Interface
NFX.Web.Messaging Namespace


IMessengerImplementation Interface

IMessengerImplementation Interface NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IMessengerImplementation : IMessenger,
    IApplicationComponent, IDisposable, IService, IConfigurable, IApplicationFinishNotifiable,
    INamed
public interface IMessengerImplementation : IMessenger,
    IApplicationComponent, IDisposable, IService, IConfigurable, IApplicationFinishNotifiable,
    INamed
Public Interface IMessengerImplementation
    Inherits IMessenger, IApplicationComponent, IDisposable, IService,
    IConfigurable, IApplicationFinishNotifiable, INamed
Public Interface IMessengerImplementation
    Inherits IMessenger, IApplicationComponent, IDisposable, IService,
    IConfigurable, IApplicationFinishNotifiable, INamed
public interface class IMessengerImplementation : IMessenger,
    IApplicationComponent, IDisposable, IService, IConfigurable, IApplicationFinishNotifiable,
    INamed
public interface class IMessengerImplementation : IMessenger,
    IApplicationComponent, IDisposable, IService, IConfigurable, IApplicationFinishNotifiable,
    INamed
type IMessengerImplementation =
    interface
        interface IMessenger
        interface IApplicationComponent
        interface IDisposable
        interface IService
        interface IConfigurable
        interface IApplicationFinishNotifiable
        interface INamed
    end
type IMessengerImplementation =
    interface
        interface IMessenger
        interface IApplicationComponent
        interface IDisposable
        interface IService
        interface IConfigurable
        interface IApplicationFinishNotifiable
        interface INamed
    end
See Also
IMessengerImplementation Members
NFX.Web.Messaging Namespace


IMessengerImplementation Members

IMessengerImplementation Members NFX Class Library

The IMessengerImplementation type exposes the following members.
Methods
 | Name | Description
Public method | ApplicationFinishAfterCleanup | (Inherited from IApplicationFinishNotifiable.)
Public method | ApplicationFinishBeforeCleanup | (Inherited from IApplicationFinishNotifiable.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from IService.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | SendMsg | (Inherited from IMessenger.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from IService.)
Public method | Start | Blocking call that starts the service instance (Inherited from IService.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from IService.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Name | (Inherited from INamed.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from IService.)
Public property | Status | Current service status (Inherited from IService.)
Back to Top
See Also
IMessengerImplementation Interface
NFX.Web.Messaging Namespace


IMessengerImplementation Methods

IMessengerImplementation Methods NFX Class Library

The IMessengerImplementation type exposes the following members.
Methods
 | Name | Description
Public method | ApplicationFinishAfterCleanup | (Inherited from IApplicationFinishNotifiable.)
Public method | ApplicationFinishBeforeCleanup | (Inherited from IApplicationFinishNotifiable.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from IService.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | SendMsg | (Inherited from IMessenger.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from IService.)
Public method | Start | Blocking call that starts the service instance (Inherited from IService.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from IService.)
Back to Top
See Also
IMessengerImplementation Interface
NFX.Web.Messaging Namespace


IMessengerImplementation Properties

IMessengerImplementation Properties NFX Class Library

The IMessengerImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Name | (Inherited from INamed.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from IService.)
Public property | Status | Current service status (Inherited from IService.)
Back to Top
See Also
IMessengerImplementation Interface
NFX.Web.Messaging Namespace


MailgunMailerSink Class

MailgunMailerSink Class NFX Class Library

Implements mailer sink using Mailgun service
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service MessageService
NFX.Web.Messaging MessageSink
NFX.Web.Messaging MailgunMailerSink

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MailgunMailerSink : MessageSink,
    IWebClientCaller
public sealed class MailgunMailerSink : MessageSink,
    IWebClientCaller
Public NotInheritable Class MailgunMailerSink
    Inherits MessageSink
    Implements IWebClientCaller
Public NotInheritable Class MailgunMailerSink
    Inherits MessageSink
    Implements IWebClientCaller
public ref class MailgunMailerSink sealed : public MessageSink,
    IWebClientCaller
public ref class MailgunMailerSink sealed : public MessageSink,
    IWebClientCaller
[<SealedAttribute>]
type MailgunMailerSink =
    class
        inherit MessageSink
        interface IWebClientCaller
    end
[<SealedAttribute>]
type MailgunMailerSink =
    class
        inherit MessageSink
        interface IWebClientCaller
    end
See Also
MailgunMailerSink Members
NFX.Web.Messaging Namespace


MailgunMailerSink Members

MailgunMailerSink Members NFX Class Library

The MailgunMailerSink type exposes the following members.
Constructors
 | Name | Description
Public method | MailgunMailerSink | Initializes a new instance of the MailgunMailerSink class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSendMsg | MessageSink DoSendMsg implementation (Overrides MessageSink DoSendMsg(Message).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SendMsg | Performs actual sending of msg. This method does not have to be thread-safe as it is called by a single thread (Inherited from MessageSink.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_FALLBACKSINK_SECTION |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | AuthorizationKey |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultFromAddress |
Public property | DefaultFromName |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | DKIM |
Public property | Domain |
Public property | KeepAlive |
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Pipelined |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServiceUrl |
Public property | Status | Current service status (Inherited from Service.)
Public property | TestMode |
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | WebServiceCallTimeoutMs |
Back to Top
See Also
MailgunMailerSink Class
NFX.Web.Messaging Namespace


MailgunMailerSink Constructor

MailgunMailerSink Constructor NFX Class Library

Initializes a new instance of the MailgunMailerSink class

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MailgunMailerSink(
    MessageService director
)
public MailgunMailerSink(
    MessageService director
)
Public Sub New (
    director As MessageService
)
Public Sub New (
    director As MessageService
)
public:
MailgunMailerSink(
    MessageService^ director
)
public:
MailgunMailerSink(
    MessageService^ director
)
new :
        director : MessageService -> MailgunMailerSink
new :
        director : MessageService -> MailgunMailerSink

Parameters

director
Type: NFX.Web.Messaging MessageService
See Also
MailgunMailerSink Class
MailgunMailerSink Members
NFX.Web.Messaging Namespace


MailgunMailerSink Fields

MailgunMailerSink Fields NFX Class Library

The MailgunMailerSink type exposes the following members.
Fields
Name | Description
CONFIG_FALLBACKSINK_SECTION |
Back to Top
See Also
MailgunMailerSink Class
NFX.Web.Messaging Namespace


MailgunMailerSink.CONFIG_FALLBACKSINK_SECTION Field

MailgunMailerSink CONFIG_FALLBACKSINK_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FALLBACKSINK_SECTION
public const string CONFIG_FALLBACKSINK_SECTION
Public Const CONFIG_FALLBACKSINK_SECTION As String
Public Const CONFIG_FALLBACKSINK_SECTION As String
public:
literal String^ CONFIG_FALLBACKSINK_SECTION
public:
literal String^ CONFIG_FALLBACKSINK_SECTION
static val mutable CONFIG_FALLBACKSINK_SECTION: string
static val mutable CONFIG_FALLBACKSINK_SECTION: string

Field Value

Type: Online String
See Also
MailgunMailerSink Class
MailgunMailerSink Members
NFX.Web.Messaging Namespace


MailgunMailerSink Methods

MailgunMailerSink Methods NFX Class Library

The MailgunMailerSink type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSendMsg | MessageSink DoSendMsg implementation (Overrides MessageSink DoSendMsg(Message).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SendMsg | Performs actual sending of msg. This method does not have to be thread-safe as it is called by a single thread (Inherited from MessageSink.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MailgunMailerSink Class
NFX.Web.Messaging Namespace


MailgunMailerSink.DoConfigure Method

MailgunMailerSink DoConfigure Method NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
MailgunMailerSink Class
MailgunMailerSink Members
NFX.Web.Messaging Namespace


MailgunMailerSink.DoSendMsg Method

MailgunMailerSink DoSendMsg Method NFX Class Library

MessageSink DoSendMsg implementation

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSendMsg(
    Message msg
)
protected override void DoSendMsg(
    Message msg
)
Protected Overrides Sub DoSendMsg (
    msg As Message
)
Protected Overrides Sub DoSendMsg (
    msg As Message
)
protected:
virtual void DoSendMsg(
    Message^ msg
) override
protected:
virtual void DoSendMsg(
    Message^ msg
) override
abstract DoSendMsg :
        msg : Message -> unit
override DoSendMsg :
        msg : Message -> unit
abstract DoSendMsg :
        msg : Message -> unit
override DoSendMsg :
        msg : Message -> unit

Parameters

msg
Type: NFX.Web.Messaging Message
Message
See Also
MailgunMailerSink Class
MailgunMailerSink Members
NFX.Web.Messaging Namespace


MailgunMailerSink Properties

MailgunMailerSink Properties NFX Class Library

The MailgunMailerSink type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | AuthorizationKey |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultFromAddress |
Public property | DefaultFromName |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | DKIM |
Public property | Domain |
Public property | KeepAlive |
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Pipelined |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServiceUrl |
Public property | Status | Current service status (Inherited from Service.)
Public property | TestMode |
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | WebServiceCallTimeoutMs |
Back to Top
See Also
MailgunMailerSink Class
NFX.Web.Messaging Namespace


MailgunMailerSink.AuthorizationKey Property

MailgunMailerSink AuthorizationKey Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string AuthorizationKey { get; set; }
[ConfigAttribute]
public string AuthorizationKey { get; set; }
<ConfigAttribute>
Public Property AuthorizationKey As String
    Get
    Set
<ConfigAttribute>
Public Property AuthorizationKey As String
    Get
    Set
public:
[ConfigAttribute]
property String^ AuthorizationKey {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ AuthorizationKey {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member AuthorizationKey : string with get, set
[<ConfigAttribute>]
member AuthorizationKey : string with get, set

Property Value

Type: Online String
See Also
MailgunMailerSink Class
MailgunMailerSink Members
NFX.Web.Messaging Namespace


MailgunMailerSink.DefaultFromAddress Property

MailgunMailerSink DefaultFromAddress Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string DefaultFromAddress { get; set; }
[ConfigAttribute]
public string DefaultFromAddress { get; set; }
<ConfigAttribute>
Public Property DefaultFromAddress As String
    Get
    Set
<ConfigAttribute>
Public Property DefaultFromAddress As String
    Get
    Set
public:
[ConfigAttribute]
property String^ DefaultFromAddress {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ DefaultFromAddress {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member DefaultFromAddress : string with get, set
[<ConfigAttribute>]
member DefaultFromAddress : string with get, set

Property Value

Type: Online String
See Also
MailgunMailerSink Class
MailgunMailerSink Members
NFX.Web.Messaging Namespace


MailgunMailerSink.DefaultFromName Property

MailgunMailerSink DefaultFromName Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string DefaultFromName { get; set; }
[ConfigAttribute]
public string DefaultFromName { get; set; }
<ConfigAttribute>
Public Property DefaultFromName As String
    Get
    Set
<ConfigAttribute>
Public Property DefaultFromName As String
    Get
    Set
public:
[ConfigAttribute]
property String^ DefaultFromName {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ DefaultFromName {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member DefaultFromName : string with get, set
[<ConfigAttribute>]
member DefaultFromName : string with get, set

Property Value

Type: Online String
See Also
MailgunMailerSink Class
MailgunMailerSink Members
NFX.Web.Messaging Namespace


MailgunMailerSink.DKIM Property

MailgunMailerSink DKIM Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool DKIM { get; set; }
[ConfigAttribute]
public bool DKIM { get; set; }
<ConfigAttribute>
Public Property DKIM As Boolean
    Get
    Set
<ConfigAttribute>
Public Property DKIM As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool DKIM {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool DKIM {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member DKIM : bool with get, set
[<ConfigAttribute>]
member DKIM : bool with get, set

Property Value

Type: Online Boolean
See Also
MailgunMailerSink Class
MailgunMailerSink Members
NFX.Web.Messaging Namespace


MailgunMailerSink.Domain Property

MailgunMailerSink Domain Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Domain { get; set; }
[ConfigAttribute]
public string Domain { get; set; }
<ConfigAttribute>
Public Property Domain As String
    Get
    Set
<ConfigAttribute>
Public Property Domain As String
    Get
    Set
public:
[ConfigAttribute]
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member Domain : string with get, set
[<ConfigAttribute>]
member Domain : string with get, set

Property Value

Type: Online String
See Also
MailgunMailerSink Class
MailgunMailerSink Members
NFX.Web.Messaging Namespace


MailgunMailerSink.KeepAlive Property

MailgunMailerSink KeepAlive Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = false)]
public bool KeepAlive { get; set; }
[ConfigAttribute(Default = false)]
public bool KeepAlive { get; set; }
<ConfigAttribute(Default := false)>
Public Property KeepAlive As Boolean
    Get
    Set
<ConfigAttribute(Default := false)>
Public Property KeepAlive As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = false)]
virtual property bool KeepAlive {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
[ConfigAttribute(Default = false)]
virtual property bool KeepAlive {
    bool get () sealed;
    void set (bool value) sealed;
}
[<ConfigAttribute(Default = false)>]
abstract KeepAlive : bool with get, set
[<ConfigAttribute(Default = false)>]
override KeepAlive : bool with get, set
[<ConfigAttribute(Default = false)>]
abstract KeepAlive : bool with get, set
[<ConfigAttribute(Default = false)>]
override KeepAlive : bool with get, set

Property Value

Type: Online Boolean

Implements

IWebClientCaller KeepAlive
See Also
MailgunMailerSink Class
MailgunMailerSink Members
NFX.Web.Messaging Namespace


MailgunMailerSink.Pipelined Property

MailgunMailerSink Pipelined Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = false)]
public bool Pipelined { get; set; }
[ConfigAttribute(Default = false)]
public bool Pipelined { get; set; }
<ConfigAttribute(Default := false)>
Public Property Pipelined As Boolean
    Get
    Set
<ConfigAttribute(Default := false)>
Public Property Pipelined As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = false)]
virtual property bool Pipelined {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
[ConfigAttribute(Default = false)]
virtual property bool Pipelined {
    bool get () sealed;
    void set (bool value) sealed;
}
[<ConfigAttribute(Default = false)>]
abstract Pipelined : bool with get, set
[<ConfigAttribute(Default = false)>]
override Pipelined : bool with get, set
[<ConfigAttribute(Default = false)>]
abstract Pipelined : bool with get, set
[<ConfigAttribute(Default = false)>]
override Pipelined : bool with get, set

Property Value

Type: Online Boolean

Implements

IWebClientCaller Pipelined
See Also
MailgunMailerSink Class
MailgunMailerSink Members
NFX.Web.Messaging Namespace


MailgunMailerSink.ServiceUrl Property

MailgunMailerSink ServiceUrl Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Uri ServiceUrl { get; }
public Uri ServiceUrl { get; }
Public ReadOnly Property ServiceUrl As Uri
    Get
Public ReadOnly Property ServiceUrl As Uri
    Get
public:
property Uri^ ServiceUrl {
    Uri^ get ();
}
public:
property Uri^ ServiceUrl {
    Uri^ get ();
}
member ServiceUrl : Uri with get
member ServiceUrl : Uri with get

Property Value

Type: Online Uri
See Also
MailgunMailerSink Class
MailgunMailerSink Members
NFX.Web.Messaging Namespace


MailgunMailerSink.TestMode Property

MailgunMailerSink TestMode Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool TestMode { get; set; }
[ConfigAttribute]
public bool TestMode { get; set; }
<ConfigAttribute>
Public Property TestMode As Boolean
    Get
    Set
<ConfigAttribute>
Public Property TestMode As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool TestMode {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool TestMode {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member TestMode : bool with get, set
[<ConfigAttribute>]
member TestMode : bool with get, set

Property Value

Type: Online Boolean
See Also
MailgunMailerSink Class
MailgunMailerSink Members
NFX.Web.Messaging Namespace


MailgunMailerSink.WebServiceCallTimeoutMs Property

MailgunMailerSink WebServiceCallTimeoutMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = 20000)]
public int WebServiceCallTimeoutMs { get; set; }
[ConfigAttribute(Default = 20000)]
public int WebServiceCallTimeoutMs { get; set; }
<ConfigAttribute(Default := 20000)>
Public Property WebServiceCallTimeoutMs As Integer
    Get
    Set
<ConfigAttribute(Default := 20000)>
Public Property WebServiceCallTimeoutMs As Integer
    Get
    Set
public:
[ConfigAttribute(Default = 20000)]
virtual property int WebServiceCallTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
public:
[ConfigAttribute(Default = 20000)]
virtual property int WebServiceCallTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
[<ConfigAttribute(Default = 20000)>]
abstract WebServiceCallTimeoutMs : int with get, set
[<ConfigAttribute(Default = 20000)>]
override WebServiceCallTimeoutMs : int with get, set
[<ConfigAttribute(Default = 20000)>]
abstract WebServiceCallTimeoutMs : int with get, set
[<ConfigAttribute(Default = 20000)>]
override WebServiceCallTimeoutMs : int with get, set

Property Value

Type: Online Int32

Implements

IWebClientCaller WebServiceCallTimeoutMs
See Also
MailgunMailerSink Class
MailgunMailerSink Members
NFX.Web.Messaging Namespace


Message Class

Message Class NFX Class Library

Represents an email msg that needs to be sent
Inheritance Hierarchy
Online System Object
NFX.Web.Messaging Message

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class Message
[SerializableAttribute]
public class Message
<SerializableAttribute>
Public Class Message
<SerializableAttribute>
Public Class Message
[SerializableAttribute]
public ref class Message
[SerializableAttribute]
public ref class Message
[<SerializableAttribute>]
type Message =  class end
[<SerializableAttribute>]
type Message =  class end
See Also
Message Members
NFX.Web.Messaging Namespace


Message Members

Message Members NFX Class Library

The Message type exposes the following members.
Constructors
 | Name | Description
Public method | Message | Initializes a new instance of the Message class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Attachments |
Back to Top
Properties
 | Name | Description
Public property | BCC |
Public property | Body | Plain/text body
Public property | CC |
Public property | Channels |
Public property | FROMAddress |
Public property | FROMName |
Public property | GUID |
Public property | HTMLBody | HTML-formatted body
Public property | Importance |
Public property | Priority |
Public property | Subject |
Public property | TOAddress |
Public property | TOName |
Back to Top
See Also
Message Class
NFX.Web.Messaging Namespace


Message Constructor

Message Constructor NFX Class Library

Initializes a new instance of the Message class

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message(
    Nullable<Guid> guid
)
public Message(
    Nullable<Guid> guid
)
Public Sub New (
    guid As Nullable(Of Guid)
)
Public Sub New (
    guid As Nullable(Of Guid)
)
public:
Message(
    Nullable<Guid> guid
)
public:
Message(
    Nullable<Guid> guid
)
new :
        guid : Nullable<Guid> -> Message
new :
        guid : Nullable<Guid> -> Message

Parameters

guid
Type: Online System Nullable Online Guid
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message Fields

Message Fields NFX Class Library

The Message type exposes the following members.
Fields
 | Name | Description
Public field | Attachments |
Back to Top
See Also
Message Class
NFX.Web.Messaging Namespace


Message.Attachments Field

Message Attachments Field NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message..::..Attachment[] Attachments
public Message..::..Attachment[] Attachments
Public Attachments As Message..::..Attachment()
Public Attachments As Message..::..Attachment()
public:
array<Message..::..Attachment>^ Attachments
public:
array<Message..::..Attachment>^ Attachments
val mutable Attachments: Message..::..Attachment[]
val mutable Attachments: Message..::..Attachment[]

Field Value

Type: Message Attachment
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message Methods

Message Methods NFX Class Library

The Message type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Message Class
NFX.Web.Messaging Namespace


Message Properties

Message Properties NFX Class Library

The Message type exposes the following members.
Properties
 | Name | Description
Public property | BCC |
Public property | Body | Plain/text body
Public property | CC |
Public property | Channels |
Public property | FROMAddress |
Public property | FROMName |
Public property | GUID |
Public property | HTMLBody | HTML-formatted body
Public property | Importance |
Public property | Priority |
Public property | Subject |
Public property | TOAddress |
Public property | TOName |
Back to Top
See Also
Message Class
NFX.Web.Messaging Namespace


Message.BCC Property

Message BCC Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BCC { get; set; }
public string BCC { get; set; }
Public Property BCC As String
    Get
    Set
Public Property BCC As String
    Get
    Set
public:
property String^ BCC {
    String^ get ();
    void set (String^ value);
}
public:
property String^ BCC {
    String^ get ();
    void set (String^ value);
}
member BCC : string with get, set
member BCC : string with get, set

Property Value

Type: Online String
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message.Body Property

Message Body Property NFX Class Library

Plain/text body

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Body { get; set; }
public string Body { get; set; }
Public Property Body As String
    Get
    Set
Public Property Body As String
    Get
    Set
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}
member Body : string with get, set
member Body : string with get, set

Property Value

Type: Online String
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message.CC Property

Message CC Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CC { get; set; }
public string CC { get; set; }
Public Property CC As String
    Get
    Set
Public Property CC As String
    Get
    Set
public:
property String^ CC {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CC {
    String^ get ();
    void set (String^ value);
}
member CC : string with get, set
member CC : string with get, set

Property Value

Type: Online String
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message.Channels Property

Message Channels Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MsgChannels Channels { get; set; }
public MsgChannels Channels { get; set; }
Public Property Channels As MsgChannels
    Get
    Set
Public Property Channels As MsgChannels
    Get
    Set
public:
property MsgChannels Channels {
    MsgChannels get ();
    void set (MsgChannels value);
}
public:
property MsgChannels Channels {
    MsgChannels get ();
    void set (MsgChannels value);
}
member Channels : MsgChannels with get, set
member Channels : MsgChannels with get, set

Property Value

Type: MsgChannels
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message.FROMAddress Property

Message FROMAddress Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FROMAddress { get; set; }
public string FROMAddress { get; set; }
Public Property FROMAddress As String
    Get
    Set
Public Property FROMAddress As String
    Get
    Set
public:
property String^ FROMAddress {
    String^ get ();
    void set (String^ value);
}
public:
property String^ FROMAddress {
    String^ get ();
    void set (String^ value);
}
member FROMAddress : string with get, set
member FROMAddress : string with get, set

Property Value

Type: Online String
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message.FROMName Property

Message FROMName Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FROMName { get; set; }
public string FROMName { get; set; }
Public Property FROMName As String
    Get
    Set
Public Property FROMName As String
    Get
    Set
public:
property String^ FROMName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ FROMName {
    String^ get ();
    void set (String^ value);
}
member FROMName : string with get, set
member FROMName : string with get, set

Property Value

Type: Online String
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message.GUID Property

Message GUID Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid GUID { get; private set; }
public Guid GUID { get; private set; }
Public Property GUID As Guid
    Get
    Private Set
Public Property GUID As Guid
    Get
    Private Set
public:
property Guid GUID {
    Guid get ();
    private: void set (Guid value);
}
public:
property Guid GUID {
    Guid get ();
    private: void set (Guid value);
}
member GUID : Guid with get, private set
member GUID : Guid with get, private set

Property Value

Type: Online Guid
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message.HTMLBody Property

Message HTMLBody Property NFX Class Library

HTML-formatted body

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HTMLBody { get; set; }
public string HTMLBody { get; set; }
Public Property HTMLBody As String
    Get
    Set
Public Property HTMLBody As String
    Get
    Set
public:
property String^ HTMLBody {
    String^ get ();
    void set (String^ value);
}
public:
property String^ HTMLBody {
    String^ get ();
    void set (String^ value);
}
member HTMLBody : string with get, set
member HTMLBody : string with get, set

Property Value

Type: Online String
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message.Importance Property

Message Importance Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MsgImportance Importance { get; set; }
public MsgImportance Importance { get; set; }
Public Property Importance As MsgImportance
    Get
    Set
Public Property Importance As MsgImportance
    Get
    Set
public:
property MsgImportance Importance {
    MsgImportance get ();
    void set (MsgImportance value);
}
public:
property MsgImportance Importance {
    MsgImportance get ();
    void set (MsgImportance value);
}
member Importance : MsgImportance with get, set
member Importance : MsgImportance with get, set

Property Value

Type: MsgImportance
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message.Priority Property

Message Priority Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MsgPriority Priority { get; set; }
public MsgPriority Priority { get; set; }
Public Property Priority As MsgPriority
    Get
    Set
Public Property Priority As MsgPriority
    Get
    Set
public:
property MsgPriority Priority {
    MsgPriority get ();
    void set (MsgPriority value);
}
public:
property MsgPriority Priority {
    MsgPriority get ();
    void set (MsgPriority value);
}
member Priority : MsgPriority with get, set
member Priority : MsgPriority with get, set

Property Value

Type: MsgPriority
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message.Subject Property

Message Subject Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Subject { get; set; }
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set
Public Property Subject As String
    Get
    Set
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
member Subject : string with get, set
member Subject : string with get, set

Property Value

Type: Online String
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message.TOAddress Property

Message TOAddress Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TOAddress { get; set; }
public string TOAddress { get; set; }
Public Property TOAddress As String
    Get
    Set
Public Property TOAddress As String
    Get
    Set
public:
property String^ TOAddress {
    String^ get ();
    void set (String^ value);
}
public:
property String^ TOAddress {
    String^ get ();
    void set (String^ value);
}
member TOAddress : string with get, set
member TOAddress : string with get, set

Property Value

Type: Online String
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message.TOName Property

Message TOName Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TOName { get; set; }
public string TOName { get; set; }
Public Property TOName As String
    Get
    Set
Public Property TOName As String
    Get
    Set
public:
property String^ TOName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ TOName {
    String^ get ();
    void set (String^ value);
}
member TOName : string with get, set
member TOName : string with get, set

Property Value

Type: Online String
See Also
Message Class
Message Members
NFX.Web.Messaging Namespace


Message.Attachment Structure

Message Attachment Structure NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Attachment
public struct Attachment
Public Structure Attachment
Public Structure Attachment
public value class Attachment
public value class Attachment
[<SealedAttribute>]
type Attachment =  struct end
[<SealedAttribute>]
type Attachment =  struct end
See Also
Message Attachment Members
NFX.Web.Messaging Namespace


Message.Attachment Members

Message Attachment Members NFX Class Library

The Message Attachment type exposes the following members.
Constructors
 | Name | Description
Public method | Message Attachment | Initializes a new instance of the Message Attachment class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Content |
Public field | ContentType |
Public field | Name |
Back to Top
See Also
Message Attachment Structure
NFX.Web.Messaging Namespace


Message.Attachment Constructor

Message Attachment Constructor NFX Class Library

Initializes a new instance of the Message Attachment class

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Attachment(
    string name,
    byte[] content,
    string contentType
)
public Attachment(
    string name,
    byte[] content,
    string contentType
)
Public Sub New (
    name As String,
    content As Byte(),
    contentType As String
)
Public Sub New (
    name As String,
    content As Byte(),
    contentType As String
)
public:
Attachment(
    String^ name,
    array<unsigned char>^ content,
    String^ contentType
)
public:
Attachment(
    String^ name,
    array<unsigned char>^ content,
    String^ contentType
)
new :
        name : string *
        content : byte[] *
        contentType : string -> Attachment
new :
        name : string *
        content : byte[] *
        contentType : string -> Attachment

Parameters

name
Type: Online System String
content
Type: Online System Byte
contentType
Type: Online System String
See Also
Message Attachment Structure
Message Attachment Members
NFX.Web.Messaging Namespace


Message.Attachment Fields

Message Attachment Fields NFX Class Library

The Message Attachment type exposes the following members.
Fields
 | Name | Description
Public field | Content |
Public field | ContentType |
Public field | Name |
Back to Top
See Also
Message Attachment Structure
NFX.Web.Messaging Namespace


Message.Attachment.Content Field

Message Attachment Content Field NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly byte[] Content
public readonly byte[] Content
Public ReadOnly Content As Byte()
Public ReadOnly Content As Byte()
public:
initonly array<unsigned char>^ Content
public:
initonly array<unsigned char>^ Content
val Content: byte[]
val Content: byte[]

Field Value

Type: Online Byte
See Also
Message Attachment Structure
Message Attachment Members
NFX.Web.Messaging Namespace


Message.Attachment.ContentType Field

Message Attachment ContentType Field NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string ContentType
public readonly string ContentType
Public ReadOnly ContentType As String
Public ReadOnly ContentType As String
public:
initonly String^ ContentType
public:
initonly String^ ContentType
val ContentType: string
val ContentType: string

Field Value

Type: Online String
See Also
Message Attachment Structure
Message Attachment Members
NFX.Web.Messaging Namespace


Message.Attachment.Name Field

Message Attachment Name Field NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Name
public readonly string Name
Public ReadOnly Name As String
Public ReadOnly Name As String
public:
initonly String^ Name
public:
initonly String^ Name
val Name: string
val Name: string

Field Value

Type: Online String
See Also
Message Attachment Structure
Message Attachment Members
NFX.Web.Messaging Namespace


Message.Attachment Methods

Message Attachment Methods NFX Class Library

The Message Attachment type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Message Attachment Structure
NFX.Web.Messaging Namespace


MessageService Class

MessageService Class NFX Class Library

Provides implementation for IMessenger service
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.Web.Messaging MessageService

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MessageService : Service,
    IMessengerImplementation, IMessenger, IApplicationComponent, IDisposable, IService,
    IConfigurable, IApplicationFinishNotifiable, INamed, IInstrumentable, IExternallyParameterized
public sealed class MessageService : Service,
    IMessengerImplementation, IMessenger, IApplicationComponent, IDisposable, IService,
    IConfigurable, IApplicationFinishNotifiable, INamed, IInstrumentable, IExternallyParameterized
Public NotInheritable Class MessageService
    Inherits Service
    Implements IMessengerImplementation, IMessenger, IApplicationComponent, IDisposable,
    IService, IConfigurable, IApplicationFinishNotifiable, INamed, IInstrumentable,
    IExternallyParameterized
Public NotInheritable Class MessageService
    Inherits Service
    Implements IMessengerImplementation, IMessenger, IApplicationComponent, IDisposable,
    IService, IConfigurable, IApplicationFinishNotifiable, INamed, IInstrumentable,
    IExternallyParameterized
public ref class MessageService sealed : public Service,
    IMessengerImplementation, IMessenger, IApplicationComponent, IDisposable, IService,
    IConfigurable, IApplicationFinishNotifiable, INamed, IInstrumentable, IExternallyParameterized
public ref class MessageService sealed : public Service,
    IMessengerImplementation, IMessenger, IApplicationComponent, IDisposable, IService,
    IConfigurable, IApplicationFinishNotifiable, INamed, IInstrumentable, IExternallyParameterized
[<SealedAttribute>]
type MessageService =
    class
        inherit Service
        interface IMessengerImplementation
        interface IMessenger
        interface IApplicationComponent
        interface IDisposable
        interface IService
        interface IConfigurable
        interface IApplicationFinishNotifiable
        interface INamed
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<SealedAttribute>]
type MessageService =
    class
        inherit Service
        interface IMessengerImplementation
        interface IMessenger
        interface IApplicationComponent
        interface IDisposable
        interface IService
        interface IConfigurable
        interface IApplicationFinishNotifiable
        interface INamed
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
MessageService Members
NFX.Web.Messaging Namespace


MessageService Members

MessageService Members NFX Class Library

The MessageService type exposes the following members.
Constructors
 | Name | Description
Public method | MessageService | Constructs the service. For most-typical cases use MailerService.Instance instead
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | ApplicationFinishAfterCleanup |
Public method | ApplicationFinishBeforeCleanup |
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SendMsg |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_FALLBACK_SINK_SECTION |
CONFIG_MAILER_SECTION |
CONFIG_MESSAGING_SECTION |
CONFIG_SINK_SECTION |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | FallbackSink |
 | Instance | Returns a singleton instance of the default mailer
Public property | InstrumentationEnabled | Turns instrumentation on/off
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Sink | Gets/sets sink that performs sending
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
MessageService Class
NFX.Web.Messaging Namespace


MessageService Constructor

MessageService Constructor NFX Class Library

Constructs the service. For most-typical cases use MailerService.Instance instead

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageService()
public MessageService()
Public Sub New
Public Sub New
public:
MessageService()
public:
MessageService()
new : unit -> MessageService
new : unit -> MessageService
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService Fields

MessageService Fields NFX Class Library

The MessageService type exposes the following members.
Fields
Name | Description
CONFIG_FALLBACK_SINK_SECTION |
CONFIG_MAILER_SECTION |
CONFIG_MESSAGING_SECTION |
CONFIG_SINK_SECTION |
Back to Top
See Also
MessageService Class
NFX.Web.Messaging Namespace


MessageService.CONFIG_FALLBACK_SINK_SECTION Field

MessageService CONFIG_FALLBACK_SINK_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FALLBACK_SINK_SECTION
public const string CONFIG_FALLBACK_SINK_SECTION
Public Const CONFIG_FALLBACK_SINK_SECTION As String
Public Const CONFIG_FALLBACK_SINK_SECTION As String
public:
literal String^ CONFIG_FALLBACK_SINK_SECTION
public:
literal String^ CONFIG_FALLBACK_SINK_SECTION
static val mutable CONFIG_FALLBACK_SINK_SECTION: string
static val mutable CONFIG_FALLBACK_SINK_SECTION: string

Field Value

Type: Online String
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.CONFIG_MAILER_SECTION Field

MessageService CONFIG_MAILER_SECTION Field NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_MAILER_SECTION
public const string CONFIG_MAILER_SECTION
Public Const CONFIG_MAILER_SECTION As String
Public Const CONFIG_MAILER_SECTION As String
public:
literal String^ CONFIG_MAILER_SECTION
public:
literal String^ CONFIG_MAILER_SECTION
static val mutable CONFIG_MAILER_SECTION: string
static val mutable CONFIG_MAILER_SECTION: string

Field Value

Type: Online String
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.CONFIG_MESSAGING_SECTION Field

MessageService CONFIG_MESSAGING_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_MESSAGING_SECTION
public const string CONFIG_MESSAGING_SECTION
Public Const CONFIG_MESSAGING_SECTION As String
Public Const CONFIG_MESSAGING_SECTION As String
public:
literal String^ CONFIG_MESSAGING_SECTION
public:
literal String^ CONFIG_MESSAGING_SECTION
static val mutable CONFIG_MESSAGING_SECTION: string
static val mutable CONFIG_MESSAGING_SECTION: string

Field Value

Type: Online String
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.CONFIG_SINK_SECTION Field

MessageService CONFIG_SINK_SECTION Field NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SINK_SECTION
public const string CONFIG_SINK_SECTION
Public Const CONFIG_SINK_SECTION As String
Public Const CONFIG_SINK_SECTION As String
public:
literal String^ CONFIG_SINK_SECTION
public:
literal String^ CONFIG_SINK_SECTION
static val mutable CONFIG_SINK_SECTION: string
static val mutable CONFIG_SINK_SECTION: string

Field Value

Type: Online String
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService Methods

MessageService Methods NFX Class Library

The MessageService type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | ApplicationFinishAfterCleanup |
Public method | ApplicationFinishBeforeCleanup |
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SendMsg |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MessageService Class
NFX.Web.Messaging Namespace


MessageService.ApplicationFinishAfterCleanup Method

MessageService ApplicationFinishAfterCleanup Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ApplicationFinishAfterCleanup(
    IApplication application
)
public void ApplicationFinishAfterCleanup(
    IApplication application
)
Public Sub ApplicationFinishAfterCleanup (
    application As IApplication
)
Public Sub ApplicationFinishAfterCleanup (
    application As IApplication
)
public:
virtual void ApplicationFinishAfterCleanup(
    IApplication^ application
) sealed
public:
virtual void ApplicationFinishAfterCleanup(
    IApplication^ application
) sealed
abstract ApplicationFinishAfterCleanup :
        application : IApplication -> unit
override ApplicationFinishAfterCleanup :
        application : IApplication -> unit
abstract ApplicationFinishAfterCleanup :
        application : IApplication -> unit
override ApplicationFinishAfterCleanup :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationFinishNotifiable ApplicationFinishAfterCleanup(IApplication)
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.ApplicationFinishBeforeCleanup Method

MessageService ApplicationFinishBeforeCleanup Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ApplicationFinishBeforeCleanup(
    IApplication application
)
public void ApplicationFinishBeforeCleanup(
    IApplication application
)
Public Sub ApplicationFinishBeforeCleanup (
    application As IApplication
)
Public Sub ApplicationFinishBeforeCleanup (
    application As IApplication
)
public:
virtual void ApplicationFinishBeforeCleanup(
    IApplication^ application
) sealed
public:
virtual void ApplicationFinishBeforeCleanup(
    IApplication^ application
) sealed
abstract ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
override ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
abstract ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
override ApplicationFinishBeforeCleanup :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationFinishNotifiable ApplicationFinishBeforeCleanup(IApplication)
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.Destructor Method

MessageService Destructor Method NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.DoConfigure Method

MessageService DoConfigure Method NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.DoSignalStop Method

MessageService DoSignalStop Method NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSignalStop()
protected override void DoSignalStop()
Protected Overrides Sub DoSignalStop
Protected Overrides Sub DoSignalStop
protected:
virtual void DoSignalStop() override
protected:
virtual void DoSignalStop() override
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.DoStart Method

MessageService DoStart Method NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.DoWaitForCompleteStop Method

MessageService DoWaitForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.ExternalGetParameter Method

MessageService ExternalGetParameter Method NFX Class Library

Gets external parameter value returning true if parameter was found

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.ExternalParametersForGroups Method

MessageService ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns named parameters that can be used to control this component

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.ExternalSetParameter Method

MessageService ExternalSetParameter Method NFX Class Library

Sets external parameter value returning true if parameter was found and set

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.SendMsg Method

MessageService SendMsg Method NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SendMsg(
    Message msg
)
public void SendMsg(
    Message msg
)
Public Sub SendMsg (
    msg As Message
)
Public Sub SendMsg (
    msg As Message
)
public:
virtual void SendMsg(
    Message^ msg
) sealed
public:
virtual void SendMsg(
    Message^ msg
) sealed
abstract SendMsg :
        msg : Message -> unit
override SendMsg :
        msg : Message -> unit
abstract SendMsg :
        msg : Message -> unit
override SendMsg :
        msg : Message -> unit

Parameters

msg
Type: NFX.Web.Messaging Message

Implements

IMessenger SendMsg(Message)
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService Properties

MessageService Properties NFX Class Library

The MessageService type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | FallbackSink |
 | Instance | Returns a singleton instance of the default mailer
Public property | InstrumentationEnabled | Turns instrumentation on/off
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Sink | Gets/sets sink that performs sending
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
MessageService Class
NFX.Web.Messaging Namespace


MessageService.ExternalParameters Property

MessageService ExternalParameters Property NFX Class Library

Returns named parameters that can be used to control this component

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.FallbackSink Property

MessageService FallbackSink Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IMessageSink FallbackSink { get; set; }
public IMessageSink FallbackSink { get; set; }
Public Property FallbackSink As IMessageSink
    Get
    Set
Public Property FallbackSink As IMessageSink
    Get
    Set
public:
property IMessageSink^ FallbackSink {
    IMessageSink^ get ();
    void set (IMessageSink^ value);
}
public:
property IMessageSink^ FallbackSink {
    IMessageSink^ get ();
    void set (IMessageSink^ value);
}
member FallbackSink : IMessageSink with get, set
member FallbackSink : IMessageSink with get, set

Property Value

Type: IMessageSink
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.Instance Property

MessageService Instance Property NFX Class Library

Returns a singleton instance of the default mailer

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IMessenger Instance { get; }
public static IMessenger Instance { get; }
Public Shared ReadOnly Property Instance As IMessenger
    Get
Public Shared ReadOnly Property Instance As IMessenger
    Get
public:
static property IMessenger^ Instance {
    IMessenger^ get ();
}
public:
static property IMessenger^ Instance {
    IMessenger^ get ();
}
static member Instance : IMessenger with get
static member Instance : IMessenger with get

Property Value

Type: IMessenger
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.InstrumentationEnabled Property

MessageService InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Turns instrumentation on/off

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public bool InstrumentationEnabled { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public bool InstrumentationEnabled { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Property InstrumentationEnabled As Boolean
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageService.Sink Property

MessageService Sink Property NFX Class Library

Gets/sets sink that performs sending

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IMessageSink Sink { get; set; }
public IMessageSink Sink { get; set; }
Public Property Sink As IMessageSink
    Get
    Set
Public Property Sink As IMessageSink
    Get
    Set
public:
property IMessageSink^ Sink {
    IMessageSink^ get ();
    void set (IMessageSink^ value);
}
public:
property IMessageSink^ Sink {
    IMessageSink^ get ();
    void set (IMessageSink^ value);
}
member Sink : IMessageSink with get, set
member Sink : IMessageSink with get, set

Property Value

Type: IMessageSink
See Also
MessageService Class
MessageService Members
NFX.Web.Messaging Namespace


MessageSink Class

MessageSink Class NFX Class Library

Base for ALL implementations that work under MailerService
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service MessageService
NFX.Web.Messaging MessageSink
NFX.Web.Messaging MailgunMailerSink
NFX.Web.Messaging NOPMessageSink
NFX.Web.Messaging SMTPMessageSink

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class MessageSink : Service<MessageService>,
    IMessageSink, IConfigurable
public abstract class MessageSink : Service<MessageService>,
    IMessageSink, IConfigurable
Public MustInherit Class MessageSink
    Inherits Service(Of MessageService)
    Implements IMessageSink, IConfigurable
Public MustInherit Class MessageSink
    Inherits Service(Of MessageService)
    Implements IMessageSink, IConfigurable
public ref class MessageSink abstract : public Service<MessageService^>,
    IMessageSink, IConfigurable
public ref class MessageSink abstract : public Service<MessageService^>,
    IMessageSink, IConfigurable
[<AbstractClassAttribute>]
type MessageSink =
    class
        inherit Service<MessageService>
        interface IMessageSink
        interface IConfigurable
    end
[<AbstractClassAttribute>]
type MessageSink =
    class
        inherit Service<MessageService>
        interface IMessageSink
        interface IConfigurable
    end
See Also
MessageSink Members
NFX.Web.Messaging Namespace


MessageSink Members

MessageSink Members NFX Class Library

The MessageSink type exposes the following members.
Constructors
 | Name | Description
Protected method | MessageSink | Initializes a new instance of the MessageSink class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSendMsg | Performs actual sending of msg. This method does not have to be thread-safe as it is called by a single thread
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SendMsg | Performs actual sending of msg. This method does not have to be thread-safe as it is called by a single thread
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
MessageSink Class
NFX.Web.Messaging Namespace


MessageSink Constructor

MessageSink Constructor NFX Class Library

Initializes a new instance of the MessageSink class

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MessageSink(
    MessageService director
)
protected MessageSink(
    MessageService director
)
Protected Sub New (
    director As MessageService
)
Protected Sub New (
    director As MessageService
)
protected:
MessageSink(
    MessageService^ director
)
protected:
MessageSink(
    MessageService^ director
)
new :
        director : MessageService -> MessageSink
new :
        director : MessageService -> MessageSink

Parameters

director
Type: NFX.Web.Messaging MessageService
See Also
MessageSink Class
MessageSink Members
NFX.Web.Messaging Namespace


MessageSink Methods

MessageSink Methods NFX Class Library

The MessageSink type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSendMsg | Performs actual sending of msg. This method does not have to be thread-safe as it is called by a single thread
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SendMsg | Performs actual sending of msg. This method does not have to be thread-safe as it is called by a single thread
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MessageSink Class
NFX.Web.Messaging Namespace


MessageSink.DoSendMsg Method

MessageSink DoSendMsg Method NFX Class Library

Performs actual sending of msg. This method does not have to be thread-safe as it is called by a single thread

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoSendMsg(
    Message msg
)
protected abstract void DoSendMsg(
    Message msg
)
Protected MustOverride Sub DoSendMsg (
    msg As Message
)
Protected MustOverride Sub DoSendMsg (
    msg As Message
)
protected:
virtual void DoSendMsg(
    Message^ msg
) abstract
protected:
virtual void DoSendMsg(
    Message^ msg
) abstract
abstract DoSendMsg :
        msg : Message -> unit
abstract DoSendMsg :
        msg : Message -> unit

Parameters

msg
Type: NFX.Web.Messaging Message
See Also
MessageSink Class
MessageSink Members
NFX.Web.Messaging Namespace


MessageSink.SendMsg Method

MessageSink SendMsg Method NFX Class Library

Performs actual sending of msg. This method does not have to be thread-safe as it is called by a single thread

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SendMsg(
    Message msg
)
public void SendMsg(
    Message msg
)
Public Sub SendMsg (
    msg As Message
)
Public Sub SendMsg (
    msg As Message
)
public:
void SendMsg(
    Message^ msg
)
public:
void SendMsg(
    Message^ msg
)
member SendMsg :
        msg : Message -> unit
member SendMsg :
        msg : Message -> unit

Parameters

msg
Type: NFX.Web.Messaging Message
See Also
MessageSink Class
MessageSink Members
NFX.Web.Messaging Namespace


MessageSink Properties

MessageSink Properties NFX Class Library

The MessageSink type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
MessageSink Class
NFX.Web.Messaging Namespace


MsgChannels Enumeration

MsgChannels Enumeration NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum MsgChannels
[FlagsAttribute]
public enum MsgChannels
<FlagsAttribute>
Public Enumeration MsgChannels
<FlagsAttribute>
Public Enumeration MsgChannels
[FlagsAttribute]
public enum class MsgChannels
[FlagsAttribute]
public enum class MsgChannels
[<FlagsAttribute>]
type MsgChannels
[<FlagsAttribute>]
type MsgChannels
Members
Member name | Value | Description
Unspecified | 0 |
All | -1 |
EMail | 1 |
SMS | 2 |
MMS | 4 |
Social | 8 |
Call | 16 |
Fax | 32 |
Letter | 64 |
See Also
NFX.Web.Messaging Namespace


MsgImportance Enumeration

MsgImportance Enumeration NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum MsgImportance
public enum MsgImportance
Public Enumeration MsgImportance
Public Enumeration MsgImportance
public enum class MsgImportance
public enum class MsgImportance
type MsgImportance
type MsgImportance
Members
Member name | Value | Description
Unimportant | -100 |
LessImportant | -10 |
Normal | 0 |
Important | 10 |
MoreImportant | 100 |
MostImportant | 1000 |
See Also
NFX.Web.Messaging Namespace


MsgPriority Enumeration

MsgPriority Enumeration NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum MsgPriority
public enum MsgPriority
Public Enumeration MsgPriority
Public Enumeration MsgPriority
public enum class MsgPriority
public enum class MsgPriority
type MsgPriority
type MsgPriority
Members
Member name | Value | Description
Urgent | 0 |
Normal | 1 |
BelowNormal | 2 |
Slowest | 2 |
See Also
NFX.Web.Messaging Namespace


NOPMessageSink Class

NOPMessageSink Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service MessageService
NFX.Web.Messaging MessageSink
NFX.Web.Messaging NOPMessageSink

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NOPMessageSink : MessageSink
public sealed class NOPMessageSink : MessageSink
Public NotInheritable Class NOPMessageSink
    Inherits MessageSink
Public NotInheritable Class NOPMessageSink
    Inherits MessageSink
public ref class NOPMessageSink sealed : public MessageSink
public ref class NOPMessageSink sealed : public MessageSink
[<SealedAttribute>]
type NOPMessageSink =
    class
        inherit MessageSink
    end
[<SealedAttribute>]
type NOPMessageSink =
    class
        inherit MessageSink
    end
See Also
NOPMessageSink Members
NFX.Web.Messaging Namespace


NOPMessageSink Members

NOPMessageSink Members NFX Class Library

The NOPMessageSink type exposes the following members.
Constructors
 | Name | Description
Public method | NOPMessageSink | Initializes a new instance of the NOPMessageSink class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSendMsg | (Overrides MessageSink DoSendMsg(Message).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SendMsg | Performs actual sending of msg. This method does not have to be thread-safe as it is called by a single thread (Inherited from MessageSink.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
NOPMessageSink Class
NFX.Web.Messaging Namespace


NOPMessageSink Constructor

NOPMessageSink Constructor NFX Class Library

Initializes a new instance of the NOPMessageSink class

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NOPMessageSink(
    MessageService director
)
public NOPMessageSink(
    MessageService director
)
Public Sub New (
    director As MessageService
)
Public Sub New (
    director As MessageService
)
public:
NOPMessageSink(
    MessageService^ director
)
public:
NOPMessageSink(
    MessageService^ director
)
new :
        director : MessageService -> NOPMessageSink
new :
        director : MessageService -> NOPMessageSink

Parameters

director
Type: NFX.Web.Messaging MessageService
See Also
NOPMessageSink Class
NOPMessageSink Members
NFX.Web.Messaging Namespace


NOPMessageSink Methods

NOPMessageSink Methods NFX Class Library

The NOPMessageSink type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSendMsg | (Overrides MessageSink DoSendMsg(Message).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SendMsg | Performs actual sending of msg. This method does not have to be thread-safe as it is called by a single thread (Inherited from MessageSink.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPMessageSink Class
NFX.Web.Messaging Namespace


NOPMessageSink.DoSendMsg Method

NOPMessageSink DoSendMsg Method NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSendMsg(
    Message msg
)
protected override void DoSendMsg(
    Message msg
)
Protected Overrides Sub DoSendMsg (
    msg As Message
)
Protected Overrides Sub DoSendMsg (
    msg As Message
)
protected:
virtual void DoSendMsg(
    Message^ msg
) override
protected:
virtual void DoSendMsg(
    Message^ msg
) override
abstract DoSendMsg :
        msg : Message -> unit
override DoSendMsg :
        msg : Message -> unit
abstract DoSendMsg :
        msg : Message -> unit
override DoSendMsg :
        msg : Message -> unit

Parameters

msg
Type: NFX.Web.Messaging Message
See Also
NOPMessageSink Class
NOPMessageSink Members
NFX.Web.Messaging Namespace


NOPMessageSink Properties

NOPMessageSink Properties NFX Class Library

The NOPMessageSink type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
NOPMessageSink Class
NFX.Web.Messaging Namespace


NOPMessenger Class

NOPMessenger Class NFX Class Library

Implements NOP Mailer that does nothing
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.Web.Messaging NOPMessenger

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NOPMessenger : Service,
    IMessengerImplementation, IMessenger, IApplicationComponent, IDisposable, IService,
    IConfigurable, IApplicationFinishNotifiable, INamed
public sealed class NOPMessenger : Service,
    IMessengerImplementation, IMessenger, IApplicationComponent, IDisposable, IService,
    IConfigurable, IApplicationFinishNotifiable, INamed
Public NotInheritable Class NOPMessenger
    Inherits Service
    Implements IMessengerImplementation, IMessenger, IApplicationComponent, IDisposable,
    IService, IConfigurable, IApplicationFinishNotifiable, INamed
Public NotInheritable Class NOPMessenger
    Inherits Service
    Implements IMessengerImplementation, IMessenger, IApplicationComponent, IDisposable,
    IService, IConfigurable, IApplicationFinishNotifiable, INamed
public ref class NOPMessenger sealed : public Service,
    IMessengerImplementation, IMessenger, IApplicationComponent, IDisposable, IService,
    IConfigurable, IApplicationFinishNotifiable, INamed
public ref class NOPMessenger sealed : public Service,
    IMessengerImplementation, IMessenger, IApplicationComponent, IDisposable, IService,
    IConfigurable, IApplicationFinishNotifiable, INamed
[<SealedAttribute>]
type NOPMessenger =
    class
        inherit Service
        interface IMessengerImplementation
        interface IMessenger
        interface IApplicationComponent
        interface IDisposable
        interface IService
        interface IConfigurable
        interface IApplicationFinishNotifiable
        interface INamed
    end
[<SealedAttribute>]
type NOPMessenger =
    class
        inherit Service
        interface IMessengerImplementation
        interface IMessenger
        interface IApplicationComponent
        interface IDisposable
        interface IService
        interface IConfigurable
        interface IApplicationFinishNotifiable
        interface INamed
    end
See Also
NOPMessenger Members
NFX.Web.Messaging Namespace


NOPMessenger Members

NOPMessenger Members NFX Class Library

The NOPMessenger type exposes the following members.
Constructors
 | Name | Description
Public method | NOPMessenger | Initializes a new instance of the NOPMessenger class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SendMsg |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IApplicationFinishNotifiable ApplicationFinishAfterCleanup |
Explicit interface implemetation | IApplicationFinishNotifiable ApplicationFinishBeforeCleanup |
Back to Top
See Also
NOPMessenger Class
NFX.Web.Messaging Namespace


NOPMessenger Constructor

NOPMessenger Constructor NFX Class Library

Initializes a new instance of the NOPMessenger class

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NOPMessenger()
public NOPMessenger()
Public Sub New
Public Sub New
public:
NOPMessenger()
public:
NOPMessenger()
new : unit -> NOPMessenger
new : unit -> NOPMessenger
See Also
NOPMessenger Class
NOPMessenger Members
NFX.Web.Messaging Namespace


NOPMessenger Methods

NOPMessenger Methods NFX Class Library

The NOPMessenger type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SendMsg |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IApplicationFinishNotifiable ApplicationFinishAfterCleanup |
Explicit interface implemetation | IApplicationFinishNotifiable ApplicationFinishBeforeCleanup |
Back to Top
See Also
NOPMessenger Class
NFX.Web.Messaging Namespace


NOPMessenger.IApplicationFinishNotifiable.ApplicationFinishAfterCleanup Method

NOPMessenger IApplicationFinishNotifiable ApplicationFinishAfterCleanup Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IApplicationFinishNotifiable.ApplicationFinishAfterCleanup(
    IApplication application
)
void IApplicationFinishNotifiable.ApplicationFinishAfterCleanup(
    IApplication application
)
Private Sub ApplicationFinishAfterCleanup (
    application As IApplication
) Implements IApplicationFinishNotifiable.ApplicationFinishAfterCleanup
Private Sub ApplicationFinishAfterCleanup (
    application As IApplication
) Implements IApplicationFinishNotifiable.ApplicationFinishAfterCleanup
private:
virtual void ApplicationFinishAfterCleanup(
    IApplication^ application
) sealed = IApplicationFinishNotifiable::ApplicationFinishAfterCleanup
private:
virtual void ApplicationFinishAfterCleanup(
    IApplication^ application
) sealed = IApplicationFinishNotifiable::ApplicationFinishAfterCleanup
private abstract ApplicationFinishAfterCleanup :
        application : IApplication -> unit
private override ApplicationFinishAfterCleanup :
        application : IApplication -> unit
private abstract ApplicationFinishAfterCleanup :
        application : IApplication -> unit
private override ApplicationFinishAfterCleanup :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationFinishNotifiable ApplicationFinishAfterCleanup(IApplication)
See Also
NOPMessenger Class
NOPMessenger Members
NFX.Web.Messaging Namespace


NOPMessenger.IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup Method

NOPMessenger IApplicationFinishNotifiable ApplicationFinishBeforeCleanup Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup(
    IApplication application
)
void IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup(
    IApplication application
)
Private Sub ApplicationFinishBeforeCleanup (
    application As IApplication
) Implements IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup
Private Sub ApplicationFinishBeforeCleanup (
    application As IApplication
) Implements IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup
private:
virtual void ApplicationFinishBeforeCleanup(
    IApplication^ application
) sealed = IApplicationFinishNotifiable::ApplicationFinishBeforeCleanup
private:
virtual void ApplicationFinishBeforeCleanup(
    IApplication^ application
) sealed = IApplicationFinishNotifiable::ApplicationFinishBeforeCleanup
private abstract ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
private override ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
private abstract ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
private override ApplicationFinishBeforeCleanup :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationFinishNotifiable ApplicationFinishBeforeCleanup(IApplication)
See Also
NOPMessenger Class
NOPMessenger Members
NFX.Web.Messaging Namespace


NOPMessenger.SendMsg Method

NOPMessenger SendMsg Method NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SendMsg(
    Message msg
)
public void SendMsg(
    Message msg
)
Public Sub SendMsg (
    msg As Message
)
Public Sub SendMsg (
    msg As Message
)
public:
virtual void SendMsg(
    Message^ msg
) sealed
public:
virtual void SendMsg(
    Message^ msg
) sealed
abstract SendMsg :
        msg : Message -> unit
override SendMsg :
        msg : Message -> unit
abstract SendMsg :
        msg : Message -> unit
override SendMsg :
        msg : Message -> unit

Parameters

msg
Type: NFX.Web.Messaging Message

Implements

IMessenger SendMsg(Message)
See Also
NOPMessenger Class
NOPMessenger Members
NFX.Web.Messaging Namespace


NOPMessenger Properties

NOPMessenger Properties NFX Class Library

The NOPMessenger type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
NOPMessenger Class
NFX.Web.Messaging Namespace


SMTPMessageSink Class

SMTPMessageSink Class NFX Class Library

Implements msg sink based on SMTPClient
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service MessageService
NFX.Web.Messaging MessageSink
NFX.Web.Messaging SMTPMessageSink

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SMTPMessageSink : MessageSink
public class SMTPMessageSink : MessageSink
Public Class SMTPMessageSink
    Inherits MessageSink
Public Class SMTPMessageSink
    Inherits MessageSink
public ref class SMTPMessageSink : public MessageSink
public ref class SMTPMessageSink : public MessageSink
type SMTPMessageSink =
    class
        inherit MessageSink
    end
type SMTPMessageSink =
    class
        inherit MessageSink
    end
See Also
SMTPMessageSink Members
NFX.Web.Messaging Namespace


SMTPMessageSink Members

SMTPMessageSink Members NFX Class Library

The SMTPMessageSink type exposes the following members.
Constructors
 | Name | Description
Public method | SMTPMessageSink | Initializes a new instance of the SMTPMessageSink class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSendMsg | (Overrides MessageSink DoSendMsg(Message).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SendMsg | Performs actual sending of msg. This method does not have to be thread-safe as it is called by a single thread (Inherited from MessageSink.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
DEFAULT_SMTP_PORT |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | CredentialsID |
Public property | CredentialsPassword |
Public property | DefaultFromAddress |
Public property | DefaultFromName |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | DropFolder |
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | SmtpHost |
Public property | SmtpPort |
Public property | SmtpSSL |
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
SMTPMessageSink Class
NFX.Web.Messaging Namespace


SMTPMessageSink Constructor

SMTPMessageSink Constructor NFX Class Library

Initializes a new instance of the SMTPMessageSink class

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SMTPMessageSink(
    MessageService director
)
public SMTPMessageSink(
    MessageService director
)
Public Sub New (
    director As MessageService
)
Public Sub New (
    director As MessageService
)
public:
SMTPMessageSink(
    MessageService^ director
)
public:
SMTPMessageSink(
    MessageService^ director
)
new :
        director : MessageService -> SMTPMessageSink
new :
        director : MessageService -> SMTPMessageSink

Parameters

director
Type: NFX.Web.Messaging MessageService
See Also
SMTPMessageSink Class
SMTPMessageSink Members
NFX.Web.Messaging Namespace


SMTPMessageSink Fields

SMTPMessageSink Fields NFX Class Library

The SMTPMessageSink type exposes the following members.
Fields
Name | Description
DEFAULT_SMTP_PORT |
Back to Top
See Also
SMTPMessageSink Class
NFX.Web.Messaging Namespace


SMTPMessageSink.DEFAULT_SMTP_PORT Field

SMTPMessageSink DEFAULT_SMTP_PORT Field NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_SMTP_PORT
public const int DEFAULT_SMTP_PORT
Public Const DEFAULT_SMTP_PORT As Integer
Public Const DEFAULT_SMTP_PORT As Integer
public:
literal int DEFAULT_SMTP_PORT
public:
literal int DEFAULT_SMTP_PORT
static val mutable DEFAULT_SMTP_PORT: int
static val mutable DEFAULT_SMTP_PORT: int

Field Value

Type: Online Int32
See Also
SMTPMessageSink Class
SMTPMessageSink Members
NFX.Web.Messaging Namespace


SMTPMessageSink Methods

SMTPMessageSink Methods NFX Class Library

The SMTPMessageSink type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSendMsg | (Overrides MessageSink DoSendMsg(Message).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SendMsg | Performs actual sending of msg. This method does not have to be thread-safe as it is called by a single thread (Inherited from MessageSink.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SMTPMessageSink Class
NFX.Web.Messaging Namespace


SMTPMessageSink.Destructor Method

SMTPMessageSink Destructor Method NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
SMTPMessageSink Class
SMTPMessageSink Members
NFX.Web.Messaging Namespace


SMTPMessageSink.DoSendMsg Method

SMTPMessageSink DoSendMsg Method NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSendMsg(
    Message msg
)
protected override void DoSendMsg(
    Message msg
)
Protected Overrides Sub DoSendMsg (
    msg As Message
)
Protected Overrides Sub DoSendMsg (
    msg As Message
)
protected:
virtual void DoSendMsg(
    Message^ msg
) override
protected:
virtual void DoSendMsg(
    Message^ msg
) override
abstract DoSendMsg :
        msg : Message -> unit
override DoSendMsg :
        msg : Message -> unit
abstract DoSendMsg :
        msg : Message -> unit
override DoSendMsg :
        msg : Message -> unit

Parameters

msg
Type: NFX.Web.Messaging Message
See Also
SMTPMessageSink Class
SMTPMessageSink Members
NFX.Web.Messaging Namespace


SMTPMessageSink.DoStart Method

SMTPMessageSink DoStart Method NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
SMTPMessageSink Class
SMTPMessageSink Members
NFX.Web.Messaging Namespace


SMTPMessageSink.DoWaitForCompleteStop Method

SMTPMessageSink DoWaitForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
SMTPMessageSink Class
SMTPMessageSink Members
NFX.Web.Messaging Namespace


SMTPMessageSink Properties

SMTPMessageSink Properties NFX Class Library

The SMTPMessageSink type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | CredentialsID |
Public property | CredentialsPassword |
Public property | DefaultFromAddress |
Public property | DefaultFromName |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | DropFolder |
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | SmtpHost |
Public property | SmtpPort |
Public property | SmtpSSL |
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
SMTPMessageSink Class
NFX.Web.Messaging Namespace


SMTPMessageSink.CredentialsID Property

SMTPMessageSink CredentialsID Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string CredentialsID { get; set; }
[ConfigAttribute]
public string CredentialsID { get; set; }
<ConfigAttribute>
Public Property CredentialsID As String
    Get
    Set
<ConfigAttribute>
Public Property CredentialsID As String
    Get
    Set
public:
[ConfigAttribute]
property String^ CredentialsID {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ CredentialsID {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member CredentialsID : string with get, set
[<ConfigAttribute>]
member CredentialsID : string with get, set

Property Value

Type: Online String
See Also
SMTPMessageSink Class
SMTPMessageSink Members
NFX.Web.Messaging Namespace


SMTPMessageSink.CredentialsPassword Property

SMTPMessageSink CredentialsPassword Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string CredentialsPassword { get; set; }
[ConfigAttribute]
public string CredentialsPassword { get; set; }
<ConfigAttribute>
Public Property CredentialsPassword As String
    Get
    Set
<ConfigAttribute>
Public Property CredentialsPassword As String
    Get
    Set
public:
[ConfigAttribute]
property String^ CredentialsPassword {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ CredentialsPassword {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member CredentialsPassword : string with get, set
[<ConfigAttribute>]
member CredentialsPassword : string with get, set

Property Value

Type: Online String
See Also
SMTPMessageSink Class
SMTPMessageSink Members
NFX.Web.Messaging Namespace


SMTPMessageSink.DefaultFromAddress Property

SMTPMessageSink DefaultFromAddress Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string DefaultFromAddress { get; set; }
[ConfigAttribute]
public string DefaultFromAddress { get; set; }
<ConfigAttribute>
Public Property DefaultFromAddress As String
    Get
    Set
<ConfigAttribute>
Public Property DefaultFromAddress As String
    Get
    Set
public:
[ConfigAttribute]
property String^ DefaultFromAddress {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ DefaultFromAddress {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member DefaultFromAddress : string with get, set
[<ConfigAttribute>]
member DefaultFromAddress : string with get, set

Property Value

Type: Online String
See Also
SMTPMessageSink Class
SMTPMessageSink Members
NFX.Web.Messaging Namespace


SMTPMessageSink.DefaultFromName Property

SMTPMessageSink DefaultFromName Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string DefaultFromName { get; set; }
[ConfigAttribute]
public string DefaultFromName { get; set; }
<ConfigAttribute>
Public Property DefaultFromName As String
    Get
    Set
<ConfigAttribute>
Public Property DefaultFromName As String
    Get
    Set
public:
[ConfigAttribute]
property String^ DefaultFromName {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ DefaultFromName {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member DefaultFromName : string with get, set
[<ConfigAttribute>]
member DefaultFromName : string with get, set

Property Value

Type: Online String
See Also
SMTPMessageSink Class
SMTPMessageSink Members
NFX.Web.Messaging Namespace


SMTPMessageSink.DropFolder Property

SMTPMessageSink DropFolder Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string DropFolder { get; set; }
[ConfigAttribute]
public string DropFolder { get; set; }
<ConfigAttribute>
Public Property DropFolder As String
    Get
    Set
<ConfigAttribute>
Public Property DropFolder As String
    Get
    Set
public:
[ConfigAttribute]
property String^ DropFolder {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ DropFolder {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member DropFolder : string with get, set
[<ConfigAttribute>]
member DropFolder : string with get, set

Property Value

Type: Online String
See Also
SMTPMessageSink Class
SMTPMessageSink Members
NFX.Web.Messaging Namespace


SMTPMessageSink.SmtpHost Property

SMTPMessageSink SmtpHost Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string SmtpHost { get; set; }
[ConfigAttribute]
public string SmtpHost { get; set; }
<ConfigAttribute>
Public Property SmtpHost As String
    Get
    Set
<ConfigAttribute>
Public Property SmtpHost As String
    Get
    Set
public:
[ConfigAttribute]
property String^ SmtpHost {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ SmtpHost {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member SmtpHost : string with get, set
[<ConfigAttribute>]
member SmtpHost : string with get, set

Property Value

Type: Online String
See Also
SMTPMessageSink Class
SMTPMessageSink Members
NFX.Web.Messaging Namespace


SMTPMessageSink.SmtpPort Property

SMTPMessageSink SmtpPort Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = 587)]
public int SmtpPort { get; set; }
[ConfigAttribute(Default = 587)]
public int SmtpPort { get; set; }
<ConfigAttribute(Default := 587)>
Public Property SmtpPort As Integer
    Get
    Set
<ConfigAttribute(Default := 587)>
Public Property SmtpPort As Integer
    Get
    Set
public:
[ConfigAttribute(Default = 587)]
property int SmtpPort {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(Default = 587)]
property int SmtpPort {
    int get ();
    void set (int value);
}
[<ConfigAttribute(Default = 587)>]
member SmtpPort : int with get, set
[<ConfigAttribute(Default = 587)>]
member SmtpPort : int with get, set

Property Value

Type: Online Int32
See Also
SMTPMessageSink Class
SMTPMessageSink Members
NFX.Web.Messaging Namespace


SMTPMessageSink.SmtpSSL Property

SMTPMessageSink SmtpSSL Property NFX Class Library

Namespace: NFX.Web.Messaging
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool SmtpSSL { get; set; }
[ConfigAttribute]
public bool SmtpSSL { get; set; }
<ConfigAttribute>
Public Property SmtpSSL As Boolean
    Get
    Set
<ConfigAttribute>
Public Property SmtpSSL As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool SmtpSSL {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool SmtpSSL {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member SmtpSSL : bool with get, set
[<ConfigAttribute>]
member SmtpSSL : bool with get, set

Property Value

Type: Online Boolean
See Also
SMTPMessageSink Class
SMTPMessageSink Members
NFX.Web.Messaging Namespace


NFX.Web.Messaging.Instrumentation Namespace

NFX.Web.Messaging.Instrumentation Namespace NFX Class Library

[This is preliminary documentation and is subject to change.]

Classes
 | Class | Description
Public class | MessagingFallbackCount |
Public class | MessagingFallbackErrorCount |
Public class | MessagingSinkCount |
Public class | MessagingSinkErrorCount |
Public class | MessagingSinkLongGauge |


MessagingFallbackCount Class

MessagingFallbackCount Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Web.Messaging.Instrumentation MessagingSinkLongGauge
NFX.Web.Messaging.Instrumentation MessagingFallbackCount

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessagingFallbackCount : MessagingSinkLongGauge
[SerializableAttribute]
public class MessagingFallbackCount : MessagingSinkLongGauge
<SerializableAttribute>
Public Class MessagingFallbackCount
    Inherits MessagingSinkLongGauge
<SerializableAttribute>
Public Class MessagingFallbackCount
    Inherits MessagingSinkLongGauge
[SerializableAttribute]
public ref class MessagingFallbackCount : public MessagingSinkLongGauge
[SerializableAttribute]
public ref class MessagingFallbackCount : public MessagingSinkLongGauge
[<SerializableAttribute>]
type MessagingFallbackCount =
    class
        inherit MessagingSinkLongGauge
    end
[<SerializableAttribute>]
type MessagingFallbackCount =
    class
        inherit MessagingSinkLongGauge
    end
See Also
MessagingFallbackCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackCount Members

MessagingFallbackCount Members NFX Class Library

The MessagingFallbackCount type exposes the following members.
Constructors
 | Name | Description
Public method | MessagingFallbackCount | Initializes a new instance of the MessagingFallbackCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
MessagingFallbackCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackCount Constructor

MessagingFallbackCount Constructor NFX Class Library

Initializes a new instance of the MessagingFallbackCount class

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessagingFallbackCount(
    string source,
    long value
)
public MessagingFallbackCount(
    string source,
    long value
)
Public Sub New (
    source As String,
    value As Long
)
Public Sub New (
    source As String,
    value As Long
)
public:
MessagingFallbackCount(
    String^ source,
    long long value
)
public:
MessagingFallbackCount(
    String^ source,
    long long value
)
new :
        source : string *
        value : int64 -> MessagingFallbackCount
new :
        source : string *
        value : int64 -> MessagingFallbackCount

Parameters

source
Type: Online System String
value
Type: Online System Int64
See Also
MessagingFallbackCount Class
MessagingFallbackCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackCount Fields

MessagingFallbackCount Fields NFX Class Library

The MessagingFallbackCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
MessagingFallbackCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackCount Methods

MessagingFallbackCount Methods NFX Class Library

The MessagingFallbackCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MessagingFallbackCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackCount.MakeAggregateInstance Method

MessagingFallbackCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
MessagingFallbackCount Class
MessagingFallbackCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackCount.Record Method

MessagingFallbackCount Record Method NFX Class Library

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    string source,
    long value
)
public static void Record(
    string source,
    long value
)
Public Shared Sub Record (
    source As String,
    value As Long
)
Public Shared Sub Record (
    source As String,
    value As Long
)
public:
static void Record(
    String^ source,
    long long value
)
public:
static void Record(
    String^ source,
    long long value
)
static member Record :
        source : string *
        value : int64 -> unit
static member Record :
        source : string *
        value : int64 -> unit

Parameters

source
Type: Online System String
value
Type: Online System Int64
See Also
MessagingFallbackCount Class
MessagingFallbackCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackCount Properties

MessagingFallbackCount Properties NFX Class Library

The MessagingFallbackCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
MessagingFallbackCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackCount.Description Property

MessagingFallbackCount Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
MessagingFallbackCount Class
MessagingFallbackCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackCount.ValueUnitName Property

MessagingFallbackCount ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
MessagingFallbackCount Class
MessagingFallbackCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackErrorCount Class

MessagingFallbackErrorCount Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Web.Messaging.Instrumentation MessagingSinkLongGauge
NFX.Web.Messaging.Instrumentation MessagingFallbackErrorCount

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessagingFallbackErrorCount : MessagingSinkLongGauge
[SerializableAttribute]
public class MessagingFallbackErrorCount : MessagingSinkLongGauge
<SerializableAttribute>
Public Class MessagingFallbackErrorCount
    Inherits MessagingSinkLongGauge
<SerializableAttribute>
Public Class MessagingFallbackErrorCount
    Inherits MessagingSinkLongGauge
[SerializableAttribute]
public ref class MessagingFallbackErrorCount : public MessagingSinkLongGauge
[SerializableAttribute]
public ref class MessagingFallbackErrorCount : public MessagingSinkLongGauge
[<SerializableAttribute>]
type MessagingFallbackErrorCount =
    class
        inherit MessagingSinkLongGauge
    end
[<SerializableAttribute>]
type MessagingFallbackErrorCount =
    class
        inherit MessagingSinkLongGauge
    end
See Also
MessagingFallbackErrorCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackErrorCount Members

MessagingFallbackErrorCount Members NFX Class Library

The MessagingFallbackErrorCount type exposes the following members.
Constructors
 | Name | Description
Protected method | MessagingFallbackErrorCount | Initializes a new instance of the MessagingFallbackErrorCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
MessagingFallbackErrorCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackErrorCount Constructor

MessagingFallbackErrorCount Constructor NFX Class Library

Initializes a new instance of the MessagingFallbackErrorCount class

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MessagingFallbackErrorCount(
    string source,
    long value
)
protected MessagingFallbackErrorCount(
    string source,
    long value
)
Protected Sub New (
    source As String,
    value As Long
)
Protected Sub New (
    source As String,
    value As Long
)
protected:
MessagingFallbackErrorCount(
    String^ source,
    long long value
)
protected:
MessagingFallbackErrorCount(
    String^ source,
    long long value
)
new :
        source : string *
        value : int64 -> MessagingFallbackErrorCount
new :
        source : string *
        value : int64 -> MessagingFallbackErrorCount

Parameters

source
Type: Online System String
value
Type: Online System Int64
See Also
MessagingFallbackErrorCount Class
MessagingFallbackErrorCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackErrorCount Fields

MessagingFallbackErrorCount Fields NFX Class Library

The MessagingFallbackErrorCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
MessagingFallbackErrorCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackErrorCount Methods

MessagingFallbackErrorCount Methods NFX Class Library

The MessagingFallbackErrorCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MessagingFallbackErrorCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackErrorCount.MakeAggregateInstance Method

MessagingFallbackErrorCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
MessagingFallbackErrorCount Class
MessagingFallbackErrorCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackErrorCount.Record Method

MessagingFallbackErrorCount Record Method NFX Class Library

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    string source,
    long value
)
public static void Record(
    string source,
    long value
)
Public Shared Sub Record (
    source As String,
    value As Long
)
Public Shared Sub Record (
    source As String,
    value As Long
)
public:
static void Record(
    String^ source,
    long long value
)
public:
static void Record(
    String^ source,
    long long value
)
static member Record :
        source : string *
        value : int64 -> unit
static member Record :
        source : string *
        value : int64 -> unit

Parameters

source
Type: Online System String
value
Type: Online System Int64
See Also
MessagingFallbackErrorCount Class
MessagingFallbackErrorCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackErrorCount Properties

MessagingFallbackErrorCount Properties NFX Class Library

The MessagingFallbackErrorCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
MessagingFallbackErrorCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackErrorCount.Description Property

MessagingFallbackErrorCount Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
MessagingFallbackErrorCount Class
MessagingFallbackErrorCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingFallbackErrorCount.ValueUnitName Property

MessagingFallbackErrorCount ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
MessagingFallbackErrorCount Class
MessagingFallbackErrorCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkCount Class

MessagingSinkCount Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Web.Messaging.Instrumentation MessagingSinkLongGauge
NFX.Web.Messaging.Instrumentation MessagingSinkCount

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessagingSinkCount : MessagingSinkLongGauge
[SerializableAttribute]
public class MessagingSinkCount : MessagingSinkLongGauge
<SerializableAttribute>
Public Class MessagingSinkCount
    Inherits MessagingSinkLongGauge
<SerializableAttribute>
Public Class MessagingSinkCount
    Inherits MessagingSinkLongGauge
[SerializableAttribute]
public ref class MessagingSinkCount : public MessagingSinkLongGauge
[SerializableAttribute]
public ref class MessagingSinkCount : public MessagingSinkLongGauge
[<SerializableAttribute>]
type MessagingSinkCount =
    class
        inherit MessagingSinkLongGauge
    end
[<SerializableAttribute>]
type MessagingSinkCount =
    class
        inherit MessagingSinkLongGauge
    end
See Also
MessagingSinkCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkCount Members

MessagingSinkCount Members NFX Class Library

The MessagingSinkCount type exposes the following members.
Constructors
 | Name | Description
Public method | MessagingSinkCount | Initializes a new instance of the MessagingSinkCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
MessagingSinkCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkCount Constructor

MessagingSinkCount Constructor NFX Class Library

Initializes a new instance of the MessagingSinkCount class

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessagingSinkCount(
    string source,
    long value
)
public MessagingSinkCount(
    string source,
    long value
)
Public Sub New (
    source As String,
    value As Long
)
Public Sub New (
    source As String,
    value As Long
)
public:
MessagingSinkCount(
    String^ source,
    long long value
)
public:
MessagingSinkCount(
    String^ source,
    long long value
)
new :
        source : string *
        value : int64 -> MessagingSinkCount
new :
        source : string *
        value : int64 -> MessagingSinkCount

Parameters

source
Type: Online System String
value
Type: Online System Int64
See Also
MessagingSinkCount Class
MessagingSinkCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkCount Fields

MessagingSinkCount Fields NFX Class Library

The MessagingSinkCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
MessagingSinkCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkCount Methods

MessagingSinkCount Methods NFX Class Library

The MessagingSinkCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MessagingSinkCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkCount.MakeAggregateInstance Method

MessagingSinkCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
MessagingSinkCount Class
MessagingSinkCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkCount.Record Method

MessagingSinkCount Record Method NFX Class Library

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    string source,
    long value
)
public static void Record(
    string source,
    long value
)
Public Shared Sub Record (
    source As String,
    value As Long
)
Public Shared Sub Record (
    source As String,
    value As Long
)
public:
static void Record(
    String^ source,
    long long value
)
public:
static void Record(
    String^ source,
    long long value
)
static member Record :
        source : string *
        value : int64 -> unit
static member Record :
        source : string *
        value : int64 -> unit

Parameters

source
Type: Online System String
value
Type: Online System Int64
See Also
MessagingSinkCount Class
MessagingSinkCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkCount Properties

MessagingSinkCount Properties NFX Class Library

The MessagingSinkCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
MessagingSinkCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkCount.Description Property

MessagingSinkCount Description Property NFX Class Library

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
MessagingSinkCount Class
MessagingSinkCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkCount.ValueUnitName Property

MessagingSinkCount ValueUnitName Property NFX Class Library

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
MessagingSinkCount Class
MessagingSinkCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkErrorCount Class

MessagingSinkErrorCount Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Web.Messaging.Instrumentation MessagingSinkLongGauge
NFX.Web.Messaging.Instrumentation MessagingSinkErrorCount

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessagingSinkErrorCount : MessagingSinkLongGauge
[SerializableAttribute]
public class MessagingSinkErrorCount : MessagingSinkLongGauge
<SerializableAttribute>
Public Class MessagingSinkErrorCount
    Inherits MessagingSinkLongGauge
<SerializableAttribute>
Public Class MessagingSinkErrorCount
    Inherits MessagingSinkLongGauge
[SerializableAttribute]
public ref class MessagingSinkErrorCount : public MessagingSinkLongGauge
[SerializableAttribute]
public ref class MessagingSinkErrorCount : public MessagingSinkLongGauge
[<SerializableAttribute>]
type MessagingSinkErrorCount =
    class
        inherit MessagingSinkLongGauge
    end
[<SerializableAttribute>]
type MessagingSinkErrorCount =
    class
        inherit MessagingSinkLongGauge
    end
See Also
MessagingSinkErrorCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkErrorCount Members

MessagingSinkErrorCount Members NFX Class Library

The MessagingSinkErrorCount type exposes the following members.
Constructors
 | Name | Description
Protected method | MessagingSinkErrorCount | Initializes a new instance of the MessagingSinkErrorCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
MessagingSinkErrorCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkErrorCount Constructor

MessagingSinkErrorCount Constructor NFX Class Library

Initializes a new instance of the MessagingSinkErrorCount class

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MessagingSinkErrorCount(
    string source,
    long value
)
protected MessagingSinkErrorCount(
    string source,
    long value
)
Protected Sub New (
    source As String,
    value As Long
)
Protected Sub New (
    source As String,
    value As Long
)
protected:
MessagingSinkErrorCount(
    String^ source,
    long long value
)
protected:
MessagingSinkErrorCount(
    String^ source,
    long long value
)
new :
        source : string *
        value : int64 -> MessagingSinkErrorCount
new :
        source : string *
        value : int64 -> MessagingSinkErrorCount

Parameters

source
Type: Online System String
value
Type: Online System Int64
See Also
MessagingSinkErrorCount Class
MessagingSinkErrorCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkErrorCount Fields

MessagingSinkErrorCount Fields NFX Class Library

The MessagingSinkErrorCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
MessagingSinkErrorCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkErrorCount Methods

MessagingSinkErrorCount Methods NFX Class Library

The MessagingSinkErrorCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MessagingSinkErrorCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkErrorCount.MakeAggregateInstance Method

MessagingSinkErrorCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
MessagingSinkErrorCount Class
MessagingSinkErrorCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkErrorCount.Record Method

MessagingSinkErrorCount Record Method NFX Class Library

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    string source,
    long value
)
public static void Record(
    string source,
    long value
)
Public Shared Sub Record (
    source As String,
    value As Long
)
Public Shared Sub Record (
    source As String,
    value As Long
)
public:
static void Record(
    String^ source,
    long long value
)
public:
static void Record(
    String^ source,
    long long value
)
static member Record :
        source : string *
        value : int64 -> unit
static member Record :
        source : string *
        value : int64 -> unit

Parameters

source
Type: Online System String
value
Type: Online System Int64
See Also
MessagingSinkErrorCount Class
MessagingSinkErrorCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkErrorCount Properties

MessagingSinkErrorCount Properties NFX Class Library

The MessagingSinkErrorCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
MessagingSinkErrorCount Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkErrorCount.Description Property

MessagingSinkErrorCount Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
MessagingSinkErrorCount Class
MessagingSinkErrorCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkErrorCount.ValueUnitName Property

MessagingSinkErrorCount ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
MessagingSinkErrorCount Class
MessagingSinkErrorCount Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkLongGauge Class

MessagingSinkLongGauge Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Web.Messaging.Instrumentation MessagingSinkLongGauge
NFX.Web.Messaging.Instrumentation MessagingFallbackCount
NFX.Web.Messaging.Instrumentation MessagingFallbackErrorCount
NFX.Web.Messaging.Instrumentation MessagingSinkCount
NFX.Web.Messaging.Instrumentation MessagingSinkErrorCount

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class MessagingSinkLongGauge : LongGauge,
    IWebInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public abstract class MessagingSinkLongGauge : LongGauge,
    IWebInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class MessagingSinkLongGauge
    Inherits LongGauge
    Implements IWebInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class MessagingSinkLongGauge
    Inherits LongGauge
    Implements IWebInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class MessagingSinkLongGauge abstract : public LongGauge,
    IWebInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class MessagingSinkLongGauge abstract : public LongGauge,
    IWebInstrument, IOperationClass, IInstrumentClass
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type MessagingSinkLongGauge =
    class
        inherit LongGauge
        interface IWebInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type MessagingSinkLongGauge =
    class
        inherit LongGauge
        interface IWebInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
MessagingSinkLongGauge Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkLongGauge Members

MessagingSinkLongGauge Members NFX Class Library

The MessagingSinkLongGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | MessagingSinkLongGauge | Initializes a new instance of the MessagingSinkLongGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
MessagingSinkLongGauge Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkLongGauge Constructor

MessagingSinkLongGauge Constructor NFX Class Library

Initializes a new instance of the MessagingSinkLongGauge class

Namespace: NFX.Web.Messaging.Instrumentation
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MessagingSinkLongGauge(
    string source,
    long value
)
protected MessagingSinkLongGauge(
    string source,
    long value
)
Protected Sub New (
    source As String,
    value As Long
)
Protected Sub New (
    source As String,
    value As Long
)
protected:
MessagingSinkLongGauge(
    String^ source,
    long long value
)
protected:
MessagingSinkLongGauge(
    String^ source,
    long long value
)
new :
        source : string *
        value : int64 -> MessagingSinkLongGauge
new :
        source : string *
        value : int64 -> MessagingSinkLongGauge

Parameters

source
Type: Online System String
value
Type: Online System Int64
See Also
MessagingSinkLongGauge Class
MessagingSinkLongGauge Members
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkLongGauge Fields

MessagingSinkLongGauge Fields NFX Class Library

The MessagingSinkLongGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
MessagingSinkLongGauge Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkLongGauge Methods

MessagingSinkLongGauge Methods NFX Class Library

The MessagingSinkLongGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MessagingSinkLongGauge Class
NFX.Web.Messaging.Instrumentation Namespace


MessagingSinkLongGauge Properties

MessagingSinkLongGauge Properties NFX Class Library

The MessagingSinkLongGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
MessagingSinkLongGauge Class
NFX.Web.Messaging.Instrumentation Namespace


NFX.Web.Pay Namespace

NFX.Web.Pay Namespace NFX Class Library

Classes
 | Class | Description
Public class | ActualAccountData |
Public class | Address | Primitive (maybe temporary) implementation of IAddress
Public class | ConfigBasedCurrencyMarket | Provides rate conversion services based on an APP config file
Public class | ConnectionParameters |
Public class | PaymentException | General NFX payment system specific exception
Public class | PaySession | Represents session of PaySystem. All PaySystem operation requires session as mandatory parameter
Public class | PaySystem | Base class for IPaySystemImplementation implementation. Instances of descendants of this class is typically created and configured in PaySystemStarter class. Then particular pay system can be obtained from PaySystem.Instances[PAY_SYSTEM_NAME] indexer
Public class | PaySystemHost |
Public class | PaySystemStarter | Represents a starter that launches payment systems on startup
Public class | PaySystemWithStaticFees |
Public class | PayWebTerminal |
Public class | Transaction | Represents an abstraction of financial operation performed with pay system
Public class | Transaction Operation |
Structures
 | Structure | Description
Public structure | Account | Represents an account data vector that is - type of account identity (i.e. 'customer'), identity id (i.e. customer number '125') and account id within this identity (i.e. ref to customer #125 card '223322.....'). May also represent temporary web terminal token generated by IWebPayTerminal in which case IsWebTerminalToken = true
Interfaces
 | Interface | Description
Public interface | IActualAccountData | Represents actual data for supplied account object. Data represented by this interface is ALWAYS TRANSITIVE in memory as some fields are either never stored permanently (i.e. CVC) or ciphered in the store (account number)
Public interface | IAddress | Represents address
Public interface | ICurrencyMarket | Represents a market that can convert buy/sell currencies
Public interface | IPaySessionContext | Denotes a context of transaction execution. Can be used to provide additional information
Public interface | IPaySystem | Describes an entity that can perform pay functions (i.e. charge, transfer)
Public interface | IPaySystemHost | Represents a process-global entity that resolves account handle into actual account data and fetches existing transactions. This design provides an indirection level between pay systems (like Stripe, PayPal, Bank etc.) and particular application data store implementation as it decouples system-internal formats of transaction and account storage from provider-internal data (i.e. PayPal payment token string). The instance of implementor is a singleton accessible via PaySystem.PaySystemHost
Public interface | IPaySystemHostImplementation | Denotes an implementation of IPaySystemHost
Public interface | IPaySystemImplementation | Describes an entity that can perform pay functions with several usefull interfaces in NFX style
Public interface | IPayWebTerminal | Represents a web terminal for pay systems that tokenize sensitive CC data via a call to provider so that actual CC numbers never touch our servers in a plain form, instead tokens/nonces are supplied back by the provider tokenizer. This is needed for PCI compliance.
Enumerations
 | Enumeration | Description
Public enumeration | AccountType | Represents account type because some pay services (i.e. Stripe) requires this info
Public enumeration | ProcessingFeeKind | Denotes processing fee types, such as: included in amount and surcharged.
Public enumeration | Transaction OperationType |
Public enumeration | TransactionStatus | Denotes transaction status
Public enumeration | TransactionType | Denotes transaction types, such as: charges, refunds, transfers


Account Structure

Account Structure NFX Class Library

Represents an account data vector that is - type of account identity (i.e. 'customer'), identity id (i.e. customer number '125') and account id within this identity (i.e. ref to customer #125 card '223322.....'). May also represent temporary web terminal token generated by IWebPayTerminal in which case IsWebTerminalToken = true

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct Account : IEquatable<Account>
[SerializableAttribute]
public struct Account : IEquatable<Account>
<SerializableAttribute>
Public Structure Account
    Implements IEquatable(Of Account)
<SerializableAttribute>
Public Structure Account
    Implements IEquatable(Of Account)
[SerializableAttribute]
public value class Account : IEquatable<Account>
[SerializableAttribute]
public value class Account : IEquatable<Account>
[<SealedAttribute>]
[<SerializableAttribute>]
type Account =
    struct
        interface IEquatable<Account>
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type Account =
    struct
        interface IEquatable<Account>
    end
See Also
Account Members
NFX.Web.Pay Namespace


Account Members

Account Members NFX Class Library

The Account type exposes the following members.
Constructors
 | Name | Description
Public method | Account | Initializes a new instance of the Account class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Account) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Operators
Name | Description
Equality |
Inequality |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AccountID | Account id within identity id domain. For example '2' - id of method of payment for customer #125.
 | EmptyInstance |
Public property | Identity | For example 'customer' - name of table.
Public property | IdentityID | For example '125' - id of customer table row 125.
Public property | IsEmpty |
Back to Top
See Also
Account Structure
NFX.Web.Pay Namespace


Account Constructor

Account Constructor NFX Class Library

Initializes a new instance of the Account class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Account(
    string identity,
    Object identityID,
    Object accountID
)
public Account(
    string identity,
    Object identityID,
    Object accountID
)
Public Sub New (
    identity As String,
    identityID As Object,
    accountID As Object
)
Public Sub New (
    identity As String,
    identityID As Object,
    accountID As Object
)
public:
Account(
    String^ identity,
    Object^ identityID,
    Object^ accountID
)
public:
Account(
    String^ identity,
    Object^ identityID,
    Object^ accountID
)
new :
        identity : string *
        identityID : Object *
        accountID : Object -> Account
new :
        identity : string *
        identityID : Object *
        accountID : Object -> Account

Parameters

identity
Type: Online System String
identityID
Type: Online System Object
accountID
Type: Online System Object
See Also
Account Structure
Account Members
NFX.Web.Pay Namespace


Account Methods

Account Methods NFX Class Library

The Account type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Account) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Account Structure
NFX.Web.Pay Namespace


Account.Equals Method

Account Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Account) |
Back to Top
See Also
Account Structure
Account Members
NFX.Web.Pay Namespace


Account.Equals Method (Object)

Account Equals Method (Object) NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Account Structure
Account Members
Equals Overload
NFX.Web.Pay Namespace


Account.Equals Method (Account)

Account Equals Method (Account) NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    Account other
)
public bool Equals(
    Account other
)
Public Function Equals (
    other As Account
) As Boolean
Public Function Equals (
    other As Account
) As Boolean
public:
virtual bool Equals(
    Account other
) sealed
public:
virtual bool Equals(
    Account other
) sealed
abstract Equals :
        other : Account -> bool
override Equals :
        other : Account -> bool
abstract Equals :
        other : Account -> bool
override Equals :
        other : Account -> bool

Parameters

other
Type: NFX.Web.Pay Account

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
Account Structure
Account Members
Equals Overload
NFX.Web.Pay Namespace


Account.GetHashCode Method

Account GetHashCode Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
Account Structure
Account Members
NFX.Web.Pay Namespace


Account.ToString Method

Account ToString Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Account Structure
Account Members
NFX.Web.Pay Namespace


Account Operators

Account Operators NFX Class Library

The Account type exposes the following members.
Operators
Name | Description
Equality |
Inequality |
Back to Top
See Also
Account Structure
NFX.Web.Pay Namespace


Account.Equality Operator

Account Equality Operator NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    Account account0,
    Account account1
)
public static bool operator ==(
    Account account0,
    Account account1
)
Public Shared Operator = (
    account0 As Account,
    account1 As Account
) As Boolean
Public Shared Operator = (
    account0 As Account,
    account1 As Account
) As Boolean
public:
static bool operator ==(
    Account account0,
    Account account1
)
public:
static bool operator ==(
    Account account0,
    Account account1
)
static let inline (=)
        account0 : Account *
        account1 : Account  : bool
static let inline (=)
        account0 : Account *
        account1 : Account  : bool

Parameters

account0
Type: NFX.Web.Pay Account
account1
Type: NFX.Web.Pay Account

Return Value

Type: Online Boolean
See Also
Account Structure
Account Members
NFX.Web.Pay Namespace


Account.Inequality Operator

Account Inequality Operator NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    Account account0,
    Account account1
)
public static bool operator !=(
    Account account0,
    Account account1
)
Public Shared Operator <> (
    account0 As Account,
    account1 As Account
) As Boolean
Public Shared Operator <> (
    account0 As Account,
    account1 As Account
) As Boolean
public:
static bool operator !=(
    Account account0,
    Account account1
)
public:
static bool operator !=(
    Account account0,
    Account account1
)
static let inline (<>)
        account0 : Account *
        account1 : Account  : bool
static let inline (<>)
        account0 : Account *
        account1 : Account  : bool

Parameters

account0
Type: NFX.Web.Pay Account
account1
Type: NFX.Web.Pay Account

Return Value

Type: Online Boolean
See Also
Account Structure
Account Members
NFX.Web.Pay Namespace


Account Properties

Account Properties NFX Class Library

The Account type exposes the following members.
Properties
 | Name | Description
Public property | AccountID | Account id within identity id domain. For example '2' - id of method of payment for customer #125.
 | EmptyInstance |
Public property | Identity | For example 'customer' - name of table.
Public property | IdentityID | For example '125' - id of customer table row 125.
Public property | IsEmpty |
Back to Top
See Also
Account Structure
NFX.Web.Pay Namespace


Account.AccountID Property

Account AccountID Property NFX Class Library

Account id within identity id domain. For example '2' - id of method of payment for customer #125.

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object AccountID { get; private set; }
public Object AccountID { get; private set; }
Public Property AccountID As Object
    Get
    Private Set
Public Property AccountID As Object
    Get
    Private Set
public:
property Object^ AccountID {
    Object^ get ();
    private: void set (Object^ value);
}
public:
property Object^ AccountID {
    Object^ get ();
    private: void set (Object^ value);
}
member AccountID : Object with get, private set
member AccountID : Object with get, private set

Property Value

Type: Online Object
See Also
Account Structure
Account Members
NFX.Web.Pay Namespace


Account.EmptyInstance Property

Account EmptyInstance Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Account EmptyInstance { get; }
public static Account EmptyInstance { get; }
Public Shared ReadOnly Property EmptyInstance As Account
    Get
Public Shared ReadOnly Property EmptyInstance As Account
    Get
public:
static property Account EmptyInstance {
    Account get ();
}
public:
static property Account EmptyInstance {
    Account get ();
}
static member EmptyInstance : Account with get
static member EmptyInstance : Account with get

Property Value

Type: Account
See Also
Account Structure
Account Members
NFX.Web.Pay Namespace


Account.Identity Property

Account Identity Property NFX Class Library

For example 'customer' - name of table.

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Identity { get; private set; }
public string Identity { get; private set; }
Public Property Identity As String
    Get
    Private Set
Public Property Identity As String
    Get
    Private Set
public:
property String^ Identity {
    String^ get ();
    private: void set (String^ value);
}
public:
property String^ Identity {
    String^ get ();
    private: void set (String^ value);
}
member Identity : string with get, private set
member Identity : string with get, private set

Property Value

Type: Online String
See Also
Account Structure
Account Members
NFX.Web.Pay Namespace


Account.IdentityID Property

Account IdentityID Property NFX Class Library

For example '125' - id of customer table row 125.

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object IdentityID { get; private set; }
public Object IdentityID { get; private set; }
Public Property IdentityID As Object
    Get
    Private Set
Public Property IdentityID As Object
    Get
    Private Set
public:
property Object^ IdentityID {
    Object^ get ();
    private: void set (Object^ value);
}
public:
property Object^ IdentityID {
    Object^ get ();
    private: void set (Object^ value);
}
member IdentityID : Object with get, private set
member IdentityID : Object with get, private set

Property Value

Type: Online Object
See Also
Account Structure
Account Members
NFX.Web.Pay Namespace


Account.IsEmpty Property

Account IsEmpty Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get
member IsEmpty : bool with get

Property Value

Type: Online Boolean
See Also
Account Structure
Account Members
NFX.Web.Pay Namespace


AccountType Enumeration

AccountType Enumeration NFX Class Library

Represents account type because some pay services (i.e. Stripe) requires this info

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum AccountType
public enum AccountType
Public Enumeration AccountType
Public Enumeration AccountType
public enum class AccountType
public enum class AccountType
type AccountType
type AccountType
Members
Member name | Value | Description
Individual | 0 |
Corporation | 1 |
See Also
NFX.Web.Pay Namespace


ActualAccountData Class

ActualAccountData Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Web.Pay ActualAccountData

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ActualAccountData : IActualAccountData
public class ActualAccountData : IActualAccountData
Public Class ActualAccountData
    Implements IActualAccountData
Public Class ActualAccountData
    Implements IActualAccountData
public ref class ActualAccountData : IActualAccountData
public ref class ActualAccountData : IActualAccountData
type ActualAccountData =
    class
        interface IActualAccountData
    end
type ActualAccountData =
    class
        interface IActualAccountData
    end
See Also
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData Members

ActualAccountData Members NFX Class Library

The ActualAccountData type exposes the following members.
Constructors
 | Name | Description
Public method | ActualAccountData | Initializes a new instance of the ActualAccountData class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Account |
Public property | AccountID |
Public property | AccountTitle |
Public property | AccountType |
Public property | BillingAddress |
Public property | CardExpirationDate |
Public property | CardHolder |
Public property | CardMaskedName |
Public property | CardVC |
Public property | EMail |
Public property | FirstName |
Public property | HadSuccessfullTransactions |
Public property | Identity |
Public property | IdentityID |
Public property | IsCard |
Public property | IsNew |
Public property | IssuerEMail |
Public property | IssuerID |
Public property | IssuerName |
Public property | IssuerPhone |
Public property | IssuerUri |
Public property | IsWebTerminal |
Public property | LastName |
Public property | MiddleName |
Public property | Phone |
Public property | RoutingNumber |
Public property | ShippingAddress |
Back to Top
See Also
ActualAccountData Class
NFX.Web.Pay Namespace


ActualAccountData Constructor

ActualAccountData Constructor NFX Class Library

Initializes a new instance of the ActualAccountData class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ActualAccountData(
    Account account
)
public ActualAccountData(
    Account account
)
Public Sub New (
    account As Account
)
Public Sub New (
    account As Account
)
public:
ActualAccountData(
    Account account
)
public:
ActualAccountData(
    Account account
)
new :
        account : Account -> ActualAccountData
new :
        account : Account -> ActualAccountData

Parameters

account
Type: NFX.Web.Pay Account
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData Methods

ActualAccountData Methods NFX Class Library

The ActualAccountData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ActualAccountData Class
NFX.Web.Pay Namespace


ActualAccountData Properties

ActualAccountData Properties NFX Class Library

The ActualAccountData type exposes the following members.
Properties
 | Name | Description
Public property | Account |
Public property | AccountID |
Public property | AccountTitle |
Public property | AccountType |
Public property | BillingAddress |
Public property | CardExpirationDate |
Public property | CardHolder |
Public property | CardMaskedName |
Public property | CardVC |
Public property | EMail |
Public property | FirstName |
Public property | HadSuccessfullTransactions |
Public property | Identity |
Public property | IdentityID |
Public property | IsCard |
Public property | IsNew |
Public property | IssuerEMail |
Public property | IssuerID |
Public property | IssuerName |
Public property | IssuerPhone |
Public property | IssuerUri |
Public property | IsWebTerminal |
Public property | LastName |
Public property | MiddleName |
Public property | Phone |
Public property | RoutingNumber |
Public property | ShippingAddress |
Back to Top
See Also
ActualAccountData Class
NFX.Web.Pay Namespace


ActualAccountData.Account Property

ActualAccountData Account Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Account Account { get; }
public Account Account { get; }
Public ReadOnly Property Account As Account
    Get
Public ReadOnly Property Account As Account
    Get
public:
virtual property Account Account {
    Account get () sealed;
}
public:
virtual property Account Account {
    Account get () sealed;
}
abstract Account : Account with get
override Account : Account with get
abstract Account : Account with get
override Account : Account with get

Property Value

Type: Account

Implements

IActualAccountData Account
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.AccountID Property

ActualAccountData AccountID Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object AccountID { get; set; }
public Object AccountID { get; set; }
Public Property AccountID As Object
    Get
    Set
Public Property AccountID As Object
    Get
    Set
public:
virtual property Object^ AccountID {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
public:
virtual property Object^ AccountID {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
abstract AccountID : Object with get, set
override AccountID : Object with get, set
abstract AccountID : Object with get, set
override AccountID : Object with get, set

Property Value

Type: Online Object

Implements

IActualAccountData AccountID
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.AccountTitle Property

ActualAccountData AccountTitle Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AccountTitle { get; }
public string AccountTitle { get; }
Public ReadOnly Property AccountTitle As String
    Get
Public ReadOnly Property AccountTitle As String
    Get
public:
virtual property String^ AccountTitle {
    String^ get () sealed;
}
public:
virtual property String^ AccountTitle {
    String^ get () sealed;
}
abstract AccountTitle : string with get
override AccountTitle : string with get
abstract AccountTitle : string with get
override AccountTitle : string with get

Property Value

Type: Online String

Implements

IActualAccountData AccountTitle
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.AccountType Property

ActualAccountData AccountType Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccountType AccountType { get; set; }
public AccountType AccountType { get; set; }
Public Property AccountType As AccountType
    Get
    Set
Public Property AccountType As AccountType
    Get
    Set
public:
virtual property AccountType AccountType {
    AccountType get () sealed;
    void set (AccountType value) sealed;
}
public:
virtual property AccountType AccountType {
    AccountType get () sealed;
    void set (AccountType value) sealed;
}
abstract AccountType : AccountType with get, set
override AccountType : AccountType with get, set
abstract AccountType : AccountType with get, set
override AccountType : AccountType with get, set

Property Value

Type: AccountType

Implements

IActualAccountData AccountType
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.BillingAddress Property

ActualAccountData BillingAddress Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IAddress BillingAddress { get; set; }
public IAddress BillingAddress { get; set; }
Public Property BillingAddress As IAddress
    Get
    Set
Public Property BillingAddress As IAddress
    Get
    Set
public:
virtual property IAddress^ BillingAddress {
    IAddress^ get () sealed;
    void set (IAddress^ value) sealed;
}
public:
virtual property IAddress^ BillingAddress {
    IAddress^ get () sealed;
    void set (IAddress^ value) sealed;
}
abstract BillingAddress : IAddress with get, set
override BillingAddress : IAddress with get, set
abstract BillingAddress : IAddress with get, set
override BillingAddress : IAddress with get, set

Property Value

Type: IAddress

Implements

IActualAccountData BillingAddress
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.CardExpirationDate Property

ActualAccountData CardExpirationDate Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> CardExpirationDate { get; set; }
public Nullable<DateTime> CardExpirationDate { get; set; }
Public Property CardExpirationDate As Nullable(Of DateTime)
    Get
    Set
Public Property CardExpirationDate As Nullable(Of DateTime)
    Get
    Set
public:
virtual property Nullable<DateTime> CardExpirationDate {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}
public:
virtual property Nullable<DateTime> CardExpirationDate {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}
abstract CardExpirationDate : Nullable<DateTime> with get, set
override CardExpirationDate : Nullable<DateTime> with get, set
abstract CardExpirationDate : Nullable<DateTime> with get, set
override CardExpirationDate : Nullable<DateTime> with get, set

Property Value

Type: Online Nullable Online DateTime

Implements

IActualAccountData CardExpirationDate
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.CardHolder Property

ActualAccountData CardHolder Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CardHolder { get; set; }
public string CardHolder { get; set; }
Public Property CardHolder As String
    Get
    Set
Public Property CardHolder As String
    Get
    Set
public:
virtual property String^ CardHolder {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ CardHolder {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract CardHolder : string with get, set
override CardHolder : string with get, set
abstract CardHolder : string with get, set
override CardHolder : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData CardHolder
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.CardMaskedName Property

ActualAccountData CardMaskedName Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CardMaskedName { get; set; }
public string CardMaskedName { get; set; }
Public Property CardMaskedName As String
    Get
    Set
Public Property CardMaskedName As String
    Get
    Set
public:
virtual property String^ CardMaskedName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ CardMaskedName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract CardMaskedName : string with get, set
override CardMaskedName : string with get, set
abstract CardMaskedName : string with get, set
override CardMaskedName : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData CardMaskedName
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.CardVC Property

ActualAccountData CardVC Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CardVC { get; set; }
public string CardVC { get; set; }
Public Property CardVC As String
    Get
    Set
Public Property CardVC As String
    Get
    Set
public:
virtual property String^ CardVC {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ CardVC {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract CardVC : string with get, set
override CardVC : string with get, set
abstract CardVC : string with get, set
override CardVC : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData CardVC
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.EMail Property

ActualAccountData EMail Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EMail { get; set; }
public string EMail { get; set; }
Public Property EMail As String
    Get
    Set
Public Property EMail As String
    Get
    Set
public:
virtual property String^ EMail {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ EMail {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract EMail : string with get, set
override EMail : string with get, set
abstract EMail : string with get, set
override EMail : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData EMail
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.FirstName Property

ActualAccountData FirstName Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FirstName { get; set; }
public string FirstName { get; set; }
Public Property FirstName As String
    Get
    Set
Public Property FirstName As String
    Get
    Set
public:
virtual property String^ FirstName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ FirstName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FirstName : string with get, set
override FirstName : string with get, set
abstract FirstName : string with get, set
override FirstName : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData FirstName
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.HadSuccessfullTransactions Property

ActualAccountData HadSuccessfullTransactions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HadSuccessfullTransactions { get; set; }
public bool HadSuccessfullTransactions { get; set; }
Public Property HadSuccessfullTransactions As Boolean
    Get
    Set
Public Property HadSuccessfullTransactions As Boolean
    Get
    Set
public:
virtual property bool HadSuccessfullTransactions {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool HadSuccessfullTransactions {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract HadSuccessfullTransactions : bool with get, set
override HadSuccessfullTransactions : bool with get, set
abstract HadSuccessfullTransactions : bool with get, set
override HadSuccessfullTransactions : bool with get, set

Property Value

Type: Online Boolean

Implements

IActualAccountData HadSuccessfullTransactions
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.Identity Property

ActualAccountData Identity Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Identity { get; set; }
public string Identity { get; set; }
Public Property Identity As String
    Get
    Set
Public Property Identity As String
    Get
    Set
public:
virtual property String^ Identity {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Identity {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Identity : string with get, set
override Identity : string with get, set
abstract Identity : string with get, set
override Identity : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData Identity
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.IdentityID Property

ActualAccountData IdentityID Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object IdentityID { get; set; }
public Object IdentityID { get; set; }
Public Property IdentityID As Object
    Get
    Set
Public Property IdentityID As Object
    Get
    Set
public:
virtual property Object^ IdentityID {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
public:
virtual property Object^ IdentityID {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
abstract IdentityID : Object with get, set
override IdentityID : Object with get, set
abstract IdentityID : Object with get, set
override IdentityID : Object with get, set

Property Value

Type: Online Object

Implements

IActualAccountData IdentityID
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.IsCard Property

ActualAccountData IsCard Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsCard { get; }
public bool IsCard { get; }
Public ReadOnly Property IsCard As Boolean
    Get
Public ReadOnly Property IsCard As Boolean
    Get
public:
virtual property bool IsCard {
    bool get () sealed;
}
public:
virtual property bool IsCard {
    bool get () sealed;
}
abstract IsCard : bool with get
override IsCard : bool with get
abstract IsCard : bool with get
override IsCard : bool with get

Property Value

Type: Online Boolean

Implements

IActualAccountData IsCard
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.IsNew Property

ActualAccountData IsNew Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsNew { get; set; }
public bool IsNew { get; set; }
Public Property IsNew As Boolean
    Get
    Set
Public Property IsNew As Boolean
    Get
    Set
public:
virtual property bool IsNew {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IsNew {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsNew : bool with get, set
override IsNew : bool with get, set
abstract IsNew : bool with get, set
override IsNew : bool with get, set

Property Value

Type: Online Boolean

Implements

IActualAccountData IsNew
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.IssuerEMail Property

ActualAccountData IssuerEMail Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string IssuerEMail { get; set; }
public string IssuerEMail { get; set; }
Public Property IssuerEMail As String
    Get
    Set
Public Property IssuerEMail As String
    Get
    Set
public:
virtual property String^ IssuerEMail {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ IssuerEMail {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract IssuerEMail : string with get, set
override IssuerEMail : string with get, set
abstract IssuerEMail : string with get, set
override IssuerEMail : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData IssuerEMail
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.IssuerID Property

ActualAccountData IssuerID Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string IssuerID { get; set; }
public string IssuerID { get; set; }
Public Property IssuerID As String
    Get
    Set
Public Property IssuerID As String
    Get
    Set
public:
virtual property String^ IssuerID {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ IssuerID {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract IssuerID : string with get, set
override IssuerID : string with get, set
abstract IssuerID : string with get, set
override IssuerID : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData IssuerID
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.IssuerName Property

ActualAccountData IssuerName Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string IssuerName { get; set; }
public string IssuerName { get; set; }
Public Property IssuerName As String
    Get
    Set
Public Property IssuerName As String
    Get
    Set
public:
virtual property String^ IssuerName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ IssuerName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract IssuerName : string with get, set
override IssuerName : string with get, set
abstract IssuerName : string with get, set
override IssuerName : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData IssuerName
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.IssuerPhone Property

ActualAccountData IssuerPhone Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string IssuerPhone { get; set; }
public string IssuerPhone { get; set; }
Public Property IssuerPhone As String
    Get
    Set
Public Property IssuerPhone As String
    Get
    Set
public:
virtual property String^ IssuerPhone {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ IssuerPhone {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract IssuerPhone : string with get, set
override IssuerPhone : string with get, set
abstract IssuerPhone : string with get, set
override IssuerPhone : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData IssuerPhone
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.IssuerUri Property

ActualAccountData IssuerUri Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string IssuerUri { get; set; }
public string IssuerUri { get; set; }
Public Property IssuerUri As String
    Get
    Set
Public Property IssuerUri As String
    Get
    Set
public:
virtual property String^ IssuerUri {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ IssuerUri {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract IssuerUri : string with get, set
override IssuerUri : string with get, set
abstract IssuerUri : string with get, set
override IssuerUri : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData IssuerUri
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.IsWebTerminal Property

ActualAccountData IsWebTerminal Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsWebTerminal { get; set; }
public bool IsWebTerminal { get; set; }
Public Property IsWebTerminal As Boolean
    Get
    Set
Public Property IsWebTerminal As Boolean
    Get
    Set
public:
virtual property bool IsWebTerminal {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IsWebTerminal {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsWebTerminal : bool with get, set
override IsWebTerminal : bool with get, set
abstract IsWebTerminal : bool with get, set
override IsWebTerminal : bool with get, set

Property Value

Type: Online Boolean

Implements

IActualAccountData IsWebTerminal
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.LastName Property

ActualAccountData LastName Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LastName { get; set; }
public string LastName { get; set; }
Public Property LastName As String
    Get
    Set
Public Property LastName As String
    Get
    Set
public:
virtual property String^ LastName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ LastName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract LastName : string with get, set
override LastName : string with get, set
abstract LastName : string with get, set
override LastName : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData LastName
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.MiddleName Property

ActualAccountData MiddleName Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MiddleName { get; set; }
public string MiddleName { get; set; }
Public Property MiddleName As String
    Get
    Set
Public Property MiddleName As String
    Get
    Set
public:
virtual property String^ MiddleName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ MiddleName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract MiddleName : string with get, set
override MiddleName : string with get, set
abstract MiddleName : string with get, set
override MiddleName : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData MiddleName
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.Phone Property

ActualAccountData Phone Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Phone { get; set; }
public string Phone { get; set; }
Public Property Phone As String
    Get
    Set
Public Property Phone As String
    Get
    Set
public:
virtual property String^ Phone {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Phone {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Phone : string with get, set
override Phone : string with get, set
abstract Phone : string with get, set
override Phone : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData Phone
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.RoutingNumber Property

ActualAccountData RoutingNumber Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RoutingNumber { get; set; }
public string RoutingNumber { get; set; }
Public Property RoutingNumber As String
    Get
    Set
Public Property RoutingNumber As String
    Get
    Set
public:
virtual property String^ RoutingNumber {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ RoutingNumber {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract RoutingNumber : string with get, set
override RoutingNumber : string with get, set
abstract RoutingNumber : string with get, set
override RoutingNumber : string with get, set

Property Value

Type: Online String

Implements

IActualAccountData RoutingNumber
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


ActualAccountData.ShippingAddress Property

ActualAccountData ShippingAddress Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IAddress ShippingAddress { get; set; }
public IAddress ShippingAddress { get; set; }
Public Property ShippingAddress As IAddress
    Get
    Set
Public Property ShippingAddress As IAddress
    Get
    Set
public:
virtual property IAddress^ ShippingAddress {
    IAddress^ get () sealed;
    void set (IAddress^ value) sealed;
}
public:
virtual property IAddress^ ShippingAddress {
    IAddress^ get () sealed;
    void set (IAddress^ value) sealed;
}
abstract ShippingAddress : IAddress with get, set
override ShippingAddress : IAddress with get, set
abstract ShippingAddress : IAddress with get, set
override ShippingAddress : IAddress with get, set

Property Value

Type: IAddress

Implements

IActualAccountData ShippingAddress
See Also
ActualAccountData Class
ActualAccountData Members
NFX.Web.Pay Namespace


Address Class

Address Class NFX Class Library

Primitive (maybe temporary) implementation of IAddress
Inheritance Hierarchy
Online System Object
NFX.Web.Pay Address

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Address : IAddress
public class Address : IAddress
Public Class Address
    Implements IAddress
Public Class Address
    Implements IAddress
public ref class Address : IAddress
public ref class Address : IAddress
type Address =
    class
        interface IAddress
    end
type Address =
    class
        interface IAddress
    end
See Also
Address Members
NFX.Web.Pay Namespace


Address Members

Address Members NFX Class Library

The Address type exposes the following members.
Constructors
 | Name | Description
Public method | Address | Initializes a new instance of the Address class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Address1 |
Public property | Address2 |
Public property | City |
Public property | Company |
Public property | Country |
Public property | EMail |
Public property | Phone |
Public property | PostalCode |
Public property | Region |
Back to Top
See Also
Address Class
NFX.Web.Pay Namespace


Address Constructor

Address Constructor NFX Class Library

Initializes a new instance of the Address class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Address()
public Address()
Public Sub New
Public Sub New
public:
Address()
public:
Address()
new : unit -> Address
new : unit -> Address
See Also
Address Class
Address Members
NFX.Web.Pay Namespace


Address Methods

Address Methods NFX Class Library

The Address type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Address Class
NFX.Web.Pay Namespace


Address.Equals Method

Address Equals Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Address Class
Address Members
NFX.Web.Pay Namespace


Address.GetHashCode Method

Address GetHashCode Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
Address Class
Address Members
NFX.Web.Pay Namespace


Address.ToString Method

Address ToString Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Address Class
Address Members
NFX.Web.Pay Namespace


Address Properties

Address Properties NFX Class Library

The Address type exposes the following members.
Properties
 | Name | Description
Public property | Address1 |
Public property | Address2 |
Public property | City |
Public property | Company |
Public property | Country |
Public property | EMail |
Public property | Phone |
Public property | PostalCode |
Public property | Region |
Back to Top
See Also
Address Class
NFX.Web.Pay Namespace


Address.Address1 Property

Address Address1 Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Address1 { get; set; }
public string Address1 { get; set; }
Public Property Address1 As String
    Get
    Set
Public Property Address1 As String
    Get
    Set
public:
virtual property String^ Address1 {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Address1 {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Address1 : string with get, set
override Address1 : string with get, set
abstract Address1 : string with get, set
override Address1 : string with get, set

Property Value

Type: Online String

Implements

IAddress Address1
See Also
Address Class
Address Members
NFX.Web.Pay Namespace


Address.Address2 Property

Address Address2 Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Address2 { get; set; }
public string Address2 { get; set; }
Public Property Address2 As String
    Get
    Set
Public Property Address2 As String
    Get
    Set
public:
virtual property String^ Address2 {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Address2 {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Address2 : string with get, set
override Address2 : string with get, set
abstract Address2 : string with get, set
override Address2 : string with get, set

Property Value

Type: Online String

Implements

IAddress Address2
See Also
Address Class
Address Members
NFX.Web.Pay Namespace


Address.City Property

Address City Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string City { get; set; }
public string City { get; set; }
Public Property City As String
    Get
    Set
Public Property City As String
    Get
    Set
public:
virtual property String^ City {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ City {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract City : string with get, set
override City : string with get, set
abstract City : string with get, set
override City : string with get, set

Property Value

Type: Online String

Implements

IAddress City
See Also
Address Class
Address Members
NFX.Web.Pay Namespace


Address.Company Property

Address Company Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Company { get; set; }
public string Company { get; set; }
Public Property Company As String
    Get
    Set
Public Property Company As String
    Get
    Set
public:
virtual property String^ Company {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Company {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Company : string with get, set
override Company : string with get, set
abstract Company : string with get, set
override Company : string with get, set

Property Value

Type: Online String

Implements

IAddress Company
See Also
Address Class
Address Members
NFX.Web.Pay Namespace


Address.Country Property

Address Country Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Country { get; set; }
public string Country { get; set; }
Public Property Country As String
    Get
    Set
Public Property Country As String
    Get
    Set
public:
virtual property String^ Country {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Country {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Country : string with get, set
override Country : string with get, set
abstract Country : string with get, set
override Country : string with get, set

Property Value

Type: Online String

Implements

IAddress Country
See Also
Address Class
Address Members
NFX.Web.Pay Namespace


Address.EMail Property

Address EMail Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EMail { get; set; }
public string EMail { get; set; }
Public Property EMail As String
    Get
    Set
Public Property EMail As String
    Get
    Set
public:
virtual property String^ EMail {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ EMail {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract EMail : string with get, set
override EMail : string with get, set
abstract EMail : string with get, set
override EMail : string with get, set

Property Value

Type: Online String

Implements

IAddress EMail
See Also
Address Class
Address Members
NFX.Web.Pay Namespace


Address.Phone Property

Address Phone Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Phone { get; set; }
public string Phone { get; set; }
Public Property Phone As String
    Get
    Set
Public Property Phone As String
    Get
    Set
public:
virtual property String^ Phone {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Phone {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Phone : string with get, set
override Phone : string with get, set
abstract Phone : string with get, set
override Phone : string with get, set

Property Value

Type: Online String

Implements

IAddress Phone
See Also
Address Class
Address Members
NFX.Web.Pay Namespace


Address.PostalCode Property

Address PostalCode Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PostalCode { get; set; }
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
Public Property PostalCode As String
    Get
    Set
public:
virtual property String^ PostalCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ PostalCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract PostalCode : string with get, set
override PostalCode : string with get, set
abstract PostalCode : string with get, set
override PostalCode : string with get, set

Property Value

Type: Online String

Implements

IAddress PostalCode
See Also
Address Class
Address Members
NFX.Web.Pay Namespace


Address.Region Property

Address Region Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Region { get; set; }
public string Region { get; set; }
Public Property Region As String
    Get
    Set
Public Property Region As String
    Get
    Set
public:
virtual property String^ Region {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Region {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Region : string with get, set
override Region : string with get, set
abstract Region : string with get, set
override Region : string with get, set

Property Value

Type: Online String

Implements

IAddress Region
See Also
Address Class
Address Members
NFX.Web.Pay Namespace


ConfigBasedCurrencyMarket Class

ConfigBasedCurrencyMarket Class NFX Class Library

Provides rate conversion services based on an APP config file
Inheritance Hierarchy
Online System Object
NFX.Web.Pay ConfigBasedCurrencyMarket

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ConfigBasedCurrencyMarket : ICurrencyMarket,
    IConfigurable
public class ConfigBasedCurrencyMarket : ICurrencyMarket,
    IConfigurable
Public Class ConfigBasedCurrencyMarket
    Implements ICurrencyMarket, IConfigurable
Public Class ConfigBasedCurrencyMarket
    Implements ICurrencyMarket, IConfigurable
public ref class ConfigBasedCurrencyMarket : ICurrencyMarket,
    IConfigurable
public ref class ConfigBasedCurrencyMarket : ICurrencyMarket,
    IConfigurable
type ConfigBasedCurrencyMarket =
    class
        interface ICurrencyMarket
        interface IConfigurable
    end
type ConfigBasedCurrencyMarket =
    class
        interface ICurrencyMarket
        interface IConfigurable
    end
See Also
ConfigBasedCurrencyMarket Members
NFX.Web.Pay Namespace


ConfigBasedCurrencyMarket Members

ConfigBasedCurrencyMarket Members NFX Class Library

The ConfigBasedCurrencyMarket type exposes the following members.
Constructors
 | Name | Description
Public method | ConfigBasedCurrencyMarket | Initializes a new instance of the ConfigBasedCurrencyMarket class
Public method | ConfigBasedCurrencyMarket(IConfigSectionNode) | Initializes a new instance of the ConfigBasedCurrencyMarket class
Back to Top
Methods
 | Name | Description
Public method | Configure |
Public method | ConvertCurrency |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_RATE_ATTR |
 | CONFIG_TABLES_SECTION |
Protected field | m_Node |
Back to Top
See Also
ConfigBasedCurrencyMarket Class
NFX.Web.Pay Namespace


ConfigBasedCurrencyMarket Constructor

ConfigBasedCurrencyMarket Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ConfigBasedCurrencyMarket | Initializes a new instance of the ConfigBasedCurrencyMarket class
Public method | ConfigBasedCurrencyMarket(IConfigSectionNode) | Initializes a new instance of the ConfigBasedCurrencyMarket class
Back to Top
See Also
ConfigBasedCurrencyMarket Class
ConfigBasedCurrencyMarket Members
NFX.Web.Pay Namespace


ConfigBasedCurrencyMarket Constructor

ConfigBasedCurrencyMarket Constructor NFX Class Library

Initializes a new instance of the ConfigBasedCurrencyMarket class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigBasedCurrencyMarket()
public ConfigBasedCurrencyMarket()
Public Sub New
Public Sub New
public:
ConfigBasedCurrencyMarket()
public:
ConfigBasedCurrencyMarket()
new : unit -> ConfigBasedCurrencyMarket
new : unit -> ConfigBasedCurrencyMarket
See Also
ConfigBasedCurrencyMarket Class
ConfigBasedCurrencyMarket Members
ConfigBasedCurrencyMarket Overload
NFX.Web.Pay Namespace


ConfigBasedCurrencyMarket Constructor (IConfigSectionNode)

ConfigBasedCurrencyMarket Constructor (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConfigBasedCurrencyMarket class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigBasedCurrencyMarket(
    IConfigSectionNode node
)
public ConfigBasedCurrencyMarket(
    IConfigSectionNode node
)
Public Sub New (
    node As IConfigSectionNode
)
Public Sub New (
    node As IConfigSectionNode
)
public:
ConfigBasedCurrencyMarket(
    IConfigSectionNode^ node
)
public:
ConfigBasedCurrencyMarket(
    IConfigSectionNode^ node
)
new :
        node : IConfigSectionNode -> ConfigBasedCurrencyMarket
new :
        node : IConfigSectionNode -> ConfigBasedCurrencyMarket

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
ConfigBasedCurrencyMarket Class
ConfigBasedCurrencyMarket Members
ConfigBasedCurrencyMarket Overload
NFX.Web.Pay Namespace


ConfigBasedCurrencyMarket Fields

ConfigBasedCurrencyMarket Fields NFX Class Library

The ConfigBasedCurrencyMarket type exposes the following members.
Fields
 | Name | Description
 | CONFIG_RATE_ATTR |
 | CONFIG_TABLES_SECTION |
Protected field | m_Node |
Back to Top
See Also
ConfigBasedCurrencyMarket Class
NFX.Web.Pay Namespace


ConfigBasedCurrencyMarket.CONFIG_RATE_ATTR Field

ConfigBasedCurrencyMarket CONFIG_RATE_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_RATE_ATTR
public const string CONFIG_RATE_ATTR
Public Const CONFIG_RATE_ATTR As String
Public Const CONFIG_RATE_ATTR As String
public:
literal String^ CONFIG_RATE_ATTR
public:
literal String^ CONFIG_RATE_ATTR
static val mutable CONFIG_RATE_ATTR: string
static val mutable CONFIG_RATE_ATTR: string

Field Value

Type: Online String
See Also
ConfigBasedCurrencyMarket Class
ConfigBasedCurrencyMarket Members
NFX.Web.Pay Namespace


ConfigBasedCurrencyMarket.CONFIG_TABLES_SECTION Field

ConfigBasedCurrencyMarket CONFIG_TABLES_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TABLES_SECTION
public const string CONFIG_TABLES_SECTION
Public Const CONFIG_TABLES_SECTION As String
Public Const CONFIG_TABLES_SECTION As String
public:
literal String^ CONFIG_TABLES_SECTION
public:
literal String^ CONFIG_TABLES_SECTION
static val mutable CONFIG_TABLES_SECTION: string
static val mutable CONFIG_TABLES_SECTION: string

Field Value

Type: Online String
See Also
ConfigBasedCurrencyMarket Class
ConfigBasedCurrencyMarket Members
NFX.Web.Pay Namespace


ConfigBasedCurrencyMarket.m_Node Field

ConfigBasedCurrencyMarket m_Node Field NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IConfigSectionNode m_Node
protected IConfigSectionNode m_Node
Protected m_Node As IConfigSectionNode
Protected m_Node As IConfigSectionNode
protected:
IConfigSectionNode^ m_Node
protected:
IConfigSectionNode^ m_Node
val mutable m_Node: IConfigSectionNode
val mutable m_Node: IConfigSectionNode

Field Value

Type: IConfigSectionNode
See Also
ConfigBasedCurrencyMarket Class
ConfigBasedCurrencyMarket Members
NFX.Web.Pay Namespace


ConfigBasedCurrencyMarket Methods

ConfigBasedCurrencyMarket Methods NFX Class Library

The ConfigBasedCurrencyMarket type exposes the following members.
Methods
 | Name | Description
Public method | Configure |
Public method | ConvertCurrency |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ConfigBasedCurrencyMarket Class
NFX.Web.Pay Namespace


ConfigBasedCurrencyMarket.Configure Method

ConfigBasedCurrencyMarket Configure Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
ConfigBasedCurrencyMarket Class
ConfigBasedCurrencyMarket Members
NFX.Web.Pay Namespace


ConfigBasedCurrencyMarket.ConvertCurrency Method

ConfigBasedCurrencyMarket ConvertCurrency Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Amount ConvertCurrency(
    string rateTable,
    Amount from,
    string targetCurrencyISO
)
public virtual Amount ConvertCurrency(
    string rateTable,
    Amount from,
    string targetCurrencyISO
)
Public Overridable Function ConvertCurrency (
    rateTable As String,
    from As Amount,
    targetCurrencyISO As String
) As Amount
Public Overridable Function ConvertCurrency (
    rateTable As String,
    from As Amount,
    targetCurrencyISO As String
) As Amount
public:
virtual Amount ConvertCurrency(
    String^ rateTable,
    Amount from,
    String^ targetCurrencyISO
)
public:
virtual Amount ConvertCurrency(
    String^ rateTable,
    Amount from,
    String^ targetCurrencyISO
)
abstract ConvertCurrency :
        rateTable : string *
        from : Amount *
        targetCurrencyISO : string -> Amount
override ConvertCurrency :
        rateTable : string *
        from : Amount *
        targetCurrencyISO : string -> Amount
abstract ConvertCurrency :
        rateTable : string *
        from : Amount *
        targetCurrencyISO : string -> Amount
override ConvertCurrency :
        rateTable : string *
        from : Amount *
        targetCurrencyISO : string -> Amount

Parameters

rateTable
Type: Online System String
from
Type: NFX.Financial Amount
targetCurrencyISO
Type: Online System String

Return Value

Type: Amount

Implements

ICurrencyMarket ConvertCurrency(String, Amount, String)
See Also
ConfigBasedCurrencyMarket Class
ConfigBasedCurrencyMarket Members
NFX.Web.Pay Namespace


ConnectionParameters Class

ConnectionParameters Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Web.Pay ConnectionParameters
NFX.Web.Pay.Braintree BraintreeConnectionParameters
NFX.Web.Pay.Mock MockConnectionParameters
NFX.Web.Pay.PayPal PayPalConnectionParameters
NFX.Web.Pay.Stripe StripeConnectionParameters

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ConnectionParameters : INamed,
    IConfigurable
public class ConnectionParameters : INamed,
    IConfigurable
Public Class ConnectionParameters
    Implements INamed, IConfigurable
Public Class ConnectionParameters
    Implements INamed, IConfigurable
public ref class ConnectionParameters : INamed,
    IConfigurable
public ref class ConnectionParameters : INamed,
    IConfigurable
type ConnectionParameters =
    class
        interface INamed
        interface IConfigurable
    end
type ConnectionParameters =
    class
        interface INamed
        interface IConfigurable
    end
See Also
ConnectionParameters Members
NFX.Web.Pay Namespace


ConnectionParameters Members

ConnectionParameters Members NFX Class Library

The ConnectionParameters type exposes the following members.
Constructors
 | Name | Description
Public method | ConnectionParameters | Initializes a new instance of the ConnectionParameters class
Public method | ConnectionParameters(IConfigSectionNode) | Initializes a new instance of the ConnectionParameters class
Public method | ConnectionParameters(String, String) | Initializes a new instance of the ConnectionParameters class
Back to Top
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
 | GetSystemHost |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Make TParams (IConfigSectionNode) |
 | Make TParams (String, String) |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name |
 | PaySystemHosts |
Public property | User |
Back to Top
See Also
ConnectionParameters Class
NFX.Web.Pay Namespace


ConnectionParameters Constructor

ConnectionParameters Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ConnectionParameters | Initializes a new instance of the ConnectionParameters class
Public method | ConnectionParameters(IConfigSectionNode) | Initializes a new instance of the ConnectionParameters class
Public method | ConnectionParameters(String, String) | Initializes a new instance of the ConnectionParameters class
Back to Top
See Also
ConnectionParameters Class
ConnectionParameters Members
NFX.Web.Pay Namespace


ConnectionParameters Constructor

ConnectionParameters Constructor NFX Class Library

Initializes a new instance of the ConnectionParameters class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConnectionParameters()
public ConnectionParameters()
Public Sub New
Public Sub New
public:
ConnectionParameters()
public:
ConnectionParameters()
new : unit -> ConnectionParameters
new : unit -> ConnectionParameters
See Also
ConnectionParameters Class
ConnectionParameters Members
ConnectionParameters Overload
NFX.Web.Pay Namespace


ConnectionParameters Constructor (IConfigSectionNode)

ConnectionParameters Constructor (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConnectionParameters class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConnectionParameters(
    IConfigSectionNode node
)
public ConnectionParameters(
    IConfigSectionNode node
)
Public Sub New (
    node As IConfigSectionNode
)
Public Sub New (
    node As IConfigSectionNode
)
public:
ConnectionParameters(
    IConfigSectionNode^ node
)
public:
ConnectionParameters(
    IConfigSectionNode^ node
)
new :
        node : IConfigSectionNode -> ConnectionParameters
new :
        node : IConfigSectionNode -> ConnectionParameters

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
ConnectionParameters Class
ConnectionParameters Members
ConnectionParameters Overload
NFX.Web.Pay Namespace


ConnectionParameters Constructor (String, String)

ConnectionParameters Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConnectionParameters class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConnectionParameters(
    string connStr,
    string format = "laconf"
)
public ConnectionParameters(
    string connStr,
    string format = "laconf"
)
Public Sub New (
    connStr As String,
    Optional format As String = "laconf"
)
Public Sub New (
    connStr As String,
    Optional format As String = "laconf"
)
public:
ConnectionParameters(
    String^ connStr,
    String^ format = L"laconf"
)
public:
ConnectionParameters(
    String^ connStr,
    String^ format = L"laconf"
)
new :
        connStr : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> ConnectionParameters
new :
        connStr : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> ConnectionParameters

Parameters

connStr
Type: Online System String
format (Optional)
Type: Online System String
See Also
ConnectionParameters Class
ConnectionParameters Members
ConnectionParameters Overload
NFX.Web.Pay Namespace


ConnectionParameters Methods

ConnectionParameters Methods NFX Class Library

The ConnectionParameters type exposes the following members.
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
 | GetSystemHost |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Make TParams (IConfigSectionNode) |
 | Make TParams (String, String) |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ConnectionParameters Class
NFX.Web.Pay Namespace


ConnectionParameters.Configure Method

ConnectionParameters Configure Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Configure(
    IConfigSectionNode node
)
public virtual void Configure(
    IConfigSectionNode node
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
ConnectionParameters Class
ConnectionParameters Members
NFX.Web.Pay Namespace


ConnectionParameters.GetSystemHost Method

ConnectionParameters GetSystemHost Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IPaySystemHost GetSystemHost(
    string name
)
public static IPaySystemHost GetSystemHost(
    string name
)
Public Shared Function GetSystemHost (
    name As String
) As IPaySystemHost
Public Shared Function GetSystemHost (
    name As String
) As IPaySystemHost
public:
static IPaySystemHost^ GetSystemHost(
    String^ name
)
public:
static IPaySystemHost^ GetSystemHost(
    String^ name
)
static member GetSystemHost :
        name : string -> IPaySystemHost
static member GetSystemHost :
        name : string -> IPaySystemHost

Parameters

name
Type: Online System String

Return Value

Type: IPaySystemHost
See Also
ConnectionParameters Class
ConnectionParameters Members
NFX.Web.Pay Namespace


ConnectionParameters.Make Method

ConnectionParameters Make Method NFX Class Library

Overload List
Name | Description
Make TParams (IConfigSectionNode) |
Make TParams (String, String) |
Back to Top
See Also
ConnectionParameters Class
ConnectionParameters Members
NFX.Web.Pay Namespace


ConnectionParameters.Make(TParams) Method (IConfigSectionNode)

ConnectionParameters Make TParams Method (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TParams Make<TParams>(
    IConfigSectionNode node
)
where TParams : ConnectionParameters
public static TParams Make<TParams>(
    IConfigSectionNode node
)
where TParams : ConnectionParameters
Public Shared Function Make(Of TParams As ConnectionParameters) (
    node As IConfigSectionNode
) As TParams
Public Shared Function Make(Of TParams As ConnectionParameters) (
    node As IConfigSectionNode
) As TParams
public:
generic<typename TParams>
where TParams : ConnectionParameters
static TParams Make(
    IConfigSectionNode^ node
)
public:
generic<typename TParams>
where TParams : ConnectionParameters
static TParams Make(
    IConfigSectionNode^ node
)
static member Make :
        node : IConfigSectionNode -> 'TParams  when 'TParams : ConnectionParameters
static member Make :
        node : IConfigSectionNode -> 'TParams  when 'TParams : ConnectionParameters

Parameters

node
Type: NFX.Environment IConfigSectionNode
Type Parameters
TParams

Return Value

Type: TParams
See Also
ConnectionParameters Class
ConnectionParameters Members
Make Overload
NFX.Web.Pay Namespace


ConnectionParameters.Make(TParams) Method (String, String)

ConnectionParameters Make TParams Method (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TParams Make<TParams>(
    string connStr,
    string format = "laconf"
)
where TParams : ConnectionParameters
public static TParams Make<TParams>(
    string connStr,
    string format = "laconf"
)
where TParams : ConnectionParameters
Public Shared Function Make(Of TParams As ConnectionParameters) (
    connStr As String,
    Optional format As String = "laconf"
) As TParams
Public Shared Function Make(Of TParams As ConnectionParameters) (
    connStr As String,
    Optional format As String = "laconf"
) As TParams
public:
generic<typename TParams>
where TParams : ConnectionParameters
static TParams Make(
    String^ connStr,
    String^ format = L"laconf"
)
public:
generic<typename TParams>
where TParams : ConnectionParameters
static TParams Make(
    String^ connStr,
    String^ format = L"laconf"
)
static member Make :
        connStr : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> 'TParams  when 'TParams : ConnectionParameters
static member Make :
        connStr : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> 'TParams  when 'TParams : ConnectionParameters

Parameters

connStr
Type: Online System String
format (Optional)
Type: Online System String
Type Parameters
TParams

Return Value

Type: TParams
See Also
ConnectionParameters Class
ConnectionParameters Members
Make Overload
NFX.Web.Pay Namespace


ConnectionParameters Properties

ConnectionParameters Properties NFX Class Library

The ConnectionParameters type exposes the following members.
Properties
 | Name | Description
Public property | Name |
 | PaySystemHosts |
Public property | User |
Back to Top
See Also
ConnectionParameters Class
NFX.Web.Pay Namespace


ConnectionParameters.Name Property

ConnectionParameters Name Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Name { get; set; }
[ConfigAttribute]
public string Name { get; set; }
<ConfigAttribute>
Public Property Name As String
    Get
    Set
<ConfigAttribute>
Public Property Name As String
    Get
    Set
public:
[ConfigAttribute]
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
[ConfigAttribute]
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
[<ConfigAttribute>]
abstract Name : string with get, set
[<ConfigAttribute>]
override Name : string with get, set
[<ConfigAttribute>]
abstract Name : string with get, set
[<ConfigAttribute>]
override Name : string with get, set

Property Value

Type: Online String

Implements

INamed Name
See Also
ConnectionParameters Class
ConnectionParameters Members
NFX.Web.Pay Namespace


ConnectionParameters.PaySystemHosts Property

ConnectionParameters PaySystemHosts Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IRegistry<IPaySystemHost> PaySystemHosts { get; }
public static IRegistry<IPaySystemHost> PaySystemHosts { get; }
Public Shared ReadOnly Property PaySystemHosts As IRegistry(Of IPaySystemHost)
    Get
Public Shared ReadOnly Property PaySystemHosts As IRegistry(Of IPaySystemHost)
    Get
public:
static property IRegistry<IPaySystemHost^>^ PaySystemHosts {
    IRegistry<IPaySystemHost^>^ get ();
}
public:
static property IRegistry<IPaySystemHost^>^ PaySystemHosts {
    IRegistry<IPaySystemHost^>^ get ();
}
static member PaySystemHosts : IRegistry<IPaySystemHost> with get
static member PaySystemHosts : IRegistry<IPaySystemHost> with get

Property Value

Type: IRegistry IPaySystemHost
See Also
ConnectionParameters Class
ConnectionParameters Members
NFX.Web.Pay Namespace


ConnectionParameters.User Property

ConnectionParameters User Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User User { get; set; }
public User User { get; set; }
Public Property User As User
    Get
    Set
Public Property User As User
    Get
    Set
public:
property User^ User {
    User^ get ();
    void set (User^ value);
}
public:
property User^ User {
    User^ get ();
    void set (User^ value);
}
member User : User with get, set
member User : User with get, set

Property Value

Type: User
See Also
ConnectionParameters Class
ConnectionParameters Members
NFX.Web.Pay Namespace


IActualAccountData Interface

IActualAccountData Interface NFX Class Library

Represents actual data for supplied account object. Data represented by this interface is ALWAYS TRANSITIVE in memory as some fields are either never stored permanently (i.e. CVC) or ciphered in the store (account number)

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IActualAccountData
public interface IActualAccountData
Public Interface IActualAccountData
Public Interface IActualAccountData
public interface class IActualAccountData
public interface class IActualAccountData
type IActualAccountData =  interface end
type IActualAccountData =  interface end
See Also
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData Members

IActualAccountData Members NFX Class Library

The IActualAccountData type exposes the following members.
Properties
 | Name | Description
Public property | Account |
Public property | AccountID |
Public property | AccountTitle |
Public property | AccountType |
Public property | BillingAddress |
Public property | CardExpirationDate |
Public property | CardHolder |
Public property | CardMaskedName |
Public property | CardVC |
Public property | EMail |
Public property | FirstName |
Public property | HadSuccessfullTransactions |
Public property | Identity |
Public property | IdentityID |
Public property | IsCard |
Public property | IsNew |
Public property | IssuerEMail |
Public property | IssuerID |
Public property | IssuerName |
Public property | IssuerPhone |
Public property | IssuerUri |
Public property | IsWebTerminal |
Public property | LastName |
Public property | MiddleName |
Public property | Phone |
Public property | RoutingNumber |
Public property | ShippingAddress |
Back to Top
See Also
IActualAccountData Interface
NFX.Web.Pay Namespace


IActualAccountData Properties

IActualAccountData Properties NFX Class Library

The IActualAccountData type exposes the following members.
Properties
 | Name | Description
Public property | Account |
Public property | AccountID |
Public property | AccountTitle |
Public property | AccountType |
Public property | BillingAddress |
Public property | CardExpirationDate |
Public property | CardHolder |
Public property | CardMaskedName |
Public property | CardVC |
Public property | EMail |
Public property | FirstName |
Public property | HadSuccessfullTransactions |
Public property | Identity |
Public property | IdentityID |
Public property | IsCard |
Public property | IsNew |
Public property | IssuerEMail |
Public property | IssuerID |
Public property | IssuerName |
Public property | IssuerPhone |
Public property | IssuerUri |
Public property | IsWebTerminal |
Public property | LastName |
Public property | MiddleName |
Public property | Phone |
Public property | RoutingNumber |
Public property | ShippingAddress |
Back to Top
See Also
IActualAccountData Interface
NFX.Web.Pay Namespace


IActualAccountData.Account Property

IActualAccountData Account Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Account Account { get; }
Account Account { get; }
ReadOnly Property Account As Account
    Get
ReadOnly Property Account As Account
    Get
property Account Account {
    Account get ();
}
property Account Account {
    Account get ();
}
abstract Account : Account with get
abstract Account : Account with get

Property Value

Type: Account
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.AccountID Property

IActualAccountData AccountID Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object AccountID { get; }
Object AccountID { get; }
ReadOnly Property AccountID As Object
    Get
ReadOnly Property AccountID As Object
    Get
property Object^ AccountID {
    Object^ get ();
}
property Object^ AccountID {
    Object^ get ();
}
abstract AccountID : Object with get
abstract AccountID : Object with get

Property Value

Type: Online Object
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.AccountTitle Property

IActualAccountData AccountTitle Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string AccountTitle { get; }
string AccountTitle { get; }
ReadOnly Property AccountTitle As String
    Get
ReadOnly Property AccountTitle As String
    Get
property String^ AccountTitle {
    String^ get ();
}
property String^ AccountTitle {
    String^ get ();
}
abstract AccountTitle : string with get
abstract AccountTitle : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.AccountType Property

IActualAccountData AccountType Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
AccountType AccountType { get; }
AccountType AccountType { get; }
ReadOnly Property AccountType As AccountType
    Get
ReadOnly Property AccountType As AccountType
    Get
property AccountType AccountType {
    AccountType get ();
}
property AccountType AccountType {
    AccountType get ();
}
abstract AccountType : AccountType with get
abstract AccountType : AccountType with get

Property Value

Type: AccountType
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.BillingAddress Property

IActualAccountData BillingAddress Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IAddress BillingAddress { get; }
IAddress BillingAddress { get; }
ReadOnly Property BillingAddress As IAddress
    Get
ReadOnly Property BillingAddress As IAddress
    Get
property IAddress^ BillingAddress {
    IAddress^ get ();
}
property IAddress^ BillingAddress {
    IAddress^ get ();
}
abstract BillingAddress : IAddress with get
abstract BillingAddress : IAddress with get

Property Value

Type: IAddress
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.CardExpirationDate Property

IActualAccountData CardExpirationDate Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<DateTime> CardExpirationDate { get; }
Nullable<DateTime> CardExpirationDate { get; }
ReadOnly Property CardExpirationDate As Nullable(Of DateTime)
    Get
ReadOnly Property CardExpirationDate As Nullable(Of DateTime)
    Get
property Nullable<DateTime> CardExpirationDate {
    Nullable<DateTime> get ();
}
property Nullable<DateTime> CardExpirationDate {
    Nullable<DateTime> get ();
}
abstract CardExpirationDate : Nullable<DateTime> with get
abstract CardExpirationDate : Nullable<DateTime> with get

Property Value

Type: Online Nullable Online DateTime
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.CardHolder Property

IActualAccountData CardHolder Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string CardHolder { get; }
string CardHolder { get; }
ReadOnly Property CardHolder As String
    Get
ReadOnly Property CardHolder As String
    Get
property String^ CardHolder {
    String^ get ();
}
property String^ CardHolder {
    String^ get ();
}
abstract CardHolder : string with get
abstract CardHolder : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.CardMaskedName Property

IActualAccountData CardMaskedName Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string CardMaskedName { get; }
string CardMaskedName { get; }
ReadOnly Property CardMaskedName As String
    Get
ReadOnly Property CardMaskedName As String
    Get
property String^ CardMaskedName {
    String^ get ();
}
property String^ CardMaskedName {
    String^ get ();
}
abstract CardMaskedName : string with get
abstract CardMaskedName : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.CardVC Property

IActualAccountData CardVC Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string CardVC { get; }
string CardVC { get; }
ReadOnly Property CardVC As String
    Get
ReadOnly Property CardVC As String
    Get
property String^ CardVC {
    String^ get ();
}
property String^ CardVC {
    String^ get ();
}
abstract CardVC : string with get
abstract CardVC : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.EMail Property

IActualAccountData EMail Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string EMail { get; }
string EMail { get; }
ReadOnly Property EMail As String
    Get
ReadOnly Property EMail As String
    Get
property String^ EMail {
    String^ get ();
}
property String^ EMail {
    String^ get ();
}
abstract EMail : string with get
abstract EMail : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.FirstName Property

IActualAccountData FirstName Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string FirstName { get; }
string FirstName { get; }
ReadOnly Property FirstName As String
    Get
ReadOnly Property FirstName As String
    Get
property String^ FirstName {
    String^ get ();
}
property String^ FirstName {
    String^ get ();
}
abstract FirstName : string with get
abstract FirstName : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.HadSuccessfullTransactions Property

IActualAccountData HadSuccessfullTransactions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool HadSuccessfullTransactions { get; }
bool HadSuccessfullTransactions { get; }
ReadOnly Property HadSuccessfullTransactions As Boolean
    Get
ReadOnly Property HadSuccessfullTransactions As Boolean
    Get
property bool HadSuccessfullTransactions {
    bool get ();
}
property bool HadSuccessfullTransactions {
    bool get ();
}
abstract HadSuccessfullTransactions : bool with get
abstract HadSuccessfullTransactions : bool with get

Property Value

Type: Online Boolean
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.Identity Property

IActualAccountData Identity Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Identity { get; }
string Identity { get; }
ReadOnly Property Identity As String
    Get
ReadOnly Property Identity As String
    Get
property String^ Identity {
    String^ get ();
}
property String^ Identity {
    String^ get ();
}
abstract Identity : string with get
abstract Identity : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.IdentityID Property

IActualAccountData IdentityID Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object IdentityID { get; }
Object IdentityID { get; }
ReadOnly Property IdentityID As Object
    Get
ReadOnly Property IdentityID As Object
    Get
property Object^ IdentityID {
    Object^ get ();
}
property Object^ IdentityID {
    Object^ get ();
}
abstract IdentityID : Object with get
abstract IdentityID : Object with get

Property Value

Type: Online Object
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.IsCard Property

IActualAccountData IsCard Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsCard { get; }
bool IsCard { get; }
ReadOnly Property IsCard As Boolean
    Get
ReadOnly Property IsCard As Boolean
    Get
property bool IsCard {
    bool get ();
}
property bool IsCard {
    bool get ();
}
abstract IsCard : bool with get
abstract IsCard : bool with get

Property Value

Type: Online Boolean
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.IsNew Property

IActualAccountData IsNew Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsNew { get; }
bool IsNew { get; }
ReadOnly Property IsNew As Boolean
    Get
ReadOnly Property IsNew As Boolean
    Get
property bool IsNew {
    bool get ();
}
property bool IsNew {
    bool get ();
}
abstract IsNew : bool with get
abstract IsNew : bool with get

Property Value

Type: Online Boolean
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.IssuerEMail Property

IActualAccountData IssuerEMail Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string IssuerEMail { get; }
string IssuerEMail { get; }
ReadOnly Property IssuerEMail As String
    Get
ReadOnly Property IssuerEMail As String
    Get
property String^ IssuerEMail {
    String^ get ();
}
property String^ IssuerEMail {
    String^ get ();
}
abstract IssuerEMail : string with get
abstract IssuerEMail : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.IssuerID Property

IActualAccountData IssuerID Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string IssuerID { get; }
string IssuerID { get; }
ReadOnly Property IssuerID As String
    Get
ReadOnly Property IssuerID As String
    Get
property String^ IssuerID {
    String^ get ();
}
property String^ IssuerID {
    String^ get ();
}
abstract IssuerID : string with get
abstract IssuerID : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.IssuerName Property

IActualAccountData IssuerName Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string IssuerName { get; }
string IssuerName { get; }
ReadOnly Property IssuerName As String
    Get
ReadOnly Property IssuerName As String
    Get
property String^ IssuerName {
    String^ get ();
}
property String^ IssuerName {
    String^ get ();
}
abstract IssuerName : string with get
abstract IssuerName : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.IssuerPhone Property

IActualAccountData IssuerPhone Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string IssuerPhone { get; }
string IssuerPhone { get; }
ReadOnly Property IssuerPhone As String
    Get
ReadOnly Property IssuerPhone As String
    Get
property String^ IssuerPhone {
    String^ get ();
}
property String^ IssuerPhone {
    String^ get ();
}
abstract IssuerPhone : string with get
abstract IssuerPhone : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.IssuerUri Property

IActualAccountData IssuerUri Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string IssuerUri { get; }
string IssuerUri { get; }
ReadOnly Property IssuerUri As String
    Get
ReadOnly Property IssuerUri As String
    Get
property String^ IssuerUri {
    String^ get ();
}
property String^ IssuerUri {
    String^ get ();
}
abstract IssuerUri : string with get
abstract IssuerUri : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.IsWebTerminal Property

IActualAccountData IsWebTerminal Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsWebTerminal { get; }
bool IsWebTerminal { get; }
ReadOnly Property IsWebTerminal As Boolean
    Get
ReadOnly Property IsWebTerminal As Boolean
    Get
property bool IsWebTerminal {
    bool get ();
}
property bool IsWebTerminal {
    bool get ();
}
abstract IsWebTerminal : bool with get
abstract IsWebTerminal : bool with get

Property Value

Type: Online Boolean
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.LastName Property

IActualAccountData LastName Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string LastName { get; }
string LastName { get; }
ReadOnly Property LastName As String
    Get
ReadOnly Property LastName As String
    Get
property String^ LastName {
    String^ get ();
}
property String^ LastName {
    String^ get ();
}
abstract LastName : string with get
abstract LastName : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.MiddleName Property

IActualAccountData MiddleName Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string MiddleName { get; }
string MiddleName { get; }
ReadOnly Property MiddleName As String
    Get
ReadOnly Property MiddleName As String
    Get
property String^ MiddleName {
    String^ get ();
}
property String^ MiddleName {
    String^ get ();
}
abstract MiddleName : string with get
abstract MiddleName : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.Phone Property

IActualAccountData Phone Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Phone { get; }
string Phone { get; }
ReadOnly Property Phone As String
    Get
ReadOnly Property Phone As String
    Get
property String^ Phone {
    String^ get ();
}
property String^ Phone {
    String^ get ();
}
abstract Phone : string with get
abstract Phone : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.RoutingNumber Property

IActualAccountData RoutingNumber Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string RoutingNumber { get; }
string RoutingNumber { get; }
ReadOnly Property RoutingNumber As String
    Get
ReadOnly Property RoutingNumber As String
    Get
property String^ RoutingNumber {
    String^ get ();
}
property String^ RoutingNumber {
    String^ get ();
}
abstract RoutingNumber : string with get
abstract RoutingNumber : string with get

Property Value

Type: Online String
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IActualAccountData.ShippingAddress Property

IActualAccountData ShippingAddress Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IAddress ShippingAddress { get; }
IAddress ShippingAddress { get; }
ReadOnly Property ShippingAddress As IAddress
    Get
ReadOnly Property ShippingAddress As IAddress
    Get
property IAddress^ ShippingAddress {
    IAddress^ get ();
}
property IAddress^ ShippingAddress {
    IAddress^ get ();
}
abstract ShippingAddress : IAddress with get
abstract ShippingAddress : IAddress with get

Property Value

Type: IAddress
See Also
IActualAccountData Interface
IActualAccountData Members
NFX.Web.Pay Namespace


IAddress Interface

IAddress Interface NFX Class Library

Represents address

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IAddress
public interface IAddress
Public Interface IAddress
Public Interface IAddress
public interface class IAddress
public interface class IAddress
type IAddress =  interface end
type IAddress =  interface end
See Also
IAddress Members
NFX.Web.Pay Namespace


IAddress Members

IAddress Members NFX Class Library

The IAddress type exposes the following members.
Properties
 | Name | Description
Public property | Address1 |
Public property | Address2 |
Public property | City |
Public property | Company |
Public property | Country |
Public property | EMail |
Public property | Phone |
Public property | PostalCode |
Public property | Region |
Back to Top
See Also
IAddress Interface
NFX.Web.Pay Namespace


IAddress Properties

IAddress Properties NFX Class Library

The IAddress type exposes the following members.
Properties
 | Name | Description
Public property | Address1 |
Public property | Address2 |
Public property | City |
Public property | Company |
Public property | Country |
Public property | EMail |
Public property | Phone |
Public property | PostalCode |
Public property | Region |
Back to Top
See Also
IAddress Interface
NFX.Web.Pay Namespace


IAddress.Address1 Property

IAddress Address1 Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Address1 { get; }
string Address1 { get; }
ReadOnly Property Address1 As String
    Get
ReadOnly Property Address1 As String
    Get
property String^ Address1 {
    String^ get ();
}
property String^ Address1 {
    String^ get ();
}
abstract Address1 : string with get
abstract Address1 : string with get

Property Value

Type: Online String
See Also
IAddress Interface
IAddress Members
NFX.Web.Pay Namespace


IAddress.Address2 Property

IAddress Address2 Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Address2 { get; }
string Address2 { get; }
ReadOnly Property Address2 As String
    Get
ReadOnly Property Address2 As String
    Get
property String^ Address2 {
    String^ get ();
}
property String^ Address2 {
    String^ get ();
}
abstract Address2 : string with get
abstract Address2 : string with get

Property Value

Type: Online String
See Also
IAddress Interface
IAddress Members
NFX.Web.Pay Namespace


IAddress.City Property

IAddress City Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string City { get; }
string City { get; }
ReadOnly Property City As String
    Get
ReadOnly Property City As String
    Get
property String^ City {
    String^ get ();
}
property String^ City {
    String^ get ();
}
abstract City : string with get
abstract City : string with get

Property Value

Type: Online String
See Also
IAddress Interface
IAddress Members
NFX.Web.Pay Namespace


IAddress.Company Property

IAddress Company Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Company { get; }
string Company { get; }
ReadOnly Property Company As String
    Get
ReadOnly Property Company As String
    Get
property String^ Company {
    String^ get ();
}
property String^ Company {
    String^ get ();
}
abstract Company : string with get
abstract Company : string with get

Property Value

Type: Online String
See Also
IAddress Interface
IAddress Members
NFX.Web.Pay Namespace


IAddress.Country Property

IAddress Country Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Country { get; }
string Country { get; }
ReadOnly Property Country As String
    Get
ReadOnly Property Country As String
    Get
property String^ Country {
    String^ get ();
}
property String^ Country {
    String^ get ();
}
abstract Country : string with get
abstract Country : string with get

Property Value

Type: Online String
See Also
IAddress Interface
IAddress Members
NFX.Web.Pay Namespace


IAddress.EMail Property

IAddress EMail Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string EMail { get; }
string EMail { get; }
ReadOnly Property EMail As String
    Get
ReadOnly Property EMail As String
    Get
property String^ EMail {
    String^ get ();
}
property String^ EMail {
    String^ get ();
}
abstract EMail : string with get
abstract EMail : string with get

Property Value

Type: Online String
See Also
IAddress Interface
IAddress Members
NFX.Web.Pay Namespace


IAddress.Phone Property

IAddress Phone Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Phone { get; }
string Phone { get; }
ReadOnly Property Phone As String
    Get
ReadOnly Property Phone As String
    Get
property String^ Phone {
    String^ get ();
}
property String^ Phone {
    String^ get ();
}
abstract Phone : string with get
abstract Phone : string with get

Property Value

Type: Online String
See Also
IAddress Interface
IAddress Members
NFX.Web.Pay Namespace


IAddress.PostalCode Property

IAddress PostalCode Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string PostalCode { get; }
string PostalCode { get; }
ReadOnly Property PostalCode As String
    Get
ReadOnly Property PostalCode As String
    Get
property String^ PostalCode {
    String^ get ();
}
property String^ PostalCode {
    String^ get ();
}
abstract PostalCode : string with get
abstract PostalCode : string with get

Property Value

Type: Online String
See Also
IAddress Interface
IAddress Members
NFX.Web.Pay Namespace


IAddress.Region Property

IAddress Region Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Region { get; }
string Region { get; }
ReadOnly Property Region As String
    Get
ReadOnly Property Region As String
    Get
property String^ Region {
    String^ get ();
}
property String^ Region {
    String^ get ();
}
abstract Region : string with get
abstract Region : string with get

Property Value

Type: Online String
See Also
IAddress Interface
IAddress Members
NFX.Web.Pay Namespace


ICurrencyMarket Interface

ICurrencyMarket Interface NFX Class Library

Represents a market that can convert buy/sell currencies

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICurrencyMarket
public interface ICurrencyMarket
Public Interface ICurrencyMarket
Public Interface ICurrencyMarket
public interface class ICurrencyMarket
public interface class ICurrencyMarket
type ICurrencyMarket =  interface end
type ICurrencyMarket =  interface end
See Also
ICurrencyMarket Members
NFX.Web.Pay Namespace


ICurrencyMarket Members

ICurrencyMarket Members NFX Class Library

The ICurrencyMarket type exposes the following members.
Methods
 | Name | Description
Public method | ConvertCurrency | Returns conversion rate for source->target conversion. rateTable is the name of the rates set, if omitted or not found then default conv rates will be used
Back to Top
See Also
ICurrencyMarket Interface
NFX.Web.Pay Namespace


ICurrencyMarket Methods

ICurrencyMarket Methods NFX Class Library

The ICurrencyMarket type exposes the following members.
Methods
 | Name | Description
Public method | ConvertCurrency | Returns conversion rate for source->target conversion. rateTable is the name of the rates set, if omitted or not found then default conv rates will be used
Back to Top
See Also
ICurrencyMarket Interface
NFX.Web.Pay Namespace


ICurrencyMarket.ConvertCurrency Method

ICurrencyMarket ConvertCurrency Method NFX Class Library

Returns conversion rate for source->target conversion. rateTable is the name of the rates set, if omitted or not found then default conv rates will be used

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Amount ConvertCurrency(
    string rateTable,
    Amount from,
    string targetCurrencyISO
)
Amount ConvertCurrency(
    string rateTable,
    Amount from,
    string targetCurrencyISO
)
Function ConvertCurrency (
    rateTable As String,
    from As Amount,
    targetCurrencyISO As String
) As Amount
Function ConvertCurrency (
    rateTable As String,
    from As Amount,
    targetCurrencyISO As String
) As Amount
Amount ConvertCurrency(
    String^ rateTable,
    Amount from,
    String^ targetCurrencyISO
)
Amount ConvertCurrency(
    String^ rateTable,
    Amount from,
    String^ targetCurrencyISO
)
abstract ConvertCurrency :
        rateTable : string *
        from : Amount *
        targetCurrencyISO : string -> Amount
abstract ConvertCurrency :
        rateTable : string *
        from : Amount *
        targetCurrencyISO : string -> Amount

Parameters

rateTable
Type: Online System String
from
Type: NFX.Financial Amount
targetCurrencyISO
Type: Online System String

Return Value

Type: Amount
See Also
ICurrencyMarket Interface
ICurrencyMarket Members
NFX.Web.Pay Namespace


IPaySessionContext Interface

IPaySessionContext Interface NFX Class Library

Denotes a context of transaction execution. Can be used to provide additional information

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPaySessionContext
public interface IPaySessionContext
Public Interface IPaySessionContext
Public Interface IPaySessionContext
public interface class IPaySessionContext
public interface class IPaySessionContext
type IPaySessionContext =  interface end
type IPaySessionContext =  interface end
See Also
NFX.Web.Pay Namespace


IPaySystem Interface

IPaySystem Interface NFX Class Library

Describes an entity that can perform pay functions (i.e. charge, transfer)

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPaySystem : INamed
public interface IPaySystem : INamed
Public Interface IPaySystem
    Inherits INamed
Public Interface IPaySystem
    Inherits INamed
public interface class IPaySystem : INamed
public interface class IPaySystem : INamed
type IPaySystem =
    interface
        interface INamed
    end
type IPaySystem =
    interface
        interface INamed
    end
See Also
IPaySystem Members
NFX.Web.Pay Namespace


IPaySystem Members

IPaySystem Members NFX Class Library

The IPaySystem type exposes the following members.
Methods
 | Name | Description
Public method | IsTransactionTypeSupported | Returns true if this system supports transaction type in the specified currency (optional)
Public method | StartSession | Starts new pay session of system-specific type. If cParams parameter is null DefaultSessionConnectParamsCfg is used
Back to Top
Properties
 | Name | Description
Public property | ChargeFeeKind | Processing fee types, such as: included in amount and surcharged.
Public property | DefaultSessionConnectParamsCfg | Config node of params used inside StartSession(ConnectionParameters, IPaySessionContext) method if PayConnectionParameters parameter is null
Public property | Name | (Inherited from INamed.)
Public property | SupportedCurrencies | Returns currency ISOs that are supported by this isntance. The processing of charges/transafers may be done only in these currencies
Public property | TransferFeeKind | Processing fee types, such as: included in amount and surcharged.
Public property | WebTerminal | Returns a pay terminal is this payment provider supports it or null
Back to Top
See Also
IPaySystem Interface
NFX.Web.Pay Namespace


IPaySystem Methods

IPaySystem Methods NFX Class Library

The IPaySystem type exposes the following members.
Methods
 | Name | Description
Public method | IsTransactionTypeSupported | Returns true if this system supports transaction type in the specified currency (optional)
Public method | StartSession | Starts new pay session of system-specific type. If cParams parameter is null DefaultSessionConnectParamsCfg is used
Back to Top
See Also
IPaySystem Interface
NFX.Web.Pay Namespace


IPaySystem.IsTransactionTypeSupported Method

IPaySystem IsTransactionTypeSupported Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true if this system supports transaction type in the specified currency (optional)

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsTransactionTypeSupported(
    TransactionType type,
    string currencyISO = null
)
bool IsTransactionTypeSupported(
    TransactionType type,
    string currencyISO = null
)
Function IsTransactionTypeSupported (
    type As TransactionType,
    Optional currencyISO As String = Nothing
) As Boolean
Function IsTransactionTypeSupported (
    type As TransactionType,
    Optional currencyISO As String = Nothing
) As Boolean
bool IsTransactionTypeSupported(
    TransactionType type,
    String^ currencyISO = nullptr
)
bool IsTransactionTypeSupported(
    TransactionType type,
    String^ currencyISO = nullptr
)
abstract IsTransactionTypeSupported :
        type : TransactionType *
        ?currencyISO : string
(* Defaults:
        let _currencyISO = defaultArg currencyISO null
*)
-> bool
abstract IsTransactionTypeSupported :
        type : TransactionType *
        ?currencyISO : string
(* Defaults:
        let _currencyISO = defaultArg currencyISO null
*)
-> bool

Parameters

type
Type: NFX.Web.Pay TransactionType
currencyISO (Optional)
Type: Online System String

Return Value

Type: Online Boolean
See Also
IPaySystem Interface
IPaySystem Members
NFX.Web.Pay Namespace


IPaySystem.StartSession Method

IPaySystem StartSession Method NFX Class Library

Starts new pay session of system-specific type. If cParams parameter is null DefaultSessionConnectParamsCfg is used

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
PaySession StartSession(
    ConnectionParameters cParams = null,
    IPaySessionContext context = null
)
PaySession StartSession(
    ConnectionParameters cParams = null,
    IPaySessionContext context = null
)
Function StartSession (
    Optional cParams As ConnectionParameters = Nothing,
    Optional context As IPaySessionContext = Nothing
) As PaySession
Function StartSession (
    Optional cParams As ConnectionParameters = Nothing,
    Optional context As IPaySessionContext = Nothing
) As PaySession
PaySession^ StartSession(
    ConnectionParameters^ cParams = nullptr,
    IPaySessionContext^ context = nullptr
)
PaySession^ StartSession(
    ConnectionParameters^ cParams = nullptr,
    IPaySessionContext^ context = nullptr
)
abstract StartSession :
        ?cParams : ConnectionParameters *
        ?context : IPaySessionContext
(* Defaults:
        let _cParams = defaultArg cParams null
        let _context = defaultArg context null
*)
-> PaySession
abstract StartSession :
        ?cParams : ConnectionParameters *
        ?context : IPaySessionContext
(* Defaults:
        let _cParams = defaultArg cParams null
        let _context = defaultArg context null
*)
-> PaySession

Parameters

cParams (Optional)
Type: NFX.Web.Pay ConnectionParameters
context (Optional)
Type: NFX.Web.Pay IPaySessionContext

Return Value

Type: PaySession
See Also
IPaySystem Interface
IPaySystem Members
NFX.Web.Pay Namespace


IPaySystem Properties

IPaySystem Properties NFX Class Library

The IPaySystem type exposes the following members.
Properties
 | Name | Description
Public property | ChargeFeeKind | Processing fee types, such as: included in amount and surcharged.
Public property | DefaultSessionConnectParamsCfg | Config node of params used inside StartSession(ConnectionParameters, IPaySessionContext) method if PayConnectionParameters parameter is null
Public property | Name | (Inherited from INamed.)
Public property | SupportedCurrencies | Returns currency ISOs that are supported by this isntance. The processing of charges/transafers may be done only in these currencies
Public property | TransferFeeKind | Processing fee types, such as: included in amount and surcharged.
Public property | WebTerminal | Returns a pay terminal is this payment provider supports it or null
Back to Top
See Also
IPaySystem Interface
NFX.Web.Pay Namespace


IPaySystem.ChargeFeeKind Property

IPaySystem ChargeFeeKind Property NFX Class Library

Processing fee types, such as: included in amount and surcharged.

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ProcessingFeeKind ChargeFeeKind { get; }
ProcessingFeeKind ChargeFeeKind { get; }
ReadOnly Property ChargeFeeKind As ProcessingFeeKind
    Get
ReadOnly Property ChargeFeeKind As ProcessingFeeKind
    Get
property ProcessingFeeKind ChargeFeeKind {
    ProcessingFeeKind get ();
}
property ProcessingFeeKind ChargeFeeKind {
    ProcessingFeeKind get ();
}
abstract ChargeFeeKind : ProcessingFeeKind with get
abstract ChargeFeeKind : ProcessingFeeKind with get

Property Value

Type: ProcessingFeeKind
See Also
IPaySystem Interface
IPaySystem Members
NFX.Web.Pay Namespace


IPaySystem.DefaultSessionConnectParamsCfg Property

IPaySystem DefaultSessionConnectParamsCfg Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Config node of params used inside StartSession(ConnectionParameters, IPaySessionContext) method if PayConnectionParameters parameter is null

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigSectionNode DefaultSessionConnectParamsCfg { get; set; }
IConfigSectionNode DefaultSessionConnectParamsCfg { get; set; }
Property DefaultSessionConnectParamsCfg As IConfigSectionNode
    Get
    Set
Property DefaultSessionConnectParamsCfg As IConfigSectionNode
    Get
    Set
property IConfigSectionNode^ DefaultSessionConnectParamsCfg {
    IConfigSectionNode^ get ();
    void set (IConfigSectionNode^ value);
}
property IConfigSectionNode^ DefaultSessionConnectParamsCfg {
    IConfigSectionNode^ get ();
    void set (IConfigSectionNode^ value);
}
abstract DefaultSessionConnectParamsCfg : IConfigSectionNode with get, set
abstract DefaultSessionConnectParamsCfg : IConfigSectionNode with get, set

Property Value

Type: IConfigSectionNode
See Also
IPaySystem Interface
IPaySystem Members
NFX.Web.Pay Namespace


IPaySystem.SupportedCurrencies Property

IPaySystem SupportedCurrencies Property NFX Class Library

Returns currency ISOs that are supported by this isntance. The processing of charges/transafers may be done only in these currencies

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<string> SupportedCurrencies { get; }
IEnumerable<string> SupportedCurrencies { get; }
ReadOnly Property SupportedCurrencies As IEnumerable(Of String)
    Get
ReadOnly Property SupportedCurrencies As IEnumerable(Of String)
    Get
property IEnumerable<String^>^ SupportedCurrencies {
    IEnumerable<String^>^ get ();
}
property IEnumerable<String^>^ SupportedCurrencies {
    IEnumerable<String^>^ get ();
}
abstract SupportedCurrencies : IEnumerable<string> with get
abstract SupportedCurrencies : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
IPaySystem Interface
IPaySystem Members
NFX.Web.Pay Namespace


IPaySystem.TransferFeeKind Property

IPaySystem TransferFeeKind Property NFX Class Library

Processing fee types, such as: included in amount and surcharged.

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ProcessingFeeKind TransferFeeKind { get; }
ProcessingFeeKind TransferFeeKind { get; }
ReadOnly Property TransferFeeKind As ProcessingFeeKind
    Get
ReadOnly Property TransferFeeKind As ProcessingFeeKind
    Get
property ProcessingFeeKind TransferFeeKind {
    ProcessingFeeKind get ();
}
property ProcessingFeeKind TransferFeeKind {
    ProcessingFeeKind get ();
}
abstract TransferFeeKind : ProcessingFeeKind with get
abstract TransferFeeKind : ProcessingFeeKind with get

Property Value

Type: ProcessingFeeKind
See Also
IPaySystem Interface
IPaySystem Members
NFX.Web.Pay Namespace


IPaySystem.WebTerminal Property

IPaySystem WebTerminal Property NFX Class Library

Returns a pay terminal is this payment provider supports it or null

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IPayWebTerminal WebTerminal { get; }
IPayWebTerminal WebTerminal { get; }
ReadOnly Property WebTerminal As IPayWebTerminal
    Get
ReadOnly Property WebTerminal As IPayWebTerminal
    Get
property IPayWebTerminal^ WebTerminal {
    IPayWebTerminal^ get ();
}
property IPayWebTerminal^ WebTerminal {
    IPayWebTerminal^ get ();
}
abstract WebTerminal : IPayWebTerminal with get
abstract WebTerminal : IPayWebTerminal with get

Property Value

Type: IPayWebTerminal
See Also
IPaySystem Interface
IPaySystem Members
NFX.Web.Pay Namespace


IPaySystemHost Interface

IPaySystemHost Interface NFX Class Library

Represents a process-global entity that resolves account handle into actual account data and fetches existing transactions. This design provides an indirection level between pay systems (like Stripe, PayPal, Bank etc.) and particular application data store implementation as it decouples system-internal formats of transaction and account storage from provider-internal data (i.e. PayPal payment token string). The instance of implementor is a singleton accessible via PaySystem.PaySystemHost

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPaySystemHost : INamed
public interface IPaySystemHost : INamed
Public Interface IPaySystemHost
    Inherits INamed
Public Interface IPaySystemHost
    Inherits INamed
public interface class IPaySystemHost : INamed
public interface class IPaySystemHost : INamed
type IPaySystemHost =
    interface
        interface INamed
    end
type IPaySystemHost =
    interface
        interface INamed
    end
See Also
IPaySystemHost Members
NFX.Web.Pay Namespace


IPaySystemHost Members

IPaySystemHost Members NFX Class Library

The IPaySystemHost type exposes the following members.
Methods
 | Name | Description
Public method | FetchAccountData | Returns actual data for supplied account object
Public method | FetchTransaction | Returns a transaction with specified ID from storage or null
Back to Top
Properties
 | Name | Description
Public property | CurrencyMarket | Currency market
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
IPaySystemHost Interface
NFX.Web.Pay Namespace


IPaySystemHost Methods

IPaySystemHost Methods NFX Class Library

The IPaySystemHost type exposes the following members.
Methods
 | Name | Description
Public method | FetchAccountData | Returns actual data for supplied account object
Public method | FetchTransaction | Returns a transaction with specified ID from storage or null
Back to Top
See Also
IPaySystemHost Interface
NFX.Web.Pay Namespace


IPaySystemHost.FetchAccountData Method

IPaySystemHost FetchAccountData Method NFX Class Library

Returns actual data for supplied account object

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IActualAccountData FetchAccountData(
    Account account
)
IActualAccountData FetchAccountData(
    Account account
)
Function FetchAccountData (
    account As Account
) As IActualAccountData
Function FetchAccountData (
    account As Account
) As IActualAccountData
IActualAccountData^ FetchAccountData(
    Account account
)
IActualAccountData^ FetchAccountData(
    Account account
)
abstract FetchAccountData :
        account : Account -> IActualAccountData
abstract FetchAccountData :
        account : Account -> IActualAccountData

Parameters

account
Type: NFX.Web.Pay Account

Return Value

Type: IActualAccountData
See Also
IPaySystemHost Interface
IPaySystemHost Members
NFX.Web.Pay Namespace


IPaySystemHost.FetchTransaction Method

IPaySystemHost FetchTransaction Method NFX Class Library

Returns a transaction with specified ID from storage or null

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Transaction FetchTransaction(
    Object id
)
Transaction FetchTransaction(
    Object id
)
Function FetchTransaction (
    id As Object
) As Transaction
Function FetchTransaction (
    id As Object
) As Transaction
Transaction^ FetchTransaction(
    Object^ id
)
Transaction^ FetchTransaction(
    Object^ id
)
abstract FetchTransaction :
        id : Object -> Transaction
abstract FetchTransaction :
        id : Object -> Transaction

Parameters

id
Type: Online System Object

Return Value

Type: Transaction
See Also
IPaySystemHost Interface
IPaySystemHost Members
NFX.Web.Pay Namespace


IPaySystemHost Properties

IPaySystemHost Properties NFX Class Library

The IPaySystemHost type exposes the following members.
Properties
 | Name | Description
Public property | CurrencyMarket | Currency market
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
IPaySystemHost Interface
NFX.Web.Pay Namespace


IPaySystemHost.CurrencyMarket Property

IPaySystemHost CurrencyMarket Property NFX Class Library

Currency market

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ICurrencyMarket CurrencyMarket { get; }
ICurrencyMarket CurrencyMarket { get; }
ReadOnly Property CurrencyMarket As ICurrencyMarket
    Get
ReadOnly Property CurrencyMarket As ICurrencyMarket
    Get
property ICurrencyMarket^ CurrencyMarket {
    ICurrencyMarket^ get ();
}
property ICurrencyMarket^ CurrencyMarket {
    ICurrencyMarket^ get ();
}
abstract CurrencyMarket : ICurrencyMarket with get
abstract CurrencyMarket : ICurrencyMarket with get

Property Value

Type: ICurrencyMarket
See Also
IPaySystemHost Interface
IPaySystemHost Members
NFX.Web.Pay Namespace


IPaySystemHostImplementation Interface

IPaySystemHostImplementation Interface NFX Class Library

Denotes an implementation of IPaySystemHost

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPaySystemHostImplementation : IPaySystemHost,
    INamed, IConfigurable
public interface IPaySystemHostImplementation : IPaySystemHost,
    INamed, IConfigurable
Public Interface IPaySystemHostImplementation
    Inherits IPaySystemHost, INamed, IConfigurable
Public Interface IPaySystemHostImplementation
    Inherits IPaySystemHost, INamed, IConfigurable
public interface class IPaySystemHostImplementation : IPaySystemHost,
    INamed, IConfigurable
public interface class IPaySystemHostImplementation : IPaySystemHost,
    INamed, IConfigurable
type IPaySystemHostImplementation =
    interface
        interface IPaySystemHost
        interface INamed
        interface IConfigurable
    end
type IPaySystemHostImplementation =
    interface
        interface IPaySystemHost
        interface INamed
        interface IConfigurable
    end
See Also
IPaySystemHostImplementation Members
NFX.Web.Pay Namespace


IPaySystemHostImplementation Members

IPaySystemHostImplementation Members NFX Class Library

The IPaySystemHostImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | FetchAccountData | Returns actual data for supplied account object (Inherited from IPaySystemHost.)
Public method | FetchTransaction | Returns a transaction with specified ID from storage or null (Inherited from IPaySystemHost.)
Back to Top
Properties
 | Name | Description
Public property | CurrencyMarket | Currency market (Inherited from IPaySystemHost.)
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
IPaySystemHostImplementation Interface
NFX.Web.Pay Namespace


IPaySystemHostImplementation Methods

IPaySystemHostImplementation Methods NFX Class Library

The IPaySystemHostImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | FetchAccountData | Returns actual data for supplied account object (Inherited from IPaySystemHost.)
Public method | FetchTransaction | Returns a transaction with specified ID from storage or null (Inherited from IPaySystemHost.)
Back to Top
See Also
IPaySystemHostImplementation Interface
NFX.Web.Pay Namespace


IPaySystemHostImplementation Properties

IPaySystemHostImplementation Properties NFX Class Library

The IPaySystemHostImplementation type exposes the following members.
Properties
 | Name | Description
Public property | CurrencyMarket | Currency market (Inherited from IPaySystemHost.)
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
IPaySystemHostImplementation Interface
NFX.Web.Pay Namespace


IPaySystemImplementation Interface

IPaySystemImplementation Interface NFX Class Library

Describes an entity that can perform pay functions with several usefull interfaces in NFX style

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPaySystemImplementation : IPaySystem,
    INamed, IConfigurable, IInstrumentable, IExternallyParameterized
public interface IPaySystemImplementation : IPaySystem,
    INamed, IConfigurable, IInstrumentable, IExternallyParameterized
Public Interface IPaySystemImplementation
    Inherits IPaySystem, INamed, IConfigurable, IInstrumentable,
    IExternallyParameterized
Public Interface IPaySystemImplementation
    Inherits IPaySystem, INamed, IConfigurable, IInstrumentable,
    IExternallyParameterized
public interface class IPaySystemImplementation : IPaySystem,
    INamed, IConfigurable, IInstrumentable, IExternallyParameterized
public interface class IPaySystemImplementation : IPaySystem,
    INamed, IConfigurable, IInstrumentable, IExternallyParameterized
type IPaySystemImplementation =
    interface
        interface IPaySystem
        interface INamed
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type IPaySystemImplementation =
    interface
        interface IPaySystem
        interface INamed
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
IPaySystemImplementation Members
NFX.Web.Pay Namespace


IPaySystemImplementation Members

IPaySystemImplementation Members NFX Class Library

The IPaySystemImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | IsTransactionTypeSupported | Returns true if this system supports transaction type in the specified currency (optional) (Inherited from IPaySystem.)
Public method | StartSession | Starts new pay session of system-specific type. If cParams parameter is null DefaultSessionConnectParamsCfg is used (Inherited from IPaySystem.)
Back to Top
Properties
 | Name | Description
Public property | ChargeFeeKind | Processing fee types, such as: included in amount and surcharged. (Inherited from IPaySystem.)
Public property | DefaultSessionConnectParamsCfg | Config node of params used inside StartSession(ConnectionParameters, IPaySessionContext) method if PayConnectionParameters parameter is null (Inherited from IPaySystem.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LogLevel | Specifies the log level for operations performed by Pay System.
Public property | Name | (Inherited from INamed.)
Public property | SupportedCurrencies | Returns currency ISOs that are supported by this isntance. The processing of charges/transafers may be done only in these currencies (Inherited from IPaySystem.)
Public property | TransferFeeKind | Processing fee types, such as: included in amount and surcharged. (Inherited from IPaySystem.)
Public property | WebTerminal | Returns a pay terminal is this payment provider supports it or null (Inherited from IPaySystem.)
Back to Top
See Also
IPaySystemImplementation Interface
NFX.Web.Pay Namespace


IPaySystemImplementation Methods

IPaySystemImplementation Methods NFX Class Library

The IPaySystemImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | IsTransactionTypeSupported | Returns true if this system supports transaction type in the specified currency (optional) (Inherited from IPaySystem.)
Public method | StartSession | Starts new pay session of system-specific type. If cParams parameter is null DefaultSessionConnectParamsCfg is used (Inherited from IPaySystem.)
Back to Top
See Also
IPaySystemImplementation Interface
NFX.Web.Pay Namespace


IPaySystemImplementation Properties

IPaySystemImplementation Properties NFX Class Library

The IPaySystemImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ChargeFeeKind | Processing fee types, such as: included in amount and surcharged. (Inherited from IPaySystem.)
Public property | DefaultSessionConnectParamsCfg | Config node of params used inside StartSession(ConnectionParameters, IPaySessionContext) method if PayConnectionParameters parameter is null (Inherited from IPaySystem.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LogLevel | Specifies the log level for operations performed by Pay System.
Public property | Name | (Inherited from INamed.)
Public property | SupportedCurrencies | Returns currency ISOs that are supported by this isntance. The processing of charges/transafers may be done only in these currencies (Inherited from IPaySystem.)
Public property | TransferFeeKind | Processing fee types, such as: included in amount and surcharged. (Inherited from IPaySystem.)
Public property | WebTerminal | Returns a pay terminal is this payment provider supports it or null (Inherited from IPaySystem.)
Back to Top
See Also
IPaySystemImplementation Interface
NFX.Web.Pay Namespace


IPaySystemImplementation.LogLevel Property

IPaySystemImplementation LogLevel Property NFX Class Library

Specifies the log level for operations performed by Pay System.

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
MessageType LogLevel { get; set; }
MessageType LogLevel { get; set; }
Property LogLevel As MessageType
    Get
    Set
Property LogLevel As MessageType
    Get
    Set
property MessageType LogLevel {
    MessageType get ();
    void set (MessageType value);
}
property MessageType LogLevel {
    MessageType get ();
    void set (MessageType value);
}
abstract LogLevel : MessageType with get, set
abstract LogLevel : MessageType with get, set

Property Value

Type: MessageType
See Also
IPaySystemImplementation Interface
IPaySystemImplementation Members
NFX.Web.Pay Namespace


IPayWebTerminal Interface

IPayWebTerminal Interface NFX Class Library

Represents a web terminal for pay systems that tokenize sensitive CC data via a call to provider so that actual CC numbers never touch our servers in a plain form, instead tokens/nonces are supplied back by the provider tokenizer. This is needed for PCI compliance.

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPayWebTerminal
public interface IPayWebTerminal
Public Interface IPayWebTerminal
Public Interface IPayWebTerminal
public interface class IPayWebTerminal
public interface class IPayWebTerminal
type IPayWebTerminal =  interface end
type IPayWebTerminal =  interface end
See Also
IPayWebTerminal Members
NFX.Web.Pay Namespace


IPayWebTerminal Members

IPayWebTerminal Members NFX Class Library

The IPayWebTerminal type exposes the following members.
Methods
 | Name | Description
Public method | GetPayInit | Returns client script body that initializes WAVE.Pay by calling WAVE.Pay.init(...) to perform operation against the provider.
Back to Top
Properties
 | Name | Description
Public property | PaySystem | References pay system that this terminal services
Back to Top
See Also
IPayWebTerminal Interface
NFX.Web.Pay Namespace


IPayWebTerminal Methods

IPayWebTerminal Methods NFX Class Library

The IPayWebTerminal type exposes the following members.
Methods
 | Name | Description
Public method | GetPayInit | Returns client script body that initializes WAVE.Pay by calling WAVE.Pay.init(...) to perform operation against the provider.
Back to Top
See Also
IPayWebTerminal Interface
NFX.Web.Pay Namespace


IPayWebTerminal.GetPayInit Method

IPayWebTerminal GetPayInit Method NFX Class Library

Returns client script body that initializes WAVE.Pay by calling WAVE.Pay.init(...) to perform operation against the provider.

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object GetPayInit()
Object GetPayInit()
Function GetPayInit As Object
Function GetPayInit As Object
Object^ GetPayInit()
Object^ GetPayInit()
abstract GetPayInit : unit -> Object
abstract GetPayInit : unit -> Object

Return Value

Type: Online Object
See Also
IPayWebTerminal Interface
IPayWebTerminal Members
NFX.Web.Pay Namespace


IPayWebTerminal Properties

IPayWebTerminal Properties NFX Class Library

The IPayWebTerminal type exposes the following members.
Properties
 | Name | Description
Public property | PaySystem | References pay system that this terminal services
Back to Top
See Also
IPayWebTerminal Interface
NFX.Web.Pay Namespace


IPayWebTerminal.PaySystem Property

IPayWebTerminal PaySystem Property NFX Class Library

References pay system that this terminal services

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IPaySystem PaySystem { get; }
IPaySystem PaySystem { get; }
ReadOnly Property PaySystem As IPaySystem
    Get
ReadOnly Property PaySystem As IPaySystem
    Get
property IPaySystem^ PaySystem {
    IPaySystem^ get ();
}
property IPaySystem^ PaySystem {
    IPaySystem^ get ();
}
abstract PaySystem : IPaySystem with get
abstract PaySystem : IPaySystem with get

Property Value

Type: IPaySystem
See Also
IPayWebTerminal Interface
IPayWebTerminal Members
NFX.Web.Pay Namespace


PaymentException Class

PaymentException Class NFX Class Library

General NFX payment system specific exception
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Web.Pay PaymentException
NFX.Web.Pay.Mock PaymentMockException
NFX.Web.Pay.Stripe PaymentStripeException

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PaymentException : NFXException
public class PaymentException : NFXException
Public Class PaymentException
    Inherits NFXException
Public Class PaymentException
    Inherits NFXException
public ref class PaymentException : public NFXException
public ref class PaymentException : public NFXException
type PaymentException =
    class
        inherit NFXException
    end
type PaymentException =
    class
        inherit NFXException
    end
See Also
PaymentException Members
NFX.Web.Pay Namespace


PaymentException Members

PaymentException Members NFX Class Library

The PaymentException type exposes the following members.
Constructors
 | Name | Description
Public method | PaymentException | Initializes a new instance of the PaymentException class
Public method | PaymentException(String) | Initializes a new instance of the PaymentException class
Protected method | PaymentException(SerializationInfo, StreamingContext) | Initializes a new instance of the PaymentException class
Public method | PaymentException(String, Exception) | Initializes a new instance of the PaymentException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PaymentException Class
NFX.Web.Pay Namespace


PaymentException Constructor

PaymentException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | PaymentException | Initializes a new instance of the PaymentException class
Public method | PaymentException(String) | Initializes a new instance of the PaymentException class
Protected method | PaymentException(SerializationInfo, StreamingContext) | Initializes a new instance of the PaymentException class
Public method | PaymentException(String, Exception) | Initializes a new instance of the PaymentException class
Back to Top
See Also
PaymentException Class
PaymentException Members
NFX.Web.Pay Namespace


PaymentException Constructor

PaymentException Constructor NFX Class Library

Initializes a new instance of the PaymentException class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PaymentException()
public PaymentException()
Public Sub New
Public Sub New
public:
PaymentException()
public:
PaymentException()
new : unit -> PaymentException
new : unit -> PaymentException
See Also
PaymentException Class
PaymentException Members
PaymentException Overload
NFX.Web.Pay Namespace


PaymentException Constructor (String)

PaymentException Constructor (String) NFX Class Library

Initializes a new instance of the PaymentException class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PaymentException(
    string message
)
public PaymentException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
PaymentException(
    String^ message
)
public:
PaymentException(
    String^ message
)
new :
        message : string -> PaymentException
new :
        message : string -> PaymentException

Parameters

message
Type: Online System String
See Also
PaymentException Class
PaymentException Members
PaymentException Overload
NFX.Web.Pay Namespace


PaymentException Constructor (SerializationInfo, StreamingContext)

PaymentException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PaymentException class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PaymentException(
    SerializationInfo info,
    StreamingContext context
)
protected PaymentException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
PaymentException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
PaymentException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PaymentException
new :
        info : SerializationInfo *
        context : StreamingContext -> PaymentException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
PaymentException Class
PaymentException Members
PaymentException Overload
NFX.Web.Pay Namespace


PaymentException Constructor (String, Exception)

PaymentException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PaymentException class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PaymentException(
    string message,
    Exception inner
)
public PaymentException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
PaymentException(
    String^ message,
    Exception^ inner
)
public:
PaymentException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> PaymentException
new :
        message : string *
        inner : Exception -> PaymentException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
PaymentException Class
PaymentException Members
PaymentException Overload
NFX.Web.Pay Namespace


PaymentException Methods

PaymentException Methods NFX Class Library

The PaymentException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
PaymentException Class
NFX.Web.Pay Namespace


PaymentException Properties

PaymentException Properties NFX Class Library

The PaymentException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PaymentException Class
NFX.Web.Pay Namespace


PaymentException Events

PaymentException Events NFX Class Library

The PaymentException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PaymentException Class
NFX.Web.Pay Namespace


PaySession Class

PaySession Class NFX Class Library

Represents session of PaySystem. All PaySystem operation requires session as mandatory parameter
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Web.Pay PaySession
NFX.Web.Pay.Braintree BraintreeSession
NFX.Web.Pay.Mock MockSession
NFX.Web.Pay.PayPal PayPalSession
NFX.Web.Pay.Stripe StripeSession

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PaySession : DisposableObject,
    INamed
public abstract class PaySession : DisposableObject,
    INamed
Public MustInherit Class PaySession
    Inherits DisposableObject
    Implements INamed
Public MustInherit Class PaySession
    Inherits DisposableObject
    Implements INamed
public ref class PaySession abstract : public DisposableObject,
    INamed
public ref class PaySession abstract : public DisposableObject,
    INamed
[<AbstractClassAttribute>]
type PaySession =
    class
        inherit DisposableObject
        interface INamed
    end
[<AbstractClassAttribute>]
type PaySession =
    class
        inherit DisposableObject
        interface INamed
    end
See Also
PaySession Members
NFX.Web.Pay Namespace


PaySession Members

PaySession Members NFX Class Library

The PaySession type exposes the following members.
Constructors
 | Name | Description
Protected method | PaySession | Initializes a new instance of the PaySession class
Back to Top
Methods
 | Name | Description
Public method | Capture | Has the same semantics as corresponding PaySystem method executed in context of this session
Public method | Charge | Has the same semantics as corresponding PaySystem method executed in context of this session
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FetchAccountData |
Public method | FetchTransaction |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GenerateTransactionID | Generates new transaction ID for desired pay session and transaction type (Charge, Transfer). Context supplies host specific information about this transation i.e. user id
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | Has the same semantics as corresponding PaySystem method executed in context of this session
Public method | Refund | Has the same semantics as corresponding PaySystem method executed in context of this session
Public method | StoreAccountData |
Public method | StoreTransaction |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Transfer | Has the same semantics as corresponding PaySystem method executed in context of this session
Public method | VerifyPotentialTransaction | Has the same semantics as corresponding PaySystem method executed in context of this session
Public method | Void | Has the same semantics as corresponding PaySystem method executed in context of this session
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | ConnectionParameters |
Public field | Context |
Public field | PaySystem |
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | IsValid |
Public property | Name |
Protected property | PaySystemHost |
Public property | User |
Back to Top
See Also
PaySession Class
NFX.Web.Pay Namespace


PaySession Constructor

PaySession Constructor NFX Class Library

Initializes a new instance of the PaySession class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PaySession(
    PaySystem paySystem,
    ConnectionParameters cParams,
    IPaySessionContext context = null
)
protected PaySession(
    PaySystem paySystem,
    ConnectionParameters cParams,
    IPaySessionContext context = null
)
Protected Sub New (
    paySystem As PaySystem,
    cParams As ConnectionParameters,
    Optional context As IPaySessionContext = Nothing
)
Protected Sub New (
    paySystem As PaySystem,
    cParams As ConnectionParameters,
    Optional context As IPaySessionContext = Nothing
)
protected:
PaySession(
    PaySystem^ paySystem,
    ConnectionParameters^ cParams,
    IPaySessionContext^ context = nullptr
)
protected:
PaySession(
    PaySystem^ paySystem,
    ConnectionParameters^ cParams,
    IPaySessionContext^ context = nullptr
)
new :
        paySystem : PaySystem *
        cParams : ConnectionParameters *
        ?context : IPaySessionContext
(* Defaults:
        let _context = defaultArg context null
*)
-> PaySession
new :
        paySystem : PaySystem *
        cParams : ConnectionParameters *
        ?context : IPaySessionContext
(* Defaults:
        let _context = defaultArg context null
*)
-> PaySession

Parameters

paySystem
Type: NFX.Web.Pay PaySystem
cParams
Type: NFX.Web.Pay ConnectionParameters
context (Optional)
Type: NFX.Web.Pay IPaySessionContext
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession Fields

PaySession Fields NFX Class Library

The PaySession type exposes the following members.
Fields
 | Name | Description
Protected field | ConnectionParameters |
Public field | Context |
Public field | PaySystem |
Back to Top
See Also
PaySession Class
NFX.Web.Pay Namespace


PaySession.ConnectionParameters Field

PaySession ConnectionParameters Field NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly ConnectionParameters ConnectionParameters
protected readonly ConnectionParameters ConnectionParameters
Protected ReadOnly ConnectionParameters As ConnectionParameters
Protected ReadOnly ConnectionParameters As ConnectionParameters
protected:
initonly ConnectionParameters^ ConnectionParameters
protected:
initonly ConnectionParameters^ ConnectionParameters
val ConnectionParameters: ConnectionParameters
val ConnectionParameters: ConnectionParameters

Field Value

Type: ConnectionParameters
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.Context Field

PaySession Context Field NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IPaySessionContext Context
public readonly IPaySessionContext Context
Public ReadOnly Context As IPaySessionContext
Public ReadOnly Context As IPaySessionContext
public:
initonly IPaySessionContext^ Context
public:
initonly IPaySessionContext^ Context
val Context: IPaySessionContext
val Context: IPaySessionContext

Field Value

Type: IPaySessionContext
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.PaySystem Field

PaySession PaySystem Field NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly PaySystem PaySystem
public readonly PaySystem PaySystem
Public ReadOnly PaySystem As PaySystem
Public ReadOnly PaySystem As PaySystem
public:
initonly PaySystem^ PaySystem
public:
initonly PaySystem^ PaySystem
val PaySystem: PaySystem
val PaySystem: PaySystem

Field Value

Type: PaySystem
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession Methods

PaySession Methods NFX Class Library

The PaySession type exposes the following members.
Methods
 | Name | Description
Public method | Capture | Has the same semantics as corresponding PaySystem method executed in context of this session
Public method | Charge | Has the same semantics as corresponding PaySystem method executed in context of this session
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FetchAccountData |
Public method | FetchTransaction |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GenerateTransactionID | Generates new transaction ID for desired pay session and transaction type (Charge, Transfer). Context supplies host specific information about this transation i.e. user id
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | Has the same semantics as corresponding PaySystem method executed in context of this session
Public method | Refund | Has the same semantics as corresponding PaySystem method executed in context of this session
Public method | StoreAccountData |
Public method | StoreTransaction |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Transfer | Has the same semantics as corresponding PaySystem method executed in context of this session
Public method | VerifyPotentialTransaction | Has the same semantics as corresponding PaySystem method executed in context of this session
Public method | Void | Has the same semantics as corresponding PaySystem method executed in context of this session
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PaySession Class
NFX.Web.Pay Namespace


PaySession.Capture Method

PaySession Capture Method NFX Class Library

Has the same semantics as corresponding PaySystem method executed in context of this session

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Capture(
    Transaction tran,
    Nullable<decimal> amount = null,
    string description = null,
    Object extraData = null
)
public bool Capture(
    Transaction tran,
    Nullable<decimal> amount = null,
    string description = null,
    Object extraData = null
)
Public Function Capture (
    tran As Transaction,
    Optional amount As Nullable(Of Decimal) = Nothing,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Boolean
Public Function Capture (
    tran As Transaction,
    Optional amount As Nullable(Of Decimal) = Nothing,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Boolean
public:
bool Capture(
    Transaction^ tran,
    Nullable<Decimal> amount = nullptr,
    String^ description = nullptr,
    Object^ extraData = nullptr
)
public:
bool Capture(
    Transaction^ tran,
    Nullable<Decimal> amount = nullptr,
    String^ description = nullptr,
    Object^ extraData = nullptr
)
member Capture :
        tran : Transaction *
        ?amount : Nullable<decimal> *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _amount = defaultArg amount null
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> bool
member Capture :
        tran : Transaction *
        ?amount : Nullable<decimal> *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _amount = defaultArg amount null
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> bool

Parameters

tran
Type: NFX.Web.Pay Transaction
amount (Optional)
Type: Online System Nullable Online Decimal
description (Optional)
Type: Online System String
extraData (Optional)
Type: Online System Object

Return Value

Type: Online Boolean
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.Charge Method

PaySession Charge Method NFX Class Library

Has the same semantics as corresponding PaySystem method executed in context of this session

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Transaction Charge(
    Account from,
    Account to,
    Amount amount,
    bool capture = true,
    string description = null,
    Object extraData = null
)
public Transaction Charge(
    Account from,
    Account to,
    Amount amount,
    bool capture = true,
    string description = null,
    Object extraData = null
)
Public Function Charge (
    from As Account,
    to As Account,
    amount As Amount,
    Optional capture As Boolean = true,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Transaction
Public Function Charge (
    from As Account,
    to As Account,
    amount As Amount,
    Optional capture As Boolean = true,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Transaction
public:
Transaction^ Charge(
    Account from,
    Account to,
    Amount amount,
    bool capture = true,
    String^ description = nullptr,
    Object^ extraData = nullptr
)
public:
Transaction^ Charge(
    Account from,
    Account to,
    Amount amount,
    bool capture = true,
    String^ description = nullptr,
    Object^ extraData = nullptr
)
member Charge :
        from : Account *
        to : Account *
        amount : Amount *
        ?capture : bool *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _capture = defaultArg capture true
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> Transaction
member Charge :
        from : Account *
        to : Account *
        amount : Amount *
        ?capture : bool *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _capture = defaultArg capture true
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> Transaction

Parameters

from
Type: NFX.Web.Pay Account
to
Type: NFX.Web.Pay Account
amount
Type: NFX.Financial Amount
capture (Optional)
Type: Online System Boolean
description (Optional)
Type: Online System String
extraData (Optional)
Type: Online System Object

Return Value

Type: Transaction
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.Destructor Method

PaySession Destructor Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.FetchAccountData Method

PaySession FetchAccountData Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IActualAccountData FetchAccountData(
    Account account
)
public IActualAccountData FetchAccountData(
    Account account
)
Public Function FetchAccountData (
    account As Account
) As IActualAccountData
Public Function FetchAccountData (
    account As Account
) As IActualAccountData
public:
IActualAccountData^ FetchAccountData(
    Account account
)
public:
IActualAccountData^ FetchAccountData(
    Account account
)
member FetchAccountData :
        account : Account -> IActualAccountData
member FetchAccountData :
        account : Account -> IActualAccountData

Parameters

account
Type: NFX.Web.Pay Account

Return Value

Type: IActualAccountData
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.FetchTransaction Method

PaySession FetchTransaction Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Transaction FetchTransaction(
    Object id
)
public Transaction FetchTransaction(
    Object id
)
Public Function FetchTransaction (
    id As Object
) As Transaction
Public Function FetchTransaction (
    id As Object
) As Transaction
public:
Transaction^ FetchTransaction(
    Object^ id
)
public:
Transaction^ FetchTransaction(
    Object^ id
)
member FetchTransaction :
        id : Object -> Transaction
member FetchTransaction :
        id : Object -> Transaction

Parameters

id
Type: Online System Object

Return Value

Type: Transaction
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.GenerateTransactionID Method

PaySession GenerateTransactionID Method NFX Class Library

Generates new transaction ID for desired pay session and transaction type (Charge, Transfer). Context supplies host specific information about this transation i.e. user id

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object GenerateTransactionID(
    TransactionType type
)
public Object GenerateTransactionID(
    TransactionType type
)
Public Function GenerateTransactionID (
    type As TransactionType
) As Object
Public Function GenerateTransactionID (
    type As TransactionType
) As Object
public:
Object^ GenerateTransactionID(
    TransactionType type
)
public:
Object^ GenerateTransactionID(
    TransactionType type
)
member GenerateTransactionID :
        type : TransactionType -> Object
member GenerateTransactionID :
        type : TransactionType -> Object

Parameters

type
Type: NFX.Web.Pay TransactionType

Return Value

Type: Online Object
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.Refresh Method

PaySession Refresh Method NFX Class Library

Has the same semantics as corresponding PaySystem method executed in context of this session

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Refresh(
    Transaction tran
)
public bool Refresh(
    Transaction tran
)
Public Function Refresh (
    tran As Transaction
) As Boolean
Public Function Refresh (
    tran As Transaction
) As Boolean
public:
bool Refresh(
    Transaction^ tran
)
public:
bool Refresh(
    Transaction^ tran
)
member Refresh :
        tran : Transaction -> bool
member Refresh :
        tran : Transaction -> bool

Parameters

tran
Type: NFX.Web.Pay Transaction

Return Value

Type: Online Boolean
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.Refund Method

PaySession Refund Method NFX Class Library

Has the same semantics as corresponding PaySystem method executed in context of this session

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Refund(
    Transaction tran,
    Nullable<decimal> amount = null,
    string description = null,
    Object extraData = null
)
public bool Refund(
    Transaction tran,
    Nullable<decimal> amount = null,
    string description = null,
    Object extraData = null
)
Public Function Refund (
    tran As Transaction,
    Optional amount As Nullable(Of Decimal) = Nothing,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Boolean
Public Function Refund (
    tran As Transaction,
    Optional amount As Nullable(Of Decimal) = Nothing,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Boolean
public:
bool Refund(
    Transaction^ tran,
    Nullable<Decimal> amount = nullptr,
    String^ description = nullptr,
    Object^ extraData = nullptr
)
public:
bool Refund(
    Transaction^ tran,
    Nullable<Decimal> amount = nullptr,
    String^ description = nullptr,
    Object^ extraData = nullptr
)
member Refund :
        tran : Transaction *
        ?amount : Nullable<decimal> *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _amount = defaultArg amount null
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> bool
member Refund :
        tran : Transaction *
        ?amount : Nullable<decimal> *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _amount = defaultArg amount null
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> bool

Parameters

tran
Type: NFX.Web.Pay Transaction
amount (Optional)
Type: Online System Nullable Online Decimal
description (Optional)
Type: Online System String
extraData (Optional)
Type: Online System Object

Return Value

Type: Online Boolean
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.StoreAccountData Method

PaySession StoreAccountData Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void StoreAccountData(
    IActualAccountData accoundData
)
public void StoreAccountData(
    IActualAccountData accoundData
)
Public Sub StoreAccountData (
    accoundData As IActualAccountData
)
Public Sub StoreAccountData (
    accoundData As IActualAccountData
)
public:
void StoreAccountData(
    IActualAccountData^ accoundData
)
public:
void StoreAccountData(
    IActualAccountData^ accoundData
)
member StoreAccountData :
        accoundData : IActualAccountData -> unit
member StoreAccountData :
        accoundData : IActualAccountData -> unit

Parameters

accoundData
Type: NFX.Web.Pay IActualAccountData
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.StoreTransaction Method

PaySession StoreTransaction Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void StoreTransaction(
    Transaction tran
)
public void StoreTransaction(
    Transaction tran
)
Public Sub StoreTransaction (
    tran As Transaction
)
Public Sub StoreTransaction (
    tran As Transaction
)
public:
void StoreTransaction(
    Transaction^ tran
)
public:
void StoreTransaction(
    Transaction^ tran
)
member StoreTransaction :
        tran : Transaction -> unit
member StoreTransaction :
        tran : Transaction -> unit

Parameters

tran
Type: NFX.Web.Pay Transaction
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.Transfer Method

PaySession Transfer Method NFX Class Library

Has the same semantics as corresponding PaySystem method executed in context of this session

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Transaction Transfer(
    Account from,
    Account to,
    Amount amount,
    string description = null,
    Object extraData = null
)
public Transaction Transfer(
    Account from,
    Account to,
    Amount amount,
    string description = null,
    Object extraData = null
)
Public Function Transfer (
    from As Account,
    to As Account,
    amount As Amount,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Transaction
Public Function Transfer (
    from As Account,
    to As Account,
    amount As Amount,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Transaction
public:
Transaction^ Transfer(
    Account from,
    Account to,
    Amount amount,
    String^ description = nullptr,
    Object^ extraData = nullptr
)
public:
Transaction^ Transfer(
    Account from,
    Account to,
    Amount amount,
    String^ description = nullptr,
    Object^ extraData = nullptr
)
member Transfer :
        from : Account *
        to : Account *
        amount : Amount *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> Transaction
member Transfer :
        from : Account *
        to : Account *
        amount : Amount *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> Transaction

Parameters

from
Type: NFX.Web.Pay Account
to
Type: NFX.Web.Pay Account
amount
Type: NFX.Financial Amount
description (Optional)
Type: Online System String
extraData (Optional)
Type: Online System Object

Return Value

Type: Transaction
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.VerifyPotentialTransaction Method

PaySession VerifyPotentialTransaction Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Has the same semantics as corresponding PaySystem method executed in context of this session

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PaymentException VerifyPotentialTransaction(
    TransactionType type,
    Account from,
    Account to,
    Amount amount
)
public PaymentException VerifyPotentialTransaction(
    TransactionType type,
    Account from,
    Account to,
    Amount amount
)
Public Function VerifyPotentialTransaction (
    type As TransactionType,
    from As Account,
    to As Account,
    amount As Amount
) As PaymentException
Public Function VerifyPotentialTransaction (
    type As TransactionType,
    from As Account,
    to As Account,
    amount As Amount
) As PaymentException
public:
PaymentException^ VerifyPotentialTransaction(
    TransactionType type,
    Account from,
    Account to,
    Amount amount
)
public:
PaymentException^ VerifyPotentialTransaction(
    TransactionType type,
    Account from,
    Account to,
    Amount amount
)
member VerifyPotentialTransaction :
        type : TransactionType *
        from : Account *
        to : Account *
        amount : Amount -> PaymentException
member VerifyPotentialTransaction :
        type : TransactionType *
        from : Account *
        to : Account *
        amount : Amount -> PaymentException

Parameters

type
Type: NFX.Web.Pay TransactionType
from
Type: NFX.Web.Pay Account
to
Type: NFX.Web.Pay Account
amount
Type: NFX.Financial Amount

Return Value

Type: PaymentException
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.Void Method

PaySession Void Method NFX Class Library

Has the same semantics as corresponding PaySystem method executed in context of this session

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Void(
    Transaction tran,
    string description = null,
    Object extraData = null
)
public bool Void(
    Transaction tran,
    string description = null,
    Object extraData = null
)
Public Function Void (
    tran As Transaction,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Boolean
Public Function Void (
    tran As Transaction,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Boolean
public:
bool Void(
    Transaction^ tran,
    String^ description = nullptr,
    Object^ extraData = nullptr
)
public:
bool Void(
    Transaction^ tran,
    String^ description = nullptr,
    Object^ extraData = nullptr
)
member Void :
        tran : Transaction *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> bool
member Void :
        tran : Transaction *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> bool

Parameters

tran
Type: NFX.Web.Pay Transaction
description (Optional)
Type: Online System String
extraData (Optional)
Type: Online System Object

Return Value

Type: Online Boolean
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession Properties

PaySession Properties NFX Class Library

The PaySession type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | IsValid |
Public property | Name |
Protected property | PaySystemHost |
Public property | User |
Back to Top
See Also
PaySession Class
NFX.Web.Pay Namespace


PaySession.IsValid Property

PaySession IsValid Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsValid { get; }
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}
public:
property bool IsValid {
    bool get ();
}
member IsValid : bool with get
member IsValid : bool with get

Property Value

Type: Online Boolean
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.Name Property

PaySession Name Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.PaySystemHost Property

PaySession PaySystemHost Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PaySystemHost PaySystemHost { get; }
protected PaySystemHost PaySystemHost { get; }
Protected ReadOnly Property PaySystemHost As PaySystemHost
    Get
Protected ReadOnly Property PaySystemHost As PaySystemHost
    Get
protected:
property PaySystemHost^ PaySystemHost {
    PaySystemHost^ get ();
}
protected:
property PaySystemHost^ PaySystemHost {
    PaySystemHost^ get ();
}
member PaySystemHost : PaySystemHost with get
member PaySystemHost : PaySystemHost with get

Property Value

Type: PaySystemHost
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySession.User Property

PaySession User Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User User { get; internal set; }
public User User { get; internal set; }
Public Property User As User
    Get
    Friend Set
Public Property User As User
    Get
    Friend Set
public:
property User^ User {
    User^ get ();
    internal: void set (User^ value);
}
public:
property User^ User {
    User^ get ();
    internal: void set (User^ value);
}
member User : User with get, internal set
member User : User with get, internal set

Property Value

Type: User
See Also
PaySession Class
PaySession Members
NFX.Web.Pay Namespace


PaySystem Class

PaySystem Class NFX Class Library

Base class for IPaySystemImplementation implementation. Instances of descendants of this class is typically created and configured in PaySystemStarter class. Then particular pay system can be obtained from PaySystem.Instances[PAY_SYSTEM_NAME] indexer
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Online Object
NFX.ServiceModel ServiceWithInstrumentationBase Online Object
NFX.Web.Pay PaySystem
NFX.Web.Pay.Braintree BraintreeSystem
NFX.Web.Pay.Mock MockSystem
NFX.Web.Pay.PayPal PayPalSystem
NFX.Web.Pay PaySystemWithStaticFees
NFX.Web.Pay.Stripe StripeSystem

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PaySystem : ServiceWithInstrumentationBase<Object>,
    IWebClientCaller, IPaySystemImplementation, IPaySystem, INamed, IConfigurable,
    IInstrumentable, IExternallyParameterized
public abstract class PaySystem : ServiceWithInstrumentationBase<Object>,
    IWebClientCaller, IPaySystemImplementation, IPaySystem, INamed, IConfigurable,
    IInstrumentable, IExternallyParameterized
Public MustInherit Class PaySystem
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements IWebClientCaller, IPaySystemImplementation, IPaySystem, INamed,
    IConfigurable, IInstrumentable, IExternallyParameterized
Public MustInherit Class PaySystem
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements IWebClientCaller, IPaySystemImplementation, IPaySystem, INamed,
    IConfigurable, IInstrumentable, IExternallyParameterized
public ref class PaySystem abstract : public ServiceWithInstrumentationBase<Object^>,
    IWebClientCaller, IPaySystemImplementation, IPaySystem, INamed, IConfigurable,
    IInstrumentable, IExternallyParameterized
public ref class PaySystem abstract : public ServiceWithInstrumentationBase<Object^>,
    IWebClientCaller, IPaySystemImplementation, IPaySystem, INamed, IConfigurable,
    IInstrumentable, IExternallyParameterized
[<AbstractClassAttribute>]
type PaySystem =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface IWebClientCaller
        interface IPaySystemImplementation
        interface IPaySystem
        interface INamed
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<AbstractClassAttribute>]
type PaySystem =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface IWebClientCaller
        interface IPaySystemImplementation
        interface IPaySystem
        interface INamed
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
PaySystem Members
NFX.Web.Pay Namespace


PaySystem Members

PaySystem Members NFX Class Library

The PaySystem type exposes the following members.
Constructors
 | Name | Description
Protected method | PaySystem(String, IConfigSectionNode) | Initializes a new instance of the PaySystem class
Protected method | PaySystem(String, IConfigSectionNode, Object) | Initializes a new instance of the PaySystem class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
 | ___SetPaySystemHost | Sets process-global pay system host used to resolve accounts and transactions. If PayStarter is used then the host may be auto-injected from configuration if it is there. Developers: Do not call this method as it is used for dependency injection from system code
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
 | AutoStartSystems | Automatically starts systems designated in config with auto-start attribute
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Overrides Service DoAcceptManagerVisit(Object, DateTime).)
Protected method | DoCapture |
Protected method | DoCharge |
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoRefresh |
Protected method | DoRefund |
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoStartSession |
Protected method | DoTransfer |
Protected method | DoVerifyPotentialTransaction |
Protected method | DoVoid |
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsTransactionTypeSupported |
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Log |
 | Make TPaySystem (String, IConfigSectionNode) |
 | Make TPaySystem (String, String, String) |
Protected method | MakeDefaultSessionConnectParams |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | StartSession | Starts new pay session of system-specific type
Protected method | StatCapture |
Protected method | StatCaptureError |
Protected method | StatCharge |
Protected method | StatChargeError |
Protected method | StatRefund |
Protected method | StatRefundError |
Protected method | StatTransfer |
Protected method | StatTransferError |
Protected method | StatVoid |
Protected method | StatVoidError |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_AUTO_START_ATTR |
 | CONFIG_CURRENCIES_SECTION |
 | CONFIG_CURRENCY_MARKET_SECTION |
 | CONFIG_FEE_FLAT_ATTR |
 | CONFIG_FEE_PCT_ATTR |
 | CONFIG_FEE_TRAN_TYPE_ATTR |
 | CONFIG_PAY_SYSTEM_HOST_SECTION |
 | CONFIG_PAY_SYSTEM_SECTION |
 | CONFIG_PAYMENT_PROCESSING_SECTION |
Protected field | Sessions |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ChargeFeeKind |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | CurrenciesCfg |
Protected property | DefaultSessionConnectParams |
Public property | DefaultSessionConnectParamsCfg |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
 | Instances | Returns the read-only registry view of payment systems currently activated
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
 | IsPaySystemHost |
Public property | KeepAlive |
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | LogLevel | Specifies the log level for operations performed by Pay System.
Public property | Name | Provides textual name for the service (Inherited from Service.)
 | PaySystemHost | Returns process-global pay system host used to resolve accounts and transactions or throws if host is not set. Check IsPaySystemHost to see if host is set. This design provides an indirection level between pay systems (like Stripe, PayPal, Bank etc.) and particular application data store implementation as it decouples system-internal formats of transaction and account storage from provider-internal data (i.e. PayPal payment token string)
Public property | Pipelined |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | SupportedCurrencies |
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransferFeeKind |
Public property | WebServiceCallTimeoutMs |
Public property | WebTerminal |
Back to Top
See Also
PaySystem Class
NFX.Web.Pay Namespace


PaySystem Constructor

PaySystem Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | PaySystem(String, IConfigSectionNode) | Initializes a new instance of the PaySystem class
Protected method | PaySystem(String, IConfigSectionNode, Object) | Initializes a new instance of the PaySystem class
Back to Top
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem Constructor (String, IConfigSectionNode)

PaySystem Constructor (String, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PaySystem class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PaySystem(
    string name,
    IConfigSectionNode node
)
protected PaySystem(
    string name,
    IConfigSectionNode node
)
Protected Sub New (
    name As String,
    node As IConfigSectionNode
)
Protected Sub New (
    name As String,
    node As IConfigSectionNode
)
protected:
PaySystem(
    String^ name,
    IConfigSectionNode^ node
)
protected:
PaySystem(
    String^ name,
    IConfigSectionNode^ node
)
new :
        name : string *
        node : IConfigSectionNode -> PaySystem
new :
        name : string *
        node : IConfigSectionNode -> PaySystem

Parameters

name
Type: Online System String
node
Type: NFX.Environment IConfigSectionNode
See Also
PaySystem Class
PaySystem Members
PaySystem Overload
NFX.Web.Pay Namespace


PaySystem Constructor (String, IConfigSectionNode, Object)

PaySystem Constructor (String, IConfigSectionNode, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PaySystem class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PaySystem(
    string name,
    IConfigSectionNode node,
    Object director
)
protected PaySystem(
    string name,
    IConfigSectionNode node,
    Object director
)
Protected Sub New (
    name As String,
    node As IConfigSectionNode,
    director As Object
)
Protected Sub New (
    name As String,
    node As IConfigSectionNode,
    director As Object
)
protected:
PaySystem(
    String^ name,
    IConfigSectionNode^ node,
    Object^ director
)
protected:
PaySystem(
    String^ name,
    IConfigSectionNode^ node,
    Object^ director
)
new :
        name : string *
        node : IConfigSectionNode *
        director : Object -> PaySystem
new :
        name : string *
        node : IConfigSectionNode *
        director : Object -> PaySystem

Parameters

name
Type: Online System String
node
Type: NFX.Environment IConfigSectionNode
director
Type: Online System Object
See Also
PaySystem Class
PaySystem Members
PaySystem Overload
NFX.Web.Pay Namespace


PaySystem Fields

PaySystem Fields NFX Class Library

The PaySystem type exposes the following members.
Fields
 | Name | Description
 | CONFIG_AUTO_START_ATTR |
 | CONFIG_CURRENCIES_SECTION |
 | CONFIG_CURRENCY_MARKET_SECTION |
 | CONFIG_FEE_FLAT_ATTR |
 | CONFIG_FEE_PCT_ATTR |
 | CONFIG_FEE_TRAN_TYPE_ATTR |
 | CONFIG_PAY_SYSTEM_HOST_SECTION |
 | CONFIG_PAY_SYSTEM_SECTION |
 | CONFIG_PAYMENT_PROCESSING_SECTION |
Protected field | Sessions |
Back to Top
See Also
PaySystem Class
NFX.Web.Pay Namespace


PaySystem.CONFIG_AUTO_START_ATTR Field

PaySystem CONFIG_AUTO_START_ATTR Field NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_AUTO_START_ATTR
public const string CONFIG_AUTO_START_ATTR
Public Const CONFIG_AUTO_START_ATTR As String
Public Const CONFIG_AUTO_START_ATTR As String
public:
literal String^ CONFIG_AUTO_START_ATTR
public:
literal String^ CONFIG_AUTO_START_ATTR
static val mutable CONFIG_AUTO_START_ATTR: string
static val mutable CONFIG_AUTO_START_ATTR: string

Field Value

Type: Online String
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.CONFIG_CURRENCIES_SECTION Field

PaySystem CONFIG_CURRENCIES_SECTION Field NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CURRENCIES_SECTION
public const string CONFIG_CURRENCIES_SECTION
Public Const CONFIG_CURRENCIES_SECTION As String
Public Const CONFIG_CURRENCIES_SECTION As String
public:
literal String^ CONFIG_CURRENCIES_SECTION
public:
literal String^ CONFIG_CURRENCIES_SECTION
static val mutable CONFIG_CURRENCIES_SECTION: string
static val mutable CONFIG_CURRENCIES_SECTION: string

Field Value

Type: Online String
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.CONFIG_CURRENCY_MARKET_SECTION Field

PaySystem CONFIG_CURRENCY_MARKET_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CURRENCY_MARKET_SECTION
public const string CONFIG_CURRENCY_MARKET_SECTION
Public Const CONFIG_CURRENCY_MARKET_SECTION As String
Public Const CONFIG_CURRENCY_MARKET_SECTION As String
public:
literal String^ CONFIG_CURRENCY_MARKET_SECTION
public:
literal String^ CONFIG_CURRENCY_MARKET_SECTION
static val mutable CONFIG_CURRENCY_MARKET_SECTION: string
static val mutable CONFIG_CURRENCY_MARKET_SECTION: string

Field Value

Type: Online String
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.CONFIG_FEE_FLAT_ATTR Field

PaySystem CONFIG_FEE_FLAT_ATTR Field NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FEE_FLAT_ATTR
public const string CONFIG_FEE_FLAT_ATTR
Public Const CONFIG_FEE_FLAT_ATTR As String
Public Const CONFIG_FEE_FLAT_ATTR As String
public:
literal String^ CONFIG_FEE_FLAT_ATTR
public:
literal String^ CONFIG_FEE_FLAT_ATTR
static val mutable CONFIG_FEE_FLAT_ATTR: string
static val mutable CONFIG_FEE_FLAT_ATTR: string

Field Value

Type: Online String
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.CONFIG_FEE_PCT_ATTR Field

PaySystem CONFIG_FEE_PCT_ATTR Field NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FEE_PCT_ATTR
public const string CONFIG_FEE_PCT_ATTR
Public Const CONFIG_FEE_PCT_ATTR As String
Public Const CONFIG_FEE_PCT_ATTR As String
public:
literal String^ CONFIG_FEE_PCT_ATTR
public:
literal String^ CONFIG_FEE_PCT_ATTR
static val mutable CONFIG_FEE_PCT_ATTR: string
static val mutable CONFIG_FEE_PCT_ATTR: string

Field Value

Type: Online String
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.CONFIG_FEE_TRAN_TYPE_ATTR Field

PaySystem CONFIG_FEE_TRAN_TYPE_ATTR Field NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FEE_TRAN_TYPE_ATTR
public const string CONFIG_FEE_TRAN_TYPE_ATTR
Public Const CONFIG_FEE_TRAN_TYPE_ATTR As String
Public Const CONFIG_FEE_TRAN_TYPE_ATTR As String
public:
literal String^ CONFIG_FEE_TRAN_TYPE_ATTR
public:
literal String^ CONFIG_FEE_TRAN_TYPE_ATTR
static val mutable CONFIG_FEE_TRAN_TYPE_ATTR: string
static val mutable CONFIG_FEE_TRAN_TYPE_ATTR: string

Field Value

Type: Online String
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.CONFIG_PAY_SYSTEM_HOST_SECTION Field

PaySystem CONFIG_PAY_SYSTEM_HOST_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PAY_SYSTEM_HOST_SECTION
public const string CONFIG_PAY_SYSTEM_HOST_SECTION
Public Const CONFIG_PAY_SYSTEM_HOST_SECTION As String
Public Const CONFIG_PAY_SYSTEM_HOST_SECTION As String
public:
literal String^ CONFIG_PAY_SYSTEM_HOST_SECTION
public:
literal String^ CONFIG_PAY_SYSTEM_HOST_SECTION
static val mutable CONFIG_PAY_SYSTEM_HOST_SECTION: string
static val mutable CONFIG_PAY_SYSTEM_HOST_SECTION: string

Field Value

Type: Online String
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.CONFIG_PAY_SYSTEM_SECTION Field

PaySystem CONFIG_PAY_SYSTEM_SECTION Field NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PAY_SYSTEM_SECTION
public const string CONFIG_PAY_SYSTEM_SECTION
Public Const CONFIG_PAY_SYSTEM_SECTION As String
Public Const CONFIG_PAY_SYSTEM_SECTION As String
public:
literal String^ CONFIG_PAY_SYSTEM_SECTION
public:
literal String^ CONFIG_PAY_SYSTEM_SECTION
static val mutable CONFIG_PAY_SYSTEM_SECTION: string
static val mutable CONFIG_PAY_SYSTEM_SECTION: string

Field Value

Type: Online String
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.CONFIG_PAYMENT_PROCESSING_SECTION Field

PaySystem CONFIG_PAYMENT_PROCESSING_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PAYMENT_PROCESSING_SECTION
public const string CONFIG_PAYMENT_PROCESSING_SECTION
Public Const CONFIG_PAYMENT_PROCESSING_SECTION As String
Public Const CONFIG_PAYMENT_PROCESSING_SECTION As String
public:
literal String^ CONFIG_PAYMENT_PROCESSING_SECTION
public:
literal String^ CONFIG_PAYMENT_PROCESSING_SECTION
static val mutable CONFIG_PAYMENT_PROCESSING_SECTION: string
static val mutable CONFIG_PAYMENT_PROCESSING_SECTION: string

Field Value

Type: Online String
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.Sessions Field

PaySystem Sessions Field NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal readonly List<PaySession> Sessions
protected internal readonly List<PaySession> Sessions
Protected Friend ReadOnly Sessions As List(Of PaySession)
Protected Friend ReadOnly Sessions As List(Of PaySession)
protected public:
initonly List<PaySession^>^ Sessions
protected public:
initonly List<PaySession^>^ Sessions
val Sessions: List<PaySession>
val Sessions: List<PaySession>

Field Value

Type: Online List PaySession
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem Methods

PaySystem Methods NFX Class Library

The PaySystem type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
 | ___SetPaySystemHost | Sets process-global pay system host used to resolve accounts and transactions. If PayStarter is used then the host may be auto-injected from configuration if it is there. Developers: Do not call this method as it is used for dependency injection from system code
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
 | AutoStartSystems | Automatically starts systems designated in config with auto-start attribute
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Overrides Service DoAcceptManagerVisit(Object, DateTime).)
Protected method | DoCapture |
Protected method | DoCharge |
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoRefresh |
Protected method | DoRefund |
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoStartSession |
Protected method | DoTransfer |
Protected method | DoVerifyPotentialTransaction |
Protected method | DoVoid |
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsTransactionTypeSupported |
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Log |
 | Make TPaySystem (String, IConfigSectionNode) |
 | Make TPaySystem (String, String, String) |
Protected method | MakeDefaultSessionConnectParams |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | StartSession | Starts new pay session of system-specific type
Protected method | StatCapture |
Protected method | StatCaptureError |
Protected method | StatCharge |
Protected method | StatChargeError |
Protected method | StatRefund |
Protected method | StatRefundError |
Protected method | StatTransfer |
Protected method | StatTransferError |
Protected method | StatVoid |
Protected method | StatVoidError |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PaySystem Class
NFX.Web.Pay Namespace


PaySystem.___SetPaySystemHost Method

PaySystem ___SetPaySystemHost Method NFX Class Library

Sets process-global pay system host used to resolve accounts and transactions. If PayStarter is used then the host may be auto-injected from configuration if it is there. Developers: Do not call this method as it is used for dependency injection from system code

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ___SetPaySystemHost(
    IPaySystemHostImplementation host
)
public static void ___SetPaySystemHost(
    IPaySystemHostImplementation host
)
Public Shared Sub ___SetPaySystemHost (
    host As IPaySystemHostImplementation
)
Public Shared Sub ___SetPaySystemHost (
    host As IPaySystemHostImplementation
)
public:
static void ___SetPaySystemHost(
    IPaySystemHostImplementation^ host
)
public:
static void ___SetPaySystemHost(
    IPaySystemHostImplementation^ host
)
static member ___SetPaySystemHost :
        host : IPaySystemHostImplementation -> unit
static member ___SetPaySystemHost :
        host : IPaySystemHostImplementation -> unit

Parameters

host
Type: NFX.Web.Pay IPaySystemHostImplementation
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.AutoStartSystems Method

PaySystem AutoStartSystems Method NFX Class Library

Automatically starts systems designated in config with auto-start attribute

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AutoStartSystems()
public static void AutoStartSystems()
Public Shared Sub AutoStartSystems
Public Shared Sub AutoStartSystems
public:
static void AutoStartSystems()
public:
static void AutoStartSystems()
static member AutoStartSystems : unit -> unit
static member AutoStartSystems : unit -> unit
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.Destructor Method

PaySystem Destructor Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.DoAcceptManagerVisit Method

PaySystem DoAcceptManagerVisit Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoAcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
protected override void DoAcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
Protected Overrides Sub DoAcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
Protected Overrides Sub DoAcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
protected:
virtual void DoAcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
) override
protected:
virtual void DoAcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
) override
abstract DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
override DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
abstract DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
override DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit

Parameters

manager
Type: Online System Object
managerNow
Type: Online System DateTime
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.DoCapture Method

PaySystem DoCapture Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract bool DoCapture(
    PaySession session,
    Transaction charge,
    Nullable<decimal> amount = null,
    string description = null,
    Object extraData = null
)
protected internal abstract bool DoCapture(
    PaySession session,
    Transaction charge,
    Nullable<decimal> amount = null,
    string description = null,
    Object extraData = null
)
Protected Friend MustOverride Function DoCapture (
    session As PaySession,
    charge As Transaction,
    Optional amount As Nullable(Of Decimal) = Nothing,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Boolean
Protected Friend MustOverride Function DoCapture (
    session As PaySession,
    charge As Transaction,
    Optional amount As Nullable(Of Decimal) = Nothing,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Boolean
protected public:
virtual bool DoCapture(
    PaySession^ session,
    Transaction^ charge,
    Nullable<Decimal> amount = nullptr,
    String^ description = nullptr,
    Object^ extraData = nullptr
) abstract
protected public:
virtual bool DoCapture(
    PaySession^ session,
    Transaction^ charge,
    Nullable<Decimal> amount = nullptr,
    String^ description = nullptr,
    Object^ extraData = nullptr
) abstract
abstract DoCapture :
        session : PaySession *
        charge : Transaction *
        ?amount : Nullable<decimal> *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _amount = defaultArg amount null
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> bool
abstract DoCapture :
        session : PaySession *
        charge : Transaction *
        ?amount : Nullable<decimal> *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _amount = defaultArg amount null
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> bool

Parameters

session
Type: NFX.Web.Pay PaySession
charge
Type: NFX.Web.Pay Transaction
amount (Optional)
Type: Online System Nullable Online Decimal
description (Optional)
Type: Online System String
extraData (Optional)
Type: Online System Object

Return Value

Type: Online Boolean
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.DoCharge Method

PaySystem DoCharge Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract Transaction DoCharge(
    PaySession session,
    Account from,
    Account to,
    Amount amount,
    bool capture = true,
    string description = null,
    Object extraData = null
)
protected internal abstract Transaction DoCharge(
    PaySession session,
    Account from,
    Account to,
    Amount amount,
    bool capture = true,
    string description = null,
    Object extraData = null
)
Protected Friend MustOverride Function DoCharge (
    session As PaySession,
    from As Account,
    to As Account,
    amount As Amount,
    Optional capture As Boolean = true,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Transaction
Protected Friend MustOverride Function DoCharge (
    session As PaySession,
    from As Account,
    to As Account,
    amount As Amount,
    Optional capture As Boolean = true,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Transaction
protected public:
virtual Transaction^ DoCharge(
    PaySession^ session,
    Account from,
    Account to,
    Amount amount,
    bool capture = true,
    String^ description = nullptr,
    Object^ extraData = nullptr
) abstract
protected public:
virtual Transaction^ DoCharge(
    PaySession^ session,
    Account from,
    Account to,
    Amount amount,
    bool capture = true,
    String^ description = nullptr,
    Object^ extraData = nullptr
) abstract
abstract DoCharge :
        session : PaySession *
        from : Account *
        to : Account *
        amount : Amount *
        ?capture : bool *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _capture = defaultArg capture true
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> Transaction
abstract DoCharge :
        session : PaySession *
        from : Account *
        to : Account *
        amount : Amount *
        ?capture : bool *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _capture = defaultArg capture true
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> Transaction

Parameters

session
Type: NFX.Web.Pay PaySession
from
Type: NFX.Web.Pay Account
to
Type: NFX.Web.Pay Account
amount
Type: NFX.Financial Amount
capture (Optional)
Type: Online System Boolean
description (Optional)
Type: Online System String
extraData (Optional)
Type: Online System Object

Return Value

Type: Transaction
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.DoConfigure Method

PaySystem DoConfigure Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.DoRefresh Method

PaySystem DoRefresh Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual bool DoRefresh(
    PaySession session,
    Transaction transaction,
    Object extraData = null
)
protected internal virtual bool DoRefresh(
    PaySession session,
    Transaction transaction,
    Object extraData = null
)
Protected Friend Overridable Function DoRefresh (
    session As PaySession,
    transaction As Transaction,
    Optional extraData As Object = Nothing
) As Boolean
Protected Friend Overridable Function DoRefresh (
    session As PaySession,
    transaction As Transaction,
    Optional extraData As Object = Nothing
) As Boolean
protected public:
virtual bool DoRefresh(
    PaySession^ session,
    Transaction^ transaction,
    Object^ extraData = nullptr
)
protected public:
virtual bool DoRefresh(
    PaySession^ session,
    Transaction^ transaction,
    Object^ extraData = nullptr
)
abstract DoRefresh :
        session : PaySession *
        transaction : Transaction *
        ?extraData : Object
(* Defaults:
        let _extraData = defaultArg extraData null
*)
-> bool
override DoRefresh :
        session : PaySession *
        transaction : Transaction *
        ?extraData : Object
(* Defaults:
        let _extraData = defaultArg extraData null
*)
-> bool
abstract DoRefresh :
        session : PaySession *
        transaction : Transaction *
        ?extraData : Object
(* Defaults:
        let _extraData = defaultArg extraData null
*)
-> bool
override DoRefresh :
        session : PaySession *
        transaction : Transaction *
        ?extraData : Object
(* Defaults:
        let _extraData = defaultArg extraData null
*)
-> bool

Parameters

session
Type: NFX.Web.Pay PaySession
transaction
Type: NFX.Web.Pay Transaction
extraData (Optional)
Type: Online System Object

Return Value

Type: Online Boolean
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.DoRefund Method

PaySystem DoRefund Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract bool DoRefund(
    PaySession session,
    Transaction charge,
    Nullable<decimal> amount = null,
    string description = null,
    Object extraData = null
)
protected internal abstract bool DoRefund(
    PaySession session,
    Transaction charge,
    Nullable<decimal> amount = null,
    string description = null,
    Object extraData = null
)
Protected Friend MustOverride Function DoRefund (
    session As PaySession,
    charge As Transaction,
    Optional amount As Nullable(Of Decimal) = Nothing,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Boolean
Protected Friend MustOverride Function DoRefund (
    session As PaySession,
    charge As Transaction,
    Optional amount As Nullable(Of Decimal) = Nothing,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Boolean
protected public:
virtual bool DoRefund(
    PaySession^ session,
    Transaction^ charge,
    Nullable<Decimal> amount = nullptr,
    String^ description = nullptr,
    Object^ extraData = nullptr
) abstract
protected public:
virtual bool DoRefund(
    PaySession^ session,
    Transaction^ charge,
    Nullable<Decimal> amount = nullptr,
    String^ description = nullptr,
    Object^ extraData = nullptr
) abstract
abstract DoRefund :
        session : PaySession *
        charge : Transaction *
        ?amount : Nullable<decimal> *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _amount = defaultArg amount null
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> bool
abstract DoRefund :
        session : PaySession *
        charge : Transaction *
        ?amount : Nullable<decimal> *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _amount = defaultArg amount null
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> bool

Parameters

session
Type: NFX.Web.Pay PaySession
charge
Type: NFX.Web.Pay Transaction
amount (Optional)
Type: Online System Nullable Online Decimal
description (Optional)
Type: Online System String
extraData (Optional)
Type: Online System Object

Return Value

Type: Online Boolean
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.DoStart Method

PaySystem DoStart Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.DoStartSession Method

PaySystem DoStartSession Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract PaySession DoStartSession(
    ConnectionParameters cParams,
    IPaySessionContext context = null
)
protected abstract PaySession DoStartSession(
    ConnectionParameters cParams,
    IPaySessionContext context = null
)
Protected MustOverride Function DoStartSession (
    cParams As ConnectionParameters,
    Optional context As IPaySessionContext = Nothing
) As PaySession
Protected MustOverride Function DoStartSession (
    cParams As ConnectionParameters,
    Optional context As IPaySessionContext = Nothing
) As PaySession
protected:
virtual PaySession^ DoStartSession(
    ConnectionParameters^ cParams,
    IPaySessionContext^ context = nullptr
) abstract
protected:
virtual PaySession^ DoStartSession(
    ConnectionParameters^ cParams,
    IPaySessionContext^ context = nullptr
) abstract
abstract DoStartSession :
        cParams : ConnectionParameters *
        ?context : IPaySessionContext
(* Defaults:
        let _context = defaultArg context null
*)
-> PaySession
abstract DoStartSession :
        cParams : ConnectionParameters *
        ?context : IPaySessionContext
(* Defaults:
        let _context = defaultArg context null
*)
-> PaySession

Parameters

cParams
Type: NFX.Web.Pay ConnectionParameters
context (Optional)
Type: NFX.Web.Pay IPaySessionContext

Return Value

Type: PaySession
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.DoTransfer Method

PaySystem DoTransfer Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract Transaction DoTransfer(
    PaySession session,
    Account from,
    Account to,
    Amount amount,
    string description = null,
    Object extraData = null
)
protected internal abstract Transaction DoTransfer(
    PaySession session,
    Account from,
    Account to,
    Amount amount,
    string description = null,
    Object extraData = null
)
Protected Friend MustOverride Function DoTransfer (
    session As PaySession,
    from As Account,
    to As Account,
    amount As Amount,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Transaction
Protected Friend MustOverride Function DoTransfer (
    session As PaySession,
    from As Account,
    to As Account,
    amount As Amount,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Transaction
protected public:
virtual Transaction^ DoTransfer(
    PaySession^ session,
    Account from,
    Account to,
    Amount amount,
    String^ description = nullptr,
    Object^ extraData = nullptr
) abstract
protected public:
virtual Transaction^ DoTransfer(
    PaySession^ session,
    Account from,
    Account to,
    Amount amount,
    String^ description = nullptr,
    Object^ extraData = nullptr
) abstract
abstract DoTransfer :
        session : PaySession *
        from : Account *
        to : Account *
        amount : Amount *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> Transaction
abstract DoTransfer :
        session : PaySession *
        from : Account *
        to : Account *
        amount : Amount *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> Transaction

Parameters

session
Type: NFX.Web.Pay PaySession
from
Type: NFX.Web.Pay Account
to
Type: NFX.Web.Pay Account
amount
Type: NFX.Financial Amount
description (Optional)
Type: Online System String
extraData (Optional)
Type: Online System Object

Return Value

Type: Transaction
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.DoVerifyPotentialTransaction Method

PaySystem DoVerifyPotentialTransaction Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual PaymentException DoVerifyPotentialTransaction(
    PaySession session,
    TransactionType type,
    Account from,
    Account to,
    Amount amount
)
protected internal virtual PaymentException DoVerifyPotentialTransaction(
    PaySession session,
    TransactionType type,
    Account from,
    Account to,
    Amount amount
)
Protected Friend Overridable Function DoVerifyPotentialTransaction (
    session As PaySession,
    type As TransactionType,
    from As Account,
    to As Account,
    amount As Amount
) As PaymentException
Protected Friend Overridable Function DoVerifyPotentialTransaction (
    session As PaySession,
    type As TransactionType,
    from As Account,
    to As Account,
    amount As Amount
) As PaymentException
protected public:
virtual PaymentException^ DoVerifyPotentialTransaction(
    PaySession^ session,
    TransactionType type,
    Account from,
    Account to,
    Amount amount
)
protected public:
virtual PaymentException^ DoVerifyPotentialTransaction(
    PaySession^ session,
    TransactionType type,
    Account from,
    Account to,
    Amount amount
)
abstract DoVerifyPotentialTransaction :
        session : PaySession *
        type : TransactionType *
        from : Account *
        to : Account *
        amount : Amount -> PaymentException
override DoVerifyPotentialTransaction :
        session : PaySession *
        type : TransactionType *
        from : Account *
        to : Account *
        amount : Amount -> PaymentException
abstract DoVerifyPotentialTransaction :
        session : PaySession *
        type : TransactionType *
        from : Account *
        to : Account *
        amount : Amount -> PaymentException
override DoVerifyPotentialTransaction :
        session : PaySession *
        type : TransactionType *
        from : Account *
        to : Account *
        amount : Amount -> PaymentException

Parameters

session
Type: NFX.Web.Pay PaySession
type
Type: NFX.Web.Pay TransactionType
from
Type: NFX.Web.Pay Account
to
Type: NFX.Web.Pay Account
amount
Type: NFX.Financial Amount

Return Value

Type: PaymentException
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.DoVoid Method

PaySystem DoVoid Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract bool DoVoid(
    PaySession session,
    Transaction charge,
    string description = null,
    Object extraData = null
)
protected internal abstract bool DoVoid(
    PaySession session,
    Transaction charge,
    string description = null,
    Object extraData = null
)
Protected Friend MustOverride Function DoVoid (
    session As PaySession,
    charge As Transaction,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Boolean
Protected Friend MustOverride Function DoVoid (
    session As PaySession,
    charge As Transaction,
    Optional description As String = Nothing,
    Optional extraData As Object = Nothing
) As Boolean
protected public:
virtual bool DoVoid(
    PaySession^ session,
    Transaction^ charge,
    String^ description = nullptr,
    Object^ extraData = nullptr
) abstract
protected public:
virtual bool DoVoid(
    PaySession^ session,
    Transaction^ charge,
    String^ description = nullptr,
    Object^ extraData = nullptr
) abstract
abstract DoVoid :
        session : PaySession *
        charge : Transaction *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> bool
abstract DoVoid :
        session : PaySession *
        charge : Transaction *
        ?description : string *
        ?extraData : Object
(* Defaults:
        let _description = defaultArg description null
        let _extraData = defaultArg extraData null
*)
-> bool

Parameters

session
Type: NFX.Web.Pay PaySession
charge
Type: NFX.Web.Pay Transaction
description (Optional)
Type: Online System String
extraData (Optional)
Type: Online System Object

Return Value

Type: Online Boolean
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.DoWaitForCompleteStop Method

PaySystem DoWaitForCompleteStop Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.IsTransactionTypeSupported Method

PaySystem IsTransactionTypeSupported Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsTransactionTypeSupported(
    TransactionType type,
    string currencyISO = null
)
public virtual bool IsTransactionTypeSupported(
    TransactionType type,
    string currencyISO = null
)
Public Overridable Function IsTransactionTypeSupported (
    type As TransactionType,
    Optional currencyISO As String = Nothing
) As Boolean
Public Overridable Function IsTransactionTypeSupported (
    type As TransactionType,
    Optional currencyISO As String = Nothing
) As Boolean
public:
virtual bool IsTransactionTypeSupported(
    TransactionType type,
    String^ currencyISO = nullptr
)
public:
virtual bool IsTransactionTypeSupported(
    TransactionType type,
    String^ currencyISO = nullptr
)
abstract IsTransactionTypeSupported :
        type : TransactionType *
        ?currencyISO : string
(* Defaults:
        let _currencyISO = defaultArg currencyISO null
*)
-> bool
override IsTransactionTypeSupported :
        type : TransactionType *
        ?currencyISO : string
(* Defaults:
        let _currencyISO = defaultArg currencyISO null
*)
-> bool
abstract IsTransactionTypeSupported :
        type : TransactionType *
        ?currencyISO : string
(* Defaults:
        let _currencyISO = defaultArg currencyISO null
*)
-> bool
override IsTransactionTypeSupported :
        type : TransactionType *
        ?currencyISO : string
(* Defaults:
        let _currencyISO = defaultArg currencyISO null
*)
-> bool

Parameters

type
Type: NFX.Web.Pay TransactionType
currencyISO (Optional)
Type: Online System String

Return Value

Type: Online Boolean

Implements

IPaySystem IsTransactionTypeSupported(TransactionType, String)
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.Log Method

PaySystem Log Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Guid Log(
    MessageType type,
    string from,
    string message,
    Exception error = null,
    Nullable<Guid> relatedMessageID = null,
    string parameters = null
)
protected Guid Log(
    MessageType type,
    string from,
    string message,
    Exception error = null,
    Nullable<Guid> relatedMessageID = null,
    string parameters = null
)
Protected Function Log (
    type As MessageType,
    from As String,
    message As String,
    Optional error As Exception = Nothing,
    Optional relatedMessageID As Nullable(Of Guid) = Nothing,
    Optional parameters As String = Nothing
) As Guid
Protected Function Log (
    type As MessageType,
    from As String,
    message As String,
    Optional error As Exception = Nothing,
    Optional relatedMessageID As Nullable(Of Guid) = Nothing,
    Optional parameters As String = Nothing
) As Guid
protected:
Guid Log(
    MessageType type,
    String^ from,
    String^ message,
    Exception^ error = nullptr,
    Nullable<Guid> relatedMessageID = nullptr,
    String^ parameters = nullptr
)
protected:
Guid Log(
    MessageType type,
    String^ from,
    String^ message,
    Exception^ error = nullptr,
    Nullable<Guid> relatedMessageID = nullptr,
    String^ parameters = nullptr
)
member Log :
        type : MessageType *
        from : string *
        message : string *
        ?error : Exception *
        ?relatedMessageID : Nullable<Guid> *
        ?parameters : string
(* Defaults:
        let _error = defaultArg error null
        let _relatedMessageID = defaultArg relatedMessageID null
        let _parameters = defaultArg parameters null
*)
-> Guid
member Log :
        type : MessageType *
        from : string *
        message : string *
        ?error : Exception *
        ?relatedMessageID : Nullable<Guid> *
        ?parameters : string
(* Defaults:
        let _error = defaultArg error null
        let _relatedMessageID = defaultArg relatedMessageID null
        let _parameters = defaultArg parameters null
*)
-> Guid

Parameters

type
Type: NFX.Log MessageType
from
Type: Online System String
message
Type: Online System String
error (Optional)
Type: Online System Exception
relatedMessageID (Optional)
Type: Online System Nullable Online Guid
parameters (Optional)
Type: Online System String

Return Value

Type: Online Guid
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.Make Method

PaySystem Make Method NFX Class Library

Overload List
Name | Description
Make TPaySystem (String, IConfigSectionNode) |
Make TPaySystem (String, String, String) |
Back to Top
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.Make(TPaySystem) Method (String, IConfigSectionNode)

PaySystem Make TPaySystem Method (String, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TPaySystem Make<TPaySystem>(
    string name,
    IConfigSectionNode node
)
where TPaySystem : PaySystem
public static TPaySystem Make<TPaySystem>(
    string name,
    IConfigSectionNode node
)
where TPaySystem : PaySystem
Public Shared Function Make(Of TPaySystem As PaySystem) (
    name As String,
    node As IConfigSectionNode
) As TPaySystem
Public Shared Function Make(Of TPaySystem As PaySystem) (
    name As String,
    node As IConfigSectionNode
) As TPaySystem
public:
generic<typename TPaySystem>
where TPaySystem : PaySystem
static TPaySystem Make(
    String^ name,
    IConfigSectionNode^ node
)
public:
generic<typename TPaySystem>
where TPaySystem : PaySystem
static TPaySystem Make(
    String^ name,
    IConfigSectionNode^ node
)
static member Make :
        name : string *
        node : IConfigSectionNode -> 'TPaySystem  when 'TPaySystem : PaySystem
static member Make :
        name : string *
        node : IConfigSectionNode -> 'TPaySystem  when 'TPaySystem : PaySystem

Parameters

name
Type: Online System String
node
Type: NFX.Environment IConfigSectionNode
Type Parameters
TPaySystem

Return Value

Type: TPaySystem
See Also
PaySystem Class
PaySystem Members
Make Overload
NFX.Web.Pay Namespace


PaySystem.Make(TPaySystem) Method (String, String, String)

PaySystem Make TPaySystem Method (String, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TPaySystem Make<TPaySystem>(
    string name,
    string cfgStr,
    string format = "laconf"
)
where TPaySystem : PaySystem
public static TPaySystem Make<TPaySystem>(
    string name,
    string cfgStr,
    string format = "laconf"
)
where TPaySystem : PaySystem
Public Shared Function Make(Of TPaySystem As PaySystem) (
    name As String,
    cfgStr As String,
    Optional format As String = "laconf"
) As TPaySystem
Public Shared Function Make(Of TPaySystem As PaySystem) (
    name As String,
    cfgStr As String,
    Optional format As String = "laconf"
) As TPaySystem
public:
generic<typename TPaySystem>
where TPaySystem : PaySystem
static TPaySystem Make(
    String^ name,
    String^ cfgStr,
    String^ format = L"laconf"
)
public:
generic<typename TPaySystem>
where TPaySystem : PaySystem
static TPaySystem Make(
    String^ name,
    String^ cfgStr,
    String^ format = L"laconf"
)
static member Make :
        name : string *
        cfgStr : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> 'TPaySystem  when 'TPaySystem : PaySystem
static member Make :
        name : string *
        cfgStr : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> 'TPaySystem  when 'TPaySystem : PaySystem

Parameters

name
Type: Online System String
cfgStr
Type: Online System String
format (Optional)
Type: Online System String
Type Parameters
TPaySystem

Return Value

Type: TPaySystem
See Also
PaySystem Class
PaySystem Members
Make Overload
NFX.Web.Pay Namespace


PaySystem.MakeDefaultSessionConnectParams Method

PaySystem MakeDefaultSessionConnectParams Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract ConnectionParameters MakeDefaultSessionConnectParams(
    IConfigSectionNode paramsSection
)
protected abstract ConnectionParameters MakeDefaultSessionConnectParams(
    IConfigSectionNode paramsSection
)
Protected MustOverride Function MakeDefaultSessionConnectParams (
    paramsSection As IConfigSectionNode
) As ConnectionParameters
Protected MustOverride Function MakeDefaultSessionConnectParams (
    paramsSection As IConfigSectionNode
) As ConnectionParameters
protected:
virtual ConnectionParameters^ MakeDefaultSessionConnectParams(
    IConfigSectionNode^ paramsSection
) abstract
protected:
virtual ConnectionParameters^ MakeDefaultSessionConnectParams(
    IConfigSectionNode^ paramsSection
) abstract
abstract MakeDefaultSessionConnectParams :
        paramsSection : IConfigSectionNode -> ConnectionParameters
abstract MakeDefaultSessionConnectParams :
        paramsSection : IConfigSectionNode -> ConnectionParameters

Parameters

paramsSection
Type: NFX.Environment IConfigSectionNode

Return Value

Type: ConnectionParameters
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.StartSession Method

PaySystem StartSession Method NFX Class Library

Starts new pay session of system-specific type

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PaySession StartSession(
    ConnectionParameters cParams = null,
    IPaySessionContext context = null
)
public PaySession StartSession(
    ConnectionParameters cParams = null,
    IPaySessionContext context = null
)
Public Function StartSession (
    Optional cParams As ConnectionParameters = Nothing,
    Optional context As IPaySessionContext = Nothing
) As PaySession
Public Function StartSession (
    Optional cParams As ConnectionParameters = Nothing,
    Optional context As IPaySessionContext = Nothing
) As PaySession
public:
virtual PaySession^ StartSession(
    ConnectionParameters^ cParams = nullptr,
    IPaySessionContext^ context = nullptr
) sealed
public:
virtual PaySession^ StartSession(
    ConnectionParameters^ cParams = nullptr,
    IPaySessionContext^ context = nullptr
) sealed
abstract StartSession :
        ?cParams : ConnectionParameters *
        ?context : IPaySessionContext
(* Defaults:
        let _cParams = defaultArg cParams null
        let _context = defaultArg context null
*)
-> PaySession
override StartSession :
        ?cParams : ConnectionParameters *
        ?context : IPaySessionContext
(* Defaults:
        let _cParams = defaultArg cParams null
        let _context = defaultArg context null
*)
-> PaySession
abstract StartSession :
        ?cParams : ConnectionParameters *
        ?context : IPaySessionContext
(* Defaults:
        let _cParams = defaultArg cParams null
        let _context = defaultArg context null
*)
-> PaySession
override StartSession :
        ?cParams : ConnectionParameters *
        ?context : IPaySessionContext
(* Defaults:
        let _cParams = defaultArg cParams null
        let _context = defaultArg context null
*)
-> PaySession

Parameters

cParams (Optional)
Type: NFX.Web.Pay ConnectionParameters
context (Optional)
Type: NFX.Web.Pay IPaySessionContext

Return Value

Type: PaySession

Implements

IPaySystem StartSession(ConnectionParameters, IPaySessionContext)
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.StatCapture Method

PaySystem StatCapture Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void StatCapture(
    Transaction charge,
    Nullable<decimal> amount
)
protected void StatCapture(
    Transaction charge,
    Nullable<decimal> amount
)
Protected Sub StatCapture (
    charge As Transaction,
    amount As Nullable(Of Decimal)
)
Protected Sub StatCapture (
    charge As Transaction,
    amount As Nullable(Of Decimal)
)
protected:
void StatCapture(
    Transaction^ charge,
    Nullable<Decimal> amount
)
protected:
void StatCapture(
    Transaction^ charge,
    Nullable<Decimal> amount
)
member StatCapture :
        charge : Transaction *
        amount : Nullable<decimal> -> unit
member StatCapture :
        charge : Transaction *
        amount : Nullable<decimal> -> unit

Parameters

charge
Type: NFX.Web.Pay Transaction
amount
Type: Online System Nullable Online Decimal
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.StatCaptureError Method

PaySystem StatCaptureError Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void StatCaptureError()
protected void StatCaptureError()
Protected Sub StatCaptureError
Protected Sub StatCaptureError
protected:
void StatCaptureError()
protected:
void StatCaptureError()
member StatCaptureError : unit -> unit
member StatCaptureError : unit -> unit
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.StatCharge Method

PaySystem StatCharge Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void StatCharge(
    Amount amount
)
protected void StatCharge(
    Amount amount
)
Protected Sub StatCharge (
    amount As Amount
)
Protected Sub StatCharge (
    amount As Amount
)
protected:
void StatCharge(
    Amount amount
)
protected:
void StatCharge(
    Amount amount
)
member StatCharge :
        amount : Amount -> unit
member StatCharge :
        amount : Amount -> unit

Parameters

amount
Type: NFX.Financial Amount
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.StatChargeError Method

PaySystem StatChargeError Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void StatChargeError()
protected void StatChargeError()
Protected Sub StatChargeError
Protected Sub StatChargeError
protected:
void StatChargeError()
protected:
void StatChargeError()
member StatChargeError : unit -> unit
member StatChargeError : unit -> unit
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.StatRefund Method

PaySystem StatRefund Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void StatRefund(
    Transaction charge,
    Nullable<decimal> amount
)
protected void StatRefund(
    Transaction charge,
    Nullable<decimal> amount
)
Protected Sub StatRefund (
    charge As Transaction,
    amount As Nullable(Of Decimal)
)
Protected Sub StatRefund (
    charge As Transaction,
    amount As Nullable(Of Decimal)
)
protected:
void StatRefund(
    Transaction^ charge,
    Nullable<Decimal> amount
)
protected:
void StatRefund(
    Transaction^ charge,
    Nullable<Decimal> amount
)
member StatRefund :
        charge : Transaction *
        amount : Nullable<decimal> -> unit
member StatRefund :
        charge : Transaction *
        amount : Nullable<decimal> -> unit

Parameters

charge
Type: NFX.Web.Pay Transaction
amount
Type: Online System Nullable Online Decimal
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.StatRefundError Method

PaySystem StatRefundError Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void StatRefundError()
protected void StatRefundError()
Protected Sub StatRefundError
Protected Sub StatRefundError
protected:
void StatRefundError()
protected:
void StatRefundError()
member StatRefundError : unit -> unit
member StatRefundError : unit -> unit
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.StatTransfer Method

PaySystem StatTransfer Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void StatTransfer(
    Amount amount
)
protected void StatTransfer(
    Amount amount
)
Protected Sub StatTransfer (
    amount As Amount
)
Protected Sub StatTransfer (
    amount As Amount
)
protected:
void StatTransfer(
    Amount amount
)
protected:
void StatTransfer(
    Amount amount
)
member StatTransfer :
        amount : Amount -> unit
member StatTransfer :
        amount : Amount -> unit

Parameters

amount
Type: NFX.Financial Amount
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.StatTransferError Method

PaySystem StatTransferError Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void StatTransferError()
protected void StatTransferError()
Protected Sub StatTransferError
Protected Sub StatTransferError
protected:
void StatTransferError()
protected:
void StatTransferError()
member StatTransferError : unit -> unit
member StatTransferError : unit -> unit
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.StatVoid Method

PaySystem StatVoid Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void StatVoid(
    Transaction charge
)
protected void StatVoid(
    Transaction charge
)
Protected Sub StatVoid (
    charge As Transaction
)
Protected Sub StatVoid (
    charge As Transaction
)
protected:
void StatVoid(
    Transaction^ charge
)
protected:
void StatVoid(
    Transaction^ charge
)
member StatVoid :
        charge : Transaction -> unit
member StatVoid :
        charge : Transaction -> unit

Parameters

charge
Type: NFX.Web.Pay Transaction
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.StatVoidError Method

PaySystem StatVoidError Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void StatVoidError()
protected void StatVoidError()
Protected Sub StatVoidError
Protected Sub StatVoidError
protected:
void StatVoidError()
protected:
void StatVoidError()
member StatVoidError : unit -> unit
member StatVoidError : unit -> unit
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem Properties

PaySystem Properties NFX Class Library

The PaySystem type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ChargeFeeKind |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | CurrenciesCfg |
Protected property | DefaultSessionConnectParams |
Public property | DefaultSessionConnectParamsCfg |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
 | Instances | Returns the read-only registry view of payment systems currently activated
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
 | IsPaySystemHost |
Public property | KeepAlive |
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | LogLevel | Specifies the log level for operations performed by Pay System.
Public property | Name | Provides textual name for the service (Inherited from Service.)
 | PaySystemHost | Returns process-global pay system host used to resolve accounts and transactions or throws if host is not set. Check IsPaySystemHost to see if host is set. This design provides an indirection level between pay systems (like Stripe, PayPal, Bank etc.) and particular application data store implementation as it decouples system-internal formats of transaction and account storage from provider-internal data (i.e. PayPal payment token string)
Public property | Pipelined |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | SupportedCurrencies |
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransferFeeKind |
Public property | WebServiceCallTimeoutMs |
Public property | WebTerminal |
Back to Top
See Also
PaySystem Class
NFX.Web.Pay Namespace


PaySystem.ChargeFeeKind Property

PaySystem ChargeFeeKind Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ProcessingFeeKind ChargeFeeKind { get; }
public virtual ProcessingFeeKind ChargeFeeKind { get; }
Public Overridable ReadOnly Property ChargeFeeKind As ProcessingFeeKind
    Get
Public Overridable ReadOnly Property ChargeFeeKind As ProcessingFeeKind
    Get
public:
virtual property ProcessingFeeKind ChargeFeeKind {
    ProcessingFeeKind get ();
}
public:
virtual property ProcessingFeeKind ChargeFeeKind {
    ProcessingFeeKind get ();
}
abstract ChargeFeeKind : ProcessingFeeKind with get
override ChargeFeeKind : ProcessingFeeKind with get
abstract ChargeFeeKind : ProcessingFeeKind with get
override ChargeFeeKind : ProcessingFeeKind with get

Property Value

Type: ProcessingFeeKind

Implements

IPaySystem ChargeFeeKind
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.CurrenciesCfg Property

PaySystem CurrenciesCfg Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("currencies")]
public IConfigSectionNode CurrenciesCfg { get; set; }
[ConfigAttribute("currencies")]
public IConfigSectionNode CurrenciesCfg { get; set; }
<ConfigAttribute("currencies")>
Public Property CurrenciesCfg As IConfigSectionNode
    Get
    Set
<ConfigAttribute("currencies")>
Public Property CurrenciesCfg As IConfigSectionNode
    Get
    Set
public:
[ConfigAttribute(L"currencies")]
property IConfigSectionNode^ CurrenciesCfg {
    IConfigSectionNode^ get ();
    void set (IConfigSectionNode^ value);
}
public:
[ConfigAttribute(L"currencies")]
property IConfigSectionNode^ CurrenciesCfg {
    IConfigSectionNode^ get ();
    void set (IConfigSectionNode^ value);
}
[<ConfigAttribute("currencies")>]
member CurrenciesCfg : IConfigSectionNode with get, set
[<ConfigAttribute("currencies")>]
member CurrenciesCfg : IConfigSectionNode with get, set

Property Value

Type: IConfigSectionNode
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.DefaultSessionConnectParams Property

PaySystem DefaultSessionConnectParams Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ConnectionParameters DefaultSessionConnectParams { get; }
protected ConnectionParameters DefaultSessionConnectParams { get; }
Protected ReadOnly Property DefaultSessionConnectParams As ConnectionParameters
    Get
Protected ReadOnly Property DefaultSessionConnectParams As ConnectionParameters
    Get
protected:
property ConnectionParameters^ DefaultSessionConnectParams {
    ConnectionParameters^ get ();
}
protected:
property ConnectionParameters^ DefaultSessionConnectParams {
    ConnectionParameters^ get ();
}
member DefaultSessionConnectParams : ConnectionParameters with get
member DefaultSessionConnectParams : ConnectionParameters with get

Property Value

Type: ConnectionParameters
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.DefaultSessionConnectParamsCfg Property

PaySystem DefaultSessionConnectParamsCfg Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("default-session-connect-params")]
public IConfigSectionNode DefaultSessionConnectParamsCfg { get; set; }
[ConfigAttribute("default-session-connect-params")]
public IConfigSectionNode DefaultSessionConnectParamsCfg { get; set; }
<ConfigAttribute("default-session-connect-params")>
Public Property DefaultSessionConnectParamsCfg As IConfigSectionNode
    Get
    Set
<ConfigAttribute("default-session-connect-params")>
Public Property DefaultSessionConnectParamsCfg As IConfigSectionNode
    Get
    Set
public:
[ConfigAttribute(L"default-session-connect-params")]
virtual property IConfigSectionNode^ DefaultSessionConnectParamsCfg {
    IConfigSectionNode^ get () sealed;
    void set (IConfigSectionNode^ value) sealed;
}
public:
[ConfigAttribute(L"default-session-connect-params")]
virtual property IConfigSectionNode^ DefaultSessionConnectParamsCfg {
    IConfigSectionNode^ get () sealed;
    void set (IConfigSectionNode^ value) sealed;
}
[<ConfigAttribute("default-session-connect-params")>]
abstract DefaultSessionConnectParamsCfg : IConfigSectionNode with get, set
[<ConfigAttribute("default-session-connect-params")>]
override DefaultSessionConnectParamsCfg : IConfigSectionNode with get, set
[<ConfigAttribute("default-session-connect-params")>]
abstract DefaultSessionConnectParamsCfg : IConfigSectionNode with get, set
[<ConfigAttribute("default-session-connect-params")>]
override DefaultSessionConnectParamsCfg : IConfigSectionNode with get, set

Property Value

Type: IConfigSectionNode

Implements

IPaySystem DefaultSessionConnectParamsCfg
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.Instances Property

PaySystem Instances Property NFX Class Library

Returns the read-only registry view of payment systems currently activated

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IRegistry<IPaySystem> Instances { get; }
public static IRegistry<IPaySystem> Instances { get; }
Public Shared ReadOnly Property Instances As IRegistry(Of IPaySystem)
    Get
Public Shared ReadOnly Property Instances As IRegistry(Of IPaySystem)
    Get
public:
static property IRegistry<IPaySystem^>^ Instances {
    IRegistry<IPaySystem^>^ get ();
}
public:
static property IRegistry<IPaySystem^>^ Instances {
    IRegistry<IPaySystem^>^ get ();
}
static member Instances : IRegistry<IPaySystem> with get
static member Instances : IRegistry<IPaySystem> with get

Property Value

Type: IRegistry IPaySystem
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.InstrumentationEnabled Property

PaySystem InstrumentationEnabled Property NFX Class Library

Implements IInstrumentable

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public override bool InstrumentationEnabled { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public override bool InstrumentationEnabled { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
IInstrumentable InstrumentationEnabled
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.IsPaySystemHost Property

PaySystem IsPaySystemHost Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsPaySystemHost { get; }
public static bool IsPaySystemHost { get; }
Public Shared ReadOnly Property IsPaySystemHost As Boolean
    Get
Public Shared ReadOnly Property IsPaySystemHost As Boolean
    Get
public:
static property bool IsPaySystemHost {
    bool get ();
}
public:
static property bool IsPaySystemHost {
    bool get ();
}
static member IsPaySystemHost : bool with get
static member IsPaySystemHost : bool with get

Property Value

Type: Online Boolean
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.KeepAlive Property

PaySystem KeepAlive Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = true)]
public bool KeepAlive { get; set; }
[ConfigAttribute(Default = true)]
public bool KeepAlive { get; set; }
<ConfigAttribute(Default := true)>
Public Property KeepAlive As Boolean
    Get
    Set
<ConfigAttribute(Default := true)>
Public Property KeepAlive As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = true)]
virtual property bool KeepAlive {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
[ConfigAttribute(Default = true)]
virtual property bool KeepAlive {
    bool get () sealed;
    void set (bool value) sealed;
}
[<ConfigAttribute(Default = true)>]
abstract KeepAlive : bool with get, set
[<ConfigAttribute(Default = true)>]
override KeepAlive : bool with get, set
[<ConfigAttribute(Default = true)>]
abstract KeepAlive : bool with get, set
[<ConfigAttribute(Default = true)>]
override KeepAlive : bool with get, set

Property Value

Type: Online Boolean

Implements

IWebClientCaller KeepAlive
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.LogLevel Property

PaySystem LogLevel Property NFX Class Library

Specifies the log level for operations performed by Pay System.

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = MessageType.Warning)]
public MessageType LogLevel { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = MessageType.Warning)]
public MessageType LogLevel { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := MessageType.Warning)>
Public Property LogLevel As MessageType
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := MessageType.Warning)>
Public Property LogLevel As MessageType
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = MessageType::Warning)]
virtual property MessageType LogLevel {
    MessageType get () sealed;
    void set (MessageType value) sealed;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = MessageType::Warning)]
virtual property MessageType LogLevel {
    MessageType get () sealed;
    void set (MessageType value) sealed;
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = MessageType.Warning)>]
abstract LogLevel : MessageType with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = MessageType.Warning)>]
override LogLevel : MessageType with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = MessageType.Warning)>]
abstract LogLevel : MessageType with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = MessageType.Warning)>]
override LogLevel : MessageType with get, set

Property Value

Type: MessageType

Implements

IPaySystemImplementation LogLevel
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.PaySystemHost Property

PaySystem PaySystemHost Property NFX Class Library

Returns process-global pay system host used to resolve accounts and transactions or throws if host is not set. Check IsPaySystemHost to see if host is set. This design provides an indirection level between pay systems (like Stripe, PayPal, Bank etc.) and particular application data store implementation as it decouples system-internal formats of transaction and account storage from provider-internal data (i.e. PayPal payment token string)

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IPaySystemHost PaySystemHost { get; }
public static IPaySystemHost PaySystemHost { get; }
Public Shared ReadOnly Property PaySystemHost As IPaySystemHost
    Get
Public Shared ReadOnly Property PaySystemHost As IPaySystemHost
    Get
public:
static property IPaySystemHost^ PaySystemHost {
    IPaySystemHost^ get ();
}
public:
static property IPaySystemHost^ PaySystemHost {
    IPaySystemHost^ get ();
}
static member PaySystemHost : IPaySystemHost with get
static member PaySystemHost : IPaySystemHost with get

Property Value

Type: IPaySystemHost
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.Pipelined Property

PaySystem Pipelined Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = true)]
public bool Pipelined { get; set; }
[ConfigAttribute(Default = true)]
public bool Pipelined { get; set; }
<ConfigAttribute(Default := true)>
Public Property Pipelined As Boolean
    Get
    Set
<ConfigAttribute(Default := true)>
Public Property Pipelined As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = true)]
virtual property bool Pipelined {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
[ConfigAttribute(Default = true)]
virtual property bool Pipelined {
    bool get () sealed;
    void set (bool value) sealed;
}
[<ConfigAttribute(Default = true)>]
abstract Pipelined : bool with get, set
[<ConfigAttribute(Default = true)>]
override Pipelined : bool with get, set
[<ConfigAttribute(Default = true)>]
abstract Pipelined : bool with get, set
[<ConfigAttribute(Default = true)>]
override Pipelined : bool with get, set

Property Value

Type: Online Boolean

Implements

IWebClientCaller Pipelined
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.SupportedCurrencies Property

PaySystem SupportedCurrencies Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<string> SupportedCurrencies { get; }
public virtual IEnumerable<string> SupportedCurrencies { get; }
Public Overridable ReadOnly Property SupportedCurrencies As IEnumerable(Of String)
    Get
Public Overridable ReadOnly Property SupportedCurrencies As IEnumerable(Of String)
    Get
public:
virtual property IEnumerable<String^>^ SupportedCurrencies {
    IEnumerable<String^>^ get ();
}
public:
virtual property IEnumerable<String^>^ SupportedCurrencies {
    IEnumerable<String^>^ get ();
}
abstract SupportedCurrencies : IEnumerable<string> with get
override SupportedCurrencies : IEnumerable<string> with get
abstract SupportedCurrencies : IEnumerable<string> with get
override SupportedCurrencies : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String

Implements

IPaySystem SupportedCurrencies
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.TransferFeeKind Property

PaySystem TransferFeeKind Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ProcessingFeeKind TransferFeeKind { get; }
public virtual ProcessingFeeKind TransferFeeKind { get; }
Public Overridable ReadOnly Property TransferFeeKind As ProcessingFeeKind
    Get
Public Overridable ReadOnly Property TransferFeeKind As ProcessingFeeKind
    Get
public:
virtual property ProcessingFeeKind TransferFeeKind {
    ProcessingFeeKind get ();
}
public:
virtual property ProcessingFeeKind TransferFeeKind {
    ProcessingFeeKind get ();
}
abstract TransferFeeKind : ProcessingFeeKind with get
override TransferFeeKind : ProcessingFeeKind with get
abstract TransferFeeKind : ProcessingFeeKind with get
override TransferFeeKind : ProcessingFeeKind with get

Property Value

Type: ProcessingFeeKind

Implements

IPaySystem TransferFeeKind
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.WebServiceCallTimeoutMs Property

PaySystem WebServiceCallTimeoutMs Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = 20000)]
public int WebServiceCallTimeoutMs { get; set; }
[ConfigAttribute(Default = 20000)]
public int WebServiceCallTimeoutMs { get; set; }
<ConfigAttribute(Default := 20000)>
Public Property WebServiceCallTimeoutMs As Integer
    Get
    Set
<ConfigAttribute(Default := 20000)>
Public Property WebServiceCallTimeoutMs As Integer
    Get
    Set
public:
[ConfigAttribute(Default = 20000)]
virtual property int WebServiceCallTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
public:
[ConfigAttribute(Default = 20000)]
virtual property int WebServiceCallTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
[<ConfigAttribute(Default = 20000)>]
abstract WebServiceCallTimeoutMs : int with get, set
[<ConfigAttribute(Default = 20000)>]
override WebServiceCallTimeoutMs : int with get, set
[<ConfigAttribute(Default = 20000)>]
abstract WebServiceCallTimeoutMs : int with get, set
[<ConfigAttribute(Default = 20000)>]
override WebServiceCallTimeoutMs : int with get, set

Property Value

Type: Online Int32

Implements

IWebClientCaller WebServiceCallTimeoutMs
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystem.WebTerminal Property

PaySystem WebTerminal Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IPayWebTerminal WebTerminal { get; }
public virtual IPayWebTerminal WebTerminal { get; }
Public Overridable ReadOnly Property WebTerminal As IPayWebTerminal
    Get
Public Overridable ReadOnly Property WebTerminal As IPayWebTerminal
    Get
public:
virtual property IPayWebTerminal^ WebTerminal {
    IPayWebTerminal^ get ();
}
public:
virtual property IPayWebTerminal^ WebTerminal {
    IPayWebTerminal^ get ();
}
abstract WebTerminal : IPayWebTerminal with get
override WebTerminal : IPayWebTerminal with get
abstract WebTerminal : IPayWebTerminal with get
override WebTerminal : IPayWebTerminal with get

Property Value

Type: IPayWebTerminal

Implements

IPaySystem WebTerminal
See Also
PaySystem Class
PaySystem Members
NFX.Web.Pay Namespace


PaySystemHost Class

PaySystemHost Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Online Object
NFX.ServiceModel ServiceWithInstrumentationBase Online Object
NFX.Web.Pay PaySystemHost

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PaySystemHost : ServiceWithInstrumentationBase<Object>,
    IPaySystemHostImplementation, IPaySystemHost, INamed, IConfigurable
public abstract class PaySystemHost : ServiceWithInstrumentationBase<Object>,
    IPaySystemHostImplementation, IPaySystemHost, INamed, IConfigurable
Public MustInherit Class PaySystemHost
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements IPaySystemHostImplementation, IPaySystemHost, INamed, IConfigurable
Public MustInherit Class PaySystemHost
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements IPaySystemHostImplementation, IPaySystemHost, INamed, IConfigurable
public ref class PaySystemHost abstract : public ServiceWithInstrumentationBase<Object^>,
    IPaySystemHostImplementation, IPaySystemHost, INamed, IConfigurable
public ref class PaySystemHost abstract : public ServiceWithInstrumentationBase<Object^>,
    IPaySystemHostImplementation, IPaySystemHost, INamed, IConfigurable
[<AbstractClassAttribute>]
type PaySystemHost =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface IPaySystemHostImplementation
        interface IPaySystemHost
        interface INamed
        interface IConfigurable
    end
[<AbstractClassAttribute>]
type PaySystemHost =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface IPaySystemHostImplementation
        interface IPaySystemHost
        interface INamed
        interface IConfigurable
    end
See Also
PaySystemHost Members
NFX.Web.Pay Namespace


PaySystemHost Members

PaySystemHost Members NFX Class Library

The PaySystemHost type exposes the following members.
Constructors
 | Name | Description
Protected method | PaySystemHost(String, IConfigSectionNode) | Initializes a new instance of the PaySystemHost class
Protected method | PaySystemHost(String, IConfigSectionNode, Object) | Initializes a new instance of the PaySystemHost class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoFetchAccountData |
Protected method | DoFetchTransaction |
Protected method | DoGenerateTransactionID |
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoStoreAccountData |
Protected method | DoStoreTransaction |
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | FetchAccountData |
Public method | FetchTransaction |
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDefaultTransactionContext |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Log |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | CurrencyMarket |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | LogLevel |
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
PaySystemHost Class
NFX.Web.Pay Namespace


PaySystemHost Constructor

PaySystemHost Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | PaySystemHost(String, IConfigSectionNode) | Initializes a new instance of the PaySystemHost class
Protected method | PaySystemHost(String, IConfigSectionNode, Object) | Initializes a new instance of the PaySystemHost class
Back to Top
See Also
PaySystemHost Class
PaySystemHost Members
NFX.Web.Pay Namespace


PaySystemHost Constructor (String, IConfigSectionNode)

PaySystemHost Constructor (String, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PaySystemHost class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PaySystemHost(
    string name,
    IConfigSectionNode node
)
protected PaySystemHost(
    string name,
    IConfigSectionNode node
)
Protected Sub New (
    name As String,
    node As IConfigSectionNode
)
Protected Sub New (
    name As String,
    node As IConfigSectionNode
)
protected:
PaySystemHost(
    String^ name,
    IConfigSectionNode^ node
)
protected:
PaySystemHost(
    String^ name,
    IConfigSectionNode^ node
)
new :
        name : string *
        node : IConfigSectionNode -> PaySystemHost
new :
        name : string *
        node : IConfigSectionNode -> PaySystemHost

Parameters

name
Type: Online System String
node
Type: NFX.Environment IConfigSectionNode
See Also
PaySystemHost Class
PaySystemHost Members
PaySystemHost Overload
NFX.Web.Pay Namespace


PaySystemHost Constructor (String, IConfigSectionNode, Object)

PaySystemHost Constructor (String, IConfigSectionNode, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PaySystemHost class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PaySystemHost(
    string name,
    IConfigSectionNode node,
    Object director
)
protected PaySystemHost(
    string name,
    IConfigSectionNode node,
    Object director
)
Protected Sub New (
    name As String,
    node As IConfigSectionNode,
    director As Object
)
Protected Sub New (
    name As String,
    node As IConfigSectionNode,
    director As Object
)
protected:
PaySystemHost(
    String^ name,
    IConfigSectionNode^ node,
    Object^ director
)
protected:
PaySystemHost(
    String^ name,
    IConfigSectionNode^ node,
    Object^ director
)
new :
        name : string *
        node : IConfigSectionNode *
        director : Object -> PaySystemHost
new :
        name : string *
        node : IConfigSectionNode *
        director : Object -> PaySystemHost

Parameters

name
Type: Online System String
node
Type: NFX.Environment IConfigSectionNode
director
Type: Online System Object
See Also
PaySystemHost Class
PaySystemHost Members
PaySystemHost Overload
NFX.Web.Pay Namespace


PaySystemHost Methods

PaySystemHost Methods NFX Class Library

The PaySystemHost type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoFetchAccountData |
Protected method | DoFetchTransaction |
Protected method | DoGenerateTransactionID |
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoStoreAccountData |
Protected method | DoStoreTransaction |
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | FetchAccountData |
Public method | FetchTransaction |
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDefaultTransactionContext |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Log |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PaySystemHost Class
NFX.Web.Pay Namespace


PaySystemHost.DoFetchAccountData Method

PaySystemHost DoFetchAccountData Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract IActualAccountData DoFetchAccountData(
    PaySession session,
    Account account
)
protected internal abstract IActualAccountData DoFetchAccountData(
    PaySession session,
    Account account
)
Protected Friend MustOverride Function DoFetchAccountData (
    session As PaySession,
    account As Account
) As IActualAccountData
Protected Friend MustOverride Function DoFetchAccountData (
    session As PaySession,
    account As Account
) As IActualAccountData
protected public:
virtual IActualAccountData^ DoFetchAccountData(
    PaySession^ session,
    Account account
) abstract
protected public:
virtual IActualAccountData^ DoFetchAccountData(
    PaySession^ session,
    Account account
) abstract
abstract DoFetchAccountData :
        session : PaySession *
        account : Account -> IActualAccountData
abstract DoFetchAccountData :
        session : PaySession *
        account : Account -> IActualAccountData

Parameters

session
Type: NFX.Web.Pay PaySession
account
Type: NFX.Web.Pay Account

Return Value

Type: IActualAccountData
See Also
PaySystemHost Class
PaySystemHost Members
NFX.Web.Pay Namespace


PaySystemHost.DoFetchTransaction Method

PaySystemHost DoFetchTransaction Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract Transaction DoFetchTransaction(
    PaySession session,
    Object id
)
protected internal abstract Transaction DoFetchTransaction(
    PaySession session,
    Object id
)
Protected Friend MustOverride Function DoFetchTransaction (
    session As PaySession,
    id As Object
) As Transaction
Protected Friend MustOverride Function DoFetchTransaction (
    session As PaySession,
    id As Object
) As Transaction
protected public:
virtual Transaction^ DoFetchTransaction(
    PaySession^ session,
    Object^ id
) abstract
protected public:
virtual Transaction^ DoFetchTransaction(
    PaySession^ session,
    Object^ id
) abstract
abstract DoFetchTransaction :
        session : PaySession *
        id : Object -> Transaction
abstract DoFetchTransaction :
        session : PaySession *
        id : Object -> Transaction

Parameters

session
Type: NFX.Web.Pay PaySession
id
Type: Online System Object

Return Value

Type: Transaction
See Also
PaySystemHost Class
PaySystemHost Members
NFX.Web.Pay Namespace


PaySystemHost.DoGenerateTransactionID Method

PaySystemHost DoGenerateTransactionID Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract Object DoGenerateTransactionID(
    PaySession session,
    TransactionType type
)
protected internal abstract Object DoGenerateTransactionID(
    PaySession session,
    TransactionType type
)
Protected Friend MustOverride Function DoGenerateTransactionID (
    session As PaySession,
    type As TransactionType
) As Object
Protected Friend MustOverride Function DoGenerateTransactionID (
    session As PaySession,
    type As TransactionType
) As Object
protected public:
virtual Object^ DoGenerateTransactionID(
    PaySession^ session,
    TransactionType type
) abstract
protected public:
virtual Object^ DoGenerateTransactionID(
    PaySession^ session,
    TransactionType type
) abstract
abstract DoGenerateTransactionID :
        session : PaySession *
        type : TransactionType -> Object
abstract DoGenerateTransactionID :
        session : PaySession *
        type : TransactionType -> Object

Parameters

session
Type: NFX.Web.Pay PaySession
type
Type: NFX.Web.Pay TransactionType

Return Value

Type: Online Object
See Also
PaySystemHost Class
PaySystemHost Members
NFX.Web.Pay Namespace


PaySystemHost.DoStoreAccountData Method

PaySystemHost DoStoreAccountData Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract void DoStoreAccountData(
    PaySession session,
    IActualAccountData accoundData
)
protected internal abstract void DoStoreAccountData(
    PaySession session,
    IActualAccountData accoundData
)
Protected Friend MustOverride Sub DoStoreAccountData (
    session As PaySession,
    accoundData As IActualAccountData
)
Protected Friend MustOverride Sub DoStoreAccountData (
    session As PaySession,
    accoundData As IActualAccountData
)
protected public:
virtual void DoStoreAccountData(
    PaySession^ session,
    IActualAccountData^ accoundData
) abstract
protected public:
virtual void DoStoreAccountData(
    PaySession^ session,
    IActualAccountData^ accoundData
) abstract
abstract DoStoreAccountData :
        session : PaySession *
        accoundData : IActualAccountData -> unit
abstract DoStoreAccountData :
        session : PaySession *
        accoundData : IActualAccountData -> unit

Parameters

session
Type: NFX.Web.Pay PaySession
accoundData
Type: NFX.Web.Pay IActualAccountData
See Also
PaySystemHost Class
PaySystemHost Members
NFX.Web.Pay Namespace


PaySystemHost.DoStoreTransaction Method

PaySystemHost DoStoreTransaction Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract void DoStoreTransaction(
    PaySession session,
    Transaction tran
)
protected internal abstract void DoStoreTransaction(
    PaySession session,
    Transaction tran
)
Protected Friend MustOverride Sub DoStoreTransaction (
    session As PaySession,
    tran As Transaction
)
Protected Friend MustOverride Sub DoStoreTransaction (
    session As PaySession,
    tran As Transaction
)
protected public:
virtual void DoStoreTransaction(
    PaySession^ session,
    Transaction^ tran
) abstract
protected public:
virtual void DoStoreTransaction(
    PaySession^ session,
    Transaction^ tran
) abstract
abstract DoStoreTransaction :
        session : PaySession *
        tran : Transaction -> unit
abstract DoStoreTransaction :
        session : PaySession *
        tran : Transaction -> unit

Parameters

session
Type: NFX.Web.Pay PaySession
tran
Type: NFX.Web.Pay Transaction
See Also
PaySystemHost Class
PaySystemHost Members
NFX.Web.Pay Namespace


PaySystemHost.FetchAccountData Method

PaySystemHost FetchAccountData Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IActualAccountData FetchAccountData(
    Account account
)
public IActualAccountData FetchAccountData(
    Account account
)
Public Function FetchAccountData (
    account As Account
) As IActualAccountData
Public Function FetchAccountData (
    account As Account
) As IActualAccountData
public:
virtual IActualAccountData^ FetchAccountData(
    Account account
) sealed
public:
virtual IActualAccountData^ FetchAccountData(
    Account account
) sealed
abstract FetchAccountData :
        account : Account -> IActualAccountData
override FetchAccountData :
        account : Account -> IActualAccountData
abstract FetchAccountData :
        account : Account -> IActualAccountData
override FetchAccountData :
        account : Account -> IActualAccountData

Parameters

account
Type: NFX.Web.Pay Account

Return Value

Type: IActualAccountData

Implements

IPaySystemHost FetchAccountData(Account)
See Also
PaySystemHost Class
PaySystemHost Members
NFX.Web.Pay Namespace


PaySystemHost.FetchTransaction Method

PaySystemHost FetchTransaction Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Transaction FetchTransaction(
    Object id
)
public Transaction FetchTransaction(
    Object id
)
Public Function FetchTransaction (
    id As Object
) As Transaction
Public Function FetchTransaction (
    id As Object
) As Transaction
public:
virtual Transaction^ FetchTransaction(
    Object^ id
) sealed
public:
virtual Transaction^ FetchTransaction(
    Object^ id
) sealed
abstract FetchTransaction :
        id : Object -> Transaction
override FetchTransaction :
        id : Object -> Transaction
abstract FetchTransaction :
        id : Object -> Transaction
override FetchTransaction :
        id : Object -> Transaction

Parameters

id
Type: Online System Object

Return Value

Type: Transaction

Implements

IPaySystemHost FetchTransaction(Object)
See Also
PaySystemHost Class
PaySystemHost Members
NFX.Web.Pay Namespace


PaySystemHost.GetDefaultTransactionContext Method

PaySystemHost GetDefaultTransactionContext Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual IPaySessionContext GetDefaultTransactionContext()
protected internal virtual IPaySessionContext GetDefaultTransactionContext()
Protected Friend Overridable Function GetDefaultTransactionContext As IPaySessionContext
Protected Friend Overridable Function GetDefaultTransactionContext As IPaySessionContext
protected public:
virtual IPaySessionContext^ GetDefaultTransactionContext()
protected public:
virtual IPaySessionContext^ GetDefaultTransactionContext()
abstract GetDefaultTransactionContext : unit -> IPaySessionContext
override GetDefaultTransactionContext : unit -> IPaySessionContext
abstract GetDefaultTransactionContext : unit -> IPaySessionContext
override GetDefaultTransactionContext : unit -> IPaySessionContext

Return Value

Type: IPaySessionContext
See Also
PaySystemHost Class
PaySystemHost Members
NFX.Web.Pay Namespace


PaySystemHost.Log Method

PaySystemHost Log Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Guid Log(
    MessageType type,
    string from,
    string message,
    Exception error = null,
    Nullable<Guid> relatedMessageID = null,
    string parameters = null
)
protected internal virtual Guid Log(
    MessageType type,
    string from,
    string message,
    Exception error = null,
    Nullable<Guid> relatedMessageID = null,
    string parameters = null
)
Protected Friend Overridable Function Log (
    type As MessageType,
    from As String,
    message As String,
    Optional error As Exception = Nothing,
    Optional relatedMessageID As Nullable(Of Guid) = Nothing,
    Optional parameters As String = Nothing
) As Guid
Protected Friend Overridable Function Log (
    type As MessageType,
    from As String,
    message As String,
    Optional error As Exception = Nothing,
    Optional relatedMessageID As Nullable(Of Guid) = Nothing,
    Optional parameters As String = Nothing
) As Guid
protected public:
virtual Guid Log(
    MessageType type,
    String^ from,
    String^ message,
    Exception^ error = nullptr,
    Nullable<Guid> relatedMessageID = nullptr,
    String^ parameters = nullptr
)
protected public:
virtual Guid Log(
    MessageType type,
    String^ from,
    String^ message,
    Exception^ error = nullptr,
    Nullable<Guid> relatedMessageID = nullptr,
    String^ parameters = nullptr
)
abstract Log :
        type : MessageType *
        from : string *
        message : string *
        ?error : Exception *
        ?relatedMessageID : Nullable<Guid> *
        ?parameters : string
(* Defaults:
        let _error = defaultArg error null
        let _relatedMessageID = defaultArg relatedMessageID null
        let _parameters = defaultArg parameters null
*)
-> Guid
override Log :
        type : MessageType *
        from : string *
        message : string *
        ?error : Exception *
        ?relatedMessageID : Nullable<Guid> *
        ?parameters : string
(* Defaults:
        let _error = defaultArg error null
        let _relatedMessageID = defaultArg relatedMessageID null
        let _parameters = defaultArg parameters null
*)
-> Guid
abstract Log :
        type : MessageType *
        from : string *
        message : string *
        ?error : Exception *
        ?relatedMessageID : Nullable<Guid> *
        ?parameters : string
(* Defaults:
        let _error = defaultArg error null
        let _relatedMessageID = defaultArg relatedMessageID null
        let _parameters = defaultArg parameters null
*)
-> Guid
override Log :
        type : MessageType *
        from : string *
        message : string *
        ?error : Exception *
        ?relatedMessageID : Nullable<Guid> *
        ?parameters : string
(* Defaults:
        let _error = defaultArg error null
        let _relatedMessageID = defaultArg relatedMessageID null
        let _parameters = defaultArg parameters null
*)
-> Guid

Parameters

type
Type: NFX.Log MessageType
from
Type: Online System String
message
Type: Online System String
error (Optional)
Type: Online System Exception
relatedMessageID (Optional)
Type: Online System Nullable Online Guid
parameters (Optional)
Type: Online System String

Return Value

Type: Online Guid
See Also
PaySystemHost Class
PaySystemHost Members
NFX.Web.Pay Namespace


PaySystemHost Properties

PaySystemHost Properties NFX Class Library

The PaySystemHost type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | CurrencyMarket |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | LogLevel |
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
PaySystemHost Class
NFX.Web.Pay Namespace


PaySystemHost.CurrencyMarket Property

PaySystemHost CurrencyMarket Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract ICurrencyMarket CurrencyMarket { get; }
public abstract ICurrencyMarket CurrencyMarket { get; }
Public MustOverride ReadOnly Property CurrencyMarket As ICurrencyMarket
    Get
Public MustOverride ReadOnly Property CurrencyMarket As ICurrencyMarket
    Get
public:
virtual property ICurrencyMarket^ CurrencyMarket {
    ICurrencyMarket^ get () abstract;
}
public:
virtual property ICurrencyMarket^ CurrencyMarket {
    ICurrencyMarket^ get () abstract;
}
abstract CurrencyMarket : ICurrencyMarket with get
abstract CurrencyMarket : ICurrencyMarket with get

Property Value

Type: ICurrencyMarket

Implements

IPaySystemHost CurrencyMarket
See Also
PaySystemHost Class
PaySystemHost Members
NFX.Web.Pay Namespace


PaySystemHost.InstrumentationEnabled Property

PaySystemHost InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Implements IInstrumentable

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool InstrumentationEnabled { get; set; }
public override bool InstrumentationEnabled { get; set; }
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
abstract InstrumentationEnabled : bool with get, set
override InstrumentationEnabled : bool with get, set
abstract InstrumentationEnabled : bool with get, set
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
PaySystemHost Class
PaySystemHost Members
NFX.Web.Pay Namespace


PaySystemHost.LogLevel Property

PaySystemHost LogLevel Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = MessageType.Warning)]
[ExternalParameterAttribute(new string[] { ... })]
public MessageType LogLevel { get; set; }
[ConfigAttribute(Default = MessageType.Warning)]
[ExternalParameterAttribute(new string[] { ... })]
public MessageType LogLevel { get; set; }
<ConfigAttribute(Default := MessageType.Warning)>
<ExternalParameterAttribute(New String() { ... })>
Public Property LogLevel As MessageType
    Get
    Set
<ConfigAttribute(Default := MessageType.Warning)>
<ExternalParameterAttribute(New String() { ... })>
Public Property LogLevel As MessageType
    Get
    Set
public:
[ConfigAttribute(Default = MessageType::Warning)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property MessageType LogLevel {
    MessageType get ();
    void set (MessageType value);
}
public:
[ConfigAttribute(Default = MessageType::Warning)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property MessageType LogLevel {
    MessageType get ();
    void set (MessageType value);
}
[<ConfigAttribute(Default = MessageType.Warning)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member LogLevel : MessageType with get, set
[<ConfigAttribute(Default = MessageType.Warning)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member LogLevel : MessageType with get, set

Property Value

Type: MessageType
See Also
PaySystemHost Class
PaySystemHost Members
NFX.Web.Pay Namespace


PaySystemStarter Class

PaySystemStarter Class NFX Class Library

Represents a starter that launches payment systems on startup
Inheritance Hierarchy
Online System Object
NFX.Web.Pay PaySystemStarter

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class PaySystemStarter : IApplicationStarter,
    IConfigurable, INamed
public sealed class PaySystemStarter : IApplicationStarter,
    IConfigurable, INamed
Public NotInheritable Class PaySystemStarter
    Implements IApplicationStarter, IConfigurable, INamed
Public NotInheritable Class PaySystemStarter
    Implements IApplicationStarter, IConfigurable, INamed
public ref class PaySystemStarter sealed : IApplicationStarter,
    IConfigurable, INamed
public ref class PaySystemStarter sealed : IApplicationStarter,
    IConfigurable, INamed
[<SealedAttribute>]
type PaySystemStarter =
    class
        interface IApplicationStarter
        interface IConfigurable
        interface INamed
    end
[<SealedAttribute>]
type PaySystemStarter =
    class
        interface IApplicationStarter
        interface IConfigurable
        interface INamed
    end
See Also
PaySystemStarter Members
NFX.Web.Pay Namespace


PaySystemStarter Members

PaySystemStarter Members NFX Class Library

The PaySystemStarter type exposes the following members.
Constructors
 | Name | Description
Public method | PaySystemStarter | Initializes a new instance of the PaySystemStarter class
Back to Top
Methods
 | Name | Description
Public method | ApplicationStartAfterInit |
Public method | ApplicationStartBeforeInit |
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationStartBreakOnException |
Public property | Name |
Back to Top
See Also
PaySystemStarter Class
NFX.Web.Pay Namespace


PaySystemStarter Constructor

PaySystemStarter Constructor NFX Class Library

Initializes a new instance of the PaySystemStarter class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PaySystemStarter()
public PaySystemStarter()
Public Sub New
Public Sub New
public:
PaySystemStarter()
public:
PaySystemStarter()
new : unit -> PaySystemStarter
new : unit -> PaySystemStarter
See Also
PaySystemStarter Class
PaySystemStarter Members
NFX.Web.Pay Namespace


PaySystemStarter Methods

PaySystemStarter Methods NFX Class Library

The PaySystemStarter type exposes the following members.
Methods
 | Name | Description
Public method | ApplicationStartAfterInit |
Public method | ApplicationStartBeforeInit |
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PaySystemStarter Class
NFX.Web.Pay Namespace


PaySystemStarter.ApplicationStartAfterInit Method

PaySystemStarter ApplicationStartAfterInit Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ApplicationStartAfterInit(
    IApplication application
)
public void ApplicationStartAfterInit(
    IApplication application
)
Public Sub ApplicationStartAfterInit (
    application As IApplication
)
Public Sub ApplicationStartAfterInit (
    application As IApplication
)
public:
virtual void ApplicationStartAfterInit(
    IApplication^ application
) sealed
public:
virtual void ApplicationStartAfterInit(
    IApplication^ application
) sealed
abstract ApplicationStartAfterInit :
        application : IApplication -> unit
override ApplicationStartAfterInit :
        application : IApplication -> unit
abstract ApplicationStartAfterInit :
        application : IApplication -> unit
override ApplicationStartAfterInit :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationStarter ApplicationStartAfterInit(IApplication)
See Also
PaySystemStarter Class
PaySystemStarter Members
NFX.Web.Pay Namespace


PaySystemStarter.ApplicationStartBeforeInit Method

PaySystemStarter ApplicationStartBeforeInit Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ApplicationStartBeforeInit(
    IApplication application
)
public void ApplicationStartBeforeInit(
    IApplication application
)
Public Sub ApplicationStartBeforeInit (
    application As IApplication
)
Public Sub ApplicationStartBeforeInit (
    application As IApplication
)
public:
virtual void ApplicationStartBeforeInit(
    IApplication^ application
) sealed
public:
virtual void ApplicationStartBeforeInit(
    IApplication^ application
) sealed
abstract ApplicationStartBeforeInit :
        application : IApplication -> unit
override ApplicationStartBeforeInit :
        application : IApplication -> unit
abstract ApplicationStartBeforeInit :
        application : IApplication -> unit
override ApplicationStartBeforeInit :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationStarter ApplicationStartBeforeInit(IApplication)
See Also
PaySystemStarter Class
PaySystemStarter Members
NFX.Web.Pay Namespace


PaySystemStarter.Configure Method

PaySystemStarter Configure Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
PaySystemStarter Class
PaySystemStarter Members
NFX.Web.Pay Namespace


PaySystemStarter Properties

PaySystemStarter Properties NFX Class Library

The PaySystemStarter type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationStartBreakOnException |
Public property | Name |
Back to Top
See Also
PaySystemStarter Class
NFX.Web.Pay Namespace


PaySystemStarter.ApplicationStartBreakOnException Property

PaySystemStarter ApplicationStartBreakOnException Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool ApplicationStartBreakOnException { get; set; }
[ConfigAttribute]
public bool ApplicationStartBreakOnException { get; set; }
<ConfigAttribute>
Public Property ApplicationStartBreakOnException As Boolean
    Get
    Set
<ConfigAttribute>
Public Property ApplicationStartBreakOnException As Boolean
    Get
    Set
public:
[ConfigAttribute]
virtual property bool ApplicationStartBreakOnException {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
[ConfigAttribute]
virtual property bool ApplicationStartBreakOnException {
    bool get () sealed;
    void set (bool value) sealed;
}
[<ConfigAttribute>]
abstract ApplicationStartBreakOnException : bool with get, set
[<ConfigAttribute>]
override ApplicationStartBreakOnException : bool with get, set
[<ConfigAttribute>]
abstract ApplicationStartBreakOnException : bool with get, set
[<ConfigAttribute>]
override ApplicationStartBreakOnException : bool with get, set

Property Value

Type: Online Boolean

Implements

IApplicationStarter ApplicationStartBreakOnException
See Also
PaySystemStarter Class
PaySystemStarter Members
NFX.Web.Pay Namespace


PaySystemStarter.Name Property

PaySystemStarter Name Property NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Name { get; set; }
[ConfigAttribute]
public string Name { get; set; }
<ConfigAttribute>
Public Property Name As String
    Get
    Set
<ConfigAttribute>
Public Property Name As String
    Get
    Set
public:
[ConfigAttribute]
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
[ConfigAttribute]
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
[<ConfigAttribute>]
abstract Name : string with get, set
[<ConfigAttribute>]
override Name : string with get, set
[<ConfigAttribute>]
abstract Name : string with get, set
[<ConfigAttribute>]
override Name : string with get, set

Property Value

Type: Online String

Implements

INamed Name
See Also
PaySystemStarter Class
PaySystemStarter Members
NFX.Web.Pay Namespace


PaySystemWithStaticFees Class

PaySystemWithStaticFees Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Online Object
NFX.ServiceModel ServiceWithInstrumentationBase Online Object
NFX.Web.Pay PaySystem
NFX.Web.Pay PaySystemWithStaticFees

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PaySystemWithStaticFees : PaySystem
public abstract class PaySystemWithStaticFees : PaySystem
Public MustInherit Class PaySystemWithStaticFees
    Inherits PaySystem
Public MustInherit Class PaySystemWithStaticFees
    Inherits PaySystem
public ref class PaySystemWithStaticFees abstract : public PaySystem
public ref class PaySystemWithStaticFees abstract : public PaySystem
[<AbstractClassAttribute>]
type PaySystemWithStaticFees =
    class
        inherit PaySystem
    end
[<AbstractClassAttribute>]
type PaySystemWithStaticFees =
    class
        inherit PaySystem
    end
See Also
PaySystemWithStaticFees Members
NFX.Web.Pay Namespace


PaySystemWithStaticFees Members

PaySystemWithStaticFees Members NFX Class Library

The PaySystemWithStaticFees type exposes the following members.
Constructors
 | Name | Description
Protected method | PaySystemWithStaticFees(String, IConfigSectionNode) | Initializes a new instance of the PaySystemWithStaticFees class
Protected method | PaySystemWithStaticFees(String, IConfigSectionNode, Object) | Initializes a new instance of the PaySystemWithStaticFees class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from PaySystem.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Inherited from PaySystem.)
Protected method | DoCapture | (Inherited from PaySystem.)
Protected method | DoCharge | (Inherited from PaySystem.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides PaySystem DoConfigure(IConfigSectionNode).)
Protected method | DoRefresh | (Inherited from PaySystem.)
Protected method | DoRefund | (Inherited from PaySystem.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Inherited from PaySystem.)
Protected method | DoStartSession | (Inherited from PaySystem.)
Protected method | DoTransfer | (Inherited from PaySystem.)
Protected method | DoVerifyPotentialTransaction | (Inherited from PaySystem.)
Protected method | DoVoid | (Inherited from PaySystem.)
Protected method | DoWaitForCompleteStop | (Inherited from PaySystem.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Protected method | GetTransactionFee |
Protected method | GetTransactionPct |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsTransactionTypeSupported | (Inherited from PaySystem.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Log | (Inherited from PaySystem.)
Protected method | MakeDefaultSessionConnectParams | (Inherited from PaySystem.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | StartSession | Starts new pay session of system-specific type (Inherited from PaySystem.)
Protected method | StatCapture | (Inherited from PaySystem.)
Protected method | StatCaptureError | (Inherited from PaySystem.)
Protected method | StatCharge | (Inherited from PaySystem.)
Protected method | StatChargeError | (Inherited from PaySystem.)
Protected method | StatRefund | (Inherited from PaySystem.)
Protected method | StatRefundError | (Inherited from PaySystem.)
Protected method | StatTransfer | (Inherited from PaySystem.)
Protected method | StatTransferError | (Inherited from PaySystem.)
Protected method | StatVoid | (Inherited from PaySystem.)
Protected method | StatVoidError | (Inherited from PaySystem.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | Sessions | (Inherited from PaySystem.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ChargeFeeKind | (Inherited from PaySystem.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | CurrenciesCfg | (Inherited from PaySystem.)
Protected property | DefaultSessionConnectParams | (Inherited from PaySystem.)
Public property | DefaultSessionConnectParamsCfg | (Inherited from PaySystem.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from PaySystem.)
Public property | KeepAlive | (Inherited from PaySystem.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | LogLevel | Specifies the log level for operations performed by Pay System. (Inherited from PaySystem.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Pipelined | (Inherited from PaySystem.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | SupportedCurrencies | (Inherited from PaySystem.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransferFeeKind | (Inherited from PaySystem.)
Public property | WebServiceCallTimeoutMs | (Inherited from PaySystem.)
Public property | WebTerminal | (Inherited from PaySystem.)
Back to Top
See Also
PaySystemWithStaticFees Class
NFX.Web.Pay Namespace


PaySystemWithStaticFees Constructor

PaySystemWithStaticFees Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | PaySystemWithStaticFees(String, IConfigSectionNode) | Initializes a new instance of the PaySystemWithStaticFees class
Protected method | PaySystemWithStaticFees(String, IConfigSectionNode, Object) | Initializes a new instance of the PaySystemWithStaticFees class
Back to Top
See Also
PaySystemWithStaticFees Class
PaySystemWithStaticFees Members
NFX.Web.Pay Namespace


PaySystemWithStaticFees Constructor (String, IConfigSectionNode)

PaySystemWithStaticFees Constructor (String, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PaySystemWithStaticFees class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PaySystemWithStaticFees(
    string name,
    IConfigSectionNode node
)
protected PaySystemWithStaticFees(
    string name,
    IConfigSectionNode node
)
Protected Sub New (
    name As String,
    node As IConfigSectionNode
)
Protected Sub New (
    name As String,
    node As IConfigSectionNode
)
protected:
PaySystemWithStaticFees(
    String^ name,
    IConfigSectionNode^ node
)
protected:
PaySystemWithStaticFees(
    String^ name,
    IConfigSectionNode^ node
)
new :
        name : string *
        node : IConfigSectionNode -> PaySystemWithStaticFees
new :
        name : string *
        node : IConfigSectionNode -> PaySystemWithStaticFees

Parameters

name
Type: Online System String
node
Type: NFX.Environment IConfigSectionNode
See Also
PaySystemWithStaticFees Class
PaySystemWithStaticFees Members
PaySystemWithStaticFees Overload
NFX.Web.Pay Namespace


PaySystemWithStaticFees Constructor (String, IConfigSectionNode, Object)

PaySystemWithStaticFees Constructor (String, IConfigSectionNode, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PaySystemWithStaticFees class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PaySystemWithStaticFees(
    string name,
    IConfigSectionNode node,
    Object director
)
protected PaySystemWithStaticFees(
    string name,
    IConfigSectionNode node,
    Object director
)
Protected Sub New (
    name As String,
    node As IConfigSectionNode,
    director As Object
)
Protected Sub New (
    name As String,
    node As IConfigSectionNode,
    director As Object
)
protected:
PaySystemWithStaticFees(
    String^ name,
    IConfigSectionNode^ node,
    Object^ director
)
protected:
PaySystemWithStaticFees(
    String^ name,
    IConfigSectionNode^ node,
    Object^ director
)
new :
        name : string *
        node : IConfigSectionNode *
        director : Object -> PaySystemWithStaticFees
new :
        name : string *
        node : IConfigSectionNode *
        director : Object -> PaySystemWithStaticFees

Parameters

name
Type: Online System String
node
Type: NFX.Environment IConfigSectionNode
director
Type: Online System Object
See Also
PaySystemWithStaticFees Class
PaySystemWithStaticFees Members
PaySystemWithStaticFees Overload
NFX.Web.Pay Namespace


PaySystemWithStaticFees Fields

PaySystemWithStaticFees Fields NFX Class Library

The PaySystemWithStaticFees type exposes the following members.
Fields
 | Name | Description
Protected field | Sessions | (Inherited from PaySystem.)
Back to Top
See Also
PaySystemWithStaticFees Class
NFX.Web.Pay Namespace


PaySystemWithStaticFees Methods

PaySystemWithStaticFees Methods NFX Class Library

The PaySystemWithStaticFees type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from PaySystem.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Inherited from PaySystem.)
Protected method | DoCapture | (Inherited from PaySystem.)
Protected method | DoCharge | (Inherited from PaySystem.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides PaySystem DoConfigure(IConfigSectionNode).)
Protected method | DoRefresh | (Inherited from PaySystem.)
Protected method | DoRefund | (Inherited from PaySystem.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Inherited from PaySystem.)
Protected method | DoStartSession | (Inherited from PaySystem.)
Protected method | DoTransfer | (Inherited from PaySystem.)
Protected method | DoVerifyPotentialTransaction | (Inherited from PaySystem.)
Protected method | DoVoid | (Inherited from PaySystem.)
Protected method | DoWaitForCompleteStop | (Inherited from PaySystem.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Protected method | GetTransactionFee |
Protected method | GetTransactionPct |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsTransactionTypeSupported | (Inherited from PaySystem.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Log | (Inherited from PaySystem.)
Protected method | MakeDefaultSessionConnectParams | (Inherited from PaySystem.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | StartSession | Starts new pay session of system-specific type (Inherited from PaySystem.)
Protected method | StatCapture | (Inherited from PaySystem.)
Protected method | StatCaptureError | (Inherited from PaySystem.)
Protected method | StatCharge | (Inherited from PaySystem.)
Protected method | StatChargeError | (Inherited from PaySystem.)
Protected method | StatRefund | (Inherited from PaySystem.)
Protected method | StatRefundError | (Inherited from PaySystem.)
Protected method | StatTransfer | (Inherited from PaySystem.)
Protected method | StatTransferError | (Inherited from PaySystem.)
Protected method | StatVoid | (Inherited from PaySystem.)
Protected method | StatVoidError | (Inherited from PaySystem.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PaySystemWithStaticFees Class
NFX.Web.Pay Namespace


PaySystemWithStaticFees.DoConfigure Method

PaySystemWithStaticFees DoConfigure Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
PaySystemWithStaticFees Class
PaySystemWithStaticFees Members
NFX.Web.Pay Namespace


PaySystemWithStaticFees.GetTransactionFee Method

PaySystemWithStaticFees GetTransactionFee Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Amount GetTransactionFee(
    string currencyISO,
    TransactionType type
)
protected Amount GetTransactionFee(
    string currencyISO,
    TransactionType type
)
Protected Function GetTransactionFee (
    currencyISO As String,
    type As TransactionType
) As Amount
Protected Function GetTransactionFee (
    currencyISO As String,
    type As TransactionType
) As Amount
protected:
Amount GetTransactionFee(
    String^ currencyISO,
    TransactionType type
)
protected:
Amount GetTransactionFee(
    String^ currencyISO,
    TransactionType type
)
member GetTransactionFee :
        currencyISO : string *
        type : TransactionType -> Amount
member GetTransactionFee :
        currencyISO : string *
        type : TransactionType -> Amount

Parameters

currencyISO
Type: Online System String
type
Type: NFX.Web.Pay TransactionType

Return Value

Type: Amount
See Also
PaySystemWithStaticFees Class
PaySystemWithStaticFees Members
NFX.Web.Pay Namespace


PaySystemWithStaticFees.GetTransactionPct Method

PaySystemWithStaticFees GetTransactionPct Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int GetTransactionPct(
    string currencyISO,
    TransactionType type
)
protected int GetTransactionPct(
    string currencyISO,
    TransactionType type
)
Protected Function GetTransactionPct (
    currencyISO As String,
    type As TransactionType
) As Integer
Protected Function GetTransactionPct (
    currencyISO As String,
    type As TransactionType
) As Integer
protected:
int GetTransactionPct(
    String^ currencyISO,
    TransactionType type
)
protected:
int GetTransactionPct(
    String^ currencyISO,
    TransactionType type
)
member GetTransactionPct :
        currencyISO : string *
        type : TransactionType -> int
member GetTransactionPct :
        currencyISO : string *
        type : TransactionType -> int

Parameters

currencyISO
Type: Online System String
type
Type: NFX.Web.Pay TransactionType

Return Value

Type: Online Int32
See Also
PaySystemWithStaticFees Class
PaySystemWithStaticFees Members
NFX.Web.Pay Namespace


PaySystemWithStaticFees Properties

PaySystemWithStaticFees Properties NFX Class Library

The PaySystemWithStaticFees type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ChargeFeeKind | (Inherited from PaySystem.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | CurrenciesCfg | (Inherited from PaySystem.)
Protected property | DefaultSessionConnectParams | (Inherited from PaySystem.)
Public property | DefaultSessionConnectParamsCfg | (Inherited from PaySystem.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from PaySystem.)
Public property | KeepAlive | (Inherited from PaySystem.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | LogLevel | Specifies the log level for operations performed by Pay System. (Inherited from PaySystem.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Pipelined | (Inherited from PaySystem.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | SupportedCurrencies | (Inherited from PaySystem.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransferFeeKind | (Inherited from PaySystem.)
Public property | WebServiceCallTimeoutMs | (Inherited from PaySystem.)
Public property | WebTerminal | (Inherited from PaySystem.)
Back to Top
See Also
PaySystemWithStaticFees Class
NFX.Web.Pay Namespace


PayWebTerminal Class

PayWebTerminal Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Web.Pay PayWebTerminal
NFX.Web.Pay.Braintree BraintreeWebTerminal
NFX.Web.Pay.Mock MockWebTerminal

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PayWebTerminal : IPayWebTerminal
public abstract class PayWebTerminal : IPayWebTerminal
Public MustInherit Class PayWebTerminal
    Implements IPayWebTerminal
Public MustInherit Class PayWebTerminal
    Implements IPayWebTerminal
public ref class PayWebTerminal abstract : IPayWebTerminal
public ref class PayWebTerminal abstract : IPayWebTerminal
[<AbstractClassAttribute>]
type PayWebTerminal =
    class
        interface IPayWebTerminal
    end
[<AbstractClassAttribute>]
type PayWebTerminal =
    class
        interface IPayWebTerminal
    end
See Also
PayWebTerminal Members
NFX.Web.Pay Namespace


PayWebTerminal Members

PayWebTerminal Members NFX Class Library

The PayWebTerminal type exposes the following members.
Constructors
 | Name | Description
Protected method | PayWebTerminal | Initializes a new instance of the PayWebTerminal class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPayInit |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | PaySystem |
Back to Top
See Also
PayWebTerminal Class
NFX.Web.Pay Namespace


PayWebTerminal Constructor

PayWebTerminal Constructor NFX Class Library

Initializes a new instance of the PayWebTerminal class

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PayWebTerminal(
    PaySystem paySystem
)
protected PayWebTerminal(
    PaySystem paySystem
)
Protected Sub New (
    paySystem As PaySystem
)
Protected Sub New (
    paySystem As PaySystem
)
protected:
PayWebTerminal(
    PaySystem^ paySystem
)
protected:
PayWebTerminal(
    PaySystem^ paySystem
)
new :
        paySystem : PaySystem -> PayWebTerminal
new :
        paySystem : PaySystem -> PayWebTerminal

Parameters

paySystem
Type: NFX.Web.Pay PaySystem
See Also
PayWebTerminal Class
PayWebTerminal Members
NFX.Web.Pay Namespace


PayWebTerminal Methods

PayWebTerminal Methods NFX Class Library

The PayWebTerminal type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPayInit |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PayWebTerminal Class
NFX.Web.Pay Namespace


PayWebTerminal.GetPayInit Method

PayWebTerminal GetPayInit Method NFX Class Library

Namespace: NFX.Web.Pay
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Object GetPayInit()
public abstract Object GetPayInit()
Public MustOverride Function GetPayInit As Object
Public MustOverride Function GetPayInit As Object
public:
virtual Object^ GetPayInit() abstract
public:
virtual Object^ GetPayInit() abstract
abstract GetPayInit : unit -> Object
abstract GetPayInit : unit -> Object

Return Value

Type: Online Object

Implements

IPayWebTerminal GetPayInit
See Also
PayWebTerminal Class
PayWebTerminal Members
NFX.Web.Pay Namespace


PayWebTerminal Properties

PayWebTerminal Properties NFX Class Library

The PayWebTerminal type exposes the following members.
Properties
 | Name | Description
Public property | PaySystem |
Back to Top
See Also
PayWebTerminal Class
NFX.Web.Pay Namespace